Sommaire

BONJOUR
Musique "Invention BWV784" J.S. BACH 1685-1750

Tutoriel et Help

Style & CSS


Accueil

Accueil CHM


Accueil

La page vide

Normal, dit comme ça,
vous ne risquez pas de comprendre.


Accueil

La page vide

J2M
J2M

JAVASCRIPT


My Home Page

Vu dans ... http://www.angelfire.com/electronic/funwithtubes/tube_stereo.html

My "HiFi" and stereo setups.

This was my first "HiFi" set bought in 1956 when I was living with my parents in Dunedin Fla. It consisted of a Newcomb Amplifier, A Jensen speaker and of Voice of Music record scratcher, er ah, record changer.

By 1959 I had converted to Stereo. I dropped a stereo cartridge into the VM and constructed two copies of the Newcom amplifier on a 17 x 13 x 3 inch chassis, seen near the bottom of the cabinet with the external power supply to its left. The VM changer is in the center of the shelf with a Stromburg-Carlson AM/FM tuner to its right. The old phonograph on the left was just to fill up space. On top of the cabinet are two different models of Silvertone real to real tape recorders. The speaker cabinets - built by my father - used a pair of 3 inch table radio speakers for tweeters and an old jukebox speaker in one and a Zenith floor model radio speaker in the other. Look at the shelf just above the right hand speaker. That's a tube tester. I still have it and it still works.

The system quickly grew and improved. By about 1962 I had constructed a pre-amp and bought a Fairchild turntable. The funny looking device just to the right of the turntable is a home built FM stereo demodulator. The speakers had been improved too by the installation of two Electro Voice 12 inch 3 way speakers and some grill cloth.

After I moved to Bowling Green KY in 1968 I took this picture. The main things of interest in this photo are the pre-amp and power amp from the old stereo which are stored on the bottom shelf of the desk. I still have them too. I put so many hours into building them I just can't bring myself to tare them apart.

Thank you for visiting my page at Angelfire.
Please come back and visit again!

This site begun March 14, 2001

This page last updated March 23, 2002


Vu dans ... http://www.angelfire.com/electronic/funwithtubes/mystery_radio.html

Hotel Radio.

What started out to be a mystery turned out to be a coin operated hotel radio. Because this radio is so unique I have decided to leave this page up with a different title and a few changes. There is plenty of information about it here. I have no way of knowing how long this link will be alive so I will summarize.

It appears to be a "Hotel Radio Corporation" model 6A. This was a coin activated radio. After the end of World War II the owners of high rise hotels received complaints from guests that radio reception in the rooms was very poor. The problem was a combination of weak signals due to the structural steel in the building combined with electrical interference. The HRC was formed to design and manufacture a radio with an RF stage and very good immunity to electromagnetic interference. The head of the HRC was a man named Frawley. Some of the radios sold by the Hotel Radio Co. had the Frawley brand name on a decal. The rest of them carried the name of the hotel they were sold to.

That mysterious brass plate covers the hole that had been cut for the coin device. There were two models made, one with the coin device and another without. The one I have may have been one made without the coin device or someone removed it before it came into my hands. The plate looks too good to be an amateur job so I assume it was original equipment. There are remains of paint on the plate as if someone tried to polish the brass and ended up removing the paint.

The radio was intended to be a chair side radio. Remember that it was made in the era before television when people would spend an evening listening to radio. The upside down markings on the dial seem to be intended for reading by someone sitting in an easy chair next to the radio.

History and Inner Workings.

Several years ago I was in an antique store in Scottsville Kentucky where I saw a radio that was too small to be a console and seemed a little too big to be a table model. There was no manufacturer's name visible on the outside.

Photograph of Radio.

What was so intriguing about it was one of the knobs. In addition to the usual "Volume", "On/Off /Tone", and "Tuning", it had a knob that was larger than the others labeled "Adjust for Best Reception".

Photograph of Radio's Control Panel.

The man said he didn't know what the knob did, the radio didn't work and he had never heard it work. The price was very reasonable for a wood radio so I bought it. When I got it home the first thing I did was to take a careful look inside. It turned out to be an All American 6.

Photograph of Underside of Radio.

I plugged it in and turned it on. Note: That is not advisable but this was before I developed the cautious approach I now use with such radios. It had the characteristic hum of an open filter capacitor so I started taking it apart.

Photograph of Insides of Radio.

To my great disappointment the paper label which had bin stapled to the board had been torn away.

Photograph of Antenna Box.

I had already guessed that the big knob controlled a rotating loop antenna and I was right but there turned out to be more to it than that. The loop is electrostaticly shielded. To allow the magnetic field to penetrate the box and induce a current in the loop there must not be a complete current path around the box. If there were it would be like a shorted turn in a transformer and there would be little signal induced in the loop. The horizontal strips of aluminum foil are broken on one side of the box. The bar in the bottom picture ties the top and bottom aluminum sheets together but it does not contact the foil strips.

Photograph of Loop Shaft Showing Insulator.

If the shaft were in electrical contact with both the top and bottom it would make a shorted turn with the tie bar. Where the shaft passes through the top plate a phonolic insulator prevents contact. On the bottom a spring ensures good contact to prevent static when the shaft is turned.

I replaced the filter capacitor and the radio sort of worked but I knew that given its RF stage and the large loop antenna it should have better sensitivity than it did.

Photograph of Loop Antenna.

The box is made of an insulating material that is a very dark gray on the outside but inside the box it is a much lighter gray. It appears to be a heavy gauge version of Fish Paper. In the picture it could be taken for sheet aluminum but it is not.

When I arrived at this stage in my initial disassembly I found that the wire that connects the loop back to the radio chassis was extremely tired. Many years of use and metal fatigue had taken its toll. I replaced it with stranded wire which will probably have to be replaced again someday.

As you can see the phonolic insulators in the middle of the loop extend beyond the loop on one end. This extension hits a screw which is visible in the picture and limits the rotation of the loop to 360 degrees. Well maybe 359.

There is one more odd thing about this radio.

Photograph Showing Slide Rule Dial.

It was designed to be a chair side radio. The upside down scale would permit the listener to have a frequency scale that would be right side up from his point of view.

The main reason why the designers of this radio were not facing any size restrictions was, it would be difficult for a customer to steal it and successfully smuggle it out of the hotel. The designers were able to produce a radio with superior performance.

This is without a doubt the best performing AM radio I have ever encountered. No doubt it was quite expensive for its day and probably very few were sold to private owners. Even the hotel market was likely rather small and, apparently, few from that source have survived making it rare.

When the radio came into my hands there was no sign that there had ever been a coin mechanism installed. It may have been removed by a previous owner or possibly there never was one. Information and photos on the pages referenced at the top of this page seem to indicate that the coin operated versions were painted while the free ones were in varnished wood. But don't hold me to that. Why the brass plate has nothing comprehensible on it is a complete mystery to me and your guess is as good as mine.

Home


The Best Breadboard for Vacuum Tube Circuits.

Vu dans ... http://www.angelfire.com/electronic/funwithtubes/New_Tube_BB.html

The Best Breadboard for
Vacuum Tube Circuits.

There are a great many ways to breadboard vacuum tube circuits. After years of experience and some recent testing I have concluded that the best way is to solder wires and small components to terminal strips. If you have not already read the page comparing the various methods of breadboarding I suggest you click here.

If after reading that page you decide to build a breadboard like this one, here is how to do it. First of all it is not necessary that you exactly duplicate what I have done. In fact this is just to give you ideas which you can pick out parts to build and parts to leave off or you may even expand on this project. Mine is built on what is left of a 12 x 7 x 4 inch Bud utility box. I say what is left because it is recycled from an earlier project. Since one picture is worth a thousand words (one of my colleagues once presented a mathematical proof of that) here are a couple of thousand words.

The circuit constructed on the breadboard is a three tube radio. It is basically the first three tubes of an All American 5. As you can see it's mainly terminal strips and tube sockets. The terminal strips are likely to stay as they have been installed but the tube sockets can and will be changed to accommodate the particular project at hand.

The 5 holes on the right side of the left hand view are all identical and are for octal tube sockets although mounting plates for IF transformers will fit, as you can see. Can type filter capacitors will also fit.

The 5 holes on the left will accommodate 7 or 9 pin miniature sockets. The bottom most socket is a 7 pin and the other two are 9 pin. Close inspection of the picture will show that the holes for the 7 pin socket partially overlap the main cutout. It is absolutely necessary that you drill the small holes before punching out the larger hole.

As you can see in the right hand view two pieces of angle aluminum are mounted across the top and bottom, as shown, to strengthen the chassis. Why didn't I use the other half of the box? It had been too badly cut up for the earlier project. Also shown on the back panel are the binding posts, BNC and phono connectors for power and signal in and out. Wires from these run up through small grommets and are soldered into the eyelets of the terminal strips. The front panel has room for 4 pots and a variable capacitor salvaged from an All American 5 radio. Two of the pots are 500 k ohm audio taper and the other two are 100 k ohm linear taper. Two 2 - 1/2 inch plastic spacers are mounted to the angle aluminum which is on the left side when the breadboard is in its normal position. As shown in the photo below these are to hold the home wound coils used in radio circuits.

It took about an afternoon and an evening to build the three tube radio. That's not too much longer than it would have taken with some sort of solderless breadboard. The problem is that it works so well that I don't want to take it apart.

But what if I built the other breadboard and found, as you did, that it's not as good as it seemed? Do what I did. Take the IC socket breadboards off of the chassis, punch holes for two more mini tube sockets and mount some terminal strips in the empty space.

When I decided to do this I had already stripped the binding posts off to use on the new version. I have replaced some of them but have left some holes open. That actually increases flexibility. Because the center row of holes permits alternating mini tubes and IF transformers it seems like a better solution for the three tube radio.

Use your "Back" button to return to where you were.

Home

Thank you for visiting my page at Angelfire.
Please come back and visit again!

This site begun March 14, 2001

This page last updated September 16, 2002


Fun With Transistors

Vu dans ... http://www.angelfire.com/planet/funwithtransistors/index.html

Welcome to
FUN WITH TRANSISTORS.

This is a noncommercial site
operated by Max Robinson,
the same guy who brought you
Fun With Tubes.
This site is dedicated to passing around the
knowledge of transistor circuits and techniques.

Keep the electrons and holes flowing in opposite directions.

JOIN NOW!

Join the Fun with Transistors discussion group.
Now all of you who have been exchanging email
messages with me can communicate with each
other directly. To subscribe send an email to
funwithtransistors-subscribe@yahoogroups.com
See you on the list.

The people who run the website EE Web have
interviewed me and written a very
nice article. Here is the link.
EE Web article.

My Opinion.

I have never cared for the term "solid state". It implies that the technology it replaced, namely the vacuum tube, was made of liquids or gasses. True, some special purpose tubes were filled with gas but the tubes themselves were made of glass and metal which are solids at room temperature. For the adjective that describes the technology based on silicon I prefer "semiconductor". That is what you will see in these pages.

This site was begun on July 27, 2006. It is under construction.
Like other web sites I have set up it will likely never be finished.

What do I need to have fun with transistors?
Click here for the answer.

The Basic Stuff
DC Circuits
AC Circuits
Semiconductor Diodes
The Bipolar Junction Transistor
The Field Effect Transistor
AM, SSB, and FM
Textbook, Electronics for Non-Engineers
Textbook, Troubleshooting
Radio
How AM Radio Works
Build a Crystal Set
Drain Detector
Infinite Impedance Detector
Base Detector
The All Japanese 6
General Information
The Converter
The IF Amplifier
Detector and AGC
Audio Amplifier
Conclusion
Construction Projects.
An Intermodulation Distortion Analyzer.
Breadboards With Built-in Power Supplies.
Audio Amplifiers, How They Work.
Power Transformers
A Technical Discussion of Power Supplies. Not for the faint of heart.
Some Useful Audio Circuits.
Building Amplifiers
200 Watt Per Channel Complementary.
Useful Information.
Data on some current and a few historic transistors
Free Downloads
Links
E-mail me

Do you like music? I also write songs which are arranged
and mixed so you can understand the words, and the lyrics
are worth listening to. Take a peak into my right brain.
Visit Max's Music Place. Click here.

Are you curious about vacuum tubes? You may have heard
your father or grandfather talk about them. You may have
even seen them in old equipment. If you would like to learn
more, visit Fun with Tubes.

Who and What.

This web site is owned and operated, as a hobby, by Max Robinson. As time goes by I will post tutorials on the fundamentals of electricity and electronics, and interesting circuits you can build with transistors and op amps.

I have a master's degree in electrical engineering from the University of Florida 1966. If you have any questions or suggestions feel free to email me.

If I Don't Answer...

I scrupulously answer all emails sent to me. If you send me one and you don't hear from me in a reasonable amount of time maybe something went wrong.

On five occasions I have received emails from people seeming to be asking legitimate questions. When I attempt to answer them I get back one of those "Mail System Error" messages saying that my email address has been blocked by the sender. Four of the five have been from AOL users. Some anti spamming programs are quite strict and maybe you forgot to enter my address as "allowed". Check your anti spam list to be sure my reply will be given to you instead of being bounced back to me.

On the other hand maybe this is someone's idea of juvenile fun. No doubt the people who have done this (you know who you are) think this is very funny. To me it's just a minor annoyance. Even though it's a small thing I could do without it. Just because you're not having fun don't spoil it for the rest of us.

Thank you for visiting my page at Angelfire.
Please come back and visit again!

This site begun July 27, 2006.

This page last updated April 16, 2011.


Fun With Tubes

Vu dans ... http://www.angelfire.com/electronic/funwithtubes/index.html

Welcome to
FUN WITH TUBES.
I've Never Lost the Wonder.

This is a noncommercial site
operated by Max Robinson and
dedicated to passing on and preserving
knowledge of vacuum tube circuits and techniques.

Keep the electrons flowing and the tubes glowing.

JOIN NOW!

Join the Fun with Tubes discussion group.
Now all of you who have been exchanging email
messages with me can communicate with each
other directly. To subscribe send an email to
funwithtubes+subscribe@groups.io
See you on the list.

Activity Log is Back

Day to day I am doing things that those other than
myself may be interested in. These activities
may or may not wind up on a page of their own
someday. If I become involved in a long project
there may be long periods of apparent inactivity
on this site. This page will let you know what
I am up to in my shop. If you have suggestions
Concerning what I am working on don't hesitate
to make them known to me. To read about my
daily activities click here.

The people who run the website EE Web have
interviewed me and written a very
nice article. Here is the link.
EE Web article.

An Observation.

If I worked on radios the same way doctors worked on people when ever a capacitor, resistor, or tube, failed I would just take it out and throw it away. Yet the radio would be expected to work as well as when it was new. So far I am down my tonsils, adenoids, about one and a half feet of large intestine, and a gall bladder. My power output is down and my distortion percentage is up.

Fun With Tubes now has a sister site.
It's called Fun With Transistors.
If you would like to tinker with electronics
But you would rather not poke around among
High voltages, check it out.

New!

Improving the Phase Inverter.
The beat goes on, totally un phased.
The Total Solar Eclipse of 8/21/2017
An Arduino Based
Audio Power Meter
Announcing a new series of articles.
Equipment Reviews
Two new entries under Test Equipment.
Bench Power Supplies for Tubes
And
Vacuum Tube Volt-Ohm Meter
Here's some help for anyone trying to build
or just understand these devices.
IF Transformers for New Construction.
And
Replacement IF Transformers for AA# Radios.
You really can use transistor IF transformers
in tube Circuits if you do it right.
Here's another design from Tim E. Smith.
The sound will surprise you.
I have done for the communications receiver
What I did for the All American Five.
An Intermodulation Distortion Analyzer.
You can build.
Speaker Impedance
Did you know it isn't constant?
Characterizing Transformers
and Interpreting Lead Colors.
The Wise Linearized Williamson Circuit.
Even this classic can be improved upon.
Harman-Kardon A-300
New information has been added
including distortion measurements.
Hotel Radio.
Have you ever seen one like this?
Design Stable
Feedback Loops
Resistors' Behavior
at MF, HF, and VHF.
A resistor may not
always be a resistor.

What do I need to have fun with tubes?
Click here for the answer.

The Basics of Electricity and Electronics.
DC Circuits: Series Circuits, Parallel Circuits, Ohms Law, and Scientific Notation.
AC Circuits: RC, RL, and RLC Networks, Filters.
Vacuum Diodes: Tubes with two elements.
Vacuum Triodes: Adding a grid to the diode.
Tubes with 2, 3, and 5 grids.
Amplitude Modulation (AM), Single Side-band (SSB), and Frequency Modulation (FM)
What is ground? One of the Most Misunderstood Concepts in Electricity.
Transmission Lines and Standing Wave Ratio (SWR): Another Misunderstood Concept.

Test Instruments.
How they work and how to use them.
Bench Power Supply.
Grid Dip Meter (GDM) / Grid Dip Oscillator (GDO).
The Neglected Q Meter.
The Vacuum Tube Volt-ohm Meter (VTVM).

Equipment Reviews

I have decided it would be helpful to viewers of this page
if I post reviews of currently manufactured test equipment.
I have not been given any of this equipment in exchange for
a favorable review. Nor did I receive any discount other than
what the dealer makes available to all customers. I do this in
the hope that I may save you from buying something that
doesn't meet your needs.
Hantek® Model DSO5202P Digital Sampling Oscilloscope
MASTECH® Model MS8340A HandHeld DMM
SIGLENT® Model SDG810 Function Generator
SIGLENT® Model SDS2202X Digital Storage Oscilloscope
MASTECH® Model MS8050A Bench Top True RMS DMM
RIGOL® Model DS1054Z 4 Channel 50 MHz Oscilloscope

How To Do It.
Restoring Electrolytic Capacitors that Appear to be Dead.
Testing Capacitors: Do You Really Know How?
Characterizing Transformers and Interpreting Lead Colors
Reading Resistor and Capacitor Color Codes
Soldering and Unsoldering
Eliminating Ground Loops
Links to Pages on Designing and Building Speakers
Tips From Mac's Workbench

Construction Projects

When I retired in 2001 I was looking forward to building
all those things I had put off for years. I had accumulated
a closet full of parts and I was going to build things
almost for free. .

Then something called the www came along. As a result
I have spent no small amount of money buying parts that
are currently in production. My reason was to make it easy
to duplicate the project. Most people who build these items
are clever, knowledgeable, and web wise. Therefor I am
going to use the free parts I have on hand. I will give
specifications but you are on your own to find equivalent
parts. Where I have bought new parts I will give the source.

Granted, some of the projects below are silicon based.
These are test equipment and in this application, whether
we like it or not, silicon is more stable, easier to build,
smaller, lighter, and performs better, than tubes.

4 Ways to Breadboard: Only One of them is Any Good.
8 Simple Power Supplies For Your Workbench.
Audio Power Meter Has Linear Scale, is Arduino Based.
The Best Breadboard: Soldering Doesn't Take Much Longer and is More Reliable.
Filter Choke Analyzer: Test Filter Chokes Under Current Load.
An IC Socket for Tubes: Not Nearly as Good as it Seemed.
Inexpensive Line Voltage Changer
An Intermodulation Distortion Analyzer.
A Load Box for Testing Power Supplies
Low Resistance Adapter for a Digital Multimeter
Using the Low Resistance adapter to characterize Unmarked Power Transformers
Making AM IF Transformers for New Construction.
Making AM IF Transformers for Replacements in Older AM Radios.
Modifying a Heath IG-18 Audio Generator For Ultra Low Distortion.
PLL Frequency Control For AM Band Receivers. Know Where You Are.
Power Supply & Amplifier: Complex but Very Useful.

Radio and Detector Circuits.
How AM Radio Works: A Simple Description.
How FM and FM Stereo Works
Winding Coils: To Wind or to Buy. Only You Can Answer That Question.
Build a Crystal Set
Build De Forest's Audion: That's Right, You Can Build His First Version of the Audion.
Grid Leak Detector: Needs an Amplifier.
Plate Detector: Needs an Amplifier.
Infinite Impedance Detector: Needs an Amplifier.
Regenerative Detector: Needs an Amplifier.
TRF Receiver: Needs an Amplifier.
Simple Superhet Receiver: Discusses Principles of Mixing and Image Frequencies.
3-Tube Superhet: Needs an Amplifier.
4-Tube Superhet: Needs an Amplifier.
5-Tube Superhet: No Coil Winding, Complete.

The All American Five: There Were Millions Made.
Introduction and Power Supply
The Converter
The Intermediate Frequency Amplifier
The Detector
The Audio Section
Cautions, Precautions, and Troubleshooting

Communications Receivers
Introduction
Image Rejection, IF Bandwidth, and Number of conversions
Block Diagram
Construction Tips
Power Supply
Audio Amplifier
RF Amplifier and Preselector
Converters, Mixers, and Local Oscillators
IF Amplifiers and Band-pass Filters
Detectors
AGC (Automatic Gain Control) and S Meter (Signal Meter)

Audio Amplifiers: How They Work
Power and Output Transformers: The Basics.
A Basic Power Supply: Found in the Newcomb D10.
A Technical Discussion of Power Supplies: Not For the Faint of Heart.
Resistance Coupled Amplifier, A Basic Building Block
Magnetic Phono Preamp: With Two Examples.
Volume and Loudness Controls; What the manufacturers don't want you to know.
Tone Controls: From Simple to Complex.
Balance Controls: The Good, the Bad, and the Useless.
Phase Inverters, Split Load Phase Inverters, and Drivers
Push-Pull Outputs
Overall Feedback, Pros and Cons
The FTC and Amplifier Power. Caveat Emptor.

Audio Amplifier Design.
How Much Power is Enough? It Depends.
Speaker Impedance: Did you know it isn't constant?
A Low Distortion Gain Block: Gain from 6.7 to 34, THD less than 0.060%.
How Does Removing the Cathode Bypass Capacitor Affect Distortion.
Practical Tone Controls: Passive and Active.
Phase Inverters and Drivers: The Heart of an Amplifier
The Pentode/Triode as Amplifier/Phase Inverter.
Improving the Phase Inverter.
The Wise Linearized Williamson Circuit.
An Amplifier Test Bed: Low THD Driver, Full Metering, & Regulated G2 Voltage.
Experiments with Triode Power Amplifier Circuits.
Designing an Amplifier with Feedback. A Downloadable Program Helps.
How To Design and Optimize Feedback Loops For Best Performance.
Optimizing Feedback Loops, a different point of View. Tim E. Smith.

An Amplifier Smorgasbord: Take Your Choice.
50 Watt Monoblock Amplifier: 6L6 GC.
The 70 Volt Line Amplifier
Contest Winning Amplifier: Results of the 2012 Amplifier Contest.
An EL34 Ultra Linear 50 Watt/Channel Amplifier.
Story of the Original Koss Headphones: Leads Into the Next Project.
A Dedicated Headphone Amplifier
Tim's Second Amplifier
Triode Monoblock: 6L6 GC.
Ultra Linear Monoblock: 6L6 GC.
A Unique Circuit Circlotron Amplifier: Probably Not Worth the Complexity.

Photo Gallery
The Total Solar Eclipse of 8/21/2017.
The Hotel Radio: No Longer a Mystery.
Project Pictures Sent to me by Viewers of this Page.
Schematics of Viewers' Projects.
Tour My Kilowatt AM/SSB Ham Station
Tour My Old Tube hi-fi and Stereo Systems.
The Lawnmower House, The Teddybear Cottage, and My Woodshop.
A New Workbench and Other Revisions to my Electronics Shop.
It Isn't Finished. Work on the Electronics Shop continues.

Operating Instructions
Silvertone Wire Recorder/Phonograph/Radio
MaxCAD Drawing Program Instruction Manual

Restoration Projects
1937 Philco Radio: This Radio Needs a Battery Eliminator to Work.
Heathkit Power Supply: The Fault Was a Most Peculiar Tube.
Harman-Kardon A-300: A Basket Case From eBay Plays Again.
Atwater-Kent Model 20: Restoring a 93 Year Old Radio Isn't Easy.

Useful Information
Verifying My Test Equipment: Making Accurate Measurements is not Easy.
Resistors' Behavior At HF and VHF. When is a Resistor Not a Resistor?
Tube Cross-reference and Selection Guide
Catalogs of Discontinued Parts
Links.
Free Programs You Can Download
Other things you can download.
Rants.
Textbook, Electronics for Non-Engineers
Textbook, Troubleshooting Techniques.
E-mail me

I've Never Lost the Wonder.

As I have said elsewhere on the web I became hooked on electronics when I saw a film on what was then known as educational television which contained animation illustrating how a vacuum tube worked. Memory of the exact year has grown a bit dim but it should have been 1951 or 1952. After that I would look into the back of my radio at night and think about the processes that were going on inside those glowing tubes and a sense of awe and wonder would come over me. The smallest things in nature, as known at that time, were being controlled inside those tubes to capture music from the air and deliver it to the speaker so I could hear it. As I began to understand radio my wonder only increased. I could hear a record that was being played on a turntable more than 1000 miles away as clear as if it were being played on my own phonograph. Actually clearer because the "needle" and record were in much better condition than my own. Over the past 66+ years I still haven't lost that sense of wonder.

It is also true that I have the same feelings about electrons and holes flying around inside the tiny crystal of a transistor. Think of it, I can hold in the palm of my hand a working computer that has more power than those first vacuum tube computers that would have filled a rich man's mansion.

The whole field of electronics encompassing audio, radio and digital systems still motivates and inspires me to wire up circuits. I still feel the same when it all works. I hope to share some of it with you.

Do you like music? I also write songs which are arranged and mixed
so you can understand the words, and the lyrics are worth listening to.
Take a peek into my right brain. Visit Max's Music Place. Click here.

Email Tube Man. SHA ZAM!
Everything you always wanted to know about
vacuum tubes but didn't know who to ask.

Ask Tube Man.

Would you like to tinker around with tubes but don't know what to do? Want to fix up that radio that belonged to your great-grandfather but don't know where to start? Are you experienced in working with tubes but you just came across a problem which has you stumped? Tube Man knows all and tells all. Just click on the super hero's picture to email a question to him. See questions submitted to Tube Man and his answers.

Who and What.

This web site is owned and operated, as a hobby, by Max Robinson. As time goes by I will post tutorials on the fundamentals of electricity and electronics, interesting circuits you can build with vacuum tubes and op amps, and I will share some of my experiences restoring antique radios and early electric phonographs.

I have a master's degree in electrical engineering from the University of Florida 1966. My early EE classes covered vacuum tubes so I know what I am talking about and doing. If you have any questions or suggestions feel free to email me.

If I Don't Answer...

I scrupulously answer all emails sent to me. If you send me one and you don't hear from me in a reasonable amount of time maybe something went wrong.

On a number of occasions I have received emails from people seeming to be asking legitimate questions. When I attempt to answer them I get back one of those "Mail System Error" messages saying that there is no such address or my email address has been blocked by the sender. Some anti spamming programs are quite strict and maybe you forgot to enter my address as "allowed". Check your anti spam list to be sure my reply will be given to you instead of being bounced back to me.

On the other hand maybe this is someone's idea of juvenile fun. No doubt the people who have done this (you know who you are) think this is very funny. To me it's just a minor annoyance. Even though it's a small thing I could do without it. Just because you're not having fun don't spoil it for the rest of us.

My Favorite things.
  • Old Country Music
  • Old Rock-n-Roll
  • Folk Music
  • Classical Music
  • Old Radios
  • Old Records
  • Old Record players
    Gramophones, Victrolas, etc.
  • Young Women (Only kidding Sue.
  • One particular woman (age, I'm not telling).

Thank you for visiting my page at Angelfire.
Please come back and visit again!

This site begun March 14, 2001

This page last updated Saturday, May 05, 2018.

Web ring has been removed because it was hijacking browsers away from this site into the ring. The ring has been rung.


Chapter 0   Electrical Fundamentals.

0.1  Electrical Quantities From Mechanical Quantities.
0.2  Resistance and Ohm's Law.
0.3  Series Circuits and Kirchhoff's Voltage Law.
0.4  Parallel Circuits and Kirchhoff's Current Law.
0.5  Prefixes.
0.6  Numerical Examples.
0.7  Capacitance.
0.8  Inductance.
0.9  Problems.
0.10 Answers to Problems.

Chapter 0.

Electrical Fundamentals.

This chapter is intended as a review of material which the student should be familiar with. If the student is not familiar with the material in this chapter, intensive study of this chapter may not be sufficient. A review of textbooks used in previous courses may be required.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

0.1 Electrical Quantities From Mechanical Quantities.

Electric Charge.

It is difficult to say exactly what electric charge is but you are all familiar with it. You walk across the carpet on a cold winter morning, reach for the doorknob and - ZAP - you get an electric shock. Your body acquired the property of electric charge by friction with the carpet.

Electric charge can be placed on objects under somewhat more controlled circumstances. One way is to rub a rubber rod with a piece of cat's fur. The rod will now attract small objects such as bits of paper. The charge on the rod induces the opposite charge on the bits of paper. The fur will also attract small objects but it is not as easy to handle as the rod.

The property of electric charge will cause two bodies which possess a charge to exert a force on one another. The magnitude of this force is directly proportional to the amount of charge on each body and inversely proportional to the square of the distance between the two bodies. In equation form this law is

F = q1 q2 / r2           (0.1)

where F is the force in Newtons, q1 is the amount of charge on body 1, q2 is the amount of charge on body 2 and r is the distance between the two bodies in meters.

If the distance is 1 meter and the force is 1 Newton and the two bodies have the same amount of charge, the amount of charge on each body is 1 coulomb. This is the definition of a coulomb, which is the unit of charge in the MKS system.

If the two bodies have charges of the same sign, the force is repulsive. If the two bodies have charges of opposite sign, the force is attractive.

The charge on one electron is 1.601864 x 10-19 coulombs. Therefore, one coulomb of charge is equal to the total charge of 6.24 x 1018 electrons.

In terms of mechanical units the dimensions of a coulomb are

Coulombs = Meters x Newtons1/2           (0.2)

Electric Current.

Electric current is the motion of electric charge through any conducting material. When a direct current is flowing in a wire, electrons are in continuous unidirectional motion along the wire.

Current expresses the amount of charge per unit time passing a given point on a conductor. One way of defining current would be to specify the number of electrons per second passing a point. Although this would be a perfectly valid way of specifying the amount of current in a conductor, the numbers which would result in practical applications would be so large as to be unwieldy. More practical numbers result if the coulomb is taken as the basic unit of charge instead of the electron.

The most commonly used unit of current is the ampere. One ampere is equal to one coulomb of charge per second passing a point on a conductor. Thus the basic units of current are

Amperes = Coulombs / seconds           (0.3)

If desired the mechanical units of charge could be substituted into this equation and a strictly mechanical definition of current could be obtained. This is left as an exercise at the end of this chapter.

The symbol I is used for steady-state currents while the symbol i is used for time-varying currents.

The mathematical equations which relate current, charge and time are

I = Q / t           (0.4)

or

I = dq / dt           (0.5)

The use of an upper-case letter for steady-state values and the lower-case equivalent for time-varying values is common practice in electricity and magnetism.

Conventional Current.

When an electric current moves through a circuit, the negatively charged electrons flow toward the positively charged part of the circuit. This means that electrons come out of the - side of a battery and go into the + side.

Physicists and electrical engineers alike prefer to use conventional current instead of electron current. Conventional current does what you would expect it to do. It flows out of the + side of a battery and flows into the - side.

Some students find this confusing. If you are among the confused, try this. Never think about electron current. Banish electron current forever from your mind and think only in terms of conventional current.

If any one man can be blamed for this confusion it seems to be the fault of Benjamin Franklin. Everyone knows about his "kite in the lightning storm" experiment. What few people know is that Dr. Franklin wrote one of the first if not the first textbook on electricity. He assembled all that was known at that time about electricity and put it in one book. He seems to have added very little in the way of original work himself but one thing he did add was a sign convention for electric charge. The convention he chose was a guess and he guessed wrong. Just think of it, if he had guessed the other way, we would have positive electrons and conventional current would be the same as electron current.

Electrical Potential.

Mechanical potential is expressed in units of work- energy. Electrical potential also is an expression of work which can be done or energy stored. The units are work per unit charge. If work is done on a given amount of charge, the potential has increased. If the charge does work the potential has decreased.

Electrical potential like mechanical potential has no absolute zero. Electrical potential is always expressed as a potential difference between two points. In some cases one of the points is implied or understood in context. Electrical potential is meaningless unless two points are specified, implied, or understood.

Because potential is specified between two points the term potential difference is often used. The "difference" is usually omitted when speaking and often omitted when writing; "potential difference" is always understood by speaker, listener, writer and reader.

The unit of electrical potential difference is the volt. Potential difference is often called the voltage difference or the voltage drop but most often just the voltage.

If one joule of work is done on one coulomb of charge, the charge is moved through a potential difference of positive one volt. If one coulomb of charge does one joule of work, the charge has moved through a potential difference of minus one volt.

The basic units of voltage difference are

volts = joules / coulomb           (0.6)

As with units of current, the mechanical units of charge could be substituted into equation 0.6 to obtain purely mechanical units of voltage difference.

The term "electromotive force" was once regularly used to describe electrical potential difference. This led to the use of the symbol emf and later to the letter E to symbolize potential difference. In more recent times the letter V has been adopted for drops across passive components. The letter E will be used for the voltage of energy sources. This convention will be used throughout this book. The equations for voltage in terms of more basic units are

V = W / Q           (0.7)

or

dv / dt = dw/dt / Q           (0.8)

Charge is not indicated as being time-varying because it is conserved. Charge can neither be created nor destroyed.

Electrical Power.

In mechanics, power is the rate of doing work or work per unit time.

Power = work / Time           (0.9)

Electrical power is no different. Electric power is

Power = Current x Voltage.           (0.10)

If we substitute the mechanical units of voltage and current into equation 0.10 we have

Watts = Coulombs / Second x Joules / Coulomb = Joules / Second   (0.11)

Thus

P = I x V           (0.12)

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

0.2 Resistance and Ohm's Law.

An Electric Circuit.

In order for electricity to be useful, it must be harnessed to do work for us. The usual way of making electricity do work is to connect a source of electric energy to a device which converts the electric energy into another useful form of energy. An example of this is the flashlight, the schematic diagram of which is shown in figure 0.1.

Figure 0.1 Schematic Diagram of a Flashlight.

For a verbal description click here.

The battery on the left converts chemical energy into electrical energy. The lamp on the right converts the electrical energy into electromagnetic energy, some of which is in the visible light part of the electromagnetic spectrum. The switch is used to interrupt the flow of electrons and permit the light to be turned on and off. The lines on the drawing indicate conductors such as wire which normally have negligible amounts of resistance compared to the rest of the circuit.

Resistance.

When an electric current flows through a very good conductor, such as a copper wire, the electrons move very easily and very little work is required to move them. A copper wire has very low, almost zero resistance.

When an electric current attempts to flow through a very poor conductor, such as a piece of glass or the open switch, a near infinite amount of energy would be required. In purely practical terms, electrons do not move through pieces of glass or open switches and there is no current flow. No current flow means that no charge is moved and no work is done. A piece of glass or an open switch has very high, almost infinite resistance.

When an electric current flows through a thin wire such as the filament in the lamp, the electrons can be moved but considerable work is required to make the electrons move. The filament of a lamp and other devices on which electricity does work are said to have finite resistance.

Current, Work and Potential.

If the current flows through a part of the circuit which has zero resistance (a super conductor) no work is required to move the electrons through this part of the circuit. Electric charge is being moved but no work is being done. In as much as potential difference (voltage) is defined as work per unit charge (equation 0.6) if the work is zero, the voltage is zero.

If the current flows through a part of the circuit which has a finite resistance, work is required to move the charge. If work is done, there is a potential difference across that part of the circuit. If the amount of charge per unit time remains constant, doubling of the amount of resistance will cause the amount of work to be doubled and the voltage to be doubled. Therefore, the voltage is directly proportional to the resistance.

If we now hold the resistance constant and allow the current (charge per unit time) to vary we discover the following. If the current doubles, there is twice as much charge to be moved and twice as much work will be required to move it. Which leads us to the conclusion that the voltage is directly proportional to the current.

We have now concluded that the voltage is directly proportional to the current and the resistance. As we saw at the beginning of this discussion, if the resistance is zero, the voltage is zero. On the other hand if the resistance is finite and the current is zero, there are no charges to do work on and there can be no potential difference. This is a strong indication that voltage is proportional to the product of resistance and current.

V = I x R           (0.13)

Resistance is defined in terms of volts and amps as follows. If a current of 1 ampere is flowing through a resistance of 1 ohm, the voltage which results will be 1 volt. Even the ohm can be defined in terms of purely mechanical units.

The above discussion is as close as we can come to a derivation of Ohm's law (equation 0.13). In fact Ohm's law was discovered experimentally and is strictly an empirical law.

Resistance and Power.

It is important to know how much power is being dissipated in a resistor. Every resistor has a maximum power rating. If this power is exceeded, the resistor will get overheated and quite literally burn up. Whenever a resistor is put into service a power calculation should be performed to make sure that the resistor will not burn out.

One way to make a power calculation is to multiply the current through the resistor by the voltage across it. This must be valid but if you know only one, voltage or current, you must use Ohm's law to calculate the other. A couple of shortcuts can be developed by combining equation 0.12 (power) with equation 0.13 (Ohm's law). A direct substitution of 0.12 into 0.11 gives

P = I x I x R = I2 x R           (0.14)

Solving Ohm's law for current and substitution gives

P = (V / R) x V = V2 / R           (0.15)

These equations should not be confused with the definition of power but they are often very handy.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

0.3 Series Circuits and Kirchhoff's Voltage Law.

Electric circuits get much more complex than the flashlight shown in Figure 0.1. We will work our way up from simple circuits to more complex circuits.

Figure 0.2 Schematic Diagram of a Series Circuit.

For a verbal description click here.

A series circuit is defined as a circuit in which there is only one path to be followed from a given point, around the circuit and back to the same point. Figure 0.2 qualifies under this definition of a series circuit.

In Figure 0.2 the letter E is used to symbolize the emf or potential difference across the battery. The symbol V1 is used for the potential difference across the resistor R1. In general the symbol VN will be used for the potential across any resistor RN.

Conventional current flows out of the positive terminal of the battery, through R1, through R2, through R3 and to the negative terminal of the battery. Current is symbolized by the letter I.

Current in Series Circuits.

Let us use the general symbol IN for the current in resistor RN and the letter I for the current in the battery. Remember that current could be expressed as the number of electrons per second passing a point in the circuit.

As electrons move around the circuit, there are no side roads for them to take. Electrons cannot pile up at any particular place in the circuit. If there was a pile-up, the concentration of negative charge would repel additional electrons from that vicinity and the pile-up would soon be gone. Pile-ups never happen in the first place.

Because we have established that electrons cannot accumulate at any point or get out of the circuit at any point, we may say that the number of electrons per second passing any point in the circuit of Figure 0.2 is the same as the number of electrons per second passing any other point in the circuit. In other words the current at any point in the circuit is exactly the same as the current at any other point in the circuit. This can be stated in equation form as

I = I1 = I2 = I3           (0.16)

Equation 0.16 is a consequence of Kirchhoff's current law although we don't officially know that yet.

Voltage in Series Circuits.

Remember that potential difference or voltage is work per unit charge. From mechanics remember: 1) the equivalents of work and energy, 2) the conservation of energy and 3) the conservation of charge. Also remember that the current in any resistor in Figure 0.2 is the same as the current in any other resistor and the same as the current in the battery.

The amount of work done by the battery is equal to the sum of the work done on each resistor, In equation form

W = W1 + W2 + W3           (0.17)

If we solve equation 0.7 for W and substitute into equation 0.17 we have

QE = QV1 + QV2 + QV3           (0.18)

As the current is the same everywhere in the circuit, the charge per unit time is the same and all occurrences of charge are the same. The charge Q will cancel out. Thus we have

E = V1 + V2 + V3           (0.19)

Equation 0.19 is a special case of Kirchhoff's voltage law.

Kirchhoff's voltage law states that the algebraic sum of all voltage drops around any closed loop is equal to zero. Thus, Kirchhoff's voltage equation for the circuit of Figure 0.2 is

- E + V1 + V2 + V3 = 0           (0.20)

Voltage Rises and Drops.

All voltages are really voltage differences. A potential difference or voltage difference can be either a voltage rise or a voltage drop. Although it may be stating the obvious, a rise is an increase in potential or voltage and a drop or fall is a decrease in potential or voltage. If we start at a particular point in a circuit and move around the circuit we may move from a point of low potential to a point of higher potential. We have traversed a potential rise. If we move from a point of high potential to a point of higher potential we have again traversed a potential rise. The starting point makes no difference; it is the change that is important. Similarly if we move from a point of any given potential to a point of lower potential we have traversed a potential drop or fall.

For example, if we traverse the battery in Figure 0.2 from bottom to top, we have traversed a rise. Conversely if we traverse the battery from top to bottom, we have traversed a drop. From this you can see that a battery is not automatically a potential rise; it depends on the direction of travel.

It is easy to tell the direction of the potential or polarity of a battery because of the polarity markings. A battery will always have the same polarity (positive on the long line) regardless of whether it is being charged (current flowing into the positive terminal) or discharged (current flowing out of the positive terminal). The positive terminal of the battery is always positive no matter which way the current is flowing.

Resistors and other passive devices are another story. Conventional current always flows out of the most negative end of a passive device. Thus, the end where the current goes in is more positive than the end where the current comes out.

In solving Kirchhoff's equation it is very important to give the proper sign to each quantity. If an incorrect sign is given to a particular value, the result will be incorrect. Here are some rules to follow in writing Kirchhoff's equations.

  1. 1 Mark the polarity on all voltage sources (batteries) by placing a minus (-) sign next to the negative terminal (short line) and a plus (+) sign next to the positive terminal (long line).

  2. 2 Assume a direction for the current. Clockwise is a standard assumption used by those who solve circuit equations. Don't be concerned if you can't tell which direction the current is actually flowing. The numeric answer will have a sign which will tell us if the initial assumption was right or wrong.

  3. 3 Mark the polarity on all passive devices (resistors) by placing a plus (+) sign at the end where the current enters and a minus (-) sign at the end where the current exits.

Now that you have polarity markings on each part in the circuit you are almost ready to write a Kirchhoff's equation.

Do not be concerned about the fact that there are + and - signs next to each other on opposite ends of the same wire. The signs refer to that particular circuit element alone. The positive end is more positive than the negative and the negative end is more negative than the positive end. The signs say nothing about what the potential is with respect to other parts of the circuit.

Kirchhoff's law states that the sum of all voltage drops is equal to zero. It could just as well say that the sum of all voltage rises is equal to zero. The only difference between the two resulting equations will be that one has been multiplied through by -1 as compared to the other.

If you are summing the rises, a drop is a negative rise. A drop is the negative of a rise. Conversely a rise is the negative of a drop. Therefore, if we sum the drops, a drop is a positive quantity and a rise is a negative quantity.

Apply the three rules above to Figure 0.2 and start at the lower left corner. The battery E is a rise which is a negative drop. Thus we write a negative (- E) in equation 0.20. The drops across the resistors are just that and are entered as positive quantities.

Example 0.1.

Write Kirchhoff's voltage equation for the circuit of Figure 0.3.

Figure 0.3 Series Circuit With Multiple Voltage Sources.

For a verbal description click here.

Solution.

First, mark a + sign near the positive (long line) and a - sign near the negative (short line) of each battery. Indicate a clockwise direction for the current by drawing an arrow on the figure. Put + and - signs on each resistor as follows. The lower end of R1 is positive and of course its upper end is negative. The left ends of R2 and R3 are positive. The upper end of R4 is positive. Of course the other end of each resistor is negative. Now we can write the equation. Start at the lower left corner and move around the circuit in a clockwise direction. If we sum the drops we get

- E1 + V1 + V2 - E2 + V3 + V4 + E3 = 0       (0.21)

If we sum the voltage rises we get

E1 - V1 - V2 + E2 - V3 - V4 - E3 = 0     (0.22)

Equation 0.22 is just equation 0.21 multiplied by -1. If we were to plug in numbers and solve them, both would give the same answer.

Resistors in Series.

Suppose we have three resistors in series as in Figure 0.4a and we wish to replace them with a single resistor as in Figure 0.4b. We want a single resistor Req which will cause the same amount of current to flow as the series combination of R1, R2, and R3, when connected across the same voltage source (battery). In other words we want one resistor which will act the same as the three resistors together.

Figure 0.4 (a) Three Resistors in Series,
(b) One Equivalent Resistor to Replace it.

For a verbal description click here.

We now apply a voltage E to the resistors as shown in Figure 0.5. Kirchhoff's equation is - E + V1 + V2 + V3 = 0. Solving for E gives

E = V1 + V2 + V3           (0.23)

The equivalent resistor Req would give the simple equation

E = Veq           (0.24)

If we substitute Ohm's law VN = I x RN and remember that the current I is the same everywhere in a series circuit we have

I x Req = I x R1 + I x R2 + I x R3           (0.25)

canceling I

Req = R1 + R2 + R3           (0.26)

and in the general form

Req = R1 + R2 + ... + RN           (0.27)

Equation 0.27 says that the equivalent of any number of resistors in series is the sum of all of the resistors in series.

Figure 0.5 (a) Three Series Resistors Connected to a Voltage
Source, (b) One Equivalent Resistor Connected to a
Similar Voltage Source.

For a verbal description click here.

Logical Checks.

In any problem-solving course it is a good idea to have in mind some rules of logic for checking answers. You should look at an answer and ask yourself "Does that answer make sense?" From time to time this book will give some common sense rules under the heading of "Logical Checks".

When finding the equivalent of series resistors the equivalent will always be greater than the largest single resistor.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

0.4 Parallel Circuits and Kirchhoff's Current Law.

A parallel circuit is defined as a circuit which has two or more independent paths which can be followed from a given point in the circuit back to the same point. A simple parallel circuit is shown in Figure 0.6.

Figure 0.6 Schematic Diagram of a Parallel Circuit.

For a verbal description click here.

Voltage in Parallel Circuits.

Now that we know Kirchhoff's voltage law let us use it. This law applies to any circuit as long as we go around a loop taking every voltage drop into account and coming back to the original starting point.

In Figure 0.6 let us start at the lower left corner, go up through the battery, to the right to the top of R1, down through R1 and then back to the left to the starting point. The resulting equation is -E + V1 = 0 or E = V1.

Now let us follow a path through R2. Start at the lower left corner, go up through the battery, to the right to the top of R2, down through R2 and then back to the left to the starting point. The resulting equation is -E + V2 = 0 or E = V2.

The argument is the same for R3. Thus we have shown that

E = V1 = V2 = V3           (0.28)

In a simple parallel circuit the voltage across any one element is the same as the voltage across any other element in the same circuit.

Current in Parallel Circuits.

Figure 0.7 is the map of a rather strange system of roads. The system is one-way, left to right. Cars are fed into the system at the left at a rate measured in cars/hour. At the first junction some cars go left, some go straight and some go right. The cars go through the three parallel roads and join up again at the rejoin point. Cars cannot get out of the system except at the ends and no cars from the outside can get in. Cars exit on the right at the same rate as they enter on the left. No stopping in the red zone.

Figure 0.7 Map of Strange Road System.

For a verbal description click here.

When the car-current (cars/hour) splits it is obvious that the sum of the car-currents (KN) in the three paths is equal to the car-current (K) in the main path.

K = K1 + K2 + K3           (0.29)

Look at Figure 0.6 and visualize the electrons in the circuit doing the same as the cars on the road. This is the justification for writing the equation

I = I1 + I2 + I3           (0.30)

which is a special case of Kirchhoff's current law.

Kirchhoff's current law says that the sum of all currents flowing into a junction is equal to zero. If current going in is defined as positive, then current coming out is negative.

In Figure 0.6 the top line is a junction where currents may be summed and the bottom line is another junction where currents may be summed. If we sum the currents in the top line we have

I - I1 - I2 - I3 = 0           (0.31)

if we sum the currents in the bottom junction we have

- I + I1 + I2 + I3 = 0           (0.32)

The only difference between equations 0.25 and 0.26 is that one is the negative of the other. Numerical solution of both equations will give the same answer.

Resistors in Parallel.

Suppose we have three resistors in parallel as in Figure 0.8a and we wish to replace them with a single resistor as in Figure 0.8b. We want a single resistor Req which will cause the same amount of current to flow as the parallel combination of R1, R2 and R3 when connected across the same voltage source (battery). In other words we want one resistor which will act the same as the three resistors together.

Figure 0.8 (a) Three Resistors in Parallel,
(b) One Equivalent Resistor to Replace it.

For a verbal description click here.

We now apply a voltage E to the resistors as shown in Figure 0.9. Kirchhoff's equation for the bottom line of the circuit is -I + I1 + I2 + I3 = 0. Solving for I gives

I = I1 + I2 + I3           (0.33)

The equivalent resistor Req would give the simple equation

I = Ieq           (0.34)

If we substitute Ohm's law IN = E / RN and remember that the voltage E is the same everywhere in a parallel circuit we have

E / Req = E / R1 + E / R2 + E / R3           (0.35)

canceling E

1 / Req = 1 / R1 + 1 / R2 + 1 / R3           (0.35)

in the general form and as more often written

Req = 1 / ( 1 / R1 + 1 / R2 + ... + 1 / RN)           (0.37)

Equation 0.37 says that the equivalent of any number of resistors in parallel is the reciprocal of the sum of all of the reciprocals of the individual resistors in parallel.

Figure 0.9 (a) Three Paralleled Resistors Connected to a
Voltage Source, (b) One Equivalent Resistor
Connected to a Similar Voltage Source

For a verbal description click here.

Logical Checks.

When finding the equivalent of parallel resistors the equivalent will always be less than the smallest single resistor.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

0.5 Prefixes.

Prefixes are used throughout the sciences to indicate multiplication by a power of ten. You probably already know that 1 centimeter = 10-2 meters and 1 kilogram = 103 grams.

In electricity and magnetism the values are so large or so small as to require the use of prefixes. You MUST be able to make instant conversions in your head from one prefix to another or the unprefixed unit. Here are the prefixes you should know.

For a more screen reader friendly version of the table below click here.

Prefix | Multiplier | Symbol
pico | 10-12 | p
nano | 10-9 | n
micro | 10-6 | u
milli | 10-3 | m
kilo | 103 | k
mega | 106 | M
giga | 109 | G

Table 0.1 List of Prefixes Commonly Used in Electronics

For a more screen reader friendly version of this table click here.

Example 0.2.

Convert; (a) 500,000 hertz to kilohertz and megahertz,
(b) 820 k ohms (kilohms) to ohms and Megohms,
(c) 9 x 10-4 amperes to mA and uA.

Solution

(a) 500 kilohertz (kHz) and 0.5 megahertz (MHz)
(b) 820,000 ohms and 0.82 M ohms
(c) 0.9 mA and 900 æA

You should be able to answer those questions as quickly as you can speak the words. If you cannot, make up some practice questions and drill until you can convert without having to stop and think.

Yes, it's memorization. Unfortunately there is no other way to learn prefixes. There is nothing to understand, just memorize, memorize, memorize.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

0.6 Numerical Examples

The following examples will illustrate the standard method for solving electric circuits. The method employs the repeated application of Ohm's and Kirchhoff's laws. The examples will also illustrate prefix conversion. In solving these circuits there is no formula you can find to plug numbers into. You must think!

Example 0.3.

In the circuit of Figure 0.2 the battery voltage E is 24.00 volts. R1 = 470 ohms, R2 = 220 ohms and R3 = 330 ohms. What is the current drawn from the battery?

Solution:

The equivalent resistance in the circuit is R1 + R2 + R3 = 470 ohms + 220 ohms + 330 ohms = 1020 ohms. The current drawn from the battery is I = E / Req I = 24 v / 1020 ohms = 2.35 x 10-2 A = 23.5 mA.

Example 0.4.

In the circuit of Figure 0.2 the resistance of each resistor is as follows. R1 = 910 ohms, R2 = 1.1 k ohms and R3 = 1.3 k ohms. The voltage across R2 is 4.985 volts. What is the battery voltage?

Solution:

Intermediate results should always be carried out to four significant digits. Answers should be rounded off to three significant digits. The current in R2 is I2 = V2 / R2 = 4.985 v / 1.1 k ohms = 4.532 mA. This also is the current in R1 and R3, I = I1 = I2 = I3. The voltage across R1 is V1 = I1 x R1 = 4.532 mA x 910 ohms = 4.124 v, V2 is given and V3 = 5.892 v. The battery voltage E is equal to the sum of all resistor voltages E = 4.124 v + 4.985 v + 5.892 v = 15.001 v. Rounding off, the battery voltage E = 15.0 volts.

Example 0.5.

In the circuit of Figure 0.6 the resistance of R2 is 620 ohms and the current through it is 125 mA. The resistance of R3 is 15 k ohms. What is the current through R3?

Solution:

The voltage across R2 is V2 = I2 x R2 = 125 mA x 620 ohms = 77.50 v. In a parallel circuit E = V1 = V2 = V3; hence V3 = 77.50 v. I3 = V3 / R3 = 77.50 v / 15 k ohms = 5.17 mA.

Example 0.6.

In figure 0.6 the current in R1 is 66.6 mA, the current in R2 is 39.4 mA, the power in R3 is 1.7 watts and the resistance of R3 is 820 ohms. What is the total battery current?

Solution:

The current in R3 is I3 = (P / R)1/2
I3 = (1.7 w / 820 ohms)1/2 = 4.553 x 10-2 A = 45.53 mA.  The battery current I = I1 + I2 +I3
I = 66.6 mA + 39.4 mA + 45.53 mA = 152 mA.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

0.7 Capacitance.

A capacitor is a device which has the property of capacitance. Capacitance is the property possessed by a capacitor. Eh?

A capacitor is nothing more than an open circuit. Yet it is the most useful open circuit ever discovered. A capacitor consists of two conductors separated by an insulator. Capacitors can best be described as devices which permit electric charge to be stored and released in a controllable and repeatable manner.

Capacitance is that electrical property which resists changes in the voltage across the circuit containing the capacitance.

Capacitors are devices in which energy can be stored for short periods of time. The energy is stored in the electric field between the two conductors of the capacitor.

Capacitance is defined as

C = Q / V           (0.38)

where C is called the capacitance and is measured in farads, Q is the charge on either conductor in coulombs and V is the potential difference between the two conductors in volts.

If equation 0.38 is solved for charge we have

Q = C V           (0.39)

If we take the time derivative of both sides of this equation we have

dq / dt = C dv / dt           (0.40)

But dq/dt = i; therefore,

i = C dv / dt           (0.41)

This equation turns out to be much more useful than you might imagine.

Example 0.7.

If the current through a capacitor is 120 milliamperes and the rate of change of voltage is to be 1.5 volts/milliseconds, what is the capacitance?

Solution:

Solving equation 0.41 for C gives

C = I / (dv/dt) = 120 x 10-3 / (1.5 v / 10-3) = 8.0 x 10-5 farads.

8 x 10-5 farads may be expressed as 80 microfarads or 80 uf. Both answers are correct, they are just different ways of expressing the same number.

Equation 0.41 tells us that we cannot change the voltage across a capacitor in zero time. If we tried, the current would be infinite. This equation also tells us that if we maintain a constant current through a capacitor, the voltage across it will change linearly with time. This is the basis of the linear sweep in an oscilloscope.

Resistance-Capacitance Circuit.

Figure 0.10 Circuit For Charging and Discharging a Capacitor.

For a verbal description click here.

Consider the circuit of Figure 0.10. The switch is placed in position 1 to insure that there is no initial charge on the capacitor. Then the switch is changed to position 2 and the capacitor begins to charge. The bottom plate will receive a negative charge while the top plate will receive a positive charge. Kirchhoff's voltage equation for this circuit at any instant of time is

E = iR + q / C           (0.42)

The battery voltage E, the resistance R and the capacitance C do not vary with time. The current i and the charge on the capacitor q do vary with time. If we take the time derivative of this equation we have

E = di / dt x R + dq / dt x 1 / C           (0.43)

If we make the substitution i = dq/dt we have

E = di / dt x R + i / C           (0.44)

The solution to this differential equation in i is

i = E / R x e-t/RC           (0.45)

This equation tells us that the current starts out as if the capacitor were a short circuit. i0+ = E/R. The current quickly falls away and decays exponentially.

When t becomes equal to RC the value of the exponent on e is -1. This point in time has been defined as the time constant of the circuit and is given as

T = RC           (0.46)

where T is the time-constant in seconds, R is the resistance in ohms and C is the capacitance in farads.

After one time-constant the current has fallen to 1/e of its initial value; after 2 time-constants the current has fallen to e-2 of its initial value and so on. Theoretically the current will never reach zero. After 5 time-constants the current will be .07% of its initial value and for most practical purposes may be considered to be zero.

Example 0.8.

Starting with equation 0.45 and using only Ohm's and Kirchhoff's laws show that the voltage across the capacitor is given by

vC = E (1 - e-t/RC)           (0.47)

Solution:

The voltage across the resistor is vR = iR or

vR = E e-t/RC           (0.48)

Solving Kirchhoff's equation for vC gives

vC = E - vR           (0.49)

Substituting equation 0.48 into 0.49 and factoring out an E gives us

vC = E (1 - e-t/RC)           (0.50)

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

0.8 Inductance.

Inductance is that electrical property which resists changes in the current in the circuit containing the inductance.

A device which has the property of inductance is called an inductor. It consists of a coil of wire. The coil may be wound on a solid iron core, a powdered iron core or a hollow tube (air core).

An inductor can store and release energy. The energy is stored in the magnetic field which is produced by the current flowing in the coil of wire.

Inductance is defined as

L = N H / I           (0.51)

where L is the inductance which is given in units called henrys, N is the number of turns on the coil, H is the magnetic flux produced by each turn and I is the current in the coil.

If we rearrange equation 0.51 we have

L I = N H           (0.52)

If we take the time derivative of equation 0.52 we have

L di / dt = N dH / dt           (0.53)

Remember from physics that

E = - N dH /dt           (0.54)

Substituting equation 0.54 into equation 0.53 yields

E = - L di / dt           (0.55)

This equation tells us that we cannot change the current through an inductor in zero time. To do so would require an infinite voltage across the inductor.

The minus sign in equation 0.55 tells us that the polarity of the voltage which is produced is in such a direction as to oppose the change which produced it.

Consider the circuit of Figure 0.11. The battery will cause current to flow to the right in the inductor (coil of wire). The normal polarity of the voltage drop across the inductor will be positive to the left as shown in the figure.

Figure 0.11 Simple Inductive Circuit.

For a verbal description click here.

If we now cause a sudden decrease in the voltage of the "battery" the current through the inductor will decrease. This is a negative di/dt. Combined with the minus sign in equation 0.55 gives a positive result. The current is flowing to the right in the inductor. A positive voltage with respect to this current means that the voltage will be positive on the right as shown. For the period of time that the change of current is taking place, the inductor may be considered as a voltage generator. The "voltage generator" in the inductor which has its positive terminal on the right is adding to the voltage of the battery. Remember that this whole thing started with a decrease in the battery voltage. The voltage being produced by the inductor is adding to the battery voltage and thereby opposing the change.

If we now cause a sudden increase in the voltage of the "battery" the current through the inductor will increase. This is a positive di/dt. Combined with the minus sign in equation 0.55 gives a negative result. The current is flowing to the right in the inductor. A negative voltage with respect to this current means that the voltage will be negative on the right as shown. For the period of time that the change of current is taking place, the inductor may be considered as a voltage generator. The "voltage generator" in the inductor which has its negative terminal on the right is subtracting from the voltage of the battery. Remember that this whole thing started with an increase in the battery voltage. The voltage being produced by the inductor is opposing the change.

The inductor only has a finite amount of energy stored in its magnetic field and it cannot maintain the voltage indefinitely. The inductor cannot prevent the change in current but it can slow it down.

Example 0.9.

A relay coil has an inductance of 95 millihenrys. A transistor switch turns off a current of 40 mA through the coil in a time of 1 us. What is the magnitude of the voltage spike which is produced?

Solution:

E = L di / dt = 95 mH x 40 mA / 1 us = 3800 volts.

Resistive-Inductive Circuits.

Figure 0.12 is the diagram of an inductive-resistive (RL) circuit. The switch is placed in position 1 to insure that there is no current in the circuit. When the switch is changed to position 2 the battery's potential is applied to the series RL circuit. For an infinitesimal instant of time, no current will flow in the circuit. The inductor has developed an emf of the polarity indicated in the figure. If the voltage across the battery and the inductor have the same magnitude and sign, Kirchhoff's law says that there is no voltage drop across the resistor. If there is no voltage across the resistor, there is no current through it. Because this is a series circuit, no current in the resistor means no current anywhere in the circuit. This situation cannot last for any finite length of time. Current begins to increase in the circuit but the change continues to be opposed by the inductor. The inductor ultimately loses the fight and the current becomes equal to E/R assuming that the inductor has zero resistance (a highly invalid assumption as it turns out).

Figure 0.12 Resistive-Inductive Circuit With Switch.

For a verbal description click here.

Now let us write Kirchhoff's equation for the circuit of Figure 0.12.

E = iR - L di / dt           (0.56)

The solution to this equation is

i = E / R (1 - e-tR/L)           (0.57)

This equation tells us that the current starts out as if the inductor were an open circuit. i0+ = 0. The current quickly rises to exponentially approach E/R.

The voltage across the inductor is

vL = E e-tR/L           (0.58)

Verification of equation 0.58 is left as an exercise for the student.

When t becomes equal to L/R the value of the exponent on e is -1. This point in time has been defined as the time constant of the circuit and is given as

T = L/R           (0.59)

where T is the time-constant in seconds, R is the resistance in ohms and L is the inductance in henrys.

After one time-constant the current has risen to 1 - 1/e of its initial value; after 2 time-constants the current has risen to 1 - e-2 of its initial value and so on. Theoretically the current will never reach the maximum value of E/R. After 5 time-constants the current will be 99.83% of E/r and for most practical purposes may be considered to be E/r.

The Reality of Inductors.

In the foregoing, inductance and resistance were treated as if they were separate components of the circuit. In practice, inductors always have resistance. Inductors are coils of wire. Wire has resistance. It is impossible to make an inductor which does not have any resistance.

For purposes of circuit analysis the inductance of a coil and its resistance are shown schematically as separate circuit elements. In the circuit of Figure 0.12 it is likely that the resistor and inductor which are shown actually represent a single coil of wire. Think of it as being roughly analogous to the X and Y components of a force.

Recent advances in superconductors may eventually make the preceding paragraphs unnecessary. However, at the present time, it is not possible to form superconducting materials into a wire and wind it into a coil. Note: That's still true in 2007.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

0.9 Problems.

  1. Two spheres are charged with +25 and +50 microcoulombs respectively. The distance between them is 20 meters. What is the force exerted between the two spheres? Is the force attractive or repulsive?

  2. Express the ampere in terms of kilograms, meters and seconds.

  3. If a current of 500 mA flows for 11 minutes, how much charge is moved?

  4. If a charge of 1026 coulombs was transferred at a constant rate in a time of 3 hours, what was the current?

  5. A current of 25 mA must be left on until a charge of 10,000 coulombs has been moved. How long must the current be left on? Express your answer in days, hours, minutes and seconds.

  6. Express the volt in terms of kilograms, meters and seconds.

  7. If 300 joules of work are done on 25 coulombs of charge, what was the potential through which the charge was moved?

  8. If 12 coulombs are moved through a potential of 120 volts, how much work was done?

  9. If 420 joules of work are done while moving a certain amount of charge through a potential difference of 28 volts, how much charge was moved?

  10. If 15 amperes are drawn from a 12 volt battery, what is the power?

  11. What is the current drawn by a 100 watt, 120 volt light bulb?

  12. For proper operation an electroplating cell requires the movement of 1.26 x 105 coulombs per hour. The cell voltage is 3.3 volts. How much power is required to keep the cell in continuous operation?

  13. Express the ohm in terms of kilograms, meters and seconds.

  14. A current of 55 mA is flowing through a 270 ohm resistor. What is the voltage drop across the resistor?

  15. When a potential of 12 volts is applied to an unknown resistor, a current of 24.74 mA flows. What is the resistance of the resistor?

  16. If a 56 ohm resistor is placed across a 15 volt power supply, how much current will flow?

  17. A resistor substitution box contains the following resistor values.

    First decade 15, 22, 33, 47, 68 and 100 ohms Second decade 150, 220, 330, 470, 680 and 1000 ohms

    Each successive decade follows the same pattern. The highest resistance is 10 Megohms. Each resistor can dissipate a maximum of 1 watt without burning out. (a) What is the minimum resistance setting which can be safely connected across the 120 volt power line?
    (b) What is the minimum resistance setting which can be safely connected across a 20 volt power supply?
    (c) What is the minimum resistance setting which can be safely connected across a 12 volt power supply?
    (d) What is the minimum resistance setting which can be safely connected across a 5 volt power supply?

  18. How much current can safely be run through; (a) a 39 ohm 1/2 watt resistor, (b) a 470 ohm 1/4 W resistor, (c) a 27 ohm 2 W resistor and (d) a 560 ohm 1 W resistor?

  19. In Figure 0.2, E = 6.60 volts, R1 = 33 ohms, R2 = 22 ohms and R3 = 11 ohms. How much current is flowing in the circuit?

  20. In Figure 0.2, E = 7.20 volts, R1 = 470 ohms, R2 = 220 ohms and R3 = 100 ohms. What is (a) the voltage across R1, (b) the voltage across R2 and (c) the voltage across R3?

  21. In Figure 0.2, R1 = 2.2 k ohms, R2 = 1.5 k ohms and R3 = 3.6 k ohms. If the voltage across R1 (V1) is 2.45 volts, what is the voltage across R3 (V3)?

  22. In Figure 0.2, E = 22.5 volts, R1 = 3.9 k ohms, R3 = 4.7 k ohms, V2 = 7.500 v and V3 = 8.198 v. What is the resistance of R2?

  23. In Figure 0.6, E = 6.60 volts, R1 = 33 ohms, R2 = 22 ohms and R3 = 11 ohms. How much current is flowing in the circuit?

  24. In Figure 0.6, the battery current I = 200 mA, R1 = 470 ohms, R2 = 220 ohms and R3 = 100 ohms. What is; (a) the current through R1, (b) the current through R2 and (c) the current through R3?

  25. In Figure 0.6, R1 = 2.2 k ohms, R2 = 1.5 k ohms and R3 = 3.6 k ohms. If I1 = 8.182 mA, what is I3?

  26. In Figure 0.6, I = 5.987 mA, R1 = 3.9 k ohms, R3 = 4.7 k ohms, I2 = 1.765 mA, and I3 = 1.915 mA. What is the resistance of R2?

  27. How much charge is stored on a 7000 uf capacitor when it is charged to a voltage of 18 volts?

  28. A circuit has a capacitance of 100 pf. How much current must the circuit deliver to the capacitor in order to change the voltage at a rate of 13 v/us?

  29. If a 2000 uf capacitor is being discharged with a current of 1 A, how much will its voltage change in 8 ms?

  30. In the circuit of Figure 0.10 if R = 1 Meg ohm, C = 1 uf and E = 10.0 v. The capacitor starts out fully discharged. How long after the switch is thrown to position 2 does the voltage across the capacitor reach 9.0 volts?

  31. A time delay circuit triggers when the voltage reaches 2/3 of the applied voltage. The capacitor always starts charging from 0 volts. It is desired that the circuit will trigger 1.5 seconds after the timing cycle begins. If the capacitor is a 0.1 uf, what value resistor is required in the circuit?

  32. Starting with equation 0.57 and using only Ohm's and Kirchhoff's laws show that the voltage across an inductor is given by vL = E e-tR/L.

  33. The current through a 50 millihenry inductor is to be changed from some value IL to zero in a time of 5 us. What must the value of IL be to give a 20 kv voltage spike?

  34. What is the time-constant of a coil which has 8 henrys of inductance and 40 ohms of resistance?

  35. A relay is a device which employs an electromagnet to close one or more sets of switch contacts. The switch contacts can carry a much larger current than is required to energize the electromagnet. The electromagnet is a coil of wire which has inductance and resistance. A given relay is taking too long to close its contacts in a particular application. It has been determined that the delay is not due to mechanical inertia of the moving parts but is due to the time- constant of the RL circuit of the coil. Discuss what may be done to shorten the time required for the relay to close. The relay itself may not be replaced or altered.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

0.10 Answers to problems.

  1. 3.125 Newtons repulsive.

  2. Coulombs = meters x Newtons-1 / seconds.

  3. 330 coulombs.

  4. 95 mA.

  5. 4 d: 15 h: 6 m: 40 s.

  6. Volts = Newton-1 x seconds

  7. 12 volts.

  8. 1440 Joules.

  9. 15 Coulombs.

  10. 180 watts.

  11. 0.833 Amps.

  12. 115.5 watts.

  13. ohms = seconds2 / meters

  14. 14.85 volts.

  15. 485 ohms.

  16. 268 mA.

  17. (a) 15 k ohms, (b) 470 ohms, (c) 150 ohms, (d) 15 ohms.

  18. (a) 113 mA, (b) 23.1 mA, (c) 272 mA, (d) 42.2 mA.

  19. 100 mA.

  20. (a) 4.28 volts, (b) 2.00 volts, (c) 0.911 volts.

  21. 4.01 volts.

  22. 4.30 k ohms.

  23. 1.10 Amps.

  24. (a) 25.5 mA, (b) 54.5 mA, (c) 120 mA.

  25. 5.00 mA.

  26. 5.10 k ohms.

  27. 0.126 Coulombs.

  28. 1.30 mA.

  29. 4.00 volts.

  30. 2.30 seconds.

  31. 13.6 Meg ohms.

  32. Beginning with the equation,
    i = E / R (1 - e-tR/L)

    The voltage across the resistor is obtained by multiplying the current by the resistance. Multiplying the equation by R gives,

    VR = E (1 - e-tR/L)

    By Kirchhoff's law,

    E = VR + VL

    Or

    VL = E - VR

    Subtracting E from the equation for VR
    VL = E - E (1 - e-tR/L)

    Removing the parentheses and carrying out the multiplication gives,

    VL = E - E + E e-tR/L

    So,

    VL = E e-tR/L

    QED.

  33. 2.00 Amps.

  34. 0.200 seconds.

  35. Place a resistor in series with the coil and increase the applied voltage to keep the current the same.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

This page copyright © Max Robinson. All rights reserved.


Chapter 1   DC Circuits.

1.1  Solving Complex Circuits Using Loop Equations.
1.2  Voltage Dividers.
1.3  Thevenin's Theorem.
1.4  Norton's Theorem.
1.5  Current Measurement, the D'Arsonval Meter.
1.6  Voltage Measurement.
1.7  Measurement Using Multimeters.
1.8  Problems.
1.9  Answers to Problems.

Chapter 1.

DC Circuits.

It may be said that after mastering the contents of chapter 0 we have in hand all of the tools we need to solve any electric network we are likely to encounter. While this is true, there are a great many shortcuts and additional theorems to be learned. It is not possible to cover all of these. We will cover a few of the most useful ones here.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

1.1 Solving Complex Circuits Using Loop Equations.

There is a theorem in network analysis which states that the total current flowing in any circuit element is the sum of the individual currents produced by each voltage source with all other sources removed and replaced by short circuits. This is called the superposition theorem. This theorem tells us that it is possible to solve for the individual components of current and add them together to obtain the total current.

We could remove the two sources, one at a time, from the circuit of Figure 1.1 and use circuit reduction to find the values of current being drawn, or injected into, each battery, but this is still an arduous method.

Instead we will consider that current flows round and round each loop and where two currents pass through the same resistor The actual current is the algebraic sum of the two. We assume a direction for the currents because we can't always figure out the current direction by inspection. We will sum the voltages around each loop of a circuit according to Kirchhoff's voltage law.

Voltage Rises and Drops.

The least confusing way to sum voltages around a loop is to give a rise a positive sign and a drop a negative sign. That's simple isn't it? Going up is positive, going down is negative. To sum voltages around a circuit you select a starting point, it doesn't matter where, and move around the circuit until you come back to the same point. If you travel across something from minus to plus you have traversed a rise. If you traverse from plus to minus it is a drop.

A battery is not automatically a rise. What matters is which way you walked across it. If you walk from plus to minus it is a drop. Similarly a resistor is not automatically a drop. If you move across it from minus to plus it is a rise. It depends on which way you go not whether it is a battery or a resistor.

Obviously assigning the plus and minus signs is key to solving a circuit. If the signs are wrong the answer will be wrong. First of all a battery is what it is. If current is flowing out of the battery, normal discharging, or into the battery, charging, the positive side is positive and the negative side is negative. That cannot change.

A resistor is a somewhat different story. The direction of current through the resistor determines the polarity of voltage across it. The current flows into the positive end and out of the negative end. This can be made clear with the simplest of all possible circuits.

Figure 1.0 Simple Circuit Showing Current Direction and Voltage Polarity.

For a verbal description click here.

Since there are only two elements in the circuit the voltage polarity is obvious by inspection. The current direction is also obvious. It flows out of the positive terminal of the battery, downward through the resistor and back to the battery. So you see that the end of the resistor where the current exits is the negative end. If you forget which way it goes you can recreate this drawing at any time or in any place and refresh your memory.

The current direction must be assumed in complex circuits but as long as consistent rules are followed the answer will be correct. If you assume wrongly the answer will have a negative sign attached but the magnitude will always be correct.

Loop Equations.

Figure 1.1 Circuit Containing Two Voltage Sources.

For a verbal description click here.

Consider the circuit of Figure 1.1. Instead of trying to solve for the voltage and current at each resistor we will take a somewhat different approach. Assume that the current in each loop follows a closed path as indicated by the arrows in Figure 1.1. The current I1 flows through E1, R1 and R2. The current I2 flows through R2, R3 and E2. The current in R1 is I1 while the current in R3 is I2. The current in R2 is the algebraic sum of I1 and I2.

We cannot tell by inspection which direction the current in each loop is flowing. You might say "obviously the current is flowing out of the positive terminal of each battery." You might be right, you might be wrong. Suppose that E1 is the power source in a battery charger and E2 is the battery which is being charged. In that case the directions indicated by the arrows would be correct. If E2 were the source and E1 were the battery being charged the true current directions would be opposite to those shown in the figure. The true current directions may or may not be as you would tend to assume by inspection. The point is, you cannot tell in advance what the directions of the currents will be. The usual procedure is to assume that all currents are clockwise. If the guess is wrong, the answer will come out with a minus sign attached and we will know that the true current is in the opposite direction.

There are two unknowns in the circuit, I1 and I2. The circuit will produce two equations. A circuit with three loops would produce three equations in three unknowns. In general then it can be said that a network with N loops will produce N equations in N unknowns.

It is assumed that the student at this level of study has already mastered at least one technique for solving systems of N by N equations. Solving systems of 3 by 3 or larger is a job best left to a computer program. We are here to learn techniques, not to get exercise from solving systems of N by N equations. For this reason the problems and examples in this text will not exceed systems of 2 by 2.

Writing the Equations.

To write the equations we sum the voltage rises around each loop. It does not matter that there are branches in and out of the loop. Kirchhoff's voltage law applies. In the circuit of Figure 1.1 the equations are written as follows.

E1 - R1 I1 - R2 I1 + R2 I2 = 0           (1.1)

- E2 - R3 I2 - R2 I2 + R2 I1 = 0           (1.2)

The polarity of the voltage sources is fixed and cannot change. The polarity of each resistor drop is marked inside of each loop. Moving in the direction of assumed current, E1 is a rise and therefore positive. The drops across R1 and R2 due to I1 are drops and therefore negative. The current in loop 2 has an influence on loop 1 and so we must include this in the equation. The term "R2 I2" reflects this influence. The term is positive because the voltage difference produced by I2 is a rise when moving in the direction of I1. In loop 2 (equation 1.2) the voltages due to I2 are all drops and therefore negative as is E2. The only positive term in equation 1.2 is the effect of I1 on loop 2.

It may seem as if there is some magic going on here. Each equation is just a statement of Kirchhoff's voltage law for that loop. The techniques for writing these equations were covered in chapter 0. If you do not understand how to write these equations, review section 0.3.

Assuming that the individual currents run in circles may be a little more difficult to understand. Intuition and visualization tell us that the currents really don't do that. However, this is a mathematical model. Mathematical models do not necessarily describe physical reality; they permit calculations to be made which will give the right answer.

Do not attempt to memorize equations 1.1 and 1.2. Learn how to write the equations from the circuit as it is given.

Example 1.1.

In the circuit of Figure 1.2, what is the voltage drop across R2?

Figure 1.2 Circuit Containing Two Voltage Sources.

For a verbal description click here.

Solution:

The equations are

12 - 330 I1 - 75 I1 + 75 I2 = 0

6 - 100 I2 - 75 I2 + 75 I1 = 0

Rearranging yields

- 405 I1 + 75 I2 = - 12

75 I1 - 175 I2 = - 6

Solving these equations simultaneously yields

I1 = 39.08 mA

I2 = 51.03 mA

These values are stated to 4 digits because they are intermediate values. Note that both have positive signs, which means that the assumed directions are correct. The question being asked is "What is the voltage across R2?" The current in R2 is made up of two components, 39.08 mA downward and 51.03 mA upward. If we define up as positive then

IR2 = - 39.08 mA + 51.03 mA = 11.95 mA

The current flows upward in R2; therefore, its upper end will be negative. The magnitude of the voltage is

V2 = I2 R2 = 11.95 mA x 75 ohms = 0.896 v

The answer is 0.896 volts upper end negative.

Understanding loop equations is very important. You may be thinking that this is just an exercise and you will never see this type of problem again. If you are thinking that, you are wrong. Problems and derivations in transistors and integrated circuits use these methods again and again. If you haven't mastered loop equations, go over this section until you do. If you go on without understanding loop equations, you will start to feel disoriented somewhere around chapter 3 and be totally lost by chapter 5. Don't say you weren't warned.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

1.2 Voltage Divider.

One application of the series circuit is known as the voltage divider. Voltage dividers are used to reduce voltages by some fixed factor. They also appear as parts of more complex circuits. The circuit of a simple voltage divider is shown in Figure 1.3.

Figure 1.3 Simple Voltage Divider.

For a verbal description click here.

The following is based on a voltage divider with no significant load. The output voltage is the voltage across R2. To find the voltage across R2 we need to find the current through it. The current through R2 is the same as the current anywhere else in the circuit. The current in the circuit is given by

I = E / (R1 + R2)           (1.3)

The voltage across R2 is given by

VO = I R2           (1.4)

Substituting equation 1.3 into equation 1.4 gives us the voltage divider equation

VO = E R2 / (R1 + R2)           (1.5)

This is one of the most often used equations in electricity and electronics. Although memorization is usually not recommended, make an exception for this one. Remember not only the equation but the procedure for obtaining it.

Often the input voltage to a voltage divider is not a battery E but sometimes a known voltage VIN. In this case the equation would be

VO = VIN R2 / (R1 + R2)           (1.6)

If the voltage divider has more than two resistors the equation is basically the same. The numerator is the sum of all of the resistors the output is taken across. The denominator is the sum of all resistors in the divider chain. An example will illustrate.

Example 1.2.

In Figure 1.4 if the VIN is 100 volts, what is the output voltage between common and; (a) 1, (b) 2, (c) 3, (d) 4, and (e) 5?

Figure 1.4 Voltage Divider.

For a verbal description click here.

Solution:

(a) When the output is taken from common and point 1, the output is connected to the input by wires. The output voltage is 100 volts.

(b)   VO = VIN (R2 + R3 + R4 + R5) / (R1 + R2 + R3 + R4 + R5)

VO = 100 v x 300 k ohms / 1000 k ohms = 30 v

(c)   VO = 100 v x 100 k ohms / 1000 k ohms = 10 v

(d)   VO = 100 v x 30 k ohms / 1000 k ohms = 3 v

(e)   VO = 100 v x 10 k ohms / 1000 k ohms = 1 v

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

1.3 Thevenin's Theorem.

The circuits we have studied so far have been self- contained. It may seem to you as if these circuits are of limited usefulness and you are right. The most useful circuits are those which have output terminals. A circuit which has output terminals can deliver electrical energy in various forms for use by other circuits. Figure 1.5 is the schematic diagram of a circuit which has output terminals.

Figure 1.5 Complex Network With Output Terminals.

For a verbal description click here.

Suppose that we wanted to find the current which would flow in a certain load resistance. Based on what we have learned to date the procedure would be to draw the load in the circuit and then solve the 3 by 3 system of equations for I3 which would be the current in the load. If it is necessary to solve for the current in a number of different loads, the system of equations must be solved as many times as there are loads. Enter Thevenin.

Thevenin's theorem states that any circuit no matter how complex may be replaced by a single voltage source in series with a single resistor as shown in Figure 1.6. The voltage source is equal to the open-circuit voltage of the complex circuit and the resistance is equal to the resistance looking in at the output terminals with all voltage sources replaced by short circuits.

Figure 1.6 Thevenin's Equivalent Circuit.

For a verbal description click here.

Finding the values for the voltage source and resistor involves solving the complex circuit only once. The original circuit and the Thevenin's circuit will act exactly the same for any load resistance. If you had each circuit sealed in separate black boxes which you could not open or x-ray, there would be no way to tell which was which. Let us work some examples to illustrate the application of the theorem.

Example 1.3.

Find Thevenin's equivalent circuit for the circuit of Figure 1.7. E1 = 30 v, E2 = 3.0 v, R1 = 240 ohms, R2 = 400 ohms, R3 = 350 ohms, R4 = 750 ohms, and R5 = 100 ohms.

Figure 1.7 Circuit For Example 1.3.

For a verbal description click here.

Solution:

In the circuit of Figure 1.7 if the output is open-circuited there will be no current in R5. I3 = 0. If there is no current in R5 there is no voltage drop across it. The output voltage is the same as the voltage across R4. This effectively reduces the problem from a 3 by 3 to a 2 by 2. The only unknowns are I1 and I2 and there are two loops to give us two equations.

E1 - R1 I1 - R2 I1 + R2 I2 = 0

E2 - R2 I2 - R3 I2 - R4 I2 + R2 I1 = 0

Substituting Values.

30 - 240 I1 - 400 I1 + 400 I2 = 0.

3 - 400 I2 - 350 I2 - 750 I2 + 400 I1 = 0.

Combining and rearranging.

-640 I1 + 400 I2 = - 30.

400 I1 - 1500 I2 = - 3.

We need to know I2 but don't care what I1 is. Multiplying the second equation by 1.6 gives.

-640 I1 + 400 I2 = - 30.

640 I1 - 2400 I2 = - 4.8.

Adding the two gives.

0 I1 - 2000 I2 = - 34.8.

I2 = - 34.8 / (- 2000) = 17.40 mA.

I2 is the only current flowing through R4 so.

VR4 = VTh = 17.40 mA x 750 ohms = 13.05 volts.

Now we must obtain the Thevenin resistance.

Figure 1.8 Figure 1.7 With Voltage Sources Removed and replaced by short circuits.

For a verbal description click here.

The Thevenin resistance is the resistance at the terminals with all voltage sources removed and replaced by short circuits. The method here is to start farthest from the terminals and start combining resistors. R1 and R2 are in parallel so.

R12 = R1 R2 / (R1 + R2) = 240 x 400 / (240 + 400) = 150 ohms.

R12 and R3 are in series so.

R123 = R12 + R3 = 150 + 350 = 500 ohms.

R123 is in parallel with R4 so.

R1234 = R123 R4 / (R123 + R4) = 300 ohms.

R1234 and R5 are in series so.

R12345 = RTh = R1234 + R5 = 400 ohms.

Figure 1.9 Thevenin's Equivalent Circuit of Figure 1.7

For a verbal description click here.

Example 1.4.

Use Thevenin's theorem to solve example 1.1. "In the circuit of Figure 1.2, what is the voltage drop across R2?"

Solution:

Because the voltage across R2 is what is wanted, we will treat R2 as a load resistor and remove it from the circuit. The result is shown in Figure 1.10.

Figure 1.10 Figure 1.2 With R2 Removed.

For a verbal description click here.

We will now write the loop equation around the outside loop to determine the current in the two resistors which are now simply in series.

12 - 330 I - 100 I + 6 = 0

18 = 430 I

I = 18 v / 430 ohms = 41.86 mA.

Now we will write the loop equation around the loop of the 12 volt battery, the 330 ohm resistor, and the load terminals. Don't be concerned that the load terminals are open. It is easily possible to have a voltage existing across an open circuit. The load voltage is what we want to know.

12 - 330 I - VL = 0

VL = 12 - 330 I = 12 - 13.814 = - 1.814 volts.

This is the Thevenin's voltage source for the equivalent circuit. If both voltage sources are replaced by short circuits the two resistors are in parallel with each other. The equivalent resistance is 76.74 ohms . This is the Thevenin's resistance for the circuit. Now we draw the Thevenin's circuit and connect R2 to it, Figure 1.11

Figure 1.11 Thevenin's Equivalent Circuit
With R2 Connected as a Load.

For a verbal description click here.

Now we apply the voltage divider equation to determine the voltage across R2.

VR2 = -1.814 v x 75 ohms / (75 ohms + 76.74 ohms) = -0.897 v

Maybe we should have carried 5 digits in our intermediate results. The error in the third decimal place is a result of using a finite number of significant digits, not any defect in either method of solution.

Thevenin's theorem can also be used on circuits so complex that they cannot easily be analyzed mathematically. An example is the function generator used in the laboratory. An electronics engineer could study the schematic diagram of the generator and calculate the Thevenin's resistance (also known as output resistance) of the generator. If the function generator had not yet been constructed a calculation would be the only way to find the Thevenin's resistance (or output resistance) of the generator.

Example 1.5.

When the function generator has no load connected, its output voltage is 7.87 volts. When a 100 ohm resistor is connected as a load the voltage is 5.20 volts. What is the output resistance of the function generator?

Solution:

The Thevenin's voltage source is always equal to the open-circuit output voltage of any Thevenin's circuit. Figure 1.12 shows the circuit with everything we know about it to date.

Figure 1.12 Thevenin's Equivalent Circuit
of a Function Generator

For a verbal description click here.

You could apply the voltage divider equation and solve it for the unknown resistor. But suppose that this is a test and you don't remember how to do that. The proper procedure is to put the best computer ever designed to work on the problem, the human mind. Kirchhoff's voltage law gives the voltage drop across the unknown resistor.

V? = VTh - VL = 7.87 - 5.20 = 2.67 v

Ohm's law gives the current through RL.

IL = VL / RL = 5.20 V / 100 ohms = 52.0 mA.

Kirchhoff's current law gives the current through the unknown.

I? = IL = 52.0 mA.

Ohm's law gives the resistance of the unknown.

R? = V? / I? = 2.67 v / 52.0 mA = 51.3 ohms.

The output resistance is 51.3 ohms.

Thevenin's theorem can be used: 1) to solve for the load conditions in circuits which have output terminals, 2) to simplify circuits by allowing a key resistor to be removed and 3) to find the output resistance of devices such as signal generators even when we do not know what is in the box. This is why it can be said that Thevenin's theorem is one of the most useful theorems in circuit analysis.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

1.4 Norton's Theorem.

The Ideal Current Source.

Before we look at ideal current sources let us look at what we know about ideal voltage sources. An ideal voltage source will maintain a constant voltage across its terminals regardless of the amount of current being drawn. The ideal voltage source will keep its voltage constant even if it has to deliver an infinite amount of current to do so. Do I hear someone saying "That's impossible!"? This is an ideal voltage source. In the ideal case, anything is possible.

An ideal voltage source delivers zero power when it is open-circuited. In the open-circuit case, the current is zero. If the current is zero, the power is zero.

We are accustomed to thinking of open-circuits as being a "zero power" condition and short-circuits as being damaging. In the real world any attempt to take anything to infinity is usually damaging to something.

Items we normally think of as voltage sources, such as batteries, are actually Thevenin's equivalent circuits with very low values of output resistance.

An ideal current source will maintain a constant current through its terminals regardless of the amount of voltage being delivered. The ideal current source will keep its current constant even if it has to deliver an infinite amount of voltage to do so. Do I hear someone saying "That's impossible!"? This is an ideal current source. In the ideal case, anything is possible.

An ideal current source delivers zero power when it is short-circuited. In the short-circuit case, the voltage is zero. If the voltage is zero, the power is zero.

We are NOT accustomed to thinking of short-circuits as being a "zero power" condition and open-circuits as being damaging. In the real world any attempt to take anything to infinity is usually damaging to something. An open-circuit current source will attempt to go to infinite voltage and that is an undesirable condition.

The Theorem.

Norton's theorem states that any circuit no matter how complex may be replaced by a single current source in parallel with a single resistor as shown in figure 1.13. The current source is equal to the short-circuit current of the complex circuit and the resistance is equal to the resistance looking in at the output terminals with all voltage sources replaced by short circuits and any current sources replaced by open circuits.

Figure 1.13 Norton's Equivalent Circuit.

For a verbal description click here.

Norton's theorem is not used as often as Thevenin's theorem but it can make short work of example 1.2. Pun fully intended.

Example 1.6.

Use Norton's theorem to solve example 1.2. "In the circuit of Figure 1.2, what is the voltage drop across R2?"

Solution:

Figure 1.14 shows the circuit with R2 removed and replaced by a short circuit. This completely isolates the two loops so they cannot affect one another.

Figure 1.14 Figure 1.2 with R2 Replaced by a Short.

For a verbal description click here.

The current due to the loop on the left is

I1 = 12 v / 330 ohms = 36.364 mA downward.

The current due to the loop on the right is.

I2 = 6 v / 100 ohms = 60.000 mA upward.

With up defined as positive, the current in the short is.

IS = 60.000 mA - 36.364 mA = 23.636 mA upward.

To make current flow upward in the load, current must flow out of the bottom terminal of the current source. The Norton's resistance is the same as the Thevenin's resistance, which is 76.744 ohms . Thus we have the circuit as shown in Figure 1.15 which shows R2 restored to the circuit.

Figure 1.15 Norton's Equivalent of Figure 1.2.

For a verbal description click here.

The current source delivers its 23.636 mA to the parallel combination of RN and R2. The voltage across R2 is the current source multiplied by the parallel combination of RN and R2.

VR2 = -23.636 mA / (1/75 + 1/76.744) = -0.897 v

Thevenin Meets Norton.

Example 1.7.

Find Thevenin's and Norton's equivalent circuits for the circuit of Figure 1.16.

Figure 1.16 Voltage Divider Circuit.

For a verbal description click here.

Solution:

The Thevenin voltage is the open-circuit output voltage of the circuit. This voltage is given by the voltage divider equation as follows.

VTh = 30 v x 1 k ohm / (1 k ohm + 2 k ohms) = 10 v

When the battery E is replaced by a short circuit, R1 and R2 are in parallel and their equivalent resistance is RTh = 666.7 ohms. The circuit would be that of Figure 1.9 except the values will be the ones calculated here. For Norton's theorem the current is equal to the short- circuit current of the original circuit. With a short on the output terminals, R2 is completely shorted out and the current is determined by R1 and the battery.

IN = 30 v / 2 k ohms = 15 mA

The Norton resistance RN is equal to the Thevenin resistance RTh.

If you place a short on a Thevenin's equivalent circuit the current will be given by

I = VTh / RTh           (1.7)

If you open-circuit a Norton's equivalent circuit the output voltage is given by

V = IN RN           (1.8)

The two circuits must behave exactly alike or one or both of the theorems would be invalid. In equation 1.7, the current I is the short-circuit current which is the same as the Norton's current source and, therefore, is IN. In equation 1.8, the voltage V is the open-circuit voltage which is the same as the Thevenin's voltage source. In reality then, the two equations are one which can be written as

RTh = RN = VTh / IN           (1.9)

If you have any two of these three quantities, you can find the other one. Depending on the circuit it may be easier to find the short-circuit current and the open-circuit voltage. You may want to do this even though you have not been asked to find Norton's equivalent circuit.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

1.5 Current Measurement, the D'Arsonval Meter.

The measurement of current is basic to many electrical measurements. For example the measurement of voltage is accomplished by setting up a circuit of known resistance, placing the unknown voltage across the circuit and measuring the current in the circuit. Other quantities (resistance for example) are converted to current for reading on a meter.

The D'Arsonval Meter Movement.

Figure 1.17 Diagram of a D'Arsonval Meter Movement.

For a verbal description click here.

A D'Arsonval meter movement consists of 4 basic parts. A permanent magnet, a coil of fine wire which is suspended so it can pivot, a pointer attached to the coil, and a scale for the pointer to point to. Figure 1.17 shows only the magnet and coil with its pivot and support. The circular object with a cutout at one point is the permanent magnet. The field is concentrated in the small circular cutout at the bottom. The red object is the coil of fine wire. The support is shown in green. The coil is supported by taught metal bands which provide spring tension to return the pointer to zero when no current is flowing through the coil. The pointer and scale have been omitted to avoid making the drawing too complicated to draw.

When a current is applied to the coil of wire, the magnetic field created by the current interacts with the field of the permanent magnet which causes a torque to be applied to the coil. The torque is opposed by the springs according to the equation

T = K Theta

where T is the torque, K is the spring constant and Theta is the angle of deflection. An equilibrium will be established at some given angle which is also the deflection of the pointer. If the current in the coil is doubled, the torque will be doubled and the angle of deflection will have to be doubled to establish a new equilibrium. The angle of deflection of the moving part of the meter is directly proportional to the current in the coil. A linear scale may be marked off and used to read current without any conversion graph.

Measuring Current.

The schematic symbol for a meter is a circle with one or more letters inside to indicate the quantity which the meter can measure. Occasionally the letter G for galvanometer or M for meter is used. A D'Arsonval meter measures the current which flows through its own coil. Thus, if we want to measure a current, we must allow that current to flow through the meter. Let us look at the circuit of a flashlight which was used in chapter 0 and is shown in Figure 1.18a. If we want to measure the current in this circuit we open the circuit and insert the meter as shown in Figure 1.18b. Because this is a simple series circuit, it makes no difference where the meter is inserted.

Figure 1.18 (a) Flashlight, (b) With Current Meter Inserted

For a verbal description click here.

If we desired to set up the circuit of Figure 1.2 to measure the currents we would have to be careful where the meters were inserted. If we want accurate measurements of I1 and I2 the meters must be inserted in places where only these currents are flowing. That is to say the branch containing R2 must not have one of the meters in it. A meter connected here would measure the algebraic sum of I1 and I2. Figure 1.19 shows how to connect the meters to measure I1 and I2. Since we do not know the directions of the currents the polarity of the meters will have to be determined experimentally. In other words if the pointer goes backward, reverse the connections to the meter.

Figure 1.19 Figure 1.2 With Current Meters Inserted.

For a verbal description click here.

Because current meters are connected in series with the circuits they are measuring, any voltage drop across the meter is lost to the circuit. The voltage drop across the meter must be kept small or inserting the meter will seriously disturb the circuit under test. By Ohm's law, to keep the voltage drop small, the resistance must be small. The typical resistance of a meter will cause a voltage drop of 100 mV (millivolts) when the meter is indicating full scale. That means that a typical meter which reads 1 ampere full-scale will have a resistance of R = 0.1 v / 1 A = 0.1 ohms.

An all-too-common student mistake is to connect an ammeter in parallel with a low resistance Thevenin source. If the above meter were to be connected across a 12 volt battery, how much current would flow through the meter?

I = 12 v / 0.1 ohms = 120 Amps.

A current of 120 amperes will virtually and instantly destroy a meter designed to read 1 ampere full-scale. When in the laboratory (or anywhere else for that matter), don't connect an ammeter or milliammeter across a power supply or battery.

Extending the Range of the Meter Movement.

Meter movements are most often sold in two common forms. One requires 50 uA (microamps) for full-scale deflection and the other requires 1 mA for full-scale deflection. These are sometimes referred to as 0-50 uA and 0-1 mA but most often are called 50 uA and 1 mA meters. Meters which come from the manufacturer with different full-scale currents are most likely one of the aforementioned types with one or two resistors added to extend the range to a higher current.

The process of adding a resistor to extend or increase the range of a meter is known as shunting the meter. The resistor which is added is called a shunt resistor. A meter with a shunt resistor connected is shown in Figure 1.20. The logical reasoning for determining the value of the shunt resistor is as follows.

Figure 1.20 Meter With Shunt Resistor Connected.

For a verbal description click here.

  1. The desired full-scale current I, the meter's full-scale current IM and the meter's resistance RM will be given.

  2. The voltage across the meter may be calculated by VM = IM RM (by Ohm's law).

  3. The voltage across the shunt resistor is the same as the meter voltage (by Kirchhoff's voltage law).

  4. The current in the shunt resistor is IS = I - IM (by Kirchhoff's current law).

  5. The value of the shunt resistor is RS = VM / IS (by Ohm's law).
For those who prefer them, the equation for this is

RS = IM / (I - IM)           (1.10)

Example 1.8.

A meter movement has a full-scale current of 50 uA and a resistance of 1800 ohms . Calculate the value of the shunt resistor to extend the range of the meter to 200 uA.

Solution:

The voltage drop across the meter is

VM = 50 uA x 1800 ohms = 90 mv

The voltage across the shunt resistor is also 90 mv. The current through the shunt resistor is

IS = 200 uA - 50 uA = 150 uA

The resistance of the shunt resistor is

RS = 90 mv / 150 uA = 600 ohms.

The Two Resistor Current Shunt.

The resistors which are used in meter circuits must be precise if the meter is to give precise readings. Precision resistors are often difficult for a person working in a physics lab to find. If a second resistor is added to the circuit as shown in Figure 1.21 the value of the shunt resistor may take on a higher value than the one indicated for the single resistor circuit.

Figure 1.21 Meter With Two Resistor Shunting Circuit.

For a verbal description click here.

The steps for using this circuit are as follows.

  1. Use the procedure (or equation 1.10) given above to determine the minimum value for the shunt resistor.

  2. Locate a resistor close to, but above, the calculated value.

  3. Calculate the voltage drop across this new shunt resistor by the equation VS = IS RS. The value of IS has not changed.

  4. Calculate the total resistance of the meter branch by RMT = VS / IM.

  5. Calculate the resistance of R1 by R1 = RMT - RM.
The equation is as follows.

R1 = RS (I - IM) - IM RM / IM           (1.11)

Example 1.9.

After working out the answer to example 1.8, you go to the stockroom and locate a 750 ohm precision resistor. Calculate the value of R1 in Figure 1.21 to permit the 750 ohm resistor to be used as the shunt.

Solution:

The voltage drop across RS is

VS = 150 uA x 750 ohms = 112.50 mv

The total resistance of the meter branch is

RMT = 112.50 mv / 50 uA = 2250.0 ohms

The value of R1 is given by

R1 = 2250 ohms - 1800 ohms = 450 ohms.

What happens if you cannot find a 450 ohm resistor? To be perfectly frank, the values used in this example are in a range of resistance in which precision resistors are easy to find. A precision resistance bridge may be used to select resistors from a stock of less precise resistors. Statistically, if you look through a large stock of 470 ohms 10% resistors you will find a 450 ohm resistor. It might have been just as easy to find a 600 ohms resistor. A better example is required.

Example 1.10.

A meter with a current of 1 mA has a resistance of 88 ohms . This meter is to be shunted to allow it to have a range of 0 to 1 ampere. The following precision shunts are available in the lab: 0.01 ohms , 0.1 ohms , 0.5 ohms and 1.0 ohms . How should the meter be shunted?

Solution:

Precision shunt resistors in values less than an ohm are difficult to find. We are restricted to what is available. First, assume the circuit of Figure 1.20 and use equation 1.10 to determine the minimum value for the shunt resistor.

RS = 1 mA x 88 ohms / (1 A - 1 mA) = 0.088088 ohms.

Among the available shunt resistors the 0.1 ohm is the next highest one from 0.088088 ohms. Use the 0.1 ohm shunt in the circuit of Figure 1.21. The value of R1 as given by equation 1.11 is as follows.

R1 = 0.1 ohm (1 A - 1 mA) - 1 mA x 88 ohms / 1 mA = 11.90 ohms.

An 11.9 ohm resistor can easily be found in a bin of 12 ohm resistors.

Ammeter Perturbation of a Circuit.

Figure 1.22 shows an ammeter being used to measure the current being drawn by some sort of load which is indicated as a resistor. When the ammeter is added into the circuit, its resistance adds to the resistance which is already there. If the resistance is changed, the current is changed, which means that the current we measure is not the same as the current was before the ammeter was put into the circuit. Is it possible to figure out what the current was before the ammeter was inserted? Let us list what we know and see what we can figure out.

Figure 1.22 Ammeter Connected to Measure
the Current Drawn by a Load

For a verbal description click here.

  1. We know the resistance of the ammeter, (RAM).

  2. We know the power supply or battery voltage, (E).

  3. We know the current, (I), being drawn by the series combination of the ammeter and the load. The ammeter is telling us that.

Using these knowns, what can we figure out?

  1. The voltage drop (VAM) across the ammeter. Multiply the ammeter reading (I) by the ammeter resistance (RAM).

  2. The voltage dropped across the load (VL). Subtract the ammeter voltage drop (VAM) from the power supply voltage (E).

  3. Load resistance (RL). Divide the voltage drop across the load (VL) by the ammeter reading (I).

  4. And finally the load current before the ammeter was inserted (IL). Divide the power supply voltage (E) by the load resistance (RL).

For those who prefer an equation, it is

IL = E / (E - I x RAM)           (1.12)

It is true that some loads are nonlinear, which means that the load resistance changes as the load voltage changes. (The load does not obey Ohm's law.) In most cases this second-order perturbation is small enough to be neglected.

Logical Check.

Remember that the insertion of an ammeter or milliammeter into a circuit will always reduce the current. The calculated load current IL must always be larger than the measured current I. If your calculated current is less than the measured current, the answer is wrong.

Example 1.11.

The 200 uA meter of example 1.8 is being used to measure the current in a load as in Figure 1.22. The power supply voltage is 5.00 volts and the meter is indicating 195 uA. What was the current in the circuit before the microammeter was inserted?

Solution:

First of all we need to calculate the resistance of the ammeter. It is the parallel combination of the 600 ohm shunt and the 1800 ohms of the meter movement. This works out to 450 ohms. The voltage drop across the microammeter is 195 uA x 450 ohms = 87.750 mv. The voltage left across the load is 5.0000 v - 87.75 mv = 4.91225 v. The resistance of the load is 4.91225 v / 195 uA = 25191 ohms. If this load were placed across 5.0000 v the current would be 5.0000 v / 25191 ohms = 198.5 uA.

Example 1.12

Calculate the percent error of the measurement in the above example.

Solution:

The calculated value of 198.5 uA is the standard of comparison or reference. The percent error is given by

% error = 100% x (Measured - Reference) / Reference           (1.13)

% error = 100% x (195 uA - 189.5 uA) / 198.5 uA = -1.76%

If we substitute equation 1.12 into equation 1.13 using I as the measured value and equation 1.12 as the reference value we eventually obtain

% error = 100% x (-I) x RAM / E           (1.14)

where I is the current measured by the meter, RAM is the resistance of the ammeter (milliammeter or microammeter) and E is the voltage of the power supply or battery. Another equation can be obtained by inverting ohms law.

I/E = 1/(RAM + RL)

which is

% error = 100% x (-RAM) / (RAM + RL)           (1.15)

if RL is known, this equation can be most useful.

Example 1.13

It is desired to measure the current to an accuracy of Plus or minus 2%. The meter has a full-scale range of 20 mA and has a voltage drop of 200 mv when reading full scale. The power supply voltage is 9.00 v and the meter reads 16.5 mA. Is this reading within plus or minus 2%?

Solution:

The meter resistance is 200 mv / 20 mA = 10 ohms. RL + RAM = 9.00 v / 16.5 mA = 545 ohms. RL = 545 ohms - 10 ohms = 535 ohms. Using equation 1.15 we have

% error = 100% x (-10 ohms) / (10 ohms + 535 ohms) = -1.83%

The measurement is of acceptable accuracy.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

1.6 Voltage Measurement.

Connecting a Voltmeter Into a Circuit.

Voltage is the electrical potential difference between two points in a circuit. If it is desired to measure the potential difference between point A and point B in a circuit, the meter must be connected between points A and B. That is one lead to point A and the other lead to point B. To measure the voltage of a battery, the voltmeter is simply connected in parallel with the battery. A voltmeter is never connected in series with a circuit. Ammeters are connected in series, voltmeters are connected in parallel.

The Voltmeter Circuit.

The D'Arsonval meter is a current measuring device. As example calculations have shown its voltage drop is typically 0.1 volts. Still, it is possible to use such a meter to measure voltages over a wide range.

What is required is a circuit in which a current will flow which is proportional to the unknown voltage. The D'Arsonval meter can be used to measure the current in this circuit. Ohm's law states that I = E / R. A resistor is all that is required to cause a current to flow which is proportional to the voltage. A voltmeter circuit is shown in Figure 1.

Figure 1.23 Circuit Diagram of a Voltmeter.

For a verbal description click here.

The total resistance in the circuit is such that the full-scale current of the meter will flow when the desired full-scale voltage is applied to the circuit. The total resistance is RV + RM; therefore, an equation may be written

RV + RM = VV / IM           (1.16)

where VV is the full-scale voltage of the voltmeter, IM is the full-scale current of the meter movement, RM is the resistance of the meter movement and RV is the resistance of the multiplier resistor. The multiplier resistance is given by the following equation.

RV = VV / IM - RM           (1.17)

Example 1.14.

Find the value of the multiplier resistor to convert a 50 uA meter into a voltmeter having a full-scale voltage of 5 volts. The resistance of the meter movement is 1800 ohms.

Solution:

The total resistance of the meter circuit is

RT = 5.00 v / 50.0 uA = 100 k ohms.

The multiplier resistor is

RV = RT - RM = 100 k ohms - 1.8 k ohms = 98.2 k ohms.

Ohms Per Volt.

Figure 1.24 is the diagram of the voltmeter of example 1.14 with an addition. It is desired to temporarily convert the 5 volt meter of example 1.14 into a 6 volt meter. As you can see in figure 1.24, this will be accomplished by adding another resistor to the circuit.

Example 1.15.

Calculate the value of RV in Figure 1.24.

Solution:

The total resistance RT = 6 v / 50 uA = 120 k ohms. But we already have 100 k ohms of resistance in the circuit. So we have RT = RV + 1.8 k ohms + 98.2 k ohms. Therefore, RV = 120 k ohms -100 k ohms = 20 k ohms.

Figure 1.24 5 volt meter with a resistor added to convert it to a 6 volt meter.

For a verbal description click here.

Example 1.16.

Calculate RV to extend the range of a 5 volt meter to 10 volts full-scale.

Solution:

The total resistance RT = 10 v / 50 uA = 200 k ohms. So we have RT = RV + 1.8 k ohms + 98.2 k ohms. Therefore, RV = 200 k ohms - 100 k ohms = 100 k ohms.

Notice in examples 1.15 and 1.16 that for every volt of range extension, we must add 20,000 ohms. In example 1.15 we added 1 volt of range and to do so we added 20,000 ohms. In example 1.16 we added 5 volts of range and to do so we added 5 x 20,000 ohms or 100 kilohms.

The number 20,000 is not standard for all voltmeters but is dependent on the current of the meter movement being used. The amount of resistance to be added for each additional volt of range is given by

RAdded = 1 v / IM

This is called the sensitivity of a voltmeter and is given as

S = 1 v / IM           (1.18)

The sensitivity of a voltmeter is a figure of merit which may be used to judge the relative quality of various voltmeters. The higher the number, the better the voltmeter.

Example 1.17.

Calculate the sensitivity of a voltmeter which used a 500 uA meter movement.

Solution:

The sensitivity is

S = 1 v / 500 uA = 2,000 ohms/volt.

Voltmeter Perturbation of a Circuit.

Figure 1.25 shows a voltmeter being used to measure the output voltage of a Thevenin's circuit (voltage source and resistor). If the voltmeter resistance is too low in comparison to the Thevenin resistance, the voltmeter will perturb the circuit by a significant amount and the reading will be in error.

It is possible to determine the voltage of the Thevenin generator (voltage source) if we can determine the value of the Thevenin resistance. This can be done in many cases. Let us now list the things we know and see what we can figure out.

  1. We know the resistance of the voltmeter (RVM).

  2. We know the voltage drop across the voltmeter (VVM). The voltmeter itself is telling us that.

  3. We know the Thevenin resistance (RTh) of the circuit whose voltage we are trying to measure.

Figure 1.25 Voltmeter Measuring Output of Thevenin's Equivalent Circuit.

For a verbal description click here.

The microammeter and its series resistor are included in the circle with a V in the center.

We can now calculate the following.

  1. The voltmeter current (IVM). Divide the voltmeter reading (VVM) by the voltmeter resistance (RVM).

  2. The current flowing through the Thevenin resistance. It is the same as the current through the voltmeter.

  3. The voltage drop across the Thevenin resistance (VRTh). Multiply the current from 2 above (IVM) by the Thevenin resistance (RTh).

  4. And finally, the voltage before the voltmeter was connected (VTh). Add the voltage drop across the Thevenin resistance (VRTh) to the voltmeter reading (VVM).

For those who prefer an equation, it is

VTh = VVM (RVM + RTh) / RVM           (1.19)

Logical Check.

Remember that the connection of a voltmeter to a circuit will always reduce the voltage. The calculated voltage VTh must always be larger than the measured voltage VVM. If your calculated voltage is less than the measured voltage, the answer is wrong.

Example 1.18.

A meter with a full-scale voltage of 10 volts and a sensitivity of 10,000 ohms /v is being used to measure the voltage of a Thevenin's equivalent circuit as shown in Figure 1.25. The Thevenin's resistance is 10 k ohms . The meter reads 9.25 volts. What is the voltage of the Thevenin's voltage source?

Solution:

The resistance of the voltmeter is RVM = 10 v x 10 k ohms/v= 100 k ohms. The current in the voltmeter is IVM = 9.25 v / 100 k ohms = 92.5 uA. The drop across the Thevenin's resistor is VRTh = 92.5 uA x 10 k ohms = 0.925 v. The Thevenin's voltage source is 9.25 v + 0.925 v = 10.175 v.

Example 1.19.

Calculate the percent error of the measurement in the above example.

Solution:

The calculated value of 10.175 v is the standard of comparison or reference. The percent error is given by equation 1.13 as follows.

% error = 100% x (9.25 v - 10.175 v) / 10.175 v = -9.09%.

If we substitute equation 1.19 into equation 1.13 using VVM as the measured value and equation 1.19 as the reference value we eventually obtain

% error = 100% x (-RTh) / (RTh + RVM)           (1.20)

where RTh is the Thevenin's resistance of the circuit being tested and RVM is the resistance of the voltmeter.

Example 1.20.

Use equation 1.20 to verify the results of example 1.19.

Solution:

Using equation 1.20 gives

% error = 100% x (-10 k ohms) / (10 k ohms + 100 k ohms) = -9.09%.

The result is verified as correct.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

1.7 Measurement Using Multimeters.

A multimeter (pronounced multi-meter) is an instrument which is capable of measuring more than one electrical quantity. The usual multimeter is capable of measuring voltage, current and resistance. Such meters are also known as volt-ohm-milliammeters or VOMs for short.

The analog multimeter (or VOM) is exemplified by the Simpson 260 which is used in the laboratory. This instrument consists of a D'Arsonval meter movement, two switches, several resistors and two diodes.

The VOM has full-scale voltage ranges from 2.5 volts to 1000 volts. The voltmeter circuit is exactly like the one studied in this chapter. To determine the input resistance of the voltmeter on any range, multiply the sensitivity by the setting of the range switch. The voltage being indicated does not affect the input resistance. The sensitivity of the Simpson VOM is 20,000 ohms per volt on DC and 5,000 ohms per volt on AC. The two diodes are used to change the AC to DC because the D'Arsonval meter will only respond to direct current.

The ammeter portion of the VOM has current ranges from 50 microamperes to 10 amperes and works only on DC. It employs a rather complex shunting arrangement which prevents the resistance of the switch contacts from affecting the accuracy of the reading. It is felt that the student would profit little from a detailed study of this shunting circuit.

The resistance or ohmmeter section of the VOM employs a battery to energize the circuit. The battery applies a known voltage to the unknown resistor and the meter measures the current which flows. The meter face incorporates a scale for reading resistance so that no calculation is necessary. Because I = V / R the scale is highly compressed at high resistance values.

The Electronic Multimeter.

Electronic multimeters most often have a digital readout instead of a D'Arsonval meter movement. The digital readout gives better accuracy than an analog meter. If the voltage being measured has some noise on it, its value is varying slightly in a random manner, a digital meter may give confused and jumpy readings.

The thing which all electronic multimeters have in common is a complex electronic circuit which will convert a voltage into an indication on the readout device. This circuit will be studied later in this book but for now it will be treated as a mysterious black box.

The basic measurement circuit of a digital multimeter is a voltmeter which will measure from 0 to 200 millivolts. The readout is from 000.0 mv to 199.9 mv. This is called a 3 and 1/2 digit readout. The most significant digit can only be 0 or 1 and this is called a 1/2 digit. The DMMs (digital multimeters) we are using in our lab are 4-1/2 digit models which means that the basic range is from 000.00 mv to 199.99 mv. To save time and space this basic range will be referred to as a 0 to 200 mv range.

The voltmeter section of a DMM uses a voltage divider similar to that of Figure 1.4. The resistance values are R1 = 9 Meg ohms, R2 = 900 k ohms, R3 = 90 k ohms, R4 = 9 k ohms, and R5 = 1 k ohms. The input resistance of the basic measuring circuit must be very high, in excess of 10 G ohms . The unknown voltage is connected to the VIN terminals in Figure 1.4 and the measuring circuit is connected between common and one of the connection points. The voltage range selector switch is what connects the measuring circuit to the selected tap on the voltage divider. Some DMMs are auto-ranging, which means that a small microprocessor will select the proper range for the voltage which is being applied to the meter. The voltage ranges work on AC or DC. The input resistance is always 10 Meg ohms on any range on AC or DC.

For current measurements the basic measuring circuit is connected in parallel with a low-value shunt resistor. For example, if a 1 ohm resistor is used as the shunt, a current of 200 mA will cause a voltage drop of 200 mv; thus a 1 ohms shunt will provide a current range of 0 to 200 mA. To change current ranges a new shunt resistor is switched in. The current ranges work on AC or DC.

The resistance measurement circuit consists of a constant current source and the basic measuring circuit. A known current is made to flow through the unknown resistor and the resultant voltage drop is measured by the measuring circuit. For example, if a current of 100 uA flows through a 2 k ohm resistor the voltage is 200 mv; thus a current of 100 uA will give a resistance range of 0 to 2 k ohms . To change ranges the magnitude of the current is changed.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

1.8 Problems.

  1. In the circuit of figure 1.1 the values are as follows. E1 = 15 v, E2 = 12 v, R1 = 1 k ohm, R2 = 500 ohms, and R3 = 1.2 k ohms. What are the values of (a) I1, (b) I2, and (c) the voltage drop across R2? (d) Is the battery at E2 being charged or discharged?

  2. In the circuit of Figure 1.3 R1 = 50 ohms, and R2 = 120 ohms. If E = 6.6 v, what is the output voltage?

  3. In the circuit of Figure 1.4 the values are as follows. R1 = 6.8 Meg ohms, R2 = 2.2 Meg ohms, R3 = 680 k ohms, R4 = 220 k ohms, and R5 = 91 k ohms. (a) What is the total resistance of the divider? If 100 volts are applied at VIN what is the output voltage between common and (b) point 1, (c) point 2, (d) point 3, (e) point 4, and (f) point 5?

  4. In the circuit of Figure 1.3 if R2 = 3.3 k ohms, what should the resistance of R1 be for the output voltage to be one third of E?

  5. In the circuit of Figure 1.3 R1 = 5.6 k ohms, and R2 = 3.3 k ohms. What must the input voltage (E) be to give an output voltage of 6.1 volts?

  6. Apply Thevenin's theorem to solve problem 1. What is the voltage across R2?

  7. In the circuit of Figure 1.4 use the values given in the figure. Calculate the Thevenin's resistance if the output is between common and (a) point 1, (b) point 2, (c) point 3, (d) point 4 and (e) point 5.

  8. A signal generator has an open-circuit output voltage of 8.00 volts. When a 1 k ohm resistor is connected across the output terminals, the voltage is 5.00 v. Find Thevenin's equivalent circuit for this generator. Draw the circuit!

  9. Apply Norton's theorem to solve problem 1. What is the voltage across R2?

  10. In the circuit of Figure 1.4 use the values given in the figure. Calculate the Norton's resistance if the output is between common and (a) point 1, (b) point 2, (c) point 3, (d) point 4 and (e) point 5.

  11. A signal generator has an open-circuit output voltage of 8.00 volts. When a 1 k ohm resistor is connected across the output terminals, the voltage is 5.00 v. Find Norton's equivalent circuit for this generator. Draw the circuit!

  12. A D'Arsonval meter movement has a resistance of 1653 ohms and a full-scale current of 100 uA. Calculate the value of a single shunt resistor to make a 1 mA meter. Draw the circuit!

  13. The meter movement from problem 12 is to be used in a two-resistor shunting circuit to make a 1 mA meter. The shunt resistor has the value 219.4 ohms. What is the required value of R1? Draw the circuit!

  14. A milliammeter which has a full-scale current of 10 mA has a voltage drop of 250 mv when it is indicating full scale. When the meter is connected into a circuit where the voltage source is 6.00 v the meter reads 7.75 mA. (a) What was the current in the circuit before the meter was inserted? (b) What is the percent error of the measurement?

  15. A D'Arsonval meter movement has a resistance of 1653 ohms and a full-scale current of 100 uA. Calculate the value of the multiplier resistor to make a 1 v meter. Draw the circuit!

  16. What is the sensitivity of a voltmeter which employs a meter movement having a full-scale current of 25 uA?

    Figure 1.26 Circuit of a 5-range Voltmeter.

    For a verbal description click here.

  17. The circuit of Figure 1.26 is of a 5-range voltmeter. As the range switch is changed from range to range, the arrowhead moves from one circle to another. As the circuit is drawn the meter is set to the 10 volt range. The switch may be set to any range, it just happens to be shown on the 10 volt range. The meter movement has a resistance of 4476 ohms and a full-scale current of 25 uA. Calculate the resistances of (a) R1, (b) R2, (c) R3, (d) R4, and (e) R5, for the voltage ranges shown. Do not jump to conclusions, look carefully at the circuit. It may be helpful to redraw the circuit with the switch set to the voltage range you are currently working on.

  18. A digital voltmeter which has an input resistance of 10 Meg ohms is being used to measure the voltage on a circuit which has a Thevenin's resistance of 470 k ohms. (a) What will be the percent error of the measurement? (b) If the indicated voltage is 8.523 volts, what was the voltage before the meter was connected to the circuit?

  19. A 5,000 ohm-per-volt VOM is being used to make a measurement on a given circuit. The Thevenin's voltage and resistance of the circuit are unknown. When the meter is set to the 2.5 volt range it indicates 2.22 volts and when it is set to the 10 volt range it indicates 3.33 volts. (a) What are the Thevenin's voltage and resistance of the circuit? (b) What was the voltage before the meter was connected? Hint: try two equations in two unknowns. This is a situation that users of VOMs encounter regularly.

  20. A digital multimeter has a basic range of 2 volts (1.999 volts). What is the resistance of a current shunt to provide a range of 0 to 20 uA?

  21. A digital multimeter has a basic range of 2 volts (1.999 volts). When this meter is set to the 200 ohms resistance range, how much current is flowing through the unknown?

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

1.9 Answers to Problems.

  1. (a) I1 = 8.4783 mA, (b) I2 = -4.5652 mA, (c) V = 6.522 v upper end positive, (d) E2 is being discharged.

  2. V = 4.659 v.

  3. (a) R = 9.991 Meg ohms, (b) V = 100 v, (c) V = 31.94 v, (d) V = 9.919 v, (e) V = 3.113 v, (f) V = 0.9108 v.

  4. R1 = 6.6 k ohms.

  5. E = 16.45 v.

  6. VTh = 13.63634 v, RTh = 545.455 ohms, VR2 = 6.522 v.

  7. (a) RTh = 0, (b) = 210 k ohms, (c) = 90 k ohms, (d) = 29.1 k ohms, (e) = 9.9 k ohms.

  8. VTh = 8.00 volts, RTh = 600 ohms, Figure 1.6 with these values.

  9. I1 = 15 mA, I2 = 10 mA. By inspection I1 is clockwise and I2 is counter clockwise. IN = 25 mA downward through the short. RN = 545.455 ohms. VR2 = 6.522 volts.

  10. (a) RN = 0, (b) = 210 k ohms, (c) = 90 k ohms, (d) = 29.1 k ohms, (e) = 9.9 k ohms.

  11. IN = 13.33 mA, RN = 600 ohms, Figure 1.13 with these values.

  12. RS = 183.7 ohms. Figure 1.20.

  13. R1 = 321.6 ohms. Figure 1.21.

  14. I = 8.009 mA, % error = -3.23%.

  15. RV = 8,347 ohms. Figure 1.23.

  16. S = 40,000 ohms / volt.

  17. (a) R1 = 35,524 ohms, (b) R2 = 60,000 ohms, (c) R3 = 300,000 ohms, (d) R4 = 1,600,000 ohms, (e) R5 = 8,000,000 ohms.

  18. (a) % error = 4.49%, (b) V = 8.924 volts.

  19. (a) VTh = 3.996 volts, RTh = 10 k ohms. (b) V = 3.996 volts.

  20. R = 100 k ohms.

  21. I = 10 mA.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

This page copyright © Max Robinson. All rights reserved.


Chapter 2   AC Circuits.

2.1  Alternating Current.
2.2  Capacitive Reactance.
2.3  Inductive Reactance.
2.4  Series Circuits and Impedance.
2.5  RC Filter Circuits.
2.6  The Decibel (dB).
2.7  Graphing Frequency Response.
2.8  Nonsinusoidal Waves.
2.9  The Effect of RC Circuits on Nonsinusoidal Waves.
2.10 R-LC Resonate Circuits.
2.11 Transformers.
2.12 The Oscilloscope.
2.13 Problems.
2.14 Answers to Problems.

Chapter 2.

AC Circuits.

To date, we have dealt with sources of electrical energy which deliver direct current. DC flows continuously in one direction. The electrical world in which we live is one of alternating current (AC). The current supplied by the electric utility, audio signals, radio and television signals are all AC.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

2.1 Alternating Current.

Alternating current reverses its direction on a regular time schedule. The current flows for a certain period of time, then reverses and flows for the same amount of time and then reverses again. There is no net movement of electrons in a wire carrying AC; the electrons simply vibrate in place.

The Cycle.

A cycle is defined as follows. The current rises from zero to a positive maximum, falls back to zero and "rises" to a negative "maximum" and then returns to zero. This definition of a cycle applies to current or voltage. For a cycle of voltage simply substitute the word "voltage" for "current" in the above definition.

If we plot a number of cycles on a graph (with current on the Y axis and time on the X axis) the plot will resemble the waves on the surface of a body of water. It is not considered correct usage to call a cycle a wave but even people with many years of experience sometimes get careless. It is considered correct usage to use the term waveform when referring to the shape of the graph of a cycle.

Notice that the definition of a cycle says nothing about the shape of the rises and falls. The cycle shape or waveform which is most often encountered is the sine wave. This waveform follows the sine function y = sin(x). Figure 2.1a shows two cycles of a sine wave alternating current. Figure 2.1b shows a square wave, 2.1c a triangular wave and 2.1d a sawtooth wave. There are an infinite number of different waveforms. The shape depends on what is generating them and what their use will be.

Figure 2.1 Four Different Waveforms.

For a verbal description click here.

Period and Frequency.

The period of an alternating current is the time required to complete one cycle. The frequency of an alternating current is the number of cycles which occur each second. The period is measured in units of time such as seconds, milliseconds or microseconds. The frequency has units of cycles/second or 1/time (a cycle is not a true unit, it is considered to be dimensionless.) The unit of frequency is called the hertz. Frequency may be given in hertz, kilohertz, megahertz or gigahertz.

The relationship between period and frequency is

P = 1 / f           (2.1)

where P is the period in seconds and f is the frequency in hertz.

Example 2.1.

What is the period of the 60 hertz line frequency?

Solution:

P = 1/f = 1/60 = 1.67 x 10-2 seconds or 16.7 ms.

Wavelength and Frequency.

The only time that the term "wave" may be applied to an alternating current is when the current has been converted into a periodic disturbance which propagates through some medium. For example a loudspeaker converts AC of appropriate frequency into sound waves which propagate through the air. For another example, if AC of an appropriate frequency flows in a structure known as an antenna, electromagnetic waves will be radiated which will propagate through air, or the vacuum of space.

When waves propagate through a physical medium, the wave has a physical length. The wavelength is given by

lambda = v / f           (2.2)

where lambda is the wavelength in meters, v is the velocity of propagation in meters per second and f is the frequency in hertz. The speed of sound in air is approximately 335 meters per second and the speed of electromagnetic waves is 3 x 108 meters per second.

Example 2.2.

A sound wave in air has a wavelength of 12 cm. What is its frequency?

Solution:

Using the speed of sound we have that

f = 335 / 0.12 = 2790 Hz.

Example 2.3.

A radio station is transmitting on a frequency of 88.9 MHz (megahertz). What is the wavelength of the electro- magnetic wave being transmitted?

Solution:

Using the speed of light we have

lambda = 3 x 108 / 88.9 x 106 = 3.37 m

Angular Frequency.

When working through calculations involving AC it is often necessary for the frequency to appear in the argument of a sine or cosine function. A particular point on a waveform can be found by multiplying the frequency by the amount of time which has passed since the waveform has started. This would be all right if cycles were the only thing we had to deal with. The arguments of sines and cosines must be in angles, not in cycles.

One cycle consists of 360 degrees or 2 pi radians. The symbol for the angular frequency is usually a small omega but we will use a "w". The angular frequency is given by

w = 2 pi f           (2.3)

where w is the angular frequency in radians per second and f is the frequency in hertz (cycles per second). A current can be expressed by the equation

i = I sin( 2 pi f t )           (2.4)

where i is the current at any instant of time, I is the peak current, f is the frequency of the current in hertz and t is time in seconds. If f = 1 hertz then during the passage of one second the argument of the sine function will run through 2 pi radians and the sine function will execute one cycle in accordance with the definition of a cycle given above.

Magnitude Measurement of AC.

An alternating current may be represented by equation 2.4. The peak value of the current is "I" and the peak-to- peak value is 2I. The peak and peak-to-peak values are the most obvious and easiest to measure, which is probably why they are not the most often used.

The most useful measure of AC is a value which gives the same power dissipation in a resistor as a direct current. Suppose that a DC current of 3 amperes is flowing through a 1 ohm resistor. The power will be 9 watts. If an AC current of 3 amperes peak flows through a 1 ohm resistor, the power is not the same as for the DC. We require a measure which will give the same power as a DC of the same magnitude.

Because we are discussing power, that is the key. Remember that power is given by

P = I2 R           (2.5)

When a resistor is being heated, the average power is what is affecting the heating. To find the measure of current we must square the current, average it over time and then take the square root. The last step is necessary so that the new measure will be proportional to the peak current, not to the square of the current. The new measure of current is called the root-mean-square which is abbreviated RMS.

The RMS value of a current is given by

I RMS = square root of 1 over 2 pi times the integral from 0 to 2 pi of I squared of t, d t.

Substituting equation 2.4 into equation 2.6 we have

I RMS = square root of 1 over 2 pi times the integral from 0 to 2 pi of I squared sine squared of t, d t.

We don't know how to integrate the sine squared function but there is a way to change it to something we can integrate. We must make the trigonometric substitution

Sin2(t) = 1/2 ( 1 - cos( 2t ))

Making this substitution and bringing I2 and 1/4 outside of the radical gives

I RMS = I over 2 times the square root of 1 over pi times the integral from 0 to 2 pi of 1 minus cosine of 2t.

The integral of the cosine over an integer number of cycles is zero; therefore,

I RMS = I over 2 times the square root of 1 over pi times the quantity 2 pi minus 0.

The end result of all of this is

I RMS = I over the square root of 2. Equation 2.7.

This is another one of those things you must remember. Conversions between RMS and peak, RMS and peak-to-peak, and peak and peak-to-peak are routine in electronics. The conversion applies to voltage as well as current.

Example 2.4.

Convert a peak current of 3 amperes to RMS.

Solution:

IRMS = I / square root of 2 = 3 / 1.4142 = 2.12 A

Example 2.5.

Convert 6.3 v RMS to peak.

Solution:

VP = VRMS x square root of 2 = 6.3 x 1.4142 = 8.91 v

The use of the RMS measure is so common in AC measurement that all quantities are RMS unless otherwise specified. If a specification gives a voltage as 117 vAC the meaning is 117 volts alternating current RMS (root-mean- square). The rule is: a voltage or current is RMS unless otherwise noted.

Logical Check.

The RMS value is always less than the peak value. RMS is a kind of average and an average will ALWAYS be less than the maximum. Similarly, the peak to peak value is greater than the peak value.

The Average.

One more AC measurement is worth mentioning. It is the average value. If an AC flows through a D'Arsonval meter movement the pointer will first be urged in one direction and then in the other. Most AC is of such a frequency that the meter's pointer cannot respond to either urging and the pointer does not move. If a rectifier is used to take the absolute value of the sine function, the meter will be able to respond to the unidirectional current in spite of the fact that it is changing with time. The meter will respond to, and indicate, the average value of the sine wave current.

If we averaged the sine function over one full cycle we would get zero. To obtain the average value of the absolute value of the sine it is sufficient to average it over one- half cycle.

I sub eh V = one over pi times the integral from 0 to pi of sine of t, d t.

A few turns of the crank gives

IAV = I x 0.63662           (2.9)

Most AC meters respond to average but are calibrated in terms of RMS. These meters work fine as long as the current or voltage being measured is a sine wave. If the input is not a sine wave the meter will not read the RMS but will read the average value times 0.70711 / 0.63662.

Use and Misuse.

The term AC is often used in ways which seem to be redundant or even contradictory. For example you might read "... the AC current ..." or "... the AC voltage ..." or even "... the AC power ...". Remember that the letters AC stand for alternating current. The first example is redundant, "alternating current current". The next two are contradictory. In spite of the redundant or contradictory nature of these terms they are used by most electrical and electronics engineers and technicians. The usage is too pervasive to be avoided even in formal writing. The writer will not make a rigorous attempt to exclude these terms from this book.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

2.2 Capacitive Reactance.

Early researchers in electricity may have been surprised to find that AC would flow through a capacitor. After all, a capacitor is an open circuit, isn't it? Experiments on capacitors show that as more AC voltage is applied more current will flow. If the frequency is increased without changing the voltage the current will increase. It can also be shown experimentally that the current in a capacitor leads the voltage by 90 degrees or 1/4 of a cycle. The way in which a capacitor reacts to AC is called the capacitive reactance.

Let us apply a voltage to a capacitor and see what happens. The voltage is v = V sin( 2 pi f t ). We will use equation 0.41 which is restated here as equation 2.10.

i = C dv / dt           (2.10)

If we insert our definition of voltage into equation 2.10 we have

i = CV d / dt sin ( 2 pi f t )

Performing the differentiation gives.

i = C V 2 pi f cos( 2 pi f t )

If we say that the current is i = I cos( 2 pi f t ) we have that

I = C V 2 pi f

solving for V/I gives.

V / I = 1 / ( 2 pi f C )

If you are awake you will recognize V / I as having the units of ohms. We now have a new quantity which in some ways is like resistance but in other ways is unlike resistance. We call this quantity the capacitive reactance and give it the symbol XC.

XC = 1 / ( 2 pi f C )           (2.11)

where XC is the capacitive reactance in ohms, f is the frequency in hertz and C is the capacitance in farads.

We applied a sine wave voltage and a cosine wave current resulted. The cosine leads the sine by 90 degrees and so the current in a capacitor leads the voltage by 90 degrees.

Example 2.6.

At what frequency will a .0039 uf capacitor have a reactance of 33 k ohms?

Solution:

Solving equation 2.11 for f gives

F = 1 / ( 2 pi XC C)

f = 1 / ( 2 pi x 3.3 x 104 ohms x 3.9 x 10-9 f ) =
1.24 x 103 Hz.

Example 2.7.

If a 0.1 uf capacitor is connected across the 120 vAC 60 Hz power line, how much current will flow?

Solution:

The reactance of a 0.1 uf capacitor at a frequency of 60 Hz is XC = 1 / ( 2 pi f C )

XC = 1 / ( 2 pi x 60 Hz x 1 x 10-7 f ) = 2.653 x 104 ohms.

I = E / XC = 120 v / 2.653 x 104 ohms = 4.52 x 10-3 A.

Power.

When an AC voltage is applied to a resistor, the current is in phase with the voltage. The instantaneous power is

p = (V sin( 2 pi f t ) ) x (I sin( 2 pi f t )

which is equal to

P = V x I x sin2( 2 pi f t ).

By trigonometric substitution the sine squared function becomes a double frequency negative cosine function.

P = V x I x 1/2 (1 - cos( 2 pi 2 f t )).

This function is entirely positive. When AC is applied to a resistor the power is "real". All energy flows from the generator into the load.

When an AC voltage is applied to a capacitor, the current leads the voltage by 90 degrees. The instantaneous power is

p = (V sin( 2 pi f t ) ) x (I cos( 2 pi f t ).

Making the substitution for sine times cosine gives.

P = V x I x sin( 2 pi 2 f t )

The sine times the cosine is a double frequency sine which has equal parts above and below the horizontal axis. This means that power is taken from the circuit for half of the time and given back for the other half of the time. The net value of power averaged over time is zero.

Here we have an incongruous situation. There is a voltage applied to a circuit element (capacitor) and there is a current flowing but the power is zero! This can be verified experimentally. It must have been "mind blowing" for the first person (probably a graduate student) who observed it.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

2.3 Inductive Reactance.

Early researchers in electricity must have been surprised to find that a coil of wire presented more "resistance" to the flow of alternating current than did the identical length of wire which was not wound into a coil. Experiments on inductors show that as more AC voltage is applied more current will flow. If the frequency is increased without changing the voltage the current will decrease. It can also be shown experimentally that the current in an inductor lags the voltage by 90 degrees or 1/4 of a cycle. The way in which an inductor reacts to AC is called the inductive reactance.

Let us apply a current to an inductor and see what happens. The current is i = I sin( 2 pi ft ). We will use equation 0.55 which is restated here as equation 2.12.

e = L di / dt           (2.12)

If we insert our definition of current into equation 2.12 we have

e = L V d/dt sin(2 pi f t )

Taking the derivative gives.

e = L V 2 pi f cos( 2 pi ft )

If we say that the voltage is e = E cos( 2 pi ft ) we have that

E = L I 2 pi f

solving for E gives

E / I = 2 pi f L

If you are awake you will recognize E / I as having the units of ohms. We now have a new quantity which in some ways is like resistance but in other ways is unlike resistance. We call this quantity the inductive reactance and give it the symbol XL.

XL = 2 pi f L           (2.13)

where XL is the inductive reactance in ohms, f is the frequency in hertz and L is the inductance in henrys.

We applied a sine wave current and a cosine wave voltage resulted. The cosine leads the sine by 90 degrees and so the voltage in an inductor leads the current by 90 degrees.

Example 2.8.

What is the value of an inductor which will present a reactance of 47 k ohms at a frequency of 100 kHz?

Solution:

Solving equation 2.13 for L we have

L = XL / ( 2 pi f )

L = 47 k ohms / ( 2 pi 100 kHz ) = 7.48 x 10-2 H or 74.8 mH

Example 2.9.

If a 500 uH inductor is used in a power line filter, how much voltage drop will be introduced at a current of 25 amperes?

Solution:

The power line frequency in the U.S. is 60 Hz. XL = 2 pi f L

XL = 2 pi x 60 Hz x 500 uH = 0.1885 ohms

The voltage drop is I x XL = 25 A x 0.1885 ohms = 4.71 v

The power in a pure inductance is zero by the same argument as for capacitors. It makes no difference that the current is lagging instead of leading. The phase difference is still 90 degrees.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

2.4 Series Circuits and Impedance.

DC circuit analysis contains only resistors and DC sources. Most real circuits operate using AC and employ capacitors and inductors. Because we must be capable of analyzing AC circuits as well as DC circuits we must study some new techniques. In this section we will develop some simple tools for the analysis of series AC circuits.

Series RC Circuits.

Figure 2.2 Series RC Circuit Driven by an AC Generator.

For a verbal description click here.

Figure 2.2 is the diagram of a simple RC circuit which contains an AC generator. The generator can take on any output voltage and any frequency.

Kirchhoff's law tells us that the current everywhere in the circuit will have the same magnitude. An extension of this law to AC circuits is to add phase. The current everywhere in the circuit will have the same phase. The current in the generator, the current in the resistor and the current in the capacitor are all in phase with each other.

The voltage across the resistor will be in-phase with the current through it. Resistors do not play tricks on us; they obey Ohm's law. The voltage and current in a resistor are always in-phase with each other.

The phase relationship between the voltage and current in a capacitor is 90 degrees with the current leading. If the current leads, the voltage follows or lags. In this example we are using the current as a reference so we say the voltage is lagging the current by 90 degrees. This can be represented pictorially as in Figure 2.3.

In Figure 2.3 the voltages and currents are represented by line segments in a plane. These lines have length and direction. Some texts refer to these as vectors. Vectors have magnitude and direction in real space and are (or at least can be) three-dimensional. The lines which represent voltages and currents cannot be three-dimensional; they are strictly two-dimensional. In addition to this, the directions do not represent directions in space, they represent relative phases of voltages and currents in electric circuits. For all of these reasons, the lines are called phasors. It should be noted that this term has been in common use in electrical engineering texts and by electrical engineers for a long time and predates the television show "Star Trek" by several decades.

Figure 2.3 Phase Relationships of Voltages and Currents.

For a verbal description click here.

Figure 2.4a is the diagram of an R-L circuit. The phasor diagram for this circuit is shown in Figure 2.4b. In an inductor the voltage leads the current by 90 degrees and so the voltage phasor is shown pointing upward. As always the voltage and current are in-phase in a resistor.

Schematic and phasor diagrams.

Figure 2.4 (a) R-L Circuit and (b) Its Phasor Diagram.

For a verbal description click here.

Kirchhoff's law tells us that the voltage of the generator in Figure 2.2 is the sum of the voltage across the resistor and the voltage across the capacitor. These voltages are not in phase and they cannot be added simply by adding their magnitudes. Their directions must also be taken into account. Even though we do not call them vectors the techniques of vector addition apply. As vector addition should be well known to any student studying physics, we will not dwell on the addition of vectors (phasors).

The fact that these phasors are at right angles makes life a lot easier for us. The familiar Kirchhoff's equation for voltages looks like this for AC:

V sub G = square root of V sub R squared plus V sub C squared.

where VG is the generator voltage, VR is the voltage across the resistor and VC is the voltage drop across the capacitor.

The phase angle theta of the generator voltage is given by

theta = arctan ( VC / VR )           (2.15)

To obtain the correct sign on the angle you must attach a minus sign to VC and a plus sign to VL.

Schematic and phasor diagrams.

Figure 2.5 R-LC (a Circuit and (b> Its Phasor Diagram.

For a verbal description click here.

If we now combine resistance, capacitance and inductance in the same circuit, as in Figure 2.5a, the phasor diagram of Figure 2.5b will result. Since VL and VC are 180 degrees apart, one will always subtract. The phasor version of Kirchhoff's voltage equation is as follows.

V sub G = square root of all V sub R squared plus quantity V sub L minus V sub C close quantity squared.

The phase angle is given by

Theta = arctan ( ( VL - VC ) / VR           (2.17)

Example 2.10.

In Figure 2.2 the magnitudes of the voltages are as follows. VR = 77.460 v at 0 degrees and VC = 91.652 v at -90 degrees. What are the magnitude and phase of the generator voltage?

Solution:

V sub G = square root of 77.460 squared plus 91.652 squared end square root = 120.0 v

The phase angle is

theta = arctan ( -91.652 v / 77.460 = 49.80 degrees.

Ohm's Law For AC.

When we made the change from DC to AC we did not repeal Ohm's law. Its form is just a little different. For resistors it is unchanged.

VR = I R           (2.18)

For capacitors and inductors it is as follows.

VC = I XC and VL = I XL           (2.19)

For a series combination of RC or R-L we will call the "resistance" something different.

VG = I Z           (2.20)

The quantity Z is called impedance and is the ratio of the generator voltage to the generator current. The impedance like the generator voltage has magnitude and angle. It is a phasor.

We can get equations for the magnitude and angle of the impedance by substituting equations 2.18, 2.19 and 2.20 into equations 2.16 and 2.17. Because the current is the same everywhere in the circuit it will cancel out and leave us with these equations. The magnitude is

Z = square root of R squared plus quantity X sub L minus X sub C close quantity squared

The phase angle is given by

theta = arctan ((XL - XC) / R           (2.22)

Impedance magnitude and phase angle involve reactances which are frequency dependent. An impedance can be calculated only if the frequency is fixed and known. If the frequency is changed, the impedance must be recalculated.

Example 2.11.

In Figure 2.2 R = 1 k ohms, C = 0.1 uf and f = 1 kHz, what is the impedance?

Solution:

First, XC must be determined.

XC = 1 / ( 2 pi 1000 x 0.1 x 10-6 ) = 1592 ohms

The magnitude of the impedance is

Z = square root of quantity open second quantity 1 k ohm close second quantity squared plus open third quantity minus 1592 ohms close third quantity squared close quantity = 1880 ohms

The phase angle is

theta = arctan (-1592 ohms / 1000 ohms) = -57.87 degrees.

The accepted way of writing this is

Z = 1880 ohms / -57.87 degrees

which is spoken as "1880 ohms at an angle of -57.87 degrees".

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

2.5 RC Filter Circuits.

One of the most commonly encountered applications of a series RC circuit is a filter. Filters are used to filter out an unwanted band of frequencies which may coexist with a wanted band of frequencies. An example is the output voltage of a thermocouple which is being used to measure the temperature in a crystal-growing oven. The temperature in the oven will change very slowly and the wanted data are contained on a voltage which is changing very slowly. The frequency content will be from zero frequency (DC) to about 0.1 Hz. An unwanted frequency which is extremely likely to be present is the ubiquitous and omnipresent 60 Hz power line frequency. A filter can be designed which will reduce magnitude of the 60 Hz output to a very low level without appreciably affecting the magnitude of the 0 to 0.1 Hz data signal.

Notice that word which is boldfaced above. A filter never removes an unwanted signal. There is no such thing as "remove". It's the same thing as taking a step equal to half of the distance to the wall. You can get as close to the wall as you want but you never can get there. A filter can be constructed to reduce an unwanted signal to as low an amplitude as desired but you never will be able to construct a filter to get the amplitude to zero.

Figure 2.6 Frequency Response of a Low-pass Filter.

For a verbal description click here.

Figure 2.7 Frequency Response of a High-pass Filter.

For a verbal description click here.

Filters can be divided into two groups, low-pass and high-pass. A low-pass filter will pass low frequencies and attenuate high frequencies. A high-pass filter will pass high frequencies and attenuate low frequencies. The dividing line between high and low is called the cutoff frequency.

The term "cutoff frequency" gives a false impression about how filters work. The notion is that all frequencies on the "pass" side of the cutoff frequencies are passed and all frequencies on the other side of the cutoff frequency are removed. That impression is wrong! The cutoff frequency is defined as that frequency where the output power is down to half of the input power. Figure 2.6 shows how the output of a low-pass filter which has a cutoff frequency of 1000 Hz (1 kHz) varies with frequency. Figure 2.7 shows the frequency response of a high-pass filter which also has a cutoff frequency of 1 kHz.

Do not be concerned if you don't know what a dB is. For now all you need to know is that it is a logarithmic function of VO / VI. The dB will be explained fully in section 2.6.

You will notice in Figures 2.6 and 2.7 that each filter has a portion of its frequency response curve where the output is unchanged as frequency changes. This is called the "flat" portion of the frequency response. The portion where the output is changing with frequency is called the "roll off" part of the curve. The cutoff frequency is that frequency where the output power is down to 1/2 of the power in the flat part of the curve. That does not conflict with the statement above because (in most cases) in the flat part of the curve the output power is equal to the input power.

Using the equation P = V2 / R it can be shown that when the power is reduced by 1/2 the voltage is reduced by 0.7071 which is 1 over the square root of 2. At the frequency where XC = R the output voltage is 0.7071 of the input voltage. This will be illustrated in an example. Thus the cutoff frequency is where XC = R.

Separating AC and DC.

As you will learn in later chapters, signals in electronics are often mixtures of AC and DC. In many cases it is desired to remove one or the other. A signal may have the form

v = VDC + VP sin( 2 pi f t )           (2.23)

where VDC is the DC part of the signal, VP is the peak value of the AC part of the signal and f is the frequency of the AC part of the signal. Figure 2.8a shows an equivalent circuit of a DC + AC generator. Figure 2.8b is a graph of the output voltage versus time.

Figure 2.8 DC + AC Generator (a) and Its Output (b).

For a verbal description click here.

Figure 2.9 Low-pass Filter with Its Input and Output.

For a verbal description Click here.

Suppose we pass this DC + AC signal through a low-pass filter as in Figure 2.9. The frequency of the AC is much higher than the cutoff frequency of the filter. That is equivalent to saying that XC is much less than R at the frequency of the AC generator. Most of the AC will be shorted out by the capacitor but the DC will be unaffected. Consequently the AC will be attenuated while the DC will not.

Figure 2.10 High-pass Filter With Its Input and Output.

For a verbal description click here.

Now let us pass this DC + AC signal through a high-pass filter as in Figure 2.10. The frequency of the AC is much higher than the cutoff frequency of the filter. That is equivalent to saying that XC is much less than R at the frequency of the AC generator. The AC will be affected very slightly by the filter but the DC will be totally removed. Consequently the DC will be attenuated while the AC will not. Because DC is zero frequency, absolutes do apply. The magnitude of the DC will be reduced to zero.

Attenuation of Unwanted AC Signals.

It is easy to calculate the amount of attenuation a filter will introduce at any frequency. The procedure is quite similar to that used to solve a voltage divider in DC circuits.

  1. Calculate the capacitive reactance XC and then the circuit impedance Z.

  2. Calculate the circuit current using the known or an assumed input voltage and the total circuit impedance Z.

  3. Multiply the current by the resistance or the reactance of the element across which the output is taken.

  4. Determine the attenuation ratio by dividing the calculated output voltage by the known or assumed input voltage.

For those who would prefer equations they are.

For a low pass filter.

A sub R = R over square root of R squared plus X sub C squared

For a high pass filter.

A sub R = X sub C over square root of R squared plus X sub C squared

Calculation of phase angle is usually not necessary.

Example 2.12.

In Figure 2.9, R = 1 k ohms and C = 10 uf. What is the attenuation ratio at a frequency of 60 Hz?

Solution:

First, calculate the reactance of the capacitor at 60 Hz.

XC = 1/(2 pi f C) = 1/(2 pi 60 Hz x 10 x 10-6 f) = 265.26 ohms.

The circuit impedance is

Z = square root of quantity R squared plus X sub C squared close quantity = square root of quantity 1000 squared plus 265.26 squared close quantity = 1034.58 ohms.

Assume an input voltage of 1 v and calculate I = E / Z

I = 1 v / 1034.58 ohms = 9.6658 x 10-4 A.

VO = I XC = 9.6658 x 10-4 A x 265.26 ohms = 0.256 v. Dividing this output voltage by 1 v gives the attenuation ratio of 0.256.

Example 2.13.

In the circuit of Figure 2.10 R = 1592 ohms and C = 0.1 uf. What are the attenuation ratios at (a) 60 Hz and (b) 1 kHz?

Solution:

For details on the calculations of XC, Z and I you are referred to example 2.12. Calculating XC at 60 Hz and 1 kHz we have
XC at 60 Hz = 2.653 x 104 ohms and
XC at 1000 Hz = 1592 ohms.
Calculating the circuit impedance at 60 and 1000 Hz.
Z at 60 Hz = 2.658 x 104 ohms and
Z at 1000 Hz = 2251 ohms.
The current for 1 v input is found to be
I at 60 Hz = 3.762 x 10-5 A and
I at 1000 Hz = 4.442 x 10-4 A.
All that remains is to calculate the output voltage. This is the only part of this example which is different from example 2.12. For Figure 2.10 the output voltage is (a) VO = I R.
At 60 Hz VO = 3.762 x 10-5 A x 1592 ohms = 5.99 x 10-2v.
The attenuation ratio AR = 5.99 x 10-2
(b) At 1000 Hz VO = 4.442 x 10-4 A x 1592 ohms = 0.707 v
therefore AR = 0.707

In the above examples we have defined the attenuation ratio of a filter to be

AR = VO / VI           (2.24)

where VO is the output voltage of the filter at one particular frequency and VI is the input voltage at the same frequency. The output divided by the input is often called the "gain" of the circuit. The term gain implies an increase, not a decrease as occurs in a passive circuit. The term gain will make more sense when we study amplifiers which do increase the amplitude of the input signal.

In the examples above if the attenuation is desired at several different frequencies it would be necessary to recalculate the value of XC for each frequency. There is a way to avoid these repeated calculations. Let us write a general equation for the attenuation ratio of a low-pass filter and see what we can do with it. The general equation is this.

A sub R = X sub C over square root of R squared plus X sub C squared.

Now we will make the substitution XC = 1 / (2 Pi f C).

A sub R = 1 over quantity 2 Pi f C close all over square root of R squared plus 1 over quantity 2 Pi f C close squared end square root.

Now we will multiply the above equation through by 2 Pi f C to obtain.

A sub R = 1 over square root of 2 Pi f C R all squared plus 1 end square root.

The cut-off frequency is where XC = R. If we substitute into the reactance equation we have

R = 1 / (2 Pi fC C)

Solving for the cut-off frequency gives.

fC = 1 / (2 Pi R C).

We can substitute this into the above equation and obtain.

A sub R = 1 over square root of quantity f over f sub c quantity squared plus 1.

Where fc is the cut-off frequency and f is any given frequency.

If we start from the high pass filter equation and follow the same procedure we will obtain.

A sub R = 1 over the quantity square root of 1 plus open f sub c over f close squared close square root.

Either one of these equations may easily be solved for fc to find the cut-off frequency for a given frequency and attenuation or for f to find the frequency for a given attenuation for a given filter.

Logical Checks.

The output voltage of an RC filter will always be less than or equal to the input voltage. If you get an output which is larger than the input, you have made a mistake.

For a low-pass filter, the output will decrease as the frequency increases. If asked to calculate the attenuation ratio at two different frequencies and you get an answer which says that the higher frequency gives a larger output voltage than does the lower frequency, you have made a mistake.

For a high-pass filter, the output will increase as the frequency increases. If asked to calculate the attenuation ratio at two different frequencies and you get an answer which says that the lower frequency gives a larger output voltage than does the higher frequency, you have made a mistake.

Example 2.13.1.

In the circuit of Figure 2.10 R = 1592 ohms and C = 0.1 uf. What are the attenuation ratios at (a) 60 Hz and (b) 1 kHz?

Solution:

This is a repeat of Example 2.13. Lets try the new tools we have. First of all.

fC = 1 / (2 Pi R C) = 1 / (2 Pi 1592 x 0.1 x 10-6) = 1000 Hz.

From equation 2.24.5 we have.

AR = 1 / sqrt(1 + (fC/f)2)

(a) AR = 1 / sqrt(1 + (1000/60)2) = 0.0599

(b) AR = 1 / sqrt(1 + (1000/1000)2) = 0.707

Example 2.13.2.

A low-pass filter is needed that has an attenuation ratio of 1.8 x 10-3 at a frequency of 60 Hz. (a) What is the cut-off frequency of this filter? (b) If the resistor is 1 Meg ohm what is the capacitor value?

Solution:

Solving equation 2.24.4 for fc gives.

f sub c = f times A sub R over square root of 1 minus A sub R squared.

(a) Fc = 60 x 1.8 x 10-3 / sqrt(1 - (1.8 x 10-3)2) = 0.108 Hz.

(b) C = 1 ( 2 Pi fc R) = 1 / (2 Pi 0.108 x 106 = 1.47 uf.

Example 2.13.3.

A high-pass filter must have an attenuation of 0.966 at a frequency of 20 Hz. (a) What is the cut-off frequency, and (b) What is the capacitor if the resistor is 470 k ohms?

Solution:

Solving equation 2.24.5 for fc gives.

f sub c = square root of 1 minus A sub R squared end square root over f times A sub R.

(a) fc = sqrt(1 - 0.9662) / (20 x 0.966) = 5.35 Hz.

(b) C = 1 / (2 Pi 5.35 x 470 x 103) = 0.0633 uf.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

2.6 The Decibel (dB).

The decibel (dB) is one tenth of a Bell (B), as in Alexander Graham Bell. From this you might assume that the Bell and decibel have something to do with sound and you would be partly correct.

The dB began life as a measure of sound pressure level. A dB is the smallest change in sound level which the human ear can detect. The key to understanding the dB is that word "change". There is no absolute zero on the dB scale.

Because the telephone converts sound to an electrical signal, an electrical definition of the dB is closely tied to the sound level definition. The electrical definition is

dB = 20 Log ( V2 / V1)           (2.25)

or

dB = 10 Log ( P2 / P1)           (2.26)

where P1 and P2 are powers and V1 and V2 are voltages. The quantity which is subscripted 2 is the one to be expressed in dB and the quantity which is subscripted 1 is the chosen reference. For example the gain of an amplifier or loss (attenuation) of a filter can be expressed in dB as follows.

dB = 20 Log (VO / VI)           (2.27)

Where VI is the input voltage and VO is the output voltage. In the above equations, if V2 = V1, P2 = P1 or VO = VI, the result is zero (0) dB. The denominator of the argument of the log function is called the reference level because it determines where the zero on the dB scale will be placed.

The reference level may be anything which the occasion demands. There are far too many standard references to list here but there is one which is so common that it is worth mentioning. A standard reference is 1 milliwatt in 600 ohms. The voltage is V2 = P R = 1 x 10-3 w x 600 ohms = 0.60 square volts and V = 0.7746 v. This dB scale is referred to as the dBm (dB referred to 1 milliwatt) scale and it appears on most analog AC meters. It is also known as the VU (volume unit) scale. The VU meters in a tape deck or radio station console use this scale.

The dB is widely used because its logarithmic nature permits it to express a wide range of values in a compact form. It is most useful in graphing quantities which have a wide range. This will become apparent in the next section.

Example 2.14.

Express the following power levels in dBm: (a) 25 microwatts, (b) 1 milliwatt, (c) 1 watt and (d) 75 watts.

Solution:

dBm = 10 Log P / 1 mw           (2.28)

(a) -16.0 dBm,
(b) 0 dBm,
(c) 30 dBm and (d) 48.8 dBm.

Example 2.15.

Express the following voltage levels in dBm: (a) 5 microvolts, (b) 2 millivolts, (c) 6 volts and (d) 120 volts.

Solution:

dBm = 20 Log V / 0.7746 v           (2.29)

(a) -103.8 dBm,
(b) -51.8 dBm,
(c) 17.8 dBm and
(d) 43.8 dBm.

Example 2.16.

A filter is being operated at its cutoff frequency. (a) Use power to express the attenuation ratio in dB. (b) Use voltage to express the attenuation ratio AR in dB.

Solution:

At the cutoff frequency the output power is 1/2 of the input power and the output voltage is 0.7071 of the input voltage.
(a) dB = 10 Log 0.5 = -3.01 dB.
(b) dB = 20 Log 0.7071 = -3.01 dB.
Let's call them both -3 dB.

At the cutoff frequency the filter's output is 3 dB down from its flat response output level. The cutoff frequency is often called the "3 dB point" or the "half-power point".

Example 2.17.

Express the results of examples 2.12 and 2.13 in dB.

Solution:

The result of example 2.12 is AR = 0.256. Since AR = VO / VI we have dB = 20 Log AR = 20 Log 0.256 = -11.8 dB.

The results of example 2.13 are at 60 Hz AR = 5.99 x 10-2 and at 1000 Hz AR = 0.707. At 60 Hz ARdB = -24.4 dB and at 1000 Hz ARdB = -3 dB.

Example 2.18

In the frequency response curve of Figure 2.6 the attenuation at 1 MHz is 60 dB, at 100 kHz it is 40 dB, at 10 kHz it is 20 dB and at 1 kHz it is 3 dB. What is the value of AR at each of these frequencies?

Solution:

Starting from the equation dB = 20 Log AR and taking the antilog of both sides we have

AR = 10dB/20.

At 1 MHz AR = 10-60/20 = 1 x 10-3,
At 100 kHz AR = 10-2,
at 10 kHz AR = 10-1, and
at 1 kHz AR = 10-3/20 = 0.708, which shows that there are often errors in reading graphs.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

2.7 Graphing Frequency Response.

As with most other things there is a right way and several wrong ways to graph frequency response curves. First we will discuss what makes a "good" graph in general and then show some examples of wrong ways to graph frequency response.

The best possible graph is a straight line. It is easy to draw, easy to pick off values from and easy to fit an equation to. If you can't get a single straight line, a couple of line segments joined by a short curving section is the next best thing. The graphs in Figures 2.6 and 2.7 fit the latter description nicely.

One of my professors once said, in jest I'm sure, "If you can get your data to plot as a straight line you should get your PhD on the spot, and if you can get the line to go through the origin you should get the Nobel prize."

In Figures 2.6 and 2.7 the frequency is plotted on a logarithmic scale. The distance between 1 and 10 is the same as the distance between 10 and 100, which is also the same as the distance between 100 and 1000. On a linear scale the distance between 10 and 100 would be 10 times larger than the distance between 1 and 10. The first dotted vertical line to the right of 1 is for 2. The next dotted line is for 5. The two dotted lines to the right of 10 are for 20 and 50 respectively. Other interpolation markings have been omitted to keep the graph from being too cluttered.

The vertical scale in Figures 2.6 and 2.7 is plotted in dB. Now that you know what a dB is you know that the vertical scale is also a logarithmic scale. If you think back to geometry you will remember that if you plot y = 1/x on a log-log scale it is a straight line. The roll-off portion of the graph of a low-pass filter is a 1/f curve, as shown in Figure 2.6. In Figure 2.7 the straight part of the roll-off is a simple y=x function which is a straight line on a log-log as well as a linear graph.

Some Wrong Ways.

Given a set of data and told to "go and plot it" with no further instructions the natural thing to do would be to use linear axes for both x and y coordinates. Figure 2.11 shows data for a low-pass filter which has been plotted on linear scales for frequency and attenuation ratio. Note that we are not using dB but just the values of AR. Because the raw data goes from 1 hertz to 1 megahertz the frequency scale is from 0 to 1 megahertz. The attenuation scale is from 0 to 1.

As you can see from Figure 2.11 the frequency response curve is a shy little thing that attempts to hide behind the X and Y axes. It is not very useful because it would be impossible to pick values from except in a very small part of the curve.

Figure 2.11 Frequency Response of a Low-pass Filter
Plotted on Linear Scales 0 to 1 MHz.

For a verbal description click here.

The curve can be pulled away from the edges by changing the scale. Figure 2.12 shows the same data plotted from 0 to 6 kilohertz. While this scale throws away most of the data it does make for a readable graph.

Figure 2.12 Frequency Response of a Low-pass Filter
Plotted on Linear Scales 0 to 6 kHz.

For a verbal description click here.

What is needed is a scale which allows wider spacing of numeric intervals when the values are small and closer spacing when the values are large. That sounds like the description of a logarithmic scale. Figure 2.13 is getting better because the frequency is now on a log scale. The vertical axis is still the attenuation ratio which ranges from 0 to 1. It is a linear scale.

Figure 2.13 Frequency Response of a Low-pass Filter
Plotted on Logarithmic Scales 1 Hz to 1 MHz.

For a verbal description click here.

From this figure it is possible to tell that the attenuation ratio is 0.707 at 1 kHz. Inspection of this graph indicates that the output of the filter is zero above 100 kHz. This is not the case! The output of a filter never goes to zero. We are in need of a logarithmic scale for the attenuation ratio as well as the frequency.

A log scale for the attenuation ratio could be obtained by using log-log graph paper to plot the data. Alternatively, we could simply take the log of AR but since the dB is so well known it seems to be the best way to get a log scale on the vertical axis. As all analog AC voltmeters have a dB scale the data may be taken in dB for plotting directly on a graph.

In Figure 2.6 we can see that the filter's output is down 3 dB at 1 kHz. We can also see that the output is down 20 dB at 10 kHz, 40 dB at 100 kHz and 60 dB and 1 MHz. In fact the output of a low-pass filter decreases by 20 dB for every decade increase in frequency. This particular rate of decrease is specific to a low-pass filter consisting of one capacitor and one resistor. Filters which are more complex will have roll-off rates of 40, 60, 80, and so on dB per decade of frequency.

Using Store-bought Graph Paper.

Many students become confused when they set out to plot a frequency response curve on a piece of semi-log graph paper. To begin with the numbers are printed on the paper in the wrong orientation. To read the numbers right-side-up you will hold the paper so that the log axis is vertical. As you can see in figure 2.6 the log axis is horizontal. Even after getting the paper turned the right way, there is still confusion about what to do with those numbers and how to relate them to frequency.

Semi-log and log-log graph paper is sold by cycles. One cycle will cover one decade of data. A representation of a piece of 2 cycle semi-log paper is shown in Figure 2.14. The numbers have been turned right-side-up for easier reading.

Figure 2.14 Representation of a Piece of Semi-log Graph Paper.

For a verbal description click here.

The numbers across the top are the numbers which are printed on the paper. The numbers in each successive decade are spaced a little farther out from the graph. The line between 1 and 2 is for 1.5. You may have noticed that it is not equidistant between 1 and 2. That is the nature of a log scale.

To plot frequency on this graph paper you would label the horizontal axis as shown along the bottom of the graph. If you have more decades to plot you must buy another piece of graph paper which has more cycles. When you go to the bookstore to buy semi-log or log-log paper you should know how many decades of data you have to plot.

If semi-log paper cannot be obtained in the desired number of cycles, it is possible to use linear paper and take the log of frequency. The log of frequency has no particular meaning (there is no equivalent to the dB for frequency), which makes it necessary to label the graph with frequency in hertz rather than log of frequency.

The magnitude (Y axis) of a frequency response plot may be plotted on a linear scale in dB or on a log scale in attenuation ratio. Although either way is acceptable, plotting dB on a linear scale is by far the most commonly used method.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

2.8 Nonsinusoidal Waves.

As shown in Figure 2.1 there are waves other than sine waves. These other waves are made up of sine waves in combination.

Sinusoids.

The simplest of oscillators, (devices which generate waves), produces a sine or cosine function. When the output of such an oscillator is plotted versus time, the result is what we call a sine wave. When a waveform is not sinusoidal (square, triangular or just not a sine wave), it can be shown mathematically and physically to be the sum of several sinusoidal waves.

Harmonics.

A harmonic is a frequency which is an integer multiple of another frequency. The "other" frequency is called the fundamental frequency. Thus a complex (nonsinusoidal) waveform is made up of a fundamental frequency, which is a sine wave with the largest amplitude and lowest frequency, and several other sine waves which are lower in amplitude and integer multiples of the fundamental frequency.

Numbering Harmonics.

Harmonic numbers are assigned on the basis of their relationship to the fundamental frequency. The fundamental frequency itself is the first harmonic. The frequency which is twice the fundamental frequency is called the second harmonic. The frequency which is three times the fundamental frequency is called the third harmonic and so on. The frequency of any harmonic is just the harmonic number multiplied by the fundamental frequency.

Fourier Series.

Remember the angular frequency? The symbol usually used for the angular frequency is a lower case omega. That symbol does not appear on my word processor. We will use instead a "w". If we call the nonsinusoidal wave F(wt) then the general form of the Fourier series for F(wt) is given by

F(wt) = a0 + a1 cos(wt) + a2 cos(2wt) + ... + an cos(nwt)
           + b1 sin(wt) + b2 sin(2wt) + ... + bn sin(nwt)     (2.30)

where w = 2 pi f, a0 is the DC component (if any) of the complex wave, an is the coefficient of the nth cosine harmonic and bn is the coefficient of the nth sine harmonic. The coefficients are given by

A sub zero=1 over 2Pi times the integral from 0 to 2Pi of F of wt dwt.

A sub n = 1 over Pi times the integral from 0 to 2Pi of F of wt cos nwt dwt.

B sub n = 1 over Pi times the integral from 0 to 2Pi of F of wt sin nwt dwt.

A square wave which has voltage levels of +V volt for the first half-cycle and -V volt for the second half-cycle and frequency w/(2 pi ) will have the Fourier series

F of wt = 4 V over Pi times the quantity sin wt plus one third sin 3wt plus one fifth sin 5wt plus dot dot dot close quantity.

The Fourier series for a triangular wave which has a positive peak voltage of +V volts and a negative peak voltage of -V volts is

F of wt = 8V over Pi times the quantity sin wt plus 1 over 3 squared sin 3wt plus 1 over 5 squared sin 5wt plus dot dot dot close quantity.

When the writer was a student, a waveform had to be capable of being described mathematically in order to obtain its Fourier series. Calculating the coefficients was a long and arduous process. Now there are computer programs which will give the coefficients of the Fourier series of any arbitrarily-shaped wave.

The Physics of It All.

Spectral line diagram.

Figure 2.15 Frequency Spectrum of a Square wave.

For a verbal description click here.

Figure 2.15 shows the spectrum of a square wave. Unlike spectra you are accustomed to seeing, this one plots frequency instead of wavelength. Also unlike other spectra you may have seen, the magnitude of each line is plotted upward from the horizontal axis. In optical spectra, the magnitude of each line is indicated by its brightness in a spectroscope or its darkness on a film negative. Other than that it's a perfectly normal spectrum.

Figure 2.16 shows how the sine waves fit together to make up a square wave. Notice that the square wave gets better as more harmonics are added. To obtain a perfect square wave it would be necessary to have an infinite number of harmonics. A quite good square wave is generated if approximately 99 harmonics are present.

Figure 2.16 Square Waves Are Built Up from Sine Waves.

For a verbal description click here.

In the top wave the red line is the sum of the first and third harmonics. In the middle diagram the sum of 1 and 3 has been redrawn in black and the 5th harmonic added. Similarly, in the bottom diagram the 7th harmonic has been added. The more harmonics are added, the flatter the sum will be and the steeper the rises and falls will be.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

2.9 The Effects of RC Circuits on Nonsinusoidal Waves.

When a nonsinusoidal wave is passed through an RC filter the shape of the wave is changed. An RC circuit cannot affect the shape of a lone sine wave. It can only affect its amplitude.

There are two different ways to look at the way in which an RC circuit changes the shape of a nonsinusoidal wave. One is to look at the way an RC circuit affects the amplitudes and phases of the harmonics (frequency domain) and the other is to look at the RC circuit as having a time constant which superimposes its own charging and discharging on the original wave (time domain).

The Frequency Domain.

Because an RC circuit affects the amplitudes of the various harmonics of a complex waveform by different amounts, the makeup of the Fourier series is changed. If you change the Fourier series, you change the shape of the wave.

Figure 2.17 shows how a square wave is modified by being passed through a low-pass RC filter. In Figure 2.17a the cutoff frequency of the filter is 10 times the frequency of the square wave. Harmonics 1, 3, 5, 7 and 9 are passed with little or no attenuation. Harmonics numbers 11 and higher are not removed; they are reduced in amplitude compared to what they were in the original wave. In Figure 2.17b the frequency of the square wave is equal to the cutoff frequency of the filter. All of the harmonics are altered in amplitude. As you can see the wave no longer looks much like a square wave. It should be pointed out that the wave has been turned on for some time, we only started looking at it where the wave seems to start. Starting and stopping transience are not shown.

Figure 2.17 RC Filter's Effects on a Square wave.

For a verbal description click here.

In Figure 2.17c the vertical scale has not been changed. The square wave has been changed into a triangular wave of somewhat reduced amplitude. The filter has imposed its own 1 over f function on the harmonics of the square wave. The harmonic amplitudes of the wave are now a 1 over f squared function. Look at the Fourier series for a triangular wave and you will see that it is a 1 over f squared function. The square wave has been converted into a triangular wave.

The analysis of other waveforms is not as easy as for a square wave but the principle is the same. In general a low- pass filter will tend to round off the sharp edges on any wave.

Figure 2.18 shows how a square wave is modified by being passed through a high-pass RC filter. In Figure 2.18a the cutoff frequency of the filter is 10 times the frequency of the square wave. Harmonics 1, 3, 5, 7 and 9 are severely attenuated with the lower numbered harmonics being attenuated more than the higher numbered ones. Harmonics numbers 11 and higher are passed with little or no attenuation. The result is a series of spikes as shown in Figure 2.18a. As with Figure 2.17, starting and stopping transients are not shown.

Figure 2.18 RC Filter's Effects on a Square wave.

For a verbal description click here.

In Figure 2.18b the cutoff frequency of the filter is equal to the fundamental frequency of the square wave. The fundamental frequency (first harmonic) of the wave will be attenuated by 3 dB while the higher harmonics will be affected very slightly. In Figure 2.18c the frequency of the wave is 10 times the cutoff frequency of the filter. The first harmonic will be affected by only about 10%. Figures 2.18b and 2.18c show how sensitive a square wave is to the amplitude of its fundamental frequency.

The Time Domain.

In Figure 2.17 a square wave is being passed through an RC low-pass filter. When the input wave changes states, say from -V to +V, the capacitor must charge up from -V to +V. As you will remember it takes one time constant for the voltage to reach 36.8% of the final value. Theoretically, the voltage will never reach the final value.

In Figure 2.17a there are 31.4 time constants in every half cycle of the square wave. This means that the capacitor has plenty of time to charge up to the final value. The difference between the final value and the charge on the capacitor is 2.27 x 10-14. In Figure 2.17b there are only 3.14 time constants in each half cycle. The capacitor has much less time to finish charging before the square wave switches to its other state. Even so the voltage will have time to reach 95.7% of its final value. In Figure 2.17c there is only 0.314 of a time constant in each half cycle of the square wave. The voltage will only reach 26% of its final value. For small values of x the equation y = e-x appears to be a straight line. That is why the square wave is converted into a triangular wave.

The time integral of a square wave is a triangular wave. RC low-pass filters are often called integrators because they can be made to integrate waves if the frequency of the wave is higher than the cutoff frequency of the filter.

If a square wave is passed through an RC high-pass filter the results are shown in Figure 2.18. In Figure 2.18a there are 31.4 time constants in every half cycle of the square wave. This means that the capacitor has plenty of time to discharge. The charge on the capacitor is 2.27 x 10-14 of its starting value. In Figure 2.18b there are only 3.14 time constants in each half cycle. The capacitor has much less time to finish discharging before the square wave switches to its other state. Even so the voltage will have time to reach 4.3% of its initial value. In Figure 2.18c there is only 0.314 of a time constant in each half cycle of the square wave. The voltage will fall to 73% of its initial value.

RC high-pass filters are often called differentiating circuits because they do an approximate differentiation on the input wave. The slope of a square wave is 0 along the flat portions of the wave and very high on the transitions. Thus the derivative of a square wave is a series of narrow spikes similar to Figure 2.18a.

The fact that the same set of figures was used for both time domain and frequency domain discussions should make it clear that these are simply two different ways of describing the same phenomenon. The physics goes on regardless of the human reasoning process or even in the total absence of human reasoning.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

2.10 R-LC Resonate Circuits.

When inductance and capacitance exist together in the same circuit the phenomenon of resonance appears. You are already familiar with resonance in a spring-mass system. If such a mechanical system is driven by an external force at different frequencies it will respond most strongly when driven at its resonant frequency. If the system is displaced and then released, it will produce damped oscillations at its resonant frequency. How rapidly the oscillations damp out will depend on the amount of energy lost in the system.

An R-LC circuit will respond electrically in exactly the same way as the mechanical system. If an external AC voltage is applied to the circuit at different frequencies, the current in the circuit will be largest at the resonant frequency. If a DC voltage is applied to the circuit and then suddenly removed, the circuit will produce damped oscillations at its resonant frequency. How rapidly the oscillations damp out will depend on the amount of resistance in the circuit.

Figure 2.19 (a) R-LC Resonant Circuit and (b) Phasor Diagram.

For a verbal description click here.

A series R-LC circuit is shown in Figure 2.19a and its phasor diagram is shown in Figure 2.19b. The current everywhere in the circuit will be in phase with itself. The voltage across the resistor will be in phase with the current. The voltage across the inductor will lead the current by 90 degrees while the voltage across the capacitor will lag the current by 90 degrees. As can be seen in Figure 2.19b the total difference in phase between VC and VL is 180 degrees. IF the two voltages are equal in magnitude, they will cancel out and the voltage across the resistor will be equal to the generator voltage. Whereas IC = IL, the only way to make VC = VL is to have XC = XL. This is the definition of the resonant condition in a series circuit. Series resonance occurs when the capacitive reactance is equal to the inductive reactance.

The total impedance of a series R-LC circuit is

Z = square root of R squared plus quantity X sub L minus X sub C quantity squared.

where R is the resistance of the resistor in ohms, XL is the reactance of the inductor in ohms and XC is the reactance of the capacitor in ohms. If we substitute XL = 2 pi fL and XC = 1/(2 pi fC) we have

Z = square root of R squared plus quantity 2 PI f L minus 1 over 2 pi f C quantity squared.

where f is the frequency in hertz, L is the inductance in henrys and C is the capacitance in farads. With R, L and C held constant Z will be infinite at f = 0 and infinity. For values of f between zero and infinity, Z will come down to a minimum of Z = R at the resonate frequency. Figure 2.20 shows impedance versus frequency and current versus frequency for a 1 volt generator, a 50 ohm resistor, a 79.6 millihenry inductor and a 0.318 microfarad capacitor connected as in figure 2.19a. The curves of resonant circuits appear on linear scales about as often as they appear on log scales.

Figure 2.20 Impedance and Current Versus Frequency.

For a verbal description click here.

Resonant circuits are used to select a narrow band of frequencies out of the entire frequency spectrum. Just how narrow a band is selected depends on the quality factor "Q" of the circuit.

Bandwidth and Q of Resonant Circuits.

The bandwidth of a resonant circuit is defined as the difference between the two frequencies where the current is down to 0.707 of its maximum value (the half power points). Remember that 0.707 is our old friend -3 dB. This is a somewhat arbitrary definition as in the case of RC filters. In the circuit of Figure 2.20 the maximum circuit current is 20 mA. The current at the -3 dB point is 14.14 mA. Notice that there are two -3 dB points on the curve at frequencies of 952 and 1052 hertz. *

The lower -3 dB frequency is called f1, the upper -3 dB frequency is called f2 and the resonant frequency is called fR. The quality of a resonant circuit may be expressed as

* These frequencies were found by placing a conditional test in the plot program and causing the frequencies to be printed out. In this sense the values were "picked off of" the graph.

Q = fR / (f2 - f1)           (2.38)

The Q or quality factor of a resonant circuit can also be expressed as follows:

Q = XL / R     or     Q = Xc / R           (2.39)

Q is defined at resonance where XL = XC. Equations 2.38 and 2.39 are based on definitions and so cannot be derived. An equation which would arise from setting equations 2.38 and 2.39 equal is an approximation which falls apart if Q is less than about 5.

Example 2.19.

What is the resonant frequency of the circuit whose curves are plotted in Figure 2.20? Calculate the Q according to both definitions.

Solution:

The resonate frequency is where XL = XC. Equating these two quantities gives

2 pi f L = 1 / (2 Pi f C)

Solving this equation for f gives

f = one over the quantity 2 Pi square root of L C close quantity.

Substituting L = 79.6 mH and C = 0.318 uf gives the result 1000 hertz. The Q of the circuit according to equation 2.38 is Q = 1000 / (1052 - 952) = 10. The values of f1 and f2 were given on page 108. To find the Q by equation 2.39 we must first find a value for XL or XC at the resonant frequency. XL = 2 pi f L = 500 ohms. Q = X/R = 500 ohms /(50 ohms ) = 10.

Example 2.20.

Using all of the same values from the previous example, what is the voltage across the capacitor in the circuit of Figure 2.19a at the resonant frequency?

Solution:

At resonance XL = XC and by equation 2.37 Z = R;
therefore, I = 1 v / (50  ohms) = 20 mA.  The reactance of
the capacitor at resonance is XC = 1 / ( 2 pi fC ) = 500  ohms.
The capacitor voltage VC = I XC = 20 mA x 500  ohms = 10 v.

Notice that the voltage across the capacitor is Q times the input voltage. This is no coincidence. The voltage across the capacitor could be taken as the output voltage of the circuit. In that case only the voltages at or near resonance will be increased in amplitude. Voltages at frequencies far away from resonance will be attenuated.

One note of caution. The circuit is NOT increasing the power of the input signal. While more voltage is available, there is less current available. You don't get something for nothing.

Also you have no doubt noticed that f1 and f2 are not equally spaced about fR. Reactive circuits behave in a geometrical rather than an arithmetical manner. That is to say f2 - fR is not equal to fR - f1 but

f2 / fR = fR / f1

in this example to an accuracy of 0.15%. (The accuracy might have been better but the frequency was restricted to integer values.) The curve would be graphically symmetrical if it had been plotted on a logarithmic frequency scale. The Q of a circuit which resonates at a radio frequency can be as high as 250. The curves of such circuits cover such a small percentage of the frequency spectrum that there is no practical difference between a logarithmic and a linear scale.

The Imperfect Inductor.

In the study of electric circuits we are accustomed to thinking of every component as if it were perfect. We think of wires as having zero resistance, resistors as having exactly the specified value and capacitors as having no built-in resistance. The errors which result from these implicit assumptions are not large enough to get us into very much trouble. Of the three basic circuit components - resistors, capacitors and inductors - inductors are the most imperfect. To assume that inductors possess only the property of inductance would be a very large mistake.

Inductors are constructed by winding a length of copper wire on a hollow nonmagnetic, nonconducting tube (air core) or an iron bar (iron core). Other core materials are used such as powdered iron (ferrite) or brass. Both the wire and the core material introduce energy losses. When energy is lost, the effect is the same as having resistance in series with the inductor.

The copper wire actually has resistance. Certain inductors have many turns which means that the total length of wire is quite long. The amount of resistance can be significant enough to lower the Q of the circuit.

Figure 2.21 Equivalent Circuit of an Inductor.

For a verbal description click here.

The loss which is introduced by the core material also contributes to the equivalent resistance of the inductor. Any energy loss in a circuit can be accounted for by calling it resistance even though there is no measurable resistance in the circuit. A core which has losses will cause the inductor to act the same as if a lossless inductor were connected in series with a real resistor.

You may be wondering why iron and material other than air are used. If the only thing a core did was to introduce losses there would be no reason to use it. An iron core will increase the amount of inductors by as much as a factor of 1000 over the same coil with an air core. The gain in inductance is well worth the increase in core loss caused by the iron.

If iron is so good, why use anything else? The reason is frequency. The common laminated iron core* is only useful through the audio frequency band (up to 20,000 Hz). Powdered iron cores are useful up to about 30 MHz. The individual grains of iron powder are held together and insulated from one another by some sort of plastic material. Brass cores are used from about 30 to 200 MHz. Above 200 MHz even air core coils have only 2 or 3 turns and a solid core is not needed to increase the inductance.

* A solid iron core is useless in AC applications because of the excessive losses due to eddy currents. In a laminated core the iron is in thin sheets and the sheets are electrically insulated from one another.

Parallel Resonant Circuits.

Figure 2.22 is the diagram of a parallel resonant circuit. Circuits such as this are used much more often than are series resonant circuits. The impedance versus frequency curve for this circuit is shown in Figure 2.23. As you can see, the impedance is low at the extremes of frequency and rises to a maximum value at resonance. If a parallel resonant circuit is used as the load for a transistor, the gain of the amplifier will be maximum at resonance and very low away from resonance. Such an amplifier is called a frequency-selective or tuned amplifier.

Figure 2.22 Parallel Resonant Circuit.

For a verbal description click here.

Figure 2.23 Impedance Versus Frequency for a Parallel Resonant Circuit.

For a verbal description click here.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

2.11 Transformers.

A transformer is a device which will change the voltage and current of AC. A transformer can be used to step down the voltage of the power line for use by circuits which would be damaged by the full 120 volts of the power line. In addition the electric utility itself uses transformers to step the voltage up and thereby step the current down to minimize the power lost in long power lines. A transformer consists of two or more coils of wire wound on an iron core. The coils are usually wound one surrounding the other. The schematic symbol for a transformer is shown in Figure 2.24. The winding to which power is applied is called the primary winding and the winding from which the power is taken is called the secondary winding. Many transformers have more than one secondary winding.

Figure 2.24 Symbol for a Transformer.

For a verbal description click here.

To determine quantitatively how the voltage is changed by a transformer we must remember the equation

E = N d phi dt.

where E is the voltage across the coil, N is the number of turns on the coil and Phi is the magnetic flux linking the coil. For the two windings of a transformer we can write

E sub P = N sub P d phi sub P dt and E sub S = N sub S d phi sub S dt.

where the subscript P refers to the primary and the subscript S refers to the secondary. In a transformer the magnetic flux is so well confined by the iron core that almost all of the flux from the primary also links the secondary and visa versa. This means that Phi sub P = Phi sub S. We can divide equation 2.42a through by NP and equation 2.42b by NS and set them equal and rearrange terms to obtain the following equation.

EP / ES = NP / NS           (2.43)

Example 2.21.

A transformer has 2450 turns on its primary and 700 turns on its secondary. If 120 volts is applied to the primary, what is the secondary voltage?

Solution:

The secondary voltage is ES = EP NS / NP = 120 x 700 / 2450 = 34.29 volts.

Example 2.22.

In the case of the transformer from example 2.21 if the secondary current is 850 mA, what is the primary current?

Solution:

Transformers are so efficient that the efficiency may be taken as 100% without introducing serious errors. Therefore, the power in the secondary equals the power in the primary. PP = PS and EP IP = ES IS; therefore,

IP / IS = ES / EP           (2.44)

and so IP = 850 mA x ( 34.29 v / 120 v ) = 243 mA.

From equation 2.44 you might properly deduce that

IP / IS = NS / NP           (2.45)

A transformer which steps up the voltage will step down the current and vise versa. An electric utility will use transformers to step up the voltage to a very high value (as much as 300 kv) to send power over very long distances. When the voltage is stepped up, the current is stepped down. Most of the loss in power transmission lines is due to the resistances of the wires. Making the current as small as possible will minimize the power loss due to resistance. The voltage is stepped back down for distribution around cities and stepped down again just before being delivered to the customer.

Impedance Transformation.

A note about terminology

The term "impedance" is often used when the term resistance could be applied. This is correct usage because of the way in which impedance is defined. Impedance is a combination of resistance and reactance. The reactive component may or may not be zero. Therefore, it is possible to say "impedance" and mean "resistance". The reverse of this is not correct.

The apparent impedance of the primary of a transformer is given by ZP = EP / IP and the impedance in the secondary is ZS = ES / IS. If we substitute equations 2.43 and 2.45 into these impedance equations we have

Z sub P = E sub P over I sub P = E sub S over I sub S times quantity N sub P over N sub S end quantity over quantity N sub s over N sub P end quantity.

Inverting the denominator and multiplying we have.

Z sub P = Z sub S times the quantity N sub P over N sub S quantity squared.

Example 2.23

What is the turns ratio of a transformer to match an 8 ohm speaker to a 600 ohm line?

Solution:

Since power goes to a speaker, the 8 ohm speaker side is the secondary of the transformer. The power flows from the transformer to the speaker.

N sub P over N sub S = square root of Z sub P over Z sub S = square root of 600 over 8 = 8.66.

True, the number of turns must be an integer. A transformer manufacture would use many turns possibly 866 / 100 or more likely 8660 / 1000. Since we are working problems and not manufacturing transformers we can be content with what ever number comes out, even a number less than one.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

2.12 The Oscilloscope.

Almost all voltmeters have ranges designed for measuring AC voltage. Most DMMs have ranges for measuring AC current. If sine waves are involved, most voltmeters and ammeters will read out only the RMS value of the voltage or current. The limitations of voltmeters and ammeters are many. They cannot tell us anything about the waveform, the frequency, the phase or noise content of the AC signal being measured. Indeed, if the waveform is other than a sine, if the frequency is too high or if the signal contains too much noise, common AC voltmeters and ammeters will give us false readings.

The most useful instrument for making measurements on AC signals is the oscilloscope. The oscilloscope can be used to make quantitative measurements of voltage, frequency, rise-time of a square wave and phase between two signals. In addition an oscilloscope can be used to make qualitative evaluations of waveform and noise content. But that's not all. With various electronic and computer add-ons an oscilloscope can display the characteristic curves of semiconductor devices, plots of frequency response, phase diagrams of complex signals and frequency spectra and logic states (1s and 0s) in a microprocessor system. If you had to do electronics in a remote area of the earth or in space and you could take only one measurement instrument, the oscilloscope would be the unquestioned choice.

An oscilloscope is basically two instruments in one: a voltmeter and a time interval meter. The voltmeter portion is usually the Y axis, although the X axis may be used in some oscilloscopes for some special applications. The time interval portion is always the X axis.

The thing which sets the oscilloscope apart from all other electrical measurement instruments is the cathode ray tube (CRT). The CRT is one of the few vacuum devices which has not been replaced by a solid state equivalent. (For some years now the solid state replacement has been promised but so far it remains only a promise.)

BINGO! That promise has at last been fulfilled. I have, at this moment, sitting on my workbench an oscilloscope which has a front panel the same size as any classic scope but instead of being seventeen and a half inches deep it is four and a half inches deep. The CRT has been replaced by a liquid crystal display. Granted, at this writing, 2006, they are still rather pricy. But knowing the electronics industry, the price will come down and the CRT will fall out of favor, except for a small number of diehards who will insist that the CRT just looks better. I have to concede that is true but the advantages still outweigh the disadvantages. The following section on the CRT will be left in until this tube completely disappears from the scene.

The Cathode Ray Tube.

A simplified, two-dimensional drawing of a CRT is shown in Figure 2.25. Electrons are emitted from the heated cathode and are formed into a fine beam and raised to a high velocity by the accelerating electrode assembly. When the electron beam strikes the screen, a small dot of light appears. The color of this light depends on the material used in the screen.

Between the electron "gun" and the screen are two pairs of deflection plates. One pair is for deflecting the electron beam in the horizontal plane and the other set deflects the beam in the vertical plane.

Figure 2.25 Simplified, Two-dimensional Drawing of a CRT.

For a verbal description click here.

If the potential difference between the deflection plates is zero, the beam will fall in the center of the screen. Suppose that we make the top Y deflection plate positive with respect to the bottom one. Since like charges repel and unlike charges attract, the electron beam will be bent upward on its way to the screen and will strike the screen above the center. If the potential is reversed, the beam will be bent downward. The X deflection plates work in the same way to bend the beam in the horizontal plane. The voltage between the deflection plates is quite large, usually about 50 volts to move the dot one inch.

A block diagram of an oscilloscope is shown in Figure 2.26. We will briefly discuss each block. Because we have not yet studied amplifiers, we cannot look at specific circuits in this chapter.

The Vertical Amplifier.

Because of the high voltage required to deflect the electron beam, it is necessary to include an amplifier in an oscilloscope. As shown in the block diagram of Figure 2.26, the amplifier is between the Y input and the Y deflection plates of the CRT. The amplifier includes range switches to permit measurement of voltages from very small (1 millivolt) to somewhat large (100 volts). There is also a control to allow the operator to position the display anywhere on the screen (or even off of it). Some oscilloscopes have switches for reversing the polarity of the signal (turning the display upside down).

The vertical input is not only to look at the pretty picture. It can be used to measure voltage. There is a range switch which is calibrated in volts per division on the screen. This allows the oscilloscope to be used as a voltmeter to measure unknown voltages.

The Time Base.

In order to plot voltage versus time (which is what an oscilloscope does best), it is necessary to move the dot of light across the screen at a constant velocity. This is done by placing a ramp voltage on the horizontal deflection plates. A ramp voltage is one which is increasing at a constant rate and would have the equation V = Kt where K is a constant. Plotted versus time, such a voltage will be a straight upward-sloping line. The time base is often called the "sweep" because the electron beam is swept across the screen. The sweep is calibrated in time per division on the scope screen and a switch selects the various sweep rates.

The dot of light begins at the left edge of the screen and is swept across to the right edge. Before the sweep is returned to its starting point, the electron beam is turned off to darken the dot so that the return sweep will not be visible and confuse the operator. The beam retraces to the left hand edge of the screen in a small fraction of the time required to sweep from left to right. Upon reaching the left edge of the screen, the electron beam is turned on again and the dot begins another trip across the screen.

Figure 2.26 Block Diagram of an Oscilloscope.

For a verbal description click here.

Triggered Sweep.

The beam does not begin another trip across the screen immediately; it waits until some triggering event has occurred. The beam is kept dark until it is triggered. When triggered, it is turned on and begins another trip across the screen. The wave on the Y axis is, in most cases, what triggers the sweep to begin.

Because the sweep begins at the same point on the wave every time it repeats, successive sweeps fall exactly on top of each other and what the user sees is a stable display.

The Power Supply.

The power supply provides high voltage to the CRT to accelerate the electrons to a high enough velocity to make the screen glow. It also supplies operating voltages to all of the circuits in the oscilloscope. There are no operator adjustments in the power supply (unless you count the ON OFF switch).

Reading the Oscilloscope.

There are lines etched on the inside of the CRT screen which divide the screen into squares which are one centimeter on a side. The squares are further divided into 0.2 cm by small hash-marks. For some reason, oscilloscope manufacturers no longer call a cm a cm. They now call it a div for division.

The range switch of the voltmeter section is usually called the "volts/div" switch. To read the voltage being measured by an oscilloscope it is necessary to read the height of the wave on the screen (in div) and multiply it by the setting of the range switch.

Example 2.24.

A wave on the screen of an oscilloscope has a vertical distance between its positive and negative peaks of 5.35 div. The range switch is set to 0.2 volts/div. What is the peak-to-peak voltage of the wave?

Solution:

The peak-to-peak voltage usually written as the P-P voltage is the product of the peak-to-peak distance and the range switch setting. The P-P voltage is 5.35 div x 0.2 v/div = 1.07 volts.

The horizontal axis of an oscilloscope is actually a time interval meter. The range switch for the time interval meter is the time/div or sec/div (seconds per division) control. To make a time interval measurement it is necessary to multiply the horizontal distance between the two points by the setting of the sec/div switch.

Example 2.25.

The width of a pulse on the screen of an oscilloscope is 7.3 div and the sec/div switch is set to 5 us/div. What is the width of the pulse in units of time?

Solution:

The pulse-width is 7.3 div x 5 us/div = 36.5 us.

Example 2.26.

Eight cycles of a sine wave cover 4.45 divisions on the screen of an oscilloscope and the sweep range is set to 0.5 us/div. What is the frequency of the sine wave?

Solution:

The sweep range is just another name for the sec/div switch. The frequency is in hertz, which is cycles/sec.

f = 8 cycles / (4.45 div x 0.5 us/div) = 3.60 MHz.

The Times Ten Probe.

The input impedance of an oscilloscope is rather low as voltmeters go. A typical value is 1 M ohms of resistance in parallel with 50 pf of capacitance. For most measurements the resistance needs to be higher and the capacitance lower than the input impedance as stated.

Higher resistance and lower capacitance can be obtained by using a special probe with the scope. The input end of the probe contains a 9 M ohms resistor in parallel with a 50/9 pf capacitor. The 9 M ohms resistor in conjunction with the 1 M ohms resistance of the scope input will give a total input resistance of 10 M ohms but it will attenuate DC and low frequency input signals by a factor of ten. The capacitor in the probe must have an XC which is 9 times that of the XC of the input capacitance of the scope so that high frequencies are also attenuated by a factor of ten. The capacitor in the probe is adjustable and the probe should be "calibrated" before it is used.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

2.13 Problems.

  1. What is the period of an AC signal which has a frequency of 2175 hertz?

  2. An oscilloscope measurement shows a wave to have a period of 2.2 us. What is its frequency?

  3. What is the wavelength in meters of a radio wave whose frequency is 162.25 MHz?

  4. What is the frequency of a 75 meter long radio wave?

  5. What is the angular frequency of the 60 hertz line?

  6. What are (a) the peak and (b) the peak-to-peak voltages of the 120 volt AC line?

  7. An oscilloscope measurement shows an AC sine wave to have a peak-to-peak value of 9.5 volts. What is its RMS voltage?

  8. What is the reactance of a 470 uf capacitor at a frequency of 120 hertz?

  9. What size capacitor is required to have a reactance of 1 ohm at a frequency of 60 hertz?

  10. If a 100 uf capacitor is connected across a 10 volt 400 hertz AC source, how much power is dissipated by the capacitor.

  11. What is the reactance of a 2.5 mH coil at a frequency of 455 kHz?

  12. How much inductance is required to have a reactance of 1000 ohms at a frequency of 1000 hertz?

  13. In a series RC circuit the voltage across the resistor is 4.4 volts and the voltage across the capacitor is 3.5 volts. The resistance of the resistor is 560 ohms and the frequency is 60 hertz. (a) What is the reactance of the capacitor? (b) What is the capacitance of the capacitor? (c) What is the magnitude of the generator voltage? (d) If the phase angle of the resistor voltage is taken as zero degrees, what is the phase angle of the capacitor voltage? (e) What is the phase angle of the circuit current? (f) What is the phase angle of the generator voltage?

  14. A series RLC circuit is connected across a generator whose frequency is 100 kHz. The resistor is 100 ohms, the inductor is 5 mH and the capacitor is 390 pf. What are the magnitude and phase angle of the impedance?

  15. An RC high-pass filter uses a .01 uf capacitor and a 15 k ohms resistor. What is the attenuation ratio of this filter at frequencies of (a) 10 hertz, (b) 1 kHz and (c) 100 kHz?

  16. An RC low-pass filter is to use a 1 M ohms resistor. Select the capacitor for an attenuation of 50 dB at 60 hertz.

  17. Convert the following attenuation ratios to dB: (a) 0.707, (b) 0.316, (c) 0.178 and (d) 0.0316.

  18. Convert the following gain figures to dB: (a) 1, (b) 2, (c) 3.16 and (d) 17.78.

  19. Obtain a piece of semi-log graph paper and plot the frequency response data given below. See also problem 20 below.

    Frequency, Hz | dB | Frequency, Hz | dB | Frequency, Hz | dB
    1.00 Hz | -40.0 | 1,000 | -0.1 | 1,000,000 | -40.0
    1.78 -35.0 1,778 -0.1 --- ---
    3.16 -30.0 3,162 -0.4 --- ---
    5.62 -25.0 5,623 -1.2 --- ---
    10.00 -20.0 10,000 -3.0 --- ---
    17.78 -15.1 17,780 -6.2 --- ---
    31.62 -10.4 31,620 -10.4 --- ---
    56.23 -6.2 56,230 -15.1 --- ---
    100.0 -3.0 100,000 -20.0 --- ---
    177.8 -1.2 177,800 -25.0 --- ---
    316.2 -0.4 316,200 -30.0 --- ---
    562.3 -0.1 562,300 -35.0 --- ---

  20. As an alternative to problem 19, if you cannot find a piece of 6 cycle semi-log graph paper, try this. Take the common log of each frequency. Plot dB versus log of frequency on linear paper. BUT LABEL THE HORIZONTAL AXIS OF THE GRAPH WITH FREQUENCY NOT LOG OF FREQUENCY!

  21. As a more modern alternative, enter the above data into a program that will draw a graph on the computer screen or printout. Be sure to select log for the horizontal axis.

  22. A square wave has a peak voltage V of 25 volts. What are the peak values of: (a) the fundamental frequency; (b) the 9th harmonic; (c) the 50th harmonic; and (d) the 99th harmonic?

  23. A square wave has a peak-to-peak voltage of 266.6 volts and a frequency of 60 hertz. What is the RMS voltage of: (a) the fundamental frequency and (b) the frequency and RMS amplitude of the harmonic which falls immediately below 10 kHz?

  24. What circuit would you use to convert a 60 Hz square wave into a series of narrow pulses? Draw the circuit and give one of its proper names. It is not necessary to give component values.

  25. If you apply an AC plus DC voltage wave of the type VDC + VAC sin( wt ) to an integrating network which has a time constant much longer than the period of the sine wave, what will the output mainly consist of?

  26. A series resonate circuit is made up of a 2.5 mH inductor, a 48.9 pf capacitor and a 100 ohms resistor. What is: (a) the resonant frequency of this circuit? (b) the Q of the circuit? And (c) the 3 dB bandwidth of the circuit?

  27. In the circuit of question 26 the bandwidth is too narrow and must be increased to 30 kHz. This can be done by adding resistance to the circuit. If a resistor is added to increase the bandwidth to 30 kHz, (a) what is the new value of Q and (b) how much resistance must be ADDED to the circuit?

  28. A variable inductor which is used in the laboratory has a nominal resistance of 40 ohms at a frequency of 1 kHz. What is the Q of this inductor at this frequency for inductance settings of (a) 5 mH and (b) 50 mH?

  29. An all-electric home is drawing a current of 65 amperes at a voltage of 240 volts. What is the current on the primary side of the supply transformer if the voltage is 9200 volts?

  30. A certain transformer has a 120 volt primary and a 40 volt secondary which is rated at 2.5 amperes maximum. What is the minimum size fuse which should be used in the primary to protect this transformer from over-Load?

  31. A triangular wave is displayed on the screen of an oscilloscope. Points are given on the screen using Cartesian coordinates with the point (0,0) at the left side of the screen and centered top to bottom. The first positive peak of the wave is at (1.2,4.3), the first negative peak is at (3.9,-4.9), the second positive peak is at (6.6,4.3) and the second negative peak is at (9.3,-4.9). (a) If the voltage range is set to 20 mv/div, what is the P-P voltage? (b) If the sweep range is set to 50 us/div, what is the frequency of the wave?

  32. In question 31 if a times ten probe is being used, what are (a) the P-P voltage and (b) the frequency?

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

2.14 Answers to Problems.

  1. 460 microseconds.

  2. 455 kHz.

  3. 1.14 meters.

  4. 4.00 MHz.

  5. 377 radians per second.

  6. (a) 169.7 v, (b) 339.4 v.

  7. 6.72 v.

  8. 2.82 ohms.

  9. 2,650 microfarads.

  10. Trick question. The answer is the big zero.

  11. 7.15 k ohms.

  12. 159 millihenrys.

  13. (a) 445 ohms, (b) 5.95 microfarads, (c) 5.62 volts, (d) -90 degrees, (e) 0 degrees, (f) -38.5 degrees.

  14. 945 / -83.9 degrees.

  15. (a) 9.42 x 10-3, (b) 0.686, (c) 1.00.

  16. 0.839 microfarads.

  17. (a) -3.01, (b) -10, (c) -15.0, (d) -30.

  18. (a) 0, (b) 6.02, (c) 9.99, (d) 25.0.

  19. Whether you use semi-log graph paper,

  20. Liner graph paper, or

  21. a computer program the graph you get should look like this.

    For a verbal description click here.

  22. (a) 31.83 v, (b) 3.537 v, (c) 0 v, (d) 0.3125 v.

  23. (a) 120.0 v, (b) 0.7273 v and 9,900 Hz.

  24. High-Pass Filter. Differentiating Network.

    For a verbal description click here.

  25. All of the DC, very little AC.

  26. (a) 455.2 kHz. (b) 71.5. (c) 6.366 kHz.

  27. (a) 15.18. (b) 138.3 ohms.

  28. (a) 0.7854, (b) 7.854.

  29. 1.696 Amps.

  30. 0.8333 Amps.

  31. (a) 0.184 volts. (b) 3.704 kHz.

  32. (a) 1.84 volts. (b) 3.704 kHz.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

This page copyright © Max Robinson. All rights reserved.


Chapter 3   DC Power Supply Circuits.

3.1  Block Diagram of a Power Supply.
3.2  Protection Devices.
3.3  The Power Transformer.
3.4  The Semiconductor Diode.
3.4A The Vacuum Diode.
3.5  Rectifier Circuits.
3.6  Filtering the Rectifier's Output.
3.7  The Zener Diode Voltage Regulator.
3.8  Integrated Circuit Voltage Regulators.
3.9  Problems.
3.10 Answers to Problems.

Chapter 3.

DC Power Supply Circuits.

Most of today's electronic circuits operate from comparatively low DC voltages (5 to 15 volts). The Electric Utility supplies 120 volts AC. We have studied transformers and, therefore, we know that the 120 vAC line voltage could be stepped down to the range of 5 to 15 volts but it would still be AC. The internal circuits of any device you can think of from a stereo receiver to an oscilloscope will not operate on AC. These devices must have internal circuits which change the AC to DC. Such a circuit is called a "DC power supply" or more often just "power supply".

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

3.1 Block Diagram of a Power Supply.

Block diagram.

Figure 3.1 Block diagram of a power supply.

For a verbal description click here.

Figure 3.1 shows the block diagram of a modern low-voltage regulated DC power supply. Each block has a specific purpose and will be dealt with in individual sections of this chapter.

The power supply is connected to the 120 vAC power line by a plug. Many power supplies (those used in laboratory equipment) have a plug with a third wire which connects the metal chassis of the instrument to earth ground. The fuse and switch constitute the protection circuits. The fuse helps to protect the power supply against circuit component failures and mistaken connections. The switch permits the power supply to be turned on and off. The transformer steps the 120 volts of the AC line down to the value required by the devices being powered. The rectifier changes the AC from the transformer to pulsating DC. The filter reduces the magnitude of the pulsations and smoothes out the DC. The regulator reduces the pulsations to a very small value and also holds the output voltage constant regardless of the load current. The regulator also contains circuits which will shut down the power supply if the load current becomes too large or the temperature of the regulator becomes too high.

If the power supply is part of something else, such as an oscilloscope, an FM tuner, or an amplifier the output of the power supply is delivered to the internal circuits of the instrument and is not available to the operator. If the power supply is a laboratory bench power supply, its output is connected to binding posts on the supply's front panel for the purpose of powering experimental circuits. A laboratory bench power supply may also include a voltmeter and an ammeter to permit the operator to monitor the voltage and current which are supplied to the load.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

3.2 Protection Devices.

All power supplies require protection from overloads and internal circuit faults. The most obvious protection device is a fuse. The type of fuse most commonly used in electronics equipment is a fine metal wire contained in a small glass tube with a metal cap on each end for electrical connection. The wire is made of a metal alloy with a low melting temperature, such as solder (40% led and 60% tin). If excessive current flows through the fuse the thin metal wire will melt, opening the circuit and turning off the current. Fuses of the type described above are manufactured in current ratings from 1/200 ampere to 30 amperes.

Fuses are often placed in the primary circuit of the transformer. If a transformer develops an internal fault it can catch fire if the power is not shut off by an open fuse. There should always be a fuse in the primary of a power transformer. Many low-cost "wall transformers" do not have fuses in their primary circuits. These units present a constant fire hazard to any building in which they are used.

There are two types of fuses, fast-acting and time delay. Time delay fuses are often called slow-blow fuses. Power supplies which have very large filter capacitors and semiconductor rectifiers will draw a very large current for a very short time after being turned on. Have you ever noticed a flicker of the lights when you turn on a transistorized stereo receiver? You are seeing the effect of a large current pulse which is charging up the capacitors in the power supply. A fast-acting fuse would most likely blow out the moment the power switch was thrown. A slow-blow fuse is used in such a case. Slow-blow fuses are used only if there is a large current pulse at the time of turn-on.

When selecting the current rating of the fuse, measure the current drawn by the device under normal operation and multiply this figure by 2. A smaller fuse than this will tend to burn out when nothing is wrong.

Other protection devices are electro-mechanical circuit breakers. A circuit breaker may use a thermal sensor to detect the heating in a small wire or the current may be detected by allowing it to flow through a coil of wire and become an electromagnet. If the temperature of the wire gets too high or the electromagnet becomes too strong, the circuit breaker will "pop out" and the circuit will be opened. The advantage of a circuit breaker is that it can be reset instead of having to be replaced, as do fuses. The major disadvantage of circuit breakers is that they are more expensive, more complex, larger and heavier than fuses. As current gets smaller, the circuit breakers get larger and more complex. Circuit breakers are usually not used for currents below 1 ampere.

In a sense the on-off switch may be considered as a protection device. If the operator smells something burning, he can use the switch to turn the power off. In a few cases a circuit breaker may serve double duty as an on-off switch. Most circuit breakers are not designed for repeated on-off cycles and will quickly wear out if used as on-off switches.

Most instruments include a small light which glows when the power is on and goes out when the power switch is turned off or the fuse blows.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

3.3 The Power Transformer.

A power transformer may have a secondary winding with a center tap, as shown in Figure 3.2a, or more than one secondary winding, as shown in Figure 3.2b.

Schematic diagram.

Figure 3.2 Two types of transformers.

For a verbal description click here.

For a detailed discussion of transformers refer back to Chapter 2 of this book.

If you look in a catalog listing power transformers you will not find "turns ratio" mentioned even once. The specifications of power transformers are written in terms of primary and secondary voltages and maximum secondary current. You may read the following specification, "Primary, 117 vAC 50 - 60 Hz. Secondary, 24 vCT @ 1 A." The translation of this is "The transformer will operate on 117 volts ±10% at a line frequency of 50 or 60 Hz. If you apply 117 volts to the primary the voltage across the entire secondary will be 24 volts if the secondary current is 1 ampere. The maximum current which can safely be drawn from the entire secondary is 1 ampere." If this current is exceeded the transformer is in danger of burning out due to over heating.

Example 3.1

A transformer has the following specification: "Primary, 117 vAC 60 Hz. Secondary, 32 vCT @ 1.5 A." If the primary is connected to a source of 120 vAC, what voltage is measured from one side of the secondary to its center-tap?

Solution:

The ratio of secondary to primary voltage is a constant. 32 / 117 = V / 120. V = 32.82 v. The voltage measured from one side of the secondary to the center-tap is 1/2 that of the whole secondary or 16.41 v.

Occasionally, transformer manufacturers specify center-tapped secondaries in a slightly different manner. The transformer would be specified as follows: "Primary, 117 vAC 60 Hz. Secondary, 25 - 0 - 25 vAC @ 500 milliamperes." This means there are 25 volts from each side of the secondary to the center-tap or 50 volts across the entire secondary. The current rating is given for a type of rectifier known as a full-wave center-tapped rectifier, the two halves of the secondary are effectively in parallel and the current is doubled. Transformers used with vacuum tubes are more likely to be specified in this way because they are most likely to be used with a full-wave center-tapped rectifier.

Electrical Isolation.

It is possible to design equipment which can cope with the full voltage of the AC power line, thus eliminating the need for a transformer. However, transformers serve another purpose as important as changing the voltage. That purpose is to provide isolation of the circuit from the power line.

The argument might be made that one side of the 120 vAC line is connected to earth ground and no isolation is necessary. If a wiring error caused the leads to be reversed, the chassis of the instrument would be at a potential of 120 v with respect to earth ground. Such a wiring error did occur at the university I recently retired from. No one was injured but there was some soiled armor. It could be most unhealthy for anyone who might be unlucky enough to complete the circuit to ground.

In addition to safety considerations there are other reasons for not wanting a piece of equipment to be connected to the power line ground. The chief reason is noise. Noise is any electrical voltage or current in a place where it is not wanted. Noise voltages and currents are the weeds of electronics. In addition to bringing us the electric power we need, the power line brings us a lot of noise. One of the most effective noise removers is a transformer. The noise on a power line often has the same phase on both wires and, therefore, will not produce a magnetic field in the primary winding of a transformer. This is called common mode noise and will be discussed in more detail in the section on differential amplifiers.

In laboratories, recording studios, and radio stations, many different pieces of equipment are connected to work together. If each piece of equipment has its own earth ground and is connected to another piece of equipment, a phenomenon known as "ground-loop noise" appears. There are two possible solutions to this problem. One is to connect each piece of equipment to earth ground and make sure there is no electrical ground connection between individual pieces of equipment. The other is to connect only one piece of equipment to earth ground and make sure that there is only one ground wire from that piece to each of the other pieces of equipment in the setup. The isolation provided by the power transformer is absolutely vital to this "single point" grounding system.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

3.4 Semiconductor Diodes.

Before we can discuss rectifier circuits it is necessary to understand the semiconductor diode. An ideal diode is a device which will conduct current in one direction only. When current flows in the forward direction, the resistance of the diode is zero, the voltage drop is zero. When current attempts to flow in the reverse direction it encounters an infinite resistance. Absolutely no current will flow and the voltage can build up to any value demanded by the circuit. As with all other ideal things, the ideal diode does not exist in the real world but real diodes come close enough to be most useful.

Unfortunately, there is insufficient space here to cover the physics of semiconductors in detail. Whole books 1 have been devoted to this topic and there is a course in this department entitled "Solid State Physics" which interested students should enroll in. Meanwhile, we can only scratch the surface. Emphasis will be placed on visualization of the physical processes which are taking place.

1   Semiconductor Devices and Applications
    by R. A. Greiner McGraw-Hill 1961

A Semiconductor Is a Semiconductor Is a Semiconductor.

A semiconductor is not a very good conductor nor is it a very good insulator. It is a semiconductor. Two examples of semiconductor material are silicon and germanium.

Silicon and germanium each have 4 valance electrons in an outer shell which has room for 8 electrons. These elements (and carbon as well) form very stable tetrahedral crystals with the shared valance electrons filling the outer electron shell of each atom. If every electron stayed in place within the crystal lattice the crystal would be a perfect insulator. The electrons do not stay home.

Graph.

Figure 3.3 Energy Diagram of a Semiconductor Material.

For a verbal description click here.

Figure 3.3 shows the possible energy levels for the electrons in a semiconductor crystal. When the electrons have a low energy level, they are in the valence energy band. Electrons which fall within this energy band will be bound to their particular valence bond. If an electron is given enough energy to jump over the forbidden energy band and enter the conduction band, it is set free from the valence bond and can move through the crystal.

The width of the forbidden band is called the band-gap energy. The band-gap energy for silicon at room temperature (300 degrees K) is 1.106 electron-volts (ev) and for germanium it is 0.67 ev. At room temperature there is enough thermal energy in the crystal lattice to promote some electrons to the conduction band.

Holes and Electrons.

Electrons which are in place in the lattice are in the valence energy band. Due to normal thermal agitation an electron can gain enough energy to move into the conduction band and leave its place in the lattice to become a conduction electron. An electron which has been promoted into the conduction energy band is free to move through the crystal under the influence of an electric field. But there is more to conduction in a semiconductor than conduction electrons.

When an electron leaves its place in the crystal lattice it leaves behind a hole in the lattice. Strange as it may seem, the hole does not stay in place but moves as if it were a positively charged particle. It has energy and even momentum. A hole can move by a nearby valence electron jumping from its place in the crystal lattice to the hole without entering the conduction energy band. After the electron has jumped, it leaves a hole where it used to be. Thus, the hole can move through the crystal lattice.

Thermal energy in the crystal lattice creates hole- electron pairs which move through the crystal. If there is an electric field present, the electrons will move toward the positively charged region and the holes will move toward the negatively charged region. If there is no electric field present, the holes and electrons will move randomly.

If you visualize a crystal of silicon warming up from absolute zero, hole-electron pairs will begin to form. This process cannot continue indefinitely or the crystal would come apart because all of its valence bonds would be broken. When holes and conduction electrons (electrons not held in a valance bond) become plentiful enough, electrons will begin to fall into holes they happen to run into. This process is called recombination and goes on at the same rate as hole- electron pair formation. The equilibrium between pair formation and recombination causes silicon and germanium crystals to be semiconductors at room temperature.

In pure semiconductor material the concentration of holes is the same as the concentration of electrons in the conduction band. (The total number of electrons cannot change, what we mean when we talk about changing the concentration of electrons, is the number of electrons which are free for conduction.) In pure silicon or germanium

Ne = Nh = KS T(3/2)           (3.1)

where Nh is the concentration of holes, Ne is the concentration of electrons in the conduction band, KS is a constant which must be determined experimentally and T is the Kelvin temperature. The value of KS is 4.74 x 1022 for silicon and 1.76 x 1022 for germanium. Ne and Nh have units of 1/m2.

We may now define the intrinsic charge carrier concentration ni as

Ni = KS T(3/2)           (3.2)

Equations 3.1 and 3.2 say that the charge carrier concentration is quite temperature dependent. Equation 3.2 defines the pure semiconductor or intrinsic charge carrier concentration.

Changing the Relative Concentration of Holes and Electrons.

Now suppose that we deliberately add some impurities to a crystal of pure semiconductor such as silicon. We are not going to just throw in some dirt from the floor; we will carefully control what goes in and how much.

If we add an element from group 5 in the periodic table the effect on a semiconductor is striking. The elements from group 5 have five electrons in the outer shell. Wherever one of these atoms appears in the crystal lattice, four of its outer electrons go into valence bonds and the fifth one becomes very loosely bound to its atom. A very small amount of energy (about 0.05 ev) is needed to promote this electron into the conduction band. Such an impurity is called a donor impurity because each atom donates an electron to the conduction energy band.

If we go back to pure silicon and add an element from group 3 in the periodic table the effect on a semiconductor is opposite to that for an element from group 5. The elements from group 3 have three electrons in the outer shell. Wherever one of these atoms appears in the crystal lattice, there are only three electrons in the outer shell to go into valence bonds. The unfilled valence bond is a hole. Once a wandering electron has fallen into this hole, a comparatively large amount of energy is required to promote that particular electron back into the conduction energy band. That electron and its three companions will remain in place and a hole will have been set free to wander through the crystal lattice. Such an impurity is called an acceptor impurity because each atom accepts an electron from the conduction energy band and causes a conduction hole to be created.

When a donor impurity loses its loosely-bound electron or an acceptor impurity captures a wandering electron (loses its loosely-bound hole), the impurity atom is said to be ionized. Ionization in a solid means the same thing it means in a liquid or gas, the loss of, or gain of an extra electron. When an impurity is added to a semiconductor, most of the impurity atoms are ionized most of the time, statistically speaking.

Because the impurity atoms are virtually 100 percent ionized, for every atom of donor impurity there is an additional electron in the conduction band. For every acceptor atom added, there is an additional conduction hole in the crystal. The meaning in this discussion is that donor impurity is added to one piece of semiconductor and acceptor impurity is added to another piece of semiconductor.

Recombinations occur when wandering holes and wandering electrons happen to collide. The probability of collisions goes up as the concentration of either holes or electrons goes up. When, for example, a donor impurity is added to a semiconductor, the increased concentration of electrons causes more frequent collisions and a higher rate of recombination. The recombination rate falls again when the hole concentration has been reduced to the point where a new equilibrium has been established. The end result is to decrease the concentration of holes in the crystal. It can be shown mathematically, in about ten pages, note 1, that

Ne Nh = ni2           (3.3)

where Nh is the concentration of holes, Ne is the concentration of electrons and ni is as defined in equation 3.2. Because the impurity atoms are completely ionized, the concentration of electrons is equal to the concentration of donor atoms Ne = Nd and for acceptor impurity Nh = Na where Nd and Na are the concentrations of donor and acceptor impurity atoms respectively. Thus it is possible to write for a semiconductor which has been "doped" with a donor impurity

Ne = Nd     and     Nh = ni2 / Nd           (3.4)

and for a semiconductor "doped" with an acceptor impurity

Nh = Na     and     Ne = ni2 / Na           (3.5)

Some Terms to Be Remembered.

As you may have guessed the process of adding impurity atoms to a semiconductor crystal is called doping. A semiconductor which has been doped with a donor impurity has many more negative charge carriers than positive charge carriers. This is known as N (negative) type semiconductor. A semiconductor which has been doped with an acceptor impurity has many more positive charge carriers than negative charge carriers. This is known as P (positive) type semiconductor.

There are two types of charge carriers, holes and electrons. A majority carrier is the type of carrier which there are more of in a particular type (P or N) of semiconductor. A minority carrier is the type of carrier which there are fewer of in a particular type (P or N) of semiconductor.

Example 3.2

Identify each of the following as majority or minority carriers: (a) electrons in N type semiconductor, (b) holes in P type semiconductor, (c) electrons in P type semiconductor and (d) holes in N type semiconductor.

Solution:

The majority carriers have the same charge polarity as the type of semiconductor in which they are found. The one which is left is the minority carrier. Thus, (a) majority, (b) majority, (c) minority and (d) minority.

The P-N Junction

Figure 3.4a shows a schematic representation of two blocks of semiconductor material. The block on the left is N type and the dots represent conduction electrons. The block on the right is P type and the circles represent the conduction holes. The concentration of minority carriers is so small as to be negligible at room temperature. In Figure 3.4b the two blocks of semiconductor material have been placed in physical contact. * As soon as contact has been established, the normal wanderings of charge carriers due to thermal agitation will cause some charge carriers to cross the junction. As soon as a carrier crosses the junction it

Drawing and graph.

Figure 3.4 "Making" a P-N Junction Diode

For a verbal description click here.

becomes a minority carrier. The probability of colliding with a carrier of opposite sign is very high and the wanderer will soon disappear by recombination with a carrier of opposite sign. There is a net movement of charge across the junction with electrons moving to the right and holes moving to the left. The departed electrons on the left leave behind the ionized donor impurity atoms which have a positive charge. The departed holes on the right leave behind the ionized acceptor impurity atoms which have a negative charge. That places an electric field across the junction, which is positive on the left and negative on the right. This electric field eventually builds up to such a value as to prevent any more electrons from moving to the right or holes from moving to the left across the junction. The graph in Figure 3.4b indicates the electric potential within the block of semiconductor material. The electric potential comes to zero at each end of the block; if it did not, we would have a cheap source of electricity.

*   This is not how P-N junction diodes are manufactured.
    In fact, this could not even be done in the laboratory.
    This is merely a thought experiment which illustrates
    how the depletion region and contact potentials are
    formed in a P-N junction.

The region near the junction becomes depleted of charge carriers in the conduction band. As stated above, there are ions in the depletion region but these ions are held in the crystal lattice and are not in the conduction energy band. The depletion region constitutes an insulator and the regions on either side of the depletion region which are not depleted of charge are conducting regions. This concept is very important. Failure to understand the depletion region will result in failure to understand how P-N junctions conduct in only one direction.

Animation, which is not possible in a paper book could not be done in any medium when I was teaching this subject. We have sure come a long way baby.

Animation.

Figure 3.4c Animation showing Figure 3.4a and 3.4b in action.

For a verbal description click here.

When the two pieces of semiconductor touch, the electrons from the N side and the holes from the P side start to randomly wander across the junction. The animation shows holes and electrons making a beeline toward their opposite number on the other side. Randomness is much harder to do in animation so the much easier straight line path was taken. It cannot be over emphasized that when electrons and holes meet and mutually annihilate, nothing is being destroyed. The electrons remain in existence but their energy level has been reduced so they are no longer in the conduction energy band. The electron filled a hole so it no longer exists but it was never their in the first place.

Schematic diagram.

Figure 3.5 Reversed and Forward Biased P-N Junction

For a verbal description click here.

Figure 3.5a shows a P-N junction with an external battery connected in such a polarity as to increase the potential across the junction. The effect of this is to increase the width of the depletion region and increase the potential across the junction. Notice that the positive terminal of the battery is connected to the N type semiconductor and the negative terminal of the battery is connected to the P type semiconductor. This condition is known as reverse bias. Under normal conditions no appreciable current will flow through a reversed biased P-N junction. It is true that minority carriers on the left (holes) are moving to the right across the junction and minority carriers on the right (electrons) are moving to the left across the junction. In modern P-N junction diodes this minority carrier current is so small that an electrometer is required to measure it.

Animation of figure 3.5a

Figure 3.5d Figure 3.5a in action.

For a verbal description click here.

In the animation it appears that the electrons on the left and the holes on the right are being absorbed by the end lines. On the left the electrons are being absorbed into the copper wire that makes contact with the semiconductor and sucked into the positive terminal of the battery. On the right there are electrons coming from the negative terminal of the battery and fed into the semiconductor. At the point of contact between the semiconductor and copper, electrons are combining with holes. The current will flow only when the voltage is changing. This is like a capacitance and is called the "charge storage capacitance", or "charge storage effect", of the diode.

The depletion region constitutes an insulator and the regions where there are charge carriers in the conduction energy band are conductors. This forms a capacitor. As the voltage changes the width of the depletion region changes, changing the amount of capacitance. Any P-N junction will show varying amounts of capacitance as the reverse voltage is changed. In rectifiers and small switching diodes this is only a few picofarads. Special diodes are available that have enhanced capacitance and are known as variable capacitance diodes or varicaps for short.

Figure 3.5b shows a P-N junction which is slightly forward biased. The first few tenths of a volt only serve to reduce the potential gradient across the junction and no conduction results. In Figure 3.5c the forward bias has been increased to the point where the contact potential has been overcome. The width of the depletion region has been reduced to zero, and current now flows in the forward direction. Notice that the positive terminal of the battery is connected to the P type semiconductor and the negative terminal of the battery is connected to the N type semiconductor. This condition is known as forward bias.

Forward biased animation.

Figure 3.5e Figures 3.5b and c in action.

For a verbal description click here.

A forward biased P-N junction will conduct large amounts of current at a voltage drop of less than one volt. As the current is increased in the forward direction, the voltage increases logarithmically as shown in Figure 3.6.

Graph of voltage versus current.

Figure 3.6 Voltage Versus Current Curve of a P-N Junction

For a verbal description click here.

The reverse bias on a P-N junction cannot build up to infinity. As the reverse bias voltage is increased, the electric field across the junction becomes so great as to rip electrons out of their valence bonds. The electric field imparts enough energy to valence electrons to promote them to the conduction energy band. The result is that we have a new source of conduction electrons. The newly freed electrons are accelerated to a high velocity and when they collide with other valence electrons, these valence electrons are also promoted to the conduction energy band. The current rises to a very large value and the voltage cannot rise any further. This condition is called avalanche breakdown but is sometimes mistakenly called Zener breakdown. Zener breakdown will be covered in a later section. Avalanche breakdown places a practical limit on how much voltage a P-N junction diode can withstand in the reverse biased direction.

A Derivation.

Get in touch with your inner physicist.

In the discussion above it was said that electrons from the N side of the junction will move towards the P side of the junction. We will call this current INN(0). The first subscript gives the polarity of the charge carrier and the second gives the type of semiconductor where the charge carrier originated. The "(0)" means with zero external bias applied. It can be shown that (note 1)

INN = INN(0) e-(eVd/kT)           (3.6)

and

IPP = IPP(0) e-(eVd/kT)           (3.7)

Under zero bias conditions there can be no net flow of holes or electrons across the junction; therefore,

INN = INP     and     IPP = IPN

That is to say there is an equilibrium of charge carriers so that the number of minority electrons crossing from P to N is equal to the number of majority electrons crossing from N to P. The same goes for holes. This means that

INP(0) = INN(0) e-(eVd/kT)           (3.8)

And

IPN(0) = IPP(0) e-(eVd/kT)           (3.9)

The "e" in the exponent is the charge on the electron, Vd is the diffusion voltage, k is Boltzmann's constant and T is the Kelvin temperature. If an external bias Vj is applied, these equations become

INN = INN(0) e-e(Vd-Vj)/kT           (3.10)

And

IPP = IPP(0) e-e(Vd-Vj)/kT           (3.11)

With an external bias applied the total junction current is

IJ = holes from P to N + electrons from N to P

IJ = (INN + IPP) e-e(Vd-Vj)/kT - IPN(0) - INP(0)           (3.12)

Combining this equation with equations 3.8 and 3.9 we have

IJ = ( INP(0) + IPN(0) ) (eeVj/kT - 1)           (3.13)

If we let IO = INP(0) + IPN(0) we have

IJ = IO (eeVj/kT - 1)           (3.14)

This is the "diode equation" and its derivation is obligatory in any discussion of semiconductor diodes.

For negative values of Vj (reverse bias) the limiting case is IJ = IO. IO is correctly called the reverse saturation current but is often called the reverse leakage current. For modern silicon P-N junction diodes the value of IO is of the order of 10-12 amperes.

For positive values of Vj the current will rise exponentially. Diodes are never used in circuits where the circuit determines the voltage. Diodes are used in circuits where the circuit sets the current and the diode itself is allowed to set its own voltage drop. With current as the independent variable the voltage rises logarithmically and will easily stay within realistic bounds.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

3.4A Vacuum Diodes.

A Minute Amount of History.

Cold Cathodes.

The very first diodes were made by Crookes. They were glass tubes with a metal electrode in each end and a place to connect a vacuum pump. Crookes didn't remove all the air from the tube. He found that an electric arc could be maintained over a much greater distance if the pressure was reduced to somewhere in the range between 1/10 to 1/100 of atmospheric pressure. He was using voltages of thousands of volts. The only thing distinguishing the anode from the cathode was which was connected to the positive of the voltage source and which to the negative.

Roentgen became curious about what would happen if the pressure was pumped down to as low as possible. He found that the arc stopped, leaving a faint greenish-blue glow. Measurements revealed that some current was flowing through the tube. The florescent material used to make watch dials glow in the dark was known in Roentgen's time and he had some in his laboratory. He happened to notice that this material glowed more brightly when the tube was in operation. He moved it closer to the tube and found that it glowed even brighter. Evidently the sample was in the form of a flat plate. Most likely it was coated on a glass plate like those used for photography in that time. When he interposed his hand between the florescent plate and the tube he probably got the shock, non electrical, of his life. He could see the outlines of the bones in his hand as shadows on the plate. That was the discovery of x-rays.

What was happening was that the strong electric field was pulling electrons out of the metal of the cathode, negative electrode, and they were being accelerated to a very high velocity and then impacting the anode. The incoming electrons had so much energy that they knocked other electrons out of the inner shells in the atoms of the anode metal. These electrons were replaced by electrons from the outer shells falling down to replace them. These large energy transitions caused the atoms to emit electro magnetic radiation of a very short wavelength, namely x-rays.

Hot Cathodes.

About this time Edison found that in a light bulb with two filaments, current would flow if the cold one was made positive with respect to the hot one but not if the polarity was reversed. He saw no use for this effect but noted it as curious.

It didn't take long for Roentgen and friends to put this discovery to use. They surmised correctly that a heated filament could emit electrons better than a cold piece of metal and the hot cathode was born.

Bulbs or Tubes?

All of this was taking place before 1900. You couldn't run down to your local Radio Shack and pick up a tube. If you wanted to experiment you had to make your own. The long slender tubes that were used by chemists were readily available but they couldn't resist pressure differences as well as a sphere. When it comes to blowing a glass bulb, a sphere was easier to form than a thin tube. That's why in those old pictures the devices are usually spherical bulbs rather than tubes. In fact writings from the early years of the 20th century in the united states refer to, what we would call a tube, as a bulb.

The Fleming Valve.

In England Fleming found that a device much like an x-ray tube, only much smaller, could be used to detect radio waves. He visualized it as working like a water valve but for electrons. It was called "The Fleming Valve" and to this day British techies and tinkerers call them electronic valves.

So What's a Diode?

The name diode comes from the Greek for two. Diodes have two elements, a cathode and an anode. The simplest diodes, and in fact the earliest ones, have a cathode which consists of a filament that can be heated to red or even orange hot by passing an electric current through it. The anode is a flat metal plate, often called the plate.

Thermeonic Emission.

Before we can understand thermeonic emission of electrons from a metal surface we need to understand how electrons behave inside a metal. Before we can understand how electrons behave inside a metal we must understand how electrons behave inside a nonmetallic solid. So here we go.

The atomic model proposed by Niels Bore is now considered hopelessly out of date. It is ridiculed by modern physicists but it is still a useful tool in understanding atoms for those who aren't going to get a PhD in the subject. The nucleus of the atom is positively charged and the negatively charged electrons spin around it a bit like the planets around the sun. It's a case of forces in balance like the solar system. The inner electrons are held very tightly and it takes a lot of energy to pull them out of orbit. The outer most are more loosely held and it doesn't take a lot of energy to pull them away from the nucleus.

At this point our solar system model starts to fall apart because an atom has things called shells. There is a maximum number of electrons that can exist in one shell. The innermost shell can hold up to 2 electrons, the second 8, the third 8, the fourth 18, the fifth 18 and the sixth 32. If the outermost shell is completely filled the atom is very unreactive, a kind of loner. These are the inert gases which refuse to form any sort of bonds with any other element. Carbon has its outer shell, which will hold 8 electrons, half filled. When several atoms of carbon get together they form very stable bonds with each other by sharing their outer electrons to make each atom feel as if its outer shell is completely filled. This is how diamonds are formed.

Many compounds are formed by sharing electrons in a partially filled outer shell. These are called covalent compounds. The bonds that hold the molecules together are known as covalent bonds. Some other compounds are formed by one, or sometimes two, electrons jumping from an atom of one element to an atom of another element. For example common table salt, sodium chloride, is formed when atoms of sodium give up the loan electron in their outer shells to an atom of chlorine which needs only one electron to fill its outer shell. The resulting positive and negative ions have a strong attraction for each other. These are known as ionic compounds.

If you could have a single atom of any element in isolation you would find that it takes a certain amount of energy to remove one electron from its outer shell. This energy varies considerably from element to element. Some need very large amounts of energy and others need much less. It always takes some energy to take an electron away from an atom in isolation.

When atoms of the same kind are clustered together, as is always the case, things change. In elements classed as metals the amount of energy required to remove an electron from its atom is zero. That's because the atoms are so close together that the electrons in the outer shells don't know to which atoms they belong. They all just wander around in there, moving randomly. If an electric field is applied externally the electrons will move in the direction the field wants them to and we now have an electric current in the metal. When there is no external field the movement is completely random.

All of these randomly moving electrons don't have the same velocity. There is a statistical value which depends on the temperature but some are faster, some are slower, and a very few are very fast. If one of these high speed electrons comes to the surface of the metal it can pass through the surface and leave the metal behind. If this happens many times the metal will develop a positive charge and subsequent would-be escapees will be attracted back to the surface.

When electrons escape from the surface of a metal it is called electron emission. If we set up a source of EMF and arrange things so the escaped electrons will be collected and the positive charge on the emitting metal is neutralized by the continuous replacement of electrons the process of electron emission will continue until the EMF source is removed. If the emitting metal is at room temperature the process is called cold emission. A very strong electric field is required to produce any significant current from cold emission. That means a high voltage applied between electrodes that are close together.

The piece of metal that is connected to the negative of the EMF and emits the electrons is called the cathode. The one that is connected to the positive and collects the electrons is called the anode. I am told that these names come from the Greek words for up and down but I couldn't begin to tell you which is which. It's all Greek to me.

Edison used to make experimental light bulbs with more than one filament to save work for his glass blowers. As related briefly above he found that conventional current would flow from a cold filament to a hot one but not the other way. This became known as the Edison effect. I don't think the existence of electrons had been recognized at this time. Conventional current flows opposite to electron current. This may well have been one of those serendipitous discoveries that seemed to occur often in early science.

As the temperature of the cathode is increased the electrons get to moving much faster than at room temperature. The likelihood of one having enough velocity to escape from the surface is tremendously increased. Hot emission does not require a strong electric field and will occur even in the absence of one. That can't go on very long because of the positive charge that develops on the cathode but it will build up a considerable space charge in an evacuated chamber. A space charge is a volume that has a lot of electrons floating around in it.

The carbonized filament that Edison used was not a very good emitter of electrons. The later tungsten filaments weren't either. Very early tubes used tungsten because that was all that was known. They glowed as bright as light bulbs. It was soon found that if a little thorium was alloyed with the tungsten the filament didn't need to run as hot and would still emit more electrons per square millimeter of filament surface. These are used to this day in transmitting tubes. They glow about the same color as the upper part of a candle flame.

The most efficient emitter is an oxide coated cathode. The discovery of this process made possible the heater-cathode type of tube. The electrical cathode is a small cylinder with the heater inside and electrically insulated from it. The heater is actually a filament but it is not the electrical cathode of the tube. Providing electrical insulation and thermal conductivity at the same time is not an easy thing to do. (The same battle is still being fought to provide cooling for transistors and microprocessors.) The end result is that the heater must be hotter than the cathode. If the cathode were thoriated, the heater would have to run so hot that it would not last long. In a heater-cathode tube the heater runs about the same temperature as a thoriated tungsten filament. The cathode runs a dull red but you can't see it in most tubes. The 6AS7G/6080WA has a gap in the plate and the grid wires can be seen. The cathode is visible between the grid wires and you need a fairly dark room to see its glow. Electrically separating the cathode from the heater had the effect of making circuits mor simple and meant that AC could be used to heat the tubes without inducing much hum in the signal path.

The hot cathode emits electrons in droves. Many more than are needed. They build up in the volume around the cathode and form a large pool of electrons just waiting for something positive to happen. This pool of electrons is called the space charge. When the anode (plate) is made positive some of the electrons are attracted to it. They impact on it, are absorbed into the metal and electrons flow out of the plate connection into the battery or what ever provided the positive voltage. The other end of the voltage source must be connected back to the cathode in some way.

If the polarity is reversed which makes the plate negative with respect to the cathode the electrons in the space charge are repelled away from the plate and no conduction takes place. The plate is cold and is made of a metal that is a very poor emitter of electrons. The voltages are not nearly as high as those used by Crooks so there is no cold emission from the plate. This makes the diode conduct current in only one direction.

Rectification.

Diodes can only do two basic things. These are 1) generate x-rays, and 2) rectify. Not many of us are interested in generating x-rays so let's talk about rectification.

The Space Charge.

The cathode of a tube is coated with a very special oxide that emits electrons very easily. It can readily be damaged by operating above or below the proper temperature or by being "poisoned" by the residual air in the tube. The space charge serves another vital function. There is no such thing as a perfect vacuum. In fact the space in near earth orbit is a better vacuum than can be made on the surface of earth. Farther out in space the vacuum is even better. What this means is there are lots of air molecules running around inside of a vacuum tube. The space charge protects the cathode from these air molecules. Some of these molecules lose an electron and become positive ions. They are attracted to the negative cathode and if it weren't for the space charge they would impact on the surface of the cathode doing considerable damage. Over time the ability of the cathode to emit electrons would be seriously impaired rendering the tube useless. As these ions run through the space charge they gain electrons from the many collisions and become negative ions. Their direction is reversed turning them away from the delicate cathode.

Indirectly heated cathodes.

Most vacuum tubes have a basically cylindrical configuration. Figure two shows how a filament (directly heated) cathode type diode differs from a heater (indirectly heated) cathode type diode.

Figure 3A.1 Construction of vacuum diodes.

For a verbal description click here.

In the filament type diode the cathode is usually a single wire running down the center of the cylindrical plate. In the heater type diode the filament is called the heater because that is its function. It is surrounded by a material which is an electrical insulator and a thermal conductor. The best known material having those properties is mica although aluminum oxide is most often used between heater and cathode. Outside of the electrical insulator is the cathode which is a cylinder with the special coating on the outside. The reason for having both types of tubes will be explained below.

Rectification.

The most important use of diodes is as a power rectifier. Rectification is the name given to the process of changing AC to DC. The process of detecting a radio signal also involves rectification. However, this process is more often called detection. The term rectification is reserved for power supply usage. Diodes are occasionally used for clamping, preventing a voltage from going above or below a given value, or clipping, preventing an audio signal from exceeding some preset level by knocking off the peaks. But by far the most common use of diodes is as rectifiers. The property of a diode that makes all this possible is its unidirectional conditivity.

Figure 3A.2 Forward and reverse connection of a vacuum diode.

For a verbal description click here.

Figure 3A.3 shows a directly heated cathode, filament, diode connected as a rectifier. As you can see from the wave forms this does not give the steady DC you are used to thinking of. For details about rectification and filtering see other sections of Chapter 3 of this book..

Figure 3A.3 Filament type diode used as a rectifier.

For a verbal description click here.

The entire filament and its supply winding are at a potential of several hundred, or even several thousand, volts above ground. The typical filament supply voltage is 5 volts so the difference has little effect on the operation of the diode. When I was a novice I used to wonder why all that voltage didn't burn out the 5 volt filament. What matters to the filament is the voltage from one end of it to the other end. If one end of the filament is at 350 volts and the other end is at 355 volts the only voltage to effect the filament is the difference of 5 volts. Consider this point carefully. It's VERY important that you understand it. If you don't understand, stop and think about it. Don't go on until you do. If you need to, email a question to me. I am the teacher in this class and answering questions is what I'm here for.

The disadvantage of a filament type rectifier, as compared to an indirectly heated cathode type, is that it requires a separate winding on the transformer or in big transmitters a separate transformer for the filament. The advantage is that the maximum voltage is limited only by the plate to filament insulation within the tube and the insulation in the filament transformer.

Figure 3A.4 Heater type diode used as a rectifier.

For a verbal description click here.

Figure 3A.4 shows an indirectly heated cathode type diode being used as a rectifier. Its heater can, and usually does, operate from the same voltage supply as the rest of the tubes in the device. Note that the heater winding is shown grounded. Also note that there is only one heater winding instead of two as in Figure 3. The insulation between the heater and cathode must withstand the full output voltage of the power supply. The best tube manufacturers were able to do was about 500 volts. Filament type diodes can be used to rectify thousands of volts.

Detection

The tubes used as power supply rectifiers are not the ones you would use for detection of radio waves. In the crystal set described else where on this site you could replace the crystal diode with a small tube such as a 6AL5 or 6H6. These tubes used as detectors may be referred to as thermeonic diodes, Fleming valves, or detector tubes. But whatever they are called they work just the same.

How I got hooked.

My lifelong addiction began, not with the building of a crystal set, but upon seeing an animated film on early TV showing how vacuum tubes worked. In my continuing attempts to pass on my addiction here is an animated picture showing the electrons in a diode serving as a rectifier. The voltmeter on the left is measuring the instantaneous voltage of the AC input to the rectifier. The voltmeter on the right shows the pulsating DC across the load resistor. You can see the electrons in the tube being attracted to the plate when it is positive and being repelled back to the filament when the plate is negative.

Figure 3A.5 animation of a rectifier in action.

For a verbal description click here.

Linearity.

Just as semiconductor diodes are non linear, the same is true of vacuum diodes. I'll spare you the derivation of the equation. Those who are interested are referred to the electrical engineering books used by their forbearers. The equation for the current in a vacuum diode is,

I = 2.335 x 10-6 A V3/2 / d2           (3A.1)

Where V is the voltage between cathode and plate, A is the cathode area, and d is the distance between plate and cathode. The area term is why high current rectifier tubes such as the 5U4 are bigger than RF detector diodes such as the 6AL5.

When a vacuum diode is used as a detector, where linearity is necessary, the current is set to a small enough value so the V term will not become significant compared to the input AC voltage. Below is a plot of this equation were A = 0.001 square meters and d = 0.00125 meters.

Figure 3A.6 I-V Curve of a Fictitious Power Rectifier Tube.

For a verbal description click here.

The values were estimated from a 5U4 and based on tube manual data I think I am in the general ballpark but don't use this curve to predict the behavior of a real 5U4 in a real circuit.

In power supply circuits the nonlinearity doesn't make a bit of difference. The only goal is to allow current to flow in one direction and a bit of nonlinearity doesn't matter.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

3.5 Rectifier Circuits.

A diode, whether vacuum or semiconductor, conducts current in only one direction. At typical current values the forward voltage drop of a semiconductor diode is 0.7 to 1 volt while the drop across a vacuum diode is typically 25 to 150 volts.

This large disparity in forward voltage drop means that a power supply must be designed to use either tube or semiconductor diodes and you can't change later. There are still some of those so called "solid state tube replacements" floating around. DON'T USE THEM! Installing them in existing equipment can result in 100 volts or more of additional B+ and you can do serious damage to what ever you put them in. I have nothing against the use of semiconductor diodes as long as the circuit has been designed for them.

It is the function of a rectifier to change AC to DC. In single phase circuits the rectifier changes the AC to a pulsating DC and some additional circuits are needed to change the pulsating DC to a smooth DC. In this section we will look at a few rectifier circuits.

The schematic symbol for a P-N junction diode is a triangle with a line across its point as shown in Figure 3.7. The triangle is the P side and the line is the N side of the junction. The P side is called the anode and the N side is called the cathode. Conventional current will flow in at the anode and out at the cathode. Current will flow in the direction of the arrow. Current will not flow from cathode to anode. Electron current flows in the opposite direction as conventional current. When current is flowing in the forward direction, the anode is more positive than the cathode by about 0.7 volts. If the cathode is positive with respect to the anode, no measurable current will flow and the voltage can have any value up to the rated maximum PIV (peak inverse voltage) or PRV (peak reverse voltage) of the diode. Typical silicon diodes have PIV ratings in the range of 50 to 1000 volts. Vacuum diodes of the type found in consumer equipment may have PIV ratings from 350 to 1500 volts. Rectifier tubes designed for use in high power transmitters may have PIV ratings in the thousands of volts and maximum currents in Amps.

These drawings are being used because they already exist. When vacuum rectifiers are used the circuits aren't any different. Just substitute a vacuum diode for the semiconductor diode shown and provide power for the filament or heater.

Schematic diagram.

Figure 3.7 Half-wave Rectifier.

For a verbal description click here.

The circuit of a half-wave rectifier is shown in Figure 3.7 above, along with its output waveform. When the top end of the transformer secondary is positive with respect to the bottom end, current will flow from the anode to the cathode of the diode. The forward drop across the diode is small compared to the voltage of the transformer and almost all of the voltage appears across the load resistor. The positive half-cycle appears across the load. When the top end of the transformer secondary is negative with respect to the bottom end, current will not flow through the series combination of the diode and load resistor. If there is no current through the load resistor, there can be no voltage drop across it. The voltage of the transformer secondary is dropped across the diode and does not appear across the load resistor. Thus we have only half of each cycle appearing across the load. This should be called half-cycle rectification but it was named in the early years of electricity (prior to 1920) when people were not as careful with their terminology as we are today. The process which is going on in Figure 3.7 is called half-wave rectification and the circuit is called a half-wave rectifier.

Schematic diagram.

Figure 3.8 Full-wave Center-tapped Rectifier.

For a verbal description click here.

Figure 3.8, above, shows the circuit and output waveform of a full-wave rectifier. You will note that the pulsations occur twice as often in Figure 3.8 as they do in Figure 3.7. A higher rate of pulsations is easier to smooth out. It is for this reason that a half-wave rectifier is very rarely used. Figure 3.8 is called a full-wave center-tapped rectifier circuit. A transformer with a center-tapped secondary is required to construct this circuit. The two diodes and the two halves of the transformer work alternately. They can handle twice as much current as either one working alone.

On the first half-cycle when the top end of the secondary is positive with respect to the center-tap the bottom end is negative with respect to the center-tap. (Note that the load is returned to the center-tap, not to the bottom of the secondary.) Diode D1 is forward biased and D2 is reversed biased. D1 conducts current which flows through the load and back to the center-tap. The first half-cycle appears across the load with the top end of the load resistor positive. On the second half-cycle the top of the secondary is negative with respect to the center-tap and the bottom is positive with respect to the center-tap. Diode D1 is reversed biased and D2 is forward biased. D1 does not conduct but D2 does. Remember that the bottom end of the transformer secondary is now positive and when D2 conducts, current flows downward through the load resistor, making its top end positive. Current flows through the load on both halves of the input sine wave and both halves appear positive across the load. This process is called full-wave rectification and the circuit is called a full-wave center-tapped rectifier.

The peak output voltage VP of this rectifier is

VP = 1.4 x (VRMS / 2) - Rect Drop.             (3.17)

where VRMS is the voltage of the entire transformer secondary. Try to understand rather than just memorize. Each half of the transformer winding works alternately so at any given instant only half of the winding is in use. The output voltage is that of only half of the secondary. The factor Rect Drop is the diode drop. The two diodes work alternately and not at the same time. Therefore only one diode drop is subtracted.

Schematic diagram.

Figure 3.9 Full-wave Bridge Rectifier.

For a verbal description click here.

Figure 3.9, above, shows a bridge rectifier circuit. Its output wave looks the same as for Figure 3.8. Because the bridge rectifier uses the whole transformer secondary all of the time, it will deliver twice the voltage at half the current as a full-wave center-tapped rectifier circuit.

When the AC voltage goes positive on the first half-cycle, current flows through D1, down through the load and back to the junction of D3 and D4. The current will not flow through D3. That would be equivalent to a river flowing up a hill. The current flows through D4 to a point of lower electrical potential. On the second half-cycle, current flows through D2, down through the load and back to the junction of D3 and D4. The current will flow through D3 back to the transformer secondary. Regardless of the direction of current in the transformer secondary winding the current always flows downward in the load resistor. The peak output voltage of this rectifier is given by.

VP = 1.4 x VRMS - 2 (Rect Drop)                 (3.18)

where VRMS is the voltage of the entire transformer secondary winding. Try to understand rather than just memorize. The bridge rectifier connects across the entire transformer secondary winding. Each time the current path is traced, it goes through two diodes in series. For this reason you must subtract two diode drops from the output voltage.

Schematic diagram.

Figure 3.10. Two different voltage doubler circuits.

For a verbal description click here.

The circuit of a full-wave voltage doubler is shown in Figure 3.10a above. A voltage doubler circuit will not work without smoothing capacitors. If in the circuit of Figure 3.7 we place a capacitor in parallel with the resistor, the output wave will change. It will now be an almost smooth line at a voltage equal to the peak value of the waveform previously obtained. (Sneak a peak ahead at Figure 3.11. I won't tell if you won't.) If we connect two Figure 3.7 circuits to one transformer (with one diode turned around) we have the circuit of a full-wave voltage doubler as shown in Figure 3.10a. Let us assume that the circuit of Figure 3.10a has been energized for several seconds and both capacitors are charged to their equilibrium voltages. The polarity of charge on the capacitors is as indicated in Figure 3.10a. On the first half-cycle the top of the secondary goes positive with respect to the bottom and current flows through D1 to recharge capacitor C1, which discharged slightly since the last time the top of the transformer went positive. When the top of the secondary goes negative, current flows through D2 replenishing the charge on C2. This circuit consists of two half-wave rectifiers with their outputs connected in series so the output voltage is twice that of one alone.

The charge on C1 is replenished 60 times per second as is the charge on C2. The charges are replenished alternately instead of at the same time; therefore, the total charge is replenished 120 times per second, which qualifies the circuit as a full-wave rectifier.

Figure 3.10b is a variation of the voltage doubler. It has the advantage that one side of both the source and load can be grounded. It has the disadvantage that it is only a half wave rectifier. This circuit is often used in test equipment to obtain the peak to peak value of the incoming wave.

When the input goes negative D1 conducts charging C1 to the peak value of the input with the polarity shown. C1 holds its charge and that voltage is added to the input voltage. When the input goes positive the charge on C1 is added to the peak voltage from the source. This gives a voltage equal to twice the peak or the peak to peak voltage. The wave form at the junction of D1 and C1 is a sine wave which is entirely above the zero axis. D2 rectifies this voltage and charges C2 up to the peak to peak value of the input wave. The charge on C2 is only replenished once for each input cycle or 60 times a second. The peak output voltage of both rectifiers is the same and is given by

VP = 2 (1.4 x VRMS - 0.7).           (3.19)

where VRMS is the voltage of the entire transformer secondary. Try to understand rather than just memorize. The entire peak secondary voltage is used to charge C1 and then C2. They are in series aiding and the voltage is twice the peak voltage of the secondary. In this circuit as in the bridge there are two diodes effectively in series and so the two diode drops are added together.

Example 3.3

A full-wave center-tapped rectifier circuit (Figure 3.8) employs a transformer which is specified as 9 vCT @ 1 A. What is the peak voltage this rectifier will deliver with semiconductor rectifiers?

Solution:

The full-wave center-tapped circuit uses only half of the secondary at a time; therefore, the output will be the peak of half of the secondary.

VP = (1.4 VRMS / 2) - Rect Drop

VP = 1.4 x 9 / 2 - 0.7 = 5.6 volts.

You could draw 1.4 A from this circuit because the two halves of the secondary are effectively connected in parallel but you are using the peak voltage.

Example 3.4

A full-wave center-tapped rectifier circuit (Figure 3.8) employs a transformer which is specified as 4.50 - 0 - 4.50 vAC @ 1.5 A. What is the peak voltage this rectifier will deliver?

Solution:

The specification means that the entire secondary voltage is 9 vAC; which is exactly the same as Example 3.3 above. The solution to this problem is exactly the same so there is no need to repeat it.

Example 3.5

A full-wave bridge rectifier (Figure 3.9) employs a transformer which has a 9 volt CT @ 1 A secondary. What is the peak output voltage of this rectifier circuit?

Solution:

The center-tap is not used. The peak output voltage is given by

VP = 1.4 VRMS - 2 x 0.7 = 1.4 x 9 - 1.4 = 11.2 volts.

Remember, these calculations are not all that precise. The available current is 0.7 A maximum.

Example 3.6

A voltage doubler rectifier (Figure 3.10) employs a transformer which has a 9 volt @ 1 A secondary. What is the peak output voltage of this rectifier circuit?

Solution:

The voltage doubler gives twice the peak voltage of the secondary

VP = 2 x (1.4 VRMS - Rect Drop) = 2 x (9 x 1.4 - 0.7) = 23.8 volts.

The current is now 0.35 A maximum.

You have no doubt noticed that the answers in all of the above examples have been rounded off quite a lot. Calculations involving power supplies are among some of the least accurate in electronics. The chief variable in the system is the line voltage provided by the electric utility. In the United States the agreed upon value for the line voltage is 120 volts ± 10 volts. When extra heavy consumer demand drives the utility to the wall, it may even reduce the voltage to 105 volts or less. The writer has personally observed the line voltage at his home and in his office to vary from a low of 114 volts to a high of 128 volts depending on the time of day and season of year. People who design power supplies normally allow large safety margins to prevent malfunctioning of equipment when the line voltage is high or low. With such large safety margins the additional digits of the square root of 2 are just not important. The diode drops should always be taken into account because they lead to a pessimistic design which provides an additional safety margin.

Maximum current.

In the above examples we have sighted a maximum current without fully explaining it. Now we will. You have to think in volt amps. You likely recognize this as watts of power. Lets take the examples above as a starting point. The original transformer was 9 volts at 1 amp. That means 9 watts. If you try to draw 9.1 watts you could get away with it because of some small amount of safety factor built into the design of the transformer. If you try to draw 18 watts you won't have a working transformer for very long.

The available current for the various connections is as follows.

Full-Wave Center-Tapped. IMax = PMax / (1.4 x VRMS / 2)

Full-Wave Bridge Rectifier. IMax = PMax / (1.4 x VRMS)

Voltage Doubler Rectifier. IMax = PMax / [2 (1.4 x VRMS)]

Notice that the diode drops are not subtracted. The power dissipated by the diodes is taken from the transformer and even if it is not available to the load must still be taken into account as power delivered by the transformer.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

3.6 Filtering the Rectifier's Output.

Filtering is another name for smoothing. Figure 3.11 shows a full-wave rectifier, one filter capacitor and the output waveform. Power supplies for semiconductor circuits always have additional filtering elements which usually take the form of electronic circuits. Vacuum tube power supplies always have additional filtering elements such as LC (inductor - capacitor) and/or RC (resistor - capacitor) sections. The critical part of most filters is the first capacitor.

Schematic diagram.

Figure 3.11 Rectifier, Filter and wave forms.

For a verbal description click here.

On a positive half-cycle the capacitor will charge through the series combination of half of the transformer secondary winding and diode D1. Because this is a low resistance current path the capacitor will charge quickly. When the positive half cycle falls away, the diode is reverse biased and cannot conduct any current. The capacitor will discharge through the resistor until another positive half cycle comes up to recharge it. The heavy red line shows the voltage across the capacitor and the normal black line shows what the voltage would be without the capacitor.

The lower the resistance of the resistor (the greater the load current), the faster the capacitor will discharge and the lower will be the voltage when the next positive half-cycle comes along. A way to keep the voltage from falling so low between the times when the capacitor is charged is to make the capacitor bigger. Because a full-wave rectifier is being used the charging peaks occur more often than would be the case for a half-wave rectifier. Thus the capacitor will not have as much time to discharge and the voltage will not fall as low as it would with a half-wave circuit. The amount of ripple (variation) in the voltage across the capacitor is given by.

Delta V = (I/C) Delta t                     (3.20)

Now the only question is "how long is delta t?" It is the period of the wave - the charging time. The writer has invested a great deal of work in deriving equations for the ripple voltage (delta V) taking the charging time into account and subsequently many hours in the laboratory attempting to verify the results experimentally. The equations did not predict the voltage any better than plus or minus 20%. These equations did not do any better than setting delta t = a little less than the period of the wave in equation 3.19. The conclusion is to set delta t = 8 ms approximately (1/120) for a full-wave rectifier or 16 ms approximately (1/60) for a half-wave rectifier. These numbers would be different for someone living outside of North America. Solving equation 3.19 for C gives

C = (I Delta t)/(Delta V)                     (3.21.1)

One more definition is necessary. That is the Valley voltage VV. The valley voltage is exactly what you would think it is, the lowest voltage of the ripple. It may seem a little tricky in a negative power supply so we define the valley voltage as that part of the ripple wave which comes closest to zero. The peak voltage of the ripple, VP, is that part of the wave which is farthest from zero.

VV = VP - Delta V                     (3.21.2)

Example 3.7

A 25.2 vCT @ 1 A transformer is being used in a full-wave center-tapped power supply which is to deliver 150 mA to the heater of a 12AX7 (DC heater supply to reduce hum). (a) Calculate the correct capacitor to give a ripple of 1.2 volts or less, (b) calculate the DC voltage at the capacitor, (c) the value of the resistor required to apply 12.6 volts to the heater of the tube, and (d) the wattage of the resistor.

Solution:

(a) Using equation 3.21.1 for C gives

C = (0.15 A x 8 ms)/(1.2 V) = 1000 microfarads.

(b) The DC output voltage is

VDC = 1.4 x 25.2 / 2 - 0.7 = 16.94 volts.

That's the peak voltage. The DC is the average voltage which is half of the ripple less than the peak voltage or 16.94 - 1.2 / 2 = 16.34 volts; let's call it 16.3 volts.

(c) The resistor is given by ohm's law as follows.

R = (16.3 - 12.6) / .15 amps = 24.7 ohms.

Use a 24 ohm resistor.

(d) The power dissipated by the resistor is given by

P = I squared R = .15 squared x 24 = .54 watts

Use a 1 watt resistor. Most designers would likely connect another 1000 microfarad capacitor from the other end of the 24 ohm resistor to common as shown in the figure below.

Schematic diagram.

Figure 3.12.1 DC Heater Supply for 12AX7.

For a verbal description click here.

Example 3.8.1

A full-wave bridge rectifier is to be used with a transformer which is rated as 28 vCT @ 2 A. The capacitor is 2200 uf and the load current is 1.3 A. What is the ripple voltage?

Solution:

Using equation 3.19 we have,

Delta V = (I/C) Delta t = (1.3 A / 2200 rf) x 8 ms = 4.7 V.

As compared to physical reality, this is a pessimistic prediction.

Example 3.8.2

A full-wave bridge rectifier is to be used with a transformer which is rated as 280 vCT @ 250 mA. The capacitor is 22 mu f and the load current is 85 mA. What is the ripple voltage?

Solution:

Using equation 3.19 we have

Delta V = (I/C) Delta t = (85 mA / 22 mu f) x 8 ms = 30.9 V

As compared to physical reality, this is a pessimistic prediction.

Additional Filtering LC section.

Electronic voltage regulators are not often used in vacuum tube circuits. When lower ripple is desired from a power supply than can be obtained from a single capacitor, additional filtering elements are added to the filter. For example an LC section may be added to the single capacitor filter to obtain the circuit shown below.

Schematic diagram.

Figure 3.12.2 Full-wave rectifier and C-L-C filter.

For a verbal description click here.

The inductor has a low resistance to DC but a much higher reactance to the AC ripple. Because it is a series element it drops very little DC while dropping a large amount (most of it in fact) of the AC. The second capacitor presents an open circuit to the DC but a low reactance to the AC ripple. It, together with the inductor, forms a voltage divider which reduces the ripple to a very low level. If X is much greater than XC the ripple across C2 is given by

VC2 = VC1 (XC2) / (XL)               (3.22)

where

XL = 2 pi f L                     (3.23)

and

XC2 = 1 / (2 pi f C2)                 (3.24)

Substituting equations 3.23 and 3.24 into equation 3.22 gives.

VC2 = (VC1) / (4 pi squared f squared L C2)               (3.25)

The DC voltage drop across the inductor (filter choke) is usually small enough to be neglected.

Additional Filtering RC section.

If an RC section is added to the single capacitor filter we have a circuit like that shown below.

Schematic diagram.

Figure 3.12.3 full wave rectifier and C-R-C filter.

For a verbal description click here.

The resistor has the same resistance to DC and AC. Because it is a series element it drops a moderate amount of DC while dropping a large amount (most of it in fact) of the AC. The reason the resistor drops more AC than DC is because the second capacitor presents an open circuit to the DC but a low reactance, almost a short, to the AC ripple. It, together with the resistor, forms a voltage divider which reduces the ripple to a very low level. If R is much greater than XC2 the ripple across 2 is given by

VC2 = VC1 (XC) / (R)                 (3.26)

where

XC2 = 1 / (2 pi f C2)                   (3.27)

Substituting equation 3.27 into equation 3.26 gives.

VC2 = (VC1) / (2 pi f R C2)               (3.28)

The DC voltage appearing across C2 is given by

VDC-C2 = VDC-C1 - ILoad R               (3.29)

Where ILoad is the sum of all DC load currents taken off from C2, C3, C4, Etcetera. Additional series R and parallel C sections may be, and often are, added on the end of the circuits of 3.12.2 or 3.12.3. Each added capacitor is numbered C3, C4, etc.

Example 3.9

A filter like that of Figure 3.12.2 has two 22 microfarad capacitors and an 8 Henry filter choke. The ripple voltage across C1 is 31 volts (Example 3.8.2). What is the ripple voltage across C2?

Solution

Using Equation 3.25 gives.

VC2 = (VC1) / (4 pi squared f squared L C2)

VC2 = 31 vAC / (4 pi squared x 120 squared x 8 henrys x 22 mu f = 0.31 vAC.

Example 3.10

A DC power supply like that of Figure 3.13 uses a transformer with a high voltage winding having a rating of 325 - 0 - 325 volts at 100 mA. (This current rating is for a capacitor input filter so the factor of 1.4 has already been accounted for.) It uses a 5Y3 rectifier tube and an RC filter with two 40 mu f capacitors and a 1 k ohm resistor. The DC load taken off at C1 is 80 mA and the load taken off at C2 is 15 mA. What are (a) the ripple across C1, (b) the ripple across C2, (c) the DC voltage across C1, and (d) the DC voltage across C2?

Solution

(a) The ripple across C1 is given by equation 3.19 which is.

Delta V = (I/C) Delta t

We must use the sum of the currents for I in this equation which is 95 mA.

Delta V = (95 mA/40 mu f) 8.3 ms = 19.7 volts.

Let's call it 20 volts.

(b) The ripple across C2 is given by equation 3.28.

VC2 = (VC1) / (2 π f R C2)

VC2 = 20 / (2 π 120 1000 40 mu f) = 0.66 volts.

(c) Using equation 3.17 gives

VDC = 1.4 VRMS / 2 - Rect Drop = 1.4 x 650 / 2 - 125 = 330 volts

The graphs in the tube manual for the 5Y3 give an output voltage of 330 volts for a load of 95 mA and a voltage on each plate of 325 volts.

(d) The voltage across C2 is given by equation 3.29 as

VDC-C2 = VDC-C1 - ILoad R = 330 V - 15 mA x 1000 Ω = 315 VDC

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

3.7 Zener Diode and Gas discharge Voltage Regulators.

Preliminary, Classes of Voltage Regulators.

There are two classes of voltage regulators, series and shunt. The way a voltage regulator works is to place a variable resistance element either, in series with, or in shunt with the voltage to be regulated. Figure 3.12.1 shows a shunt regulator in (a) and a series regulator in (b).

Schematic diagram.

Figure 3.12.1 Shunt and Series Regulators.

For a verbal description click here.

The Shunt Regulator.

Circuit (a) is a shunt regulator. The variable resistance element works to keep the voltage across the output terminals constant. It's resistance changes as needed to accomplish this. The load, which is connected across the output terminals, must operate at a voltage lower than the lowest output voltage of the rectifier and filter.

Let us say that the regulator is operating normally. Then the voltage of the rectifier/filter increases. For the load voltage to remain constant there must be an increased voltage drop across the fixed resistor. Ohm's law tells us that the current through the resistor must increase. The regulator element, inside the red box, will change its resistance to draw more current and the output voltage remains constant.

Now suppose the load current decreases a little. This would cause a decreased drop across the fixed resistor but the regulator compensates by decreasing its resistance to take more current. If the load current goes all the way to zero the regulator will take it all.

If the load current increases the regulator current will decrease to keep the voltage across the output terminals constant. However if the load current increases to the point where the regulator current goes to zero that's as far is it can go. After all the regulator is a variable resistor so it can't generate additional voltage. If the load current keeps increasing after the regulator current has gone to zero the voltage will fall below the regulated value because the regulator is powerless to prevent it from falling below the set voltage. This is the chief disadvantage of a shunt regulator. The regulator will also lose control if the rectifier/filter voltage falls so low that the regulator current goes to zero.

A regulator of this type wastes a lot of power. The current through the regulator must be set above the maximum current that the load will ever take. If this happens for only a small percent of the time and operates at say 1/10 of that value most of the time the shunt regulator will always draw the highest current from the rectifier/filter. If the rectifier/filter were replaced by a battery, it would be discharged very quickly by the large amount of current demanded by the shunt regulator.

The Series Regulator.

In Figure 3.12.1 (b) above the series regulator is connected in series with the load. This type will hold the voltage across the output terminals constant. It does this by comparing the output voltage to a reference voltage and using vacuum tube, transistor, or operational amplifiers (op amps) to amplify the difference and control the pass element. The actual pass element may be a transistor, or vacuum tube, but we don't know about such things yet so we will just think of it as a variable resistor that uses some form of magic to sense the voltage across the output terminals and adjust itself.

Notice that there is no extra resistor in the circuit. Whatever current the load draws, that much current will flow through the regulator, and the same amount will be drawn from the rectifier/filter. The voltage from the rectifier/filter can change up or down and the series regulator element will adjust it's resistance to compensate. The load current can change up or down, even to zero, and the series pass element will adjust to compensate. Series regulators are more efficient than shunt regulators because in the absents of load current they draw very little current from the source. The amplifiers that make it work need a little current but it isn't very much. In general a series regulator can operate with its input and output voltages closer together than for a shunt regulator. That makes them more efficient and a better choice for regulating the voltage in battery operated equipment.

Shunt Zener Diode Regulator.

If a specially manufactured P-N junction diode is reversed biased it presents a constant voltage characteristic. This constant voltage characteristic is perfect for a shunt voltage regulator.

If the doping level (amount of impurity) is increased in a P-N junction the reverse breakdown * voltage will be decreased. When a P-N junction breaks down in the reverse direction, the voltage is held constant (regulated) even though the current may vary over a large range. The typical characteristic of a P-N junction is shown in Figure 3.13. The portion in the first quadrant is the same as any other P-N junction diode. The portion in the third quadrant is the reverse breakdown * characteristic. As the voltage increases in the negative direction, nothing happens until the voltage reaches the constant voltage breakdown point. When this point is reached, the current goes up very rapidly and the voltage will not increase any further. If an attempt is made to force the voltage higher the diode will overheat very quickly and burn out.

* The term "breakdown" does not mean a malfunction as it does
  to an auto mechanic. In semiconductor talk "breakdown"
  means the beginning of conduction of current. A diode
  which has broken down does not have to be replaced; it is
  just beginning to go to work.

Graph.

Figure 3.13 I-V Curve of a P-N Junction Diode.

For a verbal description click here.

There are two mechanisms of reverse breakdown, Zener and avalanche. In Zener breakdown (named for its discoverer Clarence Zener) the electric field intensity in the depletion region becomes so great as to promote electrons from the valence energy band to the conduction energy band. The electrons on the P side move toward the junction and contribute to conduction. Electrons which are freed on the N side cause holes to be created which move toward the junction and also contribute to conduction. The threshold at which electrons begin to be promoted is very sharp and the so- called Zener breakdown voltage is very constant. Zener breakdown takes place up to about 6.2 volts.

If the doping has not been increased to the level where the reverse breakdown is below 6.2 volts, the mechanism is avalanche breakdown. When the electric field becomes intense enough to promote electrons to the conduction band they are accelerated by the field. These newly freed electrons collide with other valance electrons and promote them to the conduction band which in turn collide with other valence electrons promoting them to the conduction band et cetera, et cetera. Avalanche breakdown occurs if the breakdown voltage is greater than about 6.2 volts.

As you might expect the transition from Zener breakdown to avalanche breakdown is not a sudden one but a gradual one. That has interesting consequences because of the temperature coefficients of the two processes. Avalanche breakdown has a positive temperature coefficient and Zener breakdown has a negative temperature coefficient. At the voltage where the two effects play an equal role in reverse breakdown the temperature coefficient is exactly zero. This is at a voltage of 6.1 and some more decimal places.

It used to be literally true that diode manufacturers would make a batch of diodes and then test them to see what they had made. That is no longer completely true but when Zener diodes are being manufactured in the neighborhood of 6 volts, they are carefully tested. The ones which fall exactly on the magic zero temperature coefficient voltage are pulled out and sold for ten dollars a piece as reference diodes. The ones which don't pass this test are sold as 6.2 volt 5% units for seventy five cents or as 5.6 volt 10% units for forty cents. The manufacturing cost is a fraction of a cent per diode. The cost is in the testing. Even though the mechanism may be avalanche breakdown, the diodes are called Zener diodes.

Uses for the Zener Diode.

Zener diodes are sometimes used to set an upper limit to a voltage. Because it draws essentially zero current before breakdown it works well in this application. Suppose an input circuit of an amplifier is meant to operate from zero to 10 volts but would be damaged if the voltage exceeded 12 volts. A 12 volt zener diode can be placed across the input and will have no effect on voltage within the intended range of the amplifier but will conduct and prevent the voltage from going higher than the damaging value of 12 volts.

Zener diodes are also used as voltage regulators. They were formerly used to regulate voltage in both low and high power circuits. Units were available in power ratings from 1 to 50 watts. In modern electronics the Zener diode is used to provide voltage references to high power regulators. The Zener diode is a low power unit and a power transistor takes care of any heavy work. Power transistors cost much less than power Zener diodes. Zeners are now available as 0.4, 1, and 5 watt units.

A typical circuit for a Zener diode voltage regulator is shown in Figure 3.14. The input is an unregulated power supply consisting of a circuit such as Figure 3.11 without the resistor. The load current which is drawn from the output can range from a few nanoamps to several tens of milliamps.

How a voltage regulator works and what it does.

A voltage regulator has to hold the voltage constant as the voltage of the input varies and as the load current changes. The output voltage of a rectifier and filter capacitor is not constant. As mentioned earlier the line voltage can vary all over the place and then there is that ripple which is always present. Another application is in battery operated equipment. In many cases the designer of such equipment wants the voltage applied to the circuits to remain constant as the batteries run down. The battery voltage is set higher than the circuit needs and the regulator holds it constant until the voltage gets near the operating voltage. Special circuits usually warn the operator and/or turn off the equipment when the battery is so run down as to no longer operate the device.

Changing load current is another difficulty. We have used resistors to indicate the load on a power supply. The real load on a power supply is a transistor circuit and/or a small motor or two. The current drawn by a transistor circuit may change depending on what the circuit is and what it is doing at the moment. The current drawn by a motor changes as its mechanical load changes. So a regulator may have a lot to do.

A regulator can't increase the voltage applied to it. All it can do is reduce it. It regulates the voltage by reducing it by the amount required to hold it at some preset value. The difference between the regulator input and the output is called the regulator drop. Each type of regulator has it's minimum regulator drop. If the input voltage falls so low as to make the regulator drop less than the minimum the regulator will lose control and the output voltage will fall.

For example, a 12 volt regulator IC has a minimum drop of 2 volts. That means that the input voltage must be 14 volts or higher. It regulates just fine for input voltages anywhere from 14 to 40 volts. But if the input voltage falls to 13 volts the output voltage will fall to 11 volts and it will no longer be regulated. It will just be 2 volts less than the input, ripple and all. If the ripple valley falls below the minimum required the output voltage will acquire ripple as shown in the graph below.

Graph.

Figure 3.14 Input and output waves of a voltage regulator.

For a verbal description click here.

The upper wave is the output of a full wave rectifier with a capacitor filter. The lower wave is the output voltage of a voltage regulator. In (a) the input voltage is high enough that the regulator is able to do its job properly. In part (b) increased load current has pulled the ripple valley down so it is below the minimum required to maintain regulation. Note that the peak voltage is the same in both cases. This is the way ripple responds to increased load current.

A measurement with a DC voltmeter is likely to indicate that the input voltage is high enough but the ripple valley is too low. Only an oscilloscope measurement will reveal this defect. I have taught the senior projects course in the electrical engineering department for several years and I have found this to be one of the most common mistakes in circuit design.

The Zener Diode Voltage Regulator.

There is one thing about the following calculations you may find peculiar. The maximum allowable current in a zener diode is that which gives 1/4 of the rated power. The specified power rating for almost all semiconductor devices is given for the temperature of the silicon crystal to be held to 25 degrees C. This is stated in the literature as the junction temperature. About the only way to achieve this with a zener diode would be to operate it amerced in a stirred and cooled oil bath.

The power can be increased to about 1/2 of the specified power by mounting the diode through a hole in a heat sink and coating it with heat sinking compound. The hole should be sized so the diode is a tight fit and the sink should be as thick as the diode is long. When the diode is operated in open air the maximum power is 1/4 of the specified power. Operation at higher power will cause the diode to overheat and fail.

Schematic diagram.

Figure 3.15 Zener Diode Voltage Regulator Circuit.

For a verbal description click here.

To design a zener diode circuit you only need to specify the zener diode, voltage, and power, and the resistor RA, resistance, and wattage rating. After the value of RA is fixed, the minimum regulation voltage must be determined. Remember that the Zener diode holds its voltage constant. If the input voltage changes, the voltage across RA must change. Remember Kirchhoff's law? VIN = VRA + VZ where VIN is the input voltage, VRA is the voltage across RA and VZ is the voltage across the Zener diode. If VZ is constant, VIN and VRA will rise and fall together. The current through RA is also proportional to the voltage across RA. Let us assume that there is a load of 1 mA on the output of the regulator. That means that of the current through RA, 1 mA will flow through the load and the rest will flow through the Zener diode because IRA = IL + IZ. The power in the Zener diode is PZ = IZ VZ. Normal practice is to set the current through the Zener diode to such a value as to dissipate 25% of the diode's rated power. Regulation can be maintained as long as the current through the Zener diode is greater than zero. If the current tries to reverse, it cannot and regulation will be lost. The zener diode can't become a battery and hold the voltage up if the input falls below the minimum input voltage. Solving this problem is nothing more than the repeated application of Ohm's and Kirchhoff's laws and should not require any memorization.

The rules for design are as follows.

  1. Calculate the Zener diode current for 25% of rated power.

  2. Add any load current to this Zener current. This is the current through RA.

  3. Subtract the Zener voltage from the average expected input voltage.

  4. Use results of 2 and 3 in Ohm's law to calculate the resistance of RA.

  5. Calculate the minimum input voltage for regulation to be maintained. This value must be below the ripple valley voltage of the power supply.

  6. Calculate the power dissipation of the resistor based on the average ripple voltage. *

  7. Calculate the maximum power dissipated by the zener diode based on minimum load current, often zero, and average input ripple.

* because the power is proportional to the square of the voltage, using the average voltage is not quite correct. However, for realistic values of ripple the error is so small as to be unimportant.

Example 3.10.

An unregulated power supply delivers a ripple peak of 21 volts and a ripple valley of 19 volts. The Zener diode regulator circuit is to deliver 12 volts at 2 mA and will use a 12 volt 400 milliwatt Zener diode. What is (a) the value of RA, (b) the average power dissipated in RA and (c) the minimum input voltage to maintain regulation?

Solution:

The ripple waveform may be approximated as a series of straight lines and the average is simply (VP + VV) / 2 or (21 + 19) / 2 = 20 v. 25% of 400 mW is 100 mW; therefore, IZ = 100 mW / 12 v = 8.3 mA. (a) The value of RA is

RA = (VIN - VZ) / (IZ + IL)

RA = (20 v - 12 v) / 8.3 mA + 2 mA) = 780 ohms.

(b) Power in RA is P = (20 v - 12 v)2 / 780 ohms = 0.082 W

(c) Let IZ = 0.

VIN = VZ + IL RA = 12 v + 2 mA x 780 ohms = 13.6 volts.

This is much less than the ripple valley voltage of 19 volts, so the circuit will work.

The only resistors which come in what ever value you need are .05% precision resistors and these are very, very expensive. In common laboratory work we must use what the manufacturers of resistors supply us. The result of (a) in the above example was 780 ohms. In standard 5% resistor values the two closest values are 750 and 820 ohms. In this case you would tend to choose 750 ohms because it is the closest one and you would be doing the right thing. In Zener diode circuits you should always move down to the next lower value. The calculations of parts (b) and (c) should be based on the actual resistor used rather than the calculated value.

The writer considers the memorization of the table of standard values to be a waste of time and effort. This is information which can always be looked up if and when it is needed. A table of standard values is given in the appendix for those who need to look them up.

Example 3.11.

An unregulated power supply delivers a ripple peak of 39 volts and a ripple valley of 25 volts. The Zener diode regulator circuit is to deliver 16 volts at 1 mA and will use a 16 volt 1 watt Zener diode. What is (a) the value of RA, (b) the average power dissipated in RA and (c) the minimum input voltage to maintain regulation?

Solution:

The average input voltage is (39 + 25) / 2 = 32 volts. The Zener diode current is IZ = 0.25 x 1 W / 16 v = 15.6 mA. (a) RA = (32 - 16) / (15.6 + 1) = 964 ohms. The next lowest standard value is 910 ohms and that is what we will use. (b) The power is (32v - 16v)2 / 910 ohms = 0.28 watts. It is best to use a 1/2 watt resistor here. (c) The minimum input voltage is 16 v + 1 mA x 910 ohms = 16.91 volts. The circuit will work.

Zener diode voltage regulators are occasionally used to regulate the voltage for low current circuits when a design goal is to keep it simple. Because it is a shunt regulator it wastes too much power to be used in a battery operated device.

Zener diodes are most often used in conjunction with other circuits such as op amps and power transistors. We will return to these circuits later after we have studied these devices.

If You Need a High Power Zener.

Although zener diodes are no longer available in powers above 5 watts, (1.25 watts in practice), they can be obtained in voltages up to 100 volts. If you need to regulate a voltage at high current and/or high voltage, relatively speaking, you can use a transistor to effectively amplify the power of a zener diode.

Schematic diagram.

Figure 3.15.1 Amplified Zener Diode Voltage Regulator Circuit.

For a verbal description click here.

As the input voltage increases the transistor remains an open circuit until it experiences base current. There is no base current until the zener diode begins to conduct so the whole thing is an open circuit until the zener voltage + 0.6 volts is reached. When the zener does begin to conduct the transistor also begins to conduct but the collector current is typically 100 times as large as the current through the zener diode and into the base. If you need a high power shunt regulator This is the circuit for you. Remember the turn on voltage is 0.6 volts higher than the zener voltage.

Gas Discharge Regulator Tubes.

Prior to the invention of the zener diode the only regulating devices were gas discharge regulator tubes, commonly known as voltage regulator or VR tubes. These are cold cathode diode tubes filled with one of the inert gases. The pressure is low, about 1/100 of an atmosphere. They come in four voltages, 75, 90, 105, and 150 volts. The only gas I can identify with a specific voltage is neon with the 75 volt tube.

The workhorse set is the octal series, 0A3, 0B3, 0C3, and 0D3. The 0A3 is the 75 volt tube and the 0D3 is the 150 volt regulator. The current range is 5 to 40 mA for all tubes. There is a 7 pin miniature series 0A2, 0B2, and 0C2. Their voltages are 150, 105, and 75 respectively. Their maximum current is 30 mA.

The design procedure is almost the same as for the zener diode, with one exception. The glow discharge in the tubes require a higher voltage than the operating value to get the ionization started. This value is different for each tube and must be looked up in a tube manual. The initial voltage of the power supply must be above this starting value and the starting current of the load must be zero or very small. If the load is resistive, the voltage of the power supply must be large enough to place the starting voltage on the tube even with the load drawing current. The schematic symbol of a VR tube can be seen in a diagram at the end of this chapter.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

3.8 Integrated Circuit Voltage Regulators.

The design and construction of power supplies using series regulators has been made extremely simple by the introduction of the integrated circuit voltage regulator. The IC VR could not possibly be any simpler. It has three terminals: an input, an output and a ground (common). It is often called a three terminal regulator. The acronym "TTR" has never been seen or heard by the writer. The schematic symbol for the IC VR is just a rectangle with 3 lines (wires) connecting to it.

These regulators regulate very well against changes in load current and changes in input voltage. Most of the ripple voltage which is present in the output of the unregulated power supply is regulated out by the IC VR. The IC contains a current sensor and the voltage will be shut down if the load tries to draw too much current. The IC also contains a temperature sensor and, if the IC gets too hot, the voltage will be shut down. When the power is turned off the IC will cool down and the power will be turned back on again. The observable results of an IC VR which is getting too hot is that the voltage will be turned off and on periodically.

One undesirable thing that these little wonders do rather well is to oscillate at a frequency of approximately 1 Megahertz. This oscillation can cause lots of trouble and headaches for research lab workers (graduate students). The way to prevent these oscillations is to connect a 0.1 uf capacitor on each side of the regulator, one from input to ground and the other from output to ground. These capacitors must be physically close to the regulator or they will not do any good. A regulator which does not have these capacitors will, not may, but WILL, oscillate. In addition to these capacitors, the unregulated power supply must have its filter capacitor and a capacitor in the neighborhood of 25 uf connected across the output of the voltage regulator. Figure 3.16 is the circuit of a typical 5 volt 1 amp power supply.

Schematic diagram.

Figure 3.16 Complete 5 Volt 1 Amp Power Supply.

For a verbal description click here.

These IC VRs come in a wide variety of shapes and sizes but by far the most popular are the LM78XX and LM79XX regulator series. These are supplied in a TO220 (see appendix B) package which must be attached to a heat sink if it is to deliver any more than 100 mA. The LM78XX are positive regulators and the LM79XX are for regulating negative voltage power supplies. The "XX" gives the output voltage of the regulator. For example an LM7805 is a +5 volt unit, an LM7812 is a +12 and an LM7915 is a -15 volt unit. All of these units will accept input voltages of VO + 2 to 40 volts for a positive regulator and VO - 2 to -40 volts for a negative regulator. They will deliver a maximum of 1 ampere and are current limited at about 1.5 amperes.

There is another series of regulators which are very useful in low power circuits. They are the LM78LXX and LM79LXX series. These regulators are supplied in a TO92 package and have a maximum current rating of 100 mA. These units usually do not need a heat sink. The small package makes it possible to construct a very small low-power power supply.

Adjustable Voltage Regulators.

If you need a voltage in between the voltages of the fixed regulators, or you want to build a variable voltage power supply, there is another set of voltage regulators which have adjustable output voltages. The positive regulator is an LM317 and the negative regulator is an LM337. A possible disadvantage of these regulators is that their voltage will not go all the way to zero. Here is the circuit using an LM317.

Schematic diagram.

Figure 3.17 Circuit of an adjustable voltage regulator.

For a verbal description click here.

This circuit works because the voltage between the O and A terminals is fixed at 1.2 volts, and current flowing out of the A terminal is very small. The fixed output voltage causes the current through R1 to be constant. The small current in the A terminal causes the current in R2 to be essentially equal to the current in R1. This means that the drop across R2 will be constant and set by the values of R1 and R2.

Example 3.12.

If R1 is 100 ohms and R2 is 1100 ohms, what is the output voltage of the circuit?

Solution:

The voltage between the O and A terminals is 1.2 volts so the current in R1 is,

I = 1.2 / 100 = 12.0 mA.

The current in R2 is also 12 mA so the voltage across R2 is,

V = 12.0 mA x 1100 ohms = 13.2 volts.

This is not the output voltage, it is the voltage between common and the A terminal. The voltage between the o terminal and common is the sum of the voltage between common and the A terminal and the voltage between the A and O terminals or,

13.2 + 1.2 = 14.4 volts.

A triple output 1.2 to 20, -1.2 to -20, and fixed 5 volt, power supply is shown in Figure 3.18. The diodes across the output are to prevent either supply from being pulled to the opposite sign by the other power supply. If this happens, the supply will latch at -0.7 volts and will not come up to its normal voltage.

Schematic diagram.

Figure 3.18 Triple Voltage Power Supply.

For a verbal description click here.

Vacuum Tube Voltage Regulator.

Some vacuum tube circuits require regulated voltage. These include such things as the amplifiers in Vacuum Tube Volt Meters (VTVM), The screen grids of high power amplifiers, and oscillators in communications receivers and transmitters. These applications are not usually high current. It is not necessary to regulate the plate voltage of a power amplifier. If the voltage needed does not fall on one of the 4 VR tube values an electronic circuit must be used. Here is a simple regulator circuit.

Schematic diagram.

Figure 3.19 Vacuum Tube Voltage Regulator Circuit.

For a verbal description click here.

The 0A3 is a VR tube as described above. If the device containing the regulator were to be operated with the VR tube unplugged some circuit components could be damaged. The connection between pins 3 and 7 of the tube is a jumper. If the tube is removed from its socket there will not be any output from the circuit because the negative lead is open. Removing a positive voltage from something will usually result in less current rather than more.

This circuit will not go to zero voltage. One that will, needs a negative voltage supply and can get more complicated. This circuit is as simple as it can get and still be a true closed loop* regulator.

* A closed loop regulator is one in which the output voltage
  is sensed, compared to a reference voltage, and if the
  output voltage changes it is instantly corrected
  to the set voltage.
A common feature of regulators is that the heater of the pass tube, the 6AQ5 in this circuit, is operated from a separate filament transformer. The maximum heater to cathode voltage for most tubes is 200 volts so a regulator capable of output voltage higher than this must have such a transformer. One side of the heater is tied electrically to the cathode so the voltage difference is no more than the peak of the 6.3 volt heater supply voltage.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

3.9 Problems.

  1. The unregulated portion of a power supply is delivering 18 volts at a current of 1 ampere. What size (current rating) fuse should be used in the primary of the transformer?

  2. A power transformer has the ratings 34 - 0 - 34 v @ 3 amps. If this transformer is used with a full-wave center-tapped rectifier circuit, Figure 3.8, what is the peak output voltage VP? Take diode drops into account.

  3. A power transformer has the ratings 36 vCT @ 2 amps. If this transformer is used with a full-wave center-tapped rectifier circuit, Figure 3.8, what is the peak output voltage VP? Take diode drops into account.

  4. A power transformer has the ratings 21 vAC @ 5 amps. If this transformer is used with a full-wave bridge rectifier circuit, Figure 3.9, what is the peak output voltage VP? Take diode drops into account.

  5. A full-wave voltage doubler circuit (Figure 3.10) is attached to a transformer whose secondary is rated at 120 vAC @ 10 amperes. (This is an isolation transformer.) What is the peak output of this circuit? Take diode drops into account.

  6. A power transformer is rated as 40 - 0 - 40 vAC @ 1.2 amps. The transformer is equipped with a full-wave center-tapped rectifier using silicon diodes and a filter capacitor of 7,000 microfarads. What is the ripple valley voltage of this circuit if the load current is 0.8 ampere? Apply all corrections.

  7. A power transformer is rated as 20 vAC @ 7 amps. The transformer is equipped with a full-wave bridge rectifier using silicon diodes and a filter capacitor of 20,000 microfarads. What is the ripple valley voltage of this circuit if the load current is 5 amperes? Apply all corrections.

  8. Using the transformer and rectifier from problem 6, calculate the value of the filter capacitor to give a ripple valley voltage of 45 volts if the load current is 0.8 amps.

  9. Using the transformer and rectifier from problem 7, calculate the value of the filter capacitor to give a ripple valley voltage of 17 volts if the current is 5 amps.

  10. A 12 volt 300 mA transformer is being used with a bridge rectifier which is to deliver 10 mA to a load. An uninformed person uses a 20,000 uf capacitor in the power supply. What is (a) the peak output voltage and (b) the difference between the peak and valley voltages?

  11. For the conditions of problem 10, what size capacitor should be used to give a ripple valley voltage of 14 volts?

  12. A 6.2 volt 400 mW Zener diode is to be supplied from an unregulated power supply which has a peak output voltage of 26 volts and a ripple valley voltage of 22 volts. The load current on the regulator is approximately 1 picoampere. (a) Calculate the resistance of RA. (b) Select the proper value for RA from the table of standard values in the appendix. (c) Calculate the power dissipated in the resistor. (d) Calculate the minimum input voltage to maintain regulation. Restrict your answers to no more than 3 significant digits.

  13. What is the highest tolerable peak output voltage from the rectifier for each of the following regulators: (a) LM7805, (b) LM7912, (c) LM7812, (d) LM7915, and (e) LM7824? Don't forget the signs.

  14. What is the lowest tolerable ripple valley output Voltage, closest to zero, from the rectifier for each of the following regulators: (a) LM7805, (b) LM7912, (c) LM7812, (d) LM7915, and (e) LM7824? Don't forget the signs.

  15. In the circuit of Figure 3.18, what is the value of R2 to give an output voltage of 13.5 volts if R1 is 120 ohms?

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

3.10 Answers to Problems.

  1. 3/10 Amp.

  2. 46.9 volts.

  3. 24.5 volts.

  4. 28.0 volts.

  5. 334.6 volts.

  6. 54.4 volts.

  7. 24.6 volts.

  8. 621 microfarads.

  9. 4170 microfarads.

  10. (a) 15.4 volts. (b) 4.00 millivolts.

  11. 57.1 microfarads.

  12. (a) 1100 ohms, (b) 1100 ohms, (c) 0.288 watts, (d) 6.2 volts.

  13. (a) +40, (b) -40, (c) +40, (d) -40, (e) +40 volts.

  14. (a) +7, (b) -14, (c) +14, (d) -17, (e) +26 volts.

  15. 1230 ohms.

Now, if you have really mastered this material you deserve some kind of award. Go have some ice cream.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

This page copyright © Max Robinson. All rights reserved.


Chapter 4   Transistors as Switches and Amplifiers.

4.1  The Bipolar Junction Transistor (BJT).
4.2  The BJT as a Switch.
4.3  The BJT as an Amplifier.
4.4  The Field Effect Transistor (FET).
4.5  The FET as a Switch.
4.6  The FET as an Amplifier.
4.7  Differential Amplifier.
4.8  Problems.
4.9  Answers to Problems.

Chapter 4.

Transistors as Switches and Amplifiers.

The development of the transistor was the greatest single advancement in electronics since the development of the vacuum tube in the early part of the 20th century. Some people might ask "What about the integrated circuit?" The integrated circuit is just a more compact way of packaging circuitry. In fact, there was a little known attempt in the early 1960s to put vacuum tubes in an integrated package. The information available to the writer indicates that a prototype was actually constructed and tested. The demise of the vacuum tube has relegated this experiment to the dusty back shelves of history. But we digress -- oh yes -- the transistor. Even the very earliest of transistors occupied about 1/100 the volume of the average vacuum tube. Such a large change was bound to start a revolution and it did.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

4.1 The Bipolar Junction Transistor (BJT).

The full name of the tiny transistor is quite a mouthful. That is, no doubt, why it is rarely called by that name. Even people who don't know what a transistor looks like know the shortened name "transistor". Non-technical people are unaware that there are two major types of transistors, bipolar junction transistors and field effect transistors. The term "transistor" is too imprecise for our purposes. Instead of using the full name every time, we will use the acronym BJT.

A BJT will allow a small current in one circuit loop to control a much larger current (typically 100 times larger) in another circuit loop. The nature of the BJT is such that the current in the second loop may be switched (turned on and off) or varied by an arbitrarily small amount. We will be devoting much space in following sections to the circuits which permit the BJT to be used to control large currents. In this section we will study the internal physics of the BJT and try to understand how it does what it does.

A simplified cross-section of a BJT is shown in Figure 4.1. A bipolar junction transistor consists of three layers of alternating semiconductor type. These three layers have been given the names emitter, base and collector.

Schematic diagram.

Figure 4.1 Simplified Drawing of a BJT With Supply Voltages

For a verbal description click here.

BJTs may be manufactured in either of two forms. In one form the emitter is P type semiconductor, the base is N type semiconductor and the collector is P type semiconductor. Such transistors are referred to as PNP transistors. In the other form the emitter is N type semiconductor, the base is P type semiconductor and the collector is N type semiconductor. Such transistors are referred to as NPN transistors. (The designation NPN or PNP informs the reader that the transistor is a bipolar junction type and the term NPN transistor is precise.) In the example of Figure 4.1 the transistor is an NPN type which means that the emitter is N type semiconductor, the base is P type semiconductor and the collector is N type semiconductor.

The connection of the battery on the left is such as to forward bias the P-N junction between the emitter and base. The voltage drop across the emitter-base junction is about 0.6 volts. (We used 0.7 volts in rectifier circuits because the current is fairly high. In the base circuit of a BJT the currents are fairly small, typically a few tens of microamperes and the voltage drop is more typically 0.6 volts.) The collector supply voltage, VCC may be anywhere between 5 volts and the maximum the transistor will stand. With the base at +0.6 volts and the collector at more than +5 volts, the base-collector junction is reverse biased.

The forward biased emitter-base junction causes majority carriers to move across the junction. These charge carriers become minority carriers as soon as they cross the junction. Minority carriers do not immediately combine with majority carriers but will travel a short distance until statistics catch up with them and recombination occurs. The average distance a minority carrier can cover is called the mean free path. In a real transistor the width of the base region is less than the mean free path of a minority carrier in the base. That means that most of the minority carriers which are injected into the base region will make it across the base without being recombined with majority carriers from the base. As soon as a minority carrier exits the base and enters the collector, it is again a majority carrier. Majority carriers which are injected into the collector will constitute a collector current. That collector current originated in the emitter and is controlled by the base current.

In the specific case of the NPN transistor shown in Figure 4.1 the base supply voltage VBB will cause a base current to flow into the base. That will cause holes from the base to cross into the emitter and electrons from the emitter to cross into the base. The holes from the base will simply recombine with electrons in the emitter. Some electrons from the emitter will flow out through the base connection and back to VBB but most of the electrons which cross the emitter-base junction will continue on to cross the base-collector junction. Thus there are electrons originating in the emitter region and ending up in the collector region.

If the base current is increased, the number of charge carriers injected into the base will be increased and so will the number of carriers injected into the collector. More base current means more collector current. Less base current means less collector current. The animation below shows this. If the base current is shut off, the collector current will cease to flow. The collector current is typically 100 times larger than the base current.

Animation.

Figure 4.1a Animation showing holes and electrons in a BJT.

For a verbal description click here.

If a PNP transistor were to be used in the circuit of Figure 4.1, it would be necessary to reverse both batteries. The discussion above will apply to a PNP transistor, the only changes to be made are to change every occurrence of "electron" to "hole" and "hole" to "electron". All references to majority and minority carriers remain as they are.

Figure 4.2 is a repeat of Figure 4.1 but with the schematic symbol for an NPN transistor instead of the representation of the transistor's innards. We will now define a transistor parameter. It is called the forward DC current gain. It is assigned the symbol beta and is

beta = IC / IB           (4.1)

where IC is the DC collector current and IB is the DC base current of the transistor. Equation 4.1 is a definition and so cannot be derived.

Schematic diagram.

Figure 4.2 Schematic of a Properly Biased NPN Transistor.

For a verbal description click here.

By applying Kirchhoff's and Ohm's laws to the circuit of Figure 4.2 it is possible to write some other equations. Summing currents we have

IE = IC + IB           (4.2)

where IE is the emitter current. Summing voltages around the base loop we have

VBB = IB RB + VBE           (4.3)

where VBE is the base to emitter voltage drop, which is approximately 0.6 volts. If we substitute VBE = 0.6 v and rearrange equation 4.3 we have

IB = (VBB - 0.6 v) / RB           (4.4)

In the collector loop we can write

VCC = IC RC + VCE           (4.5)

where VCE is the voltage between collector and emitter. In a great many circuits VCE is taken as the output voltage of the transistor circuit. Rearranging equation 4.5 we have

VCE = VCC - IC RC           (4.6)

If we combine equations 4.1, 4.4 and 4.6 we have

VCE = VCC - beta RC (VBB - 0.6 v) / RB           (4.7)

VCE can never, repeat NEVER, change sign. The absolute value of VCC must always be greater than the absolute value of VCE in equation 4.7. VCE can never exceed VCC because to do so would require that the term on the right in equation 4.7 undergo a change of sign. That cannot happen in the real world. Because the base-emitter junction is a P-N junction diode, if VBB becomes less than 0.6 volts, the base current will simply stop, not reverse. VCE will be equal to VCC.

Within the limits 0 to VCC notice that if VBB is decreased, VCE is increased and visa versa. These are common emitter equations and may not apply to all circuits employing bipolar transistors.

The important thing about these seven equations is to understand how they were obtained. If you do not understand how these equations were obtained it is guaranteed that the rest of this chapter will be Greek to you.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

4.2 The BJT as a Switch.

As mentioned above if the base current is removed from a transistor, the collector current will become similar to the reverse current in a diode, (too small to measure). Thus if a small current is turned on and off in the base of a BJT, the collector current will be turned on and off. Because the collector current is much larger than the base current, a low power circuit can be made to turn a high power device on and off. An excellent example of this is an indicator light.

Schematic diagram.

Figure 4.3 BJT Switch Turns Light On and Off

For a verbal description click here.

Figure 4.3 shows how a transistor can be used to turn a light on and off. It is very common in both consumer and laboratory equipment for a light to come on to indicate that a particular function has been activated. The input terminals on the left connect to what will be referred to as the driving source. The driving source is not capable of delivering enough current to light the lamp. This low power circuit will deliver a voltage when the light is to be on and no (or very little) voltage when the light is to be off.

An ideal switch has infinite resistance when it is open and zero resistance when it is closed. The BJT is quite close to being ideal in the open (off) condition but in the closed (on) condition it is not quite perfect. The on condition is known as saturation and is the condition wherein the collector current is as large as it can be. When a transistor is in saturation VCE is about 0.1 or 0.2 volts.

When a BJT is in saturation, most of the power supply voltage will appear across the load (device being switched on and off) and so the current through the load is

ISAT = (VCC - VCESAT) / RL           (4.8)

where VCC is the power supply voltage, RL is the load resistance and 0.1 v < VCESAT < 0.2 volts.

Example 4.1.

A lamp having a resistance of 22 ohms is to be switched by a BJT. The power supply voltage is 5 volts and the collector saturation voltage is 0.1 volts. What is the saturation current of the transistor? See Figure 4.3.

Solution:

ISAT = (5 v - 0.1 v) / 22 ohms = 223 mA

Trouble can develop in switching circuits if the transistor is not in saturation. To place a transistor in saturation it is necessary to supply more base current than is needed to just barely place the transistor in saturation. To be absolutely certain that the transistor is in saturation, the base current should be at least twice that required to just barely saturate the transistor. It will not do any damage if the base current is larger than that required for saturation. The collector current cannot be any greater than the saturation current.

Example 4.2.

Using the same conditions from example 4.1, what is the minimum base current required to place the transistor in saturation if beta is 80?

Solution:

IBMIN = ISAT / beta = 223 mA / 80 = 2.79 mA

The resistor in the base circuit must be properly selected so as to cause the base current to be large enough to place the transistor in saturation. On the other extreme the driving source will have a practical limit to how much current it will supply. If there were no limit, the load could be connected to the source and the switching transistor would not be needed.

Example 4.3.

Continuing with examples 4.1 and 4.2, what is the range of resistance for RB if the driving source can supply a maximum of 12 mA at a voltage of 5 volts. What should the resistance be to give a saturation safety factor of 2.5?

Solution:

In example 4.2 the minimum base current was calculated to be 2.79 mA. The maximum base current is the maximum which the driving source can supply, which is given as 12 mA. Solving equation 4.4 for RB we have

RB = (VBB - 0.6 v) / IB

RBMIN = (5 v - 0.6 v) / 12 mA = 367 ohms.
RBMAX = (5 v - 0.6 v) / 2.79 mA = 1.58 k ohms.
Since the minimum base current for saturation is 2.79 mA
a safety factor of 2.5 calls for a base current of 6.98
mA. RB = (5 v - 0.6 v) / 6.98 mA = 630 ohms.
A 620 ohms standard value resistor would be used.

Another consideration in switching transistor circuits is whether the transistor will be turned off when it is supposed to be off. As long as the voltage of the driving source goes below about 0.6 volts, the transistor will most likely be turned off. But some driving sources do not go below 0.6 volts and the transistor may not be completely turned off.

Example 4.4.

In Figure 4.3 it is now assumed that VCC is 5 volts, the resistance of the lamp is 22 ohms, the resistance of RB is 620 ohms and the beta of the transistor is 80. The driving source has an "on" voltage of 5 volts. (a) If its "off" voltage is 0.2 volts, is the transistor off? If not, what is the collector current? (b) If the driving source has an "off" voltage of 1.0 volts, is the transistor off? If not, what is the collector current?

Solution:

(a) The driving source has an "off" voltage of 0.2 volts. That is less than the 0.6 volt breakdown of the base-emitter junction. There will be no base current and so there will be no collector current. The transistor switch will be off.
(b) If the "off" voltage of the driving source is 1 volt there will be some base current. The base current will be IB = (1 v - 0.6 v) / 620 ohms = 0.645 mA; the collector current will be 80 x 0.645 mA = 51.6 mA. Although they are not asked for in the original example we will calculate the drop across the load and VCE to give a complete illustration of this type of problem. The drop across the load is IC RL = 51.6 mA x 22 ohms = 1.14 volts. VCE is VCC - VL = 5 v - 1.14 v = 3.86 volts.

As you can see in the above example the transistor is "mostly" off. The lamp would glow slightly. An operator might be confused and become unsure as to whether a particular function is engaged or not. In something such as a nuclear power plant such confusion could be the difference between safe and unsafe operation. It is highly undesirable for indicator lamps to be partially on when they are supposed to be off.

Figure 4.4 shows a circuit which will overcome the problem of a driving source which will not go to zero for the off state.

Schematic diagram.

Figure 4.4 Switching Circuit for Non-zero Driving Sources

For a verbal description click here.

The procedure for solving this circuit is as follows.

  1. Assume that there is no load on the voltage divider in the base circuit and see if the transistor will be turned on or not. If the calculated voltage exceeds 0.6 volts, the transistor is at least part way on. If the voltage is less than 0.6 volts the transistor is off.

  2. To calculate the base current in the "on" state assume that VBE is 0.6 volts and calculate the current through R2 (the voltage across R2 will be 0.6 volts).

  3. Calculate the current through R1 assuming VBE to be 0.6 volts.

  4. The current through R1 will split. Some will go through R2 and the rest will go into the base of the transistor. To obtain the base current subtract the R2 current from the R1 current.

For those who would rather memorize an equation it is

IB = (VDSON - 0.6 v) / R1 - 0.6 v / R2           (4.9)

where VDSON is the on voltage of the driving source. It should be pointed out and emphasized that VBE for a good (not burned out) BJT can never exceed about 0.6 or 0.7 volts. If it does in a calculation, something has been neglected but no damage is done. If VBE exceeds 0.7 volts in the real world, the BJT is burned out. If it wasn't before, it is now.

Example 4.5

For the values given in Figure 4.4 will a driving source which has an on voltage of 5 volts and an off voltage of 1 volt turn the BJT switch on and off?

Solution:

For the off state VBE = 1 v x 1 k ohms / (5.6 k ohms + 1 k ohms) = 0.15 v; the BJT switch is off. For the on state VBE = 5 v x 1 k ohms / (5.6 k ohms + 1 k ohms) = 0.76 v; there will be base current. Calculating the amount of base current

IB = VDSON - 0.6 v) / R1 - 0.6 v / R2 = 4.4 v / 5.6 k ohms - 0.6 v / 1 k ohm = 0.186 mA

The base current required to turn the switch on is IB = IC / beta and IC = RC / VCC = 12 v / 150 ohms = 80 mA, IB = 80 mA / 100 = 0.8 mA. With 0.8 mA required and 0.186 mA supplied, there is insufficient base current to turn the BJT switch on.

Example 4.6

Will a driving source of 10 volts turn the BJT on in Figure 4.4?

Solution:

We know from example 4.5 that 5 volts is enough to slightly forward bias the base-emitter junction and so we do not need to test to see if 10 volts will do it. Calculating IB gives

IB = (10 v - 0.6 v) / 5.6 k ohms - 0.6 v / 1 k ohm = 1.08 mA.

In example 4.5 we saw that 0.8 mA was required to turn the BJT on and we have 1.08 mA. The BJT is on.

BJT switches are used whenever a device such as a microprocessor needs to switch the current to any device which draws more current than the microprocessor can supply. Devices which may be switched include lamps, relays, buzzers and digital displays.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

4.3 The BJT as an Amplifier.

An amplifier is any sort of device which will increase the magnitude of a signal. An amplifier may increase the magnitude of the voltage, current or both but to qualify as a true amplifier it must increase the power of a signal. A transformer can be used to increase the voltage of a signal, but there is no increase in power and a transformer is not an amplifier.

To characterize an amplifier completely it is necessary to know four things about it. They are

  1. the relationship between the input voltage and the input current,
  2. the relationship between the output voltage and the output current,
  3. a relationship showing how the output is affected by the input, and
  4. a relationship showing how the input is affected by the output.
These characteristics are called the four-terminal network parameters.

There are three groups of parameters, the impedance parameters, the admittance parameters and the hybrid parameters. All four of the impedance parameters have units of ohms and all four of the admittance parameters have units of ohms-1. The hybrid parameters are a mix of units.

Schematic diagram.

Figure 4.5 Generalized Four-terminal Network

For a verbal description click here.

Figure 4.5 shows a generalized four-terminal network. The open circuit impedance parameters are as follows.
  • Input Impedance Z11 = V1 / I1 with I2 = 0

  • Output Impedance Z22 = V2 / I2 with I1 = 0

  • Forward Transfer Impedance Z12 = V2 / I1 I2 = 0

  • Reverse Transfer Impedance Z21 = V1 / I2 I1 = 0

"What has all of this to do with transistors?" A transistor can be treated as a four-terminal network. "Hold on now, you said a transistor has three terminals, emitter, base and collector, I remember that!" Correct. We will use one of the terminals twice so as to use four-terminal network parameters on a BJT.

Let us apply the hybrid parameters to the common emitter configuration. That means that the input is applied between the base and emitter and the output is taken between the collector and emitter as indicated in Figure 4.6a.

In the equations to follow all of the voltages and currents are AC small signal. Small signal means that the AC voltages are small enough so that the natural nonlinearities of P-N junctions are not significant and the I-V characteristics "look" linear. This is not an unrealistic condition. All amplifier transistors must be used in this way to avoid signal distortion. Distortion is any unwanted alteration of the signal.

The small-signal common-emitter hybrid parameters for the BJT are as follows.

The short-circuit input impedance.

hie = vbe / ib   with vce = 0           (4.10)

The open-circuit output admittance.

hoe = ic / vce   with ib = 0           (4.11)

The short-circuit forward current transfer ratio.

hfe = ic / ib   with vce = 0           (4.12)

The open-circuit reverse voltage transfer ratio.

hre = vbe / vce   with ib = 0           <(4.13)

Just in case you are wondering, hre is measured by injecting a signal at the collector and making a measurement at the base. These parameters are all definitions.

Schematic diagram.

Figure 4.6 (a) BJT and (b) Four-terminal Equivalent Circuit.

For a verbal description click here.

The hybrid parameters give rise to the equivalent circuit of Figure 4.6b. This circuit takes the place of the transistor and is considered to be equivalent to it. The parameter hie is the input resistance. It is connected in series with the voltage generator which represents hre. The presence of hre indicates that a small amount of the output voltage is fed back into the base-emitter loop. In the collector-emitter loop a resistor representing hoe and a current source representing hfe are connected in parallel. Although hoe is expressed as a conductance, it is the reciprocal of the output resistance of the transistor. The current produced by the current source hfe is equal to hfe times the current in the base loop.

A generator may be connected, (in thought), to the base- emitter side of the equivalent circuit and a load resistance connected to the collector-emitter side. Equations may then be derived for such things as the input impedance, the output impedance and the gain. These equations are indeed complex. Advancing technology has saved us from having to deal with these equations.

The voltage feedback which is represented by hre is caused by the electric field within the transistor which is produced by the collector-to-emitter voltage. This field affects the concentration of charge carriers within the base and causes the forward voltage drop across the base-emitter junction (VBE) to be affected by the magnitude of VCE. The same electric field causes the collector current to increase as VCE increases. The value of hoe is the slope of the graph of IC versus VCE. Modern transistor design has overcome both of these problems to a very large extent. The amount of output voltage which is fed back to the input side is negligible in modern transistors and hre can be neglected and removed from the equivalent circuit. With modern transistors the graph of IC versus VCE is a horizontal line for voltages above about 1.5 volts. A horizontal line has a slope of zero and if hoe is zero, the output resistance is infinity. An infinite output resistance means that the resistor representing hoe may be removed from the circuit.

Schematic diagram.

Figure 4.7 Simplified Equivalent Circuit.

For a verbal description click here.

The simplified equivalent circuit is shown in Figure 4.7. The equivalent circuit consists of the resistor labeled hie and the current source labeled ib> hfe. To make use of this circuit we must connect a couple of things to it. A Thevenin's equivalent circuit of a generator is connected to the B and E terminals. A load resistor is connected to the C and E terminals. We will use this circuit to derive the equations for gain and input impedance.

The current in the first loop is simply,

ib = vbe / hie           (4.14)

The output voltage is,

vce = - hfe ib RL           (4.15)

The minus sign in equation 4.15 arises from the fact that the current in the current source is flowing downward and so it is flowing upward in the load resistor. If we now substitute equation 4.14 into equation 4.15 and divide by vbe we obtain,

vce / vbe = - (hfe RL ) / hie           (4.16)

If we define the voltage gain as AV = vce / vbe then we have

AV = - (hfe RL ) / hie           (4.17)

The input impedance of a common emitter amplifier is equal to Hie. The output impedance is virtually infinite.

Example 4.7

A BJT has the following parameters, hfe = 90 and hie = 4 k ohms. If this transistor is placed in a circuit where the load resistance is 4.7 k ohms, what is the voltage gain of the circuit?

Solution:

AV = - (hfe RL ) / hie = - ( 90 x 4.7 k ohms ) / ( 4 k ohms ) = 106

The solution to example 4.7 indicates that the amplifier in question will have an output voltage 106 times as large as its input voltage and the phase of the output signal will be inverted. 180 degrees phase shift.

Biasing the Bipolar Transistor.

The BJT is normally used to amplify small AC signals but it won't do anything unless it is provided with the proper DC voltages and currents. The process of providing the DC values is called biasing. One way to bias a transistor is as shown in Figure 4.2. The combination of VBB and RB will provide a constant DC current to the base. The collector current should be adjusted such that 1/2 of VCC is dropped across RC. VCE will also be 1/2 of VCC. This condition permits the AC output signal to be as large as it can possibly be. The collector voltage can "swing" from 0 to VCC. This type of biasing is never used in practical circuits because the collector current depends on the value of the DC beta of the transistor. The value of beta changes with temperature and is different for different transistors even of the same type number.

Schematic diagram.

Figure 4.8 Practical Audio Frequency Amplifier.

For a verbal description click here.

A complete practical one-stage audio frequency amplifier is shown in Figure 4.8. Approximately 2 volts DC are dropped across the emitter resistor which leaves a 10 volt range for VCE (2 volts to 12 volts). The static collector voltage is halfway between 2 and 12, which is 7 volts. The voltage at the base is approximately 2.6 volts. Capacitor C1 is necessary to prevent this voltage from interfering with the operation of or possibly even damaging the device which is to provide the signal to the amplifier. C3 blocks the DC at the collector from reaching the circuits or devices which may be connected to the output of the amplifier. R5 provides a charging path for C3 to make sure that there is no DC voltage present at the output even though there is no other load connected. Remember back in chapter 2 when we were talking about mixtures of AC and DC? Well, here it is. The RC networks are used just as described to pass the AC while blocking the DC.

The purpose of C2 requires a bit more explanation. If C2 were not present, the gain of the amplifier would be considerably reduced. It works this way. When the input signal goes positive, the base current increases and so does the emitter current. That increases the voltage drop across the emitter resistor and reduces the effect of the increasing signal. The effect of the signal could not be completely canceled out because, if the change in emitter current were completely canceled out, there would be no change in emitter current to cancel out the change in base current. The effect of the changing input signal is considerably reduced, which considerably reduces the gain of the circuit. Connecting C2 from the emitter to ground will prevent rapid changes in the emitter voltage and so the input signal will not have its effect reduced by any changes in the emitter voltage. The process of reducing the effective gain by removing the emitter bypass capacitor C2 is called emitter degeneration and, as we will learn in the next chapter, is not necessarily a bad thing.

Operating Point Stability

The set of conditions, IC, VCE, etc., are referred to collectively as the operating point. The operating point of a transistor must be stabilized against two types of changes. 1) The temperature can change and the value of beta is very temperature dependent. 2) Changing transistors, transistors can and do burn out and have to be replaced. The replacement most likely will not have the same value of beta as the original unit. There is no guarantee that a circuit will always be operated at room temperature. Air conditioning and heating systems can break down; portable devices can be carried outside on a summer or winter day. A device which fails to operate if the temperature gets above 85degrees or below 65degrees will not be very useful. If a transistor burns out it must be replaced to restore operation. Even if the replacement transistor has the same number as the original transistor, its beta may differ by as much as 30% from the original. If the circuit is not properly designed, the circuit may not work following the replacement of a defective transistor.

If the circuit of Figure 4.2 were used as an amplifier (and it could be) it would suffer from both problems described above. The circuit of Figure 4.8 does not suffer from these problems and here is why. The base current is small compared to the current flowing down through R1 and R2. The voltage divider which is constituted by R1 and R2 is lightly loaded and its output voltage will change only slightly as the base current changes. Suppose that the collector current tries to increase due to a temperature or a transistor change. The emitter current is IC + IB and IB is very much less than IC; therefore, IE is approximately equal to IC. As IC goes so goes IE. IE is trying to increase which will increase the voltage drop across RE which, in turn, will increase the voltage at the emitter. The voltage divider of R1 and R2 is holding the voltage at the base almost constant. An increase of emitter voltage while the base voltage is held constant will cause the forward bias on the base-emitter junction to be decreased and, therefore, decrease the base current. Remember we started out with the emitter current trying to increase which led to a decrease in base current. A decrease in base current will counteract the original increase in collector (emitter) current and the increase will not be as great as it would otherwise be. In fact, the emitter current will change only very slightly. If the collector (emitter) current tries to decrease, the voltage across RE will decrease, decreasing the emitter voltage while the base voltage is held constant. This increases the forward bias on the B-E junction and increases the base current which counteracts the decrease in collector (emitter) current.

If you were to set up the circuits of Figures 4.2 and 4.8 and put meters in the circuit to monitor the base and collector currents, you could see things happen. In the case of Figure 4.2 if heat were applied to the transistor the collector current would rise very rapidly. In the case of Figure 4.8 the collector current would change very slightly and the base current would drop off drastically. If the transistor were cooled, the currents would change in the opposite direction. A transistor with a higher beta will result in a larger collector current in the circuit of Figure 4.2 and a smaller base current in Figure 4.8.

The circuit of Figure 4.2 is called constant current biasing. It is never used in analog (as opposed to switching) circuits. The circuit of Figure 4.8 is called constant voltage biasing and it - or a variation of it - is used in all transistor circuits, including the internal circuitry of integrated circuits.

Circuit Analysis.

The circuit of Figure 4.8 is much easier to analyze if the voltage divider is replaced by its Thevenin's equivalent circuit as shown in Figure 4.9. Capacitors have been omitted because this is a DC analysis and capacitors are open circuits for DC. The values of VBB and RB are given by these equations

VBB = VCC R2 / (R1 + R2)           (4.18)

and

RB = (R1 R2) / (R1 + R2)           (4.19)

where R1 and R2 are the original base resistors as shown in Figure 4.8.

Schematic diagram.

Figure 4.9 Thevenin's Equivalent Circuit Replaces R1 and R2

For a verbal description click here.

If equations 4.18 and 4.19 seem to have "come out of the blue," you need to review the section on Thevenin's equivalent circuit (section 1.3 pages 41 to 46).

We will now write the loop equations for the circuit of Figure 4.9. Summing voltages in the base loop gives

VBB = RB IB + VBE + RE (IB + IC)           (4.20)

The voltage drop across RE (R4 in Figure 4.8) is IE RE but IE = IB + IC. The base current is given by

IB = IC / beta           (4.21)

Substituting equation 4.21 into equation 4.20 and solving for IC gives

IC = beta (VBB - VBE) / (RB + RE (1 + beta))           (4.22)

If beta is greater than 50 an error of less than 2% will be introduced by letting the (1 + beta) term in the denominator equal beta. Making this substitution and dividing through by beta we have

IC = (VBB - VBE) / (RE + RB / beta)           (4.23)

Equation 4.23 is probably the best one to use to calculate the collector current of a constant voltage biased BJT.

It is possible to make a further approximation but it must be applied with great care. In the denominator of equation 4.23 RB / beta may be much less than RE. If this is true the following equation may be used.

IC = (VBB - VBE) / RE     if and only if RB / beta << RE.           (4.24)

Example 4.8

Calculate the values of VBB and RB for the circuit of Figure 4.8.

Solution:

VBB is the unloaded output of the voltage divider consisting of R1 and R2

VBB = VCC R2 / (R1 + R2) = 12 v x 6.8 k ohms / (22 k ohms + 6.8 k ohms) = 2.83 v

RB is the parallel combination of R1 and R2

RB = R1 R2 / (R1 + R2) = 22 k ohms x 6.8 k ohms / (22 k ohms + 6.8 k ohms) = 5.19 k ohms

Example 4.9

If the transistor in Figure 4.8 has a beta of 150, what is the collector current?

Solution:

Which equation should we use? Equation 4.22 is the most exact form but the difference between beta and beta + 1 is only 0.66%. We might use equation 4.24 but that one is usually used only when beta is not given and a typical value must be assumed. We will use equation 4.23.

IC = 2.83 v - 0.6 v / (1.8 k ohms + 5.19 k ohms / 150) = 2.23 v / (1.8 k ohms + 0.03 k ohms) = 1.22 mA.

If equation 4.24 had been used the error would have only been 1.67%, which is well within acceptable limits. Perhaps another example will illustrate when equation 4.24 should not be used.

Example 4.10

In a circuit similar to Figure 4.8 VCC = 15 v, R1 = 100 K ohms, R2 = 47 k ohms, R3 = 4.7 k ohms, R4 = 3.3 k ohms and beta = 50. What is the collector current?

Solution:

Since beta = 50 this is a borderline case for the 2% rule but we will ignore beta + 1 and use equation 4.23. VBB = 15 v x 47 k ohms / (100 k ohms + 47 k ohms) = 4.80 v and RB = 100 k ohms x 47 k ohms / (100 k ohms + 47 k ohms) = 32.0 k ohms.

IC = 4.80 v - 0.6 v / (3.3 k ohms + 32.0 k ohms / 50) = 4.20 v / (3.3 k ohms + 0.64 k ohms) = 1.07 mA.

The Common Collector (Emitter-follower) Amplifier.

If the collector of a BJT is placed at AC ground potential while the input signal is applied between ground and base and the output signal is taken between ground and emitter, the collector is common to input and output. Such an amplifier is a common collector configuration but is commonly known as an emitter-follower. An AC coupled emitter-follower is shown in Figure 4.10.

Schematic diagram.

Figure 4.10 AC Coupled Emitter-follower.

For a verbal description click here.

The reason it is called an emitter-follower is because of that nearly constant 0.6 volt drop from base to emitter. How ever the base voltage may change, the emitter voltage is following along only 0.6 volts behind. To put it more precisely, for an NPN transistor the emitter voltage is 0.6 volts less then the base voltage. For a PNP transistor the emitter voltage is 0.6 volts greater than the base voltage. That 0.6 volts may not be important in the circuit of Figure 4.10 but in a DC coupled emitter-follower it may be very important.

The AC gain of an emitter-follower may be derived using the familiar common emitter parameters by drawing the equivalent circuit as in Figure 4.11. This circuit is a little difficult to follow (pun fully intended) and so the wires have been untangled in Figure 4.12. In equivalent circuits it is customary to omit DC biasing and capacitors because they add nothing to the AC circuit.

Schematic diagram.

Figure 4.11 Common Collector Equivalent Circuit.

For a verbal description click here.

Figure 4.12 Figure 4.11 with Wires Untangled.

For a verbal description click here.

Writing a loop equation around the outside loop gives

vin = ib hie + vo.           (4.25)

We will make the approximation that the base current ib is much less than the collector current ic, and the emitter current will be considered equal to the collector current. The current flowing through RL is the collector current hfeib and we have

vo = ib hfe RL.           (4.26)

If we solve equations 4.25 and 4.26 for ib and set them equal we have

vo / (hfe RL) = (vin - vo) / hie           (4.27)

Solving this equation for vo / vin and remembering that voltage gain is defined as vo / vin we have

AV = hfe RL / (hie + hfe RL)           (4.28)

Example 4.11.

A BJT has the following parameters, hie = 4 k ohms and hfe = 100. In an emitter-follower with a load (emitter) resistor of 1 k ohms, what is the voltage gain?

Solution:

AV = hfe RL / (hie + hfe RL) = 100 x 1 k ohm / (4 k ohms + 100 x 1 k ohm) = 0.962

The voltage gain of an emitter-follower is always slightly less than one. You may be wondering what use is an amplifier which slightly reduces the amplitude of the input signal. An emitter-follower has current gain. The current gain is equal to beta. For example, if you have a generator which can only supply 1 mA and you need to drive a load which requires 100 mA, an emitter-follower employing a BJT with a beta (or hfe) greater than 100 will allow the generator to drive the load provided there are no other losses in the circuit.

Input Resistance.

The input resistance of an emitter-follower is

Rin = vin / ib           (4.29)

If we rearrange equation 4.26 we have

vo / ib = hfe RL           (4.30)

Because the gain of an emitter-follower is approximately unity, vo = vin. Combining this approximation with equations 4.29 and 4.30 we have

Rin = hfe RL           (4.31)

The value of RL is the parallel combination of all resistances connected from the emitter to ground.

Example 4.12.

In the circuit of Figure 4.13 an emitter-follower is being used to drive an 8 ohm speaker. If R1 = R2 = 390 ohms, R3 = 15 ohms, beta = hfe = 75 and hie = 5 ohms, what are (a) the voltage gain and (b) the input resistance?

Figure 4.13 Emitter-follower Driving a Speaker

For a verbal description click here.

Solution:

(a) The gain is given by equation 4.28. RL in this equation is the parallel combination of R3 and the 8 ohm speaker which is 5.22 ohms.

AV = hfe RL / (hie + hfe RL = 75 x 5.22 ohms / (5 ohms + 75 x 5.22 ohms) = 0.987

(b) The input resistance is the parallel combination of the two 390 ohm resistors in the base circuit and the input resistance of the emitter-follower. The input resistance of the emitter-follower is given by equation 4.31.

Rin = hfe RL = 75 x 5.22 = 392 ohms

The total input resistance is the parallel combination of 390 ohms, 390 ohms and 392 ohms which is 130 ohms

Resistances in Parallel.

Some of you may be puzzled over why resistors are being treated as if they are connected in parallel when they are not connected to the same point in the circuit. If you are not puzzled, you may skip this section.

For example, the speaker and the 15 ohm resistor R3 have been treated as if they are in parallel when it is obvious that there is a capacitor connected between them. We are talking about AC not DC. The job of the capacitor is to block DC and pass AC to the speaker. The value of the capacitor has been chosen such that its reactance is small at the lowest frequency to be passed to the speaker. The capacitor is essentially a short circuit for AC. When the capacitor is replaced by a short circuit the speaker and the 15 ohm resistor are in parallel.

The two 390 ohm resistors in the base appear more like they are in series than in parallel. The AC signal is applied to the junction of the two resistors. One of the resistors goes to ground and the other one goes to the power supply (VCC). Within the power supply is a large capacitor connected from VCC to ground, or a voltage regulator, most likely both. For AC there is a short circuit connected from VCC to ground, which means that connecting a resistor to VCC is the same as connecting it to ground as far as AC is concerned. The input resistance of the transistor appears from base to ground and so is in parallel with the resistors in the base circuit.

Output Resistance.

To determine the output resistance of an emitter- follower we rearrange the equivalent circuit of Figure 4.12 and redraw it in Figure 4.14.

Schematic diagram.

Figure 4.14 Measuring Output Resistance of Emitter-follower.

For a verbal description click here.

The generator has been removed from the input and replaced by its internal resistance Rg. The load resistor has been removed and a generator has been connected to the output. The purpose of this is to apply a known voltage to the output and see how much current flows.

This can be done in the laboratory if care is taken not to drive the transistor into nonlinear regions of its I-V characteristic.

Summing the voltage drops around the outside loop gives

ib (Rg + hie) = V.           (4.32)

The current flowing in the generator is

I = ib (hfe + 1).           (4.33)

Eliminating ib between equations 4.32 and 4.33 and rearranging yields

V / I = (Rg + hie) / (hfe + 1)           (4.34)

Since RO = V / I we have

RO = (Rg + hie) / (hfe + 1)           (4.35)

Example 4.13.

In the circuit of Figure 4.13 calculate the output resistance which is effectively connected across the speaker. The output resistance of the generator is 50 ohms.

Solution:

The output resistance at the emitter of the transistor is given by equation 4.35. Rg must be the parallel combination of the generator resistance and the two resistors in the base circuit, 50 ohms in parallel with two 390 ohm resistors, which is 39.8 ohms

RO = (Rg + hie) / (hfe + 1) = (39.8 ohms + 5 ohms) / (75 + 1) = 0.589 ohms

The true output resistance is RO in parallel with 15 ohms but it isn't going to make much difference.

Rout = 15 ohms x 0.589 ohms / (15 ohms + 0.589 ohms) = 0.567 ohms.

Determining Transistor Parameters.

Transistor parameters may be found in a data sheet for the particular transistor or in a transistor data book. Data sheets for individual transistors may be obtained from the manufacturer often free of charge or for a nominal fee. These data sheets give all of the information you could possibly want. Data sheets give a range of values for each parameter. Whether you use an average value or the minimum value will depend on what you are trying to do.

Most data books do not give a value for hie at all. They usually give a range of values for the current gain. For audio frequencies the values of beta and hfe are the same. It is unusual for a data book to give a value of hfe at high frequencies.

If you need to know the value of hie and you can't find it anywhere you can estimate it. Hie = 25 mv / IB. Since IB = IC / beta hie can be estimated as

Hie = 25 mv x beta / IC           (4.36)

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

4.4 The Field Effect Transistor (FET).

There are two classes of field effect transistors, junction field effect transistors, JFETs, and metal oxide semiconductor field effect transistor, MOSFETs. We will begin with JFETs.

The Junction Field Effect Transistor.

Schematic diagram.

Figure 4.15 Junction Field Effect Transistor.

For a verbal description click here.

Figure 4.15 shows an N channel junction field effect transistor (JFET). If a battery is connected to the ends of the channel, (source and drain) current will flow as if it were a resistor. Like any other resistance device the resistance will depend on the length and cross-section area of the block of semiconductor material.

It is the cross-section area which is important in the JFET. If the gate to channel junction is reverse-biased the depletion region will grow outward from the gate as shown in Figure 4.16. As the depletion region grows larger the conduction cross-section area is decreased. The depletion region does not conduct current. As the reverse bias voltage on the gate-channel junction is increased, the resistance of the channel is increased. At comparatively large gate to channel voltages (about 10 volts) the channel resistance is approaching infinity. At a gate to channel voltage of zero the channel resistance is low, a typical value being 100 ohms.

Schematic diagram.

Figure 4.16 JFET with Reverse Bias on the Gate.

For a verbal description click here.

Figure 4.17 JFET Showing Pinch-off Effect.

For a verbal description click here.

When a battery is connected across the ends of the channel, another effect becomes evident. Because the gate reduces the channel cross-section area, the resistance in the region of the gate is increased and most of the voltage which is applied will be dropped across the region occupied by the gate. This voltage drop causes the channel near the top of the gate (Figure 4.17) to be more positive than the channel near the bottom of the gate. The net voltage across the gate-channel junction is greater at the top than it is at the bottom. Hence, the depletion region will be wider at the top of the gate than it is at the bottom, as shown in Figure 4.17. As the voltage applied to the ends of the channel is increased, this effect is increased until the channel becomes a constant current device. The channel does not become a negative resistance device (current decreases as voltage increases). The voltage at which the channel changes from a resistive device to a constant current device is called the pinch-off voltage.

Graph.

Figure 4.18 Drain Characteristics of a typical FET.

For a verbal description click here.

Figure 4.18 shows the drain characteristics of a typical junction field effect transistor. The semiconductor curve tracer in the laboratory will produce these curves on the screen of an oscilloscope. At drain-to-source voltages below the pinch-off voltage the drain-to-source path is a variable resistance while above the pinch-off voltage the drain-to- source path is a variable current source. Typical values for the pinch-off voltage are less than one volt.

The Metal Oxide Semiconductor Field Effect Transistor.

The metal oxide semiconductor field effect transistor (MOSFET) is at the heart of most pocket calculators and microcomputers. Its construction is quite similar to the JFET except that the gate is a metal plate which is insulated from the channel by a thin layer of silicon dioxide instead of a region of opposite type semiconductor.

The P-N junction in a JFET is not used as a diode. It operates in the reversed biased condition all of the time. The gate portion of the FET (P type semiconductor in the example shown) is only being used as a conductor. The depletion region on the gate side of the junction is being used as an insulator. Silicon dioxide is a much better insulator than is a reverse-biased P-N junction and metal is a better conductor than is P type semiconductor. So the replacements are made and the device works almost the same as it did before. In an N channel MOSFET if the gate is made negative with respect to the source the negative charge on the gate will repel negative charges in the semiconductor channel and create a depletion region around the gate the same as with a JFET. The principle of pinch-off works the same way as well.

Schematic diagram.

Figure 4.19 Metal Oxide Semiconductor FET.

For a verbal description click here.

The major difference between a JFET and a MOSFET is the gate or input resistance. For a JFET the typical input resistance is typically 1012 ohms while for a MOSFET the input resistance is typically 1016 ohms. MOSFETs are used in equipment which can measure currents in the picoampere range and below. Because of the high resistance of MOSFETs in a switching application, when they are off, they are really off. For this reason they find applications in very low power devices such as watches, calculators and lap-top computers.

The substrate is the foundation on which the MOSFETs are constructed. In the case of discreet MOSFETs (as opposed to integrated circuits) the substrate may be brought out to a connecting lead of its own so the user may connect it as desired. The substrate is usually connected to the source although a P type substrate may be connected to the most negative point in a circuit. When MOSFETs appear in an integrated circuit, the substrate is the foundation on which the IC is constructed.

Enhancement Mode MOSFETs.

MOSFETs can be divided into two groups, depletion mode and enhancement mode. The group we have been talking about up until now are the depletion mode type, so called because they work by creating a depletion region in the channel. Depletion mode MOSFETs are "on" at zero gate voltage and a negative gate voltage will turn them "off".

An enhancement mode MOSFET is "off" at zero gate voltage and a positive gate voltage (for an N channel) will turn it "on". The drawing of an enhancement mode MOSFET is shown in Figure 4.20.

Schematic diagram.

Figure 4.20 Enhancement Mode MOSFET.

For a verbal description click here.

In the case of an N channel MOSFET the substrate is P type semiconductor. Near the gate (between the source and drain) the substrate has been doped with both donor and acceptor impurities. The acceptors slightly outnumber the donors so the result is a lightly doped P type semiconductor. When the gate voltage is zero the P type semiconductor between the source and drain serves to block current between source and drain. When a positive voltage is placed on the gate, holes are repelled away from the gate. Once the holes are gone from this region, the donor impurities predominate and the material near the gate turns from P type to N type semiconductor. Current may now flow from source to drain.

Enhancement mode MOSFETs are very rarely used as amplifiers. They most often appear in digital integrated circuits where they are used as switches.

Schematic diagram.

Figure 4.21 Schematic Symbols for Various Kinds of FETs.

For a verbal description click here.

Figure 4.21 shows schematic symbols for the various kinds of FETs. The FETs in the top row are N channel and the FETs in the bottom row are P channel. A good memory device is "the arrow always points toward the N type semiconductor". The bottom connection on each FET is the source. The connection on the left of each FET is the gate and the connection at the top is the drain. For MOSFETs the connection at center-right is the substrate. The substrate is shown connected internally to the source in these symbols. In some discreet MOSFETs the substrate is brought to a separate lead.

For N channel FETs the drain is made more positive than the source. JFETs and depletion mode MOSFETs are fully on at zero gate potential. For operation as an amplifier, the gate is made more negative than the source. Enhancement mode MOSFETs are off at zero gate potential. For operation as an amplifier the gate is made more positive than the source.

For P channel FETs the drain is made more negative than the source. JFETs and depletion mode MOSFETs are fully on at zero gate potential. For operation as an amplifier, the gate is made more positive than the source. Enhancement mode MOSFETs are off at zero gate potential. For operation as an amplifier the gate is made more negative than the source.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

4.5 The FET as a Switch.

FETs are usually not used to turn lamps and relay coils on and off. They find two major applications, as logic switches and as analog (or signal) switches. We will cover the latter application first.

The term analog switch may seem to be mutually contradictory. What is meant is to interrupt an analog signal to turn it off and on as desired or to select among several sources of signal. An example of the latter is the source selector in a stereo receiver. The switch allows the user to select among several program sources. Classically this has been accomplished by a mechanical switch. Newer designs which include remote control require electronic switching. This electronic switching may be accomplished using an FET.

Figure 4.22 shows an FET being used to switch an analog signal. The control voltage is +15 volts to turn the switch on and -15 volts to turn the switch off. The signal applied to the input must never exceed approximately plus or minus 10 volts. If the input signal comes too close to +15 volts, the switch can be turned off when it is supposed to be on. If the input signal comes too close to -15 volts, the switch can be turned on when it is supposed to be off.

Schematic diagram.

Figure 4.22 Analog Switch Using a JFET.

For a verbal description click here.

When the control voltage is positive, the diode is reverse biased, which disconnects the control voltage from the switched signal. The 100 k ohm resistor will cause the gate of the FET to be at the same potential as the source and the FET will be fully on. Signals applied to the input will appear at the output with little distortion or attenuation. When the control voltage is negative, the diode will be forward biased and the gate will be at approximately -15 volts. This will cause the FET to be turned off and very little or no signal from the input will be passed to the output. The 100 k ohm resistor will be connected from the -15 volt control signal to the signal source. In order for this circuit to work properly the signal source must have a low resistance for DC.

Another type of analog switch is the CMOS (complementary MOS) device which comes in an integrated circuit. The IC operates from a single power supply (VDD) of up to 15 volts. The signal source must never go negative nor more positive than VDD. It is best for the AC signal source to be added to a DC of 1/2 VDD. If the signal part of the switch is forced outside of these limits by more than 0.7 volts the IC will, not may, but will be destroyed. The control voltage for this IC is zero to turn the switch off and VDD to turn the switch on.

A partial schematic diagram of the internal workings of this IC switch is shown in Figure 4.23. The triangle with a circle on its nose is an inverter. This is a switching device. If its input is zero, its output is VDD. If its input is VDD, its output is zero.

Schematic diagram.

Figure 4.23 MOSFET Analog Switch.

For a verbal description click here.

The circuit is called complementary because it employs an N channel and a P channel MOSFET. When the control voltage is zero, the N channel FET has a gate voltage of zero and the P channel FET has a gate voltage of VDD. That turns both of them off. If the signal source is at a potential of VDD the P channel FET will still be off and the N channel FET will be negatively biased, which makes doubly certain that it will be off. If the signal source is at zero potential the N channel FET will still be off and the P channel FET will be positively biased, which makes doubly certain that it will be off. When the control input changes to VDD the N channel FET has a positive VDD on its gate while the P channel FET has zero potential on its gate. If the signal is at zero potential the N channel FET will be on but the P channel FET will be off. If the signal is at VDD the P channel FET will be on, but the N channel FET will be off. The two FETs are in parallel. So as long as one of them is on, the switch is on.

The inverter is another example of how FETs are used as switches. Figure 4.24 shows the circuit of the inverter which was shown as a triangle in the circuit of Figure 4.23. When the input signal is at zero volts Q1 is biased fully on and Q2 is fully off. Thus the output is held to VDD. The output is high for a low input. If the input is VDD (high) Q1 is biased off (zero potential between gate and source) and Q2 is on. The output is low because it is held to ground by Q2. Whatever the state of the input, the output assumes the opposite state.

Schematic diagram.

Figure 4.24 CMOS Inverter.

For a verbal description click here.

There are ICs which are known as invertors which contain six such circuits. Although they are not intended for use as analog devices, the input may be biased at 1/2 VDD and as such they make excellent amplifiers. (Which goes to show that if someone designs something, someone else will figure out a way to use it wrong and make it work.)

Example 4.14.

A P channel depletion mode FET has -10 volts on its gate with respect to its source. Is it on or off?

Solution:

A P channel depletion mode FET is on at zero potential and its drain current decreases as the gate is made positive. At +10 volts it would most likely be off but at -10 volts it is extremely on.

Example 4.15.

An N channel enhancement mode MOSFET has a gate bias of zero volts. Is this FET on or off?

Solution:

At zero volts between gate and source any enhancement mode MOSFET is off. The FET is off.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

4.6 The FET as an Amplifier.

The FET has only two small-signal parameters, the drain resistance rd and the transfer conductance, called by contraction-loving electrical engineers transconductance Gm. The transconductance is defined as the AC drain current divided by the AC gate to source voltage with the drain to source voltage held constant.

Gm = id / vgs with vds = 0           (4.37)

The drain resistance is defined as the AC drain to source voltage divided by the AC drain current with the gate to source voltage held constant.

rd = vds / id with vgs = 0           <4.38)

Figure 4.25 Small Signal Equivalent Circuit for an FET.

For a verbal description click here.

The Common Source Amplifier.

The common source equivalent circuit we will work from is shown in Figure 4.26. The input is an open circuit, as is the input of an FET. The output circuit consists of a current source which is dependent on the voltage between the gate and source. The drain resistance is in parallel with the current source. Any load is connected in parallel with the drain resistance.

Schematic diagram.

Figure 4.26 Equivalent Circuit of Common Source Amplifier.

For a verbal description click here.

The output voltage vo is the current source times the parallel combination of rd and RL.

vo = -vin Gm rd RL / (rd + R/L)           (4.19)

Dividing through by vin and making the substitution AV = vo / vin we have,

AV = -Gm rd RL / (rd + R/L)           (4.20)

where RL is the parallel combination of all resistors connected from the drain to AC ground.

Amplifier Biasing.

A properly biased common source N channel JFET amplifier is shown in Figure 4.27. The battery VDD provides the positive bias for the drain and the battery VGG provides the negative bias for the gate. While this two-battery circuit will certainly work, it is not very practical.

Schematic diagram.

Figure 4.27 JFET Amplifier Using Battery Bias.

For a verbal description click here.

Figure 4.28a shows how the circuit may be rearranged without altering its operation. The negative connection point of VDD has been moved to the negative end of VGG, reducing VDD by the amount of VGG. This reduction is usually not significant enough to have any adverse effect. Notice that the polarity of VGG is the same as would be produced by the drain-source current flowing through a resistor in the source. Figure 4.28b shows the substitution of a resistor and a filter capacitor for the battery. The value of the source resistor sets the operating point.

Schematic diagram.

Figure 4.28 Converting Battery Biasing to Self Biasing.

For a verbal description click here.

Unlike for the BJT the operating point of the FET cannot be easily calculated. Some texts present a graphical solution which requires having a set of characteristic curves for the FET similar to those in Figure 4.18. Semiconductor manufacturers do not supply these curves for a very good reason. There is so much difference between FETs of the same type number that a set of curves would be useless. A semiconductor curve tracer interfaced to a computer and plotter could produce a set of curves for any individual FET and the graphic solution could be performed. Such a solution would be valid for only that one particular FET. Another FET would require another set of curves and a new graphical solution. We will not waste our time learning a useless procedure.

The one and only advantage that FETs have over BJTs is their very high input resistance. In commercially designed equipment it is usual to see only one or two FETs among thirty or more BJTs. Even with such limited use, setting the operating point is a problem. There are two basic solutions. One is to use a trimming potentiometer (a screwdriver- adjusted variable resistor) as the source resistor as shown in Figure 4.29(a). Part of the calibration procedure includes setting the proper operating point of the FET amplifier. The other solution is to use the FET in conjunction with a BJT in an arrangement which will automatically set the operating point of the FET as shown in Figure 4.29(b).

Schematic diagram.

Figure 4.29 Practical JFET Amplifier.

For a verbal description click here.

Which one is used depends on who is to build the circuit. If the circuit is contained in a DIY article or a kit the reader or buyer is the one who constructs it. He does not receive a bill for his time at the end of each month so there is no cost associated with having him adjust the pot for the proper operating point.

If the circuit is in a device which will be manufactured in the tens or hundreds of thousands and sold in retail stores the eventual owner cannot be held responsible for adjusting the pot. It must be done on the assembly line by a worker. It is an unavoidable fact that workers have to be paid. It is also a fact that workers do occasionally make errors. The expense of paying someone to adjust the pot will buy a lot of transistors. While the circuit at (b) is mor costly in terms of parts it is less expensive when fabrication costs are taken into account.

The (b) circuit works because the BJT sets the current through both transistors and holds it constant. The collector voltage, also the source voltage adjusts itself to what ever value is necessary to make the FET conduct the correct amount of current. The gate resistor is returned to the base to insure that the BJT will never be forced into saturation by the required gate to source voltage of the FET. The gate resistor in either circuit can easily go as high as 10 meg ohms if necessary.

Example 4.16.

In the circuit of Figure 4.29 the drain resistance of the FET is 130 k ohms and the transconductance is 600 micro mhos. What is the amplifier gain?

Solution:

RL consists of the parallel combination of 47 k ohms and 100 k ohms, which is 32.0 k ohms. The gain of the amplifier is

AV = -Gm rd RL / (rd + RL)

AV = -600 micro mhos x 130 k ohms x 32 k ohms / (130 k ohms + 32 k ohms) = -15.4

The Source-follower Amplifier.

Because the FET is used for its high input impedance, it is most often seen as a source-follower, as shown in Figure 4.30. The FET source-follower is characterized by very high input impedance, low output impedance and slightly less than unity gain.

Schematic diagram.

Figure 4.30 Source-follower Using N Channel JFET.

For a verbal descriptionclick here.

Figure 4.31 Equivalent Circuit of a Source-follower.

For a verbal description click here.

The equivalent circuit of a source-follower is shown in Figure 4.31. Summing the voltages around the outside loop we Have

Vin = vgs + vo           (4.21)

In a source-follower the value of RL is usually much less than rd so we can neglect rd in the following equation. The output voltage is given by

Vo = vgs Gm RL           (4.22)

Solving equations 4.21 and 4.22 for vgs and setting them equal gives

Vin - vo = vo / (Gm RL)           (4.23)

Solving for vo / vin and remembering that AV is defined as vo / vin we have.

AV = Gm RL / (Gm RL + 1)           (4.24)

As with the emitter-follower, the output impedance of the source-follower can be obtained by shorting the input, connecting a generator V across the output and determining the current I which flows. The output resistance is V/I. The equivalent circuit is shown in Figure 4.32.

Schematic diagram.

Figure 4.32 Finding Output Resistance of a Source-follower.

For a verbal description click here.

The current flowing through rd will be neglected. The current supplied by the generator is,

I = Gm vgs           (4.25)

Because the input is short circuited vgs = V and so,

RO = V / I = 1 / Gm.           (4.26)

The output resistance of a source-follower circuit is the parallel combination of the results of equation 4.26 and the resistor in the source of the FET. Note that unlike the emitter-follower the generator resistance has no effect on the output resistance.

Example 4.17.

In the circuit of Figure 4.30 the value of RS is 1 k ohm and the transconductance of the FET is 3000 micro mhos. What are (a) the voltage gain and (b) the output resistance of the circuit?

Solution:

(a) The gain is given by

AV = Gm RL / (Gm RL + 1)

AV = 3000 micro mhos x 1 k ohm / (3000 micro mhos x 1 k ohm + 1) = 0.75

(b) The output resistance is

RO = 1 / Gm = 1 / (3000 micro mhos) = 333 ohms.

The output resistance is 333 ohms in parallel with 1 k ohm which is 250 ohms.

You may be surprised by the low gain which is available from an FET source-follower. Designers seldom use a simple source-follower for just that reason. One very popular arrangement employs an N channel FET and a PNP BJT as shown in Figure 4.33. This circuit is often used as the input stage in oscilloscopes and AC voltmeters. This circuit is normally designed such that the collector current of the BJT is greater than the source current of the FET. This allows the BJT and the resistors to predominate in setting the operating point which eliminates the need for a trimming pot. Even so there is a DC offset between the input and output. The output may be anything from 1 to 4 volts more positive than the input. In DC coupled amplifiers such as those found in oscilloscopes this offset must be accounted for in some way to avoid adding it to the output.

Schematic diagram.

Figure 4.33 Unity Gain Impedance Buffer Using an FET.

For a verbal description click here.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

4.7 Differential Amplifier.

In the next chapter we will take up the study of operational amplifiers. A very important aspect of the op amp is its differential or difference input. A differential input consists of two input points with respect to ground. The circuit subtracts the two input signals. Thus the output of a differential amplifier is

VO = AV (V2 - V1)           (4.37)

where AV is the voltage gain of the amplifier, V1 is the signal applied to the noninverting input and V2 is the signal applied to the inverting input.

The noninverting input is so named because an AC signal applied to this input is not inverted in phase. The inverting input is so named because an AC signal applied to this input is inverted in phase.

Schematic diagram.

Figure 4.34 BJT Differential Amplifier.

For a verbal description click here.

Figure 4.34 shows a differential amplifier using BJTs. Q1 and Q2 work together to form the differential amplifier. Transistor Q3 along with R7, R8 and R9 form a constant current sink for the emitters of Q1 and Q2. The resistor network consisting of R7 and R8 keeps the voltage at the base of Q3 very stable regardless of changes in the base current of Q3. A very stable base voltage means that the emitter current will also be very stable and the collector current will also be very stable. Q3 carries the sum of the emitter currents of Q1 and Q2. If the emitter current in Q1 changes by a certain amount I, the emitter current of Q2 must change by an amount equal in magnitude and opposite in sign -I. This helps to maintain equal amounts of gain for both inputs.

Resistors R5 and R6 introduce emitter degeneration in Q1 and Q2, which lowers and further equalizes the gains. In an amplifier of this type emitter degeneration is not a bad thing. The gain is set by the ratio of R3 to R5 rather than the parameters of the transistors. It should be noted that R3 = R4 and R5 = R6. If maximum gain is desired resistors R5 and R6 may be replaced by pieces of wire but Q1 and Q2 must be very closely matched (have identical parameters) if the gains from the two inputs are to be equal in magnitude.

The output may be taken in either one of two ways. Output 1 is taken between the collectors of Q1 and Q2 as shown. This is a differential or as it is sometimes called a push-pull output. It is suitable for driving another differential amplifier or a balanced transmission line. Some oscilloscopes employ differential amplifiers from beginning to end. The deflection plates of a CRT must be driven from a differential output for best performance.

Output 2 is taken between the collector of Q1 and ground. The input marked with a - sign is the inverting input. A positive-going signal applied to the base of Q1 will cause its collector current to increase. That increase will cause a larger voltage drop across R3 which will cause the voltage at the collector of Q1 to decrease. The input marked with a + sign is the noninverting input. A positive- going signal applied to the base of Q2 will cause the collector current of Q2 to increase. That increase in collector current of Q2 must be mirrored by a decrease in the collector current of Q1. A decrease in the collector current of Q1 will cause the drop across R3 to decrease. The decreased voltage drop across R3 will increase the voltage at the collector of Q1. In case you forgot, we started with an increase in the input voltage which shows that the input marked with a + sign is the noninverting input.

Schematic diagram.

Figure 4.35 FET Differential Amplifier.

For a verbal description click here.

Figure 4.35 shows a differential amplifier employing FETs instead of BJTs. You will note that Q3, R7, R8 and R9 have been replaced by a symbol which you may have never seen before. This is the symbol for a constant current sink. It is commonly used when showing internal schematic diagrams of integrated circuits. The FET differential amplifier functions in exactly the same way as the BJT differential amplifier except its input impedance is much higher. Because FETs are even harder to match than BJTs, R5 and R6 are still necessary. Indeed they may be chosen to bring the gain down close to unity in order to balance the gains of the two transistors. FETs are used to obtain high input impedance. When large amounts of gain are needed, BJTs will be found in the circuit. If both are needed in the same amplifier, you will find both FETs and BJTs in the circuit.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

4.8 Problems.

  1. The collector current of a BJT begins in the emitter, flows through the base region and ends up in the collector region. (This current refers to charge carrier current, not conventional current.) What kind of charge carriers (minority or majority) make up the collector current when it is in the (a) emitter region, (b) the base region, and (c) the collector region?

  2. In a PNP transistor the base current (conventional current) flows out at the base terminal. Where does it flow in?

  3. In the circuit of Figure 4.3 the values are as follows: VCC = 28 volts, beta = 150, VINON = 5 volts, VINOFF = 0 and RB = 8.2 k ohms. (a) If the lamp current is 65 mA, will the lamp be turned fully on? (b) After a few years the lamp burns out and someone replaces it with a lamp which draws 100 mA. Will this new lamp be fully turned on by the BJT switch? What will be the lamp current?

  4. In the circuit of Figure 4.4 VINON = 10 volts and VINOFF = 2 volts. R1 = 3.3 k ohms and R2 = 820 ohms. All other circuit parameters are as shown in the figure. Is the switch on when the control signal is high and off when the control signal is low? Show detailed calculations for both off and on states.

  5. For the starting conditions of problem 4, all of the students involved with designing and building the circuit have graduated. The transistor burns out and the equipment must be repaired because someone is giving a paper next week. Someone finds an old germanium transistor in a drawer and in desperation installs it in the circuit. The replacement has a beta of 100 but VBE to turn it on is 0.15 volts. Is the switch on when the control signal is high and off when the control signal is low? Show detailed calculations for both off and on states.

  6. For the starting conditions of problem 4, all of the students involved with designing and building the circuit have graduated. The transistor burns out and the equipment must be repaired because someone is giving a paper next week. Someone finds an old transistor in a drawer and in desperation installs it in the circuit. The replacement transistor is a silicon unit but its beta is 25. Is the switch on when the control signal is high and off when the control signal is low? Show detailed calculations for both off and on states.

  7. A transistor has the following parameters, hie = 2.5 k ohms and hfe = 85. If RL = 3.3 k ohms what is the gain of the common emitter amplifier?

    8. Figure 4.36 Common Emitter and Emitter-follower Amplifier.
    For Q1, hie = 2 k ohms and hfe = beta = 120.
    For Q2, hie 30 ohms and hfe = beta = 55.

    For a verbal description click here.

  8. Calculate the value of the collector current of Q1 in the circuit of Figure 4.36. Do not use an equation which is any more complicated than necessary.

  9. Calculate the value of the collector current of Q2 in the circuit of Figure 4.36. Do not use an equation which is any more complicated than necessary.

  10. Calculate the voltage gain of the emitter-follower stage in Figure 4.36. Remember to take everything into account when determining RL.

  11. Calculate the voltage gain of the common emitter stage in Figure 4.36. Remember to take everything into account when determining RL.

  12. The input resistance of a common emitter amplifier is equal to hie. What is the input resistance of the circuit of Figure 4.36?

  13. In the circuit of Figure 4.36 if the 75 ohm load were removed, what would be the output resistance of the circuit?

  14. What must the gate voltage be of an enhancement mode N channel MOSFET to (a) turn it on and (b) turn it off?

  15. What must the gate voltage be of an enhancement mode P channel MOSFET to (a) turn it on and (b) turn it off?

  16. Is it possible to make the circuit of Figure 4.23 work with depletion mode MOSFETs? Why or why not?

  17. Is it possible to make the circuit of Figure 4.24 work with depletion mode MOSFETs? Why or why not?

  18. A common source FET amplifier has a load resistance of 1.5 k ohms. The FET has a Gm of 3600 micro mhos and an rd of 200 k ohms. What are (a) the input resistance, (b) the voltage gain and (c) the output resistance?

  19. An FET source-follower has a load resistor of 10 k ohms. The FET has a Gm of 2600 micro mhos and an rd of 200 k ohms. What are (a) the input resistance, (b) the voltage gain and (c) the output resistance including the 10 k ohm load resistor?

  20. In the circuit of Figure 4.34 the collector current of Q3 is 1 mA. If the collector current of Q1 is 0.340 mA, what is the collector current of Q2?

  21. In the circuit of Figure 4.35 if the drain current of Q1 increases by 50 microamps, what happens to the drain current of Q2?

  22. If the gain of a differential amplifier is 10, V1 = +1.0 volt and V2 = +1.0 volt, what is the output voltage?

  23. If the gain of a differential amplifier is 100, V1 = +1.00 volt and V2 = +1.01 volt, what is the output voltage? Be sure to give sign as well as magnitude.

  24. If the gain of a differential amplifier is 100, V1 = +1.01 volt and V2 = +1.00 volt, what is the output voltage? Be sure to give sign as well as magnitude.

  25. If the gain of a differential amplifier is 100, V1 = -1.00 volt and V2 = -1.01 volt, what is the output voltage? Be sure to give sign as well as magnitude.

  26. If the gain of a differential amplifier is 100, V1 = -1.01 volt and V2 = -1.00 volt, what is the output voltage? Be sure to give sign as well as magnitude.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

4.9 Answers to problems.

  1. Part a, majority. Part b, minority. Part c, majority.

  2. At the emitter.

  3. Part a, required base current = 0.433 mA, supplied base current = 0.536. Lamp is fully on. Part b, required base current = 0.667 mA. The lamp is not fully on. Lamp current = 80.4 mA.

  4. On state. Required IB = 0.793 mA. Supplied IB = 2.12 mA. Switch is on. Off state. VBE unloaded = 0.398 V. Switch is off.

  5. On state. Required IB = 0.793 mA. Supplied IB = 2.80 mA. Off state. VBE unloaded = 0.398 V. BE is forward biased. Supplied IB = 0.378 mA. The switch will be between the on and off states.

  6. On state. Required IB = 3.17 mA. Supplied IB = 2.12 mA. The switch is not fully on. Off state. Same as in problem 4.

  7. AV = 112.

  8. IC = 1.20 mA by equation 4.24.

  9. IC = 47.2 mA by equation 4.23.

  10. AV = 0.987.

  11. AV = 43.6. Hint: There are 4 components that have to be added in parallel to make up RL.

  12. Rin = 1.57 k ohms.

  13. RO = 16.4 ohms.

  14. (a) Positive, (b) 0.

  15. (a) Negative, (b) 0.

  16. No. In the "on" state all is fine but in the off state one of the FETs will always be on.

  17. No. Both FETs would be on, draw excessive current, and burn themselves out.

  18. 1012 ohms, (b) -5.36, (c) 1.49 k ohms.

  19. 1012 ohms, (b) 0.963, (c) 370 ohms.

  20. ICQ2 = 0.660 mA.

  21. The drain current of Q2 will decrease by 50 microamps.

  22. VO = 0 V.

  23. VO = + 1.00 V.

  24. VO = - 1.00 V.

  25. VO = - 1.00 V.

  26. VO = + 1.00 V.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

This page copyright © Max Robinson. All rights reserved.


Chapter 5   Applying Feedback To Amplifier Circuits.

5.1  Some Preliminary Information.
5.2  The Negative Feedback Equation.
5.3  The Special Case of the Inverting Amplifier.
5.4  Frequency Response and Stability.
5.5  Gain Accuracy and Precision.
5.6  Other Benefits of Negative Feedback.
5.7  Some Practical Circuits.
5.8  Positive Feedback, Oscillators.
5.9  Problems.
5.10 Answers to Problems.

Chapter 5.

Applying Feedback To Amplifier Circuits.

If you have ever operated your school's sound system or have participated in a rock or country music band, you probably know the word "feedback". Feedback occurs when a fraction of the output signal is introduced into the input of an amplifier. The kind of feedback that sound system operators are familiar with is the squeal of positive feedback. This kind of feedback is undesirable but there are kinds of feedback which cause good things to happen. In this chapter we will study the desirable kinds of feedback.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

5.1 Some Preliminary Information.

When feedback is introduced electronically its phase can be controlled. The signal which is fed back may reinforce or partially cancel the input signal. Feedback which reinforces the input signal is called positive feedback. Feedback which partially cancels the input signal is called negative feedback. We will begin our study of feedback with negative feedback.

A major confusion factor has developed in teaching negative feedback because of a split among electrical engineers. One group, the audio engineers, sets out to derive the feedback equation by assuming a generalized amplifier. The equation they derive has a minus sign in the denominator. The other group, control systems engineers, assumes a net 180 degree phase shift in the feedback loop. In other words they assume that the feedback is always negative. The equation they derive has a plus sign in the denominator.

That would be bad enough by itself but the operational amplifiers (op amps) which are so useful have grown out of the control systems branch of electrical engineering. What this means to a teacher teaching a survey course in electronics is that when teaching feedback applied to audio amplifiers the equation with the minus sign must be used and when teaching op amps the equation with the plus sign must be used. That has proven to be so confusing to students that there is doubt as to whether they ever learned anything about feedback. In this book we will define away the problem by adopting one convention and sticking to it. If you look up the subject of feedback in another textbook you may find more confusion than help.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

5.2 The Negative Feedback Equation.

Schematic diagram.

Figure 5.1 Noninverting Amplifier with Negative Feedback.

For a verbal description click here.

Figure 5.1 shows an amplifier with negative feedback applied. The amplifier is a differential amplifier which was discussed in the closing section of chapter 4. The signal generator is applied to the noninverting input of the amplifier. A fraction, beta, of the output signal is fed back to the inverting input. The difference between the two signals is amplified by the factor A and appears at the output.

The output of a differential amplifier is given by equation 4.27 which is repeated here.

VO = A (V1 - V2)           (5.1)

As shown in Figure 5.1 V1 is the input signal and V2 is the fraction of the output signal beta VO. If we make these substitutions into equation 5.1 we have

VO = A (VIN - beta VO).           (5.2)

Solving this equation for VO / VIN we have the feedback equation.

VO / Vin = A / (1 + A beta)           (5.3)

The term VO / VIN is called the closed loop gain and is given the symbol A', thus,

A' = A / (1 + A beta)           (5.4)

where A' is the closed-loop gain, A is the open-loop gain and beta is the fraction of the output which is fed back to the input. This equation is to amplifiers as Ohm's law is to electric circuits. Memorize it.

For the noninverting amplifier beta is given by

beta = R1 / (R1 + R2)           (5.5)

This beta is not to be confused with the BJT beta. They are not the same thing nor are they related in any way.

Let us be sure we understand all of the terms associated with feedback. The open-loop gain (A) is the gain of the amplifier without any feedback circuits connected. The closed-loop gain (A') is the gain of the amplifier after the feedback has been connected. Beta, (it has no other name,) is that fraction of the output which is fed back to the input.

Example 5.1.

An amplifier has an open-loop gain of 250 and a beta of 0.02. What is its closed-loop gain?

Solution:

The closed-loop gain is given by

A' = A / (1 + A beta) = 250 / (1 + 250 x 0.02) = 41.67.

Note that we indicate this gain as a positive number. The circuit of Figure 5.1 is a noninverting amplifier which has no phase inversion. Such an amplifier has the signal applied to the noninverting input.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

5.3 The Special Case of the Inverting Amplifier.

When the signal is applied to the inverting input, the circuit is called an inverting amplifier. An AC signal applied to the amplifier will be inverted by 180 degrees. When the value of the gain is stated it must be given as a negative quantity. The circuit of an inverting amplifier is shown in Figure 5.2. If you look in other texts similar to this one you are not likely to find the derivation of the gain of an inverting amplifier. The reason is that the equation which results from an exact derivation is slightly different from the one for a noninverting amplifier. Let us derive the equation and then we will discuss the difference.

Schematic diagram.

Figure 5.2 Inverting Amplifier with Equation Loops Indicated.

For a verbal description click here.

In Figure 5.2 the loops and polarity of all voltage drops are clearly marked. Consider these markings as a "snapshot" taken at the peak of the sine wave. Current flows from left to right through R1 and R2 thus causing the voltage drops to be as indicated on R1 and R2. Because of the nature of the amplifier the output voltage (VO) must have the opposite polarity as the input voltage (Vsig).

If we write the loop equations around the loops labeled "equation 5.5" and "equation 5.6" we have

VIN = I R1 + Vsig           (5.5)

And

Vsig = I R2 - VO.           (5.6)

The current I is the same in both resistors. The input resistance of the amplifier is very high and in actual practice the magnitude of Vsig is very small; hence any current flowing into the inverting input is very, very small. Therefore the currents in R1 and R2 are equal. Solving equations 5.5 and 5.6 for I and setting them equal gives

(VIN - Vsig) / R1 = (VO + Vsig) / R2           (5.7)

The nature of the amplifier requires that VO = A Vsig; therefore, Vsig = VO / A. Making this substitution into equation 5.7 gives.

(VIN - VO / A ) / R1 = (VO + VO / A) / R2           (5.8)

If we multiply equation 5.8 through by A, R1 and R2 we get

R2 VIN A - R2 VO = R1 VO A + R1 VO.           (5.9)

After collecting VO terms, factoring out VO and performing some additional algebraic calisthenics we get

VO / VIN = R2 A / (R2 + R1 A + R1)           (5.10)

Remembering that A' = VO / VIN and dividing numerator and denominator by R2 gives.

A' = A / (1 + R1 / R2 A + R1 / R2)           (5.11)

For the inverting amplifier we will now define beta as follows.

beta = R1 / R2           (5.12)

If we substitute equation 5.12 into equation 5.11 and factor out beta we now have,

A' = A / (1 + beta (A + 1)).           (5.13)

Compare equation 5.13 with equation 5.4 which is the gain for a noninverting amplifier.

You are challenged to find equation 5.13 in any other text on this level. If all starting assumptions are correct and all of the algebra has been correctly done, the solution must be correct. Careful laboratory measurements using an amplifier with a low open-loop gain have shown that the equation does accurately predict the gain of an inverting amplifier. Equation 5.13 is the correct equation for the gain of an inverting amplifier.

A Difference Which Makes No Difference Is No Difference.

If the open-loop gain A is much greater than unity, equation 5.13 may be approximated by equation 5.4 with little detectable error. In actual practice open-loop gains are almost never less than 200 and may be as high as 107. Adding one to these large numbers will not make any practical difference. Unless the open-loop gain is less than 50, you need not bother with equation 5.13. Use equation 5.4.

Example 5.2.

An inverting amplifier has an open-loop gain of -10. The values of the feedback resistors are R1 = R2 = 10 k ohms. (a) What gain is predicted by equation 5.4? (b) What gain is predicted by equation 5.13? (c) What is the percent error of equation 5.4?

Solution:

For an inverting amplifier beta = R1 / R2 and if R1 = R2, beta = 1.00. (a) The gain predicted by equation 5.4 is.

A' = A / (1 + A beta) = 10 / (1 + 10 x 1) = -0.9091.

(b) The gain predicted by equation 5.13 is.

A' = A / (1 + beta ( A + 1)) = 10 / (1 + 1 x 11) = -0.8333.

(c) The result of equation 5.13 is the standard; therefore, the percent error is + 9.10%

Example 5.3.

An inverting amplifier has an open-loop gain of -500. R1 = 10 k ohms and R2 = 200 k ohms. What is the closed-loop gain of the amplifier?

Solution:<

The value of beta is beta = R1 / R2 = 10 k ohms / 200 k ohms = 0.0500. The open-loop gain is so much greater than unity that we can use equation 5.4.

A' = A / (1 + A beta) = 500 / (1 + 500 x 0.05) = -19.23.

Example 5.4.

A noninverting amplifier has the same values as in example 5.3, A = 500, R1 = 10 k ohms and R2 = 200 k ohms. What is the closed-loop gain?

Solution:

For a noninverting amplifier the value of beta is

beta = R1 / (R1 + R2) = 10 k ohms / (10 k ohms + 200 k ohms) = 0.047619

The closed-loop gain is.

A' = A / (1 + A beta) = 500 / (1 + 500 x 0.047619) = +20.15.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

5.4 Frequency Response and Stability.

Until now we have treated amplifiers as having a phase shift of 0 degrees (noninverting) or 180 degrees (inverting). As long as the frequency response is flat (gain does not change with frequency), these rules of phase shift apply. If the gain is rising or falling with frequency, there will be an extra phase shift which may cause trouble.

The gain of an amplifier will change with frequency if there are RC networks inside the amplifier. These circuits may have been introduced intentionally or they may just be there. An example of an intentionally introduced RC circuit is the coupling capacitor between the collector of one BJT and the base of the next BJT. The resistance in the circuit and the capacitor form a high-pass filter. A semiconductor amplifier may not have any, or maybe one, of these circuits but a vacuum tube amplifier may have several.

Something never shown in schematic diagrams but always present in real circuits is stray capacitance. Remember that a capacitor consists of two conductors separated by an insulator. Any time there are two wires close together there is capacitance between them. That means that there are invisible capacitors connected from the collector of each transistor to ground and from the base of every transistor to ground. These capacitors combine with the Thevenin's resistance of the circuits to form low-pass filters. Each tiny low-pass filter causes the frequency response of the amplifier to roll off (gain decreases as frequency increases). Moreover, each transistor (BJT or FET) has its own built-in low-pass filter. Each device has its own frequency limits which are imposed by such things as collector-to-base capacitance and charge mobility within the semiconductor material.

The equations for phase shift (chapter 2) tell us that at the cutoff frequency the phase shift is 45 degrees. As the frequency gets higher than the cutoff frequency of a low- pass filter (or lower than the cutoff frequency of a high- pass filter) the phase shift quickly approaches 90 degrees. At the same time the gain is falling at a rate of a factor of 10 for each factor of 10 change in frequency.

Because the individual RC filters are isolated from one another by transistor stages, each one contributes to the total without affecting each other. If there are two RC filters with similar cutoff frequencies, the gain beyond cutoff will change by a factor of 100 for every factor of 10 change in frequency. The phase shift will approach 180 degrees. If there are three RC filters, the gain will change by a factor of 1000 for every factor of 10 change in frequency and the phase shift will approach 270 degrees. Gain change and phase shift go together like many other pairs of things you may have heard of. "You can't have one without the other." Thus, it is possible to know what the phase shift is even if you have no way of measuring it directly.

In the common operational amplifier, (op amp), the collector of the preceding transistor stage is directly coupled, not capacitively coupled, to the base of the next stage. This makes the frequency response go down to zero frequency which is DC. This is one of the few cases in electronics where it is possible to get something all the way to zero. Without any high pass filters in the amplifier the low pass filters that make the response roll off at the high frequencies are our only concern.

In some transistor amplifiers and all vacuum tube amplifiers there are high pass filters between each stage. These are capacitors in series with the signal path which are necessary to block the DC on the plate or collector of one stage from altering the bias on the grid or base of the following stage. The capacitors in conjunction with the resistors that connect to the control element of the amplifying device form high pass filters. These High-pass filters introduce phase shift and can cause low frequency oscillation if not designed properly.

The amount of phase shift depends upon the rate at which the gain is changing with frequency, which is determined by how many RC low-pass (or high-pass) circuits there are inside the amplifier. The rate of gain change is geometric. This means that a changing gain will be a straight line on a log- log graph. Figure 5.3 shows a log-log graph with various slopes (rates of change) plotted on it.

A rate of change of one decade decrease in gain for each decade increase in frequency is referred to as a slope of -1. If the gain decreases two decades for one decade increase in frequency, the slope is -2. If the gain should be increasing as frequency increases, the slope would be positive.

In the following discussion the phase shifts will be given with respect to the noninverting input. The phase shifts for the inverting input will be the algebraic sum of the stated phase shift and 180 degrees. If the slope of the frequency response is a negative 1, the phase shift will be -90 degrees. If the slope of the frequency response is -2, the phase shift will be -180 degrees. If the gain is falling with a slope of -2, the noninverting and the inverting inputs will be effectively interchanged. A connection which we thought would give negative feedback instead gives positive feedback. Positive feedback is the situation wherein the input signal is reinforced by the signal which is fed back instead of being partially canceled. When the input signal is reinforced, the output signal increases in amplitude. This causes the fed back signal to be increased which, in turn, causes the output signal to increase. This is a run- away condition and the input signal is no longer necessary; the amplifier is supplying its own input. An example is the earsplitting squeal of a sound system. This process is called oscillation and a device which oscillates is called an oscillator. When negative feedback becomes positive feedback we have an oscillator instead of an amplifier.

It would do no good to reverse the connections to the inverting and noninverting inputs. There would always be a part of the frequency spectrum where the gain is flat and there would be no extra phase shift. The circuit would oscillate because the feedback would be positive for those frequencies where the frequency response is flat.

In order to support oscillation two conditions must be met: 1) the net phase shift around the feedback loop must be zero and 2) the gain must be greater than unity. In order to prevent a feedback amplifier from oscillating, we must see to it that both conditions are not met at the same frequency. If at any given frequency only one of the two conditions is met, oscillation will not occur. The act of making internal changes to the amplifier so that both conditions will not be met at the same frequency is called amplifier compensation.

An amplifier which has not been compensated may well have a frequency response like that of the black line in Figure 5.3. A properly compensated amplifier could have a frequency response like the green line in the figure.

Graph.

Figure 5.3 Bode Diagram Showing Compensation of an Amplifier.

For a verbal description click here.

It should be pointed out that the slope of real frequency response curves does not break suddenly from one slope to another. The curves make gradual and smooth transitions from one slope to the other as we saw in chapter two. What has been drawn in Figure 5.3 are the tangents to the curves. The tangents from the flat portion and the -1 slope portion intersect directly over the -3 dB point. That is why the -3 dB frequency is sometimes called the corner frequency.

Examine the black curve in the above figure. It goes out flat to 100 kHz. Actually the frequency response is down 3 dB at 100 kHz but the Bode plot is drawn this way. At 100 kHz the plot breaks to a slope of -1. That means that one of the transistors started rolling off the frequency response. Another transistor in the amplifier begins to roll off at 1 MHz. This causes the Bode plot to break to a slope of -2. The plot falls by 40 dB, a factor of 100, between 1 and 10 MHz. At 10 MHz another transistor kicks in and the slope breaks to a slope of -3. After that the curve falls by 3 decades, 60 dB between 10 and 100 MHz.

What makes a feedback circuit oscillate is the loop gain not the gain of the amplifier. If this amplifier were to be used with a beta of 1/10000, it would not oscillate. 10000 is the value of gain where the slope breaks from -1 to -2. If a gain of 10000 is combined with a beta of 1/10000 the value of A beta is unity where the Bode plot breaks from -1 to -2 and the amplifier will be stable. Such a small value of beta would not be very useful but in audio amplifiers where the value of beta is fixed by the designer and does not change the Bode plot for A beta is used to compensate the amplifier instead of the plot of A alone.

On the other hand an op amp is frequently used with 100% feedback which is a beta of unity. To be useful an op amp must be compensated to unity gain. The way to convert the black curve in figure 5.3 into the green curve is to insert a passive circuit like that of figure 5.4 into the amplifier. This circuit produces the Bode plot of the red curve in the figure.

Schematic diagram.

Figure 5.4 Schematic of Compensation Network.

For a verbal description click here.

The frequency where the red curve breaks from flat to a slope of -1, 10 Hz in this case, is given by,

fA = 1 / (2 Pi C(R1 + R2))           (5.14.1)

The frequency where the red curve breaks from -1 to 0, 100 kHz in this case, is given by,

fB = 1 / (2 Pi C R2)           (5.14.2)

Notice that the short segment of -1 slope that is built into the amplifier is used by letting the network's plot flatten out just as the -1 slope of the amplifier is beginning.

The amplifier whose frequency response is plotted in Figure 5.3 is DC coupled. Its frequency response goes flat all the way down to DC (zero frequency). An AC coupled amplifier might have a frequency response like that of Figure 5.5. In this example the upper end of the frequency response falls with a slope of -1 because it has already been compensated. The amplifier will not oscillate in this frequency range. At the low end, however, shown by the black line, the gain has a slope of +2 and is greater than unity. If feedback were applied to this amplifier, it would oscillate somewhere in the 0.3 to 10 hertz frequency range. Some internal changes will have to be made to this amplifier to make the positive portion of the gain slope become +1 from unity gain up to maximum.

Graph.

Figure 5.5 Bode Diagram with Low Frequency Role Off.

For a verbal description click here.

The black line plot in figure 5.5 is of the amplifier in figure 5.6. Capacitors C1 and C5, if they were numbered, are outside of the feedback loop. C3 is the cathode bypass of the second amplifier and common practice is to set such capacitors so the corner frequency for the RC circuit is very much less than one Hz. Experience has shown that the cathode RC has little effect on the phase shift of the amplifier even if the corner frequency is about one Hz. The resistor values have been fudged so the corner frequencies will fall on decade marks on the Bode plot. These values are not necessarily realistic.

The capacitor values have been set the way a real, but amateur, designer would set them given the resistor values shown. Both break points have been set at 10 Hz which seems to be the reasonable thing to do. However the slope of the plot is plus 2 and the designer will find to his sorrow and possibly amazement that the circuit oscillates at a very low frequency. This kind of oscillation is often known as motorboating because it reminded someone of the sound of an old fashioned inboard motorboat.

Graph.

Figure 5.6 Vacuum Tube Amplifier With Feedback.

For a verbal description click here.

The value of beta is 1/10 so the amplifier does not have to be compensated to unity gain. A beta must be compensated to unity which means the gain needs only to be compensated to 10 as shown by the green line. To do this one of the break points must be moved down to 1 Hz and the other one up to 100 Hz.

It would not be good to move the C4 corner frequency up to 100 Hz because the output would rise below 100 Hz. So that one will be moved down to 1 Hz and the C2 corner frequency will be moved up to 100 Hz. This will give the green curve in figure 5.5. To make this amplifier stable C2 would have to be decreased to 0.001 microfarads and C4 increased to 1.0 microfarads.

Gain at Any Frequency, and Unity Gain Bandwidth (Gain-bandwidth Product).

An amplifier which has been properly compensated will have its gain change by one decade for every decade change in frequency, for all values of A beta greater than unity. A compensated amplifier may have a very large gain at middle frequencies but its gain can become quite low at the extremes of frequency near the unity gain frequencies.

Let us take as an example a properly compensated AC coupled amplifier whose Bode plot is shown in figure 5.7. Its lower unity gain frequency is 0.1 hertz and its upper unity gain frequency is 100 MHz. The tangents to the frequency response curves (often called the Bode plot) are shown in Figure 5.7. As you can see from the figure, the gain is 10 at 1 Hz and 10 MHz.

To calculate the closed-loop gain of a feedback amplifier at any frequency we must know the open-loop gain at that particular frequency. We will recycle equations 2.24.4 and 2.24.5 from chapter two. You don't have to go back to look at them unless you want to see how they were derived. Those equations have a maximum value of unity. To adapt them for use here they must be multiplied by the maximum gain of the amplifier AMax.

High end or op amp. eh = eh sub max over the square root of quantity f over f sub c2 quantity squared plus 1 close square root.

Low end. eh = eh sub max over the square root of 1 plus quantity f sub c1 over f quantity squared, close square root.

Where f is the frequency at which the gain is desired, A is the desired gain, fc1 is the lower cutoff or corner frequency, fc2 is the upper cutoff or corner frequency, and AMax is the maximum gain. For an AC coupled amplifier, one that roles off at both ends of the frequency spectrum, AMax is the maximum gain that the amplifier reaches at mid band. For a DC coupled amplifier such as an op amp the maximum gain and the DC gain are the same thing. As long as you don't interchange fc1 and fc2 you shouldn't have any trouble knowing which equation to use.

The frequency at which to change from using 5.15.1 to 5.15.2 is at the center frequency. This may not be what you assume. You must use the geometric center frequency which is given by,

fcc = sqrt(fc1 fc2)           (5.15.3)

Where fcc is the center frequency and fc1 and fc2 are as defined above. If you are working with an AC coupled amplifier, or a band-pass amplifier, use equation 5.15.1 above fcc and equation 5.15.2 below fcc.

In a device such as an audio amplifier the values of fc1 and fc2 usually are easy to measure. For op amps and some very high gain band pass amplifiers the values of fcx are likely to be very difficult to measure so the unity gain frequency is measured and stated in specifications. To calculate the corner frequency from the unity gain frequency we use the following equations.

fc1 = flu AMax     positive slope           (5.15.4)

and

fc2 = fhu / AMax     negative slope           (5.15.5)

where flu is the lower unity gain frequency, fhu is the upper unity gain frequency, fc1 is the lower corner frequency, and fc2 is the upper corner frequency.

Example 5.5.

A DC coupled (op amp) amplifier has a DC gain of 100,000 and a gain-bandwidth product (unity gain frequency) of 3 MHz. What is its gain at (a) 100 kHz, (b) 20 kHz, (c) 1000 Hz and (d) 5 Hz?

Solution:

The Bode diagram for this amplifier would be similar in appearance to the green curve in Figure 5.3 but the values would be different. There are no positive slopes in the diagram and so we apply equation 5.15.5 to find fc2.

fc2 = fhu / AMax = 3 x 106 / 105 = 30 Hz.

(a) Using equation 5.15.1 we have

A = 105 / sqrt((105 / 30)2 + 1) = 30

(b) A = 150

(c) A = 2,999

(d) A = 98,639.

Example 5.6.

An AC coupled amplifier has a lower unity gain frequency of 0.1 Hz and an upper unity gain frequency of 100 MHz. Its mid-band (maximum) gain is 1,000. What is its gain at (a) 5 Hz, (b) 20 Hz, (c) 1 kHz, (d) 20 kHz, (e) 200 kHz and (f) 4 MHz?

Solution:

The Bode diagram for this amplifier is shown in Figure 5.7. Making a Bode diagram is a good way to avoid mistakes in problems of this kind.

Figure 5.7 Bode Diagram for Example 5.6.

For a verbal description click here.

The first step is to find fc1 and fc2.

fc1 = flu AMax = 0.1 x 1000 = 100 Hz.

fc2 = fhu / AMax = 108 / 1000 = 105 Hz.

In order to decide which equation to use we must split the frequency response curve at the center of the flat portion. The center is the geometric mean of 100 Hz and 100,000 Hz. fcc is given by,

fcc = sqrt(100 x 100,000) = 3.16 kHz

(a), (b), and (c), are all below the center frequency and (d), (e), and (f), are all above it. Therefore we will use equation 5.15.2 for (a), (b), and (c), and 5.15.1 for (d), (e), and (f).

From equation 5.15.2 we have,

(a) A = 49.94,

(b) A = 196.1,

(c) A = 995.0

Now changing to equation 5.15.1,

(d) A = 980.6.

(e) A = 447.2,

(f) A = 24.99.

The Feedback Equation with Sloping Gains.

The examples above show how the magnitude of the amplifier gain varies with frequency. In order to make absolutely correct calculations of closed loop gain, taking phase shift into account, we would have to use the j operator. There is no mathematically rigorous way around it. You might suppose that we could use the Pythagorean theorem as we did in our study of RC circuits but the phase shift is not ninety degrees in the region around the corner frequency. The equation that produced the green line in figure 5.7.1 looks like this.

eh prime = eh over the square root of 1 + quantity eh beta quantity squared, close square root.

That equation seems to work but it trades off accuracy in one part of the frequency spectrum for inaccuracy in another. A graph will show what's going on.

Figure 5.7.1 Curves showing open-loop gain and
three calculations of closed-loop gain.

For a verbal description click here.

The graph shows frequency on a log scale versus dB. The numbers along the horizontal axis are the power to which you must raise 10, to obtain the frequency. The scale is from 0.1 to 100,000 Hz. Remember that ten to the 0 power is one. The red curve shows the open loop gain of a DC coupled amplifier with a DC gain of 10,000 and a unity gain bandwidth of 100 kHz. Notice that the gain is down by 3 dB at 10 Hz as it is supposed to be.

The dark blue curve is the gain calculated from equation 5.4. Notice that it is down 6 dB at 100 Hz but it should be 3 dB down.

The green curve is calculated from the equation above. It is correct in this area of the spectrum, being 3 dB down at 100 Hz but the low frequency (DC) part of the curve is off by 1 dB, approximately 10%. As beta is made smaller this error gets worse. For a beta of 0.0001 the DC gain should be 5,000 which is 74 dB. The above equation, which has no number, gives 7,071 which is 77 dB. Such large errors in DC gain calculation cannot be tolerated so the no-number equation will be considered invalid and will not be used.

The equation which produced the light blue line is given below, along with its low frequency companion.

High end or op amp. eh prime = eh over square root quantity f over f sub c2 quantity squared plus quantity 1 plus eh beta quantity squared end square root. 5.4.1.

Low end. eh prime = eh over square root quantity f sub c1 over f quantity squared plus quantity 1 plus eh beta quantity squared end square root. 5.4.2.

These equations were not so much derived as they were cloodged together to get the right answer. The light blue line behaves the way the real frequency response does. However, equations 5.4.1 and 5.4.2 will not be required in homework or test problems. They are presented for reference only.

Example 5.7.

A beta value of .01 is applied to the amplifier of example 5.5. What is the closed-loop gain at frequencies of (a) 100 kHz, (b) 20 kHz, (c) 1 kHz and (d) 5 Hz?

Solution:

(a) A' = A / (1 + A beta) = 30 / (1 + 30 x 0.01) = 23.08

(b) A' = 60.00

(c) A' = 96.77

(d) A' = 99.90

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

5.5 Gain Accuracy and Precision.

Amplifiers without feedback have rather unpredictable gains. Transistor parameters vary with temperature and from one transistor to the next. Even if a one-of-a-kind amplifier were designed and constructed, its gain would change with temperature. If a transistor ever had to be replaced the gain would most likely change drastically.

Amplifiers which are used in physics laboratories are involved with measurement of an electrical quantity. A changing gain in a measurement circuit will render the measurement useless. Negative feedback will stabilize the gain of an amplifier. How sensitive the closed-loop gain is to changes in open-loop gain can be determined through the use of calculus.

We will begin with the feedback equation

A' = A / (1 + A beta)           (5.16)

Using implicit differentiation to take the derivative of A' with respect to A we have,

dA' = ((1 + A beta)dA - A beta dA) / (1 + A beta)2           (5.17)

Splitting equation 5.17 into the difference of two quotients gives.

dA' = (1 + A beta) dA / (1 + A beta)2 - A beta dA / (1 + A beta)2           (5.18)

Now we will split the right-hand term into the product of two quotients and, at the same time, multiply everything to the right of the equal sign by 1 in the form of A / A and cancel (1 + A beta) in the first term. We now have,

dA' = A / (1 + A beta) x dA / A - A / (1 + A beta) x A beta / (1 + A beta) x dA / A.     (5.19)

The right-hand side of equation 5.16 appears twice in equation 5.19. If we substitute 5.16 into 5.19 we now have

dA' = A' x dA / A - A' x A beta / (1 + A beta) x dA / A           (5.20)

If we now divide through by A' and factor out the dA / A term we have

dA' / A' = dA / A (1 - A beta / (1 + A beta))           (5.21)

Simplifying the term inside the brackets gives,

dA' / A' = dA / A x 1 / (1 + A beta)           (5.22)

This is where the EE book I used at university stopped. But The equation can be simplified still further. To shorten the notation let us say that E = dA / A and E' = dA' / A'. In this notation we can write,

E' = E / (1 + A beta)           (5.23)

If we solve equations 5.23 and 5.16 for 1 / (1 + A beta) and set them equal we have.

E' / E = A' / A           (5.24)

Because E' and E now appear as a ratio it doesn't matter if we express E' and E as fractional changes or percentage changes.

This equation gives us one of the more important benefits of negative feedback, which is to stabilize the gain of an amplifier. Let us illustrate with an example.

Example 5.8.

An amplifier has an open-loop gain of 105 which may vary by as much as plus or minus 30%. The value of beta is 0.010. What is (a) the closed-loop gain, (b) how much is this gain in error referenced to 1 / beta, and (c) what is the percent variation in gain due to changes in open-loop gain?

Solution:

(a) The closed loop gain is

A' = 105 / (1 + 105 x 0.01) = 99.90

(b) Error referenced to 100 is -0.1%

(c) By equation 5.24

E' = E A' / A = 30 x 99.90 / 105 = 0.0300%.

This example shows that when the open-loop gain is very high, it has very little effect on the closed-loop gain. The closed-loop gain is set by beta which in turn is set by the values of two resistors. Resistors can be obtained as very high precision units.

It is often necessary to calculate how much open-loop gain is required or how much closed-loop gain can be obtained for a certain amount of gain error.

Example 5.9.

An amplifier has an open-loop gain of 5,000 which can vary by as much as 35 %. What is the maximum closed- loop gain available if the closed-loop gain variation is not to exceed 2.5 %?

Solution:

Solving equation 5.24 for A' gives,

A' = E' A / E = 2.5% x 5000 / 35% = 357.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

5.6 Other Benefits of Negative Feedback.

A fairly obvious question is "If negative feedback reduces the gain, why use it?" In the previous section we have seen that applying negative feedback to an amplifier will control its gain very accurately. That is not the only benefit of negative feedback. Almost any amplifier parameter you care to name is improved by applying negative feedback to it. Any amplifier designer will tell you that gain is the easiest of all parameters to obtain. The standard practice is to design an amplifier with much more gain than is needed and use negative feedback to trade the extra gain for improvement of all of the other parameters of the amplifier.

Frequency Response.

Frequency response is improved by the application of negative feedback. The low frequency limits are moved lower and the high frequency limits are moved higher. For example look at the Bode diagram in Figure 5.8.

Graph.

Figure 5.8 Bode Diagram of Closed and Open-loop Gains.

For a verbal description click here.

The frequency response of amplifiers is usually given in terms of the -3 dB points rather than the unity gain points. The open-loop gain of the amplifier whose Bode plot is given in Figure 5.8 has a frequency response of 1,000 to 10,000 hertz. Not exactly hi-fi is it? When negative feedback is applied to reduce the gain to 100, the frequency response becomes 10 Hz to 1 MHz. Quantitatively the improvement of frequency response is given by,

f1' = f1 / (1 + A beta)           (5.25)

and

f2' = f2 (1 + A beta)           (5.26)

Where f1 is the lower open-loop -3 dB frequency, f2 is the upper open-loop -3 dB frequency and the primes ' indicate the closed-loop equivalents.

Distortion and Noise.

Distortion is defined as any alteration of the original signal by an electronic circuit. In audio circuits distortion is expressed as a percentage. When an absolutely pure sine wave is introduced at the input of an amplifier, the output consists of the original sine wave plus harmonics of the original sine wave. The total of the harmonics is expressed as a percentage of the original sine wave. This is often called the total harmonic distortion or THD of an amplifier. To a musician, distortion represents an alteration of the reproduced sound. To a physicist, distortion represents nonlinearity and errors in measurements. Distortion and nonlinearity are reduced by the addition of negative feedback to an amplifier as follows. Consider THD to be equivalent to nonlinearity.

THD' = THD / (1 + A beta)           (5.27)

Noise is any varying voltage in a place where it is not wanted. It can be periodic as in the case of the 60 Hz line frequency which gets into everything. Noise can be aperiodic or random. Such noise is caused by the thermal agitation of charge carriers in conductors and semiconductors. The amount of noise N is affected by negative feedback as follows.

N' = N / (1 + A beta)           (5.28)

It should be pointed out that because the signal is also reduced by the factor of 1 / (1 + Abeta) the signal-to-noise ratio is not improved by negative feedback but it isn't made any worse either. The fact that negative feedback is neutral when it comes to signal-to-noise ratio means that the other benefits of negative feedback can be realized without giving up anything really important.

Input and Output Impedance.

The output impedance is lowered by the application of negative feedback by,

ZO' = ZO / (1 + A beta)           (5.29)

In the case of a noninverting amplifier the input impedance is increased by an amount,

ZIN' = ZIN (1 + A beta)           (5.30)

The input impedance which is affected is the input impedance of the transistor. Any fixed resistors which are outside of the feedback loop, such as base biasing resistors, will not be affected by the application of feedback.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

5.7 Some Practical Circuits.

From time to time in this text, laboratory tested circuits will be presented. A circuit which actually works can illustrate a principle as well as one which looks as if it might work but probably will not. The latter kind of circuits are what are normally presented in electronics texts.

It is not intended that you should memorize these circuits; they are given for possible future reference. Some day if you are in graduate school or a job and you need a circuit to accomplish some task, you may just find one here. Where practical, hints will be given on how changes may be made to the circuit to help you to adapt it to your particular situation.

The circuit of Figure 5.9 is a two-stage noninverting amplifier with feedback. The feedback is applied from the output, through the voltage divider consisting of R9 and the parallel combination of R10 and R4. For this circuit,

beta = R4 R10 / (R4 R10 + R9 (R4 + R10)           (5.31)

C2 is required because the tap on the voltage divider and the emitter of Q1 are at different DC voltage levels.

The idea of applying a signal to the emitter of a transistor may seem strange. There is an amplifier configuration (not discussed) which is known as a common base or grounded base amplifier. In such a configuration the signal is applied at the emitter and taken out at the collector. Such an amplifier does not invert the input signal. Applying a positive-going signal to the emitter is the same as applying a negative-going signal to the base. Therefore, if a signal applied to the base is inverted, a signal applied to the emitter is not inverted.

Schematic diagram.

Figure 5.9 Laboratory Tested Circuit. Gain = 47, Frequency
Response is from 35 Hz to 600 kHz +0 -3 dB, Input Impedance
is 9 k ohms, Output Impedance is 700 ohms, VCC is 12 volts.
The gain may be altered by changing the value of R9.
The transistors are 2N3904.

For a verbal description click here.

The amplifier of Figure 5.9 has two BJT stages. The signal which is applied to the base of Q1 is inverted by that stage and applied to the base of Q2 where it is inverted again. Two inversions make a noninversion and, therefore, the base of Q1 is a noninverting input. A signal applied to the emitter of Q1 appears at its collector without being inverted. When this signal is passed through the Q2 stage it is inverted. Therefore, the emitter of Q1 is an inverting input. If negative feedback is to truly be negative, it must be applied to an inverting input.

The circuit of Figure 5.9 contains a large number of resistors and capacitors because each transistor is individually biased. The circuit of Figure 5.10 eliminates the DC blocking capacitor between Q1 and Q2 and the biasing network in the base of Q2. A DC voltage exists at the collector of Q1 and a DC voltage is required at the base of Q2. The designer's trick is to make the two voltages equal and then eliminate the capacitor and biasing resistors. The base of Q2 gets its bias from the collector of Q1.

Schematic diagram.

Figure 5.10 Laboratory Tested Circuit. Gain = 85,
frequency Response is from 4 Hz to 230 kHz +0 -3 dB,
input Impedance is 53 k ohms, output Impedance
is 580 ohms, Gain may be adjusted by changing R7.

For a verbal description click here.

This circuit is especially interesting because it has two feedback paths. One is from the emitter of Q2 to the base of Q1 and the other is from the collector of Q2 (the output) to the emitter of Q1. Capacitor C2 filters out the AC signal at the emitter of Q2 and so the feedback path from the emitter of Q2 to the base of Q1 is DC only. Because Q2 gets its base bias from the collector of Q1, any change in the operating point of Q1 will be amplified and passed to Q2. The DC feedback path provides operating point stability for both stages.

If the emitter current of Q2 tries to increase, for whatever reason, the base bias on Q1 will be increased through the voltage divider consisting of R1 and R2. The increased bias on Q1 will cause its collector current to increase which pulls down its collector voltage. Since the base of Q2 is tied to the collector of Q1 the base bias on Q2 will be decreased, thus mostly canceling the increase in emitter current.

The AC gain is set by the AC feedback path which is from the output, through the voltage divider consisting of R7 and R4 to the emitter of Q1. In this case,

beta = R2 / (R2 + R7).           (5.32)

The value of R2 cannot be changed as this will upset the DC operating point of both transistors. R7 may be adjusted to set the gain to the desired value.

Figure 5.11 shows another variation on the same theme. The advantage of this circuit over Figure 5.10 is that the output voltage swing can be almost equal to VCC. In the case of Figure 5.10 the base of Q2 is at the same potential as the collector of Q1, and so VCE + VRE of Q1 is not available for output voltage swing. The circuit of Figure 5.11 overcomes this by using a PNP and an NPN transistor. The emitter of Q2 is at VCC and the output voltage can almost swing from ground to VCC.

Schematic diagram.

Figure 5.11 Laboratory Tested Circuit. Gain = 24,
Frequency Response is from 3 Hz to 1 MHz +0 -3 dB,
Input Impedance is 16.5 k ohms, Output Impedance is
332 ohms, VCC is 12 volts. The gain may be altered
by changing the value of R7.

For a verbal description click here.

The voltage divider consisting of R1 and R2 provides a constant bias for the base of Q1. For DC, 1/2 of the output is fed back to the emitter of Q1 for operating point stability. R4, R5 and R6 provide the DC feedback to the emitter of Q1. R7 and C2 combine to reduce the amount of AC feedback which will raise the AC gain of the amplifier. If R7 is shorted out, the amplifier will provide its full open- loop gain for AC. If R7 and C2 are removed from the circuit, the gain will be 2 for both AC and DC.

beta = R6 R7 / ((R4 + R6 + R7)(R5 + R6) - R62)           (5.33)

If the circuit is to be used as a DC amplifier, capacitors C1 and C3 would have to be removed from the input and output. The circuit as given would introduce a DC offset to the signal. The resistor values probably could be adjusted to reduce the offset to near zero.

Here is the circuit of a vacuum tube gain block. Gain blocks usually consist of two triodes with feedback from output plate to input triode cathode to diminish distortion to a very low level and tightly control the value of the gain. Here is a circuit I developed that will give a fairly wide range of gain at very low levels of distortion.

Schematic diagram.

Figure 5.11.1 Vacuum Tube Gain Block.

For a verbal description click here.

This circuit has a lot of open loop gain which is traded off for low distortion. The gain may be changed by changing the cathode resistor, Rk, in the first triode. Changing this resistor has a very small effect on the operating point of either triode. The numbers are given in the table below.

Cathode Resistor, Rk. | Gain. | Distortion. | Output Voltage.
36 k ohms. | 6.67 | 0.035%. | 10 v.
27 k ohms. | 8.47 | 0.04%. | 10 v.
22 k ohms. | 10.1 | 0.045%. | 10 v.
9.1 k ohms. | 21.7 | 0.045%. | 10 v.
5.1 k ohms. | 33.6 | 0.060%. | 10 v.

The value of beta for this circuit is given by,

beta = (Rk + 1100) / (Rf + Rk + 1100)           (5.33.1)

Where Rk and Rf are as labeled in the schematic above.

The feedback is DC coupled, not through a capacitor, from the plate of the second triode to the cathode of the first.

The 220 k ohm resistor makes up most of the load for the second triode which is where most of the distortion occurs. I don't recommend changing the value of Rf because it effects the operating point of the second triode. If this resistor is changed the cathode resistor in the second triode will have to be readjusted for minimum distortion.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

5.8 Positive Feedback, Oscillators.

It has been said that if a phase reversal slips into a negative feedback circuit, the amplifier will oscillate. There are circuits in which the feedback is deliberately made positive so as to generate an AC signal of known and constant frequency. Such circuits are known as oscillators.

If we reverse the sign of the feedback the feedback equation becomes,

A' = A / (1 - A beta)           (5.34)

If A is less than 1 / beta the gain of the amplifier is increased over its open-loop value but it will still work as an amplifier. If A = 1 / beta the gain becomes infinite and the amplifier will provide its own input signal and will produce an output without any input. Mathematically if A is greater than 1 / beta the amplifier will oscillate and the amplitude of the oscillations will continue to build up and approach infinity. In the physical world amplifiers do not work this way. The amplitude will build up until the amplifier begins to saturate which has the effect of reducing the open-loop gain. The gain will be reduced until A = 1 / beta.

Multivibrator.

The circuit of Figure 5.12 is at first glance two common emitter amplifiers, each one with its collector coupled to the other's base. Starting at one particular point and moving around the loop once, there are two 180 degree phase shifts which gives a total of 360 degrees, which is the same as a 0 degree phase shift. In actuality the transistors are acting as switches instead of amplifiers.

Schematic diagram.

Figure 5.12 Laboratory Tested Circuit. Oscillation
frequency is 80 Hz, VCC may be as low as 1.5 v, Waveform
is approximately square, Amplitude = (VCC - 0.1) v P-P.

For a verbal description click here.

Let us start by assuming that Q1 is off and Q2 is on. The voltage at the collector of Q1 will be VCC and the voltage at the base will be negative because of remaining charge on C2. The voltage at the collector of Q2 will be approximately zero volts and the voltage at the base will be +0.6 volts. The charge on C1 will be equal to VCC - 0.6 v with the left-hand plate positive. C2 once had a charge of VCC - 0.6 v with the right-hand plate positive. C2 is now discharging through R3 causing the negative voltage at the base of Q1 to be headed in the direction of VCC. When the base voltage of Q1 reaches +0.6 volts, Q1 begins to conduct and its collector voltage begins to fall. This falling voltage is coupled through C1 to the base of Q2 which turns it off. When Q2 turns off, its collector voltage goes up and that change causes C2 to be charged through the base of Q1, turning it on very hard. Q1 is now on and Q2 is now off. C1 has a charge of VCC - 0.6 v with the left-hand plate positive. Because the left-hand end of C1 is clamped to ground by Q1 the base of Q2 is negative, insuring that it is off. C1 begins to discharge and the cycle keeps repeating with each transistor switching alternatively on and off.

If R2 = R3 = R and C1 = C2 = C then the frequency of oscillation is given by,

f = 1 / (1.2 R C)           (5.35)

The frequency of oscillation is relatively insensitive to the power supply voltage.

Circuits You May Find in Other Texts.

A good example of a circuit you may find in other electronics texts is the Wien bridge oscillator. This is a sine wave oscillator which, if properly designed, is capable of generating very pure sine waves. Back in the vacuum tube days this circuit used a tungsten lamp as a gain regulating element. The circuit was fairly simple and it worked quite well. Modern Wien bridge designs which employ a lamp do not work very well. A high-quality Wien bridge circuit is too complex to be presented in a text of this level. The simple circuits you may see in other texts are not laboratory tested and will likely not work. The writer refuses to waste space printing circuits which won't work.

The Phase-shift Oscillator.

Schematic diagram.

Figure 5.13 Laboratory Tested Circuit. This circuit operates
from 12 volts and with the given values will oscillate at
approximately 200 Hz. Its usable frequency range is from 5
Hz to 20 kHz. For best waveform use the pot to adjust the
output amplitude to 2.25 volts RMS. The waveform is a pretty
good sine wave.

For a verbal description click here.

The phase-shift oscillator works by using the phase- shift of an RC circuit. Oscillation requires a net phase- shift around the feedback path of zero degrees. The amplifier stage in Figure 5.13 provides a phase-shift of 180 degrees. Three cascaded high-pass filters are used to provide the additional 180 degrees of phase-shift. One RC filter will provide a maximum of 90 degrees of phase-shift and you might assume that two such circuits would be enough. The phase- shift of a high-pass filter reaches 90 degrees at infinitesimally low frequencies. At such low frequencies the attenuation is approaching infinity. When three filters are used each filter is required to provide a phase-shift of only 180 degrees / 3 = 60 degrees. Because the next filter loads the previous one each section does not provide exactly 60 degrees but the average is 60 degrees per section. Under these conditions the attenuation is finite and the circuit will work.

There is only one frequency at which the total phase- shift is 180 degrees and it is given by,

f = 1 / (2 Pi sqrt(6) R C).           (5.36)

The attenuation of the circuit at this frequency is 1/29 and so the amplifier must have a gain of at least 29. The gain of the amplifier in Figure 5.13 may be set to 29 by means of the potentiometer. If the gain falls below 29 the circuit will stop oscillating. If the gain is higher than 29 the waveform will have a bit of distortion but the circuit will work reliably.

Quartz Crystal Oscillator.

Quartz is a Piezoelectric material when properly cut. The meaning of Piezoelectric is that there is an interchange between applied electric field and mechanical deformation. If the cut piece of quartz crystal is mechanically deformed, an electric field will be developed across the quartz. If an electric field is applied to a quartz plate, the plate will be mechanically deformed.

Because mechanical waves propagate through the quartz plate at a very high velocity, a thin plate of quartz will have a very high mechanical resonant frequency (roughly from 10 kHz to 100 MHz). The Piezoelectric effect allows this mechanical resonance to be transformed into an electrical resonance.

The quartz crystal behaves as if it were an LC resonant circuit. Crystals have two major advantages over LC circuits. They are 1) the quartz crystal is usually smaller than an LC circuit tuned to the same frequency and 2) the crystal has a much higher Q than an LC circuit tuned to the same frequency. The highest achievable Q values for an LC circuit are 250, although 100 is more typical. Crystal Q values range from 1,000 to 10,000. The only disadvantage of a quartz crystal is that its frequency cannot be adjusted once it leaves the factory.

When a quartz crystal is used as the frequency- determining element of an oscillator (as opposed to an LC circuit), the oscillator frequency is much more accurate and stable. The much higher Q of the crystal is what makes the oscillator frequency so much more stable.

Schematic diagram.

Figure 5.14 Laboratory Tested Circuit. This is a quartz
crystal oscillator with a frequency of 2 MHz and an
output suitable for driving one TTL logic load.

For a verbal description click here.

Figure 5.14 shows the diagram of a 2 MHz quartz crystal oscillator. The 7 to 45 pf trimmer capacitor may be used to adjust the frequency over a very small range, typically 0.05% of the crystal frequency. The JFET section is the oscillator circuit. This section could be constructed alone and the output taken from the source of the FET. The BJT portion operates as a switch and it is turned on and off by the AC signal from the oscillator portion. The entire circuit should work perfectly using a 1 MHz crystal. The oscillator section has been tested using a 10 MHz crystal but the BJT switch has not.

If you apply what you know about switching circuits you will find that the BJT is neither fully on or fully off. That is desirable in this application because the AC signal from the oscillator will drive the switch alternately on and off. If the switch were set fully off, the AC signal from the oscillator might not have enough amplitude to turn it on.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

5.9 Problems.

  1. An amplifier has an open-loop gain of 300 and a beta of 0.01. What is its closed-loop gain?

  2. A noninverting amplifier has an open-loop gain of 8. R1 = R2 = 12 k ohms. What is the closed-loop gain of this amplifier?

  3. An inverting amplifier has an open-loop gain of 8. R1 = R2 = 12 k ohms. What is the closed-loop gain of this amplifier?

  4. A noninverting amplifier has an open-loop gain of 1,000. R1 = 10 k ohms and R2 = 40 k ohms. What is the closed-loop gain of this amplifier?

  5. An inverting amplifier has an open-loop gain of 1,000. R1 = 10 k ohms and R2 = 40 k ohms. What is the closed-loop gain of this amplifier?

  6. An amplifier which has a Bode plot similar to that of Figure 5.4 has a DC gain of 75,000 and a gain-bandwidth product of 1.5 MHz. What is its gain at frequencies of (a) 100 kHz, (b) 20 kHz, (c) 1 kHz, (d) 20 Hz, and (e) 5 Hz?

  7. If negative feedback is applied to the amplifier of problem 6 and the value of beta is 0.013333, what is the closed-loop gain at frequencies of (a) 100 kHz, (b) 20 kHz, (c) 1 kHz, (d) 20 Hz, and (e) 5 Hz?

  8. An amplifier which has a Bode plot similar to that of Figure 5.5 has a lower unity gain frequency of 0.5 Hz, an upper unity gain frequency of 10 MHz and a maximum gain of 300. What is its gain at frequencies of (a) 5 Hz, (b) 20 Hz, (c) 200 Hz, (d) 1 kHz, (e) 20 kHz (f) 50 kHz, and (g) 2 MHz?

  9. If negative feedback is applied to the amplifier of problem 8 and the value of beta is 0.025, what is the closed-loop gain at frequencies of (a) 5 Hz, (b) 20 Hz, (c) 200 Hz, (d) 1 kHz, (e) 20 kHz, (f) 50 kHz and (g) 2 MHz?

  10. An amplifier is required to have a gain stability of 0.5%. The open-loop amplifier has a gain stability of 20%. If the closed-loop gain is to be 200, what must be the minimum open-loop gain of the amplifier?

  11. An amplifier has a closed-loop gain of 1,000 and an open-loop gain of 100,000 plus or minus 50%. What is the closed- loop gain error?

  12. An amplifier has an open-loop gain of 300,000 plus or minus 40%. What is the maximum closed-loop gain available if the error in the closed-loop gain is not to exceed plus or minus 1%?

  13. What is the calculated value of beta of Figure 5.9?

  14. In Figure 5.9 if the open-loop gain is 280, what is the closed-loop gain?

  15. In Figure 5.12 if resistor values are as given, what must the values of C1 and C2 be to give an oscillation frequency of 60 Hz?

  16. In Figure 5.13 if all capacitors marked C are 0.001 uf, what must be the value of the resistors R to give an oscillation frequency of 440 Hz?

  17. In Figure 5.14 if there were no AC signal from the oscillator, what would be the value of VCE of the BJT? Assume beta = 100.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

5.10 Answers to Problems.

  1. 75.

  2. 1.6.

  3. -0.8.

  4. 4.975.

  5. -3.98.

  6. (a) 15.0, (b) 75.0, (c) 1500, (d) 53,033, (e) 72,761.

  7. (a) 12.50, (b) 37.50, (c) 71.43, (d) 74.89, (e) 74.92.
    Note. These calculations are correct not just close.
    If you didn't hit the numbers on the nose,
    you must have done something wrong.

  8. fc1 = 150 Hz, fc2 = 33,333 Hz, fcc = 2,236 Hz.
    (a) 9.994, (b) 39.65, (c) 240.0, (d) 296.7, (e) 257.2, (f) 166.4, (g) 4.999.

  9. (a) 7.996, (b) 19.91, (c) 34.28, (d) 35.25, (e) 34.62, (f) 32.25, (g) 4.444.

  10. 8000.

  11. 0.5%.

  12. 7,500.

  13. 0.01799.

  14. 46.38.

  15. 0.13 microfarad.

  16. 148 k ohms.

  17. 1.48 volts.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

This page copyright © Max Robinson. All rights reserved.


Chapter 6   The Operational Amplifier.

6.1  Op Amp Behavior.
6.2  Equations of the Op Amp.
6.3  The Unity-Gain Buffer Amplifier.
6.4  The Noninverting Amplifier.
6.5  The Inverting Amplifier.
6.6  The Summing Amplifier.
6.7  The Integrating Amplifier.
6.8  Single Power Supply Operation.
6.9  Understanding Op Amp Specifications.
6.10 Problems.
6.11 Answers to Problems.

Chapter 6

The Operational Amplifier.

The operational amplifier began life as a component in an analog computer. For those who have never heard of an analog computer, it is (was) a computer in which the magnitude and sign of voltages were used to represent physical quantities. For example, one voltage might represent the velocity of a falling object, another voltage the acceleration and another voltage might represent the frictional drag of the air on the object. If you know about analog computers you think of them as being vacuum tube monstrosities but that is because of the age in which they were developed and used. If they were still in use today they would be reduced in size to desktop or even smaller just as their more successful digital brothers have.

The operational amplifier (op amp) is so called because in its original application it was used to perform mathematical operations. The two operations it was best at were addition and integration. Op amps are still used for these purposes but they have found many other applications in modern electronics.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

6.1 Op Amp Behavior.

The op amp has been reduced from its original vacuum tube size of a cubic foot or larger to an 8 pin integrated circuit. There are several hundred different type numbers, each having its own particular and sometimes subtle difference from others. The internal circuitry of these ICs is not terribly important to us. IC manufacturers do not often give the internal circuit diagrams of their ICs. Op amps are among the few exceptions to this rule.

The circuits are quite complex, the 741 op amp has 20 transistors in it. The curious student is referred to instructional books and data books devoted exclusively to op amps. There are many such books available.

Op amps are usually treated as 5 terminal devices. In the following pages they will be treated as just another component the same as a transistor is a component.

Electrical Connections.

The op amp has 5 basic electrical connections. They are inverting input, noninverting input, output, positive power supply and negative power supply. While there is no ground per se, ground is established by the power supply. Employing the theorem which states that "one picture is worth a thousand words" refer to Figure 6.1. The power supplies are replaced by batteries to make it clear how the power supplies are connected. Sometimes an op amp may be operated from a single power supply but most of the time they are operated as shown in Figure 6.1.

Except for section 6.8 you will not again see the power supply connections to an op amp. The power supply connections are always there; they are usually not shown on schematic diagrams. The op amp will not work without power supply connections. If you see a diagram which does not show power supply connections and you assume that it is not necessary to connect a power supply, you will be in error. The op amp will not work without power supply connections. They are always assumed if not shown.

Figure 6.1 Operational Amplifier Showing Power Supply Connections.

For a verbal description click here.

The two inputs must be at a voltage which is between the negative and positive power supplies. To force the voltage of either or both inputs higher than V+ (the positive power supply) or lower than V- (the negative power supply) may destroy the op amp. (There are some special purpose op amps which have been designed to permit the inputs to be at potentials outside of the power supplies. If you have a need to set the inputs outside of the power supplies, you should consult a data book to find such an op amp.)

Many op amps have inputs for adjusting the offset voltage to zero. When the voltage at the two inputs is exactly equal the output should be zero but it is not. The amount by which the input voltage must be different to bring the output to zero is the offset voltage.

The Differential Inputs.

If the inverting input is tied to ground and a variable DC voltage is applied to the noninverting input the output will go with the sign of the noninverting input. If the voltage at the noninverting input is positive, the output is positive and if the voltage at the noninverting input is negative, the output is negative.

Now we will disconnect the inverting input from ground and connect the noninverting input to ground. The variable DC voltage will be applied to the inverting input. When the voltage at the inverting input is positive, the output voltage is negative. When the voltage at the inverting input is negative, the output voltage is positive. Thus you can see why the inputs have been named as they have.

Theoretically, if both inputs are connected together, the output voltage is zero. The offset adjustments can be used to adjust the output to zero, but there is a little more to it than that. If the two inputs (tied together) are made positive or negative, the output voltage will not change. But that's only in theory.

In practical op amps the output voltage will change a little when the two inputs have the same voltage applied to them. A voltage which is applied to both inputs simultaneously is called a common mode voltage. A voltage which is applied between the two inputs is called the normal mode voltage or differential voltage.

The normal mode gain is defined as the ratio of output voltage to the differential input voltage.

ANM = VO / Vd  (6.1)

Where VO is the output voltage and Vd is the voltage difference between the two inputs. The common mode gain is defined as the ratio of the output voltage to the common mode input voltage.

ACM = VO / VCM  (6.2)

Where VCM is the voltage applied to both inputs together. The common mode rejection ratio is defined as the ratio of the normal mode gain to the common mode gain.

CMRR = ANM / ACM  (6.3)

The common mode rejection ratio (CMRR) is usually expressed in dB. The typical value for the 741 type op amp is given as 90 dB.

Example 6.1.

An op amp has had its offset adjusted to zero. Its inverting input is at +3.001 v and its noninverting input is at +3.000 v. Will its output be positive or negative?

Solution:

The noninverting input is negative with respect to the inverting input; therefore, the output will be negative.

Example 6.2.

An op amp has had its offset adjusted to zero. Its inverting input is at -5.001 v and its noninverting input is at -5.000 v. Will its output be positive or negative?

Solution:

The noninverting input is positive with respect to the inverting input; therefore, the output will be positive.

Example 6.3.

When the normal mode voltage is changed by 25 uv the output changes by 5 volts. When the common mode voltage is changed by 1 volt the output voltage changes by 6.325 volts. (a) What is the CMRR? (b) Express the CMRR in dB.

Solution:

The normal mode gain is 5 v / 25 uv = 200,000. The common mode gain is 6.325 v / 1 v = 6.325. (a) The CMRR is 200,000 / 6.325 = 31620. (b) The CMRR expressed in dB is 20 LOG (31620) = 90 dB.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

6.2 Equations of the Op Amp.

The equation of the op amp is based on an approximation, albeit a very good one. Let us restate the feedback equation.

A' = A / (1 + A beta)  (6.4)

Now we will find the limit as A approaches infinity. If we divide both numerator and denominator by A we have

A' = 1 / (1/A + beta)  (6.5)

As A approaches infinity, the 1/A term goes to zero leaving

Limit as A approaches infinity of A' = 1 / beta  (6.6)

Thus, the gain of an op amp with feedback applied is given by

A' = 1 / beta  (6.7)

While equation 6.7 is a very good approximation in most cases it should not be taken as gospel.

Example 6.4.

An op amp has a DC gain of 100,000 and a unity gain bandwidth of 1 MHz. If feedback is applied to the op amp with a beta value of 0.05, what is the exact closed-loop gain at (a) DC, (b) 1 kHz, (c) 20 kHz, and (d) 100 kHz?

Solution:

From equation 5.15.5 the corner frequency is,

fc2 = fhu / AMax

Where fc2 is the corner frequency, fhu is the upper unity gain frequency, and AMax is the DC gain.

fc2 = 1 MHz / 100,000 = 10 Hz.

(a) Using equation 6.4,

A' = A / (1 + A beta) = 100,000 / (1 + 100,000 x 0.05) = 19.9960

(b) Using equation 5.4.1

A' = ADC / sqrt([f / fc2]2 + [1 + ADC beta]2)

A' = 100,000 / sqrt([1,000 / 10]2 + [1 + 100,000 x 0.05]2) = 19.9920

(c) and (d) also use equation 5.4.1.

(c) A' = 18.5663

(d) A' = 8.94391

Example 6.5.

For the conditions of example 6.4 calculate the percent error of gain using 1/beta as the standard of comparisons at (a) DC, (b) 1 kHz, (c) 20 kHz, and (d) 100 kHz.

Solution:

Since 1/beta = 20.00000 the errors are as follows:

(a) -0.020%, (b) -0.040%, (c) -7.1685%, (d) -55.2805%.

As can be seen from these examples the 1/beta approximation is very good at DC and low frequencies but somewhere between 1 and 20 kHz the error crosses over the 2% line. If it is desired to know the exact gain at high audio frequencies equation 5.4.1 must be used rather than 6.4 or 1/beta.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

6.3 The Unity-gain Buffer Amplifier.

The definition of a buffer amplifier is an amplifier which will isolate a load from a source. Such isolation usually requires that the buffer amplifier have a very high input impedance. The output impedance may either be very low or matched to the load impedance. A buffer often has unity voltage gain although this is not a requirement under the definition.

A unity gain buffer has a voltage gain of unity as the name implies. The value of beta is set at unity by feeding back all of the output voltage to the inverting input. The circuit of Figure 6.2 is of a unity gain buffer.

Figure 6.2 Unity Voltage Gain Buffer Amplifier.

For a verbal description click here.

An op amp works by adjusting its output so that the two inputs are at the same potential. (The error due to finite op amp gain is quite small.) Because the output and the inverting input are connected together the output voltage will be the same as the inverting input voltage. Suppose that the input voltage is 0 volts and that the voltage is suddenly changed to +2 volts. Since the signal is applied to the noninverting input, for an instant of time the noninverting input will be positive with respect to the inverting input. This will cause the output to go positive. When the inverting input voltage becomes +2 volts the output will stop changing. Should the output voltage overshoot +2 volts and become higher, the output would be urged in the negative direction thus correcting the overshoot. A properly compensated op amp will not overshoot in the first place.

The voltage at the output cannot become 2.000000000000 volts. If it did the differential input voltage would be zero and the output would be zero. Since the output voltage is finite, there must be a finite difference in voltage between the noninverting input and the inverting input. That small but finite difference is caused by the finite open-loop gain of the op amp. Because the open-loop gain of the op amp is very large, the error is very small.

The percent error is,

% error = 100% x (Measured - Reference) / Reference  (6.8)

If we substitute A / (1 + A beta) for "Measured" and 1/beta for "Reference" in equation 6.8 and get some more algebraic exercise we have

% error = -100% / (1 + A beta)  (6.9)

In the case of the unity-gain buffer the value of beta is 1.0000000000; therefore, the % error becomes 100% / (A + 1).

Example 6.6.

Calculate the gain error of a unity-gain buffer if the op amp has an open-loop gain of (a) 200,000; (b) 20,000; (c) 1,000; and (d) 20?

Solution:

The % error is (a) -100% / (1 + 200,000) = -0.0004999975%, (b) -0.00499975%, (c) -0.0999%, (d) -4.7619%.
The closed-loop input and output impedances of the unity-gain buffer are,

ZIN' = ZIN (1 + A beta)  (6.10)

And

ZO' = ZO / (1 + A beta)  (6.11)

The open-loop input and output impedances must be obtained from an IC data-book. Because beta is unity and the open-loop gain is very large, the output impedance is very low and the input impedance is very high.

Often it is desired to calculate the input and/or output impedance at higher frequencies where the gain is less than the DC gain. Equations 6.10 and 6.11 may be used but the value of A must be the gain at the frequency being considered, not the gain at DC. This gain can be obtained from equation 5.15.1 which is repeated below.

Equation 6.11.1. eh = eh sub DC over square root of, quantity f over f sub c2 quantity squared plus 1 close square root.

Where A is the gain at any frequency, ADC is the DC gain of the amplifier, f is the frequency at which the gain is desired, and fc2 is calculated from equation 5.15.5 which is repeated below.

fc2 = fhu / ADC  (6.11.2)

Where fhu is the unity gain bandwidth or gain bandwidth product of the amplifier.

Example 6.7.

Determine the minimum input impedance and the maximum output impedance of a unity-gain buffer employing a type 741 op amp. The data book gives the minimum input resistance of the 741 as 0.3 M ohms, a typical output resistance of 75 ohms and a minimum gain of 20,000. The typical gain is given as 200,000.

Solution:

The minimum gain is given as 20,000. The typical gain is given as 200,000 but as the question asks for the minimum input impedance and maximum output impedance, the minimum gain should be used.

ZIN = 0.3 M ohms x 20,000 = 6 G ohms,

The output impedance is, ZO = 75 / 20,000 = 3.75 milli ohms.

The resistance of the printed circuitboard traces will be greater than the output resistance of the amplifier. Note also that this is a worst case. If the typical gain of 200,000 had been used, the input impedance would be 60 G ohms and the output impedance 0.375 m ohms.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

6.4 The Noninverting Amplifier.

Figure 6.3 Noninverting Amplifier.

For a verbal description click here.

The circuit of a noninverting amplifier is given in Figure 6.3. As we saw in the previous chapter the value of beta for this amplifier is given by,

beta = R1 / (R1 + R2)  (6.12)

The approximation for the closed-loop gain is given by equation 6.7. If the gain error is large, equation 6.4 should be used to calculate the exact gain. The gain error is given by equation 6.9. The input and output impedances are given by equations 6.10 and 6.11.

This circuit works because the op amp will always adjust its output until both inputs have the same potential. If a given potential is placed between the input terminals in Figure 6.3 the noninverting input of the op amp will be placed at that potential. The op amp will adjust its output until the inverting input is at the same potential. Because of the voltage divider consisting of R1 and R2 the output voltage must be greater than the input voltage by the amount of the divider ratio. The conditions of equal potential at both inputs require that they have the same sign. Because resistors can't change the sign of a voltage, the output voltage must also have the same sign as the input voltage.

Example 6.8.

A noninverting amplifier has the following values: R1 = 4.7 k ohms and R2 = 2.7 k ohms. The open-loop gain is 200,000. What is the closed-loop gain?

Solution:

When the open-loop gain is very high the closed-loop gain is 1/beta. Therefore, the closed-loop gain is given by A' = (R1 + R2) / R1 = (4.7 k ohms + 2.7 k ohms) / 4.7 k ohms = 1.57.

Example 6.9.

A noninverting amplifier is to have a gain of 20 dB and R2 is to be a 10 k ohm resistor. What is the necessary value of R1?

Solution:

The first step is to convert dB into gain.

A' = 10dB/20 = 1020/20 = 101 = 10.

Since A' = 1/beta to obtain a gain of 10, beta must equal 0.1. Solving equation 6.12 for R1 gives,

R1 = beta R2 / (1 - beta)

R1 = 0.1 x 10 k ohms / (1 - 0.1) = 1.11 k ohms.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

6.5 The Inverting Amplifier.

Figure 6.4 Inverting Amplifier.

For a verbal description click here.

The circuit of an inverting amplifier is given in Figure 6.4. As we saw in the previous chapter the value of beta for this amplifier is given by,

beta = R1 / R2  (6.13)

The approximation for the closed-loop gain is given by equation 6.7. If the gain error is large, equation 6.4 should be used to calculate the exact gain. The gain error is given by equation 6.9. The input impedance is given by,

RIN = R1  (6.14)

The output impedance is given by equation 6.11.

This circuit also works because the op amp will always adjust its output until both inputs have the same potential. If a voltage of a given sign and magnitude is placed between the input terminals in Figure 6.4 the inverting input of the op amp will be placed at a potential which is determined by R1 and R2. The op amp will adjust its output until the inverting input is at the same potential as the noninverting input. Because the noninverting input is grounded, the inverting input will always be adjusted to zero potential. Figure 6.5 shows an equivalent circuit to the inverting amplifier.

Figure 6.5 Equivalent Circuit of an Inverting Amplifier.

For a verbal description click here.

Imagine that you are watching the voltmeter and adjusting the voltage of the power supply. If the polarities are as shown, you will be able to find a voltage at which the voltmeter reads zero. At this point the voltmeter current will be zero and the current in R1 equals the current in R2. If the battery is VIN and the power supply is VO then

VIN / R1 = VO / R2.  (6.15)

Therefore, we can write,

VO / VIN = R2 / R1.  (6.16)

In order to bring the voltage across the voltmeter to zero, VIN and VO must have opposite signs. The op amp does exactly the same thing. The voltmeter is replaced by the input and the power supply is replaced by the output of the op amp. The op amp will adjust its output until the voltage between the two inputs is zero. When this has been accomplished, equations 6.15 and 6.16 will be satisfied.

Example 6.10.

An inverting amplifier has the following values: R1 = 4.7 k ohms and R2 = 2.7 k ohms. The open-loop gain is 200,000. What is the closed-loop gain?

Solution:

When the open-loop gain is very high the closed-loop gain is 1/beta. Therefore, the closed-loop gain is given by,

A' = R2 / R1 = 2.7 k ohms / 4.7 k ohms = -0.574.

That's right. It's possible for an inverting amplifier to have a gain of less than unity.

Example 6.11.

An inverting amplifier is to have a gain of 30 dB and R2 is to be a 10 k ohm resistor. What is the necessary value of R1?

Solution:

The first step is to convert dB into gain.

A' = 10dB/20 = 1030/20 = 103/2 = 31.62.

Since A' = 1/beta, to obtain a gain of -31.62, beta must equal 0.03163. Solving equation 6.13 for R1 gives,

R1 = beta R2 = 0.03163 x 10 k ohms = 316 ohms.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

6.6 The Summing Amplifier.

Figure 6.6 Summing Amplifier with Three Inputs.

For a verbal description click here.

The circuit of a summing amplifier is given in Figure 6.6. Remember that the op amp will adjust its output so that the voltage at the inverting input will be zero. Thus the current flowing in R2 must be the sum of the individual currents in R1A, R1B and R1C. The output voltage is given by,

VO = R2 [VINA / R1A + VINB / R1B + VINC / R1C]  (6.17)

A very good way to solve problems involving circuits of this kind is to treat them as circuit analysis problems.

Example 6.12.

In a circuit similar to that of Figure 6.6 the values are as follows: R1A = 10 k ohms, R1B = 7.5 k ohms, R1C = 5 k ohms, R2 = 10 k ohms, VINA = +15 v, VINB = -9 v, and VINC = -8 v. What is the output voltage of the amplifier?

Solution:

We will sum the currents at the node where the 4 resistors are joined. This node is at zero potential.

IA + IB + IC = I2.

Let us define current into the node as positive.

IA = VINA / R1A = 15 v / 10 k ohms = 1.5 mA.

IB = -9 v / 7.5 k ohms = -1.2 mA.

IC = -8 v / 5 k ohms = -1.6 mA.

I2 = 1.5 mA -1.2 mA -1.6 mA = -1.3 mA.

The net current flows out of the node; therefore, I2 must flow into the node to prevent a charge imbalance in the conductors. The current in R2 is flowing to the left, which means that the right end is positive with respect to the summing node. The voltage across R2 is I2 R2 = 1.3 mA 10 k ohms = +13 volts. Equation 6.17 will give the same answer.

The point where all of the resistors connect, (the inverting input), is often called the summing node or the summing junction. As has been said many times, this point is at zero potential. Of course it is not truly at zero potential because the amplifier does not have infinite gain. In most cases the gain of the amplifier is so high that the summing node is virtually at ground potential. The summing node is said to be a virtual ground point. It behaves as if it were actually shorted to ground.

Example 6.12 illustrates that a summing amplifier gives the negative of the true sum of the input voltages. This was one of the original uses of an operational amplifier.

Although we are not sound engineers, most of us own stereo systems and examples from that field are easy to relate to and understand. Suppose it is desired to add together the left and right channels of a stereo signal to form a monaural signal for a monaural amplifier. At the same time it is necessary to maintain the individual integrity of the left and right signals to feed a stereo amplifier. A circuit similar to Figure 6.6 but with two equal value resistors in the inputs will do the job nicely. The output will be a true L + R sum which is required for a monaural image. Because the summing node is a virtual ground, the individual L and R signals will not get mixed up in the lines before the summing amplifier. Audio engineers call this circuit a mixer but radio engineers mean something completely different when they say "mixer". Our best course is to avoid the term all together.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

6.7 The Integrating Amplifier.

Figure 6.7 Integrating Amplifier.

For a verbal description click here.

The other original use of an operational amplifier was as an integrator. An integrator is an electronic circuit which takes the time integral of any function which has been converted into a time varying voltage and applied to the input of the circuit. As you can see in Figure 6.7 the feedback resistor has been replaced by a capacitor. In a real circuit there is a switch in parallel with the capacitor to be certain that it starts out with zero initial charge.

The op amp will adjust its output to keep its two inputs at the same potential. Since the noninverting input is grounded, the inverting input will also be at ground potential. The current in R is

i = vin / R.  (6.18)

The voltage across a capacitor is given by

V sub C = one over C integral of i dt.

The current in the resistor and the current in the capacitor are flowing in the same direction (left to right or right to left) and the connect point (summing node) is at zero potential. The voltage at the right end of the capacitor must have the opposite sign as the input voltage. If we substitute equation 6.18 into equation 6.19 and insert the negative sign required by the op amp we have

V sub O = one over RC integral of V sub in dt..

Now you will learn what an integral really is. Maybe you think you already know. Let's see if you do.

Example 6.13.

In Figure 6.7 the capacitor starts out with zero initial charge. The input voltage is as shown in Figure 6.8. Draw the output voltage versus time, giving scale values. R = 2 M ohms and C = 1 uf.

Solution:

The integrator's output is shown in Figure 6.9. For the first 1/2 second there is no input and the output does not change. From 0.5 to 1.5 seconds the input voltage is 1.0 volts. That is an area of 1.0. If the gain of the integrator were unity, the output would be -1 after 1.5 seconds but this one has a 2 M ohm resistor which makes the 1/RC term in front of the integral to be 1/2. The input is 1 volt for 1 second or 1 volt second. The output will change by -0.5 volts/second for 1 second to give a value of -0.5 volt. From 1.5 seconds to 2.0 seconds the input is zero and the output will not change. Notice that the output is not zero when the input is zero. When the input is zero there is no additional area being added to the integral and so the output simply stays where it is. The input is -0.5 volts from 2 to 3.5 seconds which is an enclosed area of 0.75. Because of the gain of the integrator the output will change by +0.375 volts during the 1.5 seconds when the input is -0.5 volts. The output voltage will change at a rate of 0.25 volts/second for 1.5 seconds. At the end of 3.5 seconds the output will be -0.125 volts. The output will remain at this level from 3.5 to 4.0 seconds when the input is zero. When the input goes to -1.5 volts the output will change at a rate of 0.75 volts/second for a time of 0.5 seconds. The enclosed area is 0.75 and so the output will change by an amount of 0.375 volts. The output will end up at a voltage of +0.25 volts. The output will remain at this level until there is additional input or the capacitor is discharged. There is no requirement that the output come back to zero.

Figure 6.8 Integrator Input Voltage Versus Time.

For a verbal description click here.

Figure 6.9 Output Voltage of an Integrator.

For a verbal description click here.

Integrating amplifiers were used in analog computers to solve differential equations. They still can be used for that but digital computers will do it with more accuracy.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

6.8 Single Power Supply Operation.

The major advantage of operating op amps from two power supplies is that the input to and output from the op amp can be positive or negative. Because the input voltage can be zero, slowly changing DC voltages may be amplified, added or integrated.

In some applications it may not be necessary to have a bipolar output or the signals to be processed may be AC only. In such a case it is best to power an op amp from a single power supply. One power supply is less costly, smaller, lighter and generates less heat than two power supplies.

Figure 6.10 Single Power Supply Noninverting Amplifier.

For a verbal description click here.

Figure 6.10 is the circuit of a noninverting amplifier with a gain of 10 which operates from a single power supply. The parts which distinguish this circuit from a dual power supply amplifier are the two 180 k ohm resistors in the noninverting input circuit and the capacitors in the input, output and feedback portions of the circuit. The purpose of the 180 k ohm resistors is to bias the noninverting input at 1/2 of the power supply voltage. The values given are typical for an op amp with BJT inputs. The only DC path to the inverting input is through R2 from the output of the op amp. For best temperature stability the parallel combination of the biasing resistors should equal R2. This makes the DC Thevenin resistance in both inputs the same. If an FET input op amp were used the resistors could be as high as 10 M ohms each. The only requirement is that they be equal. The capacitor in the input prevents the circuit which is connected to the input from disturbing the bias on the noninverting input. Because the op amp always makes its two inputs have the same potential, the inverting input will also be at 1/2 the power supply and so the capacitor which is in series with the 10 k ohm resistor in the feedback network prevents this voltage from being disturbed. This capacitor has the additional effect of reducing the gain to unity for DC.

Figure 6.11 Single Power Supply Inverting Amplifier.

For a verbal description click here.

Figure 6.11 shows an inverting amplifier which will operate from a single power supply. This amplifier has a gain of -10. Once again the noninverting input is biased by a pair of equal value resistors to set its voltage at 1/2 of the power supply. Once again the parallel combination of the two biasing resistors should equil R2. The capacitor at the input is necessary to prevent upsetting the voltage at the inverting input.

There are some special purpose op amps which are designed for single supply operation. Their inputs may be placed at or even a little below ground even though the op amp is operating on a single positive power supply. However, the output of such an op amp can only have potentials of ground + 1.2 volts to VCC -1.2 volts. For best operation an offset should be added to the input to place the output at 1/2 of VCC.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

6.9 Understanding Op Amp Specifications.

To the uninitiated an op amp specification sheet can be a bit bewildering. The table of specifications has columns for minimum, typical and maximum values. Few entries in the table have values under all three columns. Also there are numerous footnotes giving the conditions under which the parameter was measured. Such things as power supply voltage, load resistance, source resistance and ambient temperature can all affect the value of any given parameter.

Input Offset Voltage is the voltage which must be applied to the input terminals to bring the output exactly to zero. The typical and maximum values are given here. The untrimmed value is given, which means that no trimmer pot was connected to the pins provided for that purpose. The units are usually mV (the units are always stated in the table).

Input Bias Current is the current which flows into each input of an op amp. If the input stage is a pair of BJTs, the base current of the transistors is the bias current. If the input is a pair of FETs, the bias current is the leakage current of the P-N junction which makes up the gates of the FETs. The units may be uA, nA or pA depending on the op amp. This specification is only significant when the resistance in series with the inputs is large. If the source resistance is such that the voltage drop due to the input offset current is significant compared to the input offset voltage, the resistance in the two inputs must be equal.

Input Offset Current is the difference between the bias currents in the two inputs. If the input bias current is producing a significant drop across the source resistances, the offset current will be converted to an offset voltage by the IR drop across the source resistances.

Input Resistance is the resistance the op amp inputs present to an input signal without any feedback applied to the amp.

Input Capacitance is the effective capacitance from each input to ground including Miller capacitance.

Offset Voltage Adjustment Range is only given on op amps which have pins for an offset voltage trimmer. It indicates how large the offset can be and still be adjusted to zero.

Input Voltage Range tells how far the inputs may be moved around in potential. This is usually the voltage which the amplifier will tolerate without damage. The input voltage range for proper operation of the amplifier may be given separately as a common mode voltage rating. It is usually 2 or 3 volts less than the maximum input voltage.

Common Mode Rejection Ratio (CMRR) is the ratio of normal mode gain to common mode gain. CMRR is most often given in dB. It is defined in detail on pages 244 and 245 of this text.

Supply Voltage Rejection Ratio states how much the power supply voltage will affect the output voltage of the op amp. It is the change in power supply voltage in uV divided by the change in output voltage in volts. This parameter is measured under open-loop conditions.

Large Signal Voltage Gain is the open-loop gain.

Output Voltage Swing states over what range the output voltage can vary.

Output Resistance is the Thevenin resistance of the amplifier.

Output Short Circuit Current states how much current will flow if the output of the amplifier is shorted to ground. Most op amps have built-in current limiting to protect them from damage if a short occurs.

Supply Current is how much current the op amp will draw from the power supply.

Power Consumption is the supply current multiplied by the total power supply voltage.

Transient Response (Unity Gain) states the risetime and overshoot for a unity-gain amplifier with a step input voltage.

Slew Rate is very important because it does more to limit the upper frequency limit than does the unity gain bandwidth. It states how fast the output voltage can change and is usually given in V/us.

The Gain Bandwidth Product or Unity Gain Frequency may be given in a graph rather than in the data table. It is the frequency at which the gain is unity.

Op amp data usually contains a large number of graphs. The majority of these graphs show how various parameters are effected by temperature. If you are going to use an op amp under conditions of extreme temperature, you should not ignore these graphs. If you are looking for a particular specification and it is not in the table, it may be in the graphs.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

6.10 Problems.

  1. A differential amplifier has a gain of 2.00, its noninverting input is at a potential of -1 volt and its inverting input is at a potential of +2 volts. What is its output voltage?

  2. A differential amplifier has a gain of 2.00, its noninverting input is at a potential of -5 volt and its inverting input is at a potential of -7.5 volts. What is its output voltage?

  3. A differential amplifier has a gain of 2.00, its noninverting input is at a potential of +7.5 volt and its inverting input is at a potential of +5 volts. What is its output voltage?

  4. When the normal mode voltage is changed by 30 uv the output changes by 4.5 volts. When the common mode voltage is changed by 1 volt the output voltage changes by 4.7434 volts. (a) What is the CMRR? (b) Express the CMRR in dB.

  5. An op amp with a DC gain of 200,000 and gain-bandwidth product of 1 MHz is being used in a unity-gain buffer. What will be the gain error at a frequency of 200 kHz?

  6. An op amp with a gain-bandwidth product of 1 MHz is being used in a unity-gain buffer. The input impedance is 500 k ohms. Over what range of frequencies will the buffer have an input resistance in excess of 10 M ohms? The DC gain is 200,000.

  7. A noninverting amplifier similar to Figure 6.3 has the following values: R1 = 1 k ohm and R2 = 13 k ohms. What is the DC gain of this amplifier?

  8. A noninverting amplifier is to have a gain of 12.00 and R1 is to be a 2.0 k ohm resistor. What is the value of R2 which will give the desired gain?

  9. A noninverting amplifier is to have a gain of 5 dB. The series combination of R1 and R2 must be greater than 2 k ohms but the parallel combination must not exceed 10 k ohms. Select standard 5% resistor values to come as close as you can to a gain of 5 dB and remain within the requirements stated. State the resistors you selected and the actual gain in dB which these values will produce.

  10. An inverting amplifier similar to Figure 6.4 has the following values: R1 = 1 k ohm and R2 = 13 k ohms. What is the DC gain of this amplifier?

  11. An inverting amplifier is to have a gain of 12.00 and R1 is to be a 10 k ohm resistor. What is the value of R2 which will give the desired gain?

  12. An inverting amplifier is to have a gain of 15 dB. The value of R2 must be greater than 2 k ohms but the parallel combination of R1 and R2 must not exceed 10 k ohms. Select standard 5% resistor values to come as close as you can to a gain of 15 dB and remain within the requirements stated. State the resistors you selected and the actual gain in dB which these values will produce.

  13. In a summing amplifier R1A = R1B = R1C = R2. Input A is 2 volts, input B is 3 volts and input C is -1 volt. What is the output voltage of the summing amplifier?

  14. In an integrator the resistor is a 1 M ohm and the capacitor is a 0.5 uf. The input to the integrator is as shown in Figure 6.12. Draw the graph of the output voltage versus time.

    Figure 6.12 Input Voltage for Problem 14.

    For a verbal description click here.

  15. An op amp has an input offset voltage of 1.5 mV, an input bias current of 0.2 uA and an input offset current of 0.03 uA, all typical values. Assuming equal resistances in series with each input, what is the maximum resistance for the voltage due to the input offset current to equal the input offset voltage?

  16. The input bias current is probably the most temperature sensitive of all op amp parameters. In an inverting amplifier the value of R1 is 47 k ohms and R2 is 120 k ohms. What resistor should be placed in series with the noninverting input to minimize the effects of temperature on the operating point?

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

6.11 Answers to Problems.

  1. -6 Volts.

  2. +5 Volts.

  3. +5 Volts.

  4. (a) 31,623, (b) 90 dB.

  5. -0.497 %

  6. 526 kHz.

  7. 14.00

  8. 22 k ohms.

  9. R1 = 3.9 k ohms, R2 = 3.0 k ohms, Gain = 4.956 dB.

  10. 13.

  11. 12 k ohms.

  12. R1 = 1.1 k ohms, R2 = 6.2 k ohms, Gain = 15.020 dB.

  13. -4.0 volts.

  14. Hint, the gain of the integrator is 2.

    Figure 6.13 Output Voltage for Problem 14.

    For a verbal description click here.

  15. 50 k ohms.

  16. 35.8 k ohm, nearest standard 5% value is 36 k ohm.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

This page copyright © Max Robinson. All rights reserved.


Chapter 7 &EMSP; Operational Amplifier Circuits.

7.1  Instrumentation Amplifier.
7.2  AC Voltmeter Circuit.
7.3  Open-loop Linearization.
7.4  Absolute Value Amplifier.
7.5  Log Converter.
7.6  Active Filters.
7.7  Problems.
7.8  Answers to Problems.

Chapter 7

Operational Amplifier Circuits.

The best thing about op amp circuits is that it is hard to keep them from working. Although none of the circuits in Chapter 6 was indicated as having been laboratory tested, you can build any of them and they will work! Because of this increased reliability over discrete transistors, anyone who works with electronic circuits prefers to use op amps whenever possible. Unfortunately today's low cost op amps will not perform much above the audio frequency band. If the frequency range permits, op amps are to be preferred over discrete transistors.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

7.1 Instrumentation Amplifier.

In laboratory instrumentation it is often necessary to place a sensor at some distance from the instrument to which it is connected. In such a case the long wires which connect the sensor to the instrument will act as antennas and pick up noise, (noise is any electrical signal which is in a place where it is not wanted). Using shielded cables will help but there may still be some noise pickup, especially if the voltage of the sensor is very small, requiring that the input amplifier of the instrument have a very high gain.

Figure 7.1 Signal and Noise Pickup on Long Lines.

For a verbal description click here.

The noise which is picked up on the wiring is usually common mode while the sensor is connected between the two wires so that its signal is normal mode. The situation is illustrated in Figure 7.1. Twisting the wires together to insure that they are in the same physical location will insure that the noise picked up on both wires will be the same. If the two wires are connected to the two inputs of a differential amplifier, the common mode noise on the wires will be cancelled out while the signal will be amplified. For this method of noise canceling to work properly the two inputs must have identical input impedances and gains which are equal in magnitude and opposite in sign. In addition to these requirements the gain is usually very high. An amplifier which meets all of these requirements is called an instrumentation amplifier and a circuit is shown in Figure 7.2.

Figure 7.2 Instrumentation Amplifier.

For a verbal description click here.

The best way to approach a problem involving this circuit is to treat it as a circuit analysis problem. For example, we will calculate the gain of the first amplifier stage of the circuit of Figure 7.2. The first stage consists of OA1 and OA2. If a voltage is applied between the two inputs (normal mode) the two op amps will adjust their output voltages to bring each of the inverting inputs to the same potential as the corresponding noninverting input. If we apply a voltage of VIN between the two input terminals, the identical voltage will appear across R1. This will cause a current of,

I = VIN / R1  (7.1)

to flow in the series combination of the two identical resistors labeled R2 and R1. There is no significant drop across the two resistors labeled RS. The output voltage of the first stage is the total voltage drop across the resistor chain.

VO = I (R1 + 2 R2).  (7.2)

Substituting equation 7.1 into equation 7.2 and dividing through by VIN gives,

VO / VIN = (R1 + R2) / R1  (7.3)

The gain of the second stage which consists of OA3 could be derived in the same way if desired. Rather than to have yet another equation to remember it is better to analyze the circuit using Ohm's and Kirchhoff's laws.

Example 7.1.

In the circuit of Figure 7.2 R1 = 2 k ohms, R2 = 99 k ohms, R3 = 10 k ohms and R4 = 100 k ohms. If the voltage at the top input is +2.0 mV and the voltage at the bottom input is -1.0 mV, what is the output voltage?

Solution:

The best way to keep track of voltages is to make a chart of all three terminals of all three op amps as shown. The voltages at the noninverting inputs of OA1

Terminal | OA1 | OA2 | OA3
noninverting input | +2 mV | -1 mV | 136.81818 mV
inverting input | +2 mV | -1 mV | 136.81818 mV
Output | 150.5 mV | -149.5 mV | 3.00 V

and OA2 are given and so can be filled in immediately. The op amps will make the voltage at the inverting input be the same as that at the noninverting input and so these values can also be filled in by inspection. The voltage across R1 is 2 mV -(-1 mV) = 3 mV. The current in R1 is I = 3 mV / 2 k ohms = 3/2 uA. The voltage drop across either R2 is V = 3/2 uA x 99 k ohms = 148.5 mV with the upper end positive. The lower end of the top R2 is at a potential of +2 mV; therefore, the upper end of the top R2 is at 2 mV + 148.5 mV = 150.5 mV. The upper end of the bottom R2 is at -1 mV; therefore, the lower end is at (-1 mV) + (-148.5 mV) = -149.5 mV. Notice that the difference is 150.5 mV - (-149.5 mV) = 300 mV. This confirms a first-stage gain of 100. The voltage at the noninverting input of OA3 is found by simply applying the voltage divider equation to R3 and R4. The noninverting input of OA3 does not load the voltage divider. V+3 = VO1 R4 / (R3 + R4) = 150.5 mV x 100 k ohms / 110 k ohms = 136.81818 mV. The entries for both the noninverting input and the inverting input of OA3 can now be filled in. The voltage drop across the bottom R3 is 136.81818 mV - (-149.5 mV) = 286.31818 mV. The current through the lower R3 is I = 286.31818 mV / 10 k ohms = 28.631818 uA. The voltage drop across the lower R4 is 28.631818 uA x 100 k ohms = 2863.1818 mV with the right end positive. The voltage at the output of OA3 is its inverting input voltage + the drop across the lower R4, which is 136.81818 mV + 2863.1818 mV = 2999.99998 mV which, when rounded off, gives 3.00 volts.

The results of this example confirm that the gain of the second (OA3) stage is given by

A' = R4 / R3  (7.4)

even though the circuit appears more complicated than an ordinary inverting amplifier.

The input to the circuit of Figure 7.2 is a differential input because neither side of the input needs to be connected to ground. The output of the first stage (OA1 and OA2) is a differential output because neither side is connected to ground. The input to the second (OA3) stage is also differential. The output from OA3 is said to be single-ended because one side is connected to ground. Thus a circuit consisting of two R3s, two R4s and an op amp can be used to convert a differential source to a single-ended load. The problem with using such a circuit is that the input resistances at its two inputs are not equal. The input resistance at the noninverting input is R3 + R4 while the input impedance at the inverting input is R3. The two noninverting amplifiers serve to balance the input impedances and at the same time make them very high.

Connecting R1 between the two amplifiers instead of each amplifier having its own R1 makes the amplifiers self-balancing, which increases the common mode rejection ratio. Note in the example that even though the original inputs had a 2 to 1 imbalance, the outputs had less than a 1% imbalance. The OA3 stage can easily accommodate the small imbalance. If this circuit is to have a high CMRR the values of the two R3s and the two R4s must be very well matched.

The resistors RS are used to prevent serious imbalance due to input bias currents in the event that the source has a high Thevenin resistance. If input bias current is no problem the two resistors may be omitted (replaced by pieces of wire).

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

7.2 AC Voltmeter Circuit.

Voltmeters, whether analog or digital, are basically DC measuring instruments. When it is desired to measure AC the common practice is to change the AC to DC and then measure it. This causes problems because the diodes which are used to rectify the AC are not linear. Perhaps the oldest approach is to print a separate scale on the face of the meter, (analog meters), and instruct the operator to read that scale when measuring AC. This method has worked well for many decades in meters which have no electronic circuits inside them.

Electronic voltmeters use some electronic tricks to make the response of the rectifiers linear. The circuit of a linear AC voltmeter is shown in Figure 7.3.

Figure 7.3 Linear AC Voltmeter Circuit.

For a verbal description click here.

If you trace the current through the bridge as was done in Chapter 3 the current will be seen to be flowing in or out of the op amp output, through one of the top diodes in the bridge, through the meter from right to left, through one of the bottom diodes and up or down through the resistor R2 to ground. The feedback is taken from the top of the resistor which makes the voltage waveform across R2 match the input waveform. Because R2 is a resistor, its current waveform will match the input voltage waveform. The meter and the resistor are in series. The same current is flowing in the meter as flows in R2. The meter current is the absolute value of the R2 waveform but the magnitudes are identical. If you look at the output voltage waveform on a scope, you will see a very distorted wave. What you are seeing is what has been said many times, "The op amp will adjust its output voltage to make the inverting input voltage equal the noninverting input voltage." The output voltage will be whatever it has to be to make the current in R2 directly proportional to the input voltage. In this case it is the meter current which is being linearized. Since the pointer responds to the meter current, the deflection of the pointer will be linearly proportional to the average input voltage. The meter can be calibrated to indicate the RMS of a sine wave.

The value of R2 sets the full-scale range of the meter. With the value given the range will be approximately 1 volt if a 1 mA meter is used. The 100 pf capacitor is to prevent the op amp from oscillation at high frequencies. This capacitor will cause the meter to lose accuracy at high frequencies and if you want to measure voltages of high frequency waves the capacitor must be as small as possible while still preventing oscillation. The capacitor at the input is necessary to block any DC which may be mixed with the AC to be measured.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

7.3 Open-loop Linearization.

Occasionally in a physics lab it is necessary to make a measurement on some sensor which is at a very high potential. When this is the case a way must be found to transfer the electrical signal and still not have any direct electrical connection. That may seem impossible but don't forget about the transformer which transfers electrical energy while providing electrical isolation. If the sensor delivered AC, a transformer could be used to couple the signal while isolating it. Unfortunately most sensors deliver a slowly changing DC. One approach often used is to change the DC to a proportional AC and then pass it through a transformer for isolation. After isolation the signal may be processed in any manner desired.

Figure 7.4 Open-loop Linearized Photocell.

For a verbal description click here.

A somewhat simpler method of isolation is shown in Figure 7.4. The input signal (from the sensor) is applied to the inverting input of the op amp. The feedback is taken to the noninverting input of the amp. That may seem to be positive feedback but the lamp and photocell have something to say about that. As the voltage at the output of the op amp goes positive, the lamp grows brighter. As the photocell receives more intense illumination its resistance decreases. As the resistance of the photocell decreases the voltage at the noninverting input of the op amp will be decreased. The combination of the lamp and photocell provide the inversion and so the op amp does not have to.

When a positive voltage is applied to the input the op amp will adjust the brightness of the lamp so that the voltage across the photocell on the left is equal to the input voltage. If the two photocells are closely matched the voltage across the photocell on the right will also be equal to the input voltage. Because there is no electrical connection between the two parts of the circuit, the input can be at any arbitrarily high potential and allow the output to be grounded.

In this circuit the batteries are meant to be batteries. The circuit should be constructed in an insulated box to prevent accidental electric shock. The value of the resistor and pot which are in series with the photocells depend on the illuminated resistance of the photocells. The values of these resistors will have to be determined after the photocells are obtained. The purpose of the two diodes in series with the lamp is to permit the lamp voltage to go all the way to zero. The output of an op amp will have a minimum voltage of 2 P-N junctions from the negative power supply lead. The circuit only works for positive input voltages. If a negative input is applied, the lamp will attempt to get darker than dark and nothing will happen, except in the twilight zone.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

7.4 Absolute Value Amplifier.

The AC voltmeter circuit given above will change AC to a linear meter reading but sometimes it is necessary to change an AC to a linearly proportional DC voltage. Simple rectifiers of the type used in power supplies are not linear and indeed have no output for the first 0.6 volts of the input signal. If the diodes are placed in the feedback loop of an op amp (two op amps in this case) the rectified output will be directly proportional to the input. The circuit of a linear rectifier or absolute value amplifier is shown in Figure 7.5.

Figure 7.5 Absolute Value Amplifier.

For a verbal description click here.

When an AC signal applied to the input goes positive, the output of OA1 goes negative. This reverse biases D2 and forward biases D1. The output of OA1 is disconnected from the output of the circuit. Meanwhile, the output of OA2 goes positive. This forward biases D4 which connects the output of OA2 to the output of the circuit. D3 is reverse biased as we will shortly see. The inverting input of OA2 is connected to the output node through R3. The op amp will adjust its output to whatever voltage is necessary to bring the output node to the same potential as the input node. That will cause the output of OA2 to be about 0.6 volts more positive than the input node of the circuit. D3 is therefore reverse biased by 0.6 volts. For a positive input, the output is also positive and has the same voltage.

When the input goes negative the output of OA2 goes negative, which reverse biases D4, disconnecting the output of OA2 from the output node of the circuit. D3 is forward biased. For a negative input, the output of OA1 will go positive. D2 is forward biased and D1 is reverse biased. Resistor R2 takes feedback from the output node and if R1 and R2 are of equal value the output node will have the same magnitude and opposite sign as the input node. Thus for a negative input the output is positive but has the same magnitude as the input.

If a capacitor is placed in parallel with R4 the circuit becomes a peak detector. If an RC low-pass filter is connected to the output the circuit becomes an average value detector. In the latter case the resistor in the low-pass filter should be greater than 1 M ohms for an error of less than 1%. In either case the value of the capacitor will depend on the response time required.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

7.5 Log Converter.

This section has been rendered obsolete by the low cost of powerful desk top computers and data collection systems. It has been left in to show how things were a few years ago.

If it is necessary to take the log of data which is being collected in an experiment, the method of choice is to digitize the data and let a computer do the log taking. In very well-funded laboratories the computer is on-line, (connected to the experimental equipment). In less well-funded experiments the data must be hand carried - on disk, tape or paper - to the computer.

It is always desirable and often necessary to see the log of the data as the experiment is running. Seeing the log of the data may be necessary in order to properly adjust the equipment. If the experimenter is able to see the data come out as the experiment runs, it is possible to tell if something has gone wrong. A strip-chart recorder is often used for this purpose.

Many experiments deliver the data in analog form and most strip-chart recorders accept data in analog form. For the purpose of so-called "quick look" data reduction an analog device which will take the log of analog data may be helpful.

The circuit of a working logarithmic converter is shown in Figure 7.6. This circuit is designed to be used with a strip-chart recorder having a Y axis input of 10 mV full- scale. With the values given the unit may be calibrated to 1 mV = 10 dB. The converter operates from two 9 volt transistor radio batteries.

Figure 7.6 Logarithmic Converter for Use with
a 10 mV Strip-chart Recorder.

For a verbal description click here.

The op amp is a type 558 which has two amplifiers in a single 8 pin package. The transistors used here were from the junk box. Any low power PNP transistors will do so long as they are reasonably well matched.

The batteries are connected as shown in Figure 6.1. A double pole switch is required to interrupt the current from both batteries.

The input signal is applied through R1 to the inverting input of OA1 which is nothing more than a unity-gain inverter. R5 is a zero adjust control. The op amp used has no offset adjustment pin connections and so the somewhat elaborate network of R4 through R9 is required to provide offset adjustment for the op amp.

Transistor Q1 is the element which does the log taking. The I-V curve of a P-N junction is an exponential or a logarithmic function depending on how you look at it. In this circuit we are looking at it as a log function. If a positive input signal is applied to the input, it will be inverted and appear at the output of OA1 as a negative voltage. This will cause current to flow to the left in R10. The output of OA2 will adjust itself so that the collector current of Q1 is equal to the current in R10. The voltage at the op amp's output will be adjusted so as to forward bias the base-emitter junction of Q1. If the input voltage changes, the collector current of Q1 will change linearly and the base-emitter voltage will change logarithmically.

Transistor Q2 serves to temperature compensate the circuit. For example, if the temperature goes up, the base- emitter voltage of Q1 will decrease, which will lower the output voltage. At the same time the temperature of Q2 will increase and its base-emitter voltage will also decrease. The decreased drop across Q2 will increase the output voltage which will compensate for the decrease caused by Q1. Q1 and Q2 should be in physical contact to insure that they are at the same temperature. If the transistors are in metal packages, they should be electrically insulated from each other because the case is often connected electrically to one of the transistor elements.

The network of R12 through R14 reduces the output voltage to the proper level for the 10 mV chart recorder. R13 should be adjusted for a span of 10 dB per mV at the upper end of the working range. R5 may be used to correct errors at the low end of the range. The unit will not have a working range of 100 dB as implied by 10 / mV over a range of 10 mV. The best achievable is about 50 dB. Below -50 dB the response tends to become linear rather than logarithmic.

If the input voltage is negative, OA2 will go to full negative saturation which will slam the chart recorder's pen down hard against the zero stop. The log of a negative number is undefined in the analog world as well as in the world of numbers. The only capacitor in the circuit is to prevent OA2 from oscillating at ultrasonic frequencies.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

7.6 Active Filters.

A single RC filter provides a roll off in the stop-band of 20 dB per decade. Cascading filters (connecting the output of one to the input of the next) does not work as well as might be expected. The roll off around cutoff is so gradual that the filter begins to affect the output long before any large values of attenuation are reached. A single LC filter section will give a roll off of 40 dB per decade and it affects the output only slightly on the pass-side of cutoff. Attenuation increases quickly on the stop-side of cutoff. The problem is that inductors are large, heavy, expensive and often difficult to find. The solution is an active filter. An op amp circuit which has only resistors and capacitors in addition to the op amp can simulate an LC filter. Several of such circuits could be placed in the same volume of one inductor.

Figure 7.7 shows a high-pass filter circuit. In this circuit if C = 0.01 uf and R = 10 k ohms the cutoff frequency is 2.8 kHz and the attenuation at 60 Hz is 50 dB. The cutoff frequency can be calculated from,

fC = 1 / (3.5 R C)  (7.5)

Figure 7.7 High-pass Active Filter Circuit.

For a verbal description click here.

The op amp is used as a unity-gain buffer. In order to insure good performance, the gain error should be less than the desired measurement accuracy at the highest frequency to be passed.

Figure 7.8 shows a low-pass filter circuit. In this circuit if C = 0.1 uf and R = 150 k ohms the cutoff frequency is 4.5 Hz and the attenuation at 60 Hz is 36 dB. The cutoff frequency can be calculated from,

fC = 1 / (15 R C)  (7.5)

Figure 7.8 Low-pass Active Filter Circuit.

For a verbal description click here.

The op amp is used as a unity-gain buffer. In order to insure good performance, the gain error should be less than about 5% at 10 times the cutoff frequency.

Example 7.2.

It is desired to construct a low-pass filter with a cutoff frequency of 0.1 Hz. The capacitors to be used have a value of 1.0 uf. (a) What is the calculated value of R? (b) What standard values should be used for the two resistors in the filter?

Solution:

(a) Solving equation 7.6 for R gives R = 1 / (15 fC C) =
1 / (15 x 0.1 x 1 x 10-6) = 667 k ohms

(b) The closest value for R is 680 k ohms and the closest value for 2R is 1.3 M ohms.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

7.7 Problems.

  1. In the circuit of Figure 7.2 R1 = 200 ohms, R2 = 99.9 k ohms, R3 = 10 k ohms and R4 = 1 M ohm. If the voltage at the top input is -20 uV and the voltage at the bottom input is -70 uV, (a) what are the voltages at each of the op amp terminals? Make a chart similar to that in Example 7.1. (b> What is the gain of the amplifier?

  2. Using the circuits given in this chapter draw the schematic diagram of a circuit which will take an AC signal and rectify it without introducing significant errors. Then the circuit must average the rectified AC and convert it to dB.

  3. Design a high-pass filter which has a cutoff frequency of 10 kHz. The capacitors have a value of 0.0033 uf. Give the standard values for the resistors to be used in the circuit. Draw the circuit.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

7.8 Answers to Problems.

  1. The table shows the values.

    Terminal | OA1 | OA2 | OA3
    noninverting input | -20 uV | -70 uV | 24.7079208 mV
    inverting input | -20 uV | -70 uV | 24.7079208 mV
    Output | 24.9550000 mV | -25.0450000 mV | 5.0000000 V

    (b) 100,000

  2. The averaging could be accomplished using a passive RC filter but I decided to go all out. If you drew an RC filter, your answer is correct.

    Figure 7.9 Answer to question 2.

    For a verbal description click here.

  3. R = 9.1 k ohms, 2R = 18 k ohms. The circuit is like figure 7.7.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

This page copyright © Max Robinson. All rights reserved.


Chapter 8   Digital Circuits.

8.1  The Binary Number System.
8.2  Logic Functions and Gates.
8.3  Boolean Algebra.
8.4  Combinational Logic Circuits.
8.5  Flip-Flops and Counters.
8.6  Displaying the Count.
8.7  Multiplexed Displays.
8.8  Digital to Analog Converter.
8.9  Analog to Digital Converter.
8.10 The 555 Timer.
8.11 Problems.
8.12 Answers to Problems

Chapter 8

Digital Circuits.

Up to this point we have been dealing with analog signals. An analog signal is a voltage or current which carries information and can take on any value. For example the output of a thermocouple can be 31.56 uV or 103.97 uV or even 1.6358 mV. The point is that the only limit is our ability to measure the voltage. The voltage itself may have a value of 1.63582419574239658395723656793445642467543 mV for all we know. Analog data is quantized (if at all) only by the measurement technique. The data itself may take on any value.

Digital data on the other hand is presented as numbers. Two forms you are likely familiar with are the readout of the digital multimeter and the data stored in a computer. The values of digital data are quantized. For example if the data is only available to 3 significant digits then the data can only have values such as 3.82 and 3.83. The datum cannot take on a value between 3.82 and 3.83.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

8.1 The Binary Number System.

The number system we use has ten digits (0 through 9) and we write numbers by using a system of positional weighting. The earliest computer circuits attempted to emulate this system. For example there might be a set of four different voltages, each voltage could be zero, 1 volt, 2 volts, and so on to 9 volts. One of the voltages could be used to represent units, another tens, the third hundreds and the fourth thousands. While this sounds workable in theory and easy to use, in practice the circuits become very complex and expensive to construct.

The system of binary numbers has been around for more than a century but it had no practical use until the digital computer came along. Instead of using a number system where each digit can take on ten different values it is much easier to let each digit have only two values. For example, if we have a set of voltages and each can be either 0 volts or 5 volts, we can use a system of positional weighting as shown in Figure 8.1.

28 | 27 | 26 | 25 | 24 | 23 | 22 | 21 | 20
256 | 128 | 64 | 32 | 16 | 8 | 4 | 2 | 1
0 | 1 | 1 | 0 | 0 | 1 | 0 | 1 | 1

Figure 8.1 Example of a 9 Digit Binary Number.

The first line in Figure 8.1 gives the power of 2 for each position in the binary number system. The second line gives the actual values of each position. The third line is an example of a binary number. The number is 203 decimal. The position values continue on to the left 29, 210, etc, for as far as is needed.

To convert a binary number to decimal all that is necessary is to add the positional values in all columns where the binary digit has the value 1. In Figure 8.1 it is 128 + 64 + 8 + 2 + 1 = 203. Figure 8.2 shows what counting in binary looks like.

0 | 0 0 0 0 0
1 | 0 0 0 0 1
2 | 0 0 0 1 0
3 | 0 0 0 1 1
4 | 0 0 1 0 0
5 | 0 0 1 0 1
6 | 0 0 1 1 0
7 | 0 0 1 1 1
8 | 0 1 0 0 0
9 | 0 1 0 0 1
10 | 0 1 0 1 0
11 | 0 1 0 1 1
12 | 0 1 1 0 0
13 | 0 1 1 0 1
14 | 0 1 1 1 0

Figure 8.2 Counting in Binary Numbers.

The term "binary digit" has been shortened to the word "bit". A bit is a binary digit. A number which has 8 binary digits is said to be an 8 bit number. A bit is allowed to have only two values: 0 and 1.

Binary Addition.

Addition in binary is just like addition in decimal (if you're missing eight fingers). The rules for addition are summarized in Figure 8.3.

Bits to be added | 0 + 0 | 0 + 1 | 1 + 1 | 1 + 1 + 1
Sum | 00 | 01 | 10 | 11
Single Bit Sum | 0 | 1 | 0 | 1
Carry | 0 | 0 | 1 | 1

Figure 8.3 Rules for Addition of Binary Digits.

Binary addition is limited to two binary numbers because of hardware limitations. However, if the addition of the bits to the right produced a carry the current pair of bits must include provisions for a third bit to be added. The last column allows for both bits being added to be 1 and the addition to the right to produce a carry of 1.

Example 8.1.

What is the sum of 100111 and 1011?

Solution:

As with decimal numbers the shorter number must be filled out with zeros on the left.

Carried | 0 | 1 | 1 | 1 | 1
First number | 1 | 0 | 0 | 1 | 1 | 1
Second number | 0 | 0 | 1 | 0 | 1 | 1
Sum From Figure 8.3 | 1 | 1 | 10 | 10 | 11 | 10
Write Down | 1 | 1 | 0 | 0 | 1 | 0
And Carry | 0 | 0 | 1 | 1 | 1 | 1

We'll learn multiplication in the second grade.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

8.2 Logic Functions and Gates.

We can do more with binary digits than just add them. We can perform the logic functions AND, OR and NOT on them. Since binary digits (bits) only have two states they can be used to represent anything which has two states. For example a lamp can be either on or off, a switch can be either closed or open, an answer can be either true or false; each of these may be represented by a bit which is either 1 or 0.

Suppose we connect up three switches as shown in Figure 8.4. What we know about circuits tells us that all three switches must be closed to turn on the lamp. If we set up the rule that 1 = closed = lighted we can write a table as in Figure 8.5.

Figure 8.4 AND Function Illustrated Using Switches.

For a verbal description click here.

A | B | C | LAMP
0 | 0 | 0 | 0
0 | 0 | 1 | 0
0 | 1 | 0 | 0
0 | 1 | 1 | 0
1 | 0 | 0 | 0
1 | 0 | 1 | 0
1 | 1 | 0 | 0
1 | 1 | 1 | 1

Figure 8.5 Truth Table for AND Function.

This is referred to as an AND function because to get the lamp to glow it is necessary to close switches A and B and C. A table which lists all possible combinations of inputs (stimuli) and the response for each combination is called a "truth table".

If we connect three switches in parallel, as in Figure 8.6, we have an OR function. If any one switch is closed the lamp lights. This is referred to as an OR function because to get the lamp to glow it is only necessary to close switch A or B or C. It makes no difference if more than one switch is closed, the lamp stays on. This is the inclusive OR function. It is always referred to simply as the OR function. The truth table for the OR function is shown in Figure 8.7.

Figure 8.6 OR Function Illustrated Using Switches.

For a verbal description click here.

A | B | C | LAMP
0 | 0 | 0 | 0
0 | 0 | 1 | 1
0 | 1 | 0 | 1
0 | 1 | 1 | 1
1 | 0 | 0 | 1
1 | 0 | 1 | 1
1 | 1 | 0 | 1
1 | 1 | 1 | 1

Figure 8.7 Truth Table for OR Function.

The two remaining functions cannot be illustrated using switches and lamps. The functions are NOT and Exclusive OR, referred to as XOR.

The NOT function is simply a state inverter. If the input is 0 the output is 1. If the input is 1 the output is 0. An inverter can have only one input. The truth table for an inverter is given in Figure 8.8.

³
INPUT | OUTPUT
0 | 1
1 | 0

Figure 8.8 Truth Table for Logic Inverter

An exclusive OR (XOR) function can only have two inputs. The XOR function is similar to the OR function except that if both inputs are 1s the output is 0. The output is true (1) if A is 1 or B is 1 but the case of A = B = 1 is excluded. The truth table for an XOR function is shown in Figure 8.9.

A | B | LAMP
0 | 0 | 0
0 | 1 | 1
1 | 0 | 1
1 | 1 | 0

Figure 8.9 Truth Table for XOR Function.

Logic functions are implemented with transistors, diodes and resistors which are packaged in integrated circuits. For the purpose of drawing schematic diagrams each logic function has a schematic symbol. They are given in Figure 8.10. A circuit which performs a given logic function is called a logic gate.

Figure 8.10 Schematic Symbols for Logic Gates.

For a verbal description click here.

The NAND and NOR gates which are shown in the schematic symbols are combinations of the NOT and AND, and the NOT and OR functions respectively. The truth tables for the NAND and NOR gates are given in Figure 8.11.

NAND
A | B | C | OUTPUT
0 | 0 | 0 | 1
0 | 0 | 1 | 1
0 | 1 | 0 | 1
0 | 1 | 1 | 1
1 | 0 | 0 | 1
1 | 0 | 1 | 1
1 | 1 | 0 | 1
1 | 1 | 1 | 0

NOR
A | B | C | OUTPUT
0 | 0 | 0 | 1
0 | 0 | 1 | 0
0 | 1 | 0 | 0
0 | 1 | 1 | 0
1 | 0 | 0 | 0
1 | 0 | 1 | 0
1 | 1 | 0 | 0
1 | 1 | 1 | 0

Figure 8.11 Truth Tables for NAND and NOR Gates.

It is not important to know the internal schematic diagram of a logic gate. If it were to be given here the reader would most likely not remember it. The curious reader is referred to IC data books most of which give the internal diagrams.

Logic Families.

The first digital ICs were essentially the same as the circuits of the BJT switches studied in chapter 4. These ICs employed more resistors than transistors. It is normal in discrete circuitry to use more resistors than transistors because resistors are less costly than transistors. A peculiarity of ICs is that it is actually cheaper to make transistors on a chip than it is to make resistors. Circuits were developed which would have been impractical to construct using discrete circuitry. They used more transistors than resistors.

Those first-generation ICs were called RTL for Resistor- Transistor-Logic. The logic family which contains more transistors than resistors is called TTL for Transistor- Transistor-Logic. There was an intermediate stage of development which used a large number of diodes. This family was called DTL for Diode-Transistor-Logic. Of these the only one in use today is TTL.

The two most important logic families today are TTL Transistor-Transistor-Logic and CMOS Complementary-Metal- Oxide-Semiconductor logic. Each logic family is being subdivided into many subfamilies which since this book was originally written have increased exponentially. These subfamilies are too numerous to cover in detail here. We will look briefly at a few of the most important subfamilies.

7400 Series TTL.

This family is the father of the TTL family. Because it is constructed with BJTs it has low input impedance and low output impedance. It operates from a 5 volt power supply. Each gate output can drive 10 inputs of other gates.

An input voltage in the range of 0 to 0.8 volts is recognized as a logic 0 while an input voltage in the range of 2 to 5 volts is recognized as a logic 1. If the input voltage is between 0.8 and 2 volts there is no guarantee as to what will happen.

74LS00 Series Low-power Schottky TTL.

This subfamily operates at about 1/10 the power and about twice the speed of standard TTL. Because of the speed and power difference it is not advisable to mix 74-- and 74LS-- ICs in the same circuit (unless you are sure of what you are doing).

74C00 CMOS.

The ICs in this subfamily are pin compatible with the corresponding 74-- or 74LS-- of the TTL families. However, they are NOT electrically compatible. Like all CMOS they operate from a power supply anywhere in the range of 3.6 to 15 volts. They have very high input impedance and medium output impedance. Because the logic levels are incompatible CMOS and TTL cannot be mixed even if operated from the same power supply.

In CMOS an input voltage in the range of 0 to 1/3 VCC is recognized as a logic 0 while an input voltage in the range of 2/3 VCC to VCC is recognized as a logic 1. If the input voltage is between 1/3 VCC and 2/3 VCC there is no guarantee as to what will happen.

74HC00 Series.

This is a hybrid of TTL and CMOS. It operates at TTL speeds but is level compatable with CMOS. It operates from 5 volts.

4000 Series CMOS.

The 4000 series CMOS has the same logic levels as the 74C00 CMOS. The series contains a wide variety of gates, flip-flops, counters and other special purpose ICs not found in the 74C00 series.

CMOS has a reputation of being subject to burnout from handling. Like the black widow spider and the tarantula, its reputation is undeserved. The input pins are protected by diodes which make the ICs quite rugged. Normal prudence is all that is required when handling these ICs. The writer has completed several projects using CMOS ICs and has yet to burn one out due to handling.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

8.3 Boolean Algebra.

The subject of Boolean algebra is one which could occupy an entire semester. There is not time or space to offer proofs of any of the theorems. The theorems will simply be stated and their applications indicated. The interested reader is referred to texts devoted exclusively to the subject.

Notation.

The functions in Boolean algebra are not the mathematical functions we are accustomed to but are the logic functions of AND, OR, NOT and XOR. The symbols for these functions look like some of our arithmetic symbols but in the context of Boolean algebra they are read differently.

The OR function is symbolized by a plus + sign. Thus C = A + B is not read as "c equals a plus b" but is read "c equals a or b". The table in Figure 8.12 summarizes the Boolean functions and the proper way of speaking each.

The symbol normally used for the exclusive OR function is a plus sign with a circle around it. This symbol is not available in text mode in html. The symbol in text for exclusive OR will be "XOR". In graphics the symbol will be used.

Figure 8.12 Table of Logic Functions and How to Speak Them.

For a verbal description click here.

Figure 8.13 Summary of Boolean Algebra Theorems.

For a verbal description click here.

Figure 8.13 lists some of the most important theorems in Boolean algebra. As you look over the table of theorems you will note some similarity to linear algebra. The last entry in the table is called DeMorgan's theorem. It is one of the most powerful and useful theorems for designing logic circuits.

Example 8.2.

Use a truth table to prove that not A and B or A and not B = A X-or B.

Solution:

For a verbal description click here.

QED.

Example 8.3.

Simplify the following Boolean expression.

D = A and not B and C or A and B and not C

Solution:

Factoring out an A we have

D = A and quantity not B and C or B and not C close quantity

Using the theorem proven in Example 8.2 yields

D = A and the quantity B X-or C close quantity

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

8.4 Combinational Logic Circuits.

The term combinational logic is applied to any connection of logic gates which serves some specific purpose. For example, suppose that there is an experiment in which something in the apparatus could be damaged if certain switches were to be on at the same time. A system of gates could be used to shut down some critical part of the setup if an operator accidentally set the forbidden combination.

Suppose that the equipment may be damaged if switches A and C are on at the same time or if switch B is off when switch D is on. The protection circuit P must be activated if A and C or not-B and D are on. In Boolean form the equation is,

P = A and C or not B and D. 8.1

Expression 8.1 cannot be simplified further. The circuit is shown in Figure 8.14. Gate 1 inverts the B input to form not B. Gate 2 forms the A AND C term while gate 3 forms the B AND D term. Gate 4 forms the final output.

Figure 8.14 Realization of Boolean Expression 8.1.

For a verbal description click here.

It was mentioned earlier that DeMorgan's theorem is very useful in creating logic circuits. The reason is this. The easiest type of gate for IC designers to design and manufacturers to make is the NAND gate. This is true for both TTL and CMOS logic families.

Suppose that it is necessary to implement the following Boolean expression:

D = not A or not B or not C. 8.2

The first impulse would be to use the circuit of Figure 8.15a. However, DeMorgan's theorem extended for three variables states that,

not A or not B or not C = not the quantity A and B and C close quantity. 8.3

The expression D = not the quantity A X B X C may be implemented with a single 3 input NAND gate as shown in Figure 8.15b.

Figure 8.15 DeMorgan's Theorem Is Used to Simplify Circuits.

For a verbal description click here.

The entire process of logic design is to start with a Boolean expression, simplify it and get as many NAND functions in it as possible, then convert the expression to a circuit.

Example 8.4.

The output of a logic circuit is to be high (on) if A is on and B and C are off, or if A and C are on and B is off. Write the Boolean expression, simplify it if possible and then draw the circuit.

Solution:

The initial form of the expression is

D = A and not B and not C or A and not B and C.

If we factor out an A and not B from each term we have

D = A and not B and the quantity not C or Cclose quantity.

but not C or C = 1 and A and 1 = A; therefore, D = A and not B. The first impulse is to use an inverter to obtain the NOT-B term and a two input AND gate. Something you may not know is that gates do not come one per package. Two input gates come four per package. (The term DIP is often used. DIP stands for Dual Inline Package.) A two input NAND gate may be used as an inverter by tying its two inputs together and using them as the inverter's input. We can use one of the NAND gates as an inverter to obtain the NOT-B term, use another to perform the NAND function of A NAND NOT-B and then use another inverter to invert the output of the NAND gate and thereby convert it into an AND gate. The circuit is shown in Figure 8.16.

Figure 8.16 Solution to Example 8.4.

For a verbal description click here.

The initial uninformed solution might have been to implement the logic circuit based on the description in the example. A little Boolean algebra showed that the C input was redundant. In a simple circuit this wouldn't have made any practical difference. In a very complex circuit a redundant input could lead to use of a lot of unnecessary parts.

The solution to Example 8.4 ended up using three of the gates in a quadruple 2 input NAND gate. Such an IC costs less than 25 cents in TTL and less than 50 cents in CMOS.

Combinational logic circuits can get very complex as can the Boolean expressions which represent them. Such large projects are the province of design engineers who are experienced in such matters. The physics student should only attempt to design logic circuits if they are small and simple, as in Example 8.4.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

8.5 Flip-Flops and Counters.

The formal name for a flip-flop is a bistable device. It is a device which is stable in either of two states and will remain in whichever state it is in until it is forced into the other state where it will remain until again changed. Although this definition sounds simple, flip-flops come in a wide variety of shapes, sizes and colors. We will begin with the simplest.

Switch Debouncing Flip-flop.

We are accustomed to thinking of mechanical switches as being either on or off. But if you look on a microsecond time scale, when a switch is turned on or off the contacts open and close several times before they finally settle down to the state in which it has been placed. If the switch is being used to turn a flashlight on and off the bouncing will make no difference and will not even be detectable by the user. But if the switch is being used to activate a logic circuit, operating the switch once may make the logic circuit "think" that the switch has been operated several times. The circuit of Figure 8.17 employs two NAND gates to generate one state change for each position change of the switch.

Figure 8.17 Switch Debouncing Circuit.

For a verbal description click here.

Suppose that the switch has just been thrown and is in transition between the two contacts. Neither switch contact is connected and so both switch contacts are pulled up to VCC by the 10 k ohm resistors. Suppose that Q is low (logic 0) and NOT-Q is high (logic 1). Both inputs to the upper gate are high which allows its output to be low. The lower gate has one input high and the other one low which makes its output high. So far so good, no contradictions.

If the grounded swinger of the switch makes contact to the upper contact, one of the inputs to the upper gate will be pulled low. That will force its output to go high. The lower gate will now have a high on both inputs, which will make its output low. Thus, NOT-Q will be low (0). If the swinger loses contact on a bounce, the two outputs will remain in the same state. The swinger may bounce on the upper contact as many times as it likes, the state of the flip-flop consisting of the two gates will not change again until the swinger touches the lower contact.

Each time the switch is changed to the other position, the state of the flip-flop is changed by the first bounce of the switch contact. Subsequent bounces will not affect the state of the flip-flop. The contact will not bounce far enough to touch the other contact. The contacts are not made of rubber.

The R-S (Reset Set) Master-slave Flip-flop.

The logic diagram of an R-S master-slave flip-flop is shown in Figure 8.18. If the Ck (clock) input is low, gates 1 and 2 will both have high outputs and the master flip-flop consisting of gates 3 and 4 will remain in whatever state it was in; the states of the R and S inputs will have no effect on gates 3 and 4. If the Ck (clock) input is high, gates 1

Figure 8.18 Internal Logic Diagram of an R-S Flip-flop.

For a verbal description click here.

and 2 will be open, which means that the states applied to R and S will be transferred into the master flip-flop. The high on Ck will be inverted by the inverter and gates 5 and 6 will have low states on their inputs, which will close these gates. The outputs of gates 5 and 6 will be high, which means that the slave flip-flop will remain in whatever state it was in.

It may seem impossible to ever transfer a logic state from the R and S inputs to the Q and NOT-Q outputs. Of course it is possible or the circuit would be useless. Let us start out by assuming that the Q output is low. Naturally the NOT-Q output is high. Referring to the flip-flop as a whole it is said to be in the zero state. Let us say that the S input is high, the R input is low and the Ck input is low. Because Ck is low the outputs of gates 1 and 2 will be high. The output of gate 3 must be low and gate 4 high. Gates 5 and 6 are open and these states are transferred through to gates 7 and 8. Now when the Ck input changes to high, gates 1 and 2 are opened and the states on R and S are inverted and transferred to the inputs of gates 3 and 4. A low on one of the inputs of gate 3 will cause its output to go high and gate 4 will have both of its inputs high, which will make its output low. The master flip-flop is now in the 1 state. With the Ck input high, gates 5 and 6 are closed and the slave flip-flop remains in the zero state. When the Ck input changes back to the low state, gates 1 and 2 are closed and the master flip-flop cannot be any further affected by the states on the R and S inputs. The level shift causes the inverter to change states at a lower voltage than gates 1 and 2. On a negative transition, gates 1 and 2 are closed before gates 5 and 6 are opened. Thus there is an approximate 20 nanosecond period when both sets of gates (1 and 2) and (5 and 6) are closed and the R and S inputs are never connected directly to the Q and NOT-Q outputs. With the Ck input in the low state, gates 5 and 6 are opened and the 1 state of the master flip-flop is transferred into the slave flip-flop. Thus the state of Q is now high and NOT-Q is low. If the S input is high and R is low the flip-flop will be Set to the 1 state (Q high and NOT-Q low) and when R is high and S low the flip-flop will be Reset to the zero state. The states of Q and NOT-Q will change only when the Ck input changes from high to low. After the states of Q and NOT-Q have changed to match the states of S and R, additional clock transitions have no effect on the state of the outputs.

If R and S are both low, the flip-flop will remain in its previous state. The outputs will not change states on the clock transition. If both R and S are high, the flip- flop of gates 3 and 4 will be forced into an undefined state and when the clock goes low it will be released from that state and will randomly fall into one of its two stable states. The ending state cannot be predicted. A given IC may always fall into the same state but a different IC may always fall into the other state. Yet another IC may randomly fall into one or the other state.

Most flip-flop ICs have direct set and clear inputs. These inputs will override all other inputs and force the flip-flop into the 1 (set) of 0 (clear) states. The logic involved makes the circuit look more complicated because of the increased number of inputs to gates 3, 4, 7 and 8. A student with a firm grasp of the subject of logic could figure out how to add direct set and clear to this circuit.

The J-K Flip-flop.

If the R-S flip-flop is cross wired (Q to R and NOT-Q to S) an interesting thing happens. Suppose that the flip-flop is in the zero state (Q = 0 and NOT-Q = 1). This means that S has a high applied and R has a low. When a negative edge of the clock occurs, the flip-flop will be loaded with a 1. Following the negative-going clock the R input has a high applied and the S has a low applied. On the next negative-going clock edge the flip-flop will be loaded with a zero. The flip-flop will change its state on every negative-going edge of the clock signal.

Now the importance of the level shift becomes evident. On a positive edge of the clock, gates 5 & 6 are closed before gates 1 & 2 are opened. On a negative edge gates 1 & 2 are closed before 5 & 6 are opened. If the R and S inputs were to be connected directly to the outputs even for a few tens of nanoseconds the circuit would most likely oscillate and the ending state would be completely random.

Figure 8.19 Internal Logic Diagram of a J-K Flip-flop.

For a verbal description click here.

If we make gates 1 and 2 into 3 input gates we have a J-K flip-flop as shown in Figure 8.19. The J-K flip-flop behaves differently from the R-S flip-flop in regard to what happens when J and K are high. In an R-S flip-flop when R and S are high the result is unpredictable. In a J-K flip- flop when J and K are high the flip-flop will change states on every negative edge of the clock input. The process of changing states on every clock is often called toggling. A flip-flop which has been permanently wired to change states on every clock pulse is often called a toggle flip-flop.

If J is high and K is low the flip-flop will be set to the 1 state on the next negative edge of the clock. If J is low and K is high the flip-flop will be set to the zero state on the next negative edge of the clock. If both J and K are low the state of the flip-flop will remain unchanged.

The Type-D (Data Storage) Flip-flop.

In order to store a bit (binary digit) in an R-S or J-K flip-flop it is necessary to place one of the inputs high and the other one low. Since the two inputs are always in opposite states the natural thing to do is to connect an inverter in the circuit as shown in Figure 8.20a. When a flip-flop has been internally wired in this way it is symbolized as in Figure 8.20b. Notice first of all that the internal logic diagram has been replaced by a rectangle. If a logic high (1) is placed on the D input, the next negative edge will cause the flip-flop to assume the 1 state (Q = 1 and NOT-Q = 0). If a logic low (0) is placed on the D input, the next negative edge on the clock will cause the flip-flop to assume the zero state (Q = 0 and NOT-Q = 1). Once the data bit has been stored in the flip-flop, subsequent clock pulses will just keep loading the same data again and again. If the data does not change between clock pulses the state of the flip-flop will not change.

Figure 8.20 D-type Flip-flop from J-K Flip-flop.

For a verbal description click here.

The Cl connection at the bottom of the rectangle and the S connection at the top are direct clear and set inputs respectively. This S is not the same as the S input on an R-S flip-flop. Clear and set inputs are usually active low, which means they are normally high and to clear the flip-flop the Cl input should be pulled low for a few tens of nanoseconds. To set the flip-flop the S input should be pulled low. In the case of TTL an input which is left open will automatically go high. A CMOS input should never be left open; on a CMOS flip-flop the Cl and S inputs must be tied to VCC through either a wire or a 10 k ohm resistor.

Binary Counter.

Figure 8.21 shows the diagram and truth table for a 4-bit binary counter. There is an inherent conflict between the way we draw circuits and the way we write numbers. The standard way of drawing circuits is to have the signal flow from left to right. That places the least significant bit on the left. The way we write numbers is to have the least significant bit on the right. This contradiction cannot be defined away. We must simply live with it.

The input to the counter may be irregular or regular pulses as indicated along the top of the figure. All unconnected inputs to the flip-flops are assumed to be logic high. Every time a flip-flop receives a negative-going edge, its state will change. See the table in the figure.

Figure 8.21 4-Bit Binary Counter and Its Truth Table.

For a verbal description click here.

Every time the input changes from high to low, flip-flop A will change states. Every time flip-flop A changes from a 1 to a 0, flip-flop B will change states and so on. If the counter starts from zero (all bits zero) the count at any time will equal the number of negative edges which have occurred in the input signal. The number is of course expressed in binary. The number of flip-flops in the counter may be arbitrarily large. The largest number NL a given counter can contain is

NL = 2N - 1  (8.4)

where N is the number of flip-flops in the counter.

If the input to the counter is a square wave it has a definite frequency. In this event the output of the counter also has a definite frequency. The output frequency is given by

fO = fIN / 2N  (8.5)

where fO is the output frequency, fIN is the input frequency and N is the number of flip-flops in the counter. Thus we have a means of changing (lowering) the frequency. With a simple binary divider the input frequency may only be divided by 2N where N is an integer.

When a binary counter is used to divide frequencies it is called a frequency divider. Divide ratios can be other than 2N but the circuitry becomes more complex. Noninteger divide ratios are even possible but the circuitry becomes very complex.

Example 8.5.

The input frequency to a 9 stage (9 flip-flops) binary counter is 225,280 hertz. What is the output frequency?

Solution:

fO = fIN / 2N = 225,280 / 29 = 440 hz.

The Decade Counter.

When binary numbers were introduced it was said that it was difficult to make electronic circuits which could count in decimal. In the age of the IC it is easier than it was in the vacuum tube age. Computer hardware designers still prefer to use binary but in stand alone digital instruments such as digital clocks, frequency counters and digital voltmeters the decade counter is king.

The circuit employs a number system known as binary coded decimal (BCD for short). Figure 8.22 shows how to count from 0 to 12 in BCD. Each decimal digit is represented by 4 binary digits (bits). Four bits of binary can normally express numbers as large as 15 (1111) but in BCD the highest allowed count is 9 (1001). Binary counts higher than 1001 are not allowed. Notice that in Figure 8.22 when the units count reaches 9 it resets to 0 and a 1 is placed in the tens column.

This system of counting requires more bits than a comparable binary counter. For example a 3 digit BCD counter can count to 999 and requires 3 digits x 4 bits per digit = 12 bits. A binary counter which can count to 1023 requires only 10 bits. The extra bits are well worth the tiny increase in cost. The circuitry to readout a 10 bit binary counter in decimal is far more complex and expensive than the couple of extra bits required for making BCD counters.

Decimal | Tens | Units
00 | 0 0 0 0 | 0 0 0 0
01 | 0 0 0 0 | 0 0 0 1
02 | 0 0 0 0 | 0 0 1 0
03 | 0 0 0 0 | 0 0 1 1
04 | 0 0 0 0 | 0 1 0 0
05 | 0 0 0 0 | 0 1 0 1
06 | 0 0 0 0 | 0 1 1 0
07 | 0 0 0 0 | 0 1 1 1
08 | 0 0 0 0 | 1 0 0 0
09 | 0 0 0 0 | 1 0 0 1
10 | 0 0 0 1 | 0 0 0 0
11 | 0 0 0 1 | 0 0 0 1
12 | 0 0 0 1 | 0 0 1 0

Figure 8.22 BCD Counting from 0 to 12.

In order to implement BCD in hardware it is necessary to wire together 4 flip-flops in such a way as to count from 0 to 9, which is the same thing as dividing the input frequency by ten. Ten can be factored as 2 x 5. A single flip-flop can handle the divide by 2. Three flip-flops and some gates are used to accomplish the division by 5.

A practical decade counter is made up of 4 flip-flops, as shown in Figure 8.23. This circuit consists of a count- to-one (divide by 2) and a count-to-four (divide by 5) circuit. The count-to-one section consists of flip-flop A. The count-to-four circuit consists of flip-flops B, C, D and two gates.

Whenever a TTL (transistor transistor logic) input is left open, it assumes the high logic state. (This is not recommended in circuits constructed in the laboratory.) The J and K inputs on flip-flop A are open; consequently, they both have high logic states or 1s applied. If a J-K flip-flop has 1s on both J and K inputs, the flip-flop will change states every time the clock input goes from a logic 1 to a logic 0. If there is one cycle at the output for every two cycles at the input, you have a divide by 2 counter.

The divide by 5 is not so simple. If 3 flip-flops are connected with the Q output of one going to the Ck input of the next, the counter will be a count to 7 or divide by 8. To make this counter divide by 5 instead of 8 requires some trickery.

Figure 8.23 Decade Counter and Its Truth Table.

For a verbal description click here.

The truth table which accompanies Figure 8.23 has all of the numbers written backward. This should aid in understanding the circuit. The column of binary digits for a given flip-flop is under that flip-flop.

Starting out with all flip-flops set to zero, the NAND gate will have a 0 and a 1 on its inputs. Its output will be a 1. This 1 when applied to the J input of F-F B will allow it to change states on every clock pulse. When the count in F-Fs B, C and D reaches 0 0 1 (binary 100) both inputs of the NAND gate will be 1s and the output will be 0. The 0 on the J input of F-F B will prevent it from changing states on the next clock pulse. Because there is no change in the state of F-F B, there will not be any trigger pulse delivered to F-F C and it will remain in the 0 state.

The AND gate gets its inputs from F-Fs B and C. The output of the AND gate will be 0 as long as B or C is 0. The 0 applied to the J input of F-F D will inhibit it from changing states and it will remain in the 0 state. When B and C are both 1s, there will be a 1 on the J input of F-F D and it will change states on the next clock pulse.

Note that the clock pulses are connected to F-Fs B and D. The clock pulse which caused D to change from 0 to 1 will cause B to change from 1 to 0. This change on the Q output of F-F B will cause F-F C to also change from 1 to 0. F-F B is now inhibited from changing states. As we have already seen, F-F D had a 1 on its J input before the clock transition and so the next transition will cause F-F D to change from 1 to 0. We now have all flip-flops back in the 0 state and we are ready for another counting cycle.

This circuit is almost never implemented with separate J-K flip-flops and logic gates. A decade counter integrated circuit is normally used. Different manufacturers implement the counter in different ways and many of them will not even tell us how they do it. It may be done this way or some other way; we don't know.

Variable Modulus Counters.

The modulus of a counter is that number by which it will divide an input frequency. For a counter of modulus N, for every N pulses sent to the counter it will deliver one pulse. The modulus of a 4-bit binary counter is 16, that of a decade counter is 10 and that of the B, C and D flip-flops of a decade counter is 5.

As illustrated by the decade counter it is possible to develop systems of flip-flops and gates to give any desired modulus. Such systems are hard-wired and cannot be changed by the equipment operator. There are counters whose moduli can be changed by the operator.

A very common variable modulus counter uses the up-down decade counter. Each IC has a count-up and a count-down input. There are also carry and borrow outputs. The carry output is wired to the count-up input and the borrow output is wired to the count-down input of the next most significant digit counter. These counters also have a set of direct load inputs which permit data to be loaded into the counter. A "load enable" input on the IC causes data which is presented at the data inputs to be loaded into the flip-flops of the counter.

When the input signal is applied to the count-down input of the least significant digit the borrow output of the most significant digit will go low only when all digits in the counter are zero. The rest of the time this output is high. If this output is connected to the load enable inputs of all of the other digits in the counter the data will be loaded whenever the counter arrives at zero. The data are loaded when the load enable input is low.

The sequence of events is this: the counter counts down to zero, the data are loaded, and the counter counts down to zero again. The modulus of the counter is equal to the number contained in the data which is loaded. If the data are changed, the modulus of the counter is changed.

One way an operator can interact with such a counter is by means of thumb-wheel switches. Each switch has ten positions. When the switch is set to a given position a digit (0 through 9) will show in a window to indicate to the operator the position selected. The switch has four contacts which generate the BCD code corresponding to the digit selected. These switches are designed so they may be placed side by side to allow an operator to set a decimal number on the switches. The outputs of the switches are the BCD code of the number selected. If the switches are connected to the data inputs of the up-down counters, the switches may be used to select the modulus of the counter. The usefulness of such a variable modulus counter will be shown in the next chapter.

It is possible to achieve a noninteger modulus by using combinational logic to set the modulus, as was done for the divide-by-five circuit. Such a circuit may be arranged so that a logic level on one of the gates will change the modulus of the counter. The level on this modulus control input may be rapidly switched to obtain an average modulus which is between integer values. Such a counter must be followed by several divide-by-two flip-flops in order to average out the frequency variations and give a true single frequency output. Circuits of this kind are used in an IC called a "top octave generator". This IC uses a quartz crystal (externally connected) and divides it down to deliver simultaneously all twelve of the musical notes in the top octave of the standard piano keyboard. In each lower octave the frequencies of the notes are half of those in the next higher octave. Simple binary dividers may be used to generate the rest of the notes on the keyboard.

By the way, if you want to amaze a guitar-playing friend by telling him or her the frequencies of the musical notes, it is easy using a calculator. The frequency of the note A above middle-C is 440.000 hz. The notes comprise a geometric series with the twelfth root of two being the factor. Use the YX key on your calculator to raise 2 to the 1/12 power and store the result in memory. Key in 440. To move down the musical scale, recall and divide. To move up the scale, recall and multiply. If you work your way down the scale to middle-C you will find its frequency to be 261.6256 hertz. You may well have read in an elementary physics book that middle-C has a frequency of 256 hertz. The best information available to the writer indicates that musicians changed the standard of tuning sometime early in the 20th century. They forgot to tell the physicists. Meanwhile, any physicists writing a book would look up the frequency for middle-C in the book he had used as a student which was written by someone who looked it up in a book he had used as a student and so on. This is how misinformation can be passed down from one generation to the next.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

8.6 Displaying the Count.

In any digital instrument it is necessary for the contents of the counter to be displayed in some way for an operator to read. Figure 8.24 shows the block diagram of a single digit of the readout system for a decade counter.

Figure 8.24 Decade Counter, Latch, Decoder and Display.

For a verbal description click here.

The numbers in the blocks are type numbers of specific ICs. The 7490 is the decade counter. Such a counter is in the middle of a chain of similar decade counters. The 7475 is a 4-bit memory consisting of 4 type D flip-flops. The purpose of the "strobe" input is to cause the data in the decade counter to be loaded into the memory. The purpose of the memory is to remember the count while a new count is being accumulated. The sequence of events is this. The count begins and the decade counters count up from zero. When the count has finished, the "strobe" inputs of all of the memories is pulsed which stores the data in the memory. The counters may then be reset (to zero) and a new count begins while the memory holds the previous count.

The contents of the memory are fed to the 7447 which is a decoder-driver. This IC uses combinational logic to convert the BCD code from the memory to the proper pattern to display numerals on the 7-segment display. The outputs of the decoder-driver are BJTs which are "on" to light a display and "off" to keep it dark. These BJTs are capable of switching enough current to drive almost any display which may be used.

The display itself consists of 7 light emitting diodes (LEDs). These LEDs have an I-V curve similar to any other diode. The full 5 volt power supply cannot be applied across the LEDs in the display. There must be a current limiting resistor in series with each LED in the display. A typical value is 220 ohms. Some other types of decoder-drivers have these resistors built in to the IC.

There must be one of these circuits for each digit to be displayed. An 8-digit display would have eight 7490s, eight 7475s, eight 7447s, fifty-six resistors and eight displays.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

8.7 Multiplexed Displays.

The term LSI means large scale integration. It is LSI which has made the pocket calculator possible. One problem with LSI is the number of pins necessary to connect to the display. A ten-digit calculator needs eighty pins to control the numeric display and the decimal points. That is far too many for a reasonable size for the IC and the calculator it is used in.

A way to save pins is to multiplex the display. Instead of connecting the anodes of the LEDs in the display to the +5 volt line, they are connected to the collectors of PNP switching transistors. A ten-digit calculator needs ten control lines, one for each digit. All of the segment cathodes are connected in parallel. For example the top segments in all ten of the digits are connected together. All ten of the decimal point cathodes are connected together. That means that there are 8 lines, one for each segment and 1 line for the decimal points. That makes 10 digit control lines plus 8 segment control lines for a total of 18 lines to control 10 digits, instead of 80 as would be the case for individual segment connections. Also only 8 resistors are needed for current limiting.

The way in which this works is as follows. The PNP transistors in the digit anodes can turn an entire digit on or off. The first digit is turned on (all others are off) and the pattern of bits is applied to the segment lines to display the number in the first digit. The first digit is turned off and the second digit is turned on. The data on the segment lines is changed to that of the number in the second digit. The process repeats until all of the digits have been illuminated and then the process begins again. Even though only one digit is on at a time, the eye perceives a continuous display of all digits. The scanning of the displays may occasionally be observed when a calculator is shown on television. The field rate of the TV scanning may "strobe" with the scanning rate of the calculator's display.

Figure 8.25 Multiplexed 4 Digit Display.

For a verbal description click here.

The display will appear to flicker and if the frequency of the display scanning is just right it may even be seen to scan in order. If you ever gain access to a stroboscope, (not to be confused with a strobe light), you may want to put your calculator under it and see if you can find the scanning frequency.

The keyboard of a calculator s another problem. Many calculators have 40 to 50 keys. If there had to be one pin on the IC for each key, calculators would be a lot larger and more expensive than they are.

The keyboard is divided into rows and columns (not necessarily related to their physical placement on the calculator). The keyboard is scanned. For example a calculator having 64 keys does not need 64 pins to connect the keys. The keyboard is electrically arranged into an 8 by 8 matrix and connected as shown in Figure 8.26. Each switch is a key on the calculator. The calculator IC may send pulses out on the column lines one at a time and monitor the row lines for returned pulses. When a switch is closed only one of the 8 column pulses will be received and it will be received on only one row line. That gives an unambiguous way for the chip to know which one of the switches was closed. The calculator IC needs only 16 pins for the keyboard instead of 64.

Figure 8.26 Multiplexed Calculator Keyboard.

For a verbal description click here.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

8.8 Digital to Analog Converter.

A number held in a digital counter or memory is just a number. Like any number it represents only what we humans imagine. In and of itself it represents nothing. However, a circuit may be constructed which will convert a digital number to a proportional voltage. Such a circuit is called a digital to analog converter (DAC).

A digital to analog converter (DAC) which is easy to understand is shown in Figure 8.27. Suppose that the output of the digital buffers is 5 volts if the input is a logic 1 and zero volts if the input is a logic zero. If the most significant bit (MSB) is 1 the 10 k ohm resistor will supply a current of 0.5 mA to the summing node of the op amp. The next bit will cause a current of 0.25 mA to be delivered to the summing junction, the next a current of 0.125 and so on. If the least significant bit (LSB) is a 1 the current from it is 7.8125 uA. An infinite number of bits would bring the total current (all bits on) up to 1 mA. The condition of all bits on (1) is the full-scale condition. The 5 k ohm feedback resistor will cause the op amp to have a full-scale output voltage of -5 volts. When converting binary to decimal each bit has twice the value as the bit to its right. In the case of the digital to analog converter each bit supplies twice the current as the next least significant bit. The op amp causes all of these currents to be summed and converted into a negative voltage. If a positive output is desired another op amp may be connected as a unity-gain inverter.

Figure 8.27 Simple Digital to Analog Converter.

For a verbal description click here.

Although this circuit is easy to understand it doesn't work very well. The problem is the resistors. If the resistors are not exactly right on value the converter will not yield uniform steps as the binary number is incremented. Take the case of stepping from 63 to 64. The number 63 has the 6 least significant bits on. When this number changes to 64, 6 bits turn off and a single bit takes its place. The 10 k ohm resistor must supply a current which is exactly 7.8125 uA larger than the current supplied by the combination of the 6 other resistors. (The smallest possible step in the output of a DAC is the value of the least significant bit.) Errors in resistors are random and, if the particular resistors have errors such that the 20 k ohm is a little low and the 10 k ohm is a little high, incrementing the binary code from 63 to 64 could actually result in a reduction of the output voltage instead of an increase. As the number of bits increases the smallest steps become smaller and the requirements on resistor tolerance become impossibly tight.

Another problem is the wider range of resistor values required by this type of converter. The values in this example circuit range from 10 k ohm to 640 k ohm and this is only a 7-bit converter. A 16-bit converter which has a lowest value resistor of 1 k ohm would have to have a highest value resistor of 32.768 M ohms. Maintaining the necessary tolerances over such a wide range of resistance is impossible.

Figure 8.28 Ladder Network Digital to Analog Converter.

For a verbal description click here.

Figure 8.28 shows a digital to analog converter which will work. The figure shows only 4 bits but the circuit may be extended to as many bits as desired. If the MSB is the only bit to be on, the output voltage will be half of the power supply voltage. That is as it should be because the MSB always represents half of the (largest - 1) number that a given binary number can represent. The MSB is 1/2 scale. The next bit is 1/4 scale, the next 1/8 scale and so on.

Although it is not exactly cheap, it is possible to make a large number of resistors all of the same value. The ladder network is supplied in a package which looks like an IC. The resistors were all made at the same time on a common substrate. The resistors indicated as 2R are just two of the resistors connected in series during the manufacturing process. The actual value R may vary by as much as 10% from unit to unit but within a single unit the resistors are all identical to within a small fraction of a percent. A very high precision DAC may be constructed using a ladder network.

The diagrams show noninverting buffers as the drivers for the DAC. Ordinary TTL cannot be used at all and even CMOS is not good enough for high accuracy DACs. The problem is the voltage that the output of the buffer goes up to when its output is a logic 1. TTL is only guaranteed to go up to 2.4 volts. CMOS does quite a bit better but when its output is loaded by a resistor network the output of a buffer may not make it all of the way to ground for a logic zero or all the way to VCC for a logic 1. Designers of DACs go to great length to design switching circuits which will be at zero volts for a binary zero and at VCC for a logic 1. In addition the VCC supply must be very precisely regulated.

As a physicist you will never have to worry about any of the above. DACs are available in IC form ranging in bit count from 8 to 20 and in price from $3.95 to several hundred dollars. The data sheet for the particular DAC IC to be used must be consulted in order to use it properly.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

8.9 Analog to Digital Converter.

The process of converting a voltage to a digital number is called analog to digital conversion. The voltage may be converted to a BCD (binary coded decimal) number as is done in a digital multimeter or to a binary number if the data are to be fed to a computer for processing.

Analog to digital converters (ADCs) like DACs come in IC packages. They are available in two basic forms, slow and less expensive and fast and more expensive. The slow kind are dual slope integrators and the fast are successive approximation type. Both types can be quite accurate.

Dual-slope Integrator ADCs.

The dual-slope converter is most often used in digital multimeters. Its output is usually in BCD form for easy decimal readout. The typical speed for this converter is about 4 samples per second. That is plenty fast enough for a slow human to take in.

In the circuit of Figure 8.29 the input voltage must be negative. In a complete voltmeter there are circuits which allow the input voltage to be positive or negative. A flip- flop indicates the polarity of the input voltage. To show this extra circuitry would add to the circuit complexity while adding nothing to the reader's understanding.

Figure 8.29 Dual-slope Integrator ADC.

For a verbal description click here.

In the circuit of Figure 8.29 the switches S1, S2 and S3 are not mechanical but electronic switches which are controlled by the block labeled "control logic". The sampling cycle starts by closing switch S1 to discharge the capacitor. S1 is opened and S2 is closed which signals the beginning of time period T1. The output voltage of the integrator begins to go positive because the input voltage is negative. The slope of the line is determined by the magnitude of the input voltage as indicated by the waveform drawings in the figure. At the end of T1 the output voltage of the integrator is proportional to the magnitude of the input voltage. At the end of T1 S2 opens and S3 closes, signaling the start of T2. The reference voltage is the negative of the full-scale voltage of the converter. When T2 begins, the control logic opens the AND gate by placing a logic 1 on the lower input. The upper input of the gate already has a 1 on it from the output of the comparator.

The symbol for a comparator looks like an op amp and there are similarities. A comparator is a device which can have an analog input and a digital output. It may be thought of as a one-bit analog to digital converter. If the noninverting input is more positive than the inverting input the output will be a logic 1. If the inverting input is more positive than the noninverting input the output will be a logic zero.

In the circuit of Figure 8.29 the inverting input of the comparator is grounded and the positive output of the integrator is applied to the noninverting input. The output of the comparator is a logic 1. Clock pulses from the clock are now passed to the counter. The counter counts clock pulses for the duration of T2. The time period T2 ends when the output of the integrator reaches zero. As the two different waves in the figure indicate, the higher the magnitude of the input voltage the longer T2 is and the larger the number of clock pulses counted. When the output of the integrator reaches zero the AND gate is closed because the output of the comparator has switched to a logic zero. The control logic is also notified and it initiates a number of steps. S3 is opened, the contents of the counter are loaded into the display memory and the counter is reset to zero. Now S1 is closed and the entire cycle starts over again.

You may be thinking that a much simpler way would be to let the reference voltage be integrated until it equals the input voltage and let the counter count clock pulses during this time. If you did think of this method, go to the head of the class. It shows that you are thinking. The calibration of such a single-slope integrator is very dependent on the value of the capacitor. Capacitors have a rather bad habit of changing capacitance as temperature changes. In a dual-slope integrator the capacitor is used twice and errors in the value of the capacitor are partially canceled out. This partial error cancellation is the primary reason for using a dual-slope integrator instead of a single slope integrator.

Successive Approximation ADC.

Successive approximation converters are very fast, ranging in speed from several hundred samples per second to several million samples per second. In bit count they range from 8 to 20 and in price from $3.95 to several hundred dollars. Because of their great speed they are most often used in association with microprocessors. They usually have binary output.

The diagram of a successive approximation ADC is shown in Figure 8.30. You will notice that contained within the analog to digital converter (ADC) is a digital to analog converter (DAC). The comparator compares the output of the DAC with the input signal and sends its output signal to the control logic. The wide lines on the diagram labeled "data bus" and "control bus" are a shorthand way of drawing many individual connecting lines. In the case of a 16 bit converter, there would be 16 lines connecting the control logic block to the binary register and 16 lines connecting the binary register to the DAC. It is pointless to draw 16 lines when everyone knows that they are all going to the same place.

Figure 8.30 Successive Approximation ADC.

For a verbal description click here.

One very simple way in which this circuit could be used is to start the binary register (used as a counter) at zero, count up until the comparator changes states and then stop. That method works fine provided you are not in a hurry. If the input signal is near full-scale, as many as 65 thousand clock pulses would be required to complete a conversion in a 16 bit converter. The conversion time is dependent on the magnitude of the input signal. An input signal which is near zero takes fewer clock pulses and, therefore, less time than an input signal which is near full-scale.

The successive approximation system works much faster. The difference between a binary counter and a binary register is that a binary register can be loaded with data in many ways. In the binary register used here each bit can be changed individually. The binary register starts with all bits set to zero. The control logic sets the most significant bit (MSB). If the comparator changes states because the output of the DAC is larger than the input signal, the bit is reset. Otherwise it is left set. The next least significant bit is tried in the same way: if turning it on makes the output of the DAC greater than the input the bit is turned off, if the DAC's output is less than the input, the bit is left on. If it is necessary to turn a bit off the same clock pulse which turns that bit off can turn on the next bit. In the case of a 16 bit converter only 16 clock pulses are required to complete a conversion.

A microprocessor could easily be programmed to perform the function of the control logic. A microcomputer which is equipped with a DAC for the purpose of playing music needs only the addition of a comparator feeding into a game paddle port and it can be used as an ADC.

Single IC converters use combinational logic to accomplish the job of the control logic. Such converters can be made very fast indeed.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

8.10 The 555 Timer.

The 555 timer resides in a kind of twilight zone between analog and digital. It incorporates elements of both but it is more digital than analog so it is included here.

A 555 timer is basically a monostable Multivibrator or one shot. In this device it is stable in one state where it remains until triggered. Upon being triggered it changes to the other state where it remains for a length of time determined by an RC time constant and then returns to the stable state. Both the TTL and CMOS logic families have one shots in the line. Some are retriggerable which means that if another trigger pulse arrives before the RC has timed out the time period will start over. Others are not retriggerable which means that trigger pulses are ignored while the RC is timing out. Some can be wired for either kind of behavior.

A 555 is not retriggerable and requires the addition of an external transistor to make it into one. The internal block diagram is shown in figure 8.31. Figure 8.32 shows a 555 timer wired as a one shot.

Figure 8.31 Internal Block Diagram of the 555 Timer.

For a verbal description click here.

Figure 8.32 One-shot, Pulse Stretcher.

For a verbal description click here.

In the stable state the trigger input is held high by the resistor. The output is low and the not Q input is high. This holds the transistor on which keeps the capacitor discharged. The trigger input goes to the inverting input of the comparator so the S input of the flip flop is low. The discharge and threshold pins are tied together so the noninverting input of the other comparator is low making the R input of the flip flop low. With R and S both low the flip flop will not change states.

The trigger pulse would be negative and short. A negative pulse on the inverting input of the comparator drives the output positive setting the flip flop. The not Q goes low and the output goes high. The discharge transistor is turned off and the capacitor begins to charge through the resistor. Note the network of equal value resistors in the center. The comparator on the right has its noninverting input held at 1/3 of VCC. The one on the left has its inverting input held at 2/3 of VCC. As long as the voltage across the capacitor is less than 2/3 VCC The R input of the flip flop remains low. When the voltage reaches 2/3 VCC the R input goes high and the flip flop is reset. The output returns to low, the discharge transistor is turned on, discharging the capacitor and the timer is back in its stable state.

After the timer has been triggered and before the RC circuit has timed out additional trigger pulses will have no effect. Such pulses would set the flip flop but it is already set.

There are many possible uses of this circuit but one could be as a pulse stretcher to turn on an indicator light. Suppose part of an experiment delivers pulses that are so short that even if they were used to turn on an L E D the flash would be too short to perceive. A requirement is that the operator must know when such pulses occur. The narrow pulses could be applied to the input of a circuit like that of figure 8.32 with its R and C values selected for a timeout of say 1 second. The timer could be used to light a lamp and sound a buzzer to be sure to get the attention of the operator.

The time that the output remains high is given by,

T = 1.1 R C  (8.6)

Oscillator Circuit.

In the circuit of figure 8.33 The capacitor is connected back around to the trigger input so the timer will trigger itself. There is a resistor connected between the capacitor and the discharge terminal so the capacitor will take some time to discharge.

When the output goes low and the discharge transistor is turned on the capacitor discharges through R2. When the capacitor voltage reaches 1/3 VCC the flip flop is set and the discharge transistor is turned off. The capacitor then charges through the series combination of R1 and R2. When the voltage reaches 2/3 VCC the flip flop is reset and the cycle starts over.

It is impossible to get square waves out of this circuit because the capacitor is charged through 2 resistors in series and discharged through one. The Frequency is given by,

f = 1.46 / [(R1 + 2R2)C]  (8.7)

Figure 8.33 Oscillator with Pulse Train Output.

For a verbal description click here.

Figure 8.34 Oscillator with Square Wave Output.

For a verbal description click here.

The circuit of figure 8.34 will solve this problem. When the capacitor is charging the diode effectively shorts out R2, causing the capacitor to charge through R12 alone. If the circuit is operated from 5 volts it will most likely be necessary to make R1 one 5% step less than R2 to account for the effect of the forward voltage drop across the diode. If the resistors are the same value the frequency is given by,

f = 0.730 / RC  (8.7)

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

8.11 Problems.

  1. Convert 1110111 to decimal.

  2. What is the sum of 101011 and 1101?

  3. What are the names of the gates whose truth tables are given here?

    (a)
    A | B | C | OUTPUT
    0 | 0 | 0 | 1
    0 | 0 | 1 | 1
    0 | 1 | 0 | 1
    0 | 1 | 1 | 1
    1 | 0 | 0 | 1
    1 | 0 | 1 | 1
    1 | 1 | 0 | 1
    1 | 1 | 1 | 0

    (b)
    A | B | C | OUTPUT
    0 | 0 | 0 | 1
    0 | 0 | 1 | 0
    0 | 1 | 0 | 0
    0 | 1 | 1 | 0
    1 | 0 | 0 | 0
    1 | 0 | 1 | 0
    1 | 1 | 0 | 0
    1 | 1 | 1 | 0

  4. Write the truth table for the circuit of Figure 8.35. Suggestion: Make columns in your truth table for the outputs of gates 1, 2 and 3. These tree columns will then be the inputs for gate 4.

    Figure 8.35 Combinational Logic Circuit For Problems 4 and 5.

    For a verbal description click here.

  5. Write the Boolean algebra expression for the circuit of Figure 8.35. Do not attempt to simplify it.

  6. Convert Expression 8.1 into NAND gates.

  7. Reduce the expression below to all NAND functions.

    small a = A and not B and not C and not D or, not A and not B and C and not D.

  8. Add direct Set and Clear inputs to the master-slave R-S flip-flop of Figure 8.18. Tell what the states of these inputs must be for normal operation and what state will cause a set or clear. You may add inputs to any of the gates if necessary.

  9. What is the largest number that a 13-bit binary counter can contain? Express your answer in decimal without using exponents.

  10. If the input frequency to a 12-bit binary counter is 3,579,545 hz, what is the output frequency?

  11. A frequency divider consists of a divide by 5 module followed by a divide by 7 module which is followed by a divide by 13 module. What is the division ratio of the entire system?

  12. In an 8-digit frequency counter the decimal points are to be turned on and off by circuitry within the counter chip. If the display is multiplexed, how many pins are required to connect the display to the counter IC?

  13. When a 555 timer is used as a monostable what should be the value of C to give a 1 second pulse if the resistor is 150 k ohms?

  14. When a 555 timer is used as an oscillator without a diode what should be the value Of the capacitor to give a frequency of 1 hertz if R1 = R2 = 220 k ohms?

  15. When a 555 timer is used as an oscillator with a diode what should be the value Of the capacitor to give a frequency of 1 hertz if R1 = R2 = 330 k ohms?

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

8.12 Answers to Problems.

  1. 119

  2. 111000

  3. (a) NAND, (b) NOR.

  4. Truth table.

    A | B | C | OUTPUT
    0 | 0 | 0 | 0
    0 | 0 | 1 | 1
    0 | 1 | 0 | 0
    0 | 1 | 1 | 0
    1 | 0 | 0 | 1
    1 | 0 | 1 | 0
    1 | 1 | 0 | 0
    1 | 1 | 1 | 1

  5. The unsimplified expression is,

    For a verbal description click here.

  6. The NAND gate expression is,

    For a verbal description click here.

  7. The answer is...

    For a verbal description click here.

  8. For normal operation both SET and CLR must be high. Pulling the SET input low will set the flip flop and pulling the CLR input low will clear it.

    For a verbal description click here.

  9. 8191.

  10. 873.912 Hz.

  11. 455

  12. 16.

  13. 6.06 micro farads.

  14. 2.21 micro farads.

  15. 2.21 micro farads.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

This page copyright © Max Robinson. All rights reserved.


Chapter 9   Digital Instruments.

9.1  Frequency Counter.
9.2  Digital Multimeter.
9.3  Frequency Synthesizer.
9.4  Problems.
9.5  Answers to Problems.

Chapter 9

Digital Instruments.

If you were asked to name something in which digital circuits are used you would likely answer "a digital computer". Combinational logic is certainly used in a digital computer. The subject of computers is one which can occupy a course of its own. There is not time or space here to study computers. There are certain laboratory instruments which employ digital circuitry but which are not computers. These instruments do not require connection to a computer for operation and so are called "stand alone" digital instruments. Three examples which we will look at in this chapter are the frequency counter, the digital multimeter and the frequency synthesizer.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

9.1 Frequency Counter.

Figure 9.1 is the block diagram of a basic frequency counter. This circuit is not intended as a construction project. If you were inclined to build a frequency counter, you would need more details. This circuit contains all of the essential parts for understanding the operation of a frequency counter.

Figure 9.1 Basic Block Diagram of a Frequency Counter.

For a verbal description click here.

The input feeds to a buffer which is a circuit with a high input impedance and a low output impedance. This is an analog amplifier circuit which must have a bandwidth equal to that of the counter circuits. The buffer may or may not have a voltage gain greater than unity.

After the input signal is buffered and possibly amplified, it is necessary to form it into a succession of logic highs and lows to be counted by the BCD counters. What must be done is to form the input signal into a square wave which has a low level of 0 volts and a high level of 5 volts. A comparator might be used for this purpose but there is a problem. Noise is always present. A comparator will amplify the noise and instead of a clean square wave its output would be a wave which looks to be a square wave but a closer look reveals that instead of one transition, the voltage makes several jumps from 0 to 5 volts and back again, before settling down on one or the other. Logic circuits respond so fast that they would count these extra transitions as if they were cycles of the input signal. The result would be that the counter would read several times the actual frequency.

The device which is required is called a Schmitt trigger. To explain what a Schmitt trigger does let us look at a specific example, namely the TTL Schmitt trigger. The specifications for such a circuit give its "positive-going trigger voltage VT+" as 1.7 volts and its "negative-going trigger voltage VT-" of 0.9 volts. Suppose the input voltage starts out at zero. Because the circuit is an inverter, the output will be a logic high. As the input voltage is slowly increased, nothing happens until the input voltage reaches 1.7 volts. At this input voltage, the output suddenly switches (in about 20 ns) to a logic low. Further increases in the input voltage have no additional effect. As the voltage is slowly decreased the 1.7 volt point is crossed without anything happening. Nothing happens until the input voltage gets down to 0.9 volts at which point the output switches to a logic 1. As long as the peak-to-peak amplitude of the noise is less than 0.8 volts the output of the Schmitt trigger will switch only once for each slope of the input wave. The resulting output is a clean square wave.

There are also Schmitt triggers in the CMOS logic family. For these VT+ = 2/3 VCC and VT- = 1/3 VCC. The difference between VT+ and VT- is called the hysteresis of the Schmitt trigger. If the input voltage is between VT+ and VT- the state of the output depends on whether the voltage came down from above or up from below. In other words the state depends on the history of the circuit. Hence the name hysteresis.

CMOS has a larger hysteresis than TTL and, therefore, greater immunity to noise. However, CMOS is not as fast as TTL, which means that it will not count as high a frequency as will TTL.

The next item in the diagram is a NAND gate. Now a NAND gate is just a NAND gate but the other signal to the gate requires some explanation. First of all remember that A NAND 0 = 1 and A NAND 1 = A. Inverting the signal will not change its frequency. When the signal from the flip-flop is 1 the input signal is passed to the counter circuits and when the signal from the flip-flop is 0 the gate is closed and the input signal is not passed to the counter circuits.

The 1 MHz quartz crystal oscillator gives a very precise frequency. This frequency is divided by 1,000,000 to give a very precise 1 hertz frequency. The flip-flop has its J and K inputs high and so will change states on every negative-going edge of the clock input. Thus the Q output will be high for 1 second and low for 1 second. The counter circuits count the total number of cycles and the gate is open for precisely 1 second; so the counter is indicating the number of cycles per second, which is the frequency in hertz.

The not Q output of the flip-flop is fed to the counter circuits and signals when to load the count into the display memory and reset the counter to zero. The not Q signal is not used directly for strobe and reset. It is used to trigger delay circuits, one shots, which perform the strobe and reset in the proper time sequence.

The time that the gate is open does not have to be 1 second. It could be 0.1 second or 0.01 second or anything else. Most counters have a switch to allow the user to select the desired gate time. The proper decimal point lights up in the display along with an additional indicator to tell the user whether the number should be interpreted as hertz, kilohertz or megahertz.

The reasons for having different gate times are resolution and sample rate. If a 1 second gate time is used the reading will be to the nearest hertz which is the resolution of the reading. In some measurements the user may not desire to know the frequency to such precision. The frequency source may be so unstable that the units of hertz are a random number generator. In such cases it is usual to use a shorter gate time to get rid of the insignificant digits of the reading. A shorter gate time gives faster readings. A gate time of 10 seconds gives 0.1 hertz resolution but gives a reading every 20 seconds. A 1 second gate gives a reading every 2 seconds and a gate time of 0.1 second gives 5 readings per second. The gate time chosen depends on how much precision is desired and how impatient the user is.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

9.2 Digital Multimeter.

The digital multimeter (DMM) uses a combination of digital and analog circuits to measure voltage, current and resistance with great accuracy. All of the individual circuits have been discussed earlier in this text.

The basic measurement circuit of a digital multimeter is the dual slope integrator, which is a voltage measuring device. In most DMMs (digital multimeters) the basic voltmeter circuit has a full-scale range of 0.2 volts (200 millivolts). Voltage dividers are used to give additional ranges of 2, 20, 200 and 2,000 volts full-scale.

For measuring current a series of shunt resistors is connected across the basic voltmeter. The usual ranges are 200 uA, 2 mA, 20 mA, 200 mA and 2 A. Some DMMs have a 20 amp range as well.

AC voltage and current may be measured using most DMMs. An absolute value amplifier is used to convert the basic DC voltmeter to a basic AC voltmeter. An RC network is used as an averaging circuit and so the voltmeter is an average responding voltmeter. The gain of the amplifier is adjusted so the meter will indicate RMS if the input is a sine wave.

More recent DMMs employ a true RMS circuit to convert the AC to DC. When using such meters the reading will always be true RMS regardless of the wave form.

In order to measure resistance the basic DC voltmeter is used to measure the voltage across the unknown resistor while a constant current source supplies current to the unknown. The usual ohmmeter ranges are 200 ohms, 2 k ohms, 20 k ohms, 200 k ohms, 2 M ohms and 20 M ohms. For each of these ranges the value of the current source will be 1 mA, 100 uA, 10 uA, 1 uA, 100 nA and 10 nA, respectively.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

9.3 Frequency Synthesizer.

Some types of laboratory measurements require a very stable and accurate frequency. Quartz crystal oscillators provide very stable and accurate frequencies but the frequency is determined when the crystal is manufactured and, if it is desired to change the frequency, a new crystal must be ordered.

There are various oscillator circuits whose frequencies can be varied by means of variable resistors, capacitors, or inductors, but variable frequency oscillators (VFOs) are not as stable over time as quartz crystals. If accurate frequency settings are desired, a frequency counter must be used in conjunction with the VFO.

The use of a frequency counter solves only half of the problem. VFOs drift in frequency. Drift is caused by changes in temperature and humidity, component aging, minute changes in the power supply voltage (no regulator is ever perfect) and other factors which seem to defy scientific explanation. Put a VFO in an environmental chamber, let it warm up for weeks or even months, operate it from an ultra precision power supply and it will never stop drifting.

Until the age of modern electronics the choice had to be either a fixed frequency and stable crystal oscillator or an adjustable frequency and drifting VFO. A circuit known as the frequency synthesizer is capable of combining the frequency agility of a VFO with the stability of a quartz crystal.

First of all a frequency synthesizer is not a musical instrument. A music synthesizer is comprised of an entirely different set of circuits. A frequency synthesizer can produce the musical scale but it can also produce any frequency in between the notes. The basic block diagram of a frequency synthesizer is shown in Figure 9.2.

Figure 9.2 Basic Block Diagram of a Frequency Synthesizer.

For a verbal description click here.

The circuit as drawn may also go by the name phase- locked loop. The V.C.O. is a voltage controlled oscillator. If the input voltage goes positive, the frequency of the V.C.O. will go up; if the input voltage goes negative the frequency will decrease. The phase detector has changed in recent years. It is now a digital circuit which can detect large frequency differences as well as small phase differences. If the frequency of input 2 is higher than the frequency of input 1, the output voltage of the detector goes negative. If the frequency of input 2 is lower than the frequency of input 1, the output voltage goes positive.

If the frequency of the V.C.O. is lower than it should be, the frequency of input 2 to the phase detector will be lower than the frequency of input 1 (the crystal oscillator) and the output voltage of the phase detector will go positive. This positive-going voltage will be applied to the V.C.O., which will cause its frequency to increase. The circuit will soon find an equilibrium point at which the frequency at input 2 ( fVCO / N ) is equal to the frequency of the crystal oscillator. After the frequency is correct, the circuit goes to work on the phase angle. If the phase at input 2 is leading the phase at input 1, the output of the phase detector will go slightly negative and the phase error will be corrected to zero.

The unfiltered output of the phase detector is a series of positive or negative-going pulses whose width is proportional to the phase difference between the two input signals. If the phase angle could come to exactly zero the output of the phase detector would be an open circuit all of the time. (The output has a low impedance during the pulses but is an open circuit between pulses.) Nothing in this world is ever exact or perfect. There will always be some AC output from the phase detector. The RC network which is connected between the phase detector and the V.C.O. serves the purpose of filtering out most of the AC component of the output of the phase detector.

The filter requires two resistors in order to make the loop stable. An unstable loop will cause the frequency of the V.C.O. to jump around instead of locking on to the frequency of the crystal oscillator. Typical values for R1 and R2 are 1 M ohm and 100 k ohms, respectively. The value of the capacitor may range from 0.01 uf to 10 uf. If a given loop is unstable, R2 should be temporarily replaced by a resistor substitution box and the value "played with" until the loop is stable. The capacitor should be as large as possible consistent with the minimum lock-in time of the loop.

The frequencies at inputs 1 and 2 of the phase detector will always be equal. Therefore, if the frequency of the crystal oscillator is fR and the frequency of the V.C.O. is fO, then the frequency of the V.C.O. is given by

fO = N fR  (9.1)

The divide by N block is a variable modulus counter which is usually programmed by means of thumb-wheel switches. Because N is restricted to integer values, the smallest step in frequency which is possible is the frequency which is applied to input 1 of the phase detector. The smallest step is the resolution of the frequency synthesizer.

If a crystal cannot be obtained in a low enough frequency for the desired resolution the output of the oscillator may be divided by L as shown in Figure 9.3. The output frequency is now given by

fO = fR N / L  (9.2)

The resolution is now fR / L.

Figure 9.3 Frequency Synthesizer Circuit.

For a verbal description click here.

If the resolution is to be less than one hertz the input to the phase detector must also be less than 1 hertz. The required value of C in the loop filter is so large that it takes a very long time for the loop to lock in again after the value of N has been changed. Another way to get fractional hertz changes is to insert yet another divider in the circuit also shown in Figure 9.3. The divide by M circuit is a fixed modulus divider which divides the frequency of the V.C.O. before it is delivered to the output terminal. The output frequency is given by,

fO = fR N / (L M)  (9.3)

The resolution is fR / (L M).

Example 9.1.

In a synthesizer similar to Figure 9.3 the frequency of the crystal oscillator is 100 kHz, L = 5,000, M = 400 and 10 is less than N is less than 10,000. What are (a) the frequency range and resolution of the output and (b) the frequency range of the V.C.O.?

Solution:

The frequency at input 1 of the phase detector is 100 kHz / 5,000 = 20 Hz. The frequency at input 2 is also 20 Hz and so the frequency of the V.C.O. ranges from 10 x 20 Hz to 10,000 x 20 Hz = 200 Hz to 200 khz, which is the answer to part (b). The output frequency is the V.C.O. frequency divided by 400, which is 200 Hz / 400 to 200 kHz / 400 = 0.5 Hz to 500 hz, which is the first part of (a). The smallest frequency step for the V.C.O. is 20 Hz. The smallest step for the output is 20 Hz / 400 = 0.05 hz.

The output will go from 0.5 Hz to 500 Hz in 0.05 Hz steps. The V.C.O. must be capable of being tuned from 200 Hz to 200 kHz.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

9.4 Problems.

  1. A frequency counter has an 8 digit display and any one of the decimal points can be illuminated. If the gate time is 100 us and the readout is in MHz, where should the decimal point be placed. Number the digits from left to right and state which two the decimal point is between.

  2. A DMM uses the 200 mV range to measure current. What resistor should be used as a shunt on the 20 mA range?

  3. A DMM uses the 2 volt range for the 200 ohm range. What is the constant current for this range?

  4. In a synthesizer similar to Figure 9.3 the frequency of the crystal oscillator is 2 MHz, L = 40,000, M = 5,000 and 45,000 is less than N is less than 75,000. What are (a) the frequency range of the V.C.O and (b) the frequency range and resolution of the output?

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

9.5 Answers to Problems.

  1. Between 6 and 7.

  2. 10 ohms.

  3. 10 mA.

  4. (a) 2.25 to 3.75 MHz. (b) 450 to 750 Hz in 0.01 Hz steps.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

This page copyright © Max Robinson. All rights reserved.


Appendix A.

Standard Values for Electronic Components.

Resistors, capacitors, some lines of RF chokes, and zener diodes come in standard values. The numbers may seem rather strange but they are based on a geometric series which will be explained later.

There are sets of values for tolerances of plus or minus 5%, 10% and 20%. The table below gives the standard values for the decade between 10 and 91. A value an any other decade can be obtained simply by multiplying a number from the table by the appropriate power of 10.

5% | 10% | 20%
10 | 10 | 10
11 | NV | NV
12 | 12 | NV
13 | NV | NV
15 | 15 | 15
16 | NV | NV
18 | 18 | NV
20 | NV | NV
22 | 22 | 22
24 | NV | NV
27 | 27 | NV
30 | NV | NV
33 | 33 | 33
36 | NV | NV
39 | 39 | NV
43 | NV | NV
47 | 47 | 47
51 | NV | NV
56 | 56 | NV
62 | NV | NV
68 | 68 | 68
75 | NV | NV
82 | 82 | NV
91 | NV | NV

Note, NV = No Value for this tolerance.

Why these strange values?

Let's take a 10 ohm 10% resistor as an example. That resistor could have any value between 9 and 11 ohms. It wouldn't make any sense to have an 11 ohm 10% resistor. That resistor could be anything between 9.9 and 12.1 ohms. The next higher 10% value is 12 ohms which may be anything between 10.8 and 13.2 ohms. True, there is a slight overlap but resistor values only have 2 significant digits and the next step up, 13 ohms would leave a substantial gap. The values are stepped so the tolerances just touch or overlap

1/4 watt 5% resistors are manufactured in values from 1 ohm to 10 Meg ohms

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.

This page copyright © Max Robinson. All rights reserved.


Appendix B.

Reading Component Color and Numerical Codes.

Many beginners find resistor color codes to be confusing and capacitor codes to be completely unbreakable. This page should make it possible to understand how these codes work and remove the mystery from them.
Photo of assorted resistors and capacitors.

Resistor color codes.

The basic code for 5 and 10 percent resistors uses three color bands plus a silver band indicating 10% or a gold band for 5%. You start reading on the end that the bands are closest to. Some 1/4 watt resistors have the bands equidistant from both ends. In that case you have to rely on the gold or silver band to tell you where to start. You start on the end away from the gold or silver band. Here is a drawing of a typical resistor.

Drawing of resistor showing 4 bands.

The first band may be double width indicating a wire wound resistor.

First of all each color stands for a digit as follows.

  • 0 Black.
  • 1 Brown.
  • 2 Red.
  • 3 Orange.
  • 4 Yellow.
  • 5 Green.
  • 6 Blue.
  • 7 Violet.
  • 8 Gray.
  • 9 White.

The first two bands on the left, A and B, form a two digit number. The third band, C, tells you how many zeros to place after that number. This is the number of ohms.

For example

Yellow, Violet, Black.

Start by writing down the digits 47. Then put zero zeros after it. The resistor is a 47 ohm.

Blue, Red Brown.

Write down 62 and put 1 zero after it giving 620 ohms.

Orange, White, Yellow.

39 with 4 zeros after it is 390,000 ohms.

For resistors less than 10 ohms the gold and silver colors appear in the third, C, band. A gold third band means A.B is the number of ohms. A silver third band means 0.AB ohms.

For example

Green, Blue, Gold.

This is a 5.6 ohm resistor.

Red, Violet, Silver.

This is a 0.27 ohm resistor.

If you have studied the section on scientific notation at the end of the Basic DC Circuits page the resistor color code is AB x 10C (A B times ten to the C). For this form gold is -1 and silver is -2.

Standard values.

Color coded resistors come only in certain values. If you want a 72 ohm resistor you can't get it because they are not made. The standard 5 and 10 percent values are as follows.

  • 10 +
  • 11 *
  • 12 +
  • 13 *
  • 15 +
  • 16 *
  • 18 +
  • 20 *
  • 22 +
  • 24 *
  • 27 +
  • 30 *
  • 33 +
  • 36 *
  • 39 +
  • 43 *
  • 47 +
  • 51 *
  • 56 +
  • 62 *
  • 68 +
  • 75 *
  • 82 +
  • 91 *

+ Available in 5 or 10 percent.
* Available in 5 percent only.

The remaining decades repeat this one exactly. The list continues 100, 110, 120, 130, etc.

Why these funny numbers?

These values are set up so the tolerances just about touch or overlap slightly. For example a 10 ohm 5% may fall anywhere between 9.5 and 10.5 ohms. The 11 ohm 5% may fall anywhere from 10.45 to 11.55. There wouldn't be any point in making an 11 ohm 10% resistor. The 10 ohm 10% may be 9 to 11, the 11 ohm 10% may be 9.9 to 12.1 ohms, and the 12 ohm may be 10.8 to 13.2 ohms. If you put in a 10 ohm 10% you might actually get an 11 ohm. If you put in an 11 ohm 10% you might get 10, 9.9, 12, or 12.1 ohms. So by putting in an eleven ohm you might be getting the same results as a 10 ohm or 12 ohm. That's why you can't get an 11 ohm 10% resistor.

Four Band Codes.

Some 1 and 2 percent resistors use four bands to convey the value. The colors to numbers are the same but the code is ABC with D zeros after it. In scientific notation it is ABC x 10D (A B C times ten to the D). I confess I don't know how they handle values less then 100 ohms.

Numerical coding

Some resistors use a numerical code. It's the same as the color code except the code is given only in numbers. For example a resistor marked 503 is not a 5 hundred and 3 ohm resistor but the digits 5 0 followed by 3 zeros or 50,000 ohms. High wattage wire wound resistors are often marked in this way. Sometimes the number is followed by the letter k. Don't be fooled into thinking this means kilo ohms, it does not.

This code is also used on 1% or 0.1% resistors employing more digits. The last digit is the number of zeros that go after the first group of digits.

Antique Resistors.

Some antique resistors use the same code but the colors are arranged differently. One end of the resistor is one color, the body is another color and there is a color dot on the body. The body color is the first digit corresponding to band A on a modern resistor. The end color is the second digit, band B and the dot is the multiplier band C.

Capacitor Color Codes.

First of all, capacitors are coded in pico farads pronounced peko farads. Even a value that you are accustomed to thinking of in microfarads, such as a .1 microfarad is coded as 100,000 pico farads.

There are two types of flat capacitors and one cylindrical that use color codes. They are shown in the figure below.

Drawing of three types of capacitors.

The color codes read exactly the same as resistor color codes. If the capacitor has teardrop shaped dots hold it so the points are pointing to the right. If there is an arrow on the cap hold it so the arrow points right. If there is neither, look for writing on either side and hold it so the writing is right side up. If all of this fails try a digital capacitance meter.

The designations A, B, and C, have the same meanings as in the resistor color code. The number of pico farads is AB with C zeros after it. Or in scientific notation AB x 10 (A B times ten to the C).

The 6 dot capacitor.

The dots are numbered in a peculiar manner. The top row goes left to right but the bottom row goes right to left. Dot 1 is in the upper left and dot 6 is in the lower left. Go Figure.

Dot 1, upper left, tells you something about the capacitor. A black dot means the capacitor is mica. A silver dot means it is military specification paper. I have some caps on which this dot is white. I don't know what this means. Dots 2, 3, and 4, give the capacitance in pico farads as explained above. Dot 5 gives the percent tolerance as follows.

  • 1% Brown.
  • 2% Red.
  • 3% Orange.
  • 4% Yellow.
  • 5% Green.
  • 6% Blue.
  • 7% Violet.
  • 8% Gray.
  • 9% White.
  • 5% Gold.
  • 10% Silver.
I have some caps on which this dot is black. Not a clue.

Dot 6 gives the temperature coefficient of capacitance in parts per million per degree Centigrade. The color coding is as follows.

Black | -1000 to +1000.
Brown | -500 to +500.
Red | +200.
Orange | +100.
Yellow | -20 to +100.
Green | 0 to +70.

All of these capacitors have a voltage rating of 500 volts.

Three dot capacitors.

The three dot caps are read in a very straight forward manner; just as you would expect. They all have a 500 volt rating and plus or minus 20 percent tolerance.

Tubular Capacitors.

Cylindrical or tubular capacitors perhaps present the greatest enigma to the novice. The tubulars that have the leads coming out of each end as shown in the figure look like big resistors and I have known beginners to mistake them for resistors. These are military surplus paper capacitors.

The color code is read starting with the first band and is in pico farads. The fourth band gives the tolerance as follows.

Black | + or - 20%.
Brown | + or - 1%.
Red | + or - 2%.
Green | + or - 5%.
White | + or - 10%.

Now things get a little ambiguous. I only have one of these caps in my possession and it is more than a little worse for wear. After the fourth band is an empty space. There may have been another band there which has been rubbed off. After that empty space, or missing band, is the voltage rating band. The voltages are given as follows.

Brown | 100 V.
Red | 200 V.
Orange | 300 V.
Yellow | 400 V.
Green | 500 V.
Blue | 600 V.
Violet | 700 V.
Gray | 800 V.
White | 900 V.
Gold | 1000 V.
Silver | 2000 V.
No color | 500 V.

The one I have is a yellow, violet, yellow, black, blank, red which decodes to 470,000 pf 20% tolerance 200 volt.

The somewhat smaller ceramic types look as if the wire leads were wound around each end, as indeed they were, and come off the cap at right angles. These caps are often hollow and you can see right through them. The colors are not bands but small dots of paint that look as if they were painted on by hand. The first wide band may be a blob of paint which is larger than the rest.

I don't know what the first band means and can't find any reference to it in my extensive electronics literature. As indicated in the drawing above the second through fifth bands (spots) give the value and tolerance. For the tolerance use the table in this (tubular capacitors) section.

Many newer capacitor types use the numeric code. It works the same as the color code but numbers replace the color bands or dots. Often there is a letter such as J or K after the number. Don't be fooled into thinking the number is supposed to be multiplied by 1000. Not so. The meaning of these letters is known only to the manufacturer and a few privileged high volume buyers that the maker has informed. God likely doesn't know either as I doubt if any of these very rich men ever talk to Him.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.

This page copyright © Max Robinson. All rights reserved.


Appendix C.

Transistor and IC Packages.

If one is going to do laboratory experiments or do it yourself construction projects, one must know how pins on various ICs and transistors are designated. There are literally hundreds of packages and one is not likely to run into most of them. Only the most commonly found packages are covered here.

On the left in the photo are an 8-pin and a 14-pin Dual Inline Package, DIP. The DIP comes in 6, 8, 14, 16, 18, 20, 24, 28, and 40-pin versions. The 24-pin and higher are twice the width of the smaller ones. Digital ICs, except for microprocessors, and analog devices, except for high input impedance amplifiers, come in DIPs. Military grade and wide temperature range industrial grade devices do not come in this plastic package.

Next is the TO-3 power package. Two are shown to reveal their appearance from top and bottom. Power transistors up to 200 watts and power ICs come in this style of package.

Next is the TO-5 package. Some of the best known early transistors, such as the 2N404 and 2N1302 came in this package. Premium quality ICs also come in the TO-5 configuration with 8, 10, or 12 pins, depending on the application.

Next is the ubiquitous TO-92 package. It is very inexpensive to manufacture and the low cost transistors in this package were, in part, responsible for the transistor boom of the 70s. 3-terminal voltage regulators are also sold in this package. They are limited to 3 pins.

Lastly is the almost as ubiquitous TO-220. Power transistors up to 50 watts and IC voltage regulators come in this package. It is sometimes seen with 4 or 5 pins.

The DIP.

IC data books give pin numbers and the user of such circuits must know where to start and which way around to number the pins. The figure below shows the pin numbering convention for the DIP.

There are two types of packages. Part a shows the most common which has a small notch cut in the end between pins 1 and the highest numbered pin. The pins are counted counter clockwise as viewed from the TOP.

Part b shows a package used by Motorola. Pin 1 is marked with a dot and the pins are numbered counter clockwise as viewed from the TOP.

While the IC packages shown above are viewed from the top, these are viewed from the bottom. Some of the most common configurations will be given below but the student or experimenter should always consult the data sheet, or a data book for the particular transistor being used.

TO-3.

A drawing of the TO-3 package is not necessary. The photo clearly shows the letters E and B next to the pins. The metal case is the collector terminal.

In the case of an IC voltage regulator, the LM-309K to be specific, the pin on the right is the input and the left pin is the output. Backward? I think so but I didn't design it. The case is the common or ground. Always check the data sheet before wiring the circuit.

TO-5.

For most transistors in TO-5 packages the configuration is,

1 - Emitter,
2 - Base,
3 - Collector.

Always consult the data sheet for the particular transistor. The metal case may be connected to the base, the collector, or to none of the elements.

TO-92

For most bipolar transistors such as the 2N3904 and 2N3906 the pin configuration is,

1 - Emitter,
2 - Base,
3 - Collector.

For the very popular MPF102 field effect transistor the pin-out is,

1 - Drain,
2 - Source,
3 - Gate.

For the positive low power voltage regulators, such as the 78L12, the pinout is,

1 - Output,
2 - Ground,
3 - Input.

For the negative low power voltage regulators, such as the 79L12, the pinout is,

1 - Ground,
2 - Input,
3 - Output.

Always consult the data sheet for the particular transistor or IC you are using.

TO-220.

For a bipolar transistor the pinout is,

1 - Base,
2 - Collector,
3 - Emitter.

For a positive voltage regulator such as the 7812 the pinout is,

1 - Input,
2 - Ground,
3 - Output.

For a negative voltage regulator such as the 7912 the pinout is,

1 - Ground,
2 - Input,
3 - Output.

Always consult the data sheet for the particular transistor or IC you are using.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.

This page copyright © Max Robinson. All rights reserved.


Troubleshooting Table of Contents.

My Troubleshooting Textbook.

At Western Kentucky University where I used to teach the catalog listed a course in the electrical engineering department called troubleshooting. It had never been offered because none of the senior faculty members wanted to teach it. In the spring of 1987 some students came to me and asked if I would be willing to take it on. I agreed and they petitioned the department head to offer the course. It was offered in the fall. About 15 students signed up. I taught the course and because there was no textbook anywhere to be found I wrote one. I still have the files. I have decided to update, convert them to HTML, and post them.

Although I tried I never succeeded in getting a publisher interested in it. I self published it through a copy shop near campus so the students could buy it. I retain all rights and posting it here does not mean I am placing it in the public domain.

Every so often I get a request from someone wanting a hard copy of the book. All paper copies went away years ago. The original Word Perfect files have also disappeared so all that remains are these HTML files. I have put them together with all figures in a zip file which you can download from this location. I retain all rights to these files and electronic drawings. They are for personal use only. If you are a teacher and want to use this work as a textbook in your classes pleas contact me for permission to reproduce and distribute. If you plan to have your students access the book online please do not direct them to this site. I fear such use might exceed the bandwidth limit of my provider. Contact me so we can set up a mirror site preferably on your school or university network with limited access. Thank you.

Back to Fun with Transistors.
Back to Fun with Tubes.

Troubleshooting.

Table of Contents.

Chapter 1 Introduction to Troubleshooting.

Chapter 2 Test Equipment.
2.1 The Volt-Ohm-Milliammeter (VOM).
2.2 The Electronic Voltmeter.
2.3 The Digital Multimeter (DMM).
2.4 Choosing The Correct Test Meter.
2.5 Analog Versus Digital Meters.
2.6 The Oscilloscope.
2.7 The Signal Tracer.
2.8 Miscellaneous Test Equipment.
2.9 Instruction Manuals.

Chapter 3 Failure Modes.
3.1 Generalized Failure Modes.
3.2 Electrolytic Capacitors.

Chapter 4 Troubleshooting Techniques.
4.1 Check The Obvious First.
4.2 Do Not Make Modifications.
4.3 The Power Supply Section.
4.4 Half-splitting.
4.5 Signal Tracing.
4.6 Signal Injection.
4.7 Disturbance Testing.
4.8 Static Testing.
4.9 Shotgunning.

Chapter 5 Faults in Power Supplies.
5.1 Rectifier-Filter Circuits.
5.2 Analog Voltage and current Regulator Circuits.
5.3 Switching Mode Power Supplies.

Chapter 6 Faults in Transistor Circuits.
6.1 Common Emitter Amplifier.
6.2 The Emitter-follower's Fatal Flaw.
6.3 AC Coupled Amplifiers.
6.4 DC Coupled Amplifiers.
6.5 Radio Frequency Amplifiers.
6.6 Switching Circuits.

Chapter 7 Transistorized Consumer Equipment.

7.1 Audio Amplifiers.
7.2 Radios and tuners.
7.3 Things you should leave alone.

Chapter 8 Faults in Vacuum Tube Circuits.
8.1 Audio Amplifiers.
8.2 Radio Receivers.

Chapter 9 Antique Equipment.
9.1 Before Turning on the Power.
9.2 Pre 1930 Radios.
9.3 Pre World War Two Radios.
9.4 The All American Five.
9.5 Three Way Portable Radios.
9.6 Phonographs and Record Changers.
9.7 Consoles and High Fi Components.
9.8 Wire and Tape Recorders.
9.9 Why TV Sets Are Not covered.

Chapter 10 Things That Have Never Worked.
10.1 Power Supplies.
10.2 Audio Amplifiers.
10.3 Radio Receivers.
10.4 Simple Test Equipment.

Back to Fun with Transistors.
Back to Fun with Tubes.


Troubleshooting Chapter zero.

Chapter 0   Electrical Fundamentals.

0.1  DC Circuits.
0.2  AC Circuits.
0.3  Power Supplies.
0.4  Bipolar Transistor Fundamentals.
0.5  Bipolar Transistor Circuits.
0.6  Operational Amplifiers.
0.7  Field Effect Transistors.
0.8  FET Circuits.
0.9  Vacuum Tube Fundamentals.
0.10 Vacuum Tube Circuits.

Chapter 0

Review of Fundamentals.

In order to understand the material in this book, the reader must understand certain fundamentals of electricity and electronics. The teaching of these fundamentals is far beyond the scope of this book. This chapter is merely a review. If the reader is not familiar with any of what is presented in this chapter, it is strongly urged that he or she supplement his or her knowledge by studying Electronics for Physicists.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

0.1 DC CIRCUITS.

Kirchhoff's voltage law states that the algebraic sum of all voltage drops around a closed loop is equal to zero.

Kirchhoff's current law states that the algebraic sum of all currents flowing into a node is equal to zero.

The consequences of these laws for series circuits are a) the sum of all voltage rises is equal to the sum of all voltage drops, and b) the current anywhere in a series circuit is equal to the current anywhere else in the same circuit.

The consequences of Kirchhoff's laws for parallel circuits are a) the sum of all upward flowing currents is equal to the sum of all downward flowing currents, and b) the voltage across any element in the circuit is equal to the voltage across any other element in the same circuit.

Ohm's law states the relationship between voltage, current and resistance in an electric circuit.

V = I x R           (Eq. 0.1)

I = V/R           (Eq. 0.2)

R = V/I           (Eq. 0.3)

where V is voltage in volts, I is current in amperes and R is resistance in ohms.

To properly apply Ohm's law it is necessary to use the resistance of a particular resistor, the current through that same resistor and the voltage across that same resistor.

When resistors are connected in series the total resistance is

RT = R1 + R2 + R3 + ... + Rn

for any number of resistors in series.

When resistors are connected in parallel the equivalent resistance is

1/Req = 1/R1 + 1/R2 + 1/R3 + ... + 1/Rn

for any number of resistors in parallel.

Figure 0.1, Voltage Divider Circuit.

For a verbal description click here.

Figure 0.1 is of a voltage divider. RA and RB may be the equivalent of other resistors in series and/or parallel. The output voltage Vo is given by

Vo = E RB/(RA + RB)           (Eq. 0.4)

Thevenin's theorem states that a network with output terminals and is of any level of complexity, using resistors, can be reduced to one ideal voltage source in series with a single resistance.

The ideal (Thevenin) voltage source is equal to the no- load output voltage of the original network.

The Thevenin resistance is equal to the resistance looking in at the terminals of the original network with all voltage sources replaced by shorts and all current sources replaced by opens.

Example 0.1.

Determine the Thevenin equivalent circuit of the network of figure 0.2.

Figure 0.2, Circuit for Example 0.1.

For a verbal description click here.

Solution:

With no load connected to the output, there will be no voltage drop across R3. Therefore, the voltage across R2 will be the same as the output voltage. R1 and R2 make up a voltage divider. By equation 0.4 we have

Vo = 48 v x 1 k ohm / (3 k ohm + 1 k ohm ) = 12 volts.

Figure 0.3, Network of Figure 0.2 with the voltage source replaced by a short.

For a verbal description click here.

If we replace the battery in figure 0.2 with a short and redraw the circuit we have the circuit of figure 0.3. The resistance looking in at the terminals is R1 in parallel with R2 and this combination in series with R3. R1 in parallel with R2 is R12 = 1/( 1/(1 k ohm ) + 1/(3 k ohm )) = 750 ohm. Now adding R3 in series we have 750 ohm + 500 ohm = 1250 ohm. The Thevenin equivalent circuit is shown in figure 0.4.

Figure 0.4, Thevenin's Equivalent Circuit of Figure 0.2.

For a verbal description click here.

There are many other methods of solving electric networks. A few of these are Norton's theorem, superposition theorem, loop equations, node equations and Y-delta transformation. If you do not understand these techniques, it will be necessary to take an introductory level course in electrical engineering.

RC Time Constant.

If a capacitor C is being charged or discharged through a resistor R the time constant is given by

T = R x C           (Eq. 0.5)

where T is time in seconds, R is resistance in ohms and C is capacitance in farads.

T is the time required for a charging capacitor to charge up to 63.2 percent of its final voltage or for a discharging capacitor to discharge to 36.8 percent of its starting voltage.

Theoretically a capacitor will never get fully charged or discharged. As a matter of practicality a capacitor is considered to be fully charged or discharged after 5 x T seconds have elapsed.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

0.2 AC CIRCUITS.

All of the laws and theorems which apply to DC also apply to AC. In theorems stated in words replace the word "resistance" by the word "impedance". In equations, replace the symbol R by the symbol Z where Z = R + jX or Z = Z /_ Theta

A capacitor is an open circuit for DC but has reactance for AC. The reactance of a capacitor is

XC = 1 / (2 x Pi x f x C)           (Eq. 0.6)

where XC is the reactance of the capacitor in ohms, f is the frequency in hertz and C is the capacitance in farads.

An inductor has a very low resistance for DC (ideally zero) but has reactance for AC. The reactance is given by

XL = 2 x Pi x f x L           (Eq. 0.7)

where XL is the reactance of the inductor in ohms, f is the frequency in hertz and L is the inductance in henrys.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

0.3 POWER SUPPLIES.

Power supplies serve the purpose of changing the 120 volt AC line voltage to one or more useful DC voltage(s).

Figure 0.5, Full-Wave Bridge Rectifier Power Supply.

For a verbal description click here.

The circuit of a full-wave bridge rectifier is shown in figure 0.5. The no-load output voltage of this circuit is given by

EM = EAC x Square Root (2)           (Eq. 0.8)

where EM is the no-load DC output voltage of the circuit and EAC is the RMS AC voltage across the entire transformer secondary.

Figure 0.6, Full-Wave Center-Tapped Rectifier Power Supply.

For a verbal description click here.

The circuit of a full-wave center-tapped rectifier is shown in figure 0.6. The no-load voltage of this circuit is given by

EM = EAC x Square Root (2)/2           (Eq. 0.9)

where EM is the no-load DC output voltage of the circuit and EAC is the RMS AC voltage across the entire transformer secondary.

The ripple output from a full-wave rectifier power Supply operating on 60 Hz is given by

VR = EM / (200 x RL x C           (Eq 0.10)

where VR is the peak to peak ripple voltage of the power supply, EM is the no-load DC output voltage as given by equation 0.8 or 0.9, RL is the equivalent load resistance on the power supply in ohms and C is the capacitance of the filter capacitor in farads.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

0.4 BIPOLAR TRANSISTOR FUNDAMENTALS.

All of the following discussion assumes the transistors are NPN. For PNP transistors, just reverse all voltages and currents.

A transistor has three terminals. They are called emitter, base and collector. Internally the transistor is made up of three alternating layers of semiconductor material, for example, NPN. The emitter is one of the N layers, the base is the P layer and the collector is the other N layer. This means that there are two P-N junctions, one between the emitter and base and the other between the collector and base.

The normal way of biasing a transistor is to forward bias the base-emitter junction and reverse bias the collector-base junction. For an NPN transistor this means to connect a current source between emitter and base so as to run current into the base, and connect a Thevenin circuit between emitter and collector such that the collector is positive and the Thevenin voltage source is greater than 0.6 volts. Figure 0.7 shows the biasing circuit.

Figure 0.7, Ideal Biasing Circuit for an NPN Transistor.

For a verbal description click here.

The voltage between emitter and base VBE is about 0.65 volts. Some authors round this up to 0.7 while others round it down to 0.6 volts. Depending on the magnitude of the collector current the voltage between collector and emitter VCE will be anywhere between 0.1 volts and VTH.

If VCE = 0.1 volts, the transistor is said to be in saturation. If VCE = VTH the transistor is said to be in cutoff. If 0.1 volts < VCE < VTH is true, the transistor is said to be in linear operation.

When the transistor is in linear operation the collector current is controlled by the base current. If the base current is zero, the collector current is zero because the collector base junction is reversed biased. As base current increases, the collector current increases. The current gain of the transistor is defined as follows.

Beta = IC / IB           (Eq. 0.11)

Therefore,

IC = Beta x IB           (Eq. 0.12)

The emitter current is the sum of base and collector currents.

IE = IB + IC           (Eq. 0.13)

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

0.5 BIPOLAR TRANSISTOR CIRCUITS.

Figure 0.8 gives a practical biasing circuit for an NPN transistor. It will be easier to analyze this circuit if we reduce the voltage divider in the base circuit to its Thevenin equivalent circuit. This has been done in figure 0.9.

Figure 0.8, Transistor with Constant Voltage Biasing.

For a verbal description click here.

VBB = VCC x R2 / (R1 + R2)
And
RB = (R1 x R2) / (R1 + R2).

Figure 0.9, Constant Voltage Biasing Circuit with a
Thevenin's equivalent circuit replacing the
voltage divider in the base circuit.

For a verbal description click here.

If we write a loop equation around the base loop and substitute equations 0.12 and 0.13 we get this equation for the collector current.

Exact form           IC = Beta (VBB - VBE) / (RB + RE (Beta + 1))           (Eq. 0.14)

If Beta is large or guessed at, and it is usually both, the collector current becomes

First approximation           IC = (VBB - VBE) / ((RB/Beta) + RE)           Eq. 0.15

If RB / Beta << RE, as it sometimes is, the collector current becomes,

Second approximation           IC = (VBB - VBE) / RE           (Eq. 0.16)

There are three ways of injecting and recovering signals in a transistor amplifier. These are common emitter, common collector (emitter follower) and common base.

Common Emitter Amplifier.

A common emitter amplifier is shown in figure 0.10. The common sides of the input and output are connected to the circuit ground. The emitter of the transistor is also connected to signal ground through a capacitor. The emitter is common to both input and output. The resistor on the right labeled RFS is the input resistance of the Following Stage. The voltage gain of this circuit is

AV = - Beta x RL / hie           (Eq. 0.17)

where AV is the voltage gain, Beta is as defined above, RL is the parallel combination of all resistances connected to the collector of the transistor and hie is the input resistance of the transistor. hie is never given in transistor manuals. It can be found in manufacturers' data sheets but it varies quite a lot from one unit to the next, even of the same type number. As a very rough approximation hie = (1 volt) / IC, this approximation is not good enough to get an equation number.

Figure 0.10, Common Emitter Amplifier Circuit.

For a verbal description click here.

The input impedance is equal to hie in parallel with the parallel combination of R1 and R2, The output impedance is equal to RC.

If the emitter bypass capacitor is removed the gain becomes

AV = - RL / RE           (Eq. 0.18)

where RL is as defined above and RE is the emitter resistor.

The input resistance is Rin in parallel with RB. Rin is given by

Rin = hie + Beta x RE           (Eq. 0.19)

The term Beta x RE is usually much greater than hie so the equation becomes

Rin = Beta x RE           (Eq. 0.20)

The output impedance remains equal to RC.

The upper frequency limit of an amplifier is considered to be the frequency at which the output is 3 db down from the output at medium frequencies. This is variously known as the upper frequency limit, the upper 3 db frequency, the upper corner frequency, the upper cutoff frequency or the bandwidth. We will symbolize this frequency by fC.

fC = 1 / (2 x Pi x Rl x C)           (Eq. 0.21)

where RL is the parallel combination of RC and all other resistances connected to the collector in ohms and C is the total capacitance from collector to ground in farads.

The Miller effect causes the input capacitance of an inverting amplifier to be much larger than the stray wiring capacitance. The Miller capacitance is given by

CM = CBC x (1 - AV)           (Eq. 0.22)

where CM is the Miller capacitance and CBC is the capacitance between collector and base of the transistor including wiring capacitance. Remember that in an inverting amplifier AV is a negative number.

Common Collector (Emitter-Follower) Amplifiers.

The circuit of a common collector amplifier is shown in figure 0.11. Equations 0.14 through 0.16 may be used to calculate the collector current of this circuit.

Figure 0.11, Common Collector (Emitter-Follower) Amplifier.

For a verbal description click here.

The voltage gain of this circuit is approximately equal to unity.

The input impedance of this circuit is the parallel combination of Rin in parallel with both R1 and R2.

Rin = Beta x RL           (Eq. 0.23)

where RL is the parallel combination of all resistors connected to the emitter of the transistor.

The output impedance of this circuit is RE in parallel with ROUT.

ROUT = RS / Beta           (Eq. 0.24)

where RS is the parallel combination of R1, R2 and Rg, the generator output resistance.

Because the voltage gain is very close to + 1, equation 0.22 tells us that the Miller capacitance CM is essentially zero. Do not get the mistaken impression that the input capacitance is zero. There is always stray wiring capacitance.

Common Base Amplifier.

The circuit of a common base amplifier is shown in figure 0.12. The voltage gain is given by equation 0.17. The input resistance is approximately equal to hie / Beta. The output impedance is equal to RC.

Figure 0.12, Common Base Amplifier.

For a verbal description click here.

The base of a transistor is physically between the emitter and collector. When the base is grounded (for AC), the base becomes an electrostatic shield between the emitter (input) and collector (output). Through careful circuit layout CEC the capacitance between emitter and collector can be made very small (of the order of 0.1 pf).

A common base amplifier is noninverting. Equation 0.22 would actually give a negative input capacitance. This negative Miller capacitance will cancel with positive (real) stray circuit capacitance and it is possible to achieve a net zero input capacitance. Such an amplifier can have a very wide bandwidth.

Common base amplifiers are used as amplifiers in VHF and UHF receivers and as wide-band amplifiers in the vertical channel of oscilloscopes. When used in this application the power supplies are arranged so the base is at DC as well as AC ground. This permits a low impedance ground connection.

Feedback.

When feedback is applied to transistor amplifiers, the equations are derived in such a way as to allow for positive or negative feedback. To avoid contradictions with the Electronics for Physicists book the equation given here will not be the same as seen in other books but will be the same as in the afore mentioned book. The gain of an amplifier with feedback A' is given by

A' = A / (1 + A B)           (Eq. 0.25)

where A is the gain of the amplifier without feedback and B is that fraction of the output signal which is fed back to the input.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

0.6 OPERATIONAL AMPLIFIERS.

An operational amplifier is an amplifier with a differential input and a very high gain. The frequency response of the amplifier has been tailored to prevent oscillation when negative feedback is applied to reduce the gain to unity.

A differential input consists of two inputs with respect to ground. If the same signal is applied to both inputs, the difference between the two inputs will be zero and the output of the amplifier will be zero, theoretically. There will be some small output. If two signals which are similar but not identical are applied, the amplifier will amplify the difference between the two signals.

If one input is grounded and a signal put into the other input, the amplifier will amplify that signal. If the signal is put into the noninverting input, the output will be of the same sign as the input signal. If the signal is put into the inverting input, the output will be of the opposite sign as the input signal.

If the inverting input is more positive than the noninverting input, the output will go negative. If the noninverting input is more positive than the inverting input, the output will go positive.

When we analyze operational amplifier circuits, the feedback is always assumed to be negative. The equation which results is

A' = A / (1 + A x B)          (Eq. 0.26)

The open loop gain A is entered as a positive number.

Equation 0.26 is seldom seen in connection with op amps because the open loop gain A is so large. The limit as A approaches infinity is,

A' = 1 / B           (Eq. 0.27)

where B is that fraction of the output signal which is fed back to the input.

Equation 0.27 is based on the assumption that A x B is much greater than one. A x B may not always be much greater than one, especially at high frequencies.

The gain of an op amp falls off as frequency increases at the rate of 20 db per decade. The unity gain frequency of an op amp is given in its specifications. The gain A at any frequency f is given by

A = fG / f           (Eq. 0.28)

where fG is the unity gain frequency of the op amp. If equation 0.28 gives a value greater than the specified DC gain, the DC gain is the gain at that frequency, not the result of equation 0.28.

In the case of a 741 op amp which has a unity gain bandwidth of 1 megahertz, the gain at 20 kilohertz is only 50. Common emitter amplifiers often have more gain than this.

If the gain is low due to frequency effects, equation 0.26 should be used instead of equation 0.27.

Figure 0.13 is the circuit of an inverting amplifier. For this circuit the value of B is given by

Inverting Amplifier.           B = R1 / R2          (Eq. 0.29)

This equation gives the value of B to be used in equation 0.26 or 0.27. For best temperature stability R3 should be equal to the parallel combination of R1 and R2.

Figure 0.13, Inverting Amplifier with Op Amp.

For a verbal description click here.

Figure 0.14, Noninverting Amplifier.

For a verbal description click here.

Figure 0.14 is the circuit of a noninverting amplifier. For this circuit the value of B is given by

Noninverting Amplifier.           B = R1 / (R1 + R2)          (Eq. 0.30)

This equation gives the value of B to be used in equation 0.26 or 0.27. For best temperature stability R3 should be equal to the parallel combination of R1 and R2.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

0.7 FIELD EFFECT TRANSISTORS.

Junction FET.

A field effect transistor (FET) consist of a P-N junction on the side of a bar of silicon. The bar is known as the channel. One end of the channel is the Source, the other end is the Drain, and the other side of the P-N junction is the Gate. If the channel is N type semiconductor, the Gate is P type.

When the P-N junction of the Gate and channel is reversed biased a depletion region in the channel reduces its effective cross section area. This restricts current flow between the Source and Drain. The larger the reverse bias, the more the channel is restricted and the smaller the current between Source and Drain. The JFET (Junction Field Effect Transistor) is almost never used with the Gate to channel junction forward biased.

Note: In oscillators and class C amplifiers the gate is purposefully driven positive which causes rectification. The rectified voltage is negative which provides proper bias for an N channel FET. When a MOSFET is used, see below, a diode is connected from Gate to Source to accomplish the necessary rectification.

Metal Oxide Semiconductor FET (MOSFET).

Since the P-N junction is not normally forward biased, there is no need to have an actual P-N junction to create the depletion region. All that is needed is an electric field which can be created by a metallic plate. A small spot on the N type semiconductor is exposed to oxygen which creates a thin layer of silicon dioxide, hence the name. This thin glass layer is coated with metal which forms the gate. In operation an MOSFET acts almost the same as a JFET except that the gate can be driven positive for even higher conduction. Like its junction brother, the MOS FET is rarely operated in this condition. When used in an oscillator or a class C amplifier a diode is connected from Gate to Source to provide the necessary bias rectification. For convenience an N channel MOSFET is constructed on a P type substraight. This substraight is either internally connected to the Source, or is brought out to its own lead and the user must connect it to the most negative part of the circuit. This configuration is known as a depletion mode MOSFET.

The MOSFET can be made in another configuration. A lightly doped P region, part of the substraight, is placed between the Source and Drain. This does not allow conduction between them. When the Gate is biased positively the holes in the region between Source and Drain are repelled deeper into the substraight leaving electrons behind. This effectively turns this region from P to N type semiconductor which allows conduction. The more positive the Gate the more conduction there is between Source and Drain. This is known as an enhancement mode MOSFET.

In 1987 MOSFETs were used primarily for switching in logic circuits. They are still used for that but a new generation of MOSFETs has been developed which will stand up to very high voltage and power. In that respect they are as close to silicon tubes as can be.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

0.8 FET Circuits.

The junction FET is used most often as a source follower, analogous to the emitter follower, for a high impedance input and a low impedance output. The input impedance is the resistor from gate to ground and the capacitance is a very few pf. The output impedance is 1 over the transductance in parallel with the source resistor.

A special type of JFET known as a GASFET (Gallium Arsenide) is used as the low noise amplifier in satellite receivers.

High voltage MOSFETs are used in both analog and switching modes. The former includes but not limited to, * pass transistors in constant voltage and constant current power supplies, and output transistors in audio and servo amplifiers. The latter includes * switching power supplies, and variable speed drives for industrial electric motors.

* Have you ever read one of those terms of use things on the internet?

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

0.9 Vacuum Tube Fundamentals.

A vacuum tube is constructed inside a glass envelope which is evacuated to a very high level. The envelope is usually cylindrical which is the reason for the name. The internal structure is usually cylindrical as well. The filament or heater runs down the center. If the tube is a filamentary type it serves as the cathode which emits electrons when heated. If the tube is a heater/cathode type the cylindrical cathode surrounds the heater but is electrically insulated from it. Next out is the control grid. If there are additional grids they surround the control grid. Everything is surrounded by the plate or anode and is coaxial.

Filament type tubes are the oldest type. In the golden age of tubes, 1950s, filament types were only used for very low power, used in portable radios, or high power, in radio transmitters. The heater/cathode type is by far the most common. They were used in radios, TV sets, audio amplifiers and a wide range of measurement and industrial equipment.

The minimum tube is a diode which consists of a cathode and anode. This is used primarily as a rectifier in power supplies and radio detectors.

Next higher is the triode, 3 element tube. (Note: The heater does not count when elements inside a tube are counted.) It consists of the cathode, control grid, and plate or anode. This type is favored by audio enthusiasts. Like the FET, the grid usually operates negative with respect to the cathode while the plate is positive.

Next higher on the totem pole is the tetrode which has two grids. The one closest to the cathode is the control grid and the outer one is known as the screen grid. The additional grid was added to serve as an electrostatic shield between the grid and plate. The control grid to plate capacitance caused RF amplifiers to oscillate and a means was needed to reduce this capacitance. The screen grid is made positive usually about equal to the plate or occasionally even higher. This type of tube has problems and very few true tetrodes were ever manufactured. There is a form of the tetrode in which a beam forming element was added between the screen grid and plate. It was connected to the cathode within the tube. This was done initially to avoid infringing on a patent but turned out to produce one of the best tubes ever made, the 6L6 and its many derivatives. The beam forming element suppressed secondary emission of electrons from the plate.

The pentode inserts a third grid between the screen grid and plate. This is also a method of suppressing secondary emission of electrons from the plate. It is called the suppressor grid. It is often brought out to a pin and the designer has to tie it to the cathode, or rarely, ground.

Toward the end of the golden age of tubes when there began to be significant competition from transistors, a type of tube was developed for use in car radios that would operate with no more than 12 volts on the plate. It was known as a space charge tube and was a pentode, but the control grid and screen grid were interchanged. The grid closest to the cathode was operated at 12 volts to get the electrons moving and the second grid was the control grid. The third grid served as a shield between the plate and control grid to prevent oscillation when the tube was used as a radio frequency amplifier.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

0.10 Tube Circuits.

The only circuits to be reviewed here are the resistance coupled amplifiers. Remember, this is only a refresher of knowledge you should already possess.

Figure 0.15 (a) Triode resistance coupled amplifier and (b) Pentode Resistance Coupled Amplifier.

For a verbal description click here.

The notation used is consistant with that used in resistance coupled amplifier tables found in the back of most tube manuals.

Figure 0.15a is a triode resistance coupled amplifier. The current flowing through Rk produces a voltage drop which makes the cathode positive with respect to ground. The grid is held at ground potential by Rc so the grid is negative with respect to the cathode. This is an audio frequency amplifier. Ck filters the AC component from the cathode voltage which if present would reduce the gain of the amplifier. Note: Sometimes Ck is deliberately omitted which reduces distortion along with reducing the gain.

The output of this amplifier circuit appears across Rcf. Rcf is the grid resistor of the following stage. It is assumed that this amplifier stage is sending its signal to another amplifier stage.

Figure 0.15b is a pentode amplifier stage. Pentode circuits give higher gain than triodes but have a higher parts count. Biasing works the same way as in the triode circuit. Cc2 prevents reduction of the gain which would occur if AC signals were allowed to appear at the screen grid. This capacitor is never omitted. However, if the cathode bypass capacitor is omitted the screen grid bypass capacitor must be returned to the cathode instead of ground. Gain is higher and distortion lower than with Cc2 returned to ground.


Troubleshooting Chapter one. Introduction to Troubleshooting.

Chapter 1

Introduction to Troubleshooting.

using this book.

This text assumes you are on a first name basis with the material in the book "Electronics for Physicists". You should at the very least study through chapter 5 and preferably through chapter 6.

I can't force you to take my advice. All I can do is give and hope. If you run into trouble as you work your way through this book you may find that you need to stop and study "Electronics for Physicists". There is nothing wrong with parallel study of the two books but if you skim through the other book you may occasionally find you have missed some point and need to go back for more study. In the final analysis it's up to you. However you decide to do it I wish you luck.

Troubleshooting.

When people think of electronics troubleshooting, they may think of the TV repair person. However, the steadily increasing level of technology in consumer electronics and use of surface mount components and proprietary integrated circuits have made the cost of repairing TV sets and audio equipment so high that it is no longer economically feasible to repair failed units. This has turned us into a throw away society. "If it stops working just send it to the land fill and buy a new one".

Electronic troubleshooting in the modern world has moved from consumer electronics to other fields. these are:

  1. Maintaining laboratory equipment used in industrial research and development laboratories.

  2. Maintaining automated production equipment.

  3. Working for a manufacturer to perform field service of laboratory or industrial equipment manufactured by the company.

  4. Troubleshooting prototype equipment in an R and D lab.

  5. Troubleshooting production equipment at the end of an assembly line.

  6. Troubleshooting research and teaching laboratory equipment at a university, college, or secondary school system.

  7. Individuals, who are most likely to be retired, who restore and repair antique electronic equipment for themselves and others.

  8. DIYers and hams who build their own equipment from kits or scratch.

Number 6 was essentially half of the job I did for the university. The other half was teaching.

Engineering technologists are not necessarily overqualified for these positions.

Finding troubles in an electronic circuit is rather like figuring out "Who done it?" You are Sherlock Holmes. You have a number of seemingly unrelated clues and you have to figure out which part is defective.

In every defective circuit there are symptoms and causes. The most obvious symptom is "it doesn't work". When you open up the box, you may see a burned resistor. "Aha!" you will say, and you replace the resistor. When you turn the power on, the newly replaced resistor begins to get hot, smoke and burn up. The burned resistor was just another symptom, not a cause. There is another defect which caused the resistor to burn out.

A burned out transistor may be a cause or a symptom. The odds are in favor of it being a symptom.

Often the clues are more subtle than a scorched resistor. Nine times out of ten, there are no visible defects. When this happens it is necessary to make tests on the circuit.

At first, every part is suspect. As you make more tests, some parts are eliminated as suspects. As you gather more clues, the number of suspects is narrowed down until only one is left.

Holmes' first rule: When all other suspects have been eliminated, the one which remains, no matter how improbable, is the correct one. When you apply this rule, be sure that you have eliminated all other suspects.

Probability plays a very large role in troubleshooting. If you have narrowed down the suspects to two parts, and they are equally difficult to replace, replace the one which has the highest probability of being defective.

Ease of replacement will override the probability rule. If in the above situation one of the two parts is difficult to replace, and the other is easy, than replace the easiest one first. If that one is the trouble, you have saved yourself a lot of work. If the easy one is not the trouble, you haven't wasted very much work and you now know for sure that the "hard to replace" one is bad.

The first law of troubleshooting is check the easy things first. It is possible to gain a reputation as a miracle worker by always using this law.

You may be called in to "look at" a major piece of equipment for which there is no documentation. The thing to do is to check the power supply. If you are lucky, the supply will be a simple circuit consisting of a transformer, a rectifier and a filter capacitor. If the fault is in the supply, you can "do the impossible" and fix it.

The difficulty of any given troubleshooting job depends on the amount of documentation you have for the particular piece of equipment. The less documentation you have, the more difficult the task.

Troubleshooting a piece of equipment which has no documentation can be a formidable task at best. There are times when you can "give it a try" and times when it is best to just walk away. For example, the six-transistor radio uses a somewhat standard circuit. Regardless of the manufacturer or even the country of origin, the circuits used vary only slightly. If you are familiar with this circuit, don't hesitate to "have a go at it". The same applies to the standard 5 tube radio. On the other hand, if someone asks you to work on a video cassette recorder or a computer, check the line cord, the fuses and the power supply. If the simple things are all right, forget it! For cases in between these two extremes you will have to way the complexity of the device against your skills and make your own decision.

A situation which is frequently encountered is to have a detailed schematic diagram but no normal voltages or wave-forms. In this case you must deduce what the normal voltages will be, based on your knowledge of electronics.

Those problems which seemed so theoretical in the early courses will now come down to earth and take on reality. You will use Ohm's law, Kirchhoff's laws and all you have learned about transistors and operational amplifiers to figure out what normal voltages are.

Another way to get a reputation as a miracle worker is to overestimate the amount of time required to solve the problem. That one comes from Star Trek's Scotty.

There are two distinct kinds of troubleshooting. One is in a piece of equipment that has worked but suddenly stopped working. The other is less familiar and is in a piece of equipment that has never worked. This could be something produced in a research and development laboratory or something you built yourself. It is definitely harder to troubleshoot something that has never worked. The reason is that all the parts may be good but a design flaw is keeping it from performing its intended operation. In such a case you may or may not have the cooperation of the design engineers. They have egos which are wrapped up in the design. They are likely to be unwilling to admit that they have made a mistake.


Troubleshooting Chapter Two. Test Equipment.

Chapter 2   Test Equipment.

2.1  The Volt-Ohm-Milliammeter (VOM).
2.2  The Electronic Voltmeter.
2.3  The Digital Multimeter (DMM).
2.4  Choosing The Correct Test Meter.
2.5  Analog Versus Digital Meters.
2.6  The Oscilloscope.
2.7  The Signal Tracer.
2.8  Miscellaneous Test Equipment.
2.9  Instruction Manuals.

Chapter 2

Test Equipment.

Troubleshooting is impossible unless you have test equipment and know how to use it. In actual fact, someone who is very skilled can do more with a simple voltmeter than someone who has little skill and a workbench full of test equipment.

It is every bit as important to choose the right test instrument as it is to operate it correctly. If you try to use a VOM (volt-ohm-milliammeter) to measure voltages in high impedance circuits or an electronic multimeter to test a logic circuit, you will get nowhere fast. This chapter will discuss several of the most common pieces of test equipment and explain what they can and cannot do.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

2.1 The Volt-Ohm-Milliammeter (VOM).

The volt-ohm-milliammeter (VOM) has been around longer than any other test instrument. In spite of this it remains very popular. The reasons for its popularity are: reliability, portability, ruggedness and low cost.

By definition a VOM has no amplifying devices in it. It contains only resistors, a few diodes, perhaps one capacitor, some batteries and, of course, the meter movement.

As the name implies the VOM can measure voltage, current and resistance. Most VOMs will measure both AC and DC voltage while the current ranges are DC only. The internal batteries are used in measuring resistance. A VOM will not measure the reactance of an inductor or a capacitor.

Ranges and scales.

There is a great amount of confusion about the correct usage of the terms range and scale. They are NOT interchangeable and should never be used as such. The range expresses the limits or extent over which the meter can measure with a given setting of the controls. The scale refers to the graduations which the pointer moves across.

It is NOT correct to say "the meter is set to the 10 volt scale". It is correct to say "the meter is set to the 10 volt range".

It is correct to say "the scale reading is 5.3". Notice that there are no units given. The units and the power of ten by which the scale reading must be multiplied come from the setting of the range switch.

Reading the meter.

Even a very high-quality VOM will not give useful results if the operator does not interpret the reading correctly.

A typical VOM may have 8 voltage ranges, 6 current ranges and 5 resistance ranges. There are never separate scales for each range. It is necessary to multiply the scale reading by the correct power of ten to obtain the correct reading.

Example 2.1.

A VOM is set to the 2.5 volt range. There is no 0 to 2.5 scale but there is a 0 to 250 scale. The reading on this scale is 195. What is the voltage being indicated?

Solution:

The range switch is set to the 2.5 volt range (given), which means that the meter can measure voltages anywhere in the range of 0 to 2.5 volts. It is therefore impossible for the reading to be 195 volts. If the meter were indicating full scale (all the way to the right), it would be indicating 2.5 volts. Also, the pointer would be over the 250 mark on the scale. It is necessary to divide the scale reading by 100 to obtain the correct voltage reading. 195/100 = 1.95 volts, which is the correct reading.

Example 2.2.

A VOM is set to the 500 milliampere range and the scale indication is 27 on a 0 to 50 scale. What is the meter indicating?

Solution:

The 0 to 50 scale corresponds to the 0 to 500 milliampere range; therefore, the scale indication must be multiplied by 10 to obtain the correct reading. 27 times 10 = 270 milliamperes.

Notice that you do not multiply the range switch setting by the scale reading. You choose the scale which is related to the range switch setting by a power of 10 and multiply the scale reading by that power of 10 to obtain the reading.

Most experienced VOM users simply look at the scale, mentally put the decimal point in the right place and take the reading. As so often happens, the marvelous computer called the human mind makes all of these calculations without even thinking about them.

AC voltage.

All VOMs have AC voltage ranges. Because the meter movement will respond to DC only, two or more diodes are used to change the AC to DC. Because of the nonlinear voltage - current characteristic of a diode, the meter indication is not directly proportional to voltage. This nonlinearity is compensated for by the meter manufacturer printing nonlinear scales on the meter face. These special scales are almost always in red and clearly marked AC. These special scales only apply to the lowest one or two AC ranges of the meter. Be extra careful to always read the correct scale.

Input resistance.

A VOM does not have a fixed input resistance. It depends on the setting of the range switch. All VOMs have a sensitivity rating which is stated in ohms/volt (ohms per volt). To obtain the input resistance of a VOM, it is necessary to multiply the sensitivity by the setting of the range switch. The DC sensitivity of a Simpson 260 is 20,000 ohms/volt.

Example 2.3.

A Simpson 260 is set to the ten volt range and is indicating 5.1 volts. The sensitivity is 20,000 ohms/volt. What is the input resistance of the meter when set to this range?

Solution:

The voltage being indicated is extraneous information. The input resistance is the product of the range switch setting and the sensitivity. 10 volts times 20,000 ohms/volt = 200,000 ohms or 200 k ohms.

Example 2.4.

A Simpson 260 is set to the 10 volt AC range. The stated AC sensitivity is 5,000 ohms/volt. What is the input resistance?

Solution:

10 volts times 5,000 ohms/volt = 50,000 ohms or 50 k ohms.

It is a common mistake to multiply the scale reading by the sensitivity instead of the range switch setting. If that were so, the meter's resistance would be zero when its pointer was sitting on zero. The voltmeter would be a dead short and it would be impossible for a voltage to appear across it.

Voltage measurement and loading effect.

Whenever a voltmeter is connected to a circuit, the voltmeter draws current from the circuit and perturbs it. As you remember from fundamental circuit theory, every circuit can be reduced to a Thevenin equivalent. Figure 2.1 shows a voltmeter connected to such a circuit. A practical approximation for the percent error of a measurement is given by

% error = 100 % x RTh / RM           (2.1)

where RTh is the Thevenin resistance of the circuit under test and RM is the resistance of the meter as calculated in examples 2.3 and 2.4 above. This is simple enough to be estimated by a mental calculation as opposed to needing a calculator to work it out.

Figure 2.1 Voltmeter measuring output voltage of Thevenin circuit.

For a verbal description click here.

Typical accuracy for a VOM is approximately 2% of full scale. If we do not wish to perturb the voltage under test by any more than 2%, equation 2-1 tells us that RTH must be 0.02RM. For the conditions of example 2.3 RTH must be no larger than 4,000 ohms or 4 k ohms.

Example 2.5.

A Simpson 260 is set to the 10 volt AC range and is being used to measure voltages in a circuit. What is the maximum value the Thevenin resistance can have if the meter is to perturb the voltage by no more than 2 percent?

Solution:

Referring to example 2.4, the resistance of the meter is 50 k ohms. Solving equation 2-1 for RTH yields

RTh = RM x 0.02 = 50 k ohms x 0.02 = 1 k ohm

A Simpson VOM which is set to the 10 volt AC range can only be used to measure voltage in circuits with Thevenin resistances from 0 to 1 k ohm.

Example 2.6.

A Simpson 260 is set to the 2.5 volt DC range and is being used to measure voltage in a circuit which has a Thevenin resistance of 5 k ohms. The DC sensitivity is 20 K ohms/volt. What is the percent by which the meter will perturb the measurement?

Solution:

The resistance of the meter on the 2.5 volt DC range is 2.5 V x 20 k ohms/V = 50 k ohms. From equation 2-1

% error = 100% x (5 k ohms)/(50 k ohms) = 10%

As you can see, a VOM can only be used to measure voltage in very low impedance circuits. In spite of this it remains a very popular test instrument.

Resistance measurement.

Measuring resistance with a VOM requires an extra step and a different method of interpreting the readings. Most people prefer to use a digital meter to measure resistance. If a VOM is the only meter available, you should know how to use it to measure resistance.

The scale for measuring resistance is not the same as the voltage and current scales. First of all, the zero is at the wrong end of the scale. There is a very good reason for that. The scale is also very nonlinear. This scale is always at the top of the meter and is clearly labeled "OHMS".

The circuitry within a VOM applies a voltage from a battery to the resistor under test and measures the current. Ohm's law tells us that I=V/R. This is a nonlinear function, which is the reason why the OHMS scale on the VOM is nonlinear.

The range switch is not marked the same for resistance ranges, as it is for voltage and current ranges. A typical set of resistance ranges are as found on the Simpson model 260 VOM. These ranges are RX1, RX100 and RX10,000. These are read "Resistance times one", "Resistance times one hundred", and "Resistance times ten thousand".

This indicates that the scale reading is to be multiplied by the range switch setting.

Example 2.7.

A VOM is set to the RX1 range and the ohms scale is reading 12.5. What is the resistance being measured?

Solution:

To obtain the resistance, multiply the range switch setting by the scale reading. 12.5 times 1 = 12.5 ohms.

Example 2.8.

A VOM is set to the RX10,000 range and the scale is reading 1.6. What is the resistance being measured?

Solution:

1.6 multiplied by 10,000 = 16,000 ohms or 16 k ohms.

Adjusting the ohmmeter.

To make a resistance measurement, follow this procedure.

  1. Set the range switch to the range you intend to use.

  2. Clip the two test leads together.

  3. Adjust the ZERO ADJUST knob on the VOM to bring the pointer over the zero mark on the ohms scale.

  4. Unclip the leads from each other and clip them to the resistor to be tested.

  5. Read the scale and multiply by the range switch setting.

  6. If the pointer is far to the right or left of the scale, the reading will not be very accurate.

  7. Every time you change ranges you must repeat steps 2 through 5.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

2.2 The Electronic Voltmeter.

An electronic voltmeter or electronic multimeter contains an amplifier circuit between the input terminals and the readout device. This amplifier has a very high input impedance and enables the meter to be used to measure voltages in much higher impedance circuits than a VOM can measure.

The first form of electronic voltmeter was the vacuum tube voltmeter VTVM. For several decades the VTVM was the most common instrument to be found on the test bench.

When the age of the semiconductor came upon us, the vacuum tubes in the VTVM were replaced by field effect transistors. The name FETVM was too clumsy to catch on. TVM (Transistor Voltmeter) never caught on either. The name EVM (Electronic Voltmeter) was never tried. Heath company tried SSVM for Solid State Voltmeter. I don't really know if that one caught on with other manufacturers. In this text we will use EVM as a generic term for an analog meter containing vacuum tubes or transistors.

The input resistance of an EVM (electronic voltmeter) is typically 10 megohms. More costly units have an input resistance of 100 or even 1000 megohms. unlike the VOM the input resistance is the same for AC and DC. Also, the resistance is constant on all ranges. An EVM loads the circuit under test in exactly the same way as any other meter. The only difference is that the circuit resistance can be higher before the error becomes significant.

One reads the EVM in exactly the same manner as the VOM. The terms "range" and "scale" have the same meanings and should be used the same. Remember, the range is the setting of the range switch and the scale is the set of markings on the meter face.

The resistance ranges may operate differently than on a VOM. If you are using an EVM you should consult the instruction manual for that meter to determine how to adjust and read the meter on the resistance ranges.

The AC Voltmeter.

Some EVMs are especially designed to measure AC with good accuracy over a wide range of frequencies. The lowest range on these meters is usually 1 millivolt. Such meters are clearly labeled as AC Voltmeters and will not give any reading if used to measure DC.

This is the only area where analog EVMs are still extensively used. A typical frequency range for an analog AC Voltmeter (AC only) is from 5 hertz to 4 megahertz. These meters are AC only, If you try to measure DC you will get no reading or one which makes no sense.

The input impedance of such a voltmeter is typically 10 megohms in parallel with 100 picofarads.

An AC Voltmeter is used in trouble shooting wide band amplifiers such as video amplifiers where frequencies exist to which VOMs, other EVMs and even DMMs (digital multimeters) cannot respond. The AC Voltmeter will also find uses in low-level audio equipment where signal levels are too low for other meters to indicate.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

2.3 The Digital Multimeter (DMM).

Except for AC-only models, the analog EVM has largely been replaced by the Digital Multimeter (DMM). The low cost and small size of digital circuitry and digital readouts have just about put the EVM out of business.

Digital Multimeters are smaller, lighter, cheaper and more accurate than their analog counterparts. It is no wonder why you almost never see an analog EVM anymore. The only area where DMMs are behind is in measuring AC over a wide range of frequencies. A typical frequency range for a DMM is 40 to 5,000 hertz although more expensive models will usually read accurately out to 20,000 hertz. A typical analog AC Voltmeter (AC only) may have a frequency range of 5 hertz to 4 megahertz. But when it comes to DC voltage, current and resistance, the DMM is unsurpassed.

Little thought is required to use a DMM. The measurement units V (volts), mV (millivolts), k ohms (kilohms), M ohms (megohms), etc. are usually indicated in the display window. The decimal point is always put in the right place. If the display window contains 1.364 k ohms or 103.8 uA, you have the measurement. What you see is what you get. Some DMMs even select the correct range automatically, removing almost all operator intervention in their operation.

The input resistance of most low cost DMMs is 10 megohms. Higher cost instruments may have input resistances of 100 or even 1000 megohms. DMMs load the circuit under test as do all voltmeters. Equation 2-1 applies.

Example 2.9.

A DMM which has an input resistance of 10 megohms is being used to measure voltage in a circuit where the Thevenin resistance is 100 kilohms. What is the percent error introduced by the meter loading the circuit?

Solution:

From equation 2-1

% error = (100 k ohms)/(10 M ohms) x 100% = 1%

Although 1% error is small by analog standards, it is large by digital standards. If you are making a measurement under the conditions of example 2.9, the meter will give you 3 or 4 significant digits, but you must remember that the reading is 1% low.

Correcting Measurements.

Digital meters give so many significant digits that most users will read the display and take it as absolutely correct. This is a very bad habit to get into. The meter reading should be mathematically corrected if the error given by equation 2-1 is greater than 1%.

Referring to figure 2.1 the Thevenin resistance of the circuit and the resistance of the meter make up a voltage divider. If we rearrange the voltage divider equation we have

VTh = VM ((RM + RTh)/RM)           (2.2)

where RM is the resistance of the meter, RTh is the Thevenin resistance of the circuit, VM is the voltage being read on the meter and VTh is the voltage across the terminals when the voltmeter is not present.

Example 2.10.

A DMM with an input resistance of 10 M ohms is being used to measure the voltage in a circuit where the Thevenin resistance is 220 k ohms. The meter reads 12.52 volts. What was the voltage before the meter was connected?

Solution:

Using equation 2.2 we have

VTh = 12.52 v ((10 M ohms + 220 k ohms)/10 M ohms) = 12.80 volts.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

2.4 Choosing The Correct Test Meter.

It is important to use the correct meter for a given job. Using an inappropriate meter can at best give readings which are in error and at worst give nonsensical readings or even damage the meter.

Strong Electromagnetic Fields.

Making measurements in the presence of strong electromagnetic fields is a special but important case. Such fields are found around radio, television and radar transmitters, electrical substations and large electric generators or motors.

Modern day DMMs are housed in plastic cases. Plastic does not shield against electromagnetic fields. Many instruments have a shield consisting of a layer of metal foil which is coated with plastic to prevent shorting out the circuit board. This meager shield is totally inadequate to the job of preventing electromagnetic fields from entering the circuitry of the instrument.

Electromagnetic fields can so totally jam the circuits in a digital meter as to prevent it from working. Even if the meter appears to work, its readings will not be reliable. The circuits in an electronic analog meter (EVM) can be adversely affected by strong electromagnetic fields. Only the VOM has no internal devices which can be affected by these fields.

Meter Characteristics.

Table 2-1 summarizes the characteristics of the various types of meters.

The ranges listed in the table refer to full-scale ranges, not minimum measurement capability. For example, the VOM is listed as having DC current ranges from 50 microamps to 10 amps. That does not mean that 50 uA is the smallest current that can be measured; it means that the lowest range is 0 to 50 uA. The smallest current which can be measured with any reasonable accuracy is 5 uA.

Table 2.1.

Summary of Test Meter Characteristics.

³
Characteristic | VOM | EVM | DMM
DC Voltage
Ranges 		2.5 to
5000 V 		1.0 to
1000 V 		200 mV to
1000 V
DC Current
Ranges 		50 uA to
10 Amps 		None 200 uA to
2 Amps
AC Voltage
Ranges

*

 2.5 to
5000 V

 1.0 to
1000 V

1 mV to
300 V 		200 mV to
1000 V
AC Current
Ranges 		None None 200 uA to
2 Amps
Frequency
Ranges

*

 20 Hz to
20,000 Hz

 20 Hz to
20,000 Hz

5 Hz to
4 MHz 		40 Hz to
5,000 Hz
DC Input
Resistance 		20,000
Ohms/Volt 		11
Megohms 		10
Megohms
AC Input
Resistance 		5,000
Ohms/Volt 		10
Megohms 		10
Megohms
Resistance
Ranges 		RX1 to
RX10,000 		RX1 to
RX1M 		200 ohms to
20 M ohms
Accuracy | 2% | 2% | 0.05%
Susceptibility
to EMI 		Not Very
Susceptible 		Somewhat
Susceptible 		Very
Susceptible

EMI = Electromagnetic Interference.
* Data for AC-only electronic voltmeter.

When an EVM is set to the DC voltage range a 1 Megohm resistor is connected in series with the input at the probe tip. This is done either by using a special probe only for DC voltage or by a switch on the probe tip. The purpose for this resistor is to filter out AC including RF that might be present on the measured voltage or picked up by the leads. Many EVMs use a shielded lead after the resistor.

A few examples will give you some practice in choosing the correct meter for a given task.

Example 2.11.

You need to measure voltage, current and resistance in a laboratory and the accuracy needs to be as good as possible. What kind of meter would you use?

Solution:

EMI (electromagnetic interference) is not likely to be a problem in a laboratory setting. The need for accuracy indicates the use of a DMM (Digital Multimeter).

Example 2.12.

You need to measure AC voltages over a range of 2 to 10 volts and a frequency range of 20 to 20,000 hertz. The Thevenin resistance of the sources can be as high as 5 k ohms. There are no nearby sources of EMI. Which meter would you use?

Solution:

The frequency range of 20 to 20,000 hertz eliminates the DMM from consideration. A VOM set to the 10 volt AC range will have an input resistance of 5 k ohms/V x 10 v = 50 k ohms. The circuit resistance of 5 k ohms gives an error of (5 k ohms/50 k ohms) x 100% = 10%. The VOM is eliminated. That leaves us with some kind of EVM. An AC-only model would be preferable but an electronic multimeter would serve the purpose.

Example 2.13.

You need to measure AC voltage in the neighborhood of 2500 volts. Which meter would you use?

Solution:

The only meter with ranges above 1000 volts is the VOM.

Example 2.14.

You need to make measurements on an operating microwave oven. Which meter would you use?

Solution:

A microwave oven with its service covers removed is likely to be a strong source of EMI. The old reliable VOM is the instrument of choice here.

Example 2.15.

You need to measure voltages in the range of 0.5 to 3 volts at frequencies from 100 kHz to 1 MHz. Which meter would you use?

Solution:

While the voltage range might be accommodated by other meters, the frequency range dictates the use of an AC- only EVM.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

2.5 Analog Versus Digital Meters.

There are some who might say that the analog meter is on its way out, but they would be wrong. As mentioned earlier, the analog meter is almost immune to EMI (electromagnetic interference). In addition to this it is very good for showing changes in electrical quantities.

There are many cases in which an adjustment must be made for maximum or minimum current or voltage. While it is possible to use a digital readout for such an adjustment, an analog meter makes it much easier.

Suppose you are adjusting a control for a minimum current. When using an analog meter you do not actually read the scale of the meter. You watch the pointer moving to the left as you turn the control. When the pointer starts moving to the right, you reverse direction on the control and bring the pointer back to its left-most position. It is a matter of eye-hand coordination.

On the other, hand if you are using a digital readout to make the same adjustment, you do have to read the number on the display. As you make the adjustment you continuously read the number and do a comparison to the previous one. It's no longer a matter of eye-hand coordination; now the mind must remember a number and do calculations of sorts: "Is this number larger than or smaller than the other one?" This remembering and calculating takes more time and requires more mental effort than does eye-hand coordination.

"But wait a minute" I hear some of you saying. "What about bar graph displays?" Bar graph displays usually have ten elements which gives only 10% resolution. In tuning the output circuit of a radio transmitter the capacitor is adjusted for minimum amplifier current. This setting gives maximum power output and maximum efficiency of the amplifier. If a bar graph were used for this purpose the amplifier current would have to change by 10% of full-scale before any change could be detected by the operator. If a transmitter's output stage is operated 10% "off the dip" the output could be down by as much as 30% and the output amplifier could even be damaged.

This is but one example; there are many others in the field of electronics. It can be argued that there is no reason why a bar graph must be limited to ten elements. There is a reason, money. To match the resolution of an analog meter a bar graph would have to have at least 50 elements and 100 would be preferred. At the present state of the art, a 50 or 100 element bar graph readout is so costly as to be unfeasible. And don't forget that matter of EMI. Analog meter readouts will be with us for many years to come.

In service work there are many service adjustments which require making an adjustment for zero, minimum or maximum voltage or current. That is one of the strongest arguments for keeping a VOM on the service bench.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

2.6 The Oscilloscope.

Until the 1950s an oscilloscope was considered by many to be just a high tech toy. It was possible to look at the shape of electrical waves, but it was not possible to make any measurements. Looking at the waves is useful in some circumstances but, unless it is possible to measure the voltage and period of the wave, an oscilloscope is just a technical television set.

The technicians of those days had an oscilloscope calibrator of a sort. It was a source of square-wave voltage with "calibrated" dials on it for voltage and frequency. The idea was to switch from the wave being observed to the calibrator, match the voltage and frequency to that of the original wave and read the dials on the calibrator.

Enter the Tektronix company. Their first models had the calibrator built in and a convenient switch to select the input wave or the calibrator wave. Then one of their engineers asked the question, "Why not calibrate the scope the same way a voltmeter is calibrated, with ranges?" The rest, as they say, is history.

Today we take the calibrated oscilloscope for granted. I wonder how many students know that the scope began life as described above.

The instrument is known by several different names: "oscilloscope", "o'scope", "'scope", "scope" and one author referred to it as the "CRO" (cathode ray oscilloscope). Whatever else you may call it, call it the most useful instrument on the service bench.

What an Oscilloscope Can Do.

In addition to giving us a pretty picture show, an oscilloscope can measure voltage and time interval. A clever technician armed only with a scope and a decade resistance box can measure current and resistance as well.

The modern-day oscilloscope is very accurately calibrated in volts per division on the vertical axis and in seconds per division on the horizontal axis. The display is a visual display of instantaneous voltage versus time. Such displays can give information not available using any other instrument.

For example, ripple in a power supply can render circuits inoperative but may not show up on any test meter. The problem will be readily apparent on an oscilloscope.

The following is not intended as a thorough tutorial on "how to use an oscilloscope". That can only be done if the tutorial is written for a particular make and model of oscilloscope. It is assumed that the student is familiar with oscilloscope controls and operating procedure. This section should bring together all of the fragments of knowledge you have acquired in the past few years.

Reading An Oscilloscope.

It is as important to know how to read an oscilloscope as it is to know how to read any other test instrument.

To obtain the voltage between two points on a wave, it is necessary to perform the following steps: a) Measure the vertical distance between the two points (in divisions and fractions of a division). b) Multiply the distance by the setting of the volts/division range switch. c) If a times ten probe is being used, multiply the voltage by ten.

Example 2.16.

For a wave on the screen of a scope the distance between the positive peak and the negative peak is 5.6 divisions. The setting of the vertical range switch is 100 mv/div. A times one probe is being used. What is the peak to peak voltage of the wave?

Solution:

The peak to peak distance has been given as 5.6 divisions. 5.6 divisions times 100 mv/division = 560 millivolts or 0.56 volts. The use of a times one probe means that the voltage must be multiplied by one.

To obtain the time between two points on a wave, it is necessary to perform the following steps: a) Measure the horizontal distance between the two points (in divisions and fractions of a division). b) Multiply the distance by the setting of the time/division sweep range switch.

Example 2.17.

For a wave on the screen of a scope the distance between two successive positive going zero crossings is 8.3 divisions. The setting of the sweep range switch is 0.5 ms/div. A times ten probe is being used. What is the period of the wave?

Solution:

The fact that a times ten probe is being used has no effect on the time reading. The wavelength has been given as 8.3 divisions. 8.3 divisions times 0.5 ms/division = 4.15 milliseconds.

The Times Ten Probe.

The input impedance of almost all oscilloscopes is one megohm of resistance in parallel with 30 picofarads of capacitance. That presents problems.

The resistance portion means that if we want plus or minus 2% accuracy the highest Thevenin resistance a circuit could have is 20 k ohms. That would considerably restrict the use of a scope but that's not all.

Capacitance added in parallel with a circuit presents a load at higher frequencies and slows down the rise time of square-waves and pulses. In most cases, calculation of this effect is too complex to be worth the effort. The best approach is to make the capacitance as small as physically possible.

The input capacitance of the scope by itself would not be so bad but there is more.

If you have ever touched the input terminal of a scope, or connected an unshielded wire to the input of a scope, you know that there are signals in the air which can be picked up by the wire (or your body) and displayed on the scope. If you are trying to look at a 130 kHz triangular wave, you don't want 60 Hz mixed with it. That is what you can have if you don't use shielded cables to connect circuits under test to the input of an oscilloscope.

Shielded cable consists of two conductors separated by an insulator, the definition of a capacitor. Typical cable capacitance is 30 picofarads per foot of cable. Typical cable length is 4 feet. The input capacitance now becomes 4 ft. x (30 pf/ft.) + 30 pf = 150 pf.

150 picofarads has a reactance of 20 kilohms at a frequency of 53.1 kilohertz. That says that 150 pf is much too much to have in parallel with a test instrument.

Figure 2.2 Schematic of X10 Probe.

For a verbal description click here.

It is possible to increase the input resistance and decrease the input capacitance of a scope by giving up some sensitivity. Figure 2.2(a) shows a drawing of a times ten probe and 2.2(b) the schematic diagram. The scope is presumed to have an input impedance of 1 M ohms resistor in parallel with a 30 pf capacitor. The variable capacitor in parallel with the 9 Megohm resistor would be physically inside the probe.

The frequency response of the circuit will be flat if

R1 C1 = R2 C2           (2.3)

is satisfied. Where R1 is the 9 Megohm resistor in the probe tip, C1 is the variable capacitor in the probe tip, R2 is the 1 M ohms resistor which represents the input resistance of the scope and C2 is the sum of the cable capacitance and the input capacitance of the scope 150 pf. If we solve equation 2.3 for C1 and plug in all known values, we have C1 = (1 M ohms x 150 pf)/(9 M ohms) = 16.7 pf. The effective input capacitance is C1 in series with C2 which is 15 pf. That's a lot better.

The effective input resistance is R1 in series with R2 which is 10 M ohms. That's also a lot better.

To sum it all up, by using a times ten probe the input resistance goes up by a factor of ten and the input capacitance goes down by a factor of ten. The voltage applied to the input of the scope is 1/10 of that applied to the probe tip.

Example 2.18.

The following information is obtained using an oscilloscope. Peak to peak voltage is 125 millivolts and period is 22 milliseconds. A times ten probe is being used. What are the actual voltage and period.

Solution:

The voltage is ten times what is measured, 125 mv x 10 = 1.25 volts. The times ten probe has no effect on the period measurement.

Adjusting the Times Ten Probe.

Before a times ten probe is used it must be adjusted to match the particular scope that is in use. As indicated in figure 2.2 the variable capacitor is in the probe tip but in some probes the adjustment is at the scope end of the probe cable. This is accomplished by making the capacitor at the probe tip a fixed value and a little larger than the theoretical value and placing a variable capacitor in parallel with the scope and cable capacitance, C2, placing it more conveniently at the scope end. Wherever it is it must be adjusted.

All oscilloscopes have a square-wave output which has been put there for exactly this purpose. If the probe has a switch to select X1 (times one) or X10 (times ten), be sure it is in the X10 position. Connect the probe tip to the square-wave output and adjust the controls on the scope to obtain a stable display of the square-wave.

Figure 2.3 Square-wave for (a) undercompensated probe
(b) properly compensated probe and
(c) overcompensated probe.

For a verbal description click here.

If a screwdriver is required to adjust the probe, use a plastic one. Refer to figure 2.3. Figure 2.3a shows the condition of not enough capacitance, under compensation, while figure 2.3c shows the condition of too much capacitance, overcompensation. Figure 2.3b is just right, correct compensation. If it is not readily apparent how to adjust the probe, consult the instruction manual.

AC, DC and Ground.

All but the least expensive scopes have a switch located near the input connector which is labeled "AC DC GND" for AC, DC and ground.

When this switch is set to the AC position, a capacitor is connected in series with the input to the scope. This capacitor will block DC from the input but will pass AC. The size of the capacitor is usually chosen so that the low frequency limit will be about 2 hertz. The upper frequency limit is set by the amplifiers in the scope and is uneffected by the setting of the switch.

In the DC position the scope responds to both AC and DC. The capacitor mentioned above is shorted out. The response of the scope is from DC (zero frequency) to the upper frequency limit of the scope. This makes it possible to use the scope to measure DC voltage the same as you would with a voltmeter.

When the switch is set to the GND (ground) position the input to the vertical amplifier is grounded. The input resistance (as "seen" by the circuit under test) is not affected so that the circuit under test will not be damaged. In many measurements, especially those involving DC, it is essential to know where the trace would be if the input voltage to the scope were zero. Instead of disconnecting the probe, all that is necessary is to flip the input switch to the GND position, note the position of the trace (or use the positioning control to put it where you want it) and then flip the input switch back to DC or AC.

Example 2.19.

Figure 2.4 represents the display of a DC + AC voltage on an oscilloscope. When the input switch is set to ground, the trace is positioned one division up from the bottom of the screen, or at Y = -3 divisions. In figure 2.4a the scope operator has used the horizontal positioning control to set the most positive peak on the line of hash marks. In figure 2.4b the horizontal positioning control has been adjusted to put the least positive peak on the line of hash marks. This is what you would do if you were in a laboratory instead of reading a book. The settings of the scope controls are as follows: input switch to DC, Vertical range to 0.2 v/div and sweep range to 5 ms/div. A times ten probe is being used. What is: (a) the peak to peak voltage; (b) the voltage of the most positive peak; (c) the voltage of the least positive peak; and (d) the period of the wave?

Figure 2.4 Scope screens for Example 2.19.

For a verbal description click here.

Solution:

The only difference between figures 2.4a and 2.4b is that the horizontal positioning control has been changed. Figure 2.4a reveals that the most positive peak is 3.4 divisions above the center line and figure 2.4b reveals that the least positive peak is 0.6 divisions below the center line.

(a) The peak to peak distance of 3.4 div - (-0.6 div) = 4 divisions. 4 div x 0.2 v/div x 10 = 8 volts peak to peak.

(b) The voltage of the most positive peak is measured from the zero voltage line. As given, the zero volt line is one division up from the bottom of the screen or 3 divisions below the center line. The distance between zero volts and the most positive peak is 3.4 div - (-3 div) = 6.4 divisions. 6.4 div x 0.2 v/div x 10 = 12.8 volts.

(c) The distance between zero volts and the least positive peak is -0.6 div -(-3 div) = 2.4 divisions. 2.4 div x 0.2 v/div x 10 = 4.8 volts.

(d) We must use center line crossings in order to have the hash marks to read. Selecting two successive positive going center line crossings we have the wavelength as 4 divisions. The period is 4 div x 5 ms/div = 20 ms. The times ten probe has no effect on the time measurement.

Getting Best Accuracy.

Using modern oscilloscopes with some care it is possible to obtain accuracy equivalent to that of an analog meter. There are certain things you can do to maximize the accuracy of the measurement.

For voltage and period measurements keep the vertical deflection large. The large divisions are subdivided by the hash marks into 5 subdivisions. It is possible to mentally insert 4 sub-subdivisions between the hash marks. That means that the best resolution is 1/20 of a large division. That is the ideal case. In actual practice it is more likely that the best resolution is 1/10 of a large division.

If you only have a vertical deflection of one large division, the typical accuracy is about (0.1 div)/(1 div) x 100% = 10%. If the vertical deflection is about 6 large divisions the typical accuracy is about (0.1 div)/(6 div) x 100% = 1.7%. 2% accuracy is about the best to be expected.

For period measurements have several cycles on the screen. Also, measure from zero crossing to zero crossing, not peak to peak. The horizontal position of the rounded peak of a sine wave cannot be determined with any accuracy.

If the vertical deflection is large and there are several cycles on the screen, the zero-crossings will be almost vertical. Suppose you tried to measure the period from one positive peak to the next. You would be trying to determine the exact point of tangency of the curved peak of the wave to the scale, not an easy thing to do. When an almost vertical line crosses a horizontal scale it is easier to determine the exact point where the crossing takes place.

If you measure the time for four or five cycles, the accuracy of the measurement will be improved. If you measure the period of just one cycle, the distance will be rather small and the same argument will apply as for the vertical deflection. Measuring over several cycles increases the distance of the measurement and increases the accuracy.

Trigger Modes.

In olden days the horizontal sweep was generated by an oscillator with a sawtooth wave form. To get a stationary pattern on the screen it was necessary to synchronize the sweep oscillator with the input signal. Today's scopes use a triggered sweep instead of a synchronized sawtooth oscillator.

The key difference is that an oscillator keeps on running at approximately the same frequency even in the absence of an input signal. A triggered sweep begins when a trigger pulse is received, completes one cycle and then waits for the next trigger pulse before beginning the next cycle. If the trigger pulses stop, the sweep stops.

The "auto" mode is to keep a visible trace on the screen in the absence of an input signal. If you put the input switch in the GND position, you want the trace to be on the screen so you can see where it is. A special circuit senses that there are no trigger pulses and generates artificial trigger pulses. These pulses are removed when real pulses are present. Like any other automatic circuit it can sometimes get confused and cause the pattern on the screen to be unstable. When this happens, you should switch out of the auto mode. If you want to use the GND position on the input switch, you will have to put the trigger back into the auto mode. Someday it will occur to some engineer (who can do something about it) to cause the trigger circuits to go into the auto mode whenever the input switch is placed in the GND position.

The Slope switch selects whether the sweep will trigger on the positive going or negative going slope of the input wave.

The level control sets the voltage level at which the sweep will begin.

Trigger coupling modes come in a wide variety of shapes and sizes. A few of them are DC, AC slow, AC fast, AC lf, AC lf rej, (reject), TV, TVh, TVv, TVl and TVf. DC is a full spectrum coupling. It is used for slowly changing, infrequently occurring or DC restored video signals. AC slow and AC lf are for low frequency sine or sine like waves. AC fast and AC lf rej are for square-waves, pulses or high frequency sine waves. TV is a general television trigger mode. In some scopes the horizontal or vertical sync pulses are selected depending on the setting of the sweep range switch. TV h (horizontal) and TV l (line) select the horizontal sync pulses from the TV signal to be fed to the trigger circuits. TV v (vertical) and TV f (frame of field) select the vertical sync pulses.

For complete information you should consult the instruction manual for the particular scope you are using.

Measuring Current and Resistance Using a Scope.

Earlier it was mentioned in passing that it is possible to measure current and resistance using a scope. How is that possible? A decade resistance box would come in handy but all you really need are a few precision resistors.

Measuring current is easy and maybe some of you have figured that one out already. Simply place a resistor, say one ohm, in parallel with the input of the scope. The ranges on the vertical range switch become current ranges. For example, using a 1 ohm resistor the 100 mV/div range becomes 100 mA/div. The resistor should have sufficient wattage rating to carry the current being measured. Also remember that if the voltage drop becomes too great, you will perturb the circuit under test and the current measurement will be in error.

Measuring resistance requires a bit more ingenuity. All scopes have a square-wave signal output for compensating the probe. This output is used in the circuit of figure 2.5. Since one side of the circuit is connected to the scope's own ground it is not possible to measure the voltage across each resistor individually. Measure the voltage across the reference resistor RR and then measure the voltage across the series combination of RR and RX. This last voltage is of course the output voltage of the square-wave output. For best accuracy the voltage across the reference resistor should be about half of the square-wave output. The unknown resistance is given by

RX = RR (VS - VR)/VR           (2.4)

where RX is the unknown resistance, RR is a known reference resistor, VS is the voltage of the square-wave source and VR is the measured voltage across the reference resistor.

Figure 2.5 Resistance Measurement with an Oscilloscope.

For a verbal description click here.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

2.7 The Signal Tracer.

A signal tracer is an old instrument that was used primarily to troubleshoot radios back in the tube era. If you are interested in restoring Antique radios I strongly recommend that you buy or build one. The basic instrument was an audio amplifier and a speaker built into an instrument box. Some units such as the Heathkit T-4 also contained an eye tube. This seems to me to be just to dress up the instrument and serves little practical purpose. They are old enough to be considered antiques and if you buy one off eBay you will likely pay too much. Even if you have to buy all new parts you will likely pay less to build your own. Below is a practical circuit.

Figure 2.6 Signal Tracer.

For a verbal description click here.

The output transformer is a standard 5 k ohm to voice coil and may be scavenged from an all American 5 if desired. The power transformer has a higher current rating than needed but one just above it on the AES page which had a lower current range costs a dollar more. If desired you could use the extra current capacity to power experimental circuits.

If you prefer you can substitute a 6AQ5 for the 6V6. No component changes are necessary to change the tube. Remember that the pin numbers are different.

Oscillation.

It is very likely that this circuit will oscillate when there is nothing connected to the input and the volume control is turned up all the way. The 470 pf cap from the grid of the 6V6 to ground is meant to help but it won't prevent it completely. It will insure that it will be audible. My Heathkit T-4 and the amplifier in the combo power supply and amplifier do. It can be prevented by using a lot of shielding between the output tube and transformer and the 12AX7. It really doesn't hurt anything though.

As you can see this is nothing more than an audio amplifier with a whole lot of gain. It is useful for tracing signals through the audio section of a radio. A shielded probe should be used and a scope probe is a very good choice. Get one that has a times 1/times 10 switch on it. Of course you will have to mount a BNC connector on the tracer to make use of a scope probe.

Radio Frequencies and Intermediate Frequencies.

So how does one trace signals through the RF and IF stages of a radio? Here is how.

Figure 2.7 RF Probe for Signal Tracer.

For a verbal description click here.

You can use 1N4149 diodes if you want but performance will be much improved if you use germanium diodes instead. If you can get them or their equivalents 1N270 or 1N933 diodes will perform much better. If you can't get those 1N34A diodes will work just fine. The first capacitor in line should have a voltage rating of 500 volts because it will regularly come into contact with B+ voltages.

This probe has the advantage over the one supplied with the Heathkit T-4. It filters out low frequencies and responds only to frequencies higher than 50 kHz. In a departure from the usual quality Heath engineering the T-4 was supplied with a simple probe that didn't work very well. The manual admits this by saying that the probe should not be connected to the plate of a tube because all the operator will hear is 60 Hz hum from the power supply. Using this probe that will not be a problem.

The probe should be shielded to avoid the effects of hand capacitance but the metal shield should be covered with some kind of insulating material. It is not safe to work on a radio that has lethal voltages in it while holding a grounded probe in your hand.

Another use for the probe is to measure RF voltages. The DC output of the probe is very close to the peak to peak value of the input wave. If it is a good sine wave the RMS value of the wave is Vdc / (2 Square root of 2).

Also, do not be tempted to leave out the power transformer! Some of the radios you will be working on will be of the line connected chassis type and having two pieces of hot chassis equipment on your workbench is a catastrophe waiting to happen.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

2.8 Miscellaneous Test Equipment.

There are many different pieces of test equipment. Some are not well known. Some pieces of test equipment are designed to test one particular make and model of apparatus. These are usually referred to as "test sets" rather than test instruments. Test sets cannot be covered in a book such as this. They are issued to franchised service agencies and field service persons. Training in their use comes from the manufacturer.

Signal Sources.

Signal sources are used in the signal substitution or signal injection methods of testing to be covered in chapter 4 of this book.

There are three general categories of signal sources (more often called signal generators). They are 1) audio frequency, 2) radio frequency, and 3) pulse generators.

Audio frequency generators come in a wide variety of makes and models. The minimum acceptable frequency range is 20 to 20,000 hertz but most technicians prefer a range of 5 hertz to 1 megahertz. Generators are available which provide low distortion sine waves (.05% or less). The most familiar, however, is the function generator which provides sine, square and triangular waves. The distortion of the sine wave is usually in the range of 0.3% to 1%. A typical frequency range is from 1 hertz to 2 megahertz. The Thevenin output resistance of these generators is usually 50 ohms. Some function generators also provide outputs which are compatible with digital logic circuits. For details on operating procedure consult the instruction manual for the particular make and model you are using.

Radio frequency generators are further subdivided by the part of the radio spectrum they cover. For example a Hewlett-Packard model 606A is called an HF (high frequency) signal generator. It covers the range 50 kHz to 65 MHz. Granted, the HF spectrum is from 3 to 30 MHz but they didn't want to call it a "most of LF, MF, HF and part of VHF signal generator". As you can see from this example there is considerable overlap of AF (audio frequency) and RF (radio frequency) generators.

The one feature which distinguishes an RF generator from an AF generator is calibrated output voltage and power level. All RF generators worthy of the name use a combination of an output level meter and a well-calibrated attenuator to provide an output level which is known. The level is measured across a 50 ohm load and usually ranges from 0.1 microvolts to about 1 volt. Upper limits vary from one model to the next and can range from 0.2 volts to 3 volts.

Some high-priced AF generators may also have calibrated output levels, the minimum level usually about 1 millivolt. Only an RF generator will have a minimum output of 0.1 microvolts.

Pulse generators are used to stimulate logic circuits. They have outputs which are compatible with various integrated logic families such as TTL (transistor transistor logic), CMOS (complementary metal oxide semiconductor), ECL (emitter coupled logic) and others.

The pulse width and frequency are independently adjustable. There are frequently provisions for external triggering or triggering from the operation of a pushbutton switch.

Logic Probe.

A logic probe looks simple but can be quite complex. In general it has two indicator lights, one for a low logic level and the other for a high logic level. You might think that one light would do but if no lights are on, the probe is indicating an open circuit on its input.

If the logic probe is testing a pulse train of say 20 PPS (pulses per second) or higher, the lights will flash off and on too fast for the eye to perceive as flashes and they will look as if they are on continuously. A good logic probe will contain circuits which force the lights to flash slowly enough to be perceived as flashes.

Thus you have an unambiguous indication of logic low, logic high, open circuit or pulse train.

A logic probe must be compatible with the logic family with which it is being used.

Continuity Tester.

A continuity tester is a device which gives an indication when the resistance between its test leads falls below some preset value such as 100 ohms. The indication can be either visual or oral or both.

Many logic probes incorporate a continuity test mode.

Continuity testers are good for testing fuses, switches, line cords and even diodes. Although they are employed primarily by technicians who work on power or telephone circuits they can be a handy tool for the electronics technician as well.

Test Lamp.

A test lamp has the advantage over a voltmeter of being smaller and much less hassle to use. If the user desires to know if the voltage is present or absent, it is just what the doctor ordered.

In its most common form a test lamp is a neon lamp with a current limiting resistor in series with it. It may be housed in a small plastic cylinder and be equipped with a pocket clip. It will have two test leads emerging from it. The test lamp is used to check for the presence of AC line voltage.

You can also make your own test lamp. A six volt lamp makes an excellent quick tester for the presence of five volt power in a computer circuit.

AC Ammeter.

There is a class of AC ammeters which requires no direct connection to the circuit under test. They sense the magnetic field around a wire carrying AC. This magnetic field is directly proportional to the amount of current in the wire.

These meters have a spring loaded clamp which can be opened by squeezing a handle on the meter. The clamp is opened and allowed to close around, not on, the wire in which the current is to be measured.

The clamp must be placed around one wire. If you put the clamp around a lamp cord (two wires) the meter will read zero. The reason for this is each wire in the lamp cord is carrying current in the opposite direction to the other one. Because this is a series circuit, the current in each wire has the same magnitude. The two equal and opposite currents cancel each other out and there is no reading on the meter.

These meters are often called "amprobes" but Amprobe is a registered trademark.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

2.9 Instruction Manuals.

It is a common joke among technicians and engineers that, "When all else fails, read the instruction manual." This expresses the reluctance of most technical people to admit that they don't know something. There are, however, times when you should consult the instruction manual.

If you have encountered a familiar piece of equipment such as an oscilloscope, you may feel as if you know how to use a scope and don't need the manual. But if it is one of those new digital models (with no knobs, just push buttons) you will likely be sufficiently stumped to need some help.

If the equipment is unfamiliar you should by all means "read the book". There are only a few combinations of control settings which will work and an infinite number which will not work. The odds of hitting a working combination by random turning of knobs are vanishingly small.

Don't be ashamed to "read the book". There's no shame in that. No one was born all knowing.


Troubleshooting Chapter Three. Failure Modes.

Chapter 3   Failure Modes.

3.1  Generalized Failure Modes.
3.2  Electrolytic Capacitors.

Chapter 3.

Failure Modes.

It is possible to spend an entire career studying the failure modes of electronic components. In this chapter we will cover only the electrical characteristics of failed components.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

3.1 Generalized Failure Modes.

Electronic components usually fail in a specific way. That is a good thing; it makes the job of troubleshooting easier than it would be if components failed in random ways.

For example, capacitors almost always fail shorted while resistors almost never fail shorted. If there is a parallel combination of a resistor and a capacitor and the combination is found to be shorted, we can be almost certain that the capacitor is at fault.

The word "almost" appears in these statements because we are dealing with probability and there are no absolute certainties, only very high probabilities.

Resistors.

Photo of 3 resistors.

Picture 3.1 Example Resistors.

In the photo above the top resistor is a 330 k ohm 10% 1 watt carbon composition, the middle one is a 68 ohm 5% 1 watt carbon film, and at the bottom is a 27 k ohm 5% 1/4 watt carbon film resistor.

Components fail in the way they do because of the way they are constructed. Resistors are constructed in two main ways. One type is known as carbon composition. It is made by mixing up a concoction of finely powdered graphite, an equally finely powdered insulating material and some kind of glue. The brew is molded into a small cylinder and dried. The lead is in the form of a nail as shown in Figure 3.1.

Figure 3.1 Construction of Carbon Composition Resistor.

For a verbal description click here.

The two leads are placed in contact with the ends of the cylinder and the assembly is encased in molded plastic. Color code bands are painted on the finished resistor. The force exerted by the lead's "head" against the end of the cylinder is the only connection between them. I have seen such resistors in which it was possible to rotate the resistor body on its leads. Needless to say the amplifier was very noisy especially when shaken.

The other type is carbon film or metal film. They are made by coating a ceramic or plastic cylinder with graphite or metal. Metal cups are placed over the ends of the cylinder and crimped in place to make good electrical contact with the film. The cups have leads attached as shown in figure 3.2.

Figure 3.2 Construction of Film Resistor.

For a verbal description click here.

The assembly is then placed in a lathe where a laser starts cutting a helical path in the conductive coating turning it into a coil of conductor surrounding the insulating cylinder. The resistance is being measured continuously and when it reaches the desired value the laser is turned off and the resistor goes on to have its body encased in plastic. Color bands are then painted on. The end contacts are what gives these resistors their characteristic shape.

Carbon composition resistors can be reduced in value by excessive heat which turns some of the glue from the original mix into carbon. I have seen a 100 ohm resistor be reduced to 11 ohms by being burned to a crisp. However, this is rare. They usually increase in value with age and can totally fail open or become noisy as described above.

Film resistors are much more reliable because of the crimped connections. They hold their original value very well and rarely fail spontaneously. They can even remain very close to their value after some serious overheating.

Capacitors.

Photo of 3 capacitors.

Picture 3.3 Example Capacitors.

Capacitors are constructed of two thin pieces of metal foil with a very thin insulator between them as shown in Figure 3.3.

Figure 3.3 Construction of Plastic Film Capacitor.

For a verbal description click here.

Here the most likely failure is in the insulator, which will allow the two metal foils to touch, causing a short.

It is possible for the connection between the foil and the wire (which runs through the case to the outside world) to come loose causing an open circuit, but this is a low probability occurrence.

Capacitors are constructed by starting with a long strip of a sandwich consisting of a layer of aluminum foil, a thin film of plastic, another layer of foil and another layer of plastic film. The strip is rolled up to form a cylinder. The sandwich is made so that one of the foils sticks out slightly on one side and the other sticks out the other. Thus, the two foils are exposed one on each end. The connecting lead is made to resemble a nail. The head of the nail, where the hammer would hit it, is spot welded to the foil on the end of the cylinder. The whole thing is encased in plastic.

Transformers, Chokes, and other coils.

Components which consist of a coil of wire such as transformers, inductors and TV deflection yokes have two main failure modes. The wire can break or burn in two (probably due to a manufacturing flaw) causing an open circuit or the insulation on the wire can fail causing a short.

An open is quite easy to diagnose. Testing with an ohmmeter will show infinity on the defective winding.

A short may be a little more subtle. Unless the transformer is absolutely cooked the short is likely to be over one turn. One turn out of hundreds is not enough change in resistance to show up on a DC resistance measurement. In the case of a transformer when power is applied a high current will flow and if the fuse doesn't blow the transformer will get hot very quickly and emit a bubbling sound as wax or varnish inside begins to boil. There is no saving such a transformer. It must be replaced. In the case of a choke its inductance value will be reduced to a small fraction of its normal value. An inductance bridge or meter will be required to diagnose such a defect. In the case of a TV deflection yoke the picture will b askew and either the vertical or horizontal output tube will be overheating due to too much current. Possibly to the point of having its plate glowing red. The coil of a DC relay may not be effected by a shorted turn and may operate for decades undetected. On the other hand a shorted turn in the coil of an AC relay will cause it to draw too much current and also prevent enough magnetic field from being developed to close the contacts. In a few cases it may be possible to disassemble the relay and replace the coil. In most cases the entire relay must be replaced.

Semiconductors.

When semiconductor devices fail spontaneously, which is rare, they don't fail in a binary manner. What usually happens is that a lead which was welded to the crystal in the factory comes loose. Because there is no force to move the lead away from the crystal they will remain in contact, sort of. If the device is a transistor in a radio or amplifier the result will be static in the speaker. Shaking or slapping the radio or amplifier may or may not effect the crackling sound.

In a radio the bad transistor can usually be found by half splitting although you must be aware that changing impedance as the contact makes and breaks will change the load on the previous stage and cause the defect to appear at the output of the stage previous to the one with the defective transistor.

In a stereo amplifier the presents of negative feedback will cause the static to propagate around the entire feedback loop and no amount of signal tracing will locate the defective device. In such cases the only solution is to unsolder a component such as a resistor to open the feedback loop but BEWARE! In many stereo amplifiers the same feedback loop serves to stabilize the DC operating point as well as provide AC feedback for performance improvement. Opening such a loop will usually result in the output of the amplifier locking to one of the power supply rails. This could damage the amplifier giving you more defective parts to find and replace. In such a case try temporarily replacing the feedback resistor with two resistors in series, each half the value of the original. If there was a capacitor in parallel with the resistor temporarily remove it. Connect a capacitor from the junction of the two resistors to ground. The capacitor to ground should be of such a value that it forms a 10 second time constant with the parallel equivalent resistance of the two resistors. This allows the DC feedback to remain effective while the AC feedback is removed. It should now be possible to find the source of the noise by signal tracing.

When a semiconductor device fails as a result of some other component failure the semiconductor was destroyed by heat. When the silicon crystal is heated it eventually gets hot enough to melt. This results in a short between all leads of the device. As noted elsewhere in this text, the short can result in the current being so high that the wire leads or the crystal itself are burned away leaving an open circuit. Open is a secondary failure mode.

On rare occasions the semiconductor crystal will get just hot enough for the doping impurities to defuse in the crystal which will change the characteristics of the device. The usual result is that the breakdown voltage of junctions is reduced. Meaning that a transistor will no longer operate at the applied collector voltage or a diode will conduct somewhat in the reverse direction. If this rare failure mode occurs it may be very hard to find because it is so rare and is not expected. If the early breakdown does not finish off the device it may turn into a real dog. Transistors and diodes which appear to be good in an out of circuit test may still not work in the circuit.

Summary of Failure modes.

The failure modes of the most common components are summarized in table 3.1.

Table 3.1.

Summary of Failure Modes of a Few Electronic Components.

Component High Probability
Failure Mode(s) 		Low Probability
Failure Mode(s)
Resistor Open

Resistance value
increased 		Resistance value
decreased
Capacitor,
Film 		Shorted

Leaky (Effective
parallel resistance
too low) 		Open
Capacitor,
Electrolytic 		Shorted

Leaky (Effective
parallel resistance
too low)

Effective series
resistance increased

Open
Inductor

Transformer

Relay coil

Deflection
yoke 		Open

Shorted
Diode Shorted Open
Transistor Base to Emitter
short

Base to Collector
short

Everything to
everything short 		Intermittently
noisy

Open
Operational
Amplifier 		Output shorted to
one power supply rail 		Low input
resistance
Digital IC Output shorted to
ground or V+
Vacuum
Tube 		Low cathode
emission, (weak)

Shorts between
elements 		Heater or
filament open

Cascading Failures.

Failures can cascade. Consider the case of the simple power supply of figure 3.4. This is a typical circuit of those power supplies which are in plastic cases with AC plug prongs on them. These are often called "wall mounted" power supplies or wall warts. You will note that there are no fuses in the circuit.

Figure 3.4 Schematic of Wall Wart.

For a verbal description click here.

Most recently made wall warts have some sort of fuse built into the transformer. This may be a current sensing or temperature sensing fuse. In either case it is a one time only operation and if it is burned out the entire wall wart must be replaced. The cost of obtaining a replacement transformer will most likely be about equal to the cost of a new wall wart.

If you have to repair a very old wall wart that has an unusual voltage making it impossible to replace you may have to saw it open and work on it. If so the paragraphs below will apply. These paragraphs will also apply to a power supply that is built with discrete components.

The failure could begin with a shorted filter capacitor. This causes the diodes in the bridge rectifier to overheat and eventually one or more will become shorted. This puts a very heavy load on the transformer causing it to overheat and develop shorted turns. This causes the transformer to draw even more current and get even hotter. The user may not know that anything is wrong until he or she smells the transformer burning and by then it is too late.

It is very common for failures to cascade in this manner. The first fault you find may be a symptom rather than a cause.

In the example of the power supply above, suppose that the transformer had been protected by a fuse. In that case the diodes would have likely shorted out anyway because of one of Murphy's laws, "An expensive semiconductor device protected by a fuse will protect the fuse by burning out first." Therefore, when the power supply comes to your service bench it will have a shorted filter capacitor and one or more shorted diodes. If you replace the faulty diodes and the fuse and apply power you will just burn out some more diodes and another fuse.

The table lists open semiconductors as a low probability occurrence. You may find open semiconductors in the normal course of service work. This most likely is a secondary failure mode.

In some circuits if a transistor shorts, an excessive amount of current can flow. This excessive current can cause the fine wires inside the transistor to melt, thus producing an open circuit. First the transistor shorts and second it burns open. That is a secondary failure mode.

Secondary failure modes are hard to predict in general because they depend on the circuit. In general if a secondary failure occurs, other components will be taken out as well.

The matter of secondary failures and cascading failures will be dealt with as they come up in specific circuits.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

3.2 Electrolytic Capacitors.

Picture 3.5 3 Electrolytic Capacitors.

For a verbal description click here.

Electrolytic capacitors are unique enough to warrant a section of their own. In the picture above top is a two section can electrolytic. The negative end of both capacitors is connected to the can and the positive ends are brought out to the two large lugs. A capacitor of this type mounts in a special cutout made in the chassis in a factory or more often mounts on a mounting plate which has slots for the four smaller lugs that are around the edge of the bottom of the can. These capacitors are made with up to 4 separate capacitors in one unit.

Next is a single 450 volt capacitor that is used in tube circuits. Below that is a small 25 volt capacitor that is found in transistor circuits.

All of these capacitors have positive and negative terminals. Reversing the polarity can be catastrofic.

Electrolytic capacitors are an exception to the rule that capacitors rarely fail open. They are made similarly to conventional capacitors as described above but the insulator is a porous paper instead of plastic film. The paper is impregnated with an electrolyte usually an acid. During the manufacturing process each capacitor is connected to a current source. This causes a layer of aluminum oxide to form on the positive foil. As the voltage increases the oxide layer becomes thicker and the process is terminated when the voltage reaches about 1.5 times the intended working voltage. This process is known as forming the capacitor.

The paper is not the insulator, dielectric, of the capacitor, the oxide layer is. The aluminum foil is the positive plate, the oxide layer is the insulator and the electrolyte in the paper is the negative plate.

A common failure mode in equipment which has never worked is for the capacitor to be reverse polarized. Electrolytic capacitors are used in power supplies. If someone connects one backwards the capacitor will conduct a substantial direct current. This current heats up the capacitor interior and when it gets hot enough the water in the electrolyte turns to steam, pressure builds up inside the container and the capacitor literally explodes. The minimum sound is like a fire cracker but if the capacitor is large it can range up to a cherry bomb or a silver salute.

Other than the above electrolytic capacitors don't fail anymore often than plastic film capacitors as long as the equipment is in continuous use. Defective electrolytics are most often encountered by those who restore vintage electronics.

Electrolytics made 50 or more years ago probably weren't as well sealed as modern ones. They can dry out. With most of the water gone from the electrolyte the capacitance is reduced to a small fraction of its original value. Such capacitors are open and have to be replaced.

Another very common failure mode for electrolytic capacitors in vintage electronics equipment which has not been turned on for decades is to become unformed. The oxide layer has become very thin. If treated with care such capacitors can be reformed outside of the factory. The thing you must not do with vintage equipment is turn it on. The capacitors in the power supply will explode if the primary fuse doesn't blow first. Considerable damage can be done to other components, some of them difficult to find. More details can be found in a later chapter devoted to trouble shooting and restoring vintage electronics.

WARNING! Be sure to take the special precautions outlined below or you will wind up with a burned out meter. If you just connect the meter in series with a capacitor across a power supply, when the supply is turned on the charging current of the capacitor will be as much as an ampere and a sensitive milli amp or micro amp meter will be burned out.

The empirical formulas below tell you when to discard an electrolytic capacitor. In order to actually measure the leakage currents without destroying your meter here is what to do.

  1. Connect a short across your meter and set it to a high current range.

  2. Connect the meter in series with the capacitor you want to test.

  3. Connect the combination across the power supply.

  4. Turn on the power supply.

  5. weight for 1 minute.

  6. Remove the short from the meter.

  7. Start switching to lower ranges until you can read the leakage.

  8. Write down the value.

  9. place the short back on the meter.

  10. Turn off the power supply.

  11. Discharge the capacitor by connecting a 10 k ohm 1 watt resistor across it for as long as it takes for the voltage to fall below 5 volts.

  12. Disconnect everything.

  13. Apply the formulas below to determine the state of your capacitor.

The current you measured above is termed the leakage current. In normal operation it does no harm but if it becomes too large the capacitor can fail violently as described above. A set of formulas which give the approximate leakage current are given below.

ILMin = Sqrt(VC)/5

ILMax = Sqrt(VC)/2

ILWorst Case = Sqrt(VC)*6

IL is the leakage current, V is the rated voltage and C is the rated capacitance of the capacitor.

Note: Those familiar with basic electricity will remember that CV = Q, where Q is the charge stored in Coolums. This may be just a coincidence. I can't readily see how the square root of charge gives the leakage current. Dimensionally it gives meters times the square root of Newtons. This must be an empirical equation. It came from a capacitor manufacturer which is no longer in business.

The leakage current IL values for minimum, maximum, and worst case, are for newly manufactured capacitors. But if an older capacitor fails to reform to a current less than the worst case it should probably be discarded. Detailed reforming instructions will be given in the chapter on vintage equipment.

Here is an alternative method for testing an electrolytic capacitor using a voltmeter instead of a sensitive current meter.

  1. Connect the capacitor in series with a resistor and the series combination across a power supply which is set to a voltage equal to the working voltage of the capacitor.

  2. Set a voltmeter to a range just higher than the power supply voltage.

  3. Connect the meter across the resistor. Start with a resistor having the value R = V / IL Where R is the resistance of the resistor for the initial test and IL is the expected leakage current from the above equations.

  4. When the meter reading stops increasing turn off the power supply and discharge the capacitor.

  5. Substitute a resistor having the value R = V / (10 x IL) If the capacitor is good the meter reading will rise to 90% of the power supply voltage.

The above test method will also serve to reform an electrolytic capacitor which has become unformed from prolonged disuse.

Effective Series Resistance, ESR.

Another common defect of electrolytic capacitors is for the effective series resistance to increase. All capacitors have some series resistance. It is as though there is a small resistor inside the case along with the capacitor. This resistor is in series. In film capacitors this resistance is very small being typically a fraction of an ohm. But in electrolytic capacitors the ESR can be significant. The usual cause is drying out of the electrolyte. A capacitor which is 20 years old may be slightly dried out causing an ESR of a few ohms. Depending on the application such a capacitor may not give any indication of trouble. A capacitor which is 50 years old may be so dried out that it's ESR is so high that it can no longer effectively bypass a cathode resistor or act as a filter in a power supply. It may show good on a capacitor tester and you may be able to measure its capacitance with a bridge but it just doesn't work right. Other 50 year old capacitors may be completely dried out and are effectively open. The later are usually enclosed in a cardboard tube and seeled with wax as opposed to being in metal cans. These wax seeled capacitors were used in all American 5 radios and give the symttom of a loud hum in the speaker after the tubes warm up.

Some testers and many bridges measure the D (dissipation) factor along with the capacitance. The dissipation factor is defined as

D = Rs / Xc

Where Rs is the effective series resistance, and Xc is the reactance of the capacitor calculated at the test frequency. Therefore,

Rs = D Xc

Substituting for Xc gives,

Rs = D / (2 pi f C)

Where pi = 3.14159, f is the test frequency of the meter or bridge, and C is the capacitance in farads, not microfarads.

I know of no simple setup that will reliably measure ESR. One way might be to run up the frequency until Xc is less than an ohm then apply a current and measure the voltage. The problem is that the frequency may be so much higher than the normal operating frequency as to render the results meaningless. Substituting a known good capacitor is probably the only way to diagnose high ESR.


Troubleshooting Chapter Four. Troubleshooting Techniques.

Chapter 4   Troubleshooting Techniques.

4.1  Check The Obvious First.
4.2  Do Not Make Modifications.
4.3  The Power Supply Section.
4.4  Half-splitting.
4.5  Signal Tracing.
4.6  Signal Injection.
4.7  Disturbance Testing.
4.8  Static Testing.
4.9  Shotgunning.

Chapter 4

Troubleshooting Techniques.

Before we can begin troubleshooting, we must develop some techniques tools and rules. You may already know many of these rules but have never expressed them in words. Most are simple common sense.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

4.1 Check The Obvious First.

This seems so obvious that it should not need to be said. But time and time again, service personnel will overlook a pulled out plug, a blown fuse or even a burned out power indicator light.

Replace indicator and dial lights. If the power indicator is burned out the operator may assume that the equipment did not come on when the power switch was activated. You should replace lights even if you have not been asked to do so. Equipment operators appreciate it and will have good feelings about the equipment and the people who service it. This is more important than you might think. If the operator believes that the service personnel are doing a good job, there will be fewer complaints and better evaluations for the service people.

Be tactful. If you find something so simple that the operator could have corrected it, do not be insulting to the operator. There is nothing to be gained and a great deal to be lost. If questioned by the operator, be as diplomatic as you can. Good relations between operating and service personnel are as important as the technical operation of the equipment itself.

Test for the presence of AC voltage. You may want to use a test lamp because it is quicker and easier than a voltmeter.

Test for the presence of DC voltage. Make sure that the power supplies are delivering the voltages and that they are getting to all of the circuit-boards in the unit.

Make sure the power supply voltages are correct and free of ripple. A sizable enough percentage of equipment failures are caused by the power supply to warrant always checking it first. As a friend Mike McCarty puts it, "The power supply is mama. If mama aint happy, aint nobody happy."

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

4.2 Do Not Make Modifications.

There are two basic kinds of circuits to troubleshoot, circuits which used to work and stopped working, and circuits which have never worked.

If a circuit used to work, it is safe to assume that it came from the manufacturer with all component values correct for proper operation. As a service technician your job is to find the defective component and replace it. Modifying the circuit to correct the fault will probably result in performance not as good as when the equipment was new. Modifications also make the job of any technicians who come after you almost impossible. Don't start changing component values and rearranging circuitry; find the defective part and replace it.

As with any rule there are exceptions. One is obvious, if you are the owner of the equipment and you want to add a feature that was not part of the original design. Even so you should print or write clearly information about the modification on a gummed mailing label and stick it inside the chassis or cabinet. You may think you will own the equipment as long as you live but you aren't going to live forever. Eventually this beloved device will wind up in the hands of a stranger who will be helped if such a note is included. Making notations in the manual is not good enough. After you have gone on to the big ham shack in the sky chances are the manual will be tossed and the equipment sold at an estate sail.

Another exception is if the owner specifically asks for a modification. He or she may ask if you could add a phono jack so the RCA 45 could be played through the radio. Or someone may ask if the radio, phonograph, or TV set, could be equipped with a headphone jack for private listening.

When the equipment doesn't belong to you and the owner just wants it to work again, modifications are right out.

Don't start turning internal adjustments. If the equipment is just a little bit off from its specifications, recalibration may be what is needed. If the equipment just doesn't work, changing calibration settings isn't going to fix it. If you have turned every adjustment you can find, it will be difficult to know when you have replaced the defective part or parts. You can never be sure if the symptoms are caused by a defective part or the fact that every adjustment has been tinkered with. Resist the urge to tinker. Adjustable resistors and capacitors don't turn themselves.

I personally know of a case where this happened. A student worker was troubleshooting a Wavetech function generator. There must have been half a dozen trimmer pots on the circuit board. The first thing he did was to turn every screw. Then he started randomly replacing components. He finally gave up saying it couldn't be fixed. When it landed on my bench the first thing I did was to perform the adjustment procedure in the manual. It came into alignment and worked just fine. Somewhere along the line he had replaced the defective part but didn't know it because it was so far out of adjustment. So let me reiterate, don't turn any adjustments. They don't turn themselves and they are not the reason the instrument stopped working.

Circuits which have never worked are a slightly different story. An example of such a circuit could be an R and D (research and development) prototype. In such a case there may or may not be a defective component in the circuit. It may not be working because someone installed a resistor of the wrong value or a diode or transistor backward. In a case such as this you are justified in modifying the circuit.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

4.3 The Power Supply Section.

The power supply of any line operated electronic device is the first place you should look for trouble. As pointed out above the first thing is to check for normal voltages. However an often encountered symptom is "It blows fuses." In such a case the first step is to separate the power supply section from the rest of the device. This may be as easy as pulling a plug or two but may require unsoldering some wires. Once the supply has been separated from its load try another fuse. One exception to this is if the device uses vacuum tubes and one of them is a rectifier. Unplug the rectifier tube and make sure there is no bias supply that uses a selenium or silicon rectifier. Inspect the heater circuit to make sure there aren't any shorts. Then try another fuse. If it blows the transformer is most likely shorted and needs to be replaced.

If the transformer is good no matter if the device uses tubes or transistors, check for shorted diodes and filter capacitors. If the diodes and capacitors appear to be good but fuse blowing persists try the dim bulb test. Connect a low wattage, say 25 watt, tungsten light bulb in series with the power line. The bulb may light up at full intensity. You now have current flowing in the transformer, rectifier, and filter, components. Find out what is going on in the power supply before you switch to a higher wattage bulb. Check for heating of diodes and filter capacitors. Measure voltages with an oscilloscope if possible. If you find it necessary to go to a higher wattage bulb don't go above the rated current of the device. For example if the device specifications say normal line current is 2 amperes don't go above a 250 watt bulb.

This test may reveal that a diode is going into reverse breakdown at a lower voltage than required for the supply. Contrary to popular belief a diode is not completely binary in its failure. Overheating may reduce its reverse breakdown voltage. The cause of that overheating may be an electrolytic that passed an ohmmeter test but is conducting a direct current at a much lower voltage than it's normal operating voltage. Such a symptom is quite common in vintage equipment which has not been turned on for several decades. You may observe that the DC voltage across the filter capacitor is slowly increasing. If so let things run while occasionally checking the temperature of the capacitor. If the capacitor begins to heat change to a lower wattage bulb. What is happening is that the capacitor has become unformed from disuse and is being reformed. Reforming the capacitor may restore the unit to operation. If the capacitor refuses to reform to the necessary voltage it must be replaced. Even if it does reform after a few hours of dim bulb operation replacement is still recommended if at all possible.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

4.4 Half-splitting.

Many pieces of equipment are so designed that signals or data flow through them from one operational block to the next. In this case it is possible to apply a technique known as half-splitting.

In this procedure you check for the presence or absence of signal at a point halfway between input and output. If the signal is present, you know the trouble is in the second half. If the signal is absent, you know the trouble is in the first half. Then you split the defective half in half and check for signal. In a large system this procedure can save a lot of time over moving down the line checking each block or stage as you go.

Think of it as being similar to the old "guess the number" game. "I am thinking of a number between 1 and 1000. You make a guess and I will tell you if you are too high or too low." Your first logical guess would be 500. If I say "You're too low," your next guess would be 750, and so on. If your first guess was 1 and your next guess was 2, it would take a very long time to find the number unless I happened to be thinking of 3. If I am thinking of 998 it would take a very long time.

An example might be an AM radio. Although it may not be exactly half way, the volume control is a good place to start half-splitting. It is easy to find and test equipment is easy to connect. You are likely using a signal tracer or oscilloscope. Presents of audio means that the RF and IF sections are OK and the trouble is in the audio amplifier and speaker section. At this point the circuits are so simple it is impossible to distinguish between half-splitting and down the line testing. All but the most elaborate console radios have only two stages in the audio section. So check between them, at the plate or collector of the power output and at the speaker.

If there is no audio at the volume control check to see if the local oscillator is running. Do not connect your scope probe directly to the oscillator grid in a tube radio. Connect to a low impedance point such as the cathode in a Hartley oscillator circuit. Transistor circuits operate at a low enough impedance that connecting to the base of the oscillator will not stop the circuit from oscillating.

There may be situations where half-splitting cannot be applied. One is an audio amplifier with negative feedback. Any trouble anywhere inside the loop will propagate around the loop and the signal will be out of whack everywhere. If the feedback is AC coupled only the loop can be opened up by unsoldering a resistor and maybe a capacitor. Then normal half splitting can be applied. In large and complex systems half-splitting usually can and should be employed.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

4.5 Signal Tracing.

One way in which half-splitting can be implemented is by signal tracing. In this technique a device which can detect the type of signals in the system is used to look for them.

When AM radios were about the only thing to be repaired, a device known as a signal tracer was on every service bench. The device was capable of responding to the signals in the RF (radio frequency), IF (intermediate frequency) or AF (audio frequency) stages of the radio. The "readout" of the signal tracer was a loudspeaker. Signal tracers are seldom seen these days and I know of only one company which is still manufacturing them. No such device is available for television signals.

A signal tracer for radios can easily be constructed. Any simple two tube single ended audio amplifier can be a signal tracer. Even one that already exists. Just attach a shielded probe to it such as a times 1 scope probe. If you use an existing amplifier it probably doesn't have a DC blocking capacitor in its input. One must be added before the amplifier is used as a signal tracer. Don't just say "I won't touch any high voltage. Someday you will make a mistake and touch a 300 volt point and "zap", there goes your amplifier especially if it is transistorized.

For checking IF and Rf circuitry all you need to do is add a simple AM detector as shown below.

Figure 4.1 Circuit for a Simple AM Detector Probe.

For a verbal description click here.

Silicon diodes such as 1N4148 can be used but I don't recommend it. Improved performance can be had with 1N270 if you can get them. You stand a better chance of finding 1N34A diodes. Or the ECG or NTE equivalent.

This probe can be used to test for an AM signal on the plates or collectors of IF amplifiers, mixers, and RF amplifiers. When connected to an unmodulated source of RF the detector will deliver a DC voltage approximately equal to the peak to peak voltage of the source. The probe can be used in conjunction with a high impedance DC meter to tell if the local oscillator in a radio is operating.

In the age of CD players and computerized industrial control systems, signal tracing is usually accomplished using an oscilloscope. Of course the troubleshooter must know what the signal is supposed to look like in order to know if anything is wrong. Service manuals for most modern equipment contain actual photographs of scope traces to show what the signals are supposed to look like at various points in the system.

Signal Substitution.

Signal substitution is employed when the equipment being tested has been separated from its signal source. For example, suppose you are working on a stereo receiver but you don't have a turntable handy. You would use an AF generator to substitute for the magnetic pickup of the turntable. You would then employ the techniques of signal tracing to find the trouble.

Signal substitution should not be confused with signal injection. In signal substitution the signal generator is connected to the input of a piece of equipment instead of the device or equipment which normally goes there. The signal generator is left connected at the input throughout the testing procedure.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

4.6 Signal Injection.

Another way in which half-splitting can be implemented is by signal injection. It is employed when the equipment being tested has been separated from its signal source but its output device is present.

For example suppose you are troubleshooting the vertical amplifier of an oscilloscope. You could use a function generator to inject signals at various points in the vertical amplifier and watch for the signal to appear on the scope's screen.

***  WARNING  ***

Few if any of today's signal generators have DC blocking capacitors in their outputs. The output impedance of most generators is 50 ohms. If you inject signals without using an external DC blocking capacitor, you could further damage the piece of equipment you are trying to fix and/or damage the signal generator.

It is necessary that the injected signal be compatible with the stage into which it is being injected. It will be of no use to inject the output from an RF generator into an audio stage or the output from an audio generator into an RF or IF stage.

Returning to our example of an AM radio you could start by injecting a signal at the volume control. If you don't hear the signal or it is very weak even with the generator's output turned up to full the trouble is in the audio section. Once again the circuit is so simple that there is little use in half-splitting beyond this point. If the audio signal generator you have does not have a DC blocking capacitor in its output you must use one. The simplest way is to hold one lead of a capacitor in the clip lead from the generator and use the other lead as a probe. It will usually help to shorten the leads of the capacitor. Start with the generator output set low and touch the probe to the plate or collector of the output device. Turn up the generator until you hear something. In a tube radio the sound will not be very loud even with the generator turned up to full. Turn the output down a bit and touch the grid or base of the output device. The sound should be loud with a low setting of the output. Move back to the grid or base of the first audio stage. The sound should be even louder. These statements would be true if there was no trouble in the audio section. Obviously there is so the sound will not be louder in one of the cases where it is supposed to be.

If the trouble is not in the audio section you need to work with the IF and RF sections. Set your RF signal generator to the frequency of the IF which in most cases will be 455 kHz but in car radios and some older radios may be 262.5 kHz. Remember to use a DC blocking capacitor. Touch the probe to the plate or collector of the last IF amplifier. You should hear a good loud signal with the generator set to about 0.1 volt. Move the generator to the base or grid of the same stage. Touch up the frequency of the generator to be sure it is tuned to the center of the IF band. The signal should be much louder. If the AGC in the radio is very good you might not perceive much of an increase. Don't be fooled by this. Turn down the output of the generator until the signal begins to get weak. Move the probe back to the plate or collector to confirm that the stage has a lot of gain.

The next logical thing to check is to see if the local oscillator is running. One of the least equipment intensive methods is to listen to the oscillator on another AM radio. Tune the other radio to a weak station in the top half of the AM band above 1000 kHz. Tune the radio you are troubleshooting about 455 kHz below the other one and if the oscillator is operating you will hear a beat, descending tone followed by an ascending tone, as you tune across the frequency. If you are working on a pocket transistor radio the two radios must be sitting one on top of the other for the oscillator signal from one to be picked up by the other.

Another way is to look with an oscilloscope. This is the only sure test for a transistor radio. When looking at the grid in a tube radio be sure to use a times 10 probe. Even so the frequency of the oscillator will be thrown off by several kHz.

Yet another way to confirm oscillation in a tube radio is to measure the DC voltage at the oscillator grid. If you have a genuine VTVM it will have a 1 meg ohm resistor in the DC probe. You should measure approximately -20 volts at the grid. This figure is very approximate and your mileage may very. If you measure only a fraction of a volt negative the oscillator is not running. If you only have a DMM you must use a 1 meg ohm resistor at the probe tip as described for a capacitor above. Touch the resistor to the grid. The reading will be approximately 10% low but you only want to determine if there is negative DC present at the grid. Its absolute value is not important.

If the oscillator is running but the radio is still not working you may be encountering a puzzling situation. You may be hearing stations when you touch your test probes to certain points in the radio but they go away when the probe is removed. This is most likely in a radio that has an RF amplifier stage. The trouble is there. If the radio does not have an RF stage this situation is still possible although the symptom was more likely to be that the radio would pick up very strong local stations but they sounded very weak. This would indicate trouble in the built in antenna or if the radio is very old and requires an external wire antenna the antenna transformer may be defective. You did remember to connect an external wire antenna to that old radio, didn't you?

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

4.7 Disturbance Testing.

Disturbance testing can sometimes be employed in the absence of a signal generator. You may be familiar with one kind of disturbance testing. If you touch your finger to the phono input of a stereo amplifier you will hear a loud hum in the speaker. If you have ever used this effect to find out if the amplifier was working, you have engaged in disturbance testing for the purpose of troubleshooting.

The usual method of disturbance testing is to touch or scratch various points in the circuit with a screwdriver. It is sometimes helpful to touch a finger to the metal part of the screwdriver, but only in low voltage circuits.

If you are concerned about the hazard of electric shock (as you should always be), you can touch or scratch with one lead of a resistor while holding the other lead.

Disturbance testing should always be conducted with care because it is possible to destroy some MOSFETs (metal oxide semiconductor field effect transistors) by touching the gate terminal.

Back to the example of our radio. The impedance levels in a transistor radio are too low to effectively employ disturbance testing. You can test the audio section in a tube radio by touching the center terminal of the volume control. CAUTION! In most AC operated radios the on/off switch is shared with the volume control. The AC terminals for the on/off switch are on the back of the control. The audio terminals for the volume control are on the side. It is likely to be unhealthy to get them confused. Touch the center terminal on the side of the control and turn the volume up and down. You should hear the volume of the hum change. Note: If you aren't using a knob on the shaft but turning the bear metal shaft you will find that the hum will be considerably reduced when you touch the metal shaft. That's because you are grounding your body to the chassis of the radio and the signal that your body picks up as it acts as an antenna is not nearly as strong as when it is not grounded.

Disturbance testing on the IF amplifier is done by scratching on the grid terminal of the IF tube with the blade of a screwdriver. If this produces static in the speaker it is likely the IF amplifier is alright. And that takes us back to that pesky local oscillator again.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

4.8 Static Testing.

The "static" in static testing is static as in standing still, not static you hear on the radio. Static testing means testing the device with no signals present.

Static testing is further subdivided into two types, testing with power on and testing with power off.

Testing with power on usually means making DC voltage measurements. Voltage measurements are only meaningful if you know what the voltages are supposed to be. That implies that you need a voltage chart for the particular piece of equipment. If you are without such a chart, do not despair; later chapters in this book will cover how to reason from the circuit diagram what the voltages should be.

In any radio, tube or transistor, if it stops working chances are that some vital DC supply voltage is missing. While you may not be able to say if the voltage is high or low, if it is zero the tube isn't going to do much amplifying. In a tube radio check for plate and screen grid voltages. Odds are good this will lead you to the problem. In a transistor radio check to see that base emitter junctions are forward biased and that the collector is higher, in the absolute sense, than the base. Remember that most older transistor radios used PNP transistors which means that all voltages are reversed from the way we have become accustomed to thinking of them in NPN circuits.

Static testing with power off means making resistance measurements with an ohmmeter. Because the amplifying devices used today conduct current (from the ohmmeter battery) even when no power is applied (unlike vacuum tubes), resistance measurements are seldom used.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

4.9 Shotgunning.

The term "shotgunning" and the procedure which goes with it originated with the writer's father. The procedure is quite simple. "Find what stage the trouble is in and replace all of the parts in that stage. Resistors and capacitors are cheap" (and now so are transistors) "and time is money."

This philosophy does not work quite as well in the transistor age as it did in the vacuum tube age. One reason why this is true is because transistors have such a low input impedance. The trouble can be one stage later than you think it is. Another reason shotgunning doesn't work as well as it used to is because of the increased use of feedback in transistor circuits. This makes trouble propagate around the loop, making it very difficult to pinpoint the defective stage. Negative feedback can also defeat signal tracing and half-splitting.


Troubleshooting Chapter Five. Faults in Power Supplies.

Chapter 5   Faults in Power Supplies.

5.1  Rectifier-Filter Circuits.
5.2  Analog Voltage and current Regulator Circuits.
5.3  Switching Mode Power Supplies.

Chapter 5

Faults in Power Supplies.

With the exception of battery operated equipment everything has a power supply. When troubleshooting any piece of electronics the power supply is always the place to start.

The device containing the power supply may be a kit or DIY construction project that used old parts. It may be a piece of old electronics that has not been turned on in several decades.

There are also laboratory bench power supplies that may develop a fault and wind up on your bench.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

5.1 Rectifier-Filter Circuits.

WARNING: IF THE ELECTTRONIC ITEM HAS NOT BEEN TURNED ON FOR MANY YEARS, DON'T JUST PLUG IT IN AND TURN IT ON. Refer to the chapter on antique electronics equipment before attempting to troubleshoot such items.
Power supplies can range in complexity from simple transformer-rectifier-filter circuits to multi output with electronic voltage and current regulation. If the power supply is one of the latter the regulator circuits should be separated from the basic rectifier filter and the basic circuit tested separately.

Although a simple power supply has little to go wrong, as pointed out earlier in this book failures can cascade turning a simple problem into a more complex one.

An electrolytic capacitor used in a DIY project may have been taken from NOS (new old stock) and may not be formed up to its rated voltage. Such a capacitor may show good using an ohmmeter but will blow fuses and diodes when the power is turned on. Since the capacitors have never been put into use they should be tested at their rated voltage.

For a brief discussion on the construction of an electrolytic capacitor, how to test it, and its behavior in a circuit, refer back to 3.2 Electrolytic Capacitors.

For a discussion on testing a power supply which may have unformed electrolytic capacitors and how to reform them refer back to 4.3 The Power Supply Section.

Figure 5.1, Four Most Common Rectifier-Filter Circuits.

For a verbal description click here.

Figure 5.1 shows the four rectifier-filter circuits you are most likely to encounter. The primary circuit showing connection to the power line, switch, and fuse have been omitted but will always be present in the device on your bench. Just for the record they are (a) full-wave center-tapped, (b) bridge, (c) dual voltage bridge, and (d) full-wave voltage doubler.

The terminal labeled "COM" (common) on each circuit may or may not be connected to the chassis of the work device. The positive terminal labeled "V+" could just as well be used as common to obtain a negative supply or a circuit could have its "COM" connected to the positive of another similar circuit to obtain more voltage. The circuit of Figure (c) could have the bottom or top terminal used as common to produce voltages of V+ and 2V+ or V- and 2V-.

If you have stripped the circuit down to one of these and it is found to be at fault the most likely symptom is blowing fuses. Resist the temptation to put in a bigger fuse. A good starting point is to use your ohmmeter to test the diodes. Most of the time a failed diode will be a really dead short, zero ohms. There will be parallel current paths through the other diodes and transformer secondary. If the power supply is low voltage high current the secondary may have a resistance of a small fraction of an ohm. In this case if two of the diodes are shorted it may appear as if all are shorted.

You will likely have to unsolder the diodes in order to test them. If even one defective diode is found you should replace all of them. All diodes in a rectifier should be of the same voltage and current rating. Diodes aren't all that expensive anyway.

Remember that one or more shorted diodes may be caused by a shorted or unformed electrolytic capacitor. After replacing the diodes and before plugging it in, use your bench power supply to attempt to apply the normal operating voltage across the outputs with the power supply being worked on unplugged. The bench power supply MUST be current limited.

WARNING!!! Most vacuum tube bench power supplies do not have current limiting. A resistor must be used to limit the current to a safe value for the bench power supply.

If the voltage will only come up to approximately 10% or 20% of operating voltage an unformed electrolytic capacitor is indicated.

In the case of Figure (c) the voltage may be applied to each half of the supply separately. This will localize the problem to one or the other of the circuits. If you carefully examine the circuit you will see that the bridge really consists of two full-wave center-tapped circuits like that of Figure (a). One is reversed from the other.

Silicon Diodes most often fail dead shorted. If the fuse does not blow quickly enough another diode may also go shorted and excessive current may burn one or both open. In either case the failure is binary and can be detected with an ohmmeter, even the ohmmeter section of a DMM. In higher voltage circuits the partial failure of reduced reverse breakdown voltage may be encountered. Such a failure mode is difficult to detect unless you have access to a curve tracer. In deed it may be difficult to tell the difference between such a diode failure and an unformed electrolytic capacitor. Unsoldering components for testing separately is the only way to resolve this ambiguity. If the capacitor test good up to its operating voltage the diodes should be shotgunned.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

5.2 Voltage and current Regulator Circuits.

5.2.0 How a voltage regulator works and what it does.

A voltage regulator has to hold the voltage constant as the voltage of the input varies and as the load current changes. The output voltage of a rectifier and filter capacitor is not constant. The line voltage can vary all over the place and then there is that ripple which is always present. Another application is in battery operated equipment. In many cases the designer of such equipment wants the voltage applied to the circuits to remain constant as the batteries run down. The battery voltage is set higher than the circuit needs and the regulator holds it constant until the voltage gets near the operating voltage. Special circuits usually warn the operator and/or turn off the equipment when the battery is so run down as to no longer operate the device.

Changing load current is another difficulty. We often use resistors to indicate the load on a power supply. The real load on a power supply is a transistor circuit and/or a small motor or two. The current drawn by a transistor circuit may change depending on what the circuit is and what it is doing at the moment. The current drawn by a motor changes as its mechanical load changes. So a regulator may have a lot to do.

A regulator can't increase the voltage applied to it. All it can do is reduce it. It regulates the voltage by reducing it by the amount required to hold it at some preset value. The difference between the regulator input and the output is called the regulator drop. Each type of regulator has it's minimum regulator drop. If the input voltage falls so low as to make the regulator drop less than the minimum the regulator will lose control and the output voltage will fall.

For example, a 12 volt regulator IC has a minimum drop of 2 volts. That means that the input voltage must be 14 volts or higher. It regulates just fine for input voltages anywhere from 14 to 40 volts. But if the input voltage falls to 13 volts the output voltage will fall to 11 volts and it will no longer be regulated. It will just be 2 volts less than the input, ripple and all. If the ripple valley falls below the minimum required the output voltage will acquire ripple as shown in the graph below.

A common fault in equipment that is older than 20 years is for the electrolytic filter capacitor(s) to dry out which reduces the effective capacitance value. In such a case the ripple amplitude will increase.

Figure 3.14 Input and output waves of a voltage regulator.

For a verbal description click here.

The upper wave is the output of a full wave rectifier with a capacitor filter. The lower wave is the output voltage of a voltage regulator. In (a) the input voltage is high enough that the regulator is able to do its job properly. In part (b) decreased capacitance has reduced the ripple valley so it is below the minimum required to maintain regulation. Note that the peak voltage is the same in both cases. This is the way ripple responds to decreased filter capacitance value or increased load current.

A measurement with a DC voltmeter is likely to indicate that the input voltage is high enough but the ripple valley is too low. Only an oscilloscope measurement will reveal this defect. This is one of the most overlooked problems in troubleshooting electronic devices.

5.2.1 Transistor Circuits.

If the basic rectifier filter section is working properly The problem is in the electronic regulator circuit. Beware of treating the symptom. Many power supplies I have opened up have revealed a burned or scorched resistor. Replacing this resistor will not fix the problem. The replacement will just burn out as the old one did. However, this will point you to the area of trouble.

A very basic voltage regulator circuit is shown in Figure 5.2.

Figure 5.2, Simple Voltage Regulator Circuit.

For a verbal description click here.

This type of regulator would most likely be used as the internal power supply for some piece of lab equipment such as a signal generator. The voltage adjustment pot would be of the "set and forget" type. Bench power supplies require different circuitry so their voltage can be adjusted all the way to zero.

R2 supplies a current to the zener diode D5 which maintains a constant voltage at the emitter of Q2. R1 supplies current to the base of Q1 which without Q2 would hold Q1 in near saturation. The collector of Q2 can take current away from the base of Q1 reducing the voltage at the emitter of Q1. In the equilibrium condition the voltage at the emitter of Q1 is held constant by the circuit. Q1 is known as the pass transistor and Q2 is the error amplifier. The zener diode provides the reference voltage.

If the output voltage, emitter of Q1, tries to decrease due to an increase in load or a decrease in line voltage the voltage at the base of Q2 will decrease reducing the base current because the emitter voltage of Q2 is being held constant by the zener diode. This will also decrease the collector current of Q2. This allows the base current of Q1 to increase because the current through R1 divides between the collector of Q2 and the base of Q1. If the collector current of Q2 decreases the base current of Q1 will increase. This provides more current to the emitter of Q1 partially counteracting the original decrease in voltage at the emitter of Q1.

If Q1 shorts the output voltage will be stuck at maximum and cannot be changed by the setting of the pot.

If Q2 shorts the output voltage will be reduced to a value near that of the zener diode and can't be changed.

If D5 shorts the output voltage of the circuit will fall to a very low value. The control will still have some effect but the regulation will be vary poor.

If R2 opens the circuit will still appear to be working but the regulation will not be quite as good as it was before. The emitter current of Q2 is supplying current to the zener but it will not be as large and will vary quite a bit. As zener diodes aren't perfect a varying current will cause the voltage to vary somewhat.

If R1 opens the output voltage will fall to a very low value likely zero.

Figure 5.2b, Improved Simple Voltage Regulator Circuit.

For a verbal description click here.

Improved performance equivalent to using a current source instead of R2 can be achieved by simply moving the top end of R2 to the emitter of Q1 as shown in Figure 5.2B below. The value of R2 would have to be decreased somewhat but no additional components are required. Very small changes in the output voltage would have a very very small effect on the zener current and a very very very small effect on the zener diode voltage. The operating theory is not changed by this change.

General Operating Theory.

Q1 is the pass transistor and operates as an emitter follower amplifier. Such an amplifier has current gain. In high current power supplies Q1 is often a Darlington circuit.

Q2 is a voltage amplifier. It can be easily replaced by an operational amplifier. The emitter is the noninverting input and the base is the inverting input.

A zener diode is a zener diode and there isn't anything else that can replace it. There are IC devices known as voltage references but at their heart is a zener diode. An improvement that can be made to the zener part of the circuit would be to replace R2 with a current source. The circuit with all of these improvements is shown in Figure 5.3.

Figure 5.3, Improved Voltage Regulator Circuit.

For a verbal description click here.

Q3 and R1 form a constant current source for the zener diode. This isolates the zener current from changes in the input voltage. Because the zener diode is not perfect large changes in zener diode current can cause small changes in the voltage drop across the diode.

If the op amp has bipolar inputs the current into or out of the noninverting input will be only a few microamps. If an FET input op amp is used the current will be about 1 pico amp. In either case the current is insignificant compared to the current of several milliamps flowing in the zener diode. The circuit functions exactly as the one above except that the op amp has a much higher gain than a single transistor which makes the regulation much more accurate.

Troubleshooting this circuit is in many ways easier than the more primitive circuit of Figure 5.2. This circuit is somewhat limited in range of adjustment and may be a fixed voltage supply within a piece of complex equipment. In that case the pot is a setup adjustment which is not meant to be turned by the operator. Let me reiterate, DON'T CHANGE THE SETTING OF THE CONTROL.

If either Q1 or Q2 shorts the voltage will go up to maximum. It may be difficult to determine which one is at fault without removing them from the circuit and performing a junction test. One thing to try is measure the voltage from emitter to base of each one by connecting the voltmeter leads to those two points. If one of the transistors is good it will most likely have 0.6 volts between base and emitter. If you measure zero or 0.1 volts that transistor is most likely shorted.

If the op amp fails its output will be locked to either common or the positive input rail. This will cause the output to go to either zero or maximum voltage. If the voltage goes to maximum it may be difficult to tell the difference between a short in Q1 or Q2 from a short in the op amp. Once again measure the emitter base voltage on Q1 and Q2. If both are 0.6 volts the op amp is most likely shorted.

The failure mode of FETs is not easily predictable. The gate to channel junction can short in which case the drain current will go up to the zero bias value and stay there. This may or may not produce an over current condition in the zener and R1 large enough to cook either one. The power supply might operate for several years with this condition without any hint that anything is wrong. The conditions would be that the line regulation and ripple rejection would not be up to original specifications. The condition might show up as hum in a sensitive amplifier being powered by the regulator.

If the FET should develop a gate to source short the zener and R1 would be smoked.

If the FET develops an open drain or open source the zener voltage will drop to zero and so will the output voltage of the regulator.

Current limiting.

Figure 5.4 shows a current limiting circuit added to Figure 5.3.

Figure 5.4, Improved Voltage Regulator Circuit with Current Limiting Added.

For a verbal description click here.

The ideal current limiter holds a constant voltage up to the current which is set by the value of R5 and the breakdown voltage of Q4. Once this current value has been reached the current does not increase by so much as a pico amp and the voltage of the regulator falls, to zero if necessary. The smaller the base current of Q2 is, the closer this current limiter will come to the ideal.

The circuit works as a voltage regulator as long as the voltage drop across R5 is less than the emitter base breakdown voltage of Q4. When the voltage drop across R5 reaches the breakdown voltage Q4 begins to conduct pulling base current away from Q2. R6 helps to isolate the output of the op amp from the base of Q2 so Q4 doesn't have to pull the output voltage of the op amp down.

With this circuit there would be some increase in current after limiting begins because as the voltage at the base of Q2 drops the current through R6 will increase. If Q1 and Q2 were replaced by a power FET R6 could be very large and the limiter would work quite well.

This circuit is a cascading failure waiting to happen. If the load develops a short the voltage will drop to zero but the maximum current will be flowing. If the heat sink on Q1 is not designed for this fault condition Q1 will overheat and eventually short out. When that happens the current will go up to a very large value and the voltage across R5 will exceed the emitter base breakdown voltage of Q4. This will cause the emitter base junction to short out and as the high current flows through the shorted junction the base will likely burn open. Q4 would not be a high power transistor but a small 250 mW transistor. With Q4 now burned away, R5 will smoke and burn up. As the high current continues to flow diodes in the rectifier will short out and the primary fuse will eventually blow, after most of the semiconductor devices have either shorted or melted open. Some parts in the electronics which was the load will probably be cooked as well. All in all this particular failure mode is a total disaster.

On the other hand if the heat sink was sized for continuous short circuit operation There shouldn't be any problems.

If this is a lab bench power supply the voltage and current should be fully adjustable. R5 can be a rheostat adjustable from the front panel.

If the power supply has a fixed output voltage and is part of a large device such as an oscilloscope or test set the current limit will also be fixed. Such an internal supply may also be equipped with current fold back as shown below to protect the power supply and circuitry connected to it in case of a short.

Figure 5.5, Voltage Regulator Circuit with Current Fold Back.

For a verbal description click here.

The fold back threshold is set by the voltage divider consisting of R8 and R9. C2 delays the voltage so the power supply can get started without going into fold back when the power is turned on.

In normal operation and when current limiting first begins D6 is reverse biased. As current limiting continues and the output voltage falls at some point D6 will become forward biased. This increases the base current of Q4 which takes even more current away from Q2. This shuts down Q2 and Q1 reducing the current to a small value.

If C2 should open the power supply most likely wouldn't come on. If C2 shorts or R8 opens, current fold back will be disabled. This is not likely to be discovered unless another failure brings attention to it.

If R9 should open the power supply will shut down. There will be an abnormally large current into the base of Q4. It may overheat and short, becoming a cascaded failure.

Floating the Error Amplifier.

You have noted in each of these circuits that the op amp power connections are between ground and the positive side of the rectifier-filter output. Op amp ICs typically have a maximum voltage of plus and minus eighteen volts. When using one of these ICs the highest allowable voltage of the filter output is 36 volts. The maximum regulator output voltage is several volts less than the filter output voltage so this limits the maximum voltage of the power supply. If the error amplifier is operated from an additional floating power supply the maximum output voltage is limited only by the maximum voltage of the pass transistor. An example is shown below.

Figure 5.6, Voltage Regulator Circuit with Floating Error Amplifier.

For a verbal description click here.

Note that the center of the symmetrical supply for the op amp is connected to the positive output of the regulator. The voltage reference and the noninverting input are also returned to this point. An op amp will always set its output voltage to whatever is required to bring the inverting input to the same voltage as the noninverting input. Let's say that the reference zener diode is 6 volts, R5 is 12 k ohms, and R6 is set to 36 k ohms. The op amp is going to force the inverting input to be at zero volts because the noninverting input is at zero volts. That places 6 volts across R5 and makes the current through it 0.5 mA to the right. That current isn't going to go into the inverting input because it is a high impedance point, possibly an FET input. The current is flowing downward through R6. Now 0.5 mA in 36 k ohms gives a voltage of 18 volts. That's the answer. Nothing else to add or subtract.

This arrangement is often used in laboratory power supplies which employ switches to set the voltage. This can be precisely done because the voltage is directly proportional to the resistance. The most significant digit of the switches often selects taps on transformer T1 so the pass transistor, or tube, does not have to stand the maximum voltage of the power supply. If tubes are substituted for the pass transistor the output can go up to hundreds or even thousands of volts.

A common fault in power supplies such as this is for the switch contacts to become oxidized and make poor contact. Cleaning will usually fix this problem. One or more of the range resistors can open causing the power supply to work properly up to a certain voltage setting and then go to maximum.

The fact that the positive output is labeled as 0 volts does not mean this terminal is grounded or connected to the chassis. In deed, laboratory bench power supplies never have either side connected to the chassis. Schematics for these supplies will most likely have voltages labeled in this way because it makes trouble shooting much easier. Imagine if the voltages of the power supply operating from T2 were referenced from the negative output terminal (-ADJ.). Any faults in this part of the circuit would be much harder to figure out. If this circuit were a sub part of a large circuit either side might be grounded or neither side grounded.

IC Voltage Regulators.

The 723 voltage regulator remains popular and available even after 30 years. It is a 14 pin DIP that has all the elements of a voltage regulator inside. It will work at current levels of a few mA using its own internal pass transistor. If an external high power pass transistor is driven by the internal one in a darlington connection the little IC can handle an amp or more. After study of the above circuits the data sheet of the 723 will look very familiar.

The other IC regulators are those three terminal regulators. They come in a variety of voltages from 5 to 24 volts and there is one that is adjustable. They are current limited which can't be adjusted and thermally protected.

The latter can cause a fault which may be hard for the uninformed to find. If the regulator is air cooled and the air passage becomes clogged with dust as it is guaranteed to do, The regulator will overheat and shut down. As it is no longer dissipating power it will cool and turn back on. No reset is necessary. It may take several hours to heat up enough to shut down and only a few tens of minutes to recover. So, the equipment shuts down, you are called in, and about the time you arrive the IC has cooled enough to turn back on. If this did not repeat you could get the reputation of curing equipment by laying on of hands. But it is going to repeat again, and again, until you clean out the airway.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

5.2 Vacuum Tube Power Supplies.

Figure 5.7, Vacuum Tube Voltage Regulator Circuit.

For a verbal description click here.

If this circuit seems familiar it should. Compare it with Figure 5.2. V3 is the voltage reference, V2 is the error amplifier, and V1 is the pass tube.

Isn't that funny? When I first learned transistors the analogy was drawn the other way. The circuit started out with tubes and they were replaced by transistors. Now when everyone is more familiar with transistors we have to start there and replace transistors with tubes. And now back to our regularly scheduled program.

V3 is a gas filled voltage regulator tube. They come in voltages of 75, 90, 105, and 150. They use the inert gasses with the exceptions of helium and radon. Each tube type uses a different gas. That was all we had before Clarence Zener did his thing.

R1 and R2 set the voltage on the screen grid of V2. This voltage will vary some and the more it varies the less gain the tube will have. The voltage divider is made as stiff as practical. The screen voltage is usually set between 1/2 and 2/3 of the supply voltage. R1 and R2 also provide the current for V3 the regulator tube. This tube requires a minimum of 5 mA to maintain the glow discharge and regulate the voltage. In order to insure that a brownout won't extinguish the VR tube a minimum current of 10 mA is usually set.

If the voltage at the output tries to decrease the voltage at the grid of V2 will change a bit in the negative direction. This will decrease the plate current of V2 because the cathode is held constant by the VR tube. A decrease in current through R4 will cause the voltage across it to decrease which will increase the current in V1 mostly counteracting the change.

The 7 pin miniature series of VR tubes has the anode connected to two pins and the cathode to three. This allows designers to protect the power supply against being operated with the Vr tube unplugged. In this circuit if V3 is unplugged while power is on the positive voltage will be removed from the cathode of V2. R3 will pull the cathode down close to common reducing the output voltage to near zero.

Unlike transistors tubes fail in a decided analog manner. Although there are occasionally catastrophic shorts the usual failure mode is for the cathode emission to become so low that the tube can no longer conduct enough current to do its job. The commonly used term for this is to describe the tube as weak. If V2 grows weak the output voltage will go high. It may still be possible to adjust it somewhat down from maximum but not all the way down.

If V1 grows weak the supply will still appear to work when lightly loaded, a small load current, but if loaded to its specified current the voltage will drop down and cannot be turned up to the desired value.

I have never known a VR tube to fail so I can't tell you how a failed tube behaves.

The output voltage of this circuit cannot be adjusted below the voltage of the VR tube plus about 50 volts. So a regulator built using a 105 volt tube would only come down to about 150 volts. Circuits of this kind are not used in bench power supplies but are frequently seen in fixed voltage regulators such as those found in Tektronix oscilloscopes, H P signal generators, etc.

Improved Voltage Regulator.

Figure 5.8, Improved Vacuum Tube Voltage Regulator Circuit.

For a verbal description click here.

This power supply circuit will go all the way to zero and even a little negative if R7 is not properly adjusted. R7 is usually a screwdriver adjusted rheostat. The cathode of the error amplifier, V2, is at a negative voltage and the negative end of the adjustment divider chain is held at twice that voltage.

This circuit will also go much closer to the voltage across C1 than the previous one. Figure 5.7 uses a triode but if the pentode in Figure 5.8 were to have its screen grid connected to its plate it would be triode connected. The floating power supply from T2 which is filtered by C4, R10, C5, R11, and C6, keeps the screen grid of the pass tube a constant voltage above its cathode which makes it behave as a pentode or beam tetrode. Any ripple on the screen supply will appear in the output of the regulator so it must be very well filtered.

Most power tubes have a maximum heater to cathode voltage of 200 volts. If the output of the regulator is to go higher than this the heater and its supply must be floating. The dot showing a connection from one side of the heater to the cathode of the pass tube is not a mistake.

The negative supply for the two seriesed VR tubes is derived from the negative half of the bridge on T1 and filtered by R1, C2, R2, and C3. R3 sets the current through the VR tubes and isolates them from C3. If a capacitor is placed in parallel with a VR tube it will form a relaxation oscillator just like the neon lamp type we used to build for science fair projects.

R1 dissipates more power than would be calculated based on the DC current. The output of the bridge rectifier has an AC component which has a peak to peak value equal to the peak value of half of the transformer secondary. Almost all of the AC component of current in R1 flows back to the center-tap through C2. Thus, R1 is carrying the DC plus the AC components of current. The power dissipated cannot be calculated without the use of calculus. Therefore it is recommended that this resistor be considered to be dissipating two or three times what the DC calculation yields.

Current Limiting?

I have never seen a vacuum tube power supply that was protected by a current limiting circuit. That is not to say they never existed, it's just that I have never seen one. My attempts to design such a circuit on paper have become very complicated and I doubt if they would work reliably. The only over current protection I have seen in a tube power supply is the obvious one of a fast acting fuse in series with the output or an over current relay. Think of an over current relay as being a self resetting circuitbreaker.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

5.3 Switching Mode Power Supplies.

The earliest switching mode power supplies were developed to improve the efficiency of the analog regulators shown above. Such regulators are likely to be 50 percent efficient or less. A more efficient circuit is shown below.

Figure 5.9, Early Switching Regulator Circuit.

For a verbal description click here.

The power connections to the triangular wave generator and comparator are not shown but they are assumed. If they were not present the circuit would not work.

Notice in the circuit above that the transistor is now a PNP. It acts as a switch not an analog amplifier. When the output level of the comparator which drives it is low Q1 is on. When the comparator output is high Q1 is off. When Q1 is off the power is zero. When it is on the voltage drop is small typically 0.1 to 0.5 volts depending on the current. The power is still very small for a current of 1 amp it can be as low as 250 mW.

The inductor and C2 smooth the output. When Q1 turns off the inductor produces a negative going pulse at its left end. D6 prevents this pulse from going to huge negative values that would burn out Q1.

A comparator is a device that compares two analog voltages and produces a binary output. If the noninverting input is higher than the inverting input the output is high. If the noninverting input is lower than the inverting input the output is low.

The triangular wave is applied to the inverting input. The horizontal line on the waveform is the assumed level of the noninverting input. The output wave is what would be produced.

Suppose that this is the equilibrium condition. If the load current increases the output voltage will decrease which will cause the output of the op amp to increase. The horizontal line on the triangular wave will move up and the negative pulses from the comparator will become wider. That means that Q1 will be on for a larger percentage of the time. This permits Q1 to deliver more current to the load and the output voltage will be maintained at almost the original value.

If Q1 shorts the output voltage goes up to maximum and won't come down. If either the op amp or comparator shorts to rail the output will go either to maximum or zero. If the triangular wave generator stops working the regulator circuit will seem to be working but the voltage will be bouncing up and down by some amount. Just how much and at what frequency cannot be predicted without knowing details about the regulator. It will likely be switching at a much lower rate and the output will have a definite triangular wave superimposed on the DC. Without the triangular wave generator the circuit will generate its own triangular waves.

Figure 5.10, Isolated Switching Mode Power Supply Circuit.

For a verbal description click here.

The circuit above is not regulated but is strictly open loop. It's advantages are high efficiency, light weight, and small space.

The switching frequency is quite high to place it well above the range of human hearing. That means that the transformer needs very little iron and can be small and light. Because the transistors operate as switches they dissipate little power.

The high switching frequency and fast switching transistors used mean that the circuit produces strong harmonic frequencies well into the radio spectrum. In order to reduce this interference to below 1 microvolt the entire circuit would have to be placed in a cast iron box with multi section multi compartment filters on all leads passing through the wall of the box. This would mostly defeat the purpose of a switch mode power supply.

R2 slightly forward biases the base emitter junction of the two transistors to insure that oscillation will start spontaneously. After oscillation starts capacitor C2 builds up a negative charge and R1 limits the base current to a safe value. R1 also sets the maximum base current so if it should increase in value the output power of the supply would be somewhat down.


Troubleshooting Chapter Six. Faults in Transistor Circuits.

Chapter 6   Faults in Transistor Circuits.

6.1 Common Emitter Amplifier.
6.2 The Emitter-follower's Fatal Flaw.
6.3 AC Coupled Amplifiers.
6.4 DC Coupled Amplifiers.
6.5 Radio Frequency Amplifiers.
6.6 Switching Circuits.

Chapter 6.

Faults in Transistor Circuits.

Discrete transistor circuits are found in almost every area of electronics. Transistor circuitry is to be found in consumer, industrial, automotive and military electronics. The importance of knowing how to troubleshoot transistor circuits cannot be over-emphasized. In this chapter we will examine the minimal circuits that are the building blocks of larger circuits.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

6.1 Common Emitter Amplifiers.

One of the most common uses of transistors is to provide signal amplification. The most common amplifier configuration is the common emitter amplifier.

In this and following chapters we will refer to voltages at particular points. Everyone knows that there is no such thing as a voltage at a point, only voltages between two points. When we speak of a voltage at a point, the other point is assumed to be ground. Imagine that one lead of our voltmeter is connected to the ground point of the circuit. When we speak of the voltage at a point we are connecting the other lead of our voltmeter to that point. Thus the voltage at a point is the voltage between that point and ground.

Figure 6.1 Constant Voltage Biasing.

For a verbal description click here.

Figure 6.1 is the circuit of the most popular method of biasing a common emitter amplifier. Typical voltages for this circuit would be VE (emitter to ground voltage) = 1.13 volts, VB (base to ground) = 1.73 volts, and VC (collector to ground) = 6.79 volts.

Suppose now that we observe the following voltages: VE = 1.5 volts, VB = 1.8 volts and VC = 12 volts.

The fact that VC = VCC indicates no voltage drop across the collector resistor and therefore no collector current. A shorted collector resistor can be ruled out because resistors rarely short.

VE - VB < 0.6 v could indicate a base-emitter short in the transistor, or could it? A base-emitter short would effectively place RE in parallel with R2. The parallel combination is (1.2 k ohms x 6.8 k ohms)/(1.2 k ohms + 6.8 k ohms) = 1.02 k ohms and the voltage divider equation gives a voltage at the base of 12 v x 1.02 k ohms /(1.02 k ohms + 39 k ohms) = 0.31 v. Since the measured voltage is 1.8 volts, a base to emitter short can be ruled out.

A short in the transistor involving the collector would make the collector and base voltages to be the same. Thus we can rule out a shorted transistor.

Because the voltage at the base is normal we can also rule out any trouble in R1 or R2.

If the collector resistor were open, the transistor collector would try to draw current and pull the collector voltage down to very near the emitter voltage. Thus we rule out the collector resistor.

After you have ruled out all other possibilities the one which remains is the answer. The emitter resistor open is the only thing not ruled out. Let us check the logic to see if it makes sense.

If the emitter resistor opens there can be no emitter current. With no emitter current there is also no collector current. No collector current means that there is no voltage drop across the collector resistor. Thus VC = VCC.

As a further consequence of no emitter current, the base-emitter junction will not be forward biased, VBE = 0.6 volts, which means that VE is closer than normal to VB. Since there is no base current, the voltage at the base will be normal or may increase slightly. All clues are consistent. The emitter resistor is open.

Suppose that we observe VE = 0, VB = 0 and VC = 12 volts. In this circuit there is no failure mode of the transistor which can make the base voltage zero. If R1 opens, there can be no current through R2 and no bias for the transistor. The transistor will be in cutoff; VE will be zero and VC = VCC. The answer must be R1 open.

Suppose we observe VE = 2.3 volts, VB = 2.9 volts and VC = 2.4 volts. There are two possibilities here, either the transistor is shorted (everything to everything) or the transistor is being driven into saturation. We will examine each possibility in turn.

If the transistor were shorted, the circuit would become that of figure 6.2. This places R1 in parallel with RC which is (39 k ohms x 5.6 k ohms)/(39 k ohms + 5.6 k ohms) = 4.90 k ohms and also R2 in parallel with RE (1.2 k ohms x 6.8 k ohms)/(1.2 k ohms + 6.8 k ohms) = 1.02 k ohms. The two parallel combinations make up a voltage divider. When we calculate the voltage we find 12 v x 1.02 k ohms /(1.02 k ohms + 4.90 k ohms) = 2.07 volts. If everything were shorted we should measure 2.07 volts at base, emitter and collector.

Figure 6.2 Figure 6.1 With a Shorted Transistor.

For a verbal description click here.

The only failure which could drive the transistor into saturation would be R2 open. If R2 opens, all of the current which flows through R1 will flow into the base of the transistor. We can calculate the base current as follows. From the voltage measurements above we see that the voltage at the base is approximately 3 volts. That leaves 9 volts to drop across R1. The current in R1 is 9 v / 39 k ohms = 230 microamps. If beta is 50 the collector current could be as high as 230 microamps x 50 = 11.5 mA. The resultant drop across RC is 11.5 mA x 5.6 k ohms = 64.4 volts. This is impossible! It is much greater than the power supply voltage. The transistor is in hard saturation. The fact that VB is different from VE is a strong (but not absolute) indication that the transistor is not shorted. It is time to shut down the power and make some ohmmeter tests.

Ohmmeters and Transistors.

Ohmmeters must be used on transistor circuits with some caution, not because of any danger of damage to the circuit but because of the danger of arriving at the wrong conclusion. Analog and digital ohmmeters work quite differently and you can be badly misled if you fail to understand the difference.

A digital ohmmeter applies a constant current source to the resistance under test and measures the voltage drop which results. Since the function V = I x R is linear, the scale is linear. The maximum voltage at full scale is 0.2 volts. This is not enough to forward bias a silicon P-N junction. What this means is that you cannot use a digital ohmmeter to test semiconductor devices. The meter will indicate over-range no matter what you do. You can use a digital ohmmeter to test resistors in transistor circuits without removing them from the circuit.

Many newer DMMs have a diode test position on the range switch. In this position the full-scale range is 2 volts (1.999) and a good P-N junction will indicate approximately 0.6 volts in the forward direction and over-range in the reverse direction.

An analog ohmmeter applies a voltage to the resistance under test and measures the current which flows. The ohmmeter scale is very nonlinear because I = E / R is nonlinear. The voltage applied is 1.5 volts on all but the RX10,000 range, where it is 9 volts. This voltage is sufficient to forward bias P-N junctions. You can use an analog ohmmeter to test transistors out of circuit.

In order to use an analog ohmmeter to test semiconductor devices you must know which lead of the ohmmeter is charged positively. In the case of the Simpson model 260 the terminal marked + is positive and the one marked "common" is negative. Many manufacturers are not as careful in designing their ohmmeter circuits. There are many analog ohmmeters on the market in which the terminal marked + is actually the negative side of the ohmmeter voltage source. The best way to find out is to use another test instrument to test the voltage at the ohmmeter terminals.

When you use an analog ohmmeter to test P-N junctions, you can determine if they are good, open or shorted.

When you connect the ohmmeter so as to forward bias the junction it will indicate a relatively low resistance. The actual value will be different on different ranges because a P-N junction does not obey Ohm's law.

When you connect the ohmmeter so as to reverse bias the junction the meter will indicate infinite resistance.

If a P-N junction is shorted the ohmmeter will show the same low resistance value in both directions. This value may range from 0 to a few ohms and will likely obey Ohm's law.

If the P-N junction is open it will indicate infinite resistance in both directions.

Example 6.1.

In the circuit of figure 6.3 the normal voltages are VE = 1.1 v, VB = 1.8 v and VC = 10.9 v. After the circuit develops a fault a low cost analog VOM is used to make the following voltage measurements: VE, VB and VC are all approximately 6 volts. What is wrong?

Figure 6.3 Circuit for Example 6.1.

For a verbal description click here.

Solution:

With all voltages being the same, our first conclusion might be that the transistor is totally shorted. If the transistor were shorted (everything to everything) the circuit of figure 6.4 would result. This fault places R1 in parallel with RC and R2 in parallel with RE. The two parallel combinations form a voltage divider across the power supply.

Figure 6.4 Figure 6.3 With a Shorted Transistor.

For a verbal description click here.

R1 in parallel with RC is (27 k ohms x 4.7 k ohms) / (27 k ohms + 4.7 k ohms) = 4.0 k ohms. R2 in parallel with RE is (4.7 k ohms x 4.7 k ohms) / (4.7 k ohms + 4.7 k ohms) = 2.35 k ohms. Applying the voltage divider equation gives VEBC = 12 v x 2.35 k ohms / (2.35 k ohms + 4.0 k ohms) = 4.44 volts. This seems rather far away from the measured value of 6 volts.

If R2 opened the circuit would become that of figure 6.5.

Figure 6.5 Figure 6.3 With R2 Open.

For a verbal description click here.

This would cause the transistor to be driven into hard saturation. The measured voltage indicates a drop of approximately 6 volts across R1. Since all of the current through R1 flows into the base of the transistor, the base current is 6 v / 27 k ohms = 220 microamps. Assuming 50 as a reasonable value for beta, the collector current could be as high as 50 x 220 microamps = 11 mA. If this current could flow through RC it would produce a voltage drop of 11 mA x 4.7 k ohms = 51.7 volts. This impossible voltage indicates that the transistor is in hard saturation. A transistor which is held in saturation has the equivalent circuit of figure 6.6.

Figure 6.6 Equivalent Circuit of Figure 6.3 With R2 Open.

For a verbal description click here.

If we neglect the drop across the diode in figure 6.6, we have a voltage divider consisting of R1 in parallel with RC and the parallel combination is in series with RE. The voltage at all elements is VEBC = 12 v x 4.7 k ohms / (4.7 k ohms + 4.0 k ohms) = 6.48 volts.

The possibility that the transistor is shorted gives a voltage of 4.44 volts and the possibility that R2 is open gives 6.48 volts. The original measurement was approximately 6 volts. 6.48 is closer to 6 than 4.44 v; therefore, the answer must be that R2 is open. If the transistor is good, the voltage at the base would be 0.6 or 0.7 volts higher than that at the emitter. Since our cheap voltmeter did not show us this difference between 6 and 6.6 volts, it could not show us the difference between 6 and 6.48 volts.

Troubleshooting Without a Voltage Chart.

While the major manufacturers are very good about providing typical AC and DC voltage measurements, these companies can be counted on the fingers of one hand. There are dozens of medium sized and hundreds of small manufacturers who provide electronic equipment to industry and education. The owner's manuals provided by these lesser companies range from rough to downright primitive. A schematic diagram is about all you can expect. If you get a circuit board layout, consider yourself indeed fortunate. If you do get normal operating voltages, buy stock in the company while it is still cheap.

Small companies are often able to provide quality equipment at a lower price than a large company would ask. It is for this reason that you are likely to encounter such equipment in your career.

Suppose you are working on a piece of equipment from one of these smaller manufacturers and you measure the collector voltage of a transistor. You don't know any more after you make the measurement than you did before you made it. The reason is, of course, you don't know what the voltage is supposed to be.

If you are not given the voltages, you must calculate them yourself. Let us calculate the voltages in figure 6.1.

Note: If you follow the links below, use your back button to return here.

First, we will calculate the Thevenin equivalent of R1 and R2 in the base circuit from Equations 4.18 and 4.19. VBB = 12 v x 6.8 k ohms / (6.8 k ohms + 39 k ohms) = 1.78 volts. RB = 6.8 k ohms x 39 k ohms / (6.8 k ohms + 39 k ohms) = 5.79 k ohms.

If we don't know beta we can apply Equation 4.24.

Ic = (VBB - VBE)/RE = (1.78 v - 0.6 v)/1.2 k ohms = 0.983 mA.

We may want to use Equation 4.23. To do so we must make a guess as to the beta of the transistor. It will do little good to look up the transistor in a transistor manual. Values of beta even for transistors of the same type number can range from 25 to 250 and are listed as such in the manual.

Let us make a slightly pessimistic guess that the transistor's beta is 50.

Ic = (VBB - VBE)/(RE + RB/beta)

Ic = (1.78 v - 0.6 v)/(1.2 k ohms + 5.79 k ohms / 50) = 0.897 mA.

To calculate VE we must know IE. IE = IC (1 + Beta) / Beta
IE =0.897 (51/50) = 0.915 mA. VE = IE RE = 0.915 x 1200 = 1.098 Volts.

The voltage at the collector is equal to VCC - IC x RC. VC = 12 v - 0.897 mA x 5.6 k ohms = 6.98 volts.

Example 6.2.

In figure 6.3 change R1 to 270 k ohms and R2 to 82 k ohms. Calculate the values of VB, VE and VC.

Solution:

Let us calculate the Thevenin values for the voltage divider circuit of R1 and R2. VBB = 12 v x 82 k ohms / (270 k ohms + 82 k ohms) = 2.80 v. RB = 82 k ohms x 270 k ohms / (82 k ohms + 270 k ohms) = 62.9 k ohms.

Equation 4.24 depends on the voltage drop across RB being small. Because of the large value of RB in this problem we cannot ignore this voltage drop. We must use Equation 4.23.

IC = (VBB - VBE)/(RE + RB/beta)

IC = (2.80 v - 0.6 v)/(1.2 k ohms + 62.9 k ohms/50) = .895 mA.

VE = RE IC (Beta + 1) / Beta

VE = 1200 0.895 (51/50) = 1.095 volts.

The voltage at the base is VB = VE + 0.6 = 1.695 volts.

The voltage at the collector is equal to VCC - IC x RC. VC = 12 v - 0.895 mA x 5.6 k ohms = 6.99 volts.

By now you may be wondering if all of these calculations are worth the effort. You are likely thinking that you could change a resistor or transistor while someone else is making all of those calculations. Giving all of the details of a calculation in printed or written form always takes longer than it would on a calculator. An experienced person can finish the above calculations, using a pocket calculator, before the soldering iron gets hot.

Another way is to have a computer program that will perform the calculations and show the results. Such a program may be downloaded from this location. This program only works on windows computers in north America. Clicking on the link above will initiate download.

  1. After clicking the link you will be asked if you want to open or save the file. Select save.

  2. You can save it anywhere you want but remember where you saved it. I have a folder in My Documents named AAA as a place to put such files.

  3. After download completes close the dialog box if you didn't check the box that says "Close this dialog box when download completes.

  4. Open windows explorer and navigate to the folder where you downloaded the file. Select "Transistor_Q_Point.zip" in the left hand window and it will be unzipped and the three files it contains will display in the right hand window.

  5. If "Transistor_Q_Point.zip" won't show in the left hand window, double click it in the right hand window. A new explorer window will open and three files will be displayed in it.

  6. Double click "setup.exe" and the program will begin to install.

  7. Accept all defaults unless you have a strong reason for doing otherwise.

  8. When the installation is finished you will see the message "Transistor Q Point was successfully installed."

You will find that the program gives slightly different results from the calculations performed above. The computer program uses the exact equation which was derived in chapter 4 section 3 of Electronics for Physicists. Equation 4.22 is the most accurate and that was used in the program since there is no point in using approximations in a program. Most of the above results were obtained with equation 4.23 which neglects a Beta / (Beta + 1) term.

If your computer is not close to your workbench you may be very tempted by the process of "shotgunning" described in chapter 4 but beware. You can afford to fire the shotgun only once. If you fire it and miss, you could be in trouble with your supervisor or customer. There are faults which can be misleading as to which stage the trouble is in.

There are other faults which can occur in a common emitter circuit. These faults will be covered in sections 6.3 and 6.4.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

6.2 The Emitter-Follower's Fatal Flaw.

The fatal flaw in the emitter-follower is that the transistor can fail and the circuit can continue to function under some circumstances. A "tape output" on a stereo receiver might drive one tape deck but not another; a regulated power supply which is rated to deliver 500 mA will begin to current limit at 25 mA; an oscilloscope which, when new, had a bandwidth of 100 MHz, now has only a 30 MHz bandwidth. Faults involving the emitter-follower can be so subtle that they can go undiscovered for months or even years.

When an NPN transistor develops a base-emitter short it becomes equivalent to the circuit of figure 6.7.

Figure 6.7 NPN Transistor with B to E Short.

For a verbal description click here.

Figure 6.8 Emitter-Follower Circuit.

For a verbal description click here.

If we put this shorted transistor into the emitter-follower circuit of figure 6.8 the result is the circuit of figure 6.9.

Figure 6.9 Emitter-Follower with Shorted NPN BJT.

For a verbal description click here.

The diode which was the base-collector junction in the former transistor is now just a diode. In the circuit of figure 6.9 it will always be reversed biased. We may leave out this reversed-biased diode and our former emitter-follower circuit now is that of figure 6.10.

Figure 6.10 Equivalent Circuit of Emitter-Follower with Shorted BJT.

For a verbal description click here.

An emitter-follower has a voltage gain of approximately unity. The circuit of figure 6.10 has a voltage gain of unity, which is one of the reasons why the fault can be so hard to find. An emitter-follower has a current gain of approximately the beta of the transistor. The circuit of figure 6.10 has a current gain of less than unity, which is the reason it needs to be repaired.

Tape Output Buffer Amplifier.

Consider the AC coupled emitter-follower of figure 6.11. This circuit is often incorporated in the "tape output" circuit of stereo receivers or in the output circuit of tape decks or CD players. Although most tape decks have a high input impedance, occasionally one will come along which has a medium or even low input impedance. I happen to own one that has a 10 k ohm input resistance. If a consumer has more than one tape deck it is likely that "Y" connectors will be used to parallel the inputs of the decks on the one tape output. This is why the designer of the receiver put an emitter-follower in the tape output circuit.

Figure 6.11 AC Coupled Emitter-Follower Circuit.

For a verbal description click here.

If the transistor in figure 6.11 develops a base-emitter short, the circuit will become that of figure 6.12. If the receiver is being used with one tape deck which has a high input impedance the fault may never be noticed. The fault may show up when the consumer tries to add another tape deck to the system.

Figure 6.12 Emitter-follower with Base to Emitter Short.

For a verbal description click here.

The consumer will first blame the new tape deck. After being assured by the service technician that there is nothing wrong with the new deck, the receiver is likely to be the next item to appear on the service bench. The technician is unlikely to place any load on the tape outputs and the fault will not be found. The end result is an angry consumer who may never do business with that technician again.

A fault in an emitter-follower can be more easily found by DC analysis than by AC analysis. A typical set of DC voltages for the circuit of figure 6.11 is, VE = 7.3 volts and VB = 8.0 volts. Because the collector is connected directly to the +12 volt line the collector voltage will always be 12 volts. If the transistor develops a base to emitter short, R2 will be placed in parallel with RE and the equivalent resistance is (4.7 k ohms x 22 k ohms) / (4.7 k ohms + 22 k ohms) = 3.87 k ohms. The voltage divider now consists of a 10 k ohms and a 3.87 k ohms resistor. The voltage at base and emitter is 12 v x 3.87 k ohms / (3.87 k ohms + 10 k ohms) = 3.35 volts.

If measurement of DC voltages, (static testing), in an emitter-follower reveals voltages much lower than normal, you can bet your VOM that there is trouble in the circuit.

Wide Band Amplifier.

Now consider the circuit of figure 6.13. This circuit is typical of circuits found in the vertical amplifiers of oscilloscopes. These amplifiers are always differential or push-pull in configuration. The other half of the amplifier would be exactly like the half which is shown.

The emitter bypass capacitors have not been omitted from the drawing; there are none in the circuit. This introduces a large amount of emitter degeneration or negative feedback. Like all negative feedback this emitter degeneration increases the upper limit of frequency response. The designers are giving up gain to get increased bandwidth. The gain of the common emitter stages is approximately RC/RE.

Figure 6.13 Wide Band Amplifier.

For a verbal description click here.

The emitter-follower Q2 would seem to be completely superfluous. The output impedance of the Q1 common emitter stage is the same as the collector resistor, 1 k ohms. The input impedance of the Q3 common emitter stage is approximately equal to RE x beta, or about 17 k ohms. A 1 k ohms source certainly does not need any help to drive a 17 k ohms load. If resistance was all there was to it then Q2 would be superfluous.

Two factors which control the upper frequency limit of an amplifier are the characteristics of the transistors and the capacitance in the circuit. Assuming that Q1, Q2 and Q3 are the best that money can by, the upper frequency limit of the Q1 stage will be determined by the total amount of capacitance from the collector of Q1 to ground. This capacitance is the output capacitance of Q1 and its printed circuitry, plus the input capacitance of the following stage.

If the following stage were a common emitter, this input capacitance would be made up of the input capacitance of the transistor plus the capacitance of the printed circuitry plus the Miller capacitance of the common emitter stage. If the stage following Q1 is an emitter-follower, there is no Miller capacitance. The purpose of the emitter-follower stage (Q2) is to isolate the Miller capacitance of Q3 from the output of Q1.

If Q2 develops a base-emitter short, the Miller capacitance of Q3 is no longer isolated from the output of Q1 and the frequency response of the amplifier will be impaired.

DC measurements may not reveal the fault because the emitter-follower is not doing any work at DC. The fault may show up if careful measurement is made of the base to emitter voltage of Q2 using a DMM. But even this measurement is not an ironclad guarantee of finding the trouble. It usually comes down to pulling the transistors from the board and testing them out of circuit.

If a scope with impaired frequency response comes to the bench of a technician who is unaware of this kind of fault, he or she may work for days and not find the cause. It may even get as far as recommending that the scope be junked.

Example 6.3.

In the circuit of figure 6.13 the output capacitance of the Q1 stage is 1 picofarad and the input capacitance of the Q2 stage is also 1 pf. The input capacitance of Q3 is 1 pf and the Miller capacitance is 4 pf. What are (a) the normal upper frequency limit of the amplifier and (b) the upper frequency limit if Q2 develops a base to emitter short?

Solution:

(a) When the circuit is operating normally the capacitance across R1 is 1 pf + 1 pf = 2 picofarads. fC = 1 / (2 x ã x R x C) = 1 / (6.28 x 1 k ohms x 2 pf) = 79.6 Mhz. (b) Even if Q2 is shorted its capacitance does not disappear. The total capacitance is now CT = CoQ1 + CiQ2 + CiQ3 + CmQ3 CT = 1 pf + 1 pf + 1 pf + 4 pf = 7 pf. The new corner frequency is fC = 1 / (6.28 x 7 pf x 1 k ohms) = 22.7 Mhz.

Regulated power supply.

You may not have realized it but the pass transistor in a regulated power supply is an emitter follower. The circuit of a simple adjustable voltage power supply is shown in figure 6.14. The diagram has been arranged in such a way as to emphasize the fact that the pass transistor is an emitter- follower.

Figure 6.14 Regulated Power Supply.

For a verbal description click here.

Suppose that Q1 develops a base to emitter short. The circuit reduces to that of figure 6.15. This is just a noninverting amplifier whose gain is set by R1, R2, and R3. It is amplifying the voltage of the zener diode. That is all any regulated power supply does no matter how complex it may appear.

Figure 6.15 Regulated Power Supply After Q1 Develops a Base-Emitter Short.

For a verbal description click here.

If a power supply with a shorted pass transistor comes to your service bench you may wonder at first if it was operator trouble rather than equipment trouble. The output voltage comes up, it can be adjusted over its full range (assuming that the unit you are working on is adjustable) and the scope does not show any ripple. If you send it back to the lab with no further tests, it will be back on your bench within a day.

The output of a typical op amp (operational amplifier) will deliver about 25 mA. This is sufficient to supply current to the voltage adjust resistors and the power supply will function normally as long as there is no large load on the output.

When a power supply comes to your service bench you should always test the supply at its specified maximum current.

Figure 6.16 Regulated Power Supply with Darlington Pair.

For a verbal description click here.

Many regulated power supplies use a Darlington connected pair as the pass transistor, figure 6.16. If Q2 develops a base to emitter short the power supply will still work and will likely deliver an appreciable current, several hundred milliamperes. However, it will not perform up to its specified maximum current.

If Q1 develops a base to emitter short, Q2 will try to take over the duties of Q1. Q2 is not equipped with a large heat sink and will overheat very quickly. The power supply will seem to work normally for a short time and then catastrophically fail. Q2 will likely short everything to everything. The output voltage will go above specified maximum and stay there.

If both transistors in a Darlington pair have base to emitter shorts, the supply will be down to the bare op amp as shown in Figure 6.15. If you replace only one of the defective transistors you will create one of the situations described above.

The Cause of the Short.

You may be wondering how a base-emitter short can happen. The usual cause of any failure is difficult to pinpoint. Part of the fatal flaw in the emitter-follower is that it has its cause of failure built in.

Consider the circuit of figure 6.11 again. If there is no load connected to the output when the power is turned on, C2 will remain discharged. If the output is then shorted momentarily to ground, the capacitor will be charged through the emitter of the transistor. The pulse of current is short, but it can be several amperes in magnitude. This extremely large current pulse can burn out the base-emitter junction of a small transistor. The collector-base junction is larger in cross-section area and is usually not damaged.

It is possible to burn out the tape output buffer in a stereo receiver very easily. If the owner makes connections to the tape output with power turned on, the capacitor in the output will start out with no charge on it. In the process of connecting the cables it is possible to momentarily short the output and there goes the emitter-follower transistor. This is a documented and repeatable failure in a stereo receiver from a well known manufacturer.

A modification which will prevent burning out the transistor is to connect a resistor of about 470 k ohms from ground to the terminal marked "output" in figure 6.11. This will make sure that C2 gets charged even if there is nothing connected to the output. It is the charging of C2 through a dead short, not a resistor, which can destroy the transistor.

In the case of a power supply the pass transistors can be zapped if the power supply is forced to charge a large external capacitor each time the power supply is turned on. The current limiting circuits should prevent such damage but if it is a little slow to respond the pass transistors may experience a large amplitude current pulse.

We have cited only three uses of emitter-followers, there are many others. All are subject to the same kind of failure and all can be a little tricky to find.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

6.3 AC Coupled Amplifiers.

AC coupled amplifiers make up a significant percentage of amplifier circuits. They are used in audio, radio frequency and industrial applications.

An AC coupled amplifier is shown in figure 6.17. The emitter resistors are bypassed to increase the gain to the maximum. Capacitor C1 prevents whatever may be connected to the input from upsetting the base bias of Q1. C3 prevents the DC voltage at the collector of Q1 from upsetting the base bias of Q2 and C5 prevents the DC voltage at the collector of Q2 from reaching whatever is connected to the output.

DC Voltage Measurements.

If an emitter bypass capacitor shorts, the emitter voltage of that transistor will be zero. The voltage divider in the base will cause a very large base current to flow, which will drive the transistor into hard saturation. The typical voltages for a shorted bypass capacitor will be VE = 0 v, VB = 0.7 v and VC = 0.1 v.

Figure 6.17 Two Stage Common Emitter Amplifier.

For a verbal description click here.

The results of a short in C1 are difficult to predict without knowing what is connected to the input. Suppose that a dynamic microphone is connected there. It is typical for a dynamic microphone to have a DC resistance of only a few tens of ohms. If C1 shorts, it will remove all bias from the base of Q1 and cause Q1 to be driven into cutoff. Typical voltages for this condition will be VE = 0 v, VB = 0 v and VC = VCC.

If C3 shorts, the result will depend on whether the voltage at the collector of Q1 is greater than or less than the voltage at the base of Q2. The two voltages will become equal and Q2 will be in either saturation or cutoff depending on whether VCQ1 is greater or less than VBQ2. Typical voltages cannot be given because they depend on the values of the resistors.

The effect of a short in C5 depends on what is connected to the output. If it were one side of a pair of headphones, the DC resistance would be very low, about 6 ohms. This would pull the collector voltage down and forward bias the base-collector junction. The transistor may not be damaged but it certainly will not amplify. Typical voltages would likely be VE = 0 v, VB = 0.7 v and VC = 0 volts.

AC Voltage Measurements.

If you are signal tracing instead of making static tests, you will see the signal suddenly disappear at the defect. A transistor which is in cutoff or saturation does not provide a signal path. Some types of faults can make you think that the trouble is in the stage ahead of where it actually is.

Suppose that Q2 in figure 6.17 develops a base-emitter short. The emitter is connected to ground through a capacitor. Because the base is shorted to the emitter, the base will be at AC ground potential. C3 also has a low reactance for AC and so the collector of Q1 is effectively shorted to ground for AC. The signal is no longer present at the collector of Q1 because it is shorted out by the series combination of C3, the base to emitter short in Q2 and C4.

When signal tracing, you would find signal at the base of Q1 and no signal at the collector of Q1. Your first conclusion would be that the trouble is in the Q1 stage. DC measurements would reveal that all in the Q1 stage is well. DC measurements in the Q2 stage will reveal the base to emitter short. This false clue is a very common phenomenon in transistor circuits.

A transistor which is being driven into hard saturation may appear as a short circuit to the signal. When the AC signal disappears, you must check the stage just after the point where the signal disappeared as well as the one where it disappeared.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

6.4 DC Coupled Amplifiers.

A DC coupled amplifier is one in which the stages are coupled together without using capacitors. Sometimes this is done because the amplifier must have gain all the way down to and including DC. Sometimes the reason is economics.

One of the miniature capacitors which are used in transistor circuits can cost 4 or 5 times as much as a resistor. The capacitors may even cost more than the transistors. Therefore, if it is possible to replace one capacitor with three resistors, the design engineer will do it. Even in circuits where the signals are AC only, it is very common to see groups of two, three or even four stages which are DC coupled.

A two-transistor DC coupled gain block is shown in figure 6.18. R4 is present to allow negative feedback to be applied to the emitter of Q1. If no feedback is to be connected, R4 can be replaced with a piece of wire. With R4 = 0, this circuit can provide the same amount of gain as the circuit of figure 6.17. The circuit of figure 6.18 with R4 = 0 does the same job with only 5 resistors and 3 capacitors, as opposed to 8 resistors and 5 capacitors for figure 6.17.

Figure 6.18 Two-stage DC Coupled Amplifier.

For a verbal description click here.

Operating point stabilization (DC feedback) is provided by R1 and R2 from the emitter of Q2 to the base of Q1. AC feedback along this path is prevented by C2, which bypasses AC signals at the emitter of Q2 to ground.

AC feedback is often added to this circuit by making R4 some low value, say 100 ohms, and coupling signal from the output back to the emitter of Q1.

If Q1 goes totally shorted, all of the voltages in the circuit will go nearly to zero except the collector of Q2, which will go up to VCC. The reason for this is as follows. When Q1 shorts out, all of its voltages will be equal to each other. R4, if it exists at all, is a low value and its voltage drop is very small. The short in Q1 will pull the base of Q2 down and send Q2 into cutoff.

If Q2 goes totally shorted, the emitter voltage of Q2 will remain normal, provided that R5 and R6 are not too low compared to R3. The DC feedback from the emitter of Q2 to the base of Q1 is responsible for this. The voltages at the collector and base of Q2 will be equal to the emitter voltage. The circuit with this defect will not provide gain for AC because C2 bypasses all signals to ground.

Example 6.4.

The normal voltage chart for the circuit of figure 6.18 is as follows.

VE | VB | VC
Q1 | 0 v | 0.6 v | 4.0 v
Q2 | 3.4 v | 4.0 v | 8.3 v

A fault develops and the voltages become:

VE | VB | VC
Q1 | 0 v | 0.6 v | 1.6 v
Q2 | 1.0 v | 1.6 v | 10.9 v

What is wrong?

Solution:

The transistors are not shorted because both have VB > VE and VC > VB. We conclude that both transistors are good. The voltage drop across R1 is 0.4 volts. This indicates that the current through R1 is not what it used to be. This could only be caused by R2 being open.

In example 6.4, the feedback is what causes the circuit to behave in the way it does. The voltage at the emitter of Q2 will be adjusted to whatever is necessary to make the voltage at the base of Q1 be 0.6 volts. As long as R1 and R2 are intact the emitter of Q2 adjusts to 3.4 v to forward bias Q1 by just the right amount. In this circuit you might assume that if R2 opened, the transistor would be driven into hard saturation. But if the base is receiving too much bias the collector voltage of Q1 will come down and the emitter voltage of Q2 will follow. The emitter of Q2 will assume whatever voltage is necessary to provide just the right amount of bias to the base of Q1.

This is another one of those circuits which will continue to work even with a defect, especially if there is AC feedback to the emitter of Q1. The circuit will function quite normally for small signals. On larger signals the positive peaks will be clipped off. This is because the voltage at the collector of Q2 (10.9 volts) can only go up to 12 volts but it can go down to about 1 volt.

If R3 opens there will be no current path from the collector of Q1 to VCC. The collector of Q1 which is also the base of Q2 will fall to its lowest possible potential. The voltages will be much the same as if Q1 had shorted, except if R4 is present, there will be absolutely no voltage drop across it because there is no current through it.

If R5 opened, the voltage at the collector of Q1 would fall until it became equal to the emitter voltage. All other voltages in the circuit may be normal, depending on the relative values of R3 and R6, because of the DC feedback through R1 and R2.

When R5 opens, R3 and R6 become a voltage divider with the base-emitter junction of Q2 acting as a forward biased diode. If R3 is much larger than R6 it will be unable to pull the voltage up to the normal emitter voltage. If the voltage divider of R3 and R6 can assume a voltage greater than the normal emitter voltage of Q2, the collector current of Q1 will pull the voltage down to the normal value.

Depending on the load impedance the circuit may still provide gain while adding some distortion. However, the sign of the gain will be changed. When the circuit is working normally it is a noninverting amplifier. When R5 opens, Q2 is no longer an inverting amplifier. With only Q1 doing any amplifying, the overall gain of the circuit is inverting. If this circuit is in the middle of a larger feedback loop the feedback can change from negative to positive.

If R6 opens, the emitter current of Q2 will be only that which flows through R1 and R2. The voltage at the collector of Q2 will rise to very nearly VCC. All other voltages in the circuit will be normal because of the regulating effect of the feedback.

Figure 6.19 shows a configuration involving an NPN and a PNP transistor. This circuit is stabilized by DC feedback from the tap on the collector resistor of Q2 which feeds back a portion of the output voltage to the emitter of Q1. The voltage at the node between R4 and R5 will adjust itself until Q1 has just the right collector current to provide just the right amount of bias to Q2.

Figure 6.19 Complementary DC Coupled Amplifier.

For a verbal description click here.

The feedback path also passes AC. The gain of this circuit is set at 10. If higher gain is required, the variation of figure 6.20 may be used.

If Q1 in figure 6.19 shorts, it will effectively place a 100 ohm resistor from the base of Q2 to ground. This will unquestionably drive Q2 into hard saturation. The base current will be approximately 120 mA, assuming a 12 volt power supply. This excessive base current may destroy Q2 as well. In the circuit of figure 6.20 R4 will prevent excessive current from flowing and Q2 will likely survive.

In figure 6.19 if R2 opens, Q1 will receive constant current bias through R1. This will increase the collector current of Q1 and in turn increase the collector current of Q2, driving it into saturation. The voltage at the collector of Q2 will be 12 volts but the voltage at the emitter of Q1 will be higher than the expected value of 1.2 volts. The reason is the emitter current of Q1 has become significant compared to the current flowing through R4 and R5. In a test circuit with R2 open the emitter voltage of Q1 was 3 volts.

If R3 opens, the effect may never be noticed. A slight reduction of bandwidth at high signal levels will be the only observable effect.

If R5 opens, the voltage at the collector of Q2 will fall to about 0.6 volts. This is because the feedback in the circuit will try to keep Q1 biased just right. The base of Q1 is set at 1.2 volts by R1 and R2. In order to keep Q1 properly biased, the emitter voltage must be 0.6 volts. With R5 open the voltage drop across R4 is extremely small. Thus the collector of Q2 will be at 0.6 volts.

If R4 opens, the result will be to cause the collector current of Q1 to be very high. The opening of the current path to the collector of Q2 means that the emitter of Q1 must conduct all of the current which is flowing through the resistors to ground. Q1 cannot saturate because of the base- emitter junction of Q2 in its collector circuit. The collector voltage of Q2 will be VCC because it is in saturation and its collector resistor is open.

In figure 6.20 an additional resistor has been added to raise the impedance at the emitter of Q1. The emitter of Q1 is bypassed by C2 which removes all AC feedback. If some AC feedback is needed to lower the gain, a small amount of resistance may be inserted in series with C2.

Figure 6.20 Complementary Amplifier Without AC Feedback.

For a verbal description click here.

If Q1 shorts, R4 will protect Q2 from being subjected to excessive base current, as was the case for figure 6.16.

In figure 6.20 if Q2 shorts, its collector voltage will become approximately 12 volts, which will increase the voltage applied to the emitter of Q1. The voltage at the base of Q1 is fixed by the voltage divider of R1 and R2. The short in Q2 will pull up the emitter voltage of Q1 to the point of reverse biasing the base-emitter junction of Q1. This will bias Q1 into cutoff.

If R1 opens, both transistors will be driven into cutoff and the voltage at the collector of Q2 will be zero. All other voltages will be what you would expect with both transistors in cutoff.

If R2 opens, both transistors will be in saturation. R4 in the emitter of Q1 will permit Q1 to make it into saturation.

If R3 opens, the effect will be quite noticeable. The collector current of Q1 will be reduced to equal the base current of Q2. This decreases the emitter current of Q1 which will cause the voltage drop across R4 to be reduced. Since the base voltage of Q1 is held nearly constant by the voltage divider of R1 and R2, the emitter voltage will change very little. The voltage at the node where R4, R5 and R6 join will increase. Calculations indicate and tests verify that for the given resistor values, Q2 will be biased into saturation.

If R6 opens, the voltages measured at the terminals of the transistors will change only very little. However, the voltage at the node connecting R4, R5 and R6 will rise from about 3 volts to become equal to the collector voltage of Q2 (about 6 volts). The blame is once again placed on that feedback which does its best to keep the circuit working no matter what is wrong. The circuit will adjust itself to properly bias Q1.

In actuality, both transistors are in cutoff. When a voltmeter is connected to the collector of Q2 it, the voltmeter, provides a load resistance to complete the current path. Both transistors are now conducting very small currents. An additional effect may be that the circuit which was previously dead may come to life (begin to amplify AC signals) when the voltmeter is connected and go dead again when the voltmeter is removed. This may lead one to a false conclusion that there is a loose connection in this part of the circuit.

If R5 opens, the result will be to place Q1 in saturation. The opening of the current path to the collector of Q2 means that the emitter of Q1 must conduct all of the current which is flowing through the resistors to ground. For almost any combination of resistor values this will put Q1 into saturation. When Q1 saturates, Q2 saturates.

Let us now return to a circuit which we looked at earlier, figure 6.13. In section 6.2 we discussed the effects of a short in Q2.

If Q1 shorted, the effect would be to place the emitter and collector resistors in series across the power supply. The collector voltage would be decreased. Q2 will pass this voltage through and decrease the bias on the base of Q3. This may or may not drive Q3 into cutoff. It will depend on the values of the resistors and the power supply voltages.

The following discussion will concern the effect of a total short in Q3. The same effect may well show up if Q1 were to short instead of Q3. Figure 6.13 does not show us what is driving the base of Q1. If it is an emitter follower, the effect would be the same. If it is a higher impedance source, the amplifier may simply go dead.

A total short in Q3 will convert it into a node connecting the emitter of Q2 to the bottom of R4 and the top of R5. While this does place quite a heavy load on Q2, the emitter follower could drive it.

Signals which are injected into the amplifier will come through even with a short in Q3. The gain of 3 which Q3 normally provides will become unity. That is a relatively small change.

The effect on phase shift is the one which will be most noticeable. A common emitter stage such as Q3 in normal operation inverts the input signal. A node connecting some resistors together provides no inversion. The amplifier shown in figure 6.13 is a noninverting amplifier with a gain of 9. When Q3 shorts, the amplifier becomes an inverting amplifier with a gain of 3.

Circuits such as figure 6.13 do not stand in isolation. A circuit such as this will be a small part of a much larger circuit. If the larger circuit has negative feedback, the loss of an inversion will cause this to become positive feedback.

If the feedback is AC coupled, the circuit will oscillate at some unpredictable frequency. If the entire feedback loop is DC coupled, the circuit will simply latch up at one extreme of voltage.

If the larger circuit is an electro-mechanical control system, the system will drive away from the proper point instead of towards it as it should. It will run to the mechanical limit where the limit switches will cause it to stop.

A small loss of gain inside a feedback loop can easily go unnoticed but a change of phase is very noticeable. An amplifier which oscillates or latches up or a control system which drives the wrong way can be a very puzzling situation.

Assume that the circuit of figure 6.13 is part of a sub- assembly which has been removed from a large system and taken to the repair shop. Because the circuit has been removed from its normal signal sources, signal substitution must be used for testing.

The diagram should indicate whether the amplifier unit is inverting or noninverting. The very first test should be to confirm that the phase of the amplifier is correct. If it is incorrect, some very careful testing will be necessary.

Set up the oscilloscope so it is triggered from the signal source. At each stage the scope will show the phase relationship between the input signal and the signal at the test point.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

6.5 Radio Frequency Amplifiers.

Radio frequencies are those that are higher than the audio band. It may surprise you to know that there is actually some overlap. The Omega Navigation system, no longer in operation, used a frequency range from 8 to 12 kHz. With the proper filtering to remove the power line frequency and its harmonics an audio amplifier could be connected to an antenna and some of these transmitters could be heard as they were switched on and off.

What distinguishes an RF (Radio Frequency) amplifier from an audio amplifier is that the former contains one or more LC resonant circuits to restrict the band of amplification to a narrow range of frequencies.

Common emitter amplifier.

Figure 6.21 Typical IF Amplifier used in Pocket Radios.

For a verbal description click here.

This circuit is typical of the IF (intermediate frequency) amplifiers found in most transistor sets particularly those 6 transistor pocket radios. Transistors are low impedance devices and the input impedance is especially low. The tuned transformers have been designed to work with transistors operating at a supply voltage of from 9 to 12 volts.

The transistor is a triode device and as such has a significant amount of capacitance from input (base) to output (collector). In tubes this problem was solved by adding another grid but this is not possible in a transistor. Therefore an RF amplifier must be neutralized. Note that the Vcc is applied to a tap in the middle of the coil which is not in the exact center. This serves two purposes, one, the impedance between the tap and the near end is lower than the impedance across the entire coil. This prevents the low output impedance of the transistor from lowering the Q of the tuned circuit. Second, by connecting the coil as shown the phase of the voltage at the other end of the coil is 180 degrees out of phase with the voltage at the collector. By connecting a small capacitor, less than 10 pf, from this point back to the base the feedback through the collector to base capacitance of the transistor is canceled by an equal and opposite amount of feedback from the transformer through the capacitor to the base. This is a small ceramic capacitor and its failure is unheard of. If it were to open the amplifier would be likely to oscillate. If it were to short the transistor would be placed in saturation and the circuit would cease to amplify. If the IF strip uses AGC the positive bias is likely to be conducted along the AGC line making it difficult to isolate the problem to a particular stage.

KEEP YOUR SCREWDRIVER OUT OF THE TRANSFORMER ADJUSTING SLUGS!

If the radio or tuner isn't working it isn't because the adjustment screws turned themselves. The cause of the problem is a defective component not because the tuned circuits are mistuned. The only exception to this rule is if an uninformed owner tinkerer tightened up all the loose screws. Also the slugs are made of a material something akin to glass but not as hard. They are held in place by hardened paraffin and will not move easily. If you insert a metal screwdriver and start twisting the result will usually be a broken slug. If you can verify that alignment is necessary the IF transformers in question should be gently warmed under a heat lamp, with a hair dryer, or with a heat gun held a considerable distance away.

Open coils and open resistors are more likely than shorted capacitors since the capacitors are usually ceramic with voltage ratings of 50 volts and have a very low probability of failure. DC measurements around the circuit should find the fault. The same formula used in audio amplifiers may be used to calculate the voltages if they are not given.

Grounded or Common Base Amplifier.

Figure 6.22 Two examples of grounded base amplifiers.

For a verbal description click here.

The transistor is constructed with the base physically between the collector and emitter. If the base could be grounded it would act as an electrostatic shield between the emitter and collector. When the emitter is used as the input element the impedance is quite low typically 25 millivolts divided by the emitter current. As you can see for an emitter current of 1 mA the input impedance is 25 ohms. This is a rather rough approximation and should not be used in the design of impedance matching circuits such as transformers or pi networks.

Actually grounding the base is most effective in preventing oscillation even at VHF. The circuit of Figure 6.22 (a) might be found in a short wave receiver or FM tuner. In an S W receiver there most certainly will be band switching which will complicate the schematic. If you examine the diagram carefully you will be able to tease out the basic circuitry.

Figure 6.22 (b) is a circuit often seen in portable FM radios. Because these radios use a single polarity power supply the transistor must be biased with the usual three resistor circuit which means that the base must be grounded through a capacitor rather than directly. The coil is a low Q RF choke which is tuned to the center of the FM band by circuit capacitance. The impedance at the base of a ¼ wave antenna is low which is a match for the input impedance of the amplifier. DC measurements should turn up a fault but connecting a voltmeter lead or oscilloscope probe may well make the circuit start oscillating. It may be necessary to connect a short across the collector coil to kill this oscillation in order to obtain good measurements.

Cascode Amplifier.

Figure 6.23 Cascode Amplifier sometimes found in Ham Radio Projects.

For a verbal description click here.

This circuit is used by amateur builders who don't know or didn't stop to think that a field effect transistor is not constructed like a triode tube. Proper operation of the circuit requires that the upper device have an electrostatic shield between the source and drain. FETs are not constructed in this way. The channel which has the source on one end and the drain on the other is a small bar of N type silicon. The gate is a small dot of P type silicon on one side of the channel. The gate is not physically between source and drain. For the depletion region to serve as an electrostatic shield it would have to occupy the entire cross section of the channel. That would place the FET in total cutoff and it would not function as an amplifier.

If you ever have to deal with such a circuit it will most likely come to you as a newly constructed device that has never worked. Slight detuning of the input and output tuned circuits may make it stable enough to use. The circuit is most likely to appear in fixed tuned converters so there is no tracking problem to deal with.

Probably the best cure is to break the "don't modify" rule and change the upper FET to an NPN BJT. I have used circuits of this kind and they are very stable because the grounded base of the BJT does act as an electrostatic shield in the same way as the grid of the triode did in the original tube circuit that the semiconductor version was borrowed from. If a low noise BJT is used the circuit should be just as quiet as it was with the FET. It should actually be quieter because it isn't oscillating.

A modified version of this circuit was used in the FM tuner section of the Heathkit AR-15. Instead of a series coil from the drain of the bottom fet to the source of the top fet the signal was coupled by a combination of magnetic and capacitive coupling. In addition a third winding on this transformer provided neutralization to the circuit. Clearly it took some engineering to make this circuit work well enough for use in a production product. The tuner front end came preassembled and factory aligned in the kit.

Servicing anything more complex than an IF amplifier in an AM receiver is usually beyond the capabilities of small shops and hobbyists and is best left to factory service centers. The reason is that the arrangement of leads and components effects the alignment and neutralization. Replacing a transistor in a VHF amplifier will certainly require the neutralization of the circuit to be readjusted. To do so usually requires a network analyzer which is a very expensive and complex piece of test equipment.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

6.6 Switching Circuits.

Although switching functions have largely been taken over by integrated logic, there are occasions on which a very small amount of switching circuitry is required. On such occasions the designer may elect to use discrete transistor logic.

Consider the circuit of figure 6.24. In logic terms This is a noninverting buffer. A "high" input will cause base current to flow in Q1 which will turn it on. When Q1 is on, its collector voltage will be about 0.1 volt ("low") and there will be no bias for the base of Q2. Q2 will be off and its collector voltage will be "high". If the input is "low" there will be no bias for the base of Q1 which will turn it off. With Q1 off, its collector will be "high" and there will be bias for the base of Q2, turning it on. When Q2 is on, its collector will be "low".

Figure 6.24 Discrete Noninverting Buffer.

For a verbal description click here.

If Q1 shorts, its collector will be "low" regardless of the state of the input. Q2 will be off and the output will be "high".

If Q2 shorts, its output will be "low" regardless of the state of Q1.

If R2 opens, the circuit would act the same as if Q1 had shorted. If R3 opens, changing logic levels would be observed at the collector of Q1 but Q2 would always be off and there would be a "high" at its collector.


Troubleshooting Chapter Seven. Transistorized Consumer Equipment.

Chapter 7   Transistorized Consumer Equipment.

7.1 Audio Amplifiers.
7.2 Radios and tuners.
7.3 Things you should leave alone.

Chapter 7.

Transistorized Consumer Equipment.

As you read in the foreword of this book it has been repurposed from a university textbook to a web publication whose target audience is more likely to be home experimenters and hobbyist. Therefore this chapter is about consumer grade electronics rather than exotic devices that may be found in a scientific research laboratory.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

7.1 Audio Amplifiers.

The term "audio amplifier" can cover a multitude of sins and in this section we shall cover the most important of them. There are thousands of variations on the basic audio amplifier so only a few representative samples can be given here.

Transformer Coupled Audio Amplifier.

The very first audio amplifiers employing transistors were designed as the audio section in transistor radios. Figure 7.1 is an example.

Figure 7.1 Transformer Coupled Audio Amplifier.

For a verbal description click here.

Although this circuit is very old dating back to the dawn of the transistor age it still exists in vintage radios and phonographs and is occasionally used in new equipment.

Transformer coupling was used because early transistors had low current gains. Transistors are current devices unlike tubes which are voltage devices. Note that both transformers are impedance step-down which translates to current step-up. Those transistors needed all the help they could get and the transformers provided it.

Note. The values given in the circuit are NOT from a vintage radio but have been designed to work with modern silicon transistors. If you were to construct this circuit using 2N3904s or any other small silicon NPN transistor it has a high probability of working and delivering approximately 250 mW, a little more on 12 volts.

Although the transistors are transformer coupled the failure analysis given in section 6.1 for the common emitter configuration mostly applies here. The main difference is that in the push-pull pair consisting of Q2 and Q3 the collector voltage will mostly be at Vcc for all failure modes except an open transformer winding. That case will be identical to that for an open collector resistor. For the single ended amplifier of Q1 the 1.8 k ohm resistor will be the collector load for DC and the failure modes will be almost the same. The upper base biasing resistor is effectively returned to the collector for DC but the effect of this will be small for a failure mode analysis.

In vintage equipment using germanium transistors there will be a thermistor in parallel with the resistor that is equivalent to the 270 ohm resistor. In most vintage circuits the capacitor across this resistor has been omitted. This omission likely slightly reduces power output and increases distortion. There was already so much distortion in these vintage circuits the designers probably felt that a little more wouldn't be noticed.

A variation of the transformer coupled amplifier was seen in line operated table radios from the mid 1970s onward. It came closest to being the transistor equivalent of the all American five tube radio.

Figure 7.2 Line Operated Transformer Coupled Amplifier.

For a verbal description click here.

This circuit was made possible by the fact that high voltage power transistors had come down in price sufficiently to make the circuit practical. The output transformer would likely be a 5 k ohm to 4 ohm unit not unlike the ones used in tube radios. The transistor would be mounted on a heat sink of some kind maybe the metal chassis of the radio.

The diode half wave rectifies the line voltage and the rectifier's output is filtered by the 30 uf capacitor. The ripple on the output is calculated by starting with the equation,

i = C dV/dt       (Eq 7.1)

First we mentally change the derivative to delta V / delta t and change the case of the current symbol, then solve the equation for dV.

DV = Dt I/C       (Eq 7.2)

Where DV is the change in voltage over a finite time, Dt is the time interval, I is the DC load current, and C is the capacitance of the capacitor in farads.

DV = 16 e-3 seconds x 20 mA/30 uf = 10.7 volts.

16 e-3 (16 milliseconds) is approximately the length of one cycle in north America.

The calculated peak of the 120 volt line voltage is 170 rounded to 3 digits. The calculated peak to peak ripple of 10.7 volts means that an average DC voltage of 165 volts is reasonable. This voltage value was used to design the transistor circuit. Because a transistor is a constant current device, similar to a pentode tube, voltage changes of 10 volts peak to peak will not produce any significant changes in collector current. The output transformer responds to changes in current so the hum level will be almost undetectable.

The voltage divider consisting of the 15 k ohm 2 watt and the 1.3 k ohm resistors form a voltage divider which places the base of Q5 at approximately 12.6 volts. The emitter will then be at 12 volts. The * 620 ohm resistor is the closest standard value that will produce 20 mA of emitter current in Q5. The resistor must be recalculated to account for the current drawn by the converter and IF stages of the radio. Let's say that the current drawn is 5 mA. Then the resistor has to conduct 15 mA to common to set the emitter current to 20 mA. The resistor value is given by 12 v / 15 mA = 800 ohms. The closest standard value is 820 ohms which means that the emitter and therefore the collector current of Q5 will be a shade low. In a real circuit the emitter voltage may be set a little higher and an additional RC filter stage inserted to ensure there will not be any positive feedback which could result in motorboating of the radio.

The above mention motorboating could be a fault of the circuit if the capacitor from the emitter of Q5 to ground were to develop a high effective series resistance (ESR).

If the emitter capacitor were to short Q5 would draw too much current, overheat, and short. This would apply the full line voltage peak to the converter and IF circuits thus cooking the entire radio and likely making it's repair uneconomical. Only a restorer of antiques would be interested in it after such a catastrophic failure.

Transformerless Amplifier.

Below is the circuit that was used for power amplifiers from the earliest days of transistors to some time in the early 70s.

Figure 7.3 Transformerless Amplifier from the 1960s.

For a verbal description click here.

This circuit actually has 3 feedback loops. 1) An AC negative feedback loop around the entire amplifier from the positive side of the 4000 uf capacitor, which is often called the amplifier midpoint, through the 2.2 uf capacitor and the parallel combination of the 330 k ohm resistor and the 2.7 pf capacitor to the base of the first transistor. 2) A DC coupled negative feedback loop from the amplifier midpoint through a 33 k ohm resistor to the base of the transistor that would be Q3 if I had remembered to number them. 3) An AC coupled positive feedback loop from the amplifier midpoint through the 50 uf capacitor to the junction of the 1 k ohm and 4.7 k ohm resistors.

The first two transistors on the left are in a stabilized configuration identical to that of Figure 6.18. As pointed out in chapter 6 the failure of the second transistor's collector resistor can cause the phase of the amplifier to reverse while it does continue to amplify to some degree. This would change the negative feedback to positive and the amplifier will oscillate at some frequency, most likely high, possibly ultrasonic.

If ultrasonic the oscillation is likely to do serious damage to speakers before being detected. The output transistors would most likely blow.

The second feedback loop stabilizes the amplifier midpoint at 1/2 of the Vcc supply. If the 33 k ohm or the 270 k ohm resistor opens the midpoint will go up to very near Vcc. If the 2.2 k ohm resistor opens the midpoint will come down to be very close to zero. If the 250 uf capacitor between Q2 and Q3 shorts Q3 will be driven to high collector current and the amplifier midpoint will be reduced in voltage. I think the 1 k ohm resistor in series with the 250 uf capacitor is meant to reduce the effect of such a short to prevent damage to the rest of the amplifier.

Note there are three diodes in series with the collector of Q3. Note also that the base of the top darlington pair is connected above the diodes while the base of the lower complementary darlington pair is connected below the diodes. These diodes are to temperature compensate the idling current of the outputs. They are usually very near the heatsink or may even be thermally bonded to it. If one or more of these diodes shorts the effect might not be noticed for some time. It's main effect would be to reduce the idling current of the outputs likely to zero. The resultant distortion would be compensated for and covered up by the large amount of negative feedback. The user may perceive that the amplifier doesn't sound right but may not be able to put his finger on the problem.

If one of these diodes opens, all four transistors in the output stage as well as the two 0.67 ohm resistors are in for a cooking. If you replace the two resistors and four transistors without finding out what made them cook the replacements will cook just as the originals had.

If any one of the four transistors shorts it will most likely take the other three with it. This leaves the same symptom as an open diode but one of the four transistors shorting was the precipitating event. You are likely to find all four transistors open. That is because the initial short caused excessive current to flow which shorted another transistor and then the enormous amount of current melted the transistors open before the main fuse had time to blow. I have even seen the small leads on the driver transistors between the transistor header and the PC board burned in two. Repairing such an amplifier can be a game of Russian roulette. You replace all four transistors and the two resistors and check everything else you can think of, close your eyes and apply the power. The problem with this circuit and others like it is you can't fire it up with the expensive high power transistors removed. You have to put it all back together and hope.

The third feedback loop is more commonly known as bootstrapping. The 50 uf capacitor couples AC signal from the midpoint to the junction of the two resistors. The effect is to tremendously increase the effective value of the 4.7 k ohm resistor. As the mid point is driven up and down by AC signal the left end of the 4.7 k is also driven up and down. The voltage drop across the resistor is very nearly constant. Constant voltage means constant current. Instead of behaving like a resistor it behaves like a constant current source for the collector of Q3. This has the effect of increasing the gain of Q3 and reducing distortion in the three diodes. A short in the 50 uf capacitor would place the top transistors in cutoff which would allow the midpoint to be pulled down near zero. If the capacitor were to open the bootstrapping effect would be lost. This would increase the amount of distortion but the global feedback would tend to cover it up. Depending on how demanding a listener the owner is the amplifier might be brought in for service only to have the repair man say "It sounds alright to me." On the other hand the owner may not notice that anything is wrong and the problem could go undetected for years.

Figure 7.4 Improved Transformerless Amplifier from the 1970s.

For a verbal description click here.

Here is a circuit from the third decade of transistorized consumer equipment. Its main improvement is DC coupling throughout including the global feedback loop. Also a transistor (active) current source has replaced the bootstrapped resistor. The global negative feedback is applied to one base of a differential pair with input applied to the other. There is a current source in the emitters of the differential pair. It operates from symmetrical power supplies so the midpoint is held at zero. Almost any circuit fault will cause a large DC offset which can destroy a speaker system in pretty short order if there is no protective fuse.

The chief difficulty with this kind of circuit is that any fault anywhere will propagate around the feedback loop and every voltage will be out of whack. There are often clues. Say the midpoint is locked to the positive rail. You should find that the base of Q2 is more positive than the base of Q1. Because these are PNP transistors Q2 will be in cutoff and Q1 will be taking all of the current of the current source Q3. This will pull the collector of Q1 higher than normal and pull the base of Q4 higher, increasing its collector current. This will be trying to pull the three diodes down but it can't because the amplifier is at positive rail. The feedback is telling the amplifier to go negative but something is keeping it from it. It could be a short in any one of the three transistors Q5, Q7, Q9, or the 200 pf capacitor. Q4 could also be open causing this symptom.

This circuit suffers from many of the same problems as Figure 7.3 with the additional ones introduced by DC coupled feedback.

Both of these circuits have current limiting circuitry to protect the amplifier against a short in the speaker wiring. These circuits work in the same way as current limiting in a bench power supply. The voltage drop across the low ohm resistors in the output is sensed and if it exceeds a certain value the current supply to the bases of the power transistors is shut down.

Figure 7.5 is the circuit of Figure 7.3 with the protection circuitry added.

Figure 7.5 Figure 7.3 with protection circuitry added.

For a verbal description click here.

The added parts that make up the protection circuit may be hard to find. It consists of the series combination of two zener diodes connected anode to anode and a 100 uf capacitor. The literature I have for the amplifier does not reveal the voltage of the zener diodes. If a short is placed across the output the high current will cause a large AC voltage to be developed across each of the two 0.67 ohm resistors. This voltage also appears across the series combination of the two zener diodes and the capacitor.

Suppose there is a short and the input signal is telling the output to swing positively. The emitter of the top output will swing positive creating a larger than normal voltage drop across the top 0.67 ohm resistor. The positive going swing on the emitter of the top output transistor was caused by a positive going swing on the collector of Q3. Remember that there is a short on the amplifier output and the 4000 uf capacitor prevents any significant swing on the amplifier mid point. When the voltage across the 0.67 ohm resistor is large enough the left hand diode will go into zener breakdown and the right one into forward breakdown. This will prevent the voltage at the collector of Q3 from going any higher thus limiting the current to a safe value. When the output tries to swing negatively the lower 0.67 ohm resistor conducts a high current and the voltage at the collector of Q3 is negative going. The right hand diode goes into zener breakdown while the left hand one goes into forward breakdown. This prevents the collector of Q3 from going any more negative thus limiting the current.

Because the circuit of Figure 7.4 is dc coupled the current limiting circuitry must be DC coupled and somewhat more elaborate.

Figure 7.6 Figure 7.4 with protection circuitry added.

For a verbal description click here.

The limiting transistors are Q10 and Q11. Their emitters are connected to the amplifier midpoint. Diodes D1 and D2 disconnect the current limiting circuitry when no limiting is taking place. The connections from the top and bottom ends of the sense resistors may appear to be rather complicated but if you mentally strip it all away, basically the top of the top 0.33 ohm resistor connects to the base of Q11 and the bottom of the bottom 0.33 ohm resistor connects to the base of Q10. The network of resistors, capacitors, and diodes appears to serve the main purpose of preventing oscillation when current limiting is in effect.

On the positive half cycle if the load is drawing too much current Q11 is turned on and it's collector current takes current away from the base of Q7 reducing the output to a safe level. On the negative half cycle Q10 takes current away from Q6 limiting the current.

Stop the presses, it isn't quite that simple. Those two diodes D3 and D4 appear to add a lot of complexity but the limiter wouldn't work right without them. When there is no current limiting taking place everything is going up and down positive and negative with respect to ground. The drop across the 0.33 ohm resistors is small so the two 68 ohm resistors, the two .01 uf capacitors, the two 15 ohm resistors, the two 250 uf capacitors, (they are connected to the midpoint), the top end of the top 1 k ohm resistor, the bottom end of the bottom 1 k ohm resistor, Q10, Q11, and the three capacitors that are around Q10 and Q11, are all swinging up and down with the output signal.

But on the positive swing D3 is forward biased and holds the junction of the upper 1 k and the 4.7 k to near ground. This reverse biases the base emitter junction of Q11 which was already turned off but forward biases the base emitter junction of Q10 which turns it on. This might turn off Q6 and Q8 but they are already turned off. On the negative half cycle of normal output Q11 is turned on. This has no effect until current limiting kicks in.

If there is a short or too many speakers connected to the amplifier. Q11 will be turned on as explained above. If Q10 were not already on the voltage at the collector of Q5 would be pulled down which would turn on Q6 and Q8. Q4 and Q5 are both current sources so their voltage can be easily pulled around. This would bring about the destruction of Q6, Q7, Q8, and Q9, instead of protecting them. Q10 and Q11 being turned on at the same time prevents this from happening. The similar event occurs on the negative swing.

Current limiting circuitry is not likely to fail because it rarely if ever turns on. If prolonged current limiting should overheat either or both Q10 or Q11 causing it(them) to short the amplifier might appear to work at very low volume settings but distort at even moderate listening levels. Such a fault might be hard to find if you fail to check the current limiting components.

Integrated Circuit Amplifiers.

I recently had on my bench a home theater amplifier made by Sony. It had discrete complementary output transistors but the rest of the circuitry was inside a medium power integrated circuit. Fault detection circuits found a DC offset and would not connect the speakers while indicating an error on the front panel display. The offset was not large being about 1/4 of the Vcc and Vee supplies. The power transistors had normal values of Vbe indicating neither an open or short. My only alternative was to replace the IC. That turned out to fix it. Because of minimum order requirements I had to buy 3 of the ICs. Such is the plight of someone who does not operate a professional service shop.

Then there are those amplifiers that are one great big IC for each channel. Before ordering these expensive parts perform the "what is it being told to do" test. These are really nothing but high power op amps and they will be treated as such in this explanation. If the output is locked to the positive rail and the inverting input is more positive than the noninverting input the output is being told to go negative. If the output is locked to the negative rail and the inverting input is negative with respect to the noninverting input the output is being told to go positive. In either of these cases the op amp is not doing what it is being told to do so it must be defective.

On the other hand if the output is locked to the positive rail and the inverting input is negative with respect to the noninverting input the amplifier is being told to go positive. If the output is locked to the negative rail and the inverting input is more positive than the noninverting input the amplifier is being told to go negative. In either of these cases the amplifier is doing exactly what it is being told to do. The fault lies with the surrounding circuitry that is doing the telling. There are so many variations on these circuits that it is impossible to give any examples.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

7.2 Radios and tuners.

The All Japanese Six.

The 6 transistor radio which I shall call the All Japanese 6 (AJ6) uses 3 of its transistors in the audio section, another as the converter and the remaining two in the IF amplifier.

Note. The first transistors were mass produced by Texas Instruments and their engineers designed the first practical transistor radio. It was made under contract by a company in Illinois for a time. However as has happened so many times over the years since 1952 the Japanese were able to make it at less cost which drove American manufacturers out of the transistor radio business. Even though it isn't "all" Japanese I choose to call it the AJ6 in the same way as the 5 tube radio that really was all American was called the All American 5 (AA5). I do this with apologies to the states of Texas and Illinois.

One of my professors told the following joke. "Whenever an American company comes out with a new product, within one week the Russians have invented it first, and within two weeks the Japanese are making it cheaper." I have no knowledge of the USSR claiming to have invented the transistor radio first but there is no doubt that the Japanese did make it cheaper. Now it's the Chinese but that's another story for another time.

The diagrams below were obtained from this website. The diagrams have been redrawn to avoid any copyright problems.

Figure 7.7 Voxson Model 762.

For a verbal description click here.

These diagrams give no clue as to the year of introduction. They all use germanium PNP transistors so the late 1950s or early 60s seems to be a good guess.

The Converter.

The station signal is picked up by the ferrite rod antenna and signal is coupled into the converter, Q1, by a coil that consists of a few turns wound between the turns of, or over, the grounded end of the main tuned winding. The transistor uses series fed constant voltage biasing. The 10 k ohm and 2.2 k ohm resistors provide the bias voltage to the transistor. The emitter resistor sets the collector current. The .01 uf capacitor keeps the low end of the base winding at RF ground.

In the collector of Q1 the tickler coil for the oscillator and the primary of the IF transformer are connected in series. Signal from the tickler coil is magnetically coupled to the resonant coil and a tap on this coil couples signal of the proper phase through the .01 uf capacitor to the emitter of Q1. The resonant coils of the ferrite antenna and the oscillator coil are tuned by the two sections of the tuning capacitor.

The IF (Intermediate Frequency) Amplifier.

The difference signal between the oscillator and station signal, 455 kHz, is coupled to the primary of the input IF transformer. Vcc is fed to the mid-tap on the IF transformer primary and the collector is connected to the end of the winding nearest the tap. This prevents the low impedance at the collector of Q1 from lowering the Q of the tuned circuit.

The function of D1 is unclear. Its anode is connected to the high impedance end of the primary of the input IF transformer while it's cathode is connected to the mid-tap on the interstage IF transformer. The Q point program tells us that the no signal collector current of Q2 is 212 microamps which gives a drop across the 4.7 k ohm resistor of approximately 1 volt. If a very strong nearby station were to be tuned in the peak RF voltage at the anode of D1 could exceed 1.1 volts but it is hard to say exactly what would happen. A strong signal would reduce the forward bias on Q2 bringing the voltage on the cathode of D1 closer to its DC anode voltage. The DC voltage at the mid-tap of the interstage transformer might be reduced which would reduce the gain of Q2 but the top end of the input transformer is a high impedance point which has many more turns between it and the mid-tap than there are between the collector end and the mid-tap. The cathode of the diode would have to drive the 4.7 k ohm resistor. It seems more likely that the signal on the primary of the input transformer would just be clipped distorting the modulated signal from the station.

The base winding of the input IF transformer couples signal to the base of Q2. Q2 is biased from the -9 volt line through a 180 k ohm resistor and AGC (automatic gain control) is applied through an 8.2 k ohm resistor. The AGC voltage is derived from the cathode of the detector D2 so it is positive going. This will reduce the collector current of Q2 reducing it's gain. This is the only point in the radio where closed loop AGC is applied. (Note. As speculated above the signal rectified by D1 may be forward gain control but it's function seems doubtful.) The primary function of the 4.7 k ohm resistor and 0.1 uf capacitor is to decouple the collector of Q2 from the minus nine volt line. The collector of Q3 is decoupled by the 470 ohm resistor and 0.068 uf capacitor.

The interstage IF transformer couples signal from the collector of Q2 to the base of Q3. The output IF transformer couples signal from the collector of Q3 to the detector, D2. The base of Q3 is biased by the voltage divider consisting of the 15 k ohm and 1.2 k ohm resistors. The 680 ohm resistor in the emitter sets the collector current. The 0.068 uf capacitor bypasses the cold end of the base winding on the interstage IF transformer and the 0.1 uf capacitor bypasses the emitter of Q3.

Both Q2 and Q3 are neutralized by the series combination of a resistor and small capacitor connected between the top of the IF transformer primary and the base. The use of a resistor is quite rare. Usually only a capacitor is seen. Early transistors had a substantial reverse voltage transfer ratio, hre. This consisted of the capacitance between collector and base but also an electric field effect which altered the forward voltage drop across the base emitter junction as the collector voltage changed. The resistors apparently were used to neutralize the real part of hre while the capacitors neutralized the imaginary part. This was evidently an example of thorough engineering which other companies found to be unnecessary. That would seem to point toward this being an early design. More about this when discussing figure 7.8.

Detector and AGC.

D2 half-wave rectifies the voltage on the secondary of the output IF transformer. The 0.025 uf capacitor smoothes out the 455 kHz ripple component while leaving the audio uneffected. The DC component which is proportional to the strength of the received station's signal is fed through an 8.2 k ohm resistor to the cold end of the base winding on the input IF transformer. A 10 uf capacitor filters out all audio from the AGC signal so just the strength of the station's signal will effect the gain of Q2. As the signal from the station gets stronger the DC voltage applied to the right end of the 8.2 k ohm resistor grows more positive. An increasing positive voltage reduces the bias on Q2 which reduces its collector current thus lowering its gain. Both the DC and audio are applied to the top of the 5 k ohm volume control. The signal from the wiper also contains a reduced version of the DC and audio. The 125 uf capacitor blocks the DC from the base of Q4.

The Audio Amplifier.

The base of Q4 is biased by the voltage divider consisting of the 22 k ohm and 20 k ohm resistors. The collector current of Q4 is set by the 1.2 k ohm resistor and this resistor is bypassed by the 10 uf capacitor. Signal from the collector of Q4 is coupled by the interstage audio transformer to the bases of Q5 and Q6. The low end of the primary of the interstage transformer is bypassed to ground by a 64 uf capacitor. This capacitor in conjunction with the 560 ohm resistor serves to decouple Q1 through Q4 from the effects of the audio power output transistors Q5 and Q6.

Q5 and Q6 have base bias applied through the secondary of the interstage transformer from the resistive voltage divider consisting of the 3.3 k ohm and 68 ohm resistors. Q5 and Q6 each have their own 10 ohm emitter resistors. This will provide some automatic collector current balancing effect not available if a single emitter resistor had been used for both transistors. Leaving these two resistors unbypassed also provides some negative feedback to the output stage. Signal from the collectors of Q5 and q6 is coupled by the output transformer to the speaker. The 220 ohm resistor and 0.047 uf capacitor roll off the high frequencies and stabilize the global negative feedback loop. This feedback is taken from the secondary of the output transformer back to the base of Q4 through the parallel combination of a 330 k ohm resistor and a 180 pf capacitor.

Comments.

The thoroughness of the neutralizing of the IF stages and the use of negative feedback in the audio section indicates that considerable thought was put into the design of this radio. It's hard to believe all that was used to drive a 2 inch speaker. Perhaps the design was lifted from an AC operated table radio with a larger speaker.

Another Example.

Figure 7.8 Sanyo Super-Six.

For a verbal description click here.

The converter.

This circuit is similar to the Voxson radio above but there are also notable differences. Feedback from the tuned winding of the oscillator coil is fed through a 0.003 uf capacitor to the cold end of the base winding on the ferrite rod antenna. This strikes me as a questionable design change because it is certain to result in a stronger signal from the local oscillator being radiated from the radio as compared to designs where the feedback is coupled to the emitter of the converter transistor. 4 of the 17 6 transistor radio circuits I found have oscillator feedback taken to the base of the converter transistor. The rest take the feedback to the emitter.

IF Amplifier.

Q2 and Q3 are neutralized by capacitors only which is far more typical of transistor radio designs. Also there is no decoupling for Q2 and Q3.

AGC.

The major difference is in the AGC system. The top of the output IF transformer secondary connects to the cathode of a diode D1 and the bottom connects to one end of a 0.01 uf capacitor. Instead of being connected to ground the bottom end of the winding is connected to the same voltage divider which biases the base of Q2. This divider consists of a 90 k ohm and an 18 k ohm resistor. This sets the base bias for Q2 as well as the reference for the detector at approximately -1.5 volts. This bias point is bypassed for both audio and Rf by a 10 uf capacitor.

The signal from the anode of the detector, D1, is partially filtered by the 0.01 uf capacitor which has its other end connected to the bottom of the IF secondary coil. Additional filtering is provided by the 200 ohm resistor and another 0.01 uf capacitor. At this point there is DC for AGC plus detected audio. The DC is filtered by a 5.6 k ohm resistor and the 10 uf capacitor in the emitter of Q2.

The AGC detector like any electrical source has two outputs. The positive side is the bottom end of the IF transformer secondary which is labeled AGC. The negative output is the bottom end of the 5.6 k ohm resistor. This source of DC is floating, not tied to ground anywhere, and is connected between the emitter and base of Q2. As the signal from the station becomes stronger the positive voltage applied between emitter and base becomes larger which takes away from the normal negative bias for a PNP transistor. The collector current of Q2 is reduced which reduces its gain. But in addition the voltage at the emitter becomes less negative.

Note that the bias for the base of Q3 instead of being derived from a voltage divider as in the circuit above, comes from the emitter of Q2. As the emitter voltage of Q2 becomes less negative so does the base voltage of Q3. This reduces its collector current which reduces its gain. AGC action in this radio would be much improved as compared to the one above because AGC is applied to both IF stages Q2 and Q3 instead of just to Q2.

Audio is coupled from the junction of the 200 ohm and 5.6 k ohm resistors through a 10 uf capacitor and a 1 k ohm resistor to the top of the volume control. This is labeled VR on the schematic and does not have an entry in the parts list. The wiper of the control feeds through another 10 uf capacitor to the base of Q4. Note that the designer of this radio took measures to keep DC levels off of the volume control. This reduces crackling when the control is rotated.

The Audio Amplifier.

The audio section has a few differences from the circuit above but is mostly similar. There is a 0.005 uf capacitor across the primary of the driver transformer. If the transformer is actually a 10k primary to 2k secondary the roll-off frequency is 3180 Hz which seems low even for a pocket radio. The 9 volt battery line is decoupled from the supply for Q1 through Q4 by a 200 ohm resistor and a 50 uf capacitor. The emitters of Q5 and Q6 are tied together and connected to ground through a single 10 ohm resistor. There is no negative feedback around the audio amplifier in this radio.

There is not a thermistor in either circuit selected as representative of 6 transistor radios. This may indicate that these are both early designs. Owners of radios of this type found they would stop playing if left on a beach blanket in the hot sun for several hours. The radios were found to be working upon arrival home. The problem was instability of the operating point of some of the transistors. The two most vulnerable stages were the converter, Q1, and the push-pull outputs, Q5 and Q6.

At elevated temperatures the transistor's current gain would increase causing it to go into saturation and stop oscillating. The cure for this was to make the parallel combination of the two biasing resistors in the base very approximately equal to the emitter resistor. This appears to have been done in both designs shown above. The result of an overheated push-pull pair was distorted sound and a quickly run down battery. As the transistors heated up their current gain would increase causing them to draw more current which heated them up more causing more current etc. etc. In line powered radios this runaway condition usually resulted in cooked transistors. In a battery powered radio a run down battery was usually the only result. Several repeats of this incident resulted in unhappy customers and eventually the engineers added the thermistor to compensate for wide temperature changes.

What can go wrong?

After the manufacturers made their radios able to work at the beach there really wasn't much left to go wrong. Low voltages and currents didn't put much stress on resistors, capacitors, and transistors. When a radio turned up at a service shop it was usually because of being dropped into the family swimming pool or overboard from the family boat. In such cases it was not economical to repair because the cost would exceed the price of anew radio. In deed by the late 60s a six transistor radio could be had for 5 or 6 dollars.

At this writing the very first transistor radios made in USA are 60 years old. If they haven't already these will soon become quite valuable as rare antiques and because there were so few made.

Meanwhile the transistor radios of today use the same ferrite antenna, tuning capacitor, and IF transformers, but the transistors have been incorporated into a 16 pin DIP. If a true 6 transistor radio lands on your bench it is most likely that the owner, sometimes you, wants it restored to operation for sentimental reasons. What voltage, current, and power, couldn't do to these radios, time has. The electrolytic capacitors will most certainly need to be replaced. In early transistors the mechanical connection between the leads and the germanium crystal wasn't very good and often failed. In most cases the radio will still play but the sound contains a most annoying crackling that is usually not effected by mechanical shock. Germanium transistors are available from specialty suppliers. A Google search should turn them up. I once went so far as to reengineer a transistor radio for silicon NPN transistors. It's not a job I would recommend to anyone.

The volume control in these radios is usually not the enclosed potentiometer we are accustomed to seeing in other equipment. The carbon element is glued to the circuit board and the wiping contact runs around it as the knob is turned. At the counter clockwise end of its rotation part of the wiper moves a contact opening the connection to the 9 volt battery. This leaves the carbon ring vulnerable to being damaged or at least getting dirty. Either one will result in a crackling sound when the control is rotated. If this occurs some control cleaner applied to the carbon ring will fix the problem. If the control has been damaged it will have to be replaced. The best source is probably another radio. I have no experience to offer on how to remove these rings.

Another source of crackling is the tuning capacitor. These capacitors are inside a plastic box and as far as I know opening the box is an irreversible process. To save space these capacitors have very thin layers of plastic between the plates. It is not unusual for the plastic to have worn through in a few places allowing the plates to make electrical contact. Replacing the capacitor is the only fix for this. Fortunately in most radios the tuning capacitor is easily removed and if you can obtain a matching capacitor, easily replaced.

As mentioned above the modern pocket radio contains a DIP IC instead of transistors. However, the tuning capacitor appears to have changed little if at all over the last 50 years. If all else fails, one of these IC radios could be a source of parts to repair an AJ-6.

Car Radios.

AM transistorized car radios are only slightly different from home AM radios. Three major differences are; They are with few exceptions tuned by variable inductors rather than variable capacitors, the intermediate frequency is 262.5 kHz, and the audio output is capable of delivering a watt or more. Much more in some cases. The FM stereo section is pretty standard.

The hardest part of repairing car radios is getting them out of the car and then back in after repair is complete. Modern low voltage high current power supplies are sufficient to power one while it is on the test bench. In some cases the speaker or speakers are mounted in another part of the car, such as in the door panels but any small set of speakers can be substituted for troubleshooting purposes.

One complaint may be that there is excessive ignition noise and alternator hum in the radio. This problem is very difficult to troubleshoot because it can't be tested outside of the car. In older radios power is fed into the radio through feed-through capacitors which in car radio parlance are known as spark plates. These are usually found in tube radios in an era when low impedance feed-through capacitors had not yet been developed. A spark plate is a square of metal which is connected to the hot power lead and insulated from the radio chassis with a sheet of mica. There is little to go wrong with such a device except corrosion at the point where the power lead connects to the plate. In modern transistorized radios feed-through capacitors will be found instead of the older technology.

AM/FM Stereo Car Radios.

This book is primarily aimed at those repairing or restoring vintage equipment so little time will be spent on this subject. Other than the differences noted above for AM radios there is virtually no difference between a car radio and a home AM/FM stereo receiver. With the exception of the 120 VAC power supply of course. High power car stereos require more supply voltage than the 12 volts of the car's electrical system. If only the available 12 volt supply were used the highest peak-to-peak voltage across the speaker would be approximately 22 volts using a bridge amplifier. Based on a 4 ohm speaker the power calculates out to about 15 watts. While this would be plenty for any sane person those car stereos that you can hear booming from 2 blocks away are running several hundred watts. To obtain that much power they have to use Vcc supplies of 50 or 100 volts. These comparatively high voltages are obtained from an inverter circuit which is basically a silicon version of the vibrators used in tube radios of old.

AM/FM Radios.

An AM/FM radio may be a portable, small table, clock radio, or car radio. Separate transistors are used for the AM and FM frontends. The low cost of transistors and high cost of switches is what makes this economically possible. Band switching is accomplished by switching on the Vcc to the frontend which is desired and switching off the Vcc to the other one. This can be done with a simple single pole double throw switch. Each mixer is coupled into the IF strip through the appropriate IF transformer. AM uses an intermediate frequency of 455 kHz while FM uses an intermediate frequency of 10.7 MHz.

In the IF strip the FM and AM IF transformers have their primaries and secondaries wired in series to the base or collector of each IF transistor. The highest frequency transformer, 10.7 MHz FM IF, is closest to the transistor. The AM IF usually needs only 2 stages and the signal is taken off for detection after passing through this many transistor stages. The FM signal usually needs a total of 4 stages so the IF strip continues with only 10.7 MHz transformers after the AM takeoff point. Some radios may only have a total of 3 IF stages. The last stage of the IF strip is overdriven to remove amplitude variations which contain no intelligence.

The FM signal is demodulated by a circuit known as a ratio detector. The circuit is shown below.

Figure 7.9 Ratio Detector.

For a verbal description click here.

There are three coils inside a discriminator transformer. (Note; even though the circuit is a ratio detector the transformer goes by the name of the other detector circuit which is a discriminator. The discriminator circuit is almost never used because of its poor AM rejection. But the transformer which is identical for both circuits still carries the name.) Now, where was I? Oh yes, 3 coils. The primary coil which is in the collector of the last IF transistor is tuned to the center of the FM IF, 10.7 MHz. The secondary which is center-tapped is also tuned to the center frequency. The third coil known as a tertiary winding is magnetically coupled to the primary but is untuned.

Imagine for a moment that the tertiary winding has no voltage across it. The voltages at the top and bottom of the secondary are 180 degrees out of phase with each other. There will be a positive voltage at the cathode of the top diode and a negative voltage at the anode of the bottom diode. The polarity of the DC voltages are determined by the direction of the diodes not by the phase of the RF signals. These voltages will be filtered by the 330 pf capacitors. These voltages will cause current to flow through the two 10 k ohm resistors. (Let's simplify the explanation by pretending that the 2.2 k ohm resistor doesn't exist. The imbalance it introduces can be compensated for by slightly off-tuning the secondary of the transformer.) As the junction of the two 10 k ohms is grounded the voltage at the center-tap will be zero. Without the tertiary winding it would stay like that regardless of the input frequency.

The current which is induced in the tertiary winding is in phase with the current which is induced in the secondary winding. That is because both currents are being induced from the primary winding.

The tertiary winding is untuned and it has a self resonant frequency which is much higher than 10.7 MHz. Thus it appears inductive and the voltage is leading the current induced in it by 90 degrees. The bottom of this winding is very nearly at ground potential so the voltage applied to the center-tap of the secondary leads the current by 90 degrees.

Because the secondary is tuned to resonance at 10.7 MHz the voltage from the center-tap to the top is in phase with the current and the voltage from the center-tap to the bottom is 180 degrees out of phase with the current. Let us say for the sake of argument that the RF voltages across the top half of the secondary, the bottom half of the secondary, and the tertiary winding are all equal in amplitude and equal 10 volts. This condition is shown in the phasor diagram in Figure 7.10(a).

Figure 7.10 Phasor Diagrams of Discriminator Transformer Voltages.

For a verbal description click here.

The voltages across the tertiary winding and the top half of the secondary add as to the voltages across the tertiary and the bottom half of the secondary. This addition is shown in Figure 7.10(a). The voltage at the top of the secondary is 14.14 volts at an angle of 45 degrees while the voltage at the bottom of the secondary is 14.14 volts at an angle of 135 degrees. Note that both voltages still have equal amplitude although the relative phase angle has been altered. The diodes recover only amplitude information not phase information. Therefore the DC voltages at the cathode and anode of the top and bottom diodes respectively will be equal in value and opposite in sign. (+14.14 volts at the top and -14.14 volts at the bottom). Note that the DC and audio output from the detector is taken from the center-tap of the secondary. The tertiary winding has a minute amount of reactance at audio frequencies.

Now suppose that the frequency shifts upward. The phase of the voltage at the top end of the secondary will shift negatively because the resonant secondary now appears capacitive. Voltage lags current in a capacitive circuit so the phase will shift and let's say it shifted by -45 degrees as shown in figure 7.10(b). The voltage at the top of the secondary is now 7.653 volts at an angle of 22.5 degrees. The voltage at the bottom of the secondary is 18.478 volts at an angle of 112.5 degrees.

Remember that the two 10 k ohm resistors are holding the voltages across them equal and balanced to ground. Phasors represent the peak value so the voltage between the anode of the lower diode and the center-tap is 18.478 volts with the center-tap positive with respect to the diode anode. The voltage between the upper diode cathode and the center-tap is 7.653 volts with the cathode positive with respect to the center-tap. The total voltage is 26.131 volts. Each 10 k ohm resistor will have 13.0655 volts across it. The voltage at the center-tap will be 13.0655 v - 7.653 v = 5.4125 volts. Note that for an increase in frequency the output of the detector goes positive which is desirable for tuning meters and automatic frequency control (AFC).

When the frequency goes below center by the same amount it went above center the numbers are the same but all signs are reversed.

I wonder if anyone noticed the discrepancy with the numbers. When the incoming frequency is at the exact center the total voltage across the two 10 k ohm resistors was 28.28 volts and at a frequency that will give a 45 degree phase shift the voltage was 26.131 volts. If the voltage of the tertiary winding is decreased to 1 volt the total DC is 20.1 volts at center frequency and 20.05 volts at a frequency that gives a 45 degree phase shift. Decreasing the phase shift to 30 degrees gives 20.1 v and 20.08 v respectively. Reducing the phase shift and tertiary voltage reduces the amount of recovered audio. Clearly the designers of ratio detectors have to make some compromises to obtain a practical audio level and acceptable distortion.

There are no large currents or voltages in this circuit which reduces the probability of component failure. Resistors and capacitors can simply fail from old age. The most likely one to fail from this cause is the 5 μf capacitor which is a low voltage electrolytic. This capacitor in conjunction with the 2.2 k ohm resistor set the AM rejection. If the electrolytic should dry out and its value be reduced the AM rejection of the receiver will be considerably poorer than when the set was new. Do not assume that if 5 μf is good that 10 μf is better. The impedance and time constant of the circuit consisting of the 2.2 k ohm resistor and 5 μf capacitor in conjunction with the Q of the transformer secondary set the best value of AM rejection. Changing the value of the capacitor will reduce the AM rejection of the detector. In this particular case the substitution of a 4.7 μf capacitor would probably be acceptable especially since 5 μf capacitors are no longer made.

Note: In diagrams of the Ratio Detector you are likely to find in other textbooks the 2.2 k ohm resistor will be split between the top and bottom of the circuit. The designers of this circuit are taking the AGC voltage from the bottom end of the 5 μf cap. My best guess is that if there were a resistor between the diode and this cap there would be an additional RC time constant in the AGC loop which might render it unstable.

The two 10 k ohm resistors are 5% in table radios and are often 1% in High fi tuners. If one of them were to increase in value, a common result of old age, this would cause you to alter the tuning of the secondary of the discriminator transformer in an attempt to balance the circuit at center tuning. The effect of this would be to decrease the dynamic range of the detector possibly introducing a considerable amount of distortion.

If you think the detector is misaligned refer to the alignment procedure in the FM Tuner section below. References to the stereo light and tuning meter won't apply to a portable or table radio but the sound will be the same.

FM Tuners.

There is so much variation in circuitry among various tuners that it is impossible to give any detailed schematic diagrams. An FM tuner has the following sections. RF amplifier, Mixer and local oscillator, linear IF amplifier, limiting IF amplifier, FM detector, and stereo multiplex demodulator.

The RF amplifier operates in the frequency range between 88 and 108 MHz. The physical layout is even more critical than the component values. The simple act of bending a transistor to a more upright position could seriously degrade the performance of the tuner. If there is nothing wrong in the RF and mixer/oscillator section, don't touch it. If a transistor is burned out in this section and must be replaced your odds of ever getting it working again are small.

The linear section of the IF amplifier permits information for a signal level meter and AGC to be derived, usually from a simple diode detector.

The limiting section of the IF amplifier derives a signal which has a constant output level regardless of changes in the input signal. This is not done by AGC but by simple hard clipping. This is usually done within one or more integrated circuits. If the tuner is more than 20 years old these circuits may be very hard or impossible to find. Most all modern tuners use factory tuned LC filters or fixed tuned ceramic or crystal filters. In general such devices are not bothered by component replacement. Should one of these filters be found to be defective, and the tuner is old the chances of it playing again are small.

Detector Alignment.

CAUTION! Even high quality FM tuners in the transistor age use the same tiny transformers as their little brothers. The slugs in these have an obvious slot and they are very hard to turn. You may be tempted to use a metal screwdriver. DON'T DO IT! The slot will break out and the slug may brake into several pieces rendering the chances of a successful repair even lower. These slugs are held in place with paraffin. A little gentle warming with a hair dryer will permit them to be turned safely with an alignment tool.

Unless the tuner on your bench has been in the hands of someone who tightened up all the loose screws the IF and detector really won't need much if any alignment. In every old tuner I have seen the detector was slightly miss-aligned. You shouldn't need to turn the alignment slug more than 1/2 turn and more likely it will require less than a quarter turn.

The evidence for a misaligned detector is found by tuning across a strong local station which has only very weak signals nearby. When the detector is properly aligned you will observe three distinct listening peaks, not peaks on any meter. As you approach the signal you will begin to hear audio and it may not be distorted but it may be mixed with a little noise. The tuning meter will read quite low. As the tuning meter rises the sound will grow quite distorted. As you continue tuning the distortion will clear and the tuning meter will be at its peak. The stereo light will most likely come on. As you continue to tune the sound will once again grow distorted, the tuning meter will drop, and the stereo light will go out. The distortion will clear but the audio will be a bit noisy, and the tuning meter will read quite low.

A misaligned detector will give you two peaks and it may be ambiguous as to which one is the right one. Make small changes in the discriminator transformer or quadruture coil and tune across the station until you observe the signature of a properly aligned detector described above. If a symmetrical triple peak can't be obtained it may indicate trouble in the detector, or an IF that is seriously out of alignment.

Never adjust the detector for maximum noise when tuned off a station. You will adjust the detector so it won't detect FM at all but might detect AM if the limiters aren't to hard.

Stereo Demultiplexing.

Stereophonic, two channel, recordings have been transmitted on the radio since 1960. The method of transmission is compatible with monophonic, single channel, radios. This is done by a very clever method.

The two channels of the stereo audio signal are added together to form a signal called L + R, left added to right. This signal is modulated on the transmitter so any radio can pick it up. Then a signal that can tell a receiver with the proper hardware how to separate the mixed up channels is sent on frequencies that are above the range of human hearing. A monophonic radio may pick up these signals but they are not heard by the listener. The secret signal is made by subtracting the R signal from the L signal to give L - R. In the receiver the secret signal is added to the L + R signal and at the same time in a different circuit is subtracted from the L + R. This gives.

L + R + (L - R) = 2L

L + R - (L - R) = 2R

The factor 2 can actually be heard In many stereo receivers particularly early ones where the manufacturer did not compensate for them. When the receiver is switched to mono mode the sound grows softer.

The L - R or difference signal is it is often called has to be transmitted in such a way as to not cause any interference with the sum L + R signal. The signal is transmitted as double sideband suppressed carrier on a frequency of 38 kHz. The audio bandwidth is limited to 15 kHz so the double sideband signal occupies the band from 23 to 53 kHz.

Since the carrier has been suppressed it must be reinserted at the receiver and it must be in phase with the original carrier or the stereo signal will not be properly decoded. A 19 kHz pilot tone is sent to synchronize the oscillator that replaces the missing 38 kHz carrier.

So the whole composite stereo signal consisting of the baseband audio from 50 Hz to 15 kHz, the 19 kHz pilot tone, and the double sideband suppressed carrier from 23 to 53 kHz is sent to the frequency modulator in the transmitter. Preemphasis is applied to the two left and right channels independently before they are fed to the electronics that perform what has been described above.

Why is the 38 kHz carrier suppressed? The maximum carrier deviation that the FCC will allow on American broadcast stations is plus and minus 75 kHz. The mathematics of frequency modulation are far too complicated to go into here. To describe the effect, you can only squeeze in so much power into a carrier with a fixed deviation. The more you try to put in the less there is for the rest. A 38 kHz carrier would take considerable power away from the sum channel and require it to be modulated less to stay within FCC limits. An AM carrier does nothing but sit there and burn up power so it is suppressed. That makes much more modulation power available for the sum channel and the difference channel.

In receivers constructed using semiconductor technology the decoding is done by an IC with only a few external parts. The most popular seems to be the Motorola MC1310. A block diagram of the chip is shown in figure 7.11.

Figure 7.11 Block diagram of MC1310.

For a verbal description click here.

The input buffer provides a high input impedance to the chip while providing a low output impedance to drive all the internal circuitry. The entire composite stereo signal is applied to all internal circuit blocks and each one uses what it needs and ignores the rest. This eliminates the need for tuned circuits and LC filters.

The internal 38 kHz carrier is generated from the 19 kHz pilot by a phase locked loop. The 76 kHz VCO (voltage controlled oscillator) is divided by two by a JK flip-flop and then by two again by another flip-flop. This yields 19 kHz which is fed to the phase detector. The phase detector picks out the 19 kHz pilot tone and locks the VCO to it.

When the two input signals of a phase detector are at 90 degrees and the same frequency the DC output voltage is zero. When the two signals are in phase the output is positive and when the two are 180 degrees out of phase the output is negative.

The VCO is designed and adjusted so when the DC input voltage is zero its frequency is 76 kHz. When the voltage is negative the frequency is lower than 76 kHz and when the input voltage is positive the frequency is higher.

If the frequencies differ by say 1 Hz the output of the phase detector is 1 Hz. This will cause the VCO to be frequency modulated at 1 Hz and when it falls on 76 kHz the VCO will lock onto the pilot tone. The tuning range of the VCO is small so it won't lock onto musical notes in the program material.

The phase difference of the two 19 kHz signals is 90 degrees but at twice the frequency, namely 38 kHz the phase difference becomes 180 degrees. The 38 kHz signal between the two flip-flops is 180 degrees out of phase with the carrier that is required to recover the difference signal. A reversal in phase will flip the phase of the recovered difference signal. That is The difference signal will become -L + R. When the 38 kHz signal is fed to a DBM (doubly balanced mixer) it will use the 23 to 53 kHz double sideband signal to recover the -L + R signal which when combined with the composite signal through the two 75 k ohm resistors will derive the left channel. The not Q signal from the flip-flop is 180 degrees out of phase with the Q signal so when it is applied to another DBM it derives the L - R signal. When this signal is combined with the composite signal it derives the right channel signal.

What is a doubly balanced mixer?

Note: In the discussion below the terms sum frequency and difference frequency are used. Do not confuse these terms with the terms difference signal and sum signal. The sum signal is the L + R signal and the difference signal is the L - R signal. A sum frequency is a new frequency resulting from two frequencies being added together. A difference frequency is a new frequency resulting from two frequencies being subtracted one from the other. I promise to always say exactly what I mean and mean exactly what I say.

A DBM produces the sum and difference frequencies the same as any other mixer. If two signals of 6 kHz and 4.5 kHz are injected into a DBM the output is 1.5 kHz and 10.5 kHz. But the two original signals of 4.5 kHz and 6 kHz are canceled out by the circuitry and do not appear in the output. The truth is that the internal circuitry of the two DBMs is no different from the circuitry of the phase detector. They are the same circuit serving different functions. This makes chip manufacturing easier because it becomes a series of modules that are connected together before final packaging.

The 23 to 53 kHz double sideband signal combines with the 38 kHz signal to produce audio from 50 Hz to 15kHz which is the recovered difference signal. Also the original L + R sum signal combines with the 38 kHz signal to produce sum and difference frequencies which is a whole new set of frequencies in the range of 23 to 53 kHz. If the original difference signal were not canceled out by the DBM these frequencies would combine, beat together, to produce all sorts of weird effects.

The 76 kHz VCO is an RC controlled Multivibrator with the resistor and capacitor outside the IC. Part of the resistor is usually a trimmer resistor to set the frequency of the oscillator. The four 75 k ohm resistors are internal but the 0.001 uf capacitors must be supplied on the outside.

The output of the IC is not line level so gain stages must be provided before going to line output jacks. Many tuners have elaborate filters to make sure no frequencies above the audio band escape from the tuner. If the 19 or 38 kHz signals were to appear at the output with any appreciable amplitude they would beat with the bias oscillator in a tape recorder and produce beat frequencies, tones, in the audio band. These tones would not be heard when listening to the radio but would be heard in the recording.

What can go wrong?

If there is no output from the chip it is most likely bad and must be replaced. A possible symptom is that there is audio but it is monophonic, the same signal from both channels. This can be tested for without having to rely on your ears. Connect the two channels to the X and Y inputs of an oscilloscope and be sure the station you have tuned in is transmitting stereo program material. If the output is monaural the scope will show a straight line at 45 degrees to the horizontal. If the signal is stereo the scope will show all kinds of random circles and ellipses.

If the receiver is producing monaural try adjusting the trimmer pot in the frequency determining parts of the VCO. Many times this will fix the problem.

If one channel is dead check the gain stages that come after the demodulator chip.

If there is trouble in the filters and the user owns a tape recorder there may be beats in the recording that aren't heard in normal listening. Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

7.3 Things You Should Leave Alone.

You should leave the following items alone.

  1. VCRs.

  2. CD Players.

  3. DVD Players.

  4. Flat screen TVs.

You may break the "leave it alone" rule if all four of these conditions are satisfied.

  1. The item is not working at all.

  2. It is out of warranty.

  3. The service shop you took it to declined to work on it.

  4. You own the item.

When you have nothing to lose there is no risk and you might just get it working. But don't make any bets or hold your breath.

So what to do if you decide to open it up and have a look. Before removing the screws or prying up the tabs check the back, or the manual, if you still have it, for a reset button.

Assuming you manage to get it open without doing too much damage trace the AC power line. You might find a fuse and most likely it will be a solder in type and won't be the kind you can walk into a Radio Shack and buy. If the fuse is blown don't replace it just yet. Fuses do occasionally blow all by themselves but it is rare.

Keep following the AC trail. Depending on the size of the device you may or may not find a power transformer. But eventually you will find one or more diodes and a filter capacitor. Check them for shorts.

After the rectifier and filter you may find either an analog voltage regulator or a switch mode power supply. At this point the problem usually becomes getting at the components to figure out what is there let alone test and replace them. If the designers were thoughtful enough to realize that this part of the unit is field repairable the circuit boards may come out easily.

If you get this far without finding any fault temporarily solder in a fuse clip and insert a standard fuse of the proper current rating. If it blows you haven't found the problem. If it doesn't start checking around on the net to find the proper replacement. If you can find a way to safely anchor the fuse clip so it is not hanging from the leads on the PC board you may decide to leave it in place.

CD and DVD players will have two power supply lines a positive and a negative with respect to ground. VCRs and TV sets will have a multitude of voltages available from the power supply. TV sets are most likely to have no line frequency transformer but a switch mode power supply after a bridge rectifier and filter capacitor.

DVD and CD players and VCRs can have mechanical problems which can be difficult to diagnose without special test sets supplied by the manufacturer. VCRs often have small spring loaded switches that are meant to detect trouble in the mechanism and shut off the power or reverse the action to prevent damage. These switches are often not of the best quality and they end up being the cause rather than the cure.

Often the wisest decision is to walk away particularly if the thing doesn't belong to you. In the words of the song, "You've got to know when to hold em and know when to fold em."


Troubleshooting Chapter Eight. Faults in Vacuum Tube Circuits.

Chapter 8   Faults in Vacuum Tube Circuits.

8.1 Audio Amplifiers.
8.2 Radio Receivers.

Chapter 8.

Faults in Vacuum Tube Circuits.

A large segment of the electronics community considers vacuum tubes to be an obsolete and useless technology. Another large and growing segment considers them to be superior to transistors in many applications. To name just a few they are, musicians who play electric instruments, audiophiles, hams and SWLs, and hobbyist and experimenters.

Musicians and audiophiles prefer the sound of tubes over transistors. Hams and SWLs find that a tube receiver will outperform a transistor receiver of comparable complexity and price. Electronics hobbyist, especially the older ones, prefer the point to point wiring construction used in conjunction with tubes as opposed to the printed circuit boards of transistors.

Many items of tube equipment are more than 50 years old which qualifies them as antiques. If one of these items turns up on your service bench how it is treated depends on whether it has not been turned on for several decades or if it was in daily use and suddenly failed to operate. The latter case is covered in This chapter.

If an item is brought to your shop by a tearful owner who states that he or she used to listen to it at age six and asks you if you can make it work again even though it may have been stored in a damp basement or hot attic for the last 50 years you are definitely on the hot seat. Such an item requires special care. An entire chapter will be devoted to such items. There is bound to be some duplication between this chapter and the one concerning Antiques. However, this chapter is what it is.

For additional information on tube amplifier and radio circuits see The Fun with Tubes website. Also see Electronics for Physicists particularly chapter 4A.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

8.1 Audio Amplifiers.

The largest segment of the tube culture consists of musicians and audiophiles. The amplifiers they use differ in a few details but are basically the same.

Power Supplies.

Tube aficionados disagree on whether it is best to use a tube as the rectifier or silicon diodes. Tube rectifiers have a large internal voltage drop and the drop changes with current being drawn. When the power output stage is operating in class AB the power supply voltage will fall when the amplifier is delivering large amounts of power. The term applied to this is sag. Many musicians find the sound produced by sag to be desirable.

Silicon rectifiers do produce a small amount of sag but it is very much less than that occurring with a vacuum rectifier. Some extremist will state they can tell the difference between the sound of an amplifier using a tube rectifier and silicon even at low power. Personally, I don't believe them.

Whichever type of rectifier it has the power supply should always be checked first.

Heater Wiring and Schematics.

Tube heaters and filaments must be connected to a source of power or the tube will just sit there and not do a thing. Draftsmen have three basic ways of showing these connections.

The most obvious is to draw the lines from the power source to the tube. This is more likely to be seen in circuit diagrams showing filament type tubes rather then indirectly heated cathode tubes.

Another way to indicate heater connections is shown in Figure 8.0A. The letter X is used to indicate that the power source is indeed connected to the tube heater even though it is not shown with lines on the drawing.

Figure 8.0.A Heater Connections Indicated By the Letter X.

For a verbal description click here.

The third way is to show the heaters separate from the tubes as shown in Figure 8.0B. In this method it is easier to show the heater connections in a duo triode such as the 12AX7. The circuit on the left shows parallel connection while the one on the right shows series connection.

Figure 8.0.B Heater Connections Indicated By Removing the Heater From the Tube Symbol.

For a verbal description click here.

Single Ended Amplifier.

A single ended amplifier is about as simple as it gets. A typical example of a musical instrument amplifier is shown in Figure 8.1.

Figure 8.1 Single Ended Amplifier.

For a verbal description click here.

This would be a low power practice amplifier. V1 is a 12AX7 and V2 a 6V6. In another incarnation as a desk top amplifier for a portable CD player the V1A stage would be removed and the signal fed in at the top of the volume control. Another 6V6 would be added and the other half of the 12AX7 would be in the other channel.

A common fault in tube amplifiers is evidenced by the plate of the output tube, 6V6 in this case, glowing red hot. This is not a normal condition. There are two possible causes and they are both capacitors. If C8 shorts the grid bias on V2 will be reduced to zero and excessive plate current will flow. The other defect is for C6 to become leaky. This is a resistance in parallel with the capacitor and it doesn't take much leakage current to cause problems. A leakage current of 25 micro amps will approximately double the plate current of V2. This is an effective parallel resistance of 6 meg ohms.

If the amplifier is producing weak and distorted sound you may suspect a tube. Eliminate this fault by replacing both tubes with known good ones. If this fixes the problem go back to the old tubes one at a time to see which one is at fault.

If new tubes don't fix it look for a resistor that has increased in value or a leaky capacitor. These can usually be found by voltage measurements. Do not use a VOM for these measurements. The resistance of the VOM will severely load the high resistance voltage points. The plate voltages on those tubes with resistors in the plate circuit will be approximately from 1/2 to 3/4 of the voltage at the top end of the plate resistor. Grid voltages should always read zero or perhaps a few millivolts on the lowest range of a DMM.

Another fault that would silence the amplifier would be R5 or R9 open or C2 or C5 shorted. These will be evidenced by the voltage across either or both C2 and C5 being zero. If the voltages across C2 and C5 are zero the fault could be either C5 shorted or R9 open. An ohmmeter test with power off should find which is the fault.

If the voltage across C2 is zero this could be caused by C2 shorted or R5 open. The question can be resolved by the voltage across C5. If the voltage across C5 is higher than normal there is less current than normal flowing through R9. That points to R5 being open. If the voltage across C5 is lower than normal there is more current flowing through R9 than normal which points to C2 being shorted.

Unformed electrolytic capacitors are usually not found in new equipment. Faults unique to antique electronics will be covered in a chapter devoted to that sub class.

Negative Feedback. (NFB).

A musical instrument amplifier often does not employ negative feedback. NFB sharpens the overload corner so an amplifier without it will overload more gracefully than one that has it. Distortion which is anathema to audiophiles is often a desirable effect to a guitar player. But it needs to be a particular kind of distortion. Simple sharp clipping is usually undesirable.

If NFB were to be applied to this amplifier one side of the voice coil winding would be grounded and the other side connected through a resistor to the cathode of V1A. C4 would be removed or a 100 ohm resistor would be connected in series with it. The tone control circuit consisting of R8 and C7 would have to be removed. If the tone control were left in place the NFB would reduce its effect to the point of being almost unnoticeable.

Push-Pull Amplifiers.

To make a push-pull power output amplifier work properly the two grids must be driven by signals that are 180 degrees out of phase. That is accomplished through a circuit known as a phase inverter. Examples of the two major types of inverters are shown in Figure 8.2.

Figure 8.2 (a) Split Load Phase Inverter, (b) Long Tail Pair Phase Inverter.

For a verbal description click here.

Circuit (a) is known as a split load phase inverter. As shown it is often made with a low μ duo triode such as a 6SN7. Another variation uses a high μ triode for V1 and a low μ triode for V2. Yet a third variation connects a capacitor between the plate of V1 and the grid of V2. The V2 stage is biased the same way as the modified cathode follower shown in Figure 4A.17(b). All but the last variation can be upset by a change in the power supply voltage. A fault elsewhere in the amplifier could be responsible for a power supply voltage change and mislead the repair technician.

If the power supply voltage is correct check DC voltages around the circuit. The voltage at the plate of V1, also grid of V2, should be approximately 1/4 to 1/3 of the B+ supply. The voltage drops across R4 and R5 should be equal with the remainder of the B+ voltage dropped across V2. The capacitor across R2 may be omitted to permit negative feedback to be applied.

The circuit shown in Figure 8.2(b) is known as a long tail pair. V1 is usually a high μ triode while V2 is a medium or low μ duo triode. Signal is coupled directly from the plate of V1 to the grid of V2A. The signal is inverted and appears at the plate of V2A. Some of the signal is coupled from the cathode of V2A to the Cathode of V2B and then to the plate of V2B. In this signal path V2A acts as a cathode follower while V2B acts as a grounded grid amplifier. Both configurations do not invert the signal. The signal appears at the plate of V2B without being inverted. Thus the two signals at the two plates of V2 are 180 degrees out of phase. The signal path through V2A and V2B has slightly less gain than the signal path through V2A alone. The increased value of the plate load resistor on V2B, R5, compensates for the difference in gain. R4 makes certain that the voltages at the two grids of V2 are at the same DC potential. C2 grounds the grid of the grounded grid amplifier V2B. A very slight leak in C2 will imbalance the circuit and increase the distortion.

The voltage at the plate of V1 should not be too much greater than 1/4 of B+. The voltage drops across R5 and R6 should not differ by anymore than 20%. If there is a large imbalance it is most likely caused by R4 or C2.

Figure 8.3 Complete Push-Pull Amplifier.

For a verbal description click here.

The figure above shows variation 3 of Figure 8.2(a). It also shows how NFB is applied to the circuit. The output transformer must be phased, correctly connected, to obtain negative feedback instead of positive. This amplifier suffers all the same failure modes as the single ended amplifier except there is more to go wrong. Push-pull amplifiers are found more often in audiophile equipment whereas single ended amplifiers are more likely to be found in musical instrument amplifiers. This rule is broken when the musician wants more power. Many instrument amplifiers such as those made by Fender do use negative feedback and push-pull outputs.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

8.2 Radio Receivers.

The All American Five.

The All American Five represents a triumph of the bottom line over quality and safety. It was the radio that the Atwater-Kent company went out of business rather then make. Every feature had one purpose, to reduce the cost of manufacture. After World War II there were millions sold under hundreds of brand names from Admiral to Zenith.

It is called the All American Five because all brands were made in America. This was long before the mass exodus of the electronics industry. The five comes from the fact that it used 5 tubes. There were variations using 4 tubes which didn't perform very well and 6 tubes which costs more. The average person who didn't stay up late to see how many distant stations they could hear (known as D X ing) didn't care about the improvements provided by 6 tubes. Consequently the All American Five became a post war standard which did not fade away until replaced by the All Japanese Six, the six transistor radio made in Japan.

The most prominent feature of the AA5 was that it had no power transformer. The result was that the circuit common was connected to one side of the power line. Because there was no polarized plug there was a 50 - 50 chance that the radio's chassis would be connected to the hot side of the power line. Very late models from the sixties were carefully designed not to have any metal parts on the outside even going so far as to recess screws in deep holes. In the 40s and 50s there was no such concern on the part of manufacturers. It was common to see chassis mounting screws exposed on the bottom of the plastic case. These radios could be, and sometimes were, lethal. All it would take was for an unwary person to complete the circuit between a metal part on the radio to a kitchen sink. I once owned one that was in a metal case. My friends and I called these radios "suicide boxes".

Because these radios were made literally by the millions there are still many of them around and in working order. The odds are better than even that one which has been in regular use by a nostalgic owner will be brought to your service shop.

Figure 8.4 A Typical All American Five Radio.

For a verbal description click here.

These radios came in two main varieties, the octal tube versions built mostly between 1946 and 1950, and the 7 pin miniature tube type built between 1950 and fading out in the late 1960s. I have seen a few hybrid radios that must have been made in the transition period and the designers used whatever tubes were priced the lowest by the tube manufacturer.

The tube line up was as follows.

Function | Octal tube. | 7 pin mini tube.
Converter | 12SA7 | 12BE6
IF Amplifier | 12SK7 | 12BA6
Detector and First Audio | 12SQ7 | 12AV6
Audio Power Output | 50L6 | 50C5
Rectifier | 35Z5 | 35W4

Radios of this type constitute a real danger to you and your test equipment. You don't want to join the "great balls of fire" club by burning off the ground lead of your oscilloscope probe or worse.

The safest way to work on a radio of this type is to use an isolation transformer. You need at least 36 watts to be on the safe side. You could gin up an isolation transformer out of two 6.3 volt 6 amp filament transformers connected back to back, that is the two filament windings connected together and the two 120 volt windings used as the primary and secondary of the isolation transformer. You could also use a pair of 12.6 volt 3 amp transformers or a couple of 25.2 volt 1.5 amp transformers. Larger current rating wouldn't hurt, smaller is not recommended.

If you just can't arrange an isolation transformer Plug the radio into an outlet strip that has a switch. Temporarily solder a jumper wire across the radio's on/off switch so it can't be accidently turned off. Measure the AC voltage between the cathode of the 12SQ7 or 12AV6 and AC power ground. If it is 120 volts reverse the plug. Use the switch on the power strip to turn the radio on and off while making tests.

Troubleshooting.

The most likely symptom is a loud hum which comes up as the tubes warm up. The loudness is not or very slightly effected by the volume control. Sometimes you can actually tune in a station and hear it through the hum. This is caused by the electrolytic capacitor in the power supply being dried out. It can't be reformed or recovered in any way. It must be replaced. The circuit above shows a duo 40 microfarad 150 volt capacitor. In most radios these will be a bit smaller. I have seen ones as small as 20 - 20. They may be 20 - 30, 20 - 40, 30 - 40, or 30 - 30. If you can't find the exact replacement use something that is close. You can go up in value but you should never go down. Same goes for voltage.

None of the tubes light up and there is no sound. All of the tube heaters are in series. One opens up and they all go out. Pull the tubes and perform resistance measurements on the heaters. They should range from roughly 20 to 85 ohms. Replace the burned out tube.

Tubes light up but there is no sound. It's time to do a little disturbance testing and half splitting. Turn the volume control to about 2/3 rotation. Touch a screwdriver tip to the center terminal of the three on the side of the volume control. Touch a finger to the metal shaft of the screwdriver. You may or may not hear a loud hum. You have just half split the radio. A hum means the audio section is fine and the trouble is in the Converter, IF, or detector. No hum means trouble in the audio section.

If you've got hum touch the screwdriver blade to the grid pin of the IF amplifier. No need to touch the screwdriver shaft. If you hear static the IF amplifier is good and the problem is most likely that the oscillator is not running. Use a high resistance DC voltmeter to measure the voltage at grid 1 of the converter tube. You should get a voltage ranging from -2 to -20. It will vary slightly as you tune across the band. In an AA5 sitting on my bench I read approximately -10. If you have an authentic VTVM it will measure this voltage without any major errors. A DMM may or may not work. One way to ensure that it will is to wrap one lead of a 1 meg ohm resistor around the probe or clamp it in the alligator clip. Use the other lead as the probe to touch the terminal. The reading will be about 10% low but you aren't worried about accuracy, you just want to know if the voltage is present.

If there is no static when touching or scratching on the IF amplifier grid terminal, or the oscillator is not running, check DC voltages on the IF and converter tubes. A zero plate voltage might well be caused by an open IF coil. Zero plate and screen voltages will likely point to a shorted bypass capacitor.

If you have the equipment you may find signal injection or signal tracing to be more fun. To do signal injection make absolutely sure the signal generator has a DC blocking capacitor in its output. If it does not, modify the equipment or use one externally held in an alligator clip test lead.

Set the generator for audio output and touch the lead to the plate of the output tube. Turn the amplitude up to full. You should hear a weak tone in the speaker. Move the probe to the grid of the output tube. If the output tube is functioning properly you'll get a blast of sound. Reduce the amplitude to a normal level and move the probe to the grid of the first audio tube. You'll get another blast. Turn it down again and move to the top of the volume control.

Now change the generator to modulated RF and tune it to the frequency of the IF in the receiver you are working on. 455 kHz in the case of an AA5. Touch the probe to the plate connection of the two diodes in the detector. Some AA5s use only one of the diodes for audio detection. You should hear the modulated tone on the RF generator. Touch the probe to the plate of the IF amplifier. You should still hear the tone at about the same strength. Now move to the grid of the IF amplifier. The tone should grow much louder and require you to reduce the output. Rock the frequency of the generator a little to be sure you are tuned in exactly on the IF. An older set may have drifted a little off frequency or been mis-aligned by a previous owner or technician. Move the probe to the plate of the converter tube. There should be no significant change in the amplitude of the tone. Now move the probe to grid 3 of the converter tube. Although the tuned circuit is off from the frequency you are injecting you should still hear something just by brute force injection. You would hear this tone even if the oscillator is not running.

Now tune the generator to the band that the receiver is tuned to. Tune the generator around to see if you can find it. If not, the oscillator is likely not running.

There can be a number of reasons for a non running oscillator. The oscillator coil could be open. The 22 k ohm resistor, or its equivalent in your receiver, could be open. The 220 pf capacitor, or its equivalent in your receiver, could be either open or shorted. The tuning capacitor could be damaged and the plates may be touching shorting it out.

Other Types of Radio Receivers.

Not all tube radios that still work are AA5s. There are console radios that use a conventional transformer power supply. All the tube numbers begin with a 6 and all are in parallel across the 6.3 volt transformer winding. The rectifier is sure to be a tube maybe a 5Y3 or if the audio section produces some power a 5U4. If the radio has shortwave bands, and most tube consoles did, clean the contacts on the band switch. Switches that don't make reliable contact are a major cause of malfunctions in such radios. The main feature that distinguishes these radios from an AA5, other than the power supply, is an RF stage before the converter.

There are also many receivers that were intended for use by hams and serious SWLs (Shortwave Listeners). These receivers were made by National, Hallicrafters, Hammerland and others. The more deluxe ones of these had a first If somewhere above the AM broadcast band and a second IF below it. These are called double conversion receivers. The very top of the line receivers made in the 1950s were triple conversion.

No matter how complex they may be the basic principles are the same as those of the AA5. Conversion to an Intermediate Frequency (IF), amplification, and detection.

Alignment.

Aligning the IF amplifier in an AA5 is about as straight forward as it gets. Set a signal generator to 455 kHz and turn on modulation. Connect the generator's output to grid 3 of the converter tube. Connect a VTVM set to AC to the plate of the output tube.

WARNING!!! There is a high DC potential at this point. The classic VTVM included a DC blocking capacitor to allow this measurement to be made safely. A DMM or Transistorized analog meter might have a low voltage capacitor or might not have one at all. If this is the case connect the meter across the speaker terminals.

Some top of the line radios from the 30s made by Zenith and others used stagger tuned IF transformers. If you try the procedure below you will really mess them up. Get hold of a service manual for such radios. It will have alignment instructions.

If you have an AA5 on your bench go ahead with this procedure. Set the volume to a comfortable listening level and adjust the range of the meter to get a good reading. Gently turn the trimmers or slugs in the IF cans. Adjust all for maximum reading.

For Antenna and oscillator tracking alignment the loop antenna can easily be thrown out of resonance by direct connection of a signal generator to the antenna circuit. You may be tempted to use the external antenna connection, usually just a wire sticking out of the back of the radio, as a connection point for your signal generator. DON'T DO IT!

Make a transmitting loop antenna by driving a few small nails into a piece of plywood. Make the shape circular or oval which ever strikes your fancy. Wind several turns, say 4 or 5, around the nails. Place the board so the transmitting loop is parallel to the loop in the radio and at least a foot away from it. Connect the output of your signal generator to the transmitting loop and turn up the amplitude until you can find the signal on the dial of the radio. Note: If you have a good ear you can use a local station for this part of the alignment.

Tune to the high end of the band and adjust the oscillator trimmer so the dial is in calibration. Adjust the antenna trimmer for strongest signal.

If the oscillator coil has no adjustment slug the alignment is complete. If it does, continue.

Now tune to the low end. It is difficult although not completely impossible to do this part of the alignment with a station instead of a signal generator. Set the generator's frequency to about 600 kHz or a nearby spot which is clear of a local station. Turn the radio's tuning knob to bring in the signal generator. There is no way to adjust the inductance of the loop antenna. Read the voltmeter and turn the slug in the oscillator coil until the signal is off tuned. Turn the tuning knob on the radio to bring the signal back in. Read the meter again. If it is less you turned the slug the wrong way. Turn it the other way and tune the signal again Keep doing this until you get the highest signal possible. This is known as rocking the oscillator. If it is something you do frequently you will develop a rhythm in which you are almost turning the slug and tuning knob in unison.

Go back to the high end and if necessary touch up the oscillator trimmer for dial calibration and antenna trimmer for strongest signal. A small table radio such as an AA5 usually does not need repeated iterations of this procedure. Put it back in the case and send it home.

Shortwave and Communications Receivers.

The short wave bands on an AM radio may require more attention. You should not attempt alignment of these bands without an accurately calibrated signal generator. A service manual is always a good idea but if you don't have one you can likely figure out which adjustment goes with which band if no other way than by trial and error. If the latter is necessary be sure to mark the adjustments so you won't get confused and turn an adjustment on a band which has previously been aligned.

Start at the high end. Choose a frequency that is near but not at the high end of the band. Something that is about 20 degrees of rotation of the variable capacitor from the top. Adjust the oscillator trimmer for proper calibration and the antenna trimmer and if the radio has an RF stage the RF amplifier plate trimmer for maximum signal.

Now go to the low end but not the bottom. Once again about 20 degrees off the low end. Adjust the slug in the oscillator coil for proper calibration and the antenna and RF coil slugs for strongest signal.

Now go back to the same frequency you used at the high end and repeat the dial calibration and strongest signal adjustments. Back to the low end and repeat. Go back and forth until the adjustments stop needing to be changed.

Never, never, never, never, attempt alignment of a communications grade receiver without a service manual or a lot of experience. Of course, if you have a lot of experience you will be writing your own book instead of reading mine.

Car Radios.

Car radios are only slightly different from other AM radios. Four major differences are; Car radios are with few exceptions tuned by variable inductors rather than variable capacitors, the intermediate frequency is 262.5 kHz, the B+ is derived from a vibrator power supply, and the radio will always have an RF amplifier stage.

The hardest part of repairing car radios is getting them out of the car and then back in after repair is complete. A typical transistor bench power supply may not have enough current capability to power a tube car radio. If all else fails you may have to take the battery out of the car and bring it into your shop. If you do, BE WARE OF SHORT CIRCUITS! A car battery can deliver enough current to heat a test lead instantly red hot and set the insulation ablaze. In-line fuse holders are available from electronics suppliers and you should by all means get one and fuse the battery. You could use a smaller battery such as one for a motorcycle or riding lawnmower. Even these should be fused.

If you frequently work on car radios I would recommend the construction of a battery eliminator as they were called in the day. Use one or more filament transformers, a bridge rectifier, a BIG filter capacitor, and a variac.

In some cases the speaker is mounted in another part of the car, such as in the dash above the radio and was not removed with it. But any small speaker can be substituted for troubleshooting purposes.

One complaint may be that there is excessive ignition noise and generator hash in the radio. This problem is very difficult to troubleshoot because it can't be tested outside of the car. Power is fed into the radio through feed-through capacitors which in car radio parlance are known as spark plates. A spark plate is a square of metal which is connected to the hot power lead and insulated from the radio chassis with a sheet of mica. There is little to go wrong with such a device except corrosion at the point where the power lead connects to the plate. Here we have a wide open opportunity for finger pointing. The radio repair man will say the fault is in the car while the mechanic will insist that the radio is at fault.

I have no direct experience with functioning car radios either in or out of the car, except for listening. If there are any experienced troubleshooters out there who would like to write a section on this subject be sure to get in touch with me. There's no pay, just credit.

The Vibrator and Buffer Capacitor.

The problem you are most likely to encounter is trouble in the vibrator power supply. The problem may be the vibrator itself or the buffer capacitor which is connected across the secondary of the transformer.

There are two main types of vibrator circuits used, Figure 8.5(a) is an external rectifier type and figure 8.5(b) is a synchronous rectifier type.

Figure 8.5 (a) Uses a Rectifier Tube, (b) Extra Contacts Accomplish Rectification.

For a verbal description click here.

Note: * Some cars in the tube era used positive ground instead of negative ground. OEM radios were properly designed for the make and model of car they were intended to fit. Some after market radios were universal while others were not. This would be a problem for the troubleshooter only if someone has tried to fit an after market or wrong model into a vintage car. Such an event is unlikely for a vintage car restorer. More on battery polarity later. End of note.

A vibrator is nothing more than a fast relay. You can wire any small DC relay so it's coil is energized through a normally closed contact. As soon as you apply the power the relay armature will change states opening the normally closed contact and interrupting the current to the coil. The contact will close reenergizing the coil and causing the contact to open again. This is an electromechanical oscillator. With most relays it will only operate at about 10 cycles per second. A car radio vibrator has been designed so the armature has a mechanical resonance at approximately 100 Hz where it operates.

The vibrator could be arranged to just turn the 6 or 12 volts of the car's electrical system on and off to form a square wave but it would have a DC component of ½ the supply voltage. This DC component would saturate the core of the transformer making it necessary to design the transformer with a larger core cross section. Rather than do that the transformer primary has a center tap which prevents a DC magnetic field from appearing in the core. The positive, or negative, of the car battery is applied through a filter consisting of an inductor and capacitor to the center-tap of the primary. The purpose of this filter is to keep vibrator hash out of the heaters of the tubes and causing interference. The vibrator contacts alternately connect the top and bottom ends of the primary to ground.

You will note that the vibrator coil is connected to the bottom of the primary which does not allow the current through the bottom half to drop completely to zero. Perhaps the primary has been wound to allow for this or maybe it just doesn't make any real difference.

Note: The circuit above shows the vibrator coil being energized from one of the contacts that also serves to switch the transformer. Some vibrators have been designed to use a separate contact for the coil which keeps coil current from flowing in the transformer. This connection is made inside the vibrator can and is invisible to the repair technician. Research has shown that a majority of radios were designed as shown above.

This continuous switching causes an alternating magnetic field to be induced in the core of the transformer which causes an alternating voltage across the secondary. The secondary has more turns than the primary so the voltage is stepped up. The capacitor which is shown connected across the secondary combines with its inductance to form a resonant circuit at the frequency of the vibrator. This attenuates the higher harmonics of the square-wave and makes it closer to a sine-wave. This gives higher peaks and hence more B+ and makes the vibrator work more smoothly.

Back in the day this was called a buffer capacitor and was a frequent cause of trouble. In fact it failed more often than the vibrator. This capacitor carries a considerable alternating current which common radio capacitors are not normally called upon to do. Replacement with an X or Y rated capacitor might be a good idea if space permits.

If the vibrator is bad you are not up the creek although vibrators have not been made for several decades. A Google search will turn up many DIY vibrator circuits as well as companies making silicon replacements. I have not included any links here because like bananas they have a way of going bad over time.

As shown in Figure 8.5(a) the rectifier tube is a 0Z4. This is a gas filled cold cathode type which is no longer available. I am told there are occasionally some on eBay but one can never tell if tubes from that source are good or not. I recommend removing the tube and soldering silicon diodes to the socket terminals. In a number of other places I have strongly recommended against this practice but the 0Z4 is an exception. Unlike a vacuum diode it's forward voltage drop is a nearly constant 14 volts. The slight increase in B+ voltage resulting from silicon replacements is not significant enough to cause trouble.

If the radio is from a 6 volt car you might be tempted to replace the 0Z4 with a 6AX5 and extend the heater wiring to the tube. The two plates and cathode use the same pins in both tubes. The heater current for the 6AX5 is 1.2 amps which will add this much current to the total radio current draw. Also the voltage drop across a vacuum diode is much greater than that across the gas filled diode it replaced. The B+ will be much lower which may adversely effect the performance of the radio. There is doubt in some circles that the 6AX5 would stand up to the vibration experienced by tubes in a car radio. Silicon diodes are the best replacement. If you don't want to solder them in you can destroy a bad octal tube and mount the diodes in the empty socket.

This circuit will deliver a positive B+ regardless of the polarity of the DC input voltage. As long as the designer didn't use the car battery voltage for bias somewhere such a radio should be universal with respect to positive or negative ground.

Synchronous Rectifier.

The circuit of Figure 8.5(b) is of a synchronous rectifier vibrator. Another set of contacts on the vibrator switches the secondary to the reservoir capacitor eliminating the need for any sort of electronic rectifier. The timing of the second set of contacts has been adjusted in the design so switching takes place when the current is zero. The advantage of this circuit is that there is one less component to fail and the disadvantage is that there are 3 more contacts in the vibrator to fail. The synchronous vibrator was also more costly to manufacture offsetting the cost of the rectifier tube.

The most important difference between this circuit and the external rectifier circuit is that the "B+" will have the same polarity as the car battery. If this circuit were to be used in a positive ground car either the primary or secondary leads of the transformer would have to be reversed. But not both. As this would not be considered by the manufacturer as a field adjustment the radio would be made for either positive ground or negative ground and substitution would not be possible. It is conceivable that a service switch could be added to the design which would reverse the leads of the transformer primary. But there is another set of contacts to shake loose and cause trouble.

The construction techniques used in a car radio are meant to withstand the heavy vibration that a radio in a car is likely to encounter. You will find things like hold down straps and springs, loops in wires that may seem unnecessary, and devices meant to hold the tubes in their sockets. The loops in wires are to prevent tension in wires that cause them to break under vibration and temperature extremes. DO NOT REMOVE ANY OF THESE SPECIAL FEATURES.

Other than that a car radio is pretty much standard radio. The same troubleshooting techniques and failures as an AA5 apply.

One thing that might be overlooked is the antenna trimmer. It is a screwdriver adjustment which is accessible from the outside and is usually located next to the antenna jack. To properly adjust it extend the antenna to full height and tune in a weak station near the center of the band. If no suitable station can be found power line noise can be used. Adjust the trimmer for maximum volume. Remember to use a plastic alignment tool rather than a metal screwdriver. The AGC in car radios is designed to work very well making it impossible to hear any change on a strong station when adjusting the trimmer.

Hybrid Car Radios.

My web research resulted in radios for hybrid cars rather than hybrid radios for cars. Why can't Google give you exactly what you want instead of exactly what you ask for.

A hybrid car radio is one that uses both tubes and transistors. In most examples found the pleural use of tubes was correct but the pleural for transistors was not. Hybrid car radios used 4 tubes and one transistor.

Hybrid radios for cars were produced in a very narrow time window. Research on the web resulted in spotty information at best but it appears that the first radios that used space charge tubes were produced in 1958 and the last model year to use tubes in car radios was 1962.

Space charge tubes have a very special design that permits them to operate with plate voltages as low as 12 volts. Such tubes were designed to function in a radio as the RF amplifier, Converter, IF amplifier, Detector, and First audio amplifier. In the early days of the transistor age these are the functions which transistors did rather poorly as evidenced by the performance of table and portable transistor radios from those years. Customer's expectations for the performance of car radios were, and still are, much higher than for home radios. A car radio which would not easily bring in out of town stations during the day and distant stations at night would not be excepted.

The only thing that these 12 volt tubes could not do was deliver audio power measured in watts, as opposed to milliwatts. On the other hand audio power in the single digit watts range was about the only thing that transistors of the day could do well. So the logical answer was to combine 12 volt tubes with an audio power transistor and that was exactly what was done.

The high impedance of the post detection triode was stepped down by a transformer to the low impedance of the power transistor's base. Another larger transformer matched the collector of the transistor to the speaker and they had a working radio that didn't need a vibrator to operate.

In my web research I saw someone in a forum suggest that switching transistors took the place of the mechanical vibrator in tube car radios. I have doubts that this was ever done outside of the R and D lab.

If one of these vibrator-less hybrid radios lands on your bench the output transistor is most likely to be at fault. These were PNP germanium transistors which did not stand up well to high temperatures. The only radio of this type I have had my hands on was missing it's speaker and output transformer so I junked it out. The transistor did not have a very effective heatsink. Germanium transistors are still available but they cost an arm and a leg. Substitution of a silicon transistor is possible but some reengineering will be necessary. Since both input and output are transformer coupled a change from PNP to NPN would be feasible.

FM did not appear in car radios until FM stations started playing pop and country music which was sometime in the mid 60s. By then transistors had completely supplanted tubes in most all radios including those for cars.

FM Receivers and Tuners.

Alignment of an FM receiver will be discussed after some circuit information. There are only two differences between an FM receiver and an AM receiver. The frequency range and the type of detector. The receiver tunes a range of 88 to 108 MHz and the IF is 10.7 MHz. The IF bandwidth is about 200 kHz as opposed to 15 kHz for an AM broadcast band radio. The higher frequencies make the coils much smaller but the basic principles are the same. The FM detector is another story.

FM Detectors.

There are three main types of FM detectors. The Foster-Seeley Discriminator, the Ratio detector, and the Quadruture detector. Of these the first is almost never used because it has poor AM rejection and must be preceded by very hard limiters.

The ratio detector has very good AM rejection and low distortion. It was used in most high fidelity tuners and receivers in the tube era.

The quadruture detector was developed by RCA in an attempt to get around the patents of Edwin Armstrong. The detector was used in almost all TV sets both color and monochrome. Because of the very poor sound reproduction of tube based TV sets I had never thought of this detector as high fidelity. When I had the pleasure of working on a Citation tuner I found to my surprise that it used a quadruture detector. If the Citation used it, it must have been a pretty good detector.

The Ratio Detector.

Below is the circuit of the Ratio detector used in the Stromberg-Carlson model SR-402 AM FM tuner. For a detailed discussion of the operation of the ratio detector click here. Use your back button to return here.

Figure 8.6 A Typical Ratio Detector.

For a verbal description click here.

This was a pre multiplex stereo model however it was on the horizon. There was an extra jack on the back which was labeled detector that mirrored the main audio output. Modifying it to bring pre de-emphasis signal to this jack was very simple.

There are no large currents or voltages in this circuit which reduces the probability of component failure. Resistors and capacitors can simply fail from old age. The most likely one to fail from this cause is the 5 μf capacitor which is a low voltage electrolytic. This capacitor in conjunction with the 2.2 k ohm resistor set the AM rejection. If the electrolytic should dry out and its value be reduced the AM rejection of the receiver will be considerably poorer than when the set was new. Do not assume that if 5 μf is good that 10 μf is better. The impedance and time constant of the circuit consisting of the 2.2 k ohm resistor and 5 μf capacitor in conjunction with the Q of the transformer secondary set the best value of AM rejection. Changing the value of the capacitor will reduce the AM rejection of the detector. In this particular case the substitution of a 4.7 μf capacitor would probably be acceptable especially since 5 μf capacitors are no longer made.

Note: In diagrams of the Ratio Detector you are likely to find in other textbooks the 2.2 k ohm resistor will be split between the top and bottom of the circuit. S-B designers are taking the AGC voltage from the bottom end of the 5 μf cap. My best guess is that if there were a resistor between the diode and this cap there would be an additional RC time constant in the AGC which might render it unstable.

The two 10 k ohm resistors are listed as 5% on the diagram. If one of them were to increase in value, a common result of old age, this would cause you to alter the tuning of the secondary of the discriminator transformer in an attempt to balance the circuit at center tuning. The effect of this would be to decrease the dynamic range of the detector possibly introducing a considerable amount of distortion.

The Quadruture Detector.

The circuit for this detector is somewhat simpler because a special discriminator transformer is not required.

Figure 8.7 A Quadruture Detector.

For a verbal description click here.

As mentioned earlier this circuit is found as the detector in the Citation tuner. This detector has no output for AFC or AGC. I had no diagram of the Citation. All I did was to restring the dial cord and touch up the detector coil a bit. I don't recall if it had an AFC switch. Perhaps its designers had temperature compensated the oscillator well enough that none was required.

The internal structure of the tube used in the detector such as a 6BN6 is such that grid 3 has a negative resistance characteristic. This makes the combination of grid 3 and the tuned circuit oscillate at the resonate frequency of the LC tank circuit. When a signal is present at grid 1 of the tube the oscillator is locked to the incoming frequency. If the tank circuit is tuned to the incoming frequency the relative phase of the signal and the oscillator will be 90 degrees, hence the name of the detector.

As the frequency of the incoming signal changes the relative phase of the signal and the oscillator varies. Alterations of the phase will cause the average plate current of the tube to vary. C1 filters out the RF variations at the plate and in conjunction with the parallel combination of R2 and the plate resistance of the tube adds de-emphasis.

Both C2 and C3 must be large enough to present a low reactance to audio frequencies as well as RF. When this circuit fails, round up the usual suspects, shorted capacitors and open resistors.

FM Receiver Alignment.

Before attempting alignment of the IF strip be sure it needs it. If you remove the tubes for testing be sure to mark them so you can get them back in the same sockets. Small differences in tube capacitances can significantly throw off the alignment of the IF section.

Repeat after me.

NEVER ATTEMPT TO ALIGN THE IF SECTION OF AN FM RECEIVER OR TUNER!

"Never attempt to align the if section of an fm receiver or tuner."

I CAN'T HEAR YOU!

"Never Attempt To Align The If Section Of An Fm Receiver Or Tuner."

I STILL CAN'T HEAR YOU!

"NEVER ATTEMPT TO ALIGN THE IF SECTION OF AN FM RECEIVER OR TUNER!"

YOU ARE GETTING CLOSE, TRY IT AGAIN!

NEVER ATTEMPT TO ALIGN THE IF SECTION OF AN FM RECEIVER OR TUNER!

OK. Now remember that.

Although the drill sergeant would never put up with you asking why, I will. The why is that the IF tuned circuits are stagger tuned. That means that each one is tuned to a slightly different frequency. The purpose is to obtain a wide band response with a flat top. The Citation tuner went one step further and designed an IF amplifier that was phase linear. That is, the phase shift across the bandwidth of the IF was a straight line. They used a very high priced swept frequency instrument to align the IF tuned circuits at the factory. The high priced instrument is still available, but apparently there is no one left who remembers how to perform the alignment. My advice is "don't try it." That said, if you have a sweep frequency generator and a scope and know how to use them and the IF is so badly out of alignment that the receiver does not function then you have nothing to lose.

Other brands of FM tuners weren't so sophisticated so if you have experience in aligning stagger tuned IF strips and it is clear that the IF needs alignment then go ahead. But if you make it worse, don't blame me.

Front End Alignment.

Adjust the oscillator trimmer for best calibration at the center of the band. Adjust the RF and antenna trimmers for strongest signal as indicated on the signal strength meter, maximum AGC voltage, or maximum reading at one end or the other of the equivalent of the 5 μf cap in the ratio detector.

If the frequency calibration is way off at the ends of the band you may have to get into coil adjustment. Some tuners do have slug tuned coils. If so follow the alignment instructions for the short wave bands above.

If you aren't so lucky you will find the coils to be air wound coils. Turn spacing may look a little irregular as the factory alignment consisted of altering the turn spacing of the coil. This is how inductance is changed. Follow the alignment instructions for the short wave bands above but squeeze or stretch the coils to alter their inductance.

Detector Alignment.

Unless the tuner on your bench has been in the hands of someone who tightened up all the loose screws the IF and detector really won't need much if any alignment. In every old tuner I have seen the detector was slightly miss-aligned. You shouldn't need to turn the alignment slug more than 1/2 turn and more likely it will require less than a quarter turn.

The evidence for a misaligned detector is found by tuning across a strong local station which has only very weak signals nearby. When the detector is properly aligned you will observe three distinct listening peaks, not peaks on any meter. As you approach the signal you will begin to hear audio and it may not be distorted but it may be mixed with a little noise. The tuning meter will read quite low. As the tuning meter rises the sound will grow quite distorted. As you continue tuning the distortion will clear and the tuning meter will be at its peak. The stereo light will most likely come on. As you continue to tune the sound will once again grow distorted, the tuning meter will drop, and the stereo light will go out. The distortion will clear but the audio will be a bit noisy, and the tuning meter will read quite low.

A misaligned detector will give you two peaks and it may be ambiguous as to which one is the right one. Make small changes in the discriminator transformer or quadruture coil and tune across the station until you observe the signature of a properly aligned detector described above. If a symmetrical triple peak can't be obtained it may indicate trouble in the detector, or an IF that is seriously out of alignment.

Never adjust the detector for maximum noise when tuned off a station. You will adjust the detector so it won't detect FM at all but might detect AM if the limiters aren't to hard.

Stereo Demultiplexing.

The tube version of the stereo demultiplexer could be much more complex than the IC version. The stereo decoder in the Heathkit AR-15 outdid the tube version because it was pre IC. It worked well but had a temperature drift problem.

For a discussion of the theory of operation of FM stereo click here. Use your back button to return here.

Figure 8.8 Tube Stereo Demultiplexer.

For a verbal description click here.

A typical tube type stereo demultiplexer is shown in figure 8.7 above. The input stage is a hybrid cathode follower and common cathode which provides signal to all three parts of the circuit. You will note the absents of component values. When you are working on a tuner its schematic diagram will give you the values.

Unlike the IC version the stages of the tube version are incapable of selecting the proper signal and ignoring the rest. The sum signal is separated from the others by being passed through a low pass filter which has a bandwidth of 15 kHz. This filter consists of the inductor and capacitor to ground. There is DC from the cathode follower present at the output of the filter which would upset the operation of the two detector diodes. The signal is coupled by a capacitor to the de-emphasis network where the difference signal is added and subtracted.

The 19 kHz pilot tone is taken off the cathode of the cathode follower by a capacitor which forms a series resonant circuit with the primary inductance of the 19 kHz transformer. The secondary circuit appears to be a full-wave center-tapped rectifier. That is exactly what it is however there is no filter capacitor. The circuit doubles the 19 kHz pilot to a frequency of 38 kHz. The output of the frequency doubler is fed into the grid of the 38 kHz oscillator which is a Hartley circuit. The oscillator is synchronized with the doubled pilot by a phenomenon known as injection locking. When the free-running frequency of the oscillator is close to the injected frequency the oscillator will fall into step with the injected signal. Adjusting the slug in the oscillator coil will set the phase of the oscillator with respect to the 19 kHz pilot. Proper phase is important to proper stereo signal decoding.

The wide band filter transformer in the plate of the cathode follower pulls off the difference signal. It is applied to the anode of one diode and the cathode of the other to give L - R and -L + R signals. The 38 kHz transformer in the plate circuit of the oscillator couples carrier to the suppressed carrier double sideband difference signal for proper detection by the diode detectors. The L - R signal should be the one taken off the cathode of the diode but there is an inversion from the input triode which switches the signals around reversing left and right channels.

The two capacitors block the DC from the two detectors from upsetting the bias on the next stages and the two resistors provide DC return to ground for the detectors.

As with the IC demultiplexer you can use an oscilloscope in X-Y mode to tell if the signal at the output jacks is really stereo or just two identical monaural signals. If there is no stereo or the separation is very poor a slight adjustment of the oscillator slug will bring it back. This adjustment is particularly sensitive to temperature and should only be done after a thorough warm-up. The 19 kHz transformer and the 38 kHz transformer in the plate of the oscillator will also effect the phase of the injected carrier. These transformers should be adjusted for maximum signal and the oscillator used for phase adjustment. The 23 to 53 kHz filter requires a very special sweep and marker generator for alignment. I don't think any ever existed outside of the J W Miller factory. There were very few of these coil sets made because designers came up with a less complex circuit that didn't require so many coils. If one of these goes bad your chances of ever finding a replacement are slim and none. If you are absolutely positively certain that the filter can needs alignment you might as well give it a try.

About that simpler circuit. I have it in one of my old notebooks. They are in storage until I finish building book cases to hold them. When the cases are finished and the books come out of storage I will post that simpler circuit.

Well, my books are back and I found the circuit. There are two unidentified coils and an unidentified transformer. Not only that there are several resistors and capacitors which have no value specified. That's nobody's fault but mine. I drew the diagram from a verbal description and I guess I just forgot to write them down. I hope you weren't waiting for the circuit. I'll have to see what I can brew up with some tubes and RF chokes. Oh no! Another addition to my to do list.


Troubleshooting Chapter Nine. Antique Equipment.

Chapter 9   Antique Equipment.

9.1 Before Turning on the Power.
9.2 Pre 1930 Radios.
9.3 Pre World War Two Radios.
9.4 The All American Five.
9.5 Three Way Portable Radios.
9.6 Phonographs and Record Changers.
9.7 Consoles and High Fi Components.
9.8 Wire and Tape Recorders.
9.9 Why TV Sets Are Not covered.

Chapter 9.

Antique Equipment.

Many items of tube equipment are more than 50 years old which qualifies them as antiques. If one of these items turns up on your service bench how it is treated depends on whether it has not been turned on for several decades or if it was in daily use and suddenly failed to operate. The former case is covered in This chapter.

When such an item is brought to your shop by a tearful owner who states that he or she used to listen to it at age six and asks you if you can make it work again even though it may have been stored in a damp basement or hot attic for the last 50 years you are definitely on the hot seat. Such an item requires special care.

There are many special procedures which must be followed if the item is ever to function again. Failure to observe even one of these procedures may result in serious damage to the equipment that may be difficult or even impossible to repair.

One of the many things that is unique about servicing antique equipment is that except for common parts such as tubes, resistors, and capacitors, many of the parts are simply no longer available at any price. Great care must be taken to avoid either physical or electrical damage to these parts.

Authentic Parts Verses Modern Parts.

Some restorers are nuts, that's right I said nuts, over keeping the inside of their radios authentic looking. How many people are going to be interested in looking inside a radio. OK, other restorers. If you are fixing up a radio for competition you will need to be nuts. But most of us just want the radio we found on eBay that is the same make and model on which we used to listen to The Loan Ranger to work and we don't care if it has dog bone resistors and capacitors that look like they are wax paper even if they are plastic on the inside.

In the final analysis you have to decide just how authentic you want your treasured radio to be.

If you are doing the restoration for someone else you must be sure that you and the owner are in agreement about the degree of authenticity. Be sure that the owner understands that as the radio becomes more authentic that the bill will rise. Failure to communicate may result in you having a very authentic radio on your hands with hundreds of dollars of your own money wrapped up in it with no way to recoup your losses.

Authenticity Verses Safety.

In this area I am absolutely adamant. Safety always trumps authenticity when ever and where ever they come into conflict. The example that is most often sighted is the All American Five radio. There were millions of these produced in the years roughly between 1945 and 1965 and there are still hundreds of thousands still in existence and in more or less working order.

Their danger comes from the fact that the chassis is connected to one side of the power line through the off/on switch. You may find that the chassis of the radio has 120 volts between it and an earth ground such as the kitchen sink. I hope you didn't find this out the hard way. So you do the logical thing and reverse the plug in the socket. All is fine until you turn the radio off. Then you find that there are 120 volts between the radio chassis and ground. That's right, you can't win. The chassis is "hot" no matter which way the plug is inserted in the socket. Detailed rewiring instructions with diagrams will be given in the section on post WW II radios. This is one area in which authenticity MUST be sacrificed for safety's sake.

For additional information on tube amplifier and radio circuits see The Fun with Tubes website. Also see Electronics for Physicists particularly chapter 4A.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

9.1 Before Turning on the Power.

There are certain dos and don'ts that should be observed when working on any piece of antique equipment. They are as follows.

1. Don't plug it in and turn it on.

2. Do replace paper and electrolytic capacitors and selenium rectifiers.

3. Do check all resistors for value and replace if more than 20% high or low.

4. Do check the power transformer by applying power with all tubes removed from sockets.

Replace Capacitors and Selenium Rectifiers.

The photographs below show examples of the capacitors that should be replaced.

Figure 9.1 Paper capacitors in a radio chassis.

These are wax paper capacitors. They are not just wax paper on the outside, they are wax paper on the inside as well. Refer to the construction of a capacitor in chapter 3. Instead of plastic film these capacitors use wax paper which is not unlike the stuff your mother used to wrap your school lunch sandwiches in. Paper is a hydroscopic material which means that it likes water. The wax is supposed to prevent the absorption of water but it won't work forever. Over time moisture in the air seeps into the capacitor and gets absorbed by the paper and its insulation property is compromised.

Capacitors are supposed to be a totally open circuit for DC but a paper capacitor conducts some DC current. This is referred to as leakage current and a capacitor that conducts is said to be leaky.

When you find these capacitors in radios or other old equipment replace them with modern plastic film capacitors. Don't bother testing, don't turn it on to see if it will work, don't hesitate, don't ask, don't tell, just replace them.

The photo below shows some capacitors that look nice but they are wolves in sheep's clothing. Or paper capacitors in plastic clothing.

Figure 9.2a Black Beauty and Paper Capacitors.

Figure 9.2b Dark Red Mallory Paper Capacitor.

The one on the left in Figure 9.2a is a 47,000 pico farad, center is a 6800 pf and the one on the right is unknown. The 6800 pf is really blue, gray, red, but the blue and gray didn't translate well to the internet.

The oddball on the right is disguised as a mica capacitor but it is nothing more than alternate stacks of foil and wax paper. True mica capacitors rarely have to be replaced but the paper ones are usually thicker than mica. True mica capacitors are not very thick.

The type of capacitor shown in Figure 9.2b are especially troublesome. In the mid 1960s, 50 years ago, I stocked up on these thinking they were good capacitors. They were at the time but time has been their enemy. They look really good. The ends of the plastic tube are filled with epoxy and they even test good on a digital RLC meter. The only clue that something is wrong is that the value reads out of tolerance high. I just finished going through them and they are 100% too leaky to be used in any circuit. Every last one out of more than 200 capacitors was bad and had to be thrown away.

Figure 9.3 Selenium Rectifiers.

Something else that should be replaced before turning on the power are selenium rectifiers. Selenium dioxide is not just a bad smell it is a rather deadly poison in high concentrations. Replace them with silicon diodes and a series resistor. More about this when 3 way portables are covered. Use the rectifier's mounting screw to mount a terminal strip and solder the wires, the resistor and silicon diode to the terminals.

Never, never, never, solder the diode across the terminals of the rectifier. It is going to short out some day and the results will certainly be catastrophic.

The section below was written by Mike (Mac) McCarty. Mac is a regular contributor to the Fun with Tubes email forum and Is highly knowledgeable in the areas of electricity, electronics, and mathematics. He has so many cogent thoughts on questions that are asked on the forum that I have prevailed on him to become a contributor to this book. I was going to write this section myself but when I remembered that Mac had written something along the same lines I read it over. I can't improve on what he said so why should I try to reinvent the wheel? I now place you in Mac's capable hands.

Max Robinson.

Steps To First Power On.

by Mike (Mac) McCarty.

*** C A U T I O N ***

The high voltages associated with the older tube type equipment CAN KILL YOU!

Before I get into trying to power up a piece of equipment (especially an old tube type) that hasn't been powered up in quite some time, let me say that I presume that the person performing these steps is aware of the dangers presented by high voltages, and is capable of using high voltage power supplies safely. If you have any doubts about your ability to take measurements of high voltages including AC line voltages, then do not perform these tests. Get someone else who is comfortable and experienced with high voltages to do them for you.

Disclaimer.

This little missive surely contains a mistake, or omission, or requires some other polishing. It is assumed that the reader has some electronic theory background. So use this guideline at your own risk. No one associated with the development of this document assumes any responsibility if you electrocute yourself, wife, cat, or dog.

Introduction.

You've acquired a "new" piece of vintage equipment and want to restore it to service. What steps should you follow?

There are several ways to power up a piece of equipment that hasn't been used in a long time.

  1. The quickest and most likely destructive way, is just to plug it in and turn it on. This can result in anything from a working unit, to blown fuses, or smoked parts. NOT a good method.

  2. Another method is to use a light bulb limiter. This does not allow high current, even if there is a short in the piece of equipment being powered up. The light bulb is in series with the piece of equipment under test. So if the equipment has a short, the only current that flows is that required to light the light bulb. For a 60 W 120 V bulb, that is 1/2 A.

    A good rule of thumb is that a light bulb limiter allows a maximum of about 40 % of the lamp's rated power to be dissipated in the load.

    For information on building a light bulb current limiter see:
    Light Bulb Current Limiter.
    Or Current Limiting with a Dim Bulb Tester.

    Though this method has much to recommend it over just plugging in the equipment, by itself it is not enough to ensure that the equipment does not get damaged.

  3. Another popular method is to use a variac to slowly bring the voltage up to "reform" the filter capacitors. Electrolytic capacitors have a tendency to loose their ability to store a charge if they have been lying around, not used, for a long time. I DO NOT RECOMMEND "bringing up voltage on a variac to reform capacitors". That is not a proper way to reform electrolytic capacitors.

    Especially when the rectifiers are tubes, attempting to use that method can seriously shorten the lifetime of the rectifiers. Pulling current from the cathode of a rectifier running with reduced heater voltage can damage or destroy it.

    Properly reforming electrolytic capacitors requires a current limited power supply, which a variac run through a transformer and rectifier is not. For more information on reforming electrolytic capacitors refer to Restoring Dead Capacitors.

    This technique is superior to just plugging in the equipment, but it is also not enough by itself to prevent damage to the equipment.

  4. The recommended method takes a lot longer than the previous methods, but definitely reduces or limits the chances of doing any damage to the equipment. This requires disconnecting many parts of the equipment. Because of this, remember - the high voltages used in the old tube type equipment CAN KILL YOU. So proceed at your own risk.

Preparing to power vintage tube equipment for the first time.

Before beginning work on vintage equipment which has not been powered in some time, first remove all tubes, and mark them as to where they go. Sometimes "identical" tubes don't perform identically. If you remove an IF amplifier tube from an FM set, you may need to tweak alignment if you replace it with an "identical" but not the same tube.

The heart of any piece of equipment is the power supply, and until the power supply is working properly and supplying proper voltages at adequate currents, one cannot hope to try to troubleshoot any of the other stages. Power supplies are like Mama. If Mama ain't happy, ain't nobody happy! So, I recommend you start with the power supply stage(s).

Preparing the Power Supply.

Power supplies often supply several different voltages at different currents. Usually, there are one or more heater or filament supplies which may be AC, and one or more high voltage DC supplies, usually called something like B+1, B+2, etc. Since a variety of voltages is supplied, and also to provide isolation from the AC line, such power supplies usually contain a transformer with separate windings for each heater or filament supply, and one or more high voltage windings, usually center tapped, with a rectifier followed by filtering stages, and sometimes voltage dividers, to supply the various B+ voltages.

Many low end vintage radios have a so-called AC/DC power supply, that is a power supply without a transformer. If this is the case, then one may skip the steps necessary to test the transformer, and check the integrity of the insulation. Look down below to the section Testing the Input Side of the Power Supply. However, spend the time to read and understand the intervening sections, even if you are dealing with an AC/DC power supply, since the principles apply, and some of the techniques are used, in AC/DC supplies as well.

Otherwise, the first step in preparing the power supply is to test the transformer and ensure the power supply is safe to plug in.

Testing the Transformer.

This describes how to check a "characterized" transformer, one whose characteristics are known. It's behavior is characterized, it's a known item, or one which is installed into a piece of equipment which is characterized, and from which we can derive approximate characteristics for the transformer.

If the transformer is "bare", we have no information about it other than perhaps some meaningless (to us) OEM part number, and it is "bare" in the sense of just the transformer, no equipment it is installed in, so we can't guess, except very vaguely like by its weight, what its characteristics might be, then some other checks must be performed.

However, since the transformer is in a piece of equipment which we want to power up, we omit some steps necessary for uncharacterized transformers in this procedure.

  1. Disconnect all windings from their sources or loads, or ensure that they were effectively disconnected when the tubes were removed, then test each winding for continuity using a multimeter. If any winding is open, then obviously there is a problem.

    The resistance of the primary of a transformer intended for 120 VAC is usually of the order of tens to perhaps low hundreds of ohms. The higher the power, the lower the resistance, and high power transformers may have primary resistances of just a few ohms. Transformers for 240 VAC have primary resistances about double that of transformers for 120 VAC.

    Heater and filament windings are usually much less than one ohm, and just a continuity check is all that gets done here.

    The high voltage windings are usually center tapped, and may have resistances on the order of hundreds to a few thousand ohms.

    Check for the center tap to be roughly centered for resistance. It will not be exactly balanced for resistance, because the winding is wound in layers, and is balanced for turns. The length of wire required for the outer turns is greater than that for the inner turns, so the tap is not precisely balanced for resistance.

  2. Check the integrity of the insulation between the various windings, and the core. To do this, apply a high DC voltage, of the order of 400 VDC, using in series a neon test lamp with integral resistor. Do not exceed the capability of the neon lamp tester with the DC voltage used for insulation tests. These lamps are available at many auto supply houses, or in the automotive section of Wal-Mart. This type of tester or equivalent is what you need:

Figure 9.4 Photo of Electrical Test Lamp.

Similar devices are available from Glow Circuit Tester. or Circuit Tester.

Check the test lamp, to make sure it lights up, by attaching one terminal of the power supply to a winding, the other terminal to the test lamp, and probing another end of the winding with the free probe of the test lamp. The test lamp should light indicating that there is a good connection. We don't want to think the insulation is good, when in reality it was not good, but the lamp didn't light because there was a bad connection to the winding. This check to ensure that the lamp lights up must be repeated for each winding connection.

Now, again using the free probe of the test lamp, probe all other winding ends not part of this winding, and the core. Expect to see a single flash, as the inter-winding capacitance (or to core) charges, and then little or no glow after that. If the lamp glows continuously, then there is an inter-winding short, or short to core. Such a transformer is not safe, and must not be used until the short is corrected, or the transformer must be replaced.

Note that some transformers use a single lead connecting to an internal shield, which may also be connected to the core. This lead is often uninsulated. I mention this so you won't think that there is a short from a winding to the frame, when you are actually just probing the shield, which may be intentionally connected to the core.

Repeat this test on every winding on the primary and the secondary side of the transformer.

Before applying 120VAC power, if there are line filter capacitors present on the primary side winding, then they must be replaced before doing any full power tests. This means that, if the capacitor is only across the line power, it must be X2 rated. If one or more connects from either side of the line to ground, or to the chassis, it must be Y2 rated. Below are some examples of X and Y rated capacitors.

Figure 9.5 Photo of X and Y Rated Capacitors.

The capacitors are, top left to right 0.047 uf Y2 250 VAC, 0.047 uf Y2 250 VAC, 0.1 uf Y2 275 VAC and the smaller one below is 0.047 uf X2 305 VAC.

This needs to be done between reattaching the primary winding to the switch, fuse, etc. present in the primary side and any further testing on the primary side.

Also, rarely but occasionally, there are paper capacitors in the power supply on the secondary side. These must be replaced with modern films before powering up the entire supply.

  • After verifying insulation integrity, try verifying voltages, and balance for tapped windings.

    Instead of using 120V AC, try applying 12 VAC to the primary. This makes it easy to compute voltages at 120 VAC, and yet not deal with high voltage unnecessarily. Apply the voltage through a 12 VDC automobile tail lamp. If the lamp lights, there is a problem. If not, then check the windings to see that they produce approximately 1/10 normal voltage, and that center tapped windings are balanced for voltage. If all looks well, then you are ready to apply full voltage.

    The full voltage is applied to the primary through a lamp current limiter. I use a 120 V lamp, and check for shorted windings this way. A variac is optional, but the lamp is not. I usually start with a 7 W lamp for small transformers, and a 40 W lamp for larger ones. Apply 120 VAC through the lamp, and expect to see little or no glow. With a 40 W lamp, you should expect to see no glow. If I use a variac (not usually, but sometimes) I ramp it up fairly quickly to 120 VAC.

    If the lamp lights, then there is a shorted winding somewhere, or the transformer is not truly isolated from the circuit, or the voltage is applied to the wrong winding.

    If all looks well, then another voltage check is done, and voltages should be somewhat high. For example, a 6.3 VAC winding may read 7.5 VAC with no load. To avoid unnecessarily checking high voltages, check tapped windings only from the tap to each end, and not end to end.

    At this point, we have a working transformer. Reattach it, and then start to check integrity of insulation to chassis.

    Testing the Input Side of the Power Supply.

    Using the same neon lamp technique as above, check the insulation from each side of the power line to the chassis. If all looks good, then we are getting close.

    Check the fuse, and the power switch with a ohmmeter. Measure from prong to prong on the power line cord, and ensure that the switch can make it open, and also go down to the previously measured resistance of the primary, plus an ohm or two for the fuse. If this is an AC/DC power supply, then replace any line filter capacitors, or one across the rectifier(s) connected directly to the line with X2 rated capacitors as described in section 3 just above.

    Testing the Output Side of the Power Supply.

    The next step is to investigate the secondary side of the power supply, that is the rectifier(s) and filter. Check all resistors and filter chokes for in tolerance resistance. Disconnect any filter capacitors, and disconnect all B+ outputs, and any resistive dividers, and check integrity of insulation to B- and chassis (if different), using the same neon lamp technique described above. Don't exceed the rating of the components of the rectifier, however.

    1. Attempt to reform the filter capacitors.

      Any electrolytic capacitor which has been out of service for two years or more needs significant reforming before having full voltage applied to it. Some restorers don't like to reform capacitors if they've been out of service for several years, and simply replace them. In that case, the replacements must be reformed. One doesn't know how long an electrolytic capacitor may have been sitting in a vendor's shelf. If it's two years or more, then it needs reforming. That information comes from several manufacturers, like Sprague, Hitachi, and Nichicon. All agree with that assessment, and I believe them.

      Reforming of electrolytic capacitors is worthy of a missive on its own, and is not covered in detail here. See Restoring Dead Electrolytic Capacitors, which describes some acceptable ways to reform electrolytic capacitors.

      You may expect the reforming process to take a period of at least five minutes plus one minute per month of storage. So, if the equipment has not been powered for 20 years, expect to spend about four hours or more reforming.

      After the filter capacitors are reformed (and possibly replaced) they can be reattached to the circuit. Then measure the actual resistance between B+ and B-. The positive probe from the multimeter goes to B+, the other to B-, observing polarity. That's not necessarily across the filter caps, since some sets use B- filtering or other unusual circuitry. The idea is to protect the rectifier. I've measured from the rectifier cathode to the return connection on the transformer (likely center tap of the HT winding). That's probably the best way. You want to see how much current the supply is going to demand from the rectifier. It'll take a while for the capacitors to charge up, so the reading will start out low and increase. Some meters reverse the polarity on ohms to that on volts, so that the black lead is positive. Check your meter.

      The ultimate purpose, since we've already checked the capacitors themselves by reforming them, and also checked the insulation using the neon bulb, is to ensure that we haven't inadvertently introduced a short or near short into the supply when reattaching the caps.

      The ohmmeter likely will read a low resistance, which gradually increases as the filter capacitors charge. Wait for the reading to stabilize. It should be such that not more than 2 mA of current would flow at full B+.

    2. If that's met, then I attach any resistive dividers, and it's time for First Power On of the power supply only.

      If the rectifier is a tube, I install it after checking it for shorts. See below for how to do that. No other tubes get installed.

      Ensure that the Device Under Test is not between you and the door.

      With the possible assistance of a variac but definitely with a light bulb current limiter of appropriate rating, I apply power to the power supply. A bulb limiter permits a maximum dissipation of approximately 40 % of its rating. So, a 100 W bulb would permit a maximum of 40 W or so. That's too high for a First Power On. I normally start with a 20 W to 40 W bulb. If I use a variac, I ramp it up over a space of perhaps five or ten seconds to full voltage. Normally, I just use the switch on my bulb limiter.

      The light bulb current limiter may light to perhaps yellow brilliance for a couple of seconds, then dim down to no more than a dull red glow. If that passes, then I check output voltages. They should all be "ballpark", but somewhat high. If that passes, then the power supply is probably in pretty good shape. If the output voltage has not risen to the point where it's not good for the filter caps, then I'll leave it that way, on a bulb limiter, for a few hours, to weed out any sudden changes which may occur.

    So far, all that works is the power supply. It's time to move on to Part II, powering the equipment with the power supply connected to a load.

    Good, we now have a working power supply. However, it still isn't time to plug the equipment in and turn it on. It may be that it was simply superseded, but the chances are that it was retired for a reason. Even if the equipment was in reasonable working condition when it was retired, there are components which deteriorate although they are not in use.

    Many who have not dealt with vintage tube equipment much are inclined to believe that the tubes need extensive testing, or are likely to be bad. This is usually not the case. Tubes are essentially low power and low temperature light bulbs. Even the very early ones, like the 201, though they are not low temperature, are still essentially light bulbs. Light bulbs do not go bad sitting on a shelf.

    There are three kinds of vintage components which are likely to be bad in vintage equipment. These are electrolytic capacitors, paper capacitors, and resistors. So, let's handle these likely problem spots first.

    The case for electrolytic capacitors has already been covered in the description of preparing the power supply. They must be reformed or replaced. If they are to be replaced, then the replacements must be reformed before putting them into the equipment.

    Paper capacitors are commonly subject to two kinds of deterioration. There are others, but these are the most common. Power line filter capacitors are subject to other stresses, but we covered replacement of them above.

    One is electrolysis which takes place in the oils and waxes of the capacitor when it has a DC voltage impressed upon it. The other is corrosion which is a result of residual water which remains in the paper. Paper is extremely hygroscopic, and even when the paper has been dried by heating in a vacuum, as was done when papers were the common capacitor, some still remains. This corrosion takes place even when there is no voltage impressed upon the capacitor.

    For this reason, all paper capacitors must be replaced. Some try to replace only those needing it, or to "save" them. I did that when I first started restoring vintage equipment to service, but found that, when the capacitors were properly tested at their rated voltage, 97 % of them were leaky. Even if they are not leaky enough to require replacement at the time the equipment is received, they will become so with use. They are like time bombs waiting for the moment when they explode. When a paper capacitor becomes leaky, the consequences may be disastrous for the equipment. They were commonly used for coupling capacitors from plate to grid. If one of them becomes leaky, it may cause a power amplifier to pull sufficient current through an output transformer that it damages the transformer. Transformers are expensive, when obtainable.

    If you want to retain original look, then re stuff with Modern film capacitors. They are smaller than the originals, and can be put inside the old outer wrap. This procedure is not covered here, but it is not difficult, though it is time consuming. The same is true of electrolytics. Modern electrolytic capacitors may be fitted inside the cases of vintage electrolytics.

    The third commonly bad component type is the carbon composition resistor. All resistors, carbon or not, should be measured to verify that they are within tolerance. It is very common for carbon composition resistors to change values, almost always increasing in resistance, sometimes by orders of magnitude.

    I realize that some equipment may have hundreds of resistors. However, it is much easier to troubleshoot equipment when the easy to find problems have already been repaired. A screen resistor being two orders of magnitude higher than it should be can make a tetrode act like a triode, introducing weird "birdies" into a receiver, because it now requires neutralization, and there are no neutralizing components present. It's much easier just to measure a resistor, find it out of tolerance, and replace it, than it is to track down a birdie. A cathode resistor which is five times as large as it should be can reduce gain to unacceptably low levels, causing the equipment to work, but not work well. Partially functional equipment is hard to troubleshoot.

    If you absolutely just can't wait, then perhaps you should be doing something besides restoring vintage equipment. There are many aspects to restoring vintage equipment to service which require patience. Knobs, for example, often require special care and time to remove without damage. Often switches or other controls have frozen shafts which require time and deliberation to free up.

    Flexible wire resistors, looking like a piece of insulated wire, often with a terminal on each end, are subject to being open. I recommend checking all resistors for being in tolerance. Note that vintage parts often do not have the same appearance as their modern counterparts. If you are going to work on pre WWII equipment, then I suggest you familiarize yourself with the appearance of vintage components, like dog bone resistors, wire wound resistors which look like half of a mica capacitor having dots on them, and so on.

    Something especially to watch for are paper capacitors having the appearance of a vintage mica capacitor. These usually have the trade name "Mica Mold" stamped upon them. While paper capacitors are frequently bad, and need replacement in any case, mica capacitors are very stable, and rarely need replacement. Ceramic capacitors, which often look similar to dog bone resistors, are also very stable, and normally do not need replacement.

    The way to discern these is that vintage mica capacitors have reddish brown cases, but the paper capacitors mimicking them have black cases. Also, the dot in the upper left corner is a different color. So, familiarize yourself with the appearance of vintage components.

    There is one other thing which requires checking before powering the equipment up as a whole. That is, the tubes need to be checked for shorts. This does not mean you have to have a tube tester. The reason tube testers exist has always been to sell tubes, that is to encourage customers to purchase replacements for otherwise perfectly functional tubes. If you were a repairman working for pay on someone else's set and wanted to maximize your profits, this would make sense. You are working on your own equipment and not for pay, and any tube replacements are going to come out of your own pocket.

    What I suggest is to use test equipment similar to that used for checking the insulation resistance of transformers. Use approximately 100 VDC to 200 VDC and a neon test lamp with integral current limit resistor. Check each pair of tube pins which are not supposed to be connected internally. The lamp should not light.

    Now, any reasonable tube tester can do this, perhaps a little faster, perhaps not. If you want a tube tester, then certainly feel free to use one to do at least the "shorts" test. If you want to do more extensive tests, then I can recommend one to use the Sencore "Mighty Mite" line of emissions testers for shorts, for rectifiers and other power tubes' emission, and for the grid leakage test for non rectifier tubes, at which it is superb. For testing gain, the Hickok circuit, used in certain Stark testers from Canada, is also excellent, and the Stark line, while internally a Hickok, will not cost nearly as much. However, bear in mind that the best test of the functionality of a tube is the equipment into which it is going to be placed. Unless a tester complains about shorted elements, or the tube has an open heater/filament, do not discard it just because a tester says to do so. Also, do not expect that a tube will perform adequately simply because a tube tester indicates "GOOD".

    At this point, reconnect all the power supply connections, and re insert the tubes into their respective sockets. We are now ready for a true First Power On. Ensure that the equipment is not between you and the door. You should have a Master Power Off switch which is accessible from the door, and certainly not requiring you to reach over the equipment to reach it. Many like to use a variac, and if you wish to do so, then it comes first in the power chain. Next, and not optional, is a lamp limiter. Select the lamp to have a power rating approximately twice the expected power consumption of the equipment, or perhaps a little more. If the equipment to be tested has an AC/DC supply, then an isolation transformer comes between the variac and the bulb limiter.

    Set the variac, if used, to minimum voltage. Turn the lamp limiter off, and set it to limit. Plug in the test equipment. Plug in the equipment under test to the test equipment, and turn it on. Turn the lamp limiter on, but leave it set to limit. If a variac is used, then ramp the voltage up to full voltage over a period not to exceed about thirty seconds.

    Expect to see the limit lamp to light to perhaps half brilliance for up to several seconds, perhaps ten or so, and then dim down to yellow, and then to dull red glow. If the lamp lights brightly, or if the glow does not dim fairly rapidly, then there is a problem, which must be investigated. However, if the First Power On succeeds, it's time to start to do initial checkout, and troubleshoot any remaining problems in the equipment.

    The equipment will probably function somewhat even with a limit lamp, and I normally will use a receiver and check each function, band, tone control, etc. If it appears that the equipment is mostly working, then I'll use it for a period of a few hours with the limit lamp to weed out early failures. If all looks good after that, then I'll set the limit lamp to full power, and after a few moments, begin real checkout.

    Checkout and troubleshooting are outside the purview of this document, but a reasonable first step is to measure all socket voltages and ensure that they are all within 10 % or so of nominal. One thing to watch for is that often vintage equipment literature specifies a 1000 ohms/volt or 5000 ohms/volt sensitivity meter when making measurements. Use of a modern 10 Meg ohm meter would show all voltages as being too high. Parallel your meter with an appropriate value and rating resistor to avoid this problem.

    Congratulations on successfully powering your equipment without damaging it!

    Thank you Mac.

    • Back to Fun with Transistors.
    Back to Fun with Tubes."
    Back to Table of Contents.
    Back to top.

    9.2 Pre 1930 Radios.

    Radio receivers were in a pretty primitive state in the 1920s. Many were home made crystal sets. Some manufacturers provided kits for constructing 1 or 2 tube radios. The TRF (tuned radio frequency) set was more or less the standard for commercially produced radios in the 20s.

    In a TRF all amplifiers up to the detector were tuned to the frequency of the received station. Early designers had not figured out how to make the circuits track. That is if the tuning capacitor were set to the same angle all tuned circuits would be tuned to the same frequency. When tracking was achieved all tuning capacitors could be on the same shaft and tuned by a single knob. The resonance phenomenon was not well understood in 1920 and what seems obvious to us now was not to them then.

    In 1920 the top of the line for those who could afford the price was Atwater-Kent. Here are a couple of photographs of one that I had the pleasure of restoring and have the pleasure of owning.

    A Case Study.

    Figure 9.6 Restored Atwater-Kent Model 20.

    Figure 9.7 Chassis of Atwater-Kent Model 20.

    In figure 9.7 from right to left the tubes' functions are; first RF amplifier, second RF amplifier, grid leak detector, first audio amplifier, and audio output amplifier. The round can which appears to be behind the detector tube is an audio coupling transformer between the detector and first audio stage. There was another one which was between the first and second audio stages which had an open primary. When this picture was taken the second audio interstage transformer had been replaced by a modern one. It can't be seen in the picture. I melted the tar in the defective transformer and pulled the guts out of the can. I installed the now empty can over the new transformer to give the radio an authentic look. In case you have a similar problem the new transformer came from Antique Radios inc. The original transformer is wound with many turns of very fine wire and is lacking in the complete magnetic circuit we know from modern transformer designs.

    Troubleshooting.

    Figure 9.8 Schematic of Atwater-Kent Model 20.

    This radio is so simple there isn't really much to go wrong. The one I restored probably presents a typical set of problems. There was no plate voltage on the first audio stage because the interstage transformer was open. When I connected a 100 k ohm resistor from B+ to the plate the radio began to work, sort-of. I found the grid leak resistor which is specified as having the range of 2 to 4 meg ohms read approximately 15 megs. I soldered a 3.3 meg ohm resistor under the chassis where it is out of sight. I left the snap-in grid leak in place for appearance.

    Why did the radio work with an open audio transformer? Evidently there was enough capacitance from the primary to the secondary and enough secondary inductance to couple signal from the plate of the first audio to the grid of the audio output. After installing the replacement transformer the audio quality was not improved very much. As you can see from the first picture above I am using the radio with the wrong speaker. This is in fact an RCA horn speaker. The Atwater-Kent speaker may have better quality. I am on the lookout for one.

    The operating instructions I found on line state that the B+ should be 90 volts. In fact the radio performs much better at 40 volts. This must have extended the useful life of the B battery. The instructions are also written for use with a 6 volt storage battery as the A source. I used a 5 volt logic power supply which matches the 5 volt filaments in the tubes. This means I don't have to be as cautious with the filament rheostats as the instructions state. These rheostats are the only means of volume control.

    To say the radio is difficult to tune is an understatement of gigantic proportions. With patient tuning I have managed to find some distant high power stations at night. It actually helps to have a noisy fluorescent lamp on the table next to the radio. Turn it on to peak the tuned circuits and off to see what's on that frequency.

    The model 20 dates from about 1920. TRF radios were improved through the 20 as manufacturers figured out how to make the circuits track. At first the three knobs were reduced to two with each one controlling two tuned circuits giving a total of three amplifier stages and finally with higher gain tubes one knob controlling three tuned circuits while returning to two amplifier tubes.

    Although the super heterodyne circuit was invented in 1916 I'm not sure when it came into the radio market but I am sure it was phased in gradually. It seems to have been well established by 1930.

    Back to Fun with Transistors.
    Back to Fun with Tubes."
    Back to Table of Contents.
    Back to top.

    9.3 Pre World War Two Radios.

    By 1930 the superhet was well established so any radio of this vintage you encounter is more than likely to be of this design. Now we will study the principles behind the superhet.

    The Super Heterodyne Radio.

    It's hard to say why the heterodyne radio was considered super. I suspect it was marketing ad verbiage. In any case we are stuck with the term and most of the time it is shortened to superhet.

    The TRF radio receivers have brought us up to about 1925. The principle of heterodyning had been developed by Edwin Armstrong in the 19 teens and patented by him in 1916. An early version was offered to the public as early as 1919 but it really didn't catch on in the consumer market until the late 1920s.

    The Principle of Heterodyning

    Heterodyning is more commonly known as "mixing", "conversion" or "modulation". OK; but what is it? If you combine two frequencies in a device known as a "mixer", "converter" or "modulator" you get two new frequencies. These new frequencies are the sum and difference of the two original frequencies. For example if you combine 5 MHz and 6 MHz in a mixer you get the two original frequencies and in addition you get 1 MHz and 11 MHz. If you combine 650 kHz and 1105 kHz you get 455 kHz, 650 kHz, 1105 kHz and 1755 kHz. There are some types of mixers in which the original signals are canceled out and ONLY the sum and difference frequencies appear in the output. These devices are called "doubly balanced mixers" or DBMs for short. We will likely get to them in time. But for now we will be talking about mixers in which the original two signals appear in the output along with the sum and difference frequencies.

    So What is a Mixer?

    Well, it's any nonlinear device. A nonlinear device is anything that has a graph that isn't a straight line. A diode, either vacuum or semiconductor makes an excellent mixer. A tube or transistor which is being driven into overload is another excellent mixer. The balanced variety consists of combinations of diodes and transformers, or transistors (usually in an integrated circuit). There was even a special tube developed in the 1960s that was a balanced mixer.

    The Superhet Receiver.

    In connection with the TRF receiver I mentioned that tracking of the tuned circuits was a problem. But the major problem with TRF receivers is changing selectivity as you tune across the band. The stations at the high end (near 1600 kHz) tune more broadly than the stations at the low end (near 540 kHz). If there are two stations close together in frequency at the high end you would have trouble separating them. This is not a problem at the low end.

    The reason for this is that selectivity (or bandwidth) is a constant percentage of the center frequency. Suppose the Q of a tuned circuit is 40. At a frequency of 600 kHz the bandwidth is 15 kHz. That's about right for AM reception. On the other hand the bandwidth at 1500 kHz is 37.5 kHz. There is no way around this. We would have to repeal some of the laws of electricity and magnetism to keep this bandwidth change from happening.

    If we could find a way to change the frequency of any given station to some predetermined frequency we could build a set of tuned circuits and amplifier stages that would always have the proper bandwidth and we wouldn't have to worry about tracking because the frequency of the circuits will never be changed. Calling up the station and asking them to change frequency doesn't seem to be a practical solution. We need some way to change the frequency after the station's signal enters our radio.

    Are you ahead of me? Yes. The mixer is it. The frequency we generate to combine with the incoming station is produced within our own circuitry so it is local. It is called the "local oscillator". Let's say we have constructed a fixed tuned amplifier at a frequency of 455 kHz. (That's the almost universally used frequency for this amplifier. Car radios usually use 262 kHz. I don't know why.) So if we want to listen to a station on 780 kHz we must tune our local oscillator to 780 kHz + 455 kHz = 1235 kHz. The 1235 kHz local oscillator combines with the incoming station at 780 to produce two new frequencies at 455 kHz and 2015 kHz. The tuned circuits select the frequency at 455 kHz and reject all others. The frequency of 455 kHz is in-between the station's frequency and the audio frequencies so it is called the "Intermediate Frequency" or just IF for short.

    Image Frequencies

    Suppose you live in Cincinnati so you have a strong local station on 1530 kHz. (It used to be WCKY; I don't know if it has changed. I haven't heard it in a long time because it skips over me here in BG KY.)   Well, suppose you would like to listen to an out of town station which is operating on 620 kHz. You tune your local oscillator to 620 + 455 = 1075 kHz. What do you hear? Well, WCKY on 1530 is also there and combines with your local oscillator on 1075 to produce a difference frequency of 1530 - 1075 = 455 kHz. OOPS!     That's the main drawback to a Superhet receiver. It receives two frequencies simultaneously at the same time. It's up to the antenna coil which is tuned to 620 kHz to reject the strong signal on 1530 so you can listen to the station you want to hear. A really good AM radio will have an amplifier stage before the mixer, called the "RF Amplifier" or "RF Stage" with two tuned circuits to make sure you are only listening to one station at a time.

    The 1930s are often referred to as the golden age of radio. Most of the people who use this phrase are thinking of radio programming content. However it was also technically the golden age of radio. The difference between a 1930 model and a 1940 model is striking. Probably the most striking improvement to a nontechnical person would be sound quality. But there were also large improvements in reliability, stability, and ease of tuning.

    Many consoles incorporated record players and a few even had the newest thing, FM radio. Many had push-pull output stages some boasting output power of 25 watts.

    At the other extreme there were still many battery radios which were not intended as portables. These days they are called farm radios because they were intended to be used on farms where there was no electricity at all or if there was electricity it was 6 or 32 volts DC from a gasoline powered generator and a system of storage batteries.

    Types of farm radios are as follows.

    1. Dry battery only. The source of power was a large cardboard box containing A and B batteries that sat in a compartment in the bottom of the radio. When the batteries ran down the user had to buy a new one. I suspect that when the battery pack went dead that many farms did without radio during the depression.

    2. Dry B battery and storage battery for A battery. If a means existed to charge batteries this was a good solution. A single B battery was less expensive than an A-B pack. In some radios the A battery was a 2 volt single cell lead acid battery. In others it was a 6 volt battery of the same type.

    3. Vibrator derived B+ from a 6 volt storage battery. Many farms had wind powered 6 volt generators that kept one or more 6 volt lead acid batteries charged. A 6 volt radio could operate well from such a system without the ongoing expense of buying replacement B batteries.

    4. 32 volt vibrator radios. Other farms, such as the one I grew up on, had a Delco gas powered 32 volt DC generator system. A bank of five 6 volt batteries were charged daily by the generator. The trick was to manage the power usage so there would be enough juice left in the batteries the next morning to start the generator. In addition to making electricity the generator made enough RFI to make radio listening impossible for all but the strongest station which was WHO in Des Moines.

    Troubleshooting.

    What all these radios have in common are tubes, resistors, capacitors, and inductors. The same kinds of component failures afflict all 4 types. Remember to half split at the volume control and then signal trace or signal inject to find the defective stage.

    One component found in two of the types is the vibrator. Because it is an electro-mechanical device it is the least reliable part in the radio. If you are asked to repair one of these sets you may find that the vibrator can't be made to function. There are companies you can find with a Google search that will provide vibrator replacements that use transistors as the switching elements. You really don't have any choice in replacing this part. Nobody is making mechanical vibrators anymore. In addition the owner will likely want you to build a suitable DC power supply to run the radio. This should not be difficult in this age of power transistors and IC voltage regulators. Remember that the original battery gave a wide range of voltages from fully charged to near run down. Any power supply does not have to be regulated within 1 millivolt or even 1 percent.

    AC Powered Radios.

    Refer to "Steps to First Power on" Above. Near the end of the decade early versions of the All American Five were beginning to be seen but most of the line powered radios you will encounter will have power transformers. This is both a blessing and a curse. The blessing part is that the circuitry is isolated from the power line making the set safe to work on. The curse is that the transformer may be burned out and you will have to find a replacement for it. Hammond makes a wide range of power transformers so you won't have any trouble finding a good electrical match for the original but physical mounting will be the major problem. If you are lucky the replacement will mount in the same way and it will fit in the allotted space. You may have to drill 3 new holes in the chassis to mount the new transformer. If you are unlucky there a whole host of problems that can rear their ugly heads to make your life difficult. You won't know for sure what you need to do until you have the replacement transformer in hand.

    Some Common Problems.

    At this point it is assumed that you have troubleshot the power supply section and replaced all capacitors except micas. One common problem you may have already found is for the field coil of the speaker to be open. Now the issue of authenticity versus cost of repair comes into play. In most radios the speaker field coil was used as a filter choke in the power supply. There are companies out there that will rebuild old speakers including field coil and cone and voice coil replacement. I'm not going to quote a dollar figure but it is likely to cost you more than two limbs. The easiest solution is to buy a modern permanent magnet speaker of the correct size and install it. The diagram is likely to state the resistance of the field coil and a resistor close to this value should be installed in its place.

    If after the radio is working you hear hum in the speaker you may need to add a filter choke in series with the resistor. 5 henrys will usually be enough. The filter choke may not be required if the filter capacitors which were quite small in the original were replaced with larger values. For example it was not uncommon to find filter capacitors of 2 or 4 microfarads particularly in radios of the early 30s. If you replace these with 22 or 47 uf caps the resistor will usually provide sufficient filtering. Leave the can capacitors standing on top of the chassis and install the modern ones under the chassis out of site. Don't forget to disconnect the old capacitors.

    The oscillator and antenna coils in these radios may be quite fragile and a touch or unfortunate bump from a tool may cause it to disintegrate. If this happens don't despair. Antique Electronic Supply has an assortment of oscillator coils and a few antenna and RF coils. The ones made by Hammond are the best.

    The if transformers are a different story. The fragile coils are encased in square cans and are not likely to suffer any accidental physical damage. If one is found to be open you may be out of luck. Your best chance is to substitute an IF transformer from a 1950s or 1960s radio. The only alternatives are winding a new one or make one out of RF chokes. Either way it's going to be a lot of work.

    In some 1930s Philco radios I have seen there are capacitors that are disguised as terminal strips. They have 3 terminals mounted on a black Bakelite block. Inside the block is a capacitor and it has a 99% chance of being too leaky to allow the radio to work properly. These will be found in the audio section used as coupling capacitors. Some people melt the tar out of the block and install a modern capacitor in it. I simply mounted a modern terminal strip on the mounting screw and connected a new capacitor to it. I jumpered from the input side of the capacitor to one side of the new capacitor and unsoldered the wire to the grid and the grid resistor from the block and soldered it to the other side of the new capacitor. The capacitor blocks were left in place so as not to preclude a more authentic restoration in the future.

    One more thing you are likely to encounter is a noisy volume control. Most pots have a small slit opening behind the terminals. Turn the radio so the terminals are up and use a medicine dropper to drop control cleaner at the slit. Rotate the control vigorously to work the cleaner into all of the rotating contacts. If the radio has short wave bands the band switch will also need cleaning. I have seen many radios in which the switch was so dirty that the radio would not work. If the audio section is functioning but the radio is silent clean the band switch first.

    Back to Fun with Transistors.
    Back to Fun with Tubes."
    Back to Table of Contents.
    Back to top.

    9.4 The All American Five.

    During World War II the American electronics industry turned its efforts to supplying military electronics and there were very few if any civilian radios built in the years 1942 through the first half of 1945. At the end of the war the industry started cranking out a simple and inexpensive, some might even say cheap, table radio that became known as the All American Five.

    This radio circuit represents a triumph of the bottom line over quality and safety. It was the radio that the Atwater-Kent company went out of business rather then make. Every feature had one purpose, to reduce the cost of manufacture. After World War II there were millions sold under hundreds of brand names from Admiral to Zenith.

    Much scorn has been heaped on the little AA5 by myself and others but the truth is it's a wonder of design and simplicity. The word is starting to get around and local antique dealers are bringing me their AA5s to put into operating condition. I have had the opportunity to see a great many different radios. The marvel is how well they work considering their construction. There's no such thing as a wiring harness. Wires go every which way, crossing over, twisted around, power next to audio, audio next to RF, power next to RF. Terminal strips are seldom used or used in great moderation. That sometimes means that wires are just brought together in the middle of the air and soldered together. Yet still they keep on ticken'. The design has been so well refined that it seems impossible to build one that won't work.

    It is called the All American Five because all brands were made in America. This was long before the mass exodus of the electronics industry. The five comes from the fact that it used 5 tubes. There were variations using 4 tubes which didn't perform very well and 6 tubes which cost more. The average person who didn't stay up late to see how many distant stations they could hear (known as D X ing) didn't care about the improvements provided by 6 tubes. Consequently the All American Five became a post war standard which did not fade away until replaced by the All Japanese Six, the six transistor radio made in Japan.

    The most prominent feature of the AA5 was that it had no power transformer. The result was that the circuit common was connected to one side of the power line. Because there was no polarized plug there was a 50 - 50 chance that the radio's chassis would be connected to the hot side of the power line. Very late models from the sixties were carefully designed not to have any metal parts on the outside even going so far as to recess screws in deep holes. In the 40s and 50s there was no such concern on the part of manufacturers. It was common to see chassis mounting screws exposed on the bottom of the plastic case. These radios could be, and sometimes were, lethal. All it would take was for an unwary person to complete the circuit between a metal part on the radio to a kitchen sink. I once owned one that was in a metal case. My friends and I called these radios "suicide boxes".

    Most people who owned and used them were blithely unaware of the danger. I'm sure it must have cost some of them their lives. One side of the power line connects to the chassis. Depending on how it happens to be plugged in the chassis could be "hot" 120 volts above power line ground. Most of them have the switch in the chassis side of the line which means that even if you have it plugged in correctly, when you turn the switch off the chassis will be electrically hot. With these units there is no right way to plug them in.

    A Change For Safety.

    First of all you should have replaced all paper capacitors with modern or with X or Y rated capacitors as described in section 9.1 above. Following that there is another change which must be made to make an AA5 safe to work on and use. Here is how most AA5s have the power switch wired.

    For a verbal description click here.

    Figure 9.9 Unmodified AA5.

    The common wiring method had one side of the line cord going to a pin on the rectifier tube and the other side going to one terminal of the on/off switch. The other terminal of the on/off switch went to chassis.

    It should be noted that not all radios used the metal chassis as the circuit common. In some radios all connections that went to common connected together with wire usually at a terminal lug. From this point there was a resistor and capacitor in parallel to the chassis. Commonly used values for these were 220 k ohms and 0.001 uf. When modifying such a radio the 0.001 uf capacitor should be replaced with one that is X rated. When the instructions below refer to the chassis the common point is meant.

    Suppose you plugged it in so the chassis was "cold" when the radio was turned on. That would mean that the bottom prong of the plug was connected to the power line neutral. Everything would be fine until you turned the radio off. Now the top prong of the plug is connected to the hot side of the power line. The tube heaters are cold and have a very low resistance (very approximately 100 ohms). This resistance is connected from the hot side of the power line to the chassis of the radio. You could connect a clip lead from the radio chassis to a water pipe and the radio would come on and play. If part of your body should complete the circuit instead of a clip lead you might never play again.

    I strongly urge modification of the radio circuit to make it somewhat safer. Here's the diagram.

    For a verbal description click here.

    Figure 9.10 AA5 Modified for Safety.

    Before starting to modify the radio go to a discount store and buy a polarized 2 prong plug extension cord. They are usually a dollar or less. Cut away the old power cord but leave short pieces of it on the rectifier tube and switch. If the insulation is in good shape (not always the case in these old sets) leave enough wire to reach to the switch. If the insulation on the old cord is rotten replace it with a piece of wire cut from the extension cord. Decide how long you want the new cord on the radio to be and cut the cord that length from the plug end. You will most likely never find a use for the socket end so cut off the extra cord, save it, and throw the socket end away. Thread the new cord in through the chassis hole, and secure it in the same manner that the old one was, for example tying a knot in it.

    Separate the two wires for a couple of inches, and strip about 1/4 inch of insulation off the ends of the wires. Twist the fine strands of wire tightly together and melt a small amount of solder over them to hold the strands together. This is known as tinning the wire.

    Now remove the wire connected from one side of the switch to the chassis. Strip and tin the piece of wire connected to the rectifier tube socket. Connect this wire to the terminal of the switch you just removed the chassis grounding wire from. Solder the wire in place.

    Remove the piece of old line cord from the other terminal of the switch. Solder the wire coming from the NARROW prong of the new line cord to that terminal of the switch.

    Solder the wire from the WIDE prong of the new line cord to the chassis connection where the switch used to be grounded.

    You may find after making this modification that the hum level has increased. The phrase "lead dress" was probably never spoken in an AA5 factory so the wires go every which way. The reason for putting the switch in the neutral lead was to minimize hum transfer from the off on switch to the volume control pot. Now that the switch is in the "hot" side of the line there may be more hum than desirable in the speaker. When installing the polarized cord make sure the hot leads run along the chassis and as far away as possible from the three terminals on the side of the control. It may be best to route the wires straight down to the chassis perpendicular to the shaft. Route the leads that carry audio along the chassis and away from the power line leads. You may have to solder new pieces of hookup wire in these leads to make this possible. Experience has shown that careful routing of the leads will reduce the hum to acceptable levels.

    The switch modification will make the radio much safer to use and work on but the safest way to work on these sets is to obtain and use an isolation transformer. The minimum you need is a 30 watt transformer. A higher wattage unit would give you more flexibility. It may cost you some money but how much is your life worth. If you think you are immortal or just want to live dangerously there isn't much I can say to you. If you decide to work without an isolation transformer get one of those test lights or a small night light and permanently connect one side of it to the power ground and terminate the other in a test wire. Touch the wire to the radio chassis. If the light lights up reverse the plug. Test it with the switch off. If there is no right way, plug the radio into a plug strip with a switch and use that to turn the radio on and off. Temporarily solder a jumper across the radio's off on switch to prevent yourself from absent mindedly turning it off.

    Jim sent me an email in which he makes the following recommendations.

    "These are excellent suggestions. However, I would suggest taking these steps further, by equipping the radio with a ground fault interrupter (GFI) .

    In my research, I find that many hair dryers are equipped with cords that have plugs containing the GFCI protective device. These look like wall warts on the end of the cord. I found used hair dryers in second hand stores selling for under $5 each. So, the plan is to purchase a used hair dryer with a good cord and GFCI plug, remove the cord and use it to power an AA5 radio, in one of two ways:

    The simplest way to power the radio is to make the hair dryer cord into a GFCI extension cord. Purchase, from a hardware store, an outlet that installs on the end of a cord. Then, properly wire and attach the outlet to the hair dryer cord and you have a GFCI extension cord. Plug the radio into your GFCI extension cord and plug the GFCI extension cord into AC power. Secure the radio cord into the extension cord outlet, since you want the extension cord permanently connected.

    The other way is to use the hair dryer cord to replace the cord that came with the radio. If you choose this method, note that the hair dryer cord is thicker than most AA5 radio cords. The entry hole into the chassis may need enlargement and the strain relief may require replacement to fit the larger cord.

    Look for hair dryers with plugs that have two buttons labeled TEST and RESET. If an outlet is available in the second hand store, test for proper operation of the GFCI before buying the hair dryer.

    Hair dryers have been manufactured with GFCI plugs for over 10 years now, but not all models have GFCI plugs. Therefore, check very carefully to be sure you purchase a hair dryer with a GFCI plug. GFCI plugs may also be found on hair curlers and other bathroom and kitchen electrics, so check those as well if you can't find a suitable hair dryer.

    Jim also sent along this anecdote.

    In my own case I repaired an AA5 radio which used a capacitor between the metal chassis and one side of the line cord. I found about 120 volts DC between the radio internal ground and chassis. I traced the problem to continuity between the audio output transformer's primary winding and its frame. The radio played well despite this problem. I remounted the transformer with insulated fasteners and spacers. GFI would have protected humans from electrical shock if I hadn't fixed the problem, or if the problem developed later.

    Jim"

    Testing tubes.

    You don't necessarily need a tube tester. All you need is a functioning radio that has the same tube lineup as the one you're working on. In the process of testing tubes whether it's with a tube tester or another radio, NEVER PUT A HOT TUBE INTO A COLD RADIO OR A COLD TUBE INTO A HOT RADIO. What the heck do I mean by that? Here is the hot tube into a cold radio scenario. The radio you are working on lights up but doesn't work. You turn it off and take out one of the tubes to test it. You find the tube to be good, yank it out of the tester or other radio, plug it into the radio being repaired and turn it on. The heater of the tube you just switched is hot but the heaters of all the other tubes in the radio are cold. The resistance of the cold heaters is quite low while the resistance of the hot heater is close to its operating value. In the series heater circuit the highest resistance gets most of the voltage. For a few seconds the hot heater will get almost all of the line voltage. It may burn out before the other heaters warm up and start taking their fair share.

    The cold tube into a hot radio goes like this. You have a complete set of AA5 tubes you know to be good and decide to substitute them in to a defective radio one at a time. You turn off the radio, remove one tube, replace it with one of the same type number and turn the radio back on. The cold heater won't take its share of the voltage for a few seconds. The other tubes will proportionally divide up the over voltage until the cold one warms up. If the one you plugged in cold is one of the 12 volt tubes the chances of doing serious damage are small but still exist. If the cold one is the 35 or 50, the other tubes are going to get quite a large over voltage shot and at least one of them may not survive.

    The Dial Light.

    As you learned the dial light carries the B+ current. When you first turn the radio on the light glows at normal brightness for a fraction of a second and then dims down. As the tubes warm up and the radio begins to play the light comes back to normal brightness. If you turn the radio off and right back on the light will light up very bright for a fraction of a second and then dim back to normal. You don't have to do this many times before the light burns out. SO DON'T DO IT.

    If the light burns out the voltage across that part of the heater of the rectifier tube will go up to about 12 volts. That portion of the heater will over heat and will burn out within a few hours of operation. Since dial light bulbs are much cheaper than rectifier tubes, don't operate a radio with a burned out dial light. If you have a large collection of AA5s you should keep some spares on hand.

    Troubleshooting Hints.

    The most common defect of these radios is a bad filter capacitor. This is the one I have designated in the diagrams as a dual 40 microfarad at 150 volts. In real radios it could be as low as a dual 20 microfarad. The symptom is a loud hum that may be changed slightly, if at all, by the volume control. Sometimes you can tune in a station and hear it through the hum. The only thing for this is to replace the capacitor. One with this failure mode can't be reformed. You can go up in capacitance or voltage but not down. For example if the radio has a 20 - 20 microfarad at 150 volts you could replace it with a 20 - 30 at 150 volts or 40 - 40 at 250 volts.

    If you have a radio which lights up but has no sound try this. Touch the tip of a screwdriver to the center terminal on the volume control while touching the metal part of the screwdriver with one finger. There are two terminals on the back of the control, these are the on-off switch. You don't want to touch them! The terminals of the potentiometer are in a group of 3 and are on the side of the control. Turn the volume to middle or higher. Touch the screwdriver to the terminal and touch the metal shaft of the screwdriver with a finger. You may or may not hear a loud hum or buzz. If you do the audio section is working and the trouble is in the converter, IF or detector. If you don't hear anything the trouble is in one of the two audio tubes. Not necessarily the tubes themselves. As you learned earlier this is a form of half splitting.

    Use a DC voltmeter to measure the voltages on plates and screen grids. A leaky capacitor can put a positive voltage on the control grid of the 50L6/50C5, but you already replaced that one didn't you?

    If the audio section is working, try scratching on the grid terminal of the IF tube with the screwdriver. If you hear static the IF amplifier is OK and the trouble is most likely in the converter.

    Check to see if the oscillator is running. The oscillator grid of the converter tube should have a negative voltage on it. A VOM won't work here. Use one of those cheap DMMs. Wind one lead of a 1 meg ohm resistor around the measurement probe. Touch the other lead to the oscillator grid terminal and read the voltage. The purpose of the resistor is to keep the input capacitance of the DMM from stopping the oscillator. You should read anything from about -2 volts to -50 volts. The reading will be about 10 % low but you're not going after precision, you just want to know if there is a negative voltage indicating that the oscillator is running.

    If you are using an authentic VTVM you don't need to use the resistor. The DC probe on most VTVMs has a 1 meg ohm resistor built in and the meter calibration takes this into account.

    Some AA5s might fool you because of a peculiar money saving modification. Look ahead to figure 9.11. Note the connections to grid 1 of the 1R5. You will note that there is no capacitor in the grid line and a coil that someone forgot to connect. There is virtually no inductive coupling between the tuned winding of the oscillator coil and the grid winding. The coupling is capacitive and replaces the typical 220 pf capacitor which is usually found here. I have worked on such an AA5 and I can say that it does work. It strikes me as going to great lengths to save a few cents on one capacitor per unit. It must have been economically feasible or it wouldn't have been done.

    One more thing you are likely to encounter is a noisy volume control. Most pots have a small slit opening behind the terminals. Turn the radio so the terminals are up and use a medicine dropper to drop control cleaner at the slit. Rotate the control vigorously to work the cleaner into all of the rotating contacts.

    Variations on a Familiar Theme.

    As I noted earlier there was an All American 4 which didn't work very well and an All American 6 which worked very well but cost more.

    In some radios, particularly AM/FM there wasn't enough heater voltage for the rectifier so the 35Z5/35W4 would be replaced by a selenium rectifier. If you get one of these go ahead and replace it with a silicon. The extra voltage won't hurt anything in this case.

    In the AA4, 35 + 50, + 2 X 12 doesn't add up to the line voltage. A tube manual I have from 1946 lists 45Z3 and 45Z5 which could have been substituted for the 35Z5 in an AA4. I once owned one of these radios and it didn't use one of these 45 volt tubes. I assume that most other AA4s used a fixed resistor to drop the extra voltage as mine did.

    AA6s on the other hand needed a lower voltage tube in one of the sockets. The 35L6 and 35C5 were made for this purpose. I have seen AA6s which had a 50L6 in the output tube socket while the schematic listed a 35L6. Either someone didn't know or didn't have a 35L6 in stock and decided to send the radio home with a 50L6 to get the radio working rather than wait to order the correct tube.

    Millions of AA5s were made and thousands have been restored. There are still tens of thousands out there waiting to be restored. Have fun.

    Back to Fun with Transistors.
    Back to Fun with Tubes."
    Back to Table of Contents.
    Back to top.

    9.5 Three Way Portable Radios.

    The 3 way portable radio was call that because it could operate from AC line, DC line, or an internal battery pack. They ranged in size from small enough to fit into a large coat pocket to luggables that were about 12 inches wide and 10 high. I owned one of the latter which wasn't very heavy without the battery but when batteried up was quite a load. It was a Motorola model 6L1. I don't have it anymore but I spotted it on a museum site and found the schematic on Nostalgia Air. I suppose it was for sentimental reasons that I have chosen this circuit to represent 3 way portables.

    Figure 9.11 Schematic of 3 Way Portable.

    Upon examining this schematic the first thing that struck me was that AGC is applied only to the RF tube and no other. After a few minutes of puzzlement I got it. The 1U4 is a sharp cutoff pentode. A remote cutoff pentode can provide gain control over a wide range even for voltages measured in volts or even 10s of volts. if this is attempted with a sharp cutoff tube serious distortion of an amplitude modulated signal will result. A sharp cutoff can be used as a gain control element if the signal level is kept small, in the single digit millivolts or below. That is exactly what is being done in the RF stage of this radio.

    I remember that the AGC action was about the same as an AA5 but not as good as an AA6 wherein the AGC is applied to RF, converter, and IF stages. In keeping with small voltages approximately 25% of the derived AGC voltage is applied to the control grid of the RF stage. I assume that the tapped secondary of the RF plate coil and the resistor in series with grid 3 of the 1R5 is to improve performance under extremely strong signal conditions. I don't remember it ever being blocked even when riding in a car with it and driving past a radio station's tower.

    The oscillator needs a special note as this method of coupling to grid 1 of the converter tube is used in many AA5s as well. What appears to be a link winding which has one end not connected is just that although there is probably very little in the way of magnetic coupling going on. Capacitance from the tuned section of the oscillator coil to the link replaces the mica capacitor which is usually found here. This strikes me as going to great lengths to eliminate one capacitor but the economics must have worked or it wouldn't have been done this way.

    Note that local audio ground is established from the negative side, pin 1, of the filament of the 1U5. You may find the filament string a bit tough to tease out so here is a simplified diagram of the chain.

    Figure 9.12 Filament circuit of 3 Way Portable.

    The two resistors associated with the 3V4 are to conduct the plate and screen current to ground. Without them this current would flow through the filaments of the other tubes. You will note that the filaments are a little starved for voltage and they are not all equal. When the applied voltage is 9 volts as when operated from batteries the voltages will be a bit higher. There should be more resistors for cathode current along the line. The Zenith Transoceanic has several resistors to ground along the filament chain. I don't see that adding these resistors would significantly effect the battery life. I'm sure they were left out to reduce the manufacturing cost.

    The two 1 k ohm resistors shown in this diagram are actually the 2 k ohm tapped resistor shown in the complete diagram above. This resistor became open while I owned the radio and before I had acquired sufficient skill to replace it myself. I suppose that just one of the sections opened up. The service shop where I took it made no attempt to obtain the original Motorola part. Instead they hung a 10 watt resistor by stiff wires coming through a hole drilled in the chassis. If I still had the radio I would do something about this.

    Troubleshooting.

    I have already pointed out the most likely failure in the radio. The 2 k ohm resistor is dissipating 5 watts and is the most likely component to fail.

    Remember that the selenium rectifier should be replaced with a silicon diode. Do not give in to temptation to leave it in place. When a selenium rectifier fails it gets hot and some of the selenium is oxidized. Selenium is in the same column of the periodic table as sulfur and shares some of its characteristics. Of interest here is it's oxide. Sulfur dioxide and selenium dioxide are both rather poisonous. Also they both smell like rotten eggs. If you are working on a radio that still has a selenium rectifier in place and you smell rotten eggs, unplug the radio and open the windows. A selenium rectifier is a poison bomb waiting to go off. Physically remove the rectifier from the radio because some future owner might try to restore it to authenticity by reconnecting it. Use a shorter machine screw than was used to mount the rectifier and mount a terminal strip. Connect the wires that originally went to the rectifier and solder a silicon diode in place of the rectifier. The plus marked side of the selenium corresponds to the banded, cathode, end of the diode.

    The value of the 150 ohm resistor will most likely have to be increased to keep the voltage at pin 7 of the 3V4 from exceeding 9 volts. Actually 9 or even 9.5 volts at this point wouldn't hurt any. If you are uneasy with the differing voltages along the filament string you can always do a little re-engineering by adding equalizing resistors.

    If the 20 uf capacitor shorts it would most likely take out the top half of the 2 k resistor especially if the owner unwisely left the radio turned on even though it was silent.

    If the 80 uf capacitor shorts out it will also silence the radio but it is unlikely that any additional damage will be done even to the 3V4. The 2 k resistor from the 105 volt supply is almost a constant current source and the 3V4 will not sustain any damage.

    Elsewhere the circuitry is not unlike an AA6 so if the filaments have proper voltage but the radio remains silent all you need to do is round up the usual suspects.

    If you or the owner wants battery capability you will have to construct a battery. If you are extremely lucky you will be able to find an AB pack that fits the radio. You might even find one still in it. It will be run down long ago but you can use the box and the connector socket. If not you will have to devise a method of connecting the battery that is easy to connect and disconnect.

    The 90 volt B battery is easy. Just ten 9 volt transistor batteries will do perfectly. I have heard of people making up the B battery from AA cells but I view this as overkill. The current drawn from the B battery is less than that drawn by a 6 transistor radio so the 9 volt batteries should last a long time. In the original AB pack the A battery was made up of F cells which was probably overkill. After the B battery was run down I could get several months of experimentation out of the A battery. Modern D cells or even C cells should do the job nicely. It may be that the B battery was intended to run down so the user would stop using it before the A battery lost sufficient voltage to damage the filament's coating from being operated below design temperature.

    One more thing you are likely to encounter is a noisy volume control. Most pots have a small slit opening behind the terminals. Turn the radio so the terminals are up and use a medicine dropper to drop control cleaner at the slit. Rotate the control vigorously to work the cleaner into all of the rotating contacts. If the radio has short wave bands the band switch will also need cleaning. I have seen many radios in which the switch was so dirty that the radio would not work. If the audio section is functioning but the radio is silent clean the band switch first.

    Back to Fun with Transistors.
    Back to Fun with Tubes."
    Back to Table of Contents.
    Back to top.

    9.6 Phonographs and Record Changers.

    As far as I can tell the first electric phonographs intended for home use appeared about 1930. At one time I actually had ownership of a variable reluctance pickup cartridge intended to adapt a spring driven acoustic phonograph to electrical reproduction. I couldn't make it work and not realizing the antique value even of a nonfunctional unit I either threw it away or gave it to a friend. Oh, the indiscretions of youth.

    Beginning after world war II the crystal phonograph became very popular. I owned one myself. These players used a Rochelle salt crystal cartridge which delivered about 6 volts into a 500 k ohm load. This high output meant that only one amplifier tube was required. The diagram is shown below.

    Figure 9.13 Crystal Phonograph.

    There were other variations than those indicated in the schematic. The first electric phonograph I owned used a 117L7/M7 which incorporated the rectifier and the power amplifier into the same envelope with a 117 volt heater. Another variation I saw used a selenium rectifier and a 25L6 amplifier. The motor had been designed to operate from 92 volts at a current of 300 mA. The motor was in series with the heater.

    If you find one of these phonographs your chances of ever getting it to operate in its original state are absolutely zero. The reason is the crystal pickup. Rochelle salt is a very hydroscopic material. That means it loves water and will grab onto any stray water molecules that come by. My original phonograph was bought and used for about 2 years in Iowa. Then we moved to Florida. In that humid climate it only lasted about 6 months. After having the cartridge replaced for a cost of 8 dollars it went out after another 6 months. 8 dollars was a considerable sum of money in 1952 and my mother said I would just have to do without rather than spend another 8 bucks on another crystal. The symptom is the sound grows progressively weaker and weaker until the volume control is up all the way and from that point it fades out to inaudibility. No doubt one of these cartridges would last for several years in Arizona but humid climates are death to them.

    If you must get one of these phonographs restored to operation the only way I can see to do it is to install a ceramic or even a magnetic cartridge and install a transistor preamp to bring up the level to that required. It could easily be powered from the DC level at the cathode of the power tube and hidden in an electrolytic capacitor can.

    A much better phonograph was the one with two stages of amplification. If you take away the 12SA7/12BE6 and the 12SK7/12BA6 from an AA5 and replace the heaters of the missing tubes with a 150 ohm 5 watt resistor you have the circuit of a ceramic phonograph. These were a little more expensive but if you lived in a humid climate the difference would be made up in a year. The reason that more gain was needed was that the ceramic cartridge output was less than 1 volt.

    Other than the cartridge the filter capacitor was the part most likely to fail. In an old player this is one of the parts that should be replaced as a matter of routine.

    The test for either a one stage or two stage phonograph amplifier is to lift up the arm with the unit turned on and the volume up all the way. Touch the cartridge pins one at a time while not touching anything else. If you hear a loud hum when touching one the amplifier is alright and the cartridge is dead. Even ceramic cartridges can go dead after 50 years. Although I do have a Silvertone wire recorder and phonograph that has a working ceramic cartridge in it. The sound is a little weak but it is still usable enough to record from a record to wire.

    Record Changers.

    I don't know when the record changer was invented but I once owned one that dated from about 1940. It made an incredible amount of mechanical noise. The change cycle began with a metallic bang that was a projection on the rim of the turntable hitting a lever which the eject button or the arm tracking the eccentric groove at the end of the record had pushed into the path of the projection. This raised a roller that engaged a spiral groove in the bottom of the turntable. This pulled the roller toward the center of the turntable which moved the rack in one direction. When the roller reached the end of the groove an inclined plain pushed it down which caused another one to pop up that was positioned at the beginning of the groove. This was the halfway point of the cycle. The second roller was pulled toward the center which moved the rack back in the other direction. The incline pushed the roller down completing the cycle. The rollers in the groove were metal on metal. The cycle sounded like this. Music ends, record scratch, click bang, grind grind grind, flop as the record dropped, grind grind grind record scratch, music starts.

    The odds of either one of us encountering this exact model are small although I must say the movement was quite robust and as long as I kept things oiled it worked fine.

    The three types you are most likely to encounter are the ones made by BIC, yes, that's the same as the pen company, VM (Voice of Music), and the RCA 45. The BIC name is not on every changer built by BIC. They made drop in changers for console units made by many different manufacturers. Most manufacturers put their own name on the changer. VM also made changers for consoles but you are apt to see the VM name plate on these changers. I suspect that VM wrote a clause in their contracts that required that the VM name remain on the changer.

    The BIC and VM changers worked much the same. There are gear teeth cut into the bottom end of the turntable bushing. The change drive is a gear about 5 inches in diameter with a gap at one point. During play the gap is positioned around the gear on the turntable. When the cycle is triggered a small projection is moved forward which catches the teeth and turns the change drive gear just enough to engage its teeth in the turntable's gear. There are various grooves and projections on the change gear that move the arm, activate record size detectors and initiate record drop. The change cycle takes place over about 4 revolutions of the turntable.

    The RCA 45 was another of those innovations that comes along about once in a generation. It and the records it played had been designed for each other. The entire change cycle took place in a single revolution of the turntable.

    Troubleshooting.

    If the turntable runs the most likely problem is that it stalls when going through the change cycle. One cause of this is a slippery idler wheel. If you do a Google search you may be able to find a replacement idler wheel or the rubber tire that goes around it. One thing you may be able to do is to remove the rubber tire, turn it inside out, and reinstall it. This exposes rubber which has been protected from the ravages of time. Be warned, the tire may be too fragile to withstand this treatment. If the previous option is out of the question but the tire has not totally disintegrated you may be able to resurrect it by roughing the surface with sandpaper or a file. Be careful not to create flat spots. A change in diameter of the idler will not alter the speed of the turntable. Sometimes it is necessary to shorten up the idler spring a little but don't carry this too far.

    Another cause of stalling is a frozen up bearing in the changer mechanism. The lighter hydrocarbons in the oil have evaporated leaving behind a substance that is more like tar than anything else. The bearings most likely turn with great difficulty if at all. The right way to treat this condition is to completely disassemble the mechanism and soak all parts in a degreaser, then relubricate with sewing machine oil and reassemble. I must admit that I have never felt up to such a time consuming procedure with its high risk of losing parts or forgetting how they go back together.

    One way is to simply flood the bearings with new oil and wipe up the excess. The idea is to flush out the heavy hydrocarbons and replace what's in the bearings with good oil. In particularly stubborn cases WD-40 can be used to flush out the tar and then oil the moving parts. DO NOT LEAVE WD-40 IN THE BEARINGS. It is NOT a lubricant. You MUST replace the WD-40 residue with real oil or they will freeze up tighter than they were before.

    You should use a very light oil on the parts of a record changer. The old hardware store standby 3 in 1 will do but it will tar up again in a few years. Sewing machine oil is a much better choice and you don't have to look very hard to find it.

    Troubleshooting a record changer can be difficult because it is hard to see what's going on under there. Here is a way to get the inner workings into the open and still allow it to be operated.

    Figure 9.14 Hang the Changer by Wires.

    This picture shows the transport mechanism from a Silvertone wire recorder hung by coat hanger wire from my workbench light. The florescent fixture is hung from the ceiling by chains attached to screw hooks that go into ceiling joist. Any record changer can be hung in the same way. The wires pass through hooks in wires that go over the top of the fixture. This is so the wires can be folded up against the fixture out of the way when not in use.

    Once the bearings are properly lubricated and running freely the changer will work most of the time. If it doesn't there may be a missing spring, misadjusted or misaligned part, or a warn part.

    Ace hardware does stock a few helical springs and if you need one of those you may be able to find it. If a flat spring is called for it may be harder to find. Flat springs are found in old windup clocks. Here is a case where you may need to sacrifice one antique to restore another one.

    Misalignment is sometimes the result of a missing screw. They do tend to vibrate out and get lost. Finding a new screw shouldn't be hard even if it is metric. Changer parts often pivot on nylon inserts. Do not oil these. If a previous owner did the insert has likely disintegrated and needs to be replaced. Such parts may be very hard or impossible to find. If you have some skills with files and other small hand tools you may be able to fabricate one out of aluminum or hardwood. If made of wood the friction surface should be heavily waxed, not oiled.

    A previous owner may have bent a part for some reason known only to that person. Bending it back is probably the only solution but be cautious. Metal fatigue can set in very quickly particularly if the part is made of aluminum. If it breaks you are probably back to fabricating a new part.

    If a part is just warn out the only option is to make a new one as indicated above.

    Sometimes a changer will be just so warn out that it can't be restored. One option is to disable the change mechanism by removing the change cycle initiation part or parts and using it as a single play turntable. Another option is to say "it can't be fixed". If you are working on it for someone else and they insist that they want it to work you may have to say "take it to someone else".

    Back to Fun with Transistors.
    Back to Fun with Tubes."
    Back to Table of Contents.
    Back to top.

    9.7 Consoles and High Fi Components.

    High fidelity seems to have come into existence sometime after World War II. I'm going to put it at about 1950. By 1955 the word if not the sound had become rather prevalent if not ubiquitous. Many older console designs were given a facelift, labeled as high fidelity usually in script, and remarketed with few or no internal changes.

    These renamed consoles usually featured a 12 inch electro magnetic speaker, push-pull outputs and no negative feedback. The power tubes were most likely to be 6V6s although some had 6F6s or 6K6s. A few did have 6L6s. These were monophonic. The output transformer was usually mounted on the speaker. Although stereo was introduced in late 1957 it did not really catch on with the general public until after 1960.

    Phase Inverters.

    Because most of these consoles had push-pull outputs the phase inverter circuit is important to the performance of the set. The earliest consoles used a circuit known as the open loop phase inverter. An example circuit may be seen at     this location. Look at the first diagram on the page. Use your back button to return here. The duo triode would likely be a 6SN7 rather than the 12AU7 shown, and the single triode would likely be a 6J5. Resistor values would be different.

    A variation on the open loop is the closed loop phase inverter. Negative feedback is used to make the circuit self balancing as shown below. This circuit was found in a Westinghouse console.

    Figure 9.15 Closed Loop Phase Inverter.

    The 220 k and 270 k ohm resistors form a voltage divider across the two output tube (6V6) grids. When the voltages at the two grids are equal in amplitude and opposite in phase the voltage at the junction of the two resistors is just what is needed to make the AC voltage at the plate of the second 6AT6 exactly what it should be. If aging tubes imbalances the drive to the two 6V6s, say to reduce the drive to the bottom tube, the voltage at the junction of the two resistors will increase driving the grid of the lower 6AT6 harder partially restoring the voltage to its proper value.

    The diodes in the first 6AT6 are used as the AM detector as in the all American 5.

    Troubleshooting.

    First of all it is assumed that all capacitors have been replaced or reformed as appropriate. All resistors should have been checked and replaced if out of tolerance.

    If the set still doesn't work the band switch probably needs attention. Older consoles are very likely to be either AM/FM or AM/SW or even AM/SW/FM. There may also be a phono position for a record player included in the console. Silver plating of switch contacts was common in this era as it is today. Silver can be oxidized to the point of making poor or no contact. The rubbing of contacts together which keeps them clean when in daily use is not sufficient when a radio has sat unused for several decades. Contact cleaner applied to the switch contacts will very likely restore the set to operation.

    Other causes of non operation could be an open speaker field coil. Even if the set plays, check the plate voltage on the plates of both output tubes. If one side of the output transformer is open there may be no noticeable effect on the sound at low listening volume. The tube on the open side which has screen voltage but no plate voltage will not last very long under these conditions.

    The record player, usually a changer, likely employs a ceramic pickup cartridge. Unless the set has been stored in a very damp basement, chances are good that the cartridge is still good. In units made in the late 40s and early 50s the changer was most likely a single speed 78 RPM player. I have seen many consoles from this era in which the original changer had been pulled and a 3 speed or 4 speed changer dropped in its place. At some time the size and mounting of record changers was standardized which made a drop-in retrofit possible.

    Another thing you are likely to encounter are noisy volume and tone controls. Most pots have a small slit opening behind the terminals. Turn the chassis so the terminals are up and use a medicine dropper to drop control cleaner at the slit. Rotate the control vigorously to work the cleaner into all of the rotating contacts.

    High Fi Components.

    High fi components basically took the parts of a console radio phonograph and packaged each separately. Because customers were willing to pay more for quality components they were all more elaborate than would be found in a typical console.

    The radio section was marketed as a tuner. Invariably FM and usually including an AM section as well. The FM section was as good as the state of the art at that time permitted. Sometimes the AM section was skimped although it was often of a high quality.

    The amplifier would always have negative feedback, lower distortion, and more power than a console. In the bottom of the line amplifier the output tubes would be 6V6s but higher priced amplifiers would have 6L6GCs or EL34s. For details on the circuitry of amplifiers I suggest study of all the articles under the heading of "Audio Amplifiers How they Work" on this website. You might also find useful information under the heading "Building Amplifiers". I've already written those pages so why should I reinvent the wheel. Although there was movement towards high quality capacitors some amplifiers and tuners still used wax paper capacitors. Many manufacturers thought of the black beauty as being a quality part but it was a wolf in sheep's clothing. If any of these are found they should be replaced just as in an AA5.

    Speaker systems were built in large boxes and there was little in them to go wrong. One common problem with vintage systems is that the rim support of the woofer was made from a kind of plastic that disintegrates after about 20 years. Even the much touted Acoustic Research speakers suffer this fait. You could have the speaker reconed but it is a lot cheaper to just buy a new speaker and figure on replacing in another 20 years. The crossovers have capacitors, inductors, and occasionally resistors. Unless the speaker system has been over driven it is unlikely that any of these components will be defective.

    Speaking of over driven I remember an anecdote from the late 50s. It seems that a local TV shop sold and installed a component system for a well to do family. The shop unwisely installed a standard AC outlet on the back of the cabinet containing the electronics and AC plugs on the ends of the wires from the speakers. Shortly after the installation was completed the family decided that the listening room needed to be carpeted. After the departure of the carpet installers the sound system no longer worked. You guessed it. The carpet installers in an attempt to be nice plugged everything back in as they had found it, almost. I can't imagine what sound must have come from those speakers with 120 volts AC applied.

    Back to Fun with Transistors.
    Back to Fun with Tubes."
    Back to Table of Contents.
    Back to top.

    9.8 Wire and Tape Recorders.

    In the late 40s and early 50s there were a few home disk recorders sold but they never really caught on. The main reason was probably that the media could not be reused if the performer made a mistake or if it was recorded with too low or too high a recording level. Also they needed the constant attention of an operator to sweep away the fine thread of plastic that the stylus cut out of the surface of the disk.

    Sears introduced the first wire recorder in 1948 under its Silvertone brand. The selling point was that the recording media could be used over and over until performers and engineers got everything right. There were other makes of wire recorders most notably Webcor which made machines intended for office dictation. The recording wire was very fine and there was more than a mile of it on a spool. The wire speed was 22.5 inches per second which meant if something went wrong the wire would be in a hopeless tangle before the user could get to the stop control. Such a tangle could not be recovered and the tangled section had to be cut out and thrown away with the loss of anything recorded on it.

    The wire recorder had a fairly short run and was replaced by the tape recorder in the early 50s. Tape had the advantage of running more slowly, 3 and 3/4 or 7 and 1/2 inches per second so a real did not need to contain nearly as much of it. The tape was 1/4 inch wide which made tangling caused by a malfunction of the machine much less likely. It would take a kid or a cat playing with a real to get the tape in a hopeless tangle.

    Magnetic recording.

    In theory the principle seems simple enough. To record just apply the signal to be recorded to the coil of an electro magnet and pull the media across it at a constant speed. To playback just connect the coil of the electro magnet to the input of a high gain amplifier and pull the media across the iron core at the same speed and in the same direction.

    What you will get will be the biggest mess of distortion you have ever heard. Language will be incomprehensible, Musical instruments unrecognizable, and you won't want to listen to it for very long. The problem is the magnetization curve of almost any metal. Below is the graph showing amount of magnetization versus the magnetizing force.

    Figure 9.16 Hysteresis Curve of Magnetizable Material.

    If the material starts out with zero magnetism and magnetizing force is applied the amount of magnetism will follow the red line up to the hysteresis loop and then it will be stuck on the loop. The only way to get back to zero will be to apply a slowly decreasing AC magnetizing force which will loop back to zero as shown in figure 9.19.

    If magnetizing force is altered from zero and then brought back to zero the remaining magnetism will depend on whether the magnetizing force was positive or negative. If the force goes up the red line to the tip of the curve in the first quadrant and then is reduced to zero the remaining magnetism will follow the right hand side of the curve back down to zero force but there will be some magnetism left. This is desirable but the problem is the nonlinearity of the curve.

    If in each case we start with a piece of fully demagnetized material and take the magnetizing force up from zero to a specific value and then back to zero the remaining magnetism can be plotted on a graph. What results is the graph below.

    Figure 9.17 Transfer Function of a Magnetic Recorder.

    This is the transfer function of our intuitive tape recorder described at the beginning of this section. Some method of linearizing the function is needed. The very first thing tried when magnetic recording was being invented was the use of DC bias.

    If a direct current was superimposed on the audio signal to be recorded and the value of the DC places the magnetizing force at the center of the linear region as indicated by the dashed line recording can take place with a tolerable amount of distortion. I once owned a recorder that used a permanent magnet to erase the tape and DC bias for recording. It wasn't suitable for music but I used it for several years to exchange voice letters with members of my family.

    What got magnetic recording off the ground was the use of AC bias. A frequency of approximately 10 times the highest frequency to be reproduced is added to the audio. Note, the audio does not alter the amplitude of the bias signal as in amplitude modulation. It is simple addition. That electro magnet I mentioned earlier is called the Record/Playback Head. A much oversimplified diagram of it is shown schematically in Figure 9.18.

    Figure 9.18 Magnetic Recorder Erase, Record, or Playback, Head.

    The same AC bias signal is used to energize the erase head to clean the tape before recording. As the tape passes the gap in the head a given magnetic domain will "feel" many cycles of the bias signal. For the first half of the trip across the gap the strength of the field is increasing but for the second half it is decreasing. The figure below shows what happens to a single domain as it passes from the center of the gap to its edge. Figure 9.19 below shows what happens to the magnetization of each domain as the bias field decreases.

    Figure 9.19 Bias Loops for a Magnetic Recorder.

    The remaining magnetization is brought to zero by the bias field leaving the tape free of any magnetized domains. "Blank" for all practical purposes. Next the tape passes over the record head. The Bias field is not as strong as from the erase head. A given magnetic domain will pass the gap in less time than the period of the highest frequency to be recorded. So as far as any one domain is concerned the signal to be recorded is just a DC level.

    If you are no stranger to tape recorders you have probably read that recording takes place at the trailing edge of the gap. I have, but it was never explained. Here is that long overdue explanation. As a single domain passes from the center to the edge of the gap the bias field is decreasing as for the erase head. But the field does not reduce to zero. The value it loops to is the value of the recorded signal at that moment. After the domain passes the gap it is left magnetized to the exact value of magnetism to correctly represent the recorded wave. When the tape is passed over the playback head the wave comes out accurately reproduced instead of being distorted.

    What keeps the recorded signal from going to zero at the trailing edge of the gap is the frequency relative to the width of the gap. The bias frequency is much too high to be recorded because the head gap would have to be much narrower to make that possible. The bias signal makes recording linear without being recorded itself.

    Troubleshooting.

    I don't know how many times people have asked me why their tape recorder doesn't sound as good as when it was new. When I ask them when was the last time they cleaned the heads they reply, "cleaned the heads?" Head cleaning fluid is pretty much a thing of the past. Some people used to recommend carbon tetrachloride but it is too toxic to mess with. Common drugstore alcohol will do but it is half water so be sure to avoid getting it into the works or electronics of the recorder and dry the heads thoroughly after cleaning. When you instruct the owner on how to clean the heads using a Q-tip be sure to emphasize that they are not to run tape through the machine until all liquid has either been wiped up with a dry Q-tip, or has evaporated.

    Other than dirty heads the most common problem with a tape recorder is that it will not erase a recorded tape and when a new or bulk erased tape is tried the recorded sound is weak and badly distorted. Are you ahead of me on this one? The AC bias signal is generated by an oscillator and it is not running.

    Many people record infrequently so the record/playback switch contacts have become corroded. Most times cleaning the contacts of the switch will restore the recorder to operation. This is also true for a recorder that has not been used in any way for several years or decades.

    Because a tape recorder is a mechanical device it can have similar troubles to a record changer. Many have idler wheels that no longer grip. Cleaning of rubber surfaces and tightening springs will usually set things right.

    Old recorders with rubber belts are another story. Some compounds of rubber turn to gue after 20 years. Those that don't, stretch and become too loose to transfer power. In many cases such belts can be replaced with O rings. They are available from auto and industrial supply houses.

    The Silvertone Wire Recorder.

    The Silvertone wire recorder is an especially tough nut to crack. In all that I have seen the idler wheels are made of hard plastic which even if you can get them to drive make so much mechanical noise you can't hear the content of the wire. I presume there was some kind of soft rubber coating them but it must have been very thin because there is little clearance between the wheels and what they drive. It was probably the latest material in the post war 40s and there had not been enough time to life test it before it was used.

    I have no solution for this in spite of giving it considerable thought. If anyone out there has found a successful fix I hope you will share it with me so I can share it with others.

    I will tell you how I fixed mine for all the good it will do you. I knew that Pentron made tape recorders for sears and when I was buying Silvertone wire recorders I saw a Pentron and bought it on the off chance that that might have been true for wire recorders as well. The electronics were quite different but the transport turned out to be identical. Pentron had had the good sense to use time tested and proven rubber rimmed steel idler wheels. The paint job on the Pentron was different from the Silvertone I wanted to restore so I transferred the idler and drive wheels from the Pentron to the Silvertone. So I have a working wire recorder.

    You might be fortunate enough to find phonograph idler wheels that will fit. If that fails I can't give you much hope. I have another rare portable Silvertone I would like to restore but so far I have not found any wheels to replace the plastic ones that were original equipment.

    Back to Fun with Transistors.
    Back to Fun with Tubes."
    Back to Table of Contents.
    Back to top.

    9.9 Why TV Sets Are Not Covered.

    I have little experience with TV sets. The few times in the 60s that I tried to repair a set belonging to my family I failed miserably. It's true I did successfully assemble a Heathkit color TV and get it aligned but building a kit with the quality instructions provided by Heath and repairing a set in which something has gone wrong are two very different kettles of fish. I'm sure there are lots of other resources available on the web. If anyone would like to volunteer to write a chapter on TV repair please submit it to my email address which can be found on the website that linked you to this book.

    Back to Fun with Transistors.
    Back to Fun with Tubes."
    Back to Table of Contents.
    Back to top.


Troubleshooting Chapter Ten.

Chapter 10   Things That Have Never Worked.

10.1  Power Supplies.
10.2  Audio Amplifiers.
10.3  Radio Receivers.
10.4  Simple Test Equipment.

Chapter 10

Things That Have Never Worked.

As a trouble shooter you will occasionally encounter something that has never worked. This may be a prototype constructed in an industrial or university research and development laboratory. It might be a DIY (do it yourself) project that was brought to your shop. It night be a kit that was constructed by someone else or yourself. What ever it is the fact that it has never worked can make the job of troubleshooting much harder than with something that used to work and stopped. The malfunction might be caused by a defective component but it is more likely to be cause by a wiring error or wrong component value.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

10.1 Power Supplies.

Power supplies can range in complexity from simple transformer-rectifier-filter circuits to multi output with electronic voltage and current regulation. If the power supply is one of the latter the regulator circuits should be separated from the basic rectifier filter and the basic circuit tested separately.

Although a simple power supply has little to go wrong, as pointed out earlier in this book failures can cascade turning a simple problem into a more complex one. An electrolytic capacitor may have been taken from NOS (new old stock) and may not be formed up to its rated voltage. Such a capacitor may show good using an ohmmeter but will blow fuses and diodes when the power is turned on. Since the capacitors have never been put into use they should be tested at their rated voltage.

For a brief discussion on the construction of an electrolytic capacitor, how to test it, and its behavior in a circuit, refer back to 3.2 Electrolytic Capacitors.

For a discussion on testing a power supply which may have unformed electrolytic capacitors and how to reform them refer back to 4.3 The Power Supply Section.

If the basic rectifier filter section is working properly The problem is in the electronic regulator circuit. If the unit uses IC regulators there is little to do but replace the one that seems to be causing the trouble. If the unit is blowing fuses it will be necessary to isolate the individual regulator circuits probably by removing the ICs. If the circuit is built with discrete components refer to section 5.2.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

10.2 Audio Amplifiers.

10.2.1 Transistor amplifiers.

Beware of treating the symptom. Many amplifiers I have opened up have revealed a burned or scorched resistor. Replacing this resistor will not fix the amplifier. The replacement will just burn out as the old one did. However, this will point you to the area of trouble.

Transistor audio amplifiers usually just blow fuses. This requires testing with power off. Most DMMs only apply 200 mV or less to the test leads. This may not reveal the problem. A VOM is a much better instrument for this kind of testing. Test from power supply positive to ground, from power supply negative, if the amplifier has one, to ground, and from power supply positive to negative. Be sure the polarity of the leads is such that the proper polarity is applied to the test point, positive to the positive rail and negative to the negative rail. This is likely to reveal that there is a short, which you already knew.

If the amplifier has multiple PC boards you can unsolder the power supply leads to each one in turn and determine which board the trouble is on. If there is only one board isolating the trouble is more difficult. Removing the power transistors from their sockets one channel at a time may, at least, show which channel the problem is in.

Testing Transistors.

Now that you have the power transistors out you might as well test them. A transistor tester is handy but not essential. The most basic test is the junction test. A DMM cannot be used for this test because it does not apply enough voltage to cause the junctions to break down. Set the VOM to measure ohms on the RX1 range and connect it to the collector and base. It should show a diode with the anode to the base in an NPN and the anode to the collector in a PNP transistor. The polarity reversing switch on the Simpson 260 is a real time saver when making this test. The transistor should also show a diode between base and emitter. Anode to base in NPN and anode to emitter in PNP. It should show open in both directions from emitter to collector.

WARNING: APPLYING POWER TO THE AMPLIFIER WHILE THE OUTPUT TRANSISTORS ARE REMOVED MAY DAMAGE THE DRIVER AND PREDRIVER CIRCUITS. THIS IS NOT RECOMMENDED.

A voltage breakdown test might also be a good idea. The schematic will tell you how much voltage is applied to the transistors. If for example the power supply is plus and minus 40 volts then in the static condition 40 volts is applied across each output transistor. Connect an external power supply with a series connected current limiting resistor of 10 k ohms to the collector and base of each transistor one at a time in tern. Positive to the collector of NPN transistors and negative to the collector of PNP transistors. Connect a voltmeter of any type across the 10 k ohm resistor. The meter should not indicate a voltage any grater than a few millivolts. If the reading is more than 1 volt the transistor should be replaced. Note: a reading of 1 or 2 volts might be observed if the transistor is a good germanium.

If the outputs test good.

If the transistors test good the problem may be caused by a transistor or other defective component earlier in the circuit causing the output stage to draw too much current. The high power transistors in the output are usually in sockets which require the removal of two screws to take out each transistor for testing. On the driver and predriver level the transistors will have to be unsoldered from the board. To junction test low power transistors set the VOM to the RX 10 or RX 100 range. When doing the breakdown test use a 100 k ohm resistor instead of a 10 k ohm.

If all transistors test good you need to start looking at the passive components. Shorted capacitors are the most likely suspects. Test electrolytic capacitors at their rated voltage not with the low voltage applied by an ohmmeter. Open resistors are also a possibility. For example an open resistor connected from the positive power supply rail to the collector of a predriver transistor could allow the transistor to go into saturation pulling the amplifier's output to the negative rail resulting in an apparent short.

If the defective component can't be located it may come down to shotgunning.

10.2.2 Vacuum Tube Amplifiers.

The first assumption when a non working vacuum tube amplifier is encountered is to assume a tube is defective. Although failure statistics tell us to check the tubes first in my personal experience with tube radios, TV sets, and instrument amplifiers is that the problem was caused by a passive component as often as it was by a tube. That said, the tubes should be checked first because they are so easy to replace. Even if the tubes are brand new they still should be checked. If they were taken from NOS (new old stock) there is a higher probability one is bad.

Unless you have a high quality vintage tube tester which is in good operating condition the best way to test the tubes is by substitution of tubes that are known to be good. There are two conditions in which this should not be done. One is if the amplifier is blowing fuses and the other is if one or more tubes has a red hot glowing plate. In these two cases the known good tubes may not be good after the test.

If the unit is blowing fuses and it has a rectifier tube, unplug the tube and see if the fuse blowing continues. If it does the most likely defect is a shorted power transformer. There is one thing you should check before condemning the transformer. Check to see if there are any shorts in the heater wiring or bypass capacitors in the heater circuit. Check the capacitors for shorts. If there are no capacitors unplug all the other tubes making sure you know which tubes go where. If there are no numbers imprinted on the chassis and you don't have a layout drawing, make one so you don't get the tubes mixed up. Heater shorts in a tube are rare but possible. If the amplifier still blows fuses the power transformer is the culprit.

If unplugging the rectifier tube prevented fuse blowing then the filter capacitors become the prime suspect. If the amplifier has silicon diodes check the power supply capacitors and diodes. Remember that a shorted diode is likely to be part of the symptom rather than the cause. Check the capacitors at their operating voltage before assuming the diodes are at fault.

Another way of testing the power supply is to unplug all of the tubes and use the dim bulb test. Remember you can't possibly burn out a 120 volt bulb by applying 120 volt line voltage to it. Start with a low wattage bulb and move to higher wattages. For full details on the dim bulb test refer to 9.1 Steps to First Power on.

If the fuse doesn't blow immediately after the power switch is turned on but the plate of one or both of the output tubes begins to glow red hot and then the fuse blows the outputs are drawing far too much current. In the case of a new design or kit oscillation is a good possibility. This may be taking place at a frequency above human hearing and will only be detectable with an oscilloscope. The primary leads of the output transformer may have been reversed turning negative feedback into positive feedback. Be certain there are no oscillations going on before proceeding.

Capacitors are the next suspect. If the amplifier uses cathode bias a shorted or reversed cathode bypass capacitor may be at fault. If fixed bias is used there may be a shorted or reversed capacitor in the bias rectifier/filter circuit which is preventing any negative bias from being applied. Shorted or even leaky coupling capacitors from the plates of the driver tubes to the control grids of the outputs could be applying a positive voltage to the grids causing too much current to flow. If the screen grid voltage is electronically regulated the regulator may be defective allowing too much voltage on the screen grids. This can cause too much plate current to flow.

If fuses are not being blown but the sound is week and distorted coupling capacitors earlier in the circuit are suspect. Plate load resistors which may be defective or the wrong value can also cause this symptom.

If static testing does not reveal the problem it may be necessary to disconnect the negative feedback and use signal injection or signal tracing in conjunction with signal substitution techniques to localize the defect. Be cautious when negative feedback is disconnected. The overall gain of the amplifier will be 10 times or more greater than it was with the feedback connected. Oscillation is a possibility under these conditions. Keep input and output leads separated as much as possible and by all means use shielded cables between the oscillator and input of the amplifier. Set the volume control on the amplifier very low so the oscillator can be operated at a higher level.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

10.3 Radio Receivers.

A communications or even a simple AM broadcast radio that has never worked can be a difficult problem. There are all those tuned circuits that have never been adjusted because the receiver doesn't work.

The first step is to half split at the detector. In most receivers the volume control is just after the detector. This is usually true even in short wave or ham receivers. Inject an audio signal at the top of the volume control and if you hear it the trouble is in the RF or IF circuits. If you don't hear the signal then the problem has been reduced to a simple audio amplifier problem and should be easy to solve. Once you have the audio working chances are you can align the IF and RF stages.

To troubleshoot and align the pre detector section an RF signal generator is an absolute must. It might be possible to trouble shoot without one but we are talking about a receiver that has never worked and has not been aligned.

Some service shop RF signal generators such as those made by Heath and Eico included DC blocking capacitors in the output. Higher end generators do not have a blocking capacitor and one should be added on the outside when making the following tests. Use a coaxial cable with the appropriate connector on one end and clip leads on the other. If you don't have one, make one. Clip the ground lead to the chassis* and clip one lead of a 0.001 microfarad capacitor in the hot lead clip. Use the other capacitor lead as a probe to make the tests.

* If the receiver being worked on is line operated and has no power transformer, the chassis is connected to one side of the power line. These radios, commonly known as All American Fives, should only be worked on while powered from an isolation transformer. Question. How did you get hold of an AA5 that has never worked?

Tune the generator to the frequency of the IF and turn on the modulation. Turn the generator's output up full or to 1 volt if it goes higher than that. Touch the test lead to the collector or plate of the last IF amplifier stage. You should hear a tone in the speaker. If not, find out why because you should.

If you heard a tone move the probe to the base or grid of the same amplifier stage. The tone should get much louder. Reduce the output of the generator and tune the adjustment or adjustments in the last IF transformer for maximum signal.

If the receiver is a simple tube type AM broadcast radio it most likely has only one IF amplifier stage. If a transistor AM radio it will have two IF stages. If it is a sophisticated communications receiver it will have several IF amplifiers and will likely be a double or triple conversion receiver. Work your way back through the amplifiers following the same procedure. Only align the transformer in the output of the amplifying device while the generator is connected to the input of the device. When you come to a mixer connect the probe to the plate or collector to see if you are getting a signal through all stages between there and the speaker.

Next check to see if the oscillator signal is present. If not, find the problem and fix it. If so tune the signal generator to the frequency of the preceding IF or if the receiver is single conversion to the received band. Tune the generator around until you hear it in the speaker. If this is a multi conversion receiver and the IF is off frequency adjust the oscillator frequency until it is correct. A transistor receiver may have amplifying stages between the two mixers. A tube receiver most likely will not.

As you work your way back through the receiver stages you will be aligning the tuned circuits and upon arriving at the antenna you may find the receiver is working properly. The alignment may need a little touching up.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

10.4 Simple Test Equipment.

There is a problem with test equipment. To test and repair a VOM, you need a working VOM. To test and repair an oscilloscope, you need a working oscilloscope etc etc. Since the heading is simple test equipment we will not try to repair oscilloscopes and let's not even think about digital multimeters.

If the problem is a VOM the first question is, "Is it completely dead or works on some ranges but not on others?" If the answer is completely dead the chances are the meter movement is defective. Unless you have the skills of a jeweler or watch maker repairing the meter movement is beyond consideration.

If it works on all voltage and current ranges but not the resistance ranges, check to see that batteries have been installed.

If it works on some ranges but not on others the probabilities point toward a wiring error or miss placed resistor. Since this device has never worked the chances that you will see a cooked resistor are small.

If the device is a VTVM or SSVM and it is completely dead check to be sure the amplifier is getting voltage from its power supply. Such meters have a rather complicated switching circuit between the amplifier and meter movement to allow for measuring negative voltages. Make sure this switch is wired correctly. If the meter will not come into calibration on any of its ranges check the amplifier for proper wiring and component values. If it works on DC but not on AC check the AC to DC converter (rectifier) for proper wiring and component values.

For simple things such as an RF probe the RF probe for the Signal Tracer described in section 2.7 if one of the diodes were to be installed backward there would be no output. For a wave meter, not described in this text, if the meter moves backward either reverse the diode or the connections to the meter movement.


MaxCAD Manual Introduction.

MaxCAD
INSTRUCTION MANUAL.

MaxCAD is a simple yet powerful drawing program primarily designed for drawing electronic schematic diagrams. However there is nothing inherent in the program to limit it to this application. It can be used for chassis layouts, room floor plans, and woodwork designs. It is limited to 2 dimensions but 3 dimensional objects can be represented using conventional drafting techniques once used to draw 3 dimensional objects on paper.

It is quite stable, at least on my computer and pretty much bug free. I use the program every day and if an added enhancement introduces a bug I find it quickly and fix it as quickly. If Bill Gates had used Windows 95 every day I doubt it would have taken this long to work the bugs out of the Windows operating system.

Overview.

MaxCAD will draw lines, circles, and arcs. Any geometric figure can be drawn or closely approximated with these three elements. If that's all MaxCAD did it would be of limited usefulness. It's power comes from its use of font files and shape files. Shape and font files are saved in exactly the same format as any other drawing file with the .dwg extension. Shape and font files are distinguished from other drawing files by residing in a folder where other drawing files are NOT stored and by a file name that begins with a specific 2 character combination.

Drawings may be sent to any windows printer. They can also be converted to HPGL (Hewlett Packard graphics language) format and written to a file. There are graphic programs from Corel and others which will convert HPGL to .GIF, .JPG, or .BMP formats.

Opening and saving files works the same as any other windows program. For that reason we will begin with drawing and worry about how to save files later.


MaxCAD Manual Chapter 1.

Chapter 1   Downloading and Installation.

1.1  Getting Started.
1.2  Downloading.
1.3  Installation.
1.4  Installing the shape and font files.
1.5  Desktop Icon.

Chapter 1

Downloading and Installation.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

1.1 Getting Started.

This program was compiled under Windows 98 but you can successfully install it in any version of Windows, as far as I know, up to and including Windows XP. Vista has not been heard from as yet. You must be careful NOT to let the installer replace files on your computer with OLDER files. The installer will give you a choice so always say keep the newer files. Install will proceed even if you give this answer.

If you are installing in Windows 98 and you have an especially old version the installer will ask to update some "out of date" files. In this case, and only this case, is it alright to let it replace the files.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

1.2 Downloading.

  1. Select MaxCAD from the list near the bottom of the programs page and single click the link. Your operating system may give you a paranoiac warning about viruses. I assure you there is no intentionally malicious code in this program. You can click the OK button without fear.

  2. The next box you get will give you the choice of "open" or "save". Select "save". Next your system will ask you where you want to save it. On my computer I dump all downloaded files into a folder I have named "My Downloads". Put it wherever you want but remember where you put it. The file will come with its own name but you can change it if you want to. If you do, remember what you called it. As downloaded it has the name "MaxCAD-98.exe".

  3. In this dialog box press Save. The download box will open. If the "Close this dialog box when download completes" check box is not checked, I recommend you check it.

  4. When the box closes you may close your web browser.

Now you are ready to install the program.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

1.3 Installation.

  1. Before you extract the zipped files you need to create a new folder to extract them to. This folder may be deleted after the installation is finished. I suggest naming it "AA" so it will be easy to find.

  2. Open Windows Explorer and find the file you just downloaded. Double click on it in the right hand pain.

  3. A box with the title "Extract Archive Files" will open. There is nothing you can change in this box so click "Next".

  4. A box with the title "Destination Directory" will open. Type "C:\AA" in the text box and click "Next".

  5. The next dialog will say "Extraction Complete". Click "Finish".

  6. Now select the folder "AA" in the left pain and double click on "setup.exe" in the right hand pain. You will get another warning from the paranoid boys. Click "Run".

  7. You will get a standard installation box about closing other programs. Click "OK".

  8. If you get a message about replacing files on your system, your answer depends on what operating system you are using. If Windows 98 it's alright to replace files.

  9. If you use something later than 98 replacing files could damage your system. So don't do it. No matter if the files are older or newer, DON'T REPLACE THEM.

  10. The next box tells you where the program is going to be installed. You can change it to anything you want although I recommend you stick to the standard windows path. To move on click the icon in the upper left corner of the box.

  11. Next is "choose program group" box. This is where MaxCAD appears in the Windows start menu. Click "continue" and don't worry about it unless you need to for some reason.

  12. The next message is that one that brings a big smile to your face, and mine too. "MaxCAD Setup was completed successfully". Click "OK".

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

1.4 Installing the shape and font files.

Do not run the program yet.

The download includes over 500 shape and font files. You are likely to find many of them useful in your application.

Selection of the folder into which you place the shape and font files is very important. They MUST NOT be dumped into a generic folder where other drawing files will also reside. Detection of shape and font files by the program depends on them being in a folder where no other files with the dwg extension will ever be placed. One possibility is in the same folder with the MaxCAD.exe file. The other possibility is in a folder named Shapes and Fonts.

  1. Decide if you want to put them in the same folder with the MaxCAD.exe file or in a separate folder named Shapes and Fonts.

    If the latter, I suggest you create a subfolder of "My Documents", a folder which is universally present on Windows computers, and name it "MaxCAD Drawings". Then create a subfolder of "MaxCAD Drawings" named "Shapes and Fonts".

  2. Open Windows Explorer and navigate to the folder where you installed MaxCAD. Find the file named MaxCAD_Shapes_and_Fonts.exe. Double click on it in the right hand pain.

  3. A box with the title "Extract Archive Files" will open. There is nothing you can change in this box so click "Next". That's right. This was a self extracting zip file within a self extracting zip file.

  4. A box with the title "Destination Directory" will open. In the text box type the path to where you installed MaxCAD, or the path to your shapes and fonts folder, and click "Next". If you didn't change it during the installation the path to the location of the MaxCAD.exe file will be "C:\Program Files\MaxCAD".

  5. The next dialog will say "Extraction Complete". Click "Finish".

  6. Now run the program. You may get an error message that says "Invalid Path to Shape Files. Go to Default Settings under Settings menu to correct the Path."

  7. Go to the "Settings" menu and select "Default Settings".

  8. Locate the "Shape and Fonts Path", about half way down the right hand column. If you put the shapes and fonts in the same folder with the MaxCAD.exe file, delete anything which is in the text box and leave it completely blank. If you placed the files somewhere else, type in the complete path to where you placed the shape and font files. Click the "Save Changes" button.

MaxCAD is now installed and ready to use.

Now go back and delete the folder AA. You may also want to delete the file MaxCAD_Shapes_and_Fonts.exe which is in the folder where you installed MaxCAD. If you ever need it again you may download it from Fun with Tubes.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

1.5 Desktop Icon.

I don't know about you but I prefer to start my most often used programs from a desktop icon. If you don't, skip the rest of this section.

If, on the other hand, you do want a desktop icon, here is how to make one.

1.5.1 Method 1.

  1. Click the start button and go through the maze until you get to the program you want.

  2. With the pointer on the program press and hold the RIGHT mouse button.

  3. While continuing to hold the right button drag (move the mouse) off of the menu into a blank part of the desktop.

  4. Release the button. A context menu will pop up. Select "Copy here".

  5. The icon will appear but it may not be exactly where you want it. Use the left mouse button to drag it to the desired location.

1.5.2 Method 2.

  1. Right click in a blank part of the desktop. A menu will pop up. Select "New" and then "Shortcut" from the submenu.
    The shortcut wizard will start.

  2. Press the "Browse" button and navigate to the folder where you installed MaxCAD.

  3. Select the "MaxCAD.exe" file and then click "OK". Then click "Next".

  4. This box contains the name you will see on the desktop. You don't have to use the name "MaxCAD.exe". Make it what ever suits your fancy.

  5. Then click finish.


MaxCAD Manual Chapter 2.

Chapter 2   Drawing Objects, the Draw Menu.

2.1  The First Time.
2.2  A Word About Hot Keys.
2.3  Drawing lines.
2.4  Drawing a line with an "oops" in it.
2.5  Drawing a Closed Figure.
2.6  If you left click the end of the line by mistake.
2.7  Typing Coordinates, Closed Figure.
2.8  Typing Coordinates, Open Figure.
2.9  Intermixing Mouse Clicks and Typed Coordinates.
2.10 Drawing a Circle, Clicking Radius.
2.11 Drawing a Circle, Typing Diameter.
2.12 Drawing Arcs.
2.13 Inserting Text.
2.14 Shapes.
2.15 Dial and Meter Scale Designer.
2.16 Dimensions.
2.17 Polar Array.
2.18 Rectangular Array.

Chapter 2

Drawing Objects, the Draw Menu.

It is strongly suggested that you have MaxCAD running at the same time you are viewing this instruction manual. To do so, follow these instructions.

  1. Press Windows key and M to minimize this program.

  2. Start MaxCAD by what ever means you prefer.

  3. Press Alt-TAB to switch between this manual and MaxCAD.

Now you can see the MaxCAD drawing board or try something as soon as you read about it.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

2.1 The First Time.

Start MaxCAD. You will see a mostly black screen with green dots on it. This is the drawing board. Standard looking windows bars are at the top and bottom of the screen.

Objects drawn on the screen will appear in the default color of white. The green dots are the grid markers and the default setting is 0.4 inches. The dot at the origin, X=0 and Y=0, is magenta.

At the top of the drawing board, near the center, you will see "Zoom 100%". This will be followed by two numbers separated by a comma. These numbers are the X and Y coordinates of the cursor and will change as you move the mouse. Following the coordinates you will see "Snap (Both)". Other status information and prompts will appear at the top of the drawing board depending on the operation which has been invoked.

The title bar at the top of the screen contains a great deal of useful information. Starting at the left is "MaxCAD:". To the right is "C:\...\My Documents\MaxCAD\????\*.dwg". The "????" and "*" indicate that what appears here depends on what file you have loaded and how your computer is configured. The "\...\" indicates that what is in this part of the path is complex and always the same. It is just a waste of space to repeat it each time. If your My Documents folder is in the root folder of drive C or some other drive the "\...\" will not appear. If a file has not been loaded and the drawing you are working on has not been saved for the first time this space will say "No File".

To the right of that you will see ". Where xx is the two character prefix of the currently selected font and yy is the two character prefix of the currently selected shape library. As shipped this part of the title bar will read " ".

Moving on to the right you will see "Draw Color = White Line Type = Solid". These will change as you change the draw color and/or line type.

The mouse cursor will appear as a small solid cross with a larger dotted cross behind it. You will notice that small movements of the mouse will make small movements of the solid cross but the dotted one will not move at first and then will jump to another position. This is known as snap. The default setting is 0.1 inch. The default values of grid and snap can be changed in the default dialog. The current values can also be changed from the drawing board as often as you like. Snap is extremely useful to ensure that parallel lines are indeed parallel, etc.

Snap can be turned off, applied to only X or Y, or different values of snap may be set on X and Y.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

2.2 A Word About Hot Keys.

It seems to be a little known fact that hot keys are available in most all Windows applications and in Windows itself. Any command or function that can be invoked from a menu can also be invoked by a hot key combination.

I cut my teeth on HDOS and CP/M and grew up on MSDOS. When Windows first appeared I would tell people "I don't do windows." But as the popularity of the Windows operating system grew and applications appeared which would not run in MSDOS I was forced into submission.

I have never liked accessing menus with the mouse. I feel it slows me down. I can hit a hot key combination 3 times while someone else wanders through the menus and sub menus looking for the command they want. Consequently I have given much thought, devoted much effort, and written many lines of code to make hot keys available. If you prefer the menu maze you don't have to use hot keys.

The hot keys are organized in a way which is logical to me and I hope you will also find logical. Certain key combinations have become standard in Windows applications. These have been adhered to in this program. The files and edit menus use letter keys modified by the control key. All of these follow the Windows standard such as control S for save and control C for copy to clipboard. The View menu uses unmodified function keys except for one which uses a control letter. The Draw menu uses unmodified letter keys. In this manual and the help screens these letters are given as capital letters but if you hold the shift key that will make it a different command. When told to type a letter just type without holding any other key. Five of the draw commands use a two character combination. Do not hold one while typing the other. Type one and follow it with the other. The Settings menu is somewhat of a mixed bag. As in most Windows applications pressing F1 will open the help window. The list of hot keys will be shown. Control F1 will open a screen describing how to use the help menu and screens. These will be described in later chapters.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

2.3 Drawing lines.

  1. Select "Line" from the "Draw" Menu or type L. Do not hold the shift key, just type the letter L. Upper case has been used for clarity. Starting at the upper left corner of the drawing board you will see "Line: Left click point(s) . Right click end. U undo, C close." Followed by a blue text box. Below the text box are the words "TAB to enter". The box may or may not cover the word "Zoom".

  2. Left click a point on the drawing board and move the mouse cursor away from it. A dotted line called the rubber band will stretch between the point you clicked and the current position of the mouse pointer. A new line of text will appear below the X,Y coordinates which says "R = mmm Theta = nnn" where mmm is the length of the rubber band and nnn is the angle it makes with the horizontal. Move the mouse around and note how the numbers change.

  3. Click another point. The rubber band will change to a solid line and as you move the mouse again another rubber band will stretch out. Click a few more points to amuse yourself.

  4. Right click a point to end the line. Draw mode will be terminated.

Congratulations. You have just drawn your first line with MaxCAD.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

2.4 Drawing a line with an "oops" in it.

  1. Click the wheel of your mouse. This will always recall the last draw command.

  2. Click the start point of a new line.

  3. Click a couple of points.

  4. Type the letter U, upper case or lower case, and press the TAB key. You will see that the last line segment you drew will disappear and the rubber band will now stretch from the previous point to the mouse cursor.

  5. Right click a point to end the line and terminate draw mode.

You can use this to correct mistakes in mid line without doing the entire line over again.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

2.5 Drawing a Closed Figure.

  1. Start another line.

  2. Make it a square, a rectangle, a triangle, or something irregular that strikes your fancy.

  3. Stop just before the last click that would close the figure.

  4. You can place the cursor over the start point and right click but instead try this. Type the letter C and press the TAB key.

A line segment will be drawn from the last point you clicked to the first point closing the figure. Line draw mode will be terminated.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

2.6 If you left click the end of the line by mistake.

  1. Start another line.

  2. Click 3 points and tell your self that the third one was supposed to be the end of the line. "Oops? I forgot to right click the end of the line." Don't panic. There are two possible solutions.

  3. Type an E and press TAB. The line will be ended at the last point and draw mode will be terminated.

  4. Position the cursor over the desired point and right click. Draw mode will be terminated. As long as snap is in "Both" this is easy to do accurately. If snap mode is off in either dimension, method 3 should be used.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

2.7 Typing Coordinates, Closed Figure.

I imagine your drawing board is getting a little cluttered by now so select "New" from the files menu or type Control N. You will be asked if you want to save the file. There are two reasons not to. 1) you don't know how to do that yet. 2) what you have drawn is just random trash and has no value.

  1. Type L.

  2. Instead of clicking with the mouse, type "0,0" without the quotes. As you type the characters will appear in the blue text box at the top of the drawing board.

  3. Press the TAB key.

  4. Type "1,0" no quotes and press TAB.

  5. Type "1,1" no quotes and press TAB.

  6. Type "0,1" no quotes and press TAB.

  7. Type "C" no quotes and press TAB.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

2.8 Typing Coordinates, Open Figure.

  1. Type L.

  2. Instead of clicking with the mouse, type "0,-1" without the quotes. As you type the characters will appear in the blue text box at the top of the drawing board.

  3. Press the TAB key.

  4. Type "2,-1" no quotes and press TAB.

  5. Type "2,2" no quotes and press TAB.

  6. Type "0,2" no quotes and press TAB.

  7. Type "E" no quotes and press TAB.

Typing E will end the line at anytime without right clicking. There wasn't enough room to include it in the prompt.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

2.9 Intermixing Mouse Clicks and Typed Coordinates.

  1. Type L.

  2. Type "-1,-3" and press TAB.

  3. Using the mouse left click at the point 3,-3.

  4. Type "3,3" and press TAB.

  5. Right Click the point -1,3.

You can intermix mouse clicks and typed coordinates in any order and combination.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

2.10 Drawing a Circle, Clicking Radius.

There are only two parameters that completely define a circle. They are, 1) Coordinates of the center point, and 2) Radius.

The left hand portion of the drawing board should still be empty.

  1. Select "Circle" from the "Draw" menu or type C. Do not hold the shift key, just type the letter C. Upper case has been used for clarity.

  2. Left Click a point with the mouse. The Circle prompt will appear at the top of the drawing board.

  3. Move the mouse away from the point. You will see a dotted circle that shows where the circle will be drawn.

  4. Right click to turn the dotted circle solid. The draw circle mode will be terminated.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

2.11 Drawing a Circle, Typing Diameter.

  1. Click the mouse wheel to recall the circle draw command.

  2. Click the center point.

  3. Type a 2 and press TAB. Draw circle mode will be terminated.

A circle with a radius of 1 inch, 2 inches diameter, will appear on the drawing board.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

2.12 Drawing Arcs.

An Arc is part of a circle. It is one of the most powerful and useful elements in the draftsman's toolbox. There are 4 basic parameters to describe an arc. They are, 1) Center point, 2) Radius, 3) Angle at which it starts, and 4) Total included angle.

In this program there are 3 different ways of drawing an arc. They differ in the order in which the parameters are entered. The first of the three ways is, 1) Center point, 2) Start point, this gives the radius and starting angle simultaneously, and 3) Ending angle, the angle spanned by the arc is found, by the program, by subtraction. The second way is, 1) Start point, 2) Center point, and 3) ending angle. The third way is 1) Start point, 2) End point, and 3) Center point. Each one of these is best suited to a particular situation. While there may be conditions under which two of the methods are equally applicable, the preferences of the user may lean toward one or the other. The program provides all three for maximum user comfort.

2.12.1 First Method, Center, Start, Angle.

  1. Select "Arc" from the "Draw" menu and "Center Point, Start Point, Angle" from the "Arc" submenu. Or type A1. That's the letter A followed by 1. A reminder prompt will appear after you type the A. Do not hold the shift key, just type the proper character(s). Upper case has been used for clarity. Now I'll bet you see why.

  2. Left Click a center point.

  3. Move the mouse away and you will see a dotted circle.

  4. Decide on a starting point and left click it.

  5. As you move the mouse away from this point you will see lines defining an angle. Note that the radius does not change as you move the mouse, It was locked in by the second click.

  6. Decide on an angle and right click it.

2.12.1.1 Limitations on the angle.

  1. Start another arc and when you get to step 6 go around more than 180 degrees. Right click the point.

  2. Note that this arc went the short way around. Detecting which direction and angle the user moved the mouse would take many lines of code and considerably slow down the program in this critical operation. Just remember, MaxCAD can't read your mind. Be thankful for that.

The maximum angle an arc can span is 180 degrees. If you choose an angle of exactly 180 degrees it may not go in the direction you want it to. Longer arcs must be made up of 2 arcs each approximately ½ of the total angle.

This limitation is caused by an unwise decision made early in the development process. I elected to store the arc parameters as starting angle and ending angle. If I had instead chosen to store them as starting angle and angle spanned, this problem could be overcome by entering the angle from the keyboard.

2.12.2 Second Method, Start, Center, Angle.

  1. Select "Arc" from the "Draw" menu and "Start Point, Center Point, Angle" from the "Arc" submenu. Or type A2. Do not hold the shift key, just type the proper character(s). Upper case has been used for clarity.

  2. Left Click a start point.

  3. Move the mouse away and you will see a dotted circle. Except now the mouse cursor is at the center of the circle and the circle not only grows and shrinks but moves as you move the mouse.

  4. Decide on a center point and left click it.

  5. As you move the mouse away from this point you will see lines defining an angle. Note that the radius does not change as you move the mouse, It was locked in by the second click.

  6. Decide on an angle and right click it.

2.12.3 Third Method, Start, End, Center.

  1. Select "Arc" from the "Draw" menu and "Start Point, End Point, Center Point" from the "Arc" submenu. Or type A3. Do not hold the shift key, just type the proper character(s). Upper case has been used for clarity.

  2. Left Click a start point.

  3. Move the mouse away and you will see a dotted line known as the rubber band.

  4. Decide on an end point and left click it. A copy of the dotted cursor will appear at the start point.

  5. As you move the mouse away from this point you will see a copy of the dotted cursor at the end point. You will also see a dotted circle. The solid cursor and dotted cursor will separate. You have set two points on the circumference of the circle and the center MUST be equidistant from both points. The dotted cursor indicates where the center will be placed.

  6. Move the center around until the arc has the curvature you want then right click.

This last method is perfect when an arc must be used to make a transition between two straight line segments.

2.12.4 First Method Typing Parameters.

As with the line draw command you can type in the values of Radius, Starting Angle, and Angle Spanned.

  1. Select the first method, "Arc" "Center Point, Start Point, Angle" from the menu or type A1.

  2. Click the center point.

  3. Observe the prompt carefully. It says "Arc: Left click START point or type radius, angle".

  4. Type a radius and starting angle separated by a comma. For example "2,45" without the quotes and press TAB.

  5. The screen prompt will change to "Arc: Enter angle SPANNED.". You could click the angle but you have no reference to see the angle. Instead type an angle such as 135 degrees and press TAB.

This may come in handy if you know the radius and angles and want to be sure they are exact.

2.12.5 Second Method Typing Angle.

In the second method, "Start Point, Center Point, Angle", the only thing you can type in is the angle spanned. Test yourself by doing this without any further guidance from this text.

Parameters for the third method can be entered only by using the mouse.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

2.13 Inserting Text.

When text is entered, the mouse click will place the text in four different positions. They are; middle, center, start, and end. These will be illustrated by example below.

Type Control N and answer No to the save question.

2.13.1 The middle of text.

  1. Select "Text" from the "Draw" menu or type T. Do not hold the shift key, just type the proper character(s). Upper case has been used for clarity.

  2. You will be prompted "Text: Click location". Find the X=0 line by locating the magenta dot. Any point directly above or below this dot is X=0. Click on this line and exactly on a green dot near the top of the screen.

  3. Press TAB to except the default setting of M which the prompt tells you is for middle.

  4. Press TAB again to except the angle of 0.

  5. Type something in the text entry box. It could be your name or something about quick brown foxes or anything else you want. After you finish typing press TAB.

2.13.2 The center of text.

  1. Click the mouse wheel to recall the text command.

  2. You will be prompted "Text: Click location". Click on the X=0 line exactly on a green dot just below the one you used for the previous example.

  3. Type C in the small box and press TAB.

  4. Press TAB again to except the angle of 0.

  5. Type the same thing as before in the text entry box.

Note that the first line of text is split vertically by the row of green dots while the second line is sitting on top of the row of dots.

2.13.3 The start of text.

  1. Click the mouse wheel to recall the text command.

  2. You will be prompted "Text: Click location". Click on the X=0 line exactly on a green dot just below the one you used for the previous example.

  3. Type an S in the small box and press TAB.

  4. Press TAB again to except the angle of 0.

  5. Type the same thing as before in the text entry box.

Note that the text starts on the dot where you clicked.

2.13.4 The end of text.

  1. Click the mouse wheel to recall the text command.

  2. You will be prompted "Text: Click location". Click on the X=0 line exactly on a green dot just below the one you used for the previous example.

  3. Type an E in the small box and press TAB.

  4. Press TAB again to except the angle of 0.

  5. Type the same thing as before in the text entry box.

Now you see that the text ends where you clicked.

2.13.5 Text at other angles.

  1. Click the mouse wheel to recall the text command.

  2. You will be prompted "Text: Click location". Click on the X=0 line exactly on a green dot a couple of dots below the one you used for the previous example.

  3. Press TAB.

  4. Type an angle such as 45 or 30 in the box and press TAB.

  5. Type the same thing as before in the text entry box.

Experiment with several angles. Negative values will tilt the text in the other direction.

2.13.6 Superscripts and Subscripts.

Superscripts and subscript s are accomplished through the use of operator characters. They are characters which instead of printing, make the text following them behave in a certain way. The [ moves the following text down 1/2 line while the ] character moves the text up 1/2 line.

  1. Click the mouse wheel to recall the text command and click in an empty part of the drawing board.

  2. Press TAB twice to select the defaults of Middle and 0 degrees angle.

  3. Type R[1] = 47 } and press TAB.

  4. Click the mouse wheel again and click in another blank area of the drawing board. Then press TAB twice.

  5. Type X]2[ = 25 and press TAB.

If the subscript or superscript is the last character on the line the second bracket is not necessary, as in the example R[2] has the same value as R[1. The text object has no memory of the cursor position in the one that went before.

2.13.7 Text Height.

  1. Select "Text Height" from the "Settings" menu or press Control F5.

  2. Type .2 in the blue box at the top of the drawing board and press TAB.

  3. Invoke the text command and type "Something, anything…" in the text box.

Note that the text is much bigger while the size of the earlier text has not changed. The size of each text object is stored with it so you can change it at any time and as often as you want.

2.13.8 Special Characters.

You have already seen that the [ and ] characters have been given up to make superscripts and subscripts. If they should be needed they could be made with the line command. Seven other little used characters have been sacrificed to make some symbols and Greek letters. A list follows.

Character Character
Name 		Symbol
Name
_ Underline theta
^ Caret degree
symbol
~ Tilde pi
` Grave(ah) beta
{ Left brace mu
| Vertical bar Capital Delta.
} Right brace Capital Omega

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

2.14 Shapes.

Before the Shape command can be used there must be one or more Shape Libraries on your computer. If you installed MaxCAD as instructed you have several that were supplied with the program. The default has been set to the electronics schematic symbols which are also the most numerous. The prefix for this set of shapes is "Sc" which means that all the file names begin with this two letter combination.

2.14.1 Inserting a Shape.

  1. Type Control N and click 'No" to the "Save file" question.

  2. Select "Shape" from the "Draw" menu or type S. Do not hold the shift key, just type the proper character(s). Upper case has been used for clarity.

  3. Look in the upper left corner of the list and click on "BJT Amp".

  4. The list will disappear and you will be back on the drawing board. Place the mouse somewhere and left click. A constant voltage biased amplifier will appear.

  5. Move the mouse somewhere else and left click again. The shape will disappear from its original location and reappear where you clicked.

  6. Place the mouse at about the center of the drawing board and right click.

  7. Move the mouse away from where you clicked and you will see a rubber band. Stretch out the rubber band at any angle other than zero and left clicked.

  8. Move the mouse around the center point and left click at several different angles.

  9. Set the rubber band's angle at zero, or another angle if you are a nonconformist, and right click.

  10. We will do flipping under the next heading. Right click again, it doesn't matter where, or press TAB. This terminates the draw shape command.

I hope you have notice by now that a right click is a lock-in or finish command. As the text that is part of the shape indicates this is a shape made up of other shapes.

Repeat the steps above except after the first right click type an angle instead of clicking the mouse. Press TAB and then TAB again to finish.

2.14.2 Flipping a shape.

You need to flip, or mirror image, a shape for some types of circuits. Here's an example.

  1. Type Control N and answer No.

  2. Type S.

  3. Click on BJT NPN.

  4. Right click somewhere generally to the upper right of center. Right click twice more but not too fast. How fast you can click depends on the speed of your computer and how much of its resources are being used by other programs.

  5. Type S again and this time select BJT PNP.

  6. Set your mouse 0.8 inches below the center line of the other transistor symbol and even with the left edge. That is 0.8 inches below the base lead of the other transistor.

  7. Right click only twice.

  8. Type a V in the box in answer to the prompt "Shape: Flip; H = horizontal, V = Vertical, N = none."

You now have a complementary push-pull pair of transistors on the drawing board. Try to duplicate the drawing below. For the non-technically inclined, the larger triangular object is an "Op Amp", the squiggly lines are known by the name "Resistor", the dots are "Tie Dot", the +12 V is "12 v Positive", the -12 V is "12 v Negative", and the smaller triangular object is "Ground Common". Use lines to connect things together and place a boarder around the entire circuit.

When inserting shapes that contain other shapes, or text, using Flip and an angle of other than zero together, is not advised. The letters in the flip-flops were drawn not inserted. The test instrument shapes do contain text and sum contain other shapes. However there should never be a situation where they need to be either flipped or rotated. All of the other supplied shapes contain only lines, circles, and arcs.

If you make a shape that has a hidden, dashed, line in it the line will appear dashed in the drawing into which the shape is inserted. The dash and gap length will be set in the drawing not within the shape.

As things are currently set up any shape inserted into a drawing will have the current draw color. The entire shape will be that color and parts of it may not be changed. With shapes it's either all or nothing.

The other choice would have been for the shape to carry its colors into the drawing and they could not have been changed. That would have permitted different parts of the shape to be in different colors but it would be impossible to change the colors of the shape.

Figure 2.1 Drawing made with shapes and lines.

2.14.3 Making Shape Files.

To make a new shape simply type control N to start a new drawing and draw what you want. Pay particular attention to the location of the 0,0 point. This is the location point of the shape. When you click to place the shape, the point 0,0 will be under the mouse cursor. Save the drawing in the "Shapes and Fonts" folder or the equivalent folder on your computer.

2.14.4 Naming Shape Files.

If you want to add a shape to one of the existing shape libraries you must begin the file name with the two character combination for that shape library. For example if you want to add something to the chassis layout library you must begin the file name with the letters "CL". The case must also be correct or the shape may not be recognized. The rest of the name should be the common language name of the shape. For example if you wish to add a 100 watt resistor to the Chassis Layout library the name should be "CLResistor, 100 W.dwg".

In addition if you wish to add a symbol to the Schematic library there is a second level prefix to be included. After the prefix of Sc there are two more characters which place the symbol into its proper category. These are as follows.

  • A- Analog, devices such as transistors and op amps.
  • B- Blocks, things such as DIP ICs and voltage regulators which consist of rectangles with no internal detail and terminal connections to the out side.
  • D- Diodes.
  • G- General, passive components and connection points such as jacks, plugs, power supply connections, and grounds.
  • L- Logic, gates and flip-flops.
  • M- Mathematics symbols, such as integrals and radicals.
  • R- Electrical sources, such as batteries and current sources.
  • S- Relays and switches.
  • T- Transducers, such as LEDs, meters, and speakers.
  • U- Transformers.
  • V- Vacuum tubes.
  • W- Wave forms, such as the output of a full wave rectifier.

When you call up the shape list by typing S the prefixes are not displayed and neither is the file extension. Only the name you have given it will show.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

2.15 Dial and Meter Scale Designer.

The Dial and Meter Scale designer took many lines of code and many hours of pounding the keys. It has been well worth it. I have used it to dress up a number of projects described on this site.

Figure 2.2 Identification of Parts of a Scale Object.

This feature can be used to make a linear meter scale, a linear dial scale for a variable capacitor, or a linear dial scale for a potentiometer. See Chapter 9 for the procedure used to make a nonlinear scale.

You may invoke the Dial and Meter Scale designer by typing Control D or selecting Dial & Meter Scale Designer from the Draw menu. When you do so the previous design is loaded from a file. This permits multiple scales to be designed without the need to enter the same data over and over.

There are 13 numerical parameters to be entered, 2 radio buttons, one check box, and two more numeric entries that effect only the design window. These will be described one at a time below. (I don't think it would be possible to describe all of them at once.)

  1. Scale Radius. This is the distance from the center of the arc to its perimeter as shown in the figure above. If the numbers are on the inside of the arc the distance is still to the perimeter.

  2. Total Angle. As indicated in the figure this is the angle from one end of the scale arc to the other. In the case of a meter it is approximately 90 degrees. For a variable capacitor it is 180 degrees and for a potentiometer is approximately 300 degrees although this will vary depending on the manufacturer and style of the pot.

  3. Rotation Angle. This is the angle a line from the center point to the center of the arc makes with the horizontal. The Rotation Angle, abbreviated R A is illustrated by the small meter scales across the bottom of the figure above.

  4. Major Marks. This is the number of major marks on the scale. These marks have the numbers associated with them. Be sure to count zero when setting this number. For example if you want a 0 to 10 scale with numbers every 2 units you must enter 6 in this box. (0, 2, 4, 6, 8, and 10.)

  5. Mark Length. The only thing that will distinguish between the major, intermediate, and minor, marks is their length. The entry in this box will set the length of the major mark.

  6. Intermediate Marks. This is the number of intermediate marks. If this value is set to 0, no intermediate marks will be placed on the scale.

  7. Mark Length. The only thing that will distinguish between the major, intermediate, and minor, marks is their length. The entry in this box will set the length of the intermediate mark. If the box is blank or a value of 0 is entered, A mark of 0 length will be inserted. (No mark.)

  8. Minor Marks. This is the number of minor marks. If this value is set to 0, no minor marks will be placed on the scale.

  9. Mark Length. The only thing that will distinguish between the major, intermediate, and minor, marks is their length. The entry in this box will set the length of the minor mark. If the box is blank or a value of 0 is entered, A mark of 0 length will be inserted. (No mark.)

  10. CCW Value. This is the numeric value that will be placed at the counter clockwise end of the scale.

  11. CW Value. This is the numeric value that will be placed at the clockwise end of the scale. There are no restrictions on these values. Zero may be placed at either end. To obtain a zero center scale place a value at one end and the negative of it at the other end. Be sure to use an odd number of major marks or the zero will not show.

  12. Decimal Places. This is the number of decimal places that will appear in the numeric labels on the major marks. For the example above of a 0 to 10 scale with 6 major marks this value may be set to 0 and the meter will look the way you expect. However, if you set it to 5 major marks the numbers would have to be 0, 2.5, 5, 7.5, and 10. If you set decimal places to zero, you will get 0, 3, 5, 8, and 10. Setting decimal places to 1 will give the proper values.

  13. Text Height. This sets the height of the numbers. If there are no font files on your computer or the path to them has not been specified, no numbers will appear.

  14. Numbers and Marks --. There are two radio buttons that determine if the numbers and marks are inside or outside of the arc.
    • Inside of Arc. If this button is selected the numbers and all marks will be inside the arc which connects the marks.
    • Outside of Arc. If this button is selected the numbers and all marks will be outside of the arc.
    You can make a very neat looking two scale meter by designing one scale with numbers on the outside. After placing it on the drawing board type D again to call up the designer. The same data will be in the boxes. Change the values in the CCW and CW values and switch to the Inside of Arc button and place it on the drawing board at the same point.

  15. Check Box: Numbers Oriented for Sideways Meter. There may be occasions when you want to set a meter or dial scale on its side, Rotation Angle = 0 or 180 degrees. If this box is checked the numbers will be oriented so they are mostly right side up. Meter and dial scales universally orient the numbers to be rotated around the center of the arc rather than being always horizontal.

There are two more numeric entry boxes in the designer window. They are Center Location % Height, and Center Location % Width. They set where the center of the arc will be placed in the designer window. The default setting is 50%. If the scale falls outside the window or overlaps the data entry boxes you can change these values to move the previewed scale where ever you want it in the window. The settings will be retained until you change them.

There are three buttons. They are as follows.

  1. Transfer to Drawing. This saves all scale parameters to a file, closes the designer window, and prompts you to left click the center of the scale arc. When you do so the scale will appear on the drawing board and will be the same size as it appeared in the designer window.

  2. Preview Scale Layout. This updates the scale shown in the designer window to incorporate any changes made to the parameters in the entry boxes. The designer window remains open. All parameters are also saved to a file.

  3. Cancel. This closes the design window and does not save any of the parameters.

The size of the scale in the designer window is the same as it will appear on the drawing board. The zoom setting of the drawing board is figured into the scaling. Try this example.

  1. If you haven't already placed a scale on the drawing board, type D, click Scale to Drawing, and click a point on the drawing board.

  2. type Control D again and use a ruler or pair of dividers to measure the size of the scale image in the designer window.

  3. Click Cancel and measure the size of the scale on the drawing board. They should be the same.

  4. Press F3 or F4 to zoom out or in. Make a significant change in the size of the scale.

  5. Again measure the size of the scale on the drawing board.

  6. Press Control D and measure the size of the scale in the designer window.

If the zoom and limits are set drastically different from those set the last time the designer was used it may seem as if there is no scale being displayed when you open the designer window. The scale may be a tiny dot at the center of the window or it may be so large as to be completely outside the window.

The arc is not truly an arc but consists of a series of straight lines between marks. Try this.

  1. Press Control D.

  2. change the values as follows.
    • Major Marks to 3
    • Intermediate Marks to 0.
    • Minor Marks to 0.
    • CCW Value to 0.
    • CW Value to 10

  3. Click Preview Scale Layout.

To correct this, change Minor Marks to 10, Mark Length just below it to 0, and click Preview Scale Layout. See? All better now. It strikes me as unlikely anyone would want to make a scale like this but just in case you do, now you know how.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

2.16 Dimensions.

When this was purely an electronics schematic drawing program there was no need for dimensions. Now that MaxCAD is being used to design woodworking projects, putting in dimensions one object at a time has been found to be quite tedious. So I have written a great many lines of code to make it possible to add dimensions to a drawing with just 3 mouse clicks and 3 presses of the TAB key.

  1. Type the letter D.

  2. Left click on the start point of the dimension.

  3. Left click on the end point of the dimension. At this point the length of the dimension will be displayed below the cursor coordinates at the top of the screen.

  4. Right click on the point where you want the text (numerical) value to be placed.

  5. You will see a prompt to Center or Not the text (C or N). The default is C. If you take the default the text will be exactly centered no matter how far off center you click. Press TAB to take the default or type N then TAB to Not center the text.

  6. Now you will see a prompt for the number of decimal places. The default is 2. Press TAB to take the default or change the number then press TAB.

  7. Now you will see the text as it will appear in the dimension. For example, if the two points you clicked were 2 and 3/4 screen units apart the box will contain 2.75". You may edit this to 2-3/4" or 2' 9" or leave it as is. When you are finished editing, press TAB. The dimension lines and text will appear on the drawing board.

If you clicked the right hand point first the text will be upside down and backward. To get it right always click the left point first. For a vertical dimension you may want the text to be read from bottom to top, or from top to bottom. The first point clicked will determine the beginning of the text.

There will certainly be times when the text will be too long to fit between the dimension lines, such as when labeling the thickness of a 3/4 inch thick shelf. If you try to place the text between the dimension lines you will get an error message. After clearing the message, press D again, or click the mouse wheel, and place the text outside the dimension lines. This time it will appear as it should. The answer to the "center" prompt has no effect on text placed outside the dimension lines.

2.16.1 Rules of Text Placement.

  1. The point you right click is where the middle of the text will be placed. See "2.13.1 The middle of text" above.

  2. If you leave a "C" in the "Center or Not" box it will override the point parallel to the dimension and the text will always be centered. The right click will still set the distance between the text and the dimension.

  3. When a dimension is long, and you type "N" in the "Center or Not" box, the text will not automatically be centered between the dimension lines. It will be placed where you right click.

  4. If you right click so close to a dimension line that the inserted text would overlap the arrowhead, the text will be moved far enough away from the dimension line to give a pleasing appearance. This will work at either end of the dimension.

  5. In the case of dimension text outside the dimension lines, the line on that side will be extended out to be just short of the end of the text. The answer to the "Center or Not" question will not have any effect.

  6. If you try to place the text too close to the dimension line it will be moved away to give a pleasing appearance.

  7. Whether the dimensions are horizontal, vertical, or on a diagonal, the order of left mouse clicks will set the direction of the text.

  8. The size of arrowheads, the spacing between the objects and dimension lines, and the length of dimension lines past the arrow head, are all determined by the text height. If your drawing size is 80 by 100 screen units and the text height is set to 0.1 the text and all other features of the dimension lines will be to minute to be seen.

  9. The Dimension object works on the assumption that the drawing is to scale. If you are designing a bookcase that is 84 inches tall the drawing of it must be 84 inches tall. If you make a scale drawing such as 1 inch equals 1 foot, you can simply interpret the dimensions as feet instead of inches. Each text object will have to be edited to avoid showing dimensions in decimal fractions of feet.

Here are some examples. The two green dots are where the mouse was left clicked. The side toward the beginning of the text was clicked first. The red dots are where the mouse was right clicked. The "Center or Not" question was always answered with "N".

Figure 2.3 Drawing Showing Several Examples of Dimensioning.

  1. In the upper left 1.60" dimension the left green dot was clicked first. The mouse was right clicked on the red dot which happens to be centered.

  2. To the right the text point was right clicked far outside the dimension points.

  3. Below, back on the left, the right click point is very close to the point where the arrowhead is located and the red dot is almost covered by it. The text was automatically moved over to keep it entirely within the dimension lines.

  4. Over to the right, in the 2.40" dimension, the right click point is directly above the second left click point. Because of a "greater than or equal to" in the code, this is taken as outside the dimension lines and the text is moved over as explained above.

  5. Directly below on the right, in the 2.00" and 0.40" dimensions, the right click point was directly in line with the two left click points. When this is done, the perpendicular lines are eliminated and just the lines along the dimension and arrowheads show.

  6. On the left the two 6.00" dimensions show how the order of left clicks determine the direction of text and also that the text may be placed anywhere along the dimension.

  7. To the right of these is a diagonal dimension. It works the same as orthogonal dimensions. The distance is the hypotenuse.

Unlike a shape, the dimension layout consists of separate drawing objects. Any single part can be moved, edited, or deleted.

The drawing below is an example of dimensioning a bookcase design. All text inside the lines is allowed to automatically be centered.

Figure 2.4 Bookcase design with dimensions.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

2.17 Polar Array.

A polar array is a series of drawing elements, or a series of collections of drawing elements, arranged about a center and equidistant from it.

Suppose you want to make an array of 10 long lines each with a circle at its end. Each line must start 1 inch from the center and be 1 inch long. The circle must have a diameter of 0.2 inches. You could draw each line and circle individually but the polar array was included as a time saver.

  1. Open MaxCAD and if a drawing appears press control N.

  2. Type L and draw a line from 1,0 to 2,0.

  3. Type C and click on the point 2.1,0.

  4. Type .2 and press TAB.

  5. Type A then P.

  6. Click on the line then hold the shift key and click on the circumference of the circle. Both will turn gray.

  7. Left click the point 0,0.

  8. The blue box will appear and the default value of 2 will be in it and will be selected.

  9. Type 10 and press tab.

  10. Press TAB to except the default value of 180 degrees for the array angle.

Notice that the circles do extend outside the 180 degree arc but this is most likely what would be wanted of this design. Now try this one.

  1. Press Control N to clear the drawing board.

  2. Type A then 1 for the first kind of arc.

  3. Click at the center, 0,0.

  4. Move the mouse to the point 1,0 and left click.

  5. Type 10 and press TAB.

  6. Type A then P.

  7. Click on the arc.

  8. Click at the point 0,0.

  9. Type 10 in the box and press TAB.

  10. Press TAB to except the default of 180 degrees.

Notice that the last dash in the dashed arc extends beyond 180 degrees. This is probably what would not be desired for a dashed half circle.

  1. Repeat steps 1 through 9 above.

  2. Type 170, 180 - 10, in the box and press TAB.

By reducing the angular extent of the array by the angle of one element the figure is a dashed semicircle which is most likely what was desired.

This is another example of the program not being able to read your mind. Sometimes you may want part of the array elements to extend beyond the angle of the array and sometimes not. Since the program can't think for you, you will just have to do it for yourself.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

2.18 Rectangular Array.

A rectangular array is a series of drawing elements, or a series of collections of drawing elements, arranged in rows and columns.

Suppose you want to make an array of circles that is three elements wide and two elements high.

  1. Type control N to clear the drawing board.

  2. Type C and click at the point 0,0.

  3. Right click at the point 0.4,0. This is on the green dot to the right of the magenta one.

  4. Now type an A followed by an R.

  5. Click on the perimeter of the circle. The circle will turn gray.

  6. Look at the prompt at the top of the screen. You have the option of selecting more objects to be in the array but there aren't anymore. Your being asked if you want to go to the parameters entry window. Press TAB to except the default of Y.

  7. If the boxes are blank type 2 in the Number of Rows box, 3 in the number of columns box, and 1,1 in the Cell Spacing X,Y box. If 2 and 3 appear in the first two boxes, press TAB until the cursor is in the third box and overtype 2,2 with 1,1.

  8. If the Cell Spacing radio button is not selected, select it.

  9. If the Enter Dimensions Using Mouse checkbox is checked, uncheck it.

  10. Click OK.

You now have an array that is 3 wide by 2 high. Take note, 3 columns and 2 rows. Also notice that the horizontal and vertical distances between centers of circles is 1 inch.

  1. Type control N.

  2. starting at the point 0,0 draw a square that is 0.4 on a side and has its lower left corner at 0,0.

  3. Type A then R.

  4. Select the square and press TAB to go to the parameters window.

  5. Leave the values of 2 and 3 in the first two boxes.

  6. Click on the Total Array radio button and check the Enter Dimensions Using Mouse checkbox.

  7. Left click the lower left corner of the square.

  8. Right click the point 2,1.

Notice that the outer dimensions are 2.4 by 1.4. Presumably in this case an array with outer dimensions of 2,1 would be wanted. Repeat the above procedure but this time click on the point 1.6,0.6. Now the array has the dimensions 2,1. Once again you have to think because the program can't do it for you.


MaxCAD Manual Chapter 1.

Chapter 3   Save, Open, Print, etc, the Files Menu.

3.1  The Menu Items.
3.2  Insert, Control I.

Chapter 3

Save, Open, Print, etc, the Files Menu.

The files menu contains all the things you have come to expect in any Windows application, plus a few extras. The experienced Windows user may skim over this chapter. Skimmers should pay attention to "Open Backup", "Insert", "Plot to HPGL File", and "Print List of Shortcut Keys". The recent files list has a twist I have never seen in any other Windows application but would like to see in all of them.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

3.1 The Menu Items.

  • New, Control N, Erases the drawing board and resets all view values to the default values which have been set in the Default Settings in the Settings menu. If the current drawing has been changed since the last save, you will be prompted to save it.

  • Open, Control O, Presents a dialog box in which you can select a file to be opened. The open dialog contains the following features.

    • At the lower left corner is a drive selection drop down list. It displays the currently selected drive letter and name.

    • Just above the drive box is the directory tree window. Double clicking on a directory will open it and its contents will be displayed in the files window to the right.

    • The files window shows all files in the currently selected directory that have the extension "dwg". Single clicking on a file will select it. Double clicking on a file will cause it to be loaded into the program and the "Open" dialog will be closed.

    • Below the Files window is the filename text box. If you know the name of the file you want to load, you may type it in this box. If you select a file in the files window its name will appear in the filename box.

    • In the lower left below the drive drop down is the "Open" button. If there is a file name in the filename box, clicking this button will cause it to be loaded. If the box is blank or contains ".dwg", nothing will happen.

    • To the right of the "Open" button is the "Cancel" button. If you change your mind click this button. The dialog will be closed and no file will be loaded.

  • Open Backup. When a file is saved the previously saved version is renamed to have a "BAK" extension. Then the file is saved with the normal "dwg" extension. If a file becomes corrupt or you made some changes that really messed it up you may want to go back to the previously saved version. This feature makes that possible.

    When you select "Open Backup" from the files menu, there is no hot key, the same dialog as that used in the open command will open but files with the extension "BAK" will be displayed in the files window. You may open one of these files in the same way as in the Open command above. You may not save a backup file. You must use Save As and change the file name or overwrite the existing "dwg" file, not recommended.

  • Insert, Control I, Will insert any drawing into the current drawing. When you invoke this command you are prompted to click an insertion point. This point is where the 0,0 point of the inserted drawing will be placed. Next you will be given a chance to type in a scale factor. Press TAB to take the default of 1. The standard "Open" dialog will open and you may select any dwg file to be inserted.

    If you use "Insert" to insert a shape file you can edit the shape after insertion. When the "Shape" command is used to add a shape to the drawing board it may not be edited. It's all or nothing.

  • Save, Control S, Causes the current file to be saved under the current file name which is displayed at the top of the screen. If no file name has been established since the last use of "New", the "Save As" command will be executed giving you a chance to set a file name and destination folder.

  • Save As, Causes the "Save As" dialog to open. This dialog looks exactly the same as the "Open" dialog. If no file name has been established, the filename text box will be blank. You may type in a name. If you fail to provide an extension the "dwg" extension will automatically be added. If you have typed a name that is the same as another file in the current directory you will be asked if you are sure you want to overwrite the file. If you single click on a file in the files window it will be placed in the filename text box. When you press the save button you will be asked if you are sure you want to overwrite the existing file.

  • Print Drawing, Control P, Causes the current drawing to be sent to your printer. That part of the drawing board that is within the "Limits" setting will be printed. If part of the drawing is outside of the limits, it will be clipped. If the limits are set quite large with a small drawing in the middle, the printout will appear the same way. To help you set proper limits, after invoking the "Limits" command type the letter A, upper or lower case, in the box and press tab. The limits will be automatically set to just a bit larger than your drawing.

    If you want a one-to-one scale between the screen and printer, set the screen limits to be 10 wide and 7.5 high. Then go into the "Printer Setup" and make sure the "Landscape Mode" box is checked. If you have a tall thin drawing set the limits to 10 high and 7.5 wide. Go into the "Printer Setup" and uncheck the "Landscape Mode" box.

  • Printer Setup, Opens a dialog that has 4 text boxes, two buttons, one checkbox, and a partridge in a pair tree.

    1. Print Scale permits the user to adjust the scaling between the screen and the printed page. It is currently set to 1 but can be changed.

    2. The X Offset allows adjustment of the position of the image on the printed page. See below regarding the current value.

    3. The Y offset performs the same as the X offset. The X and Y coordinates refer to the screen.

    4. Draw Width sets the width of the lines. This is currently set to 6 and is strictly a matter of taste. A larger number makes the lines wider while a smaller one makes them narrower.

    5. The Landscape Mode checkbox sets the orientation of the printed image on the page. If checked, hold the paper with long dimension horizontal to see the picture the same as on the screen. If unchecked, hold the paper with long dimension vertical to see the picture the same as on the screen.

    6. The Save Changes button saves the changes you made to the settings.

    7. The Cancel button discards the changes you made and reverts to the former settings.

    8. I lied about the partridge in a pair tree.

    This program was designed when I owned a Lexmark Z53 printer. It started making streaky printouts even with new cartridges so I bought a new one, this time an HP 7590 combo. I had to change the "X Offset" from 0 to -500. Make two drawings consisting of a frame 10 wide and 7.5 high and another 7.5 wide and 10 high. Print each one out with the appropriate setting of the "Landscape Mode" checkbox. If the frame is off center, correct it using the X and Y offsets. If the scale is off, correct it by adjusting the "Printer Scale" value.

  • Plot to HPGL File, Control H, converts the current drawing to HPGL (Hewlett Packard Graphics Language) and sends it to a file. The file has the same name as the current drawing but with a "PLT" extension. If you have not yet saved a new drawing to assign it a name you will get an error message reminding you to give the file a name.

    I have Corel Photo Paint 8 which will import HPGL files and permit them to be saved in a wide variety of formats. With line drawings such as these, the "GIF" format produces the smallest files. This is the only way I know to convert files from MaxCAD to formats that can be posted on the internet or exchanged with others. If you have a subroutine that will do it, please contact me.

  • Print List of Shortcut Keys, Control Shift F1, will send the first help page to your printer. This page contains a list of the shortcut (hot) keys, some reminders about mouse clicks and keys strokes, and a list of special characters in the supplied font.

  • The Most Recent Files List. When MaxCAD is started the most recent file to be worked on is loaded automatically. The next 9 most recent files appear in the most recent files list. The files list is scanned and files may be removed if; they are duplicated earlier in the list, or they have been moved to another folder, renamed, or deleted. Thus the list will not contain any false leads or duplicate names. I wish other programs had these features. Are you listening Microsoft and other Windows application developers? The first time you start MaxCAD there will be no previous files. The "Print List of Shortcut Keys" command will be followed by the "End" command. As you use MaxCAD the list will build up to a maximum of 9.

  • End, Control Q. This ends the program as you might expect. If the drawing has changed since the last save you will be prompted to save it. I have tried to avoid the artificial stupidity of many programs which ask you to save an unchanged or nonexistent file.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

3.2 Insert, Control I.

Although some word processors used to have an insert command, I have not seen it in some time. This will insert an entire file at any point on the drawing board. The uses of this function are limited only by the users' imagination. Here is an example that will also show the difference between using Shape and Insert.

  1. Type Control N to start with a blank drawing board.

  2. Type Control I for insert.

  3. Click the insertion point, make it 1.2 inches to the left of the point 0,0.

  4. Next you will be asked for the scale factor. For this example press TAB to take the default value of 1.

  5. The Open File dialog will open. Navigate to the location of the shape files on your computer and select "ScA-BJT, NPN.dwg".

  6. If you single click the file name it will be placed in the filename box below the files window. You can then click Open to insert the file.

  7. Double clicking on the file name will cause it to be instantly inserted.

  8. Notice that the left most point of the transistor symbol was placed at the point -1.2,0. This corresponds to the point 0,0 in the original drawing file.

  9. Now type the letter S and select "BJT, NPN from the list which appears. You will find it very near the upper left hand corner of the list.

  10. Right Click the point +1.2,0, 1.2 inches to the right of the origin.

  11. Right click two more times to lock the shape in place.

  12. Press the Del key and click on the circle in the left hand symbol.

  13. Notice that only the circle turned gray. Press the TAB key and the circle will disappear.

  14. Now press the Del key again and click on the circle in the right hand symbol.

  15. Oops, you got the whole thing, didn't you. Try control clicking on the lines away from the circumference of the circle. The whole thing turned back to white didn't it. Shift click the circle again. Press TAB and the entire symbol will disappear.

When a file goes in as a shape the contents of the file are not inserted into the file. See appendix B section 1, subsection B.1.6 Shape. Information about the file is inserted but not the entire file. Thus, when it comes to any sort of editing, it's all or nothing.

When the insert command is used the contents of the original file, less the file header, are inserted verbatim into the drawing file. The inserted object is not a single one but is as many objects as it took to make the original file. That is why the circle could be selected and deleted separately from the rest of the symbol.

A file which contains a great many shapes and is being viewed on a very old computer will draw more slowly but the file will be smaller.

A file which contains a great many shapes that were inserted using the insert command will draw more quickly but will be a larger file.

I have yet to make a drawing large enough to be noticeably slow even when MaxCAD is run on a 450 MHz Pentium running Windows 98.


MaxCAD Manual Chapter 4.

Chapter 4   Copy, Paste, and Other Editing. The Edit Menu.

4.1  Undo, Control Z.
4.2  Selecting and Unselecting Objects.
4.3  Color Change, Control K.
4.4  Copy, Ins key.
4.5  Copy to Clipboard, Control C.
4.6  Cut to Clipboard, Control X.
4.7  Paste from Clipboard, Control V.
4.8  Delete, Del key.
4.9  Edit, Control E.
4.10 Flip, Control F.
4.11 Lock, Control L.
4.12 Unlock All, Control U.
4.13 Mirror, Control Shift M.
4.14 Move, Control M.
4.15 Rotate, Control R.
4.16 Scale, Control G.
4.17 Select All, Control A.
4.18 Select Window, Control W.

Chapter 4

Copy, Paste, and Other Editing. The Edit Menu.

The edit menu has a few things that are familiar and more that aren't. Unlike the previous chapter each edit command will get its own section. Step-by-step instructions will be given for their use.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

4.1 Undo, Control Z.

The undo command works on all of the draw commands and most of the "Edit" commands. If you do something you didn't intend you can undo it if you act immediately. If you go on to another command the undo function will no longer work on the mistaken action. Instead it will work on the most recent action you took.

The Undo command will work after editing text or a shape name.

The undo does not work after editing a Scale. The Scale editor permits you to preview any changes you make to a scale so if you do something wrong you can see it and fix it before transferring the revised Scale to the drawing board.

Undo does not work on placing a Dimension object on the drawing board. That's because Dimension is actually a pseudo object. There is no Dimension object in the drawing file. Placing a Dimension object on the board causes several lines and one text object to be placed on the board. If you change your mind you will have to delete each line and the text individually.

In addition you can't undo a lock command. If you mess it up you can unlock all and start over.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

4.2 Selecting and Unselecting Objects.

The remainder of the items on the edit menu depend on knowing how to select objects. In order to practice you need a drawing with a number of objects on it. If you have downloaded this book the drawing file is in the download. Its file name is "MaxCAD_Manual_4-01.dwg". Retrieve it along with "MaxCAD_Manual_5-01.dwg" and MaxCAD_Manual_5-02.dwg" and place them in your MaxCAD drawings folder .

Figure 4.1 Practice Drawing.

Start MaxCAD and load the practice drawing. If no other drawing is saved before you shut down it will not show in the list but will be loaded the next time you start MaxCAD.

In the following exercises if you delete an object and can't get it back just reload the file. Remember not to save it, answer "NO" to that question and just reload it using the Open command (Control O).

4.2.1 Selecting objects one-at-a-time with the mouse.

A single object can be selected by left clicking the mouse on that object. To add more objects you must hold the shift key while clicking. As many objects as you have the patients to click can be added to the selection in this way. A line at the top of the drawing board will state N objects selected, where N is the number of selected objects.

When objects are selected an edit command has to be initiated first. Let's use a relatively safe command such as Color Change. This command can be selected from the Edit menu or you may type Control K. After seeing how to select and deselect objects you can abort the Color Change by pressing the Escape key.

  1. Type Control K.

  2. Left click on any object on the drawing board. It will turn gray.

  3. Hold the Shift key and left click additional objects. Each one will turn gray as you click it.

  4. You have to be on, or close to, the perimeter of a circle or arc. A shape will be selected by clicking anywhere in its footprint. For some shapes this may even be outside the shape.

  5. Press the Escape key to abort the command.

4.2.2 Unselecting objects one-at-a-time with the mouse.

Any selected object may be unselected by holding the control key while clicking the object.

For this exercise you need a situation in which the wrong object can be selected by mistake. To create this situation it is suggested that you place an Op Amp on the drawing board. (This object can be found high in the left hand column of the list of shapes.) Then draw a small circle that is completely within the triangular outline of the Op Amp. Press Control S to save the changes you just made.

  1. Click on the perimeter of the circle. Do not move the mouse after clicking. Notice that the triangular shape of the Op Amp turned gray.

  2. Hold the shift key and click again. Notice that the circle turned gray.

  3. Release the shift and press and hold the control key. Click again in the same place. Notice that the Op Amp turned back to white while the circle remained gray.

As each object is placed on the drawing board it is assigned a sequential number. When objects are selected or unselected they are scanned in order. When you click in a spot that falls within more than one object, the first one found will be selected. Subsequent Shift Clicks in the same place will select objects with higher numbers. Control clicks in the same place will unselect The first object found at that location. Thus, if you are going after a given object and you get the wrong one just shift click again to get the one you want and then control click to remove the one you don't want.

4.2.3 Selecting objects using the window.

When you start the select by window command the dotted cross cursor will disappear and a dotted rectangle will be outlined. Its boarders will change as you move the mouse. There is absolutely no restriction on which of the four corners you start with. The end corner will always be the opposite one.

When you use the Select Window it ABSOLUTELY MUST be the first thing you do after opening an edit command.

  1. Type Control K and then Control W which starts the select by window command. This can also be initiated by selecting Select Window from the Edit menu.

  2. Click somewhere, anywhere on the drawing board.

  3. Move the mouse away from that point. Notice that one corner of the rectangle is anchored at the point you clicked and the solid cross cursor is at the opposite corner.

  4. Move the mouse until some objects are totally within the dotted rectangle (window), some are partially within the window, and some are totally outside the window.

  5. Right click. Notice that the objects that were selected, were those that were totally within the window.

Even if part of an object is inside the window it will not be selected.

4.2.4 Adding and removing objects after using the Select Window.

When you use the Select Window it ABSOLUTELY MUST be the first thing you do after opening an edit command. After it's use you may add and remove objects in the same way as in 4.2.1 and 4.2.2.

  1. Type control K and then Control W.

  2. Use the Select Window to select some of the objects in your drawing.

  3. Now shift click an additional object that was not selected by the window.

  4. Use Control click to remove one or more selected objects that were inside the window.

  5. Alright, you've been good so type the number 3 and press tab. The objects you selected will turn yellow.

4.2.5 Select All.

There may be times when you want to select everything on the drawing board. The window could be used but a Select All command is faster and more certain. The Select All command may be initiated by typing Control A as in other windows applications.

  1. Type Control K then Control A.

  2. Type 4 and press return. All objects on the drawing board will turn green with envy.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

4.3 Color Change, Control K.

To remember the hot key for color change think of spelling color with a k. (Kolor).

  1. Select one or more objects.

  2. Look at the list in the upper left corner of the drawing board. Clicking on entries in this list will get you nowhere fast.

  3. Pick out the color you want to change the objects to, type that number, and press TAB.

The selected objects do not have to be the same color to start with. They will all end up the same color.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

4.4 Copy, Ins key.

This is NOT the copy to clipboard you are accustomed to. It will make a copy directly on the drawing board.

  1. Select an object such as the zigzag line.

  2. Press the Insert key (Ins) or select "Copy" from the "Edit" menu.

  3. Left click a point anywhere on the screen. That's right, it makes no difference where you click.

  4. Move the mouse away and you will see a dotted line known as the rubber band from the point you clicked to the mouse cursor.

  5. Position the mouse 0.1 inch below the first point and right click.

The copy of the object will appear 0.1 inches below the original object. The spacing of the original and the copy is determined by the distance and direction between the two mouse clicks. It doesn't matter where they are in relation to the objects.

Type control Z (Undo) to remove the copied object.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

4.5 Copy to Clipboard, Control C.

The Copy to Clipboard is your old friend from other Windows applications. You must select a point which will enable you to place it when the Paste command is used.

  1. Type control C or select "Copy to Clipboard" from the Edit menu.

  2. Select one or more objects.

  3. Left click on some easily memorable point such as the end of a line, the center of a circle or some other similar point.

  4. The selected object(s) will return to their normal color.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

4.6 Cut to Clipboard, Control X.

  1. Type control X or select "Cut to Clipboard" from the "Edit" menu.

  2. Select one or more objects.

  3. Left click a reference point such as the end of a line or the center of a circle.

  4. The objects will disappear from the drawing board. They are on the clipboard.

  5. Type control V and click at or near the point you clicked in step 3 above.

  6. The objects will return but in the new position if you clicked a different point.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

4.7 Paste from Clipboard, Control V.

The Paste command is rather far down the menu list but I don't want to keep you hanging with something on the clipboard. It is similar to the Paste command you know and love. However, it works better than in other graphics applications because you can select where the pasted object will be placed rather than being placed where the programmer thought it should go.

Have you noticed that except for the Files menu and the Undo command on the Edit menu, everything is in alphabetical order? That's no accident.

  1. Press control V or select "Paste from Clipboard" from the "Edit" menu.

  2. Left click where you want the point you clicked in 4.5 or 4.6 above to be placed.

The object(s) should have appeared. Press control Z to keep your drawing from becoming too cluttered.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

4.8 Delete, Del key.

  1. Press the Delete key (Del) or select "Delete" from the "Edit" menu.

  2. Select one or more objects.

  3. You will be prompted "PROCEED?". The default is Y for yes.

  4. Press tab to except the default. The object(s) will disappear from the drawing board.

  5. Press control Z, "Undo", to bring them back.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

4.9 Edit, Control E.

The Edit command in the Edit menu was originally designed to allow editing of text. It has been expanded to allow editing of Dial Scales or the names of shape files.

4.9.1 Editing Text.

If you followed my example you have this text on your drawing board. "The quick brown fox jumped over the lazy dog's back." On occasion I have seen this rendered "The quick brown fox jumped over the lazy brown dog."

  1. Type control E or select "Edit" from the "Edit" menu.

  2. Select the text object.

  3. You will be asked if you want to proceed. This is because it is possible to select the wrong object. If this happens you may correct your selection before being placed into the edit text mode.

  4. If you have the correct object selected, press the TAB key.

  5. The text entry box will appear at the top of the screen, the text will be in it, and it will be selected. Typing any key except the left or right arrows will cause it to disappear.

  6. The Del key will not work on the text but all other editing keys will.

  7. Make the changes and press TAB.

Notice one thing. The letter s does not appear in the revised version. The quick brown fox was invented in the 1940s to test teletype machines. It uses every letter of the alphabet. Restore the original form or do not if you feel you have had enough practice at editing text.

4.9.2 Editing a Dial Scale.

To edit a dial scale you need one on the drawing board.

  1. Type control N. Answer no to the save question.

  2. Type Control D.

  3. Click the "Transfer To Drawing" Button.

  4. Click at the point 0,0. The scale will appear on the drawing board.

  5. Press control E and select the scale.

  6. You will be prompted to "PROCEED?".

  7. If you selected the correct object, it's the only thing on the drawing board at this time, press the TAB key.

  8. The scale editor will open again and the scale will be in it.

  9. Make some change(s) to the scale parameters.

  10. Click the "Preview Scale Layout" button.

  11. Again click "Transfer To Drawing".

  12. You do not have to click, the revised scale will be placed in the same position it was in before the Edit command was invoked.

The "Undo" command will not work on this editing function. The scale appears in it's own editing window so you can look at it and be sure you have it right before you send it to the drawing board and close the editing window.

4.9.3 Editing Shape File Names.

This is a rather special command. It is unlikely you will ever have to use it but if you ever do you will be glad it is available. Reload the practice drawing.

  1. Type control E.

  2. Select one of the shapes you placed on the drawing board.

  3. If you selected the one you wanted, press the TAB key.

  4. Type this exactly as you see it observing case. "CLCap, Can" without the quotes.

  5. The original shape will be replaced by a combination of circles, arcs and lines.

  6. Type control O and answer NO to the save request.

  7. Reload your practice file.

4.9.4 Editing a Line.

The only thing you can do to a line is change it from solid to dashed or vice versa.

  1. Type control E and select one of the solid lines in the practice drawing.

  2. Press the TAB key to proceed.

  3. The line will change from solid to dashed.

That's all there is to it.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

4.10 Flip, Control F.

The Flip command makes a mirror image of all selected objects and then removes the old objects. An example use of this command is if you have created a printed circuit layout as viewed from the component side of the board and need to reverse it to make a negative for board production.

  1. Type Control F or select "Flip" from the "Edit" menu.

  2. Lets use the window. Type Control W or click "Select Window" from the "Edit" menu.

  3. Left click in the upper left corner of the drawing and then move the mouse to the right edge. Include about half of the objects on the drawing board.

  4. Right click at this location.

  5. You will be prompted "Flip: Left click Flip center."

  6. Click about half way between the top of the drawing and the lowest selected object.

  7. You will now be prompted "Flip Horizontally=H Vertically=V.

  8. Type a V and press the TAB key.

If you didn't include any text in the area that was flipped, try it again and this time include some. I had a long debate with myself over whether text should turn upside down or reverse left to right. As you can see the neighs had it. If you really, really need to flip some text you can put it in a shape, place the shape on the drawing board and then flip it. Text which is part of a shape does get flipped.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

4.11 Lock, Control L.

The lock command permits objects on the drawing board to be Locked so they cannot be selected and hence cannot be edited. My particular use for this is laying out circuits on proto PC boards. A proto PC board has a sort of universal copper trace pattern with holes on 1/10 inch centers. I have made a drawing of the pattern and locked it. I can load one of these and place lines for wires and component shapes on top of the board layout. I can edit the parts layout without fear of accidentally selecting and editing the copper trace layout.

  1. Type Control L or select "Lock" from the "Edit" menu.

  2. You will be prompted "Lock: Select Object(s).

  3. Select one or more object(s) by what ever means you want to.

  4. Press the TAB key to enter the default of Y for yes.

  5. The selected object(s) will return to their normal color.

  6. Press Control K and try to select the object(s) you just locked. Can't do it can you.

The "Undo" function will not work on this command.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

4.12 Unlock All, Control U.

This is not the next item in the "Edit" menu but these two belong together.

Type Control U or select "Unlock All" from the "Edit" menu.

Any and all objects that were locked are unlocked. If you have locked a number of objects and want to unlock just one or two, you are out of luck. The only thing you can do is to unlock all of them and then relock the ones you want to be locked. You can't select a locked object so you can't unlock just one.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

4.13 Mirror, Control Shift M.

The hot key for this command is Control Shift M. The "Move command was created first so it has dibs on Control M.

The Mirror command was created so only half of a symmetrical object would need to be drawn by hand. The mirror command will put in the other half. The difference between this and the Flip command is that Flip removes the original object(s) while the Mirror command does not.

  1. Press Control N and draw half of something. Draw a zigzag line with all vertices on the same horizontal or vertical line or get creative.

  2. Type Control Shift M or select "Mirror" from the "Edit" menu. You will be prompted "Mirror: Select Object(s)."

  3. After selecting object(s) you will be prompted "Left click Mirror point." This is the point about which the object(s) will be flipped and added to the drawing.

  4. Then you will be prompted "Mirror: Horizontal=H, Vertical=V." Type which ever one you want.

  5. If you selected the correct orientation for the object you started, it will be completed.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

4.14 Move, Control M.

This command allows one or more objects on the drawing board to be moved. For example, sometimes something just doesn't look right in relation to other objects. It may look too close to another object. So you can move it by one snap to make it look evenly spaced. You are not restricted to one snap. If you want or need to you can move something from one corner of the drawing board to the other.

  1. Type Control M or select "Move" from the "Edit" menu.

  2. Select one or more objects.

  3. You will be prompted "Left click source point". The location of this point will be moved to the location of the next point you click. The object(s) will be moved by the same amount and in the same direction.

  4. After you left click, you will be prompted "Right click destination point". The object(s) will be moved by the amount of and direction of the distance between the two clicks.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

4.15 Rotate, Control R.

Note: "Paste from Clipboard" was covered in Section 4.7.

You can rotate an object or group of objects around a center point. All objects are rotated as if you had cut out a portion of the paper they were drawn on and the cutout was rotated about a single point.

  1. Type control R or select "Rotate" from the "Edit" menu.

  2. Select one or more objects.

  3. You will be prompted "Left click center point."

  4. Click the point that will remain stationary as all selected objects rotate around it.

  5. You may type a rotation angle in degrees into the blue box or…

  6. Move the mouse away from the point you clicked. A rubber band will stretch out. When you right click the angle the rubber band makes with the horizontal will be the angle of rotation.

  7. Press control U, "Undo", to restore the drawing.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

4.16 Scale, Control G.

This command allows you to change the size of an object or group of objects. If you select several objects the size of each object will be changed as well as the distance between them.

If you enter a non orthogonal value, different values on X and Y axes, the object(s) will be scaled accordingly.

4.16.1 Orthogonal Scaling.

  1. Type control G, (think grow), or select "Scale" from the "Edit" menu.

  2. Select several objects.

  3. You will be prompted "Left click base point."

  4. This is the point that will remain stationary as the object(s) grow or shrink around it. Left click it.

  5. Type a number, less than 1 is recommended, into the blue box.

4.16.2 Non-orthogonal Scaling.

  1. Type control G again and select some objects. Be sure to include one or more of the larger circles.

  2. Left click the base point.

  3. Type "1,0.5" into the blue box, no quotes.

  4. Guess what, you have an ellipse.

4.16.3 Setting the Scale Factor Using the Mouse.

  1. Type control G again and select some objects. Be sure to include one or more of the larger circles.

  2. Left click the base point.

  3. Move the mouse away from the clicked point. Make the distance less than an inch in both X and Y with X and Y being unequal. Then right click.

If the rubber band is exactly vertical or horizontal the object(s) will be scaled equally in X and Y by the length of the rubber band. 1 Inch equals a scale factor of 1. 0.5 inches equals a scale factor of 0.5. If the angle of the rubber band is 45, 135, 225, or 315 degrees, X and Y scaling will be equal.

If the angle is such that X and Y distances are unequal, the object(s) will be scaled non-orthogonally.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

4.17 Select Window, Control W.

When you start the select by window command the dotted cross cursor will disappear and a dotted rectangle will be outlined. Its boarders will change as you move the mouse. There is absolutely no restriction on which of the four corners you start with. The end corner will always be the opposite one.

When you use the Select Window it ABSOLUTELY MUST be the first thing you do after opening an edit command.

  1. Type Control K and then Control W which starts the select by window command. This can also be initiated by selecting Select Window from the Edit menu.

  2. Click somewhere, anywhere on the drawing board.

  3. Move the mouse away from that point. Notice that one corner of the rectangle is anchored at the point you clicked and the solid cross cursor is at the opposite corner.

  4. Move the mouse until some objects are totally within the dotted rectangle (window), some are partially within the window, and some are totally outside the window.

  5. Right click. Notice that the objects that were selected, were those that were totally within the window.

Even if part of an object is inside the window it will not be selected.

The above is a repeat of section 4.2.3. See section 4.2 to put this information in context.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

4.18 Select All, Control A.

There may be times when you want to select everything on the drawing board. The window could be used but a Select All command is faster and more certain. The Select All command may be initiated by typing Control A as in other windows applications.

  1. Type Control K then Control A.

  2. Type 4 and press return. All objects on the drawing board will turn green with envy.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.


MaxCAD Manual Chapter 5.

Chapter 5  The View Menu.

5.1  Animated Rotation.
5.2  Grid Spacing.
5.3  Grid On/Off.
5.4  Limits.
5.5  Pan.
5.6  Reset Zoom and Pan.
5.7  Snap Width.
5.8  Non-orthogonal Snap.
5.9  Snap Mode.
5.10 What Is It?
5.11 Zooming.

Chapter 5
The View Menu.

The items in the "View" menu set what you see on the drawing board and the appearance of the drawing that is on it. In addition the "Limits" set how the drawing is printed out.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

5.1 Animated Rotation.

This function grew out of a need to design a swing out storage cabinet. Any interferences that may occur are best found on a computerized drawing rather than after the design has been rendered in plywood. While it is possible to use the Rotate function experience shows this to be tedious.

We will begin with a very simple drawing.

  1. Type control N and draw one straight line anywhere on the drawing board.

  2. From the "View" menu select "Animated Rotation".

  3. Click the line, it will turn gray.

  4. Click one end of the line.

  5. In the dialog that appears, set the "Angle Step (Degrees)" value to 1.

  6. Press TAB and enter .1 in the "Time/Step (Seconds)" box.

  7. If it is checked, uncheck the box labeled "Override Center Point Mouse Click".

  8. The coordinates of your second mouse click will show in the "Center Point (X,Y) box.

  9. Type "90" in the "Stop When Total Angle =" box.

  10. Click the "GO!" button.

  11. After the line stops rotating a button labeled "Restore" will appear near the upper left corhner of the drawing board.

  12. Click this button and the line will return to its original position.

  13. Play with changing the values to acquaint yourself with how they effect the action of the animation.

If you set the "Time/Step (Seconds)" less than 0.001 an error message will appear. The time entry is converted into milliseconds. A seconds value of less than 0.001 will be converted into 0 milliseconds and will trigger the error message.

Now we will get a little more complicated with Figure 5.1. This is a drawing of a closet door. The dwg file is included with the download version of this manual. The file name is "MaxCAD_Manual_5-01.dwg".

Figure 5.1 Drawing of a closet door in a wall.

This figure has been reproduced with very fine lines. Start MaxCAD and load the file "MaxCAD_Manual_5-01.dwg".

  1. Select "Animated Rotation" from the "View" menu.

  2. Click one of the lines that make up the door. Both lines will turn gray.

  3. Optionally, hold the shift key and click the word "door".

  4. Click anywhere in the drawing board. You are going to override the mouse click for the center of rotation.

  5. Enter 1 in the "Angle Step (Degrees)" box.

  6. Press TAB and enter .1 in the "Time/Step (Seconds)" box.

  7. I'm sure you have noticed that these values are already in these boxes. Values from the previous usage of this feature are remembered.

  8. Check the box labeled "Override Center Point Mouse Click".

  9. In the "Center Point (X,Y) box type "20.375,48.125".

  10. Type "90" in the "Stop When Total Angle =" box.

  11. Click the "Go!" button.

You probably have noticed that I forgot to tell you to click on the part of the hinge that is mortised into the door. Click on the restore button near the upper left corner of the drawing board. If you are so inclined, repeat the steps above but this time select the part of the hinge that is supposed to rotate with the door.

You should have also noticed that the door did not catch on the frame as it opened. If you didn't, run the simulation again. You may want to set the stop angle to something less than 90 degrees so the time to completion will be shorter.

Now type Control O and load the file "MaxCAD_Manual_5-02.dwg".

Figure 5.2 Drawing of a closet door with storage box installed.

This project is actually being seriously planned as an addition to my electronics shop which is in a spare bedroom of the house. The interior of the box will be accessed from the front through a door within a door. Details have been omitted to avoid a cluttered drawing. The point is to make sure the assembly can be opened without the box striking the door jam.

  1. Select "Animated Rotation" from the "View" menu.

  2. Click on the door and the outline of the box.

  3. Optionally, click on the text.

  4. Click anywhere in the drawing board.

  5. The dialog will open and all values should be set from the previous run. They will be there even if you have turned off your computer since working with Figure 5.1.

  6. I recommend, as a time saver, changing the stop angle to 30 degrees.

  7. Click "GO!"

Notice that the corner of the box passes through the frame. The vertical component of the distance from the corner of the box to the hinge pin is greatest when the corner is directly below the hinge pin. Play with the stop angle until the corner stops at this point. Decimal fractions of degrees are allowed.

Lay a ruler on your computer screen and measure along the back line of the box. Decide how much needs to be cut off to clear the door jam. Draw in the new box before deleting the old one.

Start at the top right and draw to the top left, then down. Lay the ruler back on the screen and stop the vertical line short of the bottom line by the amount you measured above. Click and draw the line to the right until it hits the door. Make sure it is exactly horizontal and right click. Now delete the old box outline.

Now run the animation again and see if your adjustment gives the clearance you want. Remember this is wood work. Even if you measure 10 times the dimensions are never going to come out perfect. So leave a little extra clearance to allow for errors.

You could solve this problem with the original rotate function, infact I did before adding the code to make the animation happen. The problem is, to get the interfering objects exactly in the right place you have to fiddle the angle back and forth and by the time you get it there you don't know what the rotation angle is to get it back to the original position. Very little code was required to make this function. All I had to do was to call existing routines.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

5.2 Grid Spacing.

Type Control N or select "New" from the "Files" menu. You will see a black screen with green dots on it. These dots are the grid. They help the user to know if a line is parallel to the X or Y axis and quickly estimate distances.

  1. Press F5 or select "Grid Spacing" from the "View" menu.

  2. You will be prompted "Grid Spacing" at the top left of the drawing board. The blue box will display 0.4 and the characters will be selected.

  3. Type ".2" without the quotes then press the TAB key.

  4. Experiment with several different values.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

5.3 Grid On/Off.

This function turns the grid on and off. The grid appears only on the screen and is not sent to the printer or to the HPGL plotter file.

5.2.1 Using the Function Key F6.

  1. Press F6. Notice that the grid is no longer visible.

  2. Press F6 again. Now the grid is back.

5.2.2 Selecting from the menu.

  1. Open the "View" menu. Notice that there is a check mark next to the "Grid On/Off" entry.

  2. Click on "Grid On/Off. The menu will close and the grid will disappear.

  3. Open the "View" menu again. Notice that the "Grid On/Off is not checked.

  4. Click on "Grid On/Off again.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

5.4 Limits.

The limits set how much of the drawing board is covered by the grid. They also set how much of the drawing board is sent to the printer.

5.3.1 Manually setting limits.

  1. Load the test drawing you used in Chapter 4.

  2. Press F7 or select "Limits" from the "View" menu.

  3. Type "-1,-1" without the quotes and press the TAB key.

  4. Type "1,1" without the quotes and press the TAB key. The Zoom has been set to 100 % for these limit settings.

  5. Press F3 6 times to zoom out until you can see the boarder. Notice that the grid only covers a small space around the origin.

  6. Leave the screen in exactly this condition for the next section.

5.3.2 Automatic Limit Settings.

  1. Press F7.

  2. Type the letter A, lower or upper case, in the box.

  3. Press the TAB key.

Notice that the zoom has been readjusted to almost fill the screen and the grid now also fills the screen. Press F3 to zoom out to better see this.

Now you can play with various limit settings both large and small to see how they work. After the limits have been set the screen is automatically zoomed to 100 percent for those limit settings.

5.3.3 One-to-one Scaling a Drawing to the Printer.

If you are making a printed circuit board or label for a control panel you need to know the scaling between the screen and printer page. Here's how.

If the drawing is wider than it is high, do this.

  1. Set the limits for a total width of 10 and a total height of 7.5.

  2. Open the "Printer Setup" window and make sure the "Landscape Mode" box is checked.

  3. The drawing will print 1 to 1.

If the drawing is taller than it is wide, do this.

  1. Set the limits for a total width of 7.5 and a total height of 10.

  2. Open the "Printer Setup" window and make sure the "Landscape Mode" box is not checked.

  3. The drawing will print 1 to 1.

5.3.4 One-to-one Printing of larger drawings.

If part of the drawing is outside of the limit settings it will not be printed. Suppose you have a drawing which is 15 inches wide and 6 inches high. To print this drawing do this.

  1. Open the "Printer Setup" window and make sure the "Landscape Mode" box is checked.

  2. Set the limits to 7.5 inches high and 10 wide but make it the left most 10 inches of the drawing. The right most 5 inches will be outside the limits.

  3. Print the drawing.

  4. Change the limits to include the right most 10 inches of the drawing leaving the left 5 inches outside the limits.

  5. Print the drawing.

  6. Find the best place in the overlapping 5 inches to splice the pages together.

  7. Cut one page along this line and tape it to the other, uncut, page. If the drawing is a panel label carefully cut both pages along the chosen line, trim the top and bottom, and glue it to the panel.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

5.5 Pan.

In some graphics programs the pan command will move the camera. That is if you pan to the left the objects on the drawing board will move to the right. I find this confusing.

In this program the pan command moves the drawing board. If you pan to the left the objects will move to the left.

  1. Press F2 or select "Pan" from the "View" menu.

  2. Left click near the origin.

  3. Stretch out the rubber band and right click near one corner of the screen. The origin will be moved to the position of the right click.

  4. Press F3 until you can see the whole drawing.

  5. Leave the screen in this condition for the next section.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

5.6 Reset Zoom and Pan.

This function resets the Zoom to 100 % and centers the drawing limits in the screen window.

Press F11 or select "Reset Zoom and Pan" from the "View" Menu.

That's all there is to it. It comes in handy if you have done a lot of zooming and panning. Try zooming in by pressing F4 until you can only see part of the drawing. Now experiment with panning around the screen. Then press F11 to quickly get back to 100 % zoom.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

5.7 Snap Width.

The snap width sets how far the MaxCAD cursor jumps with each snap.

  1. Type Control N.

  2. Press F8 or select "Snap Width" from the "View" menu.

  3. Type .4 into the box and press the TAB key.

You will see that the dotted cursor can only be positioned on the green dots which are 0.4 inches apart. The small solid cross is generated by Windows and apparently cannot be turned off. I would if I could find a way. The larger dotted cross is generated by MaxCAD and is the actual working cursor. Mouse clicks are registered on the snap positions. Play with different values of Snap Width.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

5.8 Non-orthogonal Snap.

Press F8 and type ".2,.4" without the quotes and press the TAB key.

As you move the mouse you will see that the cursor jumps 0.2 inches in the X direction but 0.4 inches in the Y direction. This comes in handy if you need to snap fractional inches in one axis and decimal values in the other. I have run into this situation when designing a bookcase.

If you type a single number without a comma the program will assume you meant to type the same number for both axes. When you press F8 again you will see that X snap and Y snap have been set equal.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

5.9 Snap Mode.

It will appear as if this is somewhat redundant. Well, it is. The Snap Mode routine was written first. Non-orthogonal Snap was added later. It was decided to leave Snap Mode in place to avoid any compatibility problems.

There are 4 snap modes. They are;

  1. Off,
  2. X axis only,
  3. Y axis only,
  4. Both axes.

5.8.1 Changing Snap Mode Using the Menu.

  1. Type Control N to obtain a blank screen.

  2. Press F8 and type .4 in the box and press the TAB key.

  3. Open the "View" menu.

  4. You will see "Snap Mode (Both)"

  5. Select this menu item. The words "Snap (Off)" will show in the upper right corner of the drawing board.

  6. Move the mouse around. You will notice that the dotted cross follows the solid cross smoothly in both axes.

  7. Once again open the "View" menu and select the item "Snap Mode (Off)"

  8. The legend at the upper right will change to "Snap (X)".

  9. Move the mouse and notice that the dotted cross follows the solid one smoothly in the Y direction but jumps, (snaps), in X.

  10. Open the "View" menu and select the item "Snap Mode (X)".

  11. The legend at the upper right will change to "Snap (Y)".

  12. Move the mouse and notice that the dotted cross follows the solid one smoothly in the X direction but jumps, (snaps), in Y.

  13. Open the "View" menu and select the item "Snap Mode (Y)".

  14. The legend at the upper right will change to "Snap (Both)".

  15. Move the mouse and notice that the dotted cross jumps, (snaps), in both X and Y.

  16. Leave everything in this state for the following section.

Note. The menu shows the current setting of the snap mode. When you select it the mode advances to the next setting but the menu closes so you can't see the change take place. That's why it's displayed on the screen.

5.8.2 Changing Snap Mode Using the Function Key F9.

It is assumed that you have just finished the steps in section 5.8.1.

  1. Press the F9 key and note that the legend in the upper right of the drawing board changes to "Snap (Off)"

  2. Move the mouse and note that the dotted cursor moves smoothly.

  3. Press the F9 key and note that the legend in the upper right of the drawing board changes to "Snap (X)"

  4. Move the mouse and note that the dotted cursor moves smoothly in Y but snaps in X.

  5. Press the F9 key and note that the legend in the upper right of the drawing board changes to "Snap (Y)"

  6. Move the mouse and note that the dotted cursor moves smoothly in X but snaps in Y.

  7. Press the F9 key and note that the legend in the upper right of the drawing board changes to "Snap (Both)"

  8. Move the mouse and note that the dotted cursor snaps in X and Y.

If you didn't notice it before, pay attention to the mouse cursor position legend just in front of the word "Snap". Repeat steps 1 through 8 above and notice that the number of decimal places in the position display changes. Set the "Snap Width" to 0.25 and note how the position coordinates are displayed. No more decimal places are shown than required to fully characterize the cursor position.

5.8.3 Changing Snap Mode on the Fly.

The F9 key may be used to change snap mode even in the middle of a draw command. The following example may seem a little artificial but It is likely to happen to you eventually. The snap values have been made atypically large to make the steps easier to perform.

  1. Press F8 and set the snap width to 0.2.

  2. Type L and draw a line from the point 0,-0.2 to 1,-0.2.

  3. Press the mouse wheel and draw another line from 0.8,0.8 to 1.6,1.2.

  4. Type A1, the A first then the 1, and place the center point at 0,0.

  5. Move the mouse to the point 1.4,0. A dotted circle will pass through the mouse cursor.

  6. Left click and move the mouse up. You want to make the end of the arc hit the line that is at an angle. Even moving the mouse farther away from the center still won't allow you to make the rubber band cross the dotted circle on the diagonal line.

  7. Press F9 once and note that "Snap (Both)" is now displayed at the top of the screen.

  8. Move the mouse until the rubber band crosses the dotted circle exactly on the diagonal line. Moving the mouse far away from the center point (0,0) will make this easier. Remember, you don't have to be on the dotted circle when you click the third point.

  9. When you are satisfied, right click and the arc will terminate exactly on the diagonal line.

  10. Press F9 three times to bring the snap mode back to "Both".

  11. Press F8 and set the snap width to 0.4.

  12. Type L and start a line at 0,-1.2.

  13. Now, you want to draw the line to the end of the horizontal line. But you can't get there from here. You don't want the line to stop short of the line or go past it.

  14. Press F9 twice and "Snap (X)" should show at the top of the screen.

  15. Now you note that you can move the cursor smoothly in Y but only in 0.4 inch steps in X.

  16. Set the cursor on the end of the line. This is easy because it is obvious when the dots of the cursor are on the solid line. Right click.

The corner formed by the two lines is as perfect as if it had been drawn with snap on. If you zoom in to 800 percent you will see that neither the corner nor the arc hitting the line are as perfect as they first appeared. When performing operations of this sort it is a good idea to zoom in as far as possible before performing the steps. You may not change the zoom setting in the middle of a draw command.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

5.10 What Is It?

No, I'm not asking you, that's what you can ask MaxCAD. This command may be of more use to me than it is to you but it's there if you ever need it, or are curious. It probably gives you more information than you would ever want to know.

  1. Load your practice drawing if it is not presently loaded.

  2. Type Control J or select "What is it" from the "View" menu.

  3. Select one, and only one, object on the drawing board.

  4. Press the TAB key to select the answer of Y for yes.

  5. A blue screen will come up with the information about the object printed in it.

  6. When you are finished studying the information click on the "Close" button at the top of the drawing board.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

5.11 Zooming.

Selecting "Zoom In" from the "View" menu or pressing F4 will zoom in on the drawing about 25 % each time the menu item is selected or the F4 key is pressed.

Selecting "Zoom Out" from the "View" menu or pressing F3 will zoom out from the drawing about 25 % each time the menu item is selected or the F3 key is pressed.

Zoom in is limited to 800 % and zoom out is limited to 0.01 %.

If you made your practice drawing exactly like mine there is a place where an arc goes past the angle a little so the line which was supposed to meet the end of the arc, hits it at a tangent. If you don't have such an item in your practice drawing, add one to it. Let's practice zooming and panning.

  1. Press F2 and left click on the arc overlap described above.

  2. Move the mouse to the origin, (0,0), and right click.

  3. The arc overlap will move to this point.

  4. Press F4 until the screen will no longer change. The zoom factor will be 800 %.

You can now see the details of where the arc ends and How the line actually hits the arc. On my screen it looks like this.

Figure 5.3 Screen shot of zoomed in drawing.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.


MaxCAD Manual Chapter 6.

Chapter 6  The Settings Menu.

6.1  Color.
6.2  Hidden Line Settings and Line Type.
6.3  Plot Scale.
6.4  Shape Library.
6.5  Text Height.
6.6  Default Settings.

Chapter 6

The Settings Menu.

Note: the Draw menu was covered in chapter 2.

The settings menu contains several necessary options. Some of these effect only new objects added to the drawing after the setting is changed while others effect objects already on the drawing board.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

6.1 Color.

The color setting effects only new objects. Once set to a particular color all objects added to the drawing board will be in that color. When the color setting is changed, none of the objects on the board will change but new objects will be in the new color.

  1. If it is not currently loaded, load the practice drawing.

  2. Select "Color" from the "Settings" menu and then select "Red" from the sub menu.

  3. Alternatively, type Shift R.

  4. The words "Draw Color = Red" will appear on the title bar of the screen.

  5. Draw a short line somewhere on the drawing board. The line should be red.

  6. Type Shift Y or select "Yellow" from the "Color" sub menu.

  7. The words "Draw Color = Yellow" will appear on the title bar of the screen.

  8. Draw another short line somewhere near the first. This line will be Yellow.

Notice that existing objects didn't change color. To learn how to change the color of existing objects see section 4.3.

Shortcut keys to change colors.

Press
Keys 		To Change
to Color
Shift W | White.
Shift R | Red.
Shift Y | Yellow.
Shift G | Green.
Shift C | Cyan.
Shift B | Blue.
Shift M | Magenta.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

6.2 Hidden Line Settings and Line Type.

The Line Type setting selects whether a line that is drawn will be solid or Dashed (Hidden). The Hidden Line Settings determines the length of dashes and the length of gaps between dashes in a hidden or dashed line. The settings effect all hidden lines on the drawing, new or old.

  1. Open the "Settings" menu. The item "Line Type Reverts to Solid After One Line" should be checked. Click on it.

  2. Again open the "Settings" menu and the above item should no longer be checked.

  3. Select "Line Type" from the open menu and click on "Dashed (Hidden)" from the submenu.

  4. Draw a line that is 2 inches long. It should be made up of 8 dashes.

  5. Select "Hidden Line Settings" from the "Settings" menu or press F12.

  6. The blue entry box will open and the following will appear in it. "0.14,0.12". All characters will be selected.

  7. Type ".07,.06" without the quotes and press the TAB key. Notice that the line changed to be made up of 15 shorter dashes.

Maybe someday the hidden line parameters will be stored with each line so different lines on the same drawing can have different dash and space lengths. That someday is not today.

If you save the drawing, the "Line Type" settings will be saved with the file. The "Line Type Reverts to Solid After One Line" setting and the "Line Type" setting will not. They will return to "Solid" and if the "Line Type" is changed to "Dashed (Hidden)" it will revert back to "Solid" after one line is drawn. This too may pass.

The line type may be changed from the keyboard by typing shift H for a hidden line or shift S for a solid line. The type of line will be displayed in the title bar as "Line Type = xxxxx". If the "Line type reverts to solid after drawing one line" is checked the display in the title bar will change after one hidden line is drawn.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

6.3 Plot Scale.

Plot Scale sets the scaling of the HPGL file. This is of importance to me even though I don't have an HPGL plotter. I convert the file using Corel Photo Paint 8. That version is long out of print but it is likely you can find a substitute. In the conversion process the pen width can be set. If this value is set too large the converted drawing will look the same as it would with a pen with a blunted point, the lines will be too wide, text will be hard to read and the drawing will just look messy.

If the pen width is set too small the lines may be less than a pixel wide which means they may disappear altogether. The drawing scale as well as the pen width enters into this. I have found that a drawing scale of 2 and a pen width of 0.5 millimeters will result in an appearance similar to figures 2.1 and 2.2. You would think that a scale setting of 1 and a pen width of 0.25 would act the same but you would be wrong. For some reason the conversion routines aren't linear.

To change the plot scale do this.

  1. Select "Plot Scale" from the "Settings" menu or press Control F3.

  2. You will be prompted "Enter new plot scale factor." Type the new number in the box and press the TAB key.

The plot scale is saved with each file so different files can have different scale factors without having to change them once they have been set.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

6.4 Shape Library.

Shape files are ordinary dwg files. They are distinguished from other drawing files by the first two characters of the file name and the file's location. For example, the shapes for laying out a chassis begin with Cl. You could just throw them in with all the other drawing files but if you had a drawing file named "Clock Face" it would appear in the list of chassis layout shapes. It is best to place the shape files in a folder where no other drawing files will be placed. One such place is in "C:\Program Files\MaxCAD". Another place is "My Documents\MaxCAD\Shapes and Fonts". The "MaxCAD folder can contain other folders named, for example, "Chassis Layouts", "PC Layouts", "Schematics", etc. In either case there should be only shape and font files, and no other dwg files in the folder.

To see what shape libraries you have installed on your computer select "Shape Library" from the "Settings" menu or type Control F4.

A list of all shape libraries will come up giving the following information.

  1. "Shape Prefix", the two characters that the file name begins with. It is case sensitive.

  2. "Number of Files", how many files have that prefix.

  3. "Shapes are used for" is a description I have programmed for the shapes that are shipped with MaxCAD. If you have created a shape library of your own this entry will say "User Defined".

  4. "Example File Name" gives the last file in the list having that prefix.

The two letter prefix of the current shape library will be shown in the box at the top of the drawing board. You can type a new prefix in the box, be sure to observe case, or click on an item to select from the list.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

6.5 Text Height.

Although the default text height is currently set to 0.1 you can change it at any time. Changing this value will not effect existing text. It will effect only new text items placed on the drawing board. Each text item has its height stored with it. To change the text height select "Text Height" from the "Settings" menu or press Control F5.

  1. Since the practice drawing is rather full, type Control N.

  2. Type T and place some text on the board.

  3. Type Control F5 and change the text height to 0.2.

  4. Type T and place some more text on the board.

  5. Type Control F5 and change the text height to 0.3.

  6. Type T and place some more text on the board.

Note that each time you changed the text height the size of the existing text was not changed but the new text was displayed in the new height setting.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

6.6 Default Settings.

When you select "Default Settings" from the "Settings" menu a dialog box will open. This dialog box allows the user to set the conditions that exist at program startup and when a new drawing is started. The table below gives a description of each item and it's setting in the program as shipped.

Label | Shipped Value | Description
Limits: Lower Left Corner X,Y | -5,-3.75 | Lower left corner of limit settings.
Limits: Upper Right Corner X,Y | 5,3.75 | Upper right corner of limit settings.
Grid Spacing | 0.4 | Distance between grid dots.
Grid On/Off | On | Turns grid on or off.
Snap Spacing | 0.1 | Sets both X and Y values of snap.
Snap Off/X/Y/Both Both Selects whether snap is off, X only, Y only,
Or Both X and Y.
Hidden Line Dash | 0.14 | Sets the length of the hidden line dash.
Hidden Line Gap | 0.12 | Sets the length of the gaps in a hidden line.
Plot Scale | 2 | Sets the scale of a plot in the HTML file.
Drawing File Path | C:\My Documents\MaxCAD\ | Path to the location of your drawing files. *
Default Text Height | 0.1 | Default height for new text.
Font Descender 0.4 Sets the fraction of the above line font that the
descenders extend below the line.
Font Chr. File Prefix F- Two character combination that begins names
of font character files.
Font File Name Schematic.fnt Name of the file that all font character files
are compiled into at program startup.
Shape File Prefix | Sc | File name prefix of shapes in the current shape library.
Shape and Font Path \ Sets the path to all shape and font files. *
Board Color Black Sets the color of the drawing board.
Only Black and White are allowed.
The White setting is not fully supported.
Drawing Color Black or White Sets the default color at program startup or
after selecting "New" from the "Files" menu.
Grid Color | Green | Sets the color of the grid dots.
Select Color Gray Sets the color an object turns when selected.
Currently, the only allowed color is gray.
Line Type reverts to solid
after drawing one hidden line 		Checkbox Checked Forces line type to revert to solid after a single
hidden line is drawn.

* This may be different on your system.

Most of these settings can be changed elsewhere in the program while a drawing is in progress but when ever a new drawing is started, these settings will take effect.

It is not a good idea to change any of these settings in the middle of work on a drawing. When you are working on a drawing it is very likely that you have changed many of the settings. If you change any of the default settings all settings will be changed to the default values when you click the Save button.


MaxCAD Manual Chapter 7.

Chapter 7  The Help Menu.

7.1  Moving around in the "Help" menu.
7.2  List of Shortcut Keys.

Chapter 7

The Help Menu.

Every windows application has a Help menu and this one is no exception. It does not include the search engine but it is organized in the same manner as the menus. So, if you want to find out how to draw a line, just look up "Line" under the "Draw" menu. In my view, other Windows applications make it unnecessarily complicated to find simple things.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

7.1 Moving around in the "Help" menu.

To open the help screen select any of the items under the "Help" menu. A blue window will open and the text will be light cyan. Another of my opinions is that this color scheme is very easy on the eyes. There will be a button at the top labeled close. The MaxCAD menu bar will not be covered by the help window and will still be visible.

Without clicking the "Close" button open the help menu and click a different item. The contents of the help screen will change to the new selection. Scroll down to find the menu item you are looking for. You may change the contents of the help window as many times as you wish. When you are finished with the help window, click the "Close" button to close it. Note: the F1 key does not work when the help window is open.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

7.2 List of Shortcut Keys.

The list of shortcut keys is something you may need to refer to frequently. It has been assigned a shortcut key of its own. Pressing F1 will open this section of the help file in the help window. If the help window is already open, the F1 key will not work. However, selecting "Shortcut Keys" from the "Help" menu will.

If you want a hard copy of this list press Shift Control F1 or select "Print List of Shortcut Keys" from the "Files" menu.


MaxCAD Manual Chapter 8.

Chapter 8  Making a Linear Scale for a Meter.

8.1  Altering an Existing Scale.
8.2  Making a New Linear Scale Using MaxCAD.

Chapter 8

Making a Linear Scale for a Meter.

Analog panel meters come in a wide variety of shapes and sizes. They come from the factory or the surplus dealer with a scale that may not be what your application requires. Most meters can be taken apart and a new scale installed that matches your needs.

Most round meters come apart by removing 3 screws that go radially into the meter at the back edge. When you pull it apart the meter movement and scale stay with the back part.

Meters with a round body and a square face may come apart in a couple of ways. Often there are screws that are installed with their heads toward the back of the meter on the surface that will be flat against the panel. There are usually 4 although in large meters there may be 6. Be sure you have them all out before you start prying on the front cover. The entire works of the meter stays with the case and just the front glass and escussion come off.

If you have one of the above types and you can't find any screws, chances are the front just pops off. Insert a small screwdriver and pry gently, with the emphasis on GENTLY.

There is another type of meter that you should walk away from. It is characterized by the front glass being curved convex (outward). Also the zero adjust screw does not penetrate through the glass rendering it inaccessible. I have heard variously that these meters are evacuated or have been filled with dry nitrogen. The curved glass seems to point toward a vacuum. A flat glass would have to be very thick to withstand the pressure difference.

You might feel that the meter is of no use to you in its present form so you have nothing to lose. There are likely to be flying bits of broken glass associated with an attempt to open such a meter. If you are determined to try, don't say I didn't warn you.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

8.1 Altering an Existing Scale.

This method does not employ MaxCAD but it is included for completeness. Occasionally A meter has the correct scale but the legend might not be what you want. For example, you may have a surplus meter that is calibrated from 0 to 1 and the legend says "Crystal Current in mA". You want to shunt the meter to measure 0 to 1 amp and use it in a power supply. All you need to do is alter the legend.

  1. Carefully disassemble the meter and remove the metal plate which holds the scale. Reassemble the meter leaving the screws out so as to protect the works from dust and grit. Note: (A meter movement is similar to a watch. It doesn't take much to gum up the works and stop it from working.)

  2. Place the meter scale in your scanner backed by a dark piece of paper. This is to make the mounting holes show clearly on the scanned copy.

  3. Load the scanned image into your favorite photo editor. Instead of trying to erase the old legend, use the color picker to get the exact shade of the "white" face and paint over it. If you do need to change the scale numbers do the same.

  4. Call up the lettering feature and draw the new legend on the meter face. Do the same for the numbers if you are changing them.

  5. Print out the revised meter scale on photo paper. Be sure to use a paper that contains some plastic. Ordinary paper changes dimensions as the humidity changes. High quality photo paper is designed not to do this.

  6. Cut off most of the excess paper. Turn the metal plate that holds the meter scale over and glue the new scale to the back. That is so if you should ever want the old scale back it is there to be used again. Do not use a glue that contains water as a solvent. Some spirit glues are dark and will soak through and stain the paper. Don't use one of these glues. I have installed new scales on several meters using rubber cement.

  7. If you have a light box that is the best thing for the next step. Place a light source behind the metal plate and align the dark spots that mark the mounting holes with the holes in the plate. Wipe off as much excess glue as possible and weight the scale down with something heavy and flat, (books), and leave it to dry overnight.

  8. Using an Exacto knife, trim down the paper to match the edges of the metal plate and cut out the mounting holes.

  9. Disassemble the meter, install the new scale, and reassemble.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

8.2 Making a New Linear Scale Using MaxCAD.

  1. Carefully disassemble the meter and remove the metal plate which holds the scale. Reassemble the meter leaving the screws out so as to protect the works from dust and grit. Note: (A meter movement is similar to a watch. It doesn't take much to gum up the works and stop it from working.)

  2. Now here's the rub. There is no way to get a scanned image into MaxCAD. Make some measurements on the existing scale and use the measurements to make up a new one employing the scale editor that is built into MaxCAD. Place the scale on the drawing board and mark the center of curvature with two crossed lines. Also place two small circles to mark the mounting holes.

  3. Print out the scale on tracing paper. Lay the paper over the existing scale and figure out what you need to do to make it match the scale. Too much curvature? Make the radius larger. Curvature is right but the new scale overlaps the old one at each end? Make the angle smaller.

  4. Edit the scale and pay attention to the mounting hole markers as well. I have found this to be pretty much a trial and error process.

  5. Print out the changed design and compare it to the original scale again. Go through as many iterations as it takes to get it right.

  6. Print out the revised meter scale on photo paper. Be sure to use a paper that contains some plastic. Ordinary paper changes dimensions as the humidity changes. High quality photo paper is designed not to do this.

  7. Cut off most of the excess paper. Turn the metal plate that holds the meter scale over and glue the new scale to the back. That is so if you should ever want the old scale back it is there to be used again. Do not use a glue that contains water as a solvent. Some spirit glues are dark and will soak through and stain the paper. Don't use one of these glues. I have installed new scales on several meters using rubber cement.

  8. If you have a light box that is the best thing for this step. Place a light source behind the metal plate and align the small circles that mark the mounting holes with the holes in the plate. Wipe off as much excess glue as possible and weight the scale down with something heavy and flat, (books), and leave it to dry overnight.

  9. Using an Exacto knife, trim down the paper to match the edges of the metal plate and cut out the mounting holes.

  10. Disassemble the meter, install the new scale, and reassemble.

  11. Enjoy.


MaxCAD Manual Chapter 9.

Chapter 9

Making a Nonlinear Scale for a Meter.

There are times when you have no choice but to use a nonlinear scale. Some examples are; a resistance scale in an ohmmeter that applies a constant voltage and measures the current, a transistor beta meter that keeps the collector current constant and measures the base current, a dB scale on an audio level meter, or the output level meter of a signal generator in which the nonlinearity of the detector diode causes the scale to be compressed at the low end.

This method requires that you have the project finished and operating. You need some kind of calibration standard so you can know what the value read by the meter actually is. The meter will come with a linear scale. You will use this scale to log a percent deflection for the standard values. The position of the actual points will be calculated from this data.

Note: In one case sited above there is a well known formula for the meter scale. That is a transistor beta meter.

IB = IC / Beta

The meter scale will have a one (1) on the right instead of a zero.(0). For beta values greater than 1, and they had better be or the transistor is burned out, The base current is lower which causes less deflection of the meter pointer and the function is a simple 1/x function.

The first thing you need to do is collect the data of meter deflection versus value. We will use an example of a fictitious signal generator. To make things more interesting the original meter scale will be presumed to go from 0 to 250. The calculations are a bit simpler if the scale goes from 0 to 100 but I need to cover the most general case. Here is the fictitious data from the fictitious signal generator.

Measured
Output
(Volts) 		Meter
Deflection
1.0 | 250
0.95 | 234
0.90 | 218
0.85 | 203
0.80 | 188
0.75 | 173
0.70 | 158
0.65 | 143
0.60 | 128
0.55 | 113
0.50 | 98
0.45 | 84
0.40 | 70
0.35 | 56
0.30 | 43
0.25 | 31
0.20 | 20
0.15 | 12
0.10 | 7
0.05 | 3
0.0 | 0

Now that we have collected the data we can remove the meter and disassemble it. Next you will make a scale to determine the values of "Scale Radius" and "Total Angle". Also we need to know the location of the scale mounting holes and the center of the scale arc. The following procedure will give us that information.

  1. Carefully disassemble the meter and remove the metal plate which holds the scale. Reassemble the meter leaving the screws out so as to protect the works from dust and grit. Note: (A meter movement is similar to a watch. It doesn't take much to gum up the works and stop it from working.)

  2. Now here's the rub. There is no way to get a scanned image into MaxCAD. Make some measurements on the existing scale and use the measurements to make up a new one employing the scale editor that is built into MaxCAD. Place the scale on the drawing board and mark the center of curvature with two crossed lines. Also place two small circles to mark the mounting holes.

  3. Print out the scale on tracing paper. Lay the paper over the existing scale and figure out what you need to do to make it match the scale. Too much curvature? Make the radius larger. Curvature is right but the new scale overlaps the old one at each end? Make the angle smaller.

  4. Edit the scale and pay attention to the mounting hole markers as well. I have found this to be pretty much a trial and error process.

  5. Print out the changed design and compare it to the original scale again. Go through as many iterations as it takes to get it right.

Now you know the radius and angle. Write them down so you won't forget them, or better yet use the text command in MaxCAD to place the values on the drawing board. Place them outside the meter scale so they will be cut off after the scale is glued to the scale plate.

Now decide on the number and location of major marks, intermediate marks, and minor marks. In this example we will place major marks at 0, 0.2, 0.4, 0.6, 0.8, and 1.0. Intermediate marks at 0.1, 0.3, 0.5, 0.7, and 0.9. Minor marks at 0.05, 0.15, 0.25, 0.35, 0.45, 0.55, 0.65, 0.75, 0.85, and 0.95.

Set up the linear scale that is on the drawing board to follow this plan if you are working through the example, or set it up to match your actual project. The purpose is to adjust the length of the marks so the scale will look good. Write down, or enter as text, the length of each mark as well as the text height that looks right.

Figure 9.1 A Linear Version of the Nonlinear Scale to be Created.

Now delete the meter scale leaving the arc center cross marks, the circles indicating the location of the mounting holes, and the text information about the scale.

Now draw an arc who's center is at the original arc center marked by the two crossed lines, and it's start point is the scale radius to the left of the center point, in this example, 2 inches. Enter the angle of the arc as a negative number which is the scale angle, -100 degrees in this example.

To give you some idea of where we are going with this, we will enter all marks at the lower end of the arc and then use the rotate command to place them in the proper part of the arc. Then the entire scale, marks, numbers, arc, and all will be rotated so it is a normally positioned scale. Stay tuned and you will see.

We will start with the mark at 1.0.

  1. Starting at the low end of the arc which should be at the point -2,0, draw a line from this point to the point -2.2,0.

  2. Set the snap to 0.05.

  3. Select the draw text command by typing T.

  4. Click the point -2.25,0.

  5. In the box at the top type the letter C to center the text.

  6. In the Text Angle box type 90.

  7. In the Text box type 1.0.

You should now see Figure 9.2 on the MaxCAD drawing board.

Figure 9.2 Nonlinear Scale Under Construction.

Obviously this mark and number belongs at the other end of the arc which is -100 degrees away.

  1. Start the Rotate command.

  2. Select the number 1.0 and the horizontal line

  3. Click at the center point of the arc.

  4. Type -100 in the Angle box.

Now the contents of your drawing board should look like Figure 9.3.

Figure 9.3 Nonlinear Scale Under Construction.

Well, that one was easy because it had to move from one end of the scale to the other. But next we will put in the mark for 0.95 volts and we need to rotate it to its proper location on the arc. For that we need to calculate the angle through which to rotate each mark. The table above has been repeated here with a third column added which is the angle of the mark from zero, the lower end of the arc.

Rotation Angle = -Angle x Meter Deflection / Meter Full-Scale.

Where "Rotation Angle" is the angle the marks and numbers will be rotated using the Rotate command.

"Angle" is the total angle of the scale, 100 degrees in this example.

"Meter Deflection" is the value taken from column 2 of the table.

And, "Meter Full-Scale" is the full-scale value on the meter, 250 in this example.

Measured Output (Volts) | Meter Deflection | Rotation Angle (Degrees)
1.0 | 250 | -100
0.95 | 234 | -93.6
0.90 | 218 | -87.2
0.85 | 203 | -81.2
0.80 | 188 | -75.2
0.75 | 173 | -69.2
0.70 | 158 | -63.2
0.65 | 143 | -57.2
0.60 | 128 | -51.2
0.55 | 113 | -45.2
0.50 | 98 | -39.2
0.45 | 84 | -33.6
0.40 | 70 | -28
0.35 | 56 | -22.4
0.30 | 43 | -17.2
0.25 | 31 | -12.4
0.20 | 20 | -8
0.15 | 12 | -4.8
0.10 | 7 | -2.8
0.05 | 3 | -1.2
0.0 | 0 | 0

Next we will put down the minor mark at 0.95. According to the data it is 0.75 inches long. Since we don't have snap set that small we will use keyboard entry for the second point of the line.

  1. Type L and click the low end of the arc.

  2. Type -2.075,0 and press TAB.

  3. Then type E and TAB.

  4. Type Control R and select the short line you just drew. Most likely the arc will be selected instead. Don't panic. Hold the shift while clicking the line. It will now be selected as well. Release the shift key and hold the control key while clicking the arc away from other objects. The arc will turn white.

  5. Click the center of the arc.

  6. Type -93.6 and press TAB. This is the angle from the 0.95 entry in the table.

Now we will put in the intermediate mark for 0.90.

  1. Type L and click the low end of the arc.

  2. Right click the point -2.15,0.

  3. Type Control R and select the short line you just drew. This time you should be able to select only the line.

  4. Click the center of the arc.

  5. Type -87.2 and press TAB. This is the angle from the 0.90 entry in the table.

Now perform the steps as above for the 0.95 minor mark except put in the 0.85 minor mark.

Now we will put in the 0.80 major mark.

  1. Type L and draw a line from the low end of the arc at the point -2,0, to the point -2.2,0.

  2. Select the draw text command by typing T.

  3. Click the point -2.25,0.

  4. In the box at the top type the letter C to center the text.

  5. In the Text Angle box type 90.

  6. In the Text box type 0.8.

  7. Type R and select the number 0.8 and the horizontal line

  8. Click at the center point of the arc.

  9. Type -75.2 in the Angle box and press TAB.

You should now see this on the drawing board.

Figure 9.4 Nonlinear Scale Under Construction.

Now add the rest of the marks. It may seem easier to do all the minor marks one after the other and then all the intermediate marks. That is how I did it. If you do, be careful to always read the angle from the correct line of the table. After all marks have been inserted this is what you will see on your drawing board.

Figure 9.5 Almost Finished Nonlinear Scale.

Only one more step to finish. We must rotate the whole scale so it is in the normal upright position for a meter. The equation to calculate it is,

Final Rotation Angle = -(180 - Angle) / 2

Where "Final Rotation Angle" is the angle to enter into the rotate command to bring the scale to the proper orientation,

and "Angle" is the angle of the arc 100 degrees in this case.

Final Rotation Angle = -(180 - 100) / 2 = -40 degrees.

  1. Press Control R to start the Rotate command.

  2. Press Control W to select objects using the select window.

  3. Left click the first corner of the window.

  4. Right click the other corner so as to include the entire arc, all of the marks, and all of the numbers. If you missed on the first try, press the ESC key and try again.

  5. Hold the Control key and click the crossed center marks and the mounting hole circles to deselect them.

  6. Now click the center of the crossed center marks.

  7. Type -40 into the angle box and press the TAB key.

  8. Delete the text legend.

Now your meter scale should look like this.

Figure 9.6 Finished Nonlinear Scale.

Making a nonlinear scale for a receiver dial is much the same except that the arc will subtend 180 degrees and you won't have to rotate it after you are finished. Here is how to get started.

Use MaxCAD to make a linear scale that goes from 0 to 180 and subtends an angle of 180 degrees. The normal receiver logging scale goes from 0 to 100 but by using 180 you don't have to perform any calculations.

Choose calibration points; every 100 kHz, 1MHz, or 5 MHz, depending on the frequency band being tuned.

Log the reading for each point, in a table the same as for the meter in the example above.

After marking the center point, delete the linear scale and draw an arc 180 degrees long. Then place the marks and numbers on it the same as done above for the nonlinear meter scale.


MaxCAD Manual Appendix A.

Appendix A
Auxiliary Files.

In addition to the main MaxCAD.exe file there are a number of other files which must be present on your computer for MaxCAD to work properly. Some of these files will automatically be regenerated by MaxCAD. Others can be regenerated with a little user intervention. All of these files except one reside in the same folder with the MaxCAD.exe file.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

A.1 MaxCAD_Last_Group_Opened.dat.

This is the file that contains the file path and name of the 10 most recently opened drawings. If it has been deleted, MaxCAD will create a blank file which will be filled up in the same way as it was when you first started using the program. When the file is completely empty, no drawing will be loaded on startup and there will not be any recent files list.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

A.2 MaxCAD-Default.dat.

This file contains the values set in the "Default Settings" dialog found under the "Settings" menu. When this file is missing, MaxCAD will recreate it but the path to the shapes and fonts is likely to be wrong resulting in an error message at start up.

After you click past the error messages, open the "default Settings" box and change the entry in the "Shape and Font Path" to match that on your system. Some of the numerical settings may not be original. If you have changed some of them they will not be correct. You will have to change them back to the settings you desire.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

A.3 Shape and font files.

Taken altogether the shape and font files shipped with MaxCAD number in excess of 500 at this writing and are constantly being added to. If all of these have become lost the error messages at startup will continue. It may be that the path to these files was not typed correctly in the above section (A.2). If you find that the files are indeed missing it is not necessary to reinstall MaxCAD. You can go to the programs page on the Fun with Tubes website where you originally downloaded this program and download a zip file of the shape and font files. Follow the installation procedure and all should be well.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

A.4 Schematic.fnt.

According to the original plan, if this file did not exist when MaxCAD started, the individual font character files would be read and compiled into this single file. The purpose was to allow several of these files under different names. The user would be able to change fonts on the fly the same as he can now change shape libraries on the fly. This feature has not been implemented. The contents of this file never change.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

A.5 MaxCAD_ArrayRec_Data.dat.

This file contains the rectangular array data from the last time this feature was used. If it should be deleted, MaxCAD will regenerate it the next time you use this feature. The data will be that which I used to test the feature during development. Deleting the file will cause your data to be lost.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

A.6 MaxCAD_Help.hlp.

If the help file should go missing the help function will no longer work. You will get an error message informing you that the file is missing or damaged and suggesting that you go to the web site where you originally downloaded MaxCAD to obtain a replacement copy of the help file. Follow the installation instructions you will find there.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

A.7 MaxCAD-Dial.DAT.

This file contains the data from the last time you used the dial and meter scale designer. If you have never used it this file contains an example scale. When the scale designer is opened this file is accessed and it's data placed in the designer. If the file is missing, a sample file will be automatically created when the designer is opened. After you change the values to your own needs this new data will be stored in the file and will be restored the next time you use the scale designer.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

A.8 MaxCAD-PrntSet.dat.

This file contains the printer setup information. If it is missing it will be created if you print a drawing or open the printer setup dialog. The only problem with that is the data in the created file may be wrong for your printer. After you determine the proper settings for your printer you should 1) write them down, or 2) make a backup copy of the MaxCAD-PrntSet.dat file and put it somewhere where you can find it.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

A.9 MaxCAD-ShapeList.DAT.

This file contains the list of shapes available in the current shape library. If it is missing it will be regenerated at program startup. It is also regenerated when ever the shape library is changed. Unlike the other files it resides in the folder with the shape and font files. If it should somehow be deleted while MaxCAD is running, the next time you try to draw a shape you will get an error message saying "Shapes not found or not available". To regenerate the file, press Control F4 and then the TAB key. This will recreate the file and the shape library will remain set to the one you were using when the mishap occurred. (I can't imagine how this could happen but I have had stranger, and unexplained, things happen on my system.)

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.


MaxCAD Manual Appendix B.

Appendix B
File Contents and formats.

All files associated with MaxCAD are in plain ASCII text. I thought initially that after development was completed I would change them to binary files but they are so small I can't see much to be gained by this change. In addition plane text falls in line with a desire to maintain the open nature of the program.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

B.1 The Drawing File.

All drawing files have a "dwg" extension. The first 27 lines are the file header. This header looks like this.

Shape File Prefix
Sc
Font File
Schematic.fnt
Limits
-5
-3.75
5
3.75
Grid
True
0.4
Snap Non Ortho
3
0.1,0.1
Zoom
1891.2
Pan
9515
6303
Plot Scale
2
Start Text Height
0.1
Hidden Line
0.2
0.06

The explanatory text was originally included to assist in early debugging of the program. It has been left in for convenience.

The next item is very important. It is the number of objects in the file. Each Arc, Circle, Dial, Line, Shape, or Text, is one object.

I recently experienced an incident in which a drawing file appeared to be empty. Its backup was in the same state. I opened it in Notepad and found that the entire file was there but the number of objects was set to zero. Recovery was easy because each object is numbered in the file. I changed the number to the correct value and the file was recovered. There's a lot to be said for open format. This might or might not have been possible if the file format were binary or even encrypted. Even if possible it certainly would have been much harder.
Each type of object has it's own format. They will be given below.

B.1.1 Object Header.

All objects have a standard header. The format is as follows.

  1. Object Name:

  2. Object Number: Sequential number of the object in the file.

  3. Object Color: An integer representing the color of the object. List follows.

    1. 1. White.

    2. 2. Red.

    3. 3. Yellow.

    4. 4. Green.

    5. 5. Cyan.

    6. 6. Blue.

    7. 7. Magenta.

  4. Object Parameter: This is different for each type of object and will be explained for each one.

B.1.2 Arc.

  1. Object Parameter = Radius.

  2. Center X: X coordinate of Center.

  3. Center Y: Y coordinate of Center.

  4. Starting angle in radians.

  5. Ending angle in radians.

  6. X Flip factor, 1 or -1.

  7. Y Flip factor, 1 or -1.

B.1.3 Circle.

  1. Object Parameter = Radius.

  2. Center X: X coordinate of Center.

  3. Center Y: Y coordinate of Center.

  4. X Flip factor, 1 or -1.

  5. Y Flip factor, 1 or -1.

B.1.4 Dial.

  1. Object Parameter = 15, always. This is the number of parameters necessary to define the dial scale.

  2. Center X: X coordinate of Center.

  3. Center Y: Y coordinate of Center.

  4. Numbers Inside/Outside of arc. 1 = Outside, 0 = Inside.

  5. Numbers oriented for sideways meter. 0 = No, 1.5708 = Yes.

  6. Radius.

  7. Angle Spanned.

  8. Rotation Angle.

  9. Major Marks.

  10. Major Mark Length.

  11. Minor Marks. *

  12. Minor Mark Length. *

  13. CCW Value.

  14. CW Value.

  15. Decimal Places.

  16. Text Height.

  17. Intermediate Marks. *

  18. Intermediate Mark Length. *

* Intermediate marks were added after the file format had been set. It was easier to just add them to the end instead of inserting them in order. It only matters to someone who is digging into the file as you must be now, or you wouldn't be reading this appendix.

B.1.5 Dimension.

Placing a "Dimension" on the drawing board does not create a dimension object. As such the "Dimension" object is really a pseudo object. It causes "Line" and "Text" objects to be created but a dimension object is not created and does not really exist.

B.1.6 Line.

A real world line, as opposed to a theoretical line in geometry, can be fully defined by its end points. As used in this drawing program a line can go from one point, to another, to another, etc. Such a line is fully defined by these turning points plus its end points.

No attempt has been made to make a distinction between a closed figure and an open figure. Thus an open figure made up of 3 line segments might have these coordinates.

0,0
1,0
1,1
0,1

A closed triangle might have these coordinates.

0,0
1,0
1,1
0,0

A few bytes might have been saved by making this distinction but I doubt if it would make much difference in the overall scheme of the universe.

Here are the file contents for a line.

  1. Line Type, 0 = Solid (continuous), 1 = Dashed, (Hidden).

  2. Line Width. Not implemented. Value is always 0.

  3. Object Parameter = Number of points.

  4. X value of point. *

  5. Y value of point. *

  6. * These two repeat as many times as there are points that define the line.

  7. X Flip/Scale factor, any real value.

  8. Y flip/Scale factor, any real value.

B.1.7 Shape.

A shape is not inserted into the drawing. As you will see, only information about the shape is inserted and when the screen must be redrawn or the drawing sent to the printer, or an HPGL file, the shape file is read from disk and inserted at that time.

  1. object Parameter = Scale factor.

  2. Shape file name without extension.

  3. X Flip factor, -1 or 1.

  4. Y Flip factor, -1 or 1.

  5. Insertion (rotation) angle in radians.

  6. X Coordinate of insertion point. *

  7. Y Coordinate of insertion point. *

  8. Footprint X minimum.

  9. Footprint X maximum.

  10. Footprint Y minimum.

  11. Footprint Y maximum.

* This is the location of the 0,0 point in the original shape drawing file.

The "Footprint" information is used when selecting shapes.

B.1.8 Text.

  1. Object Parameter = Text Height.

  2. Text String. String of characters that make up the text object.

  3. Text placement. M = Middle, C = Center, S = Start, and E = End.

  4. Insertion (rotation) angle.

  5. X Coordinate of Placement Point.

  6. Y Coordinate of Placement Point.

  7. Footprint X minimum.

  8. Footprint X maximum.

  9. Footprint Y minimum.

  10. Footprint Y maximum.

As with the Shapes, the "Footprint" information is used when selecting Text objects.

Objects are locked by setting the color number to a negative value. When the object is drawn or printed the absolute value of the color number is read to correctly set the color. When objects are being selected, the routine checks the value of the color number and if it is negative the selection is forbidden.

B.1.9 At the end of the file.

The last four entries are the footprint information for the entire file. This is used only when a ".dwg" file is interpreted as a shape file. The order is this.

  1. Footprint X minimum.

  2. Footprint X maximum.

  3. Footprint Y minimum.

  4. Footprint Y maximum.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

B.2 MaxCAD_ArrayRec_Data.dat.

This file consists of only 6 lines. They are as follows.

  1. Number of rows.

  2. Number of columns.

  3. Cell spacing or overall array size, (X,Y).

  4. State of "Cell Spacing" button.

  5. State of "Total Array" button.

  6. State of "Enter Dimensions Using Mouse" Checkbox. 0 = unchecked, 1 = checked.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

B.3 MaxCAD_Help.hlp.

This is an ASCII plain text file. The first line is "". After that the text begins.

Each of the help pages begins with the name of the menu enclosed in < and > signs. The file ends with

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

B.4 MaxCAD_Last_Group_Open.dat.

This file contains 20 lines. The first is the path to the most recently opened file. The next line is the file name. Subsequent lines are; path, name, path, name, etc. When the file is full it contains 10 paths and 10 names.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

B.5 MaxCAD-Default.dat.

This file contains 23 lines. They are.

  1. Drawing Board Color in 24 bit RGB.

  2. Default Draw Color in 24 bit RGB.

  3. Grid Color in 24 bit RGB.

  4. Select Color in 24 bit RGB.

  5. Font File Prefix.

  6. Compiled Font File Name.

  7. Text Descender.

  8. Default shape library Prefix.

  9. Plot Scale.

  10. Path to shape and font files.

  11. Default Text Height.

  12. Dashed (Hidden) line Gap.

  13. Dashed (Hidden) line Dash.

  14. Right X limit.

  15. Top Y limit.

  16. Left X limit.

  17. Bottom Y limit.

  18. Grid Spacing.

  19. Grid On/Off.

  20. Snap Spacing.

  21. Snap Status. 0 = off, 1 = X only, 2 = Y only, and 3 = Both.

  22. Line Type reverts to solid after drawing one line.

  23. Default Drawing File Path.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

B.6 MaxCAD-Dial.DAT.

This file contains 17 lines. They are.

  1. Scale Radius.

  2. Total Angle.

  3. Rotation Angle.

  4. Number of Major Marks.

  5. Major Mark Length.

  6. Number of Minor Marks.

  7. Minor Mark Length.

  8. CCW Value.

  9. CW Value.

  10. Number of Decimal Places.

  11. Text Height.

  12. Center Location, % Height.

  13. Center Location, % Width.

  14. Number of Intermediate Marks.

  15. Intermediate Mark Length.

  16. Numbers Inside/Outside of Arc. 1 = Inside, 2 = Outside.

  17. Numbers oriented for sideways meter. 0 = No, 1 = Yes.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

B.7 MaxCAD-PrntSet.dat.

This file contains 5 lines. They are.

  1. Print Scale.

  2. Printer X offset.

  3. Printer Y offset.

  4. Printed line width.

  5. Landscape mode, 0 = No, 1 = Yes.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

B.8 Schematic.fnt.

Because this feature has not been implemented the file contains numbers from 32 to 126 alternating with zeros. This file actually serves no useful function at the present time.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.


Electronics for Physicists Table of Contents.

My Textbook.

For 33 years I taught a course at Western Kentucky University titled "Electronics for Physicists". I spent about the first half of that time trying to find the right textbook. The choices I had were either too low level with no derivations and little math, or were too theoretical, deriving everything but with not a trace of practicality. After much frustration I decided to write my own book for the course. Contrary to what you might think, physicists need a very practical course because after they get into graduate school they need to know how to use electronics as a tool to aid in their research. You can't just give an equation to a physics major and expect it to be taken on faith. They will lose interest in a course that is taught that way. I needed to put in enough derivations to keep them happy while presenting a solid practical course.

Although I tried I never succeeded in getting a publisher interested in this book. I self published it through a copy shop near campus so the students could buy it. I retain all rights and posting it here does not mean I am placing it in the public domain.

You will find parts of it scattered around this site but the entire unedited book is here.

Every so often I get a request from someone wanting a hard copy of the book. All paper copies went away years ago. The original Word Perfect files have also disappeared so all that remains are these HTML files. I have put them together with all figures in a zip file which you can download from this location. I retain all rights to these files and electronic drawings. They are for personal use only. If you are a teacher and want to use this work as a textbook in your classes pleas contact me for permission to reproduce and distribute. If you plan to have your students access the book online please do not direct them to this site. I fear such use might exceed the bandwidth limit of my provider. Contact me so we can set up a mirror site preferably on your school or university network with limited access. Thank you.

A very kind person who wishes to remain anonymous has converted the book pages to a single Word file with drawings inserted. The same individual suggested a title change which I feel may be less intimidating than the original. The file could be printed out and distributed to a class. It may be downloaded from this location. You may print it out for your personal use but if you want to distribute it to a number of persons for a class pleas contact me for permission.

Back to Fun with Transistors.
Back to Fun with Tubes."

Electronics For Non-Engineers.

Table of Contents.

Chapter 0 Electrical Fundamentals.
0.1  Electrical Quantities From Mechanical Quantities.
0.2  Resistance and Ohm's Law.
0.3  Series Circuits and Kirchhoff's Voltage Law.
0.4  Parallel Circuits and Kirchhoff's Current Law.
0.5  Prefixes.
0.6  Numerical Examples.
0.7  Capacitance.
0.8  Inductance.
0.9  Problems.
0.10 Answers to Problems.

Chapter 1 DC Circuits.
1.1  Solving Complex Circuits Using Loop Equations.
1.2  Voltage Dividers.
1.3  Thevenin's Theorem.
1.4  Norton's Theorem.
1.5  Current Measurement, the D'Arsonval Meter.
1.6  Voltage Measurement.
1.7  Measurement Using Multimeters.
1.8  Problems.
1.9  Answers to Problems.

Chapter 2 AC Circuits.
2.1  Alternating Current.
2.2  Capacitive Reactance.
2.3  Inductive Reactance.
2.4  Series Circuits and Impedance.
2.5  RC Filter Circuits.
2.6  The Decibel (dB).
2.7  Graphing Frequency Response.
2.8  Nonsinusoidal Waves.
2.9  The Effect of RC Circuits on Nonsinusoidal Waves.
2.10 RLC Resonate Circuits.
2.11 Transformers.
2.12 The Oscilloscope.
2.13 Problems.
2.14 Answers to Problems.

Chapter 3 DC Power Supply Circuits.
3.1  Block Diagram of a Power Supply.
3.2  Protection Devices.
3.3  The Power Transformer.
3.4  The Semiconductor Diode.
3.4A The Vacuum Diode.
3.5  Rectifier Circuits.
3.6  Filtering the Rectifier's Output.
3.7  The Zener Diode Voltage Regulator.
3.8  Integrated Circuit Voltage Regulators.
3.9  Problems.
3.10 Answers to Problems.

Chapter 4 Transistors as Switches and Amplifiers.
4.1  The Bipolar Junction Transistor (BJT).
4.2  The BJT as a Switch.
4.3  The BJT as an Amplifier.
4.4  The Field Effect Transistor (FET).
4.5  The FET as a Switch.
4.6  The FET as an Amplifier.
4.7  Differential Amplifier.
4.8  Problems.
4.9  Answers to Problems.

Chapter 4A Triode Vacuum Tubes.
4A.1  The Triode (3 Element) Vacuum Tube.
4A.2  Triode Amplifier Graphical Analysis, Load Line.
4A.3  Triode Amplifier Small Signal Analysis.
4A.4  Resistance Coupled Amplifier Charts.
4A.5  The Miller Effect.
4A.6  Cathode Follower.
4A.7  Grounded Grid Amplifier.
4A.8  Cascode Amplifier.
4A.9  Problems.
4A.10 Answers to Problems.

Chapter 4B Multi Grid Tubes.
4B.1  Odes to Tetra and Penta.
4B.2  The Heptode, Pentagrid Converter.
4B.3  The Beam Deflection Tube.
4B.4  Magic Eye and Cathode Ray Tubes.
4B.5  Oscillators.
4B.6  Problems.
4B.7  Answers to Problems.

Chapter 5 Applying Feedback To Amplifier Circuits.
5.1  Some Preliminary Information.
5.2  The Negative Feedback Equation.
5.3  The Special Case of the Inverting Amplifier.
5.4  Frequency Response and Stability.
5.5  Gain Accuracy and Precision.
5.6  Other Benefits of Negative Feedback.
5.7  Some Practical Circuits.
5.8  Positive Feedback, Oscillators.
5.9  Problems.
5.10 Answers to Problems.

Chapter 6 The Operational Amplifier.
6.1  Op Amp Behavior.
6.2  Equations of the Op Amp.
6.3  The Unity-Gain Buffer Amplifier.
6.4  The Noninverting Amplifier.
6.5  The Inverting Amplifier.
6.6  The Summing Amplifier.
6.7  The Integrating Amplifier.
6.8  Single Power Supply Operation.
6.9  Understanding Op Amp Specifications.
6.10 Problems.
6.11 Answers to Problems.

Chapter 7 Operational Amplifier Circuits.
7.1  Instrumentation Amplifier.
7.2  AC Voltmeter Circuit.
7.3  Open-loop Linearization.
7.4  Absolute Value Amplifier.
7.5  Log Converter.
7.6  Active Filters.
7.7  Problems.
7.8  Answers to Problems.

Chapter 8 Digital Circuits.
8.1  The Binary Number System.
8.2  Logic Functions and Gates.
8.3  Boolean Algebra.
8.4  Combinational Logic Circuits.
8.5  Flip-Flops and Counters.
8.6  Displaying the Count.
8.7  Multiplexed Displays.
8.8  Digital to Analog Converter.
8.9  Analog to Digital Converter.
8.10 The 555 Timer.
8.11 Problems.
8.12 Answers to Problems.

Chapter 9 Digital Instruments.
9.1  Frequency Counter.
9.2  Digital Multimeter.
9.3  Frequency Synthesizer.
9.4  Problems.
9.5  Answers to Problems.

Appendix A   Standard Values for Electronic Components.

Appendix B   Reading Color Codes.

Appendix C   Transistor and IC Packages.

Back to Fun with Transistors.
Back to Fun with Tubes."


Chapter 0   Electrical Fundamentals.

0.1  Electrical Quantities From Mechanical Quantities.
0.2  Resistance and Ohm's Law.
0.3  Series Circuits and Kirchhoff's Voltage Law.
0.4  Parallel Circuits and Kirchhoff's Current Law.
0.5  Prefixes.
0.6  Numerical Examples.
0.7  Capacitance.
0.8  Inductance.
0.9  Problems.
0.10 Answers to Problems.

Chapter 0.

Electrical Fundamentals.

This chapter is intended as a review of material which the student should be familiar with. If the student is not familiar with the material in this chapter, intensive study of this chapter may not be sufficient. A review of textbooks used in previous courses may be required.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

0.1 Electrical Quantities From Mechanical Quantities.

Electric Charge.

It is difficult to say exactly what electric charge is but you are all familiar with it. You walk across the carpet on a cold winter morning, reach for the doorknob and - ZAP - you get an electric shock. Your body acquired the property of electric charge by friction with the carpet.

Electric charge can be placed on objects under somewhat more controlled circumstances. One way is to rub a rubber rod with a piece of cat's fur. The rod will now attract small objects such as bits of paper. The charge on the rod induces the opposite charge on the bits of paper. The fur will also attract small objects but it is not as easy to handle as the rod.

The property of electric charge will cause two bodies which possess a charge to exert a force on one another. The magnitude of this force is directly proportional to the amount of charge on each body and inversely proportional to the square of the distance between the two bodies. In equation form this law is

F = q1 q2 / r2           (0.1)

where F is the force in Newtons, q1 is the amount of charge on body 1, q2 is the amount of charge on body 2 and r is the distance between the two bodies in meters.

If the distance is 1 meter and the force is 1 Newton and the two bodies have the same amount of charge, the amount of charge on each body is 1 coulomb. This is the definition of a coulomb, which is the unit of charge in the MKS system.

If the two bodies have charges of the same sign, the force is repulsive. If the two bodies have charges of opposite sign, the force is attractive.

The charge on one electron is 1.601864 x 10-19 coulombs. Therefore, one coulomb of charge is equal to the total charge of 6.24 x 1018 electrons.

In terms of mechanical units the dimensions of a coulomb are

Coulombs = Meters x Newtons1/2           (0.2)

Electric Current.

Electric current is the motion of electric charge through any conducting material. When a direct current is flowing in a wire, electrons are in continuous unidirectional motion along the wire.

Current expresses the amount of charge per unit time passing a given point on a conductor. One way of defining current would be to specify the number of electrons per second passing a point. Although this would be a perfectly valid way of specifying the amount of current in a conductor, the numbers which would result in practical applications would be so large as to be unwieldy. More practical numbers result if the coulomb is taken as the basic unit of charge instead of the electron.

The most commonly used unit of current is the ampere. One ampere is equal to one coulomb of charge per second passing a point on a conductor. Thus the basic units of current are

Amperes = Coulombs / seconds           (0.3)

If desired the mechanical units of charge could be substituted into this equation and a strictly mechanical definition of current could be obtained. This is left as an exercise at the end of this chapter.

The symbol I is used for steady-state currents while the symbol i is used for time-varying currents.

The mathematical equations which relate current, charge and time are

I = Q / t           (0.4)

or

I = dq / dt           (0.5)

The use of an upper-case letter for steady-state values and the lower-case equivalent for time-varying values is common practice in electricity and magnetism.

Conventional Current.

When an electric current moves through a circuit, the negatively charged electrons flow toward the positively charged part of the circuit. This means that electrons come out of the - side of a battery and go into the + side.

Physicists and electrical engineers alike prefer to use conventional current instead of electron current. Conventional current does what you would expect it to do. It flows out of the + side of a battery and flows into the - side.

Some students find this confusing. If you are among the confused, try this. Never think about electron current. Banish electron current forever from your mind and think only in terms of conventional current.

If any one man can be blamed for this confusion it seems to be the fault of Benjamin Franklin. Everyone knows about his "kite in the lightning storm" experiment. What few people know is that Dr. Franklin wrote one of the first if not the first textbook on electricity. He assembled all that was known at that time about electricity and put it in one book. He seems to have added very little in the way of original work himself but one thing he did add was a sign convention for electric charge. The convention he chose was a guess and he guessed wrong. Just think of it, if he had guessed the other way, we would have positive electrons and conventional current would be the same as electron current.

Electrical Potential.

Mechanical potential is expressed in units of work- energy. Electrical potential also is an expression of work which can be done or energy stored. The units are work per unit charge. If work is done on a given amount of charge, the potential has increased. If the charge does work the potential has decreased.

Electrical potential like mechanical potential has no absolute zero. Electrical potential is always expressed as a potential difference between two points. In some cases one of the points is implied or understood in context. Electrical potential is meaningless unless two points are specified, implied, or understood.

Because potential is specified between two points the term potential difference is often used. The "difference" is usually omitted when speaking and often omitted when writing; "potential difference" is always understood by speaker, listener, writer and reader.

The unit of electrical potential difference is the volt. Potential difference is often called the voltage difference or the voltage drop but most often just the voltage.

If one joule of work is done on one coulomb of charge, the charge is moved through a potential difference of positive one volt. If one coulomb of charge does one joule of work, the charge has moved through a potential difference of minus one volt.

The basic units of voltage difference are

volts = joules / coulomb           (0.6)

As with units of current, the mechanical units of charge could be substituted into equation 0.6 to obtain purely mechanical units of voltage difference.

The term "electromotive force" was once regularly used to describe electrical potential difference. This led to the use of the symbol emf and later to the letter E to symbolize potential difference. In more recent times the letter V has been adopted for drops across passive components. The letter E will be used for the voltage of energy sources. This convention will be used throughout this book. The equations for voltage in terms of more basic units are

V = W / Q           (0.7)

or

dv / dt = dw/dt / Q           (0.8)

Charge is not indicated as being time-varying because it is conserved. Charge can neither be created nor destroyed.

Electrical Power.

In mechanics, power is the rate of doing work or work per unit time.

Power = work / Time           (0.9)

Electrical power is no different. Electric power is

Power = Current x Voltage.           (0.10)

If we substitute the mechanical units of voltage and current into equation 0.10 we have

Watts = Coulombs / Second x Joules / Coulomb = Joules / Second   (0.11)

Thus

P = I x V           (0.12)

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

0.2 Resistance and Ohm's Law.

An Electric Circuit.

In order for electricity to be useful, it must be harnessed to do work for us. The usual way of making electricity do work is to connect a source of electric energy to a device which converts the electric energy into another useful form of energy. An example of this is the flashlight, the schematic diagram of which is shown in figure 0.1.

Figure 0.1 Schematic Diagram of a Flashlight.

For a verbal description click here.

The battery on the left converts chemical energy into electrical energy. The lamp on the right converts the electrical energy into electromagnetic energy, some of which is in the visible light part of the electromagnetic spectrum. The switch is used to interrupt the flow of electrons and permit the light to be turned on and off. The lines on the drawing indicate conductors such as wire which normally have negligible amounts of resistance compared to the rest of the circuit.

Resistance.

When an electric current flows through a very good conductor, such as a copper wire, the electrons move very easily and very little work is required to move them. A copper wire has very low, almost zero resistance.

When an electric current attempts to flow through a very poor conductor, such as a piece of glass or the open switch, a near infinite amount of energy would be required. In purely practical terms, electrons do not move through pieces of glass or open switches and there is no current flow. No current flow means that no charge is moved and no work is done. A piece of glass or an open switch has very high, almost infinite resistance.

When an electric current flows through a thin wire such as the filament in the lamp, the electrons can be moved but considerable work is required to make the electrons move. The filament of a lamp and other devices on which electricity does work are said to have finite resistance.

Current, Work and Potential.

If the current flows through a part of the circuit which has zero resistance (a super conductor) no work is required to move the electrons through this part of the circuit. Electric charge is being moved but no work is being done. In as much as potential difference (voltage) is defined as work per unit charge (equation 0.6) if the work is zero, the voltage is zero.

If the current flows through a part of the circuit which has a finite resistance, work is required to move the charge. If work is done, there is a potential difference across that part of the circuit. If the amount of charge per unit time remains constant, doubling of the amount of resistance will cause the amount of work to be doubled and the voltage to be doubled. Therefore, the voltage is directly proportional to the resistance.

If we now hold the resistance constant and allow the current (charge per unit time) to vary we discover the following. If the current doubles, there is twice as much charge to be moved and twice as much work will be required to move it. Which leads us to the conclusion that the voltage is directly proportional to the current.

We have now concluded that the voltage is directly proportional to the current and the resistance. As we saw at the beginning of this discussion, if the resistance is zero, the voltage is zero. On the other hand if the resistance is finite and the current is zero, there are no charges to do work on and there can be no potential difference. This is a strong indication that voltage is proportional to the product of resistance and current.

V = I x R           (0.13)

Resistance is defined in terms of volts and amps as follows. If a current of 1 ampere is flowing through a resistance of 1 ohm, the voltage which results will be 1 volt. Even the ohm can be defined in terms of purely mechanical units.

The above discussion is as close as we can come to a derivation of Ohm's law (equation 0.13). In fact Ohm's law was discovered experimentally and is strictly an empirical law.

Resistance and Power.

It is important to know how much power is being dissipated in a resistor. Every resistor has a maximum power rating. If this power is exceeded, the resistor will get overheated and quite literally burn up. Whenever a resistor is put into service a power calculation should be performed to make sure that the resistor will not burn out.

One way to make a power calculation is to multiply the current through the resistor by the voltage across it. This must be valid but if you know only one, voltage or current, you must use Ohm's law to calculate the other. A couple of shortcuts can be developed by combining equation 0.12 (power) with equation 0.13 (Ohm's law). A direct substitution of 0.12 into 0.11 gives

P = I x I x R = I2 x R           (0.14)

Solving Ohm's law for current and substitution gives

P = (V / R) x V = V2 / R           (0.15)

These equations should not be confused with the definition of power but they are often very handy.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

0.3 Series Circuits and Kirchhoff's Voltage Law.

Electric circuits get much more complex than the flashlight shown in Figure 0.1. We will work our way up from simple circuits to more complex circuits.

Figure 0.2 Schematic Diagram of a Series Circuit.

For a verbal description click here.

A series circuit is defined as a circuit in which there is only one path to be followed from a given point, around the circuit and back to the same point. Figure 0.2 qualifies under this definition of a series circuit.

In Figure 0.2 the letter E is used to symbolize the emf or potential difference across the battery. The symbol V1 is used for the potential difference across the resistor R1. In general the symbol VN will be used for the potential across any resistor RN.

Conventional current flows out of the positive terminal of the battery, through R1, through R2, through R3 and to the negative terminal of the battery. Current is symbolized by the letter I.

Current in Series Circuits.

Let us use the general symbol IN for the current in resistor RN and the letter I for the current in the battery. Remember that current could be expressed as the number of electrons per second passing a point in the circuit.

As electrons move around the circuit, there are no side roads for them to take. Electrons cannot pile up at any particular place in the circuit. If there was a pile-up, the concentration of negative charge would repel additional electrons from that vicinity and the pile-up would soon be gone. Pile-ups never happen in the first place.

Because we have established that electrons cannot accumulate at any point or get out of the circuit at any point, we may say that the number of electrons per second passing any point in the circuit of Figure 0.2 is the same as the number of electrons per second passing any other point in the circuit. In other words the current at any point in the circuit is exactly the same as the current at any other point in the circuit. This can be stated in equation form as

I = I1 = I2 = I3           (0.16)

Equation 0.16 is a consequence of Kirchhoff's current law although we don't officially know that yet.

Voltage in Series Circuits.

Remember that potential difference or voltage is work per unit charge. From mechanics remember: 1) the equivalents of work and energy, 2) the conservation of energy and 3) the conservation of charge. Also remember that the current in any resistor in Figure 0.2 is the same as the current in any other resistor and the same as the current in the battery.

The amount of work done by the battery is equal to the sum of the work done on each resistor, In equation form

W = W1 + W2 + W3           (0.17)

If we solve equation 0.7 for W and substitute into equation 0.17 we have

QE = QV1 + QV2 + QV3           (0.18)

As the current is the same everywhere in the circuit, the charge per unit time is the same and all occurrences of charge are the same. The charge Q will cancel out. Thus we have

E = V1 + V2 + V3           (0.19)

Equation 0.19 is a special case of Kirchhoff's voltage law.

Kirchhoff's voltage law states that the algebraic sum of all voltage drops around any closed loop is equal to zero. Thus, Kirchhoff's voltage equation for the circuit of Figure 0.2 is

- E + V1 + V2 + V3 = 0           (0.20)

Voltage Rises and Drops.

All voltages are really voltage differences. A potential difference or voltage difference can be either a voltage rise or a voltage drop. Although it may be stating the obvious, a rise is an increase in potential or voltage and a drop or fall is a decrease in potential or voltage. If we start at a particular point in a circuit and move around the circuit we may move from a point of low potential to a point of higher potential. We have traversed a potential rise. If we move from a point of high potential to a point of higher potential we have again traversed a potential rise. The starting point makes no difference; it is the change that is important. Similarly if we move from a point of any given potential to a point of lower potential we have traversed a potential drop or fall.

For example, if we traverse the battery in Figure 0.2 from bottom to top, we have traversed a rise. Conversely if we traverse the battery from top to bottom, we have traversed a drop. From this you can see that a battery is not automatically a potential rise; it depends on the direction of travel.

It is easy to tell the direction of the potential or polarity of a battery because of the polarity markings. A battery will always have the same polarity (positive on the long line) regardless of whether it is being charged (current flowing into the positive terminal) or discharged (current flowing out of the positive terminal). The positive terminal of the battery is always positive no matter which way the current is flowing.

Resistors and other passive devices are another story. Conventional current always flows out of the most negative end of a passive device. Thus, the end where the current goes in is more positive than the end where the current comes out.

In solving Kirchhoff's equation it is very important to give the proper sign to each quantity. If an incorrect sign is given to a particular value, the result will be incorrect. Here are some rules to follow in writing Kirchhoff's equations.

  1. 1 Mark the polarity on all voltage sources (batteries) by placing a minus (-) sign next to the negative terminal (short line) and a plus (+) sign next to the positive terminal (long line).

  2. 2 Assume a direction for the current. Clockwise is a standard assumption used by those who solve circuit equations. Don't be concerned if you can't tell which direction the current is actually flowing. The numeric answer will have a sign which will tell us if the initial assumption was right or wrong.

  3. 3 Mark the polarity on all passive devices (resistors) by placing a plus (+) sign at the end where the current enters and a minus (-) sign at the end where the current exits.

Now that you have polarity markings on each part in the circuit you are almost ready to write a Kirchhoff's equation.

Do not be concerned about the fact that there are + and - signs next to each other on opposite ends of the same wire. The signs refer to that particular circuit element alone. The positive end is more positive than the negative and the negative end is more negative than the positive end. The signs say nothing about what the potential is with respect to other parts of the circuit.

Kirchhoff's law states that the sum of all voltage drops is equal to zero. It could just as well say that the sum of all voltage rises is equal to zero. The only difference between the two resulting equations will be that one has been multiplied through by -1 as compared to the other.

If you are summing the rises, a drop is a negative rise. A drop is the negative of a rise. Conversely a rise is the negative of a drop. Therefore, if we sum the drops, a drop is a positive quantity and a rise is a negative quantity.

Apply the three rules above to Figure 0.2 and start at the lower left corner. The battery E is a rise which is a negative drop. Thus we write a negative (- E) in equation 0.20. The drops across the resistors are just that and are entered as positive quantities.

Example 0.1.

Write Kirchhoff's voltage equation for the circuit of Figure 0.3.

Figure 0.3 Series Circuit With Multiple Voltage Sources.

For a verbal description click here.

Solution.

First, mark a + sign near the positive (long line) and a - sign near the negative (short line) of each battery. Indicate a clockwise direction for the current by drawing an arrow on the figure. Put + and - signs on each resistor as follows. The lower end of R1 is positive and of course its upper end is negative. The left ends of R2 and R3 are positive. The upper end of R4 is positive. Of course the other end of each resistor is negative. Now we can write the equation. Start at the lower left corner and move around the circuit in a clockwise direction. If we sum the drops we get

- E1 + V1 + V2 - E2 + V3 + V4 + E3 = 0       (0.21)

If we sum the voltage rises we get

E1 - V1 - V2 + E2 - V3 - V4 - E3 = 0     (0.22)

Equation 0.22 is just equation 0.21 multiplied by -1. If we were to plug in numbers and solve them, both would give the same answer.

Resistors in Series.

Suppose we have three resistors in series as in Figure 0.4a and we wish to replace them with a single resistor as in Figure 0.4b. We want a single resistor Req which will cause the same amount of current to flow as the series combination of R1, R2, and R3, when connected across the same voltage source (battery). In other words we want one resistor which will act the same as the three resistors together.

Figure 0.4 (a) Three Resistors in Series,
(b) One Equivalent Resistor to Replace it.

For a verbal description click here.

We now apply a voltage E to the resistors as shown in Figure 0.5. Kirchhoff's equation is - E + V1 + V2 + V3 = 0. Solving for E gives

E = V1 + V2 + V3           (0.23)

The equivalent resistor Req would give the simple equation

E = Veq           (0.24)

If we substitute Ohm's law VN = I x RN and remember that the current I is the same everywhere in a series circuit we have

I x Req = I x R1 + I x R2 + I x R3           (0.25)

canceling I

Req = R1 + R2 + R3           (0.26)

and in the general form

Req = R1 + R2 + ... + RN           (0.27)

Equation 0.27 says that the equivalent of any number of resistors in series is the sum of all of the resistors in series.

Figure 0.5 (a) Three Series Resistors Connected to a Voltage
Source, (b) One Equivalent Resistor Connected to a
Similar Voltage Source.

For a verbal description click here.

Logical Checks.

In any problem-solving course it is a good idea to have in mind some rules of logic for checking answers. You should look at an answer and ask yourself "Does that answer make sense?" From time to time this book will give some common sense rules under the heading of "Logical Checks".

When finding the equivalent of series resistors the equivalent will always be greater than the largest single resistor.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

0.4 Parallel Circuits and Kirchhoff's Current Law.

A parallel circuit is defined as a circuit which has two or more independent paths which can be followed from a given point in the circuit back to the same point. A simple parallel circuit is shown in Figure 0.6.

Figure 0.6 Schematic Diagram of a Parallel Circuit.

For a verbal description click here.

Voltage in Parallel Circuits.

Now that we know Kirchhoff's voltage law let us use it. This law applies to any circuit as long as we go around a loop taking every voltage drop into account and coming back to the original starting point.

In Figure 0.6 let us start at the lower left corner, go up through the battery, to the right to the top of R1, down through R1 and then back to the left to the starting point. The resulting equation is -E + V1 = 0 or E = V1.

Now let us follow a path through R2. Start at the lower left corner, go up through the battery, to the right to the top of R2, down through R2 and then back to the left to the starting point. The resulting equation is -E + V2 = 0 or E = V2.

The argument is the same for R3. Thus we have shown that

E = V1 = V2 = V3           (0.28)

In a simple parallel circuit the voltage across any one element is the same as the voltage across any other element in the same circuit.

Current in Parallel Circuits.

Figure 0.7 is the map of a rather strange system of roads. The system is one-way, left to right. Cars are fed into the system at the left at a rate measured in cars/hour. At the first junction some cars go left, some go straight and some go right. The cars go through the three parallel roads and join up again at the rejoin point. Cars cannot get out of the system except at the ends and no cars from the outside can get in. Cars exit on the right at the same rate as they enter on the left. No stopping in the red zone.

Figure 0.7 Map of Strange Road System.

For a verbal description click here.

When the car-current (cars/hour) splits it is obvious that the sum of the car-currents (KN) in the three paths is equal to the car-current (K) in the main path.

K = K1 + K2 + K3           (0.29)

Look at Figure 0.6 and visualize the electrons in the circuit doing the same as the cars on the road. This is the justification for writing the equation

I = I1 + I2 + I3           (0.30)

which is a special case of Kirchhoff's current law.

Kirchhoff's current law says that the sum of all currents flowing into a junction is equal to zero. If current going in is defined as positive, then current coming out is negative.

In Figure 0.6 the top line is a junction where currents may be summed and the bottom line is another junction where currents may be summed. If we sum the currents in the top line we have

I - I1 - I2 - I3 = 0           (0.31)

if we sum the currents in the bottom junction we have

- I + I1 + I2 + I3 = 0           (0.32)

The only difference between equations 0.25 and 0.26 is that one is the negative of the other. Numerical solution of both equations will give the same answer.

Resistors in Parallel.

Suppose we have three resistors in parallel as in Figure 0.8a and we wish to replace them with a single resistor as in Figure 0.8b. We want a single resistor Req which will cause the same amount of current to flow as the parallel combination of R1, R2 and R3 when connected across the same voltage source (battery). In other words we want one resistor which will act the same as the three resistors together.

Figure 0.8 (a) Three Resistors in Parallel,
(b) One Equivalent Resistor to Replace it.

For a verbal description click here.

We now apply a voltage E to the resistors as shown in Figure 0.9. Kirchhoff's equation for the bottom line of the circuit is -I + I1 + I2 + I3 = 0. Solving for I gives

I = I1 + I2 + I3           (0.33)

The equivalent resistor Req would give the simple equation

I = Ieq           (0.34)

If we substitute Ohm's law IN = E / RN and remember that the voltage E is the same everywhere in a parallel circuit we have

E / Req = E / R1 + E / R2 + E / R3           (0.35)

canceling E

1 / Req = 1 / R1 + 1 / R2 + 1 / R3           (0.35)

in the general form and as more often written

Req = 1 / ( 1 / R1 + 1 / R2 + ... + 1 / RN)           (0.37)

Equation 0.37 says that the equivalent of any number of resistors in parallel is the reciprocal of the sum of all of the reciprocals of the individual resistors in parallel.

Figure 0.9 (a) Three Paralleled Resistors Connected to a
Voltage Source, (b) One Equivalent Resistor
Connected to a Similar Voltage Source

For a verbal description click here.

Logical Checks.

When finding the equivalent of parallel resistors the equivalent will always be less than the smallest single resistor.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

0.5 Prefixes.

Prefixes are used throughout the sciences to indicate multiplication by a power of ten. You probably already know that 1 centimeter = 10-2 meters and 1 kilogram = 103 grams.

In electricity and magnetism the values are so large or so small as to require the use of prefixes. You MUST be able to make instant conversions in your head from one prefix to another or the unprefixed unit. Here are the prefixes you should know.

For a more screen reader friendly version of the table below click here.

Prefix | Multiplier | Symbol
pico | 10-12 | p
nano | 10-9 | n
micro | 10-6 | u
milli | 10-3 | m
kilo | 103 | k
mega | 106 | M
giga | 109 | G

Table 0.1 List of Prefixes Commonly Used in Electronics

For a more screen reader friendly version of this table click here.

Example 0.2.

Convert; (a) 500,000 hertz to kilohertz and megahertz,
(b) 820 k ohms (kilohms) to ohms and Megohms,
(c) 9 x 10-4 amperes to mA and uA.

Solution

(a) 500 kilohertz (kHz) and 0.5 megahertz (MHz)
(b) 820,000 ohms and 0.82 M ohms
(c) 0.9 mA and 900 æA

You should be able to answer those questions as quickly as you can speak the words. If you cannot, make up some practice questions and drill until you can convert without having to stop and think.

Yes, it's memorization. Unfortunately there is no other way to learn prefixes. There is nothing to understand, just memorize, memorize, memorize.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

0.6 Numerical Examples

The following examples will illustrate the standard method for solving electric circuits. The method employs the repeated application of Ohm's and Kirchhoff's laws. The examples will also illustrate prefix conversion. In solving these circuits there is no formula you can find to plug numbers into. You must think!

Example 0.3.

In the circuit of Figure 0.2 the battery voltage E is 24.00 volts. R1 = 470 ohms, R2 = 220 ohms and R3 = 330 ohms. What is the current drawn from the battery?

Solution:

The equivalent resistance in the circuit is R1 + R2 + R3 = 470 ohms + 220 ohms + 330 ohms = 1020 ohms. The current drawn from the battery is I = E / Req I = 24 v / 1020 ohms = 2.35 x 10-2 A = 23.5 mA.

Example 0.4.

In the circuit of Figure 0.2 the resistance of each resistor is as follows. R1 = 910 ohms, R2 = 1.1 k ohms and R3 = 1.3 k ohms. The voltage across R2 is 4.985 volts. What is the battery voltage?

Solution:

Intermediate results should always be carried out to four significant digits. Answers should be rounded off to three significant digits. The current in R2 is I2 = V2 / R2 = 4.985 v / 1.1 k ohms = 4.532 mA. This also is the current in R1 and R3, I = I1 = I2 = I3. The voltage across R1 is V1 = I1 x R1 = 4.532 mA x 910 ohms = 4.124 v, V2 is given and V3 = 5.892 v. The battery voltage E is equal to the sum of all resistor voltages E = 4.124 v + 4.985 v + 5.892 v = 15.001 v. Rounding off, the battery voltage E = 15.0 volts.

Example 0.5.

In the circuit of Figure 0.6 the resistance of R2 is 620 ohms and the current through it is 125 mA. The resistance of R3 is 15 k ohms. What is the current through R3?

Solution:

The voltage across R2 is V2 = I2 x R2 = 125 mA x 620 ohms = 77.50 v. In a parallel circuit E = V1 = V2 = V3; hence V3 = 77.50 v. I3 = V3 / R3 = 77.50 v / 15 k ohms = 5.17 mA.

Example 0.6.

In figure 0.6 the current in R1 is 66.6 mA, the current in R2 is 39.4 mA, the power in R3 is 1.7 watts and the resistance of R3 is 820 ohms. What is the total battery current?

Solution:

The current in R3 is I3 = (P / R)1/2
I3 = (1.7 w / 820 ohms)1/2 = 4.553 x 10-2 A = 45.53 mA.  The battery current I = I1 + I2 +I3
I = 66.6 mA + 39.4 mA + 45.53 mA = 152 mA.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

0.7 Capacitance.

A capacitor is a device which has the property of capacitance. Capacitance is the property possessed by a capacitor. Eh?

A capacitor is nothing more than an open circuit. Yet it is the most useful open circuit ever discovered. A capacitor consists of two conductors separated by an insulator. Capacitors can best be described as devices which permit electric charge to be stored and released in a controllable and repeatable manner.

Capacitance is that electrical property which resists changes in the voltage across the circuit containing the capacitance.

Capacitors are devices in which energy can be stored for short periods of time. The energy is stored in the electric field between the two conductors of the capacitor.

Capacitance is defined as

C = Q / V           (0.38)

where C is called the capacitance and is measured in farads, Q is the charge on either conductor in coulombs and V is the potential difference between the two conductors in volts.

If equation 0.38 is solved for charge we have

Q = C V           (0.39)

If we take the time derivative of both sides of this equation we have

dq / dt = C dv / dt           (0.40)

But dq/dt = i; therefore,

i = C dv / dt           (0.41)

This equation turns out to be much more useful than you might imagine.

Example 0.7.

If the current through a capacitor is 120 milliamperes and the rate of change of voltage is to be 1.5 volts/milliseconds, what is the capacitance?

Solution:

Solving equation 0.41 for C gives

C = I / (dv/dt) = 120 x 10-3 / (1.5 v / 10-3) = 8.0 x 10-5 farads.

8 x 10-5 farads may be expressed as 80 microfarads or 80 uf. Both answers are correct, they are just different ways of expressing the same number.

Equation 0.41 tells us that we cannot change the voltage across a capacitor in zero time. If we tried, the current would be infinite. This equation also tells us that if we maintain a constant current through a capacitor, the voltage across it will change linearly with time. This is the basis of the linear sweep in an oscilloscope.

Resistance-Capacitance Circuit.

Figure 0.10 Circuit For Charging and Discharging a Capacitor.

For a verbal description click here.

Consider the circuit of Figure 0.10. The switch is placed in position 1 to insure that there is no initial charge on the capacitor. Then the switch is changed to position 2 and the capacitor begins to charge. The bottom plate will receive a negative charge while the top plate will receive a positive charge. Kirchhoff's voltage equation for this circuit at any instant of time is

E = iR + q / C           (0.42)

The battery voltage E, the resistance R and the capacitance C do not vary with time. The current i and the charge on the capacitor q do vary with time. If we take the time derivative of this equation we have

E = di / dt x R + dq / dt x 1 / C           (0.43)

If we make the substitution i = dq/dt we have

E = di / dt x R + i / C           (0.44)

The solution to this differential equation in i is

i = E / R x e-t/RC           (0.45)

This equation tells us that the current starts out as if the capacitor were a short circuit. i0+ = E/R. The current quickly falls away and decays exponentially.

When t becomes equal to RC the value of the exponent on e is -1. This point in time has been defined as the time constant of the circuit and is given as

T = RC           (0.46)

where T is the time-constant in seconds, R is the resistance in ohms and C is the capacitance in farads.

After one time-constant the current has fallen to 1/e of its initial value; after 2 time-constants the current has fallen to e-2 of its initial value and so on. Theoretically the current will never reach zero. After 5 time-constants the current will be .07% of its initial value and for most practical purposes may be considered to be zero.

Example 0.8.

Starting with equation 0.45 and using only Ohm's and Kirchhoff's laws show that the voltage across the capacitor is given by

vC = E (1 - e-t/RC)           (0.47)

Solution:

The voltage across the resistor is vR = iR or

vR = E e-t/RC           (0.48)

Solving Kirchhoff's equation for vC gives

vC = E - vR           (0.49)

Substituting equation 0.48 into 0.49 and factoring out an E gives us

vC = E (1 - e-t/RC)           (0.50)

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

0.8 Inductance.

Inductance is that electrical property which resists changes in the current in the circuit containing the inductance.

A device which has the property of inductance is called an inductor. It consists of a coil of wire. The coil may be wound on a solid iron core, a powdered iron core or a hollow tube (air core).

An inductor can store and release energy. The energy is stored in the magnetic field which is produced by the current flowing in the coil of wire.

Inductance is defined as

L = N H / I           (0.51)

where L is the inductance which is given in units called henrys, N is the number of turns on the coil, H is the magnetic flux produced by each turn and I is the current in the coil.

If we rearrange equation 0.51 we have

L I = N H           (0.52)

If we take the time derivative of equation 0.52 we have

L di / dt = N dH / dt           (0.53)

Remember from physics that

E = - N dH /dt           (0.54)

Substituting equation 0.54 into equation 0.53 yields

E = - L di / dt           (0.55)

This equation tells us that we cannot change the current through an inductor in zero time. To do so would require an infinite voltage across the inductor.

The minus sign in equation 0.55 tells us that the polarity of the voltage which is produced is in such a direction as to oppose the change which produced it.

Consider the circuit of Figure 0.11. The battery will cause current to flow to the right in the inductor (coil of wire). The normal polarity of the voltage drop across the inductor will be positive to the left as shown in the figure.

Figure 0.11 Simple Inductive Circuit.

For a verbal description click here.

If we now cause a sudden decrease in the voltage of the "battery" the current through the inductor will decrease. This is a negative di/dt. Combined with the minus sign in equation 0.55 gives a positive result. The current is flowing to the right in the inductor. A positive voltage with respect to this current means that the voltage will be positive on the right as shown. For the period of time that the change of current is taking place, the inductor may be considered as a voltage generator. The "voltage generator" in the inductor which has its positive terminal on the right is adding to the voltage of the battery. Remember that this whole thing started with a decrease in the battery voltage. The voltage being produced by the inductor is adding to the battery voltage and thereby opposing the change.

If we now cause a sudden increase in the voltage of the "battery" the current through the inductor will increase. This is a positive di/dt. Combined with the minus sign in equation 0.55 gives a negative result. The current is flowing to the right in the inductor. A negative voltage with respect to this current means that the voltage will be negative on the right as shown. For the period of time that the change of current is taking place, the inductor may be considered as a voltage generator. The "voltage generator" in the inductor which has its negative terminal on the right is subtracting from the voltage of the battery. Remember that this whole thing started with an increase in the battery voltage. The voltage being produced by the inductor is opposing the change.

The inductor only has a finite amount of energy stored in its magnetic field and it cannot maintain the voltage indefinitely. The inductor cannot prevent the change in current but it can slow it down.

Example 0.9.

A relay coil has an inductance of 95 millihenrys. A transistor switch turns off a current of 40 mA through the coil in a time of 1 us. What is the magnitude of the voltage spike which is produced?

Solution:

E = L di / dt = 95 mH x 40 mA / 1 us = 3800 volts.

Resistive-Inductive Circuits.

Figure 0.12 is the diagram of an inductive-resistive (RL) circuit. The switch is placed in position 1 to insure that there is no current in the circuit. When the switch is changed to position 2 the battery's potential is applied to the series RL circuit. For an infinitesimal instant of time, no current will flow in the circuit. The inductor has developed an emf of the polarity indicated in the figure. If the voltage across the battery and the inductor have the same magnitude and sign, Kirchhoff's law says that there is no voltage drop across the resistor. If there is no voltage across the resistor, there is no current through it. Because this is a series circuit, no current in the resistor means no current anywhere in the circuit. This situation cannot last for any finite length of time. Current begins to increase in the circuit but the change continues to be opposed by the inductor. The inductor ultimately loses the fight and the current becomes equal to E/R assuming that the inductor has zero resistance (a highly invalid assumption as it turns out).

Figure 0.12 Resistive-Inductive Circuit With Switch.

For a verbal description click here.

Now let us write Kirchhoff's equation for the circuit of Figure 0.12.

E = iR + L di / dt           (0.56)

The solution to this equation is

i = E / R (1 - e-tR/L)           (0.57)

This equation tells us that the current starts out as if the inductor were an open circuit. i0+ = 0. The current quickly rises to exponentially approach E/R.

The voltage across the inductor is

vL = E e-tR/L           (0.58)

Verification of equation 0.58 is left as an exercise for the student.

When t becomes equal to L/R the value of the exponent on e is -1. This point in time has been defined as the time constant of the circuit and is given as

T = L/R           (0.59)

where T is the time-constant in seconds, R is the resistance in ohms and L is the inductance in henrys.

After one time-constant the current has risen to 1 - 1/e of its initial value; after 2 time-constants the current has risen to 1 - e-2 of its initial value and so on. Theoretically the current will never reach the maximum value of E/R. After 5 time-constants the current will be 99.83% of E/r and for most practical purposes may be considered to be E/r.

The Reality of Inductors.

In the foregoing, inductance and resistance were treated as if they were separate components of the circuit. In practice, inductors always have resistance. Inductors are coils of wire. Wire has resistance. It is impossible to make an inductor which does not have any resistance.

For purposes of circuit analysis the inductance of a coil and its resistance are shown schematically as separate circuit elements. In the circuit of Figure 0.12 it is likely that the resistor and inductor which are shown actually represent a single coil of wire. Think of it as being roughly analogous to the X and Y components of a force.

Recent advances in superconductors may eventually make the preceding paragraphs unnecessary. However, at the present time, it is not possible to form superconducting materials into a wire and wind it into a coil. Note: That's still true in 2007.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

0.9 Problems.

  1. Two spheres are charged with +25 and +50 microcoulombs respectively. The distance between them is 20 meters. What is the force exerted between the two spheres? Is the force attractive or repulsive?

  2. Express the ampere in terms of kilograms, meters and seconds.

  3. If a current of 500 mA flows for 11 minutes, how much charge is moved?

  4. If a charge of 1026 coulombs was transferred at a constant rate in a time of 3 hours, what was the current?

  5. A current of 25 mA must be left on until a charge of 10,000 coulombs has been moved. How long must the current be left on? Express your answer in days, hours, minutes and seconds.

  6. Express the volt in terms of kilograms, meters and seconds.

  7. If 300 joules of work are done on 25 coulombs of charge, what was the potential through which the charge was moved?

  8. If 12 coulombs are moved through a potential of 120 volts, how much work was done?

  9. If 420 joules of work are done while moving a certain amount of charge through a potential difference of 28 volts, how much charge was moved?

  10. If 15 amperes are drawn from a 12 volt battery, what is the power?

  11. What is the current drawn by a 100 watt, 120 volt light bulb?

  12. For proper operation an electroplating cell requires the movement of 1.26 x 105 coulombs per hour. The cell voltage is 3.3 volts. How much power is required to keep the cell in continuous operation?

  13. Express the ohm in terms of kilograms, meters and seconds.

  14. A current of 55 mA is flowing through a 270 ohm resistor. What is the voltage drop across the resistor?

  15. When a potential of 12 volts is applied to an unknown resistor, a current of 24.74 mA flows. What is the resistance of the resistor?

  16. If a 56 ohm resistor is placed across a 15 volt power supply, how much current will flow?

  17. A resistor substitution box contains the following resistor values.

    First decade 15, 22, 33, 47, 68 and 100 ohms Second decade 150, 220, 330, 470, 680 and 1000 ohms

    Each successive decade follows the same pattern. The highest resistance is 10 Megohms. Each resistor can dissipate a maximum of 1 watt without burning out. (a) What is the minimum resistance setting which can be safely connected across the 120 volt power line?
    (b) What is the minimum resistance setting which can be safely connected across a 20 volt power supply?
    (c) What is the minimum resistance setting which can be safely connected across a 12 volt power supply?
    (d) What is the minimum resistance setting which can be safely connected across a 5 volt power supply?

  18. How much current can safely be run through; (a) a 39 ohm 1/2 watt resistor, (b) a 470 ohm 1/4 W resistor, (c) a 27 ohm 2 W resistor and (d) a 560 ohm 1 W resistor?

  19. In Figure 0.2, E = 6.60 volts, R1 = 33 ohms, R2 = 22 ohms and R3 = 11 ohms. How much current is flowing in the circuit?

  20. In Figure 0.2, E = 7.20 volts, R1 = 470 ohms, R2 = 220 ohms and R3 = 100 ohms. What is (a) the voltage across R1, (b) the voltage across R2 and (c) the voltage across R3?

  21. In Figure 0.2, R1 = 2.2 k ohms, R2 = 1.5 k ohms and R3 = 3.6 k ohms. If the voltage across R1 (V1) is 2.45 volts, what is the voltage across R3 (V3)?

  22. In Figure 0.2, E = 22.5 volts, R1 = 3.9 k ohms, R3 = 4.7 k ohms, V2 = 7.500 v and V3 = 8.198 v. What is the resistance of R2?

  23. In Figure 0.6, E = 6.60 volts, R1 = 33 ohms, R2 = 22 ohms and R3 = 11 ohms. How much current is flowing in the circuit?

  24. In Figure 0.6, the battery current I = 200 mA, R1 = 470 ohms, R2 = 220 ohms and R3 = 100 ohms. What is; (a) the current through R1, (b) the current through R2 and (c) the current through R3?

  25. In Figure 0.6, R1 = 2.2 k ohms, R2 = 1.5 k ohms and R3 = 3.6 k ohms. If I1 = 8.182 mA, what is I3?

  26. In Figure 0.6, I = 5.987 mA, R1 = 3.9 k ohms, R3 = 4.7 k ohms, I2 = 1.765 mA, and I3 = 1.915 mA. What is the resistance of R2?

  27. How much charge is stored on a 7000 uf capacitor when it is charged to a voltage of 18 volts?

  28. A circuit has a capacitance of 100 pf. How much current must the circuit deliver to the capacitor in order to change the voltage at a rate of 13 v/us?

  29. If a 2000 uf capacitor is being discharged with a current of 1 A, how much will its voltage change in 8 ms?

  30. In the circuit of Figure 0.10 if R = 1 Meg ohm, C = 1 uf and E = 10.0 v. The capacitor starts out fully discharged. How long after the switch is thrown to position 2 does the voltage across the capacitor reach 9.0 volts?

  31. A time delay circuit triggers when the voltage reaches 2/3 of the applied voltage. The capacitor always starts charging from 0 volts. It is desired that the circuit will trigger 1.5 seconds after the timing cycle begins. If the capacitor is a 0.1 uf, what value resistor is required in the circuit?

  32. Starting with equation 0.57 and using only Ohm's and Kirchhoff's laws show that the voltage across an inductor is given by vL = E e-tR/L.

  33. The current through a 50 millihenry inductor is to be changed from some value IL to zero in a time of 5 us. What must the value of IL be to give a 20 kv voltage spike?

  34. What is the time-constant of a coil which has 8 henrys of inductance and 40 ohms of resistance?

  35. A relay is a device which employs an electromagnet to close one or more sets of switch contacts. The switch contacts can carry a much larger current than is required to energize the electromagnet. The electromagnet is a coil of wire which has inductance and resistance. A given relay is taking too long to close its contacts in a particular application. It has been determined that the delay is not due to mechanical inertia of the moving parts but is due to the time- constant of the RL circuit of the coil. Discuss what may be done to shorten the time required for the relay to close. The relay itself may not be replaced or altered.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

0.10 Answers to problems.

  1. 3.125 Newtons repulsive.

  2. Coulombs = meters x Newtons-1 / seconds.

  3. 330 coulombs.

  4. 95 mA.

  5. 4 d: 15 h: 6 m: 40 s.

  6. Volts = Newton-1 x seconds

  7. 12 volts.

  8. 1440 Joules.

  9. 15 Coulombs.

  10. 180 watts.

  11. 0.833 Amps.

  12. 115.5 watts.

  13. ohms = seconds2 / meters

  14. 14.85 volts.

  15. 485 ohms.

  16. 268 mA.

  17. (a) 15 k ohms, (b) 470 ohms, (c) 150 ohms, (d) 15 ohms.

  18. (a) 113 mA, (b) 23.1 mA, (c) 272 mA, (d) 42.2 mA.

  19. 100 mA.

  20. (a) 4.28 volts, (b) 2.00 volts, (c) 0.911 volts.

  21. 4.01 volts.

  22. 4.30 k ohms.

  23. 1.10 Amps.

  24. (a) 25.5 mA, (b) 54.5 mA, (c) 120 mA.

  25. 5.00 mA.

  26. 5.10 k ohms.

  27. 0.126 Coulombs.

  28. 1.30 mA.

  29. 4.00 volts.

  30. 2.30 seconds.

  31. 13.6 Meg ohms.

  32. Beginning with the equation,
    i = E / R (1 - e-tR/L)

    The voltage across the resistor is obtained by multiplying the current by the resistance. Multiplying the equation by R gives,

    VR = E (1 - e-tR/L)

    By Kirchhoff's law,

    E = VR + VL

    Or

    VL = E - VR

    Subtracting E from the equation for VR
    VL = E - E (1 - e-tR/L)

    Removing the parentheses and carrying out the multiplication gives,

    VL = E - E + E e-tR/L

    So,

    VL = E e-tR/L

    QED.

  33. 2.00 Amps.

  34. 0.200 seconds.

  35. Place a resistor in series with the coil and increase the applied voltage to keep the current the same.


Chapter 1   DC Circuits.

1.1  Solving Complex Circuits Using Loop Equations.
1.2  Voltage Dividers.
1.3  Thevenin's Theorem.
1.4  Norton's Theorem.
1.5  Current Measurement, the D'Arsonval Meter.
1.6  Voltage Measurement.
1.7  Measurement Using Multimeters.
1.8  Problems.
1.9  Answers to Problems.

Chapter 1.

DC Circuits.

It may be said that after mastering the contents of chapter 0 we have in hand all of the tools we need to solve any electric network we are likely to encounter. While this is true, there are a great many shortcuts and additional theorems to be learned. It is not possible to cover all of these. We will cover a few of the most useful ones here.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

1.1 Solving Complex Circuits Using Loop Equations.

There is a theorem in network analysis which states that the total current flowing in any circuit element is the sum of the individual currents produced by each voltage source with all other sources removed and replaced by short circuits. This is called the superposition theorem. This theorem tells us that it is possible to solve for the individual components of current and add them together to obtain the total current.

We could remove the two sources, one at a time, from the circuit of Figure 1.1 and use circuit reduction to find the values of current being drawn, or injected into, each battery, but this is still an arduous method.

Instead we will consider that current flows round and round each loop and where two currents pass through the same resistor The actual current is the algebraic sum of the two. We assume a direction for the currents because we can't always figure out the current direction by inspection. We will sum the voltages around each loop of a circuit according to Kirchhoff's voltage law.

Voltage Rises and Drops.

The least confusing way to sum voltages around a loop is to give a rise a positive sign and a drop a negative sign. That's simple isn't it? Going up is positive, going down is negative. To sum voltages around a circuit you select a starting point, it doesn't matter where, and move around the circuit until you come back to the same point. If you travel across something from minus to plus you have traversed a rise. If you traverse from plus to minus it is a drop.

A battery is not automatically a rise. What matters is which way you walked across it. If you walk from plus to minus it is a drop. Similarly a resistor is not automatically a drop. If you move across it from minus to plus it is a rise. It depends on which way you go not whether it is a battery or a resistor.

Obviously assigning the plus and minus signs is key to solving a circuit. If the signs are wrong the answer will be wrong. First of all a battery is what it is. If current is flowing out of the battery, normal discharging, or into the battery, charging, the positive side is positive and the negative side is negative. That cannot change.

A resistor is a somewhat different story. The direction of current through the resistor determines the polarity of voltage across it. The current flows into the positive end and out of the negative end. This can be made clear with the simplest of all possible circuits.

Figure 1.0 Simple Circuit Showing Current Direction and Voltage Polarity.

For a verbal description click here.

Since there are only two elements in the circuit the voltage polarity is obvious by inspection. The current direction is also obvious. It flows out of the positive terminal of the battery, downward through the resistor and back to the battery. So you see that the end of the resistor where the current exits is the negative end. If you forget which way it goes you can recreate this drawing at any time or in any place and refresh your memory.

The current direction must be assumed in complex circuits but as long as consistent rules are followed the answer will be correct. If you assume wrongly the answer will have a negative sign attached but the magnitude will always be correct.

Loop Equations.

Figure 1.1 Circuit Containing Two Voltage Sources.

For a verbal description click here.

Consider the circuit of Figure 1.1. Instead of trying to solve for the voltage and current at each resistor we will take a somewhat different approach. Assume that the current in each loop follows a closed path as indicated by the arrows in Figure 1.1. The current I1 flows through E1, R1 and R2. The current I2 flows through R2, R3 and E2. The current in R1 is I1 while the current in R3 is I2. The current in R2 is the algebraic sum of I1 and I2.

We cannot tell by inspection which direction the current in each loop is flowing. You might say "obviously the current is flowing out of the positive terminal of each battery." You might be right, you might be wrong. Suppose that E1 is the power source in a battery charger and E2 is the battery which is being charged. In that case the directions indicated by the arrows would be correct. If E2 were the source and E1 were the battery being charged the true current directions would be opposite to those shown in the figure. The true current directions may or may not be as you would tend to assume by inspection. The point is, you cannot tell in advance what the directions of the currents will be. The usual procedure is to assume that all currents are clockwise. If the guess is wrong, the answer will come out with a minus sign attached and we will know that the true current is in the opposite direction.

There are two unknowns in the circuit, I1 and I2. The circuit will produce two equations. A circuit with three loops would produce three equations in three unknowns. In general then it can be said that a network with N loops will produce N equations in N unknowns.

It is assumed that the student at this level of study has already mastered at least one technique for solving systems of N by N equations. Solving systems of 3 by 3 or larger is a job best left to a computer program. We are here to learn techniques, not to get exercise from solving systems of N by N equations. For this reason the problems and examples in this text will not exceed systems of 2 by 2.

Writing the Equations.

To write the equations we sum the voltage rises around each loop. It does not matter that there are branches in and out of the loop. Kirchhoff's voltage law applies. In the circuit of Figure 1.1 the equations are written as follows.

E1 - R1 I1 - R2 I1 + R2 I2 = 0           (1.1)

- E2 - R3 I2 - R2 I2 + R2 I1 = 0           (1.2)

The polarity of the voltage sources is fixed and cannot change. The polarity of each resistor drop is marked inside of each loop. Moving in the direction of assumed current, E1 is a rise and therefore positive. The drops across R1 and R2 due to I1 are drops and therefore negative. The current in loop 2 has an influence on loop 1 and so we must include this in the equation. The term "R2 I2" reflects this influence. The term is positive because the voltage difference produced by I2 is a rise when moving in the direction of I1. In loop 2 (equation 1.2) the voltages due to I2 are all drops and therefore negative as is E2. The only positive term in equation 1.2 is the effect of I1 on loop 2.

It may seem as if there is some magic going on here. Each equation is just a statement of Kirchhoff's voltage law for that loop. The techniques for writing these equations were covered in chapter 0. If you do not understand how to write these equations, review section 0.3.

Assuming that the individual currents run in circles may be a little more difficult to understand. Intuition and visualization tell us that the currents really don't do that. However, this is a mathematical model. Mathematical models do not necessarily describe physical reality; they permit calculations to be made which will give the right answer.

Do not attempt to memorize equations 1.1 and 1.2. Learn how to write the equations from the circuit as it is given.

Example 1.1.

In the circuit of Figure 1.2, what is the voltage drop across R2?

Figure 1.2 Circuit Containing Two Voltage Sources.

For a verbal description click here.

Solution:

The equations are

12 - 330 I1 - 75 I1 + 75 I2 = 0

6 - 100 I2 - 75 I2 + 75 I1 = 0

Rearranging yields

- 405 I1 + 75 I2 = - 12

75 I1 - 175 I2 = - 6

Solving these equations simultaneously yields

I1 = 39.08 mA

I2 = 51.03 mA

These values are stated to 4 digits because they are intermediate values. Note that both have positive signs, which means that the assumed directions are correct. The question being asked is "What is the voltage across R2?" The current in R2 is made up of two components, 39.08 mA downward and 51.03 mA upward. If we define up as positive then

IR2 = - 39.08 mA + 51.03 mA = 11.95 mA

The current flows upward in R2; therefore, its upper end will be negative. The magnitude of the voltage is

V2 = I2 R2 = 11.95 mA x 75 ohms = 0.896 v

The answer is 0.896 volts upper end negative.

Understanding loop equations is very important. You may be thinking that this is just an exercise and you will never see this type of problem again. If you are thinking that, you are wrong. Problems and derivations in transistors and integrated circuits use these methods again and again. If you haven't mastered loop equations, go over this section until you do. If you go on without understanding loop equations, you will start to feel disoriented somewhere around chapter 3 and be totally lost by chapter 5. Don't say you weren't warned.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

1.2 Voltage Divider.

One application of the series circuit is known as the voltage divider. Voltage dividers are used to reduce voltages by some fixed factor. They also appear as parts of more complex circuits. The circuit of a simple voltage divider is shown in Figure 1.3.

Figure 1.3 Simple Voltage Divider.

For a verbal description click here.

The following is based on a voltage divider with no significant load. The output voltage is the voltage across R2. To find the voltage across R2 we need to find the current through it. The current through R2 is the same as the current anywhere else in the circuit. The current in the circuit is given by

I = E / (R1 + R2)           (1.3)

The voltage across R2 is given by

VO = I R2           (1.4)

Substituting equation 1.3 into equation 1.4 gives us the voltage divider equation

VO = E R2 / (R1 + R2)           (1.5)

This is one of the most often used equations in electricity and electronics. Although memorization is usually not recommended, make an exception for this one. Remember not only the equation but the procedure for obtaining it.

Often the input voltage to a voltage divider is not a battery E but sometimes a known voltage VIN. In this case the equation would be

VO = VIN R2 / (R1 + R2)           (1.6)

If the voltage divider has more than two resistors the equation is basically the same. The numerator is the sum of all of the resistors the output is taken across. The denominator is the sum of all resistors in the divider chain. An example will illustrate.

Example 1.2.

In Figure 1.4 if the VIN is 100 volts, what is the output voltage between common and; (a) 1, (b) 2, (c) 3, (d) 4, and (e) 5?

Figure 1.4 Voltage Divider.

For a verbal description click here.

Solution:

(a) When the output is taken from common and point 1, the output is connected to the input by wires. The output voltage is 100 volts.

(b)   VO = VIN (R2 + R3 + R4 + R5) / (R1 + R2 + R3 + R4 + R5)

VO = 100 v x 300 k ohms / 1000 k ohms = 30 v

(c)   VO = 100 v x 100 k ohms / 1000 k ohms = 10 v

(d)   VO = 100 v x 30 k ohms / 1000 k ohms = 3 v

(e)   VO = 100 v x 10 k ohms / 1000 k ohms = 1 v

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

1.3 Thevenin's Theorem.

The circuits we have studied so far have been self- contained. It may seem to you as if these circuits are of limited usefulness and you are right. The most useful circuits are those which have output terminals. A circuit which has output terminals can deliver electrical energy in various forms for use by other circuits. Figure 1.5 is the schematic diagram of a circuit which has output terminals.

Figure 1.5 Complex Network With Output Terminals.

For a verbal description click here.

Suppose that we wanted to find the current which would flow in a certain load resistance. Based on what we have learned to date the procedure would be to draw the load in the circuit and then solve the 3 by 3 system of equations for I3 which would be the current in the load. If it is necessary to solve for the current in a number of different loads, the system of equations must be solved as many times as there are loads. Enter Thevenin.

Thevenin's theorem states that any circuit no matter how complex may be replaced by a single voltage source in series with a single resistor as shown in Figure 1.6. The voltage source is equal to the open-circuit voltage of the complex circuit and the resistance is equal to the resistance looking in at the output terminals with all voltage sources replaced by short circuits.

Figure 1.6 Thevenin's Equivalent Circuit.

For a verbal description click here.

Finding the values for the voltage source and resistor involves solving the complex circuit only once. The original circuit and the Thevenin's circuit will act exactly the same for any load resistance. If you had each circuit sealed in separate black boxes which you could not open or x-ray, there would be no way to tell which was which. Let us work some examples to illustrate the application of the theorem.

Example 1.3.

Find Thevenin's equivalent circuit for the circuit of Figure 1.7. E1 = 30 v, E2 = 3.0 v, R1 = 240 ohms, R2 = 400 ohms, R3 = 350 ohms, R4 = 750 ohms, and R5 = 100 ohms.

Figure 1.7 Circuit For Example 1.3.

For a verbal description click here.

Solution:

In the circuit of Figure 1.7 if the output is open-circuited there will be no current in R5. I3 = 0. If there is no current in R5 there is no voltage drop across it. The output voltage is the same as the voltage across R4. This effectively reduces the problem from a 3 by 3 to a 2 by 2. The only unknowns are I1 and I2 and there are two loops to give us two equations.

E1 - R1 I1 - R2 I1 + R2 I2 = 0

E2 - R2 I2 - R3 I2 - R4 I2 + R2 I1 = 0

Substituting Values.

30 - 240 I1 - 400 I1 + 400 I2 = 0.

3 - 400 I2 - 350 I2 - 750 I2 + 400 I1 = 0.

Combining and rearranging.

-640 I1 + 400 I2 = - 30.

400 I1 - 1500 I2 = - 3.

We need to know I2 but don't care what I1 is. Multiplying the second equation by 1.6 gives.

-640 I1 + 400 I2 = - 30.

640 I1 - 2400 I2 = - 4.8.

Adding the two gives.

0 I1 - 2000 I2 = - 34.8.

I2 = - 34.8 / (- 2000) = 17.40 mA.

I2 is the only current flowing through R4 so.

VR4 = VTh = 17.40 mA x 750 ohms = 13.05 volts.

Now we must obtain the Thevenin resistance.

Figure 1.8 Figure 1.7 With Voltage Sources Removed and replaced by short circuits.

For a verbal description click here.

The Thevenin resistance is the resistance at the terminals with all voltage sources removed and replaced by short circuits. The method here is to start farthest from the terminals and start combining resistors. R1 and R2 are in parallel so.

R12 = R1 R2 / (R1 + R2) = 240 x 400 / (240 + 400) = 150 ohms.

R12 and R3 are in series so.

R123 = R12 + R3 = 150 + 350 = 500 ohms.

R123 is in parallel with R4 so.

R1234 = R123 R4 / (R123 + R4) = 300 ohms.

R1234 and R5 are in series so.

R12345 = RTh = R1234 + R5 = 400 ohms.

Figure 1.9 Thevenin's Equivalent Circuit of Figure 1.7

For a verbal description click here.

Example 1.4.

Use Thevenin's theorem to solve example 1.1. "In the circuit of Figure 1.2, what is the voltage drop across R2?"

Solution:

Because the voltage across R2 is what is wanted, we will treat R2 as a load resistor and remove it from the circuit. The result is shown in Figure 1.10.

Figure 1.10 Figure 1.2 With R2 Removed.

For a verbal description click here.

We will now write the loop equation around the outside loop to determine the current in the two resistors which are now simply in series.

12 - 330 I - 100 I + 6 = 0

18 = 430 I

I = 18 v / 430 ohms = 41.86 mA.

Now we will write the loop equation around the loop of the 12 volt battery, the 330 ohm resistor, and the load terminals. Don't be concerned that the load terminals are open. It is easily possible to have a voltage existing across an open circuit. The load voltage is what we want to know.

12 - 330 I - VL = 0

VL = 12 - 330 I = 12 - 13.814 = - 1.814 volts.

This is the Thevenin's voltage source for the equivalent circuit. If both voltage sources are replaced by short circuits the two resistors are in parallel with each other. The equivalent resistance is 76.74 ohms . This is the Thevenin's resistance for the circuit. Now we draw the Thevenin's circuit and connect R2 to it, Figure 1.11

Figure 1.11 Thevenin's Equivalent Circuit
With R2 Connected as a Load.

For a verbal description click here.

Now we apply the voltage divider equation to determine the voltage across R2.

VR2 = -1.814 v x 75 ohms / (75 ohms + 76.74 ohms) = -0.897 v

Maybe we should have carried 5 digits in our intermediate results. The error in the third decimal place is a result of using a finite number of significant digits, not any defect in either method of solution.

Thevenin's theorem can also be used on circuits so complex that they cannot easily be analyzed mathematically. An example is the function generator used in the laboratory. An electronics engineer could study the schematic diagram of the generator and calculate the Thevenin's resistance (also known as output resistance) of the generator. If the function generator had not yet been constructed a calculation would be the only way to find the Thevenin's resistance (or output resistance) of the generator.

Example 1.5.

When the function generator has no load connected, its output voltage is 7.87 volts. When a 100 ohm resistor is connected as a load the voltage is 5.20 volts. What is the output resistance of the function generator?

Solution:

The Thevenin's voltage source is always equal to the open-circuit output voltage of any Thevenin's circuit. Figure 1.12 shows the circuit with everything we know about it to date.

Figure 1.12 Thevenin's Equivalent Circuit
of a Function Generator

For a verbal description click here.

You could apply the voltage divider equation and solve it for the unknown resistor. But suppose that this is a test and you don't remember how to do that. The proper procedure is to put the best computer ever designed to work on the problem, the human mind. Kirchhoff's voltage law gives the voltage drop across the unknown resistor.

V? = VTh - VL = 7.87 - 5.20 = 2.67 v

Ohm's law gives the current through RL.

IL = VL / RL = 5.20 V / 100 ohms = 52.0 mA.

Kirchhoff's current law gives the current through the unknown.

I? = IL = 52.0 mA.

Ohm's law gives the resistance of the unknown.

R? = V? / I? = 2.67 v / 52.0 mA = 51.3 ohms.

The output resistance is 51.3 ohms.

Thevenin's theorem can be used: 1) to solve for the load conditions in circuits which have output terminals, 2) to simplify circuits by allowing a key resistor to be removed and 3) to find the output resistance of devices such as signal generators even when we do not know what is in the box. This is why it can be said that Thevenin's theorem is one of the most useful theorems in circuit analysis.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

1.4 Norton's Theorem.

The Ideal Current Source.

Before we look at ideal current sources let us look at what we know about ideal voltage sources. An ideal voltage source will maintain a constant voltage across its terminals regardless of the amount of current being drawn. The ideal voltage source will keep its voltage constant even if it has to deliver an infinite amount of current to do so. Do I hear someone saying "That's impossible!"? This is an ideal voltage source. In the ideal case, anything is possible.

An ideal voltage source delivers zero power when it is open-circuited. In the open-circuit case, the current is zero. If the current is zero, the power is zero.

We are accustomed to thinking of open-circuits as being a "zero power" condition and short-circuits as being damaging. In the real world any attempt to take anything to infinity is usually damaging to something.

Items we normally think of as voltage sources, such as batteries, are actually Thevenin's equivalent circuits with very low values of output resistance.

An ideal current source will maintain a constant current through its terminals regardless of the amount of voltage being delivered. The ideal current source will keep its current constant even if it has to deliver an infinite amount of voltage to do so. Do I hear someone saying "That's impossible!"? This is an ideal current source. In the ideal case, anything is possible.

An ideal current source delivers zero power when it is short-circuited. In the short-circuit case, the voltage is zero. If the voltage is zero, the power is zero.

We are NOT accustomed to thinking of short-circuits as being a "zero power" condition and open-circuits as being damaging. In the real world any attempt to take anything to infinity is usually damaging to something. An open-circuit current source will attempt to go to infinite voltage and that is an undesirable condition.

The Theorem.

Norton's theorem states that any circuit no matter how complex may be replaced by a single current source in parallel with a single resistor as shown in figure 1.13. The current source is equal to the short-circuit current of the complex circuit and the resistance is equal to the resistance looking in at the output terminals with all voltage sources replaced by short circuits and any current sources replaced by open circuits.

Figure 1.13 Norton's Equivalent Circuit.

For a verbal description click here.

Norton's theorem is not used as often as Thevenin's theorem but it can make short work of example 1.2. Pun fully intended.

Example 1.6.

Use Norton's theorem to solve example 1.2. "In the circuit of Figure 1.2, what is the voltage drop across R2?"

Solution:

Figure 1.14 shows the circuit with R2 removed and replaced by a short circuit. This completely isolates the two loops so they cannot affect one another.

Figure 1.14 Figure 1.2 with R2 Replaced by a Short.

For a verbal description click here.

The current due to the loop on the left is

I1 = 12 v / 330 ohms = 36.364 mA downward.

The current due to the loop on the right is.

I2 = 6 v / 100 ohms = 60.000 mA upward.

With up defined as positive, the current in the short is.

IS = 60.000 mA - 36.364 mA = 23.636 mA upward.

To make current flow upward in the load, current must flow out of the bottom terminal of the current source. The Norton's resistance is the same as the Thevenin's resistance, which is 76.744 ohms . Thus we have the circuit as shown in Figure 1.15 which shows R2 restored to the circuit.

Figure 1.15 Norton's Equivalent of Figure 1.2.

For a verbal description click here.

The current source delivers its 23.636 mA to the parallel combination of RN and R2. The voltage across R2 is the current source multiplied by the parallel combination of RN and R2.

VR2 = -23.636 mA / (1/75 + 1/76.744) = -0.897 v

Thevenin Meets Norton.

Example 1.7.

Find Thevenin's and Norton's equivalent circuits for the circuit of Figure 1.16.

Figure 1.16 Voltage Divider Circuit.

For a verbal description click here.

Solution:

The Thevenin voltage is the open-circuit output voltage of the circuit. This voltage is given by the voltage divider equation as follows.

VTh = 30 v x 1 k ohm / (1 k ohm + 2 k ohms) = 10 v

When the battery E is replaced by a short circuit, R1 and R2 are in parallel and their equivalent resistance is RTh = 666.7 ohms. The circuit would be that of Figure 1.9 except the values will be the ones calculated here. For Norton's theorem the current is equal to the short- circuit current of the original circuit. With a short on the output terminals, R2 is completely shorted out and the current is determined by R1 and the battery.

IN = 30 v / 2 k ohms = 15 mA

The Norton resistance RN is equal to the Thevenin resistance RTh.

If you place a short on a Thevenin's equivalent circuit the current will be given by

I = VTh / RTh           (1.7)

If you open-circuit a Norton's equivalent circuit the output voltage is given by

V = IN RN           (1.8)

The two circuits must behave exactly alike or one or both of the theorems would be invalid. In equation 1.7, the current I is the short-circuit current which is the same as the Norton's current source and, therefore, is IN. In equation 1.8, the voltage V is the open-circuit voltage which is the same as the Thevenin's voltage source. In reality then, the two equations are one which can be written as

RTh = RN = VTh / IN           (1.9)

If you have any two of these three quantities, you can find the other one. Depending on the circuit it may be easier to find the short-circuit current and the open-circuit voltage. You may want to do this even though you have not been asked to find Norton's equivalent circuit.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

1.5 Current Measurement, the D'Arsonval Meter.

The measurement of current is basic to many electrical measurements. For example the measurement of voltage is accomplished by setting up a circuit of known resistance, placing the unknown voltage across the circuit and measuring the current in the circuit. Other quantities (resistance for example) are converted to current for reading on a meter.

The D'Arsonval Meter Movement.

Figure 1.17 Diagram of a D'Arsonval Meter Movement.

For a verbal description click here.

A D'Arsonval meter movement consists of 4 basic parts. A permanent magnet, a coil of fine wire which is suspended so it can pivot, a pointer attached to the coil, and a scale for the pointer to point to. Figure 1.17 shows only the magnet and coil with its pivot and support. The circular object with a cutout at one point is the permanent magnet. The field is concentrated in the small circular cutout at the bottom. The red object is the coil of fine wire. The support is shown in green. The coil is supported by taught metal bands which provide spring tension to return the pointer to zero when no current is flowing through the coil. The pointer and scale have been omitted to avoid making the drawing too complicated to draw.

When a current is applied to the coil of wire, the magnetic field created by the current interacts with the field of the permanent magnet which causes a torque to be applied to the coil. The torque is opposed by the springs according to the equation

T = K Theta

where T is the torque, K is the spring constant and Theta is the angle of deflection. An equilibrium will be established at some given angle which is also the deflection of the pointer. If the current in the coil is doubled, the torque will be doubled and the angle of deflection will have to be doubled to establish a new equilibrium. The angle of deflection of the moving part of the meter is directly proportional to the current in the coil. A linear scale may be marked off and used to read current without any conversion graph.

Measuring Current.

The schematic symbol for a meter is a circle with one or more letters inside to indicate the quantity which the meter can measure. Occasionally the letter G for galvanometer or M for meter is used. A D'Arsonval meter measures the current which flows through its own coil. Thus, if we want to measure a current, we must allow that current to flow through the meter. Let us look at the circuit of a flashlight which was used in chapter 0 and is shown in Figure 1.18a. If we want to measure the current in this circuit we open the circuit and insert the meter as shown in Figure 1.18b. Because this is a simple series circuit, it makes no difference where the meter is inserted.

Figure 1.18 (a) Flashlight, (b) With Current Meter Inserted

For a verbal description click here.

If we desired to set up the circuit of Figure 1.2 to measure the currents we would have to be careful where the meters were inserted. If we want accurate measurements of I1 and I2 the meters must be inserted in places where only these currents are flowing. That is to say the branch containing R2 must not have one of the meters in it. A meter connected here would measure the algebraic sum of I1 and I2. Figure 1.19 shows how to connect the meters to measure I1 and I2. Since we do not know the directions of the currents the polarity of the meters will have to be determined experimentally. In other words if the pointer goes backward, reverse the connections to the meter.

Figure 1.19 Figure 1.2 With Current Meters Inserted.

For a verbal description click here.

Because current meters are connected in series with the circuits they are measuring, any voltage drop across the meter is lost to the circuit. The voltage drop across the meter must be kept small or inserting the meter will seriously disturb the circuit under test. By Ohm's law, to keep the voltage drop small, the resistance must be small. The typical resistance of a meter will cause a voltage drop of 100 mV (millivolts) when the meter is indicating full scale. That means that a typical meter which reads 1 ampere full-scale will have a resistance of R = 0.1 v / 1 A = 0.1 ohms.

An all-too-common student mistake is to connect an ammeter in parallel with a low resistance Thevenin source. If the above meter were to be connected across a 12 volt battery, how much current would flow through the meter?

I = 12 v / 0.1 ohms = 120 Amps.

A current of 120 amperes will virtually and instantly destroy a meter designed to read 1 ampere full-scale. When in the laboratory (or anywhere else for that matter), don't connect an ammeter or milliammeter across a power supply or battery.

Extending the Range of the Meter Movement.

Meter movements are most often sold in two common forms. One requires 50 uA (microamps) for full-scale deflection and the other requires 1 mA for full-scale deflection. These are sometimes referred to as 0-50 uA and 0-1 mA but most often are called 50 uA and 1 mA meters. Meters which come from the manufacturer with different full-scale currents are most likely one of the aforementioned types with one or two resistors added to extend the range to a higher current.

The process of adding a resistor to extend or increase the range of a meter is known as shunting the meter. The resistor which is added is called a shunt resistor. A meter with a shunt resistor connected is shown in Figure 1.20. The logical reasoning for determining the value of the shunt resistor is as follows.

Figure 1.20 Meter With Shunt Resistor Connected.

For a verbal description click here.

  1. The desired full-scale current I, the meter's full-scale current IM and the meter's resistance RM will be given.

  2. The voltage across the meter may be calculated by VM = IM RM (by Ohm's law).

  3. The voltage across the shunt resistor is the same as the meter voltage (by Kirchhoff's voltage law).

  4. The current in the shunt resistor is IS = I - IM (by Kirchhoff's current law).

  5. The value of the shunt resistor is RS = VM / IS (by Ohm's law).
For those who prefer them, the equation for this is

RS = IM / (I - IM)           (1.10)

Example 1.8.

A meter movement has a full-scale current of 50 uA and a resistance of 1800 ohms . Calculate the value of the shunt resistor to extend the range of the meter to 200 uA.

Solution:

The voltage drop across the meter is

VM = 50 uA x 1800 ohms = 90 mv

The voltage across the shunt resistor is also 90 mv. The current through the shunt resistor is

IS = 200 uA - 50 uA = 150 uA

The resistance of the shunt resistor is

RS = 90 mv / 150 uA = 600 ohms.

The Two Resistor Current Shunt.

The resistors which are used in meter circuits must be precise if the meter is to give precise readings. Precision resistors are often difficult for a person working in a physics lab to find. If a second resistor is added to the circuit as shown in Figure 1.21 the value of the shunt resistor may take on a higher value than the one indicated for the single resistor circuit.

Figure 1.21 Meter With Two Resistor Shunting Circuit.

For a verbal description click here.

The steps for using this circuit are as follows.

  1. Use the procedure (or equation 1.10) given above to determine the minimum value for the shunt resistor.

  2. Locate a resistor close to, but above, the calculated value.

  3. Calculate the voltage drop across this new shunt resistor by the equation VS = IS RS. The value of IS has not changed.

  4. Calculate the total resistance of the meter branch by RMT = VS / IM.

  5. Calculate the resistance of R1 by R1 = RMT - RM.
The equation is as follows.

R1 = RS (I - IM) - IM RM / IM           (1.11)

Example 1.9.

After working out the answer to example 1.8, you go to the stockroom and locate a 750 ohm precision resistor. Calculate the value of R1 in Figure 1.21 to permit the 750 ohm resistor to be used as the shunt.

Solution:

The voltage drop across RS is

VS = 150 uA x 750 ohms = 112.50 mv

The total resistance of the meter branch is

RMT = 112.50 mv / 50 uA = 2250.0 ohms

The value of R1 is given by

R1 = 2250 ohms - 1800 ohms = 450 ohms.

What happens if you cannot find a 450 ohm resistor? To be perfectly frank, the values used in this example are in a range of resistance in which precision resistors are easy to find. A precision resistance bridge may be used to select resistors from a stock of less precise resistors. Statistically, if you look through a large stock of 470 ohms 10% resistors you will find a 450 ohm resistor. It might have been just as easy to find a 600 ohms resistor. A better example is required.

Example 1.10.

A meter with a current of 1 mA has a resistance of 88 ohms . This meter is to be shunted to allow it to have a range of 0 to 1 ampere. The following precision shunts are available in the lab: 0.01 ohms , 0.1 ohms , 0.5 ohms and 1.0 ohms . How should the meter be shunted?

Solution:

Precision shunt resistors in values less than an ohm are difficult to find. We are restricted to what is available. First, assume the circuit of Figure 1.20 and use equation 1.10 to determine the minimum value for the shunt resistor.

RS = 1 mA x 88 ohms / (1 A - 1 mA) = 0.088088 ohms.

Among the available shunt resistors the 0.1 ohm is the next highest one from 0.088088 ohms. Use the 0.1 ohm shunt in the circuit of Figure 1.21. The value of R1 as given by equation 1.11 is as follows.

R1 = 0.1 ohm (1 A - 1 mA) - 1 mA x 88 ohms / 1 mA = 11.90 ohms.

An 11.9 ohm resistor can easily be found in a bin of 12 ohm resistors.

Ammeter Perturbation of a Circuit.

Figure 1.22 shows an ammeter being used to measure the current being drawn by some sort of load which is indicated as a resistor. When the ammeter is added into the circuit, its resistance adds to the resistance which is already there. If the resistance is changed, the current is changed, which means that the current we measure is not the same as the current was before the ammeter was put into the circuit. Is it possible to figure out what the current was before the ammeter was inserted? Let us list what we know and see what we can figure out.

Figure 1.22 Ammeter Connected to Measure
the Current Drawn by a Load

For a verbal description click here.

  1. We know the resistance of the ammeter, (RAM).

  2. We know the power supply or battery voltage, (E).

  3. We know the current, (I), being drawn by the series combination of the ammeter and the load. The ammeter is telling us that.

Using these knowns, what can we figure out?

  1. The voltage drop (VAM) across the ammeter. Multiply the ammeter reading (I) by the ammeter resistance (RAM).

  2. The voltage dropped across the load (VL). Subtract the ammeter voltage drop (VAM) from the power supply voltage (E).

  3. Load resistance (RL). Divide the voltage drop across the load (VL) by the ammeter reading (I).

  4. And finally the load current before the ammeter was inserted (IL). Divide the power supply voltage (E) by the load resistance (RL).

For those who prefer an equation, it is

IL = E / (E - I x RAM)           (1.12)

It is true that some loads are nonlinear, which means that the load resistance changes as the load voltage changes. (The load does not obey Ohm's law.) In most cases this second-order perturbation is small enough to be neglected.

Logical Check.

Remember that the insertion of an ammeter or milliammeter into a circuit will always reduce the current. The calculated load current IL must always be larger than the measured current I. If your calculated current is less than the measured current, the answer is wrong.

Example 1.11.

The 200 uA meter of example 1.8 is being used to measure the current in a load as in Figure 1.22. The power supply voltage is 5.00 volts and the meter is indicating 195 uA. What was the current in the circuit before the microammeter was inserted?

Solution:

First of all we need to calculate the resistance of the ammeter. It is the parallel combination of the 600 ohm shunt and the 1800 ohms of the meter movement. This works out to 450 ohms. The voltage drop across the microammeter is 195 uA x 450 ohms = 87.750 mv. The voltage left across the load is 5.0000 v - 87.75 mv = 4.91225 v. The resistance of the load is 4.91225 v / 195 uA = 25191 ohms. If this load were placed across 5.0000 v the current would be 5.0000 v / 25191 ohms = 198.5 uA.

Example 1.12

Calculate the percent error of the measurement in the above example.

Solution:

The calculated value of 198.5 uA is the standard of comparison or reference. The percent error is given by

% error = 100% x (Measured - Reference) / Reference           (1.13)

% error = 100% x (195 uA - 189.5 uA) / 198.5 uA = -1.76%

If we substitute equation 1.12 into equation 1.13 using I as the measured value and equation 1.12 as the reference value we eventually obtain

% error = 100% x (-I) x RAM / E           (1.14)

where I is the current measured by the meter, RAM is the resistance of the ammeter (milliammeter or microammeter) and E is the voltage of the power supply or battery. Another equation can be obtained by inverting ohms law.

I/E = 1/(RAM + RL)

which is

% error = 100% x (-RAM) / (RAM + RL)           (1.15)

if RL is known, this equation can be most useful.

Example 1.13

It is desired to measure the current to an accuracy of Plus or minus 2%. The meter has a full-scale range of 20 mA and has a voltage drop of 200 mv when reading full scale. The power supply voltage is 9.00 v and the meter reads 16.5 mA. Is this reading within plus or minus 2%?

Solution:

The meter resistance is 200 mv / 20 mA = 10 ohms. RL + RAM = 9.00 v / 16.5 mA = 545 ohms. RL = 545 ohms - 10 ohms = 535 ohms. Using equation 1.15 we have

% error = 100% x (-10 ohms) / (10 ohms + 535 ohms) = -1.83%

The measurement is of acceptable accuracy.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

1.6 Voltage Measurement.

Connecting a Voltmeter Into a Circuit.

Voltage is the electrical potential difference between two points in a circuit. If it is desired to measure the potential difference between point A and point B in a circuit, the meter must be connected between points A and B. That is one lead to point A and the other lead to point B. To measure the voltage of a battery, the voltmeter is simply connected in parallel with the battery. A voltmeter is never connected in series with a circuit. Ammeters are connected in series, voltmeters are connected in parallel.

The Voltmeter Circuit.

The D'Arsonval meter is a current measuring device. As example calculations have shown its voltage drop is typically 0.1 volts. Still, it is possible to use such a meter to measure voltages over a wide range.

What is required is a circuit in which a current will flow which is proportional to the unknown voltage. The D'Arsonval meter can be used to measure the current in this circuit. Ohm's law states that I = E / R. A resistor is all that is required to cause a current to flow which is proportional to the voltage. A voltmeter circuit is shown in Figure 1.

Figure 1.23 Circuit Diagram of a Voltmeter.

For a verbal description click here.

The total resistance in the circuit is such that the full-scale current of the meter will flow when the desired full-scale voltage is applied to the circuit. The total resistance is RV + RM; therefore, an equation may be written

RV + RM = VV / IM           (1.16)

where VV is the full-scale voltage of the voltmeter, IM is the full-scale current of the meter movement, RM is the resistance of the meter movement and RV is the resistance of the multiplier resistor. The multiplier resistance is given by the following equation.

RV = VV / IM - RM           (1.17)

Example 1.14.

Find the value of the multiplier resistor to convert a 50 uA meter into a voltmeter having a full-scale voltage of 5 volts. The resistance of the meter movement is 1800 ohms.

Solution:

The total resistance of the meter circuit is

RT = 5.00 v / 50.0 uA = 100 k ohms.

The multiplier resistor is

RV = RT - RM = 100 k ohms - 1.8 k ohms = 98.2 k ohms.

Ohms Per Volt.

Figure 1.24 is the diagram of the voltmeter of example 1.14 with an addition. It is desired to temporarily convert the 5 volt meter of example 1.14 into a 6 volt meter. As you can see in figure 1.24, this will be accomplished by adding another resistor to the circuit.

Example 1.15.

Calculate the value of RV in Figure 1.24.

Solution:

The total resistance RT = 6 v / 50 uA = 120 k ohms. But we already have 100 k ohms of resistance in the circuit. So we have RT = RV + 1.8 k ohms + 98.2 k ohms. Therefore, RV = 120 k ohms -100 k ohms = 20 k ohms.

Figure 1.24 5 volt meter with a resistor added to convert it to a 6 volt meter.

For a verbal description click here.

Example 1.16.

Calculate RV to extend the range of a 5 volt meter to 10 volts full-scale.

Solution:

The total resistance RT = 10 v / 50 uA = 200 k ohms. So we have RT = RV + 1.8 k ohms + 98.2 k ohms. Therefore, RV = 200 k ohms - 100 k ohms = 100 k ohms.

Notice in examples 1.15 and 1.16 that for every volt of range extension, we must add 20,000 ohms. In example 1.15 we added 1 volt of range and to do so we added 20,000 ohms. In example 1.16 we added 5 volts of range and to do so we added 5 x 20,000 ohms or 100 kilohms.

The number 20,000 is not standard for all voltmeters but is dependent on the current of the meter movement being used. The amount of resistance to be added for each additional volt of range is given by

RAdded = 1 v / IM

This is called the sensitivity of a voltmeter and is given as

S = 1 v / IM           (1.18)

The sensitivity of a voltmeter is a figure of merit which may be used to judge the relative quality of various voltmeters. The higher the number, the better the voltmeter.

Example 1.17.

Calculate the sensitivity of a voltmeter which used a 500 uA meter movement.

Solution:

The sensitivity is

S = 1 v / 500 uA = 2,000 ohms/volt.

Voltmeter Perturbation of a Circuit.

Figure 1.25 shows a voltmeter being used to measure the output voltage of a Thevenin's circuit (voltage source and resistor). If the voltmeter resistance is too low in comparison to the Thevenin resistance, the voltmeter will perturb the circuit by a significant amount and the reading will be in error.

It is possible to determine the voltage of the Thevenin generator (voltage source) if we can determine the value of the Thevenin resistance. This can be done in many cases. Let us now list the things we know and see what we can figure out.

  1. We know the resistance of the voltmeter (RVM).

  2. We know the voltage drop across the voltmeter (VVM). The voltmeter itself is telling us that.

  3. We know the Thevenin resistance (RTh) of the circuit whose voltage we are trying to measure.

Figure 1.25 Voltmeter Measuring Output of Thevenin's Equivalent Circuit.

For a verbal description click here.

The microammeter and its series resistor are included in the circle with a V in the center.

We can now calculate the following.

  1. The voltmeter current (IVM). Divide the voltmeter reading (VVM) by the voltmeter resistance (RVM).

  2. The current flowing through the Thevenin resistance. It is the same as the current through the voltmeter.

  3. The voltage drop across the Thevenin resistance (VRTh). Multiply the current from 2 above (IVM) by the Thevenin resistance (RTh).

  4. And finally, the voltage before the voltmeter was connected (VTh). Add the voltage drop across the Thevenin resistance (VRTh) to the voltmeter reading (VVM).

For those who prefer an equation, it is

VTh = VVM (RVM + RTh) / RVM           (1.19)

Logical Check.

Remember that the connection of a voltmeter to a circuit will always reduce the voltage. The calculated voltage VTh must always be larger than the measured voltage VVM. If your calculated voltage is less than the measured voltage, the answer is wrong.

Example 1.18.

A meter with a full-scale voltage of 10 volts and a sensitivity of 10,000 ohms /v is being used to measure the voltage of a Thevenin's equivalent circuit as shown in Figure 1.25. The Thevenin's resistance is 10 k ohms . The meter reads 9.25 volts. What is the voltage of the Thevenin's voltage source?

Solution:

The resistance of the voltmeter is RVM = 10 v x 10 k ohms/v= 100 k ohms. The current in the voltmeter is IVM = 9.25 v / 100 k ohms = 92.5 uA. The drop across the Thevenin's resistor is VRTh = 92.5 uA x 10 k ohms = 0.925 v. The Thevenin's voltage source is 9.25 v + 0.925 v = 10.175 v.

Example 1.19.

Calculate the percent error of the measurement in the above example.

Solution:

The calculated value of 10.175 v is the standard of comparison or reference. The percent error is given by equation 1.13 as follows.

% error = 100% x (9.25 v - 10.175 v) / 10.175 v = -9.09%.

If we substitute equation 1.19 into equation 1.13 using VVM as the measured value and equation 1.19 as the reference value we eventually obtain

% error = 100% x (-RTh) / (RTh + RVM)           (1.20)

where RTh is the Thevenin's resistance of the circuit being tested and RVM is the resistance of the voltmeter.

Example 1.20.

Use equation 1.20 to verify the results of example 1.19.

Solution:

Using equation 1.20 gives

% error = 100% x (-10 k ohms) / (10 k ohms + 100 k ohms) = -9.09%.

The result is verified as correct.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

1.7 Measurement Using Multimeters.

A multimeter (pronounced multi-meter) is an instrument which is capable of measuring more than one electrical quantity. The usual multimeter is capable of measuring voltage, current and resistance. Such meters are also known as volt-ohm-milliammeters or VOMs for short.

The analog multimeter (or VOM) is exemplified by the Simpson 260 which is used in the laboratory. This instrument consists of a D'Arsonval meter movement, two switches, several resistors and two diodes.

The VOM has full-scale voltage ranges from 2.5 volts to 1000 volts. The voltmeter circuit is exactly like the one studied in this chapter. To determine the input resistance of the voltmeter on any range, multiply the sensitivity by the setting of the range switch. The voltage being indicated does not affect the input resistance. The sensitivity of the Simpson VOM is 20,000 ohms per volt on DC and 5,000 ohms per volt on AC. The two diodes are used to change the AC to DC because the D'Arsonval meter will only respond to direct current.

The ammeter portion of the VOM has current ranges from 50 microamperes to 10 amperes and works only on DC. It employs a rather complex shunting arrangement which prevents the resistance of the switch contacts from affecting the accuracy of the reading. It is felt that the student would profit little from a detailed study of this shunting circuit.

The resistance or ohmmeter section of the VOM employs a battery to energize the circuit. The battery applies a known voltage to the unknown resistor and the meter measures the current which flows. The meter face incorporates a scale for reading resistance so that no calculation is necessary. Because I = V / R the scale is highly compressed at high resistance values.

The Electronic Multimeter.

Electronic multimeters most often have a digital readout instead of a D'Arsonval meter movement. The digital readout gives better accuracy than an analog meter. If the voltage being measured has some noise on it, its value is varying slightly in a random manner, a digital meter may give confused and jumpy readings.

The thing which all electronic multimeters have in common is a complex electronic circuit which will convert a voltage into an indication on the readout device. This circuit will be studied later in this book but for now it will be treated as a mysterious black box.

The basic measurement circuit of a digital multimeter is a voltmeter which will measure from 0 to 200 millivolts. The readout is from 000.0 mv to 199.9 mv. This is called a 3 and 1/2 digit readout. The most significant digit can only be 0 or 1 and this is called a 1/2 digit. The DMMs (digital multimeters) we are using in our lab are 4-1/2 digit models which means that the basic range is from 000.00 mv to 199.99 mv. To save time and space this basic range will be referred to as a 0 to 200 mv range.

The voltmeter section of a DMM uses a voltage divider similar to that of Figure 1.4. The resistance values are R1 = 9 Meg ohms, R2 = 900 k ohms, R3 = 90 k ohms, R4 = 9 k ohms, and R5 = 1 k ohms. The input resistance of the basic measuring circuit must be very high, in excess of 10 G ohms . The unknown voltage is connected to the VIN terminals in Figure 1.4 and the measuring circuit is connected between common and one of the connection points. The voltage range selector switch is what connects the measuring circuit to the selected tap on the voltage divider. Some DMMs are auto-ranging, which means that a small microprocessor will select the proper range for the voltage which is being applied to the meter. The voltage ranges work on AC or DC. The input resistance is always 10 Meg ohms on any range on AC or DC.

For current measurements the basic measuring circuit is connected in parallel with a low-value shunt resistor. For example, if a 1 ohm resistor is used as the shunt, a current of 200 mA will cause a voltage drop of 200 mv; thus a 1 ohms shunt will provide a current range of 0 to 200 mA. To change current ranges a new shunt resistor is switched in. The current ranges work on AC or DC.

The resistance measurement circuit consists of a constant current source and the basic measuring circuit. A known current is made to flow through the unknown resistor and the resultant voltage drop is measured by the measuring circuit. For example, if a current of 100 uA flows through a 2 k ohm resistor the voltage is 200 mv; thus a current of 100 uA will give a resistance range of 0 to 2 k ohms . To change ranges the magnitude of the current is changed.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

1.8 Problems.

  1. In the circuit of figure 1.1 the values are as follows. E1 = 15 v, E2 = 12 v, R1 = 1 k ohm, R2 = 500 ohms, and R3 = 1.2 k ohms. What are the values of (a) I1, (b) I2, and (c) the voltage drop across R2? (d) Is the battery at E2 being charged or discharged?

  2. In the circuit of Figure 1.3 R1 = 50 ohms, and R2 = 120 ohms. If E = 6.6 v, what is the output voltage?

  3. In the circuit of Figure 1.4 the values are as follows. R1 = 6.8 Meg ohms, R2 = 2.2 Meg ohms, R3 = 680 k ohms, R4 = 220 k ohms, and R5 = 91 k ohms. (a) What is the total resistance of the divider? If 100 volts are applied at VIN what is the output voltage between common and (b) point 1, (c) point 2, (d) point 3, (e) point 4, and (f) point 5?

  4. In the circuit of Figure 1.3 if R2 = 3.3 k ohms, what should the resistance of R1 be for the output voltage to be one third of E?

  5. In the circuit of Figure 1.3 R1 = 5.6 k ohms, and R2 = 3.3 k ohms. What must the input voltage (E) be to give an output voltage of 6.1 volts?

  6. Apply Thevenin's theorem to solve problem 1. What is the voltage across R2?

  7. In the circuit of Figure 1.4 use the values given in the figure. Calculate the Thevenin's resistance if the output is between common and (a) point 1, (b) point 2, (c) point 3, (d) point 4 and (e) point 5.

  8. A signal generator has an open-circuit output voltage of 8.00 volts. When a 1 k ohm resistor is connected across the output terminals, the voltage is 5.00 v. Find Thevenin's equivalent circuit for this generator. Draw the circuit!

  9. Apply Norton's theorem to solve problem 1. What is the voltage across R2?

  10. In the circuit of Figure 1.4 use the values given in the figure. Calculate the Norton's resistance if the output is between common and (a) point 1, (b) point 2, (c) point 3, (d) point 4 and (e) point 5.

  11. A signal generator has an open-circuit output voltage of 8.00 volts. When a 1 k ohm resistor is connected across the output terminals, the voltage is 5.00 v. Find Norton's equivalent circuit for this generator. Draw the circuit!

  12. A D'Arsonval meter movement has a resistance of 1653 ohms and a full-scale current of 100 uA. Calculate the value of a single shunt resistor to make a 1 mA meter. Draw the circuit!

  13. The meter movement from problem 12 is to be used in a two-resistor shunting circuit to make a 1 mA meter. The shunt resistor has the value 219.4 ohms. What is the required value of R1? Draw the circuit!

  14. A milliammeter which has a full-scale current of 10 mA has a voltage drop of 250 mv when it is indicating full scale. When the meter is connected into a circuit where the voltage source is 6.00 v the meter reads 7.75 mA. (a) What was the current in the circuit before the meter was inserted? (b) What is the percent error of the measurement?

  15. A D'Arsonval meter movement has a resistance of 1653 ohms and a full-scale current of 100 uA. Calculate the value of the multiplier resistor to make a 1 v meter. Draw the circuit!

  16. What is the sensitivity of a voltmeter which employs a meter movement having a full-scale current of 25 uA?

    Figure 1.26 Circuit of a 5-range Voltmeter.

    For a verbal description click here.

  17. The circuit of Figure 1.26 is of a 5-range voltmeter. As the range switch is changed from range to range, the arrowhead moves from one circle to another. As the circuit is drawn the meter is set to the 10 volt range. The switch may be set to any range, it just happens to be shown on the 10 volt range. The meter movement has a resistance of 4476 ohms and a full-scale current of 25 uA. Calculate the resistances of (a) R1, (b) R2, (c) R3, (d) R4, and (e) R5, for the voltage ranges shown. Do not jump to conclusions, look carefully at the circuit. It may be helpful to redraw the circuit with the switch set to the voltage range you are currently working on.

  18. A digital voltmeter which has an input resistance of 10 Meg ohms is being used to measure the voltage on a circuit which has a Thevenin's resistance of 470 k ohms. (a) What will be the percent error of the measurement? (b) If the indicated voltage is 8.523 volts, what was the voltage before the meter was connected to the circuit?

  19. A 5,000 ohm-per-volt VOM is being used to make a measurement on a given circuit. The Thevenin's voltage and resistance of the circuit are unknown. When the meter is set to the 2.5 volt range it indicates 2.22 volts and when it is set to the 10 volt range it indicates 3.33 volts. (a) What are the Thevenin's voltage and resistance of the circuit? (b) What was the voltage before the meter was connected? Hint: try two equations in two unknowns. This is a situation that users of VOMs encounter regularly.

  20. A digital multimeter has a basic range of 2 volts (1.999 volts). What is the resistance of a current shunt to provide a range of 0 to 20 uA?

  21. A digital multimeter has a basic range of 2 volts (1.999 volts). When this meter is set to the 200 ohms resistance range, how much current is flowing through the unknown?

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

1.9 Answers to Problems.

  1. (a) I1 = 8.4783 mA, (b) I2 = -4.5652 mA, (c) V = 6.522 v upper end positive, (d) E2 is being discharged.

  2. V = 4.659 v.

  3. (a) R = 9.991 Meg ohms, (b) V = 100 v, (c) V = 31.94 v, (d) V = 9.919 v, (e) V = 3.113 v, (f) V = 0.9108 v.

  4. R1 = 6.6 k ohms.

  5. E = 16.45 v.

  6. VTh = 13.63634 v, RTh = 545.455 ohms, VR2 = 6.522 v.

  7. (a) RTh = 0, (b) = 210 k ohms, (c) = 90 k ohms, (d) = 29.1 k ohms, (e) = 9.9 k ohms.

  8. VTh = 8.00 volts, RTh = 600 ohms, Figure 1.6 with these values.

  9. I1 = 15 mA, I2 = 10 mA. By inspection I1 is clockwise and I2 is counter clockwise. IN = 25 mA downward through the short. RN = 545.455 ohms. VR2 = 6.522 volts.

  10. (a) RN = 0, (b) = 210 k ohms, (c) = 90 k ohms, (d) = 29.1 k ohms, (e) = 9.9 k ohms.

  11. IN = 13.33 mA, RN = 600 ohms, Figure 1.13 with these values.

  12. RS = 183.7 ohms. Figure 1.20.

  13. R1 = 321.6 ohms. Figure 1.21.

  14. I = 8.009 mA, % error = -3.23%.

  15. RV = 8,347 ohms. Figure 1.23.

  16. S = 40,000 ohms / volt.

  17. (a) R1 = 35,524 ohms, (b) R2 = 60,000 ohms, (c) R3 = 300,000 ohms, (d) R4 = 1,600,000 ohms, (e) R5 = 8,000,000 ohms.

  18. (a) % error = 4.49%, (b) V = 8.924 volts.

  19. (a) VTh = 3.996 volts, RTh = 10 k ohms. (b) V = 3.996 volts.

  20. R = 100 k ohms.

  21. I = 10 mA.


Electronics for non-engineers

Chapter 2   AC Circuits.

2.1  Alternating Current.
2.2  Capacitive Reactance.
2.3  Inductive Reactance.
2.4  Series Circuits and Impedance.
2.5  RC Filter Circuits.
2.6  The Decibel (dB).
2.7  Graphing Frequency Response.
2.8  Nonsinusoidal Waves.
2.9  The Effect of RC Circuits on Nonsinusoidal Waves.
2.10 RLC Resonate Circuits.
2.11 Transformers.
2.12 The Oscilloscope.
2.13 Problems.
2.14 Answers to Problems.

Chapter 2.

AC Circuits.

To date, we have dealt with sources of electrical energy which deliver direct current. DC flows continuously in one direction. The electrical world in which we live is one of alternating current (AC). The current supplied by the electric utility, audio signals, radio and television signals are all AC.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

2.1 Alternating Current.

Alternating current reverses its direction on a regular time schedule. The current flows for a certain period of time, then reverses and flows for the same amount of time and then reverses again. There is no net movement of electrons in a wire carrying AC; the electrons simply vibrate in place.

The Cycle.

A cycle is defined as follows. The current rises from zero to a positive maximum, falls back to zero and "rises" to a negative "maximum" and then returns to zero. This definition of a cycle applies to current or voltage. For a cycle of voltage simply substitute the word "voltage" for "current" in the above definition.

If we plot a number of cycles on a graph (with current on the Y axis and time on the X axis) the plot will resemble the waves on the surface of a body of water. It is not considered correct usage to call a cycle a wave but even people with many years of experience sometimes get careless. It is considered correct usage to use the term waveform when referring to the shape of the graph of a cycle.

Notice that the definition of a cycle says nothing about the shape of the rises and falls. The cycle shape or waveform which is most often encountered is the sine wave. This waveform follows the sine function y = sin(x). Figure 2.1a shows two cycles of a sine wave alternating current. Figure 2.1b shows a square wave, 2.1c a triangular wave and 2.1d a sawtooth wave. There are an infinite number of different waveforms. The shape depends on what is generating them and what their use will be.

Figure 2.1 Four Different Waveforms.

For a verbal description click here.

Period and Frequency.

The period of an alternating current is the time required to complete one cycle. The frequency of an alternating current is the number of cycles which occur each second. The period is measured in units of time such as seconds, milliseconds or microseconds. The frequency has units of cycles/second or 1/time (a cycle is not a true unit, it is considered to be dimensionless.) The unit of frequency is called the hertz. Frequency may be given in hertz, kilohertz, megahertz or gigahertz.

The relationship between period and frequency is

P = 1 / f           (2.1)

where P is the period in seconds and f is the frequency in hertz.

Example 2.1.

What is the period of the 60 hertz line frequency?

Solution:

P = 1/f = 1/60 = 1.67 x 10-2 seconds or 16.7 ms.

Wavelength and Frequency.

The only time that the term "wave" may be applied to an alternating current is when the current has been converted into a periodic disturbance which propagates through some medium. For example a loudspeaker converts AC of appropriate frequency into sound waves which propagate through the air. For another example, if AC of an appropriate frequency flows in a structure known as an antenna, electromagnetic waves will be radiated which will propagate through air, or the vacuum of space.

When waves propagate through a physical medium, the wave has a physical length. The wavelength is given by

lambda = v / f           (2.2)

where lambda is the wavelength in meters, v is the velocity of propagation in meters per second and f is the frequency in hertz. The speed of sound in air is approximately 335 meters per second and the speed of electromagnetic waves is 3 x 108 meters per second.

Example 2.2.

A sound wave in air has a wavelength of 12 cm. What is its frequency?

Solution:

Using the speed of sound we have that

f = 335 / 0.12 = 2790 Hz.

Example 2.3.

A radio station is transmitting on a frequency of 88.9 MHz (megahertz). What is the wavelength of the electro- magnetic wave being transmitted?

Solution:

Using the speed of light we have

lambda = 3 x 108 / 88.9 x 106 = 3.37 m

Angular Frequency.

When working through calculations involving AC it is often necessary for the frequency to appear in the argument of a sine or cosine function. A particular point on a waveform can be found by multiplying the frequency by the amount of time which has passed since the waveform has started. This would be all right if cycles were the only thing we had to deal with. The arguments of sines and cosines must be in angles, not in cycles.

One cycle consists of 360 degrees or 2 pi radians. The symbol for the angular frequency is usually a small omega but we will use a "w". The angular frequency is given by

w = 2 pi f           (2.3)

where w is the angular frequency in radians per second and f is the frequency in hertz (cycles per second). A current can be expressed by the equation

i = I sin( 2 pi f t )           (2.4)

where i is the current at any instant of time, I is the peak current, f is the frequency of the current in hertz and t is time in seconds. If f = 1 hertz then during the passage of one second the argument of the sine function will run through 2 pi radians and the sine function will execute one cycle in accordance with the definition of a cycle given above.

Magnitude Measurement of AC.

An alternating current may be represented by equation 2.4. The peak value of the current is "I" and the peak-to- peak value is 2I. The peak and peak-to-peak values are the most obvious and easiest to measure, which is probably why they are not the most often used.

The most useful measure of AC is a value which gives the same power dissipation in a resistor as a direct current. Suppose that a DC current of 3 amperes is flowing through a 1 ohm resistor. The power will be 9 watts. If an AC current of 3 amperes peak flows through a 1 ohm resistor, the power is not the same as for the DC. We require a measure which will give the same power as a DC of the same magnitude.

Because we are discussing power, that is the key. Remember that power is given by

P = I2 R           (2.5)

When a resistor is being heated, the average power is what is affecting the heating. To find the measure of current we must square the current, average it over time and then take the square root. The last step is necessary so that the new measure will be proportional to the peak current, not to the square of the current. The new measure of current is called the root-mean-square which is abbreviated RMS.

The RMS value of a current is given by

I RMS = square root of 1 over 2 pi times the integral from 0 to 2 pi of I squared of t, d t.

Substituting equation 2.4 into equation 2.6 we have

I RMS = square root of 1 over 2 pi times the integral from 0 to 2 pi of I squared sine squared of t, d t.

We don't know how to integrate the sine squared function but there is a way to change it to something we can integrate. We must make the trigonometric substitution

Sin2(t) = 1/2 ( 1 - cos( 2t ))

Making this substitution and bringing I2 and 1/4 outside of the radical gives

I RMS = I over 2 times the square root of 1 over pi times the integral from 0 to 2 pi of 1 minus cosine of 2t.

The integral of the cosine over an integer number of cycles is zero; therefore,

I RMS = I over 2 times the square root of 1 over pi times the quantity 2 pi minus 0.

The end result of all of this is

I RMS = I over the square root of 2. Equation 2.7.

This is another one of those things you must remember. Conversions between RMS and peak, RMS and peak-to-peak, and peak and peak-to-peak are routine in electronics. The conversion applies to voltage as well as current.

Example 2.4.

Convert a peak current of 3 amperes to RMS.

Solution:

IRMS = I / square root of 2 = 3 / 1.4142 = 2.12 A

Example 2.5.

Convert 6.3 v RMS to peak.

Solution:

VP = VRMS x square root of 2 = 6.3 x 1.4142 = 8.91 v

The use of the RMS measure is so common in AC measurement that all quantities are RMS unless otherwise specified. If a specification gives a voltage as 117 vAC the meaning is 117 volts alternating current RMS (root-mean- square). The rule is: a voltage or current is RMS unless otherwise noted.

Logical Check.

The RMS value is always less than the peak value. RMS is a kind of average and an average will ALWAYS be less than the maximum. Similarly, the peak to peak value is greater than the peak value.

The Average.

One more AC measurement is worth mentioning. It is the average value. If an AC flows through a D'Arsonval meter movement the pointer will first be urged in one direction and then in the other. Most AC is of such a frequency that the meter's pointer cannot respond to either urging and the pointer does not move. If a rectifier is used to take the absolute value of the sine function, the meter will be able to respond to the unidirectional current in spite of the fact that it is changing with time. The meter will respond to, and indicate, the average value of the sine wave current.

If we averaged the sine function over one full cycle we would get zero. To obtain the average value of the absolute value of the sine it is sufficient to average it over one- half cycle.

I sub eh V = one over pi times the integral from 0 to pi of sine of t, d t.

A few turns of the crank gives

IAV = I x 0.63662           (2.9)

Most AC meters respond to average but are calibrated in terms of RMS. These meters work fine as long as the current or voltage being measured is a sine wave. If the input is not a sine wave the meter will not read the RMS but will read the average value times 0.70711 / 0.63662.

Use and Misuse.

The term AC is often used in ways which seem to be redundant or even contradictory. For example you might read "... the AC current ..." or "... the AC voltage ..." or even "... the AC power ...". Remember that the letters AC stand for alternating current. The first example is redundant, "alternating current current". The next two are contradictory. In spite of the redundant or contradictory nature of these terms they are used by most electrical and electronics engineers and technicians. The usage is too pervasive to be avoided even in formal writing. The writer will not make a rigorous attempt to exclude these terms from this book.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

2.2 Capacitive Reactance.

Early researchers in electricity may have been surprised to find that AC would flow through a capacitor. After all, a capacitor is an open circuit, isn't it? Experiments on capacitors show that as more AC voltage is applied more current will flow. If the frequency is increased without changing the voltage the current will increase. It can also be shown experimentally that the current in a capacitor leads the voltage by 90 degrees or 1/4 of a cycle. The way in which a capacitor reacts to AC is called the capacitive reactance.

Let us apply a voltage to a capacitor and see what happens. The voltage is v = V sin( 2 pi f t ). We will use equation 0.41 which is restated here as equation 2.10.

i = C dv / dt           (2.10)

If we insert our definition of voltage into equation 2.10 we have

i = CV d / dt sin ( 2 pi f t )

Performing the differentiation gives.

i = C V 2 pi f cos( 2 pi f t )

If we say that the current is i = I cos( 2 pi f t ) we have that

I = C V 2 pi f

solving for V/I gives.

V / I = 1 / ( 2 pi f C )

If you are awake you will recognize V / I as having the units of ohms. We now have a new quantity which in some ways is like resistance but in other ways is unlike resistance. We call this quantity the capacitive reactance and give it the symbol XC.

XC = 1 / ( 2 pi f C )           (2.11)

where XC is the capacitive reactance in ohms, f is the frequency in hertz and C is the capacitance in farads.

We applied a sine wave voltage and a cosine wave current resulted. The cosine leads the sine by 90 degrees and so the current in a capacitor leads the voltage by 90 degrees.

Example 2.6.

At what frequency will a .0039 uf capacitor have a reactance of 33 k ohms?

Solution:

Solving equation 2.11 for f gives

F = 1 / ( 2 pi XC C)

f = 1 / ( 2 pi x 3.3 x 104 ohms x 3.9 x 10-9 f ) =
1.24 x 103 Hz.

Example 2.7.

If a 0.1 uf capacitor is connected across the 120 vAC 60 Hz power line, how much current will flow?

Solution:

The reactance of a 0.1 uf capacitor at a frequency of 60 Hz is XC = 1 / ( 2 pi f C )

XC = 1 / ( 2 pi x 60 Hz x 1 x 10-7 f ) = 2.653 x 104 ohms.

I = E / XC = 120 v / 2.653 x 104 ohms = 4.52 x 10-3 A.

Power.

When an AC voltage is applied to a resistor, the current is in phase with the voltage. The instantaneous power is

p = (V sin( 2 pi f t ) ) x (I sin( 2 pi f t )

which is equal to

P = V x I x sin2( 2 pi f t ).

By trigonometric substitution the sine squared function becomes a double frequency negative cosine function.

P = V x I x 1/2 (1 - cos( 2 pi 2 f t )).

This function is entirely positive. When AC is applied to a resistor the power is "real". All energy flows from the generator into the load.

When an AC voltage is applied to a capacitor, the current leads the voltage by 90 degrees. The instantaneous power is

p = (V sin( 2 pi f t ) ) x (I cos( 2 pi f t ).

Making the substitution for sine times cosine gives.

P = V x I x sin( 2 pi 2 f t )

The sine times the cosine is a double frequency sine which has equal parts above and below the horizontal axis. This means that power is taken from the circuit for half of the time and given back for the other half of the time. The net value of power averaged over time is zero.

Here we have an incongruous situation. There is a voltage applied to a circuit element (capacitor) and there is a current flowing but the power is zero! This can be verified experimentally. It must have been "mind blowing" for the first person (probably a graduate student) who observed it.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

2.3 Inductive Reactance.

Early researchers in electricity must have been surprised to find that a coil of wire presented more "resistance" to the flow of alternating current than did the identical length of wire which was not wound into a coil. Experiments on inductors show that as more AC voltage is applied more current will flow. If the frequency is increased without changing the voltage the current will decrease. It can also be shown experimentally that the current in an inductor lags the voltage by 90 degrees or 1/4 of a cycle. The way in which an inductor reacts to AC is called the inductive reactance.

Let us apply a current to an inductor and see what happens. The current is i = I sin( 2 pi ft ). We will use equation 0.55 which is restated here as equation 2.12.

e = L di / dt           (2.12)

If we insert our definition of current into equation 2.12 we have

e = L V d/dt sin(2 pi f t )

Taking the derivative gives.

e = L V 2 pi f cos( 2 pi ft )

If we say that the voltage is e = E cos( 2 pi ft ) we have that

E = L I 2 pi f

solving for E gives

E / I = 2 pi f L

If you are awake you will recognize E / I as having the units of ohms. We now have a new quantity which in some ways is like resistance but in other ways is unlike resistance. We call this quantity the inductive reactance and give it the symbol XL.

XL = 2 pi f L           (2.13)

where XL is the inductive reactance in ohms, f is the frequency in hertz and L is the inductance in henrys.

We applied a sine wave current and a cosine wave voltage resulted. The cosine leads the sine by 90 degrees and so the voltage in an inductor leads the current by 90 degrees.

Example 2.8.

What is the value of an inductor which will present a reactance of 47 k ohms at a frequency of 100 kHz?

Solution:

Solving equation 2.13 for L we have

L = XL / ( 2 pi f )

L = 47 k ohms / ( 2 pi 100 kHz ) = 7.48 x 10-2 H or 74.8 mH

Example 2.9.

If a 500 uH inductor is used in a power line filter, how much voltage drop will be introduced at a current of 25 amperes?

Solution:

The power line frequency in the U.S. is 60 Hz. XL = 2 pi f L

XL = 2 pi x 60 Hz x 500 uH = 0.1885 ohms

The voltage drop is I x XL = 25 A x 0.1885 ohms = 4.71 v

The power in a pure inductance is zero by the same argument as for capacitors. It makes no difference that the current is lagging instead of leading. The phase difference is still 90 degrees.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

2.4 Series Circuits and Impedance.

DC circuit analysis contains only resistors and DC sources. Most real circuits operate using AC and employ capacitors and inductors. Because we must be capable of analyzing AC circuits as well as DC circuits we must study some new techniques. In this section we will develop some simple tools for the analysis of series AC circuits.

Series RC Circuits.

Figure 2.2 Series RC Circuit Driven by an AC Generator.

For a verbal description click here.

Figure 2.2 is the diagram of a simple RC circuit which contains an AC generator. The generator can take on any output voltage and any frequency.

Kirchhoff's law tells us that the current everywhere in the circuit will have the same magnitude. An extension of this law to AC circuits is to add phase. The current everywhere in the circuit will have the same phase. The current in the generator, the current in the resistor and the current in the capacitor are all in phase with each other.

The voltage across the resistor will be in-phase with the current through it. Resistors do not play tricks on us; they obey Ohm's law. The voltage and current in a resistor are always in-phase with each other.

The phase relationship between the voltage and current in a capacitor is 90 degrees with the current leading. If the current leads, the voltage follows or lags. In this example we are using the current as a reference so we say the voltage is lagging the current by 90 degrees. This can be represented pictorially as in Figure 2.3.

In Figure 2.3 the voltages and currents are represented by line segments in a plane. These lines have length and direction. Some texts refer to these as vectors. Vectors have magnitude and direction in real space and are (or at least can be) three-dimensional. The lines which represent voltages and currents cannot be three-dimensional; they are strictly two-dimensional. In addition to this, the directions do not represent directions in space, they represent relative phases of voltages and currents in electric circuits. For all of these reasons, the lines are called phasors. It should be noted that this term has been in common use in electrical engineering texts and by electrical engineers for a long time and predates the television show "Star Trek" by several decades.

Figure 2.3 Phase Relationships of Voltages and Currents.

For a verbal description click here.

Figure 2.4a is the diagram of an R-L circuit. The phasor diagram for this circuit is shown in Figure 2.4b. In an inductor the voltage leads the current by 90 degrees and so the voltage phasor is shown pointing upward. As always the voltage and current are in-phase in a resistor.

Schematic and phasor diagrams.

Figure 2.4 (a) R-L Circuit and (b) Its Phasor Diagram.

For a verbal description click here.

Kirchhoff's law tells us that the voltage of the generator in Figure 2.2 is the sum of the voltage across the resistor and the voltage across the capacitor. These voltages are not in phase and they cannot be added simply by adding their magnitudes. Their directions must also be taken into account. Even though we do not call them vectors the techniques of vector addition apply. As vector addition should be well known to any student studying physics, we will not dwell on the addition of vectors (phasors).

The fact that these phasors are at right angles makes life a lot easier for us. The familiar Kirchhoff's equation for voltages looks like this for AC:

V sub G = square root of V sub R squared plus V sub C squared.

where VG is the generator voltage, VR is the voltage across the resistor and VC is the voltage drop across the capacitor.

The phase angle theta of the generator voltage is given by

theta = arctan ( VC / VR )           (2.15)

To obtain the correct sign on the angle you must attach a minus sign to VC and a plus sign to VL.

Schematic and phasor diagrams.

Figure 2.5 R-LC (a Circuit and (b> Its Phasor Diagram.

For a verbal description click here.

If we now combine resistance, capacitance and inductance in the same circuit, as in Figure 2.5a, the phasor diagram of Figure 2.5b will result. Since VL and VC are 180 degrees apart, one will always subtract. The phasor version of Kirchhoff's voltage equation is as follows.

V sub G = square root of all V sub R squared plus quantity V sub L minus V sub C close quantity squared.

The phase angle is given by

Theta = arctan ( ( VL - VC ) / VR           (2.17)

Example 2.10.

In Figure 2.2 the magnitudes of the voltages are as follows. VR = 77.460 v at 0 degrees and VC = 91.652 v at -90 degrees. What are the magnitude and phase of the generator voltage?

Solution:

V sub G = square root of 77.460 squared plus 91.652 squared end square root = 120.0 v

The phase angle is

theta = arctan ( -91.652 v / 77.460 = 49.80 degrees.

Ohm's Law For AC.

When we made the change from DC to AC we did not repeal Ohm's law. Its form is just a little different. For resistors it is unchanged.

VR = I R           (2.18)

For capacitors and inductors it is as follows.

VC = I XC and VL = I XL           (2.19)

For a series combination of RC or R-L we will call the "resistance" something different.

VG = I Z           (2.20)

The quantity Z is called impedance and is the ratio of the generator voltage to the generator current. The impedance like the generator voltage has magnitude and angle. It is a phasor.

We can get equations for the magnitude and angle of the impedance by substituting equations 2.18, 2.19 and 2.20 into equations 2.16 and 2.17. Because the current is the same everywhere in the circuit it will cancel out and leave us with these equations. The magnitude is

Z = square root of R squared plus quantity X sub L minus X sub C close quantity squared

The phase angle is given by

theta = arctan ((XL - XC) / R           (2.22)

Impedance magnitude and phase angle involve reactances which are frequency dependent. An impedance can be calculated only if the frequency is fixed and known. If the frequency is changed, the impedance must be recalculated.

Example 2.11.

In Figure 2.2 R = 1 k ohms, C = 0.1 uf and f = 1 kHz, what is the impedance?

Solution:

First, XC must be determined.

XC = 1 / ( 2 pi 1000 x 0.1 x 10-6 ) = 1592 ohms

The magnitude of the impedance is

Z = square root of quantity open second quantity 1 k ohm close second quantity squared plus open third quantity minus 1592 ohms close third quantity squared close quantity = 1880 ohms

The phase angle is

theta = arctan (-1592 ohms / 1000 ohms) = -57.87 degrees.

The accepted way of writing this is

Z = 1880 ohms / -57.87 degrees

which is spoken as "1880 ohms at an angle of -57.87 degrees".

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

2.5 RC Filter Circuits.

One of the most commonly encountered applications of a series RC circuit is a filter. Filters are used to filter out an unwanted band of frequencies which may coexist with a wanted band of frequencies. An example is the output voltage of a thermocouple which is being used to measure the temperature in a crystal-growing oven. The temperature in the oven will change very slowly and the wanted data are contained on a voltage which is changing very slowly. The frequency content will be from zero frequency (DC) to about 0.1 Hz. An unwanted frequency which is extremely likely to be present is the ubiquitous and omnipresent 60 Hz power line frequency. A filter can be designed which will reduce magnitude of the 60 Hz output to a very low level without appreciably affecting the magnitude of the 0 to 0.1 Hz data signal.

Notice that word which is boldfaced above. A filter never removes an unwanted signal. There is no such thing as "remove". It's the same thing as taking a step equal to half of the distance to the wall. You can get as close to the wall as you want but you never can get there. A filter can be constructed to reduce an unwanted signal to as low an amplitude as desired but you never will be able to construct a filter to get the amplitude to zero.

Figure 2.6 Frequency Response of a Low-pass Filter.

For a verbal description click here.

Figure 2.7 Frequency Response of a High-pass Filter.

For a verbal description click here.

Filters can be divided into two groups, low-pass and high-pass. A low-pass filter will pass low frequencies and attenuate high frequencies. A high-pass filter will pass high frequencies and attenuate low frequencies. The dividing line between high and low is called the cutoff frequency.

The term "cutoff frequency" gives a false impression about how filters work. The notion is that all frequencies on the "pass" side of the cutoff frequencies are passed and all frequencies on the other side of the cutoff frequency are removed. That impression is wrong! The cutoff frequency is defined as that frequency where the output power is down to half of the input power. Figure 2.6 shows how the output of a low-pass filter which has a cutoff frequency of 1000 Hz (1 kHz) varies with frequency. Figure 2.7 shows the frequency response of a high-pass filter which also has a cutoff frequency of 1 kHz.

Do not be concerned if you don't know what a dB is. For now all you need to know is that it is a logarithmic function of VO / VI. The dB will be explained fully in section 2.6.

You will notice in Figures 2.6 and 2.7 that each filter has a portion of its frequency response curve where the output is unchanged as frequency changes. This is called the "flat" portion of the frequency response. The portion where the output is changing with frequency is called the "roll off" part of the curve. The cutoff frequency is that frequency where the output power is down to 1/2 of the power in the flat part of the curve. That does not conflict with the statement above because (in most cases) in the flat part of the curve the output power is equal to the input power.

Using the equation P = V2 / R it can be shown that when the power is reduced by 1/2 the voltage is reduced by 0.7071 which is 1 over the square root of 2. At the frequency where XC = R the output voltage is 0.7071 of the input voltage. This will be illustrated in an example. Thus the cutoff frequency is where XC = R.

Separating AC and DC.

As you will learn in later chapters, signals in electronics are often mixtures of AC and DC. In many cases it is desired to remove one or the other. A signal may have the form

v = VDC + VP sin( 2 pi f t )           (2.23)

where VDC is the DC part of the signal, VP is the peak value of the AC part of the signal and f is the frequency of the AC part of the signal. Figure 2.8a shows an equivalent circuit of a DC + AC generator. Figure 2.8b is a graph of the output voltage versus time.

Figure 2.8 DC + AC Generator (a) and Its Output (b).

For a verbal description click here.

Figure 2.9 Low-pass Filter with Its Input and Output.

For a verbal description Click here.

Suppose we pass this DC + AC signal through a low-pass filter as in Figure 2.9. The frequency of the AC is much higher than the cutoff frequency of the filter. That is equivalent to saying that XC is much less than R at the frequency of the AC generator. Most of the AC will be shorted out by the capacitor but the DC will be unaffected. Consequently the AC will be attenuated while the DC will not.

Figure 2.10 High-pass Filter With Its Input and Output.

For a verbal description click here.

Now let us pass this DC + AC signal through a high-pass filter as in Figure 2.10. The frequency of the AC is much higher than the cutoff frequency of the filter. That is equivalent to saying that XC is much less than R at the frequency of the AC generator. The AC will be affected very slightly by the filter but the DC will be totally removed. Consequently the DC will be attenuated while the AC will not. Because DC is zero frequency, absolutes do apply. The magnitude of the DC will be reduced to zero.

Attenuation of Unwanted AC Signals.

It is easy to calculate the amount of attenuation a filter will introduce at any frequency. The procedure is quite similar to that used to solve a voltage divider in DC circuits.

  1. Calculate the capacitive reactance XC and then the circuit impedance Z.

  2. Calculate the circuit current using the known or an assumed input voltage and the total circuit impedance Z.

  3. Multiply the current by the resistance or the reactance of the element across which the output is taken.

  4. Determine the attenuation ratio by dividing the calculated output voltage by the known or assumed input voltage.

For those who would prefer equations they are.

For a low pass filter.

A sub R = R over square root of R squared plus X sub C squared

For a high pass filter.

A sub R = X sub C over square root of R squared plus X sub C squared

Calculation of phase angle is usually not necessary.

Example 2.12.

In Figure 2.9, R = 1 k ohms and C = 10 uf. What is the attenuation ratio at a frequency of 60 Hz?

Solution:

First, calculate the reactance of the capacitor at 60 Hz.

XC = 1/(2 pi f C) = 1/(2 pi 60 Hz x 10 x 10-6 f) = 265.26 ohms.

The circuit impedance is

Z = square root of quantity R squared plus X sub C squared close quantity = square root of quantity 1000 squared plus 265.26 squared close quantity = 1034.58 ohms.

Assume an input voltage of 1 v and calculate I = E / Z

I = 1 v / 1034.58 ohms = 9.6658 x 10-4 A.

VO = I XC = 9.6658 x 10-4 A x 265.26 ohms = 0.256 v. Dividing this output voltage by 1 v gives the attenuation ratio of 0.256.

Example 2.13.

In the circuit of Figure 2.10 R = 1592 ohms and C = 0.1 uf. What are the attenuation ratios at (a) 60 Hz and (b) 1 kHz?

Solution:

For details on the calculations of XC, Z and I you are referred to example 2.12. Calculating XC at 60 Hz and 1 kHz we have
XC at 60 Hz = 2.653 x 104 ohms and
XC at 1000 Hz = 1592 ohms.
Calculating the circuit impedance at 60 and 1000 Hz.
Z at 60 Hz = 2.658 x 104 ohms and
Z at 1000 Hz = 2251 ohms.
The current for 1 v input is found to be
I at 60 Hz = 3.762 x 10-5 A and
I at 1000 Hz = 4.442 x 10-4 A.
All that remains is to calculate the output voltage. This is the only part of this example which is different from example 2.12. For Figure 2.10 the output voltage is (a) VO = I R.
At 60 Hz VO = 3.762 x 10-5 A x 1592 ohms = 5.99 x 10-2v.
The attenuation ratio AR = 5.99 x 10-2
(b) At 1000 Hz VO = 4.442 x 10-4 A x 1592 ohms = 0.707 v
therefore AR = 0.707

In the above examples we have defined the attenuation ratio of a filter to be

AR = VO / VI           (2.24)

where VO is the output voltage of the filter at one particular frequency and VI is the input voltage at the same frequency. The output divided by the input is often called the "gain" of the circuit. The term gain implies an increase, not a decrease as occurs in a passive circuit. The term gain will make more sense when we study amplifiers which do increase the amplitude of the input signal.

In the examples above if the attenuation is desired at several different frequencies it would be necessary to recalculate the value of XC for each frequency. There is a way to avoid these repeated calculations. Let us write a general equation for the attenuation ratio of a low-pass filter and see what we can do with it. The general equation is this.

A sub R = X sub C over square root of R squared plus X sub C squared.

Now we will make the substitution XC = 1 / (2 Pi f C).

A sub R = 1 over quantity 2 Pi f C close all over square root of R squared plus 1 over quantity 2 Pi f C close squared end square root.

Now we will multiply the above equation through by 2 Pi f C to obtain.

A sub R = 1 over square root of 2 Pi f C R all squared plus 1 end square root.

The cut-off frequency is where XC = R. If we substitute into the reactance equation we have

R = 1 / (2 Pi fC C)

Solving for the cut-off frequency gives.

fC = 1 / (2 Pi R C).

We can substitute this into the above equation and obtain.

A sub R = 1 over square root of quantity f over f sub c quantity squared plus 1.

Where fc is the cut-off frequency and f is any given frequency.

If we start from the high pass filter equation and follow the same procedure we will obtain.

A sub R = 1 over the quantity square root of 1 plus open f sub c over f close squared close square root.

Either one of these equations may easily be solved for fc to find the cut-off frequency for a given frequency and attenuation or for f to find the frequency for a given attenuation for a given filter.

Logical Checks.

The output voltage of an RC filter will always be less than or equal to the input voltage. If you get an output which is larger than the input, you have made a mistake.

For a low-pass filter, the output will decrease as the frequency increases. If asked to calculate the attenuation ratio at two different frequencies and you get an answer which says that the higher frequency gives a larger output voltage than does the lower frequency, you have made a mistake.

For a high-pass filter, the output will increase as the frequency increases. If asked to calculate the attenuation ratio at two different frequencies and you get an answer which says that the lower frequency gives a larger output voltage than does the higher frequency, you have made a mistake.

Example 2.13.1.

In the circuit of Figure 2.10 R = 1592 ohms and C = 0.1 uf. What are the attenuation ratios at (a) 60 Hz and (b) 1 kHz?

Solution:

This is a repeat of Example 2.13. Lets try the new tools we have. First of all.

fC = 1 / (2 Pi R C) = 1 / (2 Pi 1592 x 0.1 x 10-6) = 1000 Hz.

From equation 2.24.5 we have.

AR = 1 / sqrt(1 + (fC/f)2)

(a) AR = 1 / sqrt(1 + (1000/60)2) = 0.0599

(b) AR = 1 / sqrt(1 + (1000/1000)2) = 0.707

Example 2.13.2.

A low-pass filter is needed that has an attenuation ratio of 1.8 x 10-3 at a frequency of 60 Hz. (a) What is the cut-off frequency of this filter? (b) If the resistor is 1 Meg ohm what is the capacitor value?

Solution:

Solving equation 2.24.4 for fc gives.

f sub c = f times A sub R over square root of 1 minus A sub R squared.

(a) Fc = 60 x 1.8 x 10-3 / sqrt(1 - (1.8 x 10-3)2) = 0.108 Hz.

(b) C = 1 ( 2 Pi fc R) = 1 / (2 Pi 0.108 x 106 = 1.47 uf.

Example 2.13.3.

A high-pass filter must have an attenuation of 0.966 at a frequency of 20 Hz. (a) What is the cut-off frequency, and (b) What is the capacitor if the resistor is 470 k ohms?

Solution:

Solving equation 2.24.5 for fc gives.

f sub c = square root of 1 minus A sub R squared end square root over f times A sub R.

(a) fc = sqrt(1 - 0.9662) / (20 x 0.966) = 5.35 Hz.

(b) C = 1 / (2 Pi 5.35 x 470 x 103) = 0.0633 uf.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

2.6 The Decibel (dB).

The decibel (dB) is one tenth of a Bell (B), as in Alexander Graham Bell. From this you might assume that the Bell and decibel have something to do with sound and you would be partly correct.

The dB began life as a measure of sound pressure level. A dB is the smallest change in sound level which the human ear can detect. The key to understanding the dB is that word "change". There is no absolute zero on the dB scale.

Because the telephone converts sound to an electrical signal, an electrical definition of the dB is closely tied to the sound level definition. The electrical definition is

dB = 20 Log ( V2 / V1)           (2.25)

or

dB = 10 Log ( P2 / P1)           (2.26)

where P1 and P2 are powers and V1 and V2 are voltages. The quantity which is subscripted 2 is the one to be expressed in dB and the quantity which is subscripted 1 is the chosen reference. For example the gain of an amplifier or loss (attenuation) of a filter can be expressed in dB as follows.

dB = 20 Log (VO / VI)           (2.27)

Where VI is the input voltage and VO is the output voltage. In the above equations, if V2 = V1, P2 = P1 or VO = VI, the result is zero (0) dB. The denominator of the argument of the log function is called the reference level because it determines where the zero on the dB scale will be placed.

The reference level may be anything which the occasion demands. There are far too many standard references to list here but there is one which is so common that it is worth mentioning. A standard reference is 1 milliwatt in 600 ohms. The voltage is V2 = P R = 1 x 10-3 w x 600 ohms = 0.60 square volts and V = 0.7746 v. This dB scale is referred to as the dBm (dB referred to 1 milliwatt) scale and it appears on most analog AC meters. It is also known as the VU (volume unit) scale. The VU meters in a tape deck or radio station console use this scale.

The dB is widely used because its logarithmic nature permits it to express a wide range of values in a compact form. It is most useful in graphing quantities which have a wide range. This will become apparent in the next section.

Example 2.14.

Express the following power levels in dBm: (a) 25 microwatts, (b) 1 milliwatt, (c) 1 watt and (d) 75 watts.

Solution:

dBm = 10 Log P / 1 mw           (2.28)

(a) -16.0 dBm,
(b) 0 dBm,
(c) 30 dBm and (d) 48.8 dBm.

Example 2.15.

Express the following voltage levels in dBm: (a) 5 microvolts, (b) 2 millivolts, (c) 6 volts and (d) 120 volts.

Solution:

dBm = 20 Log V / 0.7746 v           (2.29)

(a) -103.8 dBm,
(b) -51.8 dBm,
(c) 17.8 dBm and
(d) 43.8 dBm.

Example 2.16.

A filter is being operated at its cutoff frequency. (a) Use power to express the attenuation ratio in dB. (b) Use voltage to express the attenuation ratio AR in dB.

Solution:

At the cutoff frequency the output power is 1/2 of the input power and the output voltage is 0.7071 of the input voltage.
(a) dB = 10 Log 0.5 = -3.01 dB.
(b) dB = 20 Log 0.7071 = -3.01 dB.
Let's call them both -3 dB.

At the cutoff frequency the filter's output is 3 dB down from its flat response output level. The cutoff frequency is often called the "3 dB point" or the "half-power point".

Example 2.17.

Express the results of examples 2.12 and 2.13 in dB.

Solution:

The result of example 2.12 is AR = 0.256. Since AR = VO / VI we have dB = 20 Log AR = 20 Log 0.256 = -11.8 dB.

The results of example 2.13 are at 60 Hz AR = 5.99 x 10-2 and at 1000 Hz AR = 0.707. At 60 Hz ARdB = -24.4 dB and at 1000 Hz ARdB = -3 dB.

Example 2.18

In the frequency response curve of Figure 2.6 the attenuation at 1 MHz is 60 dB, at 100 kHz it is 40 dB, at 10 kHz it is 20 dB and at 1 kHz it is 3 dB. What is the value of AR at each of these frequencies?

Solution:

Starting from the equation dB = 20 Log AR and taking the antilog of both sides we have

AR = 10dB/20.

At 1 MHz AR = 10-60/20 = 1 x 10-3,
At 100 kHz AR = 10-2,
at 10 kHz AR = 10-1, and
at 1 kHz AR = 10-3/20 = 0.708, which shows that there are often errors in reading graphs.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

2.7 Graphing Frequency Response.

As with most other things there is a right way and several wrong ways to graph frequency response curves. First we will discuss what makes a "good" graph in general and then show some examples of wrong ways to graph frequency response.

The best possible graph is a straight line. It is easy to draw, easy to pick off values from and easy to fit an equation to. If you can't get a single straight line, a couple of line segments joined by a short curving section is the next best thing. The graphs in Figures 2.6 and 2.7 fit the latter description nicely.

One of my professors once said, in jest I'm sure, "If you can get your data to plot as a straight line you should get your PhD on the spot, and if you can get the line to go through the origin you should get the Nobel prize."

In Figures 2.6 and 2.7 the frequency is plotted on a logarithmic scale. The distance between 1 and 10 is the same as the distance between 10 and 100, which is also the same as the distance between 100 and 1000. On a linear scale the distance between 10 and 100 would be 10 times larger than the distance between 1 and 10. The first dotted vertical line to the right of 1 is for 2. The next dotted line is for 5. The two dotted lines to the right of 10 are for 20 and 50 respectively. Other interpolation markings have been omitted to keep the graph from being too cluttered.

The vertical scale in Figures 2.6 and 2.7 is plotted in dB. Now that you know what a dB is you know that the vertical scale is also a logarithmic scale. If you think back to geometry you will remember that if you plot y = 1/x on a log-log scale it is a straight line. The roll-off portion of the graph of a low-pass filter is a 1/f curve, as shown in Figure 2.6. In Figure 2.7 the straight part of the roll-off is a simple y=x function which is a straight line on a log-log as well as a linear graph.

Some Wrong Ways.

Given a set of data and told to "go and plot it" with no further instructions the natural thing to do would be to use linear axes for both x and y coordinates. Figure 2.11 shows data for a low-pass filter which has been plotted on linear scales for frequency and attenuation ratio. Note that we are not using dB but just the values of AR. Because the raw data goes from 1 hertz to 1 megahertz the frequency scale is from 0 to 1 megahertz. The attenuation scale is from 0 to 1.

As you can see from Figure 2.11 the frequency response curve is a shy little thing that attempts to hide behind the X and Y axes. It is not very useful because it would be impossible to pick values from except in a very small part of the curve.

Figure 2.11 Frequency Response of a Low-pass Filter
Plotted on Linear Scales 0 to 1 MHz.

For a verbal description click here.

The curve can be pulled away from the edges by changing the scale. Figure 2.12 shows the same data plotted from 0 to 6 kilohertz. While this scale throws away most of the data it does make for a readable graph.

Figure 2.12 Frequency Response of a Low-pass Filter
Plotted on Linear Scales 0 to 6 kHz.

For a verbal description click here.

What is needed is a scale which allows wider spacing of numeric intervals when the values are small and closer spacing when the values are large. That sounds like the description of a logarithmic scale. Figure 2.13 is getting better because the frequency is now on a log scale. The vertical axis is still the attenuation ratio which ranges from 0 to 1. It is a linear scale.

Figure 2.13 Frequency Response of a Low-pass Filter
Plotted on Logarithmic Scales 1 Hz to 1 MHz.

For a verbal description click here.

From this figure it is possible to tell that the attenuation ratio is 0.707 at 1 kHz. Inspection of this graph indicates that the output of the filter is zero above 100 kHz. This is not the case! The output of a filter never goes to zero. We are in need of a logarithmic scale for the attenuation ratio as well as the frequency.

A log scale for the attenuation ratio could be obtained by using log-log graph paper to plot the data. Alternatively, we could simply take the log of AR but since the dB is so well known it seems to be the best way to get a log scale on the vertical axis. As all analog AC voltmeters have a dB scale the data may be taken in dB for plotting directly on a graph.

In Figure 2.6 we can see that the filter's output is down 3 dB at 1 kHz. We can also see that the output is down 20 dB at 10 kHz, 40 dB at 100 kHz and 60 dB and 1 MHz. In fact the output of a low-pass filter decreases by 20 dB for every decade increase in frequency. This particular rate of decrease is specific to a low-pass filter consisting of one capacitor and one resistor. Filters which are more complex will have roll-off rates of 40, 60, 80, and so on dB per decade of frequency.

Using Store-bought Graph Paper.

Many students become confused when they set out to plot a frequency response curve on a piece of semi-log graph paper. To begin with the numbers are printed on the paper in the wrong orientation. To read the numbers right-side-up you will hold the paper so that the log axis is vertical. As you can see in figure 2.6 the log axis is horizontal. Even after getting the paper turned the right way, there is still confusion about what to do with those numbers and how to relate them to frequency.

Semi-log and log-log graph paper is sold by cycles. One cycle will cover one decade of data. A representation of a piece of 2 cycle semi-log paper is shown in Figure 2.14. The numbers have been turned right-side-up for easier reading.

Figure 2.14 Representation of a Piece of Semi-log Graph Paper.

For a verbal description click here.

The numbers across the top are the numbers which are printed on the paper. The numbers in each successive decade are spaced a little farther out from the graph. The line between 1 and 2 is for 1.5. You may have noticed that it is not equidistant between 1 and 2. That is the nature of a log scale.

To plot frequency on this graph paper you would label the horizontal axis as shown along the bottom of the graph. If you have more decades to plot you must buy another piece of graph paper which has more cycles. When you go to the bookstore to buy semi-log or log-log paper you should know how many decades of data you have to plot.

If semi-log paper cannot be obtained in the desired number of cycles, it is possible to use linear paper and take the log of frequency. The log of frequency has no particular meaning (there is no equivalent to the dB for frequency), which makes it necessary to label the graph with frequency in hertz rather than log of frequency.

The magnitude (Y axis) of a frequency response plot may be plotted on a linear scale in dB or on a log scale in attenuation ratio. Although either way is acceptable, plotting dB on a linear scale is by far the most commonly used method.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

2.8 Nonsinusoidal Waves.

As shown in Figure 2.1 there are waves other than sine waves. These other waves are made up of sine waves in combination.

Sinusoids.

The simplest of oscillators, (devices which generate waves), produces a sine or cosine function. When the output of such an oscillator is plotted versus time, the result is what we call a sine wave. When a waveform is not sinusoidal (square, triangular or just not a sine wave), it can be shown mathematically and physically to be the sum of several sinusoidal waves.

Harmonics.

A harmonic is a frequency which is an integer multiple of another frequency. The "other" frequency is called the fundamental frequency. Thus a complex (nonsinusoidal) waveform is made up of a fundamental frequency, which is a sine wave with the largest amplitude and lowest frequency, and several other sine waves which are lower in amplitude and integer multiples of the fundamental frequency.

Numbering Harmonics.

Harmonic numbers are assigned on the basis of their relationship to the fundamental frequency. The fundamental frequency itself is the first harmonic. The frequency which is twice the fundamental frequency is called the second harmonic. The frequency which is three times the fundamental frequency is called the third harmonic and so on. The frequency of any harmonic is just the harmonic number multiplied by the fundamental frequency.

Fourier Series.

Remember the angular frequency? The symbol usually used for the angular frequency is a lower case omega. That symbol does not appear on my word processor. We will use instead a "w". If we call the nonsinusoidal wave F(wt) then the general form of the Fourier series for F(wt) is given by

F(wt) = a0 + a1 cos(wt) + a2 cos(2wt) + ... + an cos(nwt)
           + b1 sin(wt) + b2 sin(2wt) + ... + bn sin(nwt)     (2.30)

where w = 2 pi f, a0 is the DC component (if any) of the complex wave, an is the coefficient of the nth cosine harmonic and bn is the coefficient of the nth sine harmonic. The coefficients are given by

A sub zero=1 over 2Pi times the integral from 0 to 2Pi of F of wt dwt.

A sub n = 1 over Pi times the integral from 0 to 2Pi of F of wt cos nwt dwt.

B sub n = 1 over Pi times the integral from 0 to 2Pi of F of wt sin nwt dwt.

A square wave which has voltage levels of +V volt for the first half-cycle and -V volt for the second half-cycle and frequency w/(2 pi ) will have the Fourier series

F of wt = 4 V over Pi times the quantity sin wt plus one third sin 3wt plus one fifth sin 5wt plus dot dot dot close quantity.

The Fourier series for a triangular wave which has a positive peak voltage of +V volts and a negative peak voltage of -V volts is

F of wt = 8V over Pi times the quantity sin wt plus 1 over 3 squared sin 3wt plus 1 over 5 squared sin 5wt plus dot dot dot close quantity.

When the writer was a student, a waveform had to be capable of being described mathematically in order to obtain its Fourier series. Calculating the coefficients was a long and arduous process. Now there are computer programs which will give the coefficients of the Fourier series of any arbitrarily-shaped wave.

The Physics of It All.

Spectral line diagram.

Figure 2.15 Frequency Spectrum of a Square wave.

For a verbal description click here.

Figure 2.15 shows the spectrum of a square wave. Unlike spectra you are accustomed to seeing, this one plots frequency instead of wavelength. Also unlike other spectra you may have seen, the magnitude of each line is plotted upward from the horizontal axis. In optical spectra, the magnitude of each line is indicated by its brightness in a spectroscope or its darkness on a film negative. Other than that it's a perfectly normal spectrum.

Figure 2.16 shows how the sine waves fit together to make up a square wave. Notice that the square wave gets better as more harmonics are added. To obtain a perfect square wave it would be necessary to have an infinite number of harmonics. A quite good square wave is generated if approximately 99 harmonics are present.

Figure 2.16 Square Waves Are Built Up from Sine Waves.

For a verbal description click here.

In the top wave the red line is the sum of the first and third harmonics. In the middle diagram the sum of 1 and 3 has been redrawn in black and the 5th harmonic added. Similarly, in the bottom diagram the 7th harmonic has been added. The more harmonics are added, the flatter the sum will be and the steeper the rises and falls will be.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

2.9 The Effects of RC Circuits on Nonsinusoidal Waves.

When a nonsinusoidal wave is passed through an RC filter the shape of the wave is changed. An RC circuit cannot affect the shape of a lone sine wave. It can only affect its amplitude.

There are two different ways to look at the way in which an RC circuit changes the shape of a nonsinusoidal wave. One is to look at the way an RC circuit affects the amplitudes and phases of the harmonics (frequency domain) and the other is to look at the RC circuit as having a time constant which superimposes its own charging and discharging on the original wave (time domain).

The Frequency Domain.

Because an RC circuit affects the amplitudes of the various harmonics of a complex waveform by different amounts, the makeup of the Fourier series is changed. If you change the Fourier series, you change the shape of the wave.

Figure 2.17 shows how a square wave is modified by being passed through a low-pass RC filter. In Figure 2.17a the cutoff frequency of the filter is 10 times the frequency of the square wave. Harmonics 1, 3, 5, 7 and 9 are passed with little or no attenuation. Harmonics numbers 11 and higher are not removed; they are reduced in amplitude compared to what they were in the original wave. In Figure 2.17b the frequency of the square wave is equal to the cutoff frequency of the filter. All of the harmonics are altered in amplitude. As you can see the wave no longer looks much like a square wave. It should be pointed out that the wave has been turned on for some time, we only started looking at it where the wave seems to start. Starting and stopping transience are not shown.

Figure 2.17 RC Filter's Effects on a Square wave.

For a verbal description click here.

In Figure 2.17c the vertical scale has not been changed. The square wave has been changed into a triangular wave of somewhat reduced amplitude. The filter has imposed its own 1 over f function on the harmonics of the square wave. The harmonic amplitudes of the wave are now a 1 over f squared function. Look at the Fourier series for a triangular wave and you will see that it is a 1 over f squared function. The square wave has been converted into a triangular wave.

The analysis of other waveforms is not as easy as for a square wave but the principle is the same. In general a low- pass filter will tend to round off the sharp edges on any wave.

Figure 2.18 shows how a square wave is modified by being passed through a high-pass RC filter. In Figure 2.18a the cutoff frequency of the filter is 10 times the frequency of the square wave. Harmonics 1, 3, 5, 7 and 9 are severely attenuated with the lower numbered harmonics being attenuated more than the higher numbered ones. Harmonics numbers 11 and higher are passed with little or no attenuation. The result is a series of spikes as shown in Figure 2.18a. As with Figure 2.17, starting and stopping transients are not shown.

Figure 2.18 RC Filter's Effects on a Square wave.

For a verbal description click here.

In Figure 2.18b the cutoff frequency of the filter is equal to the fundamental frequency of the square wave. The fundamental frequency (first harmonic) of the wave will be attenuated by 3 dB while the higher harmonics will be affected very slightly. In Figure 2.18c the frequency of the wave is 10 times the cutoff frequency of the filter. The first harmonic will be affected by only about 10%. Figures 2.18b and 2.18c show how sensitive a square wave is to the amplitude of its fundamental frequency.

The Time Domain.

In Figure 2.17 a square wave is being passed through an RC low-pass filter. When the input wave changes states, say from -V to +V, the capacitor must charge up from -V to +V. As you will remember it takes one time constant for the voltage to reach 36.8% of the final value. Theoretically, the voltage will never reach the final value.

In Figure 2.17a there are 31.4 time constants in every half cycle of the square wave. This means that the capacitor has plenty of time to charge up to the final value. The difference between the final value and the charge on the capacitor is 2.27 x 10-14. In Figure 2.17b there are only 3.14 time constants in each half cycle. The capacitor has much less time to finish charging before the square wave switches to its other state. Even so the voltage will have time to reach 95.7% of its final value. In Figure 2.17c there is only 0.314 of a time constant in each half cycle of the square wave. The voltage will only reach 26% of its final value. For small values of x the equation y = e-x appears to be a straight line. That is why the square wave is converted into a triangular wave.

The time integral of a square wave is a triangular wave. RC low-pass filters are often called integrators because they can be made to integrate waves if the frequency of the wave is higher than the cutoff frequency of the filter.

If a square wave is passed through an RC high-pass filter the results are shown in Figure 2.18. In Figure 2.18a there are 31.4 time constants in every half cycle of the square wave. This means that the capacitor has plenty of time to discharge. The charge on the capacitor is 2.27 x 10-14 of its starting value. In Figure 2.18b there are only 3.14 time constants in each half cycle. The capacitor has much less time to finish discharging before the square wave switches to its other state. Even so the voltage will have time to reach 4.3% of its initial value. In Figure 2.18c there is only 0.314 of a time constant in each half cycle of the square wave. The voltage will fall to 73% of its initial value.

RC high-pass filters are often called differentiating circuits because they do an approximate differentiation on the input wave. The slope of a square wave is 0 along the flat portions of the wave and very high on the transitions. Thus the derivative of a square wave is a series of narrow spikes similar to Figure 2.18a.

The fact that the same set of figures was used for both time domain and frequency domain discussions should make it clear that these are simply two different ways of describing the same phenomenon. The physics goes on regardless of the human reasoning process or even in the total absence of human reasoning.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

2.10 R-LC Resonate Circuits.

When inductance and capacitance exist together in the same circuit the phenomenon of resonance appears. You are already familiar with resonance in a spring-mass system. If such a mechanical system is driven by an external force at different frequencies it will respond most strongly when driven at its resonant frequency. If the system is displaced and then released, it will produce damped oscillations at its resonant frequency. How rapidly the oscillations damp out will depend on the amount of energy lost in the system.

An R-LC circuit will respond electrically in exactly the same way as the mechanical system. If an external AC voltage is applied to the circuit at different frequencies, the current in the circuit will be largest at the resonant frequency. If a DC voltage is applied to the circuit and then suddenly removed, the circuit will produce damped oscillations at its resonant frequency. How rapidly the oscillations damp out will depend on the amount of resistance in the circuit.

Figure 2.19 (a) R-LC Resonant Circuit and (b) Phasor Diagram.

For a verbal description click here.

A series R-LC circuit is shown in Figure 2.19a and its phasor diagram is shown in Figure 2.19b. The current everywhere in the circuit will be in phase with itself. The voltage across the resistor will be in phase with the current. The voltage across the inductor will lead the current by 90 degrees while the voltage across the capacitor will lag the current by 90 degrees. As can be seen in Figure 2.19b the total difference in phase between VC and VL is 180 degrees. IF the two voltages are equal in magnitude, they will cancel out and the voltage across the resistor will be equal to the generator voltage. Whereas IC = IL, the only way to make VC = VL is to have XC = XL. This is the definition of the resonant condition in a series circuit. Series resonance occurs when the capacitive reactance is equal to the inductive reactance.

The total impedance of a series R-LC circuit is

Z = square root of R squared plus quantity X sub L minus X sub C quantity squared.

where R is the resistance of the resistor in ohms, XL is the reactance of the inductor in ohms and XC is the reactance of the capacitor in ohms. If we substitute XL = 2 pi fL and XC = 1/(2 pi fC) we have

Z = square root of R squared plus quantity 2 PI f L minus 1 over 2 pi f C quantity squared.

where f is the frequency in hertz, L is the inductance in henrys and C is the capacitance in farads. With R, L and C held constant Z will be infinite at f = 0 and infinity. For values of f between zero and infinity, Z will come down to a minimum of Z = R at the resonate frequency. Figure 2.20 shows impedance versus frequency and current versus frequency for a 1 volt generator, a 50 ohm resistor, a 79.6 millihenry inductor and a 0.318 microfarad capacitor connected as in figure 2.19a. The curves of resonant circuits appear on linear scales about as often as they appear on log scales.

Figure 2.20 Impedance and Current Versus Frequency.

For a verbal description click here.

Resonant circuits are used to select a narrow band of frequencies out of the entire frequency spectrum. Just how narrow a band is selected depends on the quality factor "Q" of the circuit.

Bandwidth and Q of Resonant Circuits.

The bandwidth of a resonant circuit is defined as the difference between the two frequencies where the current is down to 0.707 of its maximum value (the half power points). Remember that 0.707 is our old friend -3 dB. This may seem to be a somewhat arbitrary definition. However as we will see soon if we start with the -3 dB points we can derive the equation for Q given below. The derivation could be done the other way as well. In the circuit of Figure 2.20 the maximum circuit current is 20 mA. The current at the -3 dB point is 14.14 mA. Notice that there are two -3 dB points on the curve at frequencies of 952 and 1052 hertz. *

The lower -3 dB frequency is called f1, the upper -3 dB frequency is called f2 and the resonant frequency is called fR. The quality of a resonant circuit may be expressed as

* These frequencies were found by placing a conditional test in the plot program and causing the frequencies to be printed out. In this sense the values were "picked off of" the graph. The nature of the program rounded off the frequencies which is why these values are different from the ones given below to more significant digits.

Q = fR / (f2 - f1)           (2.38)

The Q or quality factor of a resonant circuit can also be expressed as follows:

Q = XL / R     or     Q = Xc / R           (2.39)

Q is defined at resonance where XL = XC. Equation 2.39 is derived from a definition and will be shown below.

\ The most fundamental definition of Q is,

Q = (energy stored on each signal cycle) / (energy lost during 1 radian of the cycle).

One radian is the basic unit of time in AC mathematics. Read the equal sign as the three line sign meaning "is defined as". Here is how we get from the above definition to the one we all know and love.

Starting with a series resonant circuit the energy stored is continuously swapped back and forth between the inductor and capacitor. From fundamental electricity we know that the energy stored in a capacitor and an inductor are,

WC = V^2 C / 2

And

WL = I^2 L / 2

Where W is the amount of energy stored in either the capacitor or inductor according to the subscript, V is the voltage across the capacitor, C is the capacitance of the capacitor, I is the current through the inductor, and L is the inductance of the inductor. The stored energy is being traded between the inductor and capacitor and It may be hard to get a handle on it. What we must do is to order time to stop at the instant when the energy in the inductor is at its maximum value. Since this is a thought experiment we don't need a DeLorean to make that happen. We stop time at the peak value of the current. Since this is a series circuit by Kirchhoff's law the current is the same in all components. In our simple circuit the energy lost is dissipated by the resistor and we can write,

WL = (IP^2 L) / 2

And

PR = IRMS^2 R

We need the two currents to be the same so they will cancel out in the final equation.

IRMS = IP / sqrt(2)

Substituting for IRMS into the equation for PR gives.

PR = (IP / sqrt(2) )^2 R.

Since (sqrt(2))^2 = 2 we have,

PR = IP^2 R / 2.

Energy = Power times Time so as explained above we need to find the energy dissipated by the resistor in one radian of time. One radian is the period, time for one cycle given as the symbol T, of the wave divided by 2pi because there are 2 pi radians in one cycle. Furthermore the period, T = 1/ f so one radian = 1 / (2 pi f). Where have we seen that one before?

So, the energy dissipated in a resistor in 1 radian of time is,

WR = IP^2 R / (4 pi f)

Now if we divide WL by WR we have,

Q = (IP^2 L / 2) / (IP^2 R / (4 pi f))

Lets do some obvious canceling.

Q = L / (R / (2 pi f))

Inverting the divisor and multiplying gives,

Q = 2 pi f L / R

Since 2 pi f L = XL we have,

Q = XL / R.

So now we have a proven formula for calculating Q based on the reactance of the inductor at the resonant frequency and the resistance of the coil. Now we need to show the relationship between the two equations for Q which were given above.

To do this we first find the two frequencies f1 and f2 where the current is down to 1 / sqrt(2), 0.707, -3 dB, referenced to the current at the resonant frequency, fr. This derives from this equation.

Q = fr / (f2 - f1)

Where fr is the resonant frequency, peak of the curve above, f1 is the lower 0.707 point, and f2 is the upper 0.707 point. We will derive expressions for f1 and f2 and then using nothing more than algebra arrive at,

Q = XL / R

We can simplify the math a bit by removing reference to the current and the applied voltage and work directly with the impedance Z. If the voltage is constant and the current is down to 1 / sqrt(2) the impedance must be up to sqrt(2).

Resonance is defined as the frequency where XL = XC or 2 pi f L = 1/(2 pi f c). In the equation for impedance above if the condition of resonance is met the second squared term under the radical will be zero. Thus the impedance Z will be Z = sqrt(R^2) = R. For the impedance to be sqrt(2)R the second term must be equal to R. Thus,

Z = sqrt(R^2 + R^2) = sqrt(2R^2) = sqrt(2)R.

Using the simpler form of impedance we write,

Z = sqrt(R^2 + (XL - XC)^2)

By inspection we can see that if XL increases by 0.5 R and XC decreases by 0.5 R the impedance will be sqrt(2)R. Just one little problem. XL and XC don't change at the same rate. The graph of XL versus frequency is a straight upward sloping line wile the graph for XC versus frequency is a parabola. If we look at a parabola over a small enough frequency span it looks like a straight line but when the Q of the circuit is low this approximation no longer holds.

So we set the reactance expressions at f1 and f2 equal to R and ignore the radical as follows. The equations below are based on the rule "If a^2 = b^2 then a = b" except for a slight matter of signs which we will be aware of as we write the equations.

-R = 2 pi f1 L - 1 / (2 pi f1 C)

And

R = 2 pi f2 L - 1 / (2 pi f2 C)

The frequency f1 is below the resonance point and the inductive term is smaller than the capacitive term so R must be negative to be equal to the reactive term. The frequency f2 is above the resonance point and the inductive term is larger than the capacitive term so R must be positive to be equal to the reactive term. In the impedance equation squaring the terms takes care of signs and we don't have to be concerned about them. In these equations we do. Now we multiply through by 2 pi fC in both equations.

-2 pi R C f1 = 4 pi pi L C f1^2 - 1

and

2 pi R C f2 = 4 pi pi L C f2^2 - 1

Now we rearrange these equations to get them into the classic quadratic form.

-4 pi pi L C f1^2 - 2 pi R C f1 + 1 = 0

and

-4 pi pi L C f2^2 + 2 pi R C f2 + 1 = 0

The next step is to plug the values into the quadratic formula and turn the crank. But I wanted some kind of check on the reliability of these equations. I used the example that plotted the curves above. A digit has been added to the values to give greater assurance of the accuracy of the equations.

L = 79.58 millihenrys,
C = 318.3 nanofarads,
R = 50 ohms,
XL = XC = 500 ohms, and
fr = 1,000 Hz.

The Q of the circuit is given by Q = XL / R = 10. By Q = fr / (f2 - f1) , (f2 - f1) = 100 Hz.

Entering the quadratic formula into an Excel cell and spending a couple of hours trying to find the typo that kept the answer from coming out right, yielded, f1 = 951.2 Hz and f2 = 1051.2 Hz. The asymmetry of the f1 and f2 points is caused by the parabolic shape of the capacitance reactance curve which I spoke of above. Even when a resistor of 250 ohms is inserted giving a Q of 2 the bandwidth comes out right.

I used to be under the mistaken impression that the formula Q = fr / (f2 - f1) was an approximation That would fall apart at low values of Q. Also I believed it could not be derived. In fact I have never seen a derivation or proof of the validity of this formula. It's a little harder to invent the wheel when you have never seen one.

Something very important I learned from the example is that the correct answer is given by using the positive sign on the radical in the quadratic formula. When the negative sign is used the frequency is given as a negative number. Since there is no such thing as negative frequency the positive one has to be the right answer.

Well, let's grind out some more algebra. Isn't it fun?

X = (-b +/- sqrt(b^2 - 4ac)) / (2 a)

-4 pi pi L C f1^2 - 2 pi R C f1 + 1 = 0
f1 = (2 pi R C + sqrt((- 2 pi R C)^2 + 16 pi pi L C )) / ( -8 pi pi L C )

-4 pi pi L C f2^2 + 2 pi R C f2 + 1 = 0
f2 = (-2 pi R C + sqrt((2 pi R C)^2 + 16 pi pi L C ))/ ( -8 pi pi L C)

Now we subtract f1 from f2. The denominators are the same so there is no need to worry about finding a common denominator. The radical has the same value so it will go away. The b coefficient has a different sign in the two but the squaring operation makes it all positive. So it looks like we get,

f2 - f1 = (-2 pi R C -(2 pi R C)) / ( -8 pi pi L C) = -4 pi R C )/ (-8 pi pi L C )

f2 - f1 = R / ( 2 pi L )

This seemingly simple equation does produce correct answers when the values from the numerical example are inserted into it.

Now we have to divide fr by f2 - f1. This will produce the value of Q. We know that fr = 1 / (2 pi sqrt of ( L C )). What was that rule? Oh yes, invert the divisor and multiply.

Q = (( 2 pi L ) / R )( 1 / ( 2 pi sqrt(LC))

Q = (2 pi L ) / ( R (2 pi sqrt(LC)))

Q = L / (R sqrt(LC))

This equation also gives the correct numerical answer. Now, we are sorry we cancelled those 2 pi terms. Lets put them back by multiplying by (2 pi) / (2 pi)

Q = (2 pi L ) / (R 2 pi sqrt(LC))

but,

fr = 1 / (2 pi sqrt(LC)

so

Q = (2 pi fr L ) / R

Since 2 pi fr L = XL we have,

Q = XL / R

QED

Example 2.19.

What is the resonant frequency of the circuit whose curves are plotted in Figure 2.20? Calculate the Q according to both definitions.

Solution:

The resonate frequency is where XL = XC. Equating these two quantities gives

2 pi f L = 1 / (2 Pi f C)

Solving this equation for f gives

f = one over the quantity 2 Pi square root of L C close quantity.

Substituting L = 79.6 mH and C = 0.318 uf gives the result 1000 hertz. The Q of the circuit according to equation 2.38 is Q = 1000 / (1052 - 952) = 10. The values of f1 and f2 were given on page 108. To find the Q by equation 2.39 we must first find a value for XL or XC at the resonant frequency. XL = 2 pi f L = 500 ohms. Q = X/R = 500 ohms /(50 ohms ) = 10.

Example 2.20.

Using all of the same values from the previous example, what is the voltage across the capacitor in the circuit of Figure 2.19a at the resonant frequency?

Solution:

At resonance XL = XC and by equation 2.37 Z = R;
therefore, I = 1 v / (50  ohms) = 20 mA.  The reactance of
the capacitor at resonance is XC = 1 / ( 2 pi fC ) = 500  ohms.
The capacitor voltage VC = I XC = 20 mA x 500  ohms = 10 v.

Notice that the voltage across the capacitor is Q times the input voltage. This is no coincidence. The voltage across the capacitor could be taken as the output voltage of the circuit. In that case only the voltages at or near resonance will be increased in amplitude. Voltages at frequencies far away from resonance will be attenuated.

One note of caution. The circuit is NOT increasing the power of the input signal. While more voltage is available, there is less current available. You don't get something for nothing.

Also you have no doubt noticed that f1 and f2 are not equally spaced about fR. Reactive circuits behave in a geometrical rather than an arithmetical manner. That is to say f2 - fR is not equal to fR - f1 but

f2 / fR = fR / f1

in this example to an accuracy of 0.15%. (The accuracy might have been better but the frequency was restricted to integer values.) The curve would be graphically symmetrical if it had been plotted on a logarithmic frequency scale. The Q of a circuit which resonates at a radio frequency can be as high as 250. The curves of such circuits cover such a small percentage of the frequency spectrum that there is no practical difference between a logarithmic and a linear scale.

The Imperfect Inductor.

In the study of electric circuits we are accustomed to thinking of every component as if it were perfect. We think of wires as having zero resistance, resistors as having exactly the specified value and capacitors as having no built-in resistance. The errors which result from these implicit assumptions are not large enough to get us into very much trouble. Of the three basic circuit components - resistors, capacitors and inductors - inductors are the most imperfect. To assume that inductors possess only the property of inductance would be a very large mistake.

Inductors are constructed by winding a length of copper wire on a hollow nonmagnetic, nonconducting tube (air core) or an iron bar (iron core). Other core materials are used such as powdered iron (ferrite) or brass. Both the wire and the core material introduce energy losses. When energy is lost, the effect is the same as having resistance in series with the inductor.

The copper wire actually has resistance. Certain inductors have many turns which means that the total length of wire is quite long. The amount of resistance can be significant enough to lower the Q of the circuit.

Figure 2.21 Equivalent Circuit of an Inductor.

For a verbal description click here.

The loss which is introduced by the core material also contributes to the equivalent resistance of the inductor. Any energy loss in a circuit can be accounted for by calling it resistance even though there is no measurable resistance in the circuit. A core which has losses will cause the inductor to act the same as if a lossless inductor were connected in series with a real resistor.

You may be wondering why iron and material other than air are used. If the only thing a core did was to introduce losses there would be no reason to use it. An iron core will increase the amount of inductors by as much as a factor of 1000 over the same coil with an air core. The gain in inductance is well worth the increase in core loss caused by the iron.

If iron is so good, why use anything else? The reason is frequency. The common laminated iron core* is only useful through the audio frequency band (up to 20,000 Hz). Powdered iron cores are useful up to about 30 MHz. The individual grains of iron powder are held together and insulated from one another by some sort of plastic material. Brass cores are used from about 30 to 200 MHz. Above 200 MHz even air core coils have only 2 or 3 turns and a solid core is not needed to increase the inductance.

* A solid iron core is useless in AC applications because of the excessive losses due to eddy currents. In a laminated core the iron is in thin sheets and the sheets are electrically insulated from one another.

Parallel Resonant Circuits.

Figure 2.22 is the diagram of a parallel resonant circuit. Circuits such as this are used much more often than are series resonant circuits. The impedance versus frequency curve for this circuit is shown in Figure 2.23. As you can see, the impedance is low at the extremes of frequency and rises to a maximum value at resonance. If a parallel resonant circuit is used as the load for a transistor, the gain of the amplifier will be maximum at resonance and very low away from resonance. Such an amplifier is called a frequency-selective or tuned amplifier.

Figure 2.22 Parallel Resonant Circuit.

For a verbal description click here.

Figure 2.23 Impedance Versus Frequency for a Parallel Resonant Circuit.

For a verbal description click here.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

2.11 Transformers.

A transformer is a device which will change the voltage and current of AC. A transformer can be used to step down the voltage of the power line for use by circuits which would be damaged by the full 120 volts of the power line. In addition the electric utility itself uses transformers to step the voltage up and thereby step the current down to minimize the power lost in long power lines. A transformer consists of two or more coils of wire wound on an iron core. The coils are usually wound one surrounding the other. The schematic symbol for a transformer is shown in Figure 2.24. The winding to which power is applied is called the primary winding and the winding from which the power is taken is called the secondary winding. Many transformers have more than one secondary winding.

Figure 2.24 Symbol for a Transformer.

For a verbal description click here.

To determine quantitatively how the voltage is changed by a transformer we must remember the equation

E = N d phi dt.

where E is the voltage across the coil, N is the number of turns on the coil and Phi is the magnetic flux linking the coil. For the two windings of a transformer we can write

E sub P = N sub P d phi sub P dt and E sub S = N sub S d phi sub S dt.

where the subscript P refers to the primary and the subscript S refers to the secondary. In a transformer the magnetic flux is so well confined by the iron core that almost all of the flux from the primary also links the secondary and visa versa. This means that Phi sub P = Phi sub S. We can divide equation 2.42a through by NP and equation 2.42b by NS and set them equal and rearrange terms to obtain the following equation.

EP / ES = NP / NS           (2.43)

Example 2.21.

A transformer has 2450 turns on its primary and 700 turns on its secondary. If 120 volts is applied to the primary, what is the secondary voltage?

Solution:

The secondary voltage is ES = EP NS / NP = 120 x 700 / 2450 = 34.29 volts.

Example 2.22.

In the case of the transformer from example 2.21 if the secondary current is 850 mA, what is the primary current?

Solution:

Transformers are so efficient that the efficiency may be taken as 100% without introducing serious errors. Therefore, the power in the secondary equals the power in the primary. PP = PS and EP IP = ES IS; therefore,

IP / IS = ES / EP           (2.44)

and so IP = 850 mA x ( 34.29 v / 120 v ) = 243 mA.

From equation 2.44 you might properly deduce that

IP / IS = NS / NP           (2.45)

A transformer which steps up the voltage will step down the current and vise versa. An electric utility will use transformers to step up the voltage to a very high value (as much as 300 kv) to send power over very long distances. When the voltage is stepped up, the current is stepped down. Most of the loss in power transmission lines is due to the resistances of the wires. Making the current as small as possible will minimize the power loss due to resistance. The voltage is stepped back down for distribution around cities and stepped down again just before being delivered to the customer.

Impedance Transformation.

A note about terminology

The term "impedance" is often used when the term resistance could be applied. This is correct usage because of the way in which impedance is defined. Impedance is a combination of resistance and reactance. The reactive component may or may not be zero. Therefore, it is possible to say "impedance" and mean "resistance". The reverse of this is not correct.

The apparent impedance of the primary of a transformer is given by ZP = EP / IP and the impedance in the secondary is ZS = ES / IS. If we substitute equations 2.43 and 2.45 into these impedance equations we have

Z sub P = E sub P over I sub P = E sub S over I sub S times quantity N sub P over N sub S end quantity over quantity N sub s over N sub P end quantity.

Inverting the denominator and multiplying we have.

Z sub P = Z sub S times the quantity N sub P over N sub S quantity squared.

Example 2.23

What is the turns ratio of a transformer to match an 8 ohm speaker to a 600 ohm line?

Solution:

Since power goes to a speaker, the 8 ohm speaker side is the secondary of the transformer. The power flows from the transformer to the speaker.

N sub P over N sub S = square root of Z sub P over Z sub S = square root of 600 over 8 = 8.66.

True, the number of turns must be an integer. A transformer manufacture would use many turns possibly 866 / 100 or more likely 8660 / 1000. Since we are working problems and not manufacturing transformers we can be content with what ever number comes out, even a number less than one.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

2.12 The Oscilloscope.

Almost all voltmeters have ranges designed for measuring AC voltage. Most DMMs have ranges for measuring AC current. If sine waves are involved, most voltmeters and ammeters will read out only the RMS value of the voltage or current. The limitations of voltmeters and ammeters are many. They cannot tell us anything about the waveform, the frequency, the phase or noise content of the AC signal being measured. Indeed, if the waveform is other than a sine, if the frequency is too high or if the signal contains too much noise, common AC voltmeters and ammeters will give us false readings.

The most useful instrument for making measurements on AC signals is the oscilloscope. The oscilloscope can be used to make quantitative measurements of voltage, frequency, rise-time of a square wave and phase between two signals. In addition an oscilloscope can be used to make qualitative evaluations of waveform and noise content. But that's not all. With various electronic and computer add-ons an oscilloscope can display the characteristic curves of semiconductor devices, plots of frequency response, phase diagrams of complex signals and frequency spectra and logic states (1s and 0s) in a microprocessor system. If you had to do electronics in a remote area of the earth or in space and you could take only one measurement instrument, the oscilloscope would be the unquestioned choice.

An oscilloscope is basically two instruments in one: a voltmeter and a time interval meter. The voltmeter portion is usually the Y axis, although the X axis may be used in some oscilloscopes for some special applications. The time interval portion is always the X axis.

The thing which sets the oscilloscope apart from all other electrical measurement instruments is the cathode ray tube (CRT). The CRT is one of the few vacuum devices which has not been replaced by a solid state equivalent. (For some years now the solid state replacement has been promised but so far it remains only a promise.)

BINGO! That promise has at last been fulfilled. I have, at this moment, sitting on my workbench an oscilloscope which has a front panel the same size as any classic scope but instead of being seventeen and a half inches deep it is four and a half inches deep. The CRT has been replaced by a liquid crystal display. Granted, at this writing, 2006, they are still rather pricy. But knowing the electronics industry, the price will come down and the CRT will fall out of favor, except for a small number of diehards who will insist that the CRT just looks better. I have to concede that is true but the advantages still outweigh the disadvantages. The following section on the CRT will be left in until this tube completely disappears from the scene.

The Cathode Ray Tube.

A simplified, two-dimensional drawing of a CRT is shown in Figure 2.25. Electrons are emitted from the heated cathode and are formed into a fine beam and raised to a high velocity by the accelerating electrode assembly. When the electron beam strikes the screen, a small dot of light appears. The color of this light depends on the material used in the screen.

Between the electron "gun" and the screen are two pairs of deflection plates. One pair is for deflecting the electron beam in the horizontal plane and the other set deflects the beam in the vertical plane.

Figure 2.25 Simplified, Two-dimensional Drawing of a CRT.

For a verbal description click here.

If the potential difference between the deflection plates is zero, the beam will fall in the center of the screen. Suppose that we make the top Y deflection plate positive with respect to the bottom one. Since like charges repel and unlike charges attract, the electron beam will be bent upward on its way to the screen and will strike the screen above the center. If the potential is reversed, the beam will be bent downward. The X deflection plates work in the same way to bend the beam in the horizontal plane. The voltage between the deflection plates is quite large, usually about 50 volts to move the dot one inch.

A block diagram of an oscilloscope is shown in Figure 2.26. We will briefly discuss each block. Because we have not yet studied amplifiers, we cannot look at specific circuits in this chapter.

The Vertical Amplifier.

Because of the high voltage required to deflect the electron beam, it is necessary to include an amplifier in an oscilloscope. As shown in the block diagram of Figure 2.26, the amplifier is between the Y input and the Y deflection plates of the CRT. The amplifier includes range switches to permit measurement of voltages from very small (1 millivolt) to somewhat large (100 volts). There is also a control to allow the operator to position the display anywhere on the screen (or even off of it). Some oscilloscopes have switches for reversing the polarity of the signal (turning the display upside down).

The vertical input is not only to look at the pretty picture. It can be used to measure voltage. There is a range switch which is calibrated in volts per division on the screen. This allows the oscilloscope to be used as a voltmeter to measure unknown voltages.

The Time Base.

In order to plot voltage versus time (which is what an oscilloscope does best), it is necessary to move the dot of light across the screen at a constant velocity. This is done by placing a ramp voltage on the horizontal deflection plates. A ramp voltage is one which is increasing at a constant rate and would have the equation V = Kt where K is a constant. Plotted versus time, such a voltage will be a straight upward-sloping line. The time base is often called the "sweep" because the electron beam is swept across the screen. The sweep is calibrated in time per division on the scope screen and a switch selects the various sweep rates.

The dot of light begins at the left edge of the screen and is swept across to the right edge. Before the sweep is returned to its starting point, the electron beam is turned off to darken the dot so that the return sweep will not be visible and confuse the operator. The beam retraces to the left hand edge of the screen in a small fraction of the time required to sweep from left to right. Upon reaching the left edge of the screen, the electron beam is turned on again and the dot begins another trip across the screen.

Figure 2.26 Block Diagram of an Oscilloscope.

For a verbal description click here.

Triggered Sweep.

The beam does not begin another trip across the screen immediately; it waits until some triggering event has occurred. The beam is kept dark until it is triggered. When triggered, it is turned on and begins another trip across the screen. The wave on the Y axis is, in most cases, what triggers the sweep to begin.

Because the sweep begins at the same point on the wave every time it repeats, successive sweeps fall exactly on top of each other and what the user sees is a stable display.

The Power Supply.

The power supply provides high voltage to the CRT to accelerate the electrons to a high enough velocity to make the screen glow. It also supplies operating voltages to all of the circuits in the oscilloscope. There are no operator adjustments in the power supply (unless you count the ON OFF switch).

Reading the Oscilloscope.

There are lines etched on the inside of the CRT screen which divide the screen into squares which are one centimeter on a side. The squares are further divided into 0.2 cm by small hash-marks. For some reason, oscilloscope manufacturers no longer call a cm a cm. They now call it a div for division.

The range switch of the voltmeter section is usually called the "volts/div" switch. To read the voltage being measured by an oscilloscope it is necessary to read the height of the wave on the screen (in div) and multiply it by the setting of the range switch.

Example 2.24.

A wave on the screen of an oscilloscope has a vertical distance between its positive and negative peaks of 5.35 div. The range switch is set to 0.2 volts/div. What is the peak-to-peak voltage of the wave?

Solution:

The peak-to-peak voltage usually written as the P-P voltage is the product of the peak-to-peak distance and the range switch setting. The P-P voltage is 5.35 div x 0.2 v/div = 1.07 volts.

The horizontal axis of an oscilloscope is actually a time interval meter. The range switch for the time interval meter is the time/div or sec/div (seconds per division) control. To make a time interval measurement it is necessary to multiply the horizontal distance between the two points by the setting of the sec/div switch.

Example 2.25.

The width of a pulse on the screen of an oscilloscope is 7.3 div and the sec/div switch is set to 5 us/div. What is the width of the pulse in units of time?

Solution:

The pulse-width is 7.3 div x 5 us/div = 36.5 us.

Example 2.26.

Eight cycles of a sine wave cover 4.45 divisions on the screen of an oscilloscope and the sweep range is set to 0.5 us/div. What is the frequency of the sine wave?

Solution:

The sweep range is just another name for the sec/div switch. The frequency is in hertz, which is cycles/sec.

f = 8 cycles / (4.45 div x 0.5 us/div) = 3.60 MHz.

The Times Ten Probe.

The input impedance of an oscilloscope is rather low as voltmeters go. A typical value is 1 M ohms of resistance in parallel with 50 pf of capacitance. For most measurements the resistance needs to be higher and the capacitance lower than the input impedance as stated.

Higher resistance and lower capacitance can be obtained by using a special probe with the scope. The input end of the probe contains a 9 M ohms resistor in parallel with a 50/9 pf capacitor. The 9 M ohms resistor in conjunction with the 1 M ohms resistance of the scope input will give a total input resistance of 10 M ohms but it will attenuate DC and low frequency input signals by a factor of ten. The capacitor in the probe must have an XC which is 9 times that of the XC of the input capacitance of the scope so that high frequencies are also attenuated by a factor of ten. The capacitor in the probe is adjustable and the probe should be "calibrated" before it is used.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

2.13 Problems.

  1. What is the period of an AC signal which has a frequency of 2175 hertz?

  2. An oscilloscope measurement shows a wave to have a period of 2.2 us. What is its frequency?

  3. What is the wavelength in meters of a radio wave whose frequency is 162.25 MHz?

  4. What is the frequency of a 75 meter long radio wave?

  5. What is the angular frequency of the 60 hertz line?

  6. What are (a) the peak and (b) the peak-to-peak voltages of the 120 volt AC line?

  7. An oscilloscope measurement shows an AC sine wave to have a peak-to-peak value of 9.5 volts. What is its RMS voltage?

  8. What is the reactance of a 470 uf capacitor at a frequency of 120 hertz?

  9. What size capacitor is required to have a reactance of 1 ohm at a frequency of 60 hertz?

  10. If a 100 uf capacitor is connected across a 10 volt 400 hertz AC source, how much power is dissipated by the capacitor.

  11. What is the reactance of a 2.5 mH coil at a frequency of 455 kHz?

  12. How much inductance is required to have a reactance of 1000 ohms at a frequency of 1000 hertz?

  13. In a series RC circuit the voltage across the resistor is 4.4 volts and the voltage across the capacitor is 3.5 volts. The resistance of the resistor is 560 ohms and the frequency is 60 hertz. (a) What is the reactance of the capacitor? (b) What is the capacitance of the capacitor? (c) What is the magnitude of the generator voltage? (d) If the phase angle of the resistor voltage is taken as zero degrees, what is the phase angle of the capacitor voltage? (e) What is the phase angle of the circuit current? (f) What is the phase angle of the generator voltage?

  14. A series RLC circuit is connected across a generator whose frequency is 100 kHz. The resistor is 100 ohms, the inductor is 5 mH and the capacitor is 390 pf. What are the magnitude and phase angle of the impedance?

  15. An RC high-pass filter uses a .01 uf capacitor and a 15 k ohms resistor. What is the attenuation ratio of this filter at frequencies of (a) 10 hertz, (b) 1 kHz and (c) 100 kHz?

  16. An RC low-pass filter is to use a 1 M ohms resistor. Select the capacitor for an attenuation of 50 dB at 60 hertz.

  17. Convert the following attenuation ratios to dB: (a) 0.707, (b) 0.316, (c) 0.178 and (d) 0.0316.

  18. Convert the following gain figures to dB: (a) 1, (b) 2, (c) 3.16 and (d) 17.78.

  19. Obtain a piece of semi-log graph paper and plot the frequency response data given below. See also problem 20 below.

    Frequency, Hz | dB | Frequency, Hz | dB | Frequency, Hz | dB
    1.00 Hz | -40.0 | 1,000 | -0.1 | 1,000,000 | -40.0
    1.78 -35.0 1,778 -0.1 --- ---
    3.16 -30.0 3,162 -0.4 --- ---
    5.62 -25.0 5,623 -1.2 --- ---
    10.00 -20.0 10,000 -3.0 --- ---
    17.78 -15.1 17,780 -6.2 --- ---
    31.62 -10.4 31,620 -10.4 --- ---
    56.23 -6.2 56,230 -15.1 --- ---
    100.0 -3.0 100,000 -20.0 --- ---
    177.8 -1.2 177,800 -25.0 --- ---
    316.2 -0.4 316,200 -30.0 --- ---
    562.3 -0.1 562,300 -35.0 --- ---

  20. As an alternative to problem 19, if you cannot find a piece of 6 cycle semi-log graph paper, try this. Take the common log of each frequency. Plot dB versus log of frequency on linear paper. BUT LABEL THE HORIZONTAL AXIS OF THE GRAPH WITH FREQUENCY NOT LOG OF FREQUENCY!

  21. As a more modern alternative, enter the above data into a program that will draw a graph on the computer screen or printout. Be sure to select log for the horizontal axis.

  22. A square wave has a peak voltage V of 25 volts. What are the peak values of: (a) the fundamental frequency; (b) the 9th harmonic; (c) the 50th harmonic; and (d) the 99th harmonic?

  23. A square wave has a peak-to-peak voltage of 266.6 volts and a frequency of 60 hertz. What is the RMS voltage of: (a) the fundamental frequency and (b) the frequency and RMS amplitude of the harmonic which falls immediately below 10 kHz?

  24. What circuit would you use to convert a 60 Hz square wave into a series of narrow pulses? Draw the circuit and give one of its proper names. It is not necessary to give component values.

  25. If you apply an AC plus DC voltage wave of the type VDC + VAC sin( wt ) to an integrating network which has a time constant much longer than the period of the sine wave, what will the output mainly consist of?

  26. A series resonate circuit is made up of a 2.5 mH inductor, a 48.9 pf capacitor and a 100 ohms resistor. What is: (a) the resonant frequency of this circuit? (b) the Q of the circuit? And (c) the 3 dB bandwidth of the circuit?

  27. In the circuit of question 26 the bandwidth is too narrow and must be increased to 30 kHz. This can be done by adding resistance to the circuit. If a resistor is added to increase the bandwidth to 30 kHz, (a) what is the new value of Q and (b) how much resistance must be ADDED to the circuit?

  28. A variable inductor which is used in the laboratory has a nominal resistance of 40 ohms at a frequency of 1 kHz. What is the Q of this inductor at this frequency for inductance settings of (a) 5 mH and (b) 50 mH?

  29. An all-electric home is drawing a current of 65 amperes at a voltage of 240 volts. What is the current on the primary side of the supply transformer if the voltage is 9200 volts?

  30. A certain transformer has a 120 volt primary and a 40 volt secondary which is rated at 2.5 amperes maximum. What is the minimum size fuse which should be used in the primary to protect this transformer from over-Load?

  31. A triangular wave is displayed on the screen of an oscilloscope. Points are given on the screen using Cartesian coordinates with the point (0,0) at the left side of the screen and centered top to bottom. The first positive peak of the wave is at (1.2,4.3), the first negative peak is at (3.9,-4.9), the second positive peak is at (6.6,4.3) and the second negative peak is at (9.3,-4.9). (a) If the voltage range is set to 20 mv/div, what is the P-P voltage? (b) If the sweep range is set to 50 us/div, what is the frequency of the wave?

  32. In question 31 if a times ten probe is being used, what are (a) the P-P voltage and (b) the frequency?

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

2.14 Answers to Problems.

  1. 460 microseconds.

  2. 455 kHz.

  3. 1.14 meters.

  4. 4.00 MHz.

  5. 377 radians per second.

  6. (a) 169.7 v, (b) 339.4 v.

  7. 6.72 v.

  8. 2.82 ohms.

  9. 2,650 microfarads.

  10. Trick question. The answer is the big zero.

  11. 7.15 k ohms.

  12. 159 millihenrys.

  13. (a) 445 ohms, (b) 5.95 microfarads, (c) 5.62 volts, (d) -90 degrees, (e) 0 degrees, (f) -38.5 degrees.

  14. 945 / -83.9 degrees.

  15. (a) 9.42 x 10-3, (b) 0.686, (c) 1.00.

  16. 0.839 microfarads.

  17. (a) -3.01, (b) -10, (c) -15.0, (d) -30.

  18. (a) 0, (b) 6.02, (c) 9.99, (d) 25.0.

  19. Whether you use semi-log graph paper,

  20. Liner graph paper, or

  21. a computer program the graph you get should look like this.

    For a verbal description click here.

  22. (a) 31.83 v, (b) 3.537 v, (c) 0 v, (d) 0.3125 v.

  23. (a) 120.0 v, (b) 0.7273 v and 9,900 Hz.

  24. High-Pass Filter. Differentiating Network.

    For a verbal description click here.

  25. All of the DC, very little AC.

  26. (a) 455.2 kHz. (b) 71.5. (c) 6.366 kHz.

  27. (a) 15.18. (b) 138.3 ohms.

  28. (a) 0.7854, (b) 7.854.

  29. 1.696 Amps.

  30. 0.8333 Amps.

  31. (a) 0.184 volts. (b) 3.704 kHz.

  32. (a) 1.84 volts. (b) 3.704 kHz.


Chapter 3   DC Power Supply Circuits.

3.1  Block Diagram of a Power Supply.
3.2  Protection Devices.
3.3  The Power Transformer.
3.4  The Semiconductor Diode.
3.4A The Vacuum Diode.
3.5  Rectifier Circuits.
3.6  Filtering the Rectifier's Output.
3.7  The Zener Diode Voltage Regulator.
3.8  Integrated Circuit Voltage Regulators.
3.9  Problems.
3.10 Answers to Problems.

Chapter 3.

DC Power Supply Circuits.

Most of today's electronic circuits operate from comparatively low DC voltages (5 to 15 volts). The Electric Utility supplies 120 volts AC. We have studied transformers and, therefore, we know that the 120 vAC line voltage could be stepped down to the range of 5 to 15 volts but it would still be AC. The internal circuits of any device you can think of from a stereo receiver to an oscilloscope will not operate on AC. These devices must have internal circuits which change the AC to DC. Such a circuit is called a "DC power supply" or more often just "power supply".

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

3.1 Block Diagram of a Power Supply.

Figure 3.1 Block diagram of a power supply.

For a verbal description click here.

Figure 3.1 shows the block diagram of a modern low-voltage regulated DC power supply. Each block has a specific purpose and will be dealt with in individual sections of this chapter.

The power supply is connected to the 120 vAC power line by a plug. Many power supplies (those used in laboratory equipment) have a plug with a third wire which connects the metal chassis of the instrument to earth ground. The fuse and switch constitute the protection circuits. The fuse helps to protect the power supply against circuit component failures and mistaken connections. The switch permits the power supply to be turned on and off. The transformer steps the 120 volts of the AC line down to the value required by the devices being powered. The rectifier changes the AC from the transformer to pulsating DC. The filter reduces the magnitude of the pulsations and smoothes out the DC. The regulator reduces the pulsations to a very small value and also holds the output voltage constant regardless of the load current. The regulator also contains circuits which will shut down the power supply if the load current becomes too large or the temperature of the regulator becomes too high.

If the power supply is part of something else, such as an oscilloscope, an FM tuner, or an amplifier the output of the power supply is delivered to the internal circuits of the instrument and is not available to the operator. If the power supply is a laboratory bench power supply, its output is connected to binding posts on the supply's front panel for the purpose of powering experimental circuits. A laboratory bench power supply may also include a voltmeter and an ammeter to permit the operator to monitor the voltage and current which are supplied to the load.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

3.2 Protection Devices.

All power supplies require protection from overloads and internal circuit faults. The most obvious protection device is a fuse. The type of fuse most commonly used in electronics equipment is a fine metal wire contained in a small glass tube with a metal cap on each end for electrical connection. The wire is made of a metal alloy with a low melting temperature, such as solder (40% led and 60% tin). If excessive current flows through the fuse the thin metal wire will melt, opening the circuit and turning off the current. Fuses of the type described above are manufactured in current ratings from 1/200 ampere to 30 amperes.

Fuses are often placed in the primary circuit of the transformer. If a transformer develops an internal fault it can catch fire if the power is not shut off by an open fuse. There should always be a fuse in the primary of a power transformer. Many low-cost "wall transformers" do not have fuses in their primary circuits. These units present a constant fire hazard to any building in which they are used.

There are two types of fuses, fast-acting and time delay. Time delay fuses are often called slow-blow fuses. Power supplies which have very large filter capacitors and semiconductor rectifiers will draw a very large current for a very short time after being turned on. Have you ever noticed a flicker of the lights when you turn on a transistorized stereo receiver? You are seeing the effect of a large current pulse which is charging up the capacitors in the power supply. A fast-acting fuse would most likely blow out the moment the power switch was thrown. A slow-blow fuse is used in such a case. Slow-blow fuses are used only if there is a large current pulse at the time of turn-on.

When selecting the current rating of the fuse, measure the current drawn by the device under normal operation and multiply this figure by 2. A smaller fuse than this will tend to burn out when nothing is wrong.

Other protection devices are electro-mechanical circuit breakers. A circuit breaker may use a thermal sensor to detect the heating in a small wire or the current may be detected by allowing it to flow through a coil of wire and become an electromagnet. If the temperature of the wire gets too high or the electromagnet becomes too strong, the circuit breaker will "pop out" and the circuit will be opened. The advantage of a circuit breaker is that it can be reset instead of having to be replaced, as do fuses. The major disadvantage of circuit breakers is that they are more expensive, more complex, larger and heavier than fuses. As current gets smaller, the circuit breakers get larger and more complex. Circuit breakers are usually not used for currents below 1 ampere.

In a sense the on-off switch may be considered as a protection device. If the operator smells something burning, he can use the switch to turn the power off. In a few cases a circuit breaker may serve double duty as an on-off switch. Most circuit breakers are not designed for repeated on-off cycles and will quickly wear out if used as on-off switches.

Most instruments include a small light which glows when the power is on and goes out when the power switch is turned off or the fuse blows.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

3.3 The Power Transformer.

A power transformer may have a secondary winding with a center tap, as shown in Figure 3.2a, or more than one secondary winding, as shown in Figure 3.2b.

Figure 3.2 Two types of transformers.

For a verbal description click here.

For a detailed discussion of transformers refer back to Chapter 2 of this book.

If you look in a catalog listing power transformers you will not find "turns ratio" mentioned even once. The specifications of power transformers are written in terms of primary and secondary voltages and maximum secondary current. You may read the following specification, "Primary, 117 vAC 50 - 60 Hz. Secondary, 24 vCT @ 1 A." The translation of this is "The transformer will operate on 117 volts ±10% at a line frequency of 50 or 60 Hz. If you apply 117 volts to the primary the voltage across the entire secondary will be 24 volts if the secondary current is 1 ampere. The maximum current which can safely be drawn from the entire secondary is 1 ampere." If this current is exceeded the transformer is in danger of burning out due to over heating.

Example 3.1

A transformer has the following specification: "Primary, 117 vAC 60 Hz. Secondary, 32 vCT @ 1.5 A." If the primary is connected to a source of 120 vAC, what voltage is measured from one side of the secondary to its center-tap?

Solution:

The ratio of secondary to primary voltage is a constant. 32 / 117 = V / 120. V = 32.82 v. The voltage measured from one side of the secondary to the center-tap is 1/2 that of the whole secondary or 16.41 v.

Occasionally, transformer manufacturers specify center-tapped secondaries in a slightly different manner. The transformer would be specified as follows: "Primary, 117 vAC 60 Hz. Secondary, 25 - 0 - 25 vAC @ 500 milliamperes." This means there are 25 volts from each side of the secondary to the center-tap or 50 volts across the entire secondary. The current rating is given for a type of rectifier known as a full-wave center-tapped rectifier, the two halves of the secondary are effectively in parallel and the current is doubled. Transformers used with vacuum tubes are more likely to be specified in this way because they are most likely to be used with a full-wave center-tapped rectifier.

Electrical Isolation.

It is possible to design equipment which can cope with the full voltage of the AC power line, thus eliminating the need for a transformer. However, transformers serve another purpose as important as changing the voltage. That purpose is to provide isolation of the circuit from the power line.

The argument might be made that one side of the 120 vAC line is connected to earth ground and no isolation is necessary. If a wiring error caused the leads to be reversed, the chassis of the instrument would be at a potential of 120 v with respect to earth ground. Such a wiring error did occur at the university I recently retired from. No one was injured but there was some soiled armor. It could be most unhealthy for anyone who might be unlucky enough to complete the circuit to ground.

In addition to safety considerations there are other reasons for not wanting a piece of equipment to be connected to the power line ground. The chief reason is noise. Noise is any electrical voltage or current in a place where it is not wanted. Noise voltages and currents are the weeds of electronics. In addition to bringing us the electric power we need, the power line brings us a lot of noise. One of the most effective noise removers is a transformer. The noise on a power line often has the same phase on both wires and, therefore, will not produce a magnetic field in the primary winding of a transformer. This is called common mode noise and will be discussed in more detail in the section on differential amplifiers.

In laboratories, recording studios, and radio stations, many different pieces of equipment are connected to work together. If each piece of equipment has its own earth ground and is connected to another piece of equipment, a phenomenon known as "ground-loop noise" appears. There are two possible solutions to this problem. One is to connect each piece of equipment to earth ground and make sure there is no electrical ground connection between individual pieces of equipment. The other is to connect only one piece of equipment to earth ground and make sure that there is only one ground wire from that piece to each of the other pieces of equipment in the setup. The isolation provided by the power transformer is absolutely vital to this "single point" grounding system.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

3.4 Semiconductor Diodes.

Before we can discuss rectifier circuits it is necessary to understand the semiconductor diode. An ideal diode is a device which will conduct current in one direction only. When current flows in the forward direction, the resistance of the diode is zero, the voltage drop is zero. When current attempts to flow in the reverse direction it encounters an infinite resistance. Absolutely no current will flow and the voltage can build up to any value demanded by the circuit. As with all other ideal things, the ideal diode does not exist in the real world but real diodes come close enough to be most useful.

Unfortunately, there is insufficient space here to cover the physics of semiconductors in detail. Whole books 1 have been devoted to this topic and there is a course in this department entitled "Solid State Physics" which interested students should enroll in. Meanwhile, we can only scratch the surface. Emphasis will be placed on visualization of the physical processes which are taking place.

1   Semiconductor Devices and Applications
    by R. A. Greiner McGraw-Hill 1961

A Semiconductor Is a Semiconductor Is a Semiconductor.

A semiconductor is not a very good conductor nor is it a very good insulator. It is a semiconductor. Two examples of semiconductor material are silicon and germanium.

Silicon and germanium each have 4 valance electrons in an outer shell which has room for 8 electrons. These elements (and carbon as well) form very stable tetrahedral crystals with the shared valance electrons filling the outer electron shell of each atom. If every electron stayed in place within the crystal lattice the crystal would be a perfect insulator. The electrons do not stay home.

Figure 3.3 Energy Diagram of a Semiconductor Material.

For a verbal description click here.

Figure 3.3 shows the possible energy levels for the electrons in a semiconductor crystal. When the electrons have a low energy level, they are in the valence energy band. Electrons which fall within this energy band will be bound to their particular valence bond. If an electron is given enough energy to jump over the forbidden energy band and enter the conduction band, it is set free from the valence bond and can move through the crystal.

The width of the forbidden band is called the band-gap energy. The band-gap energy for silicon at room temperature (300 degrees K) is 1.106 electron-volts (ev) and for germanium it is 0.67 ev. At room temperature there is enough thermal energy in the crystal lattice to promote some electrons to the conduction band.

Holes and Electrons.

Electrons which are in place in the lattice are in the valence energy band. Due to normal thermal agitation an electron can gain enough energy to move into the conduction band and leave its place in the lattice to become a conduction electron. An electron which has been promoted into the conduction energy band is free to move through the crystal under the influence of an electric field. But there is more to conduction in a semiconductor than conduction electrons.

When an electron leaves its place in the crystal lattice it leaves behind a hole in the lattice. Strange as it may seem, the hole does not stay in place but moves as if it were a positively charged particle. It has energy and even momentum. A hole can move by a nearby valence electron jumping from its place in the crystal lattice to the hole without entering the conduction energy band. After the electron has jumped, it leaves a hole where it used to be. Thus, the hole can move through the crystal lattice.

Thermal energy in the crystal lattice creates hole- electron pairs which move through the crystal. If there is an electric field present, the electrons will move toward the positively charged region and the holes will move toward the negatively charged region. If there is no electric field present, the holes and electrons will move randomly.

If you visualize a crystal of silicon warming up from absolute zero, hole-electron pairs will begin to form. This process cannot continue indefinitely or the crystal would come apart because all of its valence bonds would be broken. When holes and conduction electrons (electrons not held in a valance bond) become plentiful enough, electrons will begin to fall into holes they happen to run into. This process is called recombination and goes on at the same rate as hole- electron pair formation. The equilibrium between pair formation and recombination causes silicon and germanium crystals to be semiconductors at room temperature.

In pure semiconductor material the concentration of holes is the same as the concentration of electrons in the conduction band. (The total number of electrons cannot change, what we mean when we talk about changing the concentration of electrons, is the number of electrons which are free for conduction.) In pure silicon or germanium

Ne = Nh = KS T(3/2)           (3.1)

where Nh is the concentration of holes, Ne is the concentration of electrons in the conduction band, KS is a constant which must be determined experimentally and T is the Kelvin temperature. The value of KS is 4.74 x 1022 for silicon and 1.76 x 1022 for germanium. Ne and Nh have units of 1/m2.

We may now define the intrinsic charge carrier concentration ni as

Ni = KS T(3/2)           (3.2)

Equations 3.1 and 3.2 say that the charge carrier concentration is quite temperature dependent. Equation 3.2 defines the pure semiconductor or intrinsic charge carrier concentration.

Changing the Relative Concentration of Holes and Electrons.

Now suppose that we deliberately add some impurities to a crystal of pure semiconductor such as silicon. We are not going to just throw in some dirt from the floor; we will carefully control what goes in and how much.

If we add an element from group 5 in the periodic table the effect on a semiconductor is striking. The elements from group 5 have five electrons in the outer shell. Wherever one of these atoms appears in the crystal lattice, four of its outer electrons go into valence bonds and the fifth one becomes very loosely bound to its atom. A very small amount of energy (about 0.05 ev) is needed to promote this electron into the conduction band. Such an impurity is called a donor impurity because each atom donates an electron to the conduction energy band.

If we go back to pure silicon and add an element from group 3 in the periodic table the effect on a semiconductor is opposite to that for an element from group 5. The elements from group 3 have three electrons in the outer shell. Wherever one of these atoms appears in the crystal lattice, there are only three electrons in the outer shell to go into valence bonds. The unfilled valence bond is a hole. Once a wandering electron has fallen into this hole, a comparatively large amount of energy is required to promote that particular electron back into the conduction energy band. That electron and its three companions will remain in place and a hole will have been set free to wander through the crystal lattice. Such an impurity is called an acceptor impurity because each atom accepts an electron from the conduction energy band and causes a conduction hole to be created.

When a donor impurity loses its loosely-bound electron or an acceptor impurity captures a wandering electron (loses its loosely-bound hole), the impurity atom is said to be ionized. Ionization in a solid means the same thing it means in a liquid or gas, the loss of, or gain of an extra electron. When an impurity is added to a semiconductor, most of the impurity atoms are ionized most of the time, statistically speaking.

Because the impurity atoms are virtually 100 percent ionized, for every atom of donor impurity there is an additional electron in the conduction band. For every acceptor atom added, there is an additional conduction hole in the crystal. The meaning in this discussion is that donor impurity is added to one piece of semiconductor and acceptor impurity is added to another piece of semiconductor.

Recombinations occur when wandering holes and wandering electrons happen to collide. The probability of collisions goes up as the concentration of either holes or electrons goes up. When, for example, a donor impurity is added to a semiconductor, the increased concentration of electrons causes more frequent collisions and a higher rate of recombination. The recombination rate falls again when the hole concentration has been reduced to the point where a new equilibrium has been established. The end result is to decrease the concentration of holes in the crystal. It can be shown mathematically, in about ten pages, note 1, that

Ne Nh = ni2           (3.3)

where Nh is the concentration of holes, Ne is the concentration of electrons and ni is as defined in equation 3.2. Because the impurity atoms are completely ionized, the concentration of electrons is equal to the concentration of donor atoms Ne = Nd and for acceptor impurity Nh = Na where Nd and Na are the concentrations of donor and acceptor impurity atoms respectively. Thus it is possible to write for a semiconductor which has been "doped" with a donor impurity

Ne = Nd     and     Nh = ni2 / Nd           (3.4)

and for a semiconductor "doped" with an acceptor impurity

Nh = Na     and     Ne = ni2 / Na           (3.5)

Some Terms to Be Remembered.

As you may have guessed the process of adding impurity atoms to a semiconductor crystal is called doping. A semiconductor which has been doped with a donor impurity has many more negative charge carriers than positive charge carriers. This is known as N (negative) type semiconductor. A semiconductor which has been doped with an acceptor impurity has many more positive charge carriers than negative charge carriers. This is known as P (positive) type semiconductor.

There are two types of charge carriers, holes and electrons. A majority carrier is the type of carrier which there are more of in a particular type (P or N) of semiconductor. A minority carrier is the type of carrier which there are fewer of in a particular type (P or N) of semiconductor.

Example 3.2

Identify each of the following as majority or minority carriers: (a) electrons in N type semiconductor, (b) holes in P type semiconductor, (c) electrons in P type semiconductor and (d) holes in N type semiconductor.

Solution:

The majority carriers have the same charge polarity as the type of semiconductor in which they are found. The one which is left is the minority carrier. Thus, (a) majority, (b) majority, (c) minority and (d) minority.

The P-N Junction

Figure 3.4a shows a schematic representation of two blocks of semiconductor material. The block on the left is N type and the dots represent conduction electrons. The block on the right is P type and the circles represent the conduction holes. The concentration of minority carriers is so small as to be negligible at room temperature. In Figure 3.4b the two blocks of semiconductor material have been placed in physical contact. * As soon as contact has been established, the normal wanderings of charge carriers due to thermal agitation will cause some charge carriers to cross the junction. As soon as a carrier crosses the junction it

Drawing and graph.

Figure 3.4 "Making" a P-N Junction Diode

For a verbal description click here.

becomes a minority carrier. The probability of colliding with a carrier of opposite sign is very high and the wanderer will soon disappear by recombination with a carrier of opposite sign. There is a net movement of charge across the junction with electrons moving to the right and holes moving to the left. The departed electrons on the left leave behind the ionized donor impurity atoms which have a positive charge. The departed holes on the right leave behind the ionized acceptor impurity atoms which have a negative charge. That places an electric field across the junction, which is positive on the left and negative on the right. This electric field eventually builds up to such a value as to prevent any more electrons from moving to the right or holes from moving to the left across the junction. The graph in Figure 3.4b indicates the electric potential within the block of semiconductor material. The electric potential comes to zero at each end of the block; if it did not, we would have a cheap source of electricity.

*   This is not how P-N junction diodes are manufactured.
    In fact, this could not even be done in the laboratory.
    This is merely a thought experiment which illustrates
    how the depletion region and contact potentials are
    formed in a P-N junction.

The region near the junction becomes depleted of charge carriers in the conduction band. As stated above, there are ions in the depletion region but these ions are held in the crystal lattice and are not in the conduction energy band. The depletion region constitutes an insulator and the regions on either side of the depletion region which are not depleted of charge are conducting regions. This concept is very important. Failure to understand the depletion region will result in failure to understand how P-N junctions conduct in only one direction.

Animation, which is not possible in a paper book could not be done in any medium when I was teaching this subject. We have sure come a long way baby.

Figure 3.4c Animation showing Figure 3.4a and 3.4b in action.

For a verbal description click here.

When the two pieces of semiconductor touch, the electrons from the N side and the holes from the P side start to randomly wander across the junction. The animation shows holes and electrons making a beeline toward their opposite number on the other side. Randomness is much harder to do in animation so the much easier straight line path was taken. It cannot be over emphasized that when electrons and holes meet and mutually annihilate, nothing is being destroyed. The electrons remain in existence but their energy level has been reduced so they are no longer in the conduction energy band. The electron filled a hole so it no longer exists but it was never their in the first place.

Figure 3.5 Reversed and Forward Biased P-N Junction

For a verbal description click here.

Figure 3.5a shows a P-N junction with an external battery connected in such a polarity as to increase the potential across the junction. The effect of this is to increase the width of the depletion region and increase the potential across the junction. Notice that the positive terminal of the battery is connected to the N type semiconductor and the negative terminal of the battery is connected to the P type semiconductor. This condition is known as reverse bias. Under normal conditions no appreciable current will flow through a reversed biased P-N junction. It is true that minority carriers on the left (holes) are moving to the right across the junction and minority carriers on the right (electrons) are moving to the left across the junction. In modern P-N junction diodes this minority carrier current is so small that an electrometer is required to measure it.

Animation of figure 3.5a

Figure 3.5d Figure 3.5a in action.

For a verbal description click here.

In the animation it appears that the electrons on the left and the holes on the right are being absorbed by the end lines. On the left the electrons are being absorbed into the copper wire that makes contact with the semiconductor and sucked into the positive terminal of the battery. On the right there are electrons coming from the negative terminal of the battery and fed into the semiconductor. At the point of contact between the semiconductor and copper, electrons are combining with holes. The current will flow only when the voltage is changing. This is like a capacitance and is called the "charge storage capacitance", or "charge storage effect", of the diode.

The depletion region constitutes an insulator and the regions where there are charge carriers in the conduction energy band are conductors. This forms a capacitor. As the voltage changes the width of the depletion region changes, changing the amount of capacitance. Any P-N junction will show varying amounts of capacitance as the reverse voltage is changed. In rectifiers and small switching diodes this is only a few picofarads. Special diodes are available that have enhanced capacitance and are known as variable capacitance diodes or varicaps for short.

Figure 3.5b shows a P-N junction which is slightly forward biased. The first few tenths of a volt only serve to reduce the potential gradient across the junction and no conduction results. In Figure 3.5c the forward bias has been increased to the point where the contact potential has been overcome. The width of the depletion region has been reduced to zero, and current now flows in the forward direction. Notice that the positive terminal of the battery is connected to the P type semiconductor and the negative terminal of the battery is connected to the N type semiconductor. This condition is known as forward bias.

Forward biased animation.

Figure 3.5e Figures 3.5b and c in action.

For a verbal description click here.

A forward biased P-N junction will conduct large amounts of current at a voltage drop of less than one volt. As the current is increased in the forward direction, the voltage increases logarithmically as shown in Figure 3.6.

Graph of voltage versus current.

Figure 3.6 Voltage Versus Current Curve of a P-N Junction

For a verbal description click here.

The reverse bias on a P-N junction cannot build up to infinity. As the reverse bias voltage is increased, the electric field across the junction becomes so great as to rip electrons out of their valence bonds. The electric field imparts enough energy to valence electrons to promote them to the conduction energy band. The result is that we have a new source of conduction electrons. The newly freed electrons are accelerated to a high velocity and when they collide with other valence electrons, these valence electrons are also promoted to the conduction energy band. The current rises to a very large value and the voltage cannot rise any further. This condition is called avalanche breakdown but is sometimes mistakenly called Zener breakdown. Zener breakdown will be covered in a later section. Avalanche breakdown places a practical limit on how much voltage a P-N junction diode can withstand in the reverse biased direction.

A Derivation.

Get in touch with your inner physicist.

In the discussion above it was said that electrons from the N side of the junction will move towards the P side of the junction. We will call this current INN(0). The first subscript gives the polarity of the charge carrier and the second gives the type of semiconductor where the charge carrier originated. The "(0)" means with zero external bias applied. It can be shown that (note 1)

INN = INN(0) e-(eVd/kT)           (3.6)

and

IPP = IPP(0) e-(eVd/kT)           (3.7)

Under zero bias conditions there can be no net flow of holes or electrons across the junction; therefore,

INN = INP     and     IPP = IPN

That is to say there is an equilibrium of charge carriers so that the number of minority electrons crossing from P to N is equal to the number of majority electrons crossing from N to P. The same goes for holes. This means that

INP(0) = INN(0) e-(eVd/kT)           (3.8)

And

IPN(0) = IPP(0) e-(eVd/kT)           (3.9)

The "e" in the exponent is the charge on the electron, Vd is the diffusion voltage, k is Boltzmann's constant and T is the Kelvin temperature. If an external bias Vj is applied, these equations become

INN = INN(0) e-e(Vd-Vj)/kT           (3.10)

And

IPP = IPP(0) e-e(Vd-Vj)/kT           (3.11)

With an external bias applied the total junction current is

IJ = holes from P to N + electrons from N to P

IJ = (INN + IPP) e-e(Vd-Vj)/kT - IPN(0) - INP(0)           (3.12)

Combining this equation with equations 3.8 and 3.9 we have

IJ = ( INP(0) + IPN(0) ) (eeVj/kT - 1)           (3.13)

If we let IO = INP(0) + IPN(0) we have

IJ = IO (eeVj/kT - 1)           (3.14)

This is the "diode equation" and its derivation is obligatory in any discussion of semiconductor diodes.

For negative values of Vj (reverse bias) the limiting case is IJ = IO. IO is correctly called the reverse saturation current but is often called the reverse leakage current. For modern silicon P-N junction diodes the value of IO is of the order of 10-12 amperes.

For positive values of Vj the current will rise exponentially. Diodes are never used in circuits where the circuit determines the voltage. Diodes are used in circuits where the circuit sets the current and the diode itself is allowed to set its own voltage drop. With current as the independent variable the voltage rises logarithmically and will easily stay within realistic bounds.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

3.4A Vacuum Diodes.

A Minute Amount of History.

Cold Cathodes.

The very first diodes were made by Crookes. They were glass tubes with a metal electrode in each end and a place to connect a vacuum pump. Crookes didn't remove all the air from the tube. He found that an electric arc could be maintained over a much greater distance if the pressure was reduced to somewhere in the range between 1/10 to 1/100 of atmospheric pressure. He was using voltages of thousands of volts. The only thing distinguishing the anode from the cathode was which was connected to the positive of the voltage source and which to the negative.

Roentgen became curious about what would happen if the pressure was pumped down to as low as possible. He found that the arc stopped, leaving a faint greenish-blue glow. Measurements revealed that some current was flowing through the tube. The florescent material used to make watch dials glow in the dark was known in Roentgen's time and he had some in his laboratory. He happened to notice that this material glowed more brightly when the tube was in operation. He moved it closer to the tube and found that it glowed even brighter. Evidently the sample was in the form of a flat plate. Most likely it was coated on a glass plate like those used for photography in that time. When he interposed his hand between the florescent plate and the tube he probably got the shock, non electrical, of his life. He could see the outlines of the bones in his hand as shadows on the plate. That was the discovery of x-rays.

What was happening was that the strong electric field was pulling electrons out of the metal of the cathode, negative electrode, and they were being accelerated to a very high velocity and then impacting the anode. The incoming electrons had so much energy that they knocked other electrons out of the inner shells in the atoms of the anode metal. These electrons were replaced by electrons from the outer shells falling down to replace them. These large energy transitions caused the atoms to emit electro magnetic radiation of a very short wavelength, namely x-rays.

Hot Cathodes.

About this time Edison found that in a light bulb with two filaments, current would flow if the cold one was made positive with respect to the hot one but not if the polarity was reversed. He saw no use for this effect but noted it as curious.

It didn't take long for Roentgen and friends to put this discovery to use. They surmised correctly that a heated filament could emit electrons better than a cold piece of metal and the hot cathode was born.

Bulbs or Tubes?

All of this was taking place before 1900. You couldn't run down to your local Radio Shack and pick up a tube. If you wanted to experiment you had to make your own. The long slender tubes that were used by chemists were readily available but they couldn't resist pressure differences as well as a sphere. When it comes to blowing a glass bulb, a sphere was easier to form than a thin tube. That's why in those old pictures the devices are usually spherical bulbs rather than tubes. In fact writings from the early years of the 20th century in the united states refer to, what we would call a tube, as a bulb.

The Fleming Valve.

In England Fleming found that a device much like an x-ray tube, only much smaller, could be used to detect radio waves. He visualized it as working like a water valve but for electrons. It was called "The Fleming Valve" and to this day British techies and tinkerers call them electronic valves.

So What's a Diode?

The name diode comes from the Greek for two. Diodes have two elements, a cathode and an anode. The simplest diodes, and in fact the earliest ones, have a cathode which consists of a filament that can be heated to red or even orange hot by passing an electric current through it. The anode is a flat metal plate, often called the plate.

Thermeonic Emission.

Before we can understand thermeonic emission of electrons from a metal surface we need to understand how electrons behave inside a metal. Before we can understand how electrons behave inside a metal we must understand how electrons behave inside a nonmetallic solid. So here we go.

The atomic model proposed by Niels Bore is now considered hopelessly out of date. It is ridiculed by modern physicists but it is still a useful tool in understanding atoms for those who aren't going to get a PhD in the subject. The nucleus of the atom is positively charged and the negatively charged electrons spin around it a bit like the planets around the sun. It's a case of forces in balance like the solar system. The inner electrons are held very tightly and it takes a lot of energy to pull them out of orbit. The outer most are more loosely held and it doesn't take a lot of energy to pull them away from the nucleus.

At this point our solar system model starts to fall apart because an atom has things called shells. There is a maximum number of electrons that can exist in one shell. The innermost shell can hold up to 2 electrons, the second 8, the third 8, the fourth 18, the fifth 18 and the sixth 32. If the outermost shell is completely filled the atom is very unreactive, a kind of loner. These are the inert gases which refuse to form any sort of bonds with any other element. Carbon has its outer shell, which will hold 8 electrons, half filled. When several atoms of carbon get together they form very stable bonds with each other by sharing their outer electrons to make each atom feel as if its outer shell is completely filled. This is how diamonds are formed.

Many compounds are formed by sharing electrons in a partially filled outer shell. These are called covalent compounds. The bonds that hold the molecules together are known as covalent bonds. Some other compounds are formed by one, or sometimes two, electrons jumping from an atom of one element to an atom of another element. For example common table salt, sodium chloride, is formed when atoms of sodium give up the loan electron in their outer shells to an atom of chlorine which needs only one electron to fill its outer shell. The resulting positive and negative ions have a strong attraction for each other. These are known as ionic compounds.

If you could have a single atom of any element in isolation you would find that it takes a certain amount of energy to remove one electron from its outer shell. This energy varies considerably from element to element. Some need very large amounts of energy and others need much less. It always takes some energy to take an electron away from an atom in isolation.

When atoms of the same kind are clustered together, as is always the case, things change. In elements classed as metals the amount of energy required to remove an electron from its atom is zero. That's because the atoms are so close together that the electrons in the outer shells don't know to which atoms they belong. They all just wander around in there, moving randomly. If an electric field is applied externally the electrons will move in the direction the field wants them to and we now have an electric current in the metal. When there is no external field the movement is completely random.

All of these randomly moving electrons don't have the same velocity. There is a statistical value which depends on the temperature but some are faster, some are slower, and a very few are very fast. If one of these high speed electrons comes to the surface of the metal it can pass through the surface and leave the metal behind. If this happens many times the metal will develop a positive charge and subsequent would-be escapees will be attracted back to the surface.

When electrons escape from the surface of a metal it is called electron emission. If we set up a source of EMF and arrange things so the escaped electrons will be collected and the positive charge on the emitting metal is neutralized by the continuous replacement of electrons the process of electron emission will continue until the EMF source is removed. If the emitting metal is at room temperature the process is called cold emission. A very strong electric field is required to produce any significant current from cold emission. That means a high voltage applied between electrodes that are close together.

The piece of metal that is connected to the negative of the EMF and emits the electrons is called the cathode. The one that is connected to the positive and collects the electrons is called the anode. I am told that these names come from the Greek words for up and down but I couldn't begin to tell you which is which. It's all Greek to me.

Edison used to make experimental light bulbs with more than one filament to save work for his glass blowers. As related briefly above he found that conventional current would flow from a cold filament to a hot one but not the other way. This became known as the Edison effect. I don't think the existence of electrons had been recognized at this time. Conventional current flows opposite to electron current. This may well have been one of those serendipitous discoveries that seemed to occur often in early science.

As the temperature of the cathode is increased the electrons get to moving much faster than at room temperature. The likelihood of one having enough velocity to escape from the surface is tremendously increased. Hot emission does not require a strong electric field and will occur even in the absence of one. That can't go on very long because of the positive charge that develops on the cathode but it will build up a considerable space charge in an evacuated chamber. A space charge is a volume that has a lot of electrons floating around in it.

The carbonized filament that Edison used was not a very good emitter of electrons. The later tungsten filaments weren't either. Very early tubes used tungsten because that was all that was known. They glowed as bright as light bulbs. It was soon found that if a little thorium was alloyed with the tungsten the filament didn't need to run as hot and would still emit more electrons per square millimeter of filament surface. These are used to this day in transmitting tubes. They glow about the same color as the upper part of a candle flame.

The most efficient emitter is an oxide coated cathode. The discovery of this process made possible the heater-cathode type of tube. The electrical cathode is a small cylinder with the heater inside and electrically insulated from it. The heater is actually a filament but it is not the electrical cathode of the tube. Providing electrical insulation and thermal conductivity at the same time is not an easy thing to do. (The same battle is still being fought to provide cooling for transistors and microprocessors.) The end result is that the heater must be hotter than the cathode. If the cathode were thoriated, the heater would have to run so hot that it would not last long. In a heater-cathode tube the heater runs about the same temperature as a thoriated tungsten filament. The cathode runs a dull red but you can't see it in most tubes. The 6AS7G/6080WA has a gap in the plate and the grid wires can be seen. The cathode is visible between the grid wires and you need a fairly dark room to see its glow. Electrically separating the cathode from the heater had the effect of making circuits mor simple and meant that AC could be used to heat the tubes without inducing much hum in the signal path.

The hot cathode emits electrons in droves. Many more than are needed. They build up in the volume around the cathode and form a large pool of electrons just waiting for something positive to happen. This pool of electrons is called the space charge. When the anode (plate) is made positive some of the electrons are attracted to it. They impact on it, are absorbed into the metal and electrons flow out of the plate connection into the battery or what ever provided the positive voltage. The other end of the voltage source must be connected back to the cathode in some way.

If the polarity is reversed which makes the plate negative with respect to the cathode the electrons in the space charge are repelled away from the plate and no conduction takes place. The plate is cold and is made of a metal that is a very poor emitter of electrons. The voltages are not nearly as high as those used by Crooks so there is no cold emission from the plate. This makes the diode conduct current in only one direction.

Rectification.

Diodes can only do two basic things. These are 1) generate x-rays, and 2) rectify. Not many of us are interested in generating x-rays so let's talk about rectification.

The Space Charge.

The cathode of a tube is coated with a very special oxide that emits electrons very easily. It can readily be damaged by operating above or below the proper temperature or by being "poisoned" by the residual air in the tube. The space charge serves another vital function. There is no such thing as a perfect vacuum. In fact the space in near earth orbit is a better vacuum than can be made on the surface of earth. Farther out in space the vacuum is even better. What this means is there are lots of air molecules running around inside of a vacuum tube. The space charge protects the cathode from these air molecules. Some of these molecules lose an electron and become positive ions. They are attracted to the negative cathode and if it weren't for the space charge they would impact on the surface of the cathode doing considerable damage. Over time the ability of the cathode to emit electrons would be seriously impaired rendering the tube useless. As these ions run through the space charge they gain electrons from the many collisions and become negative ions. Their direction is reversed turning them away from the delicate cathode.

Indirectly heated cathodes.

Most vacuum tubes have a basically cylindrical configuration. Figure two shows how a filament (directly heated) cathode type diode differs from a heater (indirectly heated) cathode type diode.

Figure 3A.1 Construction of vacuum diodes.

For a verbal description click here.

In the filament type diode the cathode is usually a single wire running down the center of the cylindrical plate. In the heater type diode the filament is called the heater because that is its function. It is surrounded by a material which is an electrical insulator and a thermal conductor. The best known material having those properties is mica although aluminum oxide is most often used between heater and cathode. Outside of the electrical insulator is the cathode which is a cylinder with the special coating on the outside. The reason for having both types of tubes will be explained below.

Rectification.

The most important use of diodes is as a power rectifier. Rectification is the name given to the process of changing AC to DC. The process of detecting a radio signal also involves rectification. However, this process is more often called detection. The term rectification is reserved for power supply usage. Diodes are occasionally used for clamping, preventing a voltage from going above or below a given value, or clipping, preventing an audio signal from exceeding some preset level by knocking off the peaks. But by far the most common use of diodes is as rectifiers. The property of a diode that makes all this possible is its unidirectional conditivity.

Figure 3A.2 Forward and reverse connection of a vacuum diode.

For a verbal description click here.

Figure 3A.3 shows a directly heated cathode, filament, diode connected as a rectifier. As you can see from the wave forms this does not give the steady DC you are used to thinking of. For details about rectification and filtering see other sections of Chapter 3 of this book..

Figure 3A.3 Filament type diode used as a rectifier.

For a verbal description click here.

The entire filament and its supply winding are at a potential of several hundred, or even several thousand, volts above ground. The typical filament supply voltage is 5 volts so the difference has little effect on the operation of the diode. When I was a novice I used to wonder why all that voltage didn't burn out the 5 volt filament. What matters to the filament is the voltage from one end of it to the other end. If one end of the filament is at 350 volts and the other end is at 355 volts the only voltage to effect the filament is the difference of 5 volts. Consider this point carefully. It's VERY important that you understand it. If you don't understand, stop and think about it. Don't go on until you do. If you need to, email a question to me. I am the teacher in this class and answering questions is what I'm here for.

The disadvantage of a filament type rectifier, as compared to an indirectly heated cathode type, is that it requires a separate winding on the transformer or in big transmitters a separate transformer for the filament. The advantage is that the maximum voltage is limited only by the plate to filament insulation within the tube and the insulation in the filament transformer.

Figure 3A.4 Heater type diode used as a rectifier.

For a verbal description click here.

Figure 3A.4 shows an indirectly heated cathode type diode being used as a rectifier. Its heater can, and usually does, operate from the same voltage supply as the rest of the tubes in the device. Note that the heater winding is shown grounded. Also note that there is only one heater winding instead of two as in Figure 3. The insulation between the heater and cathode must withstand the full output voltage of the power supply. The best tube manufacturers were able to do was about 500 volts. Filament type diodes can be used to rectify thousands of volts.

Detection

The tubes used as power supply rectifiers are not the ones you would use for detection of radio waves. In the crystal set described else where on this site you could replace the crystal diode with a small tube such as a 6AL5 or 6H6. These tubes used as detectors may be referred to as thermeonic diodes, Fleming valves, or detector tubes. But whatever they are called they work just the same.

How I got hooked.

My lifelong addiction began, not with the building of a crystal set, but upon seeing an animated film on early TV showing how vacuum tubes worked. In my continuing attempts to pass on my addiction here is an animated picture showing the electrons in a diode serving as a rectifier. The voltmeter on the left is measuring the instantaneous voltage of the AC input to the rectifier. The voltmeter on the right shows the pulsating DC across the load resistor. You can see the electrons in the tube being attracted to the plate when it is positive and being repelled back to the filament when the plate is negative.

Figure 3A.5 animation of a rectifier in action.

For a verbal description click here.

Linearity.

Just as semiconductor diodes are non linear, the same is true of vacuum diodes. I'll spare you the derivation of the equation. Those who are interested are referred to the electrical engineering books used by their forbearers. The equation for the current in a vacuum diode is,

I = 2.335 x 10-6 A V3/2 / d2           (3A.1)

Where V is the voltage between cathode and plate, A is the cathode area, and d is the distance between plate and cathode. The area term is why high current rectifier tubes such as the 5U4 are bigger than RF detector diodes such as the 6AL5.

When a vacuum diode is used as a detector, where linearity is necessary, the current is set to a small enough value so the V term will not become significant compared to the input AC voltage. Below is a plot of this equation were A = 0.001 square meters and d = 0.00125 meters.

Figure 3A.6 I-V Curve of a Fictitious Power Rectifier Tube.

For a verbal description click here.

The values were estimated from a 5U4 and based on tube manual data I think I am in the general ballpark but don't use this curve to predict the behavior of a real 5U4 in a real circuit.

In power supply circuits the nonlinearity doesn't make a bit of difference. The only goal is to allow current to flow in one direction and a bit of nonlinearity doesn't matter.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

3.5 Rectifier Circuits.

A diode, whether vacuum or semiconductor, conducts current in only one direction. At typical current values the forward voltage drop of a semiconductor diode is 0.7 to 1 volt while the drop across a vacuum diode is typically 25 to 150 volts.

This large disparity in forward voltage drop means that a power supply must be designed to use either tube or semiconductor diodes and you can't change later. There are still some of those so called "solid state tube replacements" floating around. DON'T USE THEM! Installing them in existing equipment can result in 100 volts or more of additional B+ and you can do serious damage to what ever you put them in. I have nothing against the use of semiconductor diodes as long as the circuit has been designed for them.

It is the function of a rectifier to change AC to DC. In single phase circuits the rectifier changes the AC to a pulsating DC and some additional circuits are needed to change the pulsating DC to a smooth DC. In this section we will look at a few rectifier circuits.

The schematic symbol for a P-N junction diode is a triangle with a line across its point as shown in Figure 3.7. The triangle is the P side and the line is the N side of the junction. The P side is called the anode and the N side is called the cathode. Conventional current will flow in at the anode and out at the cathode. Current will flow in the direction of the arrow. Current will not flow from cathode to anode. Electron current flows in the opposite direction as conventional current. When current is flowing in the forward direction, the anode is more positive than the cathode by about 0.7 volts. If the cathode is positive with respect to the anode, no measurable current will flow and the voltage can have any value up to the rated maximum PIV (peak inverse voltage) or PRV (peak reverse voltage) of the diode. Typical silicon diodes have PIV ratings in the range of 50 to 1000 volts. Vacuum diodes of the type found in consumer equipment may have PIV ratings from 350 to 1500 volts. Rectifier tubes designed for use in high power transmitters may have PIV ratings in the thousands of volts and maximum currents in Amps.

These drawings are being used because they already exist. When vacuum rectifiers are used the circuits aren't any different. Just substitute a vacuum diode for the semiconductor diode shown and provide power for the filament or heater.

Figure 3.7 Half-wave Rectifier.

For a verbal description click here.

The circuit of a half-wave rectifier is shown in Figure 3.7 above, along with its output waveform. When the top end of the transformer secondary is positive with respect to the bottom end, current will flow from the anode to the cathode of the diode. The forward drop across the diode is small compared to the voltage of the transformer and almost all of the voltage appears across the load resistor. The positive half-cycle appears across the load. When the top end of the transformer secondary is negative with respect to the bottom end, current will not flow through the series combination of the diode and load resistor. If there is no current through the load resistor, there can be no voltage drop across it. The voltage of the transformer secondary is dropped across the diode and does not appear across the load resistor. Thus we have only half of each cycle appearing across the load. This should be called half-cycle rectification but it was named in the early years of electricity (prior to 1920) when people were not as careful with their terminology as we are today. The process which is going on in Figure 3.7 is called half-wave rectification and the circuit is called a half-wave rectifier.

Figure 3.8 Full-wave Center-tapped Rectifier.

For a verbal description click here.

Figure 3.8, above, shows the circuit and output waveform of a full-wave rectifier. You will note that the pulsations occur twice as often in Figure 3.8 as they do in Figure 3.7. A higher rate of pulsations is easier to smooth out. It is for this reason that a half-wave rectifier is very rarely used. Figure 3.8 is called a full-wave center-tapped rectifier circuit. A transformer with a center-tapped secondary is required to construct this circuit. The two diodes and the two halves of the transformer work alternately. They can handle twice as much current as either one working alone.

On the first half-cycle when the top end of the secondary is positive with respect to the center-tap the bottom end is negative with respect to the center-tap. (Note that the load is returned to the center-tap, not to the bottom of the secondary.) Diode D1 is forward biased and D2 is reversed biased. D1 conducts current which flows through the load and back to the center-tap. The first half-cycle appears across the load with the top end of the load resistor positive. On the second half-cycle the top of the secondary is negative with respect to the center-tap and the bottom is positive with respect to the center-tap. Diode D1 is reversed biased and D2 is forward biased. D1 does not conduct but D2 does. Remember that the bottom end of the transformer secondary is now positive and when D2 conducts, current flows downward through the load resistor, making its top end positive. Current flows through the load on both halves of the input sine wave and both halves appear positive across the load. This process is called full-wave rectification and the circuit is called a full-wave center-tapped rectifier.

The peak output voltage VP of this rectifier is

VP = 1.4 x (VRMS / 2) - Rect Drop.             (3.17)

where VRMS is the voltage of the entire transformer secondary. Try to understand rather than just memorize. Each half of the transformer winding works alternately so at any given instant only half of the winding is in use. The output voltage is that of only half of the secondary. The factor Rect Drop is the diode drop. The two diodes work alternately and not at the same time. Therefore only one diode drop is subtracted.

Figure 3.9 Full-wave Bridge Rectifier.

For a verbal description click here.

Figure 3.9, above, shows a bridge rectifier circuit. Its output wave looks the same as for Figure 3.8. Because the bridge rectifier uses the whole transformer secondary all of the time, it will deliver twice the voltage at half the current as a full-wave center-tapped rectifier circuit.

When the AC voltage goes positive on the first half-cycle, current flows through D1, down through the load and back to the junction of D3 and D4. The current will not flow through D3. That would be equivalent to a river flowing up a hill. The current flows through D4 to a point of lower electrical potential. On the second half-cycle, current flows through D2, down through the load and back to the junction of D3 and D4. The current will flow through D3 back to the transformer secondary. Regardless of the direction of current in the transformer secondary winding the current always flows downward in the load resistor. The peak output voltage of this rectifier is given by.

VP = 1.4 x VRMS - 2 (Rect Drop)                 (3.18)

where VRMS is the voltage of the entire transformer secondary winding. Try to understand rather than just memorize. The bridge rectifier connects across the entire transformer secondary winding. Each time the current path is traced, it goes through two diodes in series. For this reason you must subtract two diode drops from the output voltage.

Figure 3.10. Two different voltage doubler circuits.

For a verbal description click here.

The circuit of a full-wave voltage doubler is shown in Figure 3.10a above. A voltage doubler circuit will not work without smoothing capacitors. If in the circuit of Figure 3.7 we place a capacitor in parallel with the resistor, the output wave will change. It will now be an almost smooth line at a voltage equal to the peak value of the waveform previously obtained. (Sneak a peak ahead at Figure 3.11. I won't tell if you won't.) If we connect two Figure 3.7 circuits to one transformer (with one diode turned around) we have the circuit of a full-wave voltage doubler as shown in Figure 3.10a. Let us assume that the circuit of Figure 3.10a has been energized for several seconds and both capacitors are charged to their equilibrium voltages. The polarity of charge on the capacitors is as indicated in Figure 3.10a. On the first half-cycle the top of the secondary goes positive with respect to the bottom and current flows through D1 to recharge capacitor C1, which discharged slightly since the last time the top of the transformer went positive. When the top of the secondary goes negative, current flows through D2 replenishing the charge on C2. This circuit consists of two half-wave rectifiers with their outputs connected in series so the output voltage is twice that of one alone.

The charge on C1 is replenished 60 times per second as is the charge on C2. The charges are replenished alternately instead of at the same time; therefore, the total charge is replenished 120 times per second, which qualifies the circuit as a full-wave rectifier.

Figure 3.10b is a variation of the voltage doubler. It has the advantage that one side of both the source and load can be grounded. It has the disadvantage that it is only a half wave rectifier. This circuit is often used in test equipment to obtain the peak to peak value of the incoming wave.

When the input goes negative D1 conducts charging C1 to the peak value of the input with the polarity shown. C1 holds its charge and that voltage is added to the input voltage. When the input goes positive the charge on C1 is added to the peak voltage from the source. This gives a voltage equal to twice the peak or the peak to peak voltage. The wave form at the junction of D1 and C1 is a sine wave which is entirely above the zero axis. D2 rectifies this voltage and charges C2 up to the peak to peak value of the input wave. The charge on C2 is only replenished once for each input cycle or 60 times a second. The peak output voltage of both rectifiers is the same and is given by

VP = 2 (1.4 x VRMS - 0.7).           (3.19)

where VRMS is the voltage of the entire transformer secondary. Try to understand rather than just memorize. The entire peak secondary voltage is used to charge C1 and then C2. They are in series aiding and the voltage is twice the peak voltage of the secondary. In this circuit as in the bridge there are two diodes effectively in series and so the two diode drops are added together.

Example 3.3

A full-wave center-tapped rectifier circuit (Figure 3.8) employs a transformer which is specified as 9 vCT @ 1 A. What is the peak voltage this rectifier will deliver with semiconductor rectifiers?

Solution:

The full-wave center-tapped circuit uses only half of the secondary at a time; therefore, the output will be the peak of half of the secondary.

VP = (1.4 VRMS / 2) - Rect Drop

VP = 1.4 x 9 / 2 - 0.7 = 5.6 volts.

You could draw 1.4 A from this circuit because the two halves of the secondary are effectively connected in parallel but you are using the peak voltage.

Example 3.4

A full-wave center-tapped rectifier circuit (Figure 3.8) employs a transformer which is specified as 4.50 - 0 - 4.50 vAC @ 1.5 A. What is the peak voltage this rectifier will deliver?

Solution:

The specification means that the entire secondary voltage is 9 vAC; which is exactly the same as Example 3.3 above. The solution to this problem is exactly the same so there is no need to repeat it.

Example 3.5

A full-wave bridge rectifier (Figure 3.9) employs a transformer which has a 9 volt CT @ 1 A secondary. What is the peak output voltage of this rectifier circuit?

Solution:

The center-tap is not used. The peak output voltage is given by

VP = 1.4 VRMS - 2 x 0.7 = 1.4 x 9 - 1.4 = 11.2 volts.

Remember, these calculations are not all that precise. The available current is 0.7 A maximum.

Example 3.6

A voltage doubler rectifier (Figure 3.10) employs a transformer which has a 9 volt @ 1 A secondary. What is the peak output voltage of this rectifier circuit?

Solution:

The voltage doubler gives twice the peak voltage of the secondary

VP = 2 x (1.4 VRMS - Rect Drop) = 2 x (9 x 1.4 - 0.7) = 23.8 volts.

The original transformer is 9 V at 1 A which is 9 Watts. You can't ask for any more than 9 watts from the rectifier output.

IMax = 9 W / 23.8 V = 0.37 A

This is the maximum current without damage to the transformer.

You have no doubt noticed that the answers in all of the above examples have been rounded off quite a lot. Calculations involving power supplies are among some of the least accurate in electronics. The chief variable in the system is the line voltage provided by the electric utility. In the United States the agreed upon value for the line voltage is 120 volts ± 10 volts. When extra heavy consumer demand drives the utility to the wall, it may even reduce the voltage to 105 volts or less. The writer has personally observed the line voltage at his home and in his office to vary from a low of 114 volts to a high of 128 volts depending on the time of day and season of year. People who design power supplies normally allow large safety margins to prevent malfunctioning of equipment when the line voltage is high or low. With such large safety margins the additional digits of the square root of 2 are just not important. The diode drops should always be taken into account because they lead to a pessimistic design which provides an additional safety margin.

Maximum current.

In the above examples we have sighted a maximum current without fully explaining it. Now we will. You have to think in volt amps. You likely recognize this as watts of power. Lets take the examples above as a starting point. The original transformer was 9 volts at 1 amp. That means 9 watts. If you try to draw 9.1 watts you could get away with it because of some small amount of safety factor built into the design of the transformer. If you try to draw 18 watts you won't have a working transformer for very long.

The available current for the various connections is as follows.

Full-Wave Center-Tapped. IMax = PMax / (1.4 x VRMS / 2)

Full-Wave Bridge Rectifier. IMax = PMax / (1.4 x VRMS)

Voltage Doubler Rectifier. IMax = PMax / [2 (1.4 x VRMS)]

Notice that the diode drops are not subtracted. The power dissipated by the diodes is taken from the transformer and even if it is not available to the load must still be taken into account as power delivered by the transformer.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

3.6 Filtering the Rectifier's Output.

Filtering is another name for smoothing. Figure 3.11 shows a full-wave rectifier, one filter capacitor and the output waveform. Power supplies for semiconductor circuits always have additional filtering elements which usually take the form of electronic circuits. Vacuum tube power supplies always have additional filtering elements such as LC (inductor - capacitor) and/or RC (resistor - capacitor) sections. The critical part of most filters is the first capacitor.

Figure 3.11 Rectifier, Filter and wave forms.

For a verbal description click here.

On a positive half-cycle the capacitor will charge through the series combination of half of the transformer secondary winding and diode D1. Because this is a low resistance current path the capacitor will charge quickly. When the positive half cycle falls away, the diode is reverse biased and cannot conduct any current. The capacitor will discharge through the resistor until another positive half cycle comes up to recharge it. The heavy red line shows the voltage across the capacitor and the normal black line shows what the voltage would be without the capacitor.

The lower the resistance of the resistor (the greater the load current), the faster the capacitor will discharge and the lower will be the voltage when the next positive half-cycle comes along. A way to keep the voltage from falling so low between the times when the capacitor is charged is to make the capacitor bigger. Because a full-wave rectifier is being used the charging peaks occur more often than would be the case for a half-wave rectifier. Thus the capacitor will not have as much time to discharge and the voltage will not fall as low as it would with a half-wave circuit. The amount of ripple (variation) in the voltage across the capacitor is given by.

Delta V = (I/C) Delta t                     (3.20)

Now the only question is "how long is delta t?" It is the period of the wave - the charging time. The writer has invested a great deal of work in deriving equations for the ripple voltage (delta V) taking the charging time into account and subsequently many hours in the laboratory attempting to verify the results experimentally. The equations did not predict the voltage any better than plus or minus 20%. These equations did not do any better than setting delta t = a little less than the period of the wave in equation 3.19. The conclusion is to set delta t = 8 ms approximately (1/120) for a full-wave rectifier or 16 ms approximately (1/60) for a half-wave rectifier. These numbers would be different for someone living outside of North America. Solving equation 3.19 for C gives

C = (I Delta t)/(Delta V)                     (3.21.1)

One more definition is necessary. That is the Valley voltage VV. The valley voltage is exactly what you would think it is, the lowest voltage of the ripple. It may seem a little tricky in a negative power supply so we define the valley voltage as that part of the ripple wave which comes closest to zero. The peak voltage of the ripple, VP, is that part of the wave which is farthest from zero.

VV = VP - Delta V                     (3.21.2)

Example 3.7

A 25.2 vCT @ 1 A transformer is being used in a full-wave center-tapped power supply which is to deliver 150 mA to the heater of a 12AX7 (DC heater supply to reduce hum). (a) Calculate the correct capacitor to give a ripple of 1.2 volts or less, (b) calculate the DC voltage at the capacitor, (c) the value of the resistor required to apply 12.6 volts to the heater of the tube, and (d) the wattage of the resistor.

Solution:

(a) Using equation 3.21.1 for C gives

C = (0.15 A x 8 ms)/(1.2 V) = 1000 microfarads.

(b) The DC output voltage is

VDC = 1.4 x 25.2 / 2 - 0.7 = 16.94 volts.

That's the peak voltage. The DC is the average voltage which is half of the ripple less than the peak voltage or 16.94 - 1.2 / 2 = 16.34 volts; let's call it 16.3 volts.

(c) The resistor is given by ohm's law as follows.

R = (16.3 - 12.6) / .15 amps = 24.7 ohms.

Use a 24 ohm resistor.

(d) The power dissipated by the resistor is given by

P = I squared R = .15 squared x 24 = .54 watts

Use a 1 watt resistor. Most designers would likely connect another 1000 microfarad capacitor from the other end of the 24 ohm resistor to common as shown in the figure below.

Figure 3.12.1 DC Heater Supply for 12AX7.

For a verbal description click here.

Example 3.8.1

A full-wave bridge rectifier is to be used with a transformer which is rated as 28 vCT @ 2 A. The capacitor is 2200 uf and the load current is 1.3 A. What is the ripple voltage?

Solution:

Using equation 3.19 we have,

Delta V = (I/C) Delta t = (1.3 A / 2200 rf) x 8 ms = 4.7 V.

As compared to physical reality, this is a pessimistic prediction.

Example 3.8.2

A full-wave bridge rectifier is to be used with a transformer which is rated as 280 vCT @ 250 mA. The capacitor is 22 mu f and the load current is 85 mA. What is the ripple voltage?

Solution:

Using equation 3.19 we have

Delta V = (I/C) Delta t = (85 mA / 22 mu f) x 8 ms = 30.9 V

As compared to physical reality, this is a pessimistic prediction.

Additional Filtering LC section.

Electronic voltage regulators are not often used in vacuum tube circuits. When lower ripple is desired from a power supply than can be obtained from a single capacitor, additional filtering elements are added to the filter. For example an LC section may be added to the single capacitor filter to obtain the circuit shown below.

Figure 3.12.2 Full-wave rectifier and C-L-C filter.

For a verbal description click here.

The inductor has a low resistance to DC but a much higher reactance to the AC ripple. Because it is a series element it drops very little DC while dropping a large amount (most of it in fact) of the AC. The second capacitor presents an open circuit to the DC but a low reactance to the AC ripple. It, together with the inductor, forms a voltage divider which reduces the ripple to a very low level. If X is much greater than XC the ripple across C2 is given by

VC2 = VC1 (XC2) / (XL)               (3.22)

where

XL = 2 pi f L                     (3.23)

and

XC2 = 1 / (2 pi f C2)                 (3.24)

Substituting equations 3.23 and 3.24 into equation 3.22 gives.

VC2 = (VC1) / (4 pi squared f squared L C2)               (3.25)

The DC voltage drop across the inductor (filter choke) is usually small enough to be neglected.

Additional Filtering RC section.

If an RC section is added to the single capacitor filter we have a circuit like that shown below.

Figure 3.12.3 full wave rectifier and C-R-C filter.

For a verbal description click here.

The resistor has the same resistance to DC and AC. Because it is a series element it drops a moderate amount of DC while dropping a large amount (most of it in fact) of the AC. The reason the resistor drops more AC than DC is because the second capacitor presents an open circuit to the DC but a low reactance, almost a short, to the AC ripple. It, together with the resistor, forms a voltage divider which reduces the ripple to a very low level. If R is much greater than XC2 the ripple across 2 is given by

VC2 = VC1 (XC) / (R)                 (3.26)

where

XC2 = 1 / (2 pi f C2)                   (3.27)

Substituting equation 3.27 into equation 3.26 gives.

VC2 = (VC1) / (2 pi f R C2)               (3.28)

The DC voltage appearing across C2 is given by

VDC-C2 = VDC-C1 - ILoad R               (3.29)

Where ILoad is the sum of all DC load currents taken off from C2, C3, C4, Etcetera. Additional series R and parallel C sections may be, and often are, added on the end of the circuits of 3.12.2 or 3.12.3. Each added capacitor is numbered C3, C4, etc.

Example 3.9

A filter like that of Figure 3.12.2 has two 22 microfarad capacitors and an 8 Henry filter choke. The ripple voltage across C1 is 31 volts (Example 3.8.2). What is the ripple voltage across C2?

Solution

Using Equation 3.25 gives.

VC2 = (VC1) / (4 pi squared f squared L C2)

VC2 = 31 vAC / (4 pi squared x 120 squared x 8 henrys x 22 mu f = 0.31 vAC.

Example 3.10

A DC power supply like that of Figure 3.13 uses a transformer with a high voltage winding having a rating of 325 - 0 - 325 volts at 100 mA. (This current rating is for a capacitor input filter so the factor of 1.4 has already been accounted for.) It uses a 5Y3 rectifier tube and an RC filter with two 40 mu f capacitors and a 1 k ohm resistor. The DC load taken off at C1 is 80 mA and the load taken off at C2 is 15 mA. What are (a) the ripple across C1, (b) the ripple across C2, (c) the DC voltage across C1, and (d) the DC voltage across C2?

Solution

(a) The ripple across C1 is given by equation 3.19 which is.

Delta V = (I/C) Delta t

We must use the sum of the currents for I in this equation which is 95 mA.

Delta V = (95 mA/40 mu f) 8.3 ms = 19.7 volts.

Let's call it 20 volts.

(b) The ripple across C2 is given by equation 3.28.

VC2 = (VC1) / (2 π f R C2)

VC2 = 20 / (2 π 120 1000 40 mu f) = 0.66 volts.

(c) Using equation 3.17 gives

VDC = 1.4 VRMS / 2 - Rect Drop = 1.4 x 650 / 2 - 125 = 330 volts

The graphs in the tube manual for the 5Y3 give an output voltage of 330 volts for a load of 95 mA and a voltage on each plate of 325 volts.

(d) The voltage across C2 is given by equation 3.29 as

VDC-C2 = VDC-C1 - ILoad R = 330 V - 15 mA x 1000 Ω = 315 VDC

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

3.7 Zener Diode and Gas discharge Voltage Regulators.

Preliminary, Classes of Voltage Regulators.

There are two classes of voltage regulators, series and shunt. The way a voltage regulator works is to place a variable resistance element either, in series with, or in shunt with the voltage to be regulated. Figure 3.12.1 shows a shunt regulator in (a) and a series regulator in (b).

Figure 3.12.1 Shunt and Series Regulators.

For a verbal description click here.

The Shunt Regulator.

Circuit (a) is a shunt regulator. The variable resistance element works to keep the voltage across the output terminals constant. It's resistance changes as needed to accomplish this. The load, which is connected across the output terminals, must operate at a voltage lower than the lowest output voltage of the rectifier and filter.

Let us say that the regulator is operating normally. Then the voltage of the rectifier/filter increases. For the load voltage to remain constant there must be an increased voltage drop across the fixed resistor. Ohm's law tells us that the current through the resistor must increase. The regulator element, inside the red box, will change its resistance to draw more current and the output voltage remains constant.

Now suppose the load current decreases a little. This would cause a decreased drop across the fixed resistor but the regulator compensates by decreasing its resistance to take more current. If the load current goes all the way to zero the regulator will take it all.

If the load current increases the regulator current will decrease to keep the voltage across the output terminals constant. However if the load current increases to the point where the regulator current goes to zero that's as far is it can go. After all the regulator is a variable resistor so it can't generate additional voltage. If the load current keeps increasing after the regulator current has gone to zero the voltage will fall below the regulated value because the regulator is powerless to prevent it from falling below the set voltage. This is the chief disadvantage of a shunt regulator. The regulator will also lose control if the rectifier/filter voltage falls so low that the regulator current goes to zero.

A regulator of this type wastes a lot of power. The current through the regulator must be set above the maximum current that the load will ever take. If this happens for only a small percent of the time and operates at say 1/10 of that value most of the time the shunt regulator will always draw the highest current from the rectifier/filter. If the rectifier/filter were replaced by a battery, it would be discharged very quickly by the large amount of current demanded by the shunt regulator.

The Series Regulator.

In Figure 3.12.1 (b) above the series regulator is connected in series with the load. This type will hold the voltage across the output terminals constant. It does this by comparing the output voltage to a reference voltage and using vacuum tube, transistor, or operational amplifiers (op amps) to amplify the difference and control the pass element. The actual pass element may be a transistor, or vacuum tube, but we don't know about such things yet so we will just think of it as a variable resistor that uses some form of magic to sense the voltage across the output terminals and adjust itself.

Notice that there is no extra resistor in the circuit. Whatever current the load draws, that much current will flow through the regulator, and the same amount will be drawn from the rectifier/filter. The voltage from the rectifier/filter can change up or down and the series regulator element will adjust it's resistance to compensate. The load current can change up or down, even to zero, and the series pass element will adjust to compensate. Series regulators are more efficient than shunt regulators because in the absents of load current they draw very little current from the source. The amplifiers that make it work need a little current but it isn't very much. In general a series regulator can operate with its input and output voltages closer together than for a shunt regulator. That makes them more efficient and a better choice for regulating the voltage in battery operated equipment.

Shunt Zener Diode Regulator.

If a specially manufactured P-N junction diode is reversed biased it presents a constant voltage characteristic. This constant voltage characteristic is perfect for a shunt voltage regulator.

If the doping level (amount of impurity) is increased in a P-N junction the reverse breakdown * voltage will be decreased. When a P-N junction breaks down in the reverse direction, the voltage is held constant (regulated) even though the current may vary over a large range. The typical characteristic of a P-N junction is shown in Figure 3.13. The portion in the first quadrant is the same as any other P-N junction diode. The portion in the third quadrant is the reverse breakdown * characteristic. As the voltage increases in the negative direction, nothing happens until the voltage reaches the constant voltage breakdown point. When this point is reached, the current goes up very rapidly and the voltage will not increase any further. If an attempt is made to force the voltage higher the diode will overheat very quickly and burn out.

* The term "breakdown" does not mean a malfunction as it does
  to an auto mechanic. In semiconductor talk "breakdown"
  means the beginning of conduction of current. A diode
  which has broken down does not have to be replaced; it is
  just beginning to go to work.

Figure 3.13 I-V Curve of a P-N Junction Diode.

For a verbal description click here.

There are two mechanisms of reverse breakdown, Zener and avalanche. In Zener breakdown (named for its discoverer Clarence Zener) the electric field intensity in the depletion region becomes so great as to promote electrons from the valence energy band to the conduction energy band. The electrons on the P side move toward the junction and contribute to conduction. Electrons which are freed on the N side cause holes to be created which move toward the junction and also contribute to conduction. The threshold at which electrons begin to be promoted is very sharp and the so- called Zener breakdown voltage is very constant. Zener breakdown takes place up to about 6.2 volts.

If the doping has not been increased to the level where the reverse breakdown is below 6.2 volts, the mechanism is avalanche breakdown. When the electric field becomes intense enough to promote electrons to the conduction band they are accelerated by the field. These newly freed electrons collide with other valance electrons and promote them to the conduction band which in turn collide with other valence electrons promoting them to the conduction band et cetera, et cetera. Avalanche breakdown occurs if the breakdown voltage is greater than about 6.2 volts.

As you might expect the transition from Zener breakdown to avalanche breakdown is not a sudden one but a gradual one. That has interesting consequences because of the temperature coefficients of the two processes. Avalanche breakdown has a positive temperature coefficient and Zener breakdown has a negative temperature coefficient. At the voltage where the two effects play an equal role in reverse breakdown the temperature coefficient is exactly zero. This is at a voltage of 6.1 and some more decimal places.

It used to be literally true that diode manufacturers would make a batch of diodes and then test them to see what they had made. That is no longer completely true but when Zener diodes are being manufactured in the neighborhood of 6 volts, they are carefully tested. The ones which fall exactly on the magic zero temperature coefficient voltage are pulled out and sold for ten dollars a piece as reference diodes. The ones which don't pass this test are sold as 6.2 volt 5% units for seventy five cents or as 5.6 volt 10% units for forty cents. The manufacturing cost is a fraction of a cent per diode. The cost is in the testing. Even though the mechanism may be avalanche breakdown, the diodes are called Zener diodes.

Uses for the Zener Diode.

Zener diodes are sometimes used to set an upper limit to a voltage. Because it draws essentially zero current before breakdown it works well in this application. Suppose an input circuit of an amplifier is meant to operate from zero to 10 volts but would be damaged if the voltage exceeded 12 volts. A 12 volt zener diode can be placed across the input and will have no effect on voltage within the intended range of the amplifier but will conduct and prevent the voltage from going higher than the damaging value of 12 volts.

Zener diodes are also used as voltage regulators. They were formerly used to regulate voltage in both low and high power circuits. Units were available in power ratings from 1 to 50 watts. In modern electronics the Zener diode is used to provide voltage references to high power regulators. The Zener diode is a low power unit and a power transistor takes care of any heavy work. Power transistors cost much less than power Zener diodes. Zeners are now available as 0.4, 1, and 5 watt units.

A typical circuit for a Zener diode voltage regulator is shown in Figure 3.14. The input is an unregulated power supply consisting of a circuit such as Figure 3.11 without the resistor. The load current which is drawn from the output can range from a few nanoamps to several tens of milliamps.

How a voltage regulator works and what it does.

A voltage regulator has to hold the voltage constant as the voltage of the input varies and as the load current changes. The output voltage of a rectifier and filter capacitor is not constant. As mentioned earlier the line voltage can vary all over the place and then there is that ripple which is always present. Another application is in battery operated equipment. In many cases the designer of such equipment wants the voltage applied to the circuits to remain constant as the batteries run down. The battery voltage is set higher than the circuit needs and the regulator holds it constant until the voltage gets near the operating voltage. Special circuits usually warn the operator and/or turn off the equipment when the battery is so run down as to no longer operate the device.

Changing load current is another difficulty. We have used resistors to indicate the load on a power supply. The real load on a power supply is a transistor circuit and/or a small motor or two. The current drawn by a transistor circuit may change depending on what the circuit is and what it is doing at the moment. The current drawn by a motor changes as its mechanical load changes. So a regulator may have a lot to do.

A regulator can't increase the voltage applied to it. All it can do is reduce it. It regulates the voltage by reducing it by the amount required to hold it at some preset value. The difference between the regulator input and the output is called the regulator drop. Each type of regulator has it's minimum regulator drop. If the input voltage falls so low as to make the regulator drop less than the minimum the regulator will lose control and the output voltage will fall.

For example, a 12 volt regulator IC has a minimum drop of 2 volts. That means that the input voltage must be 14 volts or higher. It regulates just fine for input voltages anywhere from 14 to 40 volts. But if the input voltage falls to 13 volts the output voltage will fall to 11 volts and it will no longer be regulated. It will just be 2 volts less than the input, ripple and all. If the ripple valley falls below the minimum required the output voltage will acquire ripple as shown in the graph below.

Figure 3.14 Input and output waves of a voltage regulator.

For a verbal description click here.

The upper wave is the output of a full wave rectifier with a capacitor filter. The lower wave is the output voltage of a voltage regulator. In (a) the input voltage is high enough that the regulator is able to do its job properly. In part (b) increased load current has pulled the ripple valley down so it is below the minimum required to maintain regulation. Note that the peak voltage is the same in both cases. This is the way ripple responds to increased load current.

A measurement with a DC voltmeter is likely to indicate that the input voltage is high enough but the ripple valley is too low. Only an oscilloscope measurement will reveal this defect. I have taught the senior projects course in the electrical engineering department for several years and I have found this to be one of the most common mistakes in circuit design.

The Zener Diode Voltage Regulator.

There is one thing about the following calculations you may find peculiar. The maximum allowable current in a zener diode is that which gives 1/4 of the rated power. The specified power rating for almost all semiconductor devices is given for the temperature of the silicon crystal to be held to 25 degrees C. This is stated in the literature as the junction temperature. About the only way to achieve this with a zener diode would be to operate it amerced in a stirred and cooled oil bath.

The power can be increased to about 1/2 of the specified power by mounting the diode through a hole in a heat sink and coating it with heat sinking compound. The hole should be sized so the diode is a tight fit and the sink should be as thick as the diode is long. When the diode is operated in open air the maximum power is 1/4 of the specified power. Operation at higher power will cause the diode to overheat and fail.

Figure 3.15 Zener Diode Voltage Regulator Circuit.

For a verbal description click here.

To design a zener diode circuit you only need to specify the zener diode, voltage, and power, and the resistor RA, resistance, and wattage rating. After the value of RA is fixed, the minimum regulation voltage must be determined. Remember that the Zener diode holds its voltage constant. If the input voltage changes, the voltage across RA must change. Remember Kirchhoff's law? VIN = VRA + VZ where VIN is the input voltage, VRA is the voltage across RA and VZ is the voltage across the Zener diode. If VZ is constant, VIN and VRA will rise and fall together. The current through RA is also proportional to the voltage across RA. Let us assume that there is a load of 1 mA on the output of the regulator. That means that of the current through RA, 1 mA will flow through the load and the rest will flow through the Zener diode because IRA = IL + IZ. The power in the Zener diode is PZ = IZ VZ. Normal practice is to set the current through the Zener diode to such a value as to dissipate 25% of the diode's rated power. Regulation can be maintained as long as the current through the Zener diode is greater than zero. If the current tries to reverse, it cannot and regulation will be lost. The zener diode can't become a battery and hold the voltage up if the input falls below the minimum input voltage. Solving this problem is nothing more than the repeated application of Ohm's and Kirchhoff's laws and should not require any memorization.

The rules for design are as follows.

  1. Calculate the Zener diode current for 25% of rated power.

  2. Add any load current to this Zener current. This is the current through RA.

  3. Subtract the Zener voltage from the average expected input voltage.

  4. Use results of 2 and 3 in Ohm's law to calculate the resistance of RA.

  5. Calculate the minimum input voltage for regulation to be maintained. This value must be below the ripple valley voltage of the power supply.

  6. Calculate the power dissipation of the resistor based on the average ripple voltage. *

  7. Calculate the maximum power dissipated by the zener diode based on minimum load current, often zero, and average input ripple.

* because the power is proportional to the square of the voltage, using the average voltage is not quite correct. However, for realistic values of ripple the error is so small as to be unimportant.

Example 3.10.

An unregulated power supply delivers a ripple peak of 21 volts and a ripple valley of 19 volts. The Zener diode regulator circuit is to deliver 12 volts at 2 mA and will use a 12 volt 400 milliwatt Zener diode. What is (a) the value of RA, (b) the average power dissipated in RA and (c) the minimum input voltage to maintain regulation?

Solution:

The ripple waveform may be approximated as a series of straight lines and the average is simply (VP + VV) / 2 or (21 + 19) / 2 = 20 v. 25% of 400 mW is 100 mW; therefore, IZ = 100 mW / 12 v = 8.3 mA. (a) The value of RA is

RA = (VIN - VZ) / (IZ + IL)

RA = (20 v - 12 v) / 8.3 mA + 2 mA) = 780 ohms.

(b) Power in RA is P = (20 v - 12 v)2 / 780 ohms = 0.082 W

(c) Let IZ = 0.

VIN = VZ + IL RA = 12 v + 2 mA x 780 ohms = 13.6 volts.

This is much less than the ripple valley voltage of 19 volts, so the circuit will work.

The only resistors which come in what ever value you need are .05% precision resistors and these are very, very expensive. In common laboratory work we must use what the manufacturers of resistors supply us. The result of (a) in the above example was 780 ohms. In standard 5% resistor values the two closest values are 750 and 820 ohms. In this case you would tend to choose 750 ohms because it is the closest one and you would be doing the right thing. In Zener diode circuits you should always move down to the next lower value. The calculations of parts (b) and (c) should be based on the actual resistor used rather than the calculated value.

The writer considers the memorization of the table of standard values to be a waste of time and effort. This is information which can always be looked up if and when it is needed. A table of standard values is given in the appendix for those who need to look them up.

Example 3.11.

An unregulated power supply delivers a ripple peak of 39 volts and a ripple valley of 25 volts. The Zener diode regulator circuit is to deliver 16 volts at 1 mA and will use a 16 volt 1 watt Zener diode. What is (a) the value of RA, (b) the average power dissipated in RA and (c) the minimum input voltage to maintain regulation?

Solution:

The average input voltage is (39 + 25) / 2 = 32 volts. The Zener diode current is IZ = 0.25 x 1 W / 16 v = 15.6 mA. (a) RA = (32 - 16) / (15.6 + 1) = 964 ohms. The next lowest standard value is 910 ohms and that is what we will use. (b) The power is (32v - 16v)2 / 910 ohms = 0.28 watts. It is best to use a 1/2 watt resistor here. (c) The minimum input voltage is 16 v + 1 mA x 910 ohms = 16.91 volts. The circuit will work.

Zener diode voltage regulators are occasionally used to regulate the voltage for low current circuits when a design goal is to keep it simple. Because it is a shunt regulator it wastes too much power to be used in a battery operated device.

Zener diodes are most often used in conjunction with other circuits such as op amps and power transistors. We will return to these circuits later after we have studied these devices.

If You Need a High Power Zener.

Although zener diodes are no longer available in powers above 5 watts, (1.25 watts in practice), they can be obtained in voltages up to 100 volts. If you need to regulate a voltage at high current and/or high voltage, relatively speaking, you can use a transistor to effectively amplify the power of a zener diode.

Figure 3.15.1 Amplified Zener Diode Voltage Regulator Circuit.

For a verbal description click here.

As the input voltage increases the transistor remains an open circuit until it experiences base current. There is no base current until the zener diode begins to conduct so the whole thing is an open circuit until the zener voltage + 0.6 volts is reached. When the zener does begin to conduct the transistor also begins to conduct but the collector current is typically 100 times as large as the current through the zener diode and into the base. If you need a high power shunt regulator This is the circuit for you. Remember the turn on voltage is 0.6 volts higher than the zener voltage.

Gas Discharge Regulator Tubes.

Prior to the invention of the zener diode the only regulating devices were gas discharge regulator tubes, commonly known as voltage regulator or VR tubes. These are cold cathode diode tubes filled with one of the inert gases. The pressure is low, about 1/100 of an atmosphere. They come in four voltages, 75, 90, 105, and 150 volts. The only gas I can identify with a specific voltage is neon with the 75 volt tube.

The workhorse set is the octal series, 0A3, 0B3, 0C3, and 0D3. The 0A3 is the 75 volt tube and the 0D3 is the 150 volt regulator. The current range is 5 to 40 mA for all tubes. There is a 7 pin miniature series 0A2, 0B2, and 0C2. Their voltages are 150, 105, and 75 respectively. Their maximum current is 30 mA.

The design procedure is almost the same as for the zener diode, with one exception. The glow discharge in the tubes require a higher voltage than the operating value to get the ionization started. This value is different for each tube and must be looked up in a tube manual. The initial voltage of the power supply must be above this starting value and the starting current of the load must be zero or very small. If the load is resistive, the voltage of the power supply must be large enough to place the starting voltage on the tube even with the load drawing current. The schematic symbol of a VR tube can be seen in a diagram at the end of this chapter.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

3.8 Integrated Circuit Voltage Regulators.

The design and construction of power supplies using series regulators has been made extremely simple by the introduction of the integrated circuit voltage regulator. The IC VR could not possibly be any simpler. It has three terminals: an input, an output and a ground (common). It is often called a three terminal regulator. The acronym "TTR" has never been seen or heard by the writer. The schematic symbol for the IC VR is just a rectangle with 3 lines (wires) connecting to it.

These regulators regulate very well against changes in load current and changes in input voltage. Most of the ripple voltage which is present in the output of the unregulated power supply is regulated out by the IC VR. The IC contains a current sensor and the voltage will be shut down if the load tries to draw too much current. The IC also contains a temperature sensor and, if the IC gets too hot, the voltage will be shut down. When the power is turned off the IC will cool down and the power will be turned back on again. The observable results of an IC VR which is getting too hot is that the voltage will be turned off and on periodically.

One undesirable thing that these little wonders do rather well is to oscillate at a frequency of approximately 1 Megahertz. This oscillation can cause lots of trouble and headaches for research lab workers (graduate students). The way to prevent these oscillations is to connect a 0.1 uf capacitor on each side of the regulator, one from input to ground and the other from output to ground. These capacitors must be physically close to the regulator or they will not do any good. A regulator which does not have these capacitors will, not may, but WILL, oscillate. In addition to these capacitors, the unregulated power supply must have its filter capacitor and a capacitor in the neighborhood of 25 uf connected across the output of the voltage regulator. Figure 3.16 is the circuit of a typical 5 volt 1 amp power supply.

Figure 3.16 Complete 5 Volt 1 Amp Power Supply.

For a verbal description click here.

These IC VRs come in a wide variety of shapes and sizes but by far the most popular are the LM78XX and LM79XX regulator series. These are supplied in a TO220 (see appendix B) package which must be attached to a heat sink if it is to deliver any more than 100 mA. The LM78XX are positive regulators and the LM79XX are for regulating negative voltage power supplies. The "XX" gives the output voltage of the regulator. For example an LM7805 is a +5 volt unit, an LM7812 is a +12 and an LM7915 is a -15 volt unit. All of these units will accept input voltages of VO + 2 to 40 volts for a positive regulator and VO - 2 to -40 volts for a negative regulator. They will deliver a maximum of 1 ampere and are current limited at about 1.5 amperes.

There is another series of regulators which are very useful in low power circuits. They are the LM78LXX and LM79LXX series. These regulators are supplied in a TO92 package and have a maximum current rating of 100 mA. These units usually do not need a heat sink. The small package makes it possible to construct a very small low-power power supply.

Adjustable Voltage Regulators.

If you need a voltage in between the voltages of the fixed regulators, or you want to build a variable voltage power supply, there is another set of voltage regulators which have adjustable output voltages. The positive regulator is an LM317 and the negative regulator is an LM337. A possible disadvantage of these regulators is that their voltage will not go all the way to zero. Here is the circuit using an LM317.

Figure 3.17 Circuit of an adjustable voltage regulator.

For a verbal description click here.

This circuit works because the voltage between the O and A terminals is fixed at 1.2 volts, and current flowing out of the A terminal is very small. The fixed output voltage causes the current through R1 to be constant. The small current in the A terminal causes the current in R2 to be essentially equal to the current in R1. This means that the drop across R2 will be constant and set by the values of R1 and R2.

Example 3.12.

If R1 is 100 ohms and R2 is 1100 ohms, what is the output voltage of the circuit?

Solution:

The voltage between the O and A terminals is 1.2 volts so the current in R1 is,

I = 1.2 / 100 = 12.0 mA.

The current in R2 is also 12 mA so the voltage across R2 is,

V = 12.0 mA x 1100 ohms = 13.2 volts.

This is not the output voltage, it is the voltage between common and the A terminal. The voltage between the o terminal and common is the sum of the voltage between common and the A terminal and the voltage between the A and O terminals or,

13.2 + 1.2 = 14.4 volts.

A triple output 1.2 to 20, -1.2 to -20, and fixed 5 volt, power supply is shown in Figure 3.18. The diodes across the output are to prevent either supply from being pulled to the opposite sign by the other power supply. If this happens, the supply will latch at -0.7 volts and will not come up to its normal voltage.

Figure 3.18 Triple Voltage Power Supply.

For a verbal description click here.

Vacuum Tube Voltage Regulator.

Some vacuum tube circuits require regulated voltage. These include such things as the amplifiers in Vacuum Tube Volt Meters (VTVM), The screen grids of high power amplifiers, and oscillators in communications receivers and transmitters. These applications are not usually high current. It is not necessary to regulate the plate voltage of a power amplifier. If the voltage needed does not fall on one of the 4 VR tube values an electronic circuit must be used. Here is a simple regulator circuit.

Figure 3.19 Vacuum Tube Voltage Regulator Circuit.

For a verbal description click here.

The 0A3 is a VR tube as described above. If the device containing the regulator were to be operated with the VR tube unplugged some circuit components could be damaged. The connection between pins 3 and 7 of the tube is a jumper. If the tube is removed from its socket there will not be any output from the circuit because the negative lead is open. Removing a positive voltage from something will usually result in less current rather than more.

This circuit will not go to zero voltage. One that will, needs a negative voltage supply and can get more complicated. This circuit is as simple as it can get and still be a true closed loop* regulator.

* A closed loop regulator is one in which the output voltage
  is sensed, compared to a reference voltage, and if the
  output voltage changes it is instantly corrected
  to the set voltage.
A common feature of regulators is that the heater of the pass tube, the 6AQ5 in this circuit, is operated from a separate filament transformer. The maximum heater to cathode voltage for most tubes is 200 volts so a regulator capable of output voltage higher than this must have such a transformer. One side of the heater is tied electrically to the cathode so the voltage difference is no more than the peak of the 6.3 volt heater supply voltage.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

3.9 Problems.

  1. The unregulated portion of a power supply is delivering 18 volts at a current of 1 ampere. What size (current rating) fuse should be used in the primary of the transformer?

  2. A power transformer has the ratings 34 - 0 - 34 v @ 3 amps. If this transformer is used with a full-wave center-tapped rectifier circuit, Figure 3.8, what is the peak output voltage VP? Take diode drops into account.

  3. A power transformer has the ratings 36 vCT @ 2 amps. If this transformer is used with a full-wave center-tapped rectifier circuit, Figure 3.8, what is the peak output voltage VP? Take diode drops into account.

  4. A power transformer has the ratings 21 vAC @ 5 amps. If this transformer is used with a full-wave bridge rectifier circuit, Figure 3.9, what is the peak output voltage VP? Take diode drops into account.

  5. A full-wave voltage doubler circuit (Figure 3.10) is attached to a transformer whose secondary is rated at 120 vAC @ 10 amperes. (This is an isolation transformer.) What is the peak output of this circuit? Take diode drops into account.

  6. A power transformer is rated as 40 - 0 - 40 vAC @ 1.2 amps. The transformer is equipped with a full-wave center-tapped rectifier using silicon diodes and a filter capacitor of 7,000 microfarads. What is the ripple valley voltage of this circuit if the load current is 0.8 ampere? Apply all corrections.

  7. A power transformer is rated as 20 vAC @ 7 amps. The transformer is equipped with a full-wave bridge rectifier using silicon diodes and a filter capacitor of 20,000 microfarads. What is the ripple valley voltage of this circuit if the load current is 5 amperes? Apply all corrections.

  8. Using the transformer and rectifier from problem 6, calculate the value of the filter capacitor to give a ripple valley voltage of 45 volts if the load current is 0.8 amps.

  9. Using the transformer and rectifier from problem 7, calculate the value of the filter capacitor to give a ripple valley voltage of 17 volts if the current is 5 amps.

  10. A 12 volt 300 mA transformer is being used with a bridge rectifier which is to deliver 10 mA to a load. An uninformed person uses a 20,000 uf capacitor in the power supply. What is (a) the peak output voltage and (b) the difference between the peak and valley voltages?

  11. For the conditions of problem 10, what size capacitor should be used to give a ripple valley voltage of 14 volts?

  12. A 6.2 volt 400 mW Zener diode is to be supplied from an unregulated power supply which has a peak output voltage of 26 volts and a ripple valley voltage of 22 volts. The load current on the regulator is approximately 1 picoampere. (a) Calculate the resistance of RA. (b) Select the proper value for RA from the table of standard values in the appendix. (c) Calculate the power dissipated in the resistor. (d) Calculate the minimum input voltage to maintain regulation. Restrict your answers to no more than 3 significant digits.

  13. What is the highest tolerable peak output voltage from the rectifier for each of the following regulators: (a) LM7805, (b) LM7912, (c) LM7812, (d) LM7915, and (e) LM7824? Don't forget the signs.

  14. What is the lowest tolerable ripple valley output Voltage, closest to zero, from the rectifier for each of the following regulators: (a) LM7805, (b) LM7912, (c) LM7812, (d) LM7915, and (e) LM7824? Don't forget the signs.

  15. In the circuit of Figure 3.18, what is the value of R2 to give an output voltage of 13.5 volts if R1 is 120 ohms?

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

3.10 Answers to Problems.

  1. 3/10 Amp.

  2. 46.9 volts.

  3. 24.5 volts.

  4. 28.0 volts.

  5. 334.6 volts.

  6. 54.4 volts.

  7. 24.6 volts.

  8. 621 microfarads.

  9. 4170 microfarads.

  10. (a) 15.4 volts. (b) 4.00 millivolts.

  11. 57.1 microfarads.

  12. (a) 1100 ohms, (b) 1100 ohms, (c) 0.288 watts, (d) 6.2 volts.

  13. (a) +40, (b) -40, (c) +40, (d) -40, (e) +40 volts.

  14. (a) +7, (b) -14, (c) +14, (d) -17, (e) +26 volts.

  15. 1230 ohms.

Now, if you have really mastered this material you deserve some kind of award. Go have some ice cream.


Chapter 4   Transistors as Switches and Amplifiers.

4.1  The Bipolar Junction Transistor (BJT).
4.2  The BJT as a Switch.
4.3  The BJT as an Amplifier.
4.4  The Field Effect Transistor (FET).
4.5  The FET as a Switch.
4.6  The FET as an Amplifier.
4.7  Differential Amplifier.
4.8  Problems.
4.9  Answers to Problems.

Chapter 4.

Transistors as Switches and Amplifiers.

The development of the transistor was the greatest single advancement in electronics since the development of the vacuum tube in the early part of the 20th century. Some people might ask "What about the integrated circuit?" The integrated circuit is just a more compact way of packaging circuitry. In fact, there was a little known attempt in the early 1960s to put vacuum tubes in an integrated package. The information available to the writer indicates that a prototype was actually constructed and tested. The demise of the vacuum tube has relegated this experiment to the dusty back shelves of history. But we digress -- oh yes -- the transistor. Even the very earliest of transistors occupied about 1/100 the volume of the average vacuum tube. Such a large change was bound to start a revolution and it did.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

4.1 The Bipolar Junction Transistor (BJT).

The full name of the tiny transistor is quite a mouthful. That is, no doubt, why it is rarely called by that name. Even people who don't know what a transistor looks like know the shortened name "transistor". Non-technical people are unaware that there are two major types of transistors, bipolar junction transistors and field effect transistors. The term "transistor" is too imprecise for our purposes. Instead of using the full name every time, we will use the acronym BJT.

A BJT will allow a small current in one circuit loop to control a much larger current (typically 100 times larger) in another circuit loop. The nature of the BJT is such that the current in the second loop may be switched (turned on and off) or varied by an arbitrarily small amount. We will be devoting much space in following sections to the circuits which permit the BJT to be used to control large currents. In this section we will study the internal physics of the BJT and try to understand how it does what it does.

A simplified cross-section of a BJT is shown in Figure 4.1. A bipolar junction transistor consists of three layers of alternating semiconductor type. These three layers have been given the names emitter, base and collector.

Figure 4.1 Simplified Drawing of a BJT With Supply Voltages

For a verbal description click here.

BJTs may be manufactured in either of two forms. In one form the emitter is P type semiconductor, the base is N type semiconductor and the collector is P type semiconductor. Such transistors are referred to as PNP transistors. In the other form the emitter is N type semiconductor, the base is P type semiconductor and the collector is N type semiconductor. Such transistors are referred to as NPN transistors. (The designation NPN or PNP informs the reader that the transistor is a bipolar junction type and the term NPN transistor is precise.) In the example of Figure 4.1 the transistor is an NPN type which means that the emitter is N type semiconductor, the base is P type semiconductor and the collector is N type semiconductor.

The connection of the battery on the left is such as to forward bias the P-N junction between the emitter and base. The voltage drop across the emitter-base junction is about 0.6 volts. (We used 0.7 volts in rectifier circuits because the current is fairly high. In the base circuit of a BJT the currents are fairly small, typically a few tens of microamperes and the voltage drop is more typically 0.6 volts.) The collector supply voltage, VCC may be anywhere between 5 volts and the maximum the transistor will stand. With the base at +0.6 volts and the collector at more than +5 volts, the base-collector junction is reverse biased.

The forward biased emitter-base junction causes majority carriers to move across the junction. These charge carriers become minority carriers as soon as they cross the junction. Minority carriers do not immediately combine with majority carriers but will travel a short distance until statistics catch up with them and recombination occurs. The average distance a minority carrier can cover is called the mean free path. In a real transistor the width of the base region is less than the mean free path of a minority carrier in the base. That means that most of the minority carriers which are injected into the base region will make it across the base without being recombined with majority carriers from the base. As soon as a minority carrier exits the base and enters the collector, it is again a majority carrier. Majority carriers which are injected into the collector will constitute a collector current. That collector current originated in the emitter and is controlled by the base current.

In the specific case of the NPN transistor shown in Figure 4.1 the base supply voltage VBB will cause a base current to flow into the base. That will cause holes from the base to cross into the emitter and electrons from the emitter to cross into the base. The holes from the base will simply recombine with electrons in the emitter. Some electrons from the emitter will flow out through the base connection and back to VBB but most of the electrons which cross the emitter-base junction will continue on to cross the base-collector junction. Thus there are electrons originating in the emitter region and ending up in the collector region.

If the base current is increased, the number of charge carriers injected into the base will be increased and so will the number of carriers injected into the collector. More base current means more collector current. Less base current means less collector current. The animation below shows this. If the base current is shut off, the collector current will cease to flow. The collector current is typically 100 times larger than the base current.

Figure 4.1a Animation showing holes and electrons in a BJT.

For a verbal description click here.

If a PNP transistor were to be used in the circuit of Figure 4.1, it would be necessary to reverse both batteries. The discussion above will apply to a PNP transistor, the only changes to be made are to change every occurrence of "electron" to "hole" and "hole" to "electron". All references to majority and minority carriers remain as they are.

Figure 4.2 is a repeat of Figure 4.1 but with the schematic symbol for an NPN transistor instead of the representation of the transistor's innards. We will now define a transistor parameter. It is called the forward DC current gain. It is assigned the symbol beta and is

beta = IC / IB           (4.1)

where IC is the DC collector current and IB is the DC base current of the transistor. Equation 4.1 is a definition and so cannot be derived.

Figure 4.2 Schematic of a Properly Biased NPN Transistor.

For a verbal description click here.

By applying Kirchhoff's and Ohm's laws to the circuit of Figure 4.2 it is possible to write some other equations. Summing currents we have

IE = IC + IB           (4.2)

where IE is the emitter current. Summing voltages around the base loop we have

VBB = IB RB + VBE           (4.3)

where VBE is the base to emitter voltage drop, which is approximately 0.6 volts. If we substitute VBE = 0.6 v and rearrange equation 4.3 we have

IB = (VBB - 0.6 v) / RB           (4.4)

In the collector loop we can write

VCC = IC RC + VCE           (4.5)

where VCE is the voltage between collector and emitter. In a great many circuits VCE is taken as the output voltage of the transistor circuit. Rearranging equation 4.5 we have

VCE = VCC - IC RC           (4.6)

If we combine equations 4.1, 4.4 and 4.6 we have

VCE = VCC - beta RC (VBB - 0.6 v) / RB           (4.7)

VCE can never, repeat NEVER, change sign. The absolute value of VCC must always be greater than the absolute value of VCE in equation 4.7. VCE can never exceed VCC because to do so would require that the term on the right in equation 4.7 undergo a change of sign. That cannot happen in the real world. Because the base-emitter junction is a P-N junction diode, if VBB becomes less than 0.6 volts, the base current will simply stop, not reverse. VCE will be equal to VCC.

Within the limits 0 to VCC notice that if VBB is decreased, VCE is increased and visa versa. These are common emitter equations and may not apply to all circuits employing bipolar transistors.

The important thing about these seven equations is to understand how they were obtained. If you do not understand how these equations were obtained it is guaranteed that the rest of this chapter will be Greek to you.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

4.2 The BJT as a Switch.

As mentioned above if the base current is removed from a transistor, the collector current will become similar to the reverse current in a diode, (too small to measure). Thus if a small current is turned on and off in the base of a BJT, the collector current will be turned on and off. Because the collector current is much larger than the base current, a low power circuit can be made to turn a high power device on and off. An excellent example of this is an indicator light.

Figure 4.3 BJT Switch Turns Light On and Off

For a verbal description click here.

Figure 4.3 shows how a transistor can be used to turn a light on and off. It is very common in both consumer and laboratory equipment for a light to come on to indicate that a particular function has been activated. The input terminals on the left connect to what will be referred to as the driving source. The driving source is not capable of delivering enough current to light the lamp. This low power circuit will deliver a voltage when the light is to be on and no (or very little) voltage when the light is to be off.

An ideal switch has infinite resistance when it is open and zero resistance when it is closed. The BJT is quite close to being ideal in the open (off) condition but in the closed (on) condition it is not quite perfect. The on condition is known as saturation and is the condition wherein the collector current is as large as it can be. When a transistor is in saturation VCE is about 0.1 or 0.2 volts.

When a BJT is in saturation, most of the power supply voltage will appear across the load (device being switched on and off) and so the current through the load is

ISAT = (VCC - VCESAT) / RL           (4.8)

where VCC is the power supply voltage, RL is the load resistance and 0.1 v < VCESAT < 0.2 volts.

Example 4.1.

A lamp having a resistance of 22 ohms is to be switched by a BJT. The power supply voltage is 5 volts and the collector saturation voltage is 0.1 volts. What is the saturation current of the transistor? See Figure 4.3.

Solution:

ISAT = (5 v - 0.1 v) / 22 ohms = 223 mA

Trouble can develop in switching circuits if the transistor is not in saturation. To place a transistor in saturation it is necessary to supply more base current than is needed to just barely place the transistor in saturation. To be absolutely certain that the transistor is in saturation, the base current should be at least twice that required to just barely saturate the transistor. It will not do any damage if the base current is larger than that required for saturation. The collector current cannot be any greater than the saturation current.

Example 4.2.

Using the same conditions from example 4.1, what is the minimum base current required to place the transistor in saturation if beta is 80?

Solution:

IBMIN = ISAT / beta = 223 mA / 80 = 2.79 mA

The resistor in the base circuit must be properly selected so as to cause the base current to be large enough to place the transistor in saturation. On the other extreme the driving source will have a practical limit to how much current it will supply. If there were no limit, the load could be connected to the source and the switching transistor would not be needed.

Example 4.3.

Continuing with examples 4.1 and 4.2, what is the range of resistance for RB if the driving source can supply a maximum of 12 mA at a voltage of 5 volts. What should the resistance be to give a saturation safety factor of 2.5?

Solution:

In example 4.2 the minimum base current was calculated to be 2.79 mA. The maximum base current is the maximum which the driving source can supply, which is given as 12 mA. Solving equation 4.4 for RB we have

RB = (VBB - 0.6 v) / IB

RBMIN = (5 v - 0.6 v) / 12 mA = 367 ohms.
RBMAX = (5 v - 0.6 v) / 2.79 mA = 1.58 k ohms.
Since the minimum base current for saturation is 2.79 mA
a safety factor of 2.5 calls for a base current of 6.98
mA. RB = (5 v - 0.6 v) / 6.98 mA = 630 ohms.
A 620 ohms standard value resistor would be used.

Another consideration in switching transistor circuits is whether the transistor will be turned off when it is supposed to be off. As long as the voltage of the driving source goes below about 0.6 volts, the transistor will most likely be turned off. But some driving sources do not go below 0.6 volts and the transistor may not be completely turned off.

Example 4.4.

In Figure 4.3 it is now assumed that VCC is 5 volts, the resistance of the lamp is 22 ohms, the resistance of RB is 620 ohms and the beta of the transistor is 80. The driving source has an "on" voltage of 5 volts. (a) If its "off" voltage is 0.2 volts, is the transistor off? If not, what is the collector current? (b) If the driving source has an "off" voltage of 1.0 volts, is the transistor off? If not, what is the collector current?

Solution:

(a) The driving source has an "off" voltage of 0.2 volts. That is less than the 0.6 volt breakdown of the base-emitter junction. There will be no base current and so there will be no collector current. The transistor switch will be off.
(b) If the "off" voltage of the driving source is 1 volt there will be some base current. The base current will be IB = (1 v - 0.6 v) / 620 ohms = 0.645 mA; the collector current will be 80 x 0.645 mA = 51.6 mA. Although they are not asked for in the original example we will calculate the drop across the load and VCE to give a complete illustration of this type of problem. The drop across the load is IC RL = 51.6 mA x 22 ohms = 1.14 volts. VCE is VCC - VL = 5 v - 1.14 v = 3.86 volts.

As you can see in the above example the transistor is "mostly" off. The lamp would glow slightly. An operator might be confused and become unsure as to whether a particular function is engaged or not. In something such as a nuclear power plant such confusion could be the difference between safe and unsafe operation. It is highly undesirable for indicator lamps to be partially on when they are supposed to be off.

Figure 4.4 shows a circuit which will overcome the problem of a driving source which will not go to zero for the off state.

Figure 4.4 Switching Circuit for Non-zero Driving Sources

For a verbal description click here.

The procedure for solving this circuit is as follows.

  1. Assume that there is no load on the voltage divider in the base circuit and see if the transistor will be turned on or not. If the calculated voltage exceeds 0.6 volts, the transistor is at least part way on. If the voltage is less than 0.6 volts the transistor is off.

  2. To calculate the base current in the "on" state assume that VBE is 0.6 volts and calculate the current through R2 (the voltage across R2 will be 0.6 volts).

  3. Calculate the current through R1 assuming VBE to be 0.6 volts.

  4. The current through R1 will split. Some will go through R2 and the rest will go into the base of the transistor. To obtain the base current subtract the R2 current from the R1 current.

For those who would rather memorize an equation it is

IB = (VDSON - 0.6 v) / R1 - 0.6 v / R2           (4.9)

where VDSON is the on voltage of the driving source. It should be pointed out and emphasized that VBE for a good (not burned out) BJT can never exceed about 0.6 or 0.7 volts. If it does in a calculation, something has been neglected but no damage is done. If VBE exceeds 0.7 volts in the real world, the BJT is burned out. If it wasn't before, it is now.

Example 4.5

For the values given in Figure 4.4 will a driving source which has an on voltage of 5 volts and an off voltage of 1 volt turn the BJT switch on and off?

Solution:

For the off state VBE = 1 v x 1 k ohms / (5.6 k ohms + 1 k ohms) = 0.15 v; the BJT switch is off. For the on state VBE = 5 v x 1 k ohms / (5.6 k ohms + 1 k ohms) = 0.76 v; there will be base current. Calculating the amount of base current

IB = VDSON - 0.6 v) / R1 - 0.6 v / R2 = 4.4 v / 5.6 k ohms - 0.6 v / 1 k ohm = 0.186 mA

The base current required to turn the switch on is IB = IC / beta and IC = RC / VCC = 12 v / 150 ohms = 80 mA, IB = 80 mA / 100 = 0.8 mA. With 0.8 mA required and 0.186 mA supplied, there is insufficient base current to turn the BJT switch on.

Example 4.6

Will a driving source of 10 volts turn the BJT on in Figure 4.4?

Solution:

We know from example 4.5 that 5 volts is enough to slightly forward bias the base-emitter junction and so we do not need to test to see if 10 volts will do it. Calculating IB gives

IB = (10 v - 0.6 v) / 5.6 k ohms - 0.6 v / 1 k ohm = 1.08 mA.

In example 4.5 we saw that 0.8 mA was required to turn the BJT on and we have 1.08 mA. The BJT is on.

BJT switches are used whenever a device such as a microprocessor needs to switch the current to any device which draws more current than the microprocessor can supply. Devices which may be switched include lamps, relays, buzzers and digital displays.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

4.3 The BJT as an Amplifier.

An amplifier is any sort of device which will increase the magnitude of a signal. An amplifier may increase the magnitude of the voltage, current or both but to qualify as a true amplifier it must increase the power of a signal. A transformer can be used to increase the voltage of a signal, but there is no increase in power and a transformer is not an amplifier.

To characterize an amplifier completely it is necessary to know four things about it. They are

  1. the relationship between the input voltage and the input current,
  2. the relationship between the output voltage and the output current,
  3. a relationship showing how the output is affected by the input, and
  4. a relationship showing how the input is affected by the output.
These characteristics are called the four-terminal network parameters.

There are three groups of parameters, the impedance parameters, the admittance parameters and the hybrid parameters. All four of the impedance parameters have units of ohms and all four of the admittance parameters have units of ohms-1. The hybrid parameters are a mix of units.

Figure 4.5 Generalized Four-terminal Network

For a verbal description click here.

Figure 4.5 shows a generalized four-terminal network. The open circuit impedance parameters are as follows.
  • Input Impedance Z11 = V1 / I1 with I2 = 0

  • Output Impedance Z22 = V2 / I2 with I1 = 0

  • Forward Transfer Impedance Z12 = V2 / I1 I2 = 0

  • Reverse Transfer Impedance Z21 = V1 / I2 I1 = 0

"What has all of this to do with transistors?" A transistor can be treated as a four-terminal network. "Hold on now, you said a transistor has three terminals, emitter, base and collector, I remember that!" Correct. We will use one of the terminals twice so as to use four-terminal network parameters on a BJT.

Let us apply the hybrid parameters to the common emitter configuration. That means that the input is applied between the base and emitter and the output is taken between the collector and emitter as indicated in Figure 4.6a.

In the equations to follow all of the voltages and currents are AC small signal. Small signal means that the AC voltages are small enough so that the natural nonlinearities of P-N junctions are not significant and the I-V characteristics "look" linear. This is not an unrealistic condition. All amplifier transistors must be used in this way to avoid signal distortion. Distortion is any unwanted alteration of the signal.

The small-signal common-emitter hybrid parameters for the BJT are as follows.

The short-circuit input impedance.

hie = vbe / ib   with vce = 0           (4.10)

The open-circuit output admittance.

hoe = ic / vce   with ib = 0           (4.11)

The short-circuit forward current transfer ratio.

hfe = ic / ib   with vce = 0           (4.12)

The open-circuit reverse voltage transfer ratio.

hre = vbe / vce   with ib = 0           <(4.13)

Just in case you are wondering, hre is measured by injecting a signal at the collector and making a measurement at the base. These parameters are all definitions.

Figure 4.6 (a) BJT and (b) Four-terminal Equivalent Circuit.

For a verbal description click here.

The hybrid parameters give rise to the equivalent circuit of Figure 4.6b. This circuit takes the place of the transistor and is considered to be equivalent to it. The parameter hie is the input resistance. It is connected in series with the voltage generator which represents hre. The presence of hre indicates that a small amount of the output voltage is fed back into the base-emitter loop. In the collector-emitter loop a resistor representing hoe and a current source representing hfe are connected in parallel. Although hoe is expressed as a conductance, it is the reciprocal of the output resistance of the transistor. The current produced by the current source hfe is equal to hfe times the current in the base loop.

A generator may be connected, (in thought), to the base- emitter side of the equivalent circuit and a load resistance connected to the collector-emitter side. Equations may then be derived for such things as the input impedance, the output impedance and the gain. These equations are indeed complex. Advancing technology has saved us from having to deal with these equations.

The voltage feedback which is represented by hre is caused by the electric field within the transistor which is produced by the collector-to-emitter voltage. This field affects the concentration of charge carriers within the base and causes the forward voltage drop across the base-emitter junction (VBE) to be affected by the magnitude of VCE. The same electric field causes the collector current to increase as VCE increases. The value of hoe is the slope of the graph of IC versus VCE. Modern transistor design has overcome both of these problems to a very large extent. The amount of output voltage which is fed back to the input side is negligible in modern transistors and hre can be neglected and removed from the equivalent circuit. With modern transistors the graph of IC versus VCE is a horizontal line for voltages above about 1.5 volts. A horizontal line has a slope of zero and if hoe is zero, the output resistance is infinity. An infinite output resistance means that the resistor representing hoe may be removed from the circuit.

Figure 4.7 Simplified Equivalent Circuit.

For a verbal description click here.

The simplified equivalent circuit is shown in Figure 4.7. The equivalent circuit consists of the resistor labeled hie and the current source labeled ib> hfe. To make use of this circuit we must connect a couple of things to it. A Thevenin's equivalent circuit of a generator is connected to the B and E terminals. A load resistor is connected to the C and E terminals. We will use this circuit to derive the equations for gain and input impedance.

The current in the first loop is simply,

ib = vbe / hie           (4.14)

The output voltage is,

vce = - hfe ib RL           (4.15)

The minus sign in equation 4.15 arises from the fact that the current in the current source is flowing downward and so it is flowing upward in the load resistor. If we now substitute equation 4.14 into equation 4.15 and divide by vbe we obtain,

vce / vbe = - (hfe RL ) / hie           (4.16)

If we define the voltage gain as AV = vce / vbe then we have

AV = - (hfe RL ) / hie           (4.17)

The input impedance of a common emitter amplifier is equal to Hie. The output impedance is virtually infinite.

Example 4.7

A BJT has the following parameters, hfe = 90 and hie = 4 k ohms. If this transistor is placed in a circuit where the load resistance is 4.7 k ohms, what is the voltage gain of the circuit?

Solution:

AV = - (hfe RL ) / hie = - ( 90 x 4.7 k ohms ) / ( 4 k ohms ) = 106

The solution to example 4.7 indicates that the amplifier in question will have an output voltage 106 times as large as its input voltage and the phase of the output signal will be inverted. 180 degrees phase shift.

Biasing the Bipolar Transistor.

The BJT is normally used to amplify small AC signals but it won't do anything unless it is provided with the proper DC voltages and currents. The process of providing the DC values is called biasing. One way to bias a transistor is as shown in Figure 4.2. The combination of VBB and RB will provide a constant DC current to the base. The collector current should be adjusted such that 1/2 of VCC is dropped across RC. VCE will also be 1/2 of VCC. This condition permits the AC output signal to be as large as it can possibly be. The collector voltage can "swing" from 0 to VCC. This type of biasing is never used in practical circuits because the collector current depends on the value of the DC beta of the transistor. The value of beta changes with temperature and is different for different transistors even of the same type number.

Figure 4.8 Practical Audio Frequency Amplifier.

For a verbal description click here.

A complete practical one-stage audio frequency amplifier is shown in Figure 4.8. Approximately 2 volts DC are dropped across the emitter resistor which leaves a 10 volt range for VCE (2 volts to 12 volts). The static collector voltage is halfway between 2 and 12, which is 7 volts. The voltage at the base is approximately 2.6 volts. Capacitor C1 is necessary to prevent this voltage from interfering with the operation of or possibly even damaging the device which is to provide the signal to the amplifier. C3 blocks the DC at the collector from reaching the circuits or devices which may be connected to the output of the amplifier. R5 provides a charging path for C3 to make sure that there is no DC voltage present at the output even though there is no other load connected. Remember back in chapter 2 when we were talking about mixtures of AC and DC? Well, here it is. The RC networks are used just as described to pass the AC while blocking the DC.

The purpose of C2 requires a bit more explanation. If C2 were not present, the gain of the amplifier would be considerably reduced. It works this way. When the input signal goes positive, the base current increases and so does the emitter current. That increases the voltage drop across the emitter resistor and reduces the effect of the increasing signal. The effect of the signal could not be completely canceled out because, if the change in emitter current were completely canceled out, there would be no change in emitter current to cancel out the change in base current. The effect of the changing input signal is considerably reduced, which considerably reduces the gain of the circuit. Connecting C2 from the emitter to ground will prevent rapid changes in the emitter voltage and so the input signal will not have its effect reduced by any changes in the emitter voltage. The process of reducing the effective gain by removing the emitter bypass capacitor C2 is called emitter degeneration and, as we will learn in the next chapter, is not necessarily a bad thing.

Operating Point Stability

The set of conditions, IC, VCE, etc., are referred to collectively as the operating point. The operating point of a transistor must be stabilized against two types of changes. 1) The temperature can change and the value of beta is very temperature dependent. 2) Changing transistors, transistors can and do burn out and have to be replaced. The replacement most likely will not have the same value of beta as the original unit. There is no guarantee that a circuit will always be operated at room temperature. Air conditioning and heating systems can break down; portable devices can be carried outside on a summer or winter day. A device which fails to operate if the temperature gets above 85degrees or below 65degrees will not be very useful. If a transistor burns out it must be replaced to restore operation. Even if the replacement transistor has the same number as the original transistor, its beta may differ by as much as 30% from the original. If the circuit is not properly designed, the circuit may not work following the replacement of a defective transistor.

If the circuit of Figure 4.2 were used as an amplifier (and it could be) it would suffer from both problems described above. The circuit of Figure 4.8 does not suffer from these problems and here is why. The base current is small compared to the current flowing down through R1 and R2. The voltage divider which is constituted by R1 and R2 is lightly loaded and its output voltage will change only slightly as the base current changes. Suppose that the collector current tries to increase due to a temperature or a transistor change. The emitter current is IC + IB and IB is very much less than IC; therefore, IE is approximately equal to IC. As IC goes so goes IE. IE is trying to increase which will increase the voltage drop across RE which, in turn, will increase the voltage at the emitter. The voltage divider of R1 and R2 is holding the voltage at the base almost constant. An increase of emitter voltage while the base voltage is held constant will cause the forward bias on the base-emitter junction to be decreased and, therefore, decrease the base current. Remember we started out with the emitter current trying to increase which led to a decrease in base current. A decrease in base current will counteract the original increase in collector (emitter) current and the increase will not be as great as it would otherwise be. In fact, the emitter current will change only very slightly. If the collector (emitter) current tries to decrease, the voltage across RE will decrease, decreasing the emitter voltage while the base voltage is held constant. This increases the forward bias on the B-E junction and increases the base current which counteracts the decrease in collector (emitter) current.

If you were to set up the circuits of Figures 4.2 and 4.8 and put meters in the circuit to monitor the base and collector currents, you could see things happen. In the case of Figure 4.2 if heat were applied to the transistor the collector current would rise very rapidly. In the case of Figure 4.8 the collector current would change very slightly and the base current would drop off drastically. If the transistor were cooled, the currents would change in the opposite direction. A transistor with a higher beta will result in a larger collector current in the circuit of Figure 4.2 and a smaller base current in Figure 4.8.

The circuit of Figure 4.2 is called constant current biasing. It is never used in analog (as opposed to switching) circuits. The circuit of Figure 4.8 is called constant voltage biasing and it - or a variation of it - is used in all transistor circuits, including the internal circuitry of integrated circuits.

Circuit Analysis.

The circuit of Figure 4.8 is much easier to analyze if the voltage divider is replaced by its Thevenin's equivalent circuit as shown in Figure 4.9. Capacitors have been omitted because this is a DC analysis and capacitors are open circuits for DC. The values of VBB and RB are given by these equations

VBB = VCC R2 / (R1 + R2)           (4.18)

and

RB = (R1 R2) / (R1 + R2)           (4.19)

where R1 and R2 are the original base resistors as shown in Figure 4.8.

Figure 4.9 Thevenin's Equivalent Circuit Replaces R1 and R2

For a verbal description click here.

If equations 4.18 and 4.19 seem to have "come out of the blue," you need to review the section on Thevenin's equivalent circuit (section 1.3 pages 41 to 46).

We will now write the loop equations for the circuit of Figure 4.9. Summing voltages in the base loop gives

VBB = RB IB + VBE + RE (IB + IC)           (4.20)

The voltage drop across RE (R4 in Figure 4.8) is IE RE but IE = IB + IC. The base current is given by

IB = IC / beta           (4.21)

Substituting equation 4.21 into equation 4.20 and solving for IC gives

IC = beta (VBB - VBE) / (RB + RE (1 + beta))           (4.22)

If beta is greater than 50 an error of less than 2% will be introduced by letting the (1 + beta) term in the denominator equal beta. Making this substitution and dividing through by beta we have

IC = (VBB - VBE) / (RE + RB / beta)           (4.23)

Equation 4.23 is probably the best one to use to calculate the collector current of a constant voltage biased BJT.

It is possible to make a further approximation but it must be applied with great care. In the denominator of equation 4.23 RB / beta may be much less than RE. If this is true the following equation may be used.

IC = (VBB - VBE) / RE     if and only if RB / beta << RE.           (4.24)

Example 4.8

Calculate the values of VBB and RB for the circuit of Figure 4.8.

Solution:

VBB is the unloaded output of the voltage divider consisting of R1 and R2

VBB = VCC R2 / (R1 + R2) = 12 v x 6.8 k ohms / (22 k ohms + 6.8 k ohms) = 2.83 v

RB is the parallel combination of R1 and R2

RB = R1 R2 / (R1 + R2) = 22 k ohms x 6.8 k ohms / (22 k ohms + 6.8 k ohms) = 5.19 k ohms

Example 4.9

If the transistor in Figure 4.8 has a beta of 150, what is the collector current?

Solution:

Which equation should we use? Equation 4.22 is the most exact form but the difference between beta and beta + 1 is only 0.66%. We might use equation 4.24 but that one is usually used only when beta is not given and a typical value must be assumed. We will use equation 4.23.

IC = 2.83 v - 0.6 v / (1.8 k ohms + 5.19 k ohms / 150) = 2.23 v / (1.8 k ohms + 0.03 k ohms) = 1.22 mA.

If equation 4.24 had been used the error would have only been 1.67%, which is well within acceptable limits. Perhaps another example will illustrate when equation 4.24 should not be used.

Example 4.10

In a circuit similar to Figure 4.8 VCC = 15 v, R1 = 100 K ohms, R2 = 47 k ohms, R3 = 4.7 k ohms, R4 = 3.3 k ohms and beta = 50. What is the collector current?

Solution:

Since beta = 50 this is a borderline case for the 2% rule but we will ignore beta + 1 and use equation 4.23. VBB = 15 v x 47 k ohms / (100 k ohms + 47 k ohms) = 4.80 v and RB = 100 k ohms x 47 k ohms / (100 k ohms + 47 k ohms) = 32.0 k ohms.

IC = 4.80 v - 0.6 v / (3.3 k ohms + 32.0 k ohms / 50) = 4.20 v / (3.3 k ohms + 0.64 k ohms) = 1.07 mA.

The Common Collector (Emitter-follower) Amplifier.

If the collector of a BJT is placed at AC ground potential while the input signal is applied between ground and base and the output signal is taken between ground and emitter, the collector is common to input and output. Such an amplifier is a common collector configuration but is commonly known as an emitter-follower. An AC coupled emitter-follower is shown in Figure 4.10.

Figure 4.10 AC Coupled Emitter-follower.

For a verbal description click here.

The reason it is called an emitter-follower is because of that nearly constant 0.6 volt drop from base to emitter. How ever the base voltage may change, the emitter voltage is following along only 0.6 volts behind. To put it more precisely, for an NPN transistor the emitter voltage is 0.6 volts less then the base voltage. For a PNP transistor the emitter voltage is 0.6 volts greater than the base voltage. That 0.6 volts may not be important in the circuit of Figure 4.10 but in a DC coupled emitter-follower it may be very important.

The AC gain of an emitter-follower may be derived using the familiar common emitter parameters by drawing the equivalent circuit as in Figure 4.11. This circuit is a little difficult to follow (pun fully intended) and so the wires have been untangled in Figure 4.12. In equivalent circuits it is customary to omit DC biasing and capacitors because they add nothing to the AC circuit.

Figure 4.11 Common Collector Equivalent Circuit.

For a verbal description click here.

Figure 4.12 Figure 4.11 with Wires Untangled.

For a verbal description click here.

Writing a loop equation around the outside loop gives

vin = ib hie + vo.           (4.25)

We will make the approximation that the base current ib is much less than the collector current ic, and the emitter current will be considered equal to the collector current. The current flowing through RL is the collector current hfeib and we have

vo = ib hfe RL.           (4.26)

If we solve equations 4.25 and 4.26 for ib and set them equal we have

vo / (hfe RL) = (vin - vo) / hie           (4.27)

Solving this equation for vo / vin and remembering that voltage gain is defined as vo / vin we have

AV = hfe RL / (hie + hfe RL)           (4.28)

Example 4.11.

A BJT has the following parameters, hie = 4 k ohms and hfe = 100. In an emitter-follower with a load (emitter) resistor of 1 k ohms, what is the voltage gain?

Solution:

AV = hfe RL / (hie + hfe RL) = 100 x 1 k ohm / (4 k ohms + 100 x 1 k ohm) = 0.962

The voltage gain of an emitter-follower is always slightly less than one. You may be wondering what use is an amplifier which slightly reduces the amplitude of the input signal. An emitter-follower has current gain. The current gain is equal to beta. For example, if you have a generator which can only supply 1 mA and you need to drive a load which requires 100 mA, an emitter-follower employing a BJT with a beta (or hfe) greater than 100 will allow the generator to drive the load provided there are no other losses in the circuit.

Input Resistance.

The input resistance of an emitter-follower is

Rin = vin / ib           (4.29)

If we rearrange equation 4.26 we have

vo / ib = hfe RL           (4.30)

Because the gain of an emitter-follower is approximately unity, vo = vin. Combining this approximation with equations 4.29 and 4.30 we have

Rin = hfe RL           (4.31)

The value of RL is the parallel combination of all resistances connected from the emitter to ground.

Example 4.12.

In the circuit of Figure 4.13 an emitter-follower is being used to drive an 8 ohm speaker. If R1 = R2 = 390 ohms, R3 = 15 ohms, beta = hfe = 75 and hie = 5 ohms, what are (a) the voltage gain and (b) the input resistance?

Figure 4.13 Emitter-follower Driving a Speaker

For a verbal description click here.

Solution:

(a) The gain is given by equation 4.28. RL in this equation is the parallel combination of R3 and the 8 ohm speaker which is 5.22 ohms.

AV = hfe RL / (hie + hfe RL = 75 x 5.22 ohms / (5 ohms + 75 x 5.22 ohms) = 0.987

(b) The input resistance is the parallel combination of the two 390 ohm resistors in the base circuit and the input resistance of the emitter-follower. The input resistance of the emitter-follower is given by equation 4.31.

Rin = hfe RL = 75 x 5.22 = 392 ohms

The total input resistance is the parallel combination of 390 ohms, 390 ohms and 392 ohms which is 130 ohms

Resistances in Parallel.

Some of you may be puzzled over why resistors are being treated as if they are connected in parallel when they are not connected to the same point in the circuit. If you are not puzzled, you may skip this section.

For example, the speaker and the 15 ohm resistor R3 have been treated as if they are in parallel when it is obvious that there is a capacitor connected between them. We are talking about AC not DC. The job of the capacitor is to block DC and pass AC to the speaker. The value of the capacitor has been chosen such that its reactance is small at the lowest frequency to be passed to the speaker. The capacitor is essentially a short circuit for AC. When the capacitor is replaced by a short circuit the speaker and the 15 ohm resistor are in parallel.

The two 390 ohm resistors in the base appear more like they are in series than in parallel. The AC signal is applied to the junction of the two resistors. One of the resistors goes to ground and the other one goes to the power supply (VCC). Within the power supply is a large capacitor connected from VCC to ground, or a voltage regulator, most likely both. For AC there is a short circuit connected from VCC to ground, which means that connecting a resistor to VCC is the same as connecting it to ground as far as AC is concerned. The input resistance of the transistor appears from base to ground and so is in parallel with the resistors in the base circuit.

Output Resistance.

To determine the output resistance of an emitter- follower we rearrange the equivalent circuit of Figure 4.12 and redraw it in Figure 4.14.

Figure 4.14 Measuring Output Resistance of Emitter-follower.

For a verbal description click here.

The generator has been removed from the input and replaced by its internal resistance Rg. The load resistor has been removed and a generator has been connected to the output. The purpose of this is to apply a known voltage to the output and see how much current flows.

This can be done in the laboratory if care is taken not to drive the transistor into nonlinear regions of its I-V characteristic.

Summing the voltage drops around the outside loop gives

ib (Rg + hie) = V.           (4.32)

The current flowing in the generator is

I = ib (hfe + 1).           (4.33)

Eliminating ib between equations 4.32 and 4.33 and rearranging yields

V / I = (Rg + hie) / (hfe + 1)           (4.34)

Since RO = V / I we have

RO = (Rg + hie) / (hfe + 1)           (4.35)

Example 4.13.

In the circuit of Figure 4.13 calculate the output resistance which is effectively connected across the speaker. The output resistance of the generator is 50 ohms.

Solution:

The output resistance at the emitter of the transistor is given by equation 4.35. Rg must be the parallel combination of the generator resistance and the two resistors in the base circuit, 50 ohms in parallel with two 390 ohm resistors, which is 39.8 ohms

RO = (Rg + hie) / (hfe + 1) = (39.8 ohms + 5 ohms) / (75 + 1) = 0.589 ohms

The true output resistance is RO in parallel with 15 ohms but it isn't going to make much difference.

Rout = 15 ohms x 0.589 ohms / (15 ohms + 0.589 ohms) = 0.567 ohms.

Determining Transistor Parameters.

Transistor parameters may be found in a data sheet for the particular transistor or in a transistor data book. Data sheets for individual transistors may be obtained from the manufacturer often free of charge or for a nominal fee. These data sheets give all of the information you could possibly want. Data sheets give a range of values for each parameter. Whether you use an average value or the minimum value will depend on what you are trying to do.

Most data books do not give a value for hie at all. They usually give a range of values for the current gain. For audio frequencies the values of beta and hfe are the same. It is unusual for a data book to give a value of hfe at high frequencies.

If you need to know the value of hie and you can't find it anywhere you can estimate it. Hie = 25 mv / IB. Since IB = IC / beta hie can be estimated as

Hie = 25 mv x beta / IC           (4.36)

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

4.4 The Field Effect Transistor (FET).

There are two classes of field effect transistors, junction field effect transistors, JFETs, and metal oxide semiconductor field effect transistor, MOSFETs. We will begin with JFETs.

The Junction Field Effect Transistor.

Figure 4.15 Junction Field Effect Transistor.

For a verbal description click here.

Figure 4.15 shows an N channel junction field effect transistor (JFET). If a battery is connected to the ends of the channel, (source and drain) current will flow as if it were a resistor. Like any other resistance device the resistance will depend on the length and cross-section area of the block of semiconductor material.

It is the cross-section area which is important in the JFET. If the gate to channel junction is reverse-biased the depletion region will grow outward from the gate as shown in Figure 4.16. As the depletion region grows larger the conduction cross-section area is decreased. The depletion region does not conduct current. As the reverse bias voltage on the gate-channel junction is increased, the resistance of the channel is increased. At comparatively large gate to channel voltages (about 10 volts) the channel resistance is approaching infinity. At a gate to channel voltage of zero the channel resistance is low, a typical value being 100 ohms.

Figure 4.16 JFET with Reverse Bias on the Gate.

For a verbal description click here.

Figure 4.17 JFET Showing Pinch-off Effect.

For a verbal description click here.

When a battery is connected across the ends of the channel, another effect becomes evident. Because the gate reduces the channel cross-section area, the resistance in the region of the gate is increased and most of the voltage which is applied will be dropped across the region occupied by the gate. This voltage drop causes the channel near the top of the gate (Figure 4.17) to be more positive than the channel near the bottom of the gate. The net voltage across the gate-channel junction is greater at the top than it is at the bottom. Hence, the depletion region will be wider at the top of the gate than it is at the bottom, as shown in Figure 4.17. As the voltage applied to the ends of the channel is increased, this effect is increased until the channel becomes a constant current device. The channel does not become a negative resistance device (current decreases as voltage increases). The voltage at which the channel changes from a resistive device to a constant current device is called the pinch-off voltage.

Figure 4.18 Drain Characteristics of a typical FET.

For a verbal description click here.

Figure 4.18 shows the drain characteristics of a typical junction field effect transistor. The semiconductor curve tracer in the laboratory will produce these curves on the screen of an oscilloscope. At drain-to-source voltages below the pinch-off voltage the drain-to-source path is a variable resistance while above the pinch-off voltage the drain-to- source path is a variable current source. Typical values for the pinch-off voltage are less than one volt.

The Metal Oxide Semiconductor Field Effect Transistor.

The metal oxide semiconductor field effect transistor (MOSFET) is at the heart of most pocket calculators and microcomputers. Its construction is quite similar to the JFET except that the gate is a metal plate which is insulated from the channel by a thin layer of silicon dioxide instead of a region of opposite type semiconductor.

The P-N junction in a JFET is not used as a diode. It operates in the reversed biased condition all of the time. The gate portion of the FET (P type semiconductor in the example shown) is only being used as a conductor. The depletion region on the gate side of the junction is being used as an insulator. Silicon dioxide is a much better insulator than is a reverse-biased P-N junction and metal is a better conductor than is P type semiconductor. So the replacements are made and the device works almost the same as it did before. In an N channel MOSFET if the gate is made negative with respect to the source the negative charge on the gate will repel negative charges in the semiconductor channel and create a depletion region around the gate the same as with a JFET. The principle of pinch-off works the same way as well.

Figure 4.19 Metal Oxide Semiconductor FET.

For a verbal description click here.

The major difference between a JFET and a MOSFET is the gate or input resistance. For a JFET the typical input resistance is typically 1012 ohms while for a MOSFET the input resistance is typically 1016 ohms. MOSFETs are used in equipment which can measure currents in the picoampere range and below. Because of the high resistance of MOSFETs in a switching application, when they are off, they are really off. For this reason they find applications in very low power devices such as watches, calculators and lap-top computers.

The substrate is the foundation on which the MOSFETs are constructed. In the case of discreet MOSFETs (as opposed to integrated circuits) the substrate may be brought out to a connecting lead of its own so the user may connect it as desired. The substrate is usually connected to the source although a P type substrate may be connected to the most negative point in a circuit. When MOSFETs appear in an integrated circuit, the substrate is the foundation on which the IC is constructed.

Enhancement Mode MOSFETs.

MOSFETs can be divided into two groups, depletion mode and enhancement mode. The group we have been talking about up until now are the depletion mode type, so called because they work by creating a depletion region in the channel. Depletion mode MOSFETs are "on" at zero gate voltage and a negative gate voltage will turn them "off".

An enhancement mode MOSFET is "off" at zero gate voltage and a positive gate voltage (for an N channel) will turn it "on". The drawing of an enhancement mode MOSFET is shown in Figure 4.20.

Figure 4.20 Enhancement Mode MOSFET.

For a verbal description click here.

In the case of an N channel MOSFET the substrate is P type semiconductor. Near the gate (between the source and drain) the substrate has been doped with both donor and acceptor impurities. The acceptors slightly outnumber the donors so the result is a lightly doped P type semiconductor. When the gate voltage is zero the P type semiconductor between the source and drain serves to block current between source and drain. When a positive voltage is placed on the gate, holes are repelled away from the gate. Once the holes are gone from this region, the donor impurities predominate and the material near the gate turns from P type to N type semiconductor. Current may now flow from source to drain.

Enhancement mode MOSFETs are very rarely used as amplifiers. They most often appear in digital integrated circuits where they are used as switches.

Figure 4.21 Schematic Symbols for Various Kinds of FETs.

For a verbal description click here.

Figure 4.21 shows schematic symbols for the various kinds of FETs. The FETs in the top row are N channel and the FETs in the bottom row are P channel. A good memory device is "the arrow always points toward the N type semiconductor". The bottom connection on each FET is the source. The connection on the left of each FET is the gate and the connection at the top is the drain. For MOSFETs the connection at center-right is the substrate. The substrate is shown connected internally to the source in these symbols. In some discreet MOSFETs the substrate is brought to a separate lead.

For N channel FETs the drain is made more positive than the source. JFETs and depletion mode MOSFETs are fully on at zero gate potential. For operation as an amplifier, the gate is made more negative than the source. Enhancement mode MOSFETs are off at zero gate potential. For operation as an amplifier the gate is made more positive than the source.

For P channel FETs the drain is made more negative than the source. JFETs and depletion mode MOSFETs are fully on at zero gate potential. For operation as an amplifier, the gate is made more positive than the source. Enhancement mode MOSFETs are off at zero gate potential. For operation as an amplifier the gate is made more negative than the source.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

4.5 The FET as a Switch.

FETs are usually not used to turn lamps and relay coils on and off. They find two major applications, as logic switches and as analog (or signal) switches. We will cover the latter application first.

The term analog switch may seem to be mutually contradictory. What is meant is to interrupt an analog signal to turn it off and on as desired or to select among several sources of signal. An example of the latter is the source selector in a stereo receiver. The switch allows the user to select among several program sources. Classically this has been accomplished by a mechanical switch. Newer designs which include remote control require electronic switching. This electronic switching may be accomplished using an FET.

Figure 4.22 shows an FET being used to switch an analog signal. The control voltage is +15 volts to turn the switch on and -15 volts to turn the switch off. The signal applied to the input must never exceed approximately plus or minus 10 volts. If the input signal comes too close to +15 volts, the switch can be turned off when it is supposed to be on. If the input signal comes too close to -15 volts, the switch can be turned on when it is supposed to be off.

Figure 4.22 Analog Switch Using a JFET.

For a verbal description click here.

When the control voltage is positive, the diode is reverse biased, which disconnects the control voltage from the switched signal. The 100 k ohm resistor will cause the gate of the FET to be at the same potential as the source and the FET will be fully on. Signals applied to the input will appear at the output with little distortion or attenuation. When the control voltage is negative, the diode will be forward biased and the gate will be at approximately -15 volts. This will cause the FET to be turned off and very little or no signal from the input will be passed to the output. The 100 k ohm resistor will be connected from the -15 volt control signal to the signal source. In order for this circuit to work properly the signal source must have a low resistance for DC.

Another type of analog switch is the CMOS (complementary MOS) device which comes in an integrated circuit. The IC operates from a single power supply (VDD) of up to 15 volts. The signal source must never go negative nor more positive than VDD. It is best for the AC signal source to be added to a DC of 1/2 VDD. If the signal part of the switch is forced outside of these limits by more than 0.7 volts the IC will, not may, but will be destroyed. The control voltage for this IC is zero to turn the switch off and VDD to turn the switch on.

A partial schematic diagram of the internal workings of this IC switch is shown in Figure 4.23. The triangle with a circle on its nose is an inverter. This is a switching device. If its input is zero, its output is VDD. If its input is VDD, its output is zero.

Figure 4.23 MOSFET Analog Switch.

For a verbal description click here.

The circuit is called complementary because it employs an N channel and a P channel MOSFET. When the control voltage is zero, the N channel FET has a gate voltage of zero and the P channel FET has a gate voltage of VDD. That turns both of them off. If the signal source is at a potential of VDD the P channel FET will still be off and the N channel FET will be negatively biased, which makes doubly certain that it will be off. If the signal source is at zero potential the N channel FET will still be off and the P channel FET will be positively biased, which makes doubly certain that it will be off. When the control input changes to VDD the N channel FET has a positive VDD on its gate while the P channel FET has zero potential on its gate. If the signal is at zero potential the N channel FET will be on but the P channel FET will be off. If the signal is at VDD the P channel FET will be on, but the N channel FET will be off. The two FETs are in parallel. So as long as one of them is on, the switch is on.

The inverter is another example of how FETs are used as switches. Figure 4.24 shows the circuit of the inverter which was shown as a triangle in the circuit of Figure 4.23. When the input signal is at zero volts Q1 is biased fully on and Q2 is fully off. Thus the output is held to VDD. The output is high for a low input. If the input is VDD (high) Q1 is biased off (zero potential between gate and source) and Q2 is on. The output is low because it is held to ground by Q2. Whatever the state of the input, the output assumes the opposite state.

Figure 4.24 CMOS Inverter.

For a verbal description click here.

There are ICs which are known as invertors which contain six such circuits. Although they are not intended for use as analog devices, the input may be biased at 1/2 VDD and as such they make excellent amplifiers. (Which goes to show that if someone designs something, someone else will figure out a way to use it wrong and make it work.)

Example 4.14.

A P channel depletion mode FET has -10 volts on its gate with respect to its source. Is it on or off?

Solution:

A P channel depletion mode FET is on at zero potential and its drain current decreases as the gate is made positive. At +10 volts it would most likely be off but at -10 volts it is extremely on.

Example 4.15.

An N channel enhancement mode MOSFET has a gate bias of zero volts. Is this FET on or off?

Solution:

At zero volts between gate and source any enhancement mode MOSFET is off. The FET is off.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

4.6 The FET as an Amplifier.

The FET has only two small-signal parameters, the drain resistance rd and the transfer conductance, called by contraction-loving electrical engineers transconductance Gm. The transconductance is defined as the AC drain current divided by the AC gate to source voltage with the drain to source voltage held constant.

Gm = id / vgs with vds = 0           (4.37)

The drain resistance is defined as the AC drain to source voltage divided by the AC drain current with the gate to source voltage held constant.

rd = vds / id with vgs = 0           <4.38)

Figure 4.25 Small Signal Equivalent Circuit for an FET.

For a verbal description click here.

The Common Source Amplifier.

The common source equivalent circuit we will work from is shown in Figure 4.26. The input is an open circuit, as is the input of an FET. The output circuit consists of a current source which is dependent on the voltage between the gate and source. The drain resistance is in parallel with the current source. Any load is connected in parallel with the drain resistance.

Figure 4.26 Equivalent Circuit of Common Source Amplifier.

For a verbal description click here.

The output voltage vo is the current source times the parallel combination of rd and RL.

vo = -vin Gm rd RL / (rd + R/L)           (4.19)

Dividing through by vin and making the substitution AV = vo / vin we have,

AV = -Gm rd RL / (rd + R/L)           (4.20)

where RL is the parallel combination of all resistors connected from the drain to AC ground.

Amplifier Biasing.

A properly biased common source N channel JFET amplifier is shown in Figure 4.27. The battery VDD provides the positive bias for the drain and the battery VGG provides the negative bias for the gate. While this two-battery circuit will certainly work, it is not very practical.

Figure 4.27 JFET Amplifier Using Battery Bias.

For a verbal description click here.

Figure 4.28a shows how the circuit may be rearranged without altering its operation. The negative connection point of VDD has been moved to the negative end of VGG, reducing VDD by the amount of VGG. This reduction is usually not significant enough to have any adverse effect. Notice that the polarity of VGG is the same as would be produced by the drain-source current flowing through a resistor in the source. Figure 4.28b shows the substitution of a resistor and a filter capacitor for the battery. The value of the source resistor sets the operating point.

Figure 4.28 Converting Battery Biasing to Self Biasing.

For a verbal description click here.

Unlike for the BJT the operating point of the FET cannot be easily calculated. Some texts present a graphical solution which requires having a set of characteristic curves for the FET similar to those in Figure 4.18. Semiconductor manufacturers do not supply these curves for a very good reason. There is so much difference between FETs of the same type number that a set of curves would be useless. A semiconductor curve tracer interfaced to a computer and plotter could produce a set of curves for any individual FET and the graphic solution could be performed. Such a solution would be valid for only that one particular FET. Another FET would require another set of curves and a new graphical solution. We will not waste our time learning a useless procedure.

The one and only advantage that FETs have over BJTs is their very high input resistance. In commercially designed equipment it is usual to see only one or two FETs among thirty or more BJTs. Even with such limited use, setting the operating point is a problem. There are two basic solutions. One is to use a trimming potentiometer (a screwdriver- adjusted variable resistor) as the source resistor as shown in Figure 4.29(a). Part of the calibration procedure includes setting the proper operating point of the FET amplifier. The other solution is to use the FET in conjunction with a BJT in an arrangement which will automatically set the operating point of the FET as shown in Figure 4.29(b).

Figure 4.29 Practical JFET Amplifier.

For a verbal description click here.

Which one is used depends on who is to build the circuit. If the circuit is contained in a DIY article or a kit the reader or buyer is the one who constructs it. He does not receive a bill for his time at the end of each month so there is no cost associated with having him adjust the pot for the proper operating point.

If the circuit is in a device which will be manufactured in the tens or hundreds of thousands and sold in retail stores the eventual owner cannot be held responsible for adjusting the pot. It must be done on the assembly line by a worker. It is an unavoidable fact that workers have to be paid. It is also a fact that workers do occasionally make errors. The expense of paying someone to adjust the pot will buy a lot of transistors. While the circuit at (b) is mor costly in terms of parts it is less expensive when fabrication costs are taken into account.

The (b) circuit works because the BJT sets the current through both transistors and holds it constant. The collector voltage, also the source voltage adjusts itself to what ever value is necessary to make the FET conduct the correct amount of current. The gate resistor is returned to the base to insure that the BJT will never be forced into saturation by the required gate to source voltage of the FET. The gate resistor in either circuit can easily go as high as 10 meg ohms if necessary.

Example 4.16.

In the circuit of Figure 4.29 the drain resistance of the FET is 130 k ohms and the transconductance is 600 micro mhos. What is the amplifier gain?

Solution:

RL consists of the parallel combination of 47 k ohms and 100 k ohms, which is 32.0 k ohms. The gain of the amplifier is

AV = -Gm rd RL / (rd + RL)

AV = -600 micro mhos x 130 k ohms x 32 k ohms / (130 k ohms + 32 k ohms) = -15.4

The Source-follower Amplifier.

Because the FET is used for its high input impedance, it is most often seen as a source-follower, as shown in Figure 4.30. The FET source-follower is characterized by very high input impedance, low output impedance and slightly less than unity gain.

Figure 4.30 Source-follower Using N Channel JFET.

For a verbal descriptionclick here.

Figure 4.31 Equivalent Circuit of a Source-follower.

For a verbal description click here.

The equivalent circuit of a source-follower is shown in Figure 4.31. Summing the voltages around the outside loop we Have

Vin = vgs + vo           (4.21)

In a source-follower the value of RL is usually much less than rd so we can neglect rd in the following equation. The output voltage is given by

Vo = vgs Gm RL           (4.22)

Solving equations 4.21 and 4.22 for vgs and setting them equal gives

Vin - vo = vo / (Gm RL)           (4.23)

Solving for vo / vin and remembering that AV is defined as vo / vin we have.

AV = Gm RL / (Gm RL + 1)           (4.24)

As with the emitter-follower, the output impedance of the source-follower can be obtained by shorting the input, connecting a generator V across the output and determining the current I which flows. The output resistance is V/I. The equivalent circuit is shown in Figure 4.32.

Figure 4.32 Finding Output Resistance of a Source-follower.

For a verbal description click here.

The current flowing through rd will be neglected. The current supplied by the generator is,

I = Gm vgs           (4.25)

Because the input is short circuited vgs = V and so,

RO = V / I = 1 / Gm.           (4.26)

The output resistance of a source-follower circuit is the parallel combination of the results of equation 4.26 and the resistor in the source of the FET. Note that unlike the emitter-follower the generator resistance has no effect on the output resistance.

Example 4.17.

In the circuit of Figure 4.30 the value of RS is 1 k ohm and the transconductance of the FET is 3000 micro mhos. What are (a) the voltage gain and (b) the output resistance of the circuit?

Solution:

(a) The gain is given by

AV = Gm RL / (Gm RL + 1)

AV = 3000 micro mhos x 1 k ohm / (3000 micro mhos x 1 k ohm + 1) = 0.75

(b) The output resistance is

RO = 1 / Gm = 1 / (3000 micro mhos) = 333 ohms.

The output resistance is 333 ohms in parallel with 1 k ohm which is 250 ohms.

You may be surprised by the low gain which is available from an FET source-follower. Designers seldom use a simple source-follower for just that reason. One very popular arrangement employs an N channel FET and a PNP BJT as shown in Figure 4.33. This circuit is often used as the input stage in oscilloscopes and AC voltmeters. This circuit is normally designed such that the collector current of the BJT is greater than the source current of the FET. This allows the BJT and the resistors to predominate in setting the operating point which eliminates the need for a trimming pot. Even so there is a DC offset between the input and output. The output may be anything from 1 to 4 volts more positive than the input. In DC coupled amplifiers such as those found in oscilloscopes this offset must be accounted for in some way to avoid adding it to the output.

Figure 4.33 Unity Gain Impedance Buffer Using an FET.

For a verbal description click here.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

4.7 Differential Amplifier.

In the next chapter we will take up the study of operational amplifiers. A very important aspect of the op amp is its differential or difference input. A differential input consists of two input points with respect to ground. The circuit subtracts the two input signals. Thus the output of a differential amplifier is

VO = AV (V2 - V1)           (4.37)

where AV is the voltage gain of the amplifier, V1 is the signal applied to the noninverting input and V2 is the signal applied to the inverting input.

The noninverting input is so named because an AC signal applied to this input is not inverted in phase. The inverting input is so named because an AC signal applied to this input is inverted in phase.

Figure 4.34 BJT Differential Amplifier.

For a verbal description click here.

Figure 4.34 shows a differential amplifier using BJTs. Q1 and Q2 work together to form the differential amplifier. Transistor Q3 along with R7, R8 and R9 form a constant current sink for the emitters of Q1 and Q2. The resistor network consisting of R7 and R8 keeps the voltage at the base of Q3 very stable regardless of changes in the base current of Q3. A very stable base voltage means that the emitter current will also be very stable and the collector current will also be very stable. Q3 carries the sum of the emitter currents of Q1 and Q2. If the emitter current in Q1 changes by a certain amount I, the emitter current of Q2 must change by an amount equal in magnitude and opposite in sign -I. This helps to maintain equal amounts of gain for both inputs.

Resistors R5 and R6 introduce emitter degeneration in Q1 and Q2, which lowers and further equalizes the gains. In an amplifier of this type emitter degeneration is not a bad thing. The gain is set by the ratio of R3 to R5 rather than the parameters of the transistors. It should be noted that R3 = R4 and R5 = R6. If maximum gain is desired resistors R5 and R6 may be replaced by pieces of wire but Q1 and Q2 must be very closely matched (have identical parameters) if the gains from the two inputs are to be equal in magnitude.

The output may be taken in either one of two ways. Output 1 is taken between the collectors of Q1 and Q2 as shown. This is a differential or as it is sometimes called a push-pull output. It is suitable for driving another differential amplifier or a balanced transmission line. Some oscilloscopes employ differential amplifiers from beginning to end. The deflection plates of a CRT must be driven from a differential output for best performance.

Output 2 is taken between the collector of Q1 and ground. The input marked with a - sign is the inverting input. A positive-going signal applied to the base of Q1 will cause its collector current to increase. That increase will cause a larger voltage drop across R3 which will cause the voltage at the collector of Q1 to decrease. The input marked with a + sign is the noninverting input. A positive- going signal applied to the base of Q2 will cause the collector current of Q2 to increase. That increase in collector current of Q2 must be mirrored by a decrease in the collector current of Q1. A decrease in the collector current of Q1 will cause the drop across R3 to decrease. The decreased voltage drop across R3 will increase the voltage at the collector of Q1. In case you forgot, we started with an increase in the input voltage which shows that the input marked with a + sign is the noninverting input.

Figure 4.35 FET Differential Amplifier.

For a verbal description click here.

Figure 4.35 shows a differential amplifier employing FETs instead of BJTs. You will note that Q3, R7, R8 and R9 have been replaced by a symbol which you may have never seen before. This is the symbol for a constant current sink. It is commonly used when showing internal schematic diagrams of integrated circuits. The FET differential amplifier functions in exactly the same way as the BJT differential amplifier except its input impedance is much higher. Because FETs are even harder to match than BJTs, R5 and R6 are still necessary. Indeed they may be chosen to bring the gain down close to unity in order to balance the gains of the two transistors. FETs are used to obtain high input impedance. When large amounts of gain are needed, BJTs will be found in the circuit. If both are needed in the same amplifier, you will find both FETs and BJTs in the circuit.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

4.8 Problems.

  1. The collector current of a BJT begins in the emitter, flows through the base region and ends up in the collector region. (This current refers to charge carrier current, not conventional current.) What kind of charge carriers (minority or majority) make up the collector current when it is in the (a) emitter region, (b) the base region, and (c) the collector region?

  2. In a PNP transistor the base current (conventional current) flows out at the base terminal. Where does it flow in?

  3. In the circuit of Figure 4.3 the values are as follows: VCC = 28 volts, beta = 150, VINON = 5 volts, VINOFF = 0 and RB = 8.2 k ohms. (a) If the lamp current is 65 mA, will the lamp be turned fully on? (b) After a few years the lamp burns out and someone replaces it with a lamp which draws 100 mA. Will this new lamp be fully turned on by the BJT switch? What will be the lamp current?

  4. In the circuit of Figure 4.4 VINON = 10 volts and VINOFF = 2 volts. R1 = 3.3 k ohms and R2 = 820 ohms. All other circuit parameters are as shown in the figure. Is the switch on when the control signal is high and off when the control signal is low? Show detailed calculations for both off and on states.

  5. For the starting conditions of problem 4, all of the students involved with designing and building the circuit have graduated. The transistor burns out and the equipment must be repaired because someone is giving a paper next week. Someone finds an old germanium transistor in a drawer and in desperation installs it in the circuit. The replacement has a beta of 100 but VBE to turn it on is 0.15 volts. Is the switch on when the control signal is high and off when the control signal is low? Show detailed calculations for both off and on states.

  6. For the starting conditions of problem 4, all of the students involved with designing and building the circuit have graduated. The transistor burns out and the equipment must be repaired because someone is giving a paper next week. Someone finds an old transistor in a drawer and in desperation installs it in the circuit. The replacement transistor is a silicon unit but its beta is 25. Is the switch on when the control signal is high and off when the control signal is low? Show detailed calculations for both off and on states.

  7. A transistor has the following parameters, hie = 2.5 k ohms and hfe = 85. If RL = 3.3 k ohms what is the gain of the common emitter amplifier?

    8. Figure 4.36 Common Emitter and Emitter-follower Amplifier.
    For Q1, hie = 2 k ohms and hfe = beta = 120.
    For Q2, hie 30 ohms and hfe = beta = 55.

    For a verbal description click here.

  8. Calculate the value of the collector current of Q1 in the circuit of Figure 4.36. Do not use an equation which is any more complicated than necessary.

  9. Calculate the value of the collector current of Q2 in the circuit of Figure 4.36. Do not use an equation which is any more complicated than necessary.

  10. Calculate the voltage gain of the emitter-follower stage in Figure 4.36. Remember to take everything into account when determining RL.

  11. Calculate the voltage gain of the common emitter stage in Figure 4.36. Remember to take everything into account when determining RL.

  12. The input resistance of a common emitter amplifier is equal to hie. What is the input resistance of the circuit of Figure 4.36?

  13. In the circuit of Figure 4.36 if the 75 ohm load were removed, what would be the output resistance of the circuit?

  14. What must the gate voltage be of an enhancement mode N channel MOSFET to (a) turn it on and (b) turn it off?

  15. What must the gate voltage be of an enhancement mode P channel MOSFET to (a) turn it on and (b) turn it off?

  16. Is it possible to make the circuit of Figure 4.23 work with depletion mode MOSFETs? Why or why not?

  17. Is it possible to make the circuit of Figure 4.24 work with depletion mode MOSFETs? Why or why not?

  18. A common source FET amplifier has a load resistance of 1.5 k ohms. The FET has a Gm of 3600 micro mhos and an rd of 200 k ohms. What are (a) the input resistance, (b) the voltage gain and (c) the output resistance?

  19. An FET source-follower has a load resistor of 10 k ohms. The FET has a Gm of 2600 micro mhos and an rd of 200 k ohms. What are (a) the input resistance, (b) the voltage gain and (c) the output resistance including the 10 k ohm load resistor?

  20. In the circuit of Figure 4.34 the collector current of Q3 is 1 mA. If the collector current of Q1 is 0.340 mA, what is the collector current of Q2?

  21. In the circuit of Figure 4.35 if the drain current of Q1 increases by 50 microamps, what happens to the drain current of Q2?

  22. If the gain of a differential amplifier is 10, V1 = +1.0 volt and V2 = +1.0 volt, what is the output voltage?

  23. If the gain of a differential amplifier is 100, V1 = +1.00 volt and V2 = +1.01 volt, what is the output voltage? Be sure to give sign as well as magnitude.

  24. If the gain of a differential amplifier is 100, V1 = +1.01 volt and V2 = +1.00 volt, what is the output voltage? Be sure to give sign as well as magnitude.

  25. If the gain of a differential amplifier is 100, V1 = -1.00 volt and V2 = -1.01 volt, what is the output voltage? Be sure to give sign as well as magnitude.

  26. If the gain of a differential amplifier is 100, V1 = -1.01 volt and V2 = -1.00 volt, what is the output voltage? Be sure to give sign as well as magnitude.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

4.9 Answers to problems.

  1. Part a, majority. Part b, minority. Part c, majority.

  2. At the emitter.

  3. Part a, required base current = 0.433 mA, supplied base current = 0.536. Lamp is fully on. Part b, required base current = 0.667 mA. The lamp is not fully on. Lamp current = 80.4 mA.

  4. On state. Required IB = 0.793 mA. Supplied IB = 2.12 mA. Switch is on. Off state. VBE unloaded = 0.398 V. Switch is off.

  5. On state. Required IB = 0.793 mA. Supplied IB = 2.80 mA. Off state. VBE unloaded = 0.398 V. BE is forward biased. Supplied IB = 0.378 mA. The switch will be between the on and off states.

  6. On state. Required IB = 3.17 mA. Supplied IB = 2.12 mA. The switch is not fully on. Off state. Same as in problem 4.

  7. AV = 112.

  8. IC = 1.20 mA by equation 4.24.

  9. IC = 47.2 mA by equation 4.23.

  10. AV = 0.987.

  11. AV = 43.6. Hint: There are 4 components that have to be added in parallel to make up RL.

  12. Rin = 1.57 k ohms.

  13. RO = 16.4 ohms.

  14. (a) Positive, (b) 0.

  15. (a) Negative, (b) 0.

  16. No. In the "on" state all is fine but in the off state one of the FETs will always be on.

  17. No. Both FETs would be on, draw excessive current, and burn themselves out.

  18. 1012 ohms, (b) -5.36, (c) 1.49 k ohms.

  19. 1012 ohms, (b) 0.963, (c) 370 ohms.

  20. ICQ2 = 0.660 mA.

  21. The drain current of Q2 will decrease by 50 microamps.

  22. VO = 0 V.

  23. VO = + 1.00 V.

  24. VO = - 1.00 V.

  25. VO = - 1.00 V.

  26. VO = + 1.00 V.


Chapter 5   Applying Feedback To Amplifier Circuits.

5.1  Some Preliminary Information.
5.2  The Negative Feedback Equation.
5.3  The Special Case of the Inverting Amplifier.
5.4  Frequency Response and Stability.
5.5  Gain Accuracy and Precision.
5.6  Other Benefits of Negative Feedback.
5.7  Some Practical Circuits.
5.8  Positive Feedback, Oscillators.
5.9  Problems.
5.10 Answers to Problems.

Chapter 5.

Applying Feedback To Amplifier Circuits.

If you have ever operated your school's sound system or have participated in a rock or country music band, you probably know the word "feedback". Feedback occurs when a fraction of the output signal is introduced into the input of an amplifier. The kind of feedback that sound system operators are familiar with is the squeal of positive feedback. This kind of feedback is undesirable but there are kinds of feedback which cause good things to happen. In this chapter we will study the desirable kinds of feedback.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

5.1 Some Preliminary Information.

When feedback is introduced electronically its phase can be controlled. The signal which is fed back may reinforce or partially cancel the input signal. Feedback which reinforces the input signal is called positive feedback. Feedback which partially cancels the input signal is called negative feedback. We will begin our study of feedback with negative feedback.

A major confusion factor has developed in teaching negative feedback because of a split among electrical engineers. One group, the audio engineers, sets out to derive the feedback equation by assuming a generalized amplifier. The equation they derive has a minus sign in the denominator. The other group, control systems engineers, assumes a net 180 degree phase shift in the feedback loop. In other words they assume that the feedback is always negative. The equation they derive has a plus sign in the denominator.

That would be bad enough by itself but the operational amplifiers (op amps) which are so useful have grown out of the control systems branch of electrical engineering. What this means to a teacher teaching a survey course in electronics is that when teaching feedback applied to audio amplifiers the equation with the minus sign must be used and when teaching op amps the equation with the plus sign must be used. That has proven to be so confusing to students that there is doubt as to whether they ever learned anything about feedback. In this book we will define away the problem by adopting one convention and sticking to it. If you look up the subject of feedback in another textbook you may find more confusion than help.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

5.2 The Negative Feedback Equation.

Figure 5.1 Noninverting Amplifier with Negative Feedback.

For a verbal description click here.

Figure 5.1 shows an amplifier with negative feedback applied. The amplifier is a differential amplifier which was discussed in the closing section of chapter 4. The signal generator is applied to the noninverting input of the amplifier. A fraction, beta, of the output signal is fed back to the inverting input. The difference between the two signals is amplified by the factor A and appears at the output.

The output of a differential amplifier is given by equation 4.27 which is repeated here.

VO = A (V1 - V2)           (5.1)

As shown in Figure 5.1 V1 is the input signal and V2 is the fraction of the output signal beta VO. If we make these substitutions into equation 5.1 we have

VO = A (VIN - beta VO).           (5.2)

Solving this equation for VO / VIN we have the feedback equation.

VO / Vin = A / (1 + A beta)           (5.3)

The term VO / VIN is called the closed loop gain and is given the symbol A', thus,

A' = A / (1 + A beta)           (5.4)

where A' is the closed-loop gain, A is the open-loop gain and beta is the fraction of the output which is fed back to the input. This equation is to amplifiers as Ohm's law is to electric circuits. Memorize it.

For the noninverting amplifier beta is given by

beta = R1 / (R1 + R2)           (5.5)

This beta is not to be confused with the BJT beta. They are not the same thing nor are they related in any way.

Let us be sure we understand all of the terms associated with feedback. The open-loop gain (A) is the gain of the amplifier without any feedback circuits connected. The closed-loop gain (A') is the gain of the amplifier after the feedback has been connected. Beta, (it has no other name,) is that fraction of the output which is fed back to the input.

Example 5.1.

An amplifier has an open-loop gain of 250 and a beta of 0.02. What is its closed-loop gain?

Solution:

The closed-loop gain is given by

A' = A / (1 + A beta) = 250 / (1 + 250 x 0.02) = 41.67.

Note that we indicate this gain as a positive number. The circuit of Figure 5.1 is a noninverting amplifier which has no phase inversion. Such an amplifier has the signal applied to the noninverting input.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

5.3 The Special Case of the Inverting Amplifier.

When the signal is applied to the inverting input, the circuit is called an inverting amplifier. An AC signal applied to the amplifier will be inverted by 180 degrees. When the value of the gain is stated it must be given as a negative quantity. The circuit of an inverting amplifier is shown in Figure 5.2. If you look in other texts similar to this one you are not likely to find the derivation of the gain of an inverting amplifier. The reason is that the equation which results from an exact derivation is slightly different from the one for a noninverting amplifier. Let us derive the equation and then we will discuss the difference.

Figure 5.2 Inverting Amplifier with Equation Loops Indicated.

For a verbal description click here.

In Figure 5.2 the loops and polarity of all voltage drops are clearly marked. Consider these markings as a "snapshot" taken at the peak of the sine wave. Current flows from left to right through R1 and R2 thus causing the voltage drops to be as indicated on R1 and R2. Because of the nature of the amplifier the output voltage (VO) must have the opposite polarity as the input voltage (Vsig).

If we write the loop equations around the loops labeled "equation 5.5" and "equation 5.6" we have

VIN = I R1 + Vsig           (5.5)

And

Vsig = I R2 - VO.           (5.6)

The current I is the same in both resistors. The input resistance of the amplifier is very high and in actual practice the magnitude of Vsig is very small; hence any current flowing into the inverting input is very, very small. Therefore the currents in R1 and R2 are equal. Solving equations 5.5 and 5.6 for I and setting them equal gives

(VIN - Vsig) / R1 = (VO + Vsig) / R2           (5.7)

The nature of the amplifier requires that VO = A Vsig; therefore, Vsig = VO / A. Making this substitution into equation 5.7 gives.

(VIN - VO / A ) / R1 = (VO + VO / A) / R2           (5.8)

If we multiply equation 5.8 through by A, R1 and R2 we get

R2 VIN A - R2 VO = R1 VO A + R1 VO.           (5.9)

After collecting VO terms, factoring out VO and performing some additional algebraic calisthenics we get

VO / VIN = R2 A / (R2 + R1 A + R1)           (5.10)

Remembering that A' = VO / VIN and dividing numerator and denominator by R2 gives.

A' = A / (1 + R1 / R2 A + R1 / R2)           (5.11)

For the inverting amplifier we will now define beta as follows.

beta = R1 / R2           (5.12)

If we substitute equation 5.12 into equation 5.11 and factor out beta we now have,

A' = A / (1 + beta (A + 1)).           (5.13)

Compare equation 5.13 with equation 5.4 which is the gain for a noninverting amplifier.

You are challenged to find equation 5.13 in any other text on this level. If all starting assumptions are correct and all of the algebra has been correctly done, the solution must be correct. Careful laboratory measurements using an amplifier with a low open-loop gain have shown that the equation does accurately predict the gain of an inverting amplifier. Equation 5.13 is the correct equation for the gain of an inverting amplifier.

A Difference Which Makes No Difference Is No Difference.

If the open-loop gain A is much greater than unity, equation 5.13 may be approximated by equation 5.4 with little detectable error. In actual practice open-loop gains are almost never less than 200 and may be as high as 107. Adding one to these large numbers will not make any practical difference. Unless the open-loop gain is less than 50, you need not bother with equation 5.13. Use equation 5.4.

Example 5.2.

An inverting amplifier has an open-loop gain of -10. The values of the feedback resistors are R1 = R2 = 10 k ohms. (a) What gain is predicted by equation 5.4? (b) What gain is predicted by equation 5.13? (c) What is the percent error of equation 5.4?

Solution:

For an inverting amplifier beta = R1 / R2 and if R1 = R2, beta = 1.00. (a) The gain predicted by equation 5.4 is.

A' = A / (1 + A beta) = 10 / (1 + 10 x 1) = -0.9091.

(b) The gain predicted by equation 5.13 is.

A' = A / (1 + beta ( A + 1)) = 10 / (1 + 1 x 11) = -0.8333.

(c) The result of equation 5.13 is the standard; therefore, the percent error is + 9.10%

Example 5.3.

An inverting amplifier has an open-loop gain of -500. R1 = 10 k ohms and R2 = 200 k ohms. What is the closed-loop gain of the amplifier?

Solution:<

The value of beta is beta = R1 / R2 = 10 k ohms / 200 k ohms = 0.0500. The open-loop gain is so much greater than unity that we can use equation 5.4.

A' = A / (1 + A beta) = 500 / (1 + 500 x 0.05) = -19.23.

Example 5.4.

A noninverting amplifier has the same values as in example 5.3, A = 500, R1 = 10 k ohms and R2 = 200 k ohms. What is the closed-loop gain?

Solution:

For a noninverting amplifier the value of beta is

beta = R1 / (R1 + R2) = 10 k ohms / (10 k ohms + 200 k ohms) = 0.047619

The closed-loop gain is.

A' = A / (1 + A beta) = 500 / (1 + 500 x 0.047619) = +20.15.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

5.4 Frequency Response and Stability.

Until now we have treated amplifiers as having a phase shift of 0 degrees (noninverting) or 180 degrees (inverting). As long as the frequency response is flat (gain does not change with frequency), these rules of phase shift apply. If the gain is rising or falling with frequency, there will be an extra phase shift which may cause trouble.

The gain of an amplifier will change with frequency if there are RC networks inside the amplifier. These circuits may have been introduced intentionally or they may just be there. An example of an intentionally introduced RC circuit is the coupling capacitor between the collector of one BJT and the base of the next BJT. The resistance in the circuit and the capacitor form a high-pass filter. A semiconductor amplifier may not have any, or maybe one, of these circuits but a vacuum tube amplifier may have several.

Something never shown in schematic diagrams but always present in real circuits is stray capacitance. Remember that a capacitor consists of two conductors separated by an insulator. Any time there are two wires close together there is capacitance between them. That means that there are invisible capacitors connected from the collector of each transistor to ground and from the base of every transistor to ground. These capacitors combine with the Thevenin's resistance of the circuits to form low-pass filters. Each tiny low-pass filter causes the frequency response of the amplifier to roll off (gain decreases as frequency increases). Moreover, each transistor (BJT or FET) has its own built-in low-pass filter. Each device has its own frequency limits which are imposed by such things as collector-to-base capacitance and charge mobility within the semiconductor material.

The equations for phase shift (chapter 2) tell us that at the cutoff frequency the phase shift is 45 degrees. As the frequency gets higher than the cutoff frequency of a low- pass filter (or lower than the cutoff frequency of a high- pass filter) the phase shift quickly approaches 90 degrees. At the same time the gain is falling at a rate of a factor of 10 for each factor of 10 change in frequency.

Because the individual RC filters are isolated from one another by transistor stages, each one contributes to the total without affecting each other. If there are two RC filters with similar cutoff frequencies, the gain beyond cutoff will change by a factor of 100 for every factor of 10 change in frequency. The phase shift will approach 180 degrees. If there are three RC filters, the gain will change by a factor of 1000 for every factor of 10 change in frequency and the phase shift will approach 270 degrees. Gain change and phase shift go together like many other pairs of things you may have heard of. "You can't have one without the other." Thus, it is possible to know what the phase shift is even if you have no way of measuring it directly.

In the common operational amplifier, (op amp), the collector of the preceding transistor stage is directly coupled, not capacitively coupled, to the base of the next stage. This makes the frequency response go down to zero frequency which is DC. This is one of the few cases in electronics where it is possible to get something all the way to zero. Without any high pass filters in the amplifier the low pass filters that make the response roll off at the high frequencies are our only concern.

In some transistor amplifiers and all vacuum tube amplifiers there are high pass filters between each stage. These are capacitors in series with the signal path which are necessary to block the DC on the plate or collector of one stage from altering the bias on the grid or base of the following stage. The capacitors in conjunction with the resistors that connect to the control element of the amplifying device form high pass filters. These High-pass filters introduce phase shift and can cause low frequency oscillation if not designed properly.

The amount of phase shift depends upon the rate at which the gain is changing with frequency, which is determined by how many RC low-pass (or high-pass) circuits there are inside the amplifier. The rate of gain change is geometric. This means that a changing gain will be a straight line on a log- log graph. Figure 5.3 shows a log-log graph with various slopes (rates of change) plotted on it.

A rate of change of one decade decrease in gain for each decade increase in frequency is referred to as a slope of -1. If the gain decreases two decades for one decade increase in frequency, the slope is -2. If the gain should be increasing as frequency increases, the slope would be positive.

In the following discussion the phase shifts will be given with respect to the noninverting input. The phase shifts for the inverting input will be the algebraic sum of the stated phase shift and 180 degrees. If the slope of the frequency response is a negative 1, the phase shift will be -90 degrees. If the slope of the frequency response is -2, the phase shift will be -180 degrees. If the gain is falling with a slope of -2, the noninverting and the inverting inputs will be effectively interchanged. A connection which we thought would give negative feedback instead gives positive feedback. Positive feedback is the situation wherein the input signal is reinforced by the signal which is fed back instead of being partially canceled. When the input signal is reinforced, the output signal increases in amplitude. This causes the fed back signal to be increased which, in turn, causes the output signal to increase. This is a run- away condition and the input signal is no longer necessary; the amplifier is supplying its own input. An example is the earsplitting squeal of a sound system. This process is called oscillation and a device which oscillates is called an oscillator. When negative feedback becomes positive feedback we have an oscillator instead of an amplifier.

It would do no good to reverse the connections to the inverting and noninverting inputs. There would always be a part of the frequency spectrum where the gain is flat and there would be no extra phase shift. The circuit would oscillate because the feedback would be positive for those frequencies where the frequency response is flat.

In order to support oscillation two conditions must be met: 1) the net phase shift around the feedback loop must be zero and 2) the gain must be greater than unity. In order to prevent a feedback amplifier from oscillating, we must see to it that both conditions are not met at the same frequency. If at any given frequency only one of the two conditions is met, oscillation will not occur. The act of making internal changes to the amplifier so that both conditions will not be met at the same frequency is called amplifier compensation.

An amplifier which has not been compensated may well have a frequency response like that of the black line in Figure 5.3. A properly compensated amplifier could have a frequency response like the green line in the figure.

Figure 5.3 Bode Diagram Showing Compensation of an Amplifier.

For a verbal description click here.

It should be pointed out that the slope of real frequency response curves does not break suddenly from one slope to another. The curves make gradual and smooth transitions from one slope to the other as we saw in chapter two. What has been drawn in Figure 5.3 are the tangents to the curves. The tangents from the flat portion and the -1 slope portion intersect directly over the -3 dB point. That is why the -3 dB frequency is sometimes called the corner frequency.

Examine the black curve in the above figure. It goes out flat to 100 kHz. Actually the frequency response is down 3 dB at 100 kHz but the Bode plot is drawn this way. At 100 kHz the plot breaks to a slope of -1. That means that one of the transistors started rolling off the frequency response. Another transistor in the amplifier begins to roll off at 1 MHz. This causes the Bode plot to break to a slope of -2. The plot falls by 40 dB, a factor of 100, between 1 and 10 MHz. At 10 MHz another transistor kicks in and the slope breaks to a slope of -3. After that the curve falls by 3 decades, 60 dB between 10 and 100 MHz.

What makes a feedback circuit oscillate is the loop gain not the gain of the amplifier. If this amplifier were to be used with a beta of 1/10000, it would not oscillate. 10000 is the value of gain where the slope breaks from -1 to -2. If a gain of 10000 is combined with a beta of 1/10000 the value of A beta is unity where the Bode plot breaks from -1 to -2 and the amplifier will be stable. Such a small value of beta would not be very useful but in audio amplifiers where the value of beta is fixed by the designer and does not change the Bode plot for A beta is used to compensate the amplifier instead of the plot of A alone.

On the other hand an op amp is frequently used with 100% feedback which is a beta of unity. To be useful an op amp must be compensated to unity gain. The way to convert the black curve in figure 5.3 into the green curve is to insert a passive circuit like that of figure 5.4 into the amplifier. This circuit produces the Bode plot of the red curve in the figure.

Figure 5.4 Schematic of Compensation Network.

For a verbal description click here.

The frequency where the red curve breaks from flat to a slope of -1, 10 Hz in this case, is given by,

fA = 1 / (2 Pi C(R1 + R2))           (5.14.1)

The frequency where the red curve breaks from -1 to 0, 100 kHz in this case, is given by,

fB = 1 / (2 Pi C R2)           (5.14.2)

Notice that the short segment of -1 slope that is built into the amplifier is used by letting the network's plot flatten out just as the -1 slope of the amplifier is beginning.

The amplifier whose frequency response is plotted in Figure 5.3 is DC coupled. Its frequency response goes flat all the way down to DC (zero frequency). An AC coupled amplifier might have a frequency response like that of Figure 5.5. In this example the upper end of the frequency response falls with a slope of -1 because it has already been compensated. The amplifier will not oscillate in this frequency range. At the low end, however, shown by the black line, the gain has a slope of +2 and is greater than unity. If feedback were applied to this amplifier, it would oscillate somewhere in the 0.3 to 10 hertz frequency range. Some internal changes will have to be made to this amplifier to make the positive portion of the gain slope become +1 from unity gain up to maximum.

Figure 5.5 Bode Diagram with Low Frequency Role Off.

For a verbal description click here.

The black line plot in figure 5.5 is of the amplifier in figure 5.6. Capacitors C1 and C5, if they were numbered, are outside of the feedback loop. C3 is the cathode bypass of the second amplifier and common practice is to set such capacitors so the corner frequency for the RC circuit is very much less than one Hz. Experience has shown that the cathode RC has little effect on the phase shift of the amplifier even if the corner frequency is about one Hz. The resistor values have been fudged so the corner frequencies will fall on decade marks on the Bode plot. These values are not necessarily realistic.

The capacitor values have been set the way a real, but amateur, designer would set them given the resistor values shown. Both break points have been set at 10 Hz which seems to be the reasonable thing to do. However the slope of the plot is plus 2 and the designer will find to his sorrow and possibly amazement that the circuit oscillates at a very low frequency. This kind of oscillation is often known as motorboating because it reminded someone of the sound of an old fashioned inboard motorboat.

Figure 5.6 Vacuum Tube Amplifier With Feedback.

For a verbal description click here.

The value of beta is 1/10 so the amplifier does not have to be compensated to unity gain. A beta must be compensated to unity which means the gain needs only to be compensated to 10 as shown by the green line. To do this one of the break points must be moved down to 1 Hz and the other one up to 100 Hz.

It would not be good to move the C4 corner frequency up to 100 Hz because the output would rise below 100 Hz. So that one will be moved down to 1 Hz and the C2 corner frequency will be moved up to 100 Hz. This will give the green curve in figure 5.5. To make this amplifier stable C2 would have to be decreased to 0.001 microfarads and C4 increased to 1.0 microfarads.

Gain at Any Frequency, and Unity Gain Bandwidth (Gain-bandwidth Product).

An amplifier which has been properly compensated will have its gain change by one decade for every decade change in frequency, for all values of A beta greater than unity. A compensated amplifier may have a very large gain at middle frequencies but its gain can become quite low at the extremes of frequency near the unity gain frequencies.

Let us take as an example a properly compensated AC coupled amplifier whose Bode plot is shown in figure 5.7. Its lower unity gain frequency is 0.1 hertz and its upper unity gain frequency is 100 MHz. The tangents to the frequency response curves (often called the Bode plot) are shown in Figure 5.7. As you can see from the figure, the gain is 10 at 1 Hz and 10 MHz.

To calculate the closed-loop gain of a feedback amplifier at any frequency we must know the open-loop gain at that particular frequency. We will recycle equations 2.24.4 and 2.24.5 from chapter two. You don't have to go back to look at them unless you want to see how they were derived. Those equations have a maximum value of unity. To adapt them for use here they must be multiplied by the maximum gain of the amplifier AMax.

High end or op amp. eh = eh sub max over the square root of quantity f over f sub c2 quantity squared plus 1 close square root.

Low end. eh = eh sub max over the square root of 1 plus quantity f sub c1 over f quantity squared, close square root.

Where f is the frequency at which the gain is desired, A is the desired gain, fc1 is the lower cutoff or corner frequency, fc2 is the upper cutoff or corner frequency, and AMax is the maximum gain. For an AC coupled amplifier, one that roles off at both ends of the frequency spectrum, AMax is the maximum gain that the amplifier reaches at mid band. For a DC coupled amplifier such as an op amp the maximum gain and the DC gain are the same thing. As long as you don't interchange fc1 and fc2 you shouldn't have any trouble knowing which equation to use.

The frequency at which to change from using 5.15.1 to 5.15.2 is at the center frequency. This may not be what you assume. You must use the geometric center frequency which is given by,

fcc = sqrt(fc1 fc2)           (5.15.3)

Where fcc is the center frequency and fc1 and fc2 are as defined above. If you are working with an AC coupled amplifier, or a band-pass amplifier, use equation 5.15.1 above fcc and equation 5.15.2 below fcc.

In a device such as an audio amplifier the values of fc1 and fc2 usually are easy to measure. For op amps and some very high gain band pass amplifiers the values of fcx are likely to be very difficult to measure so the unity gain frequency is measured and stated in specifications. To calculate the corner frequency from the unity gain frequency we use the following equations.

fc1 = flu AMax     positive slope           (5.15.4)

and

fc2 = fhu / AMax     negative slope           (5.15.5)

where flu is the lower unity gain frequency, fhu is the upper unity gain frequency, fc1 is the lower corner frequency, and fc2 is the upper corner frequency.

Example 5.5.

A DC coupled (op amp) amplifier has a DC gain of 100,000 and a gain-bandwidth product (unity gain frequency) of 3 MHz. What is its gain at (a) 100 kHz, (b) 20 kHz, (c) 1000 Hz and (d) 5 Hz?

Solution:

The Bode diagram for this amplifier would be similar in appearance to the green curve in Figure 5.3 but the values would be different. There are no positive slopes in the diagram and so we apply equation 5.15.5 to find fc2.

fc2 = fhu / AMax = 3 x 106 / 105 = 30 Hz.

(a) Using equation 5.15.1 we have

A = 105 / sqrt((105 / 30)2 + 1) = 30

(b) A = 150

(c) A = 2,999

(d) A = 98,639.

Example 5.6.

An AC coupled amplifier has a lower unity gain frequency of 0.1 Hz and an upper unity gain frequency of 100 MHz. Its mid-band (maximum) gain is 1,000. What is its gain at (a) 5 Hz, (b) 20 Hz, (c) 1 kHz, (d) 20 kHz, (e) 200 kHz and (f) 4 MHz?

Solution:

The Bode diagram for this amplifier is shown in Figure 5.7. Making a Bode diagram is a good way to avoid mistakes in problems of this kind.

Figure 5.7 Bode Diagram for Example 5.6.

For a verbal description click here.

The first step is to find fc1 and fc2.

fc1 = flu AMax = 0.1 x 1000 = 100 Hz.

fc2 = fhu / AMax = 108 / 1000 = 105 Hz.

In order to decide which equation to use we must split the frequency response curve at the center of the flat portion. The center is the geometric mean of 100 Hz and 100,000 Hz. fcc is given by,

fcc = sqrt(100 x 100,000) = 3.16 kHz

(a), (b), and (c), are all below the center frequency and (d), (e), and (f), are all above it. Therefore we will use equation 5.15.2 for (a), (b), and (c), and 5.15.1 for (d), (e), and (f).

From equation 5.15.2 we have,

(a) A = 49.94,

(b) A = 196.1,

(c) A = 995.0

Now changing to equation 5.15.1,

(d) A = 980.6.

(e) A = 447.2,

(f) A = 24.99.

The Feedback Equation with Sloping Gains.

The examples above show how the magnitude of the amplifier gain varies with frequency. In order to make absolutely correct calculations of closed loop gain, taking phase shift into account, we would have to use the j operator. There is no mathematically rigorous way around it. You might suppose that we could use the Pythagorean theorem as we did in our study of RC circuits but the phase shift is not ninety degrees in the region around the corner frequency. The equation that produced the green line in figure 5.7.1 looks like this.

eh prime = eh over the square root of 1 + quantity eh beta quantity squared, close square root.

That equation seems to work but it trades off accuracy in one part of the frequency spectrum for inaccuracy in another. A graph will show what's going on.

Figure 5.7.1 Curves showing open-loop gain and
three calculations of closed-loop gain.

For a verbal description click here.

The graph shows frequency on a log scale versus dB. The numbers along the horizontal axis are the power to which you must raise 10, to obtain the frequency. The scale is from 0.1 to 100,000 Hz. Remember that ten to the 0 power is one. The red curve shows the open loop gain of a DC coupled amplifier with a DC gain of 10,000 and a unity gain bandwidth of 100 kHz. Notice that the gain is down by 3 dB at 10 Hz as it is supposed to be.

The dark blue curve is the gain calculated from equation 5.4. Notice that it is down 6 dB at 100 Hz but it should be 3 dB down.

The green curve is calculated from the equation above. It is correct in this area of the spectrum, being 3 dB down at 100 Hz but the low frequency (DC) part of the curve is off by 1 dB, approximately 10%. As beta is made smaller this error gets worse. For a beta of 0.0001 the DC gain should be 5,000 which is 74 dB. The above equation, which has no number, gives 7,071 which is 77 dB. Such large errors in DC gain calculation cannot be tolerated so the no-number equation will be considered invalid and will not be used.

The equation which produced the light blue line is given below, along with its low frequency companion.

High end or op amp. eh prime = eh over square root quantity f over f sub c2 quantity squared plus quantity 1 plus eh beta quantity squared end square root. 5.4.1.

Low end. eh prime = eh over square root quantity f sub c1 over f quantity squared plus quantity 1 plus eh beta quantity squared end square root. 5.4.2.

These equations were not so much derived as they were cloodged together to get the right answer. The light blue line behaves the way the real frequency response does. However, equations 5.4.1 and 5.4.2 will not be required in homework or test problems. They are presented for reference only.

Example 5.7.

A beta value of .01 is applied to the amplifier of example 5.5. What is the closed-loop gain at frequencies of (a) 100 kHz, (b) 20 kHz, (c) 1 kHz and (d) 5 Hz?

Solution:

(a) A' = A / (1 + A beta) = 30 / (1 + 30 x 0.01) = 23.08

(b) A' = 60.00

(c) A' = 96.77

(d) A' = 99.90

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

5.5 Gain Accuracy and Precision.

Amplifiers without feedback have rather unpredictable gains. Transistor parameters vary with temperature and from one transistor to the next. Even if a one-of-a-kind amplifier were designed and constructed, its gain would change with temperature. If a transistor ever had to be replaced the gain would most likely change drastically.

Amplifiers which are used in physics laboratories are involved with measurement of an electrical quantity. A changing gain in a measurement circuit will render the measurement useless. Negative feedback will stabilize the gain of an amplifier. How sensitive the closed-loop gain is to changes in open-loop gain can be determined through the use of calculus.

We will begin with the feedback equation

A' = A / (1 + A beta)           (5.16)

Using implicit differentiation to take the derivative of A' with respect to A we have,

dA' = ((1 + A beta)dA - A beta dA) / (1 + A beta)2           (5.17)

Splitting equation 5.17 into the difference of two quotients gives.

dA' = (1 + A beta) dA / (1 + A beta)2 - A beta dA / (1 + A beta)2           (5.18)

Now we will split the right-hand term into the product of two quotients and, at the same time, multiply everything to the right of the equal sign by 1 in the form of A / A and cancel (1 + A beta) in the first term. We now have,

dA' = A / (1 + A beta) x dA / A - A / (1 + A beta) x A beta / (1 + A beta) x dA / A.     (5.19)

The right-hand side of equation 5.16 appears twice in equation 5.19. If we substitute 5.16 into 5.19 we now have

dA' = A' x dA / A - A' x A beta / (1 + A beta) x dA / A           (5.20)

If we now divide through by A' and factor out the dA / A term we have

dA' / A' = dA / A (1 - A beta / (1 + A beta))           (5.21)

Simplifying the term inside the brackets gives,

dA' / A' = dA / A x 1 / (1 + A beta)           (5.22)

This is where the EE book I used at university stopped. But The equation can be simplified still further. To shorten the notation let us say that E = dA / A and E' = dA' / A'. In this notation we can write,

E' = E / (1 + A beta)           (5.23)

If we solve equations 5.23 and 5.16 for 1 / (1 + A beta) and set them equal we have.

E' / E = A' / A           (5.24)

Because E' and E now appear as a ratio it doesn't matter if we express E' and E as fractional changes or percentage changes.

This equation gives us one of the more important benefits of negative feedback, which is to stabilize the gain of an amplifier. Let us illustrate with an example.

Example 5.8.

An amplifier has an open-loop gain of 105 which may vary by as much as plus or minus 30%. The value of beta is 0.010. What is (a) the closed-loop gain, (b) how much is this gain in error referenced to 1 / beta, and (c) what is the percent variation in gain due to changes in open-loop gain?

Solution:

(a) The closed loop gain is

A' = 105 / (1 + 105 x 0.01) = 99.90

(b) Error referenced to 100 is -0.1%

(c) By equation 5.24

E' = E A' / A = 30 x 99.90 / 105 = 0.0300%.

This example shows that when the open-loop gain is very high, it has very little effect on the closed-loop gain. The closed-loop gain is set by beta which in turn is set by the values of two resistors. Resistors can be obtained as very high precision units.

It is often necessary to calculate how much open-loop gain is required or how much closed-loop gain can be obtained for a certain amount of gain error.

Example 5.9.

An amplifier has an open-loop gain of 5,000 which can vary by as much as 35 %. What is the maximum closed- loop gain available if the closed-loop gain variation is not to exceed 2.5 %?

Solution:

Solving equation 5.24 for A' gives,

A' = E' A / E = 2.5% x 5000 / 35% = 357.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

5.6 Other Benefits of Negative Feedback.

A fairly obvious question is "If negative feedback reduces the gain, why use it?" In the previous section we have seen that applying negative feedback to an amplifier will control its gain very accurately. That is not the only benefit of negative feedback. Almost any amplifier parameter you care to name is improved by applying negative feedback to it. Any amplifier designer will tell you that gain is the easiest of all parameters to obtain. The standard practice is to design an amplifier with much more gain than is needed and use negative feedback to trade the extra gain for improvement of all of the other parameters of the amplifier.

Frequency Response.

Frequency response is improved by the application of negative feedback. The low frequency limits are moved lower and the high frequency limits are moved higher. For example look at the Bode diagram in Figure 5.8.

Figure 5.8 Bode Diagram of Closed and Open-loop Gains.

For a verbal description click here.

The frequency response of amplifiers is usually given in terms of the -3 dB points rather than the unity gain points. The open-loop gain of the amplifier whose Bode plot is given in Figure 5.8 has a frequency response of 1,000 to 10,000 hertz. Not exactly hi-fi is it? When negative feedback is applied to reduce the gain to 100, the frequency response becomes 10 Hz to 1 MHz. Quantitatively the improvement of frequency response is given by,

f1' = f1 / (1 + A beta)           (5.25)

and

f2' = f2 (1 + A beta)           (5.26)

Where f1 is the lower open-loop -3 dB frequency, f2 is the upper open-loop -3 dB frequency and the primes ' indicate the closed-loop equivalents.

Distortion and Noise.

Distortion is defined as any alteration of the original signal by an electronic circuit. In audio circuits distortion is expressed as a percentage. When an absolutely pure sine wave is introduced at the input of an amplifier, the output consists of the original sine wave plus harmonics of the original sine wave. The total of the harmonics is expressed as a percentage of the original sine wave. This is often called the total harmonic distortion or THD of an amplifier. To a musician, distortion represents an alteration of the reproduced sound. To a physicist, distortion represents nonlinearity and errors in measurements. Distortion and nonlinearity are reduced by the addition of negative feedback to an amplifier as follows. Consider THD to be equivalent to nonlinearity.

THD' = THD / (1 + A beta)           (5.27)

Noise is any varying voltage in a place where it is not wanted. It can be periodic as in the case of the 60 Hz line frequency which gets into everything. Noise can be aperiodic or random. Such noise is caused by the thermal agitation of charge carriers in conductors and semiconductors. The amount of noise N is affected by negative feedback as follows.

N' = N / (1 + A beta)           (5.28)

It should be pointed out that because the signal is also reduced by the factor of 1 / (1 + Abeta) the signal-to-noise ratio is not improved by negative feedback but it isn't made any worse either. The fact that negative feedback is neutral when it comes to signal-to-noise ratio means that the other benefits of negative feedback can be realized without giving up anything really important.

Input and Output Impedance.

The output impedance is lowered by the application of negative feedback by,

ZO' = ZO / (1 + A beta)           (5.29)

In the case of a noninverting amplifier the input impedance is increased by an amount,

ZIN' = ZIN (1 + A beta)           (5.30)

The input impedance which is affected is the input impedance of the transistor. Any fixed resistors which are outside of the feedback loop, such as base biasing resistors, will not be affected by the application of feedback.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

5.7 Some Practical Circuits.

From time to time in this text, laboratory tested circuits will be presented. A circuit which actually works can illustrate a principle as well as one which looks as if it might work but probably will not. The latter kind of circuits are what are normally presented in electronics texts.

It is not intended that you should memorize these circuits; they are given for possible future reference. Some day if you are in graduate school or a job and you need a circuit to accomplish some task, you may just find one here. Where practical, hints will be given on how changes may be made to the circuit to help you to adapt it to your particular situation.

The circuit of Figure 5.9 is a two-stage noninverting amplifier with feedback. The feedback is applied from the output, through the voltage divider consisting of R9 and the parallel combination of R10 and R4. For this circuit,

beta = R4 R10 / (R4 R10 + R9 (R4 + R10)           (5.31)

C2 is required because the tap on the voltage divider and the emitter of Q1 are at different DC voltage levels.

The idea of applying a signal to the emitter of a transistor may seem strange. There is an amplifier configuration (not discussed) which is known as a common base or grounded base amplifier. In such a configuration the signal is applied at the emitter and taken out at the collector. Such an amplifier does not invert the input signal. Applying a positive-going signal to the emitter is the same as applying a negative-going signal to the base. Therefore, if a signal applied to the base is inverted, a signal applied to the emitter is not inverted.

Figure 5.9 Laboratory Tested Circuit. Gain = 47, Frequency
Response is from 35 Hz to 600 kHz +0 -3 dB, Input Impedance
is 9 k ohms, Output Impedance is 700 ohms, VCC is 12 volts.
The gain may be altered by changing the value of R9.
The transistors are 2N3904.

For a verbal description click here.

The amplifier of Figure 5.9 has two BJT stages. The signal which is applied to the base of Q1 is inverted by that stage and applied to the base of Q2 where it is inverted again. Two inversions make a noninversion and, therefore, the base of Q1 is a noninverting input. A signal applied to the emitter of Q1 appears at its collector without being inverted. When this signal is passed through the Q2 stage it is inverted. Therefore, the emitter of Q1 is an inverting input. If negative feedback is to truly be negative, it must be applied to an inverting input.

The circuit of Figure 5.9 contains a large number of resistors and capacitors because each transistor is individually biased. The circuit of Figure 5.10 eliminates the DC blocking capacitor between Q1 and Q2 and the biasing network in the base of Q2. A DC voltage exists at the collector of Q1 and a DC voltage is required at the base of Q2. The designer's trick is to make the two voltages equal and then eliminate the capacitor and biasing resistors. The base of Q2 gets its bias from the collector of Q1.

Figure 5.10 Laboratory Tested Circuit. Gain = 85,
frequency Response is from 4 Hz to 230 kHz +0 -3 dB,
input Impedance is 53 k ohms, output Impedance
is 580 ohms, Gain may be adjusted by changing R7.

For a verbal description click here.

This circuit is especially interesting because it has two feedback paths. One is from the emitter of Q2 to the base of Q1 and the other is from the collector of Q2 (the output) to the emitter of Q1. Capacitor C2 filters out the AC signal at the emitter of Q2 and so the feedback path from the emitter of Q2 to the base of Q1 is DC only. Because Q2 gets its base bias from the collector of Q1, any change in the operating point of Q1 will be amplified and passed to Q2. The DC feedback path provides operating point stability for both stages.

If the emitter current of Q2 tries to increase, for whatever reason, the base bias on Q1 will be increased through the voltage divider consisting of R1 and R2. The increased bias on Q1 will cause its collector current to increase which pulls down its collector voltage. Since the base of Q2 is tied to the collector of Q1 the base bias on Q2 will be decreased, thus mostly canceling the increase in emitter current.

The AC gain is set by the AC feedback path which is from the output, through the voltage divider consisting of R7 and R4 to the emitter of Q1. In this case,

beta = R2 / (R2 + R7).           (5.32)

The value of R2 cannot be changed as this will upset the DC operating point of both transistors. R7 may be adjusted to set the gain to the desired value.

Figure 5.11 shows another variation on the same theme. The advantage of this circuit over Figure 5.10 is that the output voltage swing can be almost equal to VCC. In the case of Figure 5.10 the base of Q2 is at the same potential as the collector of Q1, and so VCE + VRE of Q1 is not available for output voltage swing. The circuit of Figure 5.11 overcomes this by using a PNP and an NPN transistor. The emitter of Q2 is at VCC and the output voltage can almost swing from ground to VCC.

Figure 5.11 Laboratory Tested Circuit. Gain = 24,
Frequency Response is from 3 Hz to 1 MHz +0 -3 dB,
Input Impedance is 16.5 k ohms, Output Impedance is
332 ohms, VCC is 12 volts. The gain may be altered
by changing the value of R7.

For a verbal description click here.

The voltage divider consisting of R1 and R2 provides a constant bias for the base of Q1. For DC, 1/2 of the output is fed back to the emitter of Q1 for operating point stability. R4, R5 and R6 provide the DC feedback to the emitter of Q1. R7 and C2 combine to reduce the amount of AC feedback which will raise the AC gain of the amplifier. If R7 is shorted out, the amplifier will provide its full open- loop gain for AC. If R7 and C2 are removed from the circuit, the gain will be 2 for both AC and DC.

beta = R6 R7 / ((R4 + R6 + R7)(R5 + R6) - R62)           (5.33)

If the circuit is to be used as a DC amplifier, capacitors C1 and C3 would have to be removed from the input and output. The circuit as given would introduce a DC offset to the signal. The resistor values probably could be adjusted to reduce the offset to near zero.

Here is the circuit of a vacuum tube gain block. Gain blocks usually consist of two triodes with feedback from output plate to input triode cathode to diminish distortion to a very low level and tightly control the value of the gain. Here is a circuit I developed that will give a fairly wide range of gain at very low levels of distortion.

Figure 5.11.1 Vacuum Tube Gain Block.

For a verbal description click here.

This circuit has a lot of open loop gain which is traded off for low distortion. The gain may be changed by changing the cathode resistor, Rk, in the first triode. Changing this resistor has a very small effect on the operating point of either triode. The numbers are given in the table below.

Cathode Resistor, Rk. | Gain. | Distortion. | Output Voltage.
36 k ohms. | 6.67 | 0.035%. | 10 v.
27 k ohms. | 8.47 | 0.04%. | 10 v.
22 k ohms. | 10.1 | 0.045%. | 10 v.
9.1 k ohms. | 21.7 | 0.045%. | 10 v.
5.1 k ohms. | 33.6 | 0.060%. | 10 v.

The value of beta for this circuit is given by,

beta = (Rk + 1100) / (Rf + Rk + 1100)           (5.33.1)

Where Rk and Rf are as labeled in the schematic above.

The feedback is DC coupled, not through a capacitor, from the plate of the second triode to the cathode of the first.

The 220 k ohm resistor makes up most of the load for the second triode which is where most of the distortion occurs. I don't recommend changing the value of Rf because it effects the operating point of the second triode. If this resistor is changed the cathode resistor in the second triode will have to be readjusted for minimum distortion.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

5.8 Positive Feedback, Oscillators.

It has been said that if a phase reversal slips into a negative feedback circuit, the amplifier will oscillate. There are circuits in which the feedback is deliberately made positive so as to generate an AC signal of known and constant frequency. Such circuits are known as oscillators.

If we reverse the sign of the feedback the feedback equation becomes,

A' = A / (1 - A beta)           (5.34)

If A is less than 1 / beta the gain of the amplifier is increased over its open-loop value but it will still work as an amplifier. If A = 1 / beta the gain becomes infinite and the amplifier will provide its own input signal and will produce an output without any input. Mathematically if A is greater than 1 / beta the amplifier will oscillate and the amplitude of the oscillations will continue to build up and approach infinity. In the physical world amplifiers do not work this way. The amplitude will build up until the amplifier begins to saturate which has the effect of reducing the open-loop gain. The gain will be reduced until A = 1 / beta.

Multivibrator.

The circuit of Figure 5.12 is at first glance two common emitter amplifiers, each one with its collector coupled to the other's base. Starting at one particular point and moving around the loop once, there are two 180 degree phase shifts which gives a total of 360 degrees, which is the same as a 0 degree phase shift. In actuality the transistors are acting as switches instead of amplifiers.

Figure 5.12 Laboratory Tested Circuit. Oscillation
frequency is 80 Hz, VCC may be as low as 1.5 v, Waveform
is approximately square, Amplitude = (VCC - 0.1) v P-P.

For a verbal description click here.

Let us start by assuming that Q1 is off and Q2 is on. The voltage at the collector of Q1 will be VCC and the voltage at the base will be negative because of remaining charge on C2. The voltage at the collector of Q2 will be approximately zero volts and the voltage at the base will be +0.6 volts. The charge on C1 will be equal to VCC - 0.6 v with the left-hand plate positive. C2 once had a charge of VCC - 0.6 v with the right-hand plate positive. C2 is now discharging through R3 causing the negative voltage at the base of Q1 to be headed in the direction of VCC. When the base voltage of Q1 reaches +0.6 volts, Q1 begins to conduct and its collector voltage begins to fall. This falling voltage is coupled through C1 to the base of Q2 which turns it off. When Q2 turns off, its collector voltage goes up and that change causes C2 to be charged through the base of Q1, turning it on very hard. Q1 is now on and Q2 is now off. C1 has a charge of VCC - 0.6 v with the left-hand plate positive. Because the left-hand end of C1 is clamped to ground by Q1 the base of Q2 is negative, insuring that it is off. C1 begins to discharge and the cycle keeps repeating with each transistor switching alternatively on and off.

If R2 = R3 = R and C1 = C2 = C then the frequency of oscillation is given by,

f = 1 / (1.2 R C)           (5.35)

The frequency of oscillation is relatively insensitive to the power supply voltage.

Circuits You May Find in Other Texts.

A good example of a circuit you may find in other electronics texts is the Wien bridge oscillator. This is a sine wave oscillator which, if properly designed, is capable of generating very pure sine waves. Back in the vacuum tube days this circuit used a tungsten lamp as a gain regulating element. The circuit was fairly simple and it worked quite well. Modern Wien bridge designs which employ a lamp do not work very well. A high-quality Wien bridge circuit is too complex to be presented in a text of this level. The simple circuits you may see in other texts are not laboratory tested and will likely not work. The writer refuses to waste space printing circuits which won't work.

The Phase-shift Oscillator.

Figure 5.13 Laboratory Tested Circuit. This circuit operates
from 12 volts and with the given values will oscillate at
approximately 200 Hz. Its usable frequency range is from 5
Hz to 20 kHz. For best waveform use the pot to adjust the
output amplitude to 2.25 volts RMS. The waveform is a pretty
good sine wave.

For a verbal description click here.

The phase-shift oscillator works by using the phase- shift of an RC circuit. Oscillation requires a net phase- shift around the feedback path of zero degrees. The amplifier stage in Figure 5.13 provides a phase-shift of 180 degrees. Three cascaded high-pass filters are used to provide the additional 180 degrees of phase-shift. One RC filter will provide a maximum of 90 degrees of phase-shift and you might assume that two such circuits would be enough. The phase- shift of a high-pass filter reaches 90 degrees at infinitesimally low frequencies. At such low frequencies the attenuation is approaching infinity. When three filters are used each filter is required to provide a phase-shift of only 180 degrees / 3 = 60 degrees. Because the next filter loads the previous one each section does not provide exactly 60 degrees but the average is 60 degrees per section. Under these conditions the attenuation is finite and the circuit will work.

There is only one frequency at which the total phase- shift is 180 degrees and it is given by,

f = 1 / (2 Pi sqrt(6) R C).           (5.36)

The attenuation of the circuit at this frequency is 1/29 and so the amplifier must have a gain of at least 29. The gain of the amplifier in Figure 5.13 may be set to 29 by means of the potentiometer. If the gain falls below 29 the circuit will stop oscillating. If the gain is higher than 29 the waveform will have a bit of distortion but the circuit will work reliably.

Quartz Crystal Oscillator.

Quartz is a Piezoelectric material when properly cut. The meaning of Piezoelectric is that there is an interchange between applied electric field and mechanical deformation. If the cut piece of quartz crystal is mechanically deformed, an electric field will be developed across the quartz. If an electric field is applied to a quartz plate, the plate will be mechanically deformed.

Because mechanical waves propagate through the quartz plate at a very high velocity, a thin plate of quartz will have a very high mechanical resonant frequency (roughly from 10 kHz to 100 MHz). The Piezoelectric effect allows this mechanical resonance to be transformed into an electrical resonance.

The quartz crystal behaves as if it were an LC resonant circuit. Crystals have two major advantages over LC circuits. They are 1) the quartz crystal is usually smaller than an LC circuit tuned to the same frequency and 2) the crystal has a much higher Q than an LC circuit tuned to the same frequency. The highest achievable Q values for an LC circuit are 250, although 100 is more typical. Crystal Q values range from 1,000 to 10,000. The only disadvantage of a quartz crystal is that its frequency cannot be adjusted once it leaves the factory.

When a quartz crystal is used as the frequency- determining element of an oscillator (as opposed to an LC circuit), the oscillator frequency is much more accurate and stable. The much higher Q of the crystal is what makes the oscillator frequency so much more stable.

Figure 5.14 Laboratory Tested Circuit. This is a quartz
crystal oscillator with a frequency of 2 MHz and an
output suitable for driving one TTL logic load.

For a verbal description click here.

Figure 5.14 shows the diagram of a 2 MHz quartz crystal oscillator. The 7 to 45 pf trimmer capacitor may be used to adjust the frequency over a very small range, typically 0.05% of the crystal frequency. The JFET section is the oscillator circuit. This section could be constructed alone and the output taken from the source of the FET. The BJT portion operates as a switch and it is turned on and off by the AC signal from the oscillator portion. The entire circuit should work perfectly using a 1 MHz crystal. The oscillator section has been tested using a 10 MHz crystal but the BJT switch has not.

If you apply what you know about switching circuits you will find that the BJT is neither fully on or fully off. That is desirable in this application because the AC signal from the oscillator will drive the switch alternately on and off. If the switch were set fully off, the AC signal from the oscillator might not have enough amplitude to turn it on.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

5.9 Problems.

  1. An amplifier has an open-loop gain of 300 and a beta of 0.01. What is its closed-loop gain?

  2. A noninverting amplifier has an open-loop gain of 8. R1 = R2 = 12 k ohms. What is the closed-loop gain of this amplifier?

  3. An inverting amplifier has an open-loop gain of 8. R1 = R2 = 12 k ohms. What is the closed-loop gain of this amplifier?

  4. A noninverting amplifier has an open-loop gain of 1,000. R1 = 10 k ohms and R2 = 40 k ohms. What is the closed-loop gain of this amplifier?

  5. An inverting amplifier has an open-loop gain of 1,000. R1 = 10 k ohms and R2 = 40 k ohms. What is the closed-loop gain of this amplifier?

  6. An amplifier which has a Bode plot similar to that of Figure 5.4 has a DC gain of 75,000 and a gain-bandwidth product of 1.5 MHz. What is its gain at frequencies of (a) 100 kHz, (b) 20 kHz, (c) 1 kHz, (d) 20 Hz, and (e) 5 Hz?

  7. If negative feedback is applied to the amplifier of problem 6 and the value of beta is 0.013333, what is the closed-loop gain at frequencies of (a) 100 kHz, (b) 20 kHz, (c) 1 kHz, (d) 20 Hz, and (e) 5 Hz?

  8. An amplifier which has a Bode plot similar to that of Figure 5.5 has a lower unity gain frequency of 0.5 Hz, an upper unity gain frequency of 10 MHz and a maximum gain of 300. What is its gain at frequencies of (a) 5 Hz, (b) 20 Hz, (c) 200 Hz, (d) 1 kHz, (e) 20 kHz (f) 50 kHz, and (g) 2 MHz?

  9. If negative feedback is applied to the amplifier of problem 8 and the value of beta is 0.025, what is the closed-loop gain at frequencies of (a) 5 Hz, (b) 20 Hz, (c) 200 Hz, (d) 1 kHz, (e) 20 kHz, (f) 50 kHz and (g) 2 MHz?

  10. An amplifier is required to have a gain stability of 0.5%. The open-loop amplifier has a gain stability of 20%. If the closed-loop gain is to be 200, what must be the minimum open-loop gain of the amplifier?

  11. An amplifier has a closed-loop gain of 1,000 and an open-loop gain of 100,000 plus or minus 50%. What is the closed- loop gain error?

  12. An amplifier has an open-loop gain of 300,000 plus or minus 40%. What is the maximum closed-loop gain available if the error in the closed-loop gain is not to exceed plus or minus 1%?

  13. What is the calculated value of beta of Figure 5.9?

  14. In Figure 5.9 if the open-loop gain is 280, what is the closed-loop gain?

  15. In Figure 5.12 if resistor values are as given, what must the values of C1 and C2 be to give an oscillation frequency of 60 Hz?

  16. In Figure 5.13 if all capacitors marked C are 0.001 uf, what must be the value of the resistors R to give an oscillation frequency of 440 Hz?

  17. In Figure 5.14 if there were no AC signal from the oscillator, what would be the value of VCE of the BJT? Assume beta = 100.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

5.10 Answers to Problems.

  1. 75.

  2. 1.6.

  3. -0.8.

  4. 4.975.

  5. -3.98.

  6. (a) 15.0, (b) 75.0, (c) 1500, (d) 53,033, (e) 72,761.

  7. (a) 12.50, (b) 37.50, (c) 71.43, (d) 74.89, (e) 74.92.
    Note. These calculations are correct not just close.
    If you didn't hit the numbers on the nose,
    you must have done something wrong.

  8. fc1 = 150 Hz, fc2 = 33,333 Hz, fcc = 2,236 Hz.
    (a) 9.994, (b) 39.65, (c) 240.0, (d) 296.7, (e) 257.2, (f) 166.4, (g) 4.999.

  9. (a) 7.996, (b) 19.91, (c) 34.28, (d) 35.25, (e) 34.62, (f) 32.25, (g) 4.444.

  10. 8000.

  11. 0.5%.

  12. 7,500.

  13. 0.01799.

  14. 46.38.

  15. 0.13 microfarad.

  16. 148 k ohms.

  17. 1.48 volts.


Chapter 6   The Operational Amplifier.

6.1  Op Amp Behavior.
6.2  Equations of the Op Amp.
6.3  The Unity-Gain Buffer Amplifier.
6.4  The Noninverting Amplifier.
6.5  The Inverting Amplifier.
6.6  The Summing Amplifier.
6.7  The Integrating Amplifier.
6.8  Single Power Supply Operation.
6.9  Understanding Op Amp Specifications.
6.10 Problems.
6.11 Answers to Problems.

Chapter 6

The Operational Amplifier.

The operational amplifier began life as a component in an analog computer. For those who have never heard of an analog computer, it is (was) a computer in which the magnitude and sign of voltages were used to represent physical quantities. For example, one voltage might represent the velocity of a falling object, another voltage the acceleration and another voltage might represent the frictional drag of the air on the object. If you know about analog computers you think of them as being vacuum tube monstrosities but that is because of the age in which they were developed and used. If they were still in use today they would be reduced in size to desktop or even smaller just as their more successful digital brothers have.

The operational amplifier (op amp) is so called because in its original application it was used to perform mathematical operations. The two operations it was best at were addition and integration. Op amps are still used for these purposes but they have found many other applications in modern electronics.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

6.1 Op Amp Behavior.

The op amp has been reduced from its original vacuum tube size of a cubic foot or larger to an 8 pin integrated circuit. There are several hundred different type numbers, each having its own particular and sometimes subtle difference from others. The internal circuitry of these ICs is not terribly important to us. IC manufacturers do not often give the internal circuit diagrams of their ICs. Op amps are among the few exceptions to this rule.

The circuits are quite complex, the 741 op amp has 20 transistors in it. The curious student is referred to instructional books and data books devoted exclusively to op amps. There are many such books available.

Op amps are usually treated as 5 terminal devices. In the following pages they will be treated as just another component the same as a transistor is a component.

Electrical Connections.

The op amp has 5 basic electrical connections. They are inverting input, noninverting input, output, positive power supply and negative power supply. While there is no ground per se, ground is established by the power supply. Employing the theorem which states that "one picture is worth a thousand words" refer to Figure 6.1. The power supplies are replaced by batteries to make it clear how the power supplies are connected. Sometimes an op amp may be operated from a single power supply but most of the time they are operated as shown in Figure 6.1.

Except for section 6.8 you will not again see the power supply connections to an op amp. The power supply connections are always there; they are usually not shown on schematic diagrams. The op amp will not work without power supply connections. If you see a diagram which does not show power supply connections and you assume that it is not necessary to connect a power supply, you will be in error. The op amp will not work without power supply connections. They are always assumed if not shown.

Figure 6.1 Operational Amplifier Showing Power Supply Connections.

For a verbal description click here.

The two inputs must be at a voltage which is between the negative and positive power supplies. To force the voltage of either or both inputs higher than V+ (the positive power supply) or lower than V- (the negative power supply) may destroy the op amp. (There are some special purpose op amps which have been designed to permit the inputs to be at potentials outside of the power supplies. If you have a need to set the inputs outside of the power supplies, you should consult a data book to find such an op amp.)

Many op amps have inputs for adjusting the offset voltage to zero. When the voltage at the two inputs is exactly equal the output should be zero but it is not. The amount by which the input voltage must be different to bring the output to zero is the offset voltage.

The Differential Inputs.

If the inverting input is tied to ground and a variable DC voltage is applied to the noninverting input the output will go with the sign of the noninverting input. If the voltage at the noninverting input is positive, the output is positive and if the voltage at the noninverting input is negative, the output is negative.

Now we will disconnect the inverting input from ground and connect the noninverting input to ground. The variable DC voltage will be applied to the inverting input. When the voltage at the inverting input is positive, the output voltage is negative. When the voltage at the inverting input is negative, the output voltage is positive. Thus you can see why the inputs have been named as they have.

Theoretically, if both inputs are connected together, the output voltage is zero. The offset adjustments can be used to adjust the output to zero, but there is a little more to it than that. If the two inputs (tied together) are made positive or negative, the output voltage will not change. But that's only in theory.

In practical op amps the output voltage will change a little when the two inputs have the same voltage applied to them. A voltage which is applied to both inputs simultaneously is called a common mode voltage. A voltage which is applied between the two inputs is called the normal mode voltage or differential voltage.

The normal mode gain is defined as the ratio of output voltage to the differential input voltage.

ANM = VO / Vd  (6.1)

Where VO is the output voltage and Vd is the voltage difference between the two inputs. The common mode gain is defined as the ratio of the output voltage to the common mode input voltage.

ACM = VO / VCM  (6.2)

Where VCM is the voltage applied to both inputs together. The common mode rejection ratio is defined as the ratio of the normal mode gain to the common mode gain.

CMRR = ANM / ACM  (6.3)

The common mode rejection ratio (CMRR) is usually expressed in dB. The typical value for the 741 type op amp is given as 90 dB.

Example 6.1.

An op amp has had its offset adjusted to zero. Its inverting input is at +3.001 v and its noninverting input is at +3.000 v. Will its output be positive or negative?

Solution:

The noninverting input is negative with respect to the inverting input; therefore, the output will be negative.

Example 6.2.

An op amp has had its offset adjusted to zero. Its inverting input is at -5.001 v and its noninverting input is at -5.000 v. Will its output be positive or negative?

Solution:

The noninverting input is positive with respect to the inverting input; therefore, the output will be positive.

Example 6.3.

When the normal mode voltage is changed by 25 uv the output changes by 5 volts. When the common mode voltage is changed by 1 volt the output voltage changes by 6.325 volts. (a) What is the CMRR? (b) Express the CMRR in dB.

Solution:

The normal mode gain is 5 v / 25 uv = 200,000. The common mode gain is 6.325 v / 1 v = 6.325. (a) The CMRR is 200,000 / 6.325 = 31620. (b) The CMRR expressed in dB is 20 LOG (31620) = 90 dB.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

6.2 Equations of the Op Amp.

The equation of the op amp is based on an approximation, albeit a very good one. Let us restate the feedback equation.

A' = A / (1 + A beta)  (6.4)

Now we will find the limit as A approaches infinity. If we divide both numerator and denominator by A we have

A' = 1 / (1/A + beta)  (6.5)

As A approaches infinity, the 1/A term goes to zero leaving

Limit as A approaches infinity of A' = 1 / beta  (6.6)

Thus, the gain of an op amp with feedback applied is given by

A' = 1 / beta  (6.7)

While equation 6.7 is a very good approximation in most cases it should not be taken as gospel.

Example 6.4.

An op amp has a DC gain of 100,000 and a unity gain bandwidth of 1 MHz. If feedback is applied to the op amp with a beta value of 0.05, what is the exact closed-loop gain at (a) DC, (b) 1 kHz, (c) 20 kHz, and (d) 100 kHz?

Solution:

From equation 5.15.5 the corner frequency is,

fc2 = fhu / AMax

Where fc2 is the corner frequency, fhu is the upper unity gain frequency, and AMax is the DC gain.

fc2 = 1 MHz / 100,000 = 10 Hz.

(a) Using equation 6.4,

A' = A / (1 + A beta) = 100,000 / (1 + 100,000 x 0.05) = 19.9960

(b) Using equation 5.4.1

A' = ADC / sqrt([f / fc2]2 + [1 + ADC beta]2)

A' = 100,000 / sqrt([1,000 / 10]2 + [1 + 100,000 x 0.05]2) = 19.9920

(c) and (d) also use equation 5.4.1.

(c) A' = 18.5663

(d) A' = 8.94391

Example 6.5.

For the conditions of example 6.4 calculate the percent error of gain using 1/beta as the standard of comparisons at (a) DC, (b) 1 kHz, (c) 20 kHz, and (d) 100 kHz.

Solution:

Since 1/beta = 20.00000 the errors are as follows:

(a) -0.020%, (b) -0.040%, (c) -7.1685%, (d) -55.2805%.

As can be seen from these examples the 1/beta approximation is very good at DC and low frequencies but somewhere between 1 and 20 kHz the error crosses over the 2% line. If it is desired to know the exact gain at high audio frequencies equation 5.4.1 must be used rather than 6.4 or 1/beta.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

6.3 The Unity-gain Buffer Amplifier.

The definition of a buffer amplifier is an amplifier which will isolate a load from a source. Such isolation usually requires that the buffer amplifier have a very high input impedance. The output impedance may either be very low or matched to the load impedance. A buffer often has unity voltage gain although this is not a requirement under the definition.

A unity gain buffer has a voltage gain of unity as the name implies. The value of beta is set at unity by feeding back all of the output voltage to the inverting input. The circuit of Figure 6.2 is of a unity gain buffer.

Figure 6.2 Unity Voltage Gain Buffer Amplifier.

For a verbal description click here.

An op amp works by adjusting its output so that the two inputs are at the same potential. (The error due to finite op amp gain is quite small.) Because the output and the inverting input are connected together the output voltage will be the same as the inverting input voltage. Suppose that the input voltage is 0 volts and that the voltage is suddenly changed to +2 volts. Since the signal is applied to the noninverting input, for an instant of time the noninverting input will be positive with respect to the inverting input. This will cause the output to go positive. When the inverting input voltage becomes +2 volts the output will stop changing. Should the output voltage overshoot +2 volts and become higher, the output would be urged in the negative direction thus correcting the overshoot. A properly compensated op amp will not overshoot in the first place.

The voltage at the output cannot become 2.000000000000 volts. If it did the differential input voltage would be zero and the output would be zero. Since the output voltage is finite, there must be a finite difference in voltage between the noninverting input and the inverting input. That small but finite difference is caused by the finite open-loop gain of the op amp. Because the open-loop gain of the op amp is very large, the error is very small.

The percent error is,

% error = 100% x (Measured - Reference) / Reference  (6.8)

If we substitute A / (1 + A beta) for "Measured" and 1/beta for "Reference" in equation 6.8 and get some more algebraic exercise we have

% error = -100% / (1 + A beta)  (6.9)

In the case of the unity-gain buffer the value of beta is 1.0000000000; therefore, the % error becomes 100% / (A + 1).

Example 6.6.

Calculate the gain error of a unity-gain buffer if the op amp has an open-loop gain of (a) 200,000; (b) 20,000; (c) 1,000; and (d) 20?

Solution:

The % error is (a) -100% / (1 + 200,000) = -0.0004999975%, (b) -0.00499975%, (c) -0.0999%, (d) -4.7619%.
The closed-loop input and output impedances of the unity-gain buffer are,

ZIN' = ZIN (1 + A beta)  (6.10)

And

ZO' = ZO / (1 + A beta)  (6.11)

The open-loop input and output impedances must be obtained from an IC data-book. Because beta is unity and the open-loop gain is very large, the output impedance is very low and the input impedance is very high.

Often it is desired to calculate the input and/or output impedance at higher frequencies where the gain is less than the DC gain. Equations 6.10 and 6.11 may be used but the value of A must be the gain at the frequency being considered, not the gain at DC. This gain can be obtained from equation 5.15.1 which is repeated below.

Equation 6.11.1. eh = eh sub DC over square root of, quantity f over f sub c2 quantity squared plus 1 close square root.

Where A is the gain at any frequency, ADC is the DC gain of the amplifier, f is the frequency at which the gain is desired, and fc2 is calculated from equation 5.15.5 which is repeated below.

fc2 = fhu / ADC  (6.11.2)

Where fhu is the unity gain bandwidth or gain bandwidth product of the amplifier.

Example 6.7.

Determine the minimum input impedance and the maximum output impedance of a unity-gain buffer employing a type 741 op amp. The data book gives the minimum input resistance of the 741 as 0.3 M ohms, a typical output resistance of 75 ohms and a minimum gain of 20,000. The typical gain is given as 200,000.

Solution:

The minimum gain is given as 20,000. The typical gain is given as 200,000 but as the question asks for the minimum input impedance and maximum output impedance, the minimum gain should be used.

ZIN = 0.3 M ohms x 20,000 = 6 G ohms,

The output impedance is, ZO = 75 / 20,000 = 3.75 milli ohms.

The resistance of the printed circuitboard traces will be greater than the output resistance of the amplifier. Note also that this is a worst case. If the typical gain of 200,000 had been used, the input impedance would be 60 G ohms and the output impedance 0.375 m ohms.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

6.4 The Noninverting Amplifier.

Figure 6.3 Noninverting Amplifier.

For a verbal description click here.

The circuit of a noninverting amplifier is given in Figure 6.3. As we saw in the previous chapter the value of beta for this amplifier is given by,

beta = R1 / (R1 + R2)  (6.12)

The approximation for the closed-loop gain is given by equation 6.7. If the gain error is large, equation 6.4 should be used to calculate the exact gain. The gain error is given by equation 6.9. The input and output impedances are given by equations 6.10 and 6.11.

This circuit works because the op amp will always adjust its output until both inputs have the same potential. If a given potential is placed between the input terminals in Figure 6.3 the noninverting input of the op amp will be placed at that potential. The op amp will adjust its output until the inverting input is at the same potential. Because of the voltage divider consisting of R1 and R2 the output voltage must be greater than the input voltage by the amount of the divider ratio. The conditions of equal potential at both inputs require that they have the same sign. Because resistors can't change the sign of a voltage, the output voltage must also have the same sign as the input voltage.

Example 6.8.

A noninverting amplifier has the following values: R1 = 4.7 k ohms and R2 = 2.7 k ohms. The open-loop gain is 200,000. What is the closed-loop gain?

Solution:

When the open-loop gain is very high the closed-loop gain is 1/beta. Therefore, the closed-loop gain is given by A' = (R1 + R2) / R1 = (4.7 k ohms + 2.7 k ohms) / 4.7 k ohms = 1.57.

Example 6.9.

A noninverting amplifier is to have a gain of 20 dB and R2 is to be a 10 k ohm resistor. What is the necessary value of R1?

Solution:

The first step is to convert dB into gain.

A' = 10dB/20 = 1020/20 = 101 = 10.

Since A' = 1/beta to obtain a gain of 10, beta must equal 0.1. Solving equation 6.12 for R1 gives,

R1 = beta R2 / (1 - beta)

R1 = 0.1 x 10 k ohms / (1 - 0.1) = 1.11 k ohms.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

6.5 The Inverting Amplifier.

Figure 6.4 Inverting Amplifier.

For a verbal description click here.

The circuit of an inverting amplifier is given in Figure 6.4. As we saw in the previous chapter the value of beta for this amplifier is given by,

beta = R1 / R2  (6.13)

The approximation for the closed-loop gain is given by equation 6.7. If the gain error is large, equation 6.4 should be used to calculate the exact gain. The gain error is given by equation 6.9. The input impedance is given by,

RIN = R1  (6.14)

The output impedance is given by equation 6.11.

This circuit also works because the op amp will always adjust its output until both inputs have the same potential. If a voltage of a given sign and magnitude is placed between the input terminals in Figure 6.4 the inverting input of the op amp will be placed at a potential which is determined by R1 and R2. The op amp will adjust its output until the inverting input is at the same potential as the noninverting input. Because the noninverting input is grounded, the inverting input will always be adjusted to zero potential. Figure 6.5 shows an equivalent circuit to the inverting amplifier.

Figure 6.5 Equivalent Circuit of an Inverting Amplifier.

For a verbal description click here.

Imagine that you are watching the voltmeter and adjusting the voltage of the power supply. If the polarities are as shown, you will be able to find a voltage at which the voltmeter reads zero. At this point the voltmeter current will be zero and the current in R1 equals the current in R2. If the battery is VIN and the power supply is VO then

VIN / R1 = VO / R2.  (6.15)

Therefore, we can write,

VO / VIN = R2 / R1.  (6.16)

In order to bring the voltage across the voltmeter to zero, VIN and VO must have opposite signs. The op amp does exactly the same thing. The voltmeter is replaced by the input and the power supply is replaced by the output of the op amp. The op amp will adjust its output until the voltage between the two inputs is zero. When this has been accomplished, equations 6.15 and 6.16 will be satisfied.

Example 6.10.

An inverting amplifier has the following values: R1 = 4.7 k ohms and R2 = 2.7 k ohms. The open-loop gain is 200,000. What is the closed-loop gain?

Solution:

When the open-loop gain is very high the closed-loop gain is 1/beta. Therefore, the closed-loop gain is given by,

A' = R2 / R1 = 2.7 k ohms / 4.7 k ohms = -0.574.

That's right. It's possible for an inverting amplifier to have a gain of less than unity.

Example 6.11.

An inverting amplifier is to have a gain of 30 dB and R2 is to be a 10 k ohm resistor. What is the necessary value of R1?

Solution:

The first step is to convert dB into gain.

A' = 10dB/20 = 1030/20 = 103/2 = 31.62.

Since A' = 1/beta, to obtain a gain of -31.62, beta must equal 0.03163. Solving equation 6.13 for R1 gives,

R1 = beta R2 = 0.03163 x 10 k ohms = 316 ohms.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

6.6 The Summing Amplifier.

Figure 6.6 Summing Amplifier with Three Inputs.

For a verbal description click here.

The circuit of a summing amplifier is given in Figure 6.6. Remember that the op amp will adjust its output so that the voltage at the inverting input will be zero. Thus the current flowing in R2 must be the sum of the individual currents in R1A, R1B and R1C. The output voltage is given by,

VO = R2 [VINA / R1A + VINB / R1B + VINC / R1C]  (6.17)

A very good way to solve problems involving circuits of this kind is to treat them as circuit analysis problems.

Example 6.12.

In a circuit similar to that of Figure 6.6 the values are as follows: R1A = 10 k ohms, R1B = 7.5 k ohms, R1C = 5 k ohms, R2 = 10 k ohms, VINA = +15 v, VINB = -9 v, and VINC = -8 v. What is the output voltage of the amplifier?

Solution:

We will sum the currents at the node where the 4 resistors are joined. This node is at zero potential.

IA + IB + IC = I2.

Let us define current into the node as positive.

IA = VINA / R1A = 15 v / 10 k ohms = 1.5 mA.

IB = -9 v / 7.5 k ohms = -1.2 mA.

IC = -8 v / 5 k ohms = -1.6 mA.

I2 = 1.5 mA -1.2 mA -1.6 mA = -1.3 mA.

The net current flows out of the node; therefore, I2 must flow into the node to prevent a charge imbalance in the conductors. The current in R2 is flowing to the left, which means that the right end is positive with respect to the summing node. The voltage across R2 is I2 R2 = 1.3 mA 10 k ohms = +13 volts. Equation 6.17 will give the same answer.

The point where all of the resistors connect, (the inverting input), is often called the summing node or the summing junction. As has been said many times, this point is at zero potential. Of course it is not truly at zero potential because the amplifier does not have infinite gain. In most cases the gain of the amplifier is so high that the summing node is virtually at ground potential. The summing node is said to be a virtual ground point. It behaves as if it were actually shorted to ground.

Example 6.12 illustrates that a summing amplifier gives the negative of the true sum of the input voltages. This was one of the original uses of an operational amplifier.

Although we are not sound engineers, most of us own stereo systems and examples from that field are easy to relate to and understand. Suppose it is desired to add together the left and right channels of a stereo signal to form a monaural signal for a monaural amplifier. At the same time it is necessary to maintain the individual integrity of the left and right signals to feed a stereo amplifier. A circuit similar to Figure 6.6 but with two equal value resistors in the inputs will do the job nicely. The output will be a true L + R sum which is required for a monaural image. Because the summing node is a virtual ground, the individual L and R signals will not get mixed up in the lines before the summing amplifier. Audio engineers call this circuit a mixer but radio engineers mean something completely different when they say "mixer". Our best course is to avoid the term all together.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

6.7 The Integrating Amplifier.

Figure 6.7 Integrating Amplifier.

For a verbal description click here.

The other original use of an operational amplifier was as an integrator. An integrator is an electronic circuit which takes the time integral of any function which has been converted into a time varying voltage and applied to the input of the circuit. As you can see in Figure 6.7 the feedback resistor has been replaced by a capacitor. In a real circuit there is a switch in parallel with the capacitor to be certain that it starts out with zero initial charge.

The op amp will adjust its output to keep its two inputs at the same potential. Since the noninverting input is grounded, the inverting input will also be at ground potential. The current in R is

i = vin / R.  (6.18)

The voltage across a capacitor is given by

V sub C = one over C integral of i dt.

The current in the resistor and the current in the capacitor are flowing in the same direction (left to right or right to left) and the connect point (summing node) is at zero potential. The voltage at the right end of the capacitor must have the opposite sign as the input voltage. If we substitute equation 6.18 into equation 6.19 and insert the negative sign required by the op amp we have

V sub O = one over RC integral of V sub in dt..

Now you will learn what an integral really is. Maybe you think you already know. Let's see if you do.

Example 6.13.

In Figure 6.7 the capacitor starts out with zero initial charge. The input voltage is as shown in Figure 6.8. Draw the output voltage versus time, giving scale values. R = 2 M ohms and C = 1 uf.

Solution:

The integrator's output is shown in Figure 6.9. For the first 1/2 second there is no input and the output does not change. From 0.5 to 1.5 seconds the input voltage is 1.0 volts. That is an area of 1.0. If the gain of the integrator were unity, the output would be -1 after 1.5 seconds but this one has a 2 M ohm resistor which makes the 1/RC term in front of the integral to be 1/2. The input is 1 volt for 1 second or 1 volt second. The output will change by -0.5 volts/second for 1 second to give a value of -0.5 volt. From 1.5 seconds to 2.0 seconds the input is zero and the output will not change. Notice that the output is not zero when the input is zero. When the input is zero there is no additional area being added to the integral and so the output simply stays where it is. The input is -0.5 volts from 2 to 3.5 seconds which is an enclosed area of 0.75. Because of the gain of the integrator the output will change by +0.375 volts during the 1.5 seconds when the input is -0.5 volts. The output voltage will change at a rate of 0.25 volts/second for 1.5 seconds. At the end of 3.5 seconds the output will be -0.125 volts. The output will remain at this level from 3.5 to 4.0 seconds when the input is zero. When the input goes to -1.5 volts the output will change at a rate of 0.75 volts/second for a time of 0.5 seconds. The enclosed area is 0.75 and so the output will change by an amount of 0.375 volts. The output will end up at a voltage of +0.25 volts. The output will remain at this level until there is additional input or the capacitor is discharged. There is no requirement that the output come back to zero.

Figure 6.8 Integrator Input Voltage Versus Time.

For a verbal description click here.

Figure 6.9 Output Voltage of an Integrator.

For a verbal description click here.

Integrating amplifiers were used in analog computers to solve differential equations. They still can be used for that but digital computers will do it with more accuracy.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

6.8 Single Power Supply Operation.

The major advantage of operating op amps from two power supplies is that the input to and output from the op amp can be positive or negative. Because the input voltage can be zero, slowly changing DC voltages may be amplified, added or integrated.

In some applications it may not be necessary to have a bipolar output or the signals to be processed may be AC only. In such a case it is best to power an op amp from a single power supply. One power supply is less costly, smaller, lighter and generates less heat than two power supplies.

Figure 6.10 Single Power Supply Noninverting Amplifier.

For a verbal description click here.

Figure 6.10 is the circuit of a noninverting amplifier with a gain of 10 which operates from a single power supply. The parts which distinguish this circuit from a dual power supply amplifier are the two 180 k ohm resistors in the noninverting input circuit and the capacitors in the input, output and feedback portions of the circuit. The purpose of the 180 k ohm resistors is to bias the noninverting input at 1/2 of the power supply voltage. The values given are typical for an op amp with BJT inputs. The only DC path to the inverting input is through R2 from the output of the op amp. For best temperature stability the parallel combination of the biasing resistors should equal R2. This makes the DC Thevenin resistance in both inputs the same. If an FET input op amp were used the resistors could be as high as 10 M ohms each. The only requirement is that they be equal. The capacitor in the input prevents the circuit which is connected to the input from disturbing the bias on the noninverting input. Because the op amp always makes its two inputs have the same potential, the inverting input will also be at 1/2 the power supply and so the capacitor which is in series with the 10 k ohm resistor in the feedback network prevents this voltage from being disturbed. This capacitor has the additional effect of reducing the gain to unity for DC.

Figure 6.11 Single Power Supply Inverting Amplifier.

For a verbal description click here.

Figure 6.11 shows an inverting amplifier which will operate from a single power supply. This amplifier has a gain of -10. Once again the noninverting input is biased by a pair of equal value resistors to set its voltage at 1/2 of the power supply. Once again the parallel combination of the two biasing resistors should equil R2. The capacitor at the input is necessary to prevent upsetting the voltage at the inverting input.

There are some special purpose op amps which are designed for single supply operation. Their inputs may be placed at or even a little below ground even though the op amp is operating on a single positive power supply. However, the output of such an op amp can only have potentials of ground + 1.2 volts to VCC -1.2 volts. For best operation an offset should be added to the input to place the output at 1/2 of VCC.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

6.9 Understanding Op Amp Specifications.

To the uninitiated an op amp specification sheet can be a bit bewildering. The table of specifications has columns for minimum, typical and maximum values. Few entries in the table have values under all three columns. Also there are numerous footnotes giving the conditions under which the parameter was measured. Such things as power supply voltage, load resistance, source resistance and ambient temperature can all affect the value of any given parameter.

Input Offset Voltage is the voltage which must be applied to the input terminals to bring the output exactly to zero. The typical and maximum values are given here. The untrimmed value is given, which means that no trimmer pot was connected to the pins provided for that purpose. The units are usually mV (the units are always stated in the table).

Input Bias Current is the current which flows into each input of an op amp. If the input stage is a pair of BJTs, the base current of the transistors is the bias current. If the input is a pair of FETs, the bias current is the leakage current of the P-N junction which makes up the gates of the FETs. The units may be uA, nA or pA depending on the op amp. This specification is only significant when the resistance in series with the inputs is large. If the source resistance is such that the voltage drop due to the input offset current is significant compared to the input offset voltage, the resistance in the two inputs must be equal.

Input Offset Current is the difference between the bias currents in the two inputs. If the input bias current is producing a significant drop across the source resistances, the offset current will be converted to an offset voltage by the IR drop across the source resistances.

Input Resistance is the resistance the op amp inputs present to an input signal without any feedback applied to the amp.

Input Capacitance is the effective capacitance from each input to ground including Miller capacitance.

Offset Voltage Adjustment Range is only given on op amps which have pins for an offset voltage trimmer. It indicates how large the offset can be and still be adjusted to zero.

Input Voltage Range tells how far the inputs may be moved around in potential. This is usually the voltage which the amplifier will tolerate without damage. The input voltage range for proper operation of the amplifier may be given separately as a common mode voltage rating. It is usually 2 or 3 volts less than the maximum input voltage.

Common Mode Rejection Ratio (CMRR) is the ratio of normal mode gain to common mode gain. CMRR is most often given in dB. It is defined in detail on pages 244 and 245 of this text.

Supply Voltage Rejection Ratio states how much the power supply voltage will affect the output voltage of the op amp. It is the change in power supply voltage in uV divided by the change in output voltage in volts. This parameter is measured under open-loop conditions.

Large Signal Voltage Gain is the open-loop gain.

Output Voltage Swing states over what range the output voltage can vary.

Output Resistance is the Thevenin resistance of the amplifier.

Output Short Circuit Current states how much current will flow if the output of the amplifier is shorted to ground. Most op amps have built-in current limiting to protect them from damage if a short occurs.

Supply Current is how much current the op amp will draw from the power supply.

Power Consumption is the supply current multiplied by the total power supply voltage.

Transient Response (Unity Gain) states the risetime and overshoot for a unity-gain amplifier with a step input voltage.

Slew Rate is very important because it does more to limit the upper frequency limit than does the unity gain bandwidth. It states how fast the output voltage can change and is usually given in V/us.

The Gain Bandwidth Product or Unity Gain Frequency may be given in a graph rather than in the data table. It is the frequency at which the gain is unity.

Op amp data usually contains a large number of graphs. The majority of these graphs show how various parameters are effected by temperature. If you are going to use an op amp under conditions of extreme temperature, you should not ignore these graphs. If you are looking for a particular specification and it is not in the table, it may be in the graphs.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

6.10 Problems.

  1. A differential amplifier has a gain of 2.00, its noninverting input is at a potential of -1 volt and its inverting input is at a potential of +2 volts. What is its output voltage?

  2. A differential amplifier has a gain of 2.00, its noninverting input is at a potential of -5 volt and its inverting input is at a potential of -7.5 volts. What is its output voltage?

  3. A differential amplifier has a gain of 2.00, its noninverting input is at a potential of +7.5 volt and its inverting input is at a potential of +5 volts. What is its output voltage?

  4. When the normal mode voltage is changed by 30 uv the output changes by 4.5 volts. When the common mode voltage is changed by 1 volt the output voltage changes by 4.7434 volts. (a) What is the CMRR? (b) Express the CMRR in dB.

  5. An op amp with a DC gain of 200,000 and gain-bandwidth product of 1 MHz is being used in a unity-gain buffer. What will be the gain error at a frequency of 200 kHz?

  6. An op amp with a gain-bandwidth product of 1 MHz is being used in a unity-gain buffer. The input impedance is 500 k ohms. Over what range of frequencies will the buffer have an input resistance in excess of 10 M ohms? The DC gain is 200,000.

  7. A noninverting amplifier similar to Figure 6.3 has the following values: R1 = 1 k ohm and R2 = 13 k ohms. What is the DC gain of this amplifier?

  8. A noninverting amplifier is to have a gain of 12.00 and R1 is to be a 2.0 k ohm resistor. What is the value of R2 which will give the desired gain?

  9. A noninverting amplifier is to have a gain of 5 dB. The series combination of R1 and R2 must be greater than 2 k ohms but the parallel combination must not exceed 10 k ohms. Select standard 5% resistor values to come as close as you can to a gain of 5 dB and remain within the requirements stated. State the resistors you selected and the actual gain in dB which these values will produce.

  10. An inverting amplifier similar to Figure 6.4 has the following values: R1 = 1 k ohm and R2 = 13 k ohms. What is the DC gain of this amplifier?

  11. An inverting amplifier is to have a gain of 12.00 and R1 is to be a 10 k ohm resistor. What is the value of R2 which will give the desired gain?

  12. An inverting amplifier is to have a gain of 15 dB. The value of R2 must be greater than 2 k ohms but the parallel combination of R1 and R2 must not exceed 10 k ohms. Select standard 5% resistor values to come as close as you can to a gain of 15 dB and remain within the requirements stated. State the resistors you selected and the actual gain in dB which these values will produce.

  13. In a summing amplifier R1A = R1B = R1C = R2. Input A is 2 volts, input B is 3 volts and input C is -1 volt. What is the output voltage of the summing amplifier?

  14. In an integrator the resistor is a 1 M ohm and the capacitor is a 0.5 uf. The input to the integrator is as shown in Figure 6.12. Draw the graph of the output voltage versus time.

    Figure 6.12 Input Voltage for Problem 14.

    For a verbal description click here.

  15. An op amp has an input offset voltage of 1.5 mV, an input bias current of 0.2 uA and an input offset current of 0.03 uA, all typical values. Assuming equal resistances in series with each input, what is the maximum resistance for the voltage due to the input offset current to equal the input offset voltage?

  16. The input bias current is probably the most temperature sensitive of all op amp parameters. In an inverting amplifier the value of R1 is 47 k ohms and R2 is 120 k ohms. What resistor should be placed in series with the noninverting input to minimize the effects of temperature on the operating point?

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

6.11 Answers to Problems.

  1. -6 Volts.

  2. +5 Volts.

  3. +5 Volts.

  4. (a) 31,623, (b) 90 dB.

  5. -0.497 %

  6. 526 kHz.

  7. 14.00

  8. 22 k ohms.

  9. R1 = 3.9 k ohms, R2 = 3.0 k ohms, Gain = 4.956 dB.

  10. 13.

  11. 12 k ohms.

  12. R1 = 1.1 k ohms, R2 = 6.2 k ohms, Gain = 15.020 dB.

  13. -4.0 volts.

  14. Hint, the gain of the integrator is 2.

    Figure 6.13 Output Voltage for Problem 14.

    For a verbal description click here.

  15. 50 k ohms.

  16. 35.8 k ohm, nearest standard 5% value is 36 k ohm.


Chapter 7   Operational Amplifier Circuits.

7.1  Instrumentation Amplifier.
7.2  AC Voltmeter Circuit.
7.3  Open-loop Linearization.
7.4  Absolute Value Amplifier.
7.5  Log Converter.
7.6  Active Filters.
7.7  Problems.
7.8  Answers to Problems.

Chapter 7

Operational Amplifier Circuits.

The best thing about op amp circuits is that it is hard to keep them from working. Although none of the circuits in Chapter 6 was indicated as having been laboratory tested, you can build any of them and they will work! Because of this increased reliability over discrete transistors, anyone who works with electronic circuits prefers to use op amps whenever possible. Unfortunately today's low cost op amps will not perform much above the audio frequency band. If the frequency range permits, op amps are to be preferred over discrete transistors.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

7.1 Instrumentation Amplifier.

In laboratory instrumentation it is often necessary to place a sensor at some distance from the instrument to which it is connected. In such a case the long wires which connect the sensor to the instrument will act as antennas and pick up noise, (noise is any electrical signal which is in a place where it is not wanted). Using shielded cables will help but there may still be some noise pickup, especially if the voltage of the sensor is very small, requiring that the input amplifier of the instrument have a very high gain.

Figure 7.1 Signal and Noise Pickup on Long Lines.

For a verbal description click here.

The noise which is picked up on the wiring is usually common mode while the sensor is connected between the two wires so that its signal is normal mode. The situation is illustrated in Figure 7.1. Twisting the wires together to insure that they are in the same physical location will insure that the noise picked up on both wires will be the same. If the two wires are connected to the two inputs of a differential amplifier, the common mode noise on the wires will be cancelled out while the signal will be amplified. For this method of noise canceling to work properly the two inputs must have identical input impedances and gains which are equal in magnitude and opposite in sign. In addition to these requirements the gain is usually very high. An amplifier which meets all of these requirements is called an instrumentation amplifier and a circuit is shown in Figure 7.2.

Figure 7.2 Instrumentation Amplifier.

For a verbal description click here.

The best way to approach a problem involving this circuit is to treat it as a circuit analysis problem. For example, we will calculate the gain of the first amplifier stage of the circuit of Figure 7.2. The first stage consists of OA1 and OA2. If a voltage is applied between the two inputs (normal mode) the two op amps will adjust their output voltages to bring each of the inverting inputs to the same potential as the corresponding noninverting input. If we apply a voltage of VIN between the two input terminals, the identical voltage will appear across R1. This will cause a current of,

I = VIN / R1  (7.1)

to flow in the series combination of the two identical resistors labeled R2 and R1. There is no significant drop across the two resistors labeled RS. The output voltage of the first stage is the total voltage drop across the resistor chain.

VO = I (R1 + 2 R2).  (7.2)

Substituting equation 7.1 into equation 7.2 and dividing through by VIN gives,

VO / VIN = (R1 + R2) / R1  (7.3)

The gain of the second stage which consists of OA3 could be derived in the same way if desired. Rather than to have yet another equation to remember it is better to analyze the circuit using Ohm's and Kirchhoff's laws.

Example 7.1.

In the circuit of Figure 7.2 R1 = 2 k ohms, R2 = 99 k ohms, R3 = 10 k ohms and R4 = 100 k ohms. If the voltage at the top input is +2.0 mV and the voltage at the bottom input is -1.0 mV, what is the output voltage?

Solution:

The best way to keep track of voltages is to make a chart of all three terminals of all three op amps as shown. The voltages at the noninverting inputs of OA1

Terminal | OA1 | OA2 | OA3
noninverting input | +2 mV | -1 mV | 136.81818 mV
inverting input | +2 mV | -1 mV | 136.81818 mV
Output | 150.5 mV | -149.5 mV | 3.00 V

and OA2 are given and so can be filled in immediately. The op amps will make the voltage at the inverting input be the same as that at the noninverting input and so these values can also be filled in by inspection. The voltage across R1 is 2 mV -(-1 mV) = 3 mV. The current in R1 is I = 3 mV / 2 k ohms = 3/2 uA. The voltage drop across either R2 is V = 3/2 uA x 99 k ohms = 148.5 mV with the upper end positive. The lower end of the top R2 is at a potential of +2 mV; therefore, the upper end of the top R2 is at 2 mV + 148.5 mV = 150.5 mV. The upper end of the bottom R2 is at -1 mV; therefore, the lower end is at (-1 mV) + (-148.5 mV) = -149.5 mV. Notice that the difference is 150.5 mV - (-149.5 mV) = 300 mV. This confirms a first-stage gain of 100. The voltage at the noninverting input of OA3 is found by simply applying the voltage divider equation to R3 and R4. The noninverting input of OA3 does not load the voltage divider. V+3 = VO1 R4 / (R3 + R4) = 150.5 mV x 100 k ohms / 110 k ohms = 136.81818 mV. The entries for both the noninverting input and the inverting input of OA3 can now be filled in. The voltage drop across the bottom R3 is 136.81818 mV - (-149.5 mV) = 286.31818 mV. The current through the lower R3 is I = 286.31818 mV / 10 k ohms = 28.631818 uA. The voltage drop across the lower R4 is 28.631818 uA x 100 k ohms = 2863.1818 mV with the right end positive. The voltage at the output of OA3 is its inverting input voltage + the drop across the lower R4, which is 136.81818 mV + 2863.1818 mV = 2999.99998 mV which, when rounded off, gives 3.00 volts.

The results of this example confirm that the gain of the second (OA3) stage is given by

A' = R4 / R3  (7.4)

even though the circuit appears more complicated than an ordinary inverting amplifier.

The input to the circuit of Figure 7.2 is a differential input because neither side of the input needs to be connected to ground. The output of the first stage (OA1 and OA2) is a differential output because neither side is connected to ground. The input to the second (OA3) stage is also differential. The output from OA3 is said to be single-ended because one side is connected to ground. Thus a circuit consisting of two R3s, two R4s and an op amp can be used to convert a differential source to a single-ended load. The problem with using such a circuit is that the input resistances at its two inputs are not equal. The input resistance at the noninverting input is R3 + R4 while the input impedance at the inverting input is R3. The two noninverting amplifiers serve to balance the input impedances and at the same time make them very high.

Connecting R1 between the two amplifiers instead of each amplifier having its own R1 makes the amplifiers self-balancing, which increases the common mode rejection ratio. Note in the example that even though the original inputs had a 2 to 1 imbalance, the outputs had less than a 1% imbalance. The OA3 stage can easily accommodate the small imbalance. If this circuit is to have a high CMRR the values of the two R3s and the two R4s must be very well matched.

The resistors RS are used to prevent serious imbalance due to input bias currents in the event that the source has a high Thevenin resistance. If input bias current is no problem the two resistors may be omitted (replaced by pieces of wire).

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

7.2 AC Voltmeter Circuit.

Voltmeters, whether analog or digital, are basically DC measuring instruments. When it is desired to measure AC the common practice is to change the AC to DC and then measure it. This causes problems because the diodes which are used to rectify the AC are not linear. Perhaps the oldest approach is to print a separate scale on the face of the meter, (analog meters), and instruct the operator to read that scale when measuring AC. This method has worked well for many decades in meters which have no electronic circuits inside them.

Electronic voltmeters use some electronic tricks to make the response of the rectifiers linear. The circuit of a linear AC voltmeter is shown in Figure 7.3.

Figure 7.3 Linear AC Voltmeter Circuit.

For a verbal description click here.

If you trace the current through the bridge as was done in Chapter 3 the current will be seen to be flowing in or out of the op amp output, through one of the top diodes in the bridge, through the meter from right to left, through one of the bottom diodes and up or down through the resistor R2 to ground. The feedback is taken from the top of the resistor which makes the voltage waveform across R2 match the input waveform. Because R2 is a resistor, its current waveform will match the input voltage waveform. The meter and the resistor are in series. The same current is flowing in the meter as flows in R2. The meter current is the absolute value of the R2 waveform but the magnitudes are identical. If you look at the output voltage waveform on a scope, you will see a very distorted wave. What you are seeing is what has been said many times, "The op amp will adjust its output voltage to make the inverting input voltage equal the noninverting input voltage." The output voltage will be whatever it has to be to make the current in R2 directly proportional to the input voltage. In this case it is the meter current which is being linearized. Since the pointer responds to the meter current, the deflection of the pointer will be linearly proportional to the average input voltage. The meter can be calibrated to indicate the RMS of a sine wave.

The value of R2 sets the full-scale range of the meter. With the value given the range will be approximately 1 volt if a 1 mA meter is used. The 100 pf capacitor is to prevent the op amp from oscillation at high frequencies. This capacitor will cause the meter to lose accuracy at high frequencies and if you want to measure voltages of high frequency waves the capacitor must be as small as possible while still preventing oscillation. The capacitor at the input is necessary to block any DC which may be mixed with the AC to be measured.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

7.3 Open-loop Linearization.

Occasionally in a physics lab it is necessary to make a measurement on some sensor which is at a very high potential. When this is the case a way must be found to transfer the electrical signal and still not have any direct electrical connection. That may seem impossible but don't forget about the transformer which transfers electrical energy while providing electrical isolation. If the sensor delivered AC, a transformer could be used to couple the signal while isolating it. Unfortunately most sensors deliver a slowly changing DC. One approach often used is to change the DC to a proportional AC and then pass it through a transformer for isolation. After isolation the signal may be processed in any manner desired.

Figure 7.4 Open-loop Linearized Photocell.

For a verbal description click here.

A somewhat simpler method of isolation is shown in Figure 7.4. The input signal (from the sensor) is applied to the inverting input of the op amp. The feedback is taken to the noninverting input of the amp. That may seem to be positive feedback but the lamp and photocell have something to say about that. As the voltage at the output of the op amp goes positive, the lamp grows brighter. As the photocell receives more intense illumination its resistance decreases. As the resistance of the photocell decreases the voltage at the noninverting input of the op amp will be decreased. The combination of the lamp and photocell provide the inversion and so the op amp does not have to.

When a positive voltage is applied to the input the op amp will adjust the brightness of the lamp so that the voltage across the photocell on the left is equal to the input voltage. If the two photocells are closely matched the voltage across the photocell on the right will also be equal to the input voltage. Because there is no electrical connection between the two parts of the circuit, the input can be at any arbitrarily high potential and allow the output to be grounded.

In this circuit the batteries are meant to be batteries. The circuit should be constructed in an insulated box to prevent accidental electric shock. The value of the resistor and pot which are in series with the photocells depend on the illuminated resistance of the photocells. The values of these resistors will have to be determined after the photocells are obtained. The purpose of the two diodes in series with the lamp is to permit the lamp voltage to go all the way to zero. The output of an op amp will have a minimum voltage of 2 P-N junctions from the negative power supply lead. The circuit only works for positive input voltages. If a negative input is applied, the lamp will attempt to get darker than dark and nothing will happen, except in the twilight zone.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

7.4 Absolute Value Amplifier.

The AC voltmeter circuit given above will change AC to a linear meter reading but sometimes it is necessary to change an AC to a linearly proportional DC voltage. Simple rectifiers of the type used in power supplies are not linear and indeed have no output for the first 0.6 volts of the input signal. If the diodes are placed in the feedback loop of an op amp (two op amps in this case) the rectified output will be directly proportional to the input. The circuit of a linear rectifier or absolute value amplifier is shown in Figure 7.5.

Figure 7.5 Absolute Value Amplifier.

For a verbal description click here.

When an AC signal applied to the input goes positive, the output of OA1 goes negative. This reverse biases D2 and forward biases D1. The output of OA1 is disconnected from the output of the circuit. Meanwhile, the output of OA2 goes positive. This forward biases D4 which connects the output of OA2 to the output of the circuit. D3 is reverse biased as we will shortly see. The inverting input of OA2 is connected to the output node through R3. The op amp will adjust its output to whatever voltage is necessary to bring the output node to the same potential as the input node. That will cause the output of OA2 to be about 0.6 volts more positive than the input node of the circuit. D3 is therefore reverse biased by 0.6 volts. For a positive input, the output is also positive and has the same voltage.

When the input goes negative the output of OA2 goes negative, which reverse biases D4, disconnecting the output of OA2 from the output node of the circuit. D3 is forward biased. For a negative input, the output of OA1 will go positive. D2 is forward biased and D1 is reverse biased. Resistor R2 takes feedback from the output node and if R1 and R2 are of equal value the output node will have the same magnitude and opposite sign as the input node. Thus for a negative input the output is positive but has the same magnitude as the input.

If a capacitor is placed in parallel with R4 the circuit becomes a peak detector. If an RC low-pass filter is connected to the output the circuit becomes an average value detector. In the latter case the resistor in the low-pass filter should be greater than 1 M ohms for an error of less than 1%. In either case the value of the capacitor will depend on the response time required.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

7.5 Log Converter.

This section has been rendered obsolete by the low cost of powerful desk top computers and data collection systems. It has been left in to show how things were a few years ago.

If it is necessary to take the log of data which is being collected in an experiment, the method of choice is to digitize the data and let a computer do the log taking. In very well-funded laboratories the computer is on-line, (connected to the experimental equipment). In less well-funded experiments the data must be hand carried - on disk, tape or paper - to the computer.

It is always desirable and often necessary to see the log of the data as the experiment is running. Seeing the log of the data may be necessary in order to properly adjust the equipment. If the experimenter is able to see the data come out as the experiment runs, it is possible to tell if something has gone wrong. A strip-chart recorder is often used for this purpose.

Many experiments deliver the data in analog form and most strip-chart recorders accept data in analog form. For the purpose of so-called "quick look" data reduction an analog device which will take the log of analog data may be helpful.

The circuit of a working logarithmic converter is shown in Figure 7.6. This circuit is designed to be used with a strip-chart recorder having a Y axis input of 10 mV full- scale. With the values given the unit may be calibrated to 1 mV = 10 dB. The converter operates from two 9 volt transistor radio batteries.

Figure 7.6 Logarithmic Converter for Use with
a 10 mV Strip-chart Recorder.

For a verbal description click here.

The op amp is a type 558 which has two amplifiers in a single 8 pin package. The transistors used here were from the junk box. Any low power PNP transistors will do so long as they are reasonably well matched.

The batteries are connected as shown in Figure 6.1. A double pole switch is required to interrupt the current from both batteries.

The input signal is applied through R1 to the inverting input of OA1 which is nothing more than a unity-gain inverter. R5 is a zero adjust control. The op amp used has no offset adjustment pin connections and so the somewhat elaborate network of R4 through R9 is required to provide offset adjustment for the op amp.

Transistor Q1 is the element which does the log taking. The I-V curve of a P-N junction is an exponential or a logarithmic function depending on how you look at it. In this circuit we are looking at it as a log function. If a positive input signal is applied to the input, it will be inverted and appear at the output of OA1 as a negative voltage. This will cause current to flow to the left in R10. The output of OA2 will adjust itself so that the collector current of Q1 is equal to the current in R10. The voltage at the op amp's output will be adjusted so as to forward bias the base-emitter junction of Q1. If the input voltage changes, the collector current of Q1 will change linearly and the base-emitter voltage will change logarithmically.

Transistor Q2 serves to temperature compensate the circuit. For example, if the temperature goes up, the base- emitter voltage of Q1 will decrease, which will lower the output voltage. At the same time the temperature of Q2 will increase and its base-emitter voltage will also decrease. The decreased drop across Q2 will increase the output voltage which will compensate for the decrease caused by Q1. Q1 and Q2 should be in physical contact to insure that they are at the same temperature. If the transistors are in metal packages, they should be electrically insulated from each other because the case is often connected electrically to one of the transistor elements.

The network of R12 through R14 reduces the output voltage to the proper level for the 10 mV chart recorder. R13 should be adjusted for a span of 10 dB per mV at the upper end of the working range. R5 may be used to correct errors at the low end of the range. The unit will not have a working range of 100 dB as implied by 10 / mV over a range of 10 mV. The best achievable is about 50 dB. Below -50 dB the response tends to become linear rather than logarithmic.

If the input voltage is negative, OA2 will go to full negative saturation which will slam the chart recorder's pen down hard against the zero stop. The log of a negative number is undefined in the analog world as well as in the world of numbers. The only capacitor in the circuit is to prevent OA2 from oscillating at ultrasonic frequencies.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

7.6 Active Filters.

A single RC filter provides a roll off in the stop-band of 20 dB per decade. Cascading filters (connecting the output of one to the input of the next) does not work as well as might be expected. The roll off around cutoff is so gradual that the filter begins to affect the output long before any large values of attenuation are reached. A single LC filter section will give a roll off of 40 dB per decade and it affects the output only slightly on the pass-side of cutoff. Attenuation increases quickly on the stop-side of cutoff. The problem is that inductors are large, heavy, expensive and often difficult to find. The solution is an active filter. An op amp circuit which has only resistors and capacitors in addition to the op amp can simulate an LC filter. Several of such circuits could be placed in the same volume of one inductor.

Figure 7.7 shows a high-pass filter circuit. In this circuit if C = 0.01 uf and R = 10 k ohms the cutoff frequency is 2.8 kHz and the attenuation at 60 Hz is 50 dB. The cutoff frequency can be calculated from,

fC = 1 / (3.5 R C)  (7.5)

Figure 7.7 High-pass Active Filter Circuit.

For a verbal description click here.

The op amp is used as a unity-gain buffer. In order to insure good performance, the gain error should be less than the desired measurement accuracy at the highest frequency to be passed.

Figure 7.8 shows a low-pass filter circuit. In this circuit if C = 0.1 uf and R = 150 k ohms the cutoff frequency is 4.5 Hz and the attenuation at 60 Hz is 36 dB. The cutoff frequency can be calculated from,

fC = 1 / (15 R C)  (7.5)

Figure 7.8 Low-pass Active Filter Circuit.

For a verbal description click here.

The op amp is used as a unity-gain buffer. In order to insure good performance, the gain error should be less than about 5% at 10 times the cutoff frequency.

Example 7.2.

It is desired to construct a low-pass filter with a cutoff frequency of 0.1 Hz. The capacitors to be used have a value of 1.0 uf. (a) What is the calculated value of R? (b) What standard values should be used for the two resistors in the filter?

Solution:

(a) Solving equation 7.6 for R gives R = 1 / (15 fC C) =
1 / (15 x 0.1 x 1 x 10-6) = 667 k ohms

(b) The closest value for R is 680 k ohms and the closest value for 2R is 1.3 M ohms.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

7.7 Problems.

  1. In the circuit of Figure 7.2 R1 = 200 ohms, R2 = 99.9 k ohms, R3 = 10 k ohms and R4 = 1 M ohm. If the voltage at the top input is -20 uV and the voltage at the bottom input is -70 uV, (a) what are the voltages at each of the op amp terminals? Make a chart similar to that in Example 7.1. (b> What is the gain of the amplifier?

  2. Using the circuits given in this chapter draw the schematic diagram of a circuit which will take an AC signal and rectify it without introducing significant errors. Then the circuit must average the rectified AC and convert it to dB.

  3. Design a high-pass filter which has a cutoff frequency of 10 kHz. The capacitors have a value of 0.0033 uf. Give the standard values for the resistors to be used in the circuit. Draw the circuit.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

7.8 Answers to Problems.

  1. The table shows the values.

    Terminal | OA1 | OA2 | OA3
    noninverting input | -20 uV | -70 uV | 24.7079208 mV
    inverting input | -20 uV | -70 uV | 24.7079208 mV
    Output | 24.9550000 mV | -25.0450000 mV | 5.0000000 V

    (b) 100,000

  2. The averaging could be accomplished using a passive RC filter but I decided to go all out. If you drew an RC filter, your answer is correct.

    Figure 7.9 Answer to question 2.

    For a verbal description click here.

  3. R = 9.1 k ohms, 2R = 18 k ohms. The circuit is like figure 7.7.


Chapter 8   Digital Circuits.

8.1  The Binary Number System.
8.2  Logic Functions and Gates.
8.3  Boolean Algebra.
8.4  Combinational Logic Circuits.
8.5  Flip-Flops and Counters.
8.6  Displaying the Count.
8.7  Multiplexed Displays.
8.8  Digital to Analog Converter.
8.9  Analog to Digital Converter.
8.10 The 555 Timer.
8.11 Problems.
8.12 Answers to Problems

Chapter 8

Digital Circuits.

Up to this point we have been dealing with analog signals. An analog signal is a voltage or current which carries information and can take on any value. For example the output of a thermocouple can be 31.56 uV or 103.97 uV or even 1.6358 mV. The point is that the only limit is our ability to measure the voltage. The voltage itself may have a value of 1.63582419574239658395723656793445642467543 mV for all we know. Analog data is quantized (if at all) only by the measurement technique. The data itself may take on any value.

Digital data on the other hand is presented as numbers. Two forms you are likely familiar with are the readout of the digital multimeter and the data stored in a computer. The values of digital data are quantized. For example if the data is only available to 3 significant digits then the data can only have values such as 3.82 and 3.83. The datum cannot take on a value between 3.82 and 3.83.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

8.1 The Binary Number System.

The number system we use has ten digits (0 through 9) and we write numbers by using a system of positional weighting. The earliest computer circuits attempted to emulate this system. For example there might be a set of four different voltages, each voltage could be zero, 1 volt, 2 volts, and so on to 9 volts. One of the voltages could be used to represent units, another tens, the third hundreds and the fourth thousands. While this sounds workable in theory and easy to use, in practice the circuits become very complex and expensive to construct.

The system of binary numbers has been around for more than a century but it had no practical use until the digital computer came along. Instead of using a number system where each digit can take on ten different values it is much easier to let each digit have only two values. For example, if we have a set of voltages and each can be either 0 volts or 5 volts, we can use a system of positional weighting as shown in Figure 8.1.

28 | 27 | 26 | 25 | 24 | 23 | 22 | 21 | 20
256 | 128 | 64 | 32 | 16 | 8 | 4 | 2 | 1
0 | 1 | 1 | 0 | 0 | 1 | 0 | 1 | 1

Figure 8.1 Example of a 9 Digit Binary Number.

The first line in Figure 8.1 gives the power of 2 for each position in the binary number system. The second line gives the actual values of each position. The third line is an example of a binary number. The number is 203 decimal. The position values continue on to the left 29, 210, etc, for as far as is needed.

To convert a binary number to decimal all that is necessary is to add the positional values in all columns where the binary digit has the value 1. In Figure 8.1 it is 128 + 64 + 8 + 2 + 1 = 203. Figure 8.2 shows what counting in binary looks like.

0 | 0 0 0 0 0
1 | 0 0 0 0 1
2 | 0 0 0 1 0
3 | 0 0 0 1 1
4 | 0 0 1 0 0
5 | 0 0 1 0 1
6 | 0 0 1 1 0
7 | 0 0 1 1 1
8 | 0 1 0 0 0
9 | 0 1 0 0 1
10 | 0 1 0 1 0
11 | 0 1 0 1 1
12 | 0 1 1 0 0
13 | 0 1 1 0 1
14 | 0 1 1 1 0

Figure 8.2 Counting in Binary Numbers.

The term "binary digit" has been shortened to the word "bit". A bit is a binary digit. A number which has 8 binary digits is said to be an 8 bit number. A bit is allowed to have only two values: 0 and 1.

Binary Addition.

Addition in binary is just like addition in decimal (if you're missing eight fingers). The rules for addition are summarized in Figure 8.3.

Bits to be added | 0 + 0 | 0 + 1 | 1 + 1 | 1 + 1 + 1
Sum | 00 | 01 | 10 | 11
Single Bit Sum | 0 | 1 | 0 | 1
Carry | 0 | 0 | 1 | 1

Figure 8.3 Rules for Addition of Binary Digits.

Binary addition is limited to two binary numbers because of hardware limitations. However, if the addition of the bits to the right produced a carry the current pair of bits must include provisions for a third bit to be added. The last column allows for both bits being added to be 1 and the addition to the right to produce a carry of 1.

Example 8.1.

What is the sum of 100111 and 1011?

Solution:

As with decimal numbers the shorter number must be filled out with zeros on the left.

Carried | 0 | 1 | 1 | 1 | 1
First number | 1 | 0 | 0 | 1 | 1 | 1
Second number | 0 | 0 | 1 | 0 | 1 | 1
Sum From Figure 8.3 | 1 | 1 | 10 | 10 | 11 | 10
Write Down | 1 | 1 | 0 | 0 | 1 | 0
And Carry | 0 | 0 | 1 | 1 | 1 | 1

We'll learn multiplication in the second grade.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

8.2 Logic Functions and Gates.

We can do more with binary digits than just add them. We can perform the logic functions AND, OR and NOT on them. Since binary digits (bits) only have two states they can be used to represent anything which has two states. For example a lamp can be either on or off, a switch can be either closed or open, an answer can be either true or false; each of these may be represented by a bit which is either 1 or 0.

Suppose we connect up three switches as shown in Figure 8.4. What we know about circuits tells us that all three switches must be closed to turn on the lamp. If we set up the rule that 1 = closed = lighted we can write a table as in Figure 8.5.

Figure 8.4 AND Function Illustrated Using Switches.

For a verbal description click here.

A | B | C | LAMP
0 | 0 | 0 | 0
0 | 0 | 1 | 0
0 | 1 | 0 | 0
0 | 1 | 1 | 0
1 | 0 | 0 | 0
1 | 0 | 1 | 0
1 | 1 | 0 | 0
1 | 1 | 1 | 1

Figure 8.5 Truth Table for AND Function.

This is referred to as an AND function because to get the lamp to glow it is necessary to close switches A and B and C. A table which lists all possible combinations of inputs (stimuli) and the response for each combination is called a "truth table".

If we connect three switches in parallel, as in Figure 8.6, we have an OR function. If any one switch is closed the lamp lights. This is referred to as an OR function because to get the lamp to glow it is only necessary to close switch A or B or C. It makes no difference if more than one switch is closed, the lamp stays on. This is the inclusive OR function. It is always referred to simply as the OR function. The truth table for the OR function is shown in Figure 8.7.

Figure 8.6 OR Function Illustrated Using Switches.

For a verbal description click here.

A | B | C | LAMP
0 | 0 | 0 | 0
0 | 0 | 1 | 1
0 | 1 | 0 | 1
0 | 1 | 1 | 1
1 | 0 | 0 | 1
1 | 0 | 1 | 1
1 | 1 | 0 | 1
1 | 1 | 1 | 1

Figure 8.7 Truth Table for OR Function.

The two remaining functions cannot be illustrated using switches and lamps. The functions are NOT and Exclusive OR, referred to as XOR.

The NOT function is simply a state inverter. If the input is 0 the output is 1. If the input is 1 the output is 0. An inverter can have only one input. The truth table for an inverter is given in Figure 8.8.

³
INPUT | OUTPUT
0 | 1
1 | 0

Figure 8.8 Truth Table for Logic Inverter

An exclusive OR (XOR) function can only have two inputs. The XOR function is similar to the OR function except that if both inputs are 1s the output is 0. The output is true (1) if A is 1 or B is 1 but the case of A = B = 1 is excluded. The truth table for an XOR function is shown in Figure 8.9.

A | B | LAMP
0 | 0 | 0
0 | 1 | 1
1 | 0 | 1
1 | 1 | 0

Figure 8.9 Truth Table for XOR Function.

Logic functions are implemented with transistors, diodes and resistors which are packaged in integrated circuits. For the purpose of drawing schematic diagrams each logic function has a schematic symbol. They are given in Figure 8.10. A circuit which performs a given logic function is called a logic gate.

Figure 8.10 Schematic Symbols for Logic Gates.

For a verbal description click here.

The NAND and NOR gates which are shown in the schematic symbols are combinations of the NOT and AND, and the NOT and OR functions respectively. The truth tables for the NAND and NOR gates are given in Figure 8.11.

NAND
A | B | C | OUTPUT
0 | 0 | 0 | 1
0 | 0 | 1 | 1
0 | 1 | 0 | 1
0 | 1 | 1 | 1
1 | 0 | 0 | 1
1 | 0 | 1 | 1
1 | 1 | 0 | 1
1 | 1 | 1 | 0

NOR
A | B | C | OUTPUT
0 | 0 | 0 | 1
0 | 0 | 1 | 0
0 | 1 | 0 | 0
0 | 1 | 1 | 0
1 | 0 | 0 | 0
1 | 0 | 1 | 0
1 | 1 | 0 | 0
1 | 1 | 1 | 0

Figure 8.11 Truth Tables for NAND and NOR Gates.

It is not important to know the internal schematic diagram of a logic gate. If it were to be given here the reader would most likely not remember it. The curious reader is referred to IC data books most of which give the internal diagrams.

Logic Families.

The first digital ICs were essentially the same as the circuits of the BJT switches studied in chapter 4. These ICs employed more resistors than transistors. It is normal in discrete circuitry to use more resistors than transistors because resistors are less costly than transistors. A peculiarity of ICs is that it is actually cheaper to make transistors on a chip than it is to make resistors. Circuits were developed which would have been impractical to construct using discrete circuitry. They used more transistors than resistors.

Those first-generation ICs were called RTL for Resistor- Transistor-Logic. The logic family which contains more transistors than resistors is called TTL for Transistor- Transistor-Logic. There was an intermediate stage of development which used a large number of diodes. This family was called DTL for Diode-Transistor-Logic. Of these the only one in use today is TTL.

The two most important logic families today are TTL Transistor-Transistor-Logic and CMOS Complementary-Metal- Oxide-Semiconductor logic. Each logic family is being subdivided into many subfamilies which since this book was originally written have increased exponentially. These subfamilies are too numerous to cover in detail here. We will look briefly at a few of the most important subfamilies.

7400 Series TTL.

This family is the father of the TTL family. Because it is constructed with BJTs it has low input impedance and low output impedance. It operates from a 5 volt power supply. Each gate output can drive 10 inputs of other gates.

An input voltage in the range of 0 to 0.8 volts is recognized as a logic 0 while an input voltage in the range of 2 to 5 volts is recognized as a logic 1. If the input voltage is between 0.8 and 2 volts there is no guarantee as to what will happen.

74LS00 Series Low-power Schottky TTL.

This subfamily operates at about 1/10 the power and about twice the speed of standard TTL. Because of the speed and power difference it is not advisable to mix 74-- and 74LS-- ICs in the same circuit (unless you are sure of what you are doing).

74C00 CMOS.

The ICs in this subfamily are pin compatible with the corresponding 74-- or 74LS-- of the TTL families. However, they are NOT electrically compatible. Like all CMOS they operate from a power supply anywhere in the range of 3.6 to 15 volts. They have very high input impedance and medium output impedance. Because the logic levels are incompatible CMOS and TTL cannot be mixed even if operated from the same power supply.

In CMOS an input voltage in the range of 0 to 1/3 VCC is recognized as a logic 0 while an input voltage in the range of 2/3 VCC to VCC is recognized as a logic 1. If the input voltage is between 1/3 VCC and 2/3 VCC there is no guarantee as to what will happen.

74HC00 Series.

This is a hybrid of TTL and CMOS. It operates at TTL speeds but is level compatable with CMOS. It operates from 5 volts.

4000 Series CMOS.

The 4000 series CMOS has the same logic levels as the 74C00 CMOS. The series contains a wide variety of gates, flip-flops, counters and other special purpose ICs not found in the 74C00 series.

CMOS has a reputation of being subject to burnout from handling. Like the black widow spider and the tarantula, its reputation is undeserved. The input pins are protected by diodes which make the ICs quite rugged. Normal prudence is all that is required when handling these ICs. The writer has completed several projects using CMOS ICs and has yet to burn one out due to handling.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

8.3 Boolean Algebra.

The subject of Boolean algebra is one which could occupy an entire semester. There is not time or space to offer proofs of any of the theorems. The theorems will simply be stated and their applications indicated. The interested reader is referred to texts devoted exclusively to the subject.

Notation.

The functions in Boolean algebra are not the mathematical functions we are accustomed to but are the logic functions of AND, OR, NOT and XOR. The symbols for these functions look like some of our arithmetic symbols but in the context of Boolean algebra they are read differently.

The OR function is symbolized by a plus + sign. Thus C = A + B is not read as "c equals a plus b" but is read "c equals a or b". The table in Figure 8.12 summarizes the Boolean functions and the proper way of speaking each.

The symbol normally used for the exclusive OR function is a plus sign with a circle around it. This symbol is not available in text mode in html. The symbol in text for exclusive OR will be "XOR". In graphics the symbol will be used.

Figure 8.12 Table of Logic Functions and How to Speak Them.

For a verbal description click here.

Figure 8.13 Summary of Boolean Algebra Theorems.

For a verbal description click here.

Figure 8.13 lists some of the most important theorems in Boolean algebra. As you look over the table of theorems you will note some similarity to linear algebra. The last entry in the table is called DeMorgan's theorem. It is one of the most powerful and useful theorems for designing logic circuits.

Example 8.2.

Use a truth table to prove that not A and B or A and not B = A X-or B.

Solution:

For a verbal description click here.

QED.

Example 8.3.

Simplify the following Boolean expression.

D = A and not B and C or A and B and not C

Solution:

Factoring out an A we have

D = A and quantity not B and C or B and not C close quantity

Using the theorem proven in Example 8.2 yields

D = A and the quantity B X-or C close quantity

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

8.4 Combinational Logic Circuits.

The term combinational logic is applied to any connection of logic gates which serves some specific purpose. For example, suppose that there is an experiment in which something in the apparatus could be damaged if certain switches were to be on at the same time. A system of gates could be used to shut down some critical part of the setup if an operator accidentally set the forbidden combination.

Suppose that the equipment may be damaged if switches A and C are on at the same time or if switch B is off when switch D is on. The protection circuit P must be activated if A and C or not-B and D are on. In Boolean form the equation is,

P = A and C or not B and D. 8.1

Expression 8.1 cannot be simplified further. The circuit is shown in Figure 8.14. Gate 1 inverts the B input to form not B. Gate 2 forms the A AND C term while gate 3 forms the B AND D term. Gate 4 forms the final output.

Figure 8.14 Realization of Boolean Expression 8.1.

For a verbal description click here.

It was mentioned earlier that DeMorgan's theorem is very useful in creating logic circuits. The reason is this. The easiest type of gate for IC designers to design and manufacturers to make is the NAND gate. This is true for both TTL and CMOS logic families.

Suppose that it is necessary to implement the following Boolean expression:

D = not A or not B or not C. 8.2

The first impulse would be to use the circuit of Figure 8.15a. However, DeMorgan's theorem extended for three variables states that,

not A or not B or not C = not the quantity A and B and C close quantity. 8.3

The expression D = not the quantity A X B X C may be implemented with a single 3 input NAND gate as shown in Figure 8.15b.

Figure 8.15 DeMorgan's Theorem Is Used to Simplify Circuits.

For a verbal description click here.

The entire process of logic design is to start with a Boolean expression, simplify it and get as many NAND functions in it as possible, then convert the expression to a circuit.

Example 8.4.

The output of a logic circuit is to be high (on) if A is on and B and C are off, or if A and C are on and B is off. Write the Boolean expression, simplify it if possible and then draw the circuit.

Solution:

The initial form of the expression is

D = A and not B and not C or A and not B and C.

If we factor out an A and not B from each term we have

D = A and not B and the quantity not C or Cclose quantity.

but not C or C = 1 and A and 1 = A; therefore, D = A and not B. The first impulse is to use an inverter to obtain the NOT-B term and a two input AND gate. Something you may not know is that gates do not come one per package. Two input gates come four per package. (The term DIP is often used. DIP stands for Dual Inline Package.) A two input NAND gate may be used as an inverter by tying its two inputs together and using them as the inverter's input. We can use one of the NAND gates as an inverter to obtain the NOT-B term, use another to perform the NAND function of A NAND NOT-B and then use another inverter to invert the output of the NAND gate and thereby convert it into an AND gate. The circuit is shown in Figure 8.16.

Figure 8.16 Solution to Example 8.4.

For a verbal description click here.

The initial uninformed solution might have been to implement the logic circuit based on the description in the example. A little Boolean algebra showed that the C input was redundant. In a simple circuit this wouldn't have made any practical difference. In a very complex circuit a redundant input could lead to use of a lot of unnecessary parts.

The solution to Example 8.4 ended up using three of the gates in a quadruple 2 input NAND gate. Such an IC costs less than 25 cents in TTL and less than 50 cents in CMOS.

Combinational logic circuits can get very complex as can the Boolean expressions which represent them. Such large projects are the province of design engineers who are experienced in such matters. The physics student should only attempt to design logic circuits if they are small and simple, as in Example 8.4.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

8.5 Flip-Flops and Counters.

The formal name for a flip-flop is a bistable device. It is a device which is stable in either of two states and will remain in whichever state it is in until it is forced into the other state where it will remain until again changed. Although this definition sounds simple, flip-flops come in a wide variety of shapes, sizes and colors. We will begin with the simplest.

Switch Debouncing Flip-flop.

We are accustomed to thinking of mechanical switches as being either on or off. But if you look on a microsecond time scale, when a switch is turned on or off the contacts open and close several times before they finally settle down to the state in which it has been placed. If the switch is being used to turn a flashlight on and off the bouncing will make no difference and will not even be detectable by the user. But if the switch is being used to activate a logic circuit, operating the switch once may make the logic circuit "think" that the switch has been operated several times. The circuit of Figure 8.17 employs two NAND gates to generate one state change for each position change of the switch.

Figure 8.17 Switch Debouncing Circuit.

For a verbal description click here.

Suppose that the switch has just been thrown and is in transition between the two contacts. Neither switch contact is connected and so both switch contacts are pulled up to VCC by the 10 k ohm resistors. Suppose that Q is low (logic 0) and NOT-Q is high (logic 1). Both inputs to the upper gate are high which allows its output to be low. The lower gate has one input high and the other one low which makes its output high. So far so good, no contradictions.

If the grounded swinger of the switch makes contact to the upper contact, one of the inputs to the upper gate will be pulled low. That will force its output to go high. The lower gate will now have a high on both inputs, which will make its output low. Thus, NOT-Q will be low (0). If the swinger loses contact on a bounce, the two outputs will remain in the same state. The swinger may bounce on the upper contact as many times as it likes, the state of the flip-flop consisting of the two gates will not change again until the swinger touches the lower contact.

Each time the switch is changed to the other position, the state of the flip-flop is changed by the first bounce of the switch contact. Subsequent bounces will not affect the state of the flip-flop. The contact will not bounce far enough to touch the other contact. The contacts are not made of rubber.

The R-S (Reset Set) Master-slave Flip-flop.

The logic diagram of an R-S master-slave flip-flop is shown in Figure 8.18. If the Ck (clock) input is low, gates 1 and 2 will both have high outputs and the master flip-flop consisting of gates 3 and 4 will remain in whatever state it was in; the states of the R and S inputs will have no effect on gates 3 and 4. If the Ck (clock) input is high, gates 1

Figure 8.18 Internal Logic Diagram of an R-S Flip-flop.

For a verbal description click here.

and 2 will be open, which means that the states applied to R and S will be transferred into the master flip-flop. The high on Ck will be inverted by the inverter and gates 5 and 6 will have low states on their inputs, which will close these gates. The outputs of gates 5 and 6 will be high, which means that the slave flip-flop will remain in whatever state it was in.

It may seem impossible to ever transfer a logic state from the R and S inputs to the Q and NOT-Q outputs. Of course it is possible or the circuit would be useless. Let us start out by assuming that the Q output is low. Naturally the NOT-Q output is high. Referring to the flip-flop as a whole it is said to be in the zero state. Let us say that the S input is high, the R input is low and the Ck input is low. Because Ck is low the outputs of gates 1 and 2 will be high. The output of gate 3 must be low and gate 4 high. Gates 5 and 6 are open and these states are transferred through to gates 7 and 8. Now when the Ck input changes to high, gates 1 and 2 are opened and the states on R and S are inverted and transferred to the inputs of gates 3 and 4. A low on one of the inputs of gate 3 will cause its output to go high and gate 4 will have both of its inputs high, which will make its output low. The master flip-flop is now in the 1 state. With the Ck input high, gates 5 and 6 are closed and the slave flip-flop remains in the zero state. When the Ck input changes back to the low state, gates 1 and 2 are closed and the master flip-flop cannot be any further affected by the states on the R and S inputs. The level shift causes the inverter to change states at a lower voltage than gates 1 and 2. On a negative transition, gates 1 and 2 are closed before gates 5 and 6 are opened. Thus there is an approximate 20 nanosecond period when both sets of gates (1 and 2) and (5 and 6) are closed and the R and S inputs are never connected directly to the Q and NOT-Q outputs. With the Ck input in the low state, gates 5 and 6 are opened and the 1 state of the master flip-flop is transferred into the slave flip-flop. Thus the state of Q is now high and NOT-Q is low. If the S input is high and R is low the flip-flop will be Set to the 1 state (Q high and NOT-Q low) and when R is high and S low the flip-flop will be Reset to the zero state. The states of Q and NOT-Q will change only when the Ck input changes from high to low. After the states of Q and NOT-Q have changed to match the states of S and R, additional clock transitions have no effect on the state of the outputs.

If R and S are both low, the flip-flop will remain in its previous state. The outputs will not change states on the clock transition. If both R and S are high, the flip- flop of gates 3 and 4 will be forced into an undefined state and when the clock goes low it will be released from that state and will randomly fall into one of its two stable states. The ending state cannot be predicted. A given IC may always fall into the same state but a different IC may always fall into the other state. Yet another IC may randomly fall into one or the other state.

Most flip-flop ICs have direct set and clear inputs. These inputs will override all other inputs and force the flip-flop into the 1 (set) of 0 (clear) states. The logic involved makes the circuit look more complicated because of the increased number of inputs to gates 3, 4, 7 and 8. A student with a firm grasp of the subject of logic could figure out how to add direct set and clear to this circuit.

The J-K Flip-flop.

If the R-S flip-flop is cross wired (Q to R and NOT-Q to S) an interesting thing happens. Suppose that the flip-flop is in the zero state (Q = 0 and NOT-Q = 1). This means that S has a high applied and R has a low. When a negative edge of the clock occurs, the flip-flop will be loaded with a 1. Following the negative-going clock the R input has a high applied and the S has a low applied. On the next negative-going clock edge the flip-flop will be loaded with a zero. The flip-flop will change its state on every negative-going edge of the clock signal.

Now the importance of the level shift becomes evident. On a positive edge of the clock, gates 5 & 6 are closed before gates 1 & 2 are opened. On a negative edge gates 1 & 2 are closed before 5 & 6 are opened. If the R and S inputs were to be connected directly to the outputs even for a few tens of nanoseconds the circuit would most likely oscillate and the ending state would be completely random.

Figure 8.19 Internal Logic Diagram of a J-K Flip-flop.

For a verbal description click here.

If we make gates 1 and 2 into 3 input gates we have a J-K flip-flop as shown in Figure 8.19. The J-K flip-flop behaves differently from the R-S flip-flop in regard to what happens when J and K are high. In an R-S flip-flop when R and S are high the result is unpredictable. In a J-K flip- flop when J and K are high the flip-flop will change states on every negative edge of the clock input. The process of changing states on every clock is often called toggling. A flip-flop which has been permanently wired to change states on every clock pulse is often called a toggle flip-flop.

If J is high and K is low the flip-flop will be set to the 1 state on the next negative edge of the clock. If J is low and K is high the flip-flop will be set to the zero state on the next negative edge of the clock. If both J and K are low the state of the flip-flop will remain unchanged.

The Type-D (Data Storage) Flip-flop.

In order to store a bit (binary digit) in an R-S or J-K flip-flop it is necessary to place one of the inputs high and the other one low. Since the two inputs are always in opposite states the natural thing to do is to connect an inverter in the circuit as shown in Figure 8.20a. When a flip-flop has been internally wired in this way it is symbolized as in Figure 8.20b. Notice first of all that the internal logic diagram has been replaced by a rectangle. If a logic high (1) is placed on the D input, the next negative edge will cause the flip-flop to assume the 1 state (Q = 1 and NOT-Q = 0). If a logic low (0) is placed on the D input, the next negative edge on the clock will cause the flip-flop to assume the zero state (Q = 0 and NOT-Q = 1). Once the data bit has been stored in the flip-flop, subsequent clock pulses will just keep loading the same data again and again. If the data does not change between clock pulses the state of the flip-flop will not change.

Figure 8.20 D-type Flip-flop from J-K Flip-flop.

For a verbal description click here.

The Cl connection at the bottom of the rectangle and the S connection at the top are direct clear and set inputs respectively. This S is not the same as the S input on an R-S flip-flop. Clear and set inputs are usually active low, which means they are normally high and to clear the flip-flop the Cl input should be pulled low for a few tens of nanoseconds. To set the flip-flop the S input should be pulled low. In the case of TTL an input which is left open will automatically go high. A CMOS input should never be left open; on a CMOS flip-flop the Cl and S inputs must be tied to VCC through either a wire or a 10 k ohm resistor.

Binary Counter.

Figure 8.21 shows the diagram and truth table for a 4-bit binary counter. There is an inherent conflict between the way we draw circuits and the way we write numbers. The standard way of drawing circuits is to have the signal flow from left to right. That places the least significant bit on the left. The way we write numbers is to have the least significant bit on the right. This contradiction cannot be defined away. We must simply live with it.

The input to the counter may be irregular or regular pulses as indicated along the top of the figure. All unconnected inputs to the flip-flops are assumed to be logic high. Every time a flip-flop receives a negative-going edge, its state will change. See the table in the figure.

Figure 8.21 4-Bit Binary Counter and Its Truth Table.

For a verbal description click here.

Every time the input changes from high to low, flip-flop A will change states. Every time flip-flop A changes from a 1 to a 0, flip-flop B will change states and so on. If the counter starts from zero (all bits zero) the count at any time will equal the number of negative edges which have occurred in the input signal. The number is of course expressed in binary. The number of flip-flops in the counter may be arbitrarily large. The largest number NL a given counter can contain is

NL = 2N - 1  (8.4)

where N is the number of flip-flops in the counter.

If the input to the counter is a square wave it has a definite frequency. In this event the output of the counter also has a definite frequency. The output frequency is given by

fO = fIN / 2N  (8.5)

where fO is the output frequency, fIN is the input frequency and N is the number of flip-flops in the counter. Thus we have a means of changing (lowering) the frequency. With a simple binary divider the input frequency may only be divided by 2N where N is an integer.

When a binary counter is used to divide frequencies it is called a frequency divider. Divide ratios can be other than 2N but the circuitry becomes more complex. Noninteger divide ratios are even possible but the circuitry becomes very complex.

Example 8.5.

The input frequency to a 9 stage (9 flip-flops) binary counter is 225,280 hertz. What is the output frequency?

Solution:

fO = fIN / 2N = 225,280 / 29 = 440 hz.

The Decade Counter.

When binary numbers were introduced it was said that it was difficult to make electronic circuits which could count in decimal. In the age of the IC it is easier than it was in the vacuum tube age. Computer hardware designers still prefer to use binary but in stand alone digital instruments such as digital clocks, frequency counters and digital voltmeters the decade counter is king.

The circuit employs a number system known as binary coded decimal (BCD for short). Figure 8.22 shows how to count from 0 to 12 in BCD. Each decimal digit is represented by 4 binary digits (bits). Four bits of binary can normally express numbers as large as 15 (1111) but in BCD the highest allowed count is 9 (1001). Binary counts higher than 1001 are not allowed. Notice that in Figure 8.22 when the units count reaches 9 it resets to 0 and a 1 is placed in the tens column.

This system of counting requires more bits than a comparable binary counter. For example a 3 digit BCD counter can count to 999 and requires 3 digits x 4 bits per digit = 12 bits. A binary counter which can count to 1023 requires only 10 bits. The extra bits are well worth the tiny increase in cost. The circuitry to readout a 10 bit binary counter in decimal is far more complex and expensive than the couple of extra bits required for making BCD counters.

Decimal | Tens | Units
00 | 0 0 0 0 | 0 0 0 0
01 | 0 0 0 0 | 0 0 0 1
02 | 0 0 0 0 | 0 0 1 0
03 | 0 0 0 0 | 0 0 1 1
04 | 0 0 0 0 | 0 1 0 0
05 | 0 0 0 0 | 0 1 0 1
06 | 0 0 0 0 | 0 1 1 0
07 | 0 0 0 0 | 0 1 1 1
08 | 0 0 0 0 | 1 0 0 0
09 | 0 0 0 0 | 1 0 0 1
10 | 0 0 0 1 | 0 0 0 0
11 | 0 0 0 1 | 0 0 0 1
12 | 0 0 0 1 | 0 0 1 0

Figure 8.22 BCD Counting from 0 to 12.

In order to implement BCD in hardware it is necessary to wire together 4 flip-flops in such a way as to count from 0 to 9, which is the same thing as dividing the input frequency by ten. Ten can be factored as 2 x 5. A single flip-flop can handle the divide by 2. Three flip-flops and some gates are used to accomplish the division by 5.

A practical decade counter is made up of 4 flip-flops, as shown in Figure 8.23. This circuit consists of a count- to-one (divide by 2) and a count-to-four (divide by 5) circuit. The count-to-one section consists of flip-flop A. The count-to-four circuit consists of flip-flops B, C, D and two gates.

Whenever a TTL (transistor transistor logic) input is left open, it assumes the high logic state. (This is not recommended in circuits constructed in the laboratory.) The J and K inputs on flip-flop A are open; consequently, they both have high logic states or 1s applied. If a J-K flip-flop has 1s on both J and K inputs, the flip-flop will change states every time the clock input goes from a logic 1 to a logic 0. If there is one cycle at the output for every two cycles at the input, you have a divide by 2 counter.

The divide by 5 is not so simple. If 3 flip-flops are connected with the Q output of one going to the Ck input of the next, the counter will be a count to 7 or divide by 8. To make this counter divide by 5 instead of 8 requires some trickery.

Figure 8.23 Decade Counter and Its Truth Table.

For a verbal description click here.

The truth table which accompanies Figure 8.23 has all of the numbers written backward. This should aid in understanding the circuit. The column of binary digits for a given flip-flop is under that flip-flop.

Starting out with all flip-flops set to zero, the NAND gate will have a 0 and a 1 on its inputs. Its output will be a 1. This 1 when applied to the J input of F-F B will allow it to change states on every clock pulse. When the count in F-Fs B, C and D reaches 0 0 1 (binary 100) both inputs of the NAND gate will be 1s and the output will be 0. The 0 on the J input of F-F B will prevent it from changing states on the next clock pulse. Because there is no change in the state of F-F B, there will not be any trigger pulse delivered to F-F C and it will remain in the 0 state.

The AND gate gets its inputs from F-Fs B and C. The output of the AND gate will be 0 as long as B or C is 0. The 0 applied to the J input of F-F D will inhibit it from changing states and it will remain in the 0 state. When B and C are both 1s, there will be a 1 on the J input of F-F D and it will change states on the next clock pulse.

Note that the clock pulses are connected to F-Fs B and D. The clock pulse which caused D to change from 0 to 1 will cause B to change from 1 to 0. This change on the Q output of F-F B will cause F-F C to also change from 1 to 0. F-F B is now inhibited from changing states. As we have already seen, F-F D had a 1 on its J input before the clock transition and so the next transition will cause F-F D to change from 1 to 0. We now have all flip-flops back in the 0 state and we are ready for another counting cycle.

This circuit is almost never implemented with separate J-K flip-flops and logic gates. A decade counter integrated circuit is normally used. Different manufacturers implement the counter in different ways and many of them will not even tell us how they do it. It may be done this way or some other way; we don't know.

Variable Modulus Counters.

The modulus of a counter is that number by which it will divide an input frequency. For a counter of modulus N, for every N pulses sent to the counter it will deliver one pulse. The modulus of a 4-bit binary counter is 16, that of a decade counter is 10 and that of the B, C and D flip-flops of a decade counter is 5.

As illustrated by the decade counter it is possible to develop systems of flip-flops and gates to give any desired modulus. Such systems are hard-wired and cannot be changed by the equipment operator. There are counters whose moduli can be changed by the operator.

A very common variable modulus counter uses the up-down decade counter. Each IC has a count-up and a count-down input. There are also carry and borrow outputs. The carry output is wired to the count-up input and the borrow output is wired to the count-down input of the next most significant digit counter. These counters also have a set of direct load inputs which permit data to be loaded into the counter. A "load enable" input on the IC causes data which is presented at the data inputs to be loaded into the flip-flops of the counter.

When the input signal is applied to the count-down input of the least significant digit the borrow output of the most significant digit will go low only when all digits in the counter are zero. The rest of the time this output is high. If this output is connected to the load enable inputs of all of the other digits in the counter the data will be loaded whenever the counter arrives at zero. The data are loaded when the load enable input is low.

The sequence of events is this: the counter counts down to zero, the data are loaded, and the counter counts down to zero again. The modulus of the counter is equal to the number contained in the data which is loaded. If the data are changed, the modulus of the counter is changed.

One way an operator can interact with such a counter is by means of thumb-wheel switches. Each switch has ten positions. When the switch is set to a given position a digit (0 through 9) will show in a window to indicate to the operator the position selected. The switch has four contacts which generate the BCD code corresponding to the digit selected. These switches are designed so they may be placed side by side to allow an operator to set a decimal number on the switches. The outputs of the switches are the BCD code of the number selected. If the switches are connected to the data inputs of the up-down counters, the switches may be used to select the modulus of the counter. The usefulness of such a variable modulus counter will be shown in the next chapter.

It is possible to achieve a noninteger modulus by using combinational logic to set the modulus, as was done for the divide-by-five circuit. Such a circuit may be arranged so that a logic level on one of the gates will change the modulus of the counter. The level on this modulus control input may be rapidly switched to obtain an average modulus which is between integer values. Such a counter must be followed by several divide-by-two flip-flops in order to average out the frequency variations and give a true single frequency output. Circuits of this kind are used in an IC called a "top octave generator". This IC uses a quartz crystal (externally connected) and divides it down to deliver simultaneously all twelve of the musical notes in the top octave of the standard piano keyboard. In each lower octave the frequencies of the notes are half of those in the next higher octave. Simple binary dividers may be used to generate the rest of the notes on the keyboard.

By the way, if you want to amaze a guitar-playing friend by telling him or her the frequencies of the musical notes, it is easy using a calculator. The frequency of the note A above middle-C is 440.000 hz. The notes comprise a geometric series with the twelfth root of two being the factor. Use the YX key on your calculator to raise 2 to the 1/12 power and store the result in memory. Key in 440. To move down the musical scale, recall and divide. To move up the scale, recall and multiply. If you work your way down the scale to middle-C you will find its frequency to be 261.6256 hertz. You may well have read in an elementary physics book that middle-C has a frequency of 256 hertz. The best information available to the writer indicates that musicians changed the standard of tuning sometime early in the 20th century. They forgot to tell the physicists. Meanwhile, any physicists writing a book would look up the frequency for middle-C in the book he had used as a student which was written by someone who looked it up in a book he had used as a student and so on. This is how misinformation can be passed down from one generation to the next.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

8.6 Displaying the Count.

In any digital instrument it is necessary for the contents of the counter to be displayed in some way for an operator to read. Figure 8.24 shows the block diagram of a single digit of the readout system for a decade counter.

Figure 8.24 Decade Counter, Latch, Decoder and Display.

For a verbal description click here.

The numbers in the blocks are type numbers of specific ICs. The 7490 is the decade counter. Such a counter is in the middle of a chain of similar decade counters. The 7475 is a 4-bit memory consisting of 4 type D flip-flops. The purpose of the "strobe" input is to cause the data in the decade counter to be loaded into the memory. The purpose of the memory is to remember the count while a new count is being accumulated. The sequence of events is this. The count begins and the decade counters count up from zero. When the count has finished, the "strobe" inputs of all of the memories is pulsed which stores the data in the memory. The counters may then be reset (to zero) and a new count begins while the memory holds the previous count.

The contents of the memory are fed to the 7447 which is a decoder-driver. This IC uses combinational logic to convert the BCD code from the memory to the proper pattern to display numerals on the 7-segment display. The outputs of the decoder-driver are BJTs which are "on" to light a display and "off" to keep it dark. These BJTs are capable of switching enough current to drive almost any display which may be used.

The display itself consists of 7 light emitting diodes (LEDs). These LEDs have an I-V curve similar to any other diode. The full 5 volt power supply cannot be applied across the LEDs in the display. There must be a current limiting resistor in series with each LED in the display. A typical value is 220 ohms. Some other types of decoder-drivers have these resistors built in to the IC.

There must be one of these circuits for each digit to be displayed. An 8-digit display would have eight 7490s, eight 7475s, eight 7447s, fifty-six resistors and eight displays.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

8.7 Multiplexed Displays.

The term LSI means large scale integration. It is LSI which has made the pocket calculator possible. One problem with LSI is the number of pins necessary to connect to the display. A ten-digit calculator needs eighty pins to control the numeric display and the decimal points. That is far too many for a reasonable size for the IC and the calculator it is used in.

A way to save pins is to multiplex the display. Instead of connecting the anodes of the LEDs in the display to the +5 volt line, they are connected to the collectors of PNP switching transistors. A ten-digit calculator needs ten control lines, one for each digit. All of the segment cathodes are connected in parallel. For example the top segments in all ten of the digits are connected together. All ten of the decimal point cathodes are connected together. That means that there are 8 lines, one for each segment and 1 line for the decimal points. That makes 10 digit control lines plus 8 segment control lines for a total of 18 lines to control 10 digits, instead of 80 as would be the case for individual segment connections. Also only 8 resistors are needed for current limiting.

The way in which this works is as follows. The PNP transistors in the digit anodes can turn an entire digit on or off. The first digit is turned on (all others are off) and the pattern of bits is applied to the segment lines to display the number in the first digit. The first digit is turned off and the second digit is turned on. The data on the segment lines is changed to that of the number in the second digit. The process repeats until all of the digits have been illuminated and then the process begins again. Even though only one digit is on at a time, the eye perceives a continuous display of all digits. The scanning of the displays may occasionally be observed when a calculator is shown on television. The field rate of the TV scanning may "strobe" with the scanning rate of the calculator's display.

Figure 8.25 Multiplexed 4 Digit Display.

For a verbal description click here.

The display will appear to flicker and if the frequency of the display scanning is just right it may even be seen to scan in order. If you ever gain access to a stroboscope, (not to be confused with a strobe light), you may want to put your calculator under it and see if you can find the scanning frequency.

The keyboard of a calculator s another problem. Many calculators have 40 to 50 keys. If there had to be one pin on the IC for each key, calculators would be a lot larger and more expensive than they are.

The keyboard is divided into rows and columns (not necessarily related to their physical placement on the calculator). The keyboard is scanned. For example a calculator having 64 keys does not need 64 pins to connect the keys. The keyboard is electrically arranged into an 8 by 8 matrix and connected as shown in Figure 8.26. Each switch is a key on the calculator. The calculator IC may send pulses out on the column lines one at a time and monitor the row lines for returned pulses. When a switch is closed only one of the 8 column pulses will be received and it will be received on only one row line. That gives an unambiguous way for the chip to know which one of the switches was closed. The calculator IC needs only 16 pins for the keyboard instead of 64.

Figure 8.26 Multiplexed Calculator Keyboard.

For a verbal description click here.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

8.8 Digital to Analog Converter.

A number held in a digital counter or memory is just a number. Like any number it represents only what we humans imagine. In and of itself it represents nothing. However, a circuit may be constructed which will convert a digital number to a proportional voltage. Such a circuit is called a digital to analog converter (DAC).

A digital to analog converter (DAC) which is easy to understand is shown in Figure 8.27. Suppose that the output of the digital buffers is 5 volts if the input is a logic 1 and zero volts if the input is a logic zero. If the most significant bit (MSB) is 1 the 10 k ohm resistor will supply a current of 0.5 mA to the summing node of the op amp. The next bit will cause a current of 0.25 mA to be delivered to the summing junction, the next a current of 0.125 and so on. If the least significant bit (LSB) is a 1 the current from it is 7.8125 uA. An infinite number of bits would bring the total current (all bits on) up to 1 mA. The condition of all bits on (1) is the full-scale condition. The 5 k ohm feedback resistor will cause the op amp to have a full-scale output voltage of -5 volts. When converting binary to decimal each bit has twice the value as the bit to its right. In the case of the digital to analog converter each bit supplies twice the current as the next least significant bit. The op amp causes all of these currents to be summed and converted into a negative voltage. If a positive output is desired another op amp may be connected as a unity-gain inverter.

Figure 8.27 Simple Digital to Analog Converter.

For a verbal description click here.

Although this circuit is easy to understand it doesn't work very well. The problem is the resistors. If the resistors are not exactly right on value the converter will not yield uniform steps as the binary number is incremented. Take the case of stepping from 63 to 64. The number 63 has the 6 least significant bits on. When this number changes to 64, 6 bits turn off and a single bit takes its place. The 10 k ohm resistor must supply a current which is exactly 7.8125 uA larger than the current supplied by the combination of the 6 other resistors. (The smallest possible step in the output of a DAC is the value of the least significant bit.) Errors in resistors are random and, if the particular resistors have errors such that the 20 k ohm is a little low and the 10 k ohm is a little high, incrementing the binary code from 63 to 64 could actually result in a reduction of the output voltage instead of an increase. As the number of bits increases the smallest steps become smaller and the requirements on resistor tolerance become impossibly tight.

Another problem is the wider range of resistor values required by this type of converter. The values in this example circuit range from 10 k ohm to 640 k ohm and this is only a 7-bit converter. A 16-bit converter which has a lowest value resistor of 1 k ohm would have to have a highest value resistor of 32.768 M ohms. Maintaining the necessary tolerances over such a wide range of resistance is impossible.

Figure 8.28 Ladder Network Digital to Analog Converter.

For a verbal description click here.

Figure 8.28 shows a digital to analog converter which will work. The figure shows only 4 bits but the circuit may be extended to as many bits as desired. If the MSB is the only bit to be on, the output voltage will be half of the power supply voltage. That is as it should be because the MSB always represents half of the (largest - 1) number that a given binary number can represent. The MSB is 1/2 scale. The next bit is 1/4 scale, the next 1/8 scale and so on.

Although it is not exactly cheap, it is possible to make a large number of resistors all of the same value. The ladder network is supplied in a package which looks like an IC. The resistors were all made at the same time on a common substrate. The resistors indicated as 2R are just two of the resistors connected in series during the manufacturing process. The actual value R may vary by as much as 10% from unit to unit but within a single unit the resistors are all identical to within a small fraction of a percent. A very high precision DAC may be constructed using a ladder network.

The diagrams show noninverting buffers as the drivers for the DAC. Ordinary TTL cannot be used at all and even CMOS is not good enough for high accuracy DACs. The problem is the voltage that the output of the buffer goes up to when its output is a logic 1. TTL is only guaranteed to go up to 2.4 volts. CMOS does quite a bit better but when its output is loaded by a resistor network the output of a buffer may not make it all of the way to ground for a logic zero or all the way to VCC for a logic 1. Designers of DACs go to great length to design switching circuits which will be at zero volts for a binary zero and at VCC for a logic 1. In addition the VCC supply must be very precisely regulated.

As a physicist you will never have to worry about any of the above. DACs are available in IC form ranging in bit count from 8 to 20 and in price from $3.95 to several hundred dollars. The data sheet for the particular DAC IC to be used must be consulted in order to use it properly.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

8.9 Analog to Digital Converter.

The process of converting a voltage to a digital number is called analog to digital conversion. The voltage may be converted to a BCD (binary coded decimal) number as is done in a digital multimeter or to a binary number if the data are to be fed to a computer for processing.

Analog to digital converters (ADCs) like DACs come in IC packages. They are available in two basic forms, slow and less expensive and fast and more expensive. The slow kind are dual slope integrators and the fast are successive approximation type. Both types can be quite accurate.

Dual-slope Integrator ADCs.

The dual-slope converter is most often used in digital multimeters. Its output is usually in BCD form for easy decimal readout. The typical speed for this converter is about 4 samples per second. That is plenty fast enough for a slow human to take in.

In the circuit of Figure 8.29 the input voltage must be negative. In a complete voltmeter there are circuits which allow the input voltage to be positive or negative. A flip- flop indicates the polarity of the input voltage. To show this extra circuitry would add to the circuit complexity while adding nothing to the reader's understanding.

Figure 8.29 Dual-slope Integrator ADC.

For a verbal description click here.

In the circuit of Figure 8.29 the switches S1, S2 and S3 are not mechanical but electronic switches which are controlled by the block labeled "control logic". The sampling cycle starts by closing switch S1 to discharge the capacitor. S1 is opened and S2 is closed which signals the beginning of time period T1. The output voltage of the integrator begins to go positive because the input voltage is negative. The slope of the line is determined by the magnitude of the input voltage as indicated by the waveform drawings in the figure. At the end of T1 the output voltage of the integrator is proportional to the magnitude of the input voltage. At the end of T1 S2 opens and S3 closes, signaling the start of T2. The reference voltage is the negative of the full-scale voltage of the converter. When T2 begins, the control logic opens the AND gate by placing a logic 1 on the lower input. The upper input of the gate already has a 1 on it from the output of the comparator.

The symbol for a comparator looks like an op amp and there are similarities. A comparator is a device which can have an analog input and a digital output. It may be thought of as a one-bit analog to digital converter. If the noninverting input is more positive than the inverting input the output will be a logic 1. If the inverting input is more positive than the noninverting input the output will be a logic zero.

In the circuit of Figure 8.29 the inverting input of the comparator is grounded and the positive output of the integrator is applied to the noninverting input. The output of the comparator is a logic 1. Clock pulses from the clock are now passed to the counter. The counter counts clock pulses for the duration of T2. The time period T2 ends when the output of the integrator reaches zero. As the two different waves in the figure indicate, the higher the magnitude of the input voltage the longer T2 is and the larger the number of clock pulses counted. When the output of the integrator reaches zero the AND gate is closed because the output of the comparator has switched to a logic zero. The control logic is also notified and it initiates a number of steps. S3 is opened, the contents of the counter are loaded into the display memory and the counter is reset to zero. Now S1 is closed and the entire cycle starts over again.

You may be thinking that a much simpler way would be to let the reference voltage be integrated until it equals the input voltage and let the counter count clock pulses during this time. If you did think of this method, go to the head of the class. It shows that you are thinking. The calibration of such a single-slope integrator is very dependent on the value of the capacitor. Capacitors have a rather bad habit of changing capacitance as temperature changes. In a dual-slope integrator the capacitor is used twice and errors in the value of the capacitor are partially canceled out. This partial error cancellation is the primary reason for using a dual-slope integrator instead of a single slope integrator.

Successive Approximation ADC.

Successive approximation converters are very fast, ranging in speed from several hundred samples per second to several million samples per second. In bit count they range from 8 to 20 and in price from $3.95 to several hundred dollars. Because of their great speed they are most often used in association with microprocessors. They usually have binary output.

The diagram of a successive approximation ADC is shown in Figure 8.30. You will notice that contained within the analog to digital converter (ADC) is a digital to analog converter (DAC). The comparator compares the output of the DAC with the input signal and sends its output signal to the control logic. The wide lines on the diagram labeled "data bus" and "control bus" are a shorthand way of drawing many individual connecting lines. In the case of a 16 bit converter, there would be 16 lines connecting the control logic block to the binary register and 16 lines connecting the binary register to the DAC. It is pointless to draw 16 lines when everyone knows that they are all going to the same place.

Figure 8.30 Successive Approximation ADC.

For a verbal description click here.

One very simple way in which this circuit could be used is to start the binary register (used as a counter) at zero, count up until the comparator changes states and then stop. That method works fine provided you are not in a hurry. If the input signal is near full-scale, as many as 65 thousand clock pulses would be required to complete a conversion in a 16 bit converter. The conversion time is dependent on the magnitude of the input signal. An input signal which is near zero takes fewer clock pulses and, therefore, less time than an input signal which is near full-scale.

The successive approximation system works much faster. The difference between a binary counter and a binary register is that a binary register can be loaded with data in many ways. In the binary register used here each bit can be changed individually. The binary register starts with all bits set to zero. The control logic sets the most significant bit (MSB). If the comparator changes states because the output of the DAC is larger than the input signal, the bit is reset. Otherwise it is left set. The next least significant bit is tried in the same way: if turning it on makes the output of the DAC greater than the input the bit is turned off, if the DAC's output is less than the input, the bit is left on. If it is necessary to turn a bit off the same clock pulse which turns that bit off can turn on the next bit. In the case of a 16 bit converter only 16 clock pulses are required to complete a conversion.

A microprocessor could easily be programmed to perform the function of the control logic. A microcomputer which is equipped with a DAC for the purpose of playing music needs only the addition of a comparator feeding into a game paddle port and it can be used as an ADC.

Single IC converters use combinational logic to accomplish the job of the control logic. Such converters can be made very fast indeed.

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

8.10 The 555 Timer.

The 555 timer resides in a kind of twilight zone between analog and digital. It incorporates elements of both but it is more digital than analog so it is included here.

A 555 timer is basically a monostable Multivibrator or one shot. In this device it is stable in one state where it remains until triggered. Upon being triggered it changes to the other state where it remains for a length of time determined by an RC time constant and then returns to the stable state. Both the TTL and CMOS logic families have one shots in the line. Some are retriggerable which means that if another trigger pulse arrives before the RC has timed out the time period will start over. Others are not retriggerable which means that trigger pulses are ignored while the RC is timing out. Some can be wired for either kind of behavior.

A 555 is not retriggerable and requires the addition of an external transistor to make it into one. The internal block diagram is shown in figure 8.31. Figure 8.32 shows a 555 timer wired as a one shot.

Figure 8.31 Internal Block Diagram of the 555 Timer.

For a verbal description click here.

Figure 8.32 One-shot, Pulse Stretcher.

For a verbal description click here.

In the stable state the trigger input is held high by the resistor. The output is low and the not Q input is high. This holds the transistor on which keeps the capacitor discharged. The trigger input goes to the inverting input of the comparator so the S input of the flip flop is low. The discharge and threshold pins are tied together so the noninverting input of the other comparator is low making the R input of the flip flop low. With R and S both low the flip flop will not change states.

The trigger pulse would be negative and short. A negative pulse on the inverting input of the comparator drives the output positive setting the flip flop. The not Q goes low and the output goes high. The discharge transistor is turned off and the capacitor begins to charge through the resistor. Note the network of equal value resistors in the center. The comparator on the right has its noninverting input held at 1/3 of VCC. The one on the left has its inverting input held at 2/3 of VCC. As long as the voltage across the capacitor is less than 2/3 VCC The R input of the flip flop remains low. When the voltage reaches 2/3 VCC the R input goes high and the flip flop is reset. The output returns to low, the discharge transistor is turned on, discharging the capacitor and the timer is back in its stable state.

After the timer has been triggered and before the RC circuit has timed out additional trigger pulses will have no effect. Such pulses would set the flip flop but it is already set.

There are many possible uses of this circuit but one could be as a pulse stretcher to turn on an indicator light. Suppose part of an experiment delivers pulses that are so short that even if they were used to turn on an L E D the flash would be too short to perceive. A requirement is that the operator must know when such pulses occur. The narrow pulses could be applied to the input of a circuit like that of figure 8.32 with its R and C values selected for a timeout of say 1 second. The timer could be used to light a lamp and sound a buzzer to be sure to get the attention of the operator.

The time that the output remains high is given by,

T = 1.1 R C  (8.6)

Oscillator Circuit.

In the circuit of figure 8.33 The capacitor is connected back around to the trigger input so the timer will trigger itself. There is a resistor connected between the capacitor and the discharge terminal so the capacitor will take some time to discharge.

When the output goes low and the discharge transistor is turned on the capacitor discharges through R2. When the capacitor voltage reaches 1/3 VCC the flip flop is set and the discharge transistor is turned off. The capacitor then charges through the series combination of R1 and R2. When the voltage reaches 2/3 VCC the flip flop is reset and the cycle starts over.

It is impossible to get square waves out of this circuit because the capacitor is charged through 2 resistors in series and discharged through one. The Frequency is given by,

f = 1.46 / [(R1 + 2R2)C]  (8.7)

Figure 8.33 Oscillator with Pulse Train Output.

For a verbal description click here.

Figure 8.34 Oscillator with Square Wave Output.

For a verbal description click here.

The circuit of figure 8.34 will solve this problem. When the capacitor is charging the diode effectively shorts out R2, causing the capacitor to charge through R12 alone. If the circuit is operated from 5 volts it will most likely be necessary to make R1 one 5% step less than R2 to account for the effect of the forward voltage drop across the diode. If the resistors are the same value the frequency is given by,

f = 0.730 / RC  (8.7)

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

8.11 Problems.

  1. Convert 1110111 to decimal.

  2. What is the sum of 101011 and 1101?

  3. What are the names of the gates whose truth tables are given here?

    (a)
    A | B | C | OUTPUT
    0 | 0 | 0 | 1
    0 | 0 | 1 | 1
    0 | 1 | 0 | 1
    0 | 1 | 1 | 1
    1 | 0 | 0 | 1
    1 | 0 | 1 | 1
    1 | 1 | 0 | 1
    1 | 1 | 1 | 0

    (b)
    A | B | C | OUTPUT
    0 | 0 | 0 | 1
    0 | 0 | 1 | 0
    0 | 1 | 0 | 0
    0 | 1 | 1 | 0
    1 | 0 | 0 | 0
    1 | 0 | 1 | 0
    1 | 1 | 0 | 0
    1 | 1 | 1 | 0

  4. Write the truth table for the circuit of Figure 8.35. Suggestion: Make columns in your truth table for the outputs of gates 1, 2 and 3. These tree columns will then be the inputs for gate 4.

    Figure 8.35 Combinational Logic Circuit For Problems 4 and 5.

    For a verbal description click here.

  5. Write the Boolean algebra expression for the circuit of Figure 8.35. Do not attempt to simplify it.

  6. Convert Expression 8.1 into NAND gates.

  7. Reduce the expression below to all NAND functions.

    small a = A and not B and not C and not D or, not A and not B and C and not D.

  8. Add direct Set and Clear inputs to the master-slave R-S flip-flop of Figure 8.18. Tell what the states of these inputs must be for normal operation and what state will cause a set or clear. You may add inputs to any of the gates if necessary.

  9. What is the largest number that a 13-bit binary counter can contain? Express your answer in decimal without using exponents.

  10. If the input frequency to a 12-bit binary counter is 3,579,545 hz, what is the output frequency?

  11. A frequency divider consists of a divide by 5 module followed by a divide by 7 module which is followed by a divide by 13 module. What is the division ratio of the entire system?

  12. In an 8-digit frequency counter the decimal points are to be turned on and off by circuitry within the counter chip. If the display is multiplexed, how many pins are required to connect the display to the counter IC?

  13. When a 555 timer is used as a monostable what should be the value of C to give a 1 second pulse if the resistor is 150 k ohms?

  14. When a 555 timer is used as an oscillator without a diode what should be the value Of the capacitor to give a frequency of 1 hertz if R1 = R2 = 220 k ohms?

  15. When a 555 timer is used as an oscillator with a diode what should be the value Of the capacitor to give a frequency of 1 hertz if R1 = R2 = 330 k ohms?

Back to Fun with Transistors.
Back to Fun with Tubes.
Back to Table of Contents.
Back to top.

8.12 Answers to Problems.

  1. 119

  2. 111000

  3. (a) NAND, (b) NOR.

  4. Truth table.

    A | B | C | OUTPUT
    0 | 0 | 0 | 0
    0 | 0 | 1 | 1
    0 | 1 | 0 | 0
    0 | 1 | 1 | 0
    1 | 0 | 0 | 1
    1 | 0 | 1 | 0
    1 | 1 | 0 | 0
    1 | 1 | 1 | 1

  5. The unsimplified expression is,

    For a verbal description click here.

  6. The NAND gate expression is,

    For a verbal description click here.

  7. The answer is...

    For a verbal description click here.

  8. For normal operation both SET and CLR must be high. Pulling the SET input low will set the flip flop and pulling the CLR input low will clear it.

    For a verbal description click here.

  9. 8191.

  10. 873.912 Hz.

  11. 455

  12. 16.

  13. 6.06 micro farads.

  14. 2.21 micro farads.

  15. 2.21 micro farads.


Chapter 9   Digital Instruments.

9.1  Frequency Counter.
9.2  Digital Multimeter.
9.3  Frequency Synthesizer.
9.4  Problems.
9.5  Answers to Problems.

Chapter 9

Digital Instruments.

If you were asked to name something in which digital circuits are used you would likely answer "a digital computer". Combinational logic is certainly used in a digital computer. The subject of computers is one which can occupy a course of its own. There is not time or space here to study computers. There are certain laboratory instruments which employ digital circuitry but which are not computers. These instruments do not require connection to a computer for operation and so are called "stand alone" digital instruments. Three examples which we will look at in this chapter are the frequency counter, the digital multimeter and the frequency synthesizer.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

9.1 Frequency Counter.

Figure 9.1 is the block diagram of a basic frequency counter. This circuit is not intended as a construction project. If you were inclined to build a frequency counter, you would need more details. This circuit contains all of the essential parts for understanding the operation of a frequency counter.

Figure 9.1 Basic Block Diagram of a Frequency Counter.

For a verbal description click here.

The input feeds to a buffer which is a circuit with a high input impedance and a low output impedance. This is an analog amplifier circuit which must have a bandwidth equal to that of the counter circuits. The buffer may or may not have a voltage gain greater than unity.

After the input signal is buffered and possibly amplified, it is necessary to form it into a succession of logic highs and lows to be counted by the BCD counters. What must be done is to form the input signal into a square wave which has a low level of 0 volts and a high level of 5 volts. A comparator might be used for this purpose but there is a problem. Noise is always present. A comparator will amplify the noise and instead of a clean square wave its output would be a wave which looks to be a square wave but a closer look reveals that instead of one transition, the voltage makes several jumps from 0 to 5 volts and back again, before settling down on one or the other. Logic circuits respond so fast that they would count these extra transitions as if they were cycles of the input signal. The result would be that the counter would read several times the actual frequency.

The device which is required is called a Schmitt trigger. To explain what a Schmitt trigger does let us look at a specific example, namely the TTL Schmitt trigger. The specifications for such a circuit give its "positive-going trigger voltage VT+" as 1.7 volts and its "negative-going trigger voltage VT-" of 0.9 volts. Suppose the input voltage starts out at zero. Because the circuit is an inverter, the output will be a logic high. As the input voltage is slowly increased, nothing happens until the input voltage reaches 1.7 volts. At this input voltage, the output suddenly switches (in about 20 ns) to a logic low. Further increases in the input voltage have no additional effect. As the voltage is slowly decreased the 1.7 volt point is crossed without anything happening. Nothing happens until the input voltage gets down to 0.9 volts at which point the output switches to a logic 1. As long as the peak-to-peak amplitude of the noise is less than 0.8 volts the output of the Schmitt trigger will switch only once for each slope of the input wave. The resulting output is a clean square wave.

There are also Schmitt triggers in the CMOS logic family. For these VT+ = 2/3 VCC and VT- = 1/3 VCC. The difference between VT+ and VT- is called the hysteresis of the Schmitt trigger. If the input voltage is between VT+ and VT- the state of the output depends on whether the voltage came down from above or up from below. In other words the state depends on the history of the circuit. Hence the name hysteresis.

CMOS has a larger hysteresis than TTL and, therefore, greater immunity to noise. However, CMOS is not as fast as TTL, which means that it will not count as high a frequency as will TTL.

The next item in the diagram is a NAND gate. Now a NAND gate is just a NAND gate but the other signal to the gate requires some explanation. First of all remember that A NAND 0 = 1 and A NAND 1 = A. Inverting the signal will not change its frequency. When the signal from the flip-flop is 1 the input signal is passed to the counter circuits and when the signal from the flip-flop is 0 the gate is closed and the input signal is not passed to the counter circuits.

The 1 MHz quartz crystal oscillator gives a very precise frequency. This frequency is divided by 1,000,000 to give a very precise 1 hertz frequency. The flip-flop has its J and K inputs high and so will change states on every negative-going edge of the clock input. Thus the Q output will be high for 1 second and low for 1 second. The counter circuits count the total number of cycles and the gate is open for precisely 1 second; so the counter is indicating the number of cycles per second, which is the frequency in hertz.

The not Q output of the flip-flop is fed to the counter circuits and signals when to load the count into the display memory and reset the counter to zero. The not Q signal is not used directly for strobe and reset. It is used to trigger delay circuits, one shots, which perform the strobe and reset in the proper time sequence.

The time that the gate is open does not have to be 1 second. It could be 0.1 second or 0.01 second or anything else. Most counters have a switch to allow the user to select the desired gate time. The proper decimal point lights up in the display along with an additional indicator to tell the user whether the number should be interpreted as hertz, kilohertz or megahertz.

The reasons for having different gate times are resolution and sample rate. If a 1 second gate time is used the reading will be to the nearest hertz which is the resolution of the reading. In some measurements the user may not desire to know the frequency to such precision. The frequency source may be so unstable that the units of hertz are a random number generator. In such cases it is usual to use a shorter gate time to get rid of the insignificant digits of the reading. A shorter gate time gives faster readings. A gate time of 10 seconds gives 0.1 hertz resolution but gives a reading every 20 seconds. A 1 second gate gives a reading every 2 seconds and a gate time of 0.1 second gives 5 readings per second. The gate time chosen depends on how much precision is desired and how impatient the user is.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

9.2 Digital Multimeter.

The digital multimeter (DMM) uses a combination of digital and analog circuits to measure voltage, current and resistance with great accuracy. All of the individual circuits have been discussed earlier in this text.

The basic measurement circuit of a digital multimeter is the dual slope integrator, which is a voltage measuring device. In most DMMs (digital multimeters) the basic voltmeter circuit has a full-scale range of 0.2 volts (200 millivolts). Voltage dividers are used to give additional ranges of 2, 20, 200 and 2,000 volts full-scale.

For measuring current a series of shunt resistors is connected across the basic voltmeter. The usual ranges are 200 uA, 2 mA, 20 mA, 200 mA and 2 A. Some DMMs have a 20 amp range as well.

AC voltage and current may be measured using most DMMs. An absolute value amplifier is used to convert the basic DC voltmeter to a basic AC voltmeter. An RC network is used as an averaging circuit and so the voltmeter is an average responding voltmeter. The gain of the amplifier is adjusted so the meter will indicate RMS if the input is a sine wave.

More recent DMMs employ a true RMS circuit to convert the AC to DC. When using such meters the reading will always be true RMS regardless of the wave form.

In order to measure resistance the basic DC voltmeter is used to measure the voltage across the unknown resistor while a constant current source supplies current to the unknown. The usual ohmmeter ranges are 200 ohms, 2 k ohms, 20 k ohms, 200 k ohms, 2 M ohms and 20 M ohms. For each of these ranges the value of the current source will be 1 mA, 100 uA, 10 uA, 1 uA, 100 nA and 10 nA, respectively.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

9.3 Frequency Synthesizer.

Some types of laboratory measurements require a very stable and accurate frequency. Quartz crystal oscillators provide very stable and accurate frequencies but the frequency is determined when the crystal is manufactured and, if it is desired to change the frequency, a new crystal must be ordered.

There are various oscillator circuits whose frequencies can be varied by means of variable resistors, capacitors, or inductors, but variable frequency oscillators (VFOs) are not as stable over time as quartz crystals. If accurate frequency settings are desired, a frequency counter must be used in conjunction with the VFO.

The use of a frequency counter solves only half of the problem. VFOs drift in frequency. Drift is caused by changes in temperature and humidity, component aging, minute changes in the power supply voltage (no regulator is ever perfect) and other factors which seem to defy scientific explanation. Put a VFO in an environmental chamber, let it warm up for weeks or even months, operate it from an ultra precision power supply and it will never stop drifting.

Until the age of modern electronics the choice had to be either a fixed frequency and stable crystal oscillator or an adjustable frequency and drifting VFO. A circuit known as the frequency synthesizer is capable of combining the frequency agility of a VFO with the stability of a quartz crystal.

First of all a frequency synthesizer is not a musical instrument. A music synthesizer is comprised of an entirely different set of circuits. A frequency synthesizer can produce the musical scale but it can also produce any frequency in between the notes. The basic block diagram of a frequency synthesizer is shown in Figure 9.2.

Figure 9.2 Basic Block Diagram of a Frequency Synthesizer.

For a verbal description click here.

The circuit as drawn may also go by the name phase- locked loop. The V.C.O. is a voltage controlled oscillator. If the input voltage goes positive, the frequency of the V.C.O. will go up; if the input voltage goes negative the frequency will decrease. The phase detector has changed in recent years. It is now a digital circuit which can detect large frequency differences as well as small phase differences. If the frequency of input 2 is higher than the frequency of input 1, the output voltage of the detector goes negative. If the frequency of input 2 is lower than the frequency of input 1, the output voltage goes positive.

If the frequency of the V.C.O. is lower than it should be, the frequency of input 2 to the phase detector will be lower than the frequency of input 1 (the crystal oscillator) and the output voltage of the phase detector will go positive. This positive-going voltage will be applied to the V.C.O., which will cause its frequency to increase. The circuit will soon find an equilibrium point at which the frequency at input 2 ( fVCO / N ) is equal to the frequency of the crystal oscillator. After the frequency is correct, the circuit goes to work on the phase angle. If the phase at input 2 is leading the phase at input 1, the output of the phase detector will go slightly negative and the phase error will be corrected to zero.

The unfiltered output of the phase detector is a series of positive or negative-going pulses whose width is proportional to the phase difference between the two input signals. If the phase angle could come to exactly zero the output of the phase detector would be an open circuit all of the time. (The output has a low impedance during the pulses but is an open circuit between pulses.) Nothing in this world is ever exact or perfect. There will always be some AC output from the phase detector. The RC network which is connected between the phase detector and the V.C.O. serves the purpose of filtering out most of the AC component of the output of the phase detector.

The filter requires two resistors in order to make the loop stable. An unstable loop will cause the frequency of the V.C.O. to jump around instead of locking on to the frequency of the crystal oscillator. Typical values for R1 and R2 are 1 M ohm and 100 k ohms, respectively. The value of the capacitor may range from 0.01 uf to 10 uf. If a given loop is unstable, R2 should be temporarily replaced by a resistor substitution box and the value "played with" until the loop is stable. The capacitor should be as large as possible consistent with the minimum lock-in time of the loop.

The frequencies at inputs 1 and 2 of the phase detector will always be equal. Therefore, if the frequency of the crystal oscillator is fR and the frequency of the V.C.O. is fO, then the frequency of the V.C.O. is given by

fO = N fR  (9.1)

The divide by N block is a variable modulus counter which is usually programmed by means of thumb-wheel switches. Because N is restricted to integer values, the smallest step in frequency which is possible is the frequency which is applied to input 1 of the phase detector. The smallest step is the resolution of the frequency synthesizer.

If a crystal cannot be obtained in a low enough frequency for the desired resolution the output of the oscillator may be divided by L as shown in Figure 9.3. The output frequency is now given by

fO = fR N / L  (9.2)

The resolution is now fR / L.

Figure 9.3 Frequency Synthesizer Circuit.

For a verbal description click here.

If the resolution is to be less than one hertz the input to the phase detector must also be less than 1 hertz. The required value of C in the loop filter is so large that it takes a very long time for the loop to lock in again after the value of N has been changed. Another way to get fractional hertz changes is to insert yet another divider in the circuit also shown in Figure 9.3. The divide by M circuit is a fixed modulus divider which divides the frequency of the V.C.O. before it is delivered to the output terminal. The output frequency is given by,

fO = fR N / (L M)  (9.3)

The resolution is fR / (L M).

Example 9.1.

In a synthesizer similar to Figure 9.3 the frequency of the crystal oscillator is 100 kHz, L = 5,000, M = 400 and 10 is less than N is less than 10,000. What are (a) the frequency range and resolution of the output and (b) the frequency range of the V.C.O.?

Solution:

The frequency at input 1 of the phase detector is 100 kHz / 5,000 = 20 Hz. The frequency at input 2 is also 20 Hz and so the frequency of the V.C.O. ranges from 10 x 20 Hz to 10,000 x 20 Hz = 200 Hz to 200 khz, which is the answer to part (b). The output frequency is the V.C.O. frequency divided by 400, which is 200 Hz / 400 to 200 kHz / 400 = 0.5 Hz to 500 hz, which is the first part of (a). The smallest frequency step for the V.C.O. is 20 Hz. The smallest step for the output is 20 Hz / 400 = 0.05 hz.

The output will go from 0.5 Hz to 500 Hz in 0.05 Hz steps. The V.C.O. must be capable of being tuned from 200 Hz to 200 kHz.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

9.4 Problems.

  1. A frequency counter has an 8 digit display and any one of the decimal points can be illuminated. If the gate time is 100 us and the readout is in MHz, where should the decimal point be placed. Number the digits from left to right and state which two the decimal point is between.

  2. A DMM uses the 200 mV range to measure current. What resistor should be used as a shunt on the 20 mA range?

  3. A DMM uses the 2 volt range for the 200 ohm range. What is the constant current for this range?

  4. In a synthesizer similar to Figure 9.3 the frequency of the crystal oscillator is 2 MHz, L = 40,000, M = 5,000 and 45,000 is less than N is less than 75,000. What are (a) the frequency range of the V.C.O and (b) the frequency range and resolution of the output?

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

9.5 Answers to Problems.

  1. Between 6 and 7.

  2. 10 ohms.

  3. 10 mA.

  4. (a) 2.25 to 3.75 MHz. (b) 450 to 750 Hz in 0.01 Hz steps.


Appendix C.

Transistor and IC Packages.

If one is going to do laboratory experiments or do it yourself construction projects, one must know how pins on various ICs and transistors are designated. There are literally hundreds of packages and one is not likely to run into most of them. Only the most commonly found packages are covered here.

On the left in the photo are an 8-pin and a 14-pin Dual Inline Package, DIP. The DIP comes in 6, 8, 14, 16, 18, 20, 24, 28, and 40-pin versions. The 24-pin and higher are twice the width of the smaller ones. Digital ICs, except for microprocessors, and analog devices, except for high input impedance amplifiers, come in DIPs. Military grade and wide temperature range industrial grade devices do not come in this plastic package.

Next is the TO-3 power package. Two are shown to reveal their appearance from top and bottom. Power transistors up to 200 watts and power ICs come in this style of package.

Next is the TO-5 package. Some of the best known early transistors, such as the 2N404 and 2N1302 came in this package. Premium quality ICs also come in the TO-5 configuration with 8, 10, or 12 pins, depending on the application.

Next is the ubiquitous TO-92 package. It is very inexpensive to manufacture and the low cost transistors in this package were, in part, responsible for the transistor boom of the 70s. 3-terminal voltage regulators are also sold in this package. They are limited to 3 pins.

Lastly is the almost as ubiquitous TO-220. Power transistors up to 50 watts and IC voltage regulators come in this package. It is sometimes seen with 4 or 5 pins.

The DIP.

IC data books give pin numbers and the user of such circuits must know where to start and which way around to number the pins. The figure below shows the pin numbering convention for the DIP.

There are two types of packages. Part a shows the most common which has a small notch cut in the end between pins 1 and the highest numbered pin. The pins are counted counter clockwise as viewed from the TOP.

Part b shows a package used by Motorola. Pin 1 is marked with a dot and the pins are numbered counter clockwise as viewed from the TOP.

While the IC packages shown above are viewed from the top, these are viewed from the bottom. Some of the most common configurations will be given below but the student or experimenter should always consult the data sheet, or a data book for the particular transistor being used.

TO-3.

A drawing of the TO-3 package is not necessary. The photo clearly shows the letters E and B next to the pins. The metal case is the collector terminal.

In the case of an IC voltage regulator, the LM-309K to be specific, the pin on the right is the input and the left pin is the output. Backward? I think so but I didn't design it. The case is the common or ground. Always check the data sheet before wiring the circuit.

TO-5.

For most transistors in TO-5 packages the configuration is,

1 - Emitter,
2 - Base,
3 - Collector.

Always consult the data sheet for the particular transistor. The metal case may be connected to the base, the collector, or to none of the elements.

TO-92

For most bipolar transistors such as the 2N3904 and 2N3906 the pin configuration is,

1 - Emitter,
2 - Base,
3 - Collector.

For the very popular MPF102 field effect transistor the pin-out is,

1 - Drain,
2 - Source,
3 - Gate.

For the positive low power voltage regulators, such as the 78L12, the pinout is,

1 - Output,
2 - Ground,
3 - Input.

For the negative low power voltage regulators, such as the 79L12, the pinout is,

1 - Ground,
2 - Input,
3 - Output.

Always consult the data sheet for the particular transistor or IC you are using.

TO-220.

For a bipolar transistor the pinout is,

1 - Base,
2 - Collector,
3 - Emitter.

For a positive voltage regulator such as the 7812 the pinout is,

1 - Input,
2 - Ground,
3 - Output.

For a negative voltage regulator such as the 7912 the pinout is,

1 - Ground,
2 - Input,
3 - Output.

Always consult the data sheet for the particular transistor or IC you are using.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.


Chapter 4A   Triode Vacuum Tubes.

4A.1  The Triode (3 Element) Vacuum Tube.
4A.2  Triode Amplifier Graphical Analysis, Load Line.
4A.3  Triode Amplifier Small Signal Analysis.
4A.4  Resistance Coupled Amplifier Charts.
4A.5  The Miller Effect.
4A.6  Cathode Follower.
4A.7  Grounded Grid Amplifier.
4A.8  Cascode Amplifier.
4A.9  Problems.
4A.10 Answers to Problems.

Chapter 4A.

Triode Vacuum Tubes.

This chapter was not a part of the original textbook. Throughout most of my teaching career I assumed that the vacuum tube was dead. Somehow it kept coming back and saying "the rumors of my death are greatly exaggerated." My department head would not have looked kindly on the inclusion of a chapter on tubes because they were considered by physicists to be obsolete technology and not worthy of being taught in a modern physics department.

After retiring I decided to put up a web site devoted to tube technology and see how much attention it would attract. I was amazed by the response. It seems that the venerable old boy just won't roll over and die the way some would like him to do. He won't even play dead. Because this book is linked from both a tube and transistor site I need to put in a good chapter on tube theory and practice. So here it is.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

4A.1 The Triode (3 Element) Vacuum Tube.

The tri part of triode means 3. There are three elements in a triode, the cathode, grid, and plate or anode. The heater doesn't count since it doesn't take part in the operation, it just provides the heat.

history.

In the United States Lee De Forest is generally credited with inventing the triode. His claim is under considerable dispute particularly in the United Kingdom. Since I wasn't there I don't know what happened but I have my suspicions. Court records of a case of De Forest versus Armstrong make it clear that De Forest didn't really understand the operation of the tube. That doesn't prove that he didn't invent it, maybe he stumbled onto it by accident. Maybe he ripped off someone else. Even though it all happened barely 100 years ago the mists of history have already settled over the facts and likely we will never know. We have the three element tube even if we aren't quite sure who to thank for it.

How it is made.

Photographs of the early Audions show a big spherical bulb with a filament like that in Edison's light bulb. Next to the filament is a grid which looks like hardware cloth (a very course window screen) and a flat plate. Modern triodes are usually cylindrical in construction with the filament or heater/cathode at the center, the grid surrounding it and the plate surrounding all as shown in Figure 4A.1 below.

Figure 4A.1 (a) filament type triode
and (b) heater type triode.

For a verbal description click here.

In these cylindrical tubes the grid takes the form of a helix, like a cork screw or spring. If you happen to have a 6AS7G or 6080WA in your tube collection you can see this construction. The plate instead of being continuous has an opening that runs the length of the cylinder and the shiny grid is clearly visible. There is a 9 pin miniature tube with the same construction but I don't know its number. I saw it once while looking for another tube and I didn't write it down.

How it works.

I've made that joke too many times already. Electrons are emitted from the cathode exactly the same as in a diode. They collect in a space charge around the cathode and protect it from heavy positive ions that could do serious damage. In normal operation the grid is made negative with respect to the cathode and never goes positive. (Except in radio transmitters). The grid does not attract electrons and because its wires are very thin, in modern tubes, few electrons run into it by accident. The electric field of the grid repels the negatively charged electrons and limits the number that can pass through to the plate. If the grid is made negative enough no electrons at all can get through. As the grid is made less negative it lets more and more electrons through. Figure 4A.2 below shows this by animation.

Figure 4A.2 Animation showing the
operation of a triode vacuum tube.

For a verbal description click here.

I know the animation is fascinating but do your best to tear yourself away from it and continue reading. Although the heater connections are not shown it is always assumed they are connected to the proper source of voltage for the heater. As the input signal swings positive the grid becomes less negative. This allows more electrons to get through to the plate which is an increase in plate current. The voltage drop across the plate resistor becomes greater and because the B+ end of the resistor is at a fixed voltage the plate end becomes less positive. You can see right off that as the grid voltage goes up the plate voltage goes down. This is the nature of this type of amplifier circuit. When the input signal swings negative the more negative grid cuts down the number of electrons getting through and the plate current is reduced. This causes the drop across the plate resistor to decrease and the plate voltage gets closer to the B+ voltage, higher. Neither the grid voltage nor the plate voltage gets all the way to zero. If it should, the amount of distortion would be very high.

I have found in teaching amplifiers, common emitter as well as common cathode, that students often have trouble grasping the concept of increasing current resulting in decreased voltage. This in spite of demonstrations and laboratory experiments. Let's try using a bungee jumper as an analogy.

Cartoon drawing of bungee jumper.

Figure 4A.3 Bungee Jumper Suspended From a Bridge.

For a verbal description click here.

This bungee jumper is in a slightly different situation than all other jumpers. There is an electric current flowing through the bungee cord. The greater the current, the longer the cord gets. As the current increases, the cord gets longer and the jumper gets closer to the ground. As the current decreases, the cord gets shorter and the jumper goes higher. So as the current goes up and down, the hapless jumper goes down and up. If he were to touch the ground or the bridge, his distortion level would be considerably increased.

Now remember that the current in a tube is in phase with the grid voltage. As the grid voltage moves up, so does the current. As the above analogy shows the plate voltage is out of phase with the plate current. And that is why a common cathode amplifier inverts the signal.

How it is Used.

Vacuum triodes are used primarily to amplify AC signals. To amplify means to make it bigger. The signals to be amplified are most likely to be in the audio range. Triodes are almost never used to amplify low power radio frequencies such as in a radio receiver. They are often found in high power radio transmitters, but that's another story.

An amplifier uses the principle shown in the animation above to increase the voltage of an AC signal. Although the voltmeters in the animation are shown deflecting by the same amount, the voltage in the plate circuit is actually much larger than the voltage in the grid circuit. This is what is meant by amplification.

The tube in the animation is biased by a battery in the grid circuit.*

* In the early days of tubes they were mainly used in radio receivers. Three different batteries were required to power up a radio. These were designated A, B, and C. The A battery lit up the filament, the B battery supplied the plates of the tubes with positive voltage and the C battery supplied the grids of the tubes with negative bias. While A is no longer used as a symbol for the filament or heater supply, (except in portable radios), the terms B and C are still very much with us as will be seen later in this chapter.
Figure 4A.4 shows a schematic diagram of a common cathode triode amplifier.

Figure 4A.4 A cathode biased resistance coupled amplifier stage.

For a verbal description click here.

The circuit above is a practical amplifier stage. The B battery is not shown but it is replace by a connection symbol labeled Ebb. The C battery appears to be completely missing but instead of battery bias the tube uses what is often called self bias or cathode bias.

Cathode Bias.

Instead of the bias being supplied by an external battery it is developed in the cathode circuit of the tube or to think of it another way by the tube itself.

Let's assume that a tube needs the grid to be at -2 volts. That means that the cathode is at zero volts and the grid is at -2 volts. Now suppose we add 2 volts to both values. The grid voltage becomes 0 volts and the cathode voltage becomes +2 volts. The grid is still -2 volts away from the cathode which is required. Think about it. Let your left hand be the grid voltage and your right hand be the cathode voltage. Place your right hand even with the table top at the edge (zero inches) and your left hand 2 inches below your right (-2 inches). Your left hand is below your right hand. Now move both hands up 2 inches. Your left hand is now even with the top of the table (zero inches) and your right hand is 2 inches above it (+2 inches). Your left hand is still 2 inches below your right hand.

To place the cathode of a triode a small number of volts positive you place a resistor in the cathode circuit as shown in Figure 4A.4.

The notation used in this figure is consistent with the resistance coupled amplifier charts found in all tube manuals. Rc is the grid resistor, why not Rg? It's a throw back to the C battery which once supplied the grid bias in early radios. RK and CK are the cathode resistor and capacitor. Yes, they knew that cathode begins with a C but C was already used. Rb is the plate resistor, another throw back to the B battery. CC is the coupling capacitor and Rcf is the grid resistor of the following tube. The plate supply voltage is labeled Ebb. Why Ebb instead of B+? In formal electrical engineering writing the voltage on a tube element is notated as Eb for the plate and Ec for the grid. There is always a resistor between the supply voltage and the element. The supply voltage is distinguished from the voltage on the element by doubling the letter. For example, Ebb, and Ecc just the way it is done in transistors. Hmmm, wasn't it the other way around?

The positive voltage on the cathode is developed by the cathode current flowing through the cathode resistor. The tube, RK, and Rb constitute a simple series circuit. The grid does not take or give any appreciable current.

The capacitor in the cathode circuit is to keep the DC voltage constant. Without this cap the voltage can vary and reduce the gain of the amplifier. This gain reduction is accompanied by a reduction of distortion so in hi-fi circuits the cap is often omitted. More about this later.

Triode Characteristics and Parameters.

The behavior of tubes is described in two ways. One is by a graph of voltages versus currents and the other is by three numerical values called plate resistance, transconductance, and amplification factor. A graph of plate characteristics for a 6SL7 is shown in Figure 4A.4 below.

Figure 4A.5 Plate Characteristics of a 6SL7.

For a verbal description click here.

The horizontal axis is the voltage between the plate and cathode, not the voltage between the plate and ground. The vertical axis is plate current, and the number labeling each curve is the voltage between the grid and cathode. We will learn in the next section how to use this graph to design amplifiers and predict the behavior of existing amplifiers.

In section 4A.3 we will learn how to use the tube parameters to calculate gain without using the graph. Although we are about to pick parameter values off the graph these parameter values can be looked up in a tube manual. The purpose of picking them from the graph is to illustrate how they are defined.

Plate Resistance.

The plate resistance is NOT the resistor in the plate circuit of a tube. It is a parameter of the tube that is a voltage divided by a current which means its units are ohms. The plate resistance is symbolized by rp. The lower case r indicates that it isn't a real resistor. The plate resistance is defined as,

rp = change in Eb / change in Ib,  with Ec constant.  (4A.1)

Where Eb is the voltage between plate and cathode, Ib is the plate current, and Ec is the voltage between grid and cathode. In the graph above you take the change in plate voltage and current along one of the grid voltage lines. It is shown as being taken at two locations. At one place the voltage goes from 180 to 220 volts while the current goes from 2.33 mA to 3.25 mA. This works out to,

rp = (220 - 180 v) / (3.25 - 2.33 mA) = 43.5 k ohms.

The other point is,

rp = (420 - 380 v) / (2.91 - 2.12 mA) = 50.6 k ohms.

The tube manual states the parameters at a plate voltage of 200 volts and a current of 2.3 mA. Compare the results from the graph with the tube manual value of 44.0 k ohms. Not bad.

Amplification Factor.

The amplification factor is symbolized by the Greek letter μ and is defined as follows.

μ = change in Eb / Ec  with Ib constant.  (4A.2)

Where Eb is the voltage between plate and cathode, Ib is the plate current, and Ec is the voltage between grid and cathode. The amplification factor must be taken along a horizontal line which is constant current. The line must start on one grid voltage line and end on another one. The two values around 200 volts and 400 volts are,

μ = (131 - 271 v) / (0 - [-2] v) = -70.

μ = (328 - 400 v) / (-3 - [-4] v) = -72.

Although the tube manual never states μ as a negative number, it needs to be one for the calculations that will be performed in section 4A.3.

Transconductance.

The transconductance is redundant because,

Gm = μ / rp  (4A.3)

Where Gm is the transconductance usually given in micro mhos. Transconductance exists because the calculations on pentode tubes become easier when it is used instead of μ. The definition is,

Gm = change in Ib / change in Ec  with Eb constant  (4A.4)

From the curves above the values are,

Gm = (4.61 - 2.8 mA) / (0 - [-1]) = 1,810 micro mhos.

Gm = (3.7 - 2.12 mA) / (-3 - [-4]) = 1,580 micro mhos.

The tube manual value is 1600 micro mhos. Calculating Gm from equation 4A.3 gives 1,609 and 1,423 micro mhos.

Parameter values are highly dependant on the operating point, plate voltage and current. If we had picked off values from lower down on the graph, say 0.5 mA, the parameters would have been quite far from the stated tube manual values. For use in calculations the most accurate parameter values can be obtained by picking them off the graph at the actual operating point.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

4A.2 Triode Amplifier Graphical Analysis, Load Line.

Some find graphical analysis to be too tedious for their taste. However, if curves are available, it is the most accurate method of predicting the DC operating point and AC gain of a resistance coupled amplifier.*
* The resistance coupled amplifier charts which we will cover in 4A.4 are much easier and just as accurate but they are restricted to one or two values of plate voltage and a few values of resistance. Graphical analysis can give accurate results over a wide range of plate supply voltages and load resistances.
The set of curves for the 6SL7 in figure 4A.6 show a complete graphical analysis. Resistance values were taken from the often mentioned resistance coupled amplifier charts to provide a standard of comparison. The data from the RCAC are tabulated along with the results of the graphical analysis at the end of this section.

If your screen is set to less than 1280 by 1024 this graph will overflow your screen. Most of the action is in the lower left corner so you shouldn't need to use your scroll bars very much.

Plate curves with load lines.

Figure 4A.6 Plate Characteristics with Graphical Solution.

For a verbal description click here.

DC Load Line.

Lower right end of DC load line = Ebb  (4A.5)

Upper left end of DC load line = Ebb / Rb  (4A.6)

We start with the value of load resistor and plate supply voltage. They are 100 k ohms and 250 volts respectively. The load line runs from zero current and full Ebb* and zero voltage and the current that would flow if the full value of Ebb was applied across the load. I = V / R = 250 / 100 k ohms = 2.5 mA. So we draw a line from 250 volts to 2.5 mA as shown by the red line in the figure.

Ignore the vertical red line and the magenta line that intersects with it. These are used in a later section.

With a 100 k ohm resistor in the plate circuit the tube can operate anywhere along the load line. For example, if we set the plate current to 1.5 mA the plate voltage, across the tube not the resistor, is 105 volts. If we set the plate current to 1 mA the voltage will be 153 volts. If we set the plate current to 0.5 mA the voltage will be 200 volts. If we were to use fixed bias on the tube we could operate it anywhere we wanted to on the load line but never off of it.

Bias Line.

If the tube is self biased, that is if a resistor is placed in the cathode, we would like to know where the tube will operate. We can do that by placing a bias line on the graph. Say we are using a 1.8 k ohm resistor in the cathode. If we placed 1 volt across the 1.8 k ohm resistor the current would be 0.555 mA. We mark this point on the -1 volt grid voltage curve. Now if we placed 2 volts across the 1.8 k ohm resistor the current would be 1.111 mA. We mark this point on the -2 volt grid voltage line and then connect the two points with a magenta line. Where the bias line crosses the load line is where the tube will operate. This is in remarkable agreement with the data from the RCAC. The operating point is often called the quiescent point or for short, the Q-point.

AC Load Line.

There is one more line on the graph to be explained. It is the green line which is an AC load line. The signal on the plate of the tube is of no use to us if we can't get it off and do something with it such as send it to the grid of another tube. That next tube will, and must, have a resistor from its grid to ground. A capacitor couples the signal from the plate of our tube to the next one. Assume the resistor in the grid of the next tube is 270 k ohms. The AC load on the tube is not 100 k ohms but the parallel combination of 100 k ohms and 270 k ohms which is 72.97 k ohms. We must place another line on the graph that has a slope of 1/72,970. That can be a little tricky. We start by finding the lower right end of the line.

Lower right end of load line = EbQ + IbQ x AC Load  (4A.7)

Where EbQ is the Q-point plate voltage, IbQ is the Q-point current, and AC Load is the parallel combination of the plate resistor and the following stage's grid resistor. So the lower right end of the AC load line is,

L-R AC L-L = 157 v + 0.93 mA x 72.97 k ohms = 225 volts.

Start the line at the bottom of the graph at 225 volts and make sure it passes through the point where the load line and bias line intersect. You only need to extend it as far as the zero grid voltage curve.

Voltage Gain.

The gain is the change in plate voltage divided by the change in grid voltage along the AC load line. The Q-point is between the -1 and -2 volt grid voltage lines so we might as well use these. At -1 volt the plate voltage is 130 volts. At -2 volts the plate voltage is 170 volts. The gain is (170 - 130) / (-2 - [-1]) = -40.

I did not precook this example. I did the numbers and let the chips fall where they may. I too am amazed at how close things came out. The RCAC data comes from laboratory measurements not graphical analysis.

There is no way to reliably evaluate distortion using the graphical method. It is possible to get a feel for it. Between Ec = 0 and -1 the plate voltage changes by 40 volts, between -1 and -2 40 volts, between -2 and -3 31 volts, and between -3 and -4 21 volts. We might be better off to operate the tube at higher current and lower voltage. We must not bias the grid so close to zero that it is driven positive. This will cause the operating point to shift on strong signals and there will be an audible recovery time after the peak.

Description | Symbol | Value From RCAC | Value From Graphic Solution
Plate Supply Voltage | Ebb | 250 Volts | --
Plate Load Resistor | Rb | 100 k ohms | --
Following Stage Grid Resistor | Rcf | 270 k ohms | --
Cathode Resistor | Rk | 1.8 k ohm | --
Plate Current | Ib | 0.917 mA | 0.93 mA
Grid Bias Voltage | Ec | -1.65 volts | -1.68 volts
Plate Voltage | Eb | 158.3 volts | 157 volts
Voltage Gain | AV | 40.0 | 40

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

4A.3 Triode Amplifier Small Signal Analysis.

The small signal calculations are based on the small signal model of a vacuum tube. The triode small signal model is shown in Figure 5 below.

Figure 4A.7 Small Signal Model of a Triode.

For a verbal description click here.

In science and engineering a model is something that represents a real system. It helps people working in the field to visualize the system more easily and make calculations based on the model that will predict the behavior of the real system. The triode tube with its resistors and power supply form a system and can be modeled.

As the figure above shows the model consists of a voltage source in series with a resistor. The resistor is symbolized with a lower case r because it is not a real resistor but a part of the model. The Greek letter μ stands for the amplification factor and rp for the plate resistance. These values can be looked up in a tube manual. If we combine the two parallel resistors Rb and Rcf into one and call it Rbc we can write some equations. The current in the circuit is,

I = -μ Vgk / (rp + Rbc)

The minus sign comes in because of the phase inversion of the amplifier. If the cathode is grounded then Vgk will be equal to Vin.

I = -μ Vin / (rp + Rbc)

The output voltage is,

Vo = I Rbc

Substituting I for I and dividing through by Vin gives,

VO / Vin = -μ Rbc / (Rbc + rp)

Remembering that the gain AV = VO / Vin we have the voltage gain of a triode amplifier.

Av = -μ Rbc / (Rbc + rp)  (4A.8)

Where Rbc is the parallel combination of Rb and Rcf as follows.

Rbc = Rb Rcf / (Rb + Rcf)  (4A.9)

Example 4A.1.

A 12AX7 has a plate load resistor, Rb, of 220 k ohms and the grid resistor of the following stage, Rcf, is 470 k ohms. Tube manual data on the 12AX7 gives Amplification factor = 100 and plate resistance = 80 k ohms. What is the gain of this 12AX7 amplifier

Solution:

First we calculate Rbc.

Rbc = Rb Rcf / (Rb + Rcf) = ( 220 k x 470 k ) / ( 220 k + 470 k ) = 150 k ohms.

Now we calculate the gain.

Av = -μ Rbc / ( rp + Rbc ) = -100 x 150 k / ( 80 k + 150 k ) = -65.2

Example 4A.2.

A triode tube is to be used as a single ended low power amplifier. The output transformer has a primary impedance of 5000 ohms. Think of Rb being 5 k ohms and Rcf as not present. Which of the following tubes will give the greatest voltage gain?

12AT7, Amplification Factor = 60, Plate Resistance = 10900
12AU7, Amplification Factor = 17, Plate Resistance = 7700
12AV7, Amplification Factor = 41, Plate Resistance = 4800
12AX7, Amplification Factor = 100, Plate Resistance = 80000

Solution:

The gain for each is given by,

Av = -μ Rb / ( rp + Rb )

For the 12AT7 it is,

Av = 60 x 5000 / ( 10900 + 5000 ) = -18.9

For the 12AU7 Av = -6.69
For the 12AV7 Av = -20.9
for the 12AX7 Av = -5.88

The 12AV7 comes in first with -20.9 and the 12AT7 is runner-up at -18.9. Notice that the 12AX7 with its impressive amplification factor of 100 comes in last at -5.88. A high amplification factor may not guarantee a high gain amplifier.

Removing the Cathode Bypass Capacitor.

If the cathode bypass capacitor is left out of the circuit, as shown in Figure 6 below, several things about the amplifier will change. The two most important are a reduction of gain and a reduction of distortion. The former is not good by itself but the latter is so good that it is worth the lost gain.

Figure 4A-8 A resistance coupled amplifier
stage with unbypassed cathode resistor.

For a verbal description click here.

Figure 4A-9 Equivalent Circuit of Resistance Coupled
Amplifier Stage with Unbypassed Cathode Resistor.

For a verbal description click here.

To derive the equation for the gain of the amplifier without a cathode bypass capacitor we must write loop equations around the loops in figure 4A.10.

We write the equation for the input loop up across the Vin generator, not shown, from G to K and back to ground across the cathode resistor.

Vin - Vgk + Ib Rk = 0  (4A.10.1)

Then we write the loop equation around the output loop starting at the cathode, up across the generator, around the loop through rp, Rbc, and Rk, back to the cathode.

-μ Vgk - Ib rp - Ib Rbc - Ib Rk = 0  (4A.10.2)

We want to eliminate Vgk between the two equations.

Vgk = Ib Rk + Vin  (4A.10.3)

Now we factor Ib out of the terms that contain only it.

-μ (Ib Rk + Vin) - Ib (rp + Rbc + Rk) = 0  (4A.10.4)

Now we multiply μ into the term on the left.

-μ Ib Rk - μ Vin - Ib (rp + Rbc + Rk) = 0  (4A.10.5)

Now we put the term containing Ib inside the parentheses.

-Ib (μ Rk + rp + Rbc + Rk) - μ Vin = 0  (4A.10.6)

Now we get Ib on the left side of the equation.

-Ib (rp + Rbc + Rk + μ Rk) = μ Vin  (4A.10.7)

Now we divide by the term that multiplies Ib and carry the minus sign over to the numerator.

Ib = -μ Vin / (rp + Rbc + Rk + μ Rk)  (4A.10.8)

Now we can write Vo = Ib Rbc. We substitute (4A.10.8) into this equation. We also factor Rk out of the two terms in the denominator that contain it.

Vo = -μ Vin Rbc / (rp + Rbc + Rk [1 + μ])  (4A.10.9)

Now we divide through by Vin and remember that AV = Vo / Vin.

Av = Vo / Vin = -μ Rbc / (rp + Rbc + Rk [μ + 1])  (4A.10.10)

Where μ is the amplification factor of the tube, rp is the plate resistance Rk is the cathode resistor and Rbc is the parallel combination of Rb and Rcf.

Example 4A.3.

A 12AX7 which is without a cathode bypass capacitor has a plate load resistor, Rb, of 220 k ohms, a cathode resistor, Rk, of 3300 ohms, and the grid resistor of the following stage, Rcf, is 470 k ohms. Tube manual data on the 12AX7 gives Amplification factor = 100 and plate resistance = 80 k ohms. What is the gain of this 12AX7 amplifier

Solution:

Without a cathode bypass capacitor the gain is given by,

Av = μ Rbc / (rp + Rbc + Rk [μ + 1])

Remembering from Example 4A.1 the parallel combination of Rb and Rcf = 150 k ohms and substituting all values gives,

Av = 100 150 k / (80 k + 150 k + 3300 x 101 ) = 26.6

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

4A.4 Resistance Coupled Amplifier Charts.

Probably the easiest way to design a resistance coupled amplifier is to use the resistance coupled amplifier charts found in most tube manuals. If you don't have one you can pick one up on eBay. At any given time there are several for sail and they usually don't cost an arm and a leg. Don't go for one from the 20s, 30s, 40s, or even the 50s. They might leave you a few limbs short. Manuals from the 1960s are usually available and go for $10 to $30. The values found in these charts have been arrived at experimentally rather than by calculation. When it comes to tubes that's often the best way.

Table with lots of numbers.

Figure 4A.10 Sample page from Sylvania Resistance Coupled Amplifier Chart.

No verbal description is available for this chart.

Yes, I do know how to rotate an image. When I tried reducing it to fit the width of a Windows 98 screen the text became unreadable. So I have kept it readable, big and turned on its side. Just turn your head to the left or download The image to your computer and rotate it yourself.

The only part that may need explaining is the zero bias section on the right.

Zero Bias.

An amplifier stage in which the cathode is grounded and there is no external source of bias is called a zero bias amplifier. The bias isn't really zero because the action of the tube will develop a small amount of bias. This is sometimes called contact bias because it is generated by electrons coming in contact with the grid.

The grid wires are thin and very few electrons strike them but there are billions of them passing by so even a small percentage is still a very large number. Electrons that strike the grid stick to it and give it a negative charge. If the grid resistor is made very large, say 10 meg ohms, the voltage on the grid will be almost a volt. Now, if the tube has been designed so this voltage is the optimum grid voltage, and some have been, the parts count of the amplifier stage can be reduced by two. A zero biased amplifier is shown in Figure 4 below.

Figure 4A.11 A zero biased resistance coupled amplifier stage.

For a verbal description click here.

This circuit is most commonly used in All American 5 radios but is also seen in hi-fi equipment. If the plate of a previous stage is coupled to a zero biased stage, as is often seen in magnetic phono preamps, a very low leakage capacitor must be used. A very tiny leakage in the capacitor would place a positive voltage on the grid. Even if there is nothing more than the wiper of a pot connected to the grid a DC blocking capacitor must be there to make sure that nothing upsets the bias voltage.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

4A.5 The Miller Effect.

Anytime any where you have two conductors separated by an insulator you have capacitance. The plate and grid in a triode tube have capacitance between them. Because the tube inverts the signal the capacitance appears to be much bigger than it actually is. Lets explain it with resistors first. In Figure 1a an AC generator is driving a single resistor. In Figure 1b There is another generator in the circuit that always does the opposite of the one on the left but 50 times greater.

Figure 4A.12 Illustration of the Miller Effect.

For a verbal description click here.

Let us derive a general equation for this situation. Say that E2 = A E1. Summing the voltages around the loop gives.

E1 - I R - A E1 = 0  (4A.11.1)

Solving this equation for E1 / I will give the effective resistance of the combination of the resistor and the second generator.

E1 / I = Reff = R / (1 - A)  (4A.11.2)

Where A is the factor that relates E2 to E1, R is the resistance of the resistor, and Reff is the effective resistance of R as seen by E1. In this particular case the value of A is -50. If we substitute R = 50 and A = -50 into (4A.11.2) we have,

Reff = 50 / 51 = 0.980 ohms.

If the generator at E1 is delivering 1 volt, the current through the resistor is I = 1 / 0.980 ohms = 1.02 amps. The 1 volt generator doesn't know about the 50 volt generator on the other end of the 50 ohm resistor. It doesn't know anything, it's just a stupid generator. All it knows is that when it puts out 1 volt it has to deliver 1.02 amps so it thinks it's driving a 0.98 ohm resistor. The second generator has made the resistor look 51 times smaller than it actually is. If a capacitor were to be substituted for the resistor its reactance would look 51 times smaller and since capacitance is inversely proportional to reactance the capacitor will look 51 times bigger.

The effective input capacitance of a triode amplifier is given by,

Cinp = Cin + Cgp (1 - Av)  (4A.11.3)

Where Cinp is the input capacitance of the amplifier, Cin is the tube manual value of input capacitance for the tube and Cgp is the given value of grid to plate capacitance. The value of Gain, A of the amplifier MUST be entered as a negative number. Notice that the factor (1 - A) switched from the denominator to the numerator. XC behaves the same as R but the capacitance is inversely proportional to XC. This causes the factor to be flipped.

Example 4A.4

In example 4A.1 we calculated the gain of a 12AX7 amplifier to be 65.2. The tube manual gives the input capacitance of the 12AX7 to be 1.6 pf and grid to plate as 1.7 pf. What is the effective input capacitance of this amplifier.

Solution.

Cinp = Cin + Cgp ( Av + 1 )

Cinp = 1.6 pf + 66.2 x 1.7 pf = 114 pf.

The Miller Effect is some what of a problem even at audio frequencies. The reactance of 114 pf at 10 kc is 140 k ohms. The effective output resistance of the 12AX7 amplifier we have been working with is the parallel combination of the tubes plate resistance, the plate resistor, and the following grid resistor. That works out to 52 k ohms. The upper 3 dB frequency is where Xc = R. If this tube stage were followed by an identical one the cutoff frequency would be f = 1 / (2 π R C ) = 1 / (2 π 52 k 114 pf ) = 26.8 kc. The response would be 1 dB down at approximately half of this frequency. The miller effect can become even more important at radio frequencies.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

4A.6 Cathode Follower.

The cathode follower has a number of properties that make it useful in electronics. It can have an input resistance in excess of 10 Meg ohms and an input capacitance of less than 2 pf contributed by the tube. Wiring capacitance will likely be about 5 pf.

The output impedance may be as low as 100 ohms. This makes it very useful when a high resistance source needs to drive a low resistance load.

The cathode follower has a voltage gain of slightly less than unity but it does have current gain which means it qualifies as an amplifier because it increases the power of the input signal. A simple cathode follower is shown in Figure 4A.13.

Figure 4A.13 Simple Cathode Follower.

For a verbal description click here.

As the input voltage goes positive the plate current increases which increases the voltage drop across RK. Since the lower end of RK is at ground potential the upper end will get more positive. The cathode can't go up by the exact amount that the grid did. If it did, there would be no net change in voltage between cathode and grid to make the plate current increase. The cathode voltage changes by a little less then the change in grid voltage. It's called a cathode follower because where ever the grid goes the cathode follows along just a little behind.

Voltage Gain.

Figure 4A.14 shows the equivalent circuit using the triode model. DC voltages and coupling capacitors are not shown in models so the plate is shown as being grounded.

Figure 4A.14 Equivalent Circuit of a Cathode Follower.

For a verbal description click here.

As was done earlier, we will use this model to find the gain. First we write the loop equation around the input loop. As we did above we sum the voltage rises starting at ground, going up through the Vin generator, down from grid to cathode, and then back to ground through Rk.

Vin - Vgk + Ib Rk = 0  (4A.12)

Then we start at the cathode and sum the voltages around the output loop.

-μ Vgk - Ib rp - Ib Rk = 0  (4A.13)

Solving (4A.12) for Vgk gives,

Vgk = Ib Rk + Vin  (4A.14)

Substituting (4A.14 into (4A.13) gives,

-μ (Ib Rk + Vin) - Ib rp - Ib Rk = 0  (4A.15)

Collecting terms and factoring out -Ib gives,

-Ib (μ Rk + Rk + rp) - μ Vin = 0  (4A.16)

Summing the voltage drops in a counter clockwise direction around the VO and Rk loop gives,

Vo + Ib Rk = 0  (4A.17)

Solving (4A.17) for -Ib gives,

-Ib = Vo / Rk  (4A.18)

Substituting (4A.18) into (4A.16) gives,

(μ Rk + Rk + rp) Vo / (Rk) - μ Vin = 0  (4A.19)

Solving (4A.19) for Vo / Vin gives,

Vo / Vin = Av = (Rk μ) / (Rk[μ + 1] + rp)  (4A.20)

If there was a load resistor, RL, connected across the output terminals in Figure 4A.13, The value of Rk to be used in equation 4A.20 would be the parallel combination of RK and RL. Note the case of the K in Rk and RK. The lower case k indicates the AC load while the upper case K is reserved for the DC load.

Example 4A.5.

Calculate the gain of a cathode follower with AC loads of, (a) 100 k ohms, (b) 10 k ohms, and (c) 1 k ohm. The tube is a 12AX7 which has a plate resistance of 80 k ohms and an amplification factor of 100.

Solution:

We use equation 4A.20.

Av = (Rk μ) / (Rk[μ + 1] + rp)

(a). Av = (100 k ohms x 100) / (100 k ohms x 101 + 80 k ohms) = 0.982

(b>. 0.917

(c). 0.552

Example 4A.6.

Which one of the tubes listed below would give the best gain in a cathode follower where RK is 1510 ohms and the load after the capacitor is 200 ohms?

6CG7/6SN7, Amplification Factor = 20, Plate Resistance = 7,700 ohms.
12AT7, Amplification Factor = 60, Plate Resistance = 10,900 ohms.
12AU7, Amplification Factor = 17, Plate Resistance = 7,700 ohms.
12AV7, Amplification Factor = 41, Plate Resistance = 4,800 ohms.
12AX7, Amplification Factor = 100, Plate Resistance = 80,000 ohms.

Solution:

Calculating Rk = 1510 x 200 / (1510 + 200) = 176.6 ohms.

6CG7/6SN7

Av = 176.6 x 20 / (176.6 x 21 + 7700 = 0.3096

12AT7, Av = 0.4889

12AU7, Av = 0.2760

12AV7, Av = 0.5926

12AX7, Av = 0.1805

The 12AV7 gives the highest gain.

Output impedance.

In order to find the output impedance we replace the cathode resistor with a voltage generator as shown in Figure 4A.15. This could be done in the laboratory if it is done a little differently.

Figure 4A.15 Equivalent Circuit for Output Impedance.

For a verbal description click here.

Note that the input terminals have been shorted. We will now calculate the current Ib which results from the voltage generator V, and divide it into the voltage. Writing the equation around the input loop gives,

-Vgk - V = 0  (4A.21)

The equation around the output loop is,

V - μ Vgk - Ib rp = 0  (4A.22)

Solving (4A.21) for Vgk and substituting it into (4A.22) gives.

V + μ V - Ib rp = 0  (4A.23)

Solving for V / Ib gives,

V / Ib = RO = rp / (μ + 1)  (4A.25)

Example 4A.7.

Which of the 5 tubes listed below has the lowest output impedance?

6CG7/6SN7, Amplification Factor = 20, Plate Resistance = 7,700 ohms.
12AT7, Amplification Factor = 60, Plate Resistance = 10,900 ohms.
12AU7, Amplification Factor = 17, Plate Resistance = 7,700 ohms.
12AV7, Amplification Factor = 41, Plate Resistance = 4,800 ohms.
12AX7, Amplification Factor = 100, Plate Resistance = 80,000 ohms.

Solution:

6CG7/6SN7 RO.

RO = rp / (&mu + 1) = 7700 / 21 = 366.7 ohms.

12AT7, RO = 178.7 ohms.

12AU7, RO = 427.8 ohms.

12AV7, RO = 114.3 ohms.

12AX7, RO = 792.1 ohms.

Looks like the 12AV7 wins again.

Operating Point.

Plate characteristic curves can be used to determine the Q-point of a cathode follower the same as for a common cathode amplifier. Because the plate connects directly to Ebb the load line goes straight up and down at the value of the voltage

Figure 4A.6 is repeated here so you won't have to scroll up to see it. This time look at the other set of lines.

Plate curves with load lines.

Figure 4A.16 Plate Characteristics with Graphical Solution.

For a verbal description click here.

The plate voltage is 300 volts so the load line is drawn vertically along that line. Let's assume a 1500 ohm resistor from the cathode to ground. 2 volts across 1500 ohms gives a current of 1.333 mA. We mark this point on the -2 volt curve. 3 volts across 1500 ohms gives 2 mA so we mark this point on the -3 line. We connect the points with a magenta line and the tube will operate where the magenta and red lines cross, 1.95 mA.

Taking the Cathode Resistor Into Account.

In example 4A.7 we calculated the effective output resistance at the cathode is if there were nothing else connected there. Obviously there is a resistor from the cathode to ground. This resistor is in parallel with the resistance presented by the tube. When calculating the output resistance of a cathode follower the cathode resistor may or may not be significant. Let's do an example where it is.

Example 4A.8.

For a 6SL7 calculate the (a) gain and (b) output resistance if a 1500 ohm resistor is used in the cathode. The amplification factor is 70, and the plate resistance is 44000 ohms.

Solution:

(a) Av = (Rk μ) / (Rk[μ + 1] + rp)

Av = 1500 x 70 / (1500 x 71 + 44000) = 0.698

(b) RO = rp / (μ + 1) = 44000 / 71 = 620 ohms.

We must now find the parallel combination of Ro with RK.

R = 620 x 1500 / (620 + 1500) = 439 ohms.

Practical Cathode Followers.

The circuit of Figure 4A.13 works but it can be of limited usefulness. The problem is its signal handling capability. The voltage at the cathode may be only one or two volts and the output voltage cannot go negative by anymore than this voltage. The voltage at the cathode can't go negative. This can be gotten around by using one of two circuits.

Figure 4A.17 Two Modified Cathode Follower Circuits.

For a verbal description click here.

The circuit in (a) might be preferred by some because it is a bit easier to design. However, it is rarely, if ever, seen. In fact, I have never seen it used in commercially produced equipment.

To design it, use the voltage divider equation to select the values of R1 and R2 to set the voltage at the grid. The cathode will be at most 3 volts higher. The value of the cathode resistor may then be calculated based on the desired cathode current. The voltage at the grid may be as high as half of Ebb.

Every tube has a maximum grid resistance stated in the tube manual. The parallel combination of R1 and R2 MUST NOT exceed this value.

Capacitor C1 is an absolute must because there is a DC level at the grid which must not be altered by anything that may be connected to the input.

The circuit of (b) is standard and is known as the modified cathode follower. The two resistors in the cathode bias the grid positive and allow the cathode to be at a much higher potential to permit a larger voltage swing.

When a graphical solution is performed the value of RK1 is used to draw the bias line. The value of RK2 may be what ever is needed to drop the desired cathode voltage up to ½ of Ebb. When doing a graphical solution remember to subtract the voltage drop across RK2 from Ebb and use this number to place the vertical line on the graph. The horizontal axis is labeled "Plate Voltage" but it is actually the voltage between plate and cathode, not between plate and ground.

The major advantage of (b) over (a) is the increased input resistance. R1 has an effective resistance much larger than it actually is because the lower end is connected to a point that is at an AC potential that is in phase with the input signal and just a little smaller. If we assume the voltage at the junction of the three resistors is 0.9 of what is at the input, if the input voltage has a peak value of 1 volt the other end of the resistor has a peak value of 0.9 volts and the voltage drop across the resistor is 0.1 volts. That makes the effective resistance of R1 10 times the actual value of the resistor.

Example 4A.9.

A cathode follower uses a 12AX7 which has an amplification factor of 100 and a plate resistance of 80 k ohms. The resistor values are as follows. Rk1 = 10 k ohms, RK2 = 100 k ohms, and R1 = 470 k ohms. What are, (a) the voltage gain, (b) the output impedance, and (c) the input impedance.

Solution:

We must use the sum of RK1 and RK2 for Rk in equation 4A.20.

(a) AV = Rk μ / (Rk[μ + 1] + rp

AV = 110 k x 100 / (110 k x 101 + 80 k) = 0.983

(b) Output resistance of the tube alone is,

Ro = rp / (μ + 1) = 792 ohms.

The true output impedance is this value in parallel with 110 k ohms which is 786 ohms.

(c) We must use (4A.11.2) to calculate the value of Reff, the effective resistance of R1. The question is what value to use for A. We must use the gain between the input and the junction of the three resistors. This is,

A = Av RK2 / (RK1 + RK2) = 0.983 x 100 k / (10 k + 100 k) = 0.894.

The effective resistance of R1 is,

Reff = R1 / (1 - A) = 470 k / (1 - 0.894) = 4.43 Meg ohms.

A maximum grid circuit resistance could not be found for this tube but it is usually 2 Meg ohms for small signal triodes. This means that a maximum input impedance of 18.9 Meg ohms could be obtained with this circuit. Using this latter value a corner frequency of 1 cycle per second could be obtained with a capacitor of 0.00844 uf as C1.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

4A.7 Grounded Grid Amplifier.

The first impulse would be to say that grounded grid amplifiers are never used in audio circuits. Nothing could be further from the truth. Negative feedback is often injected at the cathode of a stage making it a compound amplifier, both common cathode and grounded grid. Another use is in the long tail pair phase inverter where the signal from the cathode of the left hand tube drives the cathode of the right hand tube which really is in grounded grid mode.

The term "grounded" doesn't necessarily mean DC ground although that is the case in many radio frequency power amplifiers. In the next section we will see an RF amplifier in which the grid is at AC ground but a high positive potential. Here is the circuit of a simple resistance coupled grounded grid amplifier.

Many draftsmen will draw the tube with the plate on the right and the cathode on the left. The grid connection point is brought out the bottom and right to ground. I have shown the tube upright because that is the way you are accustomed to seeing it.

Figure 4A.18 Schematic of Grounded Grid Amplifier.

For a verbal description click here.

Driving the cathode is really no different than driving the grid. The most important difference is the input impedance. Instead of being an open circuit the cathode is a low impedance point as it is in a cathode follower. The other important difference is that the phase of the input signal is NOT inverted. Below is the equivalent circuit.

Figure 4A.19 Equivalent Circuit of Grounded Grid Amplifier.

For a verbal description click here.

Notice that the input signal is in series with the tube's voltage source. This is why FCC rules require that when computing the power of a grounded grid amplifier the power of the driver must be added to the power of the amplifier.

To derive the gain we write the loop equations as follows.

Vin + Vgk = 0  (4A.26)

Vin - μ Vgk - Ib rp - Ib Rb = 0  (4A.27)

Solving (4A.26) for Vgk and substituting into (4A.27) gives,

Vin + μ Vin -Ib rp - Ib Rb = 0  (4A.28)

Now we write an equation for the output voltage.

Ib Rb - Vo = 0  (4A.29)

Solving (4A.29) for Ib and substituting into (4A.28) gives,

Vin (1 + μ) - (rp + Rb) Vo / Rb = 0  (4A.30)

Solving (4A.30) for Vo / Vin gives,

Vo / Vin = Av = Rb (μ + 1) / (rp + Rb)  (4A.31)

The input impedance can be found by returning to equation (4A.28) and solving it for Vin / Ib.

Vin / Ib = Rin = (rp + Rb) / (μ + 1)  (4A.32)

Example 4A.10.

A grounded grid amplifier like that of Figure 4A.18 uses a 12AX7 and has an 1800 ohm resistor in the cathode and a 100 k ohm resistor in the plate. The parameters for the 12AX7 are, μ = 100, and rp = 80 k ohms. What are, (a) the voltage gain, and (b) the input impedance?

Solution:

(a) Calculating the voltage gain,

Av = Rb (μ + 1) / (rp + Rb)

Av = 100 k x 101 / (80 k + 100 k) = 56.1

(b) Rin = (rp + Rb) / (μ + 1) = 180 k / 101 = 1.78 k ohms.

The input impedance is this resistance, presented by the tube alone, in parallel with the cathode resistor.

Zo = Ro RK / (Ro + RK = 1.78 k x 1.8 k / (1.78 k + 1.8 k) = 895 ohms.

The grounded grid amplifier is not used in audio as a stand alone stage. As described above it is hidden in other stages. Where GG amps are found is in RF amplifiers. At radio frequencies the plate to grid capacitance of a triode is enough to cause it to oscillate. The capacitance feeds enough of the plate signal back to the grid to sustain oscillation. Obviously, this is undesirable in an amplifier. The grounded grid acts as an electrostatic shield between the input and output to prevent oscillation. In addition to that the cathode presents a low input impedance and it is not as susceptible to signals being induced as the high impedance grid.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

4A.8 Cascode Amplifier.

The cascode amplifier is never used in audio circuits. I don't know why, maybe no one ever thought of doing it. It gives about as much gain as a pentode with about the same component count. I guess the idea of using two triodes for what would be one stage is just not appealing to audio amplifier designers.

The very first stage of a VHF TV receiver or FM receiver must amplify the small signal and add as little noise as possible. The emission and travel of electrons in the tube is a random process and randomness is noise. Pentodes give superior performance at RF because they have inherently higher gain and the screen grid acts as an electrostatic shield between the control grid and plate to keep down oscillation. But those two extra grids give the electrons more opportunities to run into something and produce more random noise. It would be real nice if we could have a tube as quiet as the triode, and with the gain and high input impedance of a pentode.

Enter stage left the cascode amplifier.

Figure 4A.20 Schematic of Cascode Amplifier.

For a verbal description click here.

This circuit is essentially a common cathode amplifier driving a grounded grid amplifier. The latter provides shielding of the input from the output. There is still some small RF voltage on the plate of the lower tube. There has to be or there wouldn't be any driving signal for the upper tube. The inductor is adjusted to bring the phase of the plate voltage to such a value as to reduce the miller effect in the lower triode to near zero.

Cascode amplifiers are constructed using duo triodes such as the 12AT7 which was designed for use in the tuners of early TV sets. The two sections are closely matched and they are in series for DC so the quiescent plate currents will be equal. The resistor network consisting of R1 and R2 is set so the voltages across each triode are equal. This means that μ1 = μ2 and rp1 = rp2.

Figure 4A.21 Equivalent Circuit of Cascode Amplifier.

For a verbal description click here.

We don't need to make any distinction between μ and rp for the two triodes. First we write the loop equation in the grid of the lower triode.

Vgk1 = Vin  (4A.33)

Now we start at ground and write the equation around the grid circuit of the upper triode.

-Vgk2 + μ Vgk1 + Ib rp = 0  (4A.34)

Now we start at ground and write the equation around the main plate circuit loop. Because the two triodes are in series, Ib1 = Ib2 so there is no need to notate them separately.

-&mu Vgk1 - Ib rp - μ Vgk2g - Ib rp - Ib Rb = 0  (4A.35)

Now we solve equation 4A.34 for Vgk2 and substitute into equation  (4A.35)

Vgk2 = μ Vgk1 + Ib rp = 0  (4A.36)

-mu Vgk1 - Ib rp - μ (mu Vgk1 + Ib rp) - Ib rp - Ib Rb = 0  (4A.37)

Substituting equation 4A.33 into equation 4A.37 gives

-μ Vin - Ib rp -μ (μ Vin + Ib rp) - Ib rp - Ib Rb = 0

Now we multiply the parentheses through by μ, collect Ib terms and factor Ib out as a negative quantity.

-μ Vin - μ2 Vin -Ib (rp + μ rp + rp + Rb) = 0

Now we factor out -Vin and at the same time factor out rp inside the parentheses.

-Vin (μ + μ2) -Ib (rp [μ + 2] + Rb) = 0

Let's factor out μ so we don't have to deal with that μ2 term.

-Vin (μ [μ + 1]) -Vo / Rb (rp [μ + 2] + Rb) = 0  (4A.39)

To get the output voltage into the equation and eliminate Ib we write equation 4A.40 and substitute it into equation 4A.39.

Vo = Ib Rb

Ib = Vo / Rb  (4A.40)

-Vin (μ [μ + 1]) = Vo / Rb (rp [μ + 2] + Rb)  (4A.41)

Now we divide through by -Vin, the parentheses on the right, and multiply by Rb.

Vo / -Vin = Rb (μ [μ + 1]) / (rp [μ + 2] + Rb)

And finally we multiply through by -1 to obtain,

Vo / Vin = Av = -Rb (μ [μ + 1]) / (rp [μ + 2] + Rb)  (4A.42)

The minus sign is because the amplifier inverts the signal and therefore the gain is a negative number.

Example 4A.11.

Calculate the gain of a resistance coupled cascode amplifier using a 12AX7 with a 220 k ohm plate resistor and a 470 k ohm resistor in the grid of the following stage. For the 12AX7, μ = 100, and rp = 80 k ohms.

Solution:

Referring back to Example 4A.1 the value of Rbc is 150 k ohms. This is the value to be used for Rb in equation 4A.42.

Av = -Rb (μ [μ + 1]) / (rp [μ + 2] + Rb)

Av = -150 k x 100 x 101 / (80 k x 102 + 150 k) = -182

Cascode Versus Pentode in Audio Service.

Figure 4A.22 Comparison of Cascode with Pentode Amplifier.

For a verbal description click here.

The figure shows a direct comparison between a cascode amplifier using a 12AX7 and a pentode amplifier using a 6AU6. The parts count is comparable. 1 tube and 3 capacitors for each. The cascode has one more resistor than the pentode but resistors are cheap. True it uses a higher Ebb voltage than the pentode but that could be corrected with a different design.

The pentode design was taken intact from the resistance coupled amplifier chart. The capacitors were computed for a 1 cycle per second corner frequency.

The design of the cascode began with the RCAC data. The 12AX7 data for Ebb = 250 volts and the plate and cathode resistors shown gives 128 volts as the quiescent plate voltage. Subtract the approximate 1 volt drop across the cathode resistor and we are real close to half of the Ebb across the tube and half across the plate resistor. With a cascode we make that 1/3 across each tube and 1/3 across the plate resistor and increase the Ebb to 375 volts. Then we calculate the voltage divider in the grid of the top triode to place 1/3 of the supply voltage on the grid. A similar design could be worked out for 250 volts using plate characteristics or a breadboard.

The difference between the gain of the pentode and the cascode only amounts to 1.6 dB. Distortion in the 6AU6 is, by the chart, 1.1% at 25 volts output. The cascode might be a viable solution when high gain and low noise are needed, provided you don't need a lot of output. The measured gain is 200 and here are the distortion figures.

Vo | Distortion
25 | 8.3%
10 | 2.8%
2 | 0.56%

A cascode is not usable for a high gain high output amplifier. It should have lower noise than a pentode but I don't have time to build a fully shielded version of it to accurately measure the noise output. If one is working close to the noise floor obviously one is not going to be operating at a high level of output so in this application distortion should not be an issue. Noise shouldn't be an issue until the input voltage gets under 1 millivolt. At that level the output voltage would be 200 millivolts and the distortion would likely be unmeasurable.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

4A.9 Problems.

  1. Use the plate characteristics for the 6SL7 and (a) place a load line on the graph for a plate supply voltage of 400 volts and a resistor of 220 k ohms. (b) Place bias lines on the graph to determine the standard value cathode resistor to give a plate voltage as close as possible to 265 volts. (c) Place an AC load line on the graph for a following stage grid resistor of 470 k ohms. (d) Determine the gain from the AC load line. Note. You will need to print out the plate characteristics to have something to draw on. The best one to print may be Figure 4A.5 as what is drawn on it is all above 2 mA and will be out of your way.

  2. A 12AU7 has a 100 k ohm resistor as a plate load. The following stage grid resistor is 470 k ohms. For a 12AU7 the amplification factor is 17 and plate resistance is 7700 ohms. What is the voltage gain of this stage?

  3. A 6SN7 has a plate load of 47 k ohms and an unbypassed cathode resistor of 1 k ohm. There is no following stage grid resistor as this is in a Williamson amplifier phase inverter. The amplification factor is 20 and plate resistance is 7700 ohms. What is the voltage gain of this amplifier?

  4. It is desired to have a 12AX7 amplifier with a gain as close to 10 as possible. The load resistance is 39 k ohms. Select a cathode resistor to give this gain. The parameters for the 12AX7 are, μ = 100, and rp = 80,000 ohms.

  5. Design a 6SL7 amplifier from the sample page of a resistance coupled amplifier chart reproduced above. The only requirements are that Rcf must be 470 k ohms, the gain must be between 52 and 53, and the distortion must be less than 0.6%. In your answer state the values of, Ebb, Rb, Rk, (give 0 if zero bias is selected), Esig, Gain, and % Distortion.

  6. A 12AT6 has a gain of 50. The plate to grid capacitance is 2.0 pf and the input capacitance is 2.2 pf. What is the total input capacitance of the amplifier?

  7. A 6S4 is a 9 pin triode with a plate dissipation of 7.5 watts which is quite a lot for a small triode. Its amplification factor is 16 and its plate resistance is 3600 ohms. If this triode is used in a cathode follower where the total resistance in the cathode is 2500 ohms, what is (a) the voltage gain, and (b) the output impedance, including the cathode resistor?

  8. A 6C4 is used as a grounded grid amplifier. The plate resistor is 47 k ohms, the cathode resistor is 1 k ohm, and the following stage grid resistor is 220 k ohms. The tube parameters are μ = 17, and rp = 7,700 ohms. What are (a) the voltage gain, and (b) the input impedance including the cathode resistor.

  9. A 6SL7 is to be used in a cascode amplifier. The plate resistor is 220 k ohms and the following stage grid resistor is 470 k ohms. What is the gain? Tube parameters are, μ = 70, rp = 44,000 ohms.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

4A.10 Answers to problems.

  1. (a) The red line on the graph is the correct load line.

    (b) There are two approaches to this problem. One is the estimation method and the other is the limits method. The estimation method goes this way. 265 volts is approximately half way between the -3 and -4 curves. So lets try -3.5 volts and see what happens. The current corresponding to 265 volts is about 0.62 mA. The trial Rk is then,

    Rk = 3.5 v / 0.62 ma = 5,645 ohms.

    The closest standard value is 5.6 k ohms. Then we check this with a bias line for 5.6 k ohms.

    3 / 5.6 k = 0.536 mA
    4 / 5.6 k = 0.715 mA

    We mark these values on the -3 and -4 grid voltage lines and connect them with a line. Where the bias line and the DC load line cross is the Q-point of the tube. It is always a good idea to check the adjacent values of 4.7 k and 6.8 k.

    The limits method goes this way. The desired operating point is between -3 and -4 grid voltage. So we check the cathode resistor where the load line crosses these grid voltage lines.

    Rk-min = 3 v / 0.74 mA = 4054 ohms, and
    Rk-max = 4 v / 0.51 mA = 7843 ohms.

    There are 3 10% standard values between these limits. They are, 4.7 k, 5.6 k, and 6.8 k ohms. It is always a good idea to try all three just to be sure. The correct resistor is 5.6 k ohms.

    (c) As has been worked in an example, the parallel combination of 220 k ohms and 470 k ohms is 150 k ohms. The current where the DC load line crosses the bias line for 5.6 k ohms is 0.63 mA.

    Lower right end of AC load line = EbQn + IbQ x AC load.
    Lower right end of AC load line = 264 v + 0.63 mA x 150 k ohms = 358 Volts.

    Anchor the lower right end at 358 volts and rotate the line until it passes through the point where the DC load line and bias lines cross. Stretch it as far as you can and draw the line. Note. I did these lines on a computer screen. I had to have the image zoomed in pretty far to read the graph. The length of the AC load line was limited by the zoomed area of the graph.

    (d) The gain along the AC load line for grid voltages from -3 to -4 volts is 47.

Figure 4A.23 Graphical solution to problem 1.

For a verbal description click here.

  2. -15.5.

  3. -12.4.

  4. 2.7 k ohms.

  5. There are two possible answers.

    Self bias. Ebb = 250 V, Rb = 470 k ohms, Rk = 4.7 k ohms, Esig = 0.1 v, Gain = 52.5, and %Dist = 0.5.

    Zero bias. Ebb = 250 V, Rb = 470 k ohms, Rk = 0, Esig = 0.1 v, Gain = 52.5, and %Dist = 0.4.

  6. 104.2 pf

  7. (a) 0.868, (b) 195 ohms.

  8. (a) 15.0, (b) 721 ohms.

  9. 262.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

This page copyright © Max Robinson. All rights reserved.


Chapter 4B   Multi Grid Tubes.

4B.1  Odes to Tetra and Penta.
4B.2  The Heptode, Pentagrid Converter.
4B.3  The Beam Deflection tube.
4B.4  Magic Eye and Cathode Ray Tubes.
4B.5  Oscillators.
4B.6  Problems.
4B.7  Answers to Problems.

Chapter 4B.

Multi Grid Tubes.

Development of the vacuum tube moved rapidly after the first triode was set loose on the world. The tetrode, pentode, and heptode had all been developed by 1930. Although they were considerably refined over the following 30 years the changes consisted mainly of the way in which they were packaged. The only significant development of which the writer is aware is the beam deflection tube which came out in the late 1950s, but we are getting ahead of ourselves.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

4B.1 Odes to tetra and penta.

The triode was, and is, a pretty good tube but it does have a few problems. These problems were curable by inserting more grids into the tube. This gave rise to the Tetrode, 4 element tube, and the Pentode, 5 element tube.

Problems with the Triode.

The misbehavior of the Triode was attributed to the effect of plate to grid capacitance. There were two basic problems. These were 1) the miller effect and 2) oscillation. Due to the way a tube is constructed there is capacitance between the plate and grid. Because the tube inverts the signal the capacitance appears to be much bigger than it actually is. We studied the Miller effect in the previous chapter. If you don't remember that, it is suggested that you review section 4A.5.

Oscillation.

When triodes are used as radio frequency RF amplifiers all Hell breaks loose. The phase shifts that result from the use of tuned circuits in the grid and plate cause the signal fed back through the plate to grid capacitance to be positive feedback. That spells oscillator. If that's what you wanted then your delighted. But if you wanted to amplify small signals to make them bigger you would not be a happy camper.

There is such a thing as neutralization where in the circuit is arranged to feed signal back to the grid which is always opposite in phase and equal in amplitude to that fed back through the plate to grid capacitance. Neutralization is hard to adjust and increases circuit complexity. If there was only a way to reduce the plate to grid capacitance...

The Tetrode.

The logical thing to do seemed to be to place an additional grid between the control grid and plate. This grid could be placed at AC ground potential and would act as an electrostatic shield between plate and grid. Also the screen grid, as it was called, could be placed at a positive potential which would increase the gain of the tube by pulling more electrons toward the plate. However, a serious problem set in.

Secondary Emission.

When electrons strike the plate they are carrying a lot of kinetic energy. They give up that energy, in the form of heat, to the plate. The plate gets hot enough to begin emitting electrons. The impact of the incoming electrons helps to liberate others from the plate material. Think of them as being knocked loose. In a triode these secondary electrons have no place to go except back to the plate. It is the most positive thing in sight. In a pentode the screen grid is sitting there at a positive potential and because the plate voltage is going up and down with signal the screen grid may be, at that instant, more positive than the plate. The secondary electrons take off for the screen grid and ignore the plate. This takes away from plate current and adds to screen current. Both things are bad. But even worse is the negative resistance effect. There is a point where an increase in plate voltage will give a decrease in plate current. If you try to work that one out with ohm's law you get a negative value for resistance. This phenomenon is shown in the oscilloscope photo below.

Figure 4B.1 Oscilloscope Photo
Showing Effect of Secondary Emission.
Scales, X = 20 V/cm, Y = 2 mA/cm.
Grid voltage = 0.5 volts per step,
EC = 0 at the top. EC2 = 100 V.

For a verbal description click here.

Note the area where the line slopes slightly down to the right. This effect can be, and has been, used to make an oscillator but in an amplifier it leads to massive distortion. That's why there aren't any true tetrodes in your tube manual, unless you have a very old one.

So if there aren't any true tetrodes, how did I get these curves. I used a modern tube and tied the suppressor grid to the plate. Just as tying the screen grid to the plate makes a triode, tying the suppressor grid to the plate makes a tetrode. Even with that, modern materials used in tubes don't allow very much secondary emission. The effect would be much more pronounced if an older tube were used. This was a 6AU6. The curves for a properly connected 6AU6 will be seen below.

There were two basic solutions to the problem of secondary emission. One was to add yet another grid making a pentode, and the other was to cause the electrons to bunch up making a space charge that would repel secondary electrons back to the plate.

The beam Tetrode.

I can't say which came first historically speaking. Both solutions seem to have been around a long time. I have seen tubes such as the 6L6 called beam tetrodes in an old Tung-Sol manual I used to have. In looking through a 1937 RCA manual I find the 6L6 referred to as a beam power amplifier although the diagram shows only two grids and two little angled lines between screen and plate but positioned on either side.

I did find a 22 which is called a "SCREEN-GRID RADIO-FREQUENCY AMPLIFIER". The specified screen voltage is less than 1/2 of the plate voltage. With the screen voltage set so low the excursions of plate voltage in an RF amplifier would not be large enough to take it into the secondary emission area.

The word "tetrode" must have already become a "4 letter word" among electrical engineers and had been banished from RCA literature by 1937.

Beam tetrodes operate by having the control grid and screen grid wires very accurately aligned. This minimizes electron collisions with the screen and causes the electrons leaving the screen to travel in thin beams. The plate is a little farther from the screen grid than it would otherwise be and there are two vertical pieces of metal that are internally connected to the cathode. These compress the electrons into a horizontal beam and form a concentration of negative charge that works to repel secondary electrons.

This structure can be clearly seen in a 6CB6. The grey rectangular plates are where the electrons impact. The silver colored pieces are the beam forming electrodes. The screen and plate are seen surrounding the cathode. The semicircular band is to support the two halves of the plate and connect them electrically. A picture I take can't do it justice. You need to hold one of these tubes in your hand and turn it at different angles to see how it is made. Although the tube manual calls this tube a pentode and the diagram shows a suppressor grid it is not brought out to its own pin as true suppressor grids are.

If you decide to break a tube and disassemble its innards, be careful. First of all, don't cut yourself on the broken glass. However there is a more subtle danger. Most of the materials used in tubes are rather toxic. I would urge you to handle them with gloves and when you are finished wrap them in several layers of aluminum foil before throwing them away. The contents of one tube thrown away isn't going to constitute a hazardous material spill but thousands would.

The True Pentode.

The pentode is constructed by inserting a third grid between the screen grid and plate. So now there are three grids in our tube. You may think it's getting a little crowded in there but just wait until we get to the heptode. The third grid is called the suppressor grid or usually just the suppressor. It is usually placed at the same potential as the cathode. In some tubes it is internally connected to the cathode although these may be beam tetrodes. The wires of the suppressor are widely spaced as compared to the control and screen grids so there is little effect on the high energy electrons coming from the cathode on their way to the plate. The secondary electrons are much lower energy and the suppressor is just enough to discourage them from going anywhere but back to the plate. In some special applications the suppressor grid may be used to control the gain of the amplifier tube. This can turn the pentode into a voltage controlled amplifier (VCA).

So there we have the modern pentode tube. High gain, small Miller Effect, and low likelihood of oscillating. As you might have guessed by the tetrode characteristics above the pentode characteristics are nothing like those of the triode. Figure 4B.2 shows the plate curves for a 6AU6 taken with a curve tracer and oscilloscope.

Figure 4B.2 Oscilloscope Photo
Showing Characteristic curves for a 6AU6.
Scales, X = 20 V/cm, Y = 2 mA/cm.
Grid voltage = 0.5 volts per step,
EC = 0 at the top. EC2 = 100 V.

For a verbal description click here.

The tangle of lines at the left is an artifact of the curve tracer. If the plate voltage sweep is turned down they untangle and appear as they should. The almost horizontal lines mean that the plate resistance is very high and the best model for a pentode is a current source. Note that, unlike the tetrode, there is no change in the plate characteristics even when the plate voltage drops below the screen voltage.

Practical Circuit.

Like the triode the pentode can be connected as a resistance coupled amplifier. The tube manual circuit is shown below.

Figure 4B.3 A Pentode Resistance Coupled Amplifier Stage.

For a verbal description click here.

Once again the heater connections are assumed. The notation used here is consistent with the resistance coupled amplifier charts found in all tube manuals. You can design a pentode amplifier based on these charts, they will give you the gain and distortion at two values of input voltage.

In the next subsection you will see that small signal calculations are not accurate enough to be useful. However they can be used to correct the gain figures from the charts for an unbypassed cathode resistor.

Small Signal Calculations.

The equivalent circuit and calculations are quite different from the triode amplifier. The circuit is shown in Figure 3 below.

Figure 4B.4 The Small Signal Circuit of a Pentode.

For a verbal description click here.

When you look up a pentode in a tube manual you will find the transconductance rather than the amplification factor. If you are curious you can calculate it very simply. The amplification factor of a pentode may be found by,

μ = Gm rp  (4B.1)

Where μ is the amplification factor, Gm is the transconductance in mhos and rp is the plate resistance in ohms. The transconductance is always stated in micro mhos. The gain of a pentode amplifier may be calculated by,

Av = Gm rp Rbc / ( rp + Rbc)  (4B.2)

Where Rbc is the parallel combination of Rb and Rcf as follows.

Rbc = Rb Rcf / (Rb + Rcf)  (4B.3)

Where Gm is the transconductance of the tube, rp is the plate resistance, and Rbc is the parallel combination of Rb and Rcf as defined in equation 4B.3. The derivation of equation 4b.2 is so similar to that for the triode that it will not be given here.

One note of caution. The transconductance of a pentode is very sensitive to screen grid voltage. For example, for the 6AU6 the lowest value for transconductance is given for a screen voltage of 100 volts. Yet the resistance coupled amplifier charts give values of Eg2 of around 40 volts. Obviously the value of Gm needs to be scaled down accordingly. The tube manual gives a graph of transconductance versus grid number 1 voltage for values of grid number 2 voltage of 50, 100, and 150 volts for the 6AU6. An example will illustrate.

Example 4B.1

A 6AU6 has a stated transconductance of 3900 micro mhos and a plate resistance of 0.5 meg ohms. Calculate the gain for a plate resistor of 270 k ohms and a following stage grid resistor of 470 k ohms.

Solution:

First calculating the value of Rbc

Rbc = 270 k x 470 k / (270 k + 470 k) = 171 k ohms.

Av = Gm rp Rbc / (rp + Rbc)

Av = 3900 micro mhos x 500 k x 171 k / (500 k + 171 k) = 497

Here is the data from the resistance coupled amplifier chart for the 6AU6.

Ebb = 250 volts.
Rb = 270 k ohms.
Rc2 = 680 k ohms.
Rcf = 470 k ohms.
Rk = 1,000 ohms.
Ic2 = 0.30 mA.
Ib = 0.74 mA.
Ec1 = -1.0 volt.
Ec2 = 40 volts.
Eb = 50 volts.
Esig = 0.1 volt AC.
Eout = 25 volts AC.
Gain = 250.
% Dist = 1.1 %.
Esig(1) = 0.22 volts AC.
Eout = 47.7 volts AC
Gain = 217.
% Dist = 2.6 %.
(1) Taken at the point of 1/8 microamp of grid current.

So which one is right? The chart of course. It was based on actual measurements performed in the laboratory.

We do have curves for the 6AU6 of transconductance versus grid 1 voltage for three values of screen grid voltage including 50 volts. 50 volts is close to 40 volts and we are given the grid 1 voltage. Looking at the graph we find the value of transconductance of 2200 micro mhos. Using this value in equation 4B.2 gives a gain of 280. We would rather have calculations that do better than that. The error is likely caused by the 10 volt difference in the screen grid voltage. We can do it another way as seen below.

Gain for an Unbypassed Cathode.

If the cathode bypass capacitor is left off the gain equation becomes.

Av = Gm rp Rbc / [rp + Rbc + Rk (Gm rp + 1)]  (4B.4)

Where Gm is the transconductance of the tube, rp is the plate resistance, Rk is the cathode resistor, and Rbc is the parallel combination of Rb and Rcf as defined in equation 4B.3. The derivation of equation 4b.4 is so similar to that for the triode that it will not be given here.

Resistance coupled amplifier charts don't give gain values for an amplifier with no cathode bypass capacitor. If you want to design a low distortion pentode amplifier and need to know the gain for an unbypassed cathode here is the procedure.

  1. Design a pentode amplifier from the resistance coupled amplifier charts in a tube manual.

  2. Use the stated value of low distortion gain in equation 4B.5 to find the operating value of Gm.

    Gm = Av (rp + Rbc) / (rp Rbc)  (4B.5)

  3. Use this value of Gm in equation 4B.4 to calculate the true gain.

Example 4B.2

The plate resistance of the 6AU6 is given as 0.5 meg ohms. The data from the resistance coupled amplifier chart is given above.

This is a lot more information than we need to work the problem but The real world never gives only the information we need and no more.

Calculate (a) the operating transconductance of the tube, (b) the gain without a cathode bypass capacitor.

Solution:

First we must calculate Rbc = Rb Rcf / ( Rb + Rcf ) = 270 k x 470k / (270 k + 470 k) = 171 k ohms. Now we calculate the operating transconductance.

Gm = Av (rp + Rbc) / (rp Rbc)

Gm = 250 (500 k + 171 k) / (500 k x 171 k) = 1962 micro mhos.

Now we calculate the gain without a cathode bypass capacitor as follows.

Av = Gm rp Rbc / [rp + Rbc + Rk ( Gm rp + 1)]

Av = 1962 micro mhos x 500 k x 171 k / [500 k + 171 k + 1000 (1962 micro mhos x 500 k + 1)]

Av = 101

When the circuit was breadboarded and tested the gain with the bypass capacitor in place came out as 225 rather than 250. With the cathode bypass capacitor removed the measured gain was 96. If Gm is corrected using a gain of 225, it comes out to 1766. The calculated gain of the unbypassed circuit is 97.1.

If the screen grid bypass capacitor is returned to ground rather than to the cathode, as shown in Figure 4B.5, The gain is much lower, 73.5 to be exact. Distortion and gain figures are summarized in the table below.

Figure 4B.5 Pentode Amplifier With No Cathode Bypass Capacitor.

For a verbal description click here.

Cathode Resistor Bypassed | Screen Grid Bypassed To | Vin | Vout | Gain | Distortion
Yes | Ground | 0.1 v | 22.5 v | 225 | 3.8 %
Yes | Ground | 0.0425 V | 9.6 v | 226 | 0.72 %
No | Cathode | 0.24 v | 22.5 v | 93.8 | 1.8 %
No | Cathode | 0.1 v | 9.6 v | 96 | 0.35 %
No | Ground | 0.32 v | 22.5 v | 70 | 4.7 %
No | Ground | 0.1 v | 7.35 v | 73.5 | 0.32 %

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

4B.2 The Heptode.

Contrary to popular belief, the heptode was not invented by, or named by, a hepcat.

As the name implies the heptode has 7 elements, one cathode, 5 grids, and 1 plate. This tube is often called a pentagrid converter. Pentagrid as in 5 grids. It has one application, to serve as a mixer in radio receivers. (I have breadboarded and tested an audio voltage controlled amplifier using one of these tubes, but that's another story).

The Principle of Heterodyning

Heterodyning is more commonly known as "mixing", "conversion" or "modulation". OK; but what is it? If you combine two frequencies in a device known as a "mixer", "converter" or "modulator" you get two new frequencies. These new frequencies are the sum and difference of the two original frequencies. For example if you combine 5 MHz and 6 MHz in a mixer you get the two original frequencies and in addition you get 1 MHz and 11 MHz. If you combine 650 kHz and 1105 kHz you get 455 kHz, 650 kHz, 1105 kHz and 1755 kHz.

There are some types of mixers in which the original signals are canceled out and ONLY the sum and difference frequencies appear in the output. These devices are called "doubly balanced mixers" or DBMs for short. We will get to them shortly. But for now we will be talking about mixers in which the original two signals appear in the output along with the sum and difference frequencies.

So What is a Mixer?

Well, it's any nonlinear device. A nonlinear device is anything that has a graph that isn't a straight line. A diode, either vacuum or semiconductor makes an excellent mixer. A tube or transistor which is being driven into overload is another excellent mixer. The balanced variety consists of combinations of diodes and transformers, or transistors (usually in an integrated circuit). The beam deflection tube was developed in the 1960s that was a balanced mixer, but we're getting ahead of ourselves again.

The Superhet Receiver

The heptode was developed in the 1930s to combine the functions of oscillator and mixer into a single tube. Before that the two functions required two separate tubes. Reducing tube count also reduced cost so there was a great incentive to combine functions of two tubes into one.

We can not offer a full course in radio receiver design theory in this book. The interested reader is referred to other texts on the subject.

The block diagram of a single conversion super heterodyne receiver with an RF amplifier is shown in Figure 4B.6.

Figure 4B.6 Block Diagram of a Super Heterodyne Receiver.

For a verbal description click here.

I don't think there was ever such a thing as a heterodyne receiver. The word "super" appears to have been for marketing purposes but it is so ingrained into the consciousness of electrical engineers it will likely never be removed.

The RF Amplifier has a tuned circuit in its input and another in its output. It increases the level of the wanted incoming signal, reduces the level of the ones that are not wanted and helps to prevent the local oscillator from being radiated by the antenna. Such radiation could interfere with reception of other radio stations or services. Automatic gain control can be, and is, applied to the amplifying device here.

The converter contains an oscillator which is a locally generated signal that combines with the received frequency to generate the difference signal. The converter also does the job of mixing the local oscillator with the incoming signal. The tuned circuit of the oscillator is tuned along with the two tuned circuits in the RF Amplifier as the operator turns the tuning knob. The difference between the oscillator frequency and the incoming signal frequency is a constant. Therefore the converter delivers a constant frequency signal to the Intermediate Frequency Amplifier. Some AGC (Automatic Gain Control) is also applied to the mixer part of the converter.

The IF (intermediate Frequency) amplifier follows the converter. Its frequency is lower than the frequencies of the stations being received but higher than audio frequencies. Thus, the reasoning went, it is between the station frequencies and audio frequencies so it is intermediate. Its operating frequency is fixed and cannot be changed by the operator, or even by a skilled technician. This is where most of the selectivity of the receiver is found. Selectivity is the ability of a receiver to bring in a single station and cut out the stations that are nearby in frequency. More AGC is applied to the amplifying device in the IF amplifier.

Following the IF amplifier is the detector. This is the combination of devices and circuitry that recovers the audio from the AM signal. The detector also recovers a negative DC voltage that is proportional to the strength of the incoming signal. This is the AGC (Automatic Gain Control) voltage that is applied to the IF and RF amplifiers and the converter.

If this is a stand alone radio or short wave receiver, the audio amplifier will deliver 1 or 2 watts of power to drive a speaker. If it is a high fidelity tuner The amplifier will deliver a line level signal at a moderate impedance level for driving the input circuitry of an amplifier.

Image Frequencies.

As mentioned above a mixer/converter produces the sum and difference frequencies of the two original input signals. The mixer can and does produce two difference frequencies. If we call the frequency of the oscillator fo a frequency below the oscillator f1 and a frequency above the oscillator f2, the difference frequency fd will consist of,

fd1 = fo - f1

fd2 = f2 - fo

Suppose you live in Cincinnati Ohio so you have a strong local station on 1530 kHz. (It used to be WCKY. I don't know if it has changed. Well, suppose you would like to listen to an out of town station which is operating on 620 kHz. You tune your local oscillator to 620 + 455 = 1075 kHz. What do you hear? Well, WCKY on 1530 is also there and combines with your local oscillator on 1075 to produce a difference frequency of 1530 - 1075 = 455 kHz. OOPS!     That's the main drawback to a Superhet receiver. It receives two frequencies simultaneously at the same time. It's up to the two tuned circuits in the RF amplifier which are tuned to 620 kHz to reject the strong signal on 1530 so you can listen to the station you want to hear. Low cost AM radios omit the RF Amplifier stage which places only one tuned circuit between the antenna and converter. Such radios are not very good at rejecting the unwanted frequencies. They are called "image" frequencies by radio engineers.

The Tube and the Circuit.

Because the tube was developed to operate as a converter in AM and short wave receivers, it and the circuitry that make it work are inseparable. Figure 4B.7 is the converter section of an All American 5 radio that might have been sold between 1938 and 1950.

Figure 4B.7 Typical Converter From an AM Radio.

For a verbal description click here.

How the Converter Works.

The 6BE6/6SA7 converter has 5 grids making it a heptode or 7 element tube. Grids 2 and 4 are tied together inside the tube and grid 5 is tied to the cathode. That's how they can make it work in a 7 pin tube. They need 2 pins for the heater leaving only 5 for the other elements of the tube. In the 6SA7 which has 8 pins, grid 5 is brought out to its own pin.

The cathode and the first two grids work like a triode tube and are the local oscillator. The circuit is called a Hartley oscillator because it uses a tapped inductor. (See section 4B.5). The cathode goes to the tap and the first grid, called the oscillator grid, receives signal which is coupled from the top of the oscillator coil. The cathode current flows through a few turns at the ground, or low, end of the coil. The magnetic field induces voltage in the rest of the coil. The coil is tuned by one section of the variable capacitor and the alternating voltage which appears across the coil has the frequency to which the coil is tuned. The voltage which is applied to the grid is enough to drive the cathode current of the tube from saturation to cutoff. The pulses of cathode current flow through the lower turns of the coil and maintain the oscillation. When the alternating voltage at the top end of the coil swings positive the grid is driven slightly positive and begins to conduct current like a diode. (The grid is attracting electrons to its self and therefore acts like the plate of a diode.) The 220 pf capacitor charges up so the most positive voltage at the grid is just barely positive and most of the time the grid voltage is negative. A DC meter connected to the grid with proper isolation so it won't short out the AC, will indicate the average voltage which may be anywhere from -5 to -40 volts. So the cathode current is flowing in short pulses at the oscillator frequency. Since the cathode is the only source of electrons in the tube the plate current is also flowing in short pulses with little or no current in-between pulses.

Grid 2 is connected to B+ and acts like a plate but it is a leaky plate. Electrons pass on through it to go on and be effected by the remaining 3 grids. Grid 3 is called the mixer grid and is where the station's signal comes in from the antenna. Because the oscillator signal is over driving the tube it is a nonlinear device and the sum and difference frequencies appear. Grid 4 is connected to B+ and so accelerates the electrons on there way to the plate.

Sometimes the impact of electrons on the plate causes electrons already there to be knocked loose. This is called secondary emission. If grid 5, called the suppressor grid, were not present these secondary electrons would go to the screen grid, grid 4, and take away from the plate current as described above. There are times in the AC cycle when the plate voltage is actually less than the screen voltage. The suppressor grid, which may be grounded or tied to the cathode, is negative enough to cause the secondary electrons to go back to the plate because they have no where else to go. The wires of grid 5 are widely spaced so it has little effect on the high velocity electrons on their way to the plate.

The tuned circuit in the plate of the converter tube is tuned to 455 kHz and is the primary of the first IF transformer. Short wave receivers are likely to have a higher intermediate frequency.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

4B.3 The Beam Deflection Tube.

Like the Heptode, the Beam Deflection Tube was designed to perform a specific purpose. That is a balanced mixer, often called a balanced modulator. There are two types of balanced mixers, singly and doubly balanced.

Doubly Balanced Mixers.

A doubly balanced mixer causes both input signals to be cancelled in the output. Going back to the original example if you supply signals of 5 and 6 MHz to a doubly balanced mixer the output will consist of the sum frequency of 11 MHz and the difference frequency of 1 MHz but the original frequencies of 5 and 6 MHz will be greatly attenuated.

Figure 4B.8 Doubly Balanced Mixer Implemented with Triodes.

For a verbal description click here.

An arrangement of 6 triodes, Figure 4B.8, will perform this function but tube drift makes it difficult to keep in balance and the attenuation of the original input signals may not be very high after a few weeks of operation. Automatic balancing circuits could theoretically be added but the already complex circuit would become so complex as to not be worth the trouble.

Figure 4B.9 DBM Integrated Circuit with External Circuitry.

For a verbal description click here.

An integrated circuit consisting of 9 transistors, Figure 4B.9, one used as a diode, carries the numbers MC1496, LM596, or NE5596, and is a very good DBM (Doubly Balanced Mixer). In an IC all transistors were manufactured at the same time and they are all at the same temperature in operation. Even the very slight amount of aging that occurs in transistors proceeds at the same rate for all of them. The writer has never tried to push its upper frequency limit but it will work up to 4 MHz. The circuit elements in red are external to the IC.

Figure 4B.10 DBM Implemented with Diodes.

For a verbal description click here.

An arrangement of 4 diodes and two transformers, Figure 4B.10, also makes a very good DBM. Its balanced depends on the exact matching of the diodes. Diodes are made in batches and all four must come from the same batch. Attempting to match diodes out of a large number of them will only result in matching at the test point and they will not give very good balance in a DBM. The characteristic curve of each diode must match over the entire current range from a few hundredths of a microamp to a milliamp or more. The only feasible solution is to purchase DBMs already put together and encapsulated with transformers and all.

Singly Balanced Mixer.

A singly balanced mixer will only cancel one of the two inputs. Diode versions can be constructed and because it only uses 2 diodes external DC biasing can be used to achieve balance. I don't think anyone has bothered to make prepackaged diode or IC versions.

In the late 50s there were two tube types made that would function as a singly balanced mixer. One, the 7360, was made for the specific purpose of generating single sideband suppressed carrier signals in communications equipment. The other, the 6AR8, was made to demodulate the chroma signal in color TV receivers. Both are shown schematically in Figure 4B.11.

Neither type is being manufactured today but because of supply and demand the 7360 is selling for about 10 times the price of the 6AR8.

Figure 4B.11 Two Beam Deflection Tubes.

For a verbal description click here.

Other than which element goes to which pin the tubes are quite similar. The 6AR8 has a peculiarity in that one of the grids is tied to one side of the heater. The data on this tube states that pin 5 must be grounded. This grid is not even called a grid but an internal shield. Other than that the tube is perfectly normal.

In operation the electrons come out in a beam and if there is no potential difference between the two deflectors, the beam will strike both plates equally. An AC voltage applied to the control grid will cause an AC voltage to appear at the plates which is out of phase with the grid voltage but the voltage at the two plates will be in phase with each other.

For ease of understanding we will assume that both deflectors are driven with opposite phase voltages. This causes the electron beam to swing back and forth between the two plates. When the electron beam is on one plate that plate current will be high and the current on the other plate will be low. As the electron beam swings back the other way the current on the high current plate decreases and that on the low current plate increases. Thus the signals on the two plates are 180 degrees out of phase with each other.

To review then, the control grid causes in-phase voltages at the two plates, and the deflectors cause out of phase voltages at the two plates.

If there are two signals of different frequency applied to the control grid and deflectors the sum and difference frequencies will appear as for each plate the two signals are multiplied.

If the two plates were connected in parallel, the deflector voltage would be canceled while the control grid voltage would not. I have never seen a circuit like this. I suspect it produces quite a bit of distortion in this mode of operation.

Circuits I have seen connect the plates to the ends of a center-tapped transformer with B plus going to the center-tap. If you apply in-phase signals to the ends of a center-tapped transformer, there is no net magnetic field and no, or very little, voltage is induced in the secondary. This means that the voltage applied to the control grid will be canceled in the output. This is a singly balanced mixer.

If you apply a radio frequency of say 455 kHz to the control grid and audio to one of the deflectors, as shown in Figure 4B.12, the RF signal will be canceled in the transformer. The audio will not be canceled but the output transformer is a tuned circuit at 455 kHz and the audio signal won't come through. Because this device is a mixer the sum and difference frequencies will be created. These are the sidebands of an AM signal but the carrier is suppressed. We are generating a double-sideband suppressed-carrier signal on 455 kHz. It could be heterodyned to any desired frequency.

Figure 4B.12 455 kHz Double-Sideband Suppressed-Carrier Generator.

For a verbal description click here.

The tube could also be used as a mixer in a receiver or transceiver in which canceling one of the input frequencies could reduce spurious signals. However, when this is a problem a doubly balanced mixer is usually preferred.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

4B.4 Magic Eye and Cathode Ray Tubes.

Cathode ray tubes are familiar to most everyone. Only at this writing, 2007, are they disappearing from TV sets. Technically inclined people are also familiar with their use in oscilloscopes. They are also in the process of disappearing from that application.

The Magic Eye Tube.

A magic eye tube is much less familiar although many readers may have seen one without realizing what they were looking at. Figure 4B.13 shows a magic eye tube. In A there is no power applied to the tube, in B it is fully open, and in C it is nearly closed. It can assume any state between open and closed depending on the applied voltage.

Figure 4B.13 The Magic Eye Tube in a Heathkit Capacitor Tester.

For a verbal description click here.

Here is the schematic diagram of a magic eye tube.

Figure 4B.14 Schematic of Magic Eye Tube Circuit.

For a verbal description click here.

The input goes to the grid of a triode amplifier which has a gain somewhere between 15 and 20 depending on tube type. When the voltage on the grid, pin 3, is zero the eye is fully open as shown in the left hand photograph above. Under these conditions the plate of the triode, pin 2 will be at about 25 or 30 volts.

As the grid voltage is made negative, the plate voltage increases and the eye moves toward being closed as shown on the right above. The plate of the right hand triode is called the target and is the anode which is coated with the phosphor material as seen in the top picture above. The phosphor glows green when bombarded by electrons.

The grid of the right hand triode is called the "Shadow Control Grid" in Figure 4B.15 below. It is connected internally to the amplifier plate. The voltage on the "Shadow Grid" varies from a low of 25 volts to approximately 60 % of B+.

Figure 4B.15 Construction of Magic Eye Tube.
Not Exactly to Scale.

For a verbal description click here.

The target is not flat as it may appear in the drawing. It is shaped like a cup with a hole in the bottom. The angle of the sides coated with the phosphor is about 45 degrees. The "Shadow Rod" does exactly what its name implies, casts an electron shadow on the target. The "Shadow Rod" is connected to the cathode. When the "Shadow Control Grid" becomes more positive the "Shadow Rod" has less and less effect on the faster moving electrons and the shadow grows more narrow. The shadow rod and shadow control grid can be seen if you hold the tube at just the correct angle.

These tubes were used frequently as tuning indicators in deluxe radios from about 1935 into the 1950s. Most people could tune a radio by ear so their functionality was questionable.

The writer has heard a story, maybe true, maybe not, that some unscrupulous salesmen were telling people that if you looked into the eye and tuned in the station absolutely perfectly you could see what was going on in the radio studio. Nobody could ever achieve the level of perfection necessary to see Jack Benny, Bob Hope, et al.

Fraudulent claims not withstanding, the magic eye was used as a record level indicator on real to real tape recorders, (there weren't any other kind back then). It also turned up on a 2 meter transceiver as a modulation and power output indicator, as well as on an SSB exciter. Magic eye tubes have been used by radio hams and audio hobbyist in many applications for years.

The cathode ray tube.

The cathode ray tube is the familiar, although now disappearing, picture tube in TV sets and computer monitors. It has also enjoyed wide application in radar, and even as the numeric readout in an early electronic calculator. But perhaps the place where the CRT has found its best usage is in the oscilloscope.

If you told a service technician or maintenance engineer that he had to travel a great distance and work on an unknown piece of equipment, and he could only take one item of test gear, 999 out of 1,000 would take an oscilloscope. That 1,000th one would find himself up the proverbial creek without a paddle. An oscilloscope as it stands can measure voltage, time interval, and frequency. By the clever use of some resistors it can be used to measure current, resistance, capacitance and even transistor beta. Although there are digital multimeters that will measure all of these things the scope can still do something that no other test instrument can. That is show the shape of the wave. There are times when nothing will substitute for this.

The reader is referred to section 2.12 of this book for a detailed discussion of the cathode ray oscilloscope and its tube. There does not seem to be any point in repeating the information here.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

4B.5 Oscillators.

The very first vacuum tube oscillator was probably built by accident when someone was trying to get just a little more gain out of a radio frequency amplifier. If the plate circuit of a triode amplifier is tuned slightly higher than the grid circuit oscillation will most likely result. A parallel tuned circuit appears inductive when tuned high and one that is tuned low appears capacitive. The oscillation will take place between the resonant frequencies of the grid and plate circuits. The phase shifts that result will cause the feedback through the plate to grid capacitance to have a phase close enough to correct to sustain oscillation.

TGTP (tuned plate tuned grid) oscillators are never used because changing the frequency requires turning the variable capacitors in two tuned circuits. If you want to play with one it usually helps to supplement the plate to grid capacitance with an external capacitor of 10 pf or so. If you use a pentode, the external capacitor is an absolute must.

Colpits and Hartley Oscillators.

The Colpits oscillator is distinguished by the fact that the capacitor is split in half and the junction of the two halves is often, although not always, connected to ground.

In the Hartley oscillator the inductor is tapped and the tap may or may not be connected to AC ground. It also may or may not be connected to DC ground.

Figure 4B.16a shows a parallel fed Colpits oscillator. It is parallel fed because the DC plate current does not flow through the inductor. R3 may be replaced by an RF choke if desired. C3 keeps B+ from appearing across the variable capacitor which is generally a no no. If R1 were not present, C3 might not charge up and there would be B+ on the variable capacitor anyway. R1 makes sure that the inductor and the outer plates of the variable capacitor are held at DC ground potential. The tuning capacitor is sometimes known as a split stator but is actually the familiar dual ganged capacitor. The rotor and drive shaft are at both AC and DC ground potential.

The capacitor is, in effect, center tapped. This will place the center of the coil at AC ground potential. The effect of this is to cause the AC voltage at one end of the tuned circuit to be 180 degrees out of phase with the AC voltage at the other end. Since the plate voltage is 180 degrees out of phase with the grid voltage, the voltage fed back to the grid has the proper phase to reinforce and sustain oscillation.

The two halves of the variable capacitor need to be the same size or in a constant ratio to one another. If the oscillator is to be tuned over a narrow range, the capacitor on the plate side may be fixed and the variable capacitor on the grid side would have a fixed capacitor in parallel with it to limit its tuning range.

The AC voltage supplied to the grid is considerable. On the positive peak it drives the grid positive and C2 will be charged. When the grid is forced positive it begins to attract electrons to itself and current will flow. The grid acts like the anode of a diode. This current causes the capacitor to charge with the end of the capacitor which is toward the grid being negative. The grid never goes very far positive because the capacitor charges up and holds the charge. A small amount of charge leaks off through R2 but gets replenished on the next positive half cycle. A substantial average DC voltage, as much as -50 volts, is developed at the grid and this voltage makes the oscillator self adjusting. The negative bias lowers the gain of the tube and it will set itself to exactly what is needed to sustain oscillation. When the grid voltage goes negative, in most oscillators this will drive the tube into cutoff. This will cause the plate current to flow in short pulses but the tuned circuit rings like a bell and the waveform at the grid is a very good sine wave. The wave at the plate may not be as good.

Figure 4B.16 Parallel fed Colpits (a) and Hartley (b) oscillators.

For a verbal description click here.

Figure 4B.16b shows a series fed Hartley oscillator. Once again an RF choke could be used to replace R2. Capacitor C3 blocks the B+ voltage from the tuned circuit. Because the center tap of the coil is grounded there is no need for a resistor to ground. Neither side of the variable capacitor is at AC ground potential. An insulated coupling must be used between the capacitor shaft and tuning knob shaft to avoid the effect of hand capacitance. Hand capacitance would cause the frequency of the oscillator to shift when a person's hand came near the tuning knob.

Figure 4B.17 Two Series Fed Hartley Oscillators.

For a verbal description click here.

Series fed oscillators are more efficient and stable because there is no resistor in parallel with the tuned circuit to lower the Q. In figure A the B+ is tied to the center tap of the coil. This has the effect of placing both sides of the tuning capacitor at B+ potential. Even with insulated couplers from the capacitor shaft to the tuning shaft the "hot" capacitor is a hazard to someone servicing the equipment. That is why the tuned circuit has been moved to the cathode side of the tube as shown in B.

This is still a series fed circuit because the cathode current flows through the coil. You will note that the tap has been moved from the center to near one end and that end of the coil has been grounded. This removes B+ from the capacitor and permits the drive shaft to be at ground potential.

The reason for moving the tap has to do with gain around the loop. A center tapped inductor gives phase inversion and unity gain. With the tuned circuit connected from plate to grid the tube provides gain enough to ensure the oscillator will start and keep going. In figure 4B.17b the tube is now a cathode follower which has a little less than unity gain. The coil acts as an auto transformer and steps up the voltage applied to the tap. The top to tap ratio is typically 10 to 1. The cathode follower does not invert the phase and neither does the coil since both connections are on the same side of the ground point.

The cathode coupled series fed Hartley oscillator has become the most popular oscillator circuit among receiver design engineers. In addition to the ubiquitous All American 5 it is found in short wave, and ham receivers from about 1940 on.

Figure 4B.18a shows a parallel tuned Colpits Oscillator. The inductor labeled RFC is an RF choke. It is used in place of a resistor to provide a high impedance to the oscillator and at the same time a low DC resistance. The tuned circuit requires a high parallel impedance. If a resistor were used it would have to be of such a high value as to reduce the plate current of the tube to a very low value. If it were lowered to get the plate current up it would adversely effect the Q of the tuned circuit.

Figure 4B.18 Two Colpits Oscillators.

For a verbal description click here.

Figure 4B.18b shows a series tuned Colpits circuit which is often referred to as a Clap oscillator. Wipe off that silly grin. Like the Hartley and Colpits circuits, the Clap circuit was named after the man who invented it. Capacitors C3 and C4 are comparatively quite large. I have seen circuits in which they were 0.005 microfarads. To resonate with these capacitors at 4 MHz the inductor would have to be quite small, 0.633 microhenrys to be exact. Such a small inductor would be about one turn and would have a low Q at 4 MHz. In actuality the series tuned circuit has a normal inductor of many turns and a capacitor of 100 or 200 pf.

Remember that a series tuned circuit has minimum impedance at resonance. Just a little off resonance, on the high side, it is still a low impedance but appears inductive. A low inductive reactance means a small apparent inductance. It may seem as if the Q is low but the basic LC circuit has a high Q which will make the oscillator very stable.

Oscillator Stability.

There is nothing in the diagram of an oscillator that would indicate it would be anything but perfectly stable. That is, you could set it to a given frequency and it would stay there forever. The reality of oscillators is not even close to that. An LC oscillator will drift in frequency and unless steps are taken to minimize the drift it may be unusable for the desired function.

As the last sentence of the previous paragraph indicates, the drift of an oscillator can't be eliminated, just minimized. Let's first examine the causes of drift and then see how they can be minimized.

The main cause of frequency drift is a change in temperature. In vacuum tube equipment the heat generated by the tubes is unavoidably transferred to the elements of the tuned circuit.

As the inductor warms up the wire making up the coil gets longer. The form on which the coil is wound gets larger in diameter, and all that translates into a larger inductance.

In an air capacitor such as a variable, The plates get bigger and farther apart. Those two effects may seem to cancel each other and they do to some extent. In ceramic and mica capacitors the dielectric, (insulator), usually has a temperature coefficient all its own. This can be adjusted by the manufacturer to give a capacitor a positive, zero, or negative temperature coefficient.

The coil is sitting there with its big positive temperature coefficient so if we can incorporate a negative coefficient into the resonating capacitor this will go a long way toward making the oscillator stable.

Another source of instability is the change in tube capacitance. This change occurs much faster than those caused by warming up of the coil and capacitor. An attempt to compensate for changes in tube capacitance could result in an oscillator that would drift down in frequency until the tube reaches its operating temperature and then up as the coil and capacitor start to feel the heat from the tubes.

The trick here is to make the fixed capacitors in the circuit so large that the tube capacitances will be a small part of the total. In any of the circuits the capacitor can be made larger and the inductor smaller. This can only be carried so far. This will result in a lower Q because a coil which is too small for the frequency will have more resistance in relation to its inductance.

The parallel tuned Colpits goes somewhat in this direction. The ARRL Radio Amateurs Handbook recommends for an oscillator to tune from 3.5 to 4 MHz, that C3 be 680 pf and C4 be 0.0022 uf. For the Clap oscillator they recommend that C3 and C4 both be 0.001 uf. Although the writer once owned a VFO, (Variable Frequency Oscillator), made by E. F. Johnson that used 0.005 uf capacitors for C3 and C4.

Electron Coupled Oscillator, (ECO).

You may be wondering how to get the signal out of these oscillators. In all cases the best waveform is found at the grid although this is a very high impedance point and a lot of isolation would have to be included to keep changes in load from effecting the frequency. For the cathode coupled circuits the output signal could be taken from the cathode which is a low impedance point. Even so changes in load can cause the frequency to change quite a lot. The solution is to use a pentode and take the signal off the plate, as shown in Figure 4B.19.

Figure 4B.19 Electron Coupled Clap Oscillator.

For a verbal description click here.

This is called an Electron Coupled Oscillator because the screen grid takes the place of the plate in the triode circuit and the signal is coupled to the plate by the electrons that pass through the screen.

Notice that the screen voltage needs to be regulated and it doesn't hurt to regulate the plate voltage as well. The tuned circuit in the plate serves to clean up the waveform which is not a good sine wave if a resistor is used. R2 lowers the Q of L2 and C6 so it does not have to be tuned along with C1 and L1.

This oscillator can be plugged into the crystal socket on a 50 or 75 watt transmitter. If used as part of a transmitter it should be followed by a class A pentode stage before going into the class C stages. If used in a receiver or transceiver the output could probably be fed straight to the mixer.

Crystal Oscillators.

One solution to oscillator drift is to use a quarts crystal. If quarts crystals are cut in a certain way they are piezoelectric. Which means that if an electric field is placed across them, one or more of its mechanical dimensions will be altered. Conversely, if mechanical force is applied an electric potential will be developed. The process is known as bilateral which means it works both ways.

The crystal is cut into thin rectangular plates along a particular axis of the crystal. The subject of quarts crystals can fill a book all its own. No attempt will be made here to delve into the various orientations in which a crystal can be cut.

Every physical object has a mechanical resonant frequency. Some are low enough to hear such as a common drinking glass filled, or partly filled, with water. Early TV remote controls used aluminum rods about 3/8 inch in diameter and about 2 inches long. When one of these rods was struck on the end it would ring at a frequency above the range of human hearing. A specially designed microphone in the TV set would pick up the ultrasonic frequencies and after amplification a set of tuned circuits allowed the particular rod being struck to initiate the corresponding function. The tiny plates of quarts have mechanical resonant frequencies that are in the radio frequency range. When this mechanical resonance is translated into electrical resonance by the piezoelectric effect, the crystal exhibits the resonance of the circuit of Figure 4B.20a.

Figure 4B.20 (a) Equivalent Circuit of a Quartz Crystal,
and (b) Colpits Crystal Oscillator.

For a verbal description click here.

Because the series resonant circuit has a capacitor in parallel with it the overall effect is for the crystal to have a very low impedance at its series resonant frequency, and just a few hertz higher, a high impedance at its parallel resonant frequency. When ordering crystals you must specify which of the resonant modes you plan to use and if parallel, how much capacitance will be across the crystal.

Figure 4B.20b is the circuit of a Colpits oscillator. It operates the crystal in its parallel resonant mode. There are many crystal oscillator circuits but this is by far the best one for almost all crystals. Typical values for the capacitors are 33 pf for grid to cathode and 100 to 220 pf for cathode to ground.

The output may be taken off the cathode or if a cleaner waveform is desired a pentode may be used with a tuned circuit in its plate circuit as shown in figure 4B.19 above.

There is only one way to change the frequency of a crystal oscillator. Order a new crystal and when it comes in the mail, plug it into the socket. That's the price to be paid for a high degree of stability. In Chapter 9 of this book we will study the frequency synthesizer which gives both the agility of a tunable oscillator and the stability of a crystal oscillator. It would not be practical to construct one of these devices with vacuum tubes.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

4B.6 Problems.

  1. The plate resistance of the pentode section of a 6U8 is 0.4 Meg ohms. The RC amplifier data for it is as follows.

    Ebb = 250 volts.
    Rb = 270 k ohms.
    Rcf = 1.0 Meg ohms.
    Rc2 = 820 k ohms.
    Rk = 1200 ohms.
    Vin = 0.1 v.
    Vout = 22.0 v.
    Gain = 220.
    % Dist = 0.82 %.

    Calculate (a) the transconductance of the pentode under the above conditions, and (b) the gain of the amplifier if the cathode bypass capacitor is removed and the screen is bypassed to the cathode.

  2. A ham band receiver has a first IF of 2250 kHz, and the local oscillator operates above the incoming frequency. If the receiver is tuning the 3.5 to 4.0 MHz band what is the frequency range of the image?

  3. A doubly balanced mixer has the following input frequencies, 3.5 MHz, and 60 kHz. What frequencies will be present in its output?

  4. A singly balanced mixer has the following input frequencies, 1.5 MHz to the balanced input, and 2.5 MHz to the unbalanced input. What frequencies will be present in its output?

  5. The AGC voltage of a radio receiver is about -1 volt between stations and changes to -10 volts when a particular station is tuned in. A tuning eye (magic eye tube) in this radio will be,

    (a) closed when between stations and open when a station is tuned in.

    (b) open when between stations and closed when a station is tuned in.

  6. A wave on an oscilloscope is 3.4 cm from the lowest to the highest point and 2 complete cycles cover 8.7 cm. The controls on the scope are set as follows. Vertical to 50 milli volts/cm and time-base to 20 nsec/cm. A times 10 probe is in use. What is the RMS voltage of this wave?

  7. A wave on an oscilloscope is 3.4 cm from the lowest to the highest point and 2 complete cycles cover 8.7 cm. The controls on the scope are set as follows. Vertical to 50 milli volts/cm and time-base to 20 nsec/cm. A times 10 probe is in use. What is the frequency of this wave?

  8. An oscillator with a tapped coil is a;

    (a) Hartley.

    (b) Colpits.

    (c)Clap.

  9. An oscillator with the inductor and variable capacitor in series is a;

    (a) Hartley.

    (b) Colpits.

    (c)Clap.

  10. In an oscillator employing a tapped coil, When the coil is connected to the plate and grid the tap is;

    (a) at the center of the coil.

    (b) near one end.

  11. In an oscillator employing a tapped coil, When the coil is connected to the cathode and grid the tap is;

    (a) at the center of the coil.

    (b) near one end.

  12. In any of the oscillator circuits employing a triode tube the best waveform is found at;

    (a) the cathode.

    (b) the grid.

    (c) the plate.

  13. In an ECO the signal is coupled from the oscillator to the output by;

    (a) capacitive coupling.

    (b) magnetic inductive coupling.

    (c) the electrons inside the tube.

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

4B.7 Answers to Problems.

  1. (a) 1,585 micro mhos, (b) 98.0.

  2. 8.0 MHz to 8.5 MHz.

  3. 3440 kHz and 3560 kHz.

  4. 1.0 MHz, 2.5 MHz, and 4.0 MHz.

  5. (b)

  6. 1.7 volts.

  7. 11.5 MHz.

  8. (a)

  9. (c)

  10. (a)

  11. (b)

  12. (b)

  13. (c)

Back to Fun with Transistors.
Back to Fun with Tubes."
Back to Table of Contents.
Back to top.

This page copyright © Max Robinson. All rights reserved.


My Textbook.

For 33 years I taught a course at Western Kentucky University titled "Electronics for Physicists". I spent about the first half of that time trying to find the right textbook. The choices I had were either too low level with no derivations and little math, or were too theoretical, deriving everything but with not a trace of practicality. After much frustration I decided to write my own book for the course. Contrary to what you might think, physicists need a very practical course because after they get into graduate school they need to know how to use electronics as a tool to aid in their research. You can't just give an equation to a physics major and expect it to be taken on faith. They will lose interest in a course that is taught that way. I needed to put in enough derivations to keep them happy while presenting a solid practical course.

Although I tried I never succeeded in getting a publisher interested in it. I self published it through a copy shop near campus so the students could buy it. I retain all rights and posting it here does not mean I am placing it in the public domain.

You will find parts of it scattered around this site but the entire unedited book is here. If you get in early, some of the links won't be active yet. Keep checking back, I will get the whole thing up eventually.

Back to Fun with Transistors.
Back to Fun with Tubes."

Electronics For Physicists.

Table of Contents.

Chapter 0 Electrical Fundamentals.
0.1  Electrical Quantities From Mechanical Quantities.
0.2  Resistance and Ohm's Law.
0.3  Series Circuits and Kirchhoff's Voltage Law.
0.4  Parallel Circuits and Kirchhoff's Current Law.
0.5  Prefixes.
0.6  Numerical Examples.
0.7  Capacitance.
0.8  Inductance.
0.9  Problems.
0.10 Answers to Problems.

Chapter 1 DC Circuits.
1.1  Solving Complex Circuits Using Loop Equations.
1.2  Voltage Dividers.
1.3  Thevenin's Theorem.
1.4  Norton's Theorem.
1.5  Current Measurement, the D'Arsonval Meter.
1.6  Voltage Measurement.
1.7  Measurement Using Multimeters.
1.8  Problems.
1.9  Answers to Problems.

Chapter 2 AC Circuits.
2.1  Alternating Current.
2.2  Capacitive Reactance.
2.3  Inductive Reactance.
2.4  Series Circuits and Impedance.
2.5  RC Filter Circuits.
2.6  The Decibel (dB).
2.7  Graphing Frequency Response.
2.8  Nonsinusoidal Waves.
2.9  The Effect of RC Circuits on Nonsinusoidal Waves.
2.10 RLC Resonate Circuits.
2.11 Transformers.
2.12 The Oscilloscope.
2.13 Problems.
2.14 Answers to Problems.

Chapter 3 DC Power Supply Circuits.
3.1  Block Diagram of a Power Supply.
3.2  Protection Devices.
3.3  The Power Transformer.
3.4  The Semiconductor Diode.
3.4A The Vacuum Diode.
3.5  Rectifier Circuits.
3.6  Filtering the Rectifier's Output.
3.7  The Zener Diode Voltage Regulator.
3.8  Integrated Circuit Voltage Regulators.
3.9  Problems.
3.10 Answers to Problems.

Chapter 4 Transistors as Switches and Amplifiers.
4.1  The Bipolar Junction Transistor (BJT).
4.2  The BJT as a Switch.
4.3  The BJT as an Amplifier.
4.4  The Field Effect Transistor (FET).
4.5  The FET as a Switch.
4.6  The FET as an Amplifier.
4.7  Differential Amplifier.
4.8  Problems.
4.9  Answers to Problems.

Chapter 4A Triode Vacuum Tubes.
4A.1  The Triode (3 Element) Vacuum Tube.
4A.2  Triode Amplifier Graphical Analysis, Load Line.
4A.3  Triode Amplifier Small Signal Analysis.
4A.4  Resistance Coupled Amplifier Charts.
4A.5  The Miller Effect.
4A.6  Cathode Follower.
4A.7  Grounded Grid Amplifier.
4A.8  Cascode Amplifier.
4A.9  Problems.
4A.10 Answers to Problems.

Chapter 4B Multi Grid Tubes.
4B.1  Odes to Tetra and Penta.
4B.2  The Heptode, Pentagrid Converter.
4B.3  The Beam Deflection Tube.
4B.4  Magic Eye and Cathode Ray Tubes.
4B.5  Oscillators.
4B.6  Problems.
4B.7  Answers to Problems.

Chapter 5 Applying Feedback To Amplifier Circuits.
5.1  Some Preliminary Information.
5.2  The Negative Feedback Equation.
5.3  The Special Case of the Inverting Amplifier.
5.4  Frequency Response and Stability.
5.5  Gain Accuracy and Precision.
5.6  Other Benefits of Negative Feedback.
5.7  Some Practical Circuits.
5.8  Positive Feedback, Oscillators.
5.9  Problems.
5.10 Answers to Problems.

Chapter 6 The Operational Amplifier.
6.1  Op Amp Behavior.
6.2  Equations of the Op Amp.
6.3  The Unity-Gain Buffer Amplifier.
6.4  The Noninverting Amplifier.
6.5  The Inverting Amplifier.
6.6  The Summing Amplifier.
6.7  The Integrating Amplifier.
6.8  Single Power Supply Operation.
6.9  Understanding Op Amp Specifications.
6.10 Problems.
6.11 Answers to Problems.

Chapter 7 Operational Amplifier Circuits.
7.1  Instrumentation Amplifier.
7.2  AC Voltmeter Circuit.
7.3  Open-loop Linearization.
7.4  Absolute Value Amplifier.
7.5  Log Converter.
7.6  Active Filters.
7.7  Problems.
7.8  Answers to Problems.

Chapter 8 Digital Circuits.
8.1  The Binary Number System.
8.2  Logic Functions and Gates.
8.3  Boolean Algebra.
8.4  Combinational Logic Circuits.
8.5  Flip-Flops and Counters.
8.6  Displaying the Count.
8.7  Multiplexed Displays.
8.8  Digital to Analog Converter.
8.9  Analog to Digital Converter.
8.10 The 555 Timer.
8.11 Problems.
8.12 Answers to Problems.

Chapter 9 Digital Instruments.
9.1  Frequency Counter.
9.2  Digital Multimeter.
9.3  Frequency Synthesizer.
9.4  Problems.
9.5  Answers to Problems.

Appendix A   Standard Values for Electronic Components.

Appendix B   Reading Color Codes.

Appendix C   Transistor and IC Packages.

Back to Fun with Transistors.
Back to Fun with Tubes."

This page copyright © Max Robinson. All rights reserved.


 Figure 5.7.1. This is a screen shot of a computer program. The vertical axis is labeled Y value and goes from 0 at the bottom to 90 at the top. These are actually dB. Between every 10 dB mark are 5 smaller marks which are at 2 dB intervals. The horizontal axis is labeled X value and goes from minus 1 to plus 5 in steps of one. The frequency is 10 to the power of these numbers so the horizontal axis is really frequency on a log scale from 10 to the minus 1 to 10 to the 5. There are 4 curves on this graph. The red one starts at gain = 80 dB and frequency = 10 to the minus 1. It goes to the right and visibly falls away from the 80 dB line just past frequency = 1. It curves downward and is at 77 dB at 10 Hz. It straightens out and crosses through the point 60 dB and 100 Hz. It is now falling on a slope of minus 1 and passes through the points 40 dB, 1,000 Hz, 20 dB, 10,000 Hz, and 0 dB, 100,000 Hz. The green line starts on the left at 60 dB and 0.1 Hz. It falls away from the 60 dB line just to the right of 1 Hz. It passes through 57 dB at 100 hertz. It runs almost parallel with the red line and merges with it at two thirds of the way from 100 to 1,000 Hz. After that it follows the same path as the red line. The light blue line starts on the left at 59 dB and runs essentially parallel to the green line becoming curved at the same place. It passes through 56 dB at 100 Hz. It merges with the green line at about one third of the way between 100 and 1,000 Hz and merges with the red line at two thirds. The dark blue line begins merged with the light blue line. Dark drops below light just to the left of 10 Hz. It continues to fall below the light blue line and passes through 54 dB at 100 Hz. The dark blue line starts getting closer to the light blue line but more slowly then the others approached each other. The dark blue line finally merges with the other three about half way between 1,000 and 10,000 Hz. End verbal description.
Go back.


 Figure 0.1. A battery on the left has its negative terminal connected to the bottom line of the circuit. The positive end goes to the left end of a single pole single throw switch. The right end of the switch goes to the top end of a lamp. The lower end of the lamp connects to the bottom line of the circuit making a complete loop. End verbal description.


 Figure 0.2. A battery on the left has its negative terminal connected to the bottom line of the circuit. The battery is labeled E. The positive end goes to the left end of a resistor which is labeled R1. The right end of R1 connects to the left end of R2. The right end of R2 connects to the top of R3. The bottom end of R3 connects to the bottom line of the circuit making a complete loop. There is an arrow indicating that there is a current I, flowing in a clockwise direction around the circuit loop. Each resistor has a V associated with it. V1 is across R1, V2 across R2 and V3 across R3. End verbal description.


 Figure 0.3. A battery on the left is labeled E1 and has its negative terminal connected to the bottom line of the circuit. The positive end goes to the Bottom end of a resistor labeled R1. The top end of R1 goes to the left end of R2. The right end of R2 goes to the negative end of a battery labeled E2. The positive end of E2 goes to the left end of R3. The right end of R3 connects to the top end of R4. The bottom end of R4 connects to the positive end of a battery labeled E3. The bottom end of E3 connects to the bottom line of the circuit making a complete loop. There is an arrow indicating that a current I is flowing around the circuit in a clockwise direction. End verbal description.


 Figure 0.4. There are two parts to this figure. In part A there is a terminal on the left. This terminal connects to the left end of a resistor labeled R1. The right end of R1 connects to the left end of R2. The right end of R2 connects to the left end of R3. The right end of R3 connects to a terminal on the right. In part b there is a terminal on the left which connects to the left end of a resistor. This resistor is labeled R e q. The right end of this resistor connects to a terminal on the right. End verbal description.


 Figure 0.5. There are two parts to this figure. In part A a battery on the left is labeled E and has its negative terminal connected to the bottom line of the circuit. The positive end connects to the left end of a resistor labeled R1. The right end of R1 connects to the left end of R2. The right end of R2 connects to the top of R3. The bottom end of R3 connects to the bottom line of the circuit making a complete loop. In part B a battery labeled E has its negative end connected to the bottom line of the circuit. The positive end connects to the top of a resistor which is labeled R e q. The bottom end of R e q connects to the bottom line of the circuit making a complete loop. End verbal description.


 Figure 0.6. In this circuit the battery and all three resistors are drawn vertically. The battery on the left is labeled E and has it's negative terminal connected to the bottom line of the circuit. The positive terminal of the battery is connected to the top line of the circuit. A resistor labeled R1 has its lower end connected to the bottom line and its upper end connected to the top line. Another resistor R2 is similarly connected. A third resistor is similarly connected. At the lower left an arrow indicates that a current, I, is flowing upward into the negative, lower end, of the battery. This is conventional current. Another arrow indicates that the current, I is flowing out of the positive, upper, terminal of the battery. Another arrow indicates that another current I1 is flowing downward into the upper end of R1, Another arrow indicates that the current, I1 is flowing downward out of the lower end of R1. Similarly, I2 is flowing into the top and out of the bottom of R2. Similarly a current, I3, is flowing into the top and out of the bottom of R3. End verbal description.


 Figure 0.7. In this figure one line begins at the left but splits into 3 lines. The top line goes up and over and back down to the center right where it is rejoined by the other two lines. The second line goes up, but not as high as the first one, then down to be a little below the center and then back up to rejoine the other two lines. The third line goes down, making a negative hill and goes back up to rejoine the other two on the right. After the three lines recombine there is a short length of a single line going on to the right. There are no other connections to any of the lines. End verbal description.


 Figure 0.8. There are two parts to this figure. In part A there are two terminals, one at the upper left and the other at the lower left. The upper terminal connects to the top line of the circuit and the lower terminal connects to the bottom line. A resistor labeled R1 connects vertically from the top line to the bottom line. Similarly a resister labeled R2 is positioned to the right of R1 and connects between the upper and lower lines. A third resistor labeled R3 is positioned to the right of R2 and is connected in the same way. In part B there are also two terminals connected to a top line and a bottom line. There is only one resistor connected between the top and bottom lines and it is labeled R e q. End verbal description.


 Figure 0.9. There are two parts to this figure. In part A there is a battery on the left which is drawn vertically. The negative, bottom, end connects to the bottom line of the circuit. The positive, upper, end connects to the top line of the circuit. The battery is labeled E. There is a resistor labeled R1 that has its bottom end connected to the bottom line of the circuit and it's top end connected to the top line of the circuit. R2 and R3 are similarly connected to the top and bottom lines of the circuit. In part B the battery is connected as in part A. There is only one resistor in part B and it is labeled R e q. The lower end of R e q connects to the bottom line of the circuit, battery negative, and the upper end of R e q connects to the top line of the circuit, battery positive. End verbal description.


 Figure 0.10. A battery on the left, which is labeled E, has its negative end connected to the bottom line of the circuit. The positive end goes to position 2, one of the stationary contacts, of a single pole, double throw switch. Position 1 of the switch goes to the bottom line of the circuit. The swinger connects to a resistor labeled R. The other end of the resistor connects to a capacitor labeled C. The other end of the capacitor connects to the bottom line of the circuit. End verbal description.


 Figure 0.11. An inductor is connected across a battery. The inductor is drawn horizontally and the left end is connected to the positive end of the battery and the right end is connected to the negative. There is a legend under the inductor. Normal shows the left end of the inductor positive and right end negative. Due to a decrease the left end is marked negative and the right end is positive. Due to an increase, the left end is positive and the right end negative. End verbal description.


 Figure 0.12. A battery on the left, which is labeled E, has its negative end connected to the bottom line of the circuit. The positive end goes to position 2, one of the stationary contacts, of a single pole, double throw switch. Position 1 of the switch goes to the bottom line of the circuit. The swinger connects to a resistor labeled R. The other end of the resistor connects to an inductor labeled L. The other end of the inductor connects to the bottom line of the circuit. End verbal description.


 Figure 1.0. On the left is a battery with the positive terminal up. On the right is a resistor. A line, representing a length of wire, connects from the top, positive, end of the battery to the top of the resistor. Another line connects from the negative end of the battery to the bottom end of the resistor. There are plus and minus marks on the battery indicating that the bottom end is negative and the top end is positive. Similarly there are signs indicating that the bottom end of the resistor is negative and the top end is positive. A semicircle with an arrowhead on one end indicates that the current in the circuit is flowing clockwise around the circuit. End verbal description.


 Figure 1.1. On the left is a battery labeled E1 which has its negative end connected to the bottom line of the circuit. The positive end of E1 connects to the left end of a resistor, R1. The right end of R1 connects to the top end of R2. The bottom end of R2 connects to the bottom line. The junction of R1 and R2 connects to the left end of R3. The right end of R3 connects to the top end of another battery labeled E2. The bottom end of E2 connects to the bottom line. On the left a semicircle and arrowhead indicates that I1 is flowing clockwise through E1, R1, and R2. Another semicircle and arrowhead indicates that I2 is flowing clockwise through R2, R3, and E2. Everything has polarity markings. The upper ends of both batteries are positive. The left ends of R1 and R3 are positive. R2 has two sets of polarity markings because there are two currents flowing through it. On the left I1 causes the upper end of R2 to be positive. On the right I2 causes the lower end of R2 to be positive. This seeming contradiction can exists because of the superposition theorem. End verbal description.


 Figure 1.2. This diagram is similar to Figure 1.1 with the exception of the battery on the right which is reversed. On the left is a battery labeled E1, 12 v, which has its negative end connected to the bottom line of the circuit. The positive end of E1 connects to the left end of a resistor, R1, 330 ohms. The right end of R1 connects to the top end of R2, 75 ohms. The bottom end of R2 connects to the bottom line. The junction of R1 and R2 connects to the left end of R3, 100 ohms. The right end of R3 connects to the top, negative, end of another battery labeled E2, 6 v. The bottom end, positive, of E2 connects to the bottom line. On the left a semicircle and arrowhead indicates that I1 is flowing clockwise through E1, R1, and R2. Another semicircle and arrowhead indicates that I2 is flowing clockwise through R2, R3, and E2. Everything has polarity markings. The upper end of battery E1 is positive and the upper end of E2 is negative. The left ends of R1 and R3 are positive. R2 has two sets of polarity markings because there are two currents flowing through it. On the left I1 causes the upper end of R2 to be positive. On the right I2 causes the lower end of R2 to be positive. This seeming contradiction can exists because of the superposition theorem. End verbal description.


 Figure 1.3. On the left is a battery labeled E. Its lower, negative, terminal connects to the bottom line of the circuit. Its top end, positive, end connects to the top of a resistor, R1. The bottom end of R1 connects to the top end of R2. The bottom end of R2 connects to the bottom line. There are two output terminals. The top one connects to the junction of R1 and R2. The lower one connects to the bottom line of the circuit. End verbal description.


 Figure 1.4. There are two input terminals on the left and 6 output terminals on the right. The two input terminals are labeled V in. The bottom input terminal connects to the bottom line of the circuit. The top input terminal connects to the top of R1, 700 k ohms. The bottom of R1 connects to the top of R2, 200 k ohms. The bottom of R2 connects to the top of R3, 70 k ohms. The bottom of R3 connects to the top of R4, 20 k ohms. The bottom of R4 connects to the top of R5, 10 k ohms. The bottom of R5 connects to the bottom line of the circuit. On the right the bottom output terminal is labeled common and connects to the bottom line of the circuit. Starting at the top, output terminal 1 connects to the top of R1. Terminal 2 connects to the junction of R1 and R2. Terminal 3 connects to the junction of R2 and R3. Terminal 4 connects to the junction of R3 and R4. Terminal 5 connects to the junction of R4 and R5. End verbal description.


 Figure 1.5. On the left is a battery labeled E1. Its negative terminal is connected to the bottom line of the circuit. The top, positive, end is connected to the left end of a resistor, R1. The right end of R1 is connected to the top end of R2. The bottom end of R2 is connected to the bottom line. The junction of R1 and R2 connects to the left, negative, end of a battery, E2. The right, positive, end of E2 connects to the left end of R3. The right end of R3 connects to the top end of R4. The bottom of R4 connects to the bottom line. The junction of R3 and R4 connects to the left end of R5. The right end of R5 connects to the upper output terminal. The lower output terminal connects to the bottom line of the circuit. End verbal description.


 Figure 1.6. There is an ideal voltage source on the left. The symbol is a circle with a plus sign near the upper, positive terminal. The bottom end of the source goes to the bottom line of the circuit. The voltage source is labeled V Th. The top end of V Th connects to the left end of a resistor labeled R Th. The right end of R Th connects to the upper output terminal. The lower output terminal connects to the bottom line of the circuit. End verbal description.


 Figure 1.7. This figure is very similar to Figure 1.5. On the left is a battery labeled E1. Its negative terminal is connected to the bottom line of the circuit. The top, positive, end is connected to the left end of a resistor, R1. The right end of R1 is connected to the top end of R2. The bottom end of R2 is connected to the bottom line. The junction of R1 and R2 connects to the left, negative, end of a battery, E2. The right, positive, end of E2 connects to the left end of R3. The right end of R3 connects to the top end of R4. The bottom of R4 connects to the bottom line. The junction of R3 and R4 connects to the left end of R5. The right end of R5 connects to the upper output terminal. The lower output terminal connects to the bottom line of the circuit. Here is where the circuit begins to be different from Figure 1.5. There is a semicircle with an arrowhead indicating that I1 flows clockwise through E1, R1, and R2. Another semicircle and arrow head shows I2 flowing clockwise through R2, E2, R3, and R4. Another semicircle indicates that a current I3 is flowing through R4, R5, and the open circuit of the output terminals. I3 must be equal to zero because current cannot flow through an open circuit. Polarity markings on R1 and R3 indicate that the left ends are positive. Polarity markings on the left side of the vertical resistors R2, and R4, indicate that the upper end is positive. Polarity markings on the right side of the vertical resistors R2, and R4, indicate that the lower end is positive. R5 has no polarity markings. Each of the two batteries have a plus sign next to the positive terminal and a minus sign next to the negative terminal. End verbal description.


 Figure 1.8. On the left the battery labeled E1 has been removed and replaced by a short circuit, a piece of wire, a line. The left end of a resistor, R1 = 240 ohms, connects to the bottom line. The right end of R1 is connected to the top end of R2 = 400 ohms. The bottom end of R2 is connected to the bottom line. The junction of R1 and R2 connects to the left end of R3 = 350 ohms. E2 is also replaced by a short circuit. The right end of R3 connects to the top end of R4 = 750 ohms. The bottom of R4 connects to the bottom line. The junction of R3 and R4 connects to the left end of R5 = 100 ohms. The right end of R5 connects to the upper output terminal. The lower output terminal connects to the bottom line of the circuit. End verbal description.


 Figure 1.9. There is an ideal voltage source on the left. The bottom end of the source goes to the bottom line of the circuit. The voltage source is labeled V Th = 13.05 v. The top end of V Th connects to the left end of a resistor labeled R Th = 400 ohms. The right end of R Th connects to the upper output terminal. The lower output terminal connects to the bottom line of the circuit. End verbal description.


 Figure 1.10. There is a battery on the left labeled E1 = 12 v. The lower end, negative, connects to the bottom line of the circuit. The upper, positive, end connects to the left end of a resistor, R1 = 330 ohms. The right end of R1 connects to the left end of another resistor R3 = 100 ohms. The right end of R3 connects to the top, negative, end of a battery. The lower, positive end goes to the bottom line. The battery is labeled E2 = 6 volts. At the junction of R1 and R3 is an output terminal. Below it is another output terminal which is connected to the bottom line. These two terminals are labeled, load. This is where R2 used to be. End verbal Description.


 Figure 1.11. On the left an ideal voltage source is labeled V Th = 1.814 v. The lower, positive end, connects to the bottom line of the circuit. The top, negative end, of V Th connects to the left end of a resistor labeled R Th = 76.74 ohms. The right end of R Th connects to the top output terminal. The bottom line connects to the lower output terminal. There is a resistor connected across the two output terminals. It is labeled R2 = 75 ohms. End verbal description.


 Figure 1.12. On the left an ideal voltage source is labeled 7.87 v. Its bottom end is connected to the bottom line of the circuit. The top end connects to the left end of a resistor which is labeled with a question mark. The right end of this resistor connects to the upper output terminal. The lower output terminal is connected to the bottom line. There is a resistor connected across the output terminals. It is labeled R L = 100 ohms. There is a label indicating that the voltage between the two output terminals is 5.20 volts. End verbal description.


 Figure 1.13. On the left is an ideal current source. The symbol is a circle with an arrow inside. The arrow points in the direction of current flow. In this circuit the arrow is pointing up. The current source is labeled I N. The bottom end of I N is connected to the bottom line of the circuit. The upper end is connected to the top end of a resistor labeled R N. The lower end of R N is connected to the bottom line. The upper output terminal is connected to the top of I N and R N. The lower terminal is connected to the bottom line. End verbal description.


 Figure 1.14. There is a battery on the left labeled E1 = 12 v. The lower end, negative, connects to the bottom line of the circuit. The upper, positive, end connects to the left end of a resistor, R1 = 330 ohms. The right end of R1 connects to the left end of another resistor R3 = 100 ohms. The right end of R3 connects to the top, negative, end of a battery. The lower, positive end goes to the bottom line. The battery is labeled E2 = 6 volts. At the junction of R1 and R3 is an output terminal. Below it is another output terminal which is connected to the bottom line. These two terminals are labeled, load. This is where R2 used to be. There is a short circuit across the two terminals. End verbal Description.


 Figure 1.15. On the left is an ideal current source. The arrow is pointing up. The current source is labeled I N = 23.636 mA. The bottom end of I N is connected to the bottom line of the circuit. The upper end is connected to the top end of a resistor labeled R N = 76.744 ohms. The lower end of R N is connected to the bottom line. The upper output terminal is connected to the top of I N and R N. The lower terminal is connected to the bottom line. There is a resistor connected across the terminals. It is labeled R2 = 75 ohms. End verbal description.


 Figure 1.16. On the left is a battery labeled E = 30 v. The bottom, negative, end is connected to the bottom line of the circuit. The top, positive, end connects to the left end of a resistor labeled R1 = 2 k ohms. The right end of R1 connects to the top of another resistor labeled R2 = 1 k ohm. The bottom end of R2 connects to the bottom line. The lower output terminal connects to the bottom line. The upper output terminal connects to the junction of R1 and R2. End verbal description.


 Figure 1.17. This is a 3 dimensional drawing of a de arson a vall meter movement. The main features are a permanent magnet and a rotating coil with a pointer attached. First the magnet. This is somewhat like a horseshoe magnet except it is completely circular. It is about two inches in diameter and the hole in the center is about 1 inch in diameter. The magnet is about 3/4 of an inch thick. There is a thin cutout where the poles are. Because of the cutout it is not a complete circle and therefore has two ends. Instead of the ends of the magnet being flat they form a circular hole as if drilled out. At the inside and outside of the ring the poles almost touch. In the center they are about half an inch apart. Now for the coil. It is wound of fine wire and is held by a rectangular piece of some insulating material and a lot of glue. It appears as if the wire is self supporting with nothing holding it together. This rectangular coil is a little less than half an inch wide and 3/4 of an inch long. In the middle of the short side on each end is a short piece of springy metal known as a taught band. The free ends of the band are attached to a support which is in turn attached to the magnet across the opening between the poles, not the big hole in the center. The bands also make electrical connection to the ends of the coil. The coil does not touch the poles of the magnet but is very close to them. The pointer is attached to the coil. The taught bands hold it at a particular position but when a current flows through the wire the coil can rotate on an axis that is parallel to the axes of the holes. It can rotate a little over 100 degrees before the pointer runs into the supporting structure. A nonmagnetic metal plate has a scale printed on it for the pointer to move along. The scale hides the magnet and coil from view. End verbal description. Note. The spelling of de arson a vall has been fractured to make Jaws pronounce it correctly, or as close as I can come. I can't say how it will do with Window Eyes or some screen reader that is not on the market at this writing.


 Figure 1.18 . There are two parts to this figure. In part eh there is a battery with its negative terminal connected to the bottom line of the circuit. The positive end connects to one end of a switch. The other end of the switch connects to one end of an incandescent lamp. The other end of the lamp is connected to the bottom line. In part b there is a battery with its negative terminal connected to the bottom line of the circuit. The positive end connects to one end of a switch. The other end of the switch connects to the positive end of an ammeter. The other end of the ammeter connects to one end of an incandescent lamp. The other end of the lamp is connected to the bottom line. End verbal description.


 Figure 1.19. On the left is a 12 volt battery, E1, with its positive terminal facing up. The positive end of E1 connects to the left end of R1, 330 ohms. The right end of R1 connects to the top of R2, 75 ohms. The bottom of R2 connects to the positive, right, end of a milliamp meter. The negative, left end goes to the negative, bottom, end of E1. The junction of R1 and R2 connects to the left end of R3, 100 ohms. The right end of R3 connects to the top, negative end, of E2, 6 v. The lower, positive end, of E2 connects to the positive, right end, of another milliamp meter. The left end connects to the junction of R2 and the other milliamp meter. There are semicircles with arrowheads indicating that I1 is flowing clockwise in the loop on the left and I2 is flowing clockwise in the loop on the right. End verbal description.


 Figure 1.20. There are two terminals on the left. The top terminal connects to the top end of a resistor which is labeled R S. The bottom end of R S connects to the bottom terminal. The junction of the top terminal and the top end of R S connects to the top, positive end, of a microamp meter. The negative, lower end, connects to the junction of the lower end of R S and the bottom terminal. There is an arrow next to the upper terminal indicating that a current, I, is flowing to the right. There is an arrow next to R S indicating that a current, I S, is flowing downward. There is an arrow next to the meter indicating that a current, I M, is flowing downward. End verbal description.


 Figure 1.21. There are two terminals on the left. The top terminal connects to the top end of R S. The bottom end of R S connects to the bottom terminal. The junction of the top terminal and the top end of R S connects to the left end of another resistor labeled R1. The right end of R1 connects to the top, positive end, of a microamp meter. The negative, lower end, connects to the junction of the lower end of R S and the bottom terminal. There is an arrow next to the upper terminal indicating that a current, I, is flowing to the right. There is an arrow next to R S indicating that a current, I S, is flowing downward. There is an arrow next to the meter indicating that a current, I M, is flowing downward. End verbal description.


 Figure 1.22. On the left a battery, E, has its negative end connected to the bottom line of the circuit. The top, positive end, connects to The positive end of an ammeter or milliamp meter. The other end of the meter connects to the top end of a resistor labeled R L. The lower end of R L connects to the bottom line of the circuit. End verbal description.


 Figure 1.23. There are two terminals on the left. The upper terminal connects to the left end of a resistor labeled R V. The right end of the resistor connects to the upper, positive end, of a microamp meter. The other end of the meter connects to the lower terminal. End verbal description.


 Figure 1.24. There are two terminals on the left. The upper terminal connects to the left end of a resistor labeled R V. The right end of R V connects to the left end of another resistor which is labeled with a value, 98.2 k ohms. The right end of this resistor connects to the upper, positive end, of a microamp meter. The other end of the meter connects to the lower terminal. The meter is labeled I M = 50 microamps, R M = 1800 ohms. End verbal description.


 Figure 1.25. On the left is an ideal voltage source labeled V Th. The bottom end is connected to the bottom line of the circuit. The top, positive end, connects to the left end of a resistor labeled R Th. The right end of R Th goes to the upper terminal. The lower terminal connects to the bottom line of the circuit. A voltmeter is shown connected to the terminals, one lead to each terminal. The symbol for a voltmeter is a circle with the letter V inside it. End verbal description.


 Figure 1.26. On the left is a pair of input terminals. The lower one connects to the bottom line of the circuit. The upper one connects to the switch rotor. The symbol is an arrowhead on the end of a line pointing up. Above this is a string of resistors. The first on the left is labeled R5. Hanging down from the left end of R5 is a line with a small circle on its end. This is one of the switch stator contacts. This stator is labeled 250 v. The right end of R5 connects to the left end of R4. There is another switch stator hanging down from the junction of R5 and R4. It is labeled 50 v. In the same manner R4 connects to R3 and the stator at this point is labeled 10 v. The switch rotor, arrowhead, is shown touching this stator point. R3 connects to R2 and the stator is labeled 2.5 v. R2 connects to R1 and the stator is labeled 1 v. The right end of R1 connects to the top, positive end, of the microamp meter. The bottom end of the meter connects to the bottom line of the circuit. End verbal description.


 Figure 2.1. Part (eh) shows two cycles of a sine wave. Part B shows two cycles of a square wave. The value starts at zero and goes straight up to the top. It runs along horizontally until it turns straight down to a point as far below zero as it was above zero. before. Then it goes horizontally along until turning straight up again to the level where it started. That completes one cycle. The next cycle is an exact duplicate of the first. Part C is a triangular wave. It starts at zero and goes up to the right to a peak. At the peak it turns downward going down to the right to a point as far below zero as it was above before. Then it turns up and to the right again with this cycle ending at zero. The next cycle is a repeat of the first. Part D is a sawtooth wave. It starts at zero going up to the right. At the peak it turns and goes straight down. At the bottom which is as far below zero as it was above it turns and goes up to the right again ending at zero. Subsequent cycles are duplicates of the first. There a total of 4 cycles of this wave. End verbal description.


 Figure 2.2. There is an AC generator at left. The symbol is a circle with one cycle of a sine wave inside. The generator is labeled V sub G. The top of the generator goes to one end of a resistor which is labeled R. The other end of the resistor connects to one end of a capacitor which is labeled C. The other end of the capacitor connects back to the bottom end of the generator. End verbal description.


 Figure 2.3. Three lines join at the left. One of the lines extends horizontally to the right. About two thirds along the way to the end is an arrowhead. The arrowhead points to the right and is labeled V sub R. At the right end of the line is another arrowhead which is also pointing to the right and is labeled I. At the left where the lines join is another line which extends straight down. At the lower end of this line is an arrowhead which is pointing down and is labeled V sub C. The third line departs from the joining point and goes down and to the right. The end of the line is directly under the point of the arrowhead which is labeled V sub R. The end is also exactly to the right of the point of the arrowhead which is labeled V sub C. There is an arrowhead on the end of the sloping line which is pointing down and to the right. This point is labeled V sub G. There is an arc indicating the angle between the horizontal line and the sloping line. This angle is labeled theta. Although not shown in the diagram a line could be drawn straight down from V sub R to V sub G. Another line could be drawn horizontally from V sub C to V sub G, completing a rectangle which measures V sub R horizontally, and V sub C vertically. V sub G is the diagonal of the rectangle. End verbal description.


 Figure 2.4. Part eh is the schematic diagram of a series circuit. There is an AC voltage generator at the left. It is labeled V sub G. The top of the generator connects to a resistor labeled R. The other end of the resistor connects to one end of an inductor labeled L. The other end of the inductor connects back to the bottom of the generator. Part B is the phasor diagram for this circuit. It is quite similar to the phasor diagram above for the RC circuit except that instead of a line going straight down from the joining point, a line goes straight up from this point. There is an arrowhead on the top end of the line which is point up. This point is labeled V sub L. The diagonal line goes up to the right and the end of the line with the arrowhead is labeled V sub G. The angle theta is measured from V sub R to V sub G. A rectangle could be constructed on this diagram the same as the one above. End verbal description.


 Figure 2.5. Part eh is the schematic diagram. There is an AC generator at left. The top of the generator connects to one end of a resistor labeled R. The other end of the resistor connects to one end of an inductor labeled L. The other end of the inductor connects to one end of a capacitor labeled C. The other end of the capacitor connects back to the bottom end of the generator. Part B is the phasor diagram. There are 4 lines which join at the left. The first one goes horizontally to the right and about two thirds of the way along is an arrowhead pointing to the right and labeled V sub R. At the right end of the line is another arrowhead pointing to the right and labeled I. From the joining point a line goes straight down. There is an arrowhead at the end which is pointing down and is labeled V sub C. Another line goes from the joining point straight up. This line is about 2 and a half times as long as the one going down. At the upper end of the line is an arrowhead point up and it is labeled V sub L. On this same line a short distance up from the joining point is another arrowhead pointing up and it is labeled V sub L minus V sub C. It is to scale. The V sub G line goes up to the right and its end is above the V sub R point and to the right of the V sub C minus V sub L point. The angle theta is measured from the V sub R line to the V sub G line. End verbal description.


 Figure 2.6. This is a frequency response graph. The horizontal axis is labeled Frequency in hertz. The scale is from 1 to 1 M which stands for 1 million. The distance between 1 and 10 is one sixth of the entire horizontal graph. The distance between 10 and 100 is also one sixth of the horizontal. Each decade covers one sixth of the horizontal distance. There are intermediate marks between 1 and 10 that are approximately one third of the distance between 1 and 10. These marks are at 2 and 5. There are similar intermediate marks at 20 and 50, also at 200 and 500 and so on. The vertical axis is labeled attenuation in dB. It is linear. The top of the scale is 10, the next line down is zero, the next minus 10, next at minus 20, and so on down to the bottom line which is minus 60. The distance between zero and minus 10 is the same as that between minus 10 and minus 20 and is the same as between minus 20 and minus 30 and so on. Now for the data curve. At 1 hertz the value is zero dB. It continues flat to the right and is still zero at 200 hertz. Just after 200 hertz it begins to fall away from zero. At 500 hertz it appears to be at about minus 1 and at 1000 hertz it is at minus 3 dB. At 2000 hertz it is at about minus 6 and at 5000 hertz it is at about minus 14. Somewhere between 2000 and 5000 hertz the data curve becomes a straight line sloping down to the right. At 10000 hertz it is at minus 20 dB, at 100000 hertz it is at minus 40, and at one million it is at minus 60 dB. End verbal description.


 Figure 2.7. The scales on this graph are exactly the same as for figure 2.6. skip graph scale description. This is a frequency response graph. The horizontal axis is labeled Frequency in hertz. The scale is from 1 to 1 M which stands for 1 million. The distance between 1 and 10 is one sixth of the entire horizontal graph. The distance between 10 and 100 is also one sixth of the horizontal. Each decade covers one sixth of the horizontal distance. There are intermediate marks between 1 and 10 that are approximately one third of the distance between 1 and 10. These marks are at 2 and 5. There are similar intermediate marks at 20 and 50, also at 200 and 500 and so on. The vertical axis is labeled attenuation in dB. It is linear. The top of the scale is 10, the next line down is zero, the next minus 10, next at minus 20, and so on down to the bottom line which is minus 60. The distance between zero and minus 10 is the same as that between minus 10 and minus 20 and is the same as between minus 20 and minus 30 and so on. Now for the data curve. At 1 hertz the value is minus 60 dB. It is a straight line sloping up to the right. At 10 hertz it is at minus 40, and at 100 it is at minus 20 dB. Somewhere between 200 and 500 hertz it becomes a curve passing through approximately minus 6 dB at 500 hertz, minus 3 at 1000, minus 1 at 2000 hertz and very close to zero at 5000 hertz. The line goes on to the right at zero to one million hertz. End verbal description.


 Figure 2.8. There are two parts to this figure, a schematic diagram and a graph. In the schematic diagram there is a AC generator on the left. It is labeled V = V sub P sine 2 Pi f t. The top of the generator connects to the negative end of a battery. The positive end of the battery connects to the upper output terminal. The lower end of the generator connects to the bottom output terminal. In the graph there is a vertical axis representing voltage and a horizontal axis representing time. The graph is of a sine wave and it begins quite high on the voltage axis. It goes up and down moving to the right. The negative peaks are about as far from the zero volta line as the sine wave is tall. The sine wave is up in the air, all values positive, never coming close to zero. End verbal description.


 Figure 2.9. This figure has 3 parts. There is a wave graph on the left, a circuit in the middle and a wave graph on the right. The wave on the left Is the input to the circuit and the one on the right is the output which would result from the input. The circuit is as follows. There are two input terminals on the left. The top terminal connects to one end of a resistor labeled R. The other end of the resistor connects to one end of a capacitor labeled C. The other end of the capacitor connects to the bottom line of the circuit. The junction of the resistor and capacitor connects to the top output terminal. The lower input terminal connects to the bottom line as does the lower output terminal. The wave on the left is a sine wave which is far above zero indicating an Ac plus DC source. On the right the sine wave is very small in amplitude but has the same frequency as the one on the left. The average value of the small sine wave on the right is the same as that of the larger sine wave on the left. End verbal description.


 Figure 2.10. This figure has 3 parts. There is a wave graph on the left, a circuit in the middle and a wave graph on the right. The wave on the left Is the input to the circuit and the one on the right is the output which would result from the input. The circuit is as follows. There are two input terminals on the left. The top terminal connects to one end of a capacitor labeled C. The other end of the capacitor connects to one end of a resistor labeled R. The other end of the resistor connects to the bottom line of the circuit. The junction of the resistor and capacitor connects to the top output terminal. The lower input terminal connects to the bottom line as does the lower output terminal. The wave on the left is a sine wave which is far above zero indicating an eh c plus DC source. On the right the sine wave is identical in amplitude and frequency to the one on the left. The average value of the small sine wave on the right is zero. It is equally above and below the zero volt line on the graph. End verbal description.


 Figure 2.11. This is a graph. The horizontal axis is labeled Frequency in Megahertz and goes from 0 to 1. 0.5 MHz is exactly half way across the graph making it a linear scale. The vertical axis is labeled Attenuation ratio A sub R. it also goes from zero to one and is linear. The data curve begins at A sub R = 1 and frequency = zero. It goes straight down the left line departing from the left hand line at about A sub R = 0.2. What follows is an approximate reading of the graph without regard to the equation that generated the line. The values are read in the order Frequency, A sub R. 0.01, 0.15. 0.02, 0.1. 0.03, 0.05. 0.04, 0.03. 0.05, 0.02. The data line merges with the frequency axis at about 0.1. It goes all the way to 1 on the A sub R = 0 line. End verbal description.


 Figure 2.12. This is a graph. The horizontal axis is labeled Frequency in kilohertz and goes from 0 to 6. 3 kHz is exactly half way across the graph making it a linear scale. The vertical axis is labeled Attenuation ratio A sub R. it goes from zero to one and is also linear. The data curve begins at A sub R = 1 and frequency = zero. It goes horizontal for a very short distance, approximately 0.1 kHz then begins to fall. The points are, frequency, A sub R. 1, 0.7. 2, 0.42. 3,0.3. 4,0.25. 5,0.2. 6,0.15. End verbal description.


 Figure 2.13. The horizontal axis is labeled Frequency in hertz. The scale is from 1 to 1 M which stands for 1 million. The distance between 1 and 10 is one sixth of the entire horizontal graph. The distance between 10 and 100 is also one sixth of the horizontal. Each decade covers one sixth of the horizontal distance. There are intermediate marks between 1 and 10 that are approximately one third of the distance between 1 and 10. These marks are at 2 and 5. There are similar intermediate marks at 20 and 50, also at 200 and 500 and so on. The vertical scale is attenuation ratio, A sub R, which goes from 0 to 1. The data line starts at 1 hertz and A sub R = 1. It remains at 1 until about 100 Hz. The curve data are given in the order, frequency, A sub R. 200, 0.95. 500, 0.85. 1000, 0.7. 2000, 0.45. 5000, 0.2. 10000, 0.1. 20000, 0.05. 50000, 0.02. 100000, 0.005. Above 100000, 0. End verbal description.


 Figure 2.14. Picture a rectangle longer than it is high. Along the top edge are 3 holes representing a piece of 3 ring notebook paper. There is a smaller rectangle inside the large one representing the area of the graph on the paper. There are vertical lines within this rectangle and they are far apart at the left and get closer together toward the center. To the right of the center the lines are far apart again and then closer together toward the right edge of the inner rectangle. At the top there are numbers that are close to the top line of the inner rectangle and above it. Above the left most line is the number 1. The next vertical line has no number. The next one is labeled 2, the next 3 and so on up to 6. The next line has no label and the one after that is labeled 8. Another line is skipped and the next is labeled 1. The 1 is higher, being farther from the top line than the previous set of numbers. The same pattern is followed until the far right line is labeled 1. The numeral 1 is farther from the top line than the previous set of numbers. There are numeric labels at the bottom of the picture under the bottom line of the inner rectangle. The left most line is labeled 100. The line which has a 2 at the top is labeled 200. The line in between would be 150. the lines for 3 and 4 are not labeled at the bottom. The line with a 5 at the top is labeled 500. The lines for 6, 7, 8, and 9, are not labeled at the bottom. The line which has a 1 a little farther away from the top line is labeled 1k. The next line which is 1.5 k is not labeled at top or bottom. The next line is labeled at the bottom 2k. The next two which are labeled 3 and 4 at the top are not labeled at the bottom the 5 line is labeled 5k. The lines for 6, 7, 8, and 9, are not labeled at the bottom. The right hand line with the 1 at the top which is even farther away from the top line is labeled at the bottom 10k. End verbal description.


 Figure 2.15. There is a horizontal line which represents frequency. The left end is labeled F = 0. A point a little to the right is labeled F. To the right of that and twice the distance from 0 to F is a point labeled 3F. The same distance to the right is another point labeled 5F. On to the right are 7F, and 9F. There are vertical lines above each point except F = 0. The line at F is a certain length. The line at 3F is one third the length of that at F. The line at 5F is one fifth the length of the line at F. Similarly the lines at 7F and 9F are one over 7 and 1 over 9 of the length of the line at F. This drawing was carefully drawn to scale. End verbal description.


 Figure 2.16. There are three parts to this figure. The first part shows one cycle of a sine wave. On the same axis is another sine wave showing 3 cycles and 1 third the amplitude. A heavy line represents the point by point sum of the two waves. It starts at zero, goes up more quickly than either of the other two waves, reaches a peak which is about the same height as the one cycle wave, drops a little, goes back up to the same height and descends to zero. It keeps going down below zero then back up a little back down then back up to zero. The negative part looks the same as the positive part but mirror imaged. In the second part the sum wave from the first part is drawn along with 5 cycles of a sine wave which has an amplitude of 1 fifth of the original one cycle sine wave. The sum goes up to about the same height as before, down a little, up, down, up, each of the ups and downs are equal in height, down to zero and on below, up, down, up, down, and up to zero. The third part has the sum from the second part along with 7 cycles of a sine wave which has an amplitude of 1 seventh of the original. The sum wave goes up to a peak, then down, up, down, up, down, up, each of the ups and downs are equal in height, then down to and through zero to go down, up, down, up, down, up down, then back up to zero. End verbal description.


 Figure 2.17. There are three parts to this figure labeled eh, b and c. Part eh is a square wave which is slightly rounded off at the leading corners. The wave begins at the bottom instead of in the middle and when it ends it drops to the minimum, goes along horizontally as square waves will do and then ends. Part b starts at the bottom and goes up curving, curving to the right. There is more curvature as the wave gets higher. There is no flat top. At the top it turns abruptly and heads downwards and curving a little to the right as it gets closer to the bottom. It repeats until ending at the bottom. In part c the wave has a much smaller amplitude than the first two. It is a triangular wave. It starts at the bottom, goes up to the right making a straight line, then turns down to the right making another straight line. It repeats this until ending at the bottom. End verbal description.


 Figure 2.18. This is a graph of the output of a high pass filter with a square wave input. In part eh the wave starts at zero, rises very quickly to the height of the original square wave then immediately starts to decay exponentially to zero. Once it reaches zero it stays there for the length of time of one half of a cycle of the original wave. Then it suddenly drops to a negative value equal to the height of the original wave and quickly returns to zero. It stays at zero for the rest of the period of the original wave. This repeats until the wave ends on the right. In part b The wave starts at zero and very quickly rises to the height of the original square wave. Then it descends exponentially until it is near zero at the end of the first half of the original wave. There is no flat portion as with the wave in part eh. The wave goes negative to a value equal to the height of the original square wave. Then it returns exponentially to nearly zero. It rises again and repeats until ending on the right. In Part b the wave resembles a square wave again except that the parts that are supposed to be flat, top and bottom, are sloping down to the right on top and up to the right on the bottom. The rise and fall portions are the same length as those of the original square wave. End verbal description.


 Figure 2.19. Part eh is a schematic diagram and part b is a phasor diagram. In part eh there is an AC generator on the left labeled V sub G. The top of the generator connects to one end of a resistor labeled R. The other end of the resistor connects to one end of an inductor labeled L. The other end of the inductor connects to one end of a capacitor labeled C. The other end of the capacitor connects to the bottom end of the generator. In the phasor diagram V sub L points up from the origin and V sub C points down. These two phasors are the same length. The sum V sub L minus V sub C would be zero. There is a very short phasor exetending to the right. It is labeled V sub G and V sub R. V sub R = V sub G. There is a much longer phasor extending from the origin to the right. It is labeled I. End verbal description.


 Figure 2.20. This is a graph with two lines on it and two vertical scales, one for each line. Frequency is plotted on the horizontal axis from 0 to 2000 hertz. This is a linear scale, as is often the case when resonant circuits are involved. On the left side, impedance is plotted vertically from 0 to 1000 ohms. On the right Current is plotted from 0 to 25 mA. Both vertical scales are linear. The impedance curve comes on to the graph at 420 hertz and 1000 ohms. Then it has these values in the order frequency in hertz and impedance in ohms. 480, 800. 560, 600. 680, 400. 840, 200. 1000, 50. 1200, 200. 1560, 400. 1760, 600. 2000, 750. The line runs off the graph at this last point. The other curve is as follows. Frequency in hertz, current in milliamps. 0, 0. 200, 0.5. 400, 1. 600, 2. 800, 4.5. 1000, 20. 1200, 5. 1400, 3. 1600, 2. 1800, 1.5. 2000, 1.3. End verbal description.


 Figure 2.21. One end of a resistor is not shown as connected to anything. The other end connects to one end of an inductor. The other end of the inductor is not shown connected to anything. The two open ends are the ends of a real world coil of wire. End verbal description.


 Figure 2.22. Parallel resonant circuit. There are two terminals on the left. The upper one connects to one end of a capacitor. The other end of the capacitor connects to the lower terminal. The upper terminal also connects to one end of a resistor. The other end of the resistor connects to one end of an inductor. The other end of the inductor connects to the lower terminal. End verbal description.


 Figure 2.23. This is a graph of impedance of a parallel resonant circuit versus frequency. Frequency is on the horizontal scale and goes from 0 to 2000 hertz. Impedance is on the vertical scale and goes from 0 to 5000 ohms. Both scales are linear. The data values are as follows, Frequency in hertz, Impedance in ohms. 0, 0. 200, 100. 400, 200. 600, 400. 800, 800. 1000, 4000. 1200, 1000. 1400, 550. 1600, 400. 1800, 300. 2000, 250. End verbal description.


 Figure 2.24. This is the schematic symbol for a transformer. There are two connection points on the left. A line from the top point starts making little curly cues which resembles a side view of a coil of wire in open air. The bottom connects to the bottom connection point. This symbolizes one of the windings on the transformer. The left hand winding is usually the primary. To the right of the coil are two parallel vertical lines not touching the coil and not touching each other. They are the same length as the coil. These lines symbolize the iron core on which the two coils are wawnd. To the right of the two lines is another coil with its curly cues facing the other way. Two connection points on the right connect to the two ends of the right hand coil. This symbolizes the second winding of the transformer. The secondary is usually shown on the right. On this symbol there are 3 curls on each coil. The number of curls is sometimes related to the number of turns on the transformer winding and sometimes not. If it is necessary to draw more coils as in a transformer with two secondary windings, The two parallel lines are extended and the two windings are drawn one above the other on the right hand side of the core symbol. In the future the word, quote, transformer, end quote, will suffice to describe this symbol. End verbal description.


 Figure 2.25. This is a simplified drawing of a cathode ray tube. The outline of the tube starts on the left and is tubular for about 1 third of the length. Then it starts to widen out like a slender funnel on its side. At the right end it has become a little more than twice as wide as it is at the left end. Just inside the left end of the outline is a shallow V on its side with the point to the right. Two lines connect to the left ends of the V and cross to end outside the outline. This V is labeled heater. The lines crossing the outline indicate there are electrical connections to the heater on the outside of the tube. Usually, but not always, through pins on the small end of the tube. To the right of the heater is a vertical line as long as the heater. There are short lines which go to the left on each end of the vertical line. Connected to the lower short horizontal line is a line which crosses the outline to the outside. This part is labeled cathode. To the right of the cathode is a rectangle which is vertically the same height as the cathode and horizontally extends nearly to the point where the outline of the tube begins to widen out. There are three lines from this rectangle coming down and crossing the tube outline to the outside. This rectangle is labeled accelerating electrode assembly. In the real tube this assembly is cylindrical as is the tube. To the right of the accelerating assembly are two vertical deflection plates. They are square plates which are horizontal and placed one at the top and one at the bottom of the tube. Each plate is connected to the outside of the tube. To the right of the vertical deflection plates are the horizontal deflection plates. They are similar to the vertical plates except they are vertical and are placed one closest to the viewer and the other behind it as we see it farther from the viewer. The electron beam passes between these sets of plates and can be bent up or down by the first set and left or right by the second set. The right end of the tube has its inside coated with a substance which emits visible light when electrons impact on it. This is labeled the screen. End verbal description.


 Figure 2.26. This is the block diagram of an oscilloscope. There is not much on it except rectangles with words inside but at the right is the symbol for a cathode ray tube, C R T. It is only the outline from the previous figure, looking like a slender funnel set on its side. At the bottom of the diagram is a block labeled power supply. It has several lines coming out of it but one goes to the CRT. A jack labeled vertical input goes to a block labeled vertical amplifier. A line goes out to the CRT. A line comes in from the power supply. Another line goes out to the I N T position of the Trigger source switch. A jack labeled external trigger in goes to the E X T position of the same switch. A third position labeled line goes to the power supply. The movable contact of the trigger source switch goes to a block labeled trigger circuit. A line from the trigger circuit goes to a block labeled sweep circuit. The sweep circuit also connects to the CRT. There are connections from the power supply to both the trigger circuit and sweep circuit. End verbal description.


 Figure for answer to questions 19, 20, and 21. This is a graph of frequency response. Frequency is on the horizontal scale and is from 1 hertz to 1 Megahertz as follows. There are number labels and markings at 1, 10, 100, 1 k, 10 k, 100 k, and 1 M. The distance between 1 and 10 is the same as between 10 and 100 and so on. The vertical axis is in dB from minus 60 to 0. End verbal description.


 Figure for answer to question 24. There are two input terminals on the left and two output terminals on the right. The lower left input terminal connects to the bottom line of the circuit. The lower right output terminal also connects to the bottom line of the circuit. The upper left input terminal connects to one end of a capacitor. The other end of the capacitor connects to the upper right output terminal. The upper right output terminal also connects to tone end of a resistor. The other end of the resistor connects to the bottom line of the circuit. End verbal description.


 A two prong line plug connects to a block labeled Fuse and switch. Two lines connect from this block to the primary of a transformer. The two wires from the secondary connect to a block labeled Rectifier. A line indicating multiple wires connects to a block labeled filter. A line connects from this block to one labeled Regulator. Two terminals come out of this block and are labeled output. End verbal description.
go back.


 In figure A there is a transformer with one primary winding and one secondary winding. There is a connection at the center of the secondary which is called a center tap. Figure B shows a transformer with one primary and three secondaries. In the united states we reed left to right and so we draw diagrams from left to right. The primaries are on the left and the secondaries are on the right. End verbal description.
go back.


 Energy Level graph. The figure is a rectangle divided into three sections vertically. The lower section is cross hatched and is labeled valence band. The middle section is open and is labeled forbidden energy band. The upper section is cross hatched and is labeled Conduction band. End verbal description.


 P dash N junction. In the EH part of this figure there are two squares representing two pieces of semiconductor material. The two peaces are not touching. The one on the left is filled in completely with dots. The dots represent electrons that have energy levels in the conduction band. The one on the right is filled in with small circles. The circles represent holes that are available for conduction. In part b the two pieces have bin placed in contact. The line down the center represents the P dash N junction. In the square on the left two columns of dots are missing so the area near the junction is devoid of dots. In the square on the right two columns of circles nearest the junction are missing so there is a blank area near the junction. The dots and circles that are left have the same density as in the original in part EH. The circles and dots near the junction have been removed. There is also a graph in part b. The horizontal axis runs the length of the joined squares and represents distance. The vertical axis represents electrical potential. The line of the graph starts out at zero on the left and rises slowly at first then more rapidly until it reaches a peak about in the middle of the blank space to the left of the junction. Then it falls quickly passing through zero at the junction and reaches a negative peak. The peak is about in the middle of the blank space just to the right of the junction. The curve rises quickly at first toward zero but slows down as it approaches zero. It reaches zero at the right end of the combined squares. End verbal description.
Go back


 Biasing a diode. Part eh shows the diode as in figure 3.4 b except the depletion region is wider than in that figure. The left part of the diode, N region, is connected to the positive end of a battery. The negative end goes to a resistor, no value specified. The other end of the resistor goes to the right side of the diode, P region. There is a graph above the diode as in 3.4 b. The line of the graph begins on the left above zero. It increases to a peak just to the left of the junction. It quickly descends passing through zero at the junction. It continues to descend reaching a negative peak just to the right of the junction. It ascends slightly ending below zero. Part b shows a PN diode similar to figure 3.4 b except that the depletion region is not as wide. The left end of the diode connects to the negative end of a battery. The positive end connects to a resistor, value not given. The other end of the resistor connects to the right end of the diode. There is a graph above this diode. The curve starts out slightly below zero and rises, crossing zero to the left of the junction. It hits a peak also to the left of the junction which is about as high as it started below zero. It then crosses zero at the junction and reaches a negative peak to the right of the junction. It rises, crossing zero again and ends above zero. Part c has the battery connected the same as in part b. There is no depletion region, the electrons and holes are snuggled right up to the junction. The graph begins more negative than in part b and rises toward zero. It becomes nearly level close to the junction where it crosses zero. It continues upward getting more steep farther from the junction. It ends above zero and is higher than the graph in part b. End verbal description.


 Figure 3.6. This is a graph with a vertical axis labeled voltage, and a horizontal axis labeled current. There are no values on the axes. Only the first quadrant is shown. The curve becomes visible emerging from the left hand vertical axis line at about ¾ of the maximum value. It rises sharply for a short distance but quickly flattens out. At about 1/3 of the horizontal maximum it becomes almost a straight line. It rises only a little from that point to the maximum on both axes at the upper right corner. This plot is characterized by Y = Log of quantity, X + 1, close quantity. End verbal description.


 On the left is a power transformer. Its primary is assumed to be connected to the AC line. The bottom of the secondary is grounded. The top connects to the anode of a diode. The cathode connects through a resistor to ground. There are two terminals one coming from ground and the other coming from the diode cathode. To the right is a graph having time horizontally and voltage vertically. The graph line starts out at zero time and voltage. It rises tracing out the first half cycle of a sine wave. After returning to zero it remains at zero for the same amount of time it took to rise and fall for the first half cycle. Then it repeats. End verbal description.
go back.


 In this figure the transformer secondary is center tapped and the tap connects to ground. The top end of the secondary connects to the anode of D1 and the bottom of the winding connects to the anode of D2. The cathodes of the two diodes connect together and go through a resistor, labeled RL, to ground. There are two terminals one to each end of RL. The wave on the right is a sine wave which has been made all positive. The negative half cycles have been flipped over to be positive.
go back.


 Figure 3.9 Bridge rectifier. The top of the transformer secondary connects to the anode of D1 and the cathode of d3. The bottom of the winding connects to the anode of D2 and the cathode of D4. The anodes of D3 and D4 connect together and go to ground. The cathodes of D1 and D2 connect together and go through the load resistor, RL, to ground. There are terminals on each end of RL. End verbal description.
go back.


 In part A the top of the transformer secondary goes to the anode of D1 and the cathode of D2. The positive end of a capacitor labeled C1 connects to the cathode of D1. The negative end of C1 connects to the positive end of C2. The negative end of C2 connects to the anode of D2. The other side of the transformer secondary goes to the junction of the two caps. A load resistor, RL, is connected from the cathode of D1 to the anode of D2. The anode of D2 may be considered to be ground. In part B The bottom of the secondary is grounded. The top connects to the negative end of a cap, C1. The positive end of C1 connects to the cathode of D1 and the anode is grounded. The anode of D2 connects to the junction of C1 and D1. The cathode of D2 connects to the positive side of C2 and the negative side is grounded. The load resistor RL is connected in parallel with C2. End verbal description.
go back.


 The center tap of the secondary is grounded. The top of the winding goes to the anode of D1 and the bottom of the winding goes to the anode of D2. The cathodes of the diodes are tied together and go to the positive side of a capacitor. The negative end of the cap is grounded. There is a resistor in parallel with the cap. The wave form shows a full wave rectified sine wave in thin lines like that in figure 3.8. A heavy red line follows the sine wave up to its peak. At the peak the thin line sine wave falls away and the red line falls slowly on what looks to be a straight line sloping slightly down to the left. When the slowly falling red line and the rapidly rising thin line intersect the red line is pulled upward to the peak and the cycle repeats. End verbal description.
go back.


 Figure 3.12.1. In part eh, A large rectangular block is labeled rectifier and capacitor filter. A line comes out from the right side near the top. The line connects to a resistor. The other end of this resistor connects to the top of the regulator element. It is shown as a somewhat smaller heavy red rectangle with a variable resistor inside. The bottom end of the regulator element connects back to the right side of the large rectangle near the bottom. There are two output terminals. The bottom one connects to the bottom of the regulator element. The upper output terminal connects to the top of the regulator element. In part B, A large rectangular block is labeled rectifier and capacitor filter. A line comes out from the right side near the top. The line connects to another regulator element like the one in part eh. The other end of the regulator element connects to the upper output terminal. The lower output terminal connects to the large rectangle near the bottom. End verbal description.
go back.


 By now you should have this one down cold. The center tapped transformer winding connects to the anodes of the two diodes and CT to ground. The diode cathodes connect to the positive end of a 1000 mu f cap. This point connects through a 24 ohm 1 watt res to the positive end of another 1000 mu f cap. The negative ends of both caps are grounded. The positive end of the second cap connects to pin 4, heater, of a 12AX7. Pin 5 is grounded. End verbal description.
go back.


 Figure 3.13. A graph is shown with the origin in the middle and all four quadrants showing. The vertical axis is labeled current and the horizontal one voltage. A heavy red curve passes through the origin and it goes to the right merged with the horizontal axis for about one quarter of an inch. Then it curves upward still moving to the right. As it rises from the horizontal axis the curvature increases until it ends at 2 and a half inches it is almost vertical. It ends at this point. Now back to the origin. The curve goes to the left merged with the horizontal axis until at 2 and 3 quarter inches it suddenly turns straight downward. It goes down for 2 and a half inches without moving any further to the left. There are no numbers on the graph. End verbal description.
go back.


 Figure 3.14. Both parts of this figure are graphs. The origin is at the lower left corner and only the first quadrant is visible. The horizontal axis is labeled time and the vertical one voltage. There are two curves in each graph. In the one at eh, the upper curve is a ripple wave-form that rises quickly, falls slowly, and then repeats. This is the voltage at the input of a voltage regulator. The output voltage is shown in the lower curve. It is at a lower voltage than the input. It is a horizontal line with no voltage variations. At b the ripple voltage has its peaks at the same height as the one in eh but the valleys are coming down almost to the level of the output voltage. As the ripple of the input voltage gets close to the output voltage the output falls, duplicating the form of the tip of the ripple valley until the input goes back up. The output voltage is a straight line with a series of little triangular shaped drops when ever the ripple valley gets close to it. End verbal description.
go back.


 Figure 3.15.1. There are two input terminals on the left and two output terminals on the right. The lower left input terminal connects to the bottom line of the circuit as does the lower right output terminal. The upper left input terminal connects to one end of a resistor labeled R sub eh. The other end connects to the cathode of a zener diode. The anode connects to the base of an NPN transistor. The emitter of the transistor connects to the bottom line of the circuit. The collector connects to the junction of the resistor and zener diode. The junction of the resistor, diode, and transistor collector, connects to the upper output terminal. End verbal description.


 Figure 3.15. There are two input terminals on the left and two output terminals on the right. The lower left input terminal connects to the bottom line of the circuit as does the lower right output terminal. The upper left input terminal connects to one end of a resistor labeled R sub eh. The other end connects to the cathode of a zener diode. The anode connects to the bottom line. The junction of the resistor and diode connects to the upper output terminal. End verbal description.
go back.


 Figure 3.16. The lower prong of a two wire line plug goes to the bottom end of a transformer primary. The upper prong goes through a fuse, then through a switch to the upper end of the primary. There is a lamp in parallel with the primary. The transformer secondary has its center-tap connected to circuit common. The upper end of the secondary goes to the anode of a diode. The lower end of the secondary goes to the anode of another diode. The two cathodes are connected together and go to the positive end of a 2200 microfarad capacitor. The other end of the cap goes to common. The positive end of the cap goes to the input terminal of a 5 volt regulator labeled LM7805. There is a 0.1 microfarad cap connected between the input terminal and the common terminal of the regulator. The common terminal of the regulator goes to circuit common. There is another 0.1 microfarad cap connected between the output terminal and common terminal of the regulator. The output terminal of the regulator goes to the positive end of a 100 microfarad cap. The negative end goes to common. The output of the regulator goes to the positive output terminal of the power supply. The negative output of the power supply goes to the circuit common. End verbal description.


 Figure 3.18. The lower prong of a two wire line plug goes to the bottom end of a transformer primary. The upper prong goes through a fuse labeled 0.5 eh, then through a switch to the upper end of the primary. There is a lamp in parallel with the primary. The transformer secondary has its center-tap connected to circuit ground. The upper end of the secondary goes to the anode of a diode. The lower end of the secondary goes to the anode of another diode. The two cathodes are connected together and go to the positive end of a 4700 microfarad capacitor. The other end of the cap goes to ground. The positive end of the cap goes to the input terminal of a 5 volt regulator labeled LM309K. There is a 0.1 microfarad cap connected between the input terminal and the common terminal of the regulator. The common terminal of the regulator goes to ground. There is another 0.1 microfarad cap connected between the output terminal and common terminal of the regulator. The output terminal of the regulator goes to the positive end of a 100 microfarad cap. The negative end goes to ground. The output of the regulator goes to the plus 5 output terminal of the power supply. The negative output of the power supply goes to ground. The positive end of the 4700 microfarad capacitor goes to the I terminal of an LM317 positive adjustable regulator. There is a 0.1 mike cap going from the I terminal to ground. There is a 10 mike cap connected between the A terminal of the regulator and ground. There is an 82 ohm resistor connected between the O and A terminals. There is a 1 k ohm pot connected as a rheostat from the A terminal to ground. There is a 20 mike cap connected from the O terminal to ground. The o terminal goes to the cathode of a diode. The anode is grounded. The O terminal goes to the positive 1.2 to 15 volt output. Now going back to the transformer secondary, the top end goes to the cathode of a diode and the bottom end goes to the cathode of another diode. The two anodes are tied together and go to the negative end of a 2200 mike cap, the positive end is grounded. The negative end of the 2200 goes to the I terminal of a negative adjustable regulator, LM337. There is a 0.1 mike cap from the I terminal to ground. There is a 10 mike cap from the A terminal to ground. There is an 82 ohm resistor from the O terminal to the A terminal of the regulator. There is a 1 k ohm pot connected as a rheostat and connected from the A terminal to ground. There is a 20 mike cap from the O terminal to ground. The O terminal goes to the anode of a diode. The cathode is grounded. The O terminal goes to the minus 1.2 to minus 15 volt output. A single ground connection serves as the return for all three supplies. End verbal description.


 Figure 3.17. There are two input terminals on the left and two output terminals on the right. The two lower terminals connect to the circuit common. The upper input terminal connects to the I terminal of the adjustable regulator, LM317. There is a 0.1 microfarad cap connected from the I terminal to common. The A terminal connects through a 10 microfarad cap to common. There is another 0.1 mike cap connected between the regulator's O and A terminals. There is a resistor also connected between the regulator's O and A terminals. This resistor is labeled R sub 1. There is another resistor from the A terminal to common. This resistor is labeled R sub 2. There is a 20 microfarad cap connected from the O terminal to common. The O terminal also connects to the cathode of a diode. The anode of the diode goes to common. The O terminal of the regulator also goes to the upper output terminal of the circuit. End verbal description.


 Figure 3.19. On the left is a 3 prong power plug. The bottom prong goes to the bottom end of the primary of a power transformer. The middle prong goes to chassis. This is the round ground prong of the plug. The upper prong goes to one end of a single pole single throw switch. The other end of the switch goes to a fuse. The other end of the fuse goes to the top of the transformer primary. The transformer has two secondaries. One is the 6.3 volt heater winding and the other is the high voltage winding which is center tapped. The H V winding is labeled 125 dash 0 dash 125 V. The 6.3 volt winding goes to the heater of the 6AQ5, and the heater of the 6AU6, pins 3 and 4 in both cases. One side of the heater is tied to the negative output terminal of the power supply. The upper end of the HV winding goes to the anode of a diode. The lower end of the HV winding goes to the anode of another diode. The cathodes of the two diodes are tied together and go to the positive end of a 22 u f 250 volt cap. The negative end goes to the center tap. The positive end of the 22 u f cap goes to the screen, pin 6, of the 6AQ5. Pin 6 goes through a 22 ohm resistor to the plate, pin 5. The cathode and suppressor are tied together inside the tube. The cathode, pins 2 and 7, goes to the positive output terminal. The positive end of the 22 u f cap goes through a 3.3 k ohm 1 watt resistor than another 3.3 k ohm 1 watt res to the anode pin 5 of the 0 eh 3 VR tube. There is a 10 u f 250 v cap connected from the junction of the two 3.3 k ohm resistors to the negative output terminal. The cathode of the 0 eh 3 goes to the negative output terminal. There is a jumper inside the 0 eh 3 connected between pins 3 and 7. It is intended to be wired to turn off the power if the tube is removed from its socket. The negative end of the 22 u f cap goes to pin 3. Pin 7, the other end of the jumper goes to the negative output terminal. Pin 5 of the 0 eh 3 goes to pins 7, cathode, and pin 2, suppressor grid, of the 6AU6. The screen grid, pin 6 goes to the junction of the two 3.3 k ohm resistors. The plate, pin 5, goes through a 1 k ohm res to the grid, pin 1, of the 6AQ5. The plate of the 6AU6 also goes through a 100 k ohm res to the positive output terminal, also the cathode of the 6AQ5. The positive output terminal goes through a 100 k ohm res to the top of a 100 k ohm pot. The bottom of the pot goes through a 200 k ohm res to the negative output terminal. The wiper of the pot goes to pin 1, grid, of the 6AU6. There is a 0.1 u f 400 volt cap from the positive output terminal to the grid of the 6AU6. End verbal description.


 Figure 3eh.6. This is a graph. The horizontal axis is labeled plate voltage in volts and goes from 0 to 100 with numbered marks every 20 volts and minor marks every 4 volts. The vertical scale is labeled Plate current in mA and goes from 0 to 1600 with numbered marks every 200 mA and minor marks every 50 mA. The curve starts out at the point 0,0 and subsequent points will be given as voltage followed by current with a comma between. 0, 0. 20, 130. 40, 350. 60, 700. 80, 1,075. 100, 1,475. End verbal description.


 Figure 4.1. There is a common connection line running from left to right across the bottom of the diagram. In the center, and slightly above the line is a rectangle which is about 4 times as wide as it is high. This rectangle is labeled emitter. Above the emitter rectangle and touching it is another which is as wide but about half as high. This one is labeled base. Above the base rectangle, and touching it, is another which is the same width and height as the emitter one. It is labeled collector. The emitter rectangle is connected to the common line. On the left is a battery labeled V sub BB. Its negative end is connected to the common line. The positive end goes through a resistor labeled R sub B, value not given, to the base rectangle. On the right is another battery labeled V sub CC. Its negative end goes to the common line. The positive end goes through another resistor labeled V sub C, value not given, to the collector rectangle. End verbal description.


 Figure 4.2. This figure is almost identical to figure 4.1 except the three rectangles in the center are replaced by a standard symbol for an NPN transistor. A description of the symbol will be given at the end of this circuit description. On the left is a battery labeled V sub BB. Its negative end is connected to the common line. Its positive goes through a resistor labeled R sub B to the base of the transistor. The emitter of the transistor is connected to common. The collector goes through a resistor labeled R sub C to the positive end of a battery labeled V sub CC. The negative end of the battery is connected to common. The transistor symbol is enclosed in a circle. There is a vertical line inside the circle which is to the left of the center. The ends of this line do not touch the circle. A horizontal line goes to the left from the center of the vertical line. This horizontal line crosses the circle and is the base connection. Another line touches the vertical line about 1/3 of the way from the center to the top. This line angles up to the right to a point even with the top of the vertical line and as far to the right of the center of the circle as the vertical line is to the left. From this point the line goes straight up and crosses the circle. This is the collector connection. Another angled line starts on the vertical line about 1/3 of the way from the center to the bottom of the vertical line. This line angles down to a point even with the bottom of the vertical line and directly under the point where the upper angled line turns to exit the circle. The lower angled line turns straight down and crosses the circle. This is the emitter connection. There is an arrowhead on the lower angled line which is pointing down and to the right. The point is a little to the left of the point where the line turns straight down. If the transistor were a PNP type the arrowhead would point up and to the left. The point would be located a little to the right of where the angled line joins the vertical line. End verbal description.


 Figure 4.3. There is a common line running the length of the diagram at the bottom. On the left there are two connection points labeled input. The bottom one connects to the common line. The top one connects to one end of a resistor labeled R sub B. The other end of R sub B connects to the base of a transistor represented by a standard schematic symbol for an NPN transistor. The emitter is connected to the common line. The collector connects to one end of an incandescent lamp. The other end of the lamp connects to the positive end of a battery labeled V sub CC. The negative end of the battery is connected to common. End verbal description.


 Figure 4.4. A transistor is labeled beta = 100. The emitter is grounded. There are two terminals labeled V in. The bottom one is grounded and the top one goes to one end of a resistor labeled R 1, 6.8 k ohms. The other end goes to the base of the transistor. A resistor labeled R 2, 1.0 k ohms connects from the base to ground. The collector goes through a 150 ohm resistor to plus 12 volts. End verbal description.


 Figure 4.5. A rectangular block is labeled 4 terminal network. There are two terminals on the left and two more on the right. An arrow next to the upper left terminal indicates a current flowing into the block. This current is designated as I 1. The voltage between the two left hand terminals is labeled V 1. Another arrow next to the upper right terminal indicates a current flowing out of the block. This current is labeled I 2. The voltage between the two right hand terminals is identified as V 2. End verbal description.


 Figure 4.6. There are two parts to this figure. In part eh, there are 4 terminals, 2 on the left and 2 on the right. There is a transistor centered between them. The lower left terminal connects to the emitter of the transistor. The upper left terminal connects to the base of the transistor. The lower right terminal connects to the emitter of the transistor. The upper right terminal connects to the collector of the transistor. In part b there are also 4 terminals but the two sets, right and left, are farther apart because there is more stuff between them. The lower left terminal connects to the lower right terminal and this line is designated common. The terminals on the left are labeled V sub b e. The upper left terminal has an arrow next to it indicating the I sub B is flowing to the right. The upper left terminal connects to a resistor labeled h sub i e. The other end of this resistor is connected to the plus end of an ideal voltage source which is labeled V sub c e times h sub r e. The other end of the voltage source is connected to common. An arrow next to the upper right terminal indicates that I sub c is flowing to the left. The right hand terminals are labeled V sub c e. There is a resistor connected between the two terminals labeled h sub o e. There is an ideal current source connected in parallel with the resistor. It is labeled I sub b times h sub f e. The arrow in the current source is pointing downwards. Remember that the lower right terminal is connected to common. End verbal description.


 Figure 4.7. This figure has 4 terminals similar to figure 4.6 b. They are labeled the same way, V sub b e, etc. The upper left terminal goes to one end of a resistor labeled h sub I e. The other end goes to common. The upper right terminal goes to one end of an ideal current source labeled I sub b times h sub f e. The other end of the current source goes to common and the arrow points down toward the common line. That's all there is to it.


 Figure 4.8. One side of the input is grounded. The other side goes to the negative end of a capacitor labeled C 1, 20 microfarad. The other end goes to the base of an NPN transistor. A resistor labeled R 1, 22 k ohms goes from the base to plus 12 volts. Another resistor labeled R 2 6.8 k ohms goes from the base to ground. The emitter goes through a resistor labeled R4, R e, 1.8 k ohms, to ground. The emitter also goes through a capacitor labeled C 2, 50 microfarads, to ground. The positive end of the cap goes to the emitter. The collector goes through a resistor labeled R3, R c, 4.7 k ohms, to plus 12 volts. The collector also goes to the positive end of a capacitor labeled C3, 20 microfarads. The negative end of this cap goes to the high output terminal. The other output terminal is grounded. There is a resistor connected between the two output terminals which is labeled R5, R l, no value is given. End verbal description.


 Figure 4.9. On the left a battery labeled V sub BB has its negative end connected to common. The positive end connects through a resistor labeled R sub B to the base of an NPN transistor. The emitter of the transistor connects through a resistor labeled R sub E to common. A semicircle with an arrowhead on one end indicates that I sub b is flowing clockwise around the loop composed of V sub BB, R sub B, base to emitter of the transistor, and R sub E. On the right a battery labeled V sub CC has its negative end connected to common. The positive end goes through a resistor labeled R sub C to the collector of the transistor. A semicircle with an arrowhead on one end indicates that I sub c is flowing counter-clockwise around the loop composed of V sub cc, R sub c, collector to emitter of the transistor, and R sub e. End verbal description.


 Figure 4.10. The bottom of the input is grounded. The top input terminal goes through a capacitor labeled C 1 to the base of an NPN transistor. The base also goes through R 1 to V CC. The base also goes through R 2 to ground. The collector goes to V cc. The emitter goes through R 3 to ground. The emitter also goes through C 2 to the high output terminal. The other output terminal is grounded. There is a resistor labeled R 4 connected from one output terminal to the other. End verbal description.


 Figure 4.11. For a sighted person the physical layout of a schematic drawing can either convey or obscure information depending on how it is laid out. In figures 4.11 and 4.12 the electrical connections are identical but the layout is quite different. Figure 4.11 conveys how the equivalent circuit takes the place of the transistor but it would be hard to visualize how the loop equation is written. In figure 4.12 the correspondence between the transistor and the equivalent cirrcuitis not as clear but the loop for summing the voltages is obvious. An attempt will be made to convey this information in words. The equivalent circuit from figure 4.7 has been dropped whole into this circuit. It will be described again here so you don't have to refer back to it. There are two terminals on the left and two on the right. The bottom terminals on both sides are connected together and both are labeled with the letter E. The top terminal on the left is labeled B and there is a resistor connected from the B terminal to the E connection. This resistor is labeled h sub I e. On the right the C terminal connects to one end of an ideal current source. The other end of the source connects to the E connection. The arrow indicates that current from the source flows from C to E. The current source is labeled I sub b times h sub f e. This is a subsection of the diagram. There are other schematic symbols to the left of, below, and to the right of, this subsection. Note that neither E terminal connects to ground. On the left is an AC generator with one end going to ground. The other end connects to the B terminal. The generator is labeled V in. On the right a resistor has one end connected to the E terminal on that side. The resistor goes down and the other end connects to ground. This resistor is labeled R L. A line from the ground point goes to the right past RL and once clear of it turns upwards. When this line reaches the same level as the C terminal it turns to the left and connects to the c terminal. The c, collector, is grounded by this connection. End verbal description.


 Figure 4.12. Remember, this circuit is exactly electrically identical to that of figure 4.11. The bottom line of the circuit runs continuous from left to right. The bottom end of an AC generator connects to this line and to ground. The top end of the generator connects to a horizontal resistor labeled h sub I e. The other end of this resistor connects to one end of the current source and the resistor R L. The current source is labeled I sub b times h sub f e. The current source and R L are vertical with R L to the right of the current source. The lower ends of both connect to the ground line. Where the top of the generator meets the h sub I e resistor, the B terminal is located. Where the top of the current source meets R L there is a terminal labeled E. To keep the equivalent circuit looking like a 4 terminal network there are two C terminals, one on the left and one on the right. The C terminal on the left is on the line connecting the grounded end of the AC generator to the bottom of the current source. The C terminal on the right is between the bottom of the current source and the bottom of R l. End verbal description.


 Figure 4.13. One end of an AC generator connects to ground. The other end connects through C 1 to the base of an NPN transistor. The base connects through R 1 to plus 12 volts. The base also connects through R 2 to ground. The collector connects to plus 12 volts. The emitter connects through R 3 to ground. The emitter also connects through C2 to one side of a speaker. The other side of the speaker goes to ground. End verbal description.


 Figure 4.14. Once again we are dealing with the 4 terminal network equivalent of the BJT. On the left are the C and B terminals with the C on the bottom. On the right are the C and E terminals with C on the bottom. On the left to the left of the terminals a resistor connects from C to B. This resistor is labeled R g. Between the sets of terminals a resistor labeled h sub I e connects between the B and E terminals. Also inside the terminals the current source is connected between the C and E terminals. The arrow is pointing up toward the E terminal. On the right, outside of the terminals an AC generator connects between the C and E terminals. The generator is labeled simply V and an arrow indicates that the current I is flowing into the top of the generator, out of the E terminal. End verbal description.


 Figure 4.15. In this diagram is a long thin rectangle and a smaller one inside the larger one. The smaller one is at the bottom and centered left to right. It is approximately one third the width of the larger one and one half the height. Inside the smaller rectangle are rows and columns of circles that indicate holes. Outside the smaller rectangle but inside the larger one are rows and columns of dots indicating electrons. There is a connection on the left end of the larger rectangle labeled source. There is a connection to the bottom center, to the inner rectangle, that is labeled gate. There is a connection to the right end of the larger rectangle labeled drain. End verbal description.


 Figure 4.16. In this diagram is a long thin rectangle and a smaller one inside the larger one. The smaller one is at the bottom and centered left to right. It is approximately one third the width of the larger one and one half the height. Inside the smaller rectangle are a few circles that indicate holes. They are along the bottom near the connection point, none of them are near the boundary between the inner and outer rectangle. Outside the smaller rectangle but inside the larger one are rows and columns of dots indicating electrons. None of them are near the boundary between the inner and outer rectangle. There is a connection on the left end of the larger rectangle labeled source. There is a connection to the bottom center, to the inner rectangle, that is labeled gate. There is a connection to the right end of the larger rectangle labeled drain. The positive end of a battery connects to the source and the negative end connects to the gate. There is no connection to the drain. End verbal description.


 Figure 4.17. In this diagram the FET is upright with the source at the bottom and the drain at the top. The gate is on the left. The rectangle has been widened to better show the depletion region. The outer rectangle is almost as wide as it is high. The smaller rectangle, representing the gate, is on the left and centered top to bottom. There are 3 circles, holes, in the gate region clustered near the connection. 2 are below the connection and the remaining one is above it. In the larger, outer, rectangle the electrons are some distance from the boundary, junction, at the bottom but get farther away from it as height increases. At the top the electrons are quite far away from the junction. There is a battery on the left with its positive end connected to the source and its negative connected to the gate. There is another battery on the right with its negative end connected to the source and its positive end connected to the drain. End verbal description.


 Figure 4.18. This is a graph with the origin in the lower left corner and only the first quadrant showing. The vertical axis is labeled drain current and the horizontal axis is labeled drain to source voltage. There is a vertical dashed line about one third of the way across the graph. This line is labeled pinch off voltage. There are 4 data lines and all four begin at the origin. The first one slopes up to the right at about 30 degrees and curves over to become horizontal at the pinch off line. It is labeled V sub GS = minus 1.5 volts. The second one slopes up to the right at about 45 degrees and curves over to become horizontal at the pinch off voltage. It is labeled V sub gs = minus 1.0 volts. The third line slopes up at more than 45 degrees and curves over to become horizontal at the pinch off voltage. It is labeled V sub gs = minus 0.5 volts. The last line slopes up at about 60 degrees and curves over to be horizontal at the pinch off voltage. It is labeled V sub gs = 0 volts. End verbal description.


 Figure 4.19. This is another long thin rectangle. A line divides the rectangle into top and bottom portions. The line starts at the left and is at half the height. At about one fourth along the way it turns downward having a short vertical portion. It continues horizontally to the right at about one fourth of the height. At about three fourths the way along it turns upwards again and continues horizontally at one half the height. The area above the line is labeled P and also substrate. The area below the line is labeled N and also channel. On the bottom of the rectangle is a thick red line that is centered left to right and is the same length as that part of the line that is at one fourth the height of the rectangle. This red line touches the bottom of the rectangle and is outside it. It is labeled insulator. There is a black line below the red line that touches it. This line is labeled conductor. The source connection is at the left end of the rectangle and connected to the bottom of it. The gate connection goes to the conductor below the red line. The drain connection goes to the right end of the rectangle and to the bottom. End verbal description.


 Figure 4.20. This is another long thin rectangle. There are two much smaller rectangles within it one in the lower left and the other in the lower right corner. Each of the smaller rectangles is one half the height of the larger one and about one fourth the width. The area inside the larger rectangle and outside of the two smaller ones is labeled P and substrate. The area inside of both smaller rectangles is labeled N and channel. On the bottom of the rectangle is a thick red line that is centered left to right and is the same length as the space between the two smaller rectangles. This red line touches the bottom of the rectangle and is outside it. It is labeled insulator. There is a black line below the red line that touches it. This line is labeled conductor. The source connection is to the smaller rectangle on the left. The gate connection goes to the conductor below the red line. The drain connection goes to the smaller rectangle on the right. End verbal description.


 Figure 4.21. This figure shows the schematic symbols for six types of field effect transistors. Each of the 6 descriptions has been written to stand alone.

Number 1, the N channel junction FET. There is a circle. A line crosses the perimeter from the left outside. It would go through the center if it were that long, but it isn't. It ends at about one third the way across the circle in an arrowhead. The arrowhead points to the right. There is a vertical line touching the point of the arrowhead. This line is almost as long as it can be without touching the perimeter. At about two thirds the way across the circle a line begins below and outside and goes up crossing the perimeter. At about one third the way up it turns to the left and ends when it touches the vertical line below its center. It does not touch at the lower end of the line but a little way from the bottom. Another line starts outside and above the circle and directly above the one that started from below. It goes down and crosses the perimeter. It turns to the left at about two thirds of the height and ends when it touches the vertical line above its center. This line does not touch at the end of the vertical line but a little way from the top end. The connection on the left is the gate, the one below is the source and the one above is the drain. End of number 1.

Number 2, the P channel junction FET. There is a circle. A line crosses the perimeter from the left outside. It would go through the center if it were that long, but it isn't. It ends at about one third the way across the circle. There is an arrowhead on this line with its point just inside the perimeter. The arrowhead points to the left. There is a vertical line touching the line that comes in from the left. This line is almost as long as it can be without touching the perimeter. At about two thirds the way across the circle a line begins below and outside and goes up crossing the perimeter. At about one third the way up it turns to the left and ends when it touches the vertical line below its center. It does not touch at the lower end of the line but a little way from the bottom. Another line starts outside and above the circle and directly above the one that started from below. It goes down and crosses the perimeter. It turns to the left at about two thirds of the height and ends when it touches the vertical line above its center. This line does not touch at the end of the vertical line but a little way from the top end. The connection on the left is the gate, the one below is the source and the one above is the drain. End of number 2.

Number 3, the N channel depletion mode MOSFET. There is a circle. Imagine a capitol letter T turned on its side with the foot of the T to the left. The staff of the T crosses the perimeter of the circle with the head inside the circle. There is a vertical line to the right of the T but not touching it. This line is slightly to the left of the center of the circle and almost as long as it can be without touching the inside of the circle. At about two thirds the way across the circle a line begins below and outside and goes up crossing the perimeter. At about one third the way up it turns to the left and ends when it touches the vertical line below its center.. It does not touch at the lower end of the line but a little way from the bottom. Another line starts outside and above the circle and directly above the one that started from below. It goes down and crosses the perimeter. It turns to the left at about two thirds of the height and ends when it touches the vertical line above its center. This line does not touch at the end of the vertical line but a little way from the top end. Another line starts at the center of the vertical line and goes to the right until it is even with the lines coming up from below and down from above. It turns down and joins the line coming up from below. The horizontal part of this line has an arrowhead pointing to the left. The connection on the left is the gate, the one below is the source and the one above is the drain. End of number 3.

Number 4, the P channel depletion mode MOSFET. There is a circle. Imagine a capitol letter T turned on its side with the foot of the T to the left. The staff of the T crosses the perimeter of the circle with the head inside the circle. There is a vertical line to the right of the T but not touching it. This line is slightly to the left of the center of the circle and almost as long as it can be without touching the inside of the circle. At about two thirds the way across the circle a line begins below and outside and goes up crossing the perimeter. At about one third the way up it turns to the left and ends when it touches the vertical line below its center.. It does not touch at the lower end of the line but a little way from the bottom. Another line starts outside and above the circle and directly above the one that started from below. It goes down and crosses the perimeter. It turns to the left at about two thirds of the height and ends when it touches the vertical line above its center. This line does not touch at the end of the vertical line but a little way from the top end. Another line starts at the center of the vertical line and goes to the right until it is even with the lines coming up from below and down from above. It turns down and joins the line coming up from below. The horizontal part of this line has an arrowhead pointing to the right. The connection on the left is the gate, the one below is the source and the one above is the drain. End of number 4.

Number 5, the N channel enhancement mode MOSFET. There is a circle. Imagine a capitol letter T turned on its side with the foot of the T to the left. The staff of the T crosses the perimeter of the circle with the head inside the circle. There is a dashed vertical line to the right of the T but not touching it. This line consists of 3 dashes, one at the top, one in the center, and one at the bottom. This line is slightly to the left of the center of the circle and almost as long as it can be without touching the inside of the circle. At about two thirds the way across the circle a line begins below and outside and goes up crossing the perimeter. At about one third the way up it turns to the left and ends when it touches the lower dash of the vertical line. Another line starts outside and above the circle and directly above the one that started from below. It goes down and crosses the perimeter. It turns to the left at about two thirds of the height and ends when it touches the upper dash of the vertical line. Another line starts at the center of the center dash of the vertical line and goes to the right until it is even with the lines coming up from below and down from above. It turns down and joins the line coming up from below. The horizontal part of this line has an arrowhead pointing to the left. The connection on the left is the gate, the one below is the source and the one above is the drain. End of number 5.

Number 6, the P channel enhancement mode MOSFET. There is a circle. Imagine a capitol letter T turned on its side with the foot of the T to the left. The staff of the T crosses the perimeter of the circle with the head inside the circle. There is a dashed vertical line to the right of the T but not touching it. This line consists of 3 dashes, one at the top, one in the center, and one at the bottom. This line is slightly to the left of the center of the circle and almost as long as it can be without touching the inside of the circle. At about two thirds the way across the circle a line begins below and outside and goes up crossing the perimeter. At about one third the way up it turns to the left and ends when it touches the lower dash of the vertical line. Another line starts outside and above the circle and directly above the one that started from below. It goes down and crosses the perimeter. It turns to the left at about two thirds of the height and ends when it touches the upper dash of the vertical line. Another line starts at the center of the center dash of the vertical line and goes to the right until it is even with the lines coming up from below and down from above. It turns down and joins the line coming up from below. The horizontal part of this line has an arrowhead pointing to the right. The connection on the left is the gate, the one below is the source and the one above is the drain. End of number 6.

End verbal description.


 Figure 4.22. There are two sets of terminals, two inputs on the left and two outputs on the right. In addition there is a fifth terminal labeled control voltage input. The lower left and lower right terminals are grounded. The upper input terminal connects to the source of a junction N channel FET. The source connects through a 100 k ohm resistor to the gate. The upper output terminal connects to the drain of the JFET. The control voltage terminal connects to the cathode of a diode. The anode connects to the gate of the FET. End verbal description.


 Figure 4.23. There are two sets of terminals, two inputs on the left and two outputs on the right. In addition there is a fifth terminal labeled control voltage input. The lower left and lower right terminals are grounded. The upper input terminal connects to the source of an N channel enhancement mode MOSFET, and also to the source of a P channel enhancement mode MOSFET. The drain connections of the two FETs are connected together and go to the upper output terminal. The control voltage terminal connects to the gate of the N channel FET. It also goes to the input of an inverter which is described as a triangle with a circle on its nose, see text. The output of the inverter goes to the gate of the P channel FET. End verbal description.


 Figure 4.24. There are two sets of terminals, two inputs on the left and two outputs on the right. The lower terminals on each side are grounded. The upper input terminal connects to the gate of an N channel enhancement mode MOSFET and also to the gate of a P channel enhancement mode MOSFET. The source of the N channel is grounded and the drain connects to the drain of the P channel. The source of the P channel connects to V sub DD. The upper output terminal connects to the junction of the two drains. End verbal description.


 Figure 4.25. There are two terminals on the left labeled G, upper and S, lower. On the right are two more terminals labeled D, upper and S, lower. The G terminal connects to nothing indicating it is a voltage sensitive point. There is a current source labeled G sub m V sub gs. The arrow in the current source is pointing downward. The lower end of the current source is connected to the bottom line of the circuit. Both S terminals are also connected to the bottom line. The top of the current source is connected to the D terminal. There is a resistor labeled r sub d connected between the D and S terminals. The r in r sub d is a lower case r. Real resistors are labeled with an upper case R. End verbal description.


 Figure 4.26. There are two terminals on the left labeled G, upper and S, lower. On the right are two more terminals labeled D, upper and S, lower. The G terminal connects to nothing indicating it is a voltage sensitive point. There is a label between the G and S terminals reading V sub in. There is a current source labeled G sub m V sub gs. The arrow in the current source is pointing downward. The lower end of the current source is connected to the bottom line of the circuit. Both S terminals are also connected to the bottom line. The top of the current source is connected to the D terminal. There is a resistor labeled r sub d connected between the D and S terminals. The r in r sub d is a lower case r. Real resistors are labeled with an upper case R. There is a real resistor connected on the outside of the circuit between D and S. This resistor is labeled R sub L. End verbal description.


 Figure 4.27. An N channel JFET has its source grounded. A battery labeled V sub GG has its positive terminal grounded. The negative terminal goes to one end of a 100 k ohm resistor. The other end goes to the gate of the FET. The drain of the FET connects to one end of a resistor labeled R sub D. The other end of this resistor connects to the positive end of a battery labeled V sub DD. The negative end is grounded. End verbal description.


 Figure 4.28. This figure has two parts. In part eh an N channel JFET has its source connected to the positive end of a battery labeled V sub GG. The negative end is grounded. The gate goes to ground through a 100 k ohm resistor. The drain of the FET connects to one end of a resistor labeled R sub D. The other end of this resistor connects to the positive end of a battery labeled V sub DD. The negative end is grounded. In part b an N channel JFET has its source connected to one end of a resistor, the other end of the resistor goes to ground. There is a capacitor in parallel with the resistor. The top end of the resistor has a plus sign near it and the bottom, ground, end has a minus sign. Between the two signs is a label reading V sub GG. The negative end is grounded. The gate goes to ground through a 100 k ohm resistor. The drain of the FET connects to one end of a resistor labeled R sub D. The other end of this resistor connects to the positive end of a battery labeled V sub DD. The negative end is grounded. End verbal description.


 Figure 4.29. There are two parts to this figure. In part eh the upper input terminal goes to the gate of an N channel JFET. The lower input terminal is grounded. The gate also goes to ground through a 100 k ohm resistor. The source goes to the top of a pot. The bottom of the pot is grounded and so is the wiper. There is a 100 microfarad capacitor connected from the source to ground. The drain goes through a 47 k ohm resistor to plus 12 volts. The drain also goes through a 1 microfarad cap to one end of a 100 k ohm resistor. The other end of the resistor is grounded. The junction of the cap and resistor could be an output point. In part b the upper input terminal goes to one end of a 1 microfarad cap. The other end goes to the gate of an N channel JFET. The lower input terminal is grounded. The source of the JFET goes to the collector of a BJT. The emitter of the BJT goes through a 5.6 k ohm resistor to ground. The base of the BJT goes through another 5.6 k ohm resistor to ground. The base also goes through a 51 k ohm resistor to plus 12 volts. The base also goes through a 100 k ohm resistor to the gate of the JFET. There is a 100 microfarad cap from the JFET source to ground. The drain goes through a 47 k ohm resistor to plus 12 volts. The drain also goes through a 1 microfarad cap to one end of a 100 k ohm resistor. The other end of the resistor is grounded. The junction of the cap and resistor could be an output point. End verbal description.


 Figure 4.30. The upper input terminal goes to the gate of an N channel JFET. The lower input terminal is grounded. There is a resistor labeled R sub G from the gate to ground. The source goes through a resistor labeled R sub S to ground. The source also goes to the upper output terminal. The lower output terminal is grounded. The drain goes to V sub DD. End verbal description.


 Figure 4.31. There is an AC generator on the left labeled V sub in. Its lower terminal is connected to the D terminal of a transistor equivalent circuit. The upper end of the generator connects to the G terminal. The D terminal connects to the bottom line of the circuit and the G terminal is open. There is a current source labeled G sub m V sub gs. Its lower terminal connects to the bottom line of the circuit. The arrow in the current source is pointing up. There is a resistor in parallel with the current source labeled r sub d. Both r and d are lower case. On the right the D terminal connects to the bottom line of the circuit. The S terminal connects to the top end of the current source and the resistor. Between the terminals is a label V sub O. Outside the circuit a resistor connects between the D and S terminals. The resistor is labeled R sub L, both R and L are upper case. End verbal description.


 Figure 4.32. There is a shorting wire on the left, outside the circuit. It connects the D terminal of a transistor equivalent circuit to the G terminal. The D terminal connects to the bottom line of the circuit and the G terminal is open. There is a current source labeled G sub m V sub gs. Its lower terminal connects to the bottom line of the circuit. The arrow in the current source is pointing up. There is a resistor in parallel with the current source labeled r sub d. Both r and d are lower case. On the right the D terminal connects to the bottom line of the circuit. The S terminal connects to the top end of the current source and the resistor. Outside the circuit a generator connects between the D and S terminals. It is labeled V. Above the S terminal is an arrow pointing to the right and labeled I. End verbal description.


 Figure 4.33. The upper input terminal goes to the gate of an N channel JFET labeled Q sub 1. The lower input terminal is grounded. There is a resistor labeled R sub 1 from the gate to ground. The drain of Q sub 1 goes through a resistor labeled R sub 2 to plus 12 volts. The drain also goes to the base of Q sub 2 a PNP BJT. The emitter of Q sub 2 goes through R sub 3 to plus 12 volts. The collector of Q sub 2 goes through R sub 4 to minus 12 volts. The collector of Q sub 2 goes back to the source of Q sub 1. The collector also goes to the upper output terminal. The lower output terminal is grounded. End verbal description.


 Figure 4.34. There are no resistor values given in this circuit. On the left are two input terminals. The bottom one goes to ground and the top one is labeled with a minus sign. The minus terminal connects to the top of R 1 and the other end of R1 is grounded. The minus terminal also connects to the base of Q1. The collector of Q1 goes through R3 to plus 12 volts. The emitter of Q1 goes through R5 then R6, in series, to the emitter of Q2. The base of Q2 goes through R2 to ground. The base of Q2 connects to an input terminal labeled with a plus sign. The other side of this input is grounded. The collector of Q2 goes through R4 to plus 12 volts. The junction of R5 and R6 goes to the collector of Q3. The base of Q3 goes through R7 to ground and also through R8 to minus 12 volts. The emitter of Q3 goes through R9 to minus 12 volts. There are two ways of taking the output from this circuit. Output 1 is shown as connecting between the collectors of Q1 and Q2. Neither side of output 1 is grounded. Output 2 is taken between the collector of Q1 and ground. End verbal description.


 Figure 4.35. An input terminal marked with a minus sign goes to the gate of Q sub 1 an N channel JFET. The gate goes through R sub 1 to ground. Another input marked with a plus sign goes to the gate of Q sub 2, another N channel JFET. This gate goes through R sub 2 to ground. The drain of Q sub 1 goes through R sub 3 to plus 12 volts. The drain of Q sub 2 goes through R sub 4 to plus 12 volts. The source of Q sub 1 goes through R sub 5 to the top of the current source. The source of Q sub 2 goes through R sub 6 to the top of the current source. The bottom of the current source goes to minus 12 volts. The symbol for this current source is two circles overlaying one another. They have the same radius and their centers are offset by the distance of a radius. The center of one circle is above the other one. As the leads approach the symbol from above and below they connect to the first circle they touch. There are two outputs. Output 1 is taken between the drain of Q sub 1 and the drain of Q sub 2. Output 2 is taken between the drain of Q sub 1 and ground. End verbal description.


 Figure 4.36. The high side of the input goes through C1 to the base of Q1. The other side of the input is grounded. The base of Q1 also goes through a 10 k ohm resistor to ground. The base also goes through a 27 k ohm resistor to plus 12 volts. The emitter of Q1 goes through a 2.2 k ohm resistor to ground. The emitter also goes through C3 to ground. The collector goes through a 3.6 k ohm res to plus 12 volts. The collector of Q1 goes through C2 to the base of Q2. The base of Q2 goes through a 3.3 k ohm res to ground. The base also goes through a 2.7 k ohm res to plus 12 volts. The collector of Q2 goes to plus 12 volts. The emitter of q2 goes through a 100 ohm resistor to ground. The emitter also goes through C4 to the top of a 75 ohm resistor. The other end is grounded. End verbal description.


 Figure 1 is an end view of two cylindrically constructed triode tubes. On the left is a filament type. The filament is represented by a dot at the center. Surrounding it but not touching it is a dashed circle representing the grid and surrounding that but not touching it is a solid circle representing the plate. On the right is a heater type triode. A dot at the center represents the heater. Surrounding it and touching it is a thick circle representing the insulating material between the heater and cathode. Another thick circle touches the one representing the insulator and this one is the cathode. The dot and circles are different colors so they can be distinguished from one another. A dashed circle, representing the grid, surrounds the cathode but is not touching it. A solid circle surrounds the whole thing without touching it which represents the plate. End verbal description.
go back


 A tube has its cathode connected to the common ground line. The grid connects to one end of a resistor. The other end of the resistor connects to the negative end of a battery. The positive end is grounded. The grid also connects to one end of a capacitor and the other end connects to a terminal point which is indicated as having a sine wave applied to it. There is a zero center voltmeter connected from the grid to ground. The plate of the tube connects through a resistor to B plus. There is another identical voltmeter connected from the plate to ground. The voltmeter in the grid circuit is indicating a negative voltage. The plate voltmeter is indicating a positive voltage. Between the cathode and grid is the space charge represented by a large number of dots moving around randomly. There a few electrons passing through the grid and on to the plate. As time progresses the grid meter goes less negative. The number of electrons getting through the grid increases and the plate meter indicates a lower voltage. Neither meter gets all the way to zero. Both meters move farther away from zero and the number of electrons getting through to the plate decreases. The electron stream is never cut completely off. End of verbal description.
go back


 Figure 4 eh.3. This is a rather car toony view of a bridge built across a flat bottomed valley. There is a bungie cord attached to the bridge and a stick figure hanging from the cord by one foot. The figure is about half way between the bridge and the bottom of the valley. End verbal description.


 A tube has its cathode connected through a resistor to ground. The resistor is labeled RK. In parallel with the resistor is a capacitor which is labeled CK. The grid of the tube connects to ground through a resistor labeled Rc. There are a pair of terminals on the left labeled input. The lower one connects to ground and the upper one connects to the grid of the tube. The plate of the tube connects through a resistor labeled Rb to a point labeled plate supply voltage, E b b. The plate also connects through a capacitor labeled Cc to the upper output terminal. This terminal connects through a resistor labeled Rcf to ground. The lower output terminal is grounded. End of verbal description.
Go back


 Figure 4 eh.5. This is a graph labeled at the top 6SL7, 12SL7 Average Plate Characteristics. The horizontal axis is labeled plate volts and goes from 0 to 500. The vertical axis is labeled plate milliamps and goes from 0 to 5. There are 7 lines on the graph that start at the bottom and go generally up and to the right. These are grid voltage lines and the one on the left is for a voltage of 0 and the one on the right is for minus 6 volts. The steps are in one volt increments. The first line, E sub G = 0 starts at the origin and for a short distance goes almost straight up. It quickly curves to the right becoming almost straight and making an approximately 30 degree angle with the vertical. It passes through the points. 0, 0. 50, 1. 97, 2. 140, 3. 180, 4. 215,5. The minus 1 curve starts near the bottom and bends to the right. It straightens up and goes up parallel to the 0 curve. The points are, 21, 0.025. 110, 1. 163, 2. 210, 3. 250, 4. 290, 5. The minus 2 E sub G line has more curvature than the one to its left. Its points are, 88, 0. 185, 1. 235, 2. 280, 3. 322, 4. 349, 4.6. The minus 3 line begins at 150, 0.02. 255, 1. 307, 2. 350, 3. 394, 4. The minus 4 line starts at 225, 0 and the rest of the points are, 320, 1. 375, 2. 423, 3. The points for the minus 5 volt line are, 280, 0.02. 390, 1. 445, 2. The minus 6 volt curve has points of, 350, 0.05. 460, 1. 480, 1.25.

There are several lines which have been drawn on the graph. All of these lines are parallel to either the horizontal or vertical axis. To find the plate resistance there are two lines one horizontal and one vertical making up the sides of a right triangle. A portion of one of the grid voltage lines makes up the hypotenuse. These lines are drawn in red and labeled r sub p. The first line goes from 180, 2.33 to 220, 2.33. This line spans 40 volts horizontally. The attached line at right angles goes from 220, 2.33 to 220, 3.25. The hypotenuse is a part of the minus 1 volt grid voltage line. Over to the right and on the minus 4 volt line is 380, 2.12 to 420, 2.12, and another from 420, 2.12 to 420, 2.91. This will give a slightly different value of r sub p as explained in the regular text.

There are green lines for amplification factor. They are drawn horizontally along current lines. The first one runs along the 2.8 mA current line from the 0 grid voltage line to minus 2. The plate voltage values are 131 and 231. To the right is another line that runs along the 2.5 mA line from grid voltage lines minus 3 to minus 4. The voltages are 328 and 400.

There are magenta lines for transconductance that are vertical. The first one runs along the 200 volt plate voltage line from grid voltage of 0 to minus 1. The current values are, 2.8 and 3.61. The other runs along the 380 bolt line from minus 3 to minus 4. The current values are 2.12 and 3.7 mA. End verbal description.


 Figure 4 eh.6. This is a repeat of the graph in Figure 4 eh.5 with different lines drawn on it. If you want to skip this then jump to the next paragraph. This is a graph labeled at the top 6SL7, 12SL7 Average Plate Characteristics. The horizontal axis is labeled plate volts and goes from 0 to 500. The vertical axis is labeled plate milliamps and goes from 0 to 5. There are 7 lines on the graph that start at the bottom and go generally up and to the right. These are grid voltage lines and the one on the left is for a voltage of 0 and the one on the right is for minus 6 volts. The steps are in one volt increments. The first line, E sub G = 0 starts at the origin and for a short distance goes almost straight up. It quickly curves to the right becoming almost straight and making an approximately 30 degree angle with the vertical. It passes through the points. 0, 0. 50, 1. 97, 2. 140, 3. 180, 4. 215,5. The minus 1 curve starts near the bottom and bends to the right. It straightens up and goes up parallel to the 0 curve. The points are, 21, 0.025. 110, 1. 163, 2. 210, 3. 250, 4. 290, 5. The minus 2 E sub G line has more curvature than the one to its left. Its points are, 88, 0. 185, 1. 235, 2. 280, 3. 322, 4. 349, 4.6. The minus 3 line begins at 150, 0.02. 255, 1. 307, 2. 350, 3. 394, 4. The minus 4 line starts at 225, 0 and the rest of the points are, 320, 1. 375, 2. 423, 3. The points for the minus 5 volt line are, 280, 0.02. 390, 1. 445, 2. The minus 6 volt curve has points of, 350, 0.05. 460, 1. 480, 1.25.

There are several lines which have been drawn on the graph. There is a red line that begins at the point 250, 0 and slopes up to the left at approximately a 45 degree angle. It ends at the point 0, 2.5 mA. The minus 1 volt grid voltage line has a mark at 0.55 mA on it and the minus 2 volt line is marked at 1.11 mA. A magenta line joins these two points. The magenta line crosses the red line at 157 volts and 0.93 mA. There is a green line on the graph that starts out at 125, 0 and goes up to the left crossing through the point where the red and magenta lines intersect. It ends just after crossing the 0 volt grid voltage line. End verbal description.


 Figure 4 eh.7. Small signal model of a triode. There are two terminals on the left labeled G and K. The K terminal goes to the common line of the circuit. The G terminal goes to nothing as the grid of a tube is an open circuit. An AC voltage source is labeled minus mu times v sub g k. This source is drawn vertically. The bottom end of the source is connected to common. The top of the source is connected to one end of a resistor labeled r sub p. the r is lower case. The other end of the resistor connects to a terminal connection which is labeled P. Below this terminal is another one which is labeled K and is connected to the common line. Connected between the two terminals are two resistors in parallel. They are labeled Rb and Rcf. This time the letter R is upper case. End verbal description.


 Figure 4A.8. A tube has its cathode connected through a resistor to ground. The resistor is labeled RK. The grid of the tube connects to ground through a resistor labeled Rc. There are a pair of terminals on the left labeled input. The lower one connects to ground and the upper one connects to the grid of the tube. The plate of the tube connects through a resistor labeled Rb to a point labeled E b b. The plate also connects through a capacitor labeled Cc to the upper output terminal. This terminal connects through a resistor labeled Rcf to ground. The lower output terminal is grounded. End of verbal description.


 Figure 4 eh.9. Small signal model of a triode with its cathode resistor unbypassed. There are two terminals on the left, the top one is labeled G for grid. The bottom one is not labeled. The two are labeled collectively V in. The top one G is marked with a plus sign and the bottom one with a minus sign. The bottom terminal goes to ground. Between the two terminals and set to the right a little is a reference point labeled K. There is a minus sign next to this point. There is an AC voltage generator labeled minus mu V gk. The bottom end of this generator connects to the point labeled K. The lower end is marked with a minus sign. The upper end of the generator is marked with a plus sign and goes to the left end of a resistor labeled r p. The r is lower case. The right end of the resistor connects to a terminal labeled P. The resistor is marked with polarity with plus on the left and minus on the right. Directly below the P terminal is another one labeled K. It connects back to point K and the bottom of the generator. A resistor labeled R k connects from the K terminal to ground. An arrow indicates that a current I b is flowing upward in R k. R k is also marked with polarity with the top being negative and the bottom being positive. The P terminal connects through a resistor labeled R b c to ground. An arrow indicates that I b is flowing downward through R b c. Polarity markings indicate that the voltage across R b c is positive at the top and negative at the bottom. End verbal description.


 Figure 4 eh.11. A tube has its cathode connected to ground. The grid of the tube connects to ground through a resistor labeled 10 meg ohms. There are a pair of terminals on the left labeled input. The lower one connects to ground and the upper one connects through a capacitor to the grid of the tube. The plate of the tube connects through a resistor labeled Rb to a point labeled E b b. The plate also connects through a capacitor labeled Cc to the upper output terminal. This terminal connects through a resistor labeled Rcf to ground. The lower output terminal is grounded. End of verbal description.


 Figure 4 eh. 12. In part eh an AC generator labeled E1 is connected to a 50 ohm resistor. That's it. In part b there is an AC generator on the left which is labeled E1. The top of this generator is connected to a 50 ohm resistor. The far end of this resistor is connected to the top of another AC generator. The wave inside the circle which represents the generator indicates that it has the opposite phase as the one on the left. This generator is labeled E2 = minus 50 times E1. The bottom ends of the two generators are connected together.


 Figure 4 eh.13. There are two input terminals on the left. The lower one is grounded and the upper one goes to the grid of a triode. There is a resistor labeled R c connected from the grid to ground. The plate of the triode goes to E b b. The cathode goes through a resistor labeled R k to ground. The cathode also goes through a capacitor to the upper output terminal. The lower input terminal is grounded. End verbal description.


 Figure 4 eh.14. Small signal model of a triode cathode follower. There are two terminals on the left, the top one is labeled G for grid. The bottom one is not labeled. The two are labeled collectively V in. The top one G is marked with a plus sign and the bottom one with a minus sign. The bottom terminal goes to ground. Between the two terminals and set to the right a little is a reference point labeled K. There is a minus sign next to this point. There is an AC voltage generator labeled minus mu V gk. The bottom end of this generator connects to the point labeled K. The lower end is marked with a minus sign. The upper end of the generator is marked with a plus sign and goes to the left end of a resistor labeled r p. The r is lower case. The right end of the resistor connects to a terminal labeled P. The resistor is marked with polarity with plus on the left and minus on the right. There is an arrow indicating that I b is flowing to the right in r p. Directly below the P terminal is another one labeled K. It connects back to point K and the bottom of the generator. A resistor labeled R k connects from the K terminal to ground. An arrow indicates that a current I b is flowing upward in R k. R k is also marked with polarity with the top being negative and the bottom being positive. The P terminal connects to ground. There is a set of output terminals. The top one connects to the K terminal and top of R k. The bottom one connects to ground. They are labeled collectively, V o. The upper output terminal is marked with a plus sign and the bottom one minus. End verbal description.


 Figure 4 eh.15. Small signal model of a triode cathode follower. There are two terminals on the left, the top one is labeled G for grid. The bottom one is not labeled. The two are shorted together. The top one G is marked with a plus sign. The bottom terminal goes to ground. Between the two terminals and set to the right a little is a reference point labeled K. There is a minus sign next to this point. There is an AC voltage generator labeled minus mu V gk. The bottom end of this generator connects to the point labeled K. The lower end is marked with a minus sign. The upper end of the generator is marked with a plus sign and goes to the left end of a resistor labeled r p. The r is lower case. The right end of the resistor connects to a terminal labeled P. The resistor is marked with polarity with plus on the left and minus on the right. There is an arrow indicating that I b is flowing to the right in r p. Directly below the P terminal is another one labeled K. It connects back to point K and the bottom of the generator. There is an AC generator labeled V connected from the K terminal to ground. The top of the generator is marked with a plus sign and the bottom with a minus. An arrow indicates that a current I b is flowing upward in the generator. The P terminal connects to ground. End verbal description.


 Figure 4 eh.16. This is a repeat of the graph in Figure 4 eh.5 with different lines drawn on it. If you want to skip this then jump to the next paragraph. This is a graph labeled at the top 6SL7, 12SL7 Average Plate Characteristics. The horizontal axis is labeled plate volts and goes from 0 to 500. The vertical axis is labeled plate milliamps and goes from 0 to 5. There are 7 lines on the graph that start at the bottom and go generally up and to the right. These are grid voltage lines and the one on the left is for a voltage of 0 and the one on the right is for minus 6 volts. The steps are in one volt increments. The first line, E sub G = 0 starts at the origin and for a short distance goes almost straight up. It quickly curves to the right becoming almost straight and making an approximately 30 degree angle with the vertical. It passes through the points. 0, 0. 50, 1. 97, 2. 140, 3. 180, 4. 215,5. The minus 1 curve starts near the bottom and bends to the right. It straightens up and goes up parallel to the 0 curve. The points are, 21, 0.025. 110, 1. 163, 2. 210, 3. 250, 4. 290, 5. The minus 2 E sub G line has more curvature than the one to its left. Its points are, 88, 0. 185, 1. 235, 2. 280, 3. 322, 4. 349, 4.6. The minus 3 line begins at 150, 0.02. 255, 1. 307, 2. 350, 3. 394, 4. The minus 4 line starts at 225, 0 and the rest of the points are, 320, 1. 375, 2. 423, 3. The points for the minus 5 volt line are, 280, 0.02. 390, 1. 445, 2. The minus 6 volt curve has points of, 350, 0.05. 460, 1. 480, 1.25.

There are several lines which have been drawn on the graph. There is a red line that begins at the point 300, 0 and goes straight up along the 300 volt line. There is a point marked on the minus 2 volt grid voltage line at 1.33 mA. There is a point marked on the minus 3 volt grid voltage line at 2 mA. A magenta line connects these two points. The magenta and red lines cross at 300 volts and 1.95 mA. End verbal description.


 Figure 4 eh.17. There are two parts to this figure. In part eh there are two input terminals on the left. The lower input terminal goes to ground. The upper terminal goes through a capacitor labeled C 1 to the grid of a triode. The grid goes to ground through a resistor labeled R 2. The grid also goes through a resistor, R 1 to E b b. The plate of the triode goes to E b b. The cathode goes through a resistor, R k to ground. The cathode goes through a capacitor, C 2 to the upper output terminal. The lower output terminal is grounded. In part b the lower input terminal is grounded. The upper input terminal goes through a capacitor, C 1 to the grid of a triode. The plate of the triode goes to E b b. The cathode goes through a resistor, R k 1 then through another resistor, R k 2 to ground. The junction of R k 1 and R k 2 goes through another resistor, R 1 to the grid. The cathode goes through a capacitor, C 2 to the upper output terminal. The lower output terminal is grounded. End verbal description.


 Figure 4 eh.23. This is a repeat of the graph in Figure 4 eh.5 with different lines drawn on it. If you want to skip this then jump to the next paragraph. This is a graph labeled at the top 6SL7, 12SL7 Average Plate Characteristics. The horizontal axis is labeled plate volts and goes from 0 to 500. The vertical axis is labeled plate milliamps and goes from 0 to 5. There are 7 lines on the graph that start at the bottom and go generally up and to the right. These are grid voltage lines and the one on the left is for a voltage of 0 and the one on the right is for minus 6 volts. The steps are in one volt increments. The first line, E sub G = 0 starts at the origin and for a short distance goes almost straight up. It quickly curves to the right becoming almost straight and making an approximately 30 degree angle with the vertical. It passes through the points. 0, 0. 50, 1. 97, 2. 140, 3. 180, 4. 215,5. The minus 1 curve starts near the bottom and bends to the right. It straightens up and goes up parallel to the 0 curve. The points are, 21, 0.025. 110, 1. 163, 2. 210, 3. 250, 4. 290, 5. The minus 2 E sub G line has more curvature than the one to its left. Its points are, 88, 0. 185, 1. 235, 2. 280, 3. 322, 4. 349, 4.6. The minus 3 line begins at 150, 0.02. 255, 1. 307, 2. 350, 3. 394, 4. The minus 4 line starts at 225, 0 and the rest of the points are, 320, 1. 375, 2. 423, 3. The points for the minus 5 volt line are, 280, 0.02. 390, 1. 445, 2. The minus 6 volt curve has points of, 350, 0.05. 460, 1. 480, 1.25.

There are several lines which have been drawn on the graph. There is a red line that begins at the point 400, 0 and goes up to the left to the point 0, 0.82. The desired operating point is on the load line between the minus 3 and minus 4 volt grid voltage lines. There are points marked at 0.64 and 0.85 mA on the minus 3 and minus 4 lines respectively. A blue line connects these points and it is labeled 4.7 k. There are two more points at 0.54 and 0.72 mA. These points are connected by a magenta line and labeled 5.6 k. There are two final points marked on the lines at 0.44 and 0.59 mA. A blue line connects these points and it is labeled 6.8 k. A green line begins at the point 358, 0 and passes through the point where the red and magenta lines intersect. This point is 264, 0.52. This line goes as far to the left as it can. The green line crosses the minus 3 line at 240 volts and the minus 4 line at 387 volts. End verbal description.


 Figure 4B.1. This is a photograph of the screen of an oscilloscope. The traces all begin at the left vertical line and one line up from the bottom. This point is zero plate voltage and zero plate current. The top line rises to 9 mA at about 15 volts. It falls gradually to about 8 mA at 50 volts then rises slightly to 9 mA at 85 volts. Then it rises more steeply to 13 mA at 100 volts. It slopes less steeply until going off the top of the screen at 14 mA at 145 volts. The next curve rises to 6.5 mA at 10 volts, falls slightly to 5.5 mA at about 50 volts and rises slightly to 6.5 mA and 90 volts. It rises steeply passing through 8 mA and 100 volts. it gets less steep at 10 mA and 105 volts. The curve ends at 10.5 mA and 180 volts. There are 5 more curves that do much the same thing at successively lower and lower currents. The maximum current for the bottom curve is 1 mA. End verbal description.


 Figure 4B.2. This is an oscilloscope photo very similar to Figure 4B.1. The top curve rises to 9 mA at 20 volts. At this point it is curving from being almost vertical to almost horizontal. It passes through 10 mA at 25 volts, 10.75 mA at 100 volts and ends at 11 mA at 180 volts. The second curve rises to 6.5 mA at 20 volts where it is curving over to being horizontal. It passes through 7.6 mA at 40 volts, 7.8 mA at 100 volts and ends at 8 mA at 180 volts. As above there are 5 more curves. The lowest one has a maximum current of 0.8 mA. End verbal description.


 Figure 4B.3. A tube has its cathode connected through a resistor to ground. The resistor is labeled RK. In parallel with the resistor is a capacitor which is labeled CK. The suppressor grid is tied to the cathode. The grid of the tube connects to ground through a resistor labeled Rc. There are a pair of terminals on the left labeled input. The lower one connects to ground and the upper one connects to the grid of the tube. The screen grid of the tube connects through a resistor labeled Rc2 to a point labeled plate supply voltage, E b b. A capacitor labeled Cc2 connects from the screen grid to ground. The plate of the tube connects through a resistor labeled Rb to a point labeled plate supply voltage, E b b. The plate also connects through a capacitor labeled Cc to the upper output terminal. This terminal connects through a resistor labeled Rcf to ground. The lower output terminal is grounded. End of verbal description.
go back


 Figure 4B.4. On the left is a current source. The arrow inside the circle is pointing down indicating the direction of current flow. It is labeled GmVgk. In parallel with the current source is a resistor labeled rp. The R is lower case. There are terminals at the top and bottom of the resistor. To the right there is another resistor connected to the terminals. It is labeled Rb with a capitol R. connected in parallel with Rb is another resistor labeled Rcf. To clarify, all three resistors are connected in parallel. End verbal description.


 Figure 4B.5. A tube has its cathode connected through a resistor to ground. The resistor is labeled RK. The suppressor grid is tied to the cathode. The grid of the tube connects to ground through a resistor labeled Rc. There are a pair of terminals on the left labeled input. The lower one connects to ground and the upper one connects to the grid of the tube. The screen grid of the tube connects through a resistor labeled Rc2 to a point labeled plate supply voltage, E b b. A capacitor labeled Cc2 connects from the screen grid to the cathode. The plate of the tube connects through a resistor labeled Rb to a point labeled plate supply voltage, E b b. The plate also connects through a capacitor labeled Cc to the upper output terminal. This terminal connects through a resistor labeled Rcf to ground. The lower output terminal is grounded. End of verbal description.
go back


 Figure 4B.6. This is a block diagram. On the left is an antenna which feeds into the first block. This block is labeled, quote, RF amplifier with two tuned circuits, one on the input, and the other on the output. End quote. The output of the RF amplifier block feeds into the block labeled, quote, converter. End quote. The output of the converter block feeds into the block labeled, quote, 455 kHz I F amplifier. End quote. The output of the I F amplifier feeds into the block labeled, quote, detector. End quote. One of the outputs from the detector block feeds to the input of the block labeled, quote, audio amplifier. End quote. The other output from the detector block is labeled A G C and feeds into the I F amplifier, converter, and R F amplifier blocks. End of verbal description.
go back


 Figure 4B.7. On the left is an air core transformer labeled antenna coil. The lower end of the primary connects to earth ground and circuit ground. The upper end of the primary connects to an antenna. The lower end of the secondary goes to ground through a 0.01 u f capacitor. The lower end also goes to a point labeled A G C. The top of the secondary goes to the top of a variable capacitor. The bottom end is grounded. The top of the secondary also goes to the third grid, pin 8, of a 12SA7 heptode tube. The cathode of the tube, pin 6, goes to the tap on the oscillator coil. The bottom of the oscillator coil is grounded. The top of the coil goes to one side of a variable capacitor, the other side is grounded. This capacitor is ganged with the one on the antenna coil. The top of the oscillator coil goes through a 220 pf capacitor to grid 1, pin 5 of the tube. Pin 5 goes through a 27 k ohm resistor to ground. Grids 2 and 4 are tied together inside the tube and come out to pin 4. Pin 4 goes through a 0.1 u f cap to ground. Pin 4 goes through a 1 k ohm resistor to plus 125 volts. Pin 4 also goes to the bottom of the primary of the I F transformer. The top of the primary goes to the plate, pin 3 of the tube. The suppressor grid and metal envelope of the tube come out to pin 1, this pin is grounded. The bottom of the secondary of the I F transformer goes through a 0.01 U f cap to ground. The bottom of the secondary also goes to the A G C point. The top of the secondary is labeled to grid of I F tube. End of verbal description.
Go back


 Figure 4B.8. There are 4 triodes all in a row. We will number them from left to right, 1, 2, 3, and 4. Below them are two more triodes which we will number, 5, and 6. The cathodes of triodes 1, 2, and 5, are tied together and go through a resistor to one end of the lower pot. The wiper is grounded. In like manor the cathodes of triodes 3, 4, and 6, are tied together and go through a resistor to the other end of the lower pot. Cathodes 1, 2, and 5, go through a resistor to cathodes 3, 4, and 6. The grids of triodes 1 and 4 are tied together and go through a resistor to ground. These grids also connect to the upper input terminal. The grids of triodes 2, and 3, are tied together and go through a resistor to ground. These grids also go to the second input terminal. The plates of triodes 1 and 3 are tied together and go through a resistor to one end of the upper pot. The wiper goes to B plus. Plates 1 and 3 also go to one of the output terminals. Triode plates 2 and 4 are tied together and go through a resistor to the other end of the upper pot. Plates 2 and 4 also go to the other output terminal. The grid of triode 5 goes through a resistor to ground. The grid also goes to the third input terminal. The grid of triode 6 goes through a resistor to ground. This grid also goes to the fourth input terminal. The plates of triodes 5 and 6 go to B plus. End of verbal description.
Go back


 Figure 4B.9. The doubly balanced mixer. Components inside the eye sea are in black while external ones are in red. If no color is stated for a component, it is in black. At the very bottom of the diagram the bottom line, goes to pin 14. Pin 14 connects to minus 12 volts, shown in red. A 62 k ohm resistor, in red, connects from ground to pin 5 of the eye sea. Pin 5 connects to the collector and base of Q9. The emitter of Q9 connects to a 500 ohm resistor, and the other end goes to the bottom line. The base and collector of Q9 connect to the bases of Q7 and Q8. The emitters of Q7 and Q8 each go through their own 500 ohm resistors to the bottom line. The collector of Q7 goes to the emitter of Q5. The collector of Q8 goes to the emitter of Q6. The emitter of Q5 also goes to pin 3 of the eye sea and the emitter of Q6 goes to pin 2. A 20 k ohm resistor, in red, connects between pins 2 and 3. The base of Q5 connects to pin 1 while the base of Q6 connects to pin 4. All of the resistors mentioned below are in red. A 22 k ohm resistor connects from pin 1 to a junction point. Another 22 k ohm resistor connects from pin 4 to the junction point. A 4.7 k ohm resistor connects from the junction point to ground. Another 4.7 k ohm resistor connects from the junction point to minus 12 volts. The junction point is set at minus 6 volts. The collector of Q5 connects to the emitters of Q1 and Q2. The collector of Q6 connects to the emitters of Q3 and Q4. Now hang on tight. The bases of Q2 and Q3 are tied together and go to pin 8. The bases of Q1 and Q4 are tied together and go to pin 10. Pins 8 and 10 go through their own 4.7 k ohm resistors, shown in red, to ground. The collectors of Q1 and Q3 go to pin 6. The collectors of Q2 and Q4 go to pin 12. Pins 6 and 12 go through their own 30 k ohm resistors, shown in red, to plus 12 volts. End verbal description.


 Figure 4B.10. At the center of the diagram is an arrangement of diodes that I'll bet most sighted people will take for a bridge rectifier. It is not. Starting at the top corner of the bridge and moving clockwise, The top corner is connected to the cathode of a diode. The anode of this diode is connected to the right corner. The right corner is also connected to the cathode of a second diode. The anode of this diode is connected to the bottom corner. The bottom corner is also connected to the cathode of a third diode. The anode of this diode goes to the left corner. The left corner also connects to the cathode of a fourth diode. The anode of this diode connects to the top corner, closing the ring. On the left are two input terminals. These connect to the primary of an RF transformer. The secondary of this transformer connects to the top and bottom of the ring of diodes. At the bottom is another RF transformer and the terminals on its primary are pointing to the right indicating they are output terminals. The secondary of this transformer connects to the left and right corners of the diode ring. There are two more input terminals on the left. One goes to the center tap on the secondary of the left hand transformer. The other terminal goes to the center tap on the secondary of the bottom transformer. End of verbal description.
Go back


 Figure 4B.11. This is the diagram of two unusual tubes. On the left is the 7360 beam deflection tube. It is a 9 pin miniature type. The heater is connected to pins 4 and 5. The cathode goes to pin 1, grid number 1 to pin 3, grid number 2 to pin 2. Then there are the beam deflector elements. The left one looks like a less than sign with the electrical connection coming off the point on the left. The right one looks like a greater than sign with the electrical connection coming off the point on the right. The left deflector goes to pin 9 and the right deflector goes to pin 8. There are two plates in the tube. The left hand plate goes to pin 7 and the right one to pin 6. The other tube is a 6 eh R 8 which has 3 grids instead of two. The heater goes to pins 4 and 5. One side of the heater, pin 5, goes to grid 2. That's no mistake, I've checked it in three different tube manuals. Grid 2 is referred to as a shield in the Sylvania tube manual. The cathode goes to pin 7, grid 1 to pin 6, Grid 2 to pin 5, grid 3 to pin 3, left deflector to pin 2, right deflector to pin 1, left plate to pin 9, and right plate to pin 8. End of verbal description.
Go back


 Figure 4B.12. The cathode of a pentode goes through an RF choke to ground. On the left is a 455 kHz crystal. One end is grounded and the other end goes to the grid of the pentode. The grid goes through a resistor to ground. The grid also goes through a capacitor to the cathode. The cathode goes through another capacitor to ground. The screen grid goes to B plus. There is a capacitor from B plus to ground. The bottom of the primary of a 455 kHz I F transformer goes to B plus. The top of the primary goes to the plate of the pentode. The suppressor of the pentode goes to ground. The bottom of the secondary of the I F transformer goes to ground. The top goes to the grid, pin 3, of a 7360 beam deflection tube. The cathode, pin 1, goes through a paralleled resistor and capacitor to ground. The capacitor is large enough to bypass the RF but too small to bypass the audio. The screen grid, pin 2, goes through a capacitor to ground. The screen also goes to B plus. Each deflector goes through its own resistor to plus 25 volts. The left hand deflector, pin 9, goes through a capacitor to ground. The right deflector goes through a capacitor to a point labeled audio input. The plates, pins 6 and 7, each go to one end of the primary of a 455 kHz I F transformer. A center tap on the primary goes to B plus. The secondary goes to two output terminals. End of verbal description.
Go back


 Figure 4B.13. There are 3 photographs in this figure. The top one shows the tube with no power applied. We are looking at it from what would normally be the top. The tube is mounted on its side so we see it from the end. In the center is a round metal piece and surrounding it and behind it is a gray target, that looks like a thick ring. The whole thing looks like the bulls eye and its surrounding ring.

In the lower left picture the tube is powered. The piece in the middle is dark but the surrounding thick ring is glowing green. The entire circle is not glowing brightly. At the bottom about a quarter of the circle is cut out. It looks like one of those cakes with a hole in the center. Someone has cut out about a quarter of the cake. Inside this dark area there is still a faint green glow. It looks like there is a source of green light in the center and some object has cast a shadow on the ring.

In the lower right picture the shadow area is just a small wedge. Someone with a very small apatite has cut a tiny piece of the cake. The shadow has almost closed up completely and almost all of the ring is bright green.

End of verbal description.
Go back


 Figure 4B.14. The base diagram of the 6E5 magic eye tube looks like a twin triode with one cathode for both triodes. The heater is connected to pins 1 and 6. The cathode, pin 5, is grounded. The grid of the left hand triode, pin 3, goes to the upper input terminal, the lower input terminal is grounded. The plate of the left hand triode, pin 2, goes through a 2.2 meg ohm resistor to B plus. The grid of the right hand triode is connected inside the tube to the plate of the left hand triode. The plate of the right hand triode, pin 4, is connected to B plus. This plate is refered to as the target. End of verbal description.
Go back


 Figure 4B.15. This shows the cylindrical construction of a tube. At the center is a dot indicating the end view of the heater. Surrounding the heater is the insulator and surrounding that is the cathode. The target surrounds the whole thing. Between the cathode and target is the shadow control grid which subtends an angle of 90 degrees centered at the bottom of the circle. Just outside of the target control grid and at the bottom center, just inside the target is a dot representing the end view of the shadow rod. End of verbal description.
Go back


 Figure 4B.16. In part eh there is a triode tube with its cathode grounded. The grid goes through a resistor R2 to ground. The plate goes through a resistor R3 to B plus. The plate goes through a capacitor, C3, to one end of the coil L1. one side of a variable capacitor, C1B goes to this end of the coil. The other end of the capacitor is grounded. The other end of the coil goes to one end of another variable capacitor, C1 eh. The other end is grounded. The end of the coil away from the plate goes through a resistor, R1, to ground. This end of the coil also goes through a capacitor to the grid.

In part B the triode also has its cathode grounded. There is a resistor, R1, from the grid to ground. There is another resistor, R2, from the plate to B plus. There is a capacitor, C3 from the plate to one side of the coil. The coil has a center tap which is grounded. The other end of the coil goes through a capacitor C2 to the grid. There is a variable capacitor, C1, in parallel with the coil, from one end to the other. End of verbal description.
Go back


 Figure 4B.17. In part eh there is a triode with its cathode grounded. The grid goes to ground through a resistor. The plate connects to one end of the coil. The center tap of the coil goes to B plus. The other end of the coil goes through a capacitor to the grid. There is a variable capacitor connected from one end of the coil to the other.

In part B the tube has its cathode connected to a tap on the coil. The tap is much closer to the lower end than it is to the top. The bottom of the coil is grounded. The top of the coil goes through a capacitor to the grid of the tube. The top of the coil goes through a variable capacitor to ground. There is a resistor from the grid of the tube to ground. The plate goes to B plus. End of verbal description.
Go back


 Figure 4B.18. Parts eh and B of this figure are almost identical. The identical parts will be described first. The cathode of the tube goes to ground through an RF choke. The grid of the tube goes through a capacitor, C3, to the cathode. There is another capacitor, C4, from the cathode to ground. There is a resistor, R1, from the grid to ground. One end of a capacitor, C2, connects to the grid. The other end connects to the tuned circuit which will be described below. The plate of the tube goes to B plus.

In part eh one end of the coil, L1, connects to the capacitor from the grid. The other end of the coil goes to ground. There is a variable capacitor, C1, in parallel with the coil.

In part B one end of the coil, L1, connects to the capacitor from the grid. The other end of L1 connects to the variable capacitor, C1. The other end of C1 goes to ground. End of verbal description.
Go back


 Figure 4B.19. The cathode of a pentode goes through an RF choke to ground. There is a capacitor, C3, from the grid to the cathode. There is another capacitor, C4, from the cathode to ground. There is a resistor, R1, from the grid to ground. One end of a capacitor, C2, goes to the grid. The other end of C2 goes to one end of L1, oscillator coil. The other end of L1 goes to a variable capacitor, C1, the other end of C1 is grounded. The screen grid goes through a capacitor, C5, to ground. The screen goes to a point labeled 105 volts regulated. The suppressor grid is grounded. The plate goes through another inductor, L2, to plus 150 volts. There is a resistor, R2, in parallel with L2, and a capacitor, C6, in parallel with L2 and R2. There is a capacitor, C7, from plus 150 volts to ground. The plate of the tube goes through a capacitor, not labeled, to the output. End of verbal description.
Go back


 Figure 4B.20. In part eh there are two terminals pointing to the right. The top terminal goes through a capacitor to the bottom terminal. The top terminal also goes to one end of another capacitor. The other end of this capacitor goes to one end of an inductor. The other end of this inductor goes to one end of a resistor. The other end of this resistor goes to the bottom terminal.

In part B there is a triode tube with its cathode going to ground through an RF choke. The grid goes through a capacitor to the cathode. The cathode goes through another capacitor to ground. The grid goes through a resistor to ground. The grid also goes to one side of a quartz crystal. The other side is grounded. The plate goes to B plus. End of verbal description.
Go back


 Figure 5.1. At approximately the center of the diagram is a triangle turned on its side. The point is to the right and the left side is vertical. This is the symbol for a general amplifier as well as an operational amplifier. The amplifier has its output on the right, taken from the point of the triangle. There are two inputs on the left. The upper one is marked with a plus sign and the lower one is marked with a minus sign. On the left side of the diagram is an AC generator labeled V sub in. The bottom end of the generator is connected to ground and the upper end is connected to the plus input of the amplifier. A resistor labeled R sub 2 is connected from the output of the amplifier to the minus input. Another resistor labeled R sub 1 connects from the minus input to ground. The voltage across R sub 1 is labeled beta V sub O. The voltage at the plus input is labeled V sub 1 and the voltage at the minus input is labeled V sub 2. The output voltage is labeled V sub O. End verbal description.


 Figure 5.2. There are two input terminals labeled V sub in. The lower one connects to ground and is labeled with a minus sign. The upper terminal is labeled with a plus sign. The upper input terminal connects to one end of a resistor labeled R sub 1. The other end of this resistor goes to the minus input of a triangle indicating an amplifier. The plus input of the amplifier is grounded. The output of the amplifier goes to one end of a resistor labeled R sub 2. The other end of the resistor goes to the plus input. All voltages are marked with plus and minus signs. V sub in is labeled minus at the bottom and plus at the top. The voltage across R sub 1 is labeled plus on the left and minus on the right. The voltage between the minus input of the amplifier and ground is labeled V sub sig and is positive at the input and negative at ground. The output voltage, V sub O is labeled minus at the input and plus at ground. There are broken lines with arrows indicating the direction in which the equations were written. Equation 5.6 starts at the grounded input terminal, goes up across the input terminals, to the right across R sub 1 and down across V sub sig to ground. Equation 5.7 starts at ground below V sub sig. It goes up across V sub sig, to the right across R sub 2, and down to ground across V sub O. End verbal description.


 Figure 5.3. This is a graph. The vertical axis is labeled gain and runs from 10 to the minus 5 to 10 to the 6. The marks are equally spaced and are as follows. 10 to the minus 5, 10 to the minus 4, 10 to the minus 3, 10 to the minus 2, 10 to the minus 1, 1, 10, 10 to the 2, 10 to the 3, 10 to the 4, 10 to the 5, and 10 to the 6. The horizontal axis is labeled frequency and runs along the gain = 1 value. Frequency = 1 is on the vertical line so the two lines cross at the point gain = 1 and frequency = 1. The frequency marks are equally spaced and are, from left to right, 1, 10, 10 to the 2, 10 to the 3, 10 to the 4, 10 to the 5, 10 to the 6, 10 to the 7, and 10 to the 8. This makes this a log log graph. There are three lines on the graph, a black one, a green one, and a red one. They are made up of straight line segments, there are no gradual curves. The black line begins at the left edge of the graph at gain = 10 to the 5. This line goes horizontally to the right at the 10 to the 5 level until it reaches a frequency of 10 to the 5. At this point it turns downwards on a slope of minus 1 going to the point gain = 10 to the 4, frequency = 10 to the 6. It turns again to a slope of minus 2 going to the point gain = 10 to the 2 and frequency = 10 to the 7. At this point it turns again to a slope of minus 3 and goes to the point gain = 10 to the minus 1 and frequency = 10 to the 8. The green line starts at the left edge of the graph at a gain of 10 to the 5. It goes horizontally to the right to the point gain = 10 to the 5 and frequency = 10. At this point it turns downwards to a slope of minus 1 and goes to the point gain = 1 and frequency = 10 to the 6. At this point it turns to a slope of minus 2 to the point gain = 10 to the minus 2 and frequency = 10 to the 7. At this point it turns to a slope of minus 3 to the point gain = 10 to the minus 5 and frequency of 10 to the 8, where it ends. The red line starts on the left edge of the graph at gain = 1. It goes to the right to the point gain = 1 and frequency = 10. At this point it turns downward to a slope of minus 1 to the point gain = 10 to the minus 4 and frequency = 10 to the 5. At this point it levels out again and leaves the right edge of the graph at gain = 10 to the minus 4. End verbal description.


 Figure 5.4. There are two input terminals on the left and two more on the right. The lower left input terminal connects to the lower right output terminal and this will be called the bottom line of the circuit. The upper input terminal connects to one end of a resistor labeled R sub 1. The other end of this resistor connects to the upper output terminal. The upper output terminal also connects to one end of a resistor labeled R sub 2. The other end of this resistor connects to a capacitor labeled C. The other end of this capacitor connects to the bottom line of the circuit. End verbal description.


 Figure 5.5. This is a log log graph with two lines, one black and one green. The vertical axis is labeled gain and runs from 10 to the minus 1 at the bottom to 10 to the 4 at the top. The horizontal axis is labeled frequency and runs from 10 to the minus 1 at the left to 10 to the 7 at the right. The two axes cross at the point gain = 1 and frequency = 1. The black line begins at the point gain = minus 1 and frequency = minus 1. It rises on a slope of plus 2 to the point gain = 10 to the 3 and frequency = 10. At this point it flattens out and goes to the point gain = 10 to the 3 and frequency = 10 to the 4. It then falls on a slope of minus 1 to the point gain = 1 and frequency = 10 to the 7. The green line begins at the point gain = minus 1 and frequency = minus 1. It rises on a slope of plus 2 to the point gain = 10 and frequency = 1. At this point it breaks to a slope of plus 1 and goes to the point gain = 10 to the 3 and frequency = 10 to the 2. At this point it flattens out and goes to the point gain = 10 to the 3 and frequency = 10 to the 4. It then falls on a slope of minus 1 to the point gain = 1 and frequency = 10 to the 7. End verbal description.


 Figure 5.6. Only a few of the components in this circuit have values given. The lower input terminal is grounded. The upper input terminal connects to one end of a capacitor labeled C sub 1. The other end of C sub 1 connects to the grid of a triode vacuum tube. The grid also goes to ground through a resistor. The cathode goes to ground through a 15.9 k ohm resistor. We will return to this cathode later. The plate goes to B plus through a resistor. The plate of this triode goes through a capacitor labeled C sub 2, 0.01 microfarad to the grid of a second triode. The grid of the second triode goes to ground through a 1.59 meg ohm resistor. The cathode of the second triode goes to ground through the parallel combination of a resistor and capacitor. The capacitor is labeled C sub 3. The plate of the second triode goes through a resistor to B plus. The plate of the second triode goes through a capacitor labeled C sub 4, 0.1 microfarad, then through a 143 k ohm resistor to the cathode of the first triode. The plate of the second triode also goes through a capacitor labeled C sub 5 to the upper output terminal. The upper output terminal goes through a resistor to ground. The lower output terminal is grounded. End verbal description.


 Figure 5.7. This is another log log plot. The vertical axis is labeled gain and is marked off from 10 to the minus 1 at the bottom to 10 to the 4 at the top. The horizontal axis is labeled frequency and is marked off from 10 to the minus 2 at the left to 10 to the 8 at the right. The lines cross at the point gain = 1 and frequency = 10 to the minus 1. The only line starts at gain = 10 to the minus 1 and frequency = 10 to the minus 2. It rises on a slope of plus 1 to the point gain = 10 to the 3 and frequency = 10 to the 2. At this point it breaks to horizontal, zero slope. It goes to the point gain = 10 to the 3 and frequency = 10 to the 5. At this point it breaks to a slope of minus 1 and goes to a little past the point Gain = 1 and frequency = 10 to the 8. End verbal description.


 Figure 5.8. This is another log log Bode plot. The vertical axis is labeled gain and goes from 10 to the minus 1 at the bottom to 10 to the 4 at the top. The horizontal axis is labeled frequency and goes from 10 to the minus 2 at the left to 10 to the 8 at the right. There are two lines on this graph. The black one is labeled open loop gain and begins a little to the left of and below gain = 1 and frequency = 10 to the minus 1. It goes up on a slope of plus 1 to the point gain = 10 to the 4 and frequency = 10 to the 3. It runs horizontally to the point gain = 10 to the 4 and frequency = 10 to the 4. At this point it breaks down to a slope of minus 1 and ends a little below and to the right of gain = 1 and frequency = 10 to the 8. The red line is labeled closed loop gain and begins a little to the left of and below gain = 1 and frequency = 10 to the minus 1. It goes up on a slope of plus 1 to the point gain = 10 to the 2 and frequency = 10. It runs horizontally to the point gain = 10 to the 2 and frequency = 10 to the 6. At this point it breaks down to a slope of minus 1 and ends a little below and to the right of gain = 1 and frequency = 10 to the 8. End verbal description.


 Figure 5.9. There are two input terminals on the left. The lower one is grounded. The upper one connects to the negative end of a capacitor labeled C2, 2 u f. The positive end connects to the base of Q1. The base connects through a resistor, R1, 91 k ohm to Vcc. The base also connects through R2, 10 k ohm, to ground. The emitter connects through R4, 6.2 k ohm, to ground. The emitter also connects to the positive end of C2, 4.7 u f. The negative end connects through R10, 1 k ohm to ground. We will return to the junction of C2 and R10 later. The collector of Q1 goes through R3, 82 k ohm to Vcc. The collector also goes to the positive end of c3, 2 u f. The other end goes to the base of Q2. The base of Q2 goes through R5, 24 k ohm, to Vcc. The base also goes through R6, 4.7 k ohm to ground. The emitter of Q2 goes through R8, 1.2 k ohm to ground. The emitter goes to the positive end of C4, 10 u f. The negative end goes to ground. The collector of Q2 goes through R7, 5.6 k ohm to Vcc. The collector goes through a capacitor, unmarked, to the upper output terminal. The lower output terminal is grounded. The collector also goes through R9, 47 k ohm to the junction of C2 and R10. End verbal description.


 Figure 5.10. The lower input terminal is grounded. The upper input terminal goes to the negative end of C1, 1 u f. The positive end goes to the base of Q1, 2N3904. The base also goes to ground through R1, 75 k ohm. We will return to the base later. The emitter of Q1 goes to ground through R2, 6.8 k ohm. We will return to the emitter later. The collector of Q1 goes through R3, 82 k ohm to plus 12 volts. The collector of Q1 goes to the base of Q2, also a 2N3904. The emitter of Q2 goes to ground through R6, 3.0 k. The emitter also goes to the positive end of C2, 25 u f. The negative end is grounded. The emitter of Q2 also goes through R4, a 75 k ohm resistor to the base of Q1. The collector of Q2 goes through R5, 4.3 k ohm to plus 12 volts. The collector goes to the positive end of C3, 5 u f. The negative end of C3 goes through R7, 51 ohm to the emitter of Q1. The junction of C3 and R7 goes to the positive end of C4, 5 u f. The other end of C4 goes to the upper output terminal. The lower output terminal is grounded. End verbal description.


 Figure 5.11. The lower input terminal is grounded. The upper input terminal goes to the negative end of C1, 4.7 u f. The positive end goes to the base of Q1, 2N3904. The base goes to Vcc through R1, 27 k ohms. The base also goes to ground through R2, 47 k ohms. The emitter goes to the positive end of C2, 100 u f. The negative end goes to ground through R7, 470 ohms. We will return to the emitter later. The collector goes to Vcc through R3, 1 k ohm. The collector of Q1 goes to the base of Q2, 2N3906. The emitter of Q2 goes to Vcc. The collector goes through R5 then through R6 to ground. Both R5 and R6 are 1 k ohm. The junction of R5 and R6 goes through R4, 5.6 k ohm to the emitter of Q1. The collector of Q2 goes to the positive end of C3, 1 u f. The negative end goes to the upper output terminal. The lower output terminal is grounded. End verbal description.


 Figure 5.12. This circuit has two BJT's which are wired almost identically. The emitters of Q1 and Q2 go to ground. The bases of both transistors go through their own 100 k ohm resistors to plus 12 volts. The resistor to Q1 is R2 and the one to Q2 is R3. Each collector goes through its own 2.2 k ohm resistor to plus 12 volts. The resistor to Q1 is R1 and the one to Q2 is R4. The collector of Q1 goes through C1, 0.1 u f capacitor to the base of Q2. The collector of Q2 goes through C2, 0.1 u f cap to the base of Q1. The collector of Q1 goes to a terminal labeled output. The collector of Q2 goes to a different terminal which is also labeled output. Each output terminal has a matching terminal which is grounded. End verbal description.


 Figure 5.13. We begin with Q1 which is an F E T with the number MPF102. We will describe the gate connection at the end. The drain goes to Vcc. The source goes through a 10 k ohm resistor to ground. The source goes to the positive end of a 50 u f capacitor. The negative end goes to the base of Q2, 2N3904. The base goes through a 10 k res to ground. The base goes through an 82 k res to Vcc. The emitter goes through a 5.6 k res to ground. The emitter goes to the positive end of a 100 u f cap. The negative end goes to the top of a 1 k ohm pot. The bottom end and wiper of the pot are grounded. The collector goes through a 36 k ohm res to Vcc. The collector of Q2 goes to the base of Q3, 2n3904. The collector of Q3 goes to Vcc. The emitter of Q3 goes through a 1 k res to ground. The emitter also goes to the positive end of a 100 u f cap. The negative end goes to the upper output terminal. The lower output terminal is grounded. The emitter also goes to one end of a capacitor labeled only as C. The other end of the capacitor goes through a resistor to ground. This resistor is labeled only as R. The junction of the first C and R goes to one end of another capacitor also labeled C. The other end of this second C goes to ground through a second resistor labeled R. The junction of the second C and R goes to one end of a third capacitor labeled C. The other end goes to ground through a third resistor labeled R. The junction of the third C and R goes to the gate of Q1. End verbal description.


 Figure 5.14. The gate of an F E T, MPF102 goes to ground through a 47 k ohm resistor. The gate also connects to one end of a 2 MHz quarts crystal. The other end of the crystal is grounded. The gate of Q1 connects to one end of a variable capacitor labeled 7 to 45 pf trimmer. The other end of the variable cap goes to the source of the F E T. The source goes through a 110 pf cap to ground. The source goes through a 390 ohm resistor to ground. The source also goes through a 0.1 u f cap to the base of Q2. The drain of Q1 goes to plus 5 volts. Q2 is a 2N3904. Its emitter is grounded. Its base goes through a 100 k ohm resistor to ground. The base also goes through a 200 k ohm resistor to plus 5 volts. The collector of Q2 goes through a 2.2 k ohm resistor to plus 5 volts. The collector of Q2 goes to the upper output terminal. The lower output terminal is grounded. End verbal description.


 Figure 6.1. The op amp is symbolized by a triangle. The short side of the triangle is vertical and on the left. The other two sides are of equal length and are about half again as long as the short side. The signal inputs come to the left side. The inverting input is connected about half way between the middle and the top and is marked with a minus sign inside the triangle. The noninverting input is connected about half way between the middle and the bottom and is marked with a plus sign inside the triangle. The positive power supply connection is made to the top right side about half way between the left side and the point. The negative power supply connection is made to the bottom right side about half way between the left side and the point. The output comes off the point on the right. The positive power supply connection goes to the positive of a battery. The negative of this battery goes to ground. The positive end of another battery goes to ground. The negative of this battery goes to the negative power supply connection of the op amp. End verbal description.


 Figure 6.2. The upper input terminal connects to the noninverting input of an op amp. The lower input terminal is grounded. The output of the op amp connects to the inverting input. The output of the op amp goes to the upper output terminal. The lower output terminal is grounded. End verbal description.


 Figure 6.3. The upper input terminal connects through a resistor labeled R3, to the noninverting input of an op amp. The lower input terminal is grounded. The output of the op amp connects through a resistor labeled R2, to the inverting input. The inverting input also goes through a resistor labeled R1 to ground. The output of the op amp goes to the upper output terminal. The lower output terminal is grounded. End verbal description.


 Figure 6.4. The upper input terminal connects through a resistor labeled R1, to the inverting input of an op amp. The lower input terminal is grounded. The output of the op amp connects through a resistor labeled R2, to the inverting input. The noninverting input is grounded. The output of the op amp goes to the upper output terminal. The lower output terminal is grounded. End verbal description.


 Figure 6.5. There is a battery on the left with its negative terminal grounded. The positive end goes to a resistor labeled R1. The other end of R1 goes to one terminal of a voltmeter. The other terminal is grounded. The junction of R1 and the voltmeter goes to one end of R2. The other end of R2 goes to the negative terminal of a power supply. The positive terminal is grounded. End verbal description.


 Figure 6.6. There are 4 input terminals on the left. Three of them are designated eh, B, and C, and the fourth one is grounded. Input eh goes to one end of a resistor labeled R1eh, input B goes to one end of a resistor labeled R1B, and input C goes to one end of a resistor labeled R1C. The other ends of all three resistors go to the inverting input of an op amp. The noninverting input is grounded. The output connects through a resistor labeled R2 to the inverting input. The output of the op amp goes to the upper output terminal of the circuit. The lower output terminal is grounded. End verbal description.


 Figure 6.7. The upper input terminal goes through a resistor labeled R to the inverting input of an op amp. The lower input terminal and the noninverting input are grounded. The output connects through a capacitor labeled C to the inverting input. There is a switch in parallel with the capacitor. The output of the op amp goes to the upper output terminal of the circuit. The lower output terminal is grounded. End verbal description.


 Figure 6.8. This is a graph. The vertical axis goes from minus 1.5 to plus 1.5 and is labeled voltage. The horizontal axis goes from 0 to 5 and is labeled time. The voltage is zero from 0 to 0.5 seconds. At 0.5 seconds it suddenly switches to plus 1 volt where it remains until 1.5 seconds. At 1.5 seconds the voltage switches to zero where it stays until 2 seconds. At 2 seconds it switches to minus 0.5 volts. At 3.5 seconds it switches to zero. At 4 seconds it switches to minus 1.5 volts. At 4.5 seconds it switches to zero. It remains at zero until 5 seconds. End verbal description.


 Figure 6.9. This is a graph. The vertical axis goes from minus 0.75 to plus 0.75 and is labeled voltage. The horizontal axis goes from 0 to 5 and is labeled time. The voltage is zero from 0 to 0.5 seconds. At 0.5 seconds it slopes downward on a straight line to the point 1.5,-0.5. It turns and is horizontal from 1.5 seconds to 2 seconds. At 2 seconds it turns upward and goes on a straight line to the point 3.5, -0.125. It remains at this voltage from 3.5 to 4 seconds at which time it turns upward again to the point 4.5, 0.625. It remains at 0.625 volts from 4.5 to 5 seconds. End verbal description.


 Figure 6.10. In this diagram the power supply connections to the op amp are shown. The positive power supply connection goes to plus 12 volts. The negative power supply connection is grounded. The upper input terminal connects to the negative end of a 1 u f capacitor. The positive end goes to the noninverting input of an op amp. The lower input terminal is grounded. A 180 k ohm resistor connects from plus 12 volts to the noninverting input. Another 180 k ohm resistor connects from the noninverting input to ground. A 90 k ohm resistor connects from the op amp output to the inverting input. A 10 k ohm resistor connects from the inverting input to the positive end of a 10 u f cap. The negative end is grounded. The output of the op amp goes to the positive end of another 10 u f cap. The negative end goes to the upper output terminal. The lower terminal is grounded. End verbal description.


 Figure 6.11. In this diagram the power supply connections to the op amp are shown. The positive power supply connection goes to plus 12 volts. The negative power supply connection is grounded. The upper input terminal connects to the negative end of a 10 u f capacitor. The positive end goes through a 10 k ohm resistor to the inverting input of an op amp. The lower input terminal is grounded. A 200 k ohm resistor connects from plus 12 volts to the noninverting input. Another 200 k ohm resistor connects from the noninverting input to ground. A 100 k ohm resistor connects from the op amp output to the inverting input. The output of the op amp goes to the positive end of another 10 u f cap. The negative end goes to the upper output terminal. The lower terminal is grounded. End verbal description.


 Figure 6.12. This is a graph. The vertical axis goes from minus 1.5 to plus 1.5 and is labeled voltage. The horizontal axis goes from 0 to 5 and is labeled time. The voltage is zero from 0 to 0.5 seconds. At 0.5 seconds it suddenly switches to plus 1.5 volts where it remains until 2 seconds. At 2 seconds the voltage switches to zero where it stays until 2.5 seconds. At 2.5 seconds it switches to minus 0.5 volts. At 3 seconds it switches to minus 1 volt. At 3.5 seconds it switches to minus 1.5 volts. At 4 seconds it switches to minus 0.5 volts again. At 4.5 seconds it switches to zero. It remains at zero until 5 seconds. End verbal description.


 Figure 6.13. This is a graph. The vertical axis goes from minus 6 to plus 6 and is labeled voltage. The horizontal axis goes from 0 to 5 and is labeled time. The voltage is zero from 0 to 0.5 seconds. At 0.5 seconds it slopes downward on a straight line to the point 2.0, minus 4.5. It turns and is horizontal from 2 seconds to 2.5 seconds. At 2.5 seconds it turns upward and goes on a straight line to the point 3.0, minus 4.0. At this point it continues upwards with a different slope to the point 3.5, minus 3.0. The slope changes again and it goes to the point 4.0, minus 1.5. The slope changes again and goes to the point 4.5, minus 1.0. It then becomes horizontal and remains at minus 1 volt until 5 seconds. End verbal description.


 Figure 7.1. On the left is an AC generator, neither side is grounded. Two wires connect the generator to the two inputs of a differential amplifier on the right. In the middle is a generator with one side grounded. This generator is labeled noise. Two capacitors connect to the ungrounded side of the noise generator. One of the capacitors connects to one of the lines connecting the AC generator and the differential amplifier. The other capacitor connects to the other line. End verbal description.


 Figure 7.2. The top input terminal goes to the noninverting input of O eh 1. The bottom input terminal goes to the noninverting input of o eh 2. The output of O eh 1 goes through R2 then through R1 then through another resistor also labeled R2 to the output of o eh 2. We will distinguish between the two R2s by referring to the one connected to o eh 1 as the upper R2 and the one connected to o eh 2 as the lower R2. There is a resistor connected to the junction of the upper R2 and R1 which is labeled RS. The other end connects to the inverting input of o eh 1. There is another resistor connected to the junction of the lower R2 and R1 which is also labeled RS. It connects to the inverting input of O eh 2. The output of O eh 1 connects through R3 then R4 to ground. These are the upper R3 and R4. The junction of the upper R3 and R4 connects to the noninverting input of o eh 3. The output of o eh 2 connects through the lower R3 then through R4 to the output of o eh 3. The junction of the lower R3 and R4 connects to the inverting input of o eh 3. The output of o eh 3 connects to the circuit output terminal. End verbal description.


 Figure 7.3. There is an AC generator on the left. One side is grounded and the other side connects through a 0.01 u f cap to the noninverting input of an op amp. There is a 10 meg ohm resistor connected from the noninverting input to ground. Although this resistor has no number it is presumed that it is R1. The output of the op amp connects through a 100 pf cap to the inverting input. The output also connects to two diodes, to the cathode of one and the anode of the other. The free end cathode of one diode connects to the cathode of a third diode. The free end anode connects to the anode of a fourth diode. The free end anode and free end cathode of the third and fourth diodes connect together and go to ground through a resistor labeled R2. The ungrounded end of R2 also goes to the inverting input of the op amp. The point where the two diode cathodes connect goes to one side of a milliammeter. The point where the two diode anodes connect goes to the other side of the milliammeter. End verbal description.


 Figure 7.4. There are two input terminals on the left. The upper one goes to the inverting input of the op amp. The lower one goes to the positive end of the lower battery and also to the negative end of the upper battery. The negative power supply terminal of the op amp goes to the negative of the lower battery. The positive power supply terminal of the op amp goes to the positive side of the upper battery. The output of the op amp goes to the anode of a diode. The cathode goes to the anode of another diode. The cathode of this second diode goes to one side of a tungsten lamp. The other side of the lamp goes to the negative of the lower battery. Just to the left of the lamp is a photo resistor. The lower end of the photo resistor goes to the junction of the two batteries. The upper end goes to the noninverting input of the op amp. The upper end of the photo resistor also goes through a resistor to the positive of the upper battery. There is another photo resistor to the right of the lamp. There is no electrical connection between the components associated with this photo cell and the op amp circuit on the left. The bottom end of the second photo resistor goes to ground. Note there is no ground in the op amp circuit. The top end of the photo resistor goes through a pot connected as a rheostat, then a resistor to the positive of a third battery. The negative end of this battery is grounded. The top of the photo resistor goes to the upper output terminal. The lower output terminal is grounded. End verbal description.


 Figure 7.5. On the left the lower input terminal is grounded. The upper input terminal goes through R1, 10 k ohms, to the inverting input of o eh 1. The noninverting input is grounded. The output goes to the cathode of a diode, D1. The anode of D1 goes to the inverting input. The output of o eh 1 also goes to the anode of D2. The cathode of D2 goes to the output terminal of the circuit. The circuit output goes through R2, 10 k ohms, to the inverting input of O eh 1. The input of the circuit also goes to the noninverting input of o eh 2. The output of o eh 2 goes to the cathode of a diode, D3. The anode of D3 goes to the inverting input. The output of o eh 2 also goes to the anode of D4. The cathode of D4 goes to the output terminal of the circuit. The circuit output goes through R3, 10 k ohms, to the inverting input of O eh 2. There is a 10 k ohm resistor, R4 from the circuit output terminal to ground. The lower output terminal is grounded. End verbal description.


 Figure 7.6. On the left the lower input terminal is grounded. The upper input terminal goes through R1, 100 k ohms, to the inverting input of o eh 1. The noninverting input goes through a 51 k ohm resistor, R3, to ground. There is a voltage divider consisting of R6, 18 k ohm and R8, 5.6 k ohm from plus 9 volts to ground. The 5.6 k is the one connected to ground. There is a similar voltage divider consisting of R7, 18 k and R9, 5.6 k from minus 9 volts to ground. A 1 k ohm pot has its left end connected to the junction of R6 and R8, and its right end connected to the junction of R7 and R9. The wiper of the pot goes through R4, 3 meg ohm to the inverting input of O eh 1. The output of o eh 1 goes through R2, 100 k ohms to the inverting input. The output of o eh 1 goes through R10, an 11 k ohm, to the inverting input of O eh 2. The noninverting input is grounded. The output of o eh 2 goes through a 3300 pf cap to the inverting input. The output also goes to the emitter of Q1, a PNP transistor. The base of Q1 is grounded and the collector goes to the inverting input of O eh 2. The output of o eh 2 goes to the emitter of Q2, identical to Q1. The collector and base of Q2 are died together and go through R11, 30 k ohm to minus 9 volts. The collector and base of Q2 also go through R12, 47 k ohm, R13, 50 k ohm pot connected as a rheostat, and R14, 2.2 k ohm to ground. The junction of R13 and R14 goes to the upper output terminal. The lower output terminal is grounded. End verbal description.


 Figure 7.7. On the left the lower input terminal is grounded. The upper input terminal goes to one end of a capacitor labeled only as C. The other end of this capacitor goes through another capacitor also labeled C to the noninverting input of the op amp. The junction of the two capacitors goes through a resistor labeled 2R , not R2, to the output of the op amp. A resistor labeled R goes from the noninverting input to ground. The output is connected to the inverting input. The output of the op amp goes to the upper output terminal of the circuit. The lower output terminal is grounded. End verbal description.


 Figure 7.8. On the left the lower input terminal is grounded. The upper input terminal goes to one end of a resistor labeled 2R. The other end of this resistor goes through another resistor labeled R to the noninverting input of the op amp. The junction of the two resistors goes through a capacitor labeled C, to the output of the op amp. Another capacitor labeled C goes from the noninverting input to ground. The output is connected to the inverting input. The output of the op amp goes to the upper output terminal of the circuit. The lower output terminal is grounded. End verbal description.


 Figure 7.9. This circuit begins with figure 7.5 which was copied and pasted into this figure. The output feeds into figure 7.8 which was also copied and pasted. The output of 7.8 feeds into figure 7.6, which arrived here by the same path. The output of figure 7.6 is the output of the combination circuit. End verbal description.


 Figure 8.4. There is a battery on the left. The positive terminal of the battery goes to one side of a single pole, single throw, switch that is labeled eh. The other side of the switch goes to another SPST switch labeled B. The other side of the B switch goes to a switch labeled C. The other side of the C switch goes to one side of a lamp. The other side of the lamp goes to the negative side of the battery. End verbal description.


 Figure 8.6. There is a battery on the left. The positive terminal of the battery goes to one side of a single pole, single throw, switch that is labeled eh. The battery also goes to another SPST switch labeled B. The battery also goes to a switch labeled C. The other sides of all three switches are connected together and go to one side of a lamp. The other side of the lamp goes to the negative side of the battery. End verbal description.


 Figure 8.10. There are six schematic symbols of logic gates in this figure. The first one has three inputs on the left although gates may have any number of inputs from 2 to some large number limited only by the ability of the manufacturer to make the chips. The three inputs come to a vertical line. At the top of the line there is another line extending to the right which is about half as long as the vertical one. At the bottom there is another line extending to the right the same distance as the one at the top. The ends of each of the horizontal lines are connected by an arc forming a semicircle to the right. The output comes off from the middle of the arc. This figure is labeled A N D.

There second gate looks the same as the A N D gate except where the output line comes off there is a small circle attached to the larger arc. The output line is attached to the right side of the circle.

In the third gate the three inputs come to an arc which has its center to the left so it forms a slightly concave line. At the top another arc begins going to the right and swings downward to the output point making about one eighth of a circle. At the bottom of the left arc another arc starts that starts to the right and swings up meting the other arc at the output point making about 1 eighth of a circle. The output line comes off of the points on the right where the two 1 eighth arcs meet. This gate is labeled O R.

The fourth gate looks similar to the O R gate but at the point where the two arcs meet on the right is a small circle with its left side touching the point made by the two arcs meeting. The output line comes off the right of the small circle. This gate is labeled N O R.

The fifth gate looks like an op amp with only one input. The left side of the triangle is vertical and the input comes to the middle of it. There is only one input. On the point of the triangle, at the right, is a small circle similar to other gates in this figure. The output comes off of the right side of the circle. This gate is labeled N O T.

The last gate looks like the O R gate but there is another arc to the left of the one that is connected to the other two arcs. This arc has the same radius of curvature but is not touching the main part of the gate made of the three arcs. There are only two inputs and they come to the detached arc on the left. The output is taken from the point on the right where the two arcs meet. This gate is labeled X O R.

End verbal description.


 Figure 8.12. This is a table. The column headings are as follows. First column, function. Second column, example. Third column, think or speak. Each row will be red across with the columns in the order given above. First row. Eh N D. C = eh X B. C equals eh and B. Second row. O R. C = eh + B. C equals eh or B. Third row. N O T. B = eh with a horizontal line over the eh. B equals not eh. Fourth row. X O R. C = eh, then a plus sign drawn inside a circle, B. C equals eh X-or B. Note X-or can also be read as exclusive or. End verbal description.


 Figure 8.13. This is a table of Boolean algebra theorems. They are written using the notation indicated in the table above but they will be read as the table above says they should be spoken.

0 and 0 = 0. 0 and 1 = 0. 1 and 0 = 0. 1 and 1 = 1. eh and 0 = 0. eh and 1 = eh. eh and eh = eh. eh and not eh = 0.

0 or 0 = 0. 0 or 1 = 1. 1 or 0 = 1. 1 or 1 = 1. eh or 0 = eh. eh or 1 = 1. eh or eh = eh. eh or not eh = 1.

0 X-or 0 = 0. 0 X-or 1 = 1. 1 X-or 0 = 1. 1 X-or 1 = 0. eh X-or 0 = eh. eh X-or 1 = not eh. eh X-or eh = 0. eh X-or not eh = 1.

eh and b = b and eh. eh or B = B or eh. eh X-or B = B X-or eh.

eh and quantity B or C close quantity = quantity eh and B close quantity, or, open quantity, eh and C, close quantity.

eh or quantity B and C close quantity = quantity eh or B close quantity, and, open quantity, eh or C, close quantity.

Not the quantity eh or B close quantity, = not eh and not B.

Not the quantity eh and B close quantity, = not eh or not B.

End verbal description.


 Figure 8.14. Inputs eh and b feed into gate 2 which is an AND gate. Input B feeds into an inverter which is numbered 1 and is a not function. The term not gate is never used. Input D feeds into gate 3 which is an AND gate. The output of the inverter feeds the other input of gate 3. The outputs of gates 2 and 3 feed into gate 4 which is an or gate. The output of gate 4 is the variable P. End verbal description.


 Figure 8.15. In part eh there are 3 inputs, eh, b and c. Each one goes to the input of its own inverter. The outputs of the three inverters go to the input of an OR gate. The output of the OR gate goes to D. In part b there are 3 inputs eh b and c. They all feed into a NAND gate. The output of the NAND gate is D. End verbal description.


 Figure 8.16. Input eh goes to one of the inputs of a two input NAND gate. Input B goes to another two input NAND gate but the two inputs are tied together and input B goes to both of them. The output of this gate goes to the other input of the first gate. The output of this gate goes to a third 2 input NAND gate which also has both inputs tied together. The output of this third gate is variable D. End verbal description.


 Figure 8.17. On the left is a single pole, double throw, SPDT, switch. Its swinger is grounded. Each of the stationary contacts goes through a 10 k ohm resistor to Vcc. There are two, two-input NAND gates one positioned above the other. The top switch contact goes to one of the inputs of the top gate. The bottom switch contact goes to one of the inputs of the bottom gate. The output of the top gate goes to the other input of the bottom gate. The output of the bottom gate goes to the other input of the top gate. The output of the top gate goes to the Q output and the output of the bottom gate goes to the not Q output. End verbal description.


 Figure 8.18. This circuit consist of 8 2-input NAND gates. They will be described in pairs moving from left to right. The S input goes to one of the inputs of Gate 1. The R input goes to one of the inputs of gate 2. The other inputs of gates 1 and 2 are tied together and connect to the CK, clock, input. The output of gate 1 goes to one of the inputs of gate 3. The output of gate 2 goes to one of the inputs of gate 4. The output of gate 3 goes to the other input of gate 4. The output of gate 4 goes to the other input of gate 3. Gates 3 and 4 are labeled master. The output of gate 3 goes to one of the inputs of gate 5. The output of gate 4 goes to one of the inputs of gate 6. The Ck input goes through a level shifter to the input of an inverter, not numbered. The output of the inverter goes to the remaining inputs of gates 5 and 6. The output of gate 5 goes to one of the inputs of gate 7. The output of gate 6 goes to one of the inputs of gate 8. The output of gate 7 goes to the remaining input of gate 8. The output of gate 8 goes to the remaining input of gate 7. gates 7 and 8 are labeled slave. The output of gate 7 goes to the Q output. The output of gate 8 goes to the not Q output. End verbal description.


 Figure 8.19. This circuit consist of 2 3-input NAND gates and 6 2-input NAND gates. They will be described in pairs moving from left to right. Gates 1 and 2 are the 3-input gates. The J input goes to one of the inputs of Gate 1. The K input goes to one of the inputs of gate 2. The second set of inputs of gates 1 and 2 are tied together and connect to the CK, clock, input. We will pick up the third set of inputs at the end. The output of gate 1 goes to one of the inputs of gate 3. The output of gate 2 goes to one of the inputs of gate 4. The output of gate 3 goes to the other input of gate 4. The output of gate 4 goes to the other input of gate 3. The output of gate 3 goes to one of the inputs of gate 5. The output of gate 4 goes to one of the inputs of gate 6. The Ck input goes through a level shifter to the input of an inverter, not numbered. The output of the inverter goes to the remaining inputs of gates 5 and 6. The output of gate 5 goes to one of the inputs of gate 7. The output of gate 6 goes to one of the inputs of gate 8. The output of gate 7 goes to the remaining input of gate 8. The output of gate 8 goes to the remaining input of gate 7. The output of gate 7 goes back to the remaining input of gate 2. The output of gate 8 goes back to the remaining input of gate 1. The output of gate 7 goes to the Q output. The output of gate 8 goes to the not Q output. End verbal description.


 Figure 8.20. In part eh there is the block symbol for a JK flip-flop. The symbol is a rectangle that is twice as high as it is wide. On the right are the J, Ck, and K inputs. There are two more inputs at the top and bottom, they are direct set S and clear CL respectively. The Q and not Q outputs are on the right. On the left of the circuit are two inputs labeled data and clock. The data terminal goes to the J input. The data terminal also goes to the input of an inverter. The output of the inverter goes to the K input. The clock terminal goes to the Ck input of the flip-flop. The set and clear inputs are not connected. Part b shows a type D flip-flop. The S, CL, Q and not Q are placed the same as in the JK flip-flop but on the left instead of the three inputs are two labeled D and CK. The data terminal goes to the D input and the clock terminal goes to the Ck input. End verbal description.


 Figure 8.21. At the top are sample waves indicating what kind of input can be used to trigger the counter. The first one is a square wave. It consists of alternating 0 and 1 levels. Each period is the same length as all the others. The second wave is very irregular. Although it consists of alternating 0 and 1 levels no two periods are the same. The input feeds into the Ck input of flip-flop eh. The Q output goes to an output terminal labeled Q eh. The Q output also goes to the Ck input of flip-flop B. The Q output of B goes to the Q B output terminal and also to the Ck input of C. The Q output of C goes to the Q C output and also to the Ck input of D. The Q output of D goes to the Q D output terminal. The truth table is written below each flip-flop. This forces the binary numbers to be written backward. The columns are headed, left to right, Q eh, QB, QC, and QD. The first row is all zeros. Following rows are, 1 0 0 0, 0 1 0 0, 1 1 0 0, 0 0 1 0, 1 0 1 0, 0 1 1 0, 1 1 1 0, 0 0 0 1, 1 0 0 1, 0 1 0 1, 1 1 0 1, 0 0 1 1, 1 0 1 1, 0 1 1 1, 1 1 1 1. End verbal description.
Go back


 Figure 8.23. There are 4 flip-flops labeled from left to right, FF eh, FF B, FF C and FF D. A terminal labeled eh input goes to the Ck input of FF eh. The Q output goes to a terminal labeled Q eh. There is no other connection to FF eh. Another terminal labeled B dash D input goes to the Ck inputs of both FF B and FF D. The Q output of FF B goes to a terminal labeled Q B. This Q output also goes to the Ck input of FF C. The Q output of FF C goes to a terminal labeled Q C. The Q output of FF D goes to a terminal labeled Q D. The not Q output of FF B and the Q output of FF D go to the two inputs of a NAND gate. The output of this gate goes to the J input of FF B. The Q outputs of FF B and FF C go to the inputs of an AND gate. The output of this gate goes to the J input of FF D. Below the diagram is the legend, quote, For normal B C D operation Q eh is tied to the B dash D input. Below the legend is a truth table which has the columns Q eh, Q B, Q C, and Q D. The rows are as follows. 0 0 0 0, 1 0 0 0, 0 1 0 0, 1 1 0 0, 0 0 1 0, 1 0 1 0, 0 1 1 0, 1 1 1 0, 0 0 0 1, 1 0 0 1, 0 0 0 0. End verbal description.


 Figure 8.24. There are three rectangles representing integrated circuits and a 7 segment numeric display in this diagram. The first IC is a 7490. The input to this IC comes from an external connection labeled, quote, input from next least significant digit, end quote. There is another input to the 7490 labeled quote, reset, end quote. There are 4 outputs from the 7490 labeled eh, B, C, and D. These 4 outputs go through separate wires to the eh, B, C, and D, inputs of a 7475 IC. The D output from the 7490 also goes to an external connection labeled, quote, output to next most significant digit, end quote. The 7475 has another input labeled, quote, strobe, end quote. The 7475 has 4 outputs labeled eh, B, C, and D, which connect to the eh, B, C, and D, inputs of a 7447 IC. The 7447 has 7 outputs which are not labeled in this diagram. Each output goes through its own resistor to the segment inputs of a 7 segment display. End verbal description.


 Figure 8.25. This figure shows a 4 digit display consisting of 4 7-segment L E D displays. Above each display is a PNP transistor. The collector of each transistor is connected to the common anodes of the display below it. All the emitters are connected to VCC. Each base goes through its own current limiting resistor to the digit select inputs. The 7 segment anodes of all 4 digits are connected in parallel. Each of the 7 segment cathode lines connects through its own limiting resistor to the 7 segment driver lines. Only 11 control lines are needed to send numbers to the 4-digit, 7-segment display instead of 28 if each segment had to be driven separately. End verbal description.


 Figure 8.26. There are 8 terminals on the left of this figure. There are 8 horizontal lines, one connected to each terminal. These lines run the full width of the diagram. There are 8 more terminals along the top of the diagram. 8 vertical lines connect, one to each terminal, and run all the way to the bottom of the diagram. The vertical and horizontal lines do not connect at any point. At each crossing point there is a switch connected between the horizontal and vertical line. There are a total of 64 switches. The switches are shown in the open position. End verbal description.


 Figure 8.27. There are 7 noninverting buffers on the left. They look similar to the inverter but there is no circle on the point of the triangle. Their 7 inputs are labeled collectively binary input. The buffer with the input labeled LSB, for least significant bit, has its output connected through a 640 k ohm resistor to the inverting input of an op amp. The output of the buffer from the next bit goes through a 320 k ohm resistor to the op amp. The next bit goes through a 160 k ohm resistor to the op amp. The next bit goes through an 80 k ohm resistor to the op amp. The next is a 40 k ohm, then a 20 k ohm, and finally the MSB, most significant bit, goes through its buffer and through a 10 k ohm resistor to the inverting input of the op amp. There is a 5 k ohm resistor from the output of the op amp to the inverting input. The noninverting input is grounded. The output of the op amp is labeled analog output. End verbal description.


 Figure 8.28. There are 4 noninverting buffers on the left. The inputs are labeled collectively as binary input. The LSB buffer output goes through a resistor labeled 2R then through another resistor labeled 2R to ground. The next bit goes through a 2R resistor then one labeled R to the junction of the two previous resistors labeled 2R. The next bit goes through a 2R resistor then an R resistor to the junction of the 2R and R resistors. The MSB goes through a 2R resistor then an R resistor to the previous 2R and R resistors. The junction of these last 2R and R resistors goes to the inverting input of an op amp. There is a resistor labeled R connected from the output of the op amp to its inverting input. The noninverting input is grounded. The output of the op amp is labeled analog output. End verbal description.


 Figure 8.29. The input terminal goes through a switch, S2, to one end of a resistor, not labeled. A terminal labeled Reference goes through another switch, S3, to the same end of the resistor. The other end of the resistor goes to the inverting input of an op amp. The noninverting input is grounded. A capacitor, not labeled, goes from the inverting input to the output. There is a switch, S1, in parallel with the capacitor. The output of the op amp goes to the noninverting input of what looks like an op amp but it is labeled comparator. The inverting input is grounded. The output goes to one of the inputs of a 3 input AND gate and also to a block labeled control logic. The control logic block has two outputs, one goes to another of the inputs of the AND gate and the other goes to a block labeled counter. There is another block labeled clock. The output of this block goes to the third input of the AND gate. The output of the AND gate goes to the counter. There is a graph in the upper right corner. It is voltage versus time. The voltage starts at zero and rises on a straight line. It reaches a peak after the time interval T1 has elapsed. At the end of T1 and the beginning of T2 it slopes downward more steeply than it rose and reaches zero at the end of T2. Another line starts at zero and rises at half the slope of the first and at the end of T1 is only half as high. It slopes downward with the same slope as the first line, being parallel to it. And ends at zero. T2 for the second line is half as long as T2 for the first line. End verbal description.


 Figure 8.30. The input goes to the inverting input of a comparator. The output of the comparator goes to a block labeled control logic. The output of this block is a wide line indicating many lines carrying binary data. It is labeled control bus. The control bus goes to a block labeled binary register. Coming out of this block is another wide line labeled data bus. It goes to a block labeled D A C for digital to analog converter. The output of the D A C goes to the noninverting input of the comparator. The data bus also goes to a point labeled data output. End verbal description.


 Figure 8.31. This is the internal configuration of the 555 timer IC, not the internal schematic diagram. Remember, we are inside the IC looking out. Pin 8, V plus, connects to a chain of 3 resistors in series going to ground. Pin 1 of the IC is ground. All three are labeled as R and have a value of 5 k ohms. The junction of the top and middle resistor goes to the inverting input of a comparator. The noninverting input goes to pin 6, threshold. The output goes to the R input of a simple set and clear flip-flop. The junction of the top and middle resistors also goes to pin 5, control input. The junction of the middle and bottom resistors goes to the noninverting input of another comparator. The inverting input goes to pin 2, Trigger input. The output of this comparator goes to the S input of the flip-flop. Pin 4, reset, goes to the base of a PNP transistor. The emitter goes to a point labeled V ref. The collector goes to the reset input of the flip-flop. The not Q output of the flip-flop goes through a resistor to the base of an NPN transistor. The emitter is grounded. The collector goes to pin 7, discharge. The not Q output also goes to the input of an inverter. The output of the inverter goes to pin 3, output. End verbal description.


 Figure 8.32. Now we are on the outside of the IC looking in. Pins 8, V plus, and 4, Reset, are tied together and go to plus 12 volts. pin 1 is grounded. There is a .01 u f capacitor connected from pin 5, control input, to ground. There is a resistor from pin 2, trigger input, to plus 12 volts. There is another resistor from plus 12 volts to pin 6, threshold. Pin 6 is tied to pin 7, discharge. A capacitor connects from pins 6 and 7 to ground. Pin 3, output, is not shown connected to anything. End verbal description.


 Figure 8.33. Pins 8 and 4 are tied together and go to plus 12 volts. pin 1 is grounded. There is a .01 u f capacitor connected from pin 5 to ground. There is a resistor, R1, from plus 12 volts to pin 7. There is another resistor, R2, from pin 7 to pin 6. There is a capacitor, C, from pin 6 to ground. Pin 6 is tied to pin 2. Pin 3, output, is not shown connected to anything. End verbal description.


 Figure 8.34. Pins 8 and 4 are tied together and go to plus 12 volts. pin 1 is grounded. There is a .01 u f capacitor connected from pin 5 to ground. There is a resistor, R1, from plus 12 volts to pin 7. There is another resistor, R2, from pin 7 to pin 6. There is a diode in parallel with R2 with its cathode to pin 6. There is a capacitor, C, from pin 6 to ground. Pin 6 is tied to pin 2. Pin 3, output, is not shown connected to anything. End verbal description.


 Figure 8.35. There are 3 inputs on the left labeled eh, B, and C. Each input goes to the input of an inverter. The outputs of the inverters are, not eh, not B, and not C. Farther to the right there are 3 3-input NAND gates labeled 1, 2, and 3. The inputs to gate 1 are eh, not B, and not C. The inputs to gate 2 are, not eh, not B, and C. The inputs to gate 3 are, eh, B, and C. The outputs of gates 1 2 and 3 go to gate 4, which is also a 3 input NAND gate. The output of gate 4 is the output of the circuit. End verbal description.


 Figure 9.1. The input goes into a block labeled buffer. The output of the buffer goes into a schmitt trigger. The output of the trigger goes into one input of a 2 input NAND gate. The output of the gate goes into a block labeled decade counter, memory, decoder, and display. There is another block labeled 1 MHz crystal oscillator. Its output goes into a block labeled divide by one million. The output of the divider is indicated as 1 Hz. This output goes to the Ck input of a JK flip-flop. The not Q output of the flip-flop goes to the decade counter, memory, decoder, and display block. The Q output goes to the other input of the NAND gate. End verbal description.


 Figure 9.2. There is a block labeled crystal oscillator. Its output goes into input 1 of the phase detector. The output of the phase detector goes through a resistor, R1, to the input of the V C O. The input of the V C O also connects through a capacitor then through R2 to ground. The output of the V C O goes to another block labeled divide by N. The output of the divide by N block goes to input 2 of the phase detector. End verbal description.


 Figure 9.3. There is a block labeled crystal oscillator. Its output goes into a block labeled divide by L. The output of this block goes to input 1 of the phase detector. The output of the phase detector goes through a resistor, R1, to the input of the V C O. The input of the V C O also connects through a capacitor then through R2 to ground. The output of the V C O goes to another block labeled divide by N. The output of the divide by N block goes to input 2 of the phase detector. The output of the V C O also goes to another block labeled divide by M. The output of this block goes to the output terminal. End verbal description.


 A transformer has three secondaries, 1) a high voltage center tapped, 2) a 5 volt, and 3) a 6.3 volt. The tap on the h v is grounded and the ends of the winding go to the plates of a vacuum rectifier like the 5Y3 or 5U4. Each side of the filament goes to each side of the 5 volt winding. One of the filament connections goes to the positive of a cap labeled C1. This point goes to one end of a filter choke labeled L. The other end of the choke goes to the positive of C2. The negative ends of C1 and C2 are grounded. The output terminals come from the positive of C2 and ground. End verbal description.
go back.


 A transformer has three secondaries, 1) a high voltage center tapped, 2) a 5 volt, and 3) a 6.3 volt. The tap on the h v is grounded and the ends of the winding go to the plates of a vacuum rectifier like the 5Y3 or 5U4. Each side of the filament goes to each side of the 5 volt winding. One of the filament connections goes to the positive of a cap labeled C1. This point goes to one end of a resistor labeled R. This point also goes to a terminal connection. The other end of the resistor goes to the positive of C2. The negative ends of C1 and C2 are grounded. The output terminals come from the positive of C2 and ground. End verbal description.
go back.


MaxCAD Manual Table of contents.

MaxCAD Instruction Manual.

Table of Contents.

Introduction

Chapter 1 Downloading and Installation.
1.1  Getting Started.
1.2  Downloading.
1.3  Installation.
1.4  Installing the shape and font files.
1.5  Desktop Icon.

Chapter 2 Drawing Objects, the Draw Menu.
2.1  The First Time.
2.2  A Word About Hot Keys.
2.3  Drawing lines.
2.4  Drawing a line with an "oops" in it.
2.5  Drawing a Closed Figure.
2.6  If you left click the end of the line by mistake.
2.7  Typing Coordinates, Closed Figure.
2.8  Typing Coordinates, Open Figure.
2.9  Intermixing Mouse Clicks and Typed Coordinates.
2.10 Drawing a Circle, Clicking Radius.
2.11 Drawing a Circle, Typing Diameter.
2.12 Drawing Arcs.
2.13 Inserting Text.
2.14 Shapes.
2.15 Dial and Meter Scale Designer.
2.16 Dimensions.
2.17 Polar Array.
2.18 Rectangular Array.

Chapter 3 Save, Open, Print, etc, the Files Menu.
3.1  The Menu Items.
3.2  Insert, Control I.

Chapter 4 Copy, Paste, and Other Editing. The Edit Menu.
4.1  Undo, Control Z.
4.2  Selecting and Unselecting Objects.
4.3  Color Change, Control K.
4.4  Copy, Ins key.
4.5  Copy to Clipboard, Control C.
4.6  Cut to Clipboard, Control X.
4.7  Paste from Clipboard, Control V.
4.8  Delete, Del key.
4.9  Edit, Control E.
4.10 Flip, Control F.
4.11 Lock, Control L.
4.12 Unlock All, Control U.
4.13 Mirror, Control Shift M.
4.14 Move, Control M.
4.15 Rotate, Control R.
4.16 Scale, Control G.
4.17 Select All, Control A.
4.18 Select Window, Control W.

Chapter 5 The View Menu.
5.1  Animated Rotation.
5.2  Grid Spacing.
5.3  Grid On/Off.
5.4  Limits.
5.5  Pan.
5.6  Reset Zoom and Pan.
5.7  Snap Width.
5.8  Non-orthogonal Snap.
5.9  Snap Mode.
5.10 What Is It?
5.11 Zooming.

Chapter 6 The Settings Menu.
5.1  Color.
6.2  Hidden Line Settings and Line Type.
6.3  Plot Scale.
6.4  Shape Library.
6.5  Text Height.
6.6  Default Settings.

Chapter 7 The Help Menu.
7.1  Moving around in the "Help" menu.
7.2  List of Shortcut Keys.

Chapter 8 Making a Linear Scale for a Meter.
8.1  Altering an Existing Scale.
8.2  Making a New Linear Scale Using MaxCAD.

Chapter 9 Making a Nonlinear Scale for a Meter.

Appendix A Auxiliary Files.
A.1  MaxCAD_Last_Group_Opened.dat.
A.2  MaxCAD-Default.dat.
A.3  Shape and font files.
A.4  Schematic.fnt.
A.5  MaxCAD_ArrayRec_Data.dat.
A.6  MaxCAD_Help.hlp.
A.7  MaxCAD-Dial.DAT.
A.8  MaxCAD-PrntSet.dat.
A.9  MaxCAD-ShapeList.DAT.

Appendix B File Contents and formats.
B.1  The Drawing File.
B.2  MaxCAD_ArrayRec_Data.dat.
B.3  MaxCAD_Help.hlp.
B.4  MaxCAD_Last_Group_Open.dat.
B.5  MaxCAD-Default.dat.
B.6  MaxCAD-Dial.DAT.
B.7  MaxCAD-PrntSet.dat.
B.8  Schematic.fnt.